Cisco IOS IP アドレッシング サービス コンフィギュ レーション ガイド リリース 15.1S
DHCP Option 82 設定可能な回線 ID および リモート ID
DHCP Option 82 設定可能な回線 ID およびリモート ID
発行日;2012/01/09 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 4MB) | フィードバック

目次

DHCP Option 82 設定可能な回線 ID およびリモート ID

機能情報の検索

目次

DHCP Option 82 設定可能な回線 ID およびリモート ID の制約事項

DHCP Option 82 設定可能な回線 ID およびリモート ID について

DHCP Option 82 設定可能な回線 ID およびリモート ID の設定方法

プライベート VLAN に対する DHCP スヌーピングの設定

DHCP Option 82 設定可能な回線 ID およびリモート ID の設定例

プライベート VLAN アソシエーションのマッピング:例

参考資料

関連資料

規格

MIB

RFC

シスコのテクニカル サポート

コマンド リファレンス

DHCP Option 82 設定可能な回線 ID およびリモート ID の機能情報


 

DHCP Option 82 設定可能な回線 ID およびリモート ID

シスコ DHCP Option 82 設定可能な回線 ID およびリモート ID では、Option 82 リモート ID サブオプションおよび Option 82 回線 ID サブオプションでの命名の選択肢が広くなります。たとえば、スイッチ設定されたホスト名をリモート ID に使用するか ASCII テキスト文字列をリモート ID に指定することができ、ASCII テキスト文字列を設定して回線 ID をオーバーライドできます。


) Dynamic Host Configuration Protocol(DHCP)の設定については、ご使用のプラットフォームのコンフィギュレーション ガイドを参照してください。Cisco 7600 シリーズ ルータでの DHCP の設定については、『Cisco 7600 Series Cisco IOS Software Configuration Guide, Release 12.2SR』の「Configuring DHCP Snooping」の項を参照してください。その他の Cisco プラットフォームで DHCP を設定する場合の情報源については、「関連資料」を参照してください。


機能情報の検索

最新の機能情報および警告については、ご使用のプラットフォームおよびソフトウェア リリースのリリースノートを参照してください。このモジュールに記載されている機能に関する情報を検索したり、各機能がサポートされているリリースに関するリストを参照したりするには、「DHCP Option 82 設定可能な回線 ID およびリモート ID の機能情報」を参照してください。

プラットフォームのサポートと、Cisco IOS および Catalyst OS ソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスしてください。Cisco.com のアカウントは必要ありません。

DHCP Option 82 設定可能な回線 ID およびリモート ID の制約事項

プライマリ VLAN に対して DHCP スヌーピングが設定されている場合は、いずれのセカンダリ VLAN に対しても、異なる設定を持つスヌーピングを設定できません。関連付けられているすべての VLAN 用の DHCP スヌーピングをプライマリ VLAN に対して設定する必要があります。プライマリ VLAN に対して DHCP スヌーピングが設定されていないときに、セカンダリ VLAN、たとえば VLAN 200 に対して設定しようとすると、次のメッセージが表示されます。

2w5d:%DHCP_SNOOPING-4-DHCP_SNOOPING_PVLAN_WARNING:DHCP Snooping configuration may not take effect on secondary vlan 200. DHCP Snooping configuration on secondary vlan is derived from its primary vlan.

show ip dhcp snooping コマンドを使用すると、プライマリかセカンダリかを問わず、DHCP スヌーピングがイネーブルにされているすべての VLAN が表示されます。

DHCP Option 82 設定可能な回線 ID およびリモート ID について

DHCP Option 82 設定可能な回線 ID およびリモート ID 機能では、Option 82 リモート ID サブオプションおよび Option 82 回線 ID サブオプションで提供する情報を指定できるため、検証セキュリティが強化されます。

プライベート VLAN で DHCP スヌーピングをイネーブルにできます。DHCP スヌーピングがイネーブルの場合、設定はプライマリ VLAN およびそれに関連付けられているセカンダリ VLAN の両方に伝播します。プライマリ VLAN で DHCP スヌーピングがイネーブルの場合は、セカンダリ VLAN でもイネーブルにされます。

住宅用メトロポリタン イーサネット アクセス環境で多数の加入者に IP アドレスを大量に割り当てる場合に、DHCP を使用して集中管理する方法については、『 Cisco 7600 Series Cisco IOS Software Configuration Guide 』の「 DHCP Snooping Option-82 Data Insertion 」の項を参照してください。

図 1 に、DHCP スヌーピングがグローバルにイネーブルになっており、回線 ID サブオプションを指定して ip dhcp snooping information option グローバル コンフィギュレーション コマンドを入力した場合に使用されるパケット フォーマットを示します。

図 1 回線 ID を指定した場合のサブオプション パケット フォーマット

 

図 2 に、DHCP スヌーピングがグローバルにイネーブルになっており、リモート ID サブオプションを指定して ip dhcp snooping information option グローバル コンフィギュレーション コマンドを入力した場合に使用されるパケット フォーマットを示します。

図 2 リモート ID を指定した場合のサブオプション パケット フォーマット

 

DHCP Option 82 設定可能な回線 ID およびリモート ID の設定方法

ここでは、次の作業について説明します。

「プライベート VLAN に対する DHCP スヌーピングの設定」

プライベート VLAN に対する DHCP スヌーピングの設定

プライベートのプライマリ VLAN およびセカンダリ VLAN に対して DHCP スヌーピングを設定するには、次の作業を実行してください。

プライベートのプライマリ VLAN を設定します。

独立 VLAN をこのプライマリ VLAN に関連付けます。

プライマリ VLAN 用の SVI インターフェイスを作成し、適切なループバック IP およびヘルパー アドレスをインターフェイスに関連付けます。

プライマリ VLAN で DHCP スヌーピングをイネーブルにします。その結果、関連付けられている VLAN でも DHCP スヌーピングがイネーブルになります。


) スヌーピングに実効性を持たせるには、IP アドレス、DHCP プール、およびリレー ルートを割り当てるサーバを設定する必要もあります。


手順の概要

1. enable

2. configure terminal

3. vlan vlan-id

4. private-vlan primary

5. private-vlan association associated-vlan-list

6. configure terminal

7. vlan vlan-id

8. private-vlan isolated

9. configure terminal

10. interface vlan primary-vlan-id

11. ip unnumbered loopback

12. private-vlan mapping [ secondary-vlan-list | add secondary-vlan-list | remove secondary-vlan-list ]

13. configure terminal

14. ip dhcp snooping vlan primary-vlan-id

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

vlan vlan-id

 

Router(config)# vlan 70

指定したプライベート VLAN の VLAN コンフィギュレーション サブモードを開始します。

ステップ 4

private-vlan primary

 

Router(config-vlan)# private-vlan primary

VLAN をプライマリ プライベート VLAN として指定します。

ステップ 5

private-vlan association secondary-vlan-list

 

Router(config-vlan)# private-vlan association 7

Private VLAN(PVLAN; プライベート VLAN)の設定および PVLAN とセカンダリ VLAN とのアソシエーションの設定を行います。

ステップ 6

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 7

vlan vlan_ID

 

Router(config)# vlan 7

指定したプライベート VLAN の VLAN コンフィギュレーション モードを開始します。

この例では、関連付けられたセカンダリ VLAN、vlan 7 です。

ステップ 8

private-vlan isolated

 

Router(config-vlan)# private-vlan isolated

この VLAN を隔離プライベート VLAN として指定します。

ステップ 9

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 10

interface vlan primary-vlan_id

 

Router(config)# interface vlan 70

プライマリ VLAN に対してダイナミック Switch Virtual Interface(SVI; スイッチ仮想インターフェイス)を作成します。

ステップ 11

ip unnumbered loopback

 

Router(config)# ip unnumbered loopback1

IP アンナンバード ループバックを指定します。

ステップ 12

private-vlan mapping [ secondary-vlan-list | add secondary-vlan-list | remove secondary-vlan-list ]

 

Router(config-vlan)# private-vlan mapping 7

プライマリ VLAN とセカンダリ VLAN のマッピングを作成して、それらに同じプライマリ VLAN SVI を共有させます。

ステップ 13

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 14

ip dhcp snooping vlan primary-vlan_id

 

Router(config)# ip dhcp snooping vlan 70

プライマリ VLAN および関連付けられた VLAN で DHCP スヌーピングをイネーブルにします。

DHCP Option 82 設定可能な回線 ID およびリモート ID の設定例

ここでは、次の設定例について説明します。

「プライベート VLAN アソシエーションのマッピング:例」

プライベート VLAN アソシエーションのマッピング:例

次のインターフェイス コンフィギュレーションの例は、プライベート VLAN アソシエーションのマッピング方法を示します。ユーザ設定可能な回線 ID「aabb11」がセカンダリ VLAN の vlan 7 に挿入されています。

interface GigabitEthernet9/0/1
switchport
switchport private-vlan host-association 70 7
switchport mode private-vlan host
no mls qos trust
spanning-tree portfast
ip dhcp snooping vlan 7 information option format-type circuit-id string aabb11

次の例は、DHCP クラス「C1」を定義し、このインターフェイス コンフィギュレーションの例で入力された回線 ID 値と一致する 16 進文字列を使用して、サーバにある対応するクラスの 16 進文字列を指定する方法を示します。つまり、16 進文字列 00000000000000000000000000000006616162623131 マスク fffffffffffffffffffffffffffffff0000000000000 は、回線 ID aabb11 と一致します。

ip dhcp class C1
relay agent information
relay-information hex 00000000000000000000000000000006616162623131 mask fffffffffffffffffffffffffffffff0000000000000

参考資料

ここでは、DHCP Option 82 設定可能な回線 ID およびリモート ID 機能に関する関連資料について説明します。

関連資料

関連項目
参照先

Cisco 7600 シリーズ ルータに対する DHCP の設定

Cisco 7600 Series Cisco IOS Software Configuration Guide 』の「 Configuring DHCP Snooping 」の項

Cisco Catalyst 3550 マルチレイヤ スイッチに対する DHCP の設定

Catalyst 3550 Multilayer Switch Software Configuration Guide 』の「 Configuring DHCP Features 」の項

Cisco Catalyst 2970 スイッチに対する DHCP の設定

Catalyst 2970 Switch Software Configuration Guide 』の「 Configuring DHCP Features 」の項

Cisco Catalyst 3560 スイッチに対する DHCP の設定

Catalyst 3560 Switch Software Configuration Guide 』の「 Configuring DHCP Features and IP Source Guard 」の項

Cisco Catalyst 3750 スイッチに対する DHCP の設定

Catalyst 3750 Switch Software Configuration Guide 』の「 Configuring DHCP Features and IP Source Guard 」の項

DHCP コマンド:コマンド構文の詳細、コマンド モード、コマンド履歴、デフォルト、使用上の注意事項、および例

『Cisco IOS IP Addressing Services Command Reference』

規格

規格
タイトル

この機能がサポートする新しい規格または変更された規格はありません。また、この機能で変更された既存規格のサポートはありません。

--

MIB

MIB
MIB リンク

選択したプラットフォーム、Cisco IOS リリース、および機能セットの MIB の場所を検索しダウンロードするには、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFC

RFC
タイトル

この機能による新規または変更された RFC のサポートはありません。また、この機能による既存の RFC サポートに変更はありません。

--

シスコのテクニカル サポート

説明
リンク

右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。

以下を含むさまざまな作業にこの Web サイトが役立ちます。

テクニカル サポートを受ける

ソフトウェアをダウンロードする

セキュリティの脆弱性を報告する、またはシスコ製品のセキュリティ問題に対する支援を受ける

ツールおよびリソースへアクセスする

Product Alert の受信登録

Field Notice の受信登録

Bug Toolkit を使用した既知の問題の検索

Networking Professionals(NetPro)コミュニティで、技術関連のディスカッションに参加する

トレーニング リソースへアクセスする

TAC Case Collection ツールを使用して、ハードウェアや設定、パフォーマンスに関する一般的な問題をインタラクティブに特定および解決する

この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

http://www.cisco.com/en/US/support/index.html

コマンド リファレンス

このモジュールに記載されている 1 つ以上の機能で、次のコマンドが追加または変更されています。これらのコマンドの詳細については、『 Cisco IOS IP Addressing Services Command Reference 』を参照してください( http://www.cisco.com/en/US/docs/ios/ipaddr/command/reference/
iad_book.html
)。すべての Cisco IOS コマンドについては、 http://tools.cisco.com/Support/CLILookup にある Command Lookup Tool を使用するか、 http://www.cisco.com/en/US/docs/ios/mcl/allreleasemcl/all_book.html にある『 Cisco IOS Master Command List, All Releases 』を参照してください。

ip dhcp snooping vlan

DHCP Option 82 設定可能な回線 ID およびリモート ID の機能情報

表 1 に、この機能のリリース履歴を示します。

ご使用の Cisco IOS ソフトウェア リリースでは、一部のコマンドが使用できない場合があります。特定のコマンドのリリース情報については、コマンド リファレンス マニュアルを参照してください。

プラットフォームのサポートおよびソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator を使用すると、特定のソフトウェア リリース、機能セット、またはプラットフォームをサポートする Cisco IOS と Catalyst OS のソフトウェア イメージを判別できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスしてください。Cisco.com のアカウントは必要ありません。


表 1 に、特定の Cisco IOS ソフトウェア リリース群で特定の機能をサポートする Cisco IOS ソフトウェア リリースだけを示します。特に明記されていない限り、Cisco IOS ソフトウェア リリース群の後続のリリースでもこの機能をサポートします。


 

表 1 DHCP Option 82 設定可能な回線 ID およびリモート ID の機能情報

機能名
リリース
機能情報

DHCP Option 82 設定可能な回線 ID およびリモート ID

12.2(33)SRD1

Option 82 リモート ID サブオプションおよび Option 82 回線 ID サブオプションでの命名の選択肢を規定します。

次のコマンドが導入または変更されました。 ip dhcp snooping vlan

Copyright © 2009-2011, シスコシステムズ合同会社.
All rights reserved.