Cisco IOS IP アドレッシング サービス コンフィギュ レーション ガイド リリース 15.1S
Edge-Session 管理用の DHCP 拡張機能の 設定
Edge-Session 管理用の DHCP 拡張機能の設定
発行日;2012/01/09 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 4MB) | フィードバック

目次

Edge-Session 管理用の DHCP 拡張機能の設定

目次

Edge-Session 管理用の DHCP 拡張機能に関する情報

DHCP サーバおよびリレー エージェント

オンデマンド アドレス プールの管理

Edge-Session 管理用の DHCP 拡張機能の設計

DHCP サーバと SG の共存

DHCP リレー エージェントと SG の共存

Edge-Session 管理用の DHCP 拡張機能の利点

Edge-Session 管理用の DHCP 拡張機能の設定方法

DHCP アドレス プールおよびクラス名の設定

前提条件

リレー ソースおよび宛先をリレー プールに設定

制約事項

リモート DHCP サーバのリレー プールの設定

制約事項

その他のタイプのリレー プールの設定

アドレス プールのリレー情報の設定

リレー プールの複数のリレー ソースの設定

Edge Session 管理対応の DHCP 拡張機能の設定例

DHCP アドレス範囲およびクラス名の設定:例

SG と共存する DHCP サーバ設定:例

SG と共存する DHCP リレー エージェント設定:例

複数の DHCP プールと異なる ISP の設定:例

複数のリレー ソースおよび宛先の設定:例

SG 提供クラス名の設定:例

参考資料

関連資料

規格

MIB

RFC

シスコのテクニカル サポート

Edge-Session 管理用の DHCP 拡張機能に関する機能情報

Edge-Session 管理用の DHCP 拡張機能の設定

Edge-Session 管理用の DHCP 拡張機能により、1 つのネットワーク インフラストラクチャを使用するお客様に対して複数の Internet Service Provider(ISP; インターネット サービス プロバイダー)による同時サービスが可能になります。エンドユーザのお客様は、いつでも ISP を変更できます。

この DHCP 拡張機能は、いつクライアント DISCOVER(セッション開始)パケットが受信されたか、いつアドレスがクライアントに割り当てられたか、およびいつクライアントが DHCP リースを返却したか、またはいつリースが期限切れになるか(セッションの終了)について、DHCP サーバから情報を受信するために、Service Gateway(SG; サービス ゲートウェイ)要件から発展した拡張機能です。

変更履歴

このマニュアルの初版の発行は 2005 年 3 月 29 日 で、最終更新日は 2007 年 12 月 31 日 です。

このモジュール内の機能情報の検索

ご使用の Cisco IOS ソフトウェア リリースが、このモジュールで説明している機能の一部をサポートしていない場合があります。最新の機能情報および警告については、ご使用の Cisco IOS ソフトウェア リリースのリリース ノートを参照してください。 このモジュール内に記載されている特定の機能のリンクにアクセスする場合、および各機能がサポートされているリリースのリストを参照する場合は、「Edge-Session 管理用の DHCP 拡張機能に関する機能情報」を参照してください。

プラットフォームと、Cisco IOS および Catalyst OS ソフトウェア イメージに関するサポート情報の検索

プラットフォームのサポートと、Cisco IOS および Catalyst OS ソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスしてください。Cisco.com のアカウントは必要ありません。

Edge-Session 管理用の DHCP 拡張機能に関する情報

Edge-Session 管理用の DHCP 拡張機能を設定するには、次の概念を理解する必要があります。

「DHCP サーバおよびリレー エージェント」

「オンデマンド アドレス プールの管理」

「Edge-Session 管理用の DHCP 拡張機能の設計」

「Edge-Session 管理用の DHCP 拡張機能の利点」

DHCP サーバおよびリレー エージェント

DHCP は、TCP/IP ネットワーク上のホストに設定情報をダイナミックに渡すフレームワークを提供します。DHCP クライアントは、DHCP を使用して IP アドレスなどの設定パラメータを取得するインターネット ホストです。

DHCP リレー エージェントは、クライアントとサーバの間で DHCP パケットを転送するホストです。リレー エージェントは、同一の物理サブネット上にないクライアントとサーバ間で要求および応答を転送するために使用されます。リレー エージェント転送は、IP ルータの通常の転送とは異なります。通常の転送では、IP データグラムがネットワーク間である程度透過的にスイッチングされます。これとは対照的に、リレー エージェントは DHCP メッセージを受信すると、DHCP メッセージを新たに生成して他のインターフェイスから送信します。

詳細については、『Cisco IOS IP Addressing Services Configuration Guide, Release 12.4』の「DHCP」モジュールを参照してください。

オンデマンド アドレス プールの管理

On-Demand Address Pool(ODAP; オンデマンド アドレス プール)は、アドレスの大規模プールの管理を 1 箇所で行うため、および大規模ネットワークの設定を簡素化するために使用されます。ODAP は、IP アドレス割り当ての集中管理ポイントを提供します。

Cisco ルータを ODAP マネージャとして設定すると、IP アドレスのプールのサイズは、アドレスの利用水準に応じてダイナミックに拡大/縮小されます。ODAP マネージャは、集中 Remote Authentication Dial-In User Service(RADIUS)または DHCP サーバでサポートされており、RADIUS または DHCP サーバに対しアドレスの初期プールを要求するように設定します。

ODAP マネージャは、IP アドレスの割り当てを制御し、必要に応じて追加の IP アドレスを割り当てます。このアドレス割り当て方法により、有効なアドレス空間の使用が最適化され、中規模および大規模サイズのネットワークの設定が簡素化されます。

詳細については、「DHCP サーバ オンデマンド アドレス プール マネージャの設定」モジュールを参照してください。

Edge-Session 管理用の DHCP 拡張機能の設計

Edge-Session 管理用の DHCP 拡張機能により、DHCP サーバおよびリレー エージェントは分離されますが、緊密な関係を持ちます。この機能の基本設計では、ISP ネットワークのエッジにおいて次の 2 種類の構成が使用されます。

(同じデバイス内に)共存する DHCP サーバと SG

共存する DHCP リレー エージェントと SG

DHCP サーバと SG の共存

この構成では、DHCP サーバは SG と同じデバイスに存在し、ローカル設定されたアドレス プールからアドレスを割り当てるか、割り当てるアドレスのサブネットを、ネットワーク内の他のシステムから取得します。この構成をサポートするために、サーバ アドレス割り当て機能を変更する必要はありません。

この構成では、DHCP サーバは、エンド ユーザ DHCP クライアントが送信したブロードキャストを受信したことを、SG に通知します。SG は、MAC アドレスおよびその他の情報を DHCP サーバに渡します。また、SG は、DHCP サーバがプール クラス定義を照合するために使用するクラス名(たとえば、ISP の名前)を渡します。

リース状態情報はすでに存在しているため、DHCP サーバはリース状態を SG に常に通知します。


) ローカル設定は、DHCP サーバからアドレス プールのサブネットを取得する ODAP、または RADIUS サーバにより実行される場合もあります。


DHCP リレー エージェントと SG の共存

この構成では、リレー エージェントが SG と同じデバイスに存在し、DHCP セッションで代行受信を行い、DHCP クライアントに対する DHCP サーバとして示されます。リレー エージェントは、サーバとして DHCP セッションに関する十分な情報を取得して、すべてのイベント(たとえば、リースの終了)を SG に通知できます。

アンナンバード インターフェイスで現在使用中の DHCP 機能を使用して実行される DHCP サーバがあるように見えます。この機能により、リレー エージェントは、専用の IP アドレスをサーバの代わりに使用できます。

パケットは、リレー エージェントにより DHCP サーバに渡され、SG にはその受信が通知されます。通知の後、リレー エージェントは SG に対して、使用する DHCP クラス名について問い合わせます。次に、パケットが、リレー エージェントにより、選択した DHCP サーバに渡されます。

エンド ユーザ DHCP クライアントの MAC アドレスおよびその他の関連情報は SG に渡されます。SG は、DHCP プールの照合時に、使用する DHCP クラス名を戻します(SG がこの動作を行うように設定されている場合)。DHCP リレー エージェントがサーバとして動作しない場合、このエージェントは、パケットを DHCP サーバにリレーします。


) アドレス プールでは、1 つの DHCP クラスを定義して、リレー エージェントがパケットを渡す先の 1 つの集中 DHCP サーバを指定すること、または、複数の DHCP クラスを定義して、クライアントごとに異なる DHCP サーバを指定することができます。


Edge-Session 管理用の DHCP 拡張機能の利点

Edge-Session 管理用の DHCP 拡張機能の利点を以下に示します。

フル機能の DHCP サーバ システムをネットワークの中央に配置でき、一方で、比較的簡素な DHCP リレー エージェントをエッジで実行できます。

エッジにおける DHCP 設定を簡素化します。

すべての DHCP サーバ管理を、ネットワークの中央付近にある 1 つの集中 DHCP サーバまたは個別の DHCP サーバ(ISP ごとに 1 つ)で実行できます。

各 ISP がすべての DHCP オプションおよびリース時間を完全制御できます。

DHCP サーバ設定とクライアント設定の両方を、同じエッジ システムで同時に使用できます。

Edge-Session 管理用の DHCP 拡張機能の設定方法

ここでは、次の手順について説明します。

「DHCP アドレス プールおよびクラス名の設定」(任意)

「リレー ソースおよび宛先をリレー プールに設定」(必須)

「リモート DHCP サーバのリレー プールの設定」(必須)

「その他のタイプのリレー プールの設定」(任意)

DHCP アドレス プールおよびクラス名の設定

エッジにおいて DHCP サーバと共存する SG が割り当てた特定クラス名のアドレス プールからアドレスを割り当てる DHCP サーバを設定するには、この作業を実行します。

DHCP サーバが SG と同じデバイスに存在し、両方ともエッジにある場合、クラス名およびアドレス プールを設定する必要があります。この場合、DHCP サーバは、クライアントから受信した DISCOVER ブロードキャストを SG に通知し、SG はクラス名を戻します。戻されたクラス名により、アドレス プールのアドレス範囲が指定されます。DHCP サーバは、着信インターフェイスの MAC アドレスと IP アドレス、または指定されたリレー エージェント アドレスを SG に送信します。


) DHCP サーバがローカルで定義されているアドレス プールを所有する場合、または ODAP を使用して ISP DHCP サーバまたは AAA サーバからサブネットを取得する場合、SG の代わりの追加の DHCP サーバ設定は必要ありません。


ODAP を使用したアドレス プールのダイナミック割り当てが必要な場合、 origin コマンドを指定します。

前提条件

各 DHCP クライアント クラス名を指定するために、DHCP アドレス プール設定または SG システム自体でクラス名を指定する必要があります。ユーザがデフォルト クラス名を所有していない場合、デフォルト クラス名を設定する必要があります。

各アドレス プールを 1 つ以上の DHCP クラス(アドレス プロバイダー ISP)に関連付ける必要があります。DHCP クライアントが ISP を選択すると、その選択が、SG により指定されるクラス名になります。

手順の概要

1. enable

2. configure terminal

3. ip dhcp pool name

4. origin { dhcp | file url }

5. network network-number [ mask | prefix-length ]

6. class class-name

7. address range start-ip end-ip

8. ステップ 3、5、および 6 を繰り返します。

9. exit

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip dhcp pool name

 

Router(config)# ip dhcp pool abc-pool

Cisco IOS DHCP サーバで DHCP アドレス プールを設定し、DHCP プール コンフィギュレーション モードを開始します。 name 引数はプールの名前で、文字列によるわかりやすい名前(engineering など)または整数(0 など)を指定できます。

ステップ 4

origin { dhcp | file url }

 

Router(dhcp-config)# origin dhcp

(任意)On-Demand Address Pool(ODAP; オンデマンド アドレス プール)またはスタティック マッピング プールを設定します。引数およびキーワードは次のとおりです。

ステップ 5

network network-number [ mask | prefix-length ]

 

Router(dhcp-config)# network 10.10.0.0 255.255.0.0

Cisco IOS DHCP サーバの DHCP アドレス プールに、サブネットの番号およびマスクを設定します。引数は次のとおりです。

network-number :DHCP アドレス プールの IP アドレス。ODAP が IP アドレス割り当て方式ではない場合、この引数を使用します。

mask :(任意)DHCP アドレス プールのアドレスのどの部分がネットワークまたはサブネットを示すか、およびどの部分がホストを示すか表すビットの組み合わせ。

prefix-length :(任意)アドレス プレフィクスを構成するビットの数。プレフィクスは、クライアントのネットワーク マスクを指定する代替方法です。プレフィクス長には、スラッシュ(/)を前に付ける必要があります。

ステップ 6

class class-name

 

Router(dhcp-config)# class abc-pool

クラスを DHCP アドレス プールに関連付け、DHCP プール クラス コンフィギュレーション モードを開始します。 class-name 引数はクラスの名前です。これは、DHCP アドレス プール名と一致している必要があります。

SG でデフォルト クラス名が必要な場合は、この手順を繰り返してデフォルト クラス名を指定します。

ステップ 7

address range start-ip end-ip

 

Router(config-dhcp-pool-class)# address range 10.10.5.0 10.99.99.99

(任意)IP アドレスの範囲を設定します。DHCP サーバは、この範囲内の IP アドレスから IP アドレスを割り当てます。SG が設定されていない IP アドレスを戻した場合、処理は実行されません。

この手順により、前の手順で指定したクラス名の範囲からのアドレスの割り当てがイネーブルになります。

コマンドでアドレスを指定します。

ステップ 8

ステップ 3、5、および 6 を繰り返します。

複数のサブネットおよび異なる ISP が設定されているインターフェイスがある場合、サブネットの数の分だけこの手順を繰り返します。「複数の DHCP プールと異なる ISP の設定:例」を参照してください。

ステップ 9

exit

 

Router(config-dhcp-pool-class)# exit

DHCP プール コンフィギュレーション モードを終了します。

リレー ソースおよび宛先をリレー プールに設定

DHCP リレーおよび SG がエッジにある同じデバイスに存在し、すべてのエンド ユーザが 1 つのプールからアドレスを取得する場合、この作業を実行してリレー プールを設定します。この作業は、IP ヘルパー アドレス インターフェイスの設定の代わりに行う作業です。

SG が、特定の DHCP クライアントに関する DHCP セッション通知が必要であることを、リレー エージェントに通知する場合、リレー エージェントは、DHCP セッションに関する十分な情報を保持し、SG にすべてのイベント(たとえば、リースの終了)を通知します。リレーは DHCP セッションを代行受信し、DHCP サーバの役割を代行します。IP アドレス設定は、DHCP クライアント情報および SG デバイス ポリシー情報に基づき、ダイナミックに変更される値となります。

制約事項

リレー エージェントが DHCP セッションで代行受信を行い、DHCP サーバの役割を代行する場合、DHCP 認証は使用できません。

手順の概要

1. enable

2. configure terminal

3. ip dhcp pool name

4. update arp

5. relay source ip-address subnet-mask

6. relay destination [ vrf vrf-name | global ] ip-address

7. accounting method-list-name

8. exit

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip dhcp pool name

 

Router(config)# ip dhcp pool abc-pool

Cisco IOS DHCP サーバで DHCP アドレス プールを設定し、DHCP プール コンフィギュレーション モードを開始します。 name 引数はプールの名前で、文字列によるわかりやすい名前(engineering など)または整数(0 など)を指定できます。複数の名前を設定できます。

ステップ 4

update arp

 

Router(dhcp-config)# update arp

(任意)対応する DHCP バインディングに対して、セキュアなダイナミック Address Resolution Protocol(ARP; アドレス解決プロトコル)テーブル エントリを ARP テーブルに設定します。

(注) システムがアドレス プールからアドレスを割り当てる場合、システムはセキュア ARP を追加します。システムがアドレス プールを使用してパケットをリレーする場合も、システムはセキュア ARP を追加します。

ステップ 5

relay source ip-address subnet-mask

 

Router(dhcp-config)# relay source 10.0.0.0 255.0.0.0

リレー ソースを設定します。 ip-address 引数と subnet-mask 引数は、リレー ソースの IP アドレスとサブネット マスクです。

コマンドと類似しています。

ステップ 6

relay destination [ vrf vrf-name | global ] ip-address

 

Router(dhcp-config)# relay destination 10.5.5.0

DHCP クライアント パケットが送信される先のリモート DHCP サーバの IPv4 アドレスを設定します。引数およびキーワードは次のとおりです。

vrf :(任意)Virtual Routing and Forwarding(VRF; 仮想ルーティングおよび転送)。 vrf-name 引数は、リレー宛先 IP アドレスに関連付けられている VRF の名前です。

global :(任意)グローバル IP アドレス。リレー エージェントがグローバル アドレス空間にあり、リレー ソースが VRF にある場合、このキーワードを使用します。

ip-address :リレー宛先の IP アドレス。

キーワードを指定する必要があります。

ステップ 7

accounting method-list-name

 

Router(dhcp-config)# accounting RADIUS-GROUP1

(任意)指定したサーバ グループを設定して RADIUS アカウンティングを実行する場合、DHCP アカウンティングをイネーブルにします。

DHCP アカウンティングを動作させる前に、AAA および RADIUS をイネーブルにする必要があります。

この例では、RADIUS-GROUP1 が start-stop グループとして設定された場合に、DHCP アカウンティングの START および STOP メッセージを送信するように設定しています。STOP メッセージは、RADIUS-GROUP1 が stop-only グループとして設定された場合に限り送信されます。DHCP アカウンティングの詳細については、「アカウンティングおよびセキュリティ対応の DHCP サービスの設定」モジュールを参照してください。

ステップ 8

exit

 

Router(dhcp-config)# exit

グローバル コンフィギュレーション モードを終了します。

リモート DHCP サーバのリレー プールの設定

設定済みのリレー プールでリモート DHCP サーバを選択し、それを使用して DHCP クライアント パケットのリレー方法を指定する場合、この作業を実行して SG 提供のクラス名を使用します。すべてのアドレスがリレー目的で使用される場合、リレー ターゲットの複数の設定を、プール クラス定義で表すことができます。

制約事項

relay source コマンドは、 network コマンドまたは origin コマンドと併用できません。これは、これらのコマンドが暗黙的に着信インターフェイスを指定するため、およびこれらのコマンドが異なるタイプのプールを定義するために使用されるためです。このコマンドは、 ip helper-address コマンドをインターフェイス コンフィギュレーション コマンドとして実行するのと同じ方法で、リレーをインターフェイスにのみ関連付けます。

手順の概要

1. enable

2. configure terminal

3. ip dhcp pool name

4. relay source ip-address subnet-mask

5. relay destination [ vrf vrf-name | global ] ip-address

6. accounting method-list-name

7. class class-name

8. relay target [ vrf vrf-name | global ] ip-address

9. exit

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip dhcp pool name

 

Router(config)# ip dhcp pool abc-pool

Cisco IOS DHCP サーバで DHCP アドレス プールを設定し、DHCP プール コンフィギュレーション モードを開始します。 name 引数はプールの名前で、文字列によるわかりやすい名前(engineering など)または整数(0 など)を指定できます。複数の DHCP アドレス プールを指定できます。

ステップ 4

relay source ip-address subnet-mask

 

Router(dhcp-config)# relay source 10.0.0.0 255.0.0.0

リレー ソースを設定します。 ip-address 引数と subnet-mask 引数は、リレー ソースの IP アドレスとサブネット マスクです。

コマンドと類似しています。

ステップ 5

relay destination [ vrf vrf-name | global ] ip-address

 

Router(dhcp-config)# relay destination 10.5.5.0

DHCP クライアント パケットが送信される先のリモート DHCP サーバの IPv4 アドレスを設定します。引数およびキーワードは次のとおりです。

vrf :(任意)Virtual Routing and Forwarding(VRF; 仮想ルーティングおよび転送)。 vrf-name 引数は、リレー宛先 IP アドレスに関連付けられている VRF の名前です。

global :(任意)グローバル IP アドレス。リレー エージェントがグローバル アドレス空間にあり、リレー ソースが VRF にある場合、このキーワードを使用します。

ip-address :リレー宛先の IP アドレス。

キーワードを指定する必要があります。

ステップ 6

accounting method-list-name

 

Router(dhcp-config)# accounting RADIUS-GROUP1

(任意)指定したサーバ グループを設定して RADIUS アカウンティングを実行する場合、DHCP アカウンティングをイネーブルにします。

DHCP アカウンティングを動作させる前に、AAA および RADIUS をイネーブルにする必要があります。

この例では、RADIUS-GROUP1 が start-stop グループとして設定された場合に、DHCP アカウンティングの START および STOP メッセージを送信するように設定しています。STOP メッセージは、RADIUS-GROUP1 が stop-only グループとして設定された場合に限り送信されます。DHCP アカウンティングの詳細については、「アカウンティングおよびセキュリティ対応の DHCP サービスの設定」モジュールを参照してください。

ステップ 7

class class-name

 

Router(dhcp-config)# class abc-pool

クラスを DHCP アドレス プールに関連付け、DHCP プール クラス コンフィギュレーション モードを開始します。 class-name 引数はクラスの名前です。複数のクラス名を設定できます。

ステップ 8

relay target [ vrf vrf-name | global ] ip-address

 

Router(config-dhcp-pool-class)# relay target 10.0.0.0

リレー宛先の IP アドレスを設定します。引数およびキーワードは次のとおりです。

vrf :(任意)Virtual Routing and Forwarding(VRF; 仮想ルーティングおよび転送)。 vrf-name 引数は、リレー ターゲット IP アドレスに関連付けられている VRF の名前で、複数のターゲットを指定できます。

global :(任意)グローバル IP アドレス空間。

ip-address :リレー ターゲットの IP アドレス。複数のターゲット IP アドレスを指定できます。

コマンドと同じ方法で、リレー機能の宛先を指定します。

キーワードを指定する必要があります。

ステップ 9

exit

 

Router(config-dhcp-pool-class)# exit

DHCP プール コンフィギュレーション モードを終了します。

その他のタイプのリレー プールの設定

ここでは、次の手順について説明します。

「アドレス プールのリレー情報の設定」(必須)

「リレー プールの複数のリレー ソースの設定」(必須)

アドレス プールのリレー情報の設定

アドレス プールのリレー情報を設定するには、この作業を実行します。この設定では、SG は 1 つのクラス名を送信し、その結果、DISCOVER パケットが relay target コマンドを使用して設定された IP アドレスのサーバにリレーされます。SG が、アドレス プールに関連付けられるように設定されていないクラス名を送信する場合、処理は実行されません。

制約事項

プール クラス定義で address range コマンドおよび relay target コマンドは指定できません。これにより、同じパケットに対してアドレスおよびリレーが割り当てられるためです。

手順の概要

1. enable

2. configure terminal

3. ip dhcp pool name

4. network network-number [ mask | prefix-length ]

5. class class-name

6. relay target [ vrf vrf-name | global ] ip-address

7. exit

8. 設定する必要がある DHCP クラスごとに、ステップ 5 ~ 7 を繰り返します。

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip dhcp pool name

 

Router(config)# ip dhcp pool abc-pool

Cisco IOS DHCP サーバで DHCP アドレス プールを設定し、DHCP プール コンフィギュレーション モードを開始します。 name 引数はプールの名前で、文字列によるわかりやすい名前(engineering など)または整数(0 など)を指定できます。

ステップ 4

network network-number [ mask | prefix-length ]

 

Router(dhcp-config)# network 10.0.0.0 255.0.0.0

Cisco IOS DHCP サーバの DHCP アドレス プールに、サブネットの番号およびマスクを設定します。引数は次のとおりです。

network-number :DHCP アドレス プールの IP アドレス。

mask :(任意)DHCP アドレス プールのアドレスのどの部分がネットワークまたはサブネットを示すか、およびどの部分がホストを示すか表すビットの組み合わせ。

prefix-length :(任意)アドレス プレフィクスを構成するビットの数。プレフィクスは、クライアントのネットワーク マスクを指定する代替方法です。プレフィクス長には、スラッシュ(/)を前に付ける必要があります。

ステップ 5

class class-name

 

Router(dhcp-config)# class abc-pool

クラスを DHCP アドレス プールに関連付け、DHCP プール クラス コンフィギュレーション モードを開始します。 class-name 引数はクラスの名前です。複数のクラス名を設定できます。

(注) DHCP プール クラス名に対してリレー ターゲットまたはアドレス範囲が設定されていない場合、デフォルトでは、クラスとして DHCP プール設定が使用されます。

ステップ 6

relay target [ vrf vrf-name | global ] ip-address

 

Router(config-dhcp-pool-class)# relay target 10.0.0.0

リレー宛先の IP アドレスを設定します。 relay target コマンドの引数およびキーワードは次のとおりです。

vrf :(任意)Virtual Routing and Forwarding(VRF; 仮想ルーティングおよび転送)。 vrf-name 引数は、リレー ターゲット IP アドレスに関連付けられている VRF の名前で、複数のターゲットを指定できます。

global :(任意)グローバル IP アドレス空間。

ip-address :リレー ターゲットの IP アドレス。複数のターゲット IP アドレスを指定できます。

キーワードを指定する必要があります。

ステップ 7

exit

 

Router(config-dhcp-pool-class)# exit

DHCP プール コンフィギュレーション モードを終了します。

ステップ 8

設定する必要がある DHCP クラスごとに、ステップ 5 ~ 7 を繰り返します。

--

リレー プールの複数のリレー ソースの設定

リレー プールに対し複数のリレー ソースを設定するには、この作業を実行します。この設定は、複数のインターフェイスに IP ヘルパー アドレスを設定するのと類似しています。 show running-config コマンドを使用すると、インターフェイスでの IP アドレスの表示順に、プールと着信インターフェイスの IP アドレスが照合されます。リレーが検出された場合、またはアドレス割り当てが検出された場合、検索は停止します。

手順の概要

1. enable

2. configure terminal

3. interface type number

4. ip address ip-address mask [ secondary ]

5. exit

6. ip dhcp pool name

7. relay source ip-address subnet-mask

8. relay destination [ vrf vrf-name | global ] ip-address

9. accounting method-list-name

10. 設定済みの DHCP プールごとにステップ 6 ~ 7 を繰り返します。

11. exit

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface type number

 

Router(config)# interface ethernet1

インターフェイスを設定し、インターフェイス コンフィギュレーション モードを開始します。引数は次のとおりです。

ステップ 4

ip address ip-address mask [ secondary ]

 

Router(config-if)# ip address 10.0.0.0 255.0.0.0

インターフェイスに対するプライマリ IP アドレスまたはセカンダリ IP アドレスを設定します。

ステップ 5

exit

 

Router(config-if)# exit

グローバル コンフィギュレーション モードを終了します。

ステップ 6

ip dhcp pool name

 

Router(config)# ip dhcp pool abc-pool1

DHCP サーバに対し DHCP アドレス プールを設定し、DHCP プール コンフィギュレーション モードを開始します。 name 引数はプールの名前で、文字列によるわかりやすい名前(engineering など)または整数(0 など)を指定できます。複数のプールを割り当てることができます。

ステップ 7

relay source ip-address subnet-mask

 

Router(dhcp-config)# relay source 10.0.0.0 255.0.0.0

リレー ソースを設定します。 ip-address 引数と subnet-mask 引数は、リレー ソースの IP アドレスとサブネット マスクです。

コマンドと類似しています。

ステップ 8

relay destination [ vrf vrf-name | global ] ip-address

 

Router(dhcp-config)# relay destination 10.5.5.0

DHCP クライアント パケットが送信される先のリモート DHCP サーバの IPv4 アドレスを設定します。引数およびキーワードは次のとおりです。

vrf :(任意)Virtual Routing and Forwarding(VRF; 仮想ルーティングおよび転送)。 vrf-name 引数は、リレー宛先 IP アドレスに関連付けられている VRF の名前です。

global :(任意)グローバル IP アドレス。リレー エージェントがグローバル アドレス空間にあり、リレー ソースが VRF にある場合、このキーワードを使用します。

ip-address :リレー宛先の IP アドレス。

キーワードを指定する必要があります。

ステップ 9

accounting method-list-name

 

Router(dhcp-config)# accounting RADIUS-GROUP1

(任意)指定したサーバ グループを設定して RADIUS アカウンティングを実行する場合、DHCP アカウンティングをイネーブルにします。

DHCP アカウンティングを動作させる前に、AAA および RADIUS をイネーブルにする必要があります。

この例では、RADIUS-GROUP1 が start-stop グループとして設定された場合に、DHCP アカウンティングの START および STOP メッセージを送信するように設定しています。STOP メッセージは、RADIUS-GROUP1 が stop-only グループとして設定された場合に限り送信されます。DHCP アカウンティングの詳細については、「アカウンティングおよびセキュリティ対応の DHCP サービスの設定」モジュールを参照してください。

ステップ 10

設定済みの DHCP プールごとにステップ 6 ~ 7 を繰り返します。

--

ステップ 11

exit

 

Router(dhcp-config)# exit

グローバル コンフィギュレーション モードを終了します。

Edge Session 管理対応の DHCP 拡張機能の設定例

ここでは、次の設定例について説明します。

「DHCP アドレス範囲およびクラス名の設定:例」

「SG と共存する DHCP サーバ設定:例」

「SG と共存する DHCP リレー エージェント設定:例」

「複数の DHCP プールと異なる ISP の設定:例」

「複数のリレー ソースおよび宛先の設定:例」

「SG 提供クラス名の設定:例」

DHCP アドレス範囲およびクラス名の設定:例

次の例は、特定ネットワークのアドレス範囲および DHCP プールのクラス名を設定する方法を示しています。

ip dhcp pool abc-pool
network 10.10.0.0 255.255.0.0
class abc-pool
address range 10.10.5.0 10.10.5.99

SG と共存する DHCP サーバ設定:例

次の例では、ISP は ABC 社と DEF 社です。ABC 社は、ODAP を使用してダイナミックに割り当てられるアドレス プールからアドレスを割り当てています。DEF 社は、アドレス プール 10.100.0.0/16 から、カスタマー アドレスを割り当てています。ISP に関係しないお客様は、アドレス プール 10.1.0.0/16 から割り当てられたアドレスを使用し、リース時間は 10 分に設定されます。

!Interface configuration
 
interface ethernet1
ip address 10.20.0.1. 255.255.0.0
ip address 10.1.0.1 255.255.0.0 secondary
ip address 10.100.0.1 255.255.0.0 secondary
 
!Address pool for ABC customers
 
ip dhcp pool abc-pool
network 20.1.0.0 255.255.0.0
class abc
!
!Address pool for DEF customers
 
ip dhcp pool def-pool
network 10.100.0.0 255.255.0.0
class def
 
!Address pool for customers without an ISP
 
ip dhcp pool temp
network 10.1.0.0 255.255.0.0
lease 0 0 10
class default

SG と共存する DHCP リレー エージェント設定:例

次の例では、2 つの ISP(abcpool と defpool)があります。abcpool ISP とそのお客様は、範囲 10.1.0.0/16 と範囲 30.1.0.0/16 のアドレスを使用することが許可され、10.55.10.1 の DHCP サーバにリレーされます。defpool ISP とそのお客様は、範囲 20.1.0.0/16 および範囲 40.4.0.0/16 の IP アドレスを使用することが許可され、12.10.2.1 の DHCP サーバにリレーされます。

!Address ranges:
 
interface ethernet1
ip address 10.1.0.0 255.255.0.0
ip address 10.2.0.0 255.255.0.0 secondary
 
interface ethernet2
ip address 10.3.0.0 255.255.0.0
ip address 10.4.0.0 255.255.0.0 secondary
 
!Address pools for abcpool1 and abcpool2:
 
ip dhcp pool abcpool1
relay source 10.1.0.0 255.255.0.0
class abcpool
relay target 10.5.10.1
 
!Address pool for abcpool2:
 
ip dhcp pool abcpool2
relay source 10.1.0.0 255.255.0.0
class abcpool
relay target 10.55.10.1
 
!Address pools for defpool1 and defpool2:
 
ip dhcp pool defpool1
relay source 10.1.0.0 255.255.0.0
class defpool
relay target 10.10.2.1
 
ip dhcp pool defpool2
relay source 10.4.0.0 255.255.0.0
class defpool
relay target 10.10.2.1

複数の DHCP プールと異なる ISP の設定:例

次の例は、 network コマンドを使用して、異なる ISP に適用する 1 つのインターフェイスと複数の DHCP プールを設定する方法を示しています。

interface ethernet1
ip address 10.0.0.1 255.0.0.0
ip address 10.1.0.1 255.0.0.0
!
ip dhcp pool x
network 10.0.0.0 255.0.0.0
class ISP1
!
ip dhcp pool y
network 10.1.0.0 255.0.0.0
class ISP2

複数のリレー ソースおよび宛先の設定:例

次の例では、リレー プールに対し複数のリレー ソースおよび宛先を設定できます。これは、複数インターフェイスでの IP ヘルパー アドレス設定と同様です。 show running-config コマンドを使用してインターフェイスに関する情報を表示すると、IP アドレスの表示順に、プールと着信インターフェイスの IP アドレス(場合によっては複数の IP アドレス)が照合されます。リレーが検出された場合、またはアドレス割り当てが検出された場合、検索は停止します。たとえば、次の設定があるとします。

interface ethernet1
ip address 10.0.0.1 255.0.0.0
ip address 10.0.0.5 255.0.0.0 secondary
 
ip dhcp pool x
relay source 10.0.0.0 255.0.0.0
relay destination 10.0.0.1
 
ip dhcp pool y
relay source 10.0.0.0 255.0.0.0
relay destination 10.0.0.1
 

次の例では、SG がクラス名として ISP1 を指定している場合は、DHCP クライアント パケットは 10.0.0.1 にリレーされ、SG がクラス名として ISP2 を指定している場合は、DHCP クライアント パケットは 10.0.0.5 にリレーされます。

interface ethernet1
ip address 10.0.0.1 255.0.0.0
ip address 10.0.0.5 255.0.0.0 secondary
 
ip dhcp pool x
relay source 10.0.0.0 255.0.0.0
relay destination 10.2.0.0 255.0.0.0
class ISP1
relay target 10.0.0.1
class ISP2
relay target 10.0.0.5

SG 提供クラス名の設定:例

次の例では、パケットのリレー先のリモート DHCP サーバの選択で、SG 提供クラス名が使用されます。

ip dhcp pool abc-pool-1
relay source 10.1.0.0 255.255.0.0
relay destination 10.1.0.0
class classname1
relay target 10.20.10.1
class classname2
relay target 10.0.10.1
class classname3
 

上の例では、classname1 という名前の SG 提供クラス名により、DHCP DISCOVER パケットがリレー ターゲット IP アドレス 10.20.10.1 のサーバにリレーされ、一方で、SG classname2 により、DHCP DISCOVER パケットがリレー ターゲット IP アドレス 10.0.10.1 のサーバにリレーされます。この設定では、インターフェイスの最初の設定済みアドレスにプールが一致するため、パケットは、宛先 IP アドレス 10.0.0.1 にリレーされます。SG が classname3 を戻す場合、デフォルト プールは、リレー宛先として指定されているデフォルト アドレスです。SG が classname1、classname2、または classname3 以外のクラス名を戻す場合、リレー アクションは実行されません。

参考資料

ここでは、Edge-Session 管理用の DHCP 拡張機能の設定に関連する参考資料を示します。

関連資料

関連項目
参照先

DHCP コマンド:コマンド構文の詳細、コマンド モード、コマンド履歴、デフォルト、使用上の注意事項、および例

『Cisco IOS IP Addressing Services Command Reference』

DHCP の概念情報

「DHCP Overview」 モジュール

DHCP サーバ設定

「Configuring the Cisco IOS DHCP Server」 モジュール

DHCP クライアント設定

「Configuring the Cisco IOS DHCP Client」 モジュール

DHCP リレー エージェント設定

「Configuring the Cisco IOS DHCP Relay Agent」 モジュール

DHCP サーバ オンデマンド アドレス プール マネージャの設定

「Configuring the DHCP Server On-Demand Address Pool Manager」 モジュール

DHCP 拡張機能

「Configuring DHCP Services for Accounting and Security」 モジュール

DHCP オプション

Network Registrar User's Guide , Release 6.1.1』の付録「DHCP Options」

規格

規格
タイトル

この機能がサポートする新しい規格または変更された規格はありません。

--

MIB

MIB
MIB リンク

この機能によってサポートされる新しい MIB または変更された MIB はありません。

選択したプラットフォーム、Cisco IOS リリース、および機能セットの MIB の場所を検索しダウンロードするには、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFC

RFC
タイトル

RFC 951

『Bootstrap Protocol (BOOTP)』

RFC 1542

『Clarifications and Extensions for the Bootstrap Protocol』

RFC 2131

『Dynamic Host Configuration Protocol』

RFC 2685

『Virtual Private Networks Identifier』

RFC 3046

『DHCP Relay Information Option』

シスコのテクニカル サポート

説明
リンク

右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。

以下を含むさまざまな作業にこの Web サイトが役立ちます。

テクニカル サポートを受ける

ソフトウェアをダウンロードする

セキュリティの脆弱性を報告する、またはシスコ製品のセキュリティ問題に対する支援を受ける

ツールおよびリソースへアクセスする

Product Alert の受信登録

Field Notice の受信登録

Bug Toolkit を使用した既知の問題の検索

Networking Professionals(NetPro)コミュニティで、技術関連のディスカッションに参加する

トレーニング リソースへアクセスする

TAC Case Collection ツールを使用して、ハードウェアや設定、パフォーマンスに関する一般的な問題をインタラクティブに特定および解決する

この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

http://www.cisco.com/en/US/support/index.html

Edge-Session 管理用の DHCP 拡張機能に関する機能情報

表 1 に、このモジュールで説明した機能をリストし、特定の設定情報へのリンクを示します。この表には、Cisco IOS Release 12.2(1) 以降のリリースで導入または変更された機能だけを示します。

このテクノロジーの機能でここに記載されていないものについては、『 DHCP Features Roadmap 』を参照してください。

ご使用の Cisco IOS ソフトウェア リリースでは、一部のコマンドが使用できない場合があります。特定のコマンドのリリース情報については、コマンド リファレンス マニュアルを参照してください。

プラットフォームのサポートおよびソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator を使用すると、特定のソフトウェア リリース、機能セット、またはプラットフォームをサポートする Cisco IOS と Catalyst OS のソフトウェア イメージを判別できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスしてください。Cisco.com のアカウントは必要ありません。


表 1 に、特定の Cisco IOS ソフトウェア リリース群で特定の機能をサポートする Cisco IOS ソフトウェア リリースだけを示します。特に明記されていない限り、Cisco IOS ソフトウェア リリース群の後続のリリースでもこの機能をサポートします。


 

表 1 Edge-Session 管理用の DHCP 拡張機能に関する機能情報

機能名
リリース
機能の設定情報

DHCP リレー アカウンティング

12.4(6)T

DHCP リレー アカウンティング機能により、Cisco IOS DHCP リレー エージェントは、クライアントにアドレスが割り当てられたときに RADIUS アカウンティング開始パケットを送信でき、アドレスがリリースされたときに RADIUS アカウンティング停止パケットを送信できます。この機能は、DHCP プール コンフィギュレーション モードで relay destination コマンドを使用するリレー プールを指定した accounting コマンドを使用してイネーブルにします。

次のセクションで、この機能に関する情報を参照できます。

「リレー ソースおよび宛先をリレー プールに設定」

「リモート DHCP サーバのリレー プールの設定」

この機能により導入された新しいコマンドはありません。

Edge-Session 管理用の DHCP 拡張機能

12.3(14)T

12.2(28)SB

12.2(33)SRC

Edge-Session 管理用の DHCP 拡張機能は、1 つのネットワーク インフラストラクチャしか使用しないお客様が、複数の ISP から同時にサービスを受けることができるようにします。エンドユーザのお客様は、いつでも ISP を変更できます。

このモジュールのすべてのセクションでは、この機能についての情報を提供します。

この機能により、次のコマンドが導入されました。 relay destination relay source 、および relay target