Cisco IOS IP アドレッシング サービス コンフィギュ レーション ガイド リリース 15.1S
IPv4 アドレスの設定
IPv4 アドレスの設定
発行日;2012/01/09 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 4MB) | フィードバック

目次

IPv4 アドレスの設定

目次

IP アドレスに関する情報

2 進数ナンバリング

IP アドレスの構造

IP アドレス クラス

IP ネットワークのサブネット化

IP ネットワーク アドレス割り当て

クラスレス Inter-Domain ルーティング

プレフィクス

IP アドレスの設定方法

IP アドレスをインターフェイスに割り当てることによるネットワークとの IP 接続の確立

トラブルシューティングのヒント

セカンダリ IP アドレスの使用によるネットワークでサポートされる IP ホストの数の増加

トラブルシューティングのヒント

次の作業

ポイントツーポイント WAN インターフェイスでの IP アンナンバードを使用することによる、IP 接続の確立を必要とする IP アドレス数の削減

IP アンナンバード機能

制約事項

トラブルシューティングのヒント

ポイントツーポイント WAN インターフェイスで 31 ビット プレフィクスの IP アドレスを使用することによる、IP 接続の確立を必要とする IP アドレス数の削減

RFC 3021

前提条件

制約事項

トラブルシューティングのヒント

IP サブネット ゼロの使用を許可することによる、使用できる IP サブネットの数の最大化

トラブルシューティングのヒント

ネットワーク マスクの形式の指定

現在のセッションでのネットマスクの表示形式の指定

個々の回線でのネットマスクの表示形式の指定

IP アドレスの設定例

IP アドレスをインターフェイスに割り当てることによるネットワークとの IP 接続の確立:例

セカンダリ IP アドレスの使用によるネットワークでサポートされる IP ホストの数の増加:例

ポイントツーポイント WAN インターフェイスでの IP アンナンバードを使用することによる、IP 接続の確立を必要とする IP アドレス数の削減:例

ポイントツーポイント WAN インターフェイスで 31 ビット プレフィクスの IP アドレスを使用することによる、IP 接続の確立を必要とする IP アドレス数の削減:例

IP サブネット ゼロの使用を許可することによる、使用できる IP サブネットの数の最大化:例

次の作業

参考資料

関連資料

規格

MIB

RFC

シスコのテクニカル サポート

IP アドレスの機能情報

IPv4 アドレスの設定

この章では、ネットワーキング デバイスの一部であるインターフェイスでの IPv4 アドレスの設定およびその手順について説明します。


) このマニュアルでは、これ以降 IPv4 アドレスを示す場合、IPv4 ではなく、IP だけ使用します。


このモジュール内の機能情報の検索

ご使用の Cisco IOS ソフトウェア リリースが、このモジュールで説明している機能の一部をサポートしていない場合があります。 このモジュール内に記載されている特定の機能のリンクにアクセスする場合、および各機能がサポートされているリリースのリストを参照する場合は、「IP アドレスの機能情報」を参照してください。

プラットフォームと、Cisco IOS および Catalyst OS ソフトウェア イメージに関するサポート情報の検索

プラットフォームのサポートと、Cisco IOS および Catalyst OS ソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスしてください。Cisco.com のアカウントは必要ありません。

IP アドレスに関する情報

IP アドレスを設定するには、次の概念を理解しておく必要があります。

「2 進数ナンバリング」

「IP アドレスの構造」

「IP アドレス クラス」

「IP ネットワークのサブネット化」

「IP ネットワーク アドレス割り当て」

「クラスレス Inter-Domain ルーティング」

「プレフィクス」

2 進数ナンバリング

IP アドレスは 32 ビット長です。32 ビットは 4 つのオクテット(8 ビット)に分割されます。2 進数ナンバリングの基本を理解しておくと、ネットワークで IP アドレスを管理する場合に非常に役に立ちます。これは、32 ビットの値が変わると、別の IP ネットワーク アドレスまたは IP ホスト アドレスのいずれかを示すためです。

2 進数の値は、右から左に順番に 0 ~ 7 で累乗した 2 を、各位置の数(0 または 1)に掛けた数値で表されます。図 1 に、8 桁の 2 進数の例を示します。

図 1 8 桁の 2 進数の例

 

図 2 に、0 ~ 255 における 2 進数から 10 進数の変換例を示します。

図 2 0 ~ 134 における 2 進数から 10 進数への変換

 

図 3 に、135 ~ 255 における 2 進数から 10 進数の変換例を示します。

図 3 135 ~ 255 における 2 進数から 10 進数への変換

 

IP アドレスの構造

IP ホスト アドレスは、IP パケットを送信できるデバイスを示します。IP ネットワーク アドレスは、1 つ以上のホストが接続できる特定のネットワーク セグメントを示します。次に、IP アドレスの特性を示します。

IP アドレスは 32 ビット長です。

IP アドレスは、それぞれが 1 バイト(オクテット)の 4 セクションに分割されます。

IP アドレスは、通常、ドット付き 10 進で知られる形式で記述されます。

表 1 に、IP アドレスの例をいくつか示します。

 

表 1 IP アドレスの例

ドット付き 10 進形式の IP アドレス
2 進数形式の IP アドレス

10.34.216.75

00001010.00100010.11011000.01001011

172.16.89.34

10101100.00010000.01011001.00100010

192.168.100.4

11000000.10101000.01100100.00000100


表 1 の IP アドレスは、RFC 1918『Address Allocation for Private Internets』のものです。これらの IP アドレスは、インターネット上でルーティングできません。これらは、プライベート ネットワークで使用されます。RFC1918 の詳細については、http://www.ietf.org/rfc/rfc1918.txt を参照してください。


IP アドレスは、ネットワークおよびホストとして知られる 2 つのセクションにさらに分割されます。この分割は、IP アドレスからクラスの任意の範囲で行われます。詳細については、RFC 791『Internet Protocol』( http://www.ietf.org/rfc/rfc0791.txt )を参照してください。

IP アドレス クラス

IP アドレスの割り当て方法にいくつかの構造を提供するため、IP アドレスはクラスにグループ化されます。各クラスには、IP アドレスの範囲があります。各クラスの IP アドレスの範囲は、32 ビット IP アドレスのネットワーク セクションに割り当てられるビットの数により決まります。ネットワーク セクションに割り当てられるビットの数は、ドット付き 10 進形式のマスク、または略字 / n (ここで n はマスクのビットの数です)で表されます。

表 2 に、クラスおよび各クラスに関連付けられるマスクごとの IP アドレスの範囲のリストを示します。太字の数値は、各クラスの IP アドレスのネットワーク セクションを示します。他の数値は、ホスト IP アドレスに使用できます。たとえば、IP アドレス 10.90.45.1、マスク 255.0.0.0 は、ネットワーク IP アドレス 10.0.0.0 およびホスト IP アドレス 0.90.45.1 に分割されます。

 

表 2 クラスおよびマスク別の IP アドレス範囲

クラス
範囲

A(ドット付き 10 進形式の範囲/マスク)

0 .0.0.0 ~ 127.0.0.0/8(255.0.0.0)

A(2 進数形式の範囲)

00000000 .00000000.00000000.00000000 ~
01111111 .00000000.00000000.00000000

A(2 進数形式のマスク)

11111111.00000000.00000000.00000000/8

B(ドット付き 10 進形式の範囲/マスク)

128 .0.0.0 ~ 191 . 255 .0.0/16(255.255.0.0)

B(2 進数形式の範囲)

10000000 . 00000000 .00000000.00000000 ~
10111111 . 11111111 .00000000.00000000

B(2 進数形式のマスク)

11111111 . 11111111 .00000000.00000000/16

C(ドット付き 10 進形式の範囲/マスク)

192 . 0 . 0 .0 ~ 223 . 255 . 255 .0/24(255.255.255.0)

C(2 進数形式の範囲)

11000000 . 00000000 . 00000000 .00000000 ~
11011111 . 11111111 . 11111111 .00000000

C(2 進数形式のマスク)

11111111.11111111.11111111.0000000/24

D1(ドット付き 10 進形式の範囲/マスク)

224 . 0 . 0 . 0 239 . 255 . 255 . 255 /32(255.255.255.255)

D(2 進数形式の範囲)

11100000 . 00000000 . 00000000 . 00000000
11101111 . 11111111 . 11111111 . 11111111

D(2 進数形式のマスク)

11111111.11111111.11111111.11111111/32

E2(ドット付き 10 進形式の範囲/マスク)

240 . 0 . 0 . 0 255 . 255 . 255 . 255 /32(255.255.255.255)

E(2 進数形式の範囲)

11110000 . 00000000 . 00000000 . 00000000
11111111 . 11111111 . 11111111 . 11111111

E(2 進数形式のマスク)

11111111.11111111.11111111.11111111/32

1.クラス D の IP アドレスは、マルチキャスト アプリケーションに予約されています。

2.クラス E の IP アドレスは、ブロードキャスト トラフィックに予約されています。


) これらの範囲の一部の IP アドレスは、特殊な目的のために予約されています。詳細については、RFC 3330『Special-Use IP Addresses』(http://www.ietf.org/rfc/rfc3330.txt)を参照してください。


ネットワーク マスク内の数値が 1 から 0 または 0 から 1 に変更されると、ネットワーク アドレスが変わります。たとえば、10101100.00010000.01011001.00100010/16 を 10101100.00110000.01011001.00100010/16 に変更すると、ネットワーク アドレスが 172.16.89.34/16 から 172.48.89.34/16 に変わります。

ネットワーク マスク外の数値が 1 から 0 または 0 から 1 に変更されると、ホスト アドレスが変わります。たとえば、10101100.00010000.01011001.00100010/16 を 10101100.00010000.01011001.00100011/16 に変更すると、ホスト アドレスが 172.16.89.34/16 から 172.16.89.35/16 に変わります。

各クラスの IP アドレスは、特定の範囲の IP ネットワーク アドレスおよび IP ホスト アドレスをサポートします。各クラスで使用できる IP ネットワーク アドレスの範囲は、使用できるビットの数で 2 を累乗した式で求められます。クラス A アドレスの場合、最初のオクテット( 表 2 )の最初のビットの値は常に 0 です。7 ビットは、追加ネットワーク アドレスの作成用です。そのため、クラス A で使用できる IP ネットワーク アドレスは 128 あります(27 = 128)。

IP アドレス クラスで使用できる IP ホスト アドレスの数は、使用できるビットの数で 2 を累乗し 2 を引いた数で求められます。IP ホスト アドレスのクラス A アドレスで使用できるビットは 24 あります。そのため、クラス A で使用できる IP ホスト アドレスは 16,777,214 あります((224) - 2 = 16,777,214)。


) 累乗した数から 2 を引くのは、ホストで使用できない IP アドレスが 2 つあるためです。すべて 0 のホスト アドレスは、ネットワーク アドレスと同じになるため使用できません。たとえば、10.0.0.0 は、IP ネットワーク アドレスと IP ホスト アドレスの両方で使用できません。すべて 1 のアドレスは、ネットワークのすべてのホストにアクセスするときに使用されるブロードキャスト アドレスです。たとえば、アドレスが 10.255.255.255 の IP データグラムは、ネットワーク 10.0.0.0 のすべてのホストにより受け入れられます。


表 3 に、各クラスの IP アドレスで使用できるネットワークおよびホスト アドレスを示します。

 

表 3 各クラスの IP アドレスで使用できるネットワークおよびホスト アドレス

クラス
ネットワーク アドレス
ホスト アドレス

A

128

16,777,214

B

16,3843

65534

C

2,097,1524

254

3.表 2 に示すように、最初の 2 ビットは常に 10 になるため、クラス B の IP ネットワーク アドレスで使用できるビットは 14 だけです。

4.表 2 に示すように、最初の 3 ビットは常に 110 になるため、クラス C の IP ネットワーク アドレスで使用できるビットは 21 だけです。

IP ネットワークのサブネット化

IP アドレス クラスのネットワークおよびホスト ビットを任意に分割したことで、IP スペースの割り当てが非効率的になりました。たとえば、ネットワークに 16 の物理セグメントがある場合、16 の IP ネットワーク アドレスが必要です。16 のクラス B の IP ネットワーク アドレスを使用する場合、各物理セグメントで 65,534 のホストをサポートできます。サポートされるホスト IP アドレスは合計で 1,048,544(16 × 65,534 = 1,048,544)です。単一のネットワーク セグメントで 65,534 のホストを使用できるネットワーク テクノロジーはあまりありません。また、1,048,544 の IP ホスト アドレスを必要とする組織もあまりありません。この問題では、同様の IP サブネットワーク アドレスのグループに IP ネットワーク アドレスを分割できる新しい戦略を開発する必要がありました。この戦略は、サブネット化と呼ばれます。

たとえば、ネットワークに 16 の物理セグメントがある場合、16 の IP サブネットワーク アドレスが必要です。これは、1 つのクラス B の IP アドレスで実現できます。たとえば、クラス B の IP アドレス 172.16.0.0 の場合、3 番めのオクテットから 4 ビットをサブネット ビットとして予約できます。これにより、16 のサブネット IP アドレスを使用できます(24 = 16)。 表 4 に、172.16.0.0/20 の IP サブネットを示します。

 

表 4 172.16.0.0/20 を使用した IP サブネット アドレスの例

数値
ドット付き 10 進形式の IP サブネット アドレス
2 進数形式の IP サブネット アドレス

05

172.16.0.0

10101100.00010000.00000000.00000000

1

172.16.16.0

10101100.00010000.00010000.00000000

2

172.16.32.0

10101100.00010000.00100000.00000000

3

172.16.48.0

10101100.00010000.00110000.00000000

4

172.16.64.0

10101100.00010000.01000000.00000000

5

172.16.80.0

10101100.00010000.01010000.00000000

6

172.16.96.0

10101100.00010000.01100000.00000000

7

172.16.112.0

10101100.00010000.01110000.00000000

8

172.16.128.0

10101100.00010000.10000000.00000000

9

172.16.144.0

10101100.00010000.10010000.00000000

10

172.16.160.0

10101100.00010000.10100000.00000000

11

172.16.176.0

10101100.00010000.10110000.00000000

12

172.16.192.0

10101100.00010000.11000000.00000000

13

172.16.208.0

10101100.00010000.11010000.00000000

14

172.16.224.0

10101100.00010000.11100000.00000000

15

172.16.240.0

10101100.00010000.11110000.00000000

5.サブネット ビットがすべて 0 に設定されている最初のサブネットは、サブネット 0 と呼ばれます。これはネットワーク アドレスとの区別ができないため、注意して使用する必要があります。

サブネットワーク(サブネット)マスク内の数値が 1 から 0 または 0 から 1 に変更されると、サブネットワーク アドレスが変わります。たとえば、10101100.00010000.01011001.00100010/20 を 10101100.00010000.01111001.00100010/20 に変更すると、ネットワーク アドレスが 172.16.89.34/20 から 172.48.121.34/20 に変わります。

サブネット マスク内の数値が 1 から 0 または 0 から 1 に変更されると、ホスト アドレスが変わります。たとえば、10101100.00010000.01011001.00100010/20 から 10101100.00010000.01011001.00100011/20 に変更すると、ホスト アドレスが 172.16.89.34/20 から 172.16.89.35/20 に変わります。


ワンポイント アドバイス 手動による IP ネットワーク、サブネットワークおよびホストの計算の必要性をなくすには、インターネットで利用できるいずれかの無料の IP サブネット カリキュレータを使用します。


ネットワーク アドレス サブネット または サブネットワーク アドレス という用語は混同しやすいこともあります。また、これらを使用する状況も複雑な場合があります。一般的に、 ネットワーク アドレス という用語は、「特定のネットワーク セグメント用の宛先 IP ホストでトラフィックを受信できるように、ルータがトラフィックをそのセグメントに送信するときに使用する IP アドレス」を表します。そのため、 ネットワーク アドレス という用語は、サブネット化されていない IP ネットワーク アドレスとサブネット化された IP ネットワーク アドレスの両方に使用できます。実際はサブネット化されたネットワーク アドレスである特定の IP ネットワーク アドレスにルータからトラフィックを転送するときの問題をトラブルシューティングする場合、宛先ネットワーク アドレスをサブネット ネットワーク アドレスとするとより詳しくなります。これは、ルーティング プロトコルによっては、サブネット ネットワーク ルートとネットワーク ルートのアドバイタズの処理が異なる場合があるためです。たとえば、RIP v2 のデフォルトの動作では、ルーティング アップデートを他のルータに送信するときに、サブネット化されていないネットワーク アドレス(172.16.32.0/24 は RIP v2 により 172.16.0.0/16 としてアドバタイズされます)に接続されるようにサブネット ネットワーク アドレスを自動的に集約します。そのため、他のルータが、ネットワークの IP ネットワーク アドレスを認識している場合もありますが、その IP ネットワーク アドレスのサブネット化されたネットワーク アドレスを認識していない場合もあります。


ヒント IP アドレス空間という用語は、IP アドレスの範囲を示すときに使用されることがあります。次に例を示します。「現在の IP アドレス空間で使用できるすべての IP アドレスを使用しているために新しい IP ネットワーク アドレスをネットワークに割り当てる必要があります。」


IP ネットワーク アドレス割り当て

ルータは、IP ネットワーク アドレスを追跡し、ネットワークのネットワーク IP トポロジ(OSI リファレンス モデルのレイヤ 3)を理解して、IP トラフィックを正しくルートできます。ルータがネットワーク レイヤ(IP)トポロジを理解できるようにするには、ルータにより他の物理ネットワーク セグメントから分離されているすべての個々の物理ネットワーク セグメントに、固有の IP ネットワーク アドレスが必要です。

図 4 に、IP ネットワーク アドレスが正しく設定された簡単なネットワークの例を示します。R1 のルーティング テーブルは、 表 5 のようになります。

 

表 5 正しく設定されたネットワークのルーティング テーブル

インターフェイス イーサネット 0
インターフェイス イーサネット 1

172.31.32.0/24(接続)

172.31.16.0/24(接続)

図 4 正しく設定されたネットワーク

 

図 5 に、IP ネットワーク アドレスが正しく設定されていない簡単なネットワークの例を示します。R1 のルーティング テーブルは、 表 6 のようになります。IP アドレスが 172.31.32.3 の PC が、IP アドレス 172.31.32.54 の PC に IP トラフィックを送信しようした場合、ルータ R1 は、IP アドレスが 172.31.32.54 の PC の接続先となるインターフェイスを判別できません。

 

表 6 正しく設定されていないネットワークのルータ R1 のルーティング テーブル(例 1)

イーサネット 0
イーサネット 1

172.31.32.0/24(接続)

172.31.32.0/24(接続)

図 5 正しく設定されていないネットワーク(例 1)

 

図 5 のような間違いを防止するため、Cisco IOS-based ネットワーキング デバイスでは、IP ルーティングがイネーブルにされている場合にルータの複数のインターフェイスで同じ IP ネットワーク アドレスを設定できません。

172.16.31.0/24 が R2 および R3 で使用されている、図 6 のような間違いを防ぐ唯一の方法として、IP ネットワーク アドレスを割り当てている場所を正確に示したネットワーク ドキュメントが必要です。

 

表 7 正しく設定されていないネットワークのルータ R1 のルーティング テーブル(例 2)

イーサネット 0
シリアル 0
シリアル 1

172.16.32.0/24(接続)

192.168.100.4/29(接続)
172.16.31.0/24 RIP

192.168.100.8/29(接続)
172.16.31.0/24 RIP

図 6 正しく設定されていないネットワーク(例 2)

 

IP ルーティングの詳細については、「関連資料」で IP ルーティングに関連するドキュメントのリストを参照してください。

クラスレス Inter-Domain ルーティング

インターネットの使用が増加を続け、 表 2 に示すように、クラス構造を使用した IP アドレスの割り当て方法には制限があるため、IP アドレスを割り当てるためのさらに柔軟な方法が必要になりました。この新しい方法については、RFC 1519『 Classless Inter-Domain Routing (CIDR): an Address Assignment and Aggregation Strategy 』に記載されています。CIDR により、ネットワーク管理者は、任意のマスクを IP アドレスに適用して、管理するネットワークの要件を満たす IP アドレッシング計画を作成できます。

CIDR の詳細については、RFC 1519( http://www.ietf.org/rfc/rfc1519.txt )を参照してください。

プレフィクス

プレフィクスという用語は、通常、ルーティング テーブルの構築に重要な IP ネットワーク アドレスのビット数を示すときに使用されます。クラスフル(A、B、C ネットワーク アドレス境界を厳守する)IP アドレスだけを使用する場合、プレフィクスは、アドレスのクラスのマスクと同じです。たとえば、クラスフル IP アドレッシングを使用すると、192.168.10.0 などのクラス C の IP ネットワーク アドレスは、24 ビットのマスク(/24 または 255.255.255.0)を使用します。また、24 ビットのプレフィクスを使用するということもできます。

CIDR を使用する場合、プレフィクスは、ネットワークのルーティング テーブルをどのように読み込むかに基づいて、IP ネットワーク アドレスに任意に割り当てられます。たとえば、192.168.10.0、192.168.11.0、192.168.12.0、192.168.13.0 など、クラス C の IP アドレスのグループは、16 ビット プレフィクス(192.168.0.0/16)の 192.168.0.0 への単一ルートとしてアドバタイズできます。これにより、ネットワークのルータで管理が必要なルートの数が 1/4 に削減されます。

IP アドレスの設定方法

ここでは、次の作業について説明します。

「IP アドレスをインターフェイスに割り当てることによるネットワークとの IP 接続の確立」

「セカンダリ IP アドレスの使用によるネットワークでサポートされる IP ホストの数の増加」

「ポイントツーポイント WAN インターフェイスでの IP アンナンバードを使用することによる、IP 接続の確立を必要とする IP アドレス数の削減」

「ポイントツーポイント WAN インターフェイスで 31 ビット プレフィクスの IP アドレスを使用することによる、IP 接続の確立を必要とする IP アドレス数の削減」

「IP サブネット ゼロの使用を許可することによる、使用できる IP サブネットの数の最大化」

「ネットワーク マスクの形式の指定」

IP アドレスをインターフェイスに割り当てることによるネットワークとの IP 接続の確立

インターフェイスで IP アドレスを設定するには、次の操作を実行します。

手順の概要

1. enable

2. configure terminal

3. interface type number

4. no shutdown

5. ip address ip-address mask

6. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface type number

 

Router(config)# interface fastethernet 0/0

インターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 4

no shutdown

 

Router(config-if)# no shutdown

インターフェイスをイネーブルにします。

ステップ 5

ip address ip-address mask

 

Router(config-if)# ip address 172.16.16.1 255.255.240.0

インターフェイスの IP アドレスを設定します。

ステップ 6

end

 

Router(config-if)# end

現在のコンフィギュレーション モードを終了し、特権 EXEC モードに戻ります。

トラブルシューティングのヒント

次のコマンドは、IP アドレッシングのトラブルシューティングに役に立ちます。

show ip interface :インターフェイスの IP パラメータを表示します。

show ip route connected :ネットワーキング デバイスの接続先 IP ネットワークを表示します。

セカンダリ IP アドレスの使用によるネットワークでサポートされる IP ホストの数の増加

ネットワーク セグメントを割り当てているサブネットで使用できる IP ホスト アドレスをすべて使用している状態で、ネットワーク セグメントにさらに多くの IP ホストを接続する必要がある場合、セカンド IP ネットワーク アドレスをネットワーク セグメントに追加することで、サブネットが異なるすべてのホストのアドレッシングを変更する必要がなくなります。

インターフェイスでセカンダリ IP アドレスを設定するには、次の作業を実行します。

手順の概要

1. enable

2. configure terminal

3. interface type number

4. no shutdown

5. ip address ip-address mask

6. ip address ip-address mask secondary

7. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface type number

 

Router(config)# interface fastethernet 0/0

インターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 4

no shutdown

 

Router(config-if)# no shutdown

インターフェイスをイネーブルにします。

ステップ 5

ip address ip-address mask

 

Router(config-if)# ip address 172.16.16.1 255.255.240.0

インターフェイスの IP アドレスを設定します。

ステップ 6

ip address ip-address mask secondary

 

Router(config-if)# ip address 172.16.32.1 255.255.240.0 secondary

インターフェイスでセカンダリ IP アドレスを設定します。

ステップ 7

end

 

Router(config-if)# end

現在のコンフィギュレーション モードを終了し、特権 EXEC モードに戻ります。

トラブルシューティングのヒント

次のコマンドは、IP アドレッシングのトラブルシューティングに役に立ちます。

show ip interface :インターフェイスの IP パラメータを表示します。

show ip route connected :ネットワーキング デバイスの接続先 IP ネットワークを表示します。

次の作業

ネットワークで複数のルータを使用していて、ルーティング プロトコルをすでに設定している場合、他のルータが、割り当てられている新しい IP ネットワークにアクセスできるようにします。この場合、状況によっては、新しいネットワークをアドバタイズできるように、ルータのルーティング プロトコルの設定を変更する必要があります。ルーティング プロトコルの設定については、次の URL の『 Cisco IOS IP Routing Protocols Configuration Guide, Release 12.4T』を参照してください。

http://www.cisco.com/en/US/docs/ios/iproute/configuration/guide/12_4t/irp_12_4t_book.html.

ポイントツーポイント WAN インターフェイスでの IP アンナンバードを使用することによる、IP 接続の確立を必要とする IP アドレス数の削減

IP ネットワークまたはサブネット アドレスの数が制限されていて、ネットワークでポイントツーポイント WAN を使用している場合、IP アンナンバード インターフェイス機能を使用することで、実際に IP アドレスを割り当てることなく、ポイントツーポイント WAN インターフェイスの IP 接続をイネーブルにできます。

ポイントツーポイント WAN インターフェイスで IP アンナンバード インターフェイス機能を設定するには、次の作業を実行します。

「IP アンナンバード機能」

「制約事項」

「手順の概要」

「手順の詳細」

「トラブルシューティングのヒント」

IP アンナンバード機能

IP アンナンバード インターフェイス機能を使用すると、明示的な IP アドレスに割り当てることなく、ポイントツーポイント WAN インターフェイスで IP 処理をイネーブルにできます。IP アンナンバード ポイントツーポイント WAN インターフェイスは、別のインターフェイスの IP アドレスを使用して IP 接続をイネーブルにします。これにより、ネットワーク アドレスを節約できます。

制約事項

IP アンナンバード インターフェイス機能には次の制約事項が適用されます。

IP アンナンバード インターフェイス機能がサポートされるのは、ポイントツーポイント(非マルチアクセス)WAN インターフェイスだけです。

IP アンナンバード インターフェイス機能を使用するインターフェイスで Cisco IOS イメージをネットブートできません。

手順の概要

1. enable

2. configure terminal

3. interface type number

4. no shutdown

5. ip address ip-address mask

6. interface type number

7. no shutdown

8. ip unnumbered type number

9. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface type number

 

Router(config)# interface fastethernet 0/0

インターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 4

no shutdown

 

Router(config-if)# no shutdown

インターフェイスをイネーブルにします。

ステップ 5

ip address ip-address mask

 

Router(config-if)# ip address 172.16.16.1 255.255.240.0

インターフェイスの IP アドレスを設定します。

ステップ 6

interface type number

 

Router(config-if)# interface serial 0/0

ポイントツーポイント WAN インターフェイスを指定して、インターフェイス コンフィギュレーション モードを開始します。

ステップ 7

no shutdown

 

Router(config-if)# no shutdown

ポイントツーポイント WAN インターフェイスをイネーブルにします。

ステップ 8

ip unnumbered type number

 

Router(config-if)# ip unnumbered fastethernet 0/0

ポイントツーポイント WAN インターフェイスで IP アンナンバード機能をイネーブルにします。

この例では、ポイントツーポイント WAN インターフェイスは、ファスト イーサネット 0/0 から IP アドレス 172.16.16.1 を使用します。

ステップ 9

end

 

Router(config-if)# end

現在のコンフィギュレーション モードを終了し、特権 EXEC モードに戻ります。

トラブルシューティングのヒント

次のコマンドは、IP アドレッシングのトラブルシューティングに役に立ちます。

show ip interface :インターフェイスの IP パラメータを表示します。

show ip route connected :ネットワーキング デバイスの接続先 IP ネットワークを表示します。

ポイントツーポイント WAN インターフェイスで 31 ビット プレフィクスの IP アドレスを使用することによる、IP 接続の確立を必要とする IP アドレス数の削減

ネットワーキング デバイスにより使用される IP サブネットの数を削減して、RFC 3021 で規定されている 31 ビット プレフィクスの IP アドレスを使用して接続先のポイントツーポイント WAN との IP 接続を確立できます。

ポイントツーポイント WAN インターフェイスで 31 ビット プレフィクスの IP アドレスを設定するには、次の作業を実行します。

「RFC 3021」

「前提条件」

「制約事項」

「手順の概要」

「手順の詳細」

「トラブルシューティングのヒント」

RFC 3021

RFC 3021『 Using 31-bit Prefixes on IPv4 Point-to-Point Links 』より以前では、多くのネットワーク管理者は、30 ビット サブネット マスク(255.255.255.252)の IP アドレスをポイントツーポイント インターフェイスに割り当て、IP アドレス空間を節約していました。これにより、255.255.255.240 などのより短いサブネット マスクの IP アドレスを割り当てた場合よりも、IP アドレス空間を節約できましたが、30 ビット サブネット マスクの IP アドレスでは、リンクあたり 4 つのアドレスが必要です。これらは、ホスト アドレスが 2 つ(リンクの各ホスト インターフェイスに 1 つずつ)、すべてゼロのネットワーク アドレスが 1 つ、すべて 1 のブロードキャスト ネットワーク アドレスが 1 つです。

表 8 に、30 ビット(255.255.255.252 または /30)サブネット マスクが IP アドレス 192.168.100.4 に適用されるときに作成される 4 つの IP アドレスの例を示します。ホスト IP アドレスの指定に使用されるビットは太字で示しています。

 

表 8 30 ビット サブネット マスク(/30)が使用されるときに作成される 4 つの IP アドレス

Address
説明
2 進数

192.168.100.4/30

すべてゼロの IP アドレス

11000000.10101000.01100100.000001 00

192.168.100.5/30

最初のホスト アドレス

11000000.10101000.01100100.000001 01

192.168.100.6/30

2 番めのホスト アドレス

11000000.10101000.01100100.000001 10

192.168.100.7/30

すべて 1 のブロードキャスト アドレス

11000000.10101000.01100100.000001 11

ポイントツーポイントにはエンドポイント(ホスト)は 2 つだけで、一方のホストで転送される任意のパケットは、常にもう一方のホストで受信されるため、ブロードキャスト サポートは必要ありません。そのため、すべて 1 のブロードキャスト IP アドレスは、ポイントツーポイント インターフェイスには必要ありません。

RFC 3021 を簡単に説明すると、31 ビット プレフィクス(31 ビット サブネット マスクを IP アドレスに適用されることで作成されます)を使用することで、ポイントツーポイント ネットワークですべてゼロとすべて 1 の IP アドレスをホスト アドレスとして割り当てることができます。RFC 3021 より以前では、ポイントツーポイント リンクで一般的に使用される最長のプレフィクスは 30 ビットでした。つまり、すべてゼロとすべて 1 の IP アドレスは使用されていませんでした。

表 9 に、31 ビット(255.255.255.254 または /31)サブネット マスクが IP アドレス 192.168.100.4 に適用されるときに作成される 2 つの IP アドレスの例を示します。ホスト IP アドレスの指定に使用されるビットは太字で示しています。

 

表 9 31 ビット サブネット マスク(/31)が使用されるときに作成される 4 つの IP アドレス

Address
説明
2 進数

192.168.100.4/31

最初のホスト アドレス

11000000.10101000.01100100.0000010 0

192.168.100.5/31

2 番めのホスト アドレス

11000000.10101000.01100100.0000010 1

RFC 3021 の詳細については、 http://www.ietf.org/rfc/rfc3021.txt を参照してください。

前提条件

31 ビット プレフィクスの IP アドレスをポイントツーポイント インターフェイスで設定する前に、クラスレス IP アドレッシングをネットワーキング デバイスで設定する必要があります。クラスレス IP アドレッシングは、Cisco IOS ソフトウェアの多くのバージョンでデフォルトでイネーブルにされています。ネットワーキング デバイスで IP クラスレス アドレッシングが設定されているかわからない場合、グローバル コンフィギュレーション モードで ip classless コマンドを入力して、クラスレス IP アドレッシングをイネーブルにします。

制約事項

この作業は、ポイントツーポイント(非マルチアクセス)WAN インターフェイスだけで実行できます。

手順の概要

1. enable

2. configure terminal

3. ip classless

4. interface type number

5. no shutdown

6. ip address ip-address mask

7. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip classless

 

Router(config)# ip classless

(任意)IP クラスレス(CIDR)をイネーブルにします。

コマンドが設定に表示されていない場合、デフォルトでイネーブルにされています。

ステップ 4

interface type number

 

Router(config)# interface serial 0/0

ポイントツーポイント WAN インターフェイスを指定して、インターフェイス コンフィギュレーション モードを開始します。

ステップ 5

no shutdown

 

Router(config-if)# no shutdown

インターフェイスをイネーブルにします。

ステップ 6

ip address ip-address mask

 

Router(config-if)# ip address 192.168.100.4 255.255.255.254

31 ビット プレフィクスの IP アドレスをポイントツーポイント WAN インターフェイスで設定します。

ステップ 7

end

 

Router(config-if)# end

現在のコンフィギュレーション モードを終了し、特権 EXEC モードに戻ります。

トラブルシューティングのヒント

次のコマンドは、IP アドレッシングのトラブルシューティングに役に立ちます。

show ip interface :インターフェイスの IP パラメータを表示します。

show ip route connected :ネットワーキング デバイスの接続先 IP ネットワークを表示します。

IP サブネット ゼロの使用を許可することによる、使用できる IP サブネットの数の最大化

ネットワーク アドレスをすべて使用しているときに、ネットワークでサブネット化を使用すると、サブネット ゼロを設定できるようにネットワーキング デバイスを設定できます。これにより、IP アドレッシング方式のすべてのサブネットに使用できるネットワーク アドレスが 1 つ追加されます。 表 4 に、172.16.0.0/20 の IP サブネット(サブネット 0 を含む)を示します。

ネットワーキング デバイスで IP サブネット ゼロの使用をイネーブルにするには、次の作業を実行します。

手順の概要

1. enable

2. configure terminal

3. ip subnet-zero

4. interface type number

5. no shutdown

6. ip address ip-address mask

7. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip subnet-zero

 

Router(config)# ip subnet-zero

IP サブネット ゼロの使用をイネーブルにします。

ステップ 4

interface type number

 

Router(config)# interface fastethernet 0/0

インターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 5

no shutdown

 

Router(config-if)# no shutdown

インターフェイスをイネーブルにします。

ステップ 6

ip address ip-address mask

 

Router(config-if)# ip address 172.16.0.1 255.255.240.0

インターフェイスでサブネット ゼロ IP アドレスを設定します。

ステップ 7

end

 

Router(config-if)# end

現在のコンフィギュレーション モードを終了し、特権 EXEC モードに戻ります。

トラブルシューティングのヒント

次のコマンドは、IP アドレッシングのトラブルシューティングに役に立ちます。

show ip interface :インターフェイスの IP パラメータを表示します。

show ip route connected :ネットワーキング デバイスの接続先 IP ネットワークを表示します。

ネットワーク マスクの形式の指定

デフォルトでは、 show コマンドは、IP アドレスおよびそのネットマスクをドット付き 10 進表記で表示します。たとえば、サブネットは 131.108.11.55 255.255.255.0 として表示されます。

ネットワーク マスクは、16 進数形式またはビット カウント形式で表示する方が便利なこともあります。16 進数形式は通常 UNIX システムで使用されます。前述の例の場合、131.108.11.55 0XFFFFFF00 として表示されます。

ビット カウント形式でネットワーク マスクを表示すると、アドレス自体にスラッシュ(/)とネットマスクの合計ビット数が追加されます。前述の例の場合、131.108.11.55/24 として表示されます。

「現在のセッションでのネットマスクの表示形式の指定」

「個々の回線でのネットマスクの表示形式の指定」

現在のセッションでのネットマスクの表示形式の指定

現在のセッションでのネットマスクの表示形式を指定するには、次の作業を実行します。

手順の概要

1. enable

2. term ip netmask-format {bitcount | decimal | hexadecimal}

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

term ip netmask-format { bitcount | decimal | hexadecimal }

 

Router# term ip netmask-format hexadecimal

ルータでのネットワーク マスクの表示に使用される形式を指定します。

個々の回線でのネットマスクの表示形式の指定

個々の回線でのネットマスクの表示形式を指定するには、次の作業を実行します。

手順の概要

1. enable

2. configure terminal

3. line vty first last

4. term ip netmask-format { bitcount | decimal | hexadecimal }

5. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

line vty first last

 

Router(config)# line vty 0 4

first および last 引数で指定した回線の範囲でライン コンフィギュレーション モードを開始します。

ステップ 4

term ip netmask-format { bitcount | decimal | hexadecimal }

 

Router(config-line)# ip netmask-format hexadecimal

ルータで個々の回線のネットワーク マスクを表示するときに使用される形式を指定します。

ステップ 5

end

 

Router(config-if)# end

現在のコンフィギュレーション モードを終了し、特権 EXEC モードに戻ります。

IP アドレスの設定例

ここでは、次の設定例について説明します。

「IP アドレスをインターフェイスに割り当てることによるネットワークとの IP 接続の確立:例」

「セカンダリ IP アドレスの使用によるネットワークでサポートされる IP ホストの数の増加:例」

「ポイントツーポイント WAN インターフェイスでの IP アンナンバードを使用することによる、IP 接続の確立を必要とする IP アドレス数の削減:例」

「ポイントツーポイント WAN インターフェイスで 31 ビット プレフィクスの IP アドレスを使用することによる、IP 接続の確立を必要とする IP アドレス数の削減:例」

「IP サブネット ゼロの使用を許可することによる、使用できる IP サブネットの数の最大化:例」

IP アドレスをインターフェイスに割り当てることによるネットワークとの IP 接続の確立:例

次の例では、3 つのインターフェイスで IP アドレスを設定します。

!
interface FastEthernet0/0
no shutdown
ip address 172.16.16.1 255.255.240.0
!
interface FastEthernet0/1
no shutdown
ip address 172.16.32.1 255.255.240.0
!
interface FastEthernet0/2
no shutdown
ip address 172.16.48.1 255.255.240.0
!
 

セカンダリ IP アドレスの使用によるネットワークでサポートされる IP ホストの数の増加:例

次の例では、3 つのインターフェイスでセカンダリ IP アドレスを設定します。

!
interface FastEthernet0/0
no shutdown
ip address 172.16.16.1 255.255.240.0
ip address 172.16.32.1 255.255.240.0 secondary
!
!
interface FastEthernet0/1
no shutdown
ip address 172.17.16.1 255.255.240.0
ip address 172.17.32.1 255.255.240.0 secondary
!
!
interface FastEthernet0/2
no shutdown
ip address 172.18.16.1 255.255.240.0
ip address 172.18.32.1 255.255.240.0 secondary
!
 

ポイントツーポイント WAN インターフェイスでの IP アンナンバードを使用することによる、IP 接続の確立を必要とする IP アドレス数の削減:例

次の例では、3 つのインターフェイスでアンナンバード IP 機能を設定します。

!
interface FastEthernet0/0
no shutdown
ip address 172.16.16.1 255.255.240.0
!
interface serial0/0
no shutdown
ip unnumbered fastethernet0/0
!
interface serial0/1
no shutdown
ip unnumbered fastethernet0/0
!
interface serial0/2
no shutdown
ip unnumbered fastethernet0/0
!

ポイントツーポイント WAN インターフェイスで 31 ビット プレフィクスの IP アドレスを使用することによる、IP 接続の確立を必要とする IP アドレス数の削減:例

次の例では、2 つのインターフェイスで 31 ビット プレフィクスを設定します。

!
ip classless
!
interface serial0/0
no shutdown
ip address 192.168.100.2 255.255.255.254
!
!
interface serial0/1
no shutdown
ip address 192.168.100.4 255.255.255.254
 

IP サブネット ゼロの使用を許可することによる、使用できる IP サブネットの数の最大化:例

次の例では、サブネット ゼロをイネーブルにします。

!
interface FastEthernet0/0
no shutdown
ip address 172.16.16.1 255.255.240.0
!
ip subnet-zero
!

次の作業

ネットワークに複数のルータがあり、ルーティング プロトコルを設定していない場合、ルーティング プロトコルの設定については、次の URL の『 Cisco IOS IP Routing Protocols Configuration Guide , Release 12.4T』を参照してください。

http://www.cisco.com/en/US/docs/ios/iproute/configuration/guide/12_4t/irp_12_4t_book.html

参考資料

ここでは、IP アドレスに関する関連資料について説明します。

関連資料

関連項目
参照先

IP アドレッシング コマンド:コマンド構文の詳細、コマンド モード、コマンド履歴、デフォルト、使用上の注意事項、および例

『Cisco IOS IP Addressing Services Command Reference』

IP アドレッシング IP ルーティングの基本原理

『IP Routing Primer ISBN 1578701082』

規格

規格
タイトル

新しい規格または変更された規格はサポートされていません。また、既存の規格に対するサポートに変更はありません。

--

MIB

MIB
MIB リンク

新しい MIB または変更された MIB はサポートされていません。また、既存の MIB に対するサポートに変更はありません。

--

RFC

RFC6
タイトル

RFC 791

『Internet Protocol』

http://www.ietf.org/rfc/rfc0791.txt

RFC 1338

『Classless Inter-Domain Routing (CIDR): an Address Assignment and Aggregation Strategy』
http://www.ietf.org/rfc/rfc1519.txt

RFC 1466

『Guidelines for Management of IP Address Space』
http://www.ietf.org/rfc/rfc1466.txt

RFC 1716

『Towards Requirements for IP Routers』
http://www.ietf.org/rfc/rfc1716.txt

RFC 1918

『Address Allocation for Private Internets』
http://www.ietf.org/rfc/rfc1918.txt

RFC 3330

『Special-Use IP Addresses』
http://www.ietf.org/rfc/rfc3330.txt

6.これらの参考資料は、IP アドレッシングおよび IP ルーティングに関連する項目で使用できる多くの RFC の例です。RFC の完全なリストについては、IETF RFC のサイト(http://www.ietf.org/rfc.html)を参照してください。

シスコのテクニカル サポート

説明
リンク

右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。

以下を含むさまざまな作業にこの Web サイトが役立ちます。

テクニカル サポートを受ける

ソフトウェアをダウンロードする

セキュリティの脆弱性を報告する、またはシスコ製品のセキュリティ問題に対する支援を受ける

ツールおよびリソースへアクセスする

Product Alert の受信登録

Field Notice の受信登録

Bug Toolkit を使用した既知の問題の検索

Networking Professionals(NetPro)コミュニティで、技術関連のディスカッションに参加する

トレーニング リソースへアクセスする

TAC Case Collection ツールを使用して、ハードウェアや設定、パフォーマンスに関する一般的な問題をインタラクティブに特定および解決する

この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

http://www.cisco.com/en/US/support/index.html

IP アドレスの機能情報

表 10 に、このモジュールで説明した機能をリストし、特定の設定情報へのリンクを示します。

ご使用の Cisco IOS ソフトウェア リリースでは、一部のコマンドが使用できない場合があります。特定のコマンドのリリース情報については、コマンド リファレンス マニュアルを参照してください。

プラットフォームのサポートおよびソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator を使用すると、特定のソフトウェア リリース、機能セット、またはプラットフォームをサポートする Cisco IOS と Catalyst OS のソフトウェア イメージを判別できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスしてください。Cisco.com のアカウントは必要ありません。


表 10 に、特定の Cisco IOS ソフトウェア リリース群で特定の機能をサポートする Cisco IOS ソフトウェア リリースだけを示します。特に明記されていない限り、Cisco IOS ソフトウェア リリース群の後続のリリースでもこの機能をサポートします。


 

表 10 IP アドレスの機能情報

機能名
リリース
機能情報

IP ポイントツーポイント リンクでの 31 ビット プレフィクスの使用

12.0(14)S
12.2(4)T

インターネットで IP アドレス空間を節約するために、31 ビット プレフィクス長により、ポイントツーポイント リンクで 2 つだけの IP アドレスの使用が可能になりました。以前は、カスタマーは、ポイントツーポイント リンクで IP アドレスまたはアンナンバード インターフェイスを 4 つ使用する必要がありました。

次のセクションで、この機能に関する情報を参照できます。

「ポイントツーポイント WAN インターフェイスで 31 ビット プレフィクスの IP アドレスを使用することによる、IP 接続の確立を必要とする IP アドレス数の削減」

IP アンナンバード インターフェイス

10.0

IP アドレス空間を節約するために、IP アンナンバード インターフェイスは、別のインターフェイスの IP アドレスを使用して IP 接続を確立できます。

次のコマンドが導入または変更されました。 ip unnumbered

IP サブネット ゼロ

10.0

IP アドレス空間を節約するために、IP サブネット ゼロにより、インターフェイスの IP アドレスとしてすべてゼロのサブネットを使用できます。たとえば、ファスト イーサネット 0/0 で 172.16.0.1/24 を設定できます。

次のコマンドが導入または変更されました。 ip subnet-zero

クラスレス Inter-Domain ルーティング

10.0

CIDR は、クラス(クラス A、クラス B など)の概念をなくす、新しい IP アドレスの参照方法です。たとえば、ネットワーク 192.213.0.0(不正なクラス C ネットワーク番号)は、CIDR 表記で 192.213.0.0/16 と表される場合、有効なスーパーネットです。/16 は、スーパーネット マスクが 16 ビットで構成されることを示します(左からカウントします)。そのため、192.213.0.0/16 は、192.213.0.0 255.255.0.0 と同じです。

次のコマンドが導入または変更されました。 ip classless