Cisco Services Ready Engine Virtualization インストレーション/コンフィギュレーション ガイド ソフトウェア リリース 2.0
仮想マシンの管理
仮想マシンの管理
発行日;2012/06/01 | 英語版ドキュメント(2011/12/15 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 3MB) | フィードバック

目次

仮想マシンの管理

vSphere Client のダウンロードとインストール

VMware vCenter Server のダウンロード

VMware vCenter Server での Cisco SRE サービス モジュールの管理

ロックダウン モードについて

ロックダウン モードが無効の場合の動作

ロックダウン モードが有効の場合の動作

ロックダウン モードが有効であるかどうかの確認

仮想マシンの作成についての重要事項

仮想マシンを作成するための基本的なワークフロー

仮想マシンの作成に関する制限事項

仮想マシンを作成する場合のネットワーキングに関する前提条件

VMware ツールのインストール

vSwitch について

VMware vSphere Hypervisor の高度なカスタマイズ

ネットワーク解析モジュールのサポート

システムの再設定後にしばらくしてからコンソールがリブートされる

VMware vSphere Hypervisor の IP アドレスを vSphere コンソール インターフェイスから変更できない

VMware vSphere Hypervisor の Management Network の IP アドレスの変更

Management Network リンクの変更

DCUI へのアクセスの変更

VMware vSphere Hypervisor がシャットダウン状態にならない

仮想マシンを VMware vSphere Hypervisor と同じサブネットに追加

仮想マシンの管理

仮想マシンとは、(物理的なコンピュータと同等な)ソフトウェア コンピュータです。この仮想マシン上で、オペレーティング システムやアプリケーションを実行します。仮想マシンは、VMware vSphere Hypervisor 上で稼動します。同じ VMware vSphere Hypervisor を使用して、複数の仮想マシンを実行できます。仮想マシンを作成および管理するには、vSphere Client GUI を使用します。複数の VMware vSphere Hypervisor ホスト を管理するには、VMware vCenter Server を使用します。

「vSphere Client のダウンロードとインストール」

「VMware vCenter Server のダウンロード」

「VMware vCenter Server での Cisco SRE サービス モジュールの管理」

「ロックダウン モードについて」

「仮想マシンの作成についての重要事項」

「vSwitch について」

「VMware vSphere Hypervisor の高度なカスタマイズ」

vSphere Client のダウンロードとインストール

仮想マシンを管理するには、Microsoft .NET 3.5 SP1 フレームワークがある Microsoft Windows システムで vSphere Client をダウンロードし、インストールする必要があります。

vSphere Client には、初心者向けのオンライン チュートリアルが含まれます。また、インライン コンテンツとしてセットアップ用のアシスタント機能が組み込まれています。このアシスタント機能を使用すると、簡単な手順に従って仮想インフラストラクチャを設定できます。経験豊富なユーザは、このインライン コンテンツのアシスタント機能を無効にすることを選択できます。


) vSphere Client をダウンロードするには、インターネットへの接続が必要になります。vSphere Client をダウンロードする前に、ネットワークに接続していることを確認します。


手順


ステップ 1 https:// hypervisor-ip-address にアクセスします。

VMware Web サイトに移動し、[Welcome] ページが表示されます。

ステップ 2 [Download vSphere Client] をクリックしてから、[Run] をクリックして、vSphere Client をダウンロードします。VMware vSphere Client がインストールされ、VMware vSphere Client へのショートカット アイコンがデスクトップに表示されます。

ステップ 3 [VMware vSphere Client] アイコンをクリックして、ログイン ウィンドウを表示します。

ステップ 4 単一の VMware vSphere Hypervisor を管理するには、VMware vSphere Hypervisor の IP アドレスまたはホスト名と、ユーザ名およびパスワードを入力し、[Login] をクリックします。VSphere Client GUI が表示されます。


) VMware vSphere Hypervisor を初めて使用する場合は、ユーザ名に root を使用し、パスワードのフィールドは空のままにしておきます。ログイン後に、パスワードを変更することを推奨します。



) Cisco SRE-V オプション 3(ハードウェア、仮想化ソフトウェア、および Microsoft Windows ソフトウェア)を購入した場合は、仮想マシンがデフォルトで提供されます。Cisco SRE-V オプションについては、図 1-3を参照してください。


ステップ 5 vSphere Client のメイン ページで、次のいずれかの手順を実行します。

Cisco SRE-V ソフトウェア オプション 3 でデフォルトにより提供された既存の仮想マシンを使用するには、次の手順を実行します。

左側のナビゲーション ツリーで、ホスト名をクリックしてナビゲーション ツリーを展開し、仮想マシンを選択します。

[Getting Started] タブの右側のペインに表示された指示に従います。図 6-1を参照してください。

図 6-1 仮想マシンが選択されている vSphere Client インベントリ ページ

 

新しい仮想マシンを作成するには、「仮想マシンの作成についての重要事項」を参照し、次の手順を実行します。

左側のナビゲーション ツリーで、ホスト名を選択します。

[Getting Started] タブの右側のペインに表示された指示に従います。図 6-2を参照してください。

図 6-2 ホスト名が選択されている vSphere Client インベントリ ページ

 


) 経験豊富なユーザは、ビューから [Getting Started] タブを削除することを選択できます。[Edit] > [Client Settings] の順に選択します。[General] タブがデフォルトで選択されています。[Tasks] ペインで [Show Getting Started Tab] チェックボックスをオフにします。


ステップ 6 仮想マシンを管理するには、vSphere Client により提供された機能を使用します。


 

関連項目

「VMware vCenter Server のダウンロード」

「VMware vCenter Server での Cisco SRE サービス モジュールの管理」

「仮想マシンの作成についての重要事項」

VMware vCenter Server のダウンロード

複数の VMware vSphere Hypervisor ホストを管理するには、VMware vCenter Server をダウンロードします。

はじめに

vSphere Client をダウンロードし、インストールします。「vSphere Client のダウンロードとインストール」を参照してください。

VMware vCenter Server をダウンロードするには、インターネットへの接続が必要になります。ネットワークに接続していることを確認します。

手順


ステップ 1 https:// hypervisor-ip-address にアクセスします。

VMware Web サイトに移動し、[Welcome] ページが表示されます。

ステップ 2 [Download VMware vCenter] をクリックします。

VMware vCenter Server については、『 vSphere のインストールとセットアップ 』( http://pubs.vmware.com/vsphere-50/topic/com.vmware.ICbase/PDF/vsphere-esxi-vcenter-server-50-installation-setup-guide.pdf )を参照してください。


 

VMware vCenter Server での Cisco SRE サービス モジュールの管理

はじめに

vSphere Client をダウンロードし、インストールします。「vSphere Client のダウンロードとインストール」を参照してください。

VMware vCenter Server をダウンロードします。「VMware vCenter Server のダウンロード」を参照してください。

手順


ステップ 1 [VMware vSphere Client] アイコンをクリックして、ログイン ウィンドウを表示します。

ステップ 2 複数のホストを管理するには、VMware vCenter Server の IP アドレスまたはホスト名と、VMware vCenter Server のユーザ名およびパスワードを入力し、[Login] をクリックします。

VSphere Client GUI が表示されます。

ステップ 3 vSphere Client のメイン ページで、次の手順を実行します。

a. データストアを作成します。

b. VMware vSphere Hypervisor ホストを追加します。[Add Host Wizard] ページが表示されます。

c. VMware vSphere Hypervisor ホストの IP アドレス、ユーザ名、およびパスワードを提供します。

詳細については、『 vSphere のインストールとセットアップ 』( http://pubs.vmware.com/vsphere-50/topic/com.vmware.ICbase/PDF/vsphere-esxi-vcenter-server-50-installation-setup-guide.pdf )を参照してください。


 

ロックダウン モードについて

VMware vSphere Hypervisor では、VMware vCenter Server によって制御されているホストをロックダウン モードにすることができます。

「ロックダウン モードが無効の場合の動作」

「ロックダウン モードが有効の場合の動作」

「ロックダウン モードが有効であるかどうかの確認」

ロックダウン モードが無効の場合の動作

デフォルトでは、ロックダウン モードは無効です。ロックダウン モードが無効の場合は、すべてのルータとモジュールの通信コマンドが正常に動作します。

ロックダウン モードが有効の場合の動作

ロックダウン モードが有効の場合、VMware vSphere Hypervisor ホストは、vpxuser と呼ばれる内部ユーザを使用して VMware vCenter Server によってのみ管理できます。vSphere Client、PowerCLI、vCLI などの他のすべての通信手段は無効になります。

表 6-1 に、ロックダウン モードが有効の場合のコマンドの動作を示します。

表 6-1 ロックダウン モードでのコマンドの動作

コマンド
ロックダウン モードでの動作

service-module slot /0 status

正常に動作します。次のようなステータスが表示されます。
VMware ESXi 5.0.0 build-469512 running on SRE (LOCKDOWN).

interface slot /0

service-module heartbeat-reset

正常に動作します。

(注) これは、ロックダウン モードが無効の場合と同じ動作です。

service-module sm slot /0 reset

正常に動作します。

(注) これは、ロックダウン モードが無効の場合と同じ動作です。

interface slot /0

service-module ip address

service-module ip default gateway

無視されます。これらのコマンドは Cisco IOS 設定に保持され、 show running-config コマンドを入力したときに表示されます。ただし、VMware vSphere Hypervisor の設定は変更されません。

service-module sm slot /0 reload

service-module sm slot /0 shutdown

ホスト ルータにより報告されたサービス モジュールのステータスを変更しますが、VMware vSphere Hypervisor に影響を与えません。

ロックダウン モードが有効であるかどうかの確認

ロックダウン モードが有効であるかどうかを確認するには、 service-module sm slot /0 status コマンドを入力します。ロックダウン モードが有効な場合は、出力に「(LOCKDOWN)」と表示されます。次の例を参照してください。

VMware ESXi 5.0.0 build-469512 running on SRE (LOCKDOWN)

) ロックダウン モードを有効にしてからシステムがそのことを認識するまでに最大 10 秒かかることがあります。


VMware vSphere Hypervisor ロックダウン モードの詳細については、VMware Knowledge Base の記事( http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=1008077 )を参照してください。

仮想マシンの作成についての重要事項

Cisco SRE-V オプション 3(ハードウェア、仮想化ソフトウェア、および Microsoft Windows ソフトウェア)を購入した場合は、VMware ツールとデータストアを備えた仮想マシンがデフォルトで提供されます。必要に応じて、追加の仮想マシンを作成できます。

Cisco SRE-V オプション 1(ハードウェアのみ。仮想化ソフトウェアや Microsoft Windows ソフトウェアはなし)またはオプション 2(ハードウェアと仮想化ソフトウェア)を購入した場合は、仮想マシンを作成する必要があります。

Cisco SRE-V オプションについては、図 1-3を参照してください。

次の項を参照してください。

「仮想マシンを作成するための基本的なワークフロー」

「仮想マシンの作成に関する制限事項」

「仮想マシンを作成する場合のネットワーキングに関する前提条件」

「VMware ツールのインストール」

仮想マシンを作成するための基本的なワークフロー

1. (任意)Cisco SRE-V でデータストアを作成します。

2. 仮想マシンを作成します。

3. 仮想マシンにオペレーティング システムをインストールします。

4. 仮想マシンにネットワーキング(外部)を設定します。

5. 仮想マシンにネットワーキング(内部)を設定します。

手順については、vSphere Client のオンライン ヘルプを参照してください。

仮想マシンの作成に関する制限事項

仮想マシンを作成する前に、次の制限事項を確認してください。

各仮想マシンには、それぞれ独自のリソース制限(CPU コア数やメモリ サイズなど)があります。

Virtual Symmetric Multiprocessing(vSMP)はサポートされません。

シリアル ポートなどの物理的な周辺機器はサポートされません。

Cisco SRE サービス モジュールの前面パネルにある USB ポートに接続する物理的な USB デバイスは 500 mA(2.5 W)を超えないようにする必要があります。USB デバイスを仮想マシンに割り当てる方法については、vSphere のユーザ ガイドを参照してください。

関連項目

「vSphere Client のダウンロードとインストール」

仮想マシンを作成する場合のネットワーキングに関する前提条件

異なる VLAN に仮想マシンを割り当てる場合は、ISR G2 で VLAN を設定する必要があります。

interface SM1/1
description Internal switch interface connected to Service Module
switchport mode trunk
!
interface Vlan50
ip address 50.50.50.5 255.255.255.0
!
interface Vlan60
ip address 60.60.60.6 255.255.255.0
 

関連項目

「vSphere Client のダウンロードとインストール」

VMware ツールのインストール

VMware ツールは、仮想マシンのゲスト オペレーティング システムのパフォーマンスと仮想マシンの管理を改善するユーティリティ スイートです。

Cisco SRE-V オプション 3(ハードウェア、仮想化ソフトウェア、および Microsoft Windows ソフトウェア)を購入した場合は、VMware ツールを備えた仮想マシンがデフォルトで提供されるので、VMware ツールをマシンにインストールする必要はありません。ただし、新規の仮想マシンを作成する場合は、その仮想マシンに VMware ツールをインストールする必要があります。

Cisco SRE-V オプション 1(ハードウェアのみ。仮想化ソフトウェアや Microsoft Windows ソフトウェアはなし)またはオプション 2(ハードウェアと仮想化ソフトウェア)を購入した場合は、仮想マシンの作成後に VMware ツールをインストールする必要があります。

Cisco SRE-V オプションについては、図 1-3を参照してください。

はじめに

サポートされているゲスト オペレーティング システムを仮想マシンにインストールします。

手順


ステップ 1 vSphere Client GUI のメイン ページにアクセスします。

ステップ 2 左側のナビゲーション ツリーでホスト名をクリックして、ナビゲーション ツリーを展開します。

ステップ 3 VMware ツールをインストールする仮想マシンを右クリックし、[Power] > [Power On] の順に選択します。

ステップ 4 [Console] タブをクリックして、ゲスト オペレーティング システムが正常に起動していることを確認し、必要な場合はログインします。

ステップ 5 VMware ツールをインストールする仮想マシンを右クリックし、[Guest] を選択し、次に [Install/Upgrade VMware Tools] を選択します。

[Install VMware Tools] 確認ダイアログ ボックスが表示されます。

ステップ 6 確認ダイアログ ボックス内の [Ok] をクリックします。

ステップ 7 仮想マシンにログインします。

ステップ 8 [Start] > [Open Windows Explorer] の順に選択します。

ステップ 9 [Computer] の下で、[VMware Tools] フォルダをクリックし、環境に応じて [VMware Tools] または [VMware Tools 64] を選択します。

VMware インストール ウィザードが起動します。

ステップ 10 このウィザード内の手順に従って、インストールを実行します。

ステップ 11 [Finish] をクリックします。

ステップ 12 システムを再起動するように指示するプロンプトが表示されたら、[Yes] を選択します。

ステップ 13 VMware ツールのインストール状態を確認するために、vSphere Client GUI の [Summary] タブをクリックします。「VM Tools - Status OK」と表示されていることを確認します。


 

詳細については、『 The VMware Tools Installation Guide For Operating System Specific Packages 』を参照してください。

関連項目

「vSphere Client のダウンロードとインストール」

vSwitch について

システムでは、VMware vSphere Hypervisor 内に次の vSwitch が作成されます。

vSwitch0:PCIe インターフェイスを使用して、VMware vSphere Hypervisor に接続します。PCIe インターフェイスは sm slot/0 です。

vSwitch0 には、Management Network 用の VMkernel ポート グループが含まれます。Management Network は、VMware vSphere Hypervisor に接続するために vSphere Client によって使用されます。


) Cisco IOS service-module コマンドを有効にするには、Management Network VMkernel ポート グループが、PCIe インターフェイスを備えた vSwitch をアップリンクとして使用するように設定されていることを確認します。デフォルトの VMkernel ポート グループ名(Management Network)を変更しないことを推奨します。


vSwitch1:デフォルトでは、vSwitch1 は Cisco SRE サービス モジュールの MGF インターフェイスに接続されます。MGF インターフェイスは sm slot/1 です。

vSwitch1 には、ゲスト仮想マシンが使用できる VM Network ポート グループが含まれます。

VMware vSphere Hypervisor の高度なカスタマイズ

「ネットワーク解析モジュールのサポート」

「システムの再設定後にしばらくしてからコンソールがリブートされる」

「VMware vSphere Hypervisor の IP アドレスを vSphere コンソール インターフェイスから変更できない」

「VMware vSphere Hypervisor の Management Network の IP アドレスの変更」

「Management Network リンクの変更」

「DCUI へのアクセスの変更」

「VMware vSphere Hypervisor がシャットダウン状態にならない」

「仮想マシンを VMware vSphere Hypervisor と同じサブネットに追加」

ネットワーク解析モジュールのサポート

デフォルトでは、Cisco SRE-V でネットワーク解析モジュール(NAM)機能がイネーブルになります。ISR G2 では、1 つの NAM 対応サービス モジュールだけがサポートされます。したがって、ISR G2 に複数の NAM が含まれる場合は、1 つの NAM をイネーブルにし、残りの NAM をディセーブルにしてください。

NAM をディセーブルにするには、tech-support から次のコマンドを使用します。

# esxcfg-advcfg --user-var CiscoRBCPNAMCapable --set-user-var 0
 

NAM をイネーブルにするには、tech-support から次のコマンドを使用します。

# esxcfg-advcfg --user-var CiscoRBCPNAMCapable --set-user-var 1
 

変更を反映するために Cisco SRE サービス モジュールをリブートします。

システムの再設定後にしばらくしてからコンソールがリブートされる

vSphere コンソール インターフェイスから [Reset System Configuration] オプションを選択した場合、コンソールは約 2 分後にリブートされます。これは想定されている動作です。

VMware vSphere Hypervisor の IP アドレスを vSphere コンソール インターフェイスから変更できない

vSphere コンソール インターフェイスを使用して VMware vSphere Hypervisor の IP アドレスを変更する場合、その IP アドレスの変更は一時的なものであり、 Cisco SRE サービス モジュール のリブート後に反映されません。 Cisco SRE サービス モジュールをリブートすると、 次の Cisco IOS コマンドを使用して設定した IP アドレスが有効であることを確認できます。

service-module ip address hypervisor-ip-address subnet-mask

VMware vSphere Hypervisor の IP アドレスを変更する場合は、「VMware vSphere Hypervisor の Management Network の IP アドレスの変更」を参照してください。

VMware vSphere Hypervisor の Management Network の IP アドレスの変更

VMware vSphere Hypervisor の IP アドレス を変更するには、 次の手順を実行します。

1. Cisco SRE サービス モジュールが装着されたスロットとポートのインターフェイス コンフィギュレーション モードを開始します。次に例を示します。

Router(config)# interface sm 1/0
Router(config-if)#
 

2. 次のコマンドを入力します。

Router(config-if)# service-module heartbeat-reset disable
Router(config-if)# no service-module ip default-gateway hypervisor-gateway-ip-address
Router(config-if)# no service-module ip address hypervisor-ip-address subnet-mask
 

3. vSphere コンソール インターフェイスを使用して VMware vSphere Hypervisor の IP アドレスを変更します。

Management Network リンクの変更

vSphere Client で、 [Home] > [Inventory] > [Configuration] > [Networking] の順に選択します 。[Virtual Network: vswitch0] の下で、Management Network が PCIe リンクである物理アダプタ vmnic1 に接続されていることを確認します。このリンクを、たとえば、vmnic1 から vmic0 に変更するには、次の手順を実行します。

1. Cisco SRE サービス モジュールが装着されたスロットとポートのインターフェイス コンフィギュレーション モードを開始します。次に例を示します。

Router(config)# interface sm 1/0
Router(config-if)#
 

2. 次のコマンドを入力します。

Router(config-if)# service-module heartbeat-reset disable
Router(config-if)# no service-module ip default-gateway hypervisor-gateway-ip-address
Router(config-if)# no service-module ip address hypervisor-ip-address subnet-mask

DCUI へのアクセスの変更

VMkernel.Boot.tty2Port の値は com1 です。この値は変更しないでください。

Cisco IOS は com1 シリアル ポートを使用してコンソール インターフェイスとのセッションを確立します。コンソール インターフェイスを使用して、VMware vSphere Hypervisor DCUI にアクセスし、Cisco SRE-V の設定を行うことができます。vSphere Client GUI の [Advanced Settings] で com1 ポート値を変更しようとする場合は、Cisco SRE サービス モジュールにアクセスできません。Cisco SRE サービス モジュールにアクセスするには、Cisco SRE-V を再インストールする必要があります。

VMware vSphere Hypervisor がシャットダウン状態にならない

ハートビート リセットをディセーブルにしない限り、VMware vSphere Hypervisor をシャットダウン状態にすることはできません。

ハートビート リセットをディセーブルにするには、次の手順を実行します。

1. Cisco SRE サービス モジュールが装着されたスロットとポートのインターフェイス コンフィギュレーション モードを開始します。次に例を示します。

Router(config)# interface sm 1/0
Router(config-if)#
 

2. service-module heartbeat-reset disable コマンドを入力して、ハートビート リセットをディセーブルにします。

Router(config-if)# service-module heartbeat-reset disable

仮想マシンを VMware vSphere Hypervisor と同じサブネットに追加

仮想マシンを VMware vSphere Hypervisor と同じサブネットに追加するには、次の手順を実行します。

手順の概要

ホスト ルータ CLI での手順(次のコマンドを入力)

1. enable

2. configure terminal

VLAN の設定

1. interface vlan vlan_number

2. ip address vlan-ip-address subnet mask

3. no shut

4. end

VMware vSphere Hypervisor の slot /0 の設定

1. interface sm slot /0

2. ip unnumbered vlan vlan_number

3. service-module ip address hypervisor-ip-address subnet-mask

4. service-module ip default-gateway hypervisor-gateway-ip-address

5. no shut

6. exit

7. ip route hypervisor-ip-address subnet-mask sm slot /0

VMware vSphere Hypervisor の slot/ 1 の設定

1. interface sm slot /1

2. switchport mode trunk

3. [switchport trunk allowed vlan vlan_numbers ]

4. exit

設定の保存

1. copy running-config startup-config

2. show running-config

手順の詳細

コマンドまたはアクション
目的
 
ホスト ルータ CLI での手順

ステップ 1

enable

<password>

 

Router> enable

Router> <password>

Router#

ホスト ルータ上で特権 EXEC モードを開始します。プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

ホスト ルータ上でグローバル コンフィギュレーション モードを開始します。

 
VLAN の設定

ステップ 1

interface vlan vlan_number

 

Router(config)# interface vlan1

指定した VLAN 番号の VLAN コンフィギュレーション モードを開始します。

ステップ 2

ip address vlan-ip-address subnet-mask

 

Router(config-if)# ip address 10.0.0.100 255.255.255.0

 

VLAN の IP アドレスを指定します。

vlan-ip-address :VLAN の IP アドレス。

subnet-mask :IP アドレスに付加するサブネット マスク。

ステップ 3

no shut

 

Router(config-if)# no shut

インターフェイスが管理上のアップ状態になります。

ステップ 4

end

 

Router(config)# end

ホスト ルータ上でグローバル コンフィギュレーション モードに戻ります。

 
VMware vSphere Hypervisor の slot/0 の設定

ステップ 1

interface sm slot /0

 

Router(config)# interface sm 1/0

Cisco SRE サービス モジュールが装着されたスロットとポートのインターフェイス コンフィギュレーション モードを開始します。

ステップ 2

ip unnumbered vlan vlan_number

 

Router(config-if)# ip unnumbered vlan1

 

ip unnumbered コマンドにより、指定された VLAN インターフェイスでの IP 処理がイネーブルになります(そのインターフェイスに明示的な IP アドレスを割り当てる必要はありません)。

vlan_number :IP アドレスが割り当てられたルータの VLAN インターフェイスの番号。

コマンドにより、デバイス間のポイントツーポイント インターフェイスが作成されます。ブロードキャストはサポートされません。

ステップ 3

service-module ip address hypervisor-ip-address subnet-mask

 

Router(config-if)# service-module ip address 10.0.0.1 255.255.255.0

 

VMware vSphere Hypervisor の IP アドレスを指定します。

hypervisor- ip-address :VMware vSphere Hypervisor の IP アドレス。図 3-2を参照してください。

subnet-mask :IP アドレスに付加するサブネット マスクであり、ホスト ルータと同じサブネットに属する必要があります。

ステップ 4

service-module ip default-gateway hypervisor-gateway-ip-address

 

Router(config-if)# service-module ip default-gateway 10.0.0.100

 

VMware vSphere Hypervisor のデフォルト ゲートウェイの IP アドレスを指定します。

hypervisor- gateway-ip-address :デフォルト ゲートウェイ ルータの IP アドレス。

ステップ 5

no shut

 

Router(config-if)# no shut

インターフェイスが管理上のアップ状態になります。

ステップ 6

exit

 

Router(config)# exit

ホスト ルータ上でグローバル コンフィギュレーション モードに戻ります。

ステップ 7

ip route hypervisor-ip-address subnet-mask sm slot /0

 

Router(config)# ip route 10.0.0.1 255.255.255.255 SM1/0

スタティック ルートを作成します。

ip unnumbered コマンドをステップ 2 で使用した場合は、 ip route hypervisor-ip-address subnet-mask sm slot/ 0 コマンドを使用してスタティック ルートを作成する必要があります。

hypervisor-ip-address subnet-mask :VMware vSphere Hypervisor の IP アドレスとサブネット マスク。

slot/0 :Cisco SRE サービス モジュールが装着されているスロットとポート。

 
VMware vSphere Hypervisor の slot/1 の設定

ステップ 1

interface sm slot /1

 

Router(config)# interface sm 1/1

Cisco SRE サービス モジュールが装着されたスロットとポートのインターフェイス コンフィギュレーション モードを開始します。

ステップ 2

switchport mode trunk

 

Router(config-if)# switchport mode trunk

ポートを永続的なトランキング モードにします。デフォルトの設定は、アクセス モードです。

ステップ 3

[switchport trunk allowed vlan vlan_numbers ]
 

Router(config-if)# switchport mode trunk

Router(config-if)# switchport trunk allowed vlan 1-2,40,60,1002-1005

(任意)指定した VLAN 上でのトランキングを許可します。

vlan_numbers :トランキングを許可する VLAN 番号。

ステップ 4

exit

 

Router(config)# exit

ホスト ルータ上でグローバル コンフィギュレーション モードに戻ります。

 
設定の保存

ステップ 1

copy running-config startup-config

 

Router# copy running-config startup-config

ルータの新しい実行コンフィギュレーションをスタートアップ コンフィギュレーションとして保存します。

ステップ 2

show running-config

 

Router# show running-config

アドレス設定を確認できるように、ルータの実行コンフィギュレーションを表示します。