Cisco Services Ready Engine Virtualization インストレーション/コンフィギュレーション ガイド ソフトウェア リリース 2.0
Cisco SRE サービス モジュール インターフェイスの設定
Cisco SRE サービス モジュール インターフェイスの設定
発行日;2012/06/01 | 英語版ドキュメント(2011/12/15 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 3MB) | フィードバック

目次

Cisco SRE サービス モジュール インターフェイスの設定

Cisco SRE サービス モジュール インターフェイスの概要

Cisco SRE サービス モジュール インターフェイスを設定するための前提条件

Cisco ルータの前提条件

Cisco SRE サービス モジュールの前提条件

ルータ上での Cisco SRE サービス モジュール インターフェイスの設定

MGF レイヤ 2 スイッチド設定:推奨

Cisco IOS レイヤ 3 ルーテッド設定オプション

Cisco IOS レイヤ 3 ルーテッド設定:異なるブランチ サブネット内のデバイス

Cisco IOS レイヤ 3 ルーテッド設定:同じブランチ サブネット内のデバイス

外部インターフェイス設定

Cisco SRE サービス モジュールのリロード、リセット、およびシャットダウン

CLI コマンドを使用したサービス モジュールのリロード、リセット、またはシャットダウン

ハードウェアを使用した Cisco SRE サービス モジュールのシャットダウン

Cisco SRE サービス モジュール インターフェイスの設定

ここでは、Cisco SRE-V システム ソフトウェアを実行するように Cisco SRE サービス モジュール インターフェイスを設定する方法に関する情報を提供します。

「Cisco SRE サービス モジュール インターフェイスの概要」

「Cisco SRE サービス モジュール インターフェイスを設定するための前提条件」

「ルータ上での Cisco SRE サービス モジュール インターフェイスの設定」

「Cisco SRE サービス モジュールのリロード、リセット、およびシャットダウン」

Cisco SRE サービス モジュール インターフェイスの概要

ホスト ルータおよび Cisco SRE サービス モジュールでは、内部通信と外部通信のために複数のインターフェイスが使用されます。ルータ上で各インターフェイスを設定するために、Cisco IOS CLI コマンドを使用します。

Cisco SRE サービス モジュールは、次の 3 つのインターフェイスを介してホスト ルータと通信します。

MGF インターフェイス

コンソール インターフェイス

外部サービス モジュール インターフェイス

インターフェイスの詳細については、 表 3-1 を参照してください。

 

表 3-1 Cisco SRE サービス モジュール インターフェイス

インターフェイス
目的
アクセス元
その他の情報

MGF インターフェイス

Cisco SRE サービス モジュールが高速バックプレーン スイッチ経由で通信できるようにします。

ホスト ルータ内。

ルータと Cisco SRE サービス モジュールとの間に内部レイヤ 2 ギガビット イーサネット リンクを提供します。

Cisco IOS CLI を使用して MGF インターフェイスを設定します。

MGF の設定の詳細については、『 Cisco 3900 Series, 2900 Series, and 1900 Series Integrated Services Routers Software Configuration Guide 』の「 Multi-Gigabit Fabric on the Router 」の章を参照してください。

コンソール インターフェイス

Cisco SRE-V 設定を実行するために、VMware vSphere Hypervisor Direct Console User Interface(DCUI)へのアクセスを提供します。

ホスト ルータ内。

ルータと Cisco SRE サービス モジュールとの間に内部レイヤ 3 ギガビット イーサネット リンクを提供します。

Cisco IOS CLI を使用して、コンソール インターフェイスの設定と管理を行います。

外部サービス モジュール インターフェイス

VMware vSphere Hypervisor または仮想マシンにより、プライマリ インターフェイスまたはバックアップ インターフェイスとして使用されます。

制御と管理は主に VMware vSphere Hypervisor によって行われます。

VMware vSphere Hypervisor が、MGF インターフェイスまたはコンソール インターフェイスを介してトラフィックをルータに転送するように設定されていない限り、トラフィックはルータに到達しません。

Cisco SRE サービス モジュール インターフェイスを設定するための前提条件

「Cisco ルータの前提条件」

「Cisco SRE サービス モジュールの前提条件」

Cisco ルータの前提条件

Cisco ルータで適切な Cisco IOS ソフトウェア バージョンが実行され、Cisco SRE サービス モジュールが認識されることを確認します。

「ルータ、Cisco SRE サービス モジュール、および Cisco IOS ソフトウェア バージョンの互換性の確認」および「Cisco SRE サービス モジュールの取り付けの確認」を参照してください。

Cisco SRE サービス モジュールの前提条件


) ほとんどの場合、ルータは、内部に Cisco SRE サービス モジュールがすでに取り付けられた状態で出荷されます。


インターフェイスを設定する前に、Cisco SRE サービス モジュール コマンド環境を開始するための次の情報があることを確認します。

Cisco SRE サービス モジュールを装着する Cisco ルータの IP アドレス。

ルータにログインするためのユーザ名とパスワード。

ホスト ルータ内での Cisco SRE サービス モジュールのスロットとポートの位置:

slot: Cisco SRE サービス モジュールが装着されているホスト ルータ シャーシ スロットの ID。サービス モジュールの取り付け後、Cisco IOS ソフトウェア CLI の show running-config コマンドを使用することにより、この情報を取得できます。

port :Cisco SRE サービス モジュール上のネットワーク インターフェイス カード(NIC)の ID。コンソール インターフェイスの値は 0、MGF インターフェイスの値は 1 です。

ルータ上での Cisco SRE サービス モジュール インターフェイスの設定

Cisco SRE サービス モジュールとホスト ルータとの間の内部インターフェイスを設定します。この初期設定が完了すれば、サービス モジュールにアクセスして、Cisco SRE-V アプリケーションのインストールおよび設定ができるようになります。

Cisco SRE-V では、次の設定オプションが提供されます。

MGF レイヤ 2 スイッチド設定:この設定オプションでは、トラフィックがルータではなく EtherSwitch を通過するため、パフォーマンスが向上し、ルータ CPU には影響を与えません。ブロードキャストなど、すべてのレイヤ 2 機能がサポートされます。この設定オプションを使用するには、EtherSwitch EHWIC または EtherSwitch サービス モジュールを購入する必要があります。「MGF レイヤ 2 スイッチド設定:推奨」を参照してください。

Cisco IOS レイヤ 3 ルーテッド設定:次のいずれかのオプションを選択します。

異なるサブネット内のデバイスを使用した Cisco IOS レイヤ 3 ルーテッド設定:VMware vSphere Hypervisor と仮想サーバを 1 つのブランチ サブネットに追加し、クライアント PC を別のブランチ サブネットに追加する場合は、この設定オプションを選択します。この設定オプションでは、機器の追加は不要ですが、ルータ CPU に影響を与えます。「Cisco IOS レイヤ 3 ルーテッド設定:異なるブランチ サブネット内のデバイス」を参照してください。

同じサブネット内のデバイスを使用した Cisco IOS レイヤ 3 ルーテッド設定:VMware vSphere Hypervisor と仮想サーバをクライアント PC と同じブランチ サブネットに追加する場合は、この設定オプションを選択します。この設定オプションでは、機器の追加は不要ですが、ルータ CPU に影響を与えます。このオプションは複雑であり、一部のレイヤ 2 機能(ブロードキャストなど)はサポートされません。「Cisco IOS レイヤ 3 ルーテッド設定:同じブランチ サブネット内のデバイス」を参照してください。

外部インターフェイス設定:この設定オプションは、設定しやすく、低コストであり、ルータ CPU にも影響を与えません。しかし、外部スイッチ上での追加のケーブル配線と追加のギガビット イーサネット スイッチポートを必要とします。さらに、VMware vSphere Hypervisor ネットワーク上で Cisco IOS の機能を使用できません(たとえば、仮想マシンを DMZ 内に配置できません)。また、内部インターフェイスで使用可能なハードウェア TCP/IP/UDP/iSCSI オフ ロード機能を利用できません。「外部インターフェイス設定」を参照してください。


) Cisco IOS service-module コマンドを有効にするには、Management Network VMkernel ポート グループが、PCIe インターフェイスを備えた vSwitch をアップリンクとして使用するように設定されていることを確認します。デフォルトの VMkernel ポート グループ名(Management Network)を変更しないことを推奨します。


MGF レイヤ 2 スイッチド設定:推奨

図 3-1 に、MGF レイヤ 2 スイッチド設定でのトラフィック フローを示します。MGF バックプレーン スイッチにより、複数のハイパーバイザ間にわたって仮想ネットワークが接続され、ルータ CPU 経由でトラフィックを送信しなくても、Cisco EtherSwitch EHWIC または EtherSwitch サービス モジュール経由で LAN に直接アクセスできるようになります。サポートされる Cisco EtherSwitch EHWIC および EtherSwitch サービス モジュールについては、 表 1-2 を参照してください。

図 3-1 MGF レイヤ 2 スイッチド設定でのトラフィック フロー

図 3-2 に、IP アドレスの位置を示します。

ISR G2 経由で VMware vSphere Hypervisor にアクセスするには、2 つの IP アドレスが必要です。1 つは、ルータを VMware vSphere Hypervisor に接続するインターフェイスの IP アドレスで、もう 1 つは VMware vSphere Hypervisor の IP アドレスです。

仮想マシンには MGF インターフェイス経由でアクセスします。VMware vSphere Hypervisor の vSwitch 上のポート グループは、Cisco IOS の対応する VLAN インターフェイスに割り当てることができます。たとえば、VMware vSphere Hypervisor のポート グループ 50 は Cisco IOS の VLAN 50 に割り当てることができます。

図 3-2 IP アドレスの位置

手順の概要

ホスト ルータ CLI での手順(次のコマンドを入力)

1. enable

2. configure terminal

VMware vSphere Hypervisor の slot /0 の設定

1. interface sm slot /0

2. ip address router-to-hypervisor-interface-IP-address subnet-mask
または
[ip unnumbered type number ]

3. service-module ip address hypervisor-ip-address subnet-mask

4. service-module ip default-gateway hypervisor-gateway-ip-address

5. no shut

6. exit

7. [ip route hypervisor-ip-address subnet-mask sm slot /0]

VMware vSphere Hypervisor の slot/ 1 の設定

1. interface sm slot /1

2. switchport mode trunk

3. [switchport trunk allowed vlan vlan_numbers ]

4. exit

VLAN の設定

1. configure terminal

2. interface vlan vlan_number

3. ip address vlan-ip-address subnet mask

4. no shut

5. end

設定の保存

1. copy running-config startup-config

2. show running-config

手順の詳細

 
コマンドまたはアクション
目的
 
ホスト ルータ CLI での手順

ステップ 1

enable

<password>

 

Router> enable

Router> <password>

Router#

ホスト ルータ上で特権 EXEC モードを開始します。プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

ホスト ルータ上でグローバル コンフィギュレーション モードを開始します。

 
VMware vSphere Hypervisor の slot/0 の設定

ステップ 1

interface sm slot /0

 

Router(config)# interface sm 1/0

Cisco SRE サービス モジュールが装着されたスロットとポート用のインターフェイス コンフィギュレーション モードを開始します。

ステップ 2

ip address router-to-hypervisor-interface-IP-address subnet-mask

 

または

[ip unnumbered type number ]

 

Router(config-if)# ip address 10.0.0.100 255.255.255.0

 

または

Router(config-if)# ip unnumbered gigabitethernet 1/0

 

ルータを VMware vSphere Hypervisor に接続するインターフェイスの IP アドレスを指定します。図 3-2 を参照してください。

router-to-hypervisor-interface-IP-address: ルータを VMware vSphere Hypervisor に接続するインターフェイスの IP アドレス。

subnet-mask :IP アドレスに付加するサブネット マスク。

または

(任意) ip unnumbered コマンドは、インターフェイスに明示的な IP アドレスを割り当てずに、そのインターフェイス上での IP 処理をイネーブルにします。

type :割り当てられた IP アドレスをルータが保持しているインターフェイスのタイプ。

number :割り当てられた IP アドレスをルータが保持しているインターフェイスの番号。

(注) アンナンバード インターフェイスは、一意である必要があります。別のアンナンバード インターフェイスは指定できません。


注意 ip unnumbered コマンドでは、デバイス間のポイントツーポイント インターフェイスが作成されます。ブロードキャストはサポートされません。

ステップ 7 を参照してください。

ステップ 3

service-module ip address hypervisor-ip-address subnet-mask

 

Router(config-if)# service-module ip address 10.0.0.1 255.255.255.0

 

VMware vSphere Hypervisor の IP アドレスを指定します。

hypervisor- ip-address :VMware vSphere Hypervisor の IP アドレス。図 3-2 を参照してください。

subnet-mask :IP アドレスに付加するサブネット マスクで、ホスト ルータと同じサブネット内にある必要があります。

ステップ 4

service-module ip default-gateway hypervisor-gateway-ip-address

 

Router(config-if)# service-module ip default-gateway 10.0.0.100

 

VMware vSphere Hypervisor のデフォルト ゲートウェイの IP アドレスを指定します。

hypervisor- gateway-ip-address :デフォルト ゲートウェイ ルータの IP アドレス。

ステップ 5

no shut

 

Router(config-if)# no shut

インターフェイスが管理上のアップ状態になります。

ステップ 6

exit

 

Router(config)# exit

ホスト ルータ上でグローバル コンフィギュレーション モードに戻ります。

ステップ 7

[ip route hypervisor-ip-address subnet-mask sm slot /0]

 

Router(config)# ip route 10.0.0.1 255.255.255.255 SM1/0

スタティック ルートを作成します。

ip unnumbered コマンドをステップ 2 で使用した場合は、 ip route hypervisor-ip-address subnet-mask sm slot/ 0 コマンドを使用してスタティック ルートを作成する必要があります

hypervisor-ip-address subnet-mask: VMware vSphere Hypervisor の IP アドレスとサブネット マスク。

slot/0: Cisco SRE サービス モジュールが装着されているスロットとポート。

 
VMware vSphere Hypervisor の slot/1 の設定

ステップ 1

interface sm slot /1

 

Router(config)# interface sm 1/1

Cisco SRE サービス モジュールが装着されたスロットとポート用のインターフェイス コンフィギュレーション モードを開始します。

ステップ 2

switchport mode trunk

 

Router(config-if)# switchport mode trunk

ポートを永続的なトランキング モードにします。デフォルトの設定は、アクセス モードです。

ステップ 3

[switchport trunk allowed vlan vlan_numbers ]

 

Router(config-if)# switchport mode trunk

Router(config-if)# switchport trunk allowed vlan 1-2,40,60,1002-1005

(任意)指定した VLAN 上でのトランキングを許可します。

vlan_numbers :トランキングを許可する VLAN 番号。

ステップ 4

exit

 

Router(config)# exit

ホスト ルータ上でグローバル コンフィギュレーション モードに戻ります。

 
VLAN の設定

ステップ 1

configure terminal

 

Router# configure terminal

ホスト ルータ上でグローバル コンフィギュレーション モードを開始します。

ステップ 2

interface vlan vlan_number

 

Router(config)# interface vlan 40

指定した VLAN 番号の VLAN コンフィギュレーション モードを開始します。

ステップ 3

ip address vlan-ip-address subnet-mask

 

Router(config-if)# ip address 40.0.0.100 255.255.255.0

 

VLAN の IP アドレスを指定します。

vlan-ip-address :VLAN の IP アドレス。

subnet-mask :IP アドレスに付加するサブネット マスク。

ステップ 4

no shut

 

Router(config-if)# no shut

インターフェイスが管理上のアップ状態になります。

ステップ 5

end

 

Router(config)# end

ホスト ルータ上でグローバル コンフィギュレーション モードに戻ります。

 
設定の保存

ステップ 1

copy running-config startup-config

 

Router# copy running-config startup-config

ルータの新しい実行コンフィギュレーションをスタートアップ コンフィギュレーションとして保存します。

ステップ 2

show running-config

 

Router# show running-config

アドレス設定を確認できるように、ルータの実行コンフィギュレーションを表示します。

図 3-3 に、MGF レイヤ 2 スイッチド設定の例を示します。

左側のペインは、sm 1/0、sm 1/1、および VLAN の各インターフェイスでの Cisco IOS コマンドの設定例を示しています。

右側のペインは、この設定が VMware vSphere Hypervisor に適用されていることを示しています。右側のペインの一番下の領域は、標準的な Microsoft Windows ネットワーク構成設定プロセスを使用して設定されている Microsoft Windows Server の設定を示しています。これらの Microsoft Windows Server は、仮想マシンとして稼動します。


) この設定例の IP アドレスは参照用に示しただけなので、実際には有効でない可能性があります。


図 3-3 MGF レイヤ 2 スイッチド設定の設定例

関連項目

「Cisco SRE-V ソフトウェアのダウンロード」

Cisco IOS レイヤ 3 ルーテッド設定オプション

図 3-4 に、Cisco IOS レイヤ 3 ルーテッド設定でのトラフィック フローを示します。MGF バックプレーン スイッチにより、トラフィックがルータ CPU に転送されます。

図 3-4 Cisco IOS レイヤ 3 ルーテッド設定でのトラフィック フロー

VMware vSphere Hypervisor と仮想サーバを 1 つのブランチ サブネットに追加し、クライアント PC を別のブランチ サブネットに追加するか、すべてのデバイスを同じブランチ サブネットに追加することができます。デバイスを追加するブランチ サブネットの選択によって、使用する必要のあるコンフィギュレーション コマンドは異なります。Cisco IOS レイヤ 3 ルーテッド設定オプションについては、次の項を参照してください。

「Cisco IOS レイヤ 3 ルーテッド設定:異なるブランチ サブネット内のデバイス」

「Cisco IOS レイヤ 3 ルーテッド設定:同じブランチ サブネット内のデバイス」

Cisco IOS レイヤ 3 ルーテッド設定:異なるブランチ サブネット内のデバイス

VMware vSphere Hypervisor と仮想サーバを 1 つのブランチ サブネットに追加し、クライアント PC を別のブランチ サブネットに追加する場合は、この設定オプションを使用します。

VMware vSphere Hypervisor と仮想サーバにサブネットを割り当てると、そのサブネットは、直接接続されたルートとしてルーティング テーブルに自動的に追加されます。クライアント PC がルータから到達可能なサブネットにある限り、ルーティング設定の追加は必要ありません。通常、クライアント PC はオンボードのイーサネット インターフェイスのサブネットにあり、これも直接接続されたルートとしてルーティング テーブルに自動的に追加されます。したがって、ルータは、VMware vSphere Hypervisor および仮想サーバのサブネットと、クライアント PC のサブネットの間で、スタティック ルートやルーティング プロトコルの設定なしにトラフィックを送信します。

手順の概要

ホスト ルータ CLI での手順(次のコマンドを入力)

1. enable

2. configure terminal

VMware vSphere Hypervisor の slot /0 の設定

1. interface sm slot /0

2. ip address router-to-hypervisor-interface-IP-address subnet-mask

3. service-module ip address hypervisor-ip-address subnet-mask

4. service-module ip default-gateway hypervisor-gateway-ip-address

5. no shut

6. exit

VMware vSphere Hypervisor の slot /1 の設定

1. interface sm slot /1

2. switchport mode trunk

3. [switchport trunk allowed vlan vlan_numbers ]

4. exit

VLAN の設定

1. configure terminal

2. interface vlan vlan_number

3. ip address vlan-ip-address subnet mask

4. no shut

5. exit

ギガビット イーサネット slot/port の設定

1. interface gigabitethernet slot /port sub-interface

2. ip address branch-VLAN-ip-address subnet-mask

3. encapsulation dot1q vlan-id

4. exit

設定の保存

1. copy running-config startup-config

2. show running-config

手順の詳細

 
コマンドまたはアクション
目的
 
ホスト ルータ CLI での手順

ステップ 1

enable

<password>

 

Router> enable

Router> <password>

Router#

ホスト ルータ上で特権 EXEC モードを開始します。プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

ホスト ルータ上でグローバル コンフィギュレーション モードを開始します。

 
VMware vSphere Hypervisor の slot/0 の設定

ステップ 1

interface sm slot /0

 

Router(config)# interface sm 1/0

Cisco SRE サービス モジュールが装着されたスロットとポート用のインターフェイス コンフィギュレーション モードを開始します。

ステップ 2

ip address router-to-hypervisor-interface-IP-address subnet-mask

 

Router(config-if)# ip address 10.0.0.100 255.255.255.0

ルータを VMware vSphere Hypervisor に接続するインターフェイスの IP アドレスを指定します。図 3-2 を参照してください。

router-to-hypervisor-interface-IP-address: ルータを VMware vSphere Hypervisor に接続するインターフェイスの IP アドレス。

subnet-mask :IP アドレスに付加するサブネット マスク。

ステップ 3

service-module ip address hypervisor-ip-address subnet-mask

 

Router(config-if)# service-module ip address 10.0.0.1 255.255.255.0

 

VMware vSphere Hypervisor の IP アドレスを指定します。

hypervisor- ip-address :VMware vSphere Hypervisor の IP アドレス。図 3-2 を参照してください。

subnet-mask :IP アドレスに付加するサブネット マスクで、ホスト ルータと同じサブネット内にある必要があります。

ステップ 4

service-module ip default-gateway hypervisor-gateway-ip-address

 

Router(config-if)# service-module ip default-gateway 10.0.0.100

 

VMware vSphere Hypervisor のデフォルト ゲートウェイの IP アドレスを指定します。

hypervisor- gateway-ip-address :デフォルト ゲートウェイ ルータの IP アドレス。

ステップ 5

no shut

 

Router(config-if)# no shut

インターフェイスが管理上のアップ状態になります。

ステップ 6

exit

 

Router(config)# exit

ホスト ルータ上でグローバル コンフィギュレーション モードに戻ります。

 
VMware vSphere Hypervisor の slot/1 の設定

ステップ 1

interface sm slot /1

 

Router(config)# interface sm 1/1

Cisco SRE サービス モジュールが装着されたスロットとポート用のインターフェイス コンフィギュレーション モードを開始します。

ステップ 2

switchport mode trunk

 

Router(config-if)# switchport mode trunk

ポートを永続的なトランキング モードにします。

デフォルトの設定は、アクセス モードです。アクセス モードは、ネイティブ VLAN で動作します。Cisco SRE サービス モジュールでは、VLAN 1 がこれに該当します。

ステップ 3

[switchport trunk allowed vlan vlan_numbers ]

 

Router(config-if)# switchport mode trunk

Router(config-if)# switchport trunk allowed vlan 1-2,40,60,1002-1005

(任意)指定した VLAN 上でのトランキングを許可します。

vlan_numbers :トランキングを許可する VLAN 番号。

ステップ 4

exit

 

Router(config)# exit

ホスト ルータ上でグローバル コンフィギュレーション モードに戻ります。

 
VLAN の設定

ステップ 1

configure terminal

 

Router# configure terminal

ホスト ルータ上でグローバル コンフィギュレーション モードを開始します。

ステップ 2

interface vlan vlan_number

 

Router(config)# interface vlan 40

指定した VLAN 番号の VLAN コンフィギュレーション モードを開始します。

ステップ 3

ip address vlan-ip-address subnet-mask

 

Router(config-if)# ip address 40.0.0.100 255.255.255.0

 

VLAN の IP アドレスを指定します。

vlan-ip-address :VLAN の IP アドレス。

subnet-mask :IP アドレスに付加するサブネット マスク。

ステップ 4

no shut

 

Router(config-if)# no shut

インターフェイスが管理上のアップ状態になります。

ステップ 5

exit

 

Router(config)# exit

ホスト ルータ上でグローバル コンフィギュレーション モードに戻ります。

 
ギガビット イーサネット slot/port の設定

ステップ 1

interface gigabitethernet slot/port sub-interface

 

Router(config)# interface gigabitethernet 0/1.120

指定したサブインターフェイス用のギガビット イーサネット コンフィギュレーション モードを開始します。

slot/port :ルータ シャーシ内でのギガビット イーサネット インターフェイスの位置。

sub-interface :割り当てられた IP アドレスをルータが保持しているギガビット イーサネット インターフェイスの番号。

ステップ 2

ip address branch-VLAN-ip-address subnet-mask

 

Router(config-if)# ip address 80.80.120.1 255.255.255.0

 

特定のブランチ VLAN の IP アドレスを設定します。

branch-VLAN-ip-address :特定のブランチ VLAN の IP アドレス。

subnet-mask :IP アドレスに付加するサブネット マスク。

ステップ 3

encapsulation dot1q vlan-id

 

Router(config-if)# encapsulation dot1q 120

VLAN 内の指定したサブインターフェイス上で、トラフィックの IEEE 802.1Q カプセル化をイネーブルにします。

vlan-id :仮想 LAN 識別子。指定できる範囲は 1 ~ 1000 です。

ステップ 4

exit

インターフェイス モードを終了します。

 
設定の保存

ステップ 1

copy running-config startup-config

 

Router# copy running-config startup-config

ルータの新しい実行コンフィギュレーションをスタートアップ コンフィギュレーションとして保存します。

ステップ 2

show running-config

 

Router# show running-config

アドレス設定を確認できるように、ルータの実行コンフィギュレーションを表示します。

に、VMware vSphere Hypervisor と仮想サーバが 1 つのブランチ サブネットにあり、クライアント PC が別のブランチ サブネットにある場合の Cisco IOS レイヤ 3 ルーテッド設定の例を示します。

左側のペインは、sm 1/0、sm 1/1、および VLAN の各インターフェイスでの Cisco IOS コマンドの設定例を示しています。

右側のペインは、この設定が VMware vSphere Hypervisor に適用されていることを示しています。右側のペインの一番下の領域は、標準的な Microsoft Windows ネットワーク構成設定プロセスを使用して設定されている Microsoft Windows Server の設定を示しています。これらの Microsoft Windows Server は、仮想マシンとして稼動します。


) この設定例の IP アドレスは参照用に示しただけなので、実際には有効でない可能性があります。


Cisco IOS レイヤ 3 ルーテッド設定:異なるサブネット内のデバイス

関連項目

「Cisco SRE-V ソフトウェアのダウンロード」

Cisco IOS レイヤ 3 ルーテッド設定:同じブランチ サブネット内のデバイス

VMware vSphere Hypervisor と仮想サーバをクライアント PC と同じブランチ サブネットに追加する場合は、この設定オプションを使用します。

ip unnumbered インターフェイス設定を使用して、VMware vSphere Hypervisor と仮想サーバをクライアント PC と同じサブネットに配置します。 ip unnumbered インターフェイス設定により、Cisco IOS では同じサブネットで 2 つのインターフェイスが作成されるので、VMware vSphere Hypervisor と仮想サーバ用のスタティック ルートも設定する必要があります。

手順の概要

ホスト ルータ CLI での手順(次のコマンドを入力)

1. enable

2. configure terminal

VMware vSphere Hypervisor の slot /0 の設定

1. interface sm slot /0

2. ip unnumbered gigabitethernet slot/port sub-interface

3. service-module ip address hypervisor-ip-address subnet-mask

4. service-module ip default-gateway hypervisor-gateway-ip-address

5. exit

VMware vSphere Hypervisor の slot /1 の設定

1. interface sm slot /1

2. switchport mode trunk

3. [switchport trunk allowed vlan vlan_numbers ]

4. exit

VLAN の設定

1. configure terminal

2. interface vlan vlan_ number

3. ip unnumbered gigabitethernet slot/port sub-interface

4. exit

GE slot/port の設定

1. interface gigabitethernet slot /port sub-interface

2. ip address branch-VLAN-ip-address subnet-mask

3. encapsulation dot1q vlan-id

4. exit

5. ip route virtual-machine-ip-address subnet-mask vlan vlan_number

6. ip route hypervisor-ip-address subnet-mask sm slot /0

7. exit

設定の保存

1. copy running-config startup-config

2. show running-config

手順の詳細

 
コマンドまたはアクション
目的
 
ホスト ルータ CLI での手順

ステップ 1

enable

<password>

 

Router> enable

Router> <password>

Router#

ホスト ルータ上で特権 EXEC モードを開始します。プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

ホスト ルータ上でグローバル コンフィギュレーション モードを開始します。

 
VMware vSphere Hypervisor の slot/0 の設定

ステップ 1

interface sm slot /0

 

Router(config)# interface sm 1/0

Cisco SRE サービス モジュールが装着されたスロットとポート用のインターフェイス コンフィギュレーション モードを開始します。

ステップ 2

ip unnumbered gigabitethernet slot/port sub-interface

 

Router(config-if)# ip unnumbered gigabitethernet 0/0.1

インターフェイスに明示的な IP アドレスを割り当てずに、そのインターフェイス上での IP 処理をイネーブルにします。トラフィックはギガビット イーサネット サブインターフェイスに対して双方向に転送されます。

slot/port :ルータ シャーシ内でのギガビット イーサネット インターフェイスの位置。

sub-interface :割り当てられた IP アドレスをルータが保持しているギガビット イーサネット サブインターフェイスの番号。

(注) アンナンバード インターフェイスは、一意である必要があります。別のアンナンバード インターフェイスは指定できません。


注意 ip unnumbered コマンドでは、デバイス間のポイントツーポイント インターフェイスが作成されます。ブロードキャストはサポートされません。

ステップ 3

service-module ip address hypervisor-ip-address subnet-mask

 

Router(config-if)# service-module ip address 10.0.0.1 255.255.255.0

VMware vSphere Hypervisor の IP アドレスを指定します。

hypervisor- ip-address :VMware vSphere Hypervisor の IP アドレス。図 3-2 を参照してください。

subnet-mask :IP アドレスに付加するサブネット マスクで、ホスト ルータと同じサブネット内にある必要があります。

ステップ 4

service-module ip default-gateway hypervisor-gateway-ip-address

 

Router(config-if)# service-module ip default-gateway 10.0.0.100

VMware vSphere Hypervisor のデフォルト ゲートウェイの IP アドレスを指定します。

hypervisor- gateway-ip-address :デフォルト ゲートウェイ ルータの IP アドレス。

ステップ 5

exit

インターフェイス モードを終了します。

 
VMware vSphere Hypervisor の slot/1 の設定

ステップ 1

interface sm slot /1

 

Router(config)# interface sm 1/1

Cisco SRE サービス モジュールが装着されたスロットとポート用のインターフェイス コンフィギュレーション モードを開始します。

ステップ 2

switchport mode trunk

 

Router(config-if)# switchport mode trunk

ポートを永続的なトランキング モードにします。

デフォルトの設定は、アクセス モードです。アクセス モードは、ネイティブ VLAN で動作します。Cisco SRE サービス モジュールでは、VLAN 1 がこれに該当します。

ステップ 3

[switchport trunk allowed vlan vlan_numbers ]

 

Router(config-if)# switchport mode trunk

Router(config-if)# switchport trunk allowed vlan 1-2,40,60,1002-1005

(任意)指定した VLAN 上でのトランキングを許可します。

vlan_numbers :トランキングを許可する VLAN 番号。

ステップ 4

exit

 

Router(config)# exit

ホスト ルータ上でグローバル コンフィギュレーション モードに戻ります。

 
VLAN の設定

ステップ 1

configure terminal

 

Router# configure terminal

ホスト ルータ上でグローバル コンフィギュレーション モードを開始します。

ステップ 2

interface vlan vlan_number

 

Router(config)# interface vlan 40

指定した VLAN 番号の VLAN コンフィギュレーション モードを開始します。

ステップ 3

ip unnumbered gigabitethernet slot/port sub-interface

 

Router(config-if)# ip unnumbered gigabitethernet 0/0.40

インターフェイスに明示的な IP アドレスを割り当てずに、そのインターフェイス上での IP 処理をイネーブルにします。トラフィックはギガビット イーサネット サブインターフェイスに対して双方向に転送されます。

slot/port :ルータ シャーシ内でのギガビット イーサネット インターフェイスの位置。

sub-interface :割り当てられた IP アドレスをルータが保持しているギガビット イーサネット サブインターフェイスの番号。

(注) アンナンバード インターフェイスは、一意である必要があります。別のアンナンバード インターフェイスは指定できません。


注意 ip unnumbered コマンドでは、デバイス間のポイントツーポイント インターフェイスが作成されます。ブロードキャストはサポートされません。

ステップ 4

exit

インターフェイス モードを終了します。

 
ギガビット イーサネット slot/port の設定

ステップ 1

interface gigabitethernet slot/port sub-interface

 

Router(config)# interface gigabitethernet 0/0.40

指定したサブインターフェイス用のギガビット イーサネット コンフィギュレーション モードを開始します。

slot/port :ルータ シャーシ内でのギガビット イーサネット インターフェイスの位置。

sub-interface :割り当てられた IP アドレスをルータが保持しているギガビット イーサネット インターフェイスの番号。

ステップ 2

ip address branch-VLAN-ip-address subnet-mask

 

Router(config-if)# ip address 40.0.0.100 255.255.255.0

特定のブランチ VLAN の IP アドレスを設定します。

branch-VLAN-ip-address subnet-mask :特定のブランチ VLAN の IP アドレス。この IP アドレスは、ステップ 5 で定義される VLAN 内の仮想マシンのデフォルト ゲートウェイとして使用できます。

ステップ 3

encapsulation dot1q vlan-id

 

Router(config-if)# encapsulation dot1q 40

VLAN 内の指定したサブインターフェイス上で、トラフィックの IEEE 802.1Q カプセル化をイネーブルにします。

vlan-id :仮想 LAN 識別子。指定できる範囲は 1 ~ 1000 です。

ステップ 4

exit

インターフェイス モードを終了します。

ステップ 5

ip route virtual-machine-ip-address subnet-mask vlan vlan_number

 

Router(config)# ip route 40.0.0.2 255.255.255.0 vlan 40

仮想マシン用のスタティック ルート エントリを作成します。

virtual-machine-ip-address subnet-mask:仮想マシンの IP アドレスとサブネット マスク。

ステップ 6

ip route hypervisor-ip-address subnet-mask sm slot /0

 

Router(config)# ip route 10.0.0.1 255.255.255.255 SM1/0

スタティック ルートを作成します。

hypervisor-ip-address subnet-mask: VMware vSphere Hypervisor の IP アドレスとサブネット マスク。

slot/0: Cisco SRE サービス モジュールが装着されているスロットとポート。

ステップ 7

exit

インターフェイス モードを終了します。

 
設定の保存

ステップ 1

copy running-config startup-config

 

Router# copy running-config startup-config

ルータの新しい実行コンフィギュレーションをスタートアップ コンフィギュレーションとして保存します。

ステップ 2

show running-config

 

Router# show running-config

アドレス設定を確認できるように、ルータの実行コンフィギュレーションを表示します。

図 3-5 に、VMware vSphere Hypervisor と仮想サーバがクライアント PC と同じブランチ サブネットにある場合の Cisco IOS レイヤ 3 ルーテッド設定の例を示します。

左側のペインは、sm 1/0、sm 1/1、VLAN、およびギガビット イーサネットの各インターフェイスでの Cisco IOS コマンドの設定例を示しています。

右側のペインは、この設定が VMware vSphere Hypervisor に適用されていることを示しています。右側のペインの一番下の領域は、標準的な Microsoft Windows ネットワーク構成設定プロセスを使用して設定されている Microsoft Windows Server の設定を示しています。これらの Microsoft Windows Server は、仮想マシンとして稼動します。


) この設定例の IP アドレスは参照用に示しただけなので、実際には有効でない可能性があります。


図 3-5 Cisco IOS レイヤ 3 ルーテッド設定:同じサブネット内のデバイス

関連項目

「Cisco SRE-V ソフトウェアのダウンロード」

外部インターフェイス設定

この設定で使用される Cisco IOS コマンドは、次の点を除いて、「MGF レイヤ 2 スイッチド設定:推奨」または「Cisco IOS レイヤ 3 ルーテッド設定オプション」で使用されるコマンドと同じです。

仮想マシンの IP アドレスは、外部インターフェイスに接続されるネットワーク上のものになります。

仮想マシンのデフォルト ゲートウェイは、外部インターフェイスを指します。

(Cisco IOS レイヤ 3 ルーテッド設定では設定される)仮想マシン用のスタティック ルート エントリは必要ありません。

図 3-6 に、外部インターフェイス設定でのトラフィック フローを示します。サービス モジュールは、トラフィックを外部インターフェイス経由で送信します。

図 3-6 外部インターフェイス設定でのトラフィック フロー

外部インターフェイスを設定するには、次の手順を実行します。

手順


ステップ 1 VMware vSphere Hypervisor へのアクセスを設定するには、次のいずれかで説明されているコンフィギュレーション コマンドを使用します。

「MGF レイヤ 2 スイッチド設定:推奨」

または

「Cisco IOS レイヤ 3 ルーテッド設定オプション」

ステップ 2 vSphere Client GUI を使用して、外部インターフェイス経由での仮想マシンへのアクセスを設定します。手順については、vSphere Client のオンライン ヘルプを参照してください。


 

図 3-7 に、外部インターフェイス設定の例を示します。


) この設定例の IP アドレスは参照用に示しただけなので、実際には有効でない可能性があります。


図 3-7 外部インターフェイス設定

関連項目

「Cisco SRE-V ソフトウェアのダウンロード」

Cisco SRE サービス モジュールのリロード、リセット、およびシャットダウン

「CLI コマンドを使用したサービス モジュールのリロード、リセット、またはシャットダウン」

「ハードウェアを使用した Cisco SRE サービス モジュールのシャットダウン」

CLI コマンドを使用したサービス モジュールのリロード、リセット、またはシャットダウン

Cisco SRE サービス モジュールをリロード、リセット、またはシャットダウンするには、表 3-2 に記載されている一般的なルータ コマンドから選択します。Cisco SRE サービス モジュールのシャットダウンは、サービス上の理由から、あるいは未使用時にエネルギーを節約するために選択することがあります。


) • これらの Cisco IOS service-module コマンドを有効にするには、Management Network VMkernel ポート グループが、vmnic1 インターフェイスを備えた vSwitch をアップリンクとして使用するように設定されていることを確認します。

shutdown コマンドには、サービスを中断させる可能性があるものもあります。そのようなコマンドを実行して確認のプロンプトが表示された場合は、Enter を押して確認するか、 n と入力してキャンセルしてから Enter を押します。 no-confirm キーワードを使用することで、プロンプトが表示されないようにすることができます。

コマンドには、モジュールまたはアプリケーションをシャットダウンして即時に再起動するものがあります。


 

 

表 3-2 共通のシャットダウン、起動コマンド

コンフィギュレーション モード
コマンド
目的
Router#

service-module sm slot /0 reload

Cisco SRE サービス モジュールを通常の方法でシャットダウンしてから、電源をオンにします。

Router#

service-module sm slot /0 reset

Cisco SRE サービス モジュール上のハードウェアをリセットします。このコマンドは、シャットダウンまたは障害が発生した状態から回復する場合にだけ使用します。


注意 このコマンドを使用しても、ソフトウェアは順序正しくシャットダウンされず、進行中のファイル処理に影響を与える可能性があります。

Router#

service-module sm slot /0 shutdown

Cisco SRE サービス モジュール システムを通常の方法でシャットダウンします。活性挿抜(OIR)時にホットスワップ可能なモジュールの取り外しまたは交換を行う場合にこのコマンドを使用します。「Cisco SRE サービス モジュールの活性挿抜」を参照してください。

VMware vSphere Hypervisor 上の仮想マシンに VMware ツールがインストールされている場合、このコマンドを実行すると、まず仮想マシンがシャットダウンし、その後に Cisco SRE サービス モジュールがシャットダウンします。

仮想マシンに VMware ツールがインストールされていない場合、このコマンドを実行すると、まず仮想マシンの電源が切断され、その後にシャットダウン シグナルがサービス モジュールに送信されます。およそ 2 分後、Cisco SRE サービス モジュールがシャットダウンします。

コマンドを実行できなくなります。ロックダウン モードの詳細については、「ロックダウン モードについて」を参照してください。

ハードウェアを使用した Cisco SRE サービス モジュールのシャットダウン

Cisco SRE サービス モジュールのシャットダウン ボタンを押すことによって、ソフトウェアをシャットダウンできます。図 3-8 に、Cisco SRE 900 サービス モジュールのシャットダウン ボタンの位置を示します。このボタンは Cisco SRE 700、710、および 910 サービス モジュールと同じ位置にあります。

図 3-8 Cisco SRE 900 サービス モジュールのシャットダウン ボタン

 

ソフトウェアのグレースフル シャットダウンを実行するには、次の手順を実行します。


) この手順は、ソフトウェアをインストールした後にだけ実行できます。


手順


ステップ 1 シャットダウン ボタンの位置を確認します。図 3-8 を参照してください。

ステップ 2 くぼみにピンを差し込んでボタンを押します。

システムが正常にシャットダウンします。


 

Cisco SRE サービス モジュールをシャットダウンしたら、ハートビート リセット機能を無効にして、システムが再起動しないようにします。ハートビート リセット機能を無効にするには、 service-module sm slot /0 heartbeat-reset disable コマンドを使用します。「VMware vSphere Hypervisor がシャットダウン状態にならない」を参照してください。