Cisco Services Ready Engine Virtualization インストレーション/コンフィギュレーション ガイド
Cisco SRE サービス モジュール インター フェイスの設定
Cisco SRE サービス モジュール インターフェイスの設定
発行日;2012/01/31 | 英語版ドキュメント(2011/02/07 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 2MB) | フィードバック

目次

Cisco SRE サービス モジュール インターフェイスの設定

Cisco SRE サービス モジュール インターフェイスを設定するための基本的なワークフロー

Cisco SRE サービス モジュール インターフェイスの概要

Cisco SRE サービス モジュール インターフェイスの設定

Cisco SRE サービス モジュール インターフェイスを設定するための前提条件

ルータ上での Cisco SRE サービス モジュール インターフェイスの設定

MGF レイヤ 2 スイッチド設定:推奨

Cisco IOS レイヤ 3 ルーテッド設定

外部インターフェイス設定

VLAN の設定

MGF レイヤ 2 スイッチド設定での VLAN の設定

Cisco IOS レイヤ 3 ルーテッド設定での VLAN の設定

外部インターフェイス設定での VLAN の設定

リロード、リセット、およびシャットダウン コマンド

Cisco SRE サービス モジュール インターフェイスの設定

ここでは、Cisco SRE-V システム ソフトウェアを実行するように Cisco SRE サービス モジュール インターフェイスを設定する方法に関する情報を提供します。

始める前に、内部に Cisco SRE サービス モジュールが取り付けられる ISR G2 において、サポートされる Cisco IOS ソフトウェア バージョンが実行されていることを確認する必要があります。「ルータ、Cisco SRE サービス モジュール、および Cisco IOS ソフトウェア バージョンの互換性の確認」を参照してください。

この章の内容は、次のとおりです。

「Cisco SRE サービス モジュール インターフェイスを設定するための基本的なワークフロー」

「Cisco SRE サービス モジュール インターフェイスの概要」

「Cisco SRE サービス モジュール インターフェイスの設定」

「VLAN の設定」

「リロード、リセット、およびシャットダウン コマンド」

Cisco SRE サービス モジュール インターフェイスを設定するための基本的なワークフロー

1. Cisco SRE サービスモジュール インターフェイス sm1/0 を設定します。

2. Cisco SRE サービスモジュール インターフェイス sm1/1 を設定します。

3. VLAN 1 を設定します。

4. (任意)追加の VLAN を設定します。

「ルータ上での Cisco SRE サービス モジュール インターフェイスの設定」および「VLAN の設定」を参照してください。

Cisco SRE サービス モジュール インターフェイスの概要

ホスト ルータおよび Cisco SRE サービス モジュールでは、内部通信と外部通信のために複数のインターフェイスが使用されます。ルータ上で各インターフェイスを設定するために、Cisco IOS CLI コマンドを使用します。

インターフェイスを設定する前に、Cisco SRE サービス モジュール コマンド環境を開始するための次の情報を確認してください。

Cisco SRE サービス モジュールを装着する Cisco ルータの IP アドレス

ルータにログインするためのユーザ名とパスワード

Cisco SRE サービス モジュールのスロットとユニット番号

Cisco SRE サービス モジュールは、次の 3 つのインターフェイスを介してホスト ルータと通信します。

コンソール マネージャ インターフェイス:コンソール マネージャ インターフェイスでは、サービス モジュール コンソールにアクセスして、SRE-V 設定を実行できます。ホスト ルータ内からアクセスできるため、このインターフェイスにより、ルータと Cisco SRE サービス モジュールとの間に内部レイヤ 3 ギガビット イーサネット リンクが提供されます。コンソール マネージャ インターフェイスのすべての設定と管理は、Cisco IOS CLI を使用して実行されます。

MGF インターフェイス:MGF インターフェイスにより、Cisco SRE サービス モジュールは、高速バックプレーン スイッチ経由で通信できるようになります。ホスト ルータ内からアクセスできるため、このインターフェイスにより、ルータと Cisco SRE サービス モジュールとの間に内部レイヤ 2 ギガビット イーサネット リンクが提供されます。MGF インターフェイスの設定は、Cisco IOS CLI を使用して実行されます。MGF の設定の詳細については、Cisco.com にある『 Cisco 3900 Series, 2900 Series, and 1900 Series Integrated Services Routers Software Configuration Guide 』の「Multi-Gigabit Fabric on the Router」の章を参照してください。

外部サービス モジュール インターフェイス:VMware vSphere Hypervisor TM または仮想マシンは、外部サービス モジュール インターフェイスをプライマリ インターフェイスまたはバックアップ インターフェイスとして使用できます。内部インターフェイスの場合とは異なり、外部インターフェイスの制御と管理は主に VMware vSphere Hypervisor TM によって行われます。VMware vSphere Hypervisor TM がトラフィックを MGF インターフェイス経由でルータに転送するように設定されていない限り、トラフィックはルータを通過しません。

関連資料

「Cisco SRE サービス モジュール インターフェイスの設定」

Cisco SRE サービス モジュール インターフェイスの設定

ここでは、Cisco IOS CLI を使用した Cisco SRE サービス モジュールの基本的なネットワーク パラメータの設定方法について説明します。次の事項について説明します。

「Cisco SRE サービス モジュール インターフェイスを設定するための前提条件」

「ルータ上での Cisco SRE サービス モジュール インターフェイスの設定」

「VLAN の設定」

Cisco SRE サービス モジュール インターフェイスを設定するための前提条件

ここでは、ルータ、Cisco SRE サービス モジュール、および FTP/SFTP/HTTP サーバの前提条件について説明します。

Cisco ルータの前提条件

Cisco ルータで適切な Cisco IOS ソフトウェア バージョンが実行され、Cisco SRE サービス モジュールが認識されることを確認します。「ルータ、Cisco SRE サービス モジュール、および Cisco IOS ソフトウェア バージョンの互換性の確認」および「Cisco SRE サービス モジュールの取り付けの確認」を参照してください。

Cisco SRE サービス モジュールの前提条件


) ほとんどの場合、ルータは、内部に Cisco SRE サービス モジュールがすでに取り付けられた状態で出荷されます。


ホスト ルータ内での Cisco SRE サービス モジュールのスロットとポートの位置を特定します。

slot: Cisco SRE サービス モジュールが装着されているホスト ルータ シャーシ スロットの ID。サービス モジュールの取り付け後、Cisco IOS ソフトウェア CLI の show running-config コマンドを使用することにより、この情報を取得できます。

port :Cisco SRE サービス モジュール上の Network Interface Card(NIC; ネットワーク インターフェイス カード)の ID。
コンソール マネージャ インターフェイスの値は 0、MGF インターフェイスの値は 1 です。

関連資料

「ルータ上での Cisco SRE サービス モジュール インターフェイスの設定」

ルータ上での Cisco SRE サービス モジュール インターフェイスの設定

Cisco SRE サービス モジュールとホスト ルータとの間の内部インターフェイスを設定します。この初期設定が完了すれば、サービス モジュールにアクセスして、Cisco SRE-V アプリケーションのインストールおよび設定ができるようになります。

Cisco SRE-V では、次の 3 つの設定オプションが提供されます。

MGF レイヤ 2 スイッチド設定:この設定オプションでは、トラフィックがルータではなく EtherSwitch を通過するため、パフォーマンスが向上し、ルータ CPU には負荷がかかりません。ブロードキャスティングなど、すべてのレイヤ 2 機能がサポートされます。この設定オプションを使用するには、EtherSwitch EHWIC または EtherSwitch サービス モジュールを購入する必要があります。

Cisco IOS レイヤ 3 ルーテッド設定:この設定オプションでは、機器の追加は不要ですが、ルータ CPU に負荷がかかります。このオプションは複雑であり、一部のレイヤ 2 機能(ブロードキャスティングなど)はサポートされません。

外部インターフェイス設定:この設定オプションは、設定しやすく、低コストであり、ルータ CPU に負荷をかけません。しかし、外部スイッチ上での追加のケーブル配線と追加のギガビット イーサネット スイッチポートを必要とします。さらに、VMware vSphere Hypervisor TM ネットワーク上で Cisco IOS 機能を使用できません(たとえば、仮想マシンを DMZ 内に配置できません)。また、内部インターフェイスで使用可能なハードウェア TCP/IP/UDP/iSCSI オフ ロード機能を利用できません。

詳細については、次の項を参照してください。

「MGF レイヤ 2 スイッチド設定:推奨」

「Cisco IOS レイヤ 3 ルーテッド設定」

「外部インターフェイス設定」

MGF レイヤ 2 スイッチド設定:推奨

図 3-1 に、MGF レイヤ 2 スイッチド設定でのトラフィック フローを示します。MGF バックプレーン スイッチにより、複数のハイパーバイザ間にわたって仮想ネットワークが接続され、ルータ CPU 経由でトラフィックを送信しなくても、Cisco EtherSwitch EHWIC または EtherSwitch サービス モジュール経由で LAN に直接アクセスできるようになります。サポートされる Cisco EtherSwitch EHWIC および EtherSwitch サービス モジュールについては、 表 1-2 を参照してください。

図 3-1 MGF レイヤ 2 スイッチド設定でのトラフィック フロー

図 3-2 に、Cisco SRE サービス モジュール インターフェイス上に設定する IP アドレスの位置を示します。

コンソール マネージャには、2 つの IP アドレスが必要です。ルータからコンソール マネージャへのリンクのルータ側に 1 つ、同じリンクのコンソール マネージャ側にもう 1 つです。

VMware vSphere Hypervisor TM にも 2 つの IP アドレスが必要です。ルータを VMware vSphere Hypervisor TM に接続するリンクのルータ側に 1 つ、VMware vSphere Hypervisor TM にもう 1 つです。

図 3-2 IP アドレスの位置

手順の概要

ホスト ルータ CLI での手順(次のコマンドを入力)

1. enable

2. configure terminal

コンソール マネージャの slot /0 の設定

1. interface sm slot /0

2. ip address console-manager-router-side-ip-address subnet-mask
または
ip unnumbered type number

3. service-module ip address console-manager-ip-address subnet-mask

4. service-module ip default-gateway console-manager-gateway-ip-address

5. service-module mgf ip address hypervisor-ip-address subnet-mask

6. no shut

7. exit

8. [ip route console-manager -ip-address subnet-mask sm slot /0]

コンソール マネージャの slot /1 の設定

1. interface sm slot /1

2. switchport mode trunk

3. [switchport trunk allowed vlan vlan_numbers ]

4. exit

VLAN 1 の設定

1. interface vlan 1

2. ip address hypervisor-router-side-ip-address subnet-mask

3. no shut

4. end

5. copy running-config startup-config

6. show running-config

手順の詳細

コマンドまたは操作
目的
 
ホスト ルータ CLI での手順

ステップ 1

enable

<password>

 

Router> enable

Router> <password>

Router#

ホスト ルータ上で特権 EXEC モードを開始します。パスワードの入力を求められた場合は入力します。

ステップ 2

configure terminal

 

Router# configure terminal

ホスト ルータ上でグローバル コンフィギュレーション モードを開始します。

 
コンソール マネージャの slot/0 の設定

ステップ 1

interface sm slot /0

 

Router(config)# interface sm 1/0

Cisco SRE サービス モジュールが装着されたスロットとポート用のインターフェイス コンフィギュレーション モードを開始します。

ステップ 2

ip address console-manager-router-side-ip-address subnet-mask

 

または

ip unnumbered type number

 

Router(config-if)# ip address 10.0.0.100 255.255.255.0

 

または

Router(config-if)# ip unnumbered gigabitethernet 1/0

ルータをコンソール マネージャに接続するリンクのルータ側の IP アドレスを指定します。

コンソール マネージャには、2 つの IP アドレスが必要です。ルータからコンソール マネージャへのリンクのルータ側に 1 つ、同じリンクのコンソール マネージャ側にもう 1 つです。この手順では、リンクのルータ側の IP アドレスを設定します。図 3-2 を参照してください。

console-manager-router-side-ip-address subnet-mask :ルータをコンソール マネージャに接続するリンクのルータ側の IP アドレス。IP アドレスにアペンドするサブネット マスク。

または

ip unnumbered コマンドは、インターフェイスに明示的な IP アドレスを割り当てずに、そのインターフェイス上での IP 処理をイネーブルにします。

type :割り当てられた IP アドレスをルータが保持しているインターフェイスのタイプを示します。

number :割り当てられた IP アドレスをルータが保持しているインターフェイスの番号を示します。

(注) 番号付けされていないインターフェイスは、一意になる必要があります。番号付けされていない別のインターフェイスは指定できません。


注意 ip unnumbered コマンドでは、デバイス間のポイントツーポイント インターフェイスが作成されます。ブロードキャスティングはサポートされません。

ステップ 8 を参照してください。

ステップ 3

service-module ip address console-manager-ip-address subnet-mask

 

Router(config-if)# service-module ip address 10.0.0.1 255.255.255.0

コンソール マネージャの IP アドレスを指定します。

console-manager -ip-address :コンソール マネージャの IP アドレス。図 3-2 を参照してください。

subnet-mask :IP アドレスにアペンドするサブネット マスクを示します。ホスト ルータと同じサブネット内にある必要があります。

(注) コンソール マネージャの IP アドレスを変更する場合は、サービス モジュールをリロードする必要があります。

ステップ 4

service-module ip default-gateway console-manager-gateway-ip-address

 

Router(config-if)# service-module ip default-gateway 10.0.0.100

コンソール マネージャのデフォルト ゲートウェイの IP アドレスを指定します。

console-manager- gateway-ip-address :デフォルト ゲートウェイ ルータの IP アドレス。

ステップ 5

service-module mgf ip address hypervisor-ip-address subnet-mask

 

Router(config-if)# service-module mgf ip address 20.0.0.1 255.255.255.0

VMware vSphere Hypervisor TM の IP アドレスを指定します。

hypervisor- ip-address :VMware vSphere Hypervisor TM の IP アドレス。図 3-2 を参照してください。

subnet-mask :IP アドレスにアペンドするサブネット マスクを示します。ホスト ルータと同じサブネット内にある必要があります。

ステップ 6

no shut

 

Router(config-if)# no shut

インターフェイスが管理上のアップ状態になります。

ステップ 7

exit

 

Router(config)# exit

ホスト ルータ上でグローバル コンフィギュレーション モードに戻ります。

ステップ 8

[ip route console-manager-ip-address subnet-mask sm slot /0]

 

Router(config)# ip route 10.0.0.1 255.255.255.255 SM1/0

スタティック ルートを作成します。

ステップ 2 ip unnumbered コマンドを使用した場合は、 ip route console-manager-ip-address subnet-mask sm slot/ 0 コマンドを使用してスタティック ルートを作成する必要があります

console-manager-ip-address subnet-mask: コンソール マネージャの IP アドレスとサブネット マスク。

slot/0: Cisco SRE サービス モジュールが装着されているスロットとポート。

 
コンソール マネージャの slot/1 の設定

ステップ 1

interface sm slot /1

 

Router(config)# interface sm 1/1

Cisco SRE サービス モジュールが装着されたスロットとポート用のインターフェイス コンフィギュレーション モードを開始します。

ステップ 2

switchport mode trunk

 

Router(config-if)# switchport mode trunk

ポートを永続的なトランキング モードにします。

デフォルトの設定は、アクセス モードです。アクセス モードは、ネイティブ VLAN で動作します。Cisco SRE サービス モジュールでは、VLAN 1 がこれに該当します。

ステップ 3

[switchport trunk allowed vlan vlan_numbers ]

 

Router(config-if)# switchport mode trunk

Router(config-if)# switchport trunk allowed vlan 40, 60

(任意)指定した VLAN 上でのトランキングを許可します。

vlan_numbers :トランキングを許可する VLAN 番号。

ステップ 4

exit

 

Router(config)# exit

ホスト ルータ上でグローバル コンフィギュレーション モードに戻ります。

 
VLAN 1 の設定

ステップ 1

interface vlan 1

 

Router(config)# interface vlan 1

VLAN 1 用の VLAN コンフィギュレーション モードを開始します。

ステップ 2

ip address hypervisor-router-side-ip-address subnet-mask

 

Router(config-if)# ip address 20.0.0.100 255.255.255.0

ルータから VMware vSphere Hypervisor TM へのリンクのルータ側の IP アドレスを指定します。図 3-2 を参照してください。

hypervisor-router-side-ip-address: ルータを VMware vSphere Hypervisor TM に接続するリンクのルータ側の IP アドレス。ステップ 5 で設定した VMware vSphere Hypervisor TM の IP アドレスと同じサブネットに属する必要があります。

subnet-mask :IP アドレスにアペンドするサブネット マスク。

ステップ 3

no shut

 

Router(config-if)# no shut

インターフェイスが管理上のアップ状態になります。

ステップ 4

end

 

Router(config)# end

ホスト ルータ上でグローバル コンフィギュレーション モードに戻ります。

ステップ 5

copy running-config startup-config

 

Router# copy running-config startup-config

ルータの新しい実行コンフィギュレーションをスタートアップ コンフィギュレーションとして保存します。

ステップ 6

show running-config

 

Router# show running-config

アドレス設定を確認できるように、ルータの実行コンフィギュレーションを表示します。

図 3-3 に、MGF レイヤ 2 スイッチド設定の例を示します。

左側のペインは、sm 1/0、sm 1/1、および vlan 1 の各インターフェイスでの Cisco IOS コマンドの設定例を示しています。

右側のペインは、この設定が Cisco SRE-V においてコンソール マネージャと VMware vSphere Hypervisor TM に適用されていることを示しています。右側のペインの一番下の領域は、標準的な Microsoft Windows ネットワーク構成設定プロセスを使用して設定されている Microsoft Windows Server の設定を示しています。この Microsoft Windows Server は、仮想マシンとして稼動しています。


) この設定例の IP アドレスは参照用に示しただけなので、実際には有効でない可能性があります。


図 3-3 MGF レイヤ 2 スイッチド設定の設定例

関連資料

「MGF レイヤ 2 スイッチド設定での VLAN の設定」

「Cisco SRE-V ソフトウェアのダウンロード」

Cisco IOS レイヤ 3 ルーテッド設定

図 3-4 に、Cisco IOS レイヤ 3 ルーテッド設定でのトラフィック フローを示します。MGF バックプレーン スイッチにより、トラフィックがルータ CPU に転送されます。

図 3-4 Cisco IOS レイヤ 3 ルーテッド設定でのトラフィック フロー

手順の概要

ホスト ルータ CLI での手順(次のコマンドを入力)

1. enable

2. configure terminal

コンソール マネージャの slot /0 の設定

1. interface sm slot /0

2. ip address console-manager-router-side-ip-address subnet-mask
または
ip unnumbered type number

3. service-module ip address console-manager-ip-address subnet-mask

4. service-module ip default-gateway console-manager-gateway-ip-address

5. service-module mgf ip address hypervisor-ip-address subnet-mask

6. no shut

7. exit

8. [ip route console-manager-ip-address subnet-mask sm slot /0]

コンソール マネージャの slot /1 の設定

1. interface sm slot /1

2. switchport mode trunk

3. [switchport trunk allowed vlan vlan_numbers ]

4. exit

VLAN 1 の設定

1. interface vlan 1

2. ip unnumbered gigabitethernet slot/port sub-interface

GE slot/port の設定

1. interface gigabitethernet slot/port sub-interface

2. ip address branch-LAN-ip-address subnet-mask

3. exit

4. ip route hypervisor-ip-address subnet-mask vlan 1

5. ip route virtual-machine-ip-address subnet-mask vlan 1

6. no shut

7. end

8. copy running-config startup-config

9. show running-config

手順の詳細

コマンドまたは操作
目的
 
ホスト ルータ CLI での手順

ステップ 1

enable

<password>

 

Router> enable

Router> <password>

Router#

ホスト ルータ上で特権 EXEC モードを開始します。パスワードの入力を求められた場合は入力します。

ステップ 2

configure terminal

 

Router# configure terminal

ホスト ルータ上でグローバル コンフィギュレーション モードを開始します。

 
コンソール マネージャの slot/0 の設定

ステップ 1

interface sm slot /0

 

Router(config)# interface sm 1/0

Cisco SRE サービス モジュールが装着されたスロットとポート用のインターフェイス コンフィギュレーション モードを開始します。

ステップ 2

ip address console-manager-router-side-ip-address subnet-mask

 

または

ip unnumbered type number

 

Router(config-if)# ip address 10.0.0.100 255.255.255.0

 

または

Router(config-if)# ip unnumbered gigabitethernet 1/0

ルータをコンソール マネージャに接続するリンクのルータ側の IP アドレスを指定します。

コンソール マネージャには、2 つの IP アドレスが必要です。ルータからコンソール マネージャへのリンクのルータ側に 1 つ、同じリンクのコンソール マネージャ側にもう 1 つです。この手順では、リンクのルータ側の IP アドレスを設定します。図 3-2 を参照してください。

console-manager-router-side-ip-address subnet-mask :ルータをコンソール マネージャに接続するリンクのルータ側の IP アドレス。IP アドレスにアペンドするサブネット マスク。

または

ip unnumbered コマンドは、インターフェイスに明示的な IP アドレスを割り当てずに、そのインターフェイス上での IP 処理をイネーブルにします。

type :割り当てられた IP アドレスをルータが保持しているインターフェイスのタイプを示します。

number :割り当てられた IP アドレスをルータが保持しているインターフェイスの番号を示します。

(注) 番号付けされていないインターフェイスは、一意になる必要があります。番号付けされていない別のインターフェイスは指定できません。


注意 ip unnumbered コマンドでは、デバイス間のポイントツーポイント インターフェイスが作成されます。ブロードキャスティングはサポートされません。

ステップ 8 を参照してください。

ステップ 3

service-module ip address console-manager-ip-address subnet-mask

 

Router(config-if)# service-module ip address 10.0.0.1 255.255.255.0

コンソール マネージャの IP アドレスを指定します。

console-manager -ip-address :コンソール マネージャの IP アドレス。図 3-2 を参照してください。

subnet-mask :IP アドレスにアペンドするサブネット マスクを示します。ホスト ルータと同じサブネット内にある必要があります。

(注) コンソール マネージャの IP アドレスを変更する場合は、サービス モジュールをリロードする必要があります。

ステップ 4

service-module ip default-gateway console-manager-gateway-ip-address

 

Router(config-if)# service-module ip default-gateway 10.0.0.100

コンソール マネージャのデフォルト ゲートウェイの IP アドレスを指定します。

console-manager- gateway-ip-address :デフォルト ゲートウェイ ルータの IP アドレス。

ステップ 5

service-module mgf ip address hypervisor-ip-address subnet-mask

 

Router(config-if)# service-module mgf ip address 20.0.0.1 255.255.255.0

VMware vSphere Hypervisor TM の IP アドレスを指定します。

hypervisor- ip-address :VMware vSphere Hypervisor TM の IP アドレス。図 3-2 を参照してください。

subnet-mask :IP アドレスにアペンドするサブネット マスクを示します。ホスト ルータと同じサブネット内にある必要があります。

ステップ 6

no shut

 

Router(config-if)# no shut

インターフェイスが管理上のアップ状態になります。

ステップ 7

exit

 

Router(config)# exit

ホスト ルータ上でグローバル コンフィギュレーション モードに戻ります。

ステップ 8

[ip route console-manager-ip-address subnet-mask sm slot /0]

 

Router(config)# ip route 10.0.0.1 255.255.255.255 SM1/0

スタティック ルートを作成します。

ステップ 2 ip unnumbered コマンドを使用した場合は、 ip route console-manager-ip-address subnet-mask sm slot/ 0 コマンドを使用してスタティック ルートを作成する必要があります

console-manager-ip-address subnet-mask: コンソール マネージャの IP アドレスとサブネット マスク。

slot/0: Cisco SRE サービス モジュールが装着されているスロットとポート。

 
コンソール マネージャの slot/1 の設定

ステップ 1

interface sm slot /1

 

Router(config)# interface sm 1/1

Cisco SRE サービス モジュールが装着されたスロットとポート用のインターフェイス コンフィギュレーション モードを開始します。

ステップ 2

switchport mode trunk

 

Router(config-if)# switchport mode trunk

ポートを永続的なトランキング モードにします。

デフォルトの設定は、アクセス モードです。アクセス モードは、ネイティブ VLAN で動作します。Cisco SRE サービス モジュールでは、VLAN 1 がこれに該当します。

ステップ 3

[switchport trunk allowed vlan vlan_numbers ]

 

Router(config-if)# switchport mode trunk

Router(config-if)# switchport trunk allowed vlan 30, 40

(任意)指定した VLAN 上でのトランキングを許可します。

vlan_numbers :トランキングを許可する VLAN 番号。

ステップ 4

exit

 

Router(config)# exit

ホスト ルータ上でグローバル コンフィギュレーション モードに戻ります。

 
VLAN 1 の設定

ステップ 1

interface vlan 1

 

Router(config)# interface vlan 1

VLAN 1 用の VLAN コンフィギュレーション モードを開始します。

ステップ 2

ip unnumbered gigabitethernet slot/port sub-interface

 

Router(config-if)# ip unnumbered gigabitethernet 0/0.1

インターフェイスに明示的な IP アドレスを割り当てずに、そのインターフェイス上での IP 処理をイネーブルにします。トラフィックはギガビット イーサネット インターフェイスに対して双方向に転送されます。

slot/port :ルータ シャーシ内でのギガビット イーサネット インターフェイスの位置。

sub-interface :割り当てられた IP アドレスをルータが保持しているギガビット イーサネット インターフェイスの番号。

(注) 番号付けされていないインターフェイスは、一意になる必要があります。番号付けされていない別のインターフェイスは指定できません。


注意 ip unnumbered コマンドでは、デバイス間のポイントツーポイント インターフェイスが作成されます。ブロードキャスティングはサポートされません。

 
ギガビット イーサネット slot/port の設定

ステップ 1

interface gigabitethernet slot/port sub-interface

 

Router(config)# interface gigabitethernet 0/0.1

指定したサブ インターフェイス用のギガビット イーサネット コンフィギュレーション モードを開始します。

slot/port :ルータ シャーシ内でのギガビット イーサネット インターフェイスの位置。

sub-interface :割り当てられた IP アドレスをルータが保持しているギガビット イーサネット インターフェイスの番号。

ステップ 2

ip address branch-LAN-ip-address subnet-mask

 

Router(config-if)# ip address 20.0.0.100 255.255.255.0

ブランチ ローカル エリア ネットワークの IP アドレスを設定します。

branch-LAN-ip-address subnet-mask :ブランチ ローカル エリア ネットワークの IP アドレス。IP アドレスにアペンドするサブネット マスク。

ステップ 3

exit

インターフェイス モードを終了します。

ステップ 4

ip route hypervisor-ip-address subnet-mask vlan 1

 

Router(config)# ip route 20.0.0.1 255.255.255.0

VMware vSphere Hypervisor TM 用のスタティック ルート エントリを作成します。

hypervisor -ip-address subnet-mask :VMware vSphere Hypervisor TM の IP アドレスとサブネット マスク。図 3-2 を参照してください。

ステップ 5

ip route virtual-machine-ip-address subnet-mask vlan 1

 

Router(config)# ip route 20.0.0.2 255.255.255.0

仮想マシン用のスタティック ルート エントリを作成します。

virtual-machine-ip-address subnet-mask:仮想マシンの IP アドレスとサブネット マスク。

ステップ 6

no shut

 

Router(config-if)# no shut

インターフェイスが管理上のアップ状態になります。

ステップ 7

end

 

Router(config)# end

ホスト ルータ上でグローバル コンフィギュレーション モードに戻ります。

ステップ 8

copy running-config startup-config

 

Router# copy running-config startup-config

ルータの新しい実行コンフィギュレーションをスタートアップ コンフィギュレーションとして保存します。

ステップ 9

show running-config

 

Router# show running-config

アドレス設定を確認できるように、ルータの実行コンフィギュレーションを表示します。

図 3-5 に、Cisco IOS レイヤ 3 ルーテッド設定の例を示します。

左側のペインは、sm 1/0、sm 1/1、vlan 1、およびギガビット イーサネットの各インターフェイスでの Cisco IOS コマンドの設定例を示しています。

右側のペインは、この設定が Cisco SRE-V においてコンソール マネージャと VMware vSphere Hypervisor TM に適用されていることを示しています。

右側のペインの一番下の領域は、標準的な Microsoft Windows ネットワーク構成設定プロセスを使用して設定されている Microsoft Windows Server の設定を示しています。この Microsoft Windows Server は、仮想マシンとして稼動しています。


) この設定例の IP アドレスは参照用に示しただけなので、実際には有効でない可能性があります。


図 3-5 Cisco IOS レイヤ 3 ルーテッド設定の設定例

関連資料

「Cisco IOS レイヤ 3 ルーテッド設定での VLAN の設定」

「Cisco SRE-V ソフトウェアのダウンロード」

外部インターフェイス設定

外部インターフェイス設定に使用する Cisco IOS コンフィギュレーション コマンドは、次の点を除いて、「MGF レイヤ 2 スイッチド設定:推奨」「Cisco IOS レイヤ 3 ルーテッド設定」で使用されるコマンドと同じです。

仮想マシンの IP アドレスは、外部インターフェイスに接続されるネットワーク上のものになります。

仮想マシンのデフォルト ゲートウェイは、外部インターフェイスを指します。

(Cisco IOS レイヤ 3 ルーテッド設定では設定される)仮想マシン用のスタティック ルート エントリは必要ありません。

図 3-6 に、外部インターフェイス設定でのトラフィック フローを示します。サービス モジュールは、トラフィックを外部インターフェイス経由で送信します。

図 3-6 外部インターフェイス設定でのトラフィック フロー

外部インターフェイスを設定するには、次の手順を実行します。


ステップ 1 コンソール マネージャと VMware vSphere Hypervisor TM へのアクセスを設定するには、次のいずれかで説明されているコンフィギュレーション コマンドを使用します。

「MGF レイヤ 2 スイッチド設定:推奨」

または

「Cisco IOS レイヤ 3 ルーテッド設定」

ステップ 2 vSphere Client GUI を使用して、外部インターフェイス経由での仮想マシンへのアクセスを設定します。手順については、vSphere Client のオンライン ヘルプを参照してください。


 

関連資料

「外部インターフェイス設定での VLAN の設定」

「Cisco SRE-V ソフトウェアのダウンロード」

VLAN の設定

異なるセグメントに専用の VLAN を設定するには、VLAN を作成する必要があります。必要に応じて次の各項を参照してください。

「MGF レイヤ 2 スイッチド設定での VLAN の設定」

「Cisco IOS レイヤ 3 ルーテッド設定での VLAN の設定」

「外部インターフェイス設定での VLAN の設定」

MGF レイヤ 2 スイッチド設定での VLAN の設定

MGF レイヤ 2 スイッチド設定を使用して Cisco SRE サービス モジュールを設定済みであり、異なるセグメントに専用の VLAN を設定する場合は、ここに示されているコマンドを使用します。

前提条件

スイッチポートがトランク モードであることを確認する必要があります。「コンソール マネージャの slot/1 の設定」を参照してください。

手順の概要

ホスト ルータ CLI での手順

1. enable

2. vlan database

3. vlan vlan_number

4. exit

5. configure terminal

6. interface vlan vlan_number

7. ip address vlan-ip-address subnet mask

手順の詳細

コマンドまたは操作
目的
 
ホスト ルータ CLI での手順

ステップ 1

enable

<password>

 

Router> enable

Router> <password>

Router#

ホスト ルータ上で特権 EXEC モードを開始します。パスワードの入力を求められた場合は入力します。

ステップ 2

vlan database

 

Router# vlan database

VLAN データベース モードを開始します。

ステップ 3

vlan vlan_number

 

Router(vlan)# vlan 40

VLAN 40 added:

Name: VLAN0040

指定した VLAN をデータベースに追加します。

ステップ 4

exit

 

Router(vlan)# exit

VLAN データベース モードを終了します。

ステップ 5

configure terminal

 

Router# configure terminal

ホスト ルータ上でグローバル コンフィギュレーション モードを開始します。

ステップ 6

interface vlan vlan_number

 

Router(config)# interface vlan 40

指定した VLAN 番号の VLAN コンフィギュレーション モードを開始します。

ステップ 7

ip address vlan-ip-address subnet-mask

 

Router(config-if)# ip address 40.0.0.100 255.255.255.0

VLAN の IP アドレスを指定します。

vlan-ip-address :VLAN の IP アドレス。

subnet-mask :IP アドレスにアペンドするサブネット マスク。

図 3-7 に、2 つの新しい VLAN(vlan 40 と vlan 60)を追加した MGF レイヤ 2 スイッチド設定全体の例を示します。


) この設定例の IP アドレスは参照用に示しただけなので、実際には有効でない可能性があります。


図 3-7 新しい VLAN を追加した MGF レイヤ 2 スイッチド設定の例

関連資料

「MGF レイヤ 2 スイッチド設定:推奨」

「Cisco SRE-V ソフトウェアのダウンロード」

Cisco IOS レイヤ 3 ルーテッド設定での VLAN の設定

Cisco IOS レイヤ 3 設定を使用して Cisco SRE サービス モジュールを設定済みであり、異なるセグメントに専用の VLAN を設定する場合は、ここに示されているコマンドを使用します。

前提条件

スイッチポートがトランク モードであることを確認する必要があります。「コンソール マネージャの slot/1 の設定」を参照してください。

手順の概要

ホスト ルータ CLI での手順

1. enable

2. vlan database

3. vlan vlan_number

4. exit

5. configure terminal

6. interface vlan number

7. ip unnumbered gigabitethernet slot/port sub-interface

8. exit

GE slot/port の設定

1. interface gigabitethernet slot /port sub-interface

2. ip address branch-VLAN-ip-address subnet-mask

3. encapsulation dot1q vlan-id

4. exit

5. ip route virtual-machine-ip-address subnet-mask vlan_number

手順の詳細

コマンドまたは操作
目的
 
ホスト ルータ CLI での手順

ステップ 1

enable

<password>

 

Router> enable

Router> <password>

Router#

ホスト ルータ上で特権 EXEC モードを開始します。パスワードの入力を求められた場合は入力します。

ステップ 2

vlan database

 

Router# vlan database

VLAN データベース モードを開始します。

ステップ 3

vlan vlan_number

 

Router(vlan)# vlan 40

VLAN 40 added:

Name: VLAN0040

指定した VLAN をデータベースに追加します。

ステップ 4

exit

 

Router(vlan)# exit

VLAN データベース モードを終了します。

ステップ 5

configure terminal

 

Router# configure terminal

ホスト ルータ上でグローバル コンフィギュレーション モードを開始します。

ステップ 6

interface vlan vlan_number

 

Router(config)# interface vlan 40

指定した VLAN 番号の VLAN コンフィギュレーション モードを開始します。

ステップ 7

ip unnumbered gigabitethernet slot/port sub-interface

 

Router(config-if)# ip unnumbered gigabitethernet 0/0.40

インターフェイスに明示的な IP アドレスを割り当てずに、そのインターフェイス上での IP 処理をイネーブルにします。トラフィックはギガビット イーサネット サブインターフェイスに対して双方向に転送されます。

slot/port :ルータ シャーシ内でのギガビット イーサネット インターフェイスの位置。

sub-interface :割り当てられた IP アドレスをルータが保持しているギガビット イーサネット サブ インターフェイスの番号。

(注) 番号付けされていないインターフェイスは、一意になる必要があります。番号付けされていない別のインターフェイスは指定できません。


注意 ip unnumbered コマンドでは、デバイス間のポイントツーポイント インターフェイスが作成されます。ブロードキャスティングはサポートされません。

ステップ 8

exit

インターフェイス モードを終了します。

 
ギガビット イーサネット slot/port の設定

ステップ 1

interface gigabitethernet slot/port sub-interface

 

Router(config)# interface gigabitethernet 0/0.40

指定したサブ インターフェイス用のギガビット イーサネット コンフィギュレーション モードを開始します。

slot/port :ルータ シャーシ内でのギガビット イーサネット インターフェイスの位置。

sub-interface :割り当てられた IP アドレスをルータが保持しているギガビット イーサネット インターフェイスの番号。

ステップ 2

ip address branch-VLAN-ip-address subnet-mask

 

Router(config-if)# ip address 40.0.0.100 255.255.255.0

特定のブランチ VLAN の IP アドレスを設定します。

branch-VLAN-ip-address subnet-mask :特定のブランチ VLAN の IP アドレス。この IP アドレスは、ステップ 5 で定義される VLAN 内の仮想マシンのデフォルト ゲートウェイとして使用できます。

ステップ 3

encapsulation dot1q vlan-id

 

Router(config-if)# encapsulation dot1q 40

VLAN 内の指定したサブインターフェイス上のトラフィックの IEEE 802.1Q カプセル化をイネーブルにします。

vlan-id :仮想 LAN 識別子。指定できる範囲は 1 ~ 1000 です。

ステップ 4

exit

インターフェイス モードを終了します。

ステップ 5

ip route virtual-machine-ip-address subnet-mask vlan_number

 

Router(config)# ip route 40.0.0.2 255.255.255.0

仮想マシン用のスタティック ルート エントリを作成します。

virtual-machine-ip-address subnet-mask:仮想マシンの IP アドレスとサブネット マスク。

図 3-8 に、2 つの新しい VLAN(vlan 40 と vlan 60)を追加した Cisco IOS レイヤ 3 ルーテッド設定全体の例を示します。


) この設定例の IP アドレスは参照用に示しただけなので、実際には有効でない可能性があります。


図 3-8 新しい VLAN を追加した Cisco IOS レイヤ 3 ルーテッド設定の例

関連資料

「Cisco IOS レイヤ 3 ルーテッド設定」

「Cisco SRE-V ソフトウェアのダウンロード」

外部インターフェイス設定での VLAN の設定

外部インターフェイス設定では、外部 vSwitch を使用して VLAN を設定します。


) VLAN の作成に、Cisco IOS CLI は必要ありません。


図 3-9 に、2 つの新しい VLAN(vlan 40 と vlan 60)を追加した外部インターフェイス設定全体の例を示します。


) この設定例の IP アドレスは参照用に示しただけなので、実際には有効でない可能性があります。


図 3-9 新しい VLAN を追加した外部インターフェイス設定の例

関連資料

「外部インターフェイス設定」

「Cisco SRE-V ソフトウェアのダウンロード」

リロード、リセット、およびシャットダウン コマンド

Cisco SRE サービス モジュールをリロード、リセット、またはシャットダウンするには、表 3-1 に記載されている一般的なルータ コマンドから選択します。Cisco SRE サービス モジュールのシャットダウンは、サービス上の理由から、あるいは未使用時にエネルギーを節約するために選択することがあります。


) • シャットダウン コマンドの一部には、サービスを中断する可能性があるものがあります。このようなコマンドのコマンド出力に確認プロンプトが表示された場合、Enter を押して確認するか、n と入力して Enter を押してキャンセルします。no-confirm キーワードを使用することで、プロンプトが表示されないようにすることができます。

コマンドには、モジュールまたはアプリケーションをシャットダウンして即時に再起動するものがあります。


 

 

表 3-1 一般的なシャットダウン コマンドおよびスタートアップ コマンド

コンフィギュレーション モード
コマンド
目的
Router#

service-module sm slot /0 reload

Cisco SRE サービス モジュール オペレーティング システムを通常の方法でシャットダウンします。

Router#

service-module sm slot /0 reset

Cisco SRE サービス モジュール上のハードウェアをリセットします。このコマンドは、シャットダウンまたは障害が発生した状態から回復する場合にだけ使用します。


注意 このコマンドを使用しても、ソフトウェアは順序正しくシャットダウンされず、進行中のファイル処理に影響を与える可能性があります。

Router#

service-module sm slot /0 shutdown

Cisco SRE サービス モジュール システムを通常の方法でシャットダウンします。Online Insertion and Removal(OIR; 活性挿抜)時にホットスワップ可能なモジュールの取り外しまたは交換を行う場合にこのコマンドを使用します。「Cisco SRE サービス モジュールの活性挿抜」を参照してください。

VMware vSphere Hypervisor TM 上の仮想マシンに VMware ツールがインストールされている場合、このコマンドを実行すると、まず最初に仮想マシンがシャットダウンし、その後に Cisco SRE サービス モジュールがシャットダウンします。

仮想マシンに VMware ツールがインストールされていない場合、このコマンドを実行すると、まず仮想マシンの電源が切断され、その後にシャットダウン シグナルがサービス モジュールに送信されます。およそ 2 分後、Cisco SRE サービス モジュールがシャットダウンします。