Cisco Services Ready Engine Virtualization インストレーション/コンフィギュレーション ガイド
Cisco SRE サービス モジュール インター フェイスの設定:Cisco IOS Version 15.1(2)T
Cisco SRE サービス モジュール インターフェイスの設定:Cisco IOS Version 15.1(2)T
発行日;2012/01/31 | 英語版ドキュメント(2010/11/19 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 2MB) | フィードバック

目次

Cisco SRE サービス モジュール インターフェイスの設定:Cisco IOS Version 15.1(2)T

Cisco SRE サービス モジュール インターフェイスを設定するための基本的なワークフロー

Cisco SRE サービス モジュール インターフェイスの概要

サービス モジュール インターフェイス

MGF インターフェイス

外部サービス モジュール インターフェイス

Cisco SRE サービス モジュール インターフェイスの設定

Cisco SRE サービス モジュール インターフェイスを設定するための前提条件

ルータ上でのサービス モジュール インターフェイスの設定

モジュール上の MGF インターフェイスの設定

Cisco SRE サービス モジュール インターフェイスの設定:Cisco IOS Version 15.1(2)T


) Cisco SRE サービス モジュールが装着されている ISR G2 で Cisco IOS version 15.1(2)T を実行している場合、サポートされている Cisco IOS バージョン(「ルータ、Cisco SRE サービス モジュール、および Cisco IOS ソフトウェア バージョンの互換性の確認」を参照)にアップグレードしないようにするには、この付録に記載されている手順に従って、Cisco SRE サービス モジュール インターフェイスを設定します。



注意 ISR G2 で Cisco IOS version 15.1(2)T が実行されている場合は、Cisco SRE サービス モジュールに VLAN を設定できません。

ここでは、Cisco SRE-V システム ソフトウェアを実行するように Cisco SRE サービス モジュール インターフェイスを設定する方法に関する情報を提供します。

この章の内容は、次のとおりです。

「Cisco SRE サービス モジュール インターフェイスを設定するための基本的なワークフロー」

「Cisco SRE サービス モジュール インターフェイスの概要」

「Cisco SRE サービス モジュール インターフェイスの設定」

Cisco SRE サービス モジュール インターフェイスを設定するための基本的なワークフロー

1. ルータ上でサービスモジュール インターフェイスを設定します。「ルータ上でのサービス モジュール インターフェイスの設定」を参照してください。

2. モジュール上で MGF インターフェイスを設定します。「モジュール上の MGF インターフェイスの設定」を参照してください。

Cisco SRE サービス モジュール インターフェイスの概要

ホスト ルータおよび Cisco SRE サービス モジュールでは、内部通信と外部通信のために複数のインターフェイスが使用されます。ルータ上で各インターフェイスを設定するために、Cisco IOS CLI コマンドを使用します。

インターフェイスを設定する前に、Cisco SRE サービス モジュール コマンド環境を開始するための次の情報を確認してください。

Cisco SRE サービス モジュールを装着する Cisco ルータの IP アドレス

ルータにログインするためのユーザ名とパスワード

Cisco SRE サービス モジュールのスロットとユニット番号

サービス モジュールは、2 つの内部 Gigabit Ethernet(GE; ギガビット イーサネット)インターフェイスを介してホスト ルータと通信します。

一方の GE インターフェイスは、ルータの Peripheral Component Interconnect Express(PCIe)に接続します。Cisco IOS CLI を使用して、このインターフェイスを設定および管理します。このインターフェイスは sm slot /0 です。

もう一方の GE インターフェイスは、Multi-Gigabit Fabric(MGF)に接続します。Cisco IOS CLI を使用して、VMware vSphere Hypervisor TM 用に MGF インターフェイスの IP アドレスを設定します。この設定によって、VSphere Client は VMware vSphere Hypervisor TM と通信できるようになります。このインターフェイスは sm slot /1 です。

Cisco SRE サービス モジュールの外面には、3 つめのギガビット イーサネット インターフェイスが搭載されています。このギガビット イーサネット インターフェイスは、VMware vSphere Hypervisor TM によって設定および管理されます。

図 A-1 を参照してください。

図 A-1 ホスト ルータおよび Cisco SRE サービス モジュール インターフェイス

 

引き出し線
場所
Cisco SRE サービス モジュール インターフェイス
スロットおよびポート
IP アドレスの設定
設定元
1

PCIe リンク

サービス モジュール インターフェイス

slot /0

インターフェイスのルータ側の IP アドレス

例:

Router(config-if)# ip address 10.0.0.1 255.255.255.0

Cisco IOS CLI

2

インターフェイスのモジュール側の IP アドレス

例:

Router(config-if)# service-module ip address 10.0.0.2 255.255.255.0

3

MGF リンク

MGF インターフェイス
(仮想マシンを管理するためのモジュール インターフェイス)

slot /1

インターフェイスのルータ側の IP アドレス

例:

Router(config-if)# ip address 10.10.10.1 255.255.255.0

Cisco IOS CLI

4

インターフェイスのモジュール側の IP アドレス

例:

Router(config-if)# service-module ip address 10.10.10.2 255.255.255.0

5

モジュールの前面プレート

外部インターフェイス
(外部リンクへのモジュール インターフェイス)

--

--

VMware vSphere Hypervisor TM

詳細については、次の項を参照してください。

「サービス モジュール インターフェイス」

「MGF インターフェイス」

「外部サービス モジュール インターフェイス」

サービス モジュール インターフェイス

サービス モジュール インターフェイスは、設定のためのサービス モジュール コンソールにアクセスするために使用されます。ホスト ルータ上の Cisco IOS ソフトウェアにだけ表示されるサービス モジュール インターフェイスは、ルータと Cisco SRE サービス モジュールとの間の内部 GE インターフェイスになります。サービス モジュール インターフェイスはルータの PCIe と接続し、サービス モジュール インターフェイスのすべての設定と管理は Cisco IOS CLI を使用して行われます。

MGF インターフェイス

MGF インターフェイスによって、ホスト ルータに装着された 1 つ以上のサービス モジュールと Cisco SRE サービス モジュールとの通信が可能になります。MGF インターフェイスの設定は、Cisco IOS CLI で実行します。Cisco SRE サービス モジュールで実行中のシスコ認定アプリケーションによって、接続が管理されます。MGF の設定の詳細については、Cisco.com にある『 Cisco 3900 Series, 2900 Series, and 1900 Series Integrated Services Routers Software Configuration Guide 』の「Multi-Gigabit Fabric on the Router」の章を参照してください。

外部サービス モジュール インターフェイス

外部サービス モジュール インターフェイスをバックアップ インターフェイスとして使用して、VMware vSphere Hypervisor を直接 LAN に接続できます。内部インターフェイスとは異なり、外部インターフェイスは主に VMware vSphere Hypervisor によって制御および管理されます。VMware vSphere Hypervisor が、MGF インターフェイスを介してトラフィックをルータに転送するように設定されていない限り、トラフィックはルータに到達しません。

Cisco SRE サービス モジュール インターフェイスの設定

ここでは、Cisco IOS CLI を使用した Cisco SRE サービス モジュールの基本的なネットワーク パラメータの設定方法について説明します。次の事項について説明します。

「Cisco SRE サービス モジュール インターフェイスを設定するための前提条件」

「ルータ上でのサービス モジュール インターフェイスの設定」

「モジュール上の MGF インターフェイスの設定」

Cisco SRE サービス モジュール インターフェイスを設定するための前提条件

Cisco ルータの前提条件

Cisco ルータで適切な Cisco IOS ソフトウェア バージョンが実行され、Cisco SRE サービス モジュールが認識されることを確認します。

Cisco SRE サービス モジュールの前提条件


) ほとんどの場合、ルータは、内部に Cisco SRE サービス モジュールがすでに取り付けられた状態で出荷されます。


ホスト ルータ上の Cisco SRE サービス モジュール スロットの位置を確認してください。

slot Cisco SRE サービス モジュールが装着されているホスト ルータ シャーシ スロットの ID。この情報は、モジュールを装着した後で Cisco IOS ソフトウェア CLI の show running-config コマンドを使用して取得できます。

port :Cisco SRE サービス モジュール上の Network Interface Card(NIC; ネットワーク インターフェイス カード)の ID。PCIe インターフェイスの場合の値は 0、MGF インターフェイスの場合は 1 です。

FTP/SFTP/HTTP サーバの前提条件

新しいイメージをダウンロードする必要がある場合は、FTP、Secure FTP(SFTP)、または HTTP の各サーバにアクセスします。

FTP/SFTP/HTTP サーバがアクセス可能であることを確認します。

ルータ上でのサービス モジュール インターフェイスの設定

Cisco SRE サービス モジュールとホスト ルータとの間の内部インターフェイスを設定します。この初期設定が完了すれば、サービス モジュールにアクセスして、Cisco SRE-V アプリケーションのインストールおよび設定ができるようになります。

手順の概要

ホスト ルータ CLI での手順

1. enable

2. configure terminal

3. interface sm slot /0

4. ip address router-side-ip-address subnet-mask
または
ip unnumbered type number

5. service-module ip address module-side-ip-address subnet-mask

6. service-module ip default-gateway gateway-ip-address

7. no shut

8. end

9. copy running-config startup-config

10. show running-config

手順の詳細

コマンドまたは操作
目的
 
ホスト ルータ CLI での手順

ステップ 1

enable

<password>

 

Router> enable

Router> <password>

Router#

ホスト ルータ上で特権 EXEC モードを開始します。パスワードの入力を求められた場合は入力します。

ステップ 2

configure terminal

 

Router# configure terminal

ホスト ルータ上でグローバル コンフィギュレーション モードを開始します。

ステップ 3

interface sm slot /0

 

Router(config)# interface sm 1/0

Cisco SRE サービス モジュールが装着されたスロットとポート用のインターフェイス コンフィギュレーション モードを開始します。

ステップ 4

ip address router-side-ip-address subnet-mask

 

または

ip unnumbered type number

exit

ip route service-module-ip-address subnet-mask sm slot /0

 

Router(config-if)# ip address 10.0.0.1 255.255.255.0

 

または

Router(config-if)# ip unnumbered gigabitethernet 1/0

Router(config-if)# exit

Router(config)# ip route 192.168.100.60 255.255.255.255 SM1/0

インターフェイスのルータ側の IP アドレスを指定します。

router-side-ip-address subnet-mask :ルータの IP アドレスとサブネット マスクを示します。

または

インターフェイスに対して明示的に IP アドレスを割り当てなくても、インターフェイス上で IP 処理できるようにします。

type :割り当てられた IP アドレスをルータが保持しているインターフェイスのタイプを示します。

number :割り当てられた IP アドレスをルータが保持しているインターフェイスの番号を示します。

(注) アンナンバード インターフェイスを別のアンナンバード インターフェイスにはできません。

インターフェイス モードを終了してから、 ip route コマンドを入力します。

service-module-ip-address subnet-mask :サービス モジュールの IP アドレスとサブネット マスク。

slot/0 :Cisco SRE サービス モジュールが装着されているスロットとポート。

ステップ 5

service-module ip address module-side-ip-address subnet-mask

 

Router(config-if)# service-module ip address 10.0.0.2 255.255.255.0

インターフェイスのモジュール側の IP アドレスを指定します。

module-side-ip-address :モジュールの IP アドレスを示します。

subnet-mask :IP アドレスにアペンドするサブネット マスクを示します。ホスト ルータと同じサブネット内にある必要があります。

ステップ 6

service-module ip default-gateway gateway-ip-address

 

Router(config-if)# service-module ip default-gateway 10.0.0.1

モジュールのデフォルト ゲートウェイの IP アドレスを指定します。

gateway-ip-address :デフォルト ルータの IP アドレスを示します。

ステップ 7

no shut

 

Router# no shut

インターフェイスが管理上のダウン状態になります。

ステップ 8

end

 

Router(config-if)# end

ホスト ルータ上でグローバル コンフィギュレーション モードに戻ります。

ステップ 9

copy running-config startup-config

 

Router# copy running-config startup-config

ルータの新しい実行コンフィギュレーションをスタートアップ コンフィギュレーションとして保存します。

ステップ 10

show running-config

 

Router# show running-config

アドレス設定を確認できるように、ルータの実行コンフィギュレーションを表示します。

次に、Cisco SRE サービス モジュールとルータとの間の内部インターフェイスの設定例を示します。

interface SM1/0
ip address 10.0.0.1 255.255.255.0
service-module ip address 10.0.0.2 255.255.255.0
service-module ip default-gateway 10.0.0.1

モジュール上の MGF インターフェイスの設定

Cisco 3900 シリーズおよび 2900 シリーズの ISR G2 は、MGF インターフェイスを使用してルータと相互通信します。次世代のモジュール ドライバは MGF と統合し、ポート設定の実行、パケット フローの設定、およびトラフィック バッファリングの制御を行います。

手順の概要

ホスト ルータ CLI での手順

1. enable

2. configure terminal

3. interface sm slot /1

4. ip address router-side-ip-address subnet-mask

5. service-module ip address module-side-ip-address subnet-mask

6. end

7. copy running-config startup-config

8. service module sm slot /0 session

コンソール マネージャ インターフェイスでの手順

9. hypervisor set ip default-gateway module-side-ip-address

10. Control と Alt を押した状態で 6 x を押します。

手順の詳細

コマンドまたは操作
目的
 
ホスト ルータ CLI での手順

ステップ 1

enable

<password>

 

Router> enable

Router> <password>

Router#

ホスト ルータ上で特権 EXEC モードを開始します。パスワードの入力を求められた場合は入力します。

ステップ 2

configure terminal

 

Router# configure terminal

ホスト ルータ上でグローバル コンフィギュレーション モードを開始します。

ステップ 3

interface sm slot /1

 

Router(config)# interface sm 1/1

Cisco SRE サービス モジュールが装着されたスロットとポート用のインターフェイス コンフィギュレーション モードを開始します。

ステップ 4

ip address router-side-ip-address subnet-mask

 

Router(config-if)# ip address 10.10.10.1 255.255.255.0

インターフェイスのルータ側の IP アドレスを指定します。

router-side-ip-address subnet-mask :ルータの IP アドレスとサブネット マスクを示します。

ステップ 5

service-module ip address module-side-ip-address subnet-mask

 

Router(config-if)# service-module ip address 10.10.10.2 255.255.255.0

インターフェイスのモジュール側の IP アドレスを指定します。

module-side-ip-address :モジュールの IP アドレスを示します。

subnet-mask :IP アドレスにアペンドするサブネット マスクを示します。ホスト ルータと同じサブネット内にある必要があります。

ステップ 6

end

 

Router(config-if)# end

ホスト ルータ上でグローバル コンフィギュレーション モードに戻ります。

ステップ 7

copy running-config startup-config

 

Router# copy running-config startup-config

ルータの新しい実行コンフィギュレーションをスタートアップ コンフィギュレーションとして保存します。

ステップ 8

service module sm slot /0 session

 

Router# service module sm 1/0 session

Trying 10.0.0.1, 2065 .. Open

Cisco SRE サービス モジュールでセッションを開始します。コンフィギュレーション セッションを開始するには、Enter を押します。

 
コンソール マネージャ インターフェイスでの手順 EXEC モードでコマンドを入力します。

ステップ 9

hypervisor set ip default-gateway router-side-ip-address

例:

SRE-Module# hypervisor set ip default-gateway 10.10.10.1

VMware vSphere Hypervisor が VSphere クライアントとの通信に使用するデフォルト ゲートウェイの IP アドレスを指定します。

router-side-ip-address :インターフェイスのルータ側に設定されている IP アドレス。ステップ 4 を参照してください。

ステップ 10

Control と Alt を押した状態で 6 x を押します。

サービス モジュール セッションを終了し、ホスト ルータ CLI に戻ります。

を押すことで、このセッションにルータ CLI から戻ることができます。

次に、Cisco SRE サービス モジュールと MGF との間のインターフェイスの設定例を示します。

interface SM1/1

ip address 10.10.10.1 255.255.255.0

service-module ip address 10.10.10.2 255.255.255.0