Cisco UCS E シリーズ サーバ スタートアップ ガイド リリース 2.x
ルータと E シリーズ サーバ間の接続の設定
ルータと E シリーズ サーバ間の接続の設定
発行日;2014/01/08   |   ドキュメントご利用ガイド   |   ダウンロード ;   この章 pdf   ,   ドキュメント全体 pdf    |   フィードバック

ルータと E シリーズ サーバ間の接続の設定

この章では、ISR G2 と E シリーズ サーバ間、および Cisco ISR 4451-XE シリーズ サーバ間の内部接続を設定するための手順について説明します。 ここで説明する内容は、次のとおりです。

ISR G2 と E シリーズ サーバ間の内部接続の設定

アプリケーションまたはオペレーティング システムに対するトラフィックを ISR G2 経由にするには、次の設定を使用します。 ISR G2 と E シリーズ サーバ間の内部接続を設定するには、これらの IP アドレスを設定する必要があります。
  • トラフィックを PCIe 接続経由にするには(次の図を参照)、次のように設定します。
    • ルータを E シリーズ サーバの GE0 インターフェイスに接続するルータの内部 PCIe インターフェイスの IP アドレス。
    • E シリーズ サーバの GE0 インターフェイスの IP アドレス。
  • トラフィックを MGF 接続経由にするには(次の図を参照)、次のように設定します。
    • ルータの内部 MGF VLAN インターフェイスの IP アドレス。
    • E シリーズ サーバの GE1 インターフェイスの IP アドレス。

次の図は、ルータと E シリーズ サーバ間の内部接続を示しています。

図 1. ISR G2 と E シリーズ サーバ 間の内部接続

手順
     コマンドまたはアクション目的
    ステップ 1Router> enable  

    ホスト ルータで特権 EXEC モードを開始します。 パスワードを入力します(要求された場合)。

     
    ステップ 2Router# configure terminal  

    ホスト ルータでグローバル コンフィギュレーション モードを開始します。

     
    ステップ 3 Router (config)# interface ucse slot/0  

    ルータの PCIe slot/0 インターフェイスの ucse インターフェイス コンフィギュレーション モードを開始します。

     
    ステップ 4次のいずれかのコマンドを入力します。
    • Router (config-if)# ip address router-to-e-series-server-interface-ip-address subnet mask
    • Router (config-if)# ip unnumbered type number
     

    ip address コマンドで、ルータを E シリーズ サーバの GE0 インターフェイスに接続する内部 PCIe インターフェイスの IP アドレスを指定します。 上の図を参照してください。

    または

    (任意)ip unnumbered コマンドは、インターフェイスに明示的な IP アドレスを割り当てずに、そのインターフェイス上での IP 処理をイネーブルにします。

    • type:割り当てられた IP アドレスをルータが保持しているインターフェイスのタイプ。
    • number:割り当てられた IP アドレスをルータが保持しているインターフェイスの番号。
    (注)     

    アンナンバード インターフェイスは、一意である必要があります。 番号付けされていない別のインターフェイスは指定できません。

    注意       

    ip unnumbered コマンドでは、デバイス間のポイントツーポイント インターフェイスが作成されます。 ブロードキャストはサポートされません。

     
    ステップ 5Router (config-if)# no shut  

    インターフェイスが管理上のアップ状態になります。

     
    ステップ 6Router (config-if)# end  

    コンフィギュレーション モードを終了します。

     
    ステップ 7サーバのオペレーティング システムを使用して E シリーズ サーバGE0 インターフェイスを設定します。 上の図を参照してください。 

     
    ステップ 8 Router (config)# interface ucse slot/1  

    ルータの MGF slot/1 VLAN インターフェイスの ucse インターフェイス コンフィギュレーション モードを開始します。 上の図を参照してください。

     
    ステップ 9 Router (config-if)# switchport mode trunk  

    ポートを永続的なトランキング モードにします。 デフォルトの設定は、アクセス モードです。

     
    ステップ 10 Router (config-if)# [switchport trunk allowed vlan vlan-numbers]  

    (任意)指定した VLAN 上でのトランキングを許可します。

    • vlan-numbers:トランキングを許可する VLAN 数。
     
    ステップ 11Router (config-if)# exit  

    インターフェイス コンフィギュレーション モードを終了します。

     
    ステップ 12Router# configure terminal  

    ホスト ルータでグローバル コンフィギュレーション モードを開始します。

     
    ステップ 13 Router (config)# interface vlan vlan-number  

    指定した VLAN 番号の VLAN コンフィギュレーション モードを開始します。

     
    ステップ 14 Router (config-if)# ip address vlan-ip-address subnet-mask  

    VLAN の IP アドレスを指定します。 上の図を参照してください。

    • vlan-ip-address:VLAN の IP アドレス。
    • subnet-mask:IP アドレスに付加するサブネット マスク。
     
    ステップ 15Router (config-if)# no shut  

    インターフェイスが管理上のアップ状態になります。

     
    ステップ 16Router (config-if)# end  

    コンフィギュレーション モードを終了します。

     
    ステップ 17サーバのオペレーティング システムを使用して E シリーズ サーバGE1 インターフェイスを設定します。 上の図を参照してください。 

     
    ステップ 18Router# show running-config  

    アドレス設定を確認できるように、ルータの実行コンフィギュレーションを表示します。

     

    次の例は、ルータと E シリーズ サーバ間の内部接続を設定する方法を示しています。


    (注)  


    この設定例の IP アドレスは参照用に示しただけなので、実際には有効でない可能性があります。


    Router> enable
    Router# configure terminal
    
    Router(config)# interface ucse 1/0
    Router(config-if)# ip address 10.0.0.1 255.0.0.0
    Router(config-if)# no shut
    Router(config-if)# end
    
    Use the server’s operating system to configure the E-Series Server’s GE0 interface
    
    Router(config)# interface ucse 1/1
    Router(config-if)# switchport mode trunk
    Router(config-if)# exit
    
    Router# configure terminal
    Router(config)# interface vlan 1
    Router(config-if)# ip address 20.0.0.1 255.255.255.0
    Router(config-if)# no shut
    Router(config-if)# end
    
    Use the server’s operating system to configure the E-Series Server’s GE1 interface.
    
    Router# show running-config
    

    Cisco ISR 4451-X と E シリーズ サーバ間の内部接続の設定

    アプリケーションまたはオペレーティング システムに対するトラフィックを Cisco ISR 4451-X 経由にする場合はこの設定を使用します。 Cisco ISR 4451-XE シリーズ サーバ間に内部接続を設定するには、これらの IP アドレスを設定する必要があります。
    • ルータの ucse slot/0/0E シリーズ サーバの内部 GE0 インターフェイスを経由するトラフィック(次の図を参照)では、次のように設定します。
      • ルータを E シリーズ サーバの GE0 インターフェイスに接続する、ルータの ucse slot/0/0 インターフェイスの IP アドレス。
      • E シリーズ サーバの GE0 インターフェイスの IP アドレス。
    • ルータの ucse slot/0/1E シリーズ サーバの内部 GE1 インターフェイスを経由するトラフィック(次の図を参照)では、次のように設定します。
      • ルータの ucse slot/0/1 インターフェイスの IP アドレス。
      • E シリーズ サーバの GE1 インターフェイスの IP アドレス。

    次の図は、ルータと E シリーズ サーバ間の内部接続を示しています。

    図 2. Cisco ISR 4451-XE シリーズ サーバ間の内部接続

    手順
       コマンドまたはアクション目的
      ステップ 1Router> enable  

      ホスト ルータで特権 EXEC モードを開始します。 パスワードを入力します(要求された場合)。

       
      ステップ 2Router# configure terminal  

      ホスト ルータでグローバル コンフィギュレーション モードを開始します。

       
      ステップ 3 Router (config)# interface ucse slot/0/0  

      ルータの ucse slot/0/0インターフェイスのインターフェイス コンフィギュレーション モードを開始します。

       
      ステップ 4次のいずれかのコマンドを入力します。
      • Router (config-if)# ip address router-to-e-series-server-interface-ip-address subnet-mask
      • Router (config-if)# ip unnumbered type number
       

      ルータを E シリーズ サーバの GE0 インターフェイスに接続する、ルータの ucse slot 0/0 インターフェイスの IP アドレスを指定します。 上の図を参照してください。

      または

      (任意)ip unnumbered コマンドは、インターフェイスに明示的な IP アドレスを割り当てずに、そのインターフェイス上での IP 処理をイネーブルにします。

      • type:割り当てられた IP アドレスをルータが保持しているインターフェイスのタイプ。
      • number:割り当てられた IP アドレスをルータが保持しているインターフェイスの番号。
      (注)     

      アンナンバード インターフェイスは、一意である必要があります。 番号付けされていない別のインターフェイスは指定できません。

      注意       

      ip unnumbered コマンドでは、デバイス間のポイントツーポイント インターフェイスが作成されます。 ブロードキャストはサポートされません。

       
      ステップ 5Router (config-if)# no shut  

      インターフェイスが管理上のアップ状態になります。

       
      ステップ 6Router (config-if)# end  

      コンフィギュレーション モードを終了します。

       
      ステップ 7サーバのオペレーティング システムを使用して E シリーズ サーバGE0 インターフェイスを設定します。 上の図を参照してください。 

       
      ステップ 8 Router (config)# interface ucse slot/0/1  

      ルータの ucse slot/0/1 インターフェイスの ucse インターフェイス コンフィギュレーション モードを開始します。 上の図を参照してください。

       
      ステップ 9Router (config-if)# no shut  

      インターフェイスが管理上のアップ状態になります。

       
      ステップ 10Router (config-if)# end  

      コンフィギュレーション モードを終了します。

       
      ステップ 11サーバのオペレーティング システムを使用して E シリーズ サーバGE1 インターフェイスを設定します。 上の図を参照してください。 

       
      ステップ 12Router# show running-config  

      アドレス設定を確認できるように、ルータの実行コンフィギュレーションを表示します。

       

      次の例は、ルータと E シリーズ サーバ間の内部接続を設定する方法を示しています。


      (注)  


      この設定例の IP アドレスは参照用に示しただけなので、実際には有効でない可能性があります。


      Router> enable
      Router# configure terminal
      
      Router(config)# interface ucse 1/0/0
      Router(config-if)# ip address 10.0.0.1 255.0.0.0
      Router(config-if)# no shut
      Router(config-if)# end
      
      Use the server's operating system to configure the E-Series Server's GE0 interface.
      
      Router(config)# interface ucse 1/0/1
      Router(config-if)# ip address 11.0.0.1 255.255.255.0
      Router(config-if)# no shut
      Router(config-if)# end
      
      Use the server's operating system to configure the E-Series Server's GE1 interface.
      
      Router# show running-config
      

      サービス インスタンスの作成およびサービス インスタンスのブリッジ インターフェイスへのバインド:Cisco ISR 4451-X

      選択したデータをカプセル化し、E シリーズ サーバにインストールされたオペレーティング システムまたはインストールされたハイパーバイザで作成された仮想マシンに転送するために VLAN を追加している場合は、この手順を使用します。

      はじめる前に

      Cisco ISR 4451-XE シリーズ サーバ間の内部接続を設定します。

      手順
         コマンドまたはアクション目的
        ステップ 1Router> enable  

        ホスト ルータで特権 EXEC モードを開始します。 パスワードを入力します(要求された場合)。

         
        ステップ 2Router# configure terminal  

        ホスト ルータでグローバル コンフィギュレーション モードを開始します。

         
        ステップ 3 Router (config)# interface ucse slot/0/0  

        ルータの ucseslot/0/0 インターフェイスの ucse インターフェイス コンフィギュレーション モードを開始します。

         
        ステップ 4Router (config-if)# service instance id ethernet  

        インターフェイスでイーサネット サービス インスタンスを設定し、イーサネット サービス コンフィギュレーション モードを開始します。

         
        ステップ 5Router (config-if)# encapsulation encapsulation-type vlan-id  

        カプセル化タイプを定義します。

         
        ステップ 6Router (config-if)# bridge-domain bridge-id  

        ブリッジ ドメインを設定します。

         
        ステップ 7Router (config-if)# exit  

        ホスト ルータのグローバル コンフィギュレーション モードに戻ります。

         
        ステップ 8 Router (config)# interface BDI bridge-id  

        ブリッジ ドメイン インターフェイスを入力します。

         
        ステップ 9Router (config-if)# ip address router-to-e-series-server-interface-ip-address subnet-mask 

        ルータを E シリーズ サーバの GE0 インターフェイスに接続する、ルータの ucse slot 0/0 インターフェイスの IP アドレスを指定します。 上の図を参照してください。

         
        ステップ 10Router (config-if)# end  

        ホスト ルータのグローバル コンフィギュレーション モードに戻ります。

         
        ステップ 11 サーバのオペレーティング システムを使用して E シリーズ サーバGE0 インターフェイスを設定します。 上の図を参照してください。 

         
        ステップ 12Router# show running-config  

        アドレス設定を確認できるように、ルータの実行コンフィギュレーションを表示します。

         

        次に、サービス インスタンスを作成してブリッジ インターフェイスにバインドする方法を示します。


        (注)  


        この設定例の IP アドレスは参照用に示しただけなので、実際には有効でない可能性があります。


        Router> enable
        Router# configure terminal
        
        Router(config)# interface ucse 1/0/0
        Router(config-if)# service instance 1 ethernet
        Router(config-if)# encapsulation untagged
        Router(config-if)# bridge-domain 1
        Router(config-if)# exit
        
        Router(config)# interface BDI 1
        Router(config-if)# ip address 10.0.0.1 255.0.0.0
        Router(config-if)# end
        
        Use the server's operating system to configure the E-Series Server's GE0 interface.
        
        Router# show running-config
        

        (注)  


        http:/​/​www.cisco.com/​en/​US/​docs/​ios-xml/​ios/​cether/​configuration/​xe-3s/​ce-ether-vc-infra-xe.html#GUID-235129F5-A32F-473C-B1C0-ADD8016BF298 で手順を参照することもできます。


        ネットワーク インターフェイス マッピングの概要

        このセクションでは、次のデバイスのネットワーク インターフェイス マッピングを決定する方法について説明します。

        • E シリーズ サーバのコンソール、GE1、GE2、および GE3 インターフェイス:ISR G2
        • E シリーズ サーバの GE0、GE1、GE2、および GE3 インターフェイス:Cisco ISR 4451-X
        • NetXtreme II 1 Gigabit Server(PCIe カード)
        • NetXtreme II 10 Gigabit Server(PCIe カード)

        E シリーズ サーバのコンソール、GE1、GE2、および GE3 インターフェイスのネットワーク インターフェイス マッピングの決定:ISR G2

        ネットワーク インターフェイスの MAC アドレスを見ると、E シリーズ サーバ のポートの番号付けを決定できます。 次の点に注意してください。

        • 番号が最も小さい MAC アドレスは、ルータのコンソール インターフェイスに対応します。
        • 2 番目に小さい MAC アドレスは、E シリーズ サーバ の GE1 インターフェイスです。
        • 3 番目に小さい MAC アドレスは、E シリーズ サーバ の GE2 インターフェイスです。
        • 4 番目に小さい MAC アドレスは、E シリーズ サーバ の GE3 インターフェイスです。

        (注)  


        インターフェイスの MAC アドレスを決定するには、Microsoft Windows、Linux、および VMware vSphere Hypervisor の MAC アドレスの決定、または適切なプラットフォームのドキュメントを参照してください。


        E シリーズ サーバの GE0、GE1、GE2、および GE3 インターフェイスのネットワーク インターフェイス マッピングの決定:Cisco ISR 4451-X

        ネットワーク インターフェイスの MAC アドレスを見ると、E シリーズ サーバ のポートの番号付けを決定できます。 次の点に注意してください。

        • 番号が最も小さい MAC アドレスは、E シリーズ サーバの GE0 インターフェイスに対応します。
        • 2 番目に小さい MAC アドレスは、E シリーズ サーバ の GE1 インターフェイスです。
        • 3 番目に小さい MAC アドレスは、E シリーズ サーバ の GE2 インターフェイスです。
        • 4 番目に小さい MAC アドレスは、E シリーズ サーバ の GE3 インターフェイスです。

        (注)  


        インターフェイスの MAC アドレスを決定するには、Microsoft Windows、Linux、および VMware vSphere Hypervisor の MAC アドレスの決定、または適切なプラットフォームのドキュメントを参照してください。


        NetXtreme II 1 Gigabit Server のインターフェイス名とポート マッピングの決定

        NetXtreme II 1 Gigabit Server(PCIe カード)のインターフェイス名とポート番号のマッピングを決定するには、次の操作を実行します。
        1. ネットワーク ケーブルを使用して外部ネットワーク デバイスに PCIe カードのポート 0 を接続します。
        2. ホスト オペレーティング システムからインターフェイスのステータスをチェックし、接続されているインターフェイスを確認します。
        3. ポート 1、2、3 に対して手順 2 を繰り返します。

        (注)  


        インターフェイスのステータスを確認する方法については、適切なオペレーティング システムのドキュメントを参照してください。


        NetXtreme II 10 Gigabit Server のインターフェイス名とポート マッピングの決定


        (注)  


        NetXtreme II 10 Gigabit Server(PCIe カード)では 1 つのポートのみイネーブルになっています。


        NetXtreme II 10 Gigabit Server(PCIe カード)のインターフェイス名とポート番号のマッピングを決定するには、次の操作を実行します。

        1. ネットワーク ケーブルを使用して外部ネットワーク デバイスに PCIe カードのポート 0 を接続します。
        2. ホスト オペレーティング システムからインターフェイスのステータスをチェックし、接続されているインターフェイスを確認します。

        (注)  


        インターフェイスのステータスを確認する方法については、適切なオペレーティング システムのドキュメントを参照してください。


        Microsoft Windows、Linux、および VMware vSphere Hypervisor の MAC アドレスの決定

        このセクションでは、Microsoft Windows、Linux、および VMware vSphere Hypervisor™ の MAC アドレスを決定する方法を示します。

        Microsoft Windows オペレーティング システムの MAC アドレスの決定

        Microsoft Windows オペレーティング システムのインターフェイスの MAC アドレスを決定するには、コマンド ウィンドウを開き、ipconfig /all コマンドを入力します。

        Linux オペレーティング システムの MAC アドレスの決定

        Linux オペレーティング システムでインターフェイスの MAC アドレスを決定するには、ターミナル ウィンドウを開き、ifconfig -a コマンドを入力してすべてのインターフェイスの MAC アドレスを表示するか、ifconfig interface-name コマンドを入力して特定のインターフェイスの MAC アドレスを表示します。

        VMware vSphere Hypervisor の MAC アドレスの決定

        VMware vSphere Hypervisor™ のインターフェイスの MAC アドレスを決定するには、次の操作を実行します。

        1. Web ブラウザで、最初のセットアップ時に CIMC にアクセスするために設定した IP アドレスを入力して、CIMC にログインします。 CIMC のホーム ページである [Server Summary] ページが表示されます。
        2. [Server Summary] ページの [Actions] 領域にある [Launch KVM Console] アイコンをクリックします。 [KVM Console] が別ウィンドウで開きます。
        3. [KVM Console] で [KVM] タブをクリックし、次の操作を実行します。
          • F2 を押して VMware vSphere Hypervisor™ の DCUI カスタマイズ メニューにアクセスします。 [DCUI] ログイン ページが表示されます。
          • [DCUI] にログインします。 [System Customization] ページが表示されます。
          • [System Customization] ページの [Configure Management Network] をクリックします。 [Configure Management Network] ページが表示されます。このページには、[Network Adapter] などいくつかのメニュー オプションがあります。 [Network Adapter] メニュー オプションを使用すると、インターフェイスの MAC アドレスを表示できます。