IP : Cisco IOS と NX-OS ソフトウェア

MPLS VPN over mGRE

MPLS VPN over mGRE
発行日;2012/01/21 | 英語版ドキュメント(2011/09/27 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf | フィードバック

目次

MPLS VPN over mGRE

機能情報の検索

マニュアルの内容

MPLS VPN over mGRE の前提条件

MPLS VPN over mGRE の制約事項

MPLS VPN over mGRE について

MPLS VPN over mGRE

ルート マップ

トンネル エンドポイントの検出およびフォワーディング

トンネルの非カプセル化

トンネル送信元

IPv6 VPN

MPLS VPN over mGRE の設定方法

L3VPN カプセル化プロファイルの設定

BGP およびルート マップの設定

MPLS VPN over mGRE の設定例

MPLS VPN over mGRE 設定の確認:例

MPLS VPN over mGRE の設定の流れ:例

参考資料

関連資料

規格

MIB

RFC

シスコのテクニカル サポート

MPLS VPN over mGRE の機能情報

MPLS VPN over mGRE

 

MPLS VPN over mGRE 機能では、IP 専用ネットワークによって接続されている各ネットワーク間の MPLS 接続を提供することによって、通信事業者が Multiprotocol Label Switching(MPLS; マルチプロトコル ラベル スイッチング)をサポートしていなければならないという要件を克服しています。これにより、MPLS Label Switched Path(LSP; ラベル スイッチド パス)が、Generic Routing Encapsulation(GRE)トンネルを使用して、ルーティング エリア、自律システム、および Internet service provider(ISP; インターネット サービス プロバイダー)を横断することが可能になります。MPLS VPN を Multipoint Generic Routing Encapsulation(mGRE)を介して設定すると、標準ベース IP コアを使用して Layer-3(L3; レイヤ 3)Provider Edge(PE; プロバイダー エッジ)ベースの Virtual Private Network(VPN; 仮想プライベート ネットワーク)を配置できます。これにより、オーバーレイ方式を使用しないで VPN サービスをプロビジョニングできます。

機能情報の検索

ご使用のソフトウェア リリースでは、このモジュールで説明されているすべての機能がサポートされているとは限りません。最新の機能情報および警告については、ご使用のプラットフォームおよびソフトウェア リリースのリリースノートを参照してください。このモジュールに記載されている機能に関する情報を検索したり、各機能がサポートされているリリースに関するリストを参照したりするには、「MPLS VPN over mGRE の機能情報」を参照してください。

プラットフォームのサポートおよび Cisco IOS と Catalyst OS ソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスしてください。Cisco.com のアカウントは必要ありません。

MPLS VPN over mGRE の前提条件

マルチポイント GRE トンネルを使用して MPLS VPN を設定する前に、MPLS VPN が設定されていて、正しく動作していることを確認してください。MPLS VPN の設定については、『 Configuring MPLS Layer 3 VPNs 』マニュアルを参照してください。

MPLS VPN over mGRE の制約事項

MPLS VPN over mGRE は、ES-40 ライン カードおよび SIP 400 ライン カードが前面を向いた中心的なカードとして使用されている Cisco 7600 シリーズ ルータ上でサポートされている。

トンネル型タグ トラフィックは、MPLS VPN over mGRE がサポートされているライン カードを介してルータにアクセスする必要がある。サポート対象ライン カードは、ES-40 および SIP-400。

各 PE ルータでサポートされるトンネル コンフィギュレーションは 1 つだけ。

MPLS VPN over mGRE では、VPN 間におけるマルチキャスト トラフィックの転送はサポートされていない。

GRE トンネルの宛先アドレスおよび送信元アドレスが mGRE と同じである場合、トンネルによってルートキャッシュが切り替えられる。

フラグメンテーションが必要なパケットによって、ルートキャッシュが切り替えられる。

L3VPN プロファイルが、いったん削除して後で戻す場合、 clear ip bgp soft コマンドを使用して、BGP をクリアする必要がある。

mGRE トンネルが作成されると、ダミー トンネルも作成される。

BGP コンフィギュレーションのアップデート元で使用されるループバックまたは IP アドレスは、L3VPN プロファイルの送信元と同じである必要がある。

mGRE は、Stateful Switchover(SSO)には対応していない。ただし、mGRE と SSO の両方が共存している。

MPLS VPN over mGRE 機能の制限事項は、以下のとおりです。

ハードウェア内で、すべての GRE オプションがサポートされているわけではない(GRE 拡張ヘッダーや GRE キーなど)。

トンネル上では、複数の同一 VLAN(Internet Control Message Protocol(ICMP; インターネット制御メッセージ プロトコル)リダイレクト)のチェックはサポートされていない。

トンネル上では、Unicast Reverse Path Forwarding(uRPF)や BGP ポリシー アカウントなどの機能はサポートされていない。

MPLS VPN over mGRE について

mGRE トンネルを設定して、IP バックボーンをオーバーレイするマルチポイント トンネル ネットワークを作成できます。このオーバーレイによって、VPN トラフィックを転送するために各 PE ルータ同士が接続されます。

さらに、MPLS VPN を mGRE を介して設定すると、標準ベースの IP コアを使用して、L3 PE ベースの VPN サービスを導入できます。これにより、オーバーレイ方式を使用しないで VPN サービスをプロビジョニングできます。MPLS VPN over mGRE が設定されると、システムでは、PE 間の VPN ラベル IPv4 および IPv6 パケットのカプセル化に IPv4 ベースの mGRE トンネルが使用されます。

MPLS VPN over mGRE 機能を設定するには、次の概念について理解する必要があります。

「MPLS VPN over mGRE」

MPLS VPN over mGRE

GRE とは、ポイントツーポイント トンネリング プロトコルの 1 つであり、2 つのピアがトンネルのエンドポイントとなります。GRE は、ネットワーク層のパケットを IP トンネリング パケット内にカプセル化するように設計されています。mGRE は、GRE と類似したプロトコルですが、トンネルの片方は単一のエンドポイントで、それがトンネルのもう片方にある複数のエンドポイントに接続されています。mGRE トンネルによって、同じ VPN に接続された各支社間が共通のリンクを使用できるようになります。mGRE は、ポイントツーマルチポイント モデルなので、各 MPLS VPN PE デバイスを相互接続するうえでフル メッシュ構造の GRE トンネルは不要です。

MPLS は、広く採用されている VPN インターネット アキーテクチャです。MPLS では、ネットワーク内のすべてのコア ルータで MPLS がサポートされていることが必要です。この機能は、サービス プロバイダーがバックボーン キャリアを使用して接続を提供しているネットワークで有用です。

MPLS VPN over mGRE 機能では、IP 専用ネットワークによって接続されている各ネットワーク間で MPLS 接続を可能にすることによって、通信事業者が MPLS をサポートしていなければならないという要件を克服しています。これにより、MPLS LSP が、GRE トンネルを使用して、ルーティング エリア、自律システム、および ISP を横断することが可能になります。

mGRE を介して MPLS VPN を設定すると、標準ベースの IP コアを使用して、L3 PE ベースの VPN サービスを導入できます。これにより、LSP や Label Distribution Protocol(LDP; ラベル配布プロトコル)オーバーレイ方式を使用しないで VPN サービスをプロビジョニングできます。システムでは、PE 間の VPN ラベル IPv4 および IPv6 パケットのカプセル化に IPv4 ベースの mGRE トンネルが使用されます。

また、MPLS VPN over mGRE 機能によって、既存の MPLS VPN LSP カプセル化テクノロジーを、MPLS VPN over mGRE と同時に導入し、特定のトラフィックをルーティングするために使用されるカプセル化方式が自動的に決定されるようにすることも可能です。入力 PE ルータによって、パケットがリモート PE ルータに送信されるときに使用されるカプセル化テクノロジーが決定されます。

ここでは、MPLS VPN over mGRE 機能に関する次の項目について説明します。

「ルート マップ」

「トンネル エンドポイントの検出およびフォワーディング」

「トンネルの非カプセル化」

「トンネル送信元」

「IPv6 VPN」

ルート マップ

デフォルトでは、VPN トラフィックの送信に LSP が使用されます。MPLS VPN over mGRE 機能では、ユーザ定義のルート マップが使用されて、mGRE トンネルを介して到達可能な VPN プレフィクスと、LSP を使用して到達可能な VPN プレフィクスが決定されます。ルート マップは、VPNv4 および VPNv6 アドレス ファミリーのアドバタイズメントに適用されます。ルート マップでは、VPN トラフィックのカプセル化方式の決定に NextHOP Tunnel Table が使用されます。

mGRE トンネルを介してトラフィックをルーティングするため、mGRE トンネル内でトラフィックをルーティングすることによって到達されるすべてのネクスト ホップを示す代替アドレス レンジが自動的に作成されます。mGRE トンネルを使用する特定のルートを設定するには、ユーザが、そのルートのエントリをルート マップに追加します。その新しいエントリによって、代替アドレス レンジに対して、そのルートの Network Layer Reachability Information(NLRI; ネットワーク レイヤ到着可能性情報)が再マッピングされます。あるルートのルート マップ内に再マッピング エントリが存在しない場合、そのルート上のトラフィックは LSP を介して転送されます。

ユーザが MPLS VPN over mGRE を設定すると、代替アドレス レンジが自動的にプロビジョニングされ、通常の場合、トンネルカプセル化 Virtual Routing and Forwarding(VRF)インスタンス内に保持されます。アドレス レンジを介して到達可能なトラフィックが確実にすべてカプセル化されるように、トンネル外への単一のデフォルト ルートが自動的にインストールされます。また、ルート マップ上にデフォルト トンネルも自動的に作成されます。ユーザは、このデフォルト ルート マップを、適切な BGP アップデートに対応付けることが可能です。

トンネル エンドポイントの検出およびフォワーディング

MPLS VPN over mGRE 機能が正しく機能するように、システム内のリモート PE が自動的に検出され、それらのリモート PC のトンネル フォワーディング情報が自動的に作成されるようにする必要があります。また、リモート PE が無効となったことが自動的に検出され、その PE のトンネル フォワーディング情報が自動的に削除されるようにする必要もあります。

入力 PE によって BGP を介して VPN アドバタイズメントが受信される場合、その入力 PE によってルート ターゲット属性(VRF に入力されます)および、アドバタイズメントからの MPLS VPN ラベルが使用され、その結果、プレフィクスと適切なお客様が関連付けられます。入力されたネクスト ホップが、アドバタイズメントの NLRI が設定されます。

アドバタイズされたプレフィクスには、システム内のリモート PE に関する情報が(NLRI の形式で)格納され、PE では、この情報が使用されて、NLRI がアクティブまたは非アクティブになったときシステムに通知されます。システムでは、この通知が使用されて、PE フォワーディング情報がアップデートされます。

システムによって、新しいリモート PE の通知が受信されると、Tunnel Endpoint Database にその情報が追加され、これを契機として、トンネル インターフェイスに関連付けられた隣接が自動的に作成されます。この隣接の説明として、カプセル化に関する情報、およびカプセル化されたパケットを新しいリモート PE に送信するために自動的に実行される必要のあるその他の処理に関する情報が記述されています。

この隣接情報は、トンネル カプセル化 VRF に入力されます。ユーザが(ルート マップを使用して)VRF 内のルートに VPN NLRI を再マッピングすると、その NLRI が隣接に対して自動的にリンクされ、その結果、VPN がトンネルにリンクされます。

トンネルの非カプセル化

MPLS VPN over mGRE 機能を使用するトンネル インターフェイスからのパケットを 入力 PE が受信すると、その PE によってパケットが非カプセル化され、VPN ラベル タグ付きパケットが作成されて、MPLS Forwarding(MFI)コードにそのパケットが送信されます。

トンネル送信元

MPLS VPN over mGRE 機能では、大量のエンドポイント(リモート PE)を持つシステムの設定に、mGRE トンネルとして設定された単一のトンネルが使用されます。トンネルカプセル化パケットの送信元を特定するために、システムによってトンネル送信元情報が使用されます。

送信(入力)PE では、VPN パケットがトンネルに送信されるときのトンネル宛先は NLRI です。受信(出力)PE では、トンネル送信元は、mGRE トンネルでカプセル化されたパケットが受信されるアドレスです。そのため、出力 PE では、パケットの宛先がローカル PE からの NLRI と一致している必要があります。

IPv6 VPN

アドバタイジング PE ルータのアドレスが IPv6 である場合、(PE 間のネットワークには関係なく)NLRI のアドレスも IPv6 である必要があります。各 PE 間のネットワークが IPv4 ベースである場合、::FFFF:IPv4-PE-address という形式の IPv4 射影アドレスが使用されて、アドバタイジング PE の IPv6 アドレスが自動的に作成されます。受信 PE によって、VPN タグ IPv6 プレフィクスのネクスト ホップが、IPv6 NLRI に埋め込まれた IPv4 アドレスに設定されます。これにより、PE によって、VPNv4 トラフィックをマッピングするのと同じ方法で、VPNv6 トラフィックを LSP または mGRE トンネルにリンクすることが可能になります。

PE によって VPNv6 アップデートが受信されると、そのアップデートが IPv6 ルート マップに適用されます。MPLS VPN over mGRE 機能では、Tunnel_Encap VRF におけるネクスト ホップ情報の設定に IPv6 ルート マップが使用されます。

MPLS VPN over mGRE の設定方法

ここでは、MPLS VPN over mGRE トンネルを設定する手順について説明します。

MPLS VPN over mGRE トンネルを配置するには、VRF インスタンスを作成し、L3 VPN カプセル化をイネーブルおよび設定し、ルート マップをアプリケーション テンプレートにリンクし、アップデートがルート マップを介してフィルタ処理されるように BGP VPNv4 と VPNv6 の交換を設定します。

MPLS VPN over mGRE を配置するための設定手順は、次の各項で説明します。

「L3VPN カプセル化プロファイルの設定」(必須)

「BGP およびルート マップの設定」(必須)

L3VPN カプセル化プロファイルの設定

ここでは、L3VPN カプセル化プロファイルを設定する方法を説明します。


) この設定では、IPv6、MPLS、IP、および Layer 2 Tunneling Protocol Version 3(L2TPv3; レイヤ 2 プロトコル トンネリング バージョン 3)のような転送プロトコルも使用できます。


手順の概要

1. enable

2. configure terminal

3. l3vpn encapsulation ip profile name

4. transport ipv4 [ source interface-type interface-number ]

5. protocol gre [ key gre-key ]

6. end

7. show l3vpn encapsulation ip profile name

詳細手順

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

l3vpn encapsulation ip profile name

 

Router(config)# l3vpn encapsulation ip tunnel encap

トンネルを作成するための L3 VPN カプセル化コンフィギュレーション モードを開始します。

ステップ 4

transport ipv4 source interface-type interface-number

 

Router(config-l3vpn-encap-ip)# transport ipv4 source loopback 0

(任意)IPv4 送信元モードを指定して、送信元インターフェイスを定義します。

このコマンドを使用する場合、指定した送信元アドレスが、PE によってアドバタイズされた BGP アップデートにおけるネクストホップとして使用されていることを確認します。

このコマンドを使用しない場合、 bgp update source または bgp next-hop コマンドが、トンネル送信元として自動的に使用されます。

ステップ 5

protocol gre [ key gre-key ]

 

Router(config-l3vpn-encap-ip)# protocol gre key 1234

GRE をトンネル モードとして指定し、GRE キーを設定します。

ステップ 6

end

 

Router(config-l3vpn-encap-ip)# end

L3 VPN カプセル化コンフィギュレーション モードを終了し、特権 EXEC モードに戻ります。

ステップ 7

show l3vpn encapsulation ip profile name

 

Router# show l3vpn encapsulation ip tunnel encap

 

プロファイルの状態および基本となるトンネル インターフェイスを表示します。

BGP およびルート マップの設定

ここでは、BGP およびルート マップの設定方法を説明します。次の手順では、ルート マップをアプリケーション テンプレートにリンクし、アップデートがルート マップを介してフィルタ処理されるように BGP VPNv4 と VPNv6 の交換を設定することも可能です。

手順の概要

1. enable

2. configure terminal

3. router bgp as-number

4. bgp log-neighbor-changes

5. neighbor ip-address remote-as as-number

6. neighbor ip-address update-source interface-name interface-number

7. address-family ipv4

8. no synchronization

9. redistribute connected

10. neighbor ip-address activate

11. no auto-summary

12. exit

13. address-family vpnv4

14. neighbor ip-address activate

15. neighbor ip-address send-community both

16. neighbor ip-address route-map map-name in

17. exit

18. address-family vpnv6

19. neighbor ip-address activate

20. neighbor ip-address send-community both

21. neighbor ip-address route-map map-name in

22. exit

23. route-map map-tag permit position

24. set ip next-hop encapsulate l3vpn profile name

25. set ipv6 next-hop encapsulate l3vpn profile name

26. exit

27. exit

詳細手順

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router bgp as-number

 

Router (config)# router bgp 100

他の BGP ルータに接続されたルータを特定する自律システムの番号を指定し、転送されるルーティング情報にタグ付けし、ルータ コンフィギュレーションモードを開始します。

ステップ 4

bgp log-neighbor-changes

 

Router(config-router)# bgp log-neighbor-changes

BGP ネイバー リセットをイネーブルにします。

ステップ 5

neighbor ip-address remote-as as-number

 

Router(config-router)# neighbor 209.165.200.225 remote-as 100

エントリを、BGP またはマルチプロトコル BGP ネイバー テーブルに追加します。

ステップ 6

neighbor ip-address update-source interface name

 

Router(config-router)# neighbor 209.165.200.225 update-source loopback 0

BGP セッションに対して、TCP 接続のすべての動作可能なインターフェイスの使用を許可します。

ステップ 7

address-family ipv4

 

Router(config-router)# address-family ipv4

IPv4 アドレス プレフィクスを使用するルーティング セッションを設定するためのアドレス ファミリー コンフィギュレーション モードを開始します。

ステップ 8

no synchronization

 

Router(config-router-af)# no synchronization

Cisco IOS ソフトウェアを、IGP を待機することなくネットワーク ルートをアドバタイズするようにイネーブルにします。

ステップ 9

redistribute connected

 

Router(config-router-af)# redistribute connected

ルートを、あるルーティング ドメインから別のルーティング ドメインに再配布し、ターゲット プロトコルに対して、送信元プロトコルが実行されている各インターフェイス上の、送信元プロトコルおよび接続されたプレフィクスによって学習されたルートの再配布を許可します。

ステップ 10

neighbor ip-address activate

 

Router(config-router-af)# neighbor 209.165.200.225 activate

BGP ネイバーとの情報の交換をイネーブルにします。

ステップ 11

no auto-summary

 

Router(config-router-af)# no auto-summary

自動サマライズをディセーブルにして、クラスフル ネットワークの境界を越えてサブプレフィクス ルーティング情報を送信します。

ステップ 12

exit

 

Router(config-router-af)# exit

アドレス ファミリー コンフィギュレーションモードを終了します。

ステップ 13

address-family vpnv4

 

Router(config-router)# address-family vpnv4

標準 VPNv4 アドレス プレフィクスを使用するルーティング セッション(BGP など)を設定するためのアドレス ファミリー コンフィギュレーション モードを開始します。

ステップ 14

neighbor ip-address activate

 

Router(config-router-af)# neighbor 209.165.200.225 activate

BGP ネイバーとの情報の交換をイネーブルにします。

ステップ 15

neighbor ip-address send-community both

 

Router(config-router-af)# neighbor 209.165.200.225 send-community both

標準コミュニティおよび拡張コミュニティの両方のためのコミュニティ属性が BGP ネイバーに送信されるように指定します。

ステップ 16

neighbor ip-address route-map map-name in

 

Router(config-router-af)# neighbor 209.165.200.225 route-map SELECT_UPDATE_FOR_L3VPN in

名前付きルート マップを受信ルートに適用します。

ステップ 17

exit

 

Router(config-router-af)# exit

アドレス ファミリー コンフィギュレーションモードを終了します。

ステップ 18

address-family vpnv6

 

Router(config-router)# address-family vpnv6

VPNv6 アドレス プレフィクスを使用するルーティング セッション(BGP など)を設定するためのアドレス ファミリー コンフィギュレーション モードを開始します。

ステップ 19

neighbor ip-address activate

 

Router(config-router-af)# neighbor 209.165.200.252 activate

BGP ネイバーとの情報の交換をイネーブルにします。

ステップ 20

neighbor ip-address send-community both

 

Router(config-router-af)# neighbor 209.165.200.252 send-community both

標準コミュニティおよび拡張コミュニティの両方のためのコミュニティ属性が BGP ネイバーに送信されるように指定します。

ステップ 21

neighbor ip-address route-map map-name in

 

Router(config-router-af)# neighbor 209.165.200.252 route-map SELECT_UPDATE_FOR_L3VPN in

名前付きルート マップを受信ルートに適用します。

ステップ 22

exit

 

Router(config-router-af)# exit

アドレス ファミリー コンフィギュレーションモードを終了します。

ステップ 23

route-map map-tag permit position

 

Router(config-router)# route-map SELECT_UPDATE_FOR_L3VPN permit 10

ルートマップ コンフィギュレーション モードを開始し、ルートをあるルーティング プロトコルから別のルーティング プロトコルへ再分配するための条件を定義します。

redistribute ルータ コンフィギュレーション コマンドでは、指定したマップ タグが使用され、そのルート マップが参照されます。複数のルート マップが同一のマップ タグ名を共有している場合があります。

このルート マップの一致基準が満たされた場合、ルートが、この設定アクションによって制御されながら再分配されます。

一致基準が満たされない場合、同一のマップ タグを持つ次のルート マップがテストされます。あるルートが、同一の名前を共有する一連のルート マップの一致基準のいずれをも満たさなかった場合、そのルートは、その設定では再分配されません。

position 引数は、すでに同一の名前で設定されているルート マップのリスト内に新しいルート マップが入る位置を示します。

ステップ 24

set ip next-hop encapsulate l3vpn profile name

 

Router(config-route-map)# set ip next-hop encapsulate l3vpn my profile

ルート マップの match 句を引き渡すための出力 IPv4 パケットが、トンネル カプセル化のために VRF に送信されることを示します。

ステップ 25

set ipv6 next-hop encapsulate l3vpn profile name

 

Router(config-route-map)# set ip next-hop encapsulate l3vpn tunnel encap

 

ルート マップの match 句を引き渡すための出力 IPv6 パケットが、トンネル カプセル化のために VRF に送信されることを示します。

ステップ 26

exit

 

Router(config-route-map)# exit

ルートマップ コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードを開始します。

ステップ 27

exit

 

Router(config)# exit

グローバル コンフィギュレーション モードを終了します。

MPLS VPN over mGRE の設定例

ここでは、次の設定例について説明します。

「MPLS VPN over mGRE 設定の確認:例」

「MPLS VPN over mGRE の設定の流れ:例」

MPLS VPN over mGRE 設定の確認:例

設定が正しく動作していることを確認する例を次に示します。

Cisco Express Forwarding(CEF)スイッチング

CEF スイッチングが想定どおりに動作しているかどうかを確認します。

Router# show ip cef vrf Customer_A tunnel 0
 
209.165.200.250/24
nexthop 209.165.200.251 Tunnel0 label 16

エンドポイントの作成

トンネルのエンドポイントが作成されているかどうかを確認します。

Router# show tunnel endpoints tunnel 0
 
Tunnel0 running in multi-GRE/IP mode
 
Endpoint transport 209.165.200.251 Refcount 3 Base 0x2AE93F0 Create Time 00:00:42
overlay 209.165.200.254 Refcount 2 Parent 0x2AE93F0 Create Time 00:00:42

隣接

対応する隣接が作成されているかどうかを確認します。

Router# show adjacency tunnel 0
 
Protocol Interface Address
IP Tunnel0 209.165.200.251(4)
TAG Tunnel0 209.165.200.251(3)

 

プロファイルの状態

show l3vpn encapsulation profile name コマンドを使用して、アプリケーションの基本的な状態に関する情報を取得できます。このコマンドの出力には、基本となるトンネルの詳細が表示されます。

Router# show l3vpn encapsulation ip tunnel encap
 
Profile: tunnel encap
transport ipv4 source Auto: Loopback0
protocol gre
Tunnel Tunnel0 Created [OK]
Tunnel Linestate [OK]
Tunnel Transport Source (Auto) Loopback0 [OK]

MPLS VPN over mGRE の設定の流れ:例

次に、MPLS VPN over mGRE の設定の流れの例を示します。

vrf definition Customer A
rd 100:110
route-target export 100:1000
route-target import 100:1000
!
address-family ipv4
exit-address-family
!
address-family ipv6
exit-address-family
!
!
ip cef
!
ipv6 unicast-routing
ipv6 cef
!
!
l3vpn encapsulation ip profile name
transport source loopback 0
protocol gre key 1234
!
!
interface Loopback0
ip address 209.165.200.252 255.255.255.224
ip router isis
!
interface Serial2/0
vrf forwarding Customer A
ip address 209.165.200.253 255.255.255.224
ipv6 address 3FFE:1001::/64 eui-64
no fair-queue
serial restart-delay 0
!
router bgp 100
bgp log-neighbor-changes
neighbor 209.165.200.254 remote-as 100
neighbor 209.165.200.254 update-source Loopback0
!
address-family ipv4
no synchronization
redistribute connected
neighbor 209.165.200.254 activate
no auto-summary
exit-address-family
!
address-family vpnv4
neighbor 209.165.200.254 activate
neighbor 209.165.200.254 send-community both
neighbor 209.165.200.254 route-map SELECT_UPDATE_FOR_L3VPN in
exit-address-family
!
address-family vpnv6
neighbor 209.165.200.254 activate
neighbor 209.165.200.254 send-community both
neighbor 209.165.200.254 route-map SELECT_UPDATE_FOR_L3VPN in
exit-address-family
!
address-family ipv4 vrf Customer A
no synchronization
redistribute connected
exit-address-family
!
address-family ipv6 vrf Customer A
redistribute connected
no synchronization
exit-address-family
!
!
route-map SELECT_UPDATE_FOR_L3VPN permit 10
set ip next-hop encapulate profile name
set ipv6 next-hop encapsulate profile name

参考資料

MPLS VPN over mGRE に関連した追加情報については、次の参考資料を参照してください。

関連資料

関連項目
参照先

MPLS レイヤ 3 VPN の設定

『Cisco IOS Multiprotocol Label Switching Configuration Guide』

マルチポイント GRE トンネルを使用したダイナミック レイヤ 3 VPN

『Cisco IOS Interface and Hardware Component Configuration Guide』

Cisco Express Forwarding

『Cisco IOS IP Switching Configuration Guide』

Generic Routing Encapsulation

『Cisco IOS Interface and Hardware Component Configuration Guide』

規格

規格
タイトル

なし

MIB

MIB
MIB リンク

IETF-PPVPN-MPLS-VPN-MIB

選択したプラットフォーム、Cisco IOS リリース、およびフィーチャ セットの MIB の場所を検索しダウンロードするには、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFC

RFC
タイトル

RFC 2547

『BGP/MPLS VPNs』

RFC 2784

『Generic Routing Encapsulation(GRE)』

RFC 2890

『Key Sequence Number Extensions to GRE』

RFC 4023

『Encapsulating MPLS in IP or Generic Routing Encapsulation』

RFC 4364

『BGP/MPLS IP Virtual Private Networks(VPNs)』

シスコのテクニカル サポート

説明
リンク

右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。

以下を含むさまざまな作業にこの Web サイトが役立ちます。

テクニカル サポートを受ける

ソフトウェアをダウンロードする

セキュリティの脆弱性を報告する、またはシスコ製品のセキュリティ問題に対する支援を受ける

ツールおよびリソースへアクセスする

Product Alert の受信登録

Field Notice の受信登録

Bug Toolkit を使用した既知の問題の検索

Networking Professionals(NetPro)コミュニティで、技術関連のディスカッションに参加する

トレーニング リソースへアクセスする

TAC Case Collection ツールを使用して、ハードウェアや設定、パフォーマンスに関する一般的な問題をインタラクティブに特定および解決する

この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

http://www.cisco.com/cisco/web/support/index.html

MPLS VPN over mGRE の機能情報

表 1 に、このモジュールで説明した機能をリストし、特定の設定情報へのリンクを示します。表には、Cisco IOS リリース 12.0(23)S 以降で導入または変更された機能だけを示しています。

ご使用の Cisco IOS ソフトウェア リリースですべてのコマンドが利用できるとは限りません。特定のコマンドに関するリリース情報については、コマンド リファレンス マニュアルを参照してください。

プラットフォームのサポートおよびソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator を使用すると、特定のソフトウェア リリース、フィーチャ セット、またはプラットフォームをサポートする Cisco IOS および Catalyst OS のソフトウェア イメージを判別できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスしてください。Cisco.com のアカウントは必要ありません。


表 1 に、特定の Cisco IOS ソフトウェア リリース群で特定の機能をサポートする Cisco IOS ソフトウェア リリースだけを示します。特に明記されていない限り、Cisco IOS ソフトウェア リリース群の後続のリリースでもこの機能をサポートします。


 

表 1 MPLS VPN over mGRE の機能情報

機能名
リリース
機能情報

MPLS VPN over mGRE

12.2(33)SRE

この機能では、mGRE を介した MPLS レイヤ 3 VPN トラフィックの搬送がサポートされています。この機能では、Cisco 7600 シリーズ ルータ上の SIP-400 および ES-40 もサポートされています。

次の項では、この機能に関する情報について説明します。

「L3VPN カプセル化プロファイルの設定」

「BGP およびルート マップの設定」

この機能では、コマンド l3vpn encapsulation ip protocol gre key , set ip next-hop show l3vpn encapsulation ip transport ipv4 source が導入または変更されています。