Cisco IGX 8400 シリーズ プロビジョニング ガイド (Release 9.3.3 以降)
Cisco IGX 8400 シリーズの IP サービス
Cisco IGX 8400 シリーズの IP サービス
発行日;2012/02/03 | ドキュメントご利用ガイド | ダウンロード ; この章pdf | フィードバック

目次

Cisco IGX 8400 シリーズの IP サービス

IP サービスの機能の概要

必要なハードウェアおよびソフトウェア

URM

仮想スレーブ インターフェイス(VSI)

VSI マスターおよびスレーブ

接続アドミッション制御

サービス クラス テンプレート

Qbin

MPLS の概要

MPLS ラベリングの条件

IGX の MPLS CoS

MPLS 対応 VPN

MPLS ラベル転送

IGX でマージされる VC

IGX でサポートされる MPLS 接続

IP サービスのプロビジョニング

コントローラのリソースのプランニング

VSI の設定

論理スイッチの配分とリソースの割り当て

UXM と UXM-E のスレーブ冗長構成

コントローラとスレーブの追加および削除

IGX での VC マージ

IGX 上の VSI に関連するスイッチ ソフトウェアのコマンド

IGX での MPLS の設定

LVC の初期セットアップ

IGX ATM-LSR の MPLS の設定

Cisco IGX 8410、8420、8430 ATM-LSR のIGX スイッチ部分の設定

Cisco IGX 8410、8420、 8430 の LSC 1 および LSC 2 部分の設定

エッジ ラベル スイッチ ルータ、LSR-A および LSR-B の設定

ルーティング プロトコルによる 、MPLS を使った LVC の設定

MPLS ネットワークの設定のテスト

IGX 拡張 ATM インターフェイスの確認

MPLS VPN の設定例

IP サービスの管理

スレーブ リソースの管理

VSI 冗長化機能の設定

Qbin 統計情報

Qbin 統計情報コマンドの一覧

関連情報

Cisco IGX 8400 シリーズの IP サービス

IP サービスの機能の概要

Cisco IGX 8400 シリーズでは、Universal Router Module(URM; ユニバーサル ルータ モジュール)を使うことでインシャーシ IP ルーティングが実現されます。URM はデュアルプロセッサのカード セットであり、高密度の音声およびデータ インターフェイスが提供されます。 IP ルーティングサービスは、外部ルータを使用して、IGX に ATM PVC を設定することでセットアップすることもできます。

IGX での IP サービスは、Virtual Slave Interface(VSI; 仮想スレーブ インターフェイス)の設定を通じて機能します。これにより、ノードを Multiprotocol Label Switching(MPLS; マルチプロトコル ラベル スイッチング)などの複数のlabel switch controller(LSC; ラベル スイッチ コントローラ)で管理できます。


) Private Network-to-Network Interface(PNNI; プライベート ネットワーク間インターフェイス)は、URM ではサポートされません。


ここでは、主として URM による IGX での MPLS サポートについて説明します。 Cisco 7200 などの外部ルータを使用した MPLS の設定については、『 Update to the Cisco IGX 8400 Series Reference Guide 』を参照してください。

IGX でサポートされているその他の Cisco IOS の機能については、「関連マニュアル」に記載の Cisco IOS マニュアルを参照してください。

必要なハードウェアおよびソフトウェア

表 10-1 は、IGX ノードの IP サービスのプロビジョニングに必要なハードウェアおよびソフトウェアです。


) Cisco IOS ソフトウェア、スイッチ ソフトウェア、およびファームウェアの互換性要件については、互換性の表を参照してください。


 

表 10-1 IP サービスに必要なハードウェアおよびソフトウェア

ハードウェア オプション
サービス カード ファームウェア
Cisco IOS リリース
スイッチ ソフトウェア
リリース

外部ルータを使ってノードに IP サービスを設定するのに必要なハードウェア:

Cisco IGX 8410、8420、8430のいずれか

NPM-64B

UXM サービス カード

32 MB RAM(64 MB 推奨)搭載の LSC ルータ

UXM モデル C ファームウェア

12.1(3)T 以降(IP 専用リリースを推奨)

9.3.10 以降

インシャーシ URM を使ってノードに IP サービスを設定するのに必要なハードウェア:

Cisco IGX 8410、8420、8430のいずれか

NPM-64B

URM

URM 管理ファームウェア バージョン XAA 以降


) BC-URI-2FE バック カードのサポートには、URM管理
ファームウェア バージョン XBA が必要


12.2(2)XB 以降(VPN および音声機能専用のみ)

12.2(8)T 以降(MPLS、VPN、および音声機能)

9.3.20 以降(音声機能のみ)

9.3.30 以降(MPLS、VPN、および音声機能)

URM


) この章に記載する相違点を除けば、URM は、外部ルータおよび UXM または UXM-E カードと同様に設定できます。 カードの組み込み UXM-E 部分でのスイッチ ソフトウェアの設定は、UXM または UXM-E での設定と同じですが、組み込みルータはシスコ製の外部ルータと同様に設定します。URM の詳細については、「ユニバーサル ルータ モジュール」を参照してください。


URM は、Universal Router Interface(URI; ユニバーサル ルータ インターフェイス)バック カードに接続された、論理的に配分されたフロント カードからなります。 このフロント カードは、管理ファームウェア イメージを実行する組み込み UXM-E と、Cisco IOS イメージを実行する組み込みルータから成ります。組み込み UXM-E と組み込みルータは、OC3 ATM ポートと同等の機能を備えた、論理的な内部 ATM インターフェイスで接続されます。

論理的に定義された内部 ATM インターフェイスは、組み込みルータと組み込み UXM-E プロセッサとの間の物理インターフェイスに見えます。 ただし、URM で終端するリモート接続は、内部 ATM インターフェイスをエンドポイントとして使用でき、その際には組み込み UXM-E プロセッサから組み込みルータに伝送データが渡されます。

URM は、次の IP サービスをサポートしています。

VoIP(URI-2FE2V バック カード搭載)

IP+ATM(VoATM 利用可、URI-2FE2V バック カードが必要)

IP+FR(VoFR 利用可、URI-2FE2V バック カードが必要。また、URM の内部 ATM インターフェイスとリモート FR エンドポイント間の FRF.8 サービス インターワーキングを使用)

MPLS

MPLS Virtual Private Networks(VPN; バーチャル プライベート ネットワーク)

IPsec-VPN(AIM-VPN/HP モジュール搭載)

IP サービス用に URM を設定するには、スイッチ ソフトウェアと Cisco IOS コマンドの両方を使う必要があります。 基本的な URM の取り付けと設定については、「機能の概要」を参照してください。

仮想スレーブ インターフェイス(VSI)


) VSI は、UXM または UXM-E カード セット上でしか設定できません。 VSI コントローラに対する FR サポートは、UXM または UXM-E フロント カード上の FRF.8 サービス インターワーキングを介して機能します。


VSI により、ノードを MPLS などの複数のコントローラで管理できます。

VSI の制御モデルでは、コントローラはスイッチを専用のインターフェイスを持つ複数のスレーブの集まりとして認識します。 コントローラは、自身のパーティションに割り当てられたリソースを使用して 任意の 2 つのインターフェイス間で接続を確立できます。 たとえば、MPLS コントローラがアクセスできるのは、MPLS コントローラの配分に設定されたインターフェイスだけです。

VSI 配分を作成、有効化すると、コントローラが VSI インターフェイスを利用できるようになります。 コントローラは、VSI プロトコルを通じてその配分を管理し、VSI マスターを実行します。 VSI マスターは、VSI 配分内の各スレーブとやりとりし、VSI 接続を設定し、終端します。

IGX 上では最大 3 つの VSI 配分を有効にできます。 各 VSI 配分は一緒にまたは独立して機能でき、さらに各インターフェイス上で AutoRoute 状態にできます。

IGX 上の VSI には次の機能があります。

Class of Service(CoS; サービス クラス)テンプレート

ポートおよびトランク インターフェイス上の配分

VSI の仮想トランクのサポート

VSI の SV+ のサポート

最大 3 つのコントローラ

IGX での VSI 配分と VSI の設定については、「VSI の設定」を参照してください。

VSI マスターおよびスレーブ

コントローラ アプリケーションは 1 つの VSI マスターを使用して、1 つ以上の VSI スレーブを制御します。 URM のない IGX の場合、コントローラ アプリケーションとマスター VSI は外部ルータに存在し、VSI スレーブは IGX ノード上の UXM カードに存在します(図 10-1を参照)。

URM が搭載された IGX ノードは、コントローラ アプリケーションとマスター VSI の配置場所として、URM フロント カード上の組み込みルータを利用します。

図 10-1 VSI、コントローラ、およびスレーブ VSI

 

コントローラは、VSI マスターと、対応するスイッチ上の各 VSI スレーブとの間に、リンクを 1 本ずつ確立します。各スレーブの間でも、相互にリンクが確立されます(図 10-2 を参照)。

図 10-2 VSI マスターと VSI スレーブの例

 

複数のスイッチが一緒に接続されている場合は、個々のスイッチの相互接続によりスイッチ間のリンクが確立されます(図 10-3を参照)。

図 10-3 スイッチ間のリンクと相互接続

 

接続アドミッション制御

VSI スレーブが接続要求を受け取ると、その要求は実際の接続処理を行う FW 層へ転送される前に、Connection Admission Control(CAC; 接続アドミッション制御)で処理されます。接続の許可は次の基準に基づいて判定されます。

VSI 配分で使用できる LCN

帯域幅

QoS の保証

最大 CLR

最大 CDV

VSI スレーブは、CAC の後に MPLS コントローラの VSI マスターから接続設定コマンドを受信すると、サービス タイプ、帯域幅パラメータ、および QoS パラメータを含む接続情報を受け取ります。この情報を基に VI で選択されているサービス テンプレートの VC 記述子テーブルを照会するためのインデックスを特定し、記述子テーブル内の関連拡張パラメータ セットにアクセスします。

CoS バッファ リンクを格納する事前割り当て入サービス テンプレートは、入トラフィックを管理します。

サービス クラス テンプレート


) Service Class Template(SCT; サービス クラス テンプレート) は、主に仮想回線(VC)で使用され、IGX を、Label Swich Controller(LSC; ラベル スイッチ コントローラ)の VSI マスターと連携動作するように設定する場合に使用する必要があります。


SCT を使用すると、標準接続プロトコルのパラメータを、異なるハードウェア プラットフォームにマッピングすることができます。たとえば、BPX 用の SCTと IGX 用の SCT は異なりますが、BPX と IGX は完全な QoS を実現する等価な CoS を提供できます。

IGX では、NPM に SCT のセットが保存されます。 UXM または UXM-E を初めて設定するときに、適切な SCT がカードにダウンロードされます。 また、後からカードに新しいインターフェイスを設定すると、新しいインターフェイスに合った SCT がカードにダウンロードされます。

各 SCT には、次の情報が含まれます。

接続の確立に必要なパラメータ。UPC アクション、さまざまな帯域幅関連の項目、VC ごとのしきい値(VC 用)などのエントリがあります。

QoS をサポートするための CoS バッファ(Qbin)を設定するのに必要なパラメータ

各 SCT には、関連する Qbin マッピング テーブルがあります。Qbin マッピング テーブルは、セルを一時的に格納し、利用可能な帯域幅と CoS の優先度に基づいてそれらのセルをインターフェイスに送出することで、帯域幅を管理します。


) インターフェイスを設定すると、デフォルト SCT であるテンプレート 1 が自動的に Virtual Interface(VI; 仮想インターフェイス)に割り当てられます。


次の 9 つの SCT が VSI に割り当てられます。

VSI 特殊タイプ(テンプレート 1、デフォルト)

MPLS1

ATMF_tagcos_1

ATMF_tagcos_2

ATMF_tagABR_1

ATMF_tagABR_2

ATMF_tagcos_tagABR_1

ATMF_tagcos_tagABR_2

図 10-4 に、SCT 機能の詳細を示します。 サポートされている SCT 特性については、 表 10-2 を参照してください。


注意 SCT は稼働中のインターフェイスに割り当て直すことができます。この場合、UXM または UXM-E とコントローラの間で再同期化処理が行われます。ただし、Cisco MPLS VSI コントローラでは、稼働中のインターフェイスに SCT を割り当て直すと、カードのすべての接続がコントローラと再同期化されるため、サービスに影響を与えることがあります。

図 10-4 サービス テンプレートの概要

 

サポートされるサービス タイプ

サービス タイプ識別子は 32 ビットの数値です。

サポートされるサービス タイプは次のとおりです。

VSI 特殊タイプ

MPLS タイプ

サービス クラス テンプレートの番号とサービス タイプを指定して dspsct コマンドを実行すると、サービス タイプ識別子が画面に表示されます。たとえば、次のように指定します。

dspsct <1> <TagABR>
 

サポートされているサービス テンプレートのリストと、関連する Qbin およびサービス タイプを 表 10-2 に示します。

 

表 10-2 サービス カテゴリの一覧

テンプレート タイプ
サービス タイプ
識別子
サービス タイプ
対応する Qbin

VSI 特殊タイプ

0x0001

デフォルト

MPLS1、ATMF1、
および ATMF2 用テンプレート×13

0x0002

シグナリング

MPLS1 用テンプレート×10

MPLS タイプ

0x0001

0x0002

0x0200

0x0201

0x0202

0x0203

0x0204

0x0205

0x0206

0x0207

0x0210

デフォルト

シグナリング

タグ0

タグ1

タグ2

タグ3

タグ4

タグ5

タグ6

タグ7

TagABR

13

10

10

11

12

13

10

11

12

13

14

ATMF_tagcos_1 *

ATMF_tagcos_2*

0x0001

0x0100

0x0101

0x0102

0x0103

0x0104

0x0105

0x0106

0x0107

0x0108

0x0109

0x010A

0x010B

0x0200

0x0201

0x0202

0x0203

0x0204

0x0205

0x0206

0x0207

0x0210

デフォルト

CBR.1

VBR.1-RT

VBR.2-RT

VBR.3-RT

VBR.1-nRT

VBR.2-nRT

VBR.3-nRT

UBR.1

UBR.2

ABR

CBR.2

CBR.3

タグ0

タグ1

タグ2

タグ3

タグ4

タグ5

タグ6

タグ7

TagABR

10

15

11

11

11

12

12

12

10

10

14

15

15

10

10

13

13

10

10

13

13

14

ATMF_TagABR_1 *

ATMF_TagABR_2*

0x0001

0x0100

0x0101

0x0102

0x0103

0x0104

0x0105

0x0106

0x0107

0x0108

0x0109

0x010A

0x010B

0x0200

0x0201

0x0202

0x0203

0x0204

0x0205

0x0206

0x0207

0x0210

デフォルト

CBR.1

VBR.1-RT

VBR.2-RT

VBR.3-RT

VBR.1-nRT

VBR.2-nRT

VBR.3-nRT

UBR.1

UBR.2

ABR

CBR.2

CBR.3

タグ0

タグ1

タグ2

タグ3

タグ4

タグ5

タグ6

タグ7

TagABR

10

15

11

11

11

12

12

12

10

10

14

15

15

10

10

10

10

10

10

10

10

13

ATMF_TagCoS_TagABR_1 *

ATMF_TagCoS_TagABR_2*

0x0001

0x0100

0x0101

0x0102

0x0103

0x0104

0x0105

0x0106

0x0107

0x0108

0x0109

0x010A

0x010B

0x0200

0x0201

0x0202

0x0203

0x0204

0x0205

0x0206

0x0207

0x0210

デフォルト

CBR.1

VBR.1-RT

VBR.2-RT

VBR.3-RT

VBR.1-nRT

VBR.2-nRT

VBR.3-nRT

UBR.1

UBR.2

ABR

CBR.2

CBR.3

タグ0

タグ1

タグ2

タグ3

タグ4

タグ5

タグ6

タグ7

TagABR

10

10

10

10

10

11

11

11

12

12

11

10

10

12

13

14

15

12

13

14

15

13

 
* ATMF タイプはこのリリースではサポートされていません。

IGX での ATM Cos サービス テンプレートと Qbin

サービス クラス テンプレートは、拡張パラメータ セットをマッピングする手段です。このテンプレートは、通常、プラットフォームに固有で、UXM ポート インターフェイスを最初に起動するときに、その中の VSI スレーブへ渡される標準 ATM パラメータに基づいています。

各スイッチにはサービス テンプレートが一式格納されています。VSI インターフェイスの初期設定で、トランクまたは回線をサービス モジュール(UXM)で有効にする際に、このテンプレートが UXM へ適宜ダウンロードされます。

MPLS サービス テンプレートは、トランクまたはポートの初期化時に VSI インターフェイスに割り当てられます。 CoS の Multiple LVC オプションがエッジ label switch router(LSR; ラベル スイッチ ルータ)で有効になると、Label Switch Controller(LSC; ラベル スイッチ コントローラ)は、ルーティング プロトコル(OSPF など)や ラベル配布プロトコル(LDP)を使用して、自動的に LVC を設定します。

multiple VC オプションが(エッジ LSR で)有効なとき、各 IP 送信元/宛先に対して 4 つの LVC が設定されます。 4 つの LVC それぞれにサービス テンプレート タイプが割り当てられます。 たとえば、4 つのセル ラベルの 1 つにラベル cos2 サービス タイプ カテゴリが割り当てられます。

サービス テンプレートの各タイプには、対応する Qbin があります。 Qbin を使うと、一時的にセルを保存し、帯域幅が利用できるときに送出することで、帯域幅を管理できるようになります。 これは、利用可能な帯域幅、各種サービス クラスの相対的な優先度などの要素に基づきます。

エッジ LSR から UXM ポートに到達した ATM セルに 4 種類の CoS ラベルのどれかが含まれている場合、セルはこのラベルに応じて CoS 管理されます。テーブルが検索された後、それぞれのセルに対してその接続分類に合った処理が行われます。各セルは CoS ラベルに基づいて、自身のテンプレート タイプ(MPLS1 テンプレート)およびサービス タイプ(ラベル cos2 bw など)に対応する ATM 差別化サービスを受けます。その際、対応する Qbin の特性やその他の ATM パラメータも考慮されます。

IGX でのサービス クラス テンプレートの設定については、「ATM サービスの機能の概要」を参照してください。

VC 記述子パラメータ

表 10-3 は、VC ごとの ATM サービス クラスの接続パラメータと設定できる値の範囲(事前に設定されていない場合)です。

すべてのサービス クラスに、すべてのパラメータがあるわけではありません。たとえば、CBR サービス タイプのパラメータ数は、ABR サービス タイプより少なくなっています。


) すべてのサービス クラスで、表 10-3に記載されているすべてのパラメータについて値が定義されているわけでありません。


 

表 10-3 接続パラメータの範囲と指定単位

オブジェクト名
範囲/値
単位

Qbin 番号

10~15

Qbin 番号

スケーリング クラス

0~3

どれかを選択

CDVT

0~5M(5 秒)

MBS

1~5M

セル数

ICR

MCR~PCR

セル数

MCR

50~LR

セル数

SCR

MCR~回線速度

セル数

UPC イネーブル

0 :GCRA を無効化

1 :GCRA を有効化

2 :GCRA #1 を有効化

3 :GCRA #2 を有効化

どれかを選択

UPC CLP 選択

0 :Bk 1、CLP (0+1)

Bk 2、CLP(0)

1 :Bk 1、CLP(0+1)

Bk 2、CLP(0+1)

2 :Bk 1、CLP(0+1)

Bk 2、無効

どれかを選択

ポリシング アクション(GCRA #1)

0 :廃棄

1 :CLP ビットを設定

2 :タグなしのセルの

CLP を設定し、

タグ付きセルを廃棄

どれかを選択

ポリシング アクション(GCRA #2)

0 :廃棄

1 :CLP ビットを設定

2 :タグなしのセルの CLP を設定し、タグ付きセルを廃棄

どれかを選択

VC Max

 

セル数

CLP 下限

0~100

VC max %

CLP 上限

0~100

VC max %

EFCI

0~100

VC max %

VC 廃棄しきい値選択

0 :CLP ヒステリシス

1 :EPD

どれかを選択

VSVD

0:なし

1:VSVD

2:外部セグメント付き VSVD

どれかを選択

Reduced Format ADTF

0~7

どれかを選択

RRDF(Reduced Format Rate Decrease Factor)

1~15

どれかを選択

Reduced format rate increase factor(RRIF)

1~15

どれかを選択

Reduced format time between forward RM cells(RTrm)

0~7

どれかを選択

Cut-off no. of RM cells(CRM)

1~4095

セル数

SVC 記述子

表 10-4 は、各サービス テンプレートに関連付けられたパラメータの一覧です。

 

表 10-4 MPLS サービス カテゴリ

パラメータ
デフォルト
シグナリング
Tag 0/4
Tag 1/5
Tag 2/6
Tag 3/7
Tag-ABR

Qbin 番号

13

10

10

11

12

13

14

UPC イネーブル

なし

なし

なし

なし

なし

なし

なし

スケーリング クラス

1

1

1

1

1

1

2

CAC 処理

LCN

LCN

LCN

LCN

LCN

LCN

LCN

VC Max

61440

0

61440

61440

61440

61440

61440

VC 廃棄選択

EPD

ヒステリシス

EPD

EPD

EPD

EPD

EPD

VC CLP 上限

100

75

100

100

100

100

100

VC CLP 下限

--

30

--

--

--

--

--

VC EPD

40

--

40

40

40

40

40

セル遅延変動許容値

250000

--

--

--

--

--

--

UPC CLP 選択

--

--

--

--

--

--

--

ポリシング アクション(GCRA #1)

--

--

--

--

--

--

--

ポリシング アクション(GCRA #2)

--

--

--

--

--

--

--

PCR

--

--

--

--

--

--

--

MCR

--

--

--

--

--

--

0

SCR

--

--

--

--

--

--

0

ICR

--

--

--

--

--

--

100

MBS

--

--

--

--

--

--

1024

VC EFCI

--

--

--

--

--

--

20

VSVD/FCES

--

--

--

--

--

--

なし

ADTF

--

--

--

--

--

--

500

RDF

--

--

--

--

--

--

16

RIF

--

--

--

--

--

--

16

NRM

--

--

--

--

--

--

32

TRM

--

--

--

--

--

--

0

CDF

--

--

--

--

--

--

16

TBE

--

--

--

--

--

--

16777215

FRTT

--

--

--

--

--

--

0

Qbin

Qbin は、セルを格納し、利用可能な帯域幅と CoS の優先度に基づいて、それらのセルをインターフェイスに送出します(図 10-5 を参照)。たとえば、CBR セルと ABR セルがスイッチの同じインターフェイスから送出される必要がある場合で、そのインターフェイスがすでに他のソースからの CBR セルを送信している場合は、新しく受信した CBR セルと ABR セルは、そのインターフェイスに関係付けられた Qbin に保持されます。インターフェイスがアクセス可能になると、Qbin は送信のために CBR セルをインターフェイスに送ります。CBR セルの送信が終わると、ABR セルがインターフェイスに渡されて、宛先に送信されます。

図 10-5 UXM の仮想インターフェイスと Qbin

 

Qbin は、VSI マスターが別のコントローラ(ラベル スイッチ コントローラ:LSC)上で動作している、VSI である VI で使用されます。VSI マスターが VSI を処理するためには、各仮想回線(VC、FR ネットワークで使用する場合は仮想チャネルと呼ぶ)が、32 ビットのサービス タイプ識別子で指定されたサービス クラスを受け取る必要があります。IGX では、次のサービス タイプの識別子がサポートされています。

ATM Forum

MPLS

VSI スレーブは、LSC の VSI マスターから接続確立要求を受け取ると、このサービス タイプ識別子を SCT データベース中でインデックスとして使います。この SCT データベースには、そのサービス タイプ識別子に対応する接続のための拡張パラメータ設定が入っています。次に、VSI スレーブはこの拡張パラメータ設定を使用して、接続を確立し、必要に応じて接続の維持と完了のために必要な設定を行います。

通常、VSI マスターは VSI スレーブに、サービス タイプ識別子(ATM Forum または MPLS)、QoS パラメータ(CLR または CDV など)、および帯域幅パラメータ(PCR または MCR)を送信します。

Qbin テンプレート

Qbin テンプレートには、インターフェイスに対応付けられた Qbin のデフォルト設定が定義されています。SCT をインターフェイスに割り当てると、スイッチ ソフトウェアにより Qbin テンプレートから設定がコピーされ、そのインターフェイスに対応付けられたすべての Qbin に適用されます。

Qbin テンプレートは、VSI 配分に利用可能な Qbin だけに適用されます。つまり、Qbin テンプレートは、Qbin 10 ~ 15 だけに適用されます。 Qbin 0 ~ 9 は、Automatic Routing Management(ARM; 自動ルーティング管理)によって予約されており、ARM によって設定されます。

インターフェイスに対応付けられた Qbin の一部のパラメータは、インターフェイスごとに再設定できます。この変更は、インターフェイスに対応付けられた Qbin には影響しますが、NPM に保存されている Qbin テンプレートには影響しません。

図 10-6 に、SCT と Qbin テンプレートの関係を示します。

図 10-6 サービス テンプレートと関連する Qbin の選択

 

Qbin のデフォルト設定

表 10-5 は、LSC に対する Qbin と SCT のデフォルト設定です。


) テンプレート 2、4、6、および 8 は、Partial Packet Discard(PPD; 部分パケット廃棄)のポリシングをサポートします。


 

表 10-5 Qbin のデフォルト設定

Qbin
最大 Qbin しきい値
(usec)
CLP 上限
CLP 下限/EPD
EFCI
廃棄選択
ラベル
テンプレート 1

10(ヌル、シグナリング、タグ 0、4)

300,000

100%

95%

100%

EPD*

11(タグ 1、5)

300,000

100%

95%

100%

EPD

12(タグ 2、6)

300,000

100%

95%

100%

EPD

13(タグ 3、7)、デフォルト

300,000

100%

95%

100%

EPD

14(タグ Abr)

300,000

100%

95%

6%

EPD

15(タグ使用せず)

300,000

100%

95%

100%

EPD

10(タグ 0、2、3、4、1、5、デフォルト、UBR、Tag-Abr*)

300,000

100%

95%

100%

EPD

11(VbrRt)

53000

80%

60%

100%

EPD

12(VbrNrt)

53000

80%

60%

100%

EPD

13(タグ 2、6、3、7)

300,000

100%

95%

100%

EPD

14(Abr)

105000

80%

60%

20%

EPD

15(Cbr)

4200

80%

60%

100%

CLP

10(タグ 0、4、1、5、2、6、3、7 UBR)

300,000

100%

95%

100%

EPD

11(VbrRt)

53000

80%

60%

100%

EPD

12(VbrNrt)

53000

80%

60%

100%

EPD

13 (Tag-Abr)、デフォルト

300,000

100%

95%

6%

EPD

14(Abr)

105000

80%

60%

20%

EPD

15(Cbr)

4200

80%

60%

100%

CLP

10(Cbr、Vbr-rt)

4200

80%

60%

100%

CLP

11(Vbr-nrt、Abr)

53000

80%

60%

20%

EPD

12(Ubr、タグ 0、4)

300,000

100%

95%

100%

EPD

13(タグ 1、5、Tag-Abr)

300,000

100%

95%

6%

EPD

14(タグ 2、6)

300,000

100%

95%

100%

EPD

15(タグ 3、7)

300,000

100%

95%

100%

EPD

 
* Early Packet Discard(EPD; 早期パケット廃棄)です。

Qbin の依存関係

Qbin 10 ~ 15は、トランクまたはポートとして設定されたインターフェイス上で VSI によって使用されます。残りの Qbin(0 ~ 9)は予約されており、AutoRoute によって設定されます。

dspsct コマンドを実行することで、デフォルトのサービス タイプと Qbin 番号を表示させることができます。

Qbin の使用可能なパラメータを、 表 10-6 に示します。


) VSI で使用できる Qbin は、そのインターフェイスの Qbin 10 ~ 15 に限定されます。使用可能な 16 個の仮想インターフェイスすべてに、16 個の Qbin が提供されます。


 

表 10-6 サービス テンプレートの Qbin パラメータ

テンプレート オブジェクト名
テンプレートの単位
テンプレート内での範囲/値

Qbin 番号

どれかを選択

0~ 15(VSI では 10 ~ 15 が有効)

最大 Qbin しきい値

u sec

1~2000000

Qbin CLP 上限しきい値

最大 Qbin しきい値の %

0~100

Qbin CLP 下限しきい値

最大 Qbin しきい値の %

0~100

EFCI しきい値

最大 Qbin しきい値の %

0~100

廃棄選択

どれかを選択

1 :CLP ヒステリシス

2 :フレーム廃棄

均等化キューイング

有効/無効

0:disable(無効)

1:enable(有効)

MPLS の概要

MPLS により、エッジ ルータは、ネットワークに伝送する前にパケットやフレームにラベルを適用できます。 ネットワークにパケットやフレームが伝送されると、ネットワークのコア装置は、このラベルにより最低限の検査でラベル付けされたパケットをスイッチングできます。 このプロセスにより、IP ルーティングと仮想回線スイッチングが統合され、ATM バックボーン上で拡張性に優れた IP ネットワークが実現できます。 MPLS は、ルーティング判断をまとめることで、スイッチが IP 転送、ネットワーク コアを経由するパケットのルートの最適化を実行できるようにします。

MPLS により、パス、リソース アベイラビリティ、要求された Quality of Service(QoS)の制約を使用して、明示的なデータ フロー ルートを設定できます。

IGX ノード上で MPLS を有効にするには、2 通りの方法があります。1 つはネットワークで全 IGX ノードの MPLS コントローラとして機能する、Cisco 7204VXR などの外部ラベル スイッチ コントローラ(LSC)を接続することで、もう 1 つは搭載済みの URM を MPLS コントローラとして設定することです。 MPLS のサポートは、IGX とコントローラ間の共通制御インターフェイスまたは VSI を使うことで可能となります。


) MPLS の設定には、ネットワーク内の MPLS が稼働する IGX ノードの各パーティションごとに 1 つの LSC が必要です。



ヒント ラックのスペースを節約するには、同じ IGX ノード上の複数のパーティションに対する LSC として、複数の個別に取り付けられた URM を使用します。


IGX 上の MPLS の詳細については、『 MPLS Label Switch Controller and Enhancements 12.2(8)T 』を参照してください。

MPLS ラベリングの条件

ビジネス IP サービスにとって、MPLS の最も重要な利点は、特殊な意味を持つラベルを割り当てられる能力です。 ラベル セットにより、宛先アドレスとアプリケーション タイプまたはサービス クラスが区別されます(図 10-7を参照)。

図 10-7 MPLS ラベルの利点

 

MPLS ラベルは、IGX ATM LSR などのコア装置の予測交換テーブルにたとえられ、各スイッチがパケットに正しい IP サービスを自動的に適用できるようになります。 すべてのホップでパケットの再処理が行われることがないように、テーブルは事前に計算されます。 この方針によって、ベストエフォート トラフィックをミッションクリティカル トラフィックと分けるといった、トラフィック タイプの分類ができるだけでなく、MPLS ソリューションの拡張性が大幅に高まります。

MPLS ではパケットへのラベルの割り当てに異なるポリシー メカニズムを使用するので、IP ヘッダーの内容とパケットの転送が分離されます。 ラベルにはローカルでの重要性があり、大規模ネットワークでは何度も使用されます。 したがって、ラベルなしで実行することはほぼ不可能です。 この特性は、QoS、大規模 VPN、トラフィック計画などの高度な IP サービスを実現するために不可欠です。

IGX の MPLS CoS

ここでは、Cisco IGX 8410、8420、8430 ATM ラベル スイッチ ルータ(ATM LSR)を使った MPLS CoS について説明します。 MPLS CoS は、LSC として URM を使用したネットワークでもサポートされます。


) URM を LSR として設定する場合は MPLS CoS はサポートされません。また、URM-LSR を使用するネットワークは、URM-LSR を含むネットワーク セグメントでは MPLS CoS を実行できません。


MPLS CoS 機能により、ネットワーク管理者は、MPLS スイッチング ネットワークで、差別化されたサービスタイプを提供できます。 差別化されたサービスは、CoS サービスにより各パケット用に指定された特定のサービスタイプを提供することで、一定範囲の要求を満たします。サービスタイプは、さまざまな方法で指定できます。たとえば、IP パケットや送信元アドレスと宛先アドレスの IP 優先順位ビットを使う方法などです。

MPLS CoS 機能は、オプションでMPLS 仮想プライベート ネットワークと共に使用されます。 MPLS CoS は、MPLS スイッチング ネットワークでも使用できます。

差別化されたサービスを提供する際、MPLS CoS は、パケット分類、輻輳回避、輻輳管理を行います。 表 10-7 に、これらの機能とその実現方法を示します。

 

表 10-7 CoS サービスと機能

サービス
CoS 機能
説明

パケット分類

専用アクセス レート(CAR)。 パケットは、ラベルが割り当てられる前にネットワークのエッジで分類されます。

CAR は、IP ヘッダーの Type of Service(TOS; タイプ オブ サービス)ビットを使用して、入出力の伝送速度に応じてパケットを分類します。 ネットワークを出入りするトラフィックを制御するため、CAR はネットワーク エッジでインターフェイス上に設定されることがよくあります。 CAR 分類コマンドを使用するとパケットの分類や分類のやり直しができます。

輻輳回避

重み付けランダム早期検出(WRED)。 パケットは、廃棄確率に基づいて分類されます。

WRED はネットワーク トラフィックを監視し、一般的なネットワークとインターネットワークのボトルネックで輻輳を予測して回避しようとします。 WRED は、インターフェイスが輻輳しはじめると、優先順位の低いトラフィックを選択して廃棄します。 また、各種のサービス クラスに対し、差別化されたパフォーマンス特性を提供します。

輻輳管理

均等化キューイング(WFQ)。 パケット クラスは、帯域幅とバウンディッド遅延に基づいて分類されます。

WFQ は自動スケジューリング システムであり、すべてのネットワーク トラフィックに公平に帯域幅を割り当てます。 WFQ は、トラフィックを会話に分類し、重み(優先順位)を使用して、他の会話との相対で、各会話にどの程度の帯域幅を割り当てるかを決定します。

MPLS CoS を使用することで、Label Switch Router(LSR; ラベル スイッチ ルータ)、エッジ LSR、ATM ラベル スイッチング ルータ(ATM LSR)などの MPLS スイッチング装置に、Cisco IOS IP CoS(レイヤ 3)機能ができるだけ厳密に複製されます。 MPLS CoS 機能により、すべてのインターフェイス タイプでほぼ 1 対 1 で IP CoS 機能がマッピングされます。

詳細は、シスコ製ルータおよび MPLS 関連の Cisco IOS マニュアルを参照してください(「Cisco IOS ソフトウェアのマニュアル」を参照)。

MPLS CoS の要件

MPLS CoS 機能を使用するには、ネットワークで次の Cisco IOS 機能が実行されている必要があります。

CEF スイッチング(MPLS 対応のすべてのルータで)

MPLS

ATM 機能

また、IGX には次のものを装備しておく必要があります。

Cisco IOS ソフトウェアに対応するスイッチ ソフトウェア

対応する UXM カードにロードされたファームウェア


ヒント スイッチ ソフトウェア、Cisco IOS ソフトウェア、カード ファームウェアの互換性については、http://www.cisco.com/kobayashi/sw-center/sw-wan.shtml にある互換性の表を参照してください。


IP+ATM ネットワークの MPLS CoS

IP+ATM ネットワークでは、MPLS は各サービス クラスに対し事前に定義されたラベルを使用するため、スイッチは自動的に優先順位キューイングが必要なトラフィックを認識します。 宛先ごとに別のラベルを使用して各サービス クラスを指定します(図 10-8を参照)。

IPの 送信元/宛先ごとに最大 4 つまでラベルを使用できます。 このラベルを使用することにより、コア LSR は、クラスベースの WFQ を実現し、各サービス クラスに対する一定量の帯域幅とバッファを割り当てます。 セルはクラスごとにキューに入れられ、遅延保証が実現されます。

Cisco IP+ATM LSR では、各サービス クラスに割り当てられる重みは相対値であり、絶対値ではありません。 このため、スイッチはあるクラスから未使用の帯域幅を借りて、重みに応じて別のクラスに割り当てることができます。 これにより、帯域幅の利用がきわめて効率的になります。 クラスベースの WFQ ソリューションにより、未使用の帯域幅があるときはいつでもカスタマー トラフィックが送信されるようになります。これに対し、通常の ATM VC では、帯域幅がある場合でも加入過多のクラスのセルが廃棄されます。

図 10-8 IP QoS サービスの複数のLVC

 

パケットの IP ヘッダー内のタイプ オブ サービス フィールドには優先ビットがあり、ホストまたは途中のルータでセットされます。このルータはエッジ ラベル スイッチ ルータ(LSR)のこともあります。 優先ビットにより CoS 0 ~ 3 が定義され、それぞれ available(利用可能)、standard(標準)、premium(プレミアム)、control(制御)となります。

IGX と対応する LSC ルータの初期設定時に CoS を使った運用を確立するには、IGX 上の各 LVC インターフェイスに割り当てるバインディング タイプを、複数 LVC に設定します。

次に、ルーティング プロトコル(たとえば OSPF)で、各 IP 送信元/宛先の要件に対してネットワークで 4 つの LVC をセットアップします。 ATM LSR に送信されるパケット ATM セルは、エッジ LSR が受信するパケットにセットされた優先ビットに応じて、4 つのクラスのいずれかになります(セル ラベル、つまり VPI.VCI によって決定されます)。 さらに、セルの Cell Loss Priority(CLP; セル廃棄優先 )ビットを利用して、各クラス内で 2 つのサブクラスに区別されます。

その後で ATM LSR は MPLS データ テーブル検索を実行し、適切な CoS テンプレートと Qbin 特性を割り当てます。 表 10-8 に、CoS のデフォルト マッピングを示します。

 

表 10-8 タイプ オブ サービスと関連 CoS

サービス クラス マッピング
サービス クラス
IP ToS

Available

0

ToS 0/4

Standard

1

ToS 1/5

Premium

2

ToS 2/6

Control

3

ToS 3/7

図 10-9 は、IGX-ATM LSR で構成される ATM コアでの IP トラフィックの例です。 ホストは、双方向ビデオと非タイムクリティカル データの 2 種類のトラフィックをネットワークに送信します。 すべての IP 送信元/宛先パスに対して複数の LVC が自動生成されるため、各送信元/宛先のトラフィックは、IP パケット ヘッダー内の優先ビットの設定に基づいて、4つの LVC のどれかに割り当てられます。

この例の場合、ビデオ トラフィックは premium CoS に割り当てられ、ネットワークで伝送されることになります。 これはエッジ LSR-A からセル ラベル "51" で開始され、エッジ LSR-C に適用されたセル ラベル "91" でネットワークで伝送されます。各 IGX-ATM LSR では、セルは、"premium" トラフィックに見合う、事前に割り当てられた帯域幅、キューイング、その他の ATM QoS 機能で処理されます。

同様に、同じ IP 送信元/宛先を持つ低優先度のデータ トラフィック セルには、エッジ LSR-A でセル ラベル "53" が割り当てられ、"available" トラフィックに見合う、事前に割り当てられた帯域幅、キューイング、その他の ATM QoS 機能を利用しながら、最後にラベル "93" で エッジ LSR-C に到着します。

図 10-9 IGX での複数 LVC CoS の例

 

MPLS 対応 VPN

MPLS を使用して IP VPN のまったく新しいクラスを作成できます。 MPLS 対応 VPN(MPLS-VPN)は、フレームリレーまたは ATM VCを使用して構築された VPN と同じプライバシを持つ、コネクションレス ネットワークです。

Cisco MPLS ソリューションは、複数の IP サービス クラスを提供してビジネスベースのポリシーを実現します。 共通のインフラストラクチャ上にサービスを統合し、プロビジョニングとネットワークの運営を改善できるため、プロバイダーは、安価な管理 IP サービスを提供できます。

フレームリレーとマルチサービス ATM ではプライバシと CoS が実現されますが、IP では不特定多数の接続が実現されます。IGX-ATM LSR などの Cisco IP+ATM スイッチ上の MPLS により、プロバイダーは ATM のインフラストラクチャを使って、ビジネスクオリティの IP サービスが持つ利点を提供できます。

レイヤ 3 に構築される MPLS-VPN はコネクションレスであるため、従来のVPNに比べて非常に拡張性が高く、構築や管理も容易です。

また、アプリケーションおよびデータ ホスティング、ネットワーク商取引、電話サービスといった付加価値サービスを特定の MPLS-VPN に追加するのが容易で、サービス プロバダイダーのバックボーンは、各 MPLS-VPN を個別のコネクションレス IP ネットワークとして認識します。 IP+ATM VPN ネットワークで MPLS を使うことで、IP ネットワークの拡張性と柔軟性に ATM のパフォーマンスと QoS 機能が融合されます。

単一のアクセス ポイントから複数の VPN を配置できるようになりました。各 VPN は、異なるサービス セットを意味します(図 10-10を参照)。 ユーザとサービスをこのように柔軟にまとめることで、新しいサービスを迅速かつすぐれたコストパフォーマンスで提供できます。 非公開のユーザのグループを特定のサービスと対応付ける能力は、サービス プロバダイダーの付加価値サービス戦略にとって不可欠です。

図 10-10 VPN ネットワーク

 

VPN ネットワークは、音声、ミッションクリティカル アプリケーション、電子メールなどのアプリケーション タイプ別にトラフィックを認識できる必要があります。 ネットワークは、複雑なポイントツーポイント メッシュを設定しなくても、対応する VPN に基づいてトラフィックを簡単に分離できるべきです。

サービス プロバイダーが、ユーザが必要とするサービスでユーザをイントラネットまたはエクストラネットに簡単にグループ分けできるよう、ネットワークは「VPN 対応」でなければなりません。 そのようなネットワークで VPN がサービスプロバイダーに提供してくれる技術は、拡張性が高く、加入者が迅速かつ安全に新しいパートナーにエクストラネットを提供できるような技術です。 MPLS により、スイッチド ネットワークまたはルーテッド ネットワークは「VPN 対応」になります。 サービス プロバダイダーは、同じインフラストラクチャにあらゆるサイズのセキュア VPN を迅速かつコスト効率良く配置できます。

VPN QoS

VPN サービスの一環として、特定のカスタマーまたはアプリケーションからのトラフィックを高速に処理するような、SLA で定義したプレミアム サービスを提供できます。 IP ネットワークの QoS によって、ネットワーク ポリシーの指示に従ってトラフィックを優先的に処理するための知性が装置に与えられます。

QoS メカニズムによって、ネットワーク マネージャーは、ネットワークでの帯域幅、遅延、ジッタ、パケット損失を組み合わせて制御できるようになります。 QoS は装置の機能ではありません。エンドツーエンドのシステム アーキテクチャです。 堅牢な QoS ソリューションにはさまざまなテクノロジーがあり、システム全体の性能監視機能と組み合わせることで、拡張性があり、メディアに依存しないサービスが提供されます。


) VPN は、MPLS 用の CoS 機能と一緒に使用できます。 MPLS-VPN では、MPLS CoS を使用する必要がありません。 CoS ありの MPLS-VPN は URM-LSC でサポートされますが、URM-LSR ではサポートされません。


MPLS 対応 IP VPN ネットワークは、マルチメディア アプリケーションのサポート、パケット音声、アプリケーション ホスティングといった付加価値 IP サービスを提供するための基盤です。このような IP サービスでは、いずれも一定のサービス品質とプライバシが必要となります。 QoS とプライバシは MPLS と一体化した機能なので、個別のネットワーク処理は必要ありません。

シスコの総合的な QoS 機能を使用することで、プロバイダーは、サービス クラスの優先度の設定、帯域幅の割り当て、輻輳回避、レイヤ 2 の QoS とレイヤ 3 の QoS メカニズムの関連付けができます。

専用アクセス レート(CAR)
アプリケーションとプロトコル別にパケットを分類し、帯域幅割り当てを指定

低遅延キューイング(LLQ)
必要な場合に、ミッションクリティカルなアプリケーションのトラフィックを必ず転送し、クリティカルでないアプリケーションのトラフィックを遅らせることで、効率的な帯域幅利用を実現

重み付けランダム早期検出(WRED)
輻輳が発生する前に伝送速度を落として輻輳を回避し、一定の配信保証を必要とするミッションクリティカルなアプリケーションために、予測可能なサービスを実現

MPLS により、超大規模ルーテッド ネットワークで拡張性のある QoS が使用でき、ATM ネットワークでレイヤ 3 の IP QoS が使用できるようになります。これは、サービス クラスに対応するラベルのセットをプロバイダーが指定できるためです。 ルーテッド ネットワークでは、MPLS 対応の QoS により、コア全体にわたって処理をが大幅に削減され、パフォーマンスが最適化されます。 ATM ネットワークでは、MPLS により、エンドツーエンドのレイヤ 3 タイプのサービスが可能になります。

伝統的な ATM およびフレームリレー ネットワークでは、ポイントツーポイントの仮想回線で CoS を実現しますが、プロビジョニングと管理のオーバーヘッドが大きいので、拡張性がありません。 エッジでトラフィックをサービス クラスに入れることにより、プロバイダーは、ネットワーク全体でクラスを計画して管理できます。 サービス プロバイダーが、ポイントツーポイントの接続でなく、サービス クラスに基づいてネットワークを管理すると、追跡しなければならない詳細事項の量が大幅に削減され、機能を損なわずに効率を向上させることができます。

回線単位の管理と比べた場合、ATM ネットワークでの MPLS 対応 CoSは、複雑さが大幅に緩和されていながら、事実上ポイントツーポイント メッシュのすべての利点を備えています。 ATM ネットワークで IP CoS を実現するのに MPLS を使用すれば、VC ごとの設定が不要になります。 ネットワーク全体のプロビジョニングと設計が容易になります。

VPN セキュリティ

加入者は、自身の VPN、アプリケーション、通信がプライベートで安全であることを望みます。 シスコでは、情報の機密保持する堅牢なセキュリティ手段を数多くそろえています。

暗号化データ

アクセスを許可ユーザに制限

ネットワーク接続した後のユーザの追跡

リアルタイムの侵入監査

Cisco MPLS に基づくイントラネットおよびエクストラネット VPN では、パケットは一意の Route Distinguisher(RD; ルート区別子)を使用して転送されます。 RD はエンドユーザからは見えず、VPN のプロビジョニングの際、自動的に一意に割り当てられます。 VPN に加入するには、ユーザは対応する論理ポートに接続し、正しい RD を設定する必要があります。RD は、パケット ヘッダーに入れられ、トラフィックが特定の VPN コミュニティに属することが識別されます。

MPLS パケットは、IP ヘッダーの前に付くラベルを使って転送されます。 MPLS ネットワークは パケット ヘッダー内の IP アドレスを読み取らないので、さまざまなカスタマーの間で同じ IP アドレス空間が共有でき、IP アドレスの管理が簡単になります。

サービス プロバイダーは、フレームリレーやATM サービスでユーザが慣れているのと同じレベルのセキュリティを持った、完全に管理された MPLS ベースの VPN を提供できます。その際、PVC を手作業で設定したり、VPN customer premises equipment(CPE; 顧客宅内機器)ごとにルータを設定するといった、複雑なプロビジョニングは必要ありません。

QoS は、予測可能なパフォーマンスとポリシーの実現という、VPN 上で動作するアプリケーションに対する 2 つの要件に対処します。 ポリシーは、アプリケーション、プロジェクト グループ、サーバに対して優先度をつけてリソースを割り当てるのに使用します。 プロジェクトベースの要件とともにネットワーク トラフィックの量が増えると、サービス プロバイダーは、帯域幅の管理、ネットワーク ポリシーとビジネス ポリシーの調整を、動的かつ柔軟に行う必要が出てきます。

Cisco MPLS テクノロジーに基づくVPN は、同じインフラストラクチャで数千のビジネスクオリティ VPN をサポートできるだけの拡張性があります。 MPLS ベースの VPN サービスにより、大規模 VC と IP トンネル トポロジに共通するピア隣接関係と拡張性の問題が解決されます。 複雑なPVC/SVC(相手先固定接続/相手先選択接続)メッシュはもう必要がありません。プロバイダーは、新しい洗練されたトラフィック計画手法を使って、事前に決定されたパスを選択し、IP QoS をプレミアム ビジネス アプリケーションおよびサービスに提供します。

IP+ATM バックボーンでのMPLS VPN

サービス プロバイダーは、MPLS を使用して既存の ATM ネットワーク上で高度な IP VPN を構築できます。 ルーティング時のすべての決定は事前に計算されスイッチング テーブルに入っているため、MPLS を使うことでプロバイダー エッジで大規模 ATM ネットワークでの IP 転送が高速になると同時に、レイヤ 2 コア内で Cisco IOS テクノロジーを使ったレイヤ 3 の豊富なサービスが適用できるようになります。

既存の ATM コアを持っているサービス プロバイダーは、MPLS 対応エッジ スイッチまたはルータ(LSR)を配置して、差別化したビジネス IP サービスが提供できます。 サービス プロバイダーで必要なのは、プロバイダー エッジ スイッチまたはルータを相互接続して多くのセキュア VPN を供給する、少数の VC だけです。

Cisco IP+ATM ソリューションにより、ATM ネットワークは、IP アプリケーション トラフィックを ATM/フレームリレー トラフィックとまったく異なったものとして「見る」ことができます。 IP と ATM の両方の特性を持つことで、サービス プロバイダーはイントラネットまたはエクストラネット VPN をプロビジョニングできます。 シスコは MPLS を使った IP+ATM ソリューションを可能にし、Cisco IOS ソフトウェアのアプリケーションをキャリアクラスの ATM スイッチと統合します(図 10-11を参照)。

図 10-11 Cisco IP+ATM ネットワークでの MPLS-VPN

 

もし MPLS がないと、ATM ネットワーク上で IP を転送するのに、IP の アドレッシングおよびルーティングを ATM のアドレッシングおよびルーティングにマッピングするための変換規則の複雑な階層が必要になります。

MPLS では、IP アドレッシングおよびルーティング情報を ATM スイッチング テーブルに直接マッピングすることで、複雑さが解消されます。 MPLS のラベル スワッピング パラダイムは、ATM スイッチが ATM セルの転送に使用するのと同じメカニズムです。 このソリューションは、サービス プロバイダーにとってさらに利点をもたらします。差別化されたビジネスクオリティの IP サービスの提供を可能としながら、現在のフレームリレー、専用回線、ATM サービス ポートフォリオを提供し続けることができます。

組み込み VPN の認知度

豊富な機能を持つ IP VPN を高いコストパフォーマンスでプロビジョニングするには、プロバイダーは、各種のアプリケーション トラフィックを区別し、プライバシと QoS を適用する機能が必要です。その際、オーバーレイ IP トンネル、フレームリレー、ATM「メッシュ」のどれよりも複雑さがはるかに少ないことが必要です。

オーバーレイ ソリューションと比べた場合、MPLS 対応ネットワークは、トンネリングや暗号化なしでトラフィックを分離してプライバシを提供できます。 フレームリレーまたは ATM でコネクションごとにプライバシが提供されるのと同様に、MPLS 対応ネットワークではネットワークごとにプライバシが提供されます。 フレームリレーまたは ATM VPN は基本的な伝送路を提供しますが、MPLS 対応ネットワークは、拡張可能な VPN サービスと IP ベースの付加価値アプリケーションをサポートします。 この手法は、転送志向モデルからサービス中心モデルへのサービス プロバイダーのビジネス シフトの一環です。

MPLS 対応 VPN では、IP スイッチド コアまたは ATM LSR スイッチ コアのどちらを使う場合でも、プロバイダーは各 VPN にルート区別子(RD)と呼ばれる一意の識別子を割り当てます。これはプロバイダー ネットワーク内のイントラネットまたはエクストラネットごとに異なります。 転送テーブルは VPN-IP アドレス(図 10-12を参照)と呼ばれる一意のアドレスから成り、RD をカスタマーの IP アドレスに関連付けています。 VPN-IP アドレスはネットワークのエンドポイントごとに一意であり、エントリは、VPN の各ノードについて転送テーブルに保存されます。

図 10-12 VPN-IP アドレス形式

 

BGP プロトコル

Border Gateway Protocol(BGP; ボーダー ゲートウェイ プロトコル)はルーティング情報配布プロトコルであり、MPLS 拡張機能とコミュニティ属性を使用して誰と誰が話すことができるかが定義されています。 MPLS 対応 VPN では、BGP は同じ VPN のメンバーにだけ VPN に関する情報を配布し、トラフィックの分離を通じてネイティブ セキュリティが実現されます。 図 10-13 は、サービス プロバイダーのエッジ ラベル スイッチ ルータ(PE)とカスタマー エッジ ルータ(CE)が接続されたサービス プロバイダー ネットワークの例です。 「BGP」と書かれた両頭の矢印は、ATM バックボーン スイッチです。

すべてのトラフィックが LSR を使って転送されるため、さらにセキュリティが強化されます。LSR によりネットワーク中の具体的なパスが決まりますが、これは変更できません。 このラベルベースのパラダイムは、フレームリレーや ATM のコネクションでプライバシを保証しているのと同じものです。

図 10-13 サービス プロバイダー バックボーンでの VPN

 

VPN のプロビジョニング時に、カスタマーではなくプロバイダーが特定の VPN を各インターフェイスに対応付けます。 プロバイダー ネットワーク内では、RD はすべてのパケットに関連付けられるため、フローやパケットを「スプーフィング」しても VPN に侵入できません。 ユーザがイントラネットまたはエクストラネットに参加できるのは、正しい物理ポートに接続されて正しい RD を持っている場合です。 この設定によって Cisco MPLS 対応 VPN への侵入が困難になり、フレームリレー、専用回線、ATM サービスでユーザが慣れているのと同じセキュリティ レベルが実現されます。

VPN-IP 転送テーブルには、VPN-IP アドレスに対応するラベルが入っています。 このラベルにより、トラフィックは VPN の各サイトにルーティングされます(図 10-14を参照)。

IP アドレスの代わりにラベルが使用されるため、企業のインターネット内ではプライベートなアドレス割り当て方式をそのまま使えます。プロバイダーのネットワーク経由でトラフィックを受け渡すために、Network Address Translation(NAT; ネットワーク アドレス変換)を使う必要はありません。 トラフィックは、各 VPN に対して論理的に別個の転送テーブルを使用して、VPN ごとに分離されます。 スイッチは、着信インターフェイスに応じて転送テーブルを選択しますが、このテーブルには、BGP によって指定された、その VPN 内の有効な宛先だけが入っています。 エクストラネットを構築するため、プロバイダーは明示的に VPN 間の到達可能性を設定します。 NAT の設定が必要な場合もあります。

図 10-14 MPLS による VPN の構築

 

MPLS の長所のひとつは、プロバイダーは同じインフラストラクチャを使用して多くの VPN をサポートでき、カスタマーごとに別のネットワークを構築する必要がないということです。 VPN は、プロバイダー ネットワークの「サブネット」にほぼ対応しています。

このソリューションでは、ネットワーク自身に IP VPN 機能が構築されるため、プロバイダーは 1 つのネットワークで全加入者用の設定ができます。このネットワークは、複雑な管理、トンネル、または VC メッシュなしで、イントラネットやエクストラネットといったプライベートな IP ネットワーク サービスを提供します。 アプリケーション対応 QoS により、VPN にカスタマーごとのビジネス ポリシーが適用できるようになります。 MPLS ベースの VPN への QoS 追加はスムーズに行われ、プロバイダーのエッジ LSR は、VPN 内の各アプリケーションについて正しい優先度を割り当てます。

MPLS 対応の IP VPN ネットワークは、IP ベースのカスタマー ネットワークとの統合が容易です。 加入者は、イントラネット アプリケーションを変更しなくてもプロバイダー サービスとスムーズに相互接続できます。アプリケーション対応が組み込まれており、プライバシ、QoS、不特定多数間でのネットワーキング機能を持っているためです。 利用者は、NAT なしでプライベート IP アドレスを透過的に使用することさえできます。

同じインフラストラクチャで多くのカスタマーの多くの VPN をサポートし、オーバーレイ VPN のように、カスタマーごとに個別に新規ネットワークを設計する負担が不要になくなります。

追加、移動、変更も非常に容易です。 企業が VPN に新しいサイトを追加する場合、サービス プロバイダーは CPE ルータにネットワークへの到達方法を指定し、LSR を設定して CPE の VPN メンバーシップを認識させるだけです。 BGP により、VPN メンバーが自動的に更新されます。

この方法は、新しいサイトごとに新しいポイントツーポイント VC メッシュを構築するよりも簡単、迅速、安価です。 オーバーレイ VPN に新しいサイトを追加するには、トラフィック マトリックスの更新、新規のサイトから既存の全サイトへのポイントツーポイント VC のプロビジョニング、全サイトの OSPF 設計の更新、各 CPE の新しいテクノロジーに対する再設定が必要です。

仮想ルーティング/転送

各 VPN は、1 つ以上の VPN routing/forwarding instance(VRF; VPN ルーティング/転送インスタンス)と対応付けられます。 VRF テーブルにより、PE ルータに接続するカスタマー サイトで VPN が定義されます。VRF テーブルの構成要素は、次のとおりです。

IP ルーティング テーブル

導出された Cisco Express Forwarding (CEF; Cisco エクスプレス転送)テーブル

転送テーブルを使用するインターフェイスのセット

転送テーブルに登録する内容を決定する規則とルーティング プロトコル変数のセット

カスタマー サイトと VPN の間は必ずしも 1 対 1 の関係ではありません。特定のサイトを、複数の VPN のメンバーにすることができます。ただし、1 つのサイトが関連付けられる VRF は、1 つに限られます。 サイト VRF を構成するのは、メンバーとなっている VPN からサイトが利用できる全ルートです。

パケット転送情報は、各 VRF 用の IP ルーティング テーブルと CEF テーブルに保存されます。この 2 つのテーブルを合わせたものは、ラベル スイッチングで使用される転送情報ベース(FIB)に似ています。

各 VRF について、論理的に無関係なルーティング テーブルと CEF テーブルのセットが作成されます。この 2 つのテーブルによって、情報が当該 VPN から外部に転送されるのを防ぐと同時に、VPN の外側からのパケットが VPN 内部のルータに転送されるのも防ぎます。

VPN ルートターゲット コミュニティ

VPN ルーティング情報の配布は、VPN ルートターゲット コミュニティを使用して制御されます。VPN ルートターゲット コミュニティは、BGP 拡張コミュニティによって実装されています。

VPN ルートが BGP に投入されると、VPN ルートターゲット拡張コミュニティのリストに関連付けられます。 一般的に、VPN コミュニティ リストは、ルート情報のある VRF に対応する拡張コミュニティ区別子のエクスポート リストを通して設定されます。

各 VRF には、ルートターゲット コミュニティのインポート リストが対応付けられています。 このリストには、特定ルートを VPN ルーティング インスタンスにインポートするのが妥当であるか判断するために、VRF テーブルで確認すべき値が定義されています。

たとえば、特定の VRF のインポート リストに、コミュニティ区別子 A、B、および C がある場合、A、B、 または C を伝送する VPN ルートすべてが VRF にインポートされます。

VPN ルーティング情報の BGP による配布

サービス プロバイダの PE ルータは、IP プレフィックスを、customer edge(CE)ルータの静的な設定、CE ルータとの BGP セッション、または CE ルータとの Routing Information Protocol(RIP; ルーティング情報プロトコル)を通して入手できます。

ルータは、プレフィックスを入手すると、8 バイトのルート区別子を IP プレフィックスに結合して、IP プレフィックスに基づく VPN-IPv4(vpnv4)プレフィックスを生成します。サイトがグローバルには一意でない IP アドレス(未登録のプライベート IP アドレス)を使用している場合であっても、この拡張された VPN-IPv4 アドレスにより、各 VPN サイト内でホストが一意に識別されます。

VPN-IPv4 プレフィックスの作成に使用される RD は、PE 上の設定コマンドで指定します。

BGP は、VPN-IPv4 アドレスを使用して、サービス プロバイダー ネットワーク内の各 VPN についてのネットワーク到達可能性情報を配布します。 BGP は、メッセージを使用して IP ドメイン(自律システムという)間でルーティング情報を配布し、ルーティング テーブルを構築または保守します。 BGP 通信は、ドメイン内(内部 BGP つまり IBGP)またはドメイン間(外部 BGP つまり EBGP)の 2 つのレベルで行われます。

BGP は、拡張アドレスを取り扱うために、BGP マルチプロトコル拡張を使用して、vpnv4 情報を伝えます(RFC 2283の 『 Multiprotocol Extensions for BGP-4 』を参照してください)。 BGP は、到達可能性情報(VPN-IPv4 アドレスとして表される)を PE ルータ間で伝えます。VPN の到達可能性情報は、その VPN の他のメンバーだけに伝えられます。 BGP マルチプロトコル拡張によって、VPN ルーティング情報の有効な配布先が識別されます。 VPN のすべてのメンバーは他のメンバーのルート情報を入手します。

MPLS ラベル転送

Cisco ラベル スイッチングでは、各 VRF の IP ルーティング テーブルと CEF テーブルに格納されているルーティング情報に基づき、拡張 VPN-IPv4 アドレスを使用してパケットが宛先に転送されます。

MPLS ラベルは、各カスタマーのルートに対応付けられます。PE ルータは、ルートで決まるラベルを割り当て、データ パケットが正しい CE ルータに向かうようにします。

プロバイダーのバックボーン内では、ダイナミック IP パスまたはトラフィック計画されたパスに基づいてラベル転送が行われます。利用者のデータ パケットは、バックボーンを内で転送されるとき、次の 2 つのレベルのラベルが付けられます。

最初のラベルによって、パケットは正しい PE ルータに向かいます。

2 番目のラベルで、PE ルータがどのようにパケットを転送するかが決まります。

PE ルータでは、各 CE ルータと、その CE ルータが使用可能なルートの内容だけを含む転送テーブルとが対応付けられます。

no auto-summary
redistribute static
exit-address-family
!
address-family ipv4 unicast vrf vrf2
neighbor 10.20.1.11 activate
no auto-summary
redistribute static
exit-address-family
!
! Define a VRF static route
ip route vrf vrf1 12.0.0.0 255.0.0.0 e5/0/1 10.20.0.60
 

IGX でマージされる VC


Switch Software Release 9.3.40 より前のリリースでは、IGX での VC マージはサポートされていません。


IGX での VC マージ機能とは、複数の着信 VC を 1つの発信 VC(結合 VC)に結合し、MPLS ネットワークの拡張性を向上させる機能です。 VC マージは、UXM-E にある ATM インターフェイスの出力バッファリングの一部として実装されます。 各 VC マージは、接続の出方向で実行されます。

スレーブ間接続、スレーブ内接続ともにサポートされます。 ただし、OAM セル形式も MPLS コントローラの tagABR もサポートされていません。


) VC マージは UXM カードではサポートされていません。


UXM-E で VC マージを使用するには、接続が次の条件を満たしている必要があります。

接続は片方向である。

接続は Virtual Channel Connections(VCC; 仮想チャネル接続)である。


) IGX での VC マージでは、Virtual Path Connections(VPC; 仮想パス接続)はサポートされません。


接続が単一エンドポイントの接続でない。

マージ対象の接続は同じサービス タイプを使用している。

IGX でサポートされる MPLS 接続

IGX での直接 MPLS 接続は、URM カード上だけでサポートされます。 表 10-9 に記載されていない機器で MPLS 接続を設定するには、外部 Label Edge Router(LER; ラベル エッジ ルータ)を使用します。


) VISM 接続の場合は、URM は VoIP だけをサポートします。


 

表 10-9 URM でサポートされる接続

ハードウェア
プラットフォーム
接続エンドポイント
接続の種類
音声接続
データ接続

Cisco BPX

BXM

CBR

Y

Y

Cisco BPX

BXM

VBRrt

Y

Y

Cisco BPX

BXM

VBRnt

Y

Y

Cisco BPX

BXM

ABR

N

Y

Cisco BPX

BXM

UBR

N

Y

Cisco BPX

BXM

FST

N

Y

Cisco IGX

UXM

CBR

Y

Y

Cisco IGX

UXM

VBRrt

Y

Y

Cisco IGX

UXM

VBRnt

Y

Y

Cisco IGX

UXM

ABR

N

Y

Cisco IGX

UXM

UBR

N

Y

Cisco IGX

UXM

FST

N

Y

Cisco IGX

UFM

FR

Y FRF.8 SIW

Y FRF.8 SIW

Cisco IGX

UFM

FST

N

Y FRF.8 SIW

Cisco IGX

URM

CBR

Y

Y

Cisco IGX

URM

VBRrt

Y

Y

Cisco IGX

URM

VBRnt

Y

Y

Cisco IGX

URM

ABR

N

Y

Cisco IGX

URM

UBR

N

Y

Cisco IGX

URM

FST

N

Y

Cisco IGX

CVM

--

N

N

Cisco IGX

HDM

--

N

N

Cisco IGX

LDM

--

N

N

Cisco MGX

VISM

--

Y

N

Cisco MGX

RPM

--

N

Y

Cisco MGX

FRSM

FR

Y FRF.8 SIW

Y FRF.8 SIW

Cisco MGX

FRSM

FST

N

Y FRF.8 SIW

Cisco MGX

AUSM

CBR

Y

Y

Cisco MGX

AUSM

VBRrt

Y

Y

Cisco MGX

AUSM

VBRnt

Y

Y

Cisco MGX

AUSM

ABR

N

Y

Cisco MGX

AUSM

UBR

N

Y

Cisco MGX

AUSM

FST

N

Y


) VoATM 接続には FRF.8 SIW 透過モードを使用し、VoIP およびデータ接続には FRF.8 SIW 変換モードを使用します。


IP サービスのプロビジョニング

URM カードを使用することで、IGX のさまざまな複雑な IP サービスをプロビジョニングできます。

VoIP または VoATM のインシャーシ ルータとして URM を使用する場合、基本的な URM の設定については、カードおよび URM で使用する Cisco IOS ソフトウェアについて記載した Cisco IOS ソフトウェア マニュアルを参照してください。

IPsec-VPN 機能を備えたインシャーシ ルータとして URM を使用する場合、VPN への正しい AIM モジュールの取り付けについては、『 Cisco IGX 8400 Series Installation Guide 』の「 Installing the Encryption Advanced Interface Module 」の章を参照してください。 IPSec の設定については、「Cisco IOS ソフトウェアのマニュアル」に記載の Cisco IOS マニュアルを参照してください。

ここでは、IGX スイッチを外部コントローラと組み合わせて使うようにセットアップする方法を説明します。これは IGX を MPLS 用に設定する準備となります。IGX 上での MPLS の設定については、「IGX での MPLS の設定」を参照してください。IGX 上での MPLS-VPN の設定については、「MPLS VPN の設定例」を参照してください。


ヒント IGX でサポートされるその他の Cisco IOS 機能については、URM で使用する Cisco IOS ソフトウェア リリースのリリース ノートを参照してください。


コントローラのリソースのプランニング

コントローラでは、IGX ポートでのシグナリングに少なくとも 150 Cps の帯域幅の空きを確保しておく必要があります。 最低限の 150 Cps がポートで利用できない場合は、スイッチ ソフトウェアのコマンド addctrlr を実行できません。 帯域幅の空きを計算するには、次の式を使用します。

空き帯域幅 = ポート速度 - PVC 最大帯域幅 - VSI 帯域幅

150 Cps の空き帯域幅を得るために、AutoRoute に割り当てる帯域幅の変更が必要なこともあります。 ポートの帯域幅を割り当て直すには、スイッチ ソフトウェアのコマンド cnfrsrc を使用します。

VSI の設定


) インターフェイスに VSI 配分を設定しなくても、その UXM インターフェイスにコントローラを追加できますが、その場合、インターフェイスを VSI 接続で使用できません。 たとえば、MPLS コントローラの XTAG インターフェイス サポートには、ホスティングしているインターフェイスと XTAG インターフェイス間のタグ制御 VC(tag-control-VC)の設定が含まれます。 この VC は VSI 接続です。したがって、コントローラは、ホスティングしているインターフェイスに VSI 配分が設定されるまでは、VSI 接続を設定できません。


VSI のノードを設定する手順は、次のとおりです。


ステップ 1 リソースの割り当てを計画します(「論理スイッチの配分とリソースの割り当て」を参照)。

ステップ 2 スイッチ ソフトウェアのコマンド uptrk upln upport を使用して、設定済みパーティションの目的のトランク、回線、ポートをアクティブにします。

ステップ 3 スイッチ ソフトウェアのコマンド cnfrsrc を使用して、アクティブ インターフェイスにパーティション リソースを設定します(コマンドのパラメータは 表 10-10 を参照)。


ヒント VPI の範囲はローカルで重要であり、ノード内の各ポートで同じである必要はありません。 ただし、追跡の目的のため、ノード内の各ポートで VPI の範囲を同一にすることをお勧めします。


 

表 10-10 cnfrsrc コマンドのパラメータ

パラメータ(オブジェクト)名
範囲/値
デフォルト
説明

VSI 配分

1~3

1

一意の配分 ID を指定

配分の状態

D = 配分を無効にする
E = 配分を有効にする

D

配分の有効/無効化(必須オブジェクトが必要)

最小 LCN 数

0~8000


) URM では 0 ~ 941


0

選択した配分に保証されている最小 LCN(接続)を指定

最大 LCN 数

0~8000


) URM では 0 ~ 941


0

選択した配分に許可されている最大 LCN(接続)を指定

開始 VPI

0 ~ 255(UNI の場合)
0 ~ 4095 (NNI の場合)


) URM では NNI はサポートされません。


0

選択した配分の初期インターフェイスを指定

終了 VPI

0 ~ 255(UNI の場合)
0 ~ 4095 (NNI の場合)


) URM では NNI はサポートされません。


0

選択した配分の最終インターフェイスを指定

最小帯域幅

0 ~最大回線速度

0

選択した配分に利用可能な最小帯域幅を指定

最大帯域幅

0 ~最大回線速度

0

選択した配分に利用可能な最大帯域幅を指定

ステップ 4 スイッチ ソフトウェアのコマンド addctrlr を使用して、コントローラを追加します。


addctrlr コマンドがサポートするのは、AnnexG プロトコルのサポートが不要な MPLS と汎用 VSI コントローラだけです。



ヒント addctrlr では、コントローラ ID を、1 ~ 16 の範囲の一意の識別子で指定する必要があります。 異なるコントローラには別のコントローラ ID を指定します。


ステップ 5 ATM CoS テンプレートをインターフェイスに割り当てます(ATM サービスのみ。「ATM サービスの機能の概要」を参照)。

ステップ 6 スレーブを追加します(VSI のマスターとスレーブの詳細については、「VSI マスターおよびスレーブ」を参照)。

ステップ 7 スレーブ冗長構成を設定します(UXM と UXM-E のみ)。


ヒント URM では、ホット スタンバイのスレーブ冗長構成はサポートされません。 URM では、冗長な配分を設定して、ウォーム スタンバイの冗長構成にする必要があります。 『MPLS Label Switch Controller and Enhancements 12.2(8)T』を参照してください。


ステップ 8 スイッチ ソフトウェアのコマンド dspctrlrs を使用して、コントローラの設定を表示します。

ステップ 9 リソースを管理します。


ヒント IGX に接続されたすべての VSI コントローラを表示するには、dspctrlrs を使用します。 IGX からコントローラを削除するには、delctrlr を使用します。



) インターフェイス シェルフとして機能する MPLS コントローラは、ラベル スイッチ コントローラとして指定します。



 

論理スイッチの配分とリソースの割り当て

リソースを有効化して、そのリソースを配分に割り当てることで、論理スイッチが設定されます。 この設定は、インターフェイスの配分ごとに実行する必要があります。同じ手順を繰り返して、論理スイッチを個別に定義します。

論理スイッチに割り当てるリソースは次のとおりです。

LCN

帯域幅

VPI の範囲

リソースはインターフェイスごとに設定して割り当てますが、リソース プールは異なるレベルで管理する場合があります。帯域幅はインターフェイスの速度によって制限されます。同様に、VPI の範囲もインターフェイス レベルで決まります。

インターフェイスの VSI 配分に設定するパラメータは次のとおりです。

min lcn:インターフェイスの当該配分で保証する LCN 数

max lcn:当該配分がインターフェイスで接続のセットアップができる最大 LCN 数

min bw:インターフェイスの当該配分で保証する帯域幅

max bw:インターフェイスの当該配分の最大帯域幅

start vpi:インターフェイスの当該配分用に予約される VPI 範囲の下限

end vpi:インターフェイスの当該配分用に予約される VPI 範囲の上限

配分の設定には cnfrsrc コマンドを使用します。


) スイッチ ソフトウェア リソース 9.3 以降では最大 3 つまでの配分がサポートされます。


表 10-11 は、ifc1(インターフェイス コントローラ 1)に指定した配分に設定する 3 つのリソースです。

 

表 10-11 ifc1 のパラメータ(仮想スイッチ インターフェイス)

ifc1 のパラメータ
最小
最大

lcns

min_lcn

max_lcn

bw

min_bw

max_bw

vpi

min_vpi

max_vpi

コントローラには、LCN、VPI、帯域幅の範囲を指定します。 表 10-12 は、VPI 配分に利用できる VPI 値の範囲の例です。

 

表 10-12 配分の VPI の範囲

UXM
範囲

トランク

1 ~ 4095 VPI 範囲(UNI/NNI)

ポート

UNI:1 ~ 255/NNI:1 ~ 4095

仮想トランク

現在、仮想トランクは特定の VPI で定義されているため、仮想トランクごとに利用できる VPI は 1 つだけです。

トランクがアクティブになると、帯域幅全体が AutoRoute に割り当てられます。割り当てを変更して VSI にリソースを供給する場合は、IGX スイッチで cnfrsrc コマンドを使用します。

AutoRoute PVC と 3 つの VSI LSC コントローラとの間で配分リソースを設定できます。その結果、コントロール プレーンが異なる最大 3 つの VSI コントローラが、互いに通信を行うことなく個別にスイッチを制御できます。 コントローラは、スイッチを共用している他のコントロール プレーンを認識しません。コントロール プレーンが違えばスイッチ リソースの配分も異なるためです。

VSI の複数配分には次の制約があります。

サポートされる配分は最大 3 つまで。

VSI 配分に割り当て済みのリソースは、他の VSI 配分に再割り当てが可能。

配分に割り当てられるリソースは、LCN、帯域幅、VPI 範囲。

リソースは AutoRoute に割り当てられます。 このリソースは AutoRoute から解放して VSI に割り当てることができます。

仮想トランクでは複数の配分はサポートされません。仮想トランクは、AutoRoute または単一の VSI 配分のいずれかで管理されます。

VSI 配分は IGX スイッチにローカルであり、ネットワーク全体には関係がありません。

複数配分の例

各論理スイッチは、それぞれに一組のリソースが割り当てられたインターフェイスの集合体を表します。

以降の例は、次の 4 つのインターフェイスを持つ IGX です。

10.1

10.2.1

11.1

11.7.1

図 10-15 のインターフェイス設定については、例10-1を参照してください。 表 10-13 は、3 つの配分が有効になっている例です。

図 10-15 仮想スイッチ

 

インターフェイスのリソース配分を表示するには、 dsprsrc コマンドを使用します(例10-1を参照)。

例10-1 複数の配分がある IGX の設定

sw188 TN Cisco IGX 8420 9.3.10 Aug. 16 2000
16:47 GMT
 
VSI Partitions on this node
 
Interface (slot.port) Part 1 Part 2 Part 3
Line 10.1 E E D
VTrunk 10.2.1 D D D
Trunk 11.1 E E D
VTrunk 11.7.1 E D D
 
 
Last Command:dsprsrc
 
 
Next Command:

 

表 10-13 配分の例

インタフェース
AutoRoute
パーティション 1
パーティション 2
パーティション 3

4.2

lcns:1000
bw:20000 Cps

有効
lcns:2000
bw:1000 ~ 2000 Cps
vpi:200 ~ 250

有効
lcns:2000
bw:77840~77840 Cps
vpi:20 ~ 29

有効
lcns:2000
bw:1000 ~ 2000 Cps
vpi:30 ~ 50

UXM と UXM-E のスレーブ冗長構成

対になった 2 つの冗長構成スレーブによって、すべての VSI 接続で冗長カードのホット スタンバイ状態が維持されます。これは、Y 冗長性を追加する際に、その時点で存在している接続を(スタンバイ スレーブ上で)一括して更新するとともに、その後のすべての接続で順次更新することで実現します。

スレーブ ホット スタンバイ冗長化機能を利用すれば、冗長カードを使ってアクティブ カード上のすべての VSI 接続を完全に二重化し、切り替え時の運用に備えることが可能になります。冗長側のカードは、自身の起動時にアクティブ カード上の接続情報を一括して取り込み、高速同期が可能になります。その後は、アクティブ カードがリアルタイムで冗長カードを更新します。

VSI スレーブのホット スタンバイ冗長化機能では、スレーブのスタンバイ カードがアクティブ カードと同じ状態に維持されるように、事前にプログラムすることが可能です。その結果、アクティブ カードで障害が発生しても、迅速にスレーブ カードに切り替えることができます。UXM カードで VSI の処理を行わない場合でも、NPM から送られてくる CommBus メッセージをスタンバイ UXM カードも受け取るようにすることで、UXM カードのホット スタンバイ機能を実現できるようになっています。

以降の項では、VSI マスターと VSI スレーブの冗長化をサポートするために必要な、スイッチ ソフトウェアとファームウェア間の通信の種類について説明します。

VSI スレーブの冗長性ミスマッチ チェック

UXM カード上でスムーズに VSI 機能に移行できるように、回線とトランクの Y 冗長性がサポートされています。特定のスロットで VSI 機能が有効に設定されていない場合、VSI 機能を持つカードと持たないカードをペアにして、Y 冗長ペアにできます。VSI 機能が設定されていないスロットでは、スイッチ ソフトウェアは、UXM ファームウェアが VSI 機能をサポートしているかどうかをチェックする「ミスマッチ チェック」を行いません。VSI 機能の有無はカード アトリビュートとして扱われ、アトリビュート リストに追加されます。

Y 冗長構成では、ペアとして VSI 機能があるかどうかは、ペアを構成する 2 枚のカードに VSI 機能があるかどうかで決まります。 VSI 機能がないカードでは、インターフェイスのどれかがコントローラにアクティブな配分を持っている場合はミスマッチとなります。 VSI をサポートしない論理カードで配分を有効にするか、コントローラを追加しようとしても、受け付けられません。

コントローラとスレーブの追加および削除

ノードに LSC を追加する場合は addctrlr コマンドを使用します。コントローラを追加するときに、配分 ID を指定する必要があります。配分 ID によって、コントローラに割り当てる論理スイッチが識別されます。 有効な配分は 1、2、3です。


) 自動ルーティング管理 PVC と 3 つの VSI LSC コントローラとの間で配分のリソースを設定できます。


ノードのコントローラ リストを表示させるには、 dspctrlrs コマンドを使用します。スイッチの MIB にある switchIfTable を SNMP で参照することでも、同じことができます。

VSI スレーブのリソースを管理するためには、ノードにある各スレーブとそのノードに接続されている各コントローラの間に通信制御 PVC がなければなりません。 addctrlr コマンドを使用して IGX にコントローラを追加すると、NPM が、新しく追加したコントローラのポートとスイッチ内のすべてのアクティブ スレーブとの間に、マスター スレーブ間接続をセットアップします。接続は既知の VPI.VCI(well known VPI.VCI)を使ってセットアップされます。マスター スレーブ間接続の VPI のデフォルト値は 0、VCI のデフォルト値は(40 + [ slot - 2])の式で計算されます( slot はスレーブの論理スロット番号)。


) コントローラをノードに追加すると、そのコントローラとスレーブ間の接続インフラストラクチャが常時維持されます。 コントローラは、その状態によって、この接続を使用することも使用しないこともあります。 コントローラが存在するかどうかに関係なく、スレーブ間チャネルは存在します。


制御 VC のセットアップに使うチャネル(16 スロット スイッチの 14 から 32 スロット スイッチの 30)が十分にない UXM スレーブが 1 つでもあると、コントローラをノードに追加できません。

スレーブは、NPM からコントローラ設定メッセージを受信すると、VSI メッセージ トラップをコントローラに送信してスレーブの存在を通知します。 これにより、スレーブでインターフェイス検出プロセスを開始するコントローラからの交換が促されます。

コントローラが追加されると、NPM は VSI 設定 CommBus メッセージにこのコントローラの情報を付けて、各スレーブに送ります。そして、そのコントローラのポートと各スレーブの間に、対応する制御 VC をセットアップします。

スレーブの追加

VSI をサポートする UXM カードで最初の回線またはトランクをアクティブにしてノードでスレーブを新たに起動すると、NPM は VSI 設定 CommBus(IGX 内部のプロトコル)メッセージにそのスイッチに接続されているコントローラのリストを付けて送信します。

NPM はスイッチ内の各コントローラ ポートと追加したスレーブとの間に、マスター スレーブ間接続をセットアップします。 また、新しいスレーブともう一方のアクティブな VSI スレーブとの間にスレーブ間接続をセットアップします。


) スタンバイ モードのスレーブは、設定済みの VSI とみなされず、スレーブ間接続では考慮されません。


コントローラの削除

インターフェイスに追加されているコントローラを削除するには、 delctrlr コマンドを使用します。

delctrlr コマンドでコントローラのどれかが削除された場合、マスター スレーブ間接続と、すべての UXM カードでこのコントローラに対応付けられた接続が削除されます。 VSI 配分はノードに設定されたままです。

コントローラを削除すると、新しい VSI 設定メッセージが送信されます。 このメッセージにはノードに接続されているコントローラのリストが含まれ、削除済みのコントローラはリストから削除されています。このメッセージは、ノード内の各アクティブ スレーブに送信されます。

ノードの配分にコントローラが 1 つでも接続されている限りは、その配分に割り当てられたリソースは、その他のコントローラがノードから削除されることによる影響を受けません。 スレーブは、配分自身が無効にされたときに初めて、配分で使用しているすべての VSI リソースを解放します。

スレーブの削除

カードの最後の回線またはトランクをダウンすることでスレーブが停止すると、NPM は、スレーブとノードのコントローラ ポート間のマスター スレーブ間接続を切断します。 NPM はまた、スレーブをもう一方のアクティブ VSI スレーブに接続するすべてのスレーブ間接続も削除します。

IGX での VC マージ


) VC マージは UXM ではサポートされていないため、UXM-E と UXM を使用して Y 冗長性をセットアップすると、必ず機能ミスマッチ エラーとなります。 UXM-E と UXM との間で Y 冗長性を設定した場合は、VC マージ機能を有効にできません。


Switch Software Release 9.3.40 では、IGX での VC マージがサポートされています。

2 つの UXM-E カードに Y 冗長性を設定するには、まず両方のカードで VC マージ機能のサポートが有効になっているか確認する必要があります。 両カードは、VC マージ機能をサポートするカード ファームウェアを備えている必要があります。

UXM-E での Y 冗長性の詳細については、「機能の概要」「カードの冗長性」を参照してください。


ヒント VC マージを有効にする前に、cnfrsrc コマンドでチャネルの最小数を 550 に設定します。 カード上でこの最小チャネル数が利用できない場合は、エラー メッセージが表示されます。


IGX で VC マージを有効にするには、次の手順を実行します。


ステップ 1 cnfcdparm slot number 2 e コマンドを使用して、VC マージのカード パラメータを設定します。

ステップ 2 次のようなエラー メッセージが表示された場合は、ステップ 1を繰り返します。

Card rejected cmd. VC Merge NOT enabled!

ステップ 3 スイッチの設定または管理を続けます。


ヒント IGX で VC マージの現在のステータスを表示するには、dspcdparm slot number コマンドを入力します。



 

IGX で VC マージを無効にするには、次の手順を実行します。


ステップ 1 cnfcdparm slot number 2 d コマンドを使用して、VC マージのカード パラメータを設定します。

ステップ 2 次のメッセージで y を入力して VC マージの無効化を続けます。

Disabling VC Merge with active VSI partns on card may result in dropped conns
Continue?
 

ステップ 3 次のようなエラー メッセージが表示された場合は、ステップ 1 および ステップ 2を繰り返します。

Card rejected cmd. VC Merge NOT disabled!
 

VC マージがまだ有効な間にスロットの最後の配分を無効にすると、スロットの VC マージは無効になり、カードでは次のエラー メッセージが表示されます。

Disabling of last partn on slot has caused disabling of VC Merge.
 

ステップ 4 スイッチの設定または管理を続けます。


 

IGX 上の VSI に関連するスイッチ ソフトウェアのコマンド

 

表 10-14 VSI セットアップ用のスイッチ ソフトウェアのコマンド

ニーモニック
説明

addctrlr

ノードにコントローラを接続する。

cnfctrlr

コントローラを設定する。

cnfqbin

Qbin を設定する。

cnfrsrc

リソースを設定する。 例:AutoRoute PVC または MPLS コントローラ(LSC)

cnfvsiif

インターフェイスに違うクラス テンプレートを割り当てる。

delctrlr

IGX ノードから MPLS コントローラなどのコントローラを削除する。

dspchuse

指定スロットのチャネル振り分け状態のサマリー画面を表示する。

dspctrlrs

IGX ノードの VSI コントローラを表示する。

dspqbin

現在 Qbin に設定されている Qbin パラメータを表示する。

dspqbint

Qbin テンプレートを表示する。

dsprsrc

配分リソースを表示する。

dspsct

インターフェイスに割り当てられた SCT を表示する。このコマンドには、次の 3 つの実行レベルがあります。

dspsct
引数を指定しない場合、ノード上のすべてのサービス テンプレートを一覧表示します。

dspsct tmplt_id
テンプレートのサービス クラスをすべて表示します。

dspsct tmplt_id Service_Class
指定したサービス クラスのパラメータをすべて表示します。

dspvsiif

インターフェイスに割り当てられたサービス クラス テンプレートを表示する。

dspvsipartinfo

トランクと配分の VSI リソースのステータスを表示する。

IGX での MPLS の設定

ここでは、図 10-16 に示すネットワークを使って、MPLS を設定する例を示します。

Cisco IOS ソフトウェアの MPLS の設定については、『 MPLS Label Switch Controller and Enhancements 12.2(8)T 』を参照してください。

図 10-16 MPLS ネットワークを設定する簡単な例

 

図 10-16 のネットワークの説明

図 10-16 は、ATM ネットワークを通る IP パケットの MPLS スイッチングを行うために、IGX を MPLS ラベル スイッチ (ATM-LSR) として設定する例です。 また、この図は、シスコ製ルータをネットワークのエッジでラベル エッジ ルータ(エッジ LSR)として使うための設定も示します。

図 10-16 では、次のコンポーネントの設定を示します。

エッジ LSR-A

エッジ LSR-C(ATM-LSR-2 IGX シャーシに URM カードを搭載)

ATM LSR-1(IGX スイッチとコントローラ)

ATM LSR-2(IGX スイッチに、ATM-LSC 2 およびエッジ LSR-C として動作する 2 枚の URM を搭載)

ATM LSR-3、ATM LSR-4、ATM LSR-5 の設定については、このマニュアルでは詳しく説明しません。 ただし、ATM LSR-1 および ATM LSR-2 用に説明した設定の例と同じです。 エッジ LSR-B の設定は、エッジ LSR-A および LSR-C と同じです。

LVC の初期セットアップ

サービス テンプレートでは、次の 2 種類のデータが定義されています。

接続パラメータ
接続を確立するために必要なパラメータ(すなわち LVC ごと)で、UPC アクション、さまざまな帯域幅関連の項目、LVC ごとのしきい値などがあります。

CoS 設定(UXM、UXM-E、URM-LSC)
CoS のサポートを行う、対応する CoS バッファ(Qbin)の設定に必要なデータ項目。


) MPLS CoS は URM-LSR ではサポートされません。


VSI スレーブ(たとえば、UXM 内のスレーブ)は、LSC の VSI マスターから接続セットアップ要求を受け取ると、サービス タイプ識別子をインデックスにして SCT データベースを検索し、その接続に必要な拡張パラメータの設定値を調べます。スレーブはこの値を使用して接続をセットアップし、ハードウェアをプログラムします。

IGX ATM-LSR の MPLS の設定

ATM-LSR は、IGX スイッチ(ラベル スイッチ スレーブとも呼ばれる)と、LSC として設定されたルータの、2 つのハードウェア コンポーネントから成ります。 LSC は、Cisco 7204 などのシスコ製外部ルータでも、シャーシに搭載した URM でも構いません。 どちらのルータを選択しても LSC 設定は基本的に同じです。

LSC で動作する Cisco IOS ソフトウェアに MPLS を設定する方法については、『 MPLS Label Switch Controller and Enhancements 12.2(8)T 』を参照してください。


ヒント URM を搭載した IGX で ATM-LSR を設定するときは、2 つの端末セッションを使用します。1 つ目では、URM カードの組み込み UXM-E にログインして ATM-LSR のラベル スイッチ スレーブ部分を設定し、2 つ目では、URM カードの組み込みルータにログインして ATM-LSR の LSC 部分を設定します。


IGX ノードで MPLS を設定するには、次の手順を実行します。

1. ATM LSR を設定します。

a. IGX スイッチ(ラベル スイッチ スレーブ):IGX を VSI 用に設定します。

b. LSC :ルータを、IGX 上の拡張 ATM インターフェイスに設定します。

2. ラベル エッジ ルータ(LER)をセットアップします。

3. MPLS は、ネットワークに LVC を自動的にセットアップします。

図 10-17 は MPLS ネットワークの概要です。 204.129.33.127 宛のパケットをリアルタイム ビデオ、204.133.44.129 宛のパケットを、帯域幅が利用できるときに転送されるデータ ファイルとします。

図 10-17 のノード(ATM-LSR 1 ~ ATM-LSR 5、エッジ LSR_A、エッジ LSR_B、エッジ LSR_C)で MPLS がセットアップされると、自動ネットワーク検出が有効になります。 次に、MPLS は、ネットワークに LVC を自動的にセットアップします。 各 ATM LSR で、VCI スイッチング(ラベル スワッピングとも呼ばれる)は、以前決定された LVC パスでセルを転送します。

エッジ LSR では、受信パケットにはラベルが追加され、送信パケットからはラベルが削除されます。図 10-17 では、宛先ホストが 204.129.33.127のIP パケットが、LVC 1 でラベル付き ATM セルとして転送されています。また、宛先ホストが 204.133.44.129 の IP パケットが、LVC 2 でラベル付き ATM セルとして転送されています。

記載されている IP アドレスは説明用のもので、外部ネットワークからは分離されていると仮定しています。 お使いのネットワークの正しい IP アドレスはネットワーク管理者に確認してください。

図 10-17 MPLS ネットワークの設定の概要

 

図 10-18 は、MPLS ラベル スワッピングのプロセスです。 このプロセスは、LVC1 および LVC2 仮想回線のネットワークで ATM セルの形式で IP パケットを転送する際に起こります。

1. 宛先が 204.133.44.129 のラベルなし IP パケットが、エッジ ラベル スイッチング ルータ(LSR-A)に到着します。

2. エッジ LSR-A は、自身のラベル転送情報ベース(LFIB)を調べ、プレフィックス 204.133.44.0/8 で宛先を照合します。

3. エッジ LSR-A は AAL5 フレームをセルに変換し、1/VCI 50 上でセルのシーケンスとしてフレームを送出します。

4. ATM-LSR-1(Cisco IGX 8410、8420、8430 ラベル スイッチ ルータ)は、ルーティング エンジンによって制御され、自身の LFIB を確認して、インターフェイス 2/VCI 50 の着信セルを発信インターフェイス 0/VCI 42 にスイッチングして、通常のスイッチング動作を実行します。

5. ATM-LSR-2 は LFIB を確認し、インターフェイス 2/VCI 42 の着信セルを発信インターフェイス 0/VCI 90 にスイッチングします。

6. エッジ LSR-C は、着信インターフェイス 1/VCI 90 の着信セルを受信し、自身の LFIB を確認し、ATM セルを AAL5 フレームと IP パケットに戻してから、発信パケットを LAN の宛先 204.133.44.129 に送信します。

図 10-18 ラベル スワッピングの詳細

 

Cisco IGX 8410、8420、8430 ATM-LSR のIGX スイッチ部分の設定


) IGX ノードでの MPLS サポートを設定する前に、ATM ネットワークに IGX ノードをセットアップして設定する必要があります(他のノードへのリンクも含む)。


IGX ノードを運用できるように設定するには、 cnfrsrc コマンドを使用して仮想インターフェイスと対応する配分をセットアップします。

シスコ製ルータを IGX にリンクするには、 addctrlr コマンドを使用して VSI コントローラとしてルータを追加します。 これにより、ルータのラベル スイッチ コントローラ機能がノードの MPLS 動作を制御できます。

IGX 配分リソースの分配など IGX 配分の設定については、「VSI の設定」を参照してください。

この例では、ノードあたり 1 つの外部コントローラがサポートされるものとしているため、選択される配分は常に 1 です。

ATM-LSR-1 の IGX 1 部分の設定

Cisco IGX 8410、8420、8430 のラベル スイッチ ルータ、ATM-LSR-1 および ATM-LSR-2 を設定する手順は、次のとおりです。

 

 
コマンド
説明

ステップ 1

カードの状態確認:

dspcds 3

UXM カードの状態が表示されます。設定する UXM カードは "Standby" または "Active" でなければなりません。

ステップ 2

UXM インターフェイスの有効化:

upln 3.1
upport 3.2

この例では、回線 3.1 は LSC コントローラへのリンクであり、回線 3.2 は LVC が使用する相互接続としてセットアップされています。


) UXM インターフェイスは、別のスイッチまたは MGX 8220 フィーダに接続する場合はトランクです。 LSC への VSI 接続は、トランクまたは回線です。 その他のインターフェイスは、一般にサービス インターフェイスに対するポートです。


ステップ 3

UXM 回線インターフェイスでの VSI 配分の設定:

 
cnfrsrc 3.1 256 26000 y 1 e 512 1500 240 255 26000 105000
 

個別に入力する場合:

cnfrsrc 3.1
256 {PVC LCNs, accept default value}
26000

) トランクを確立する際には帯域幅の指定は不要です。


y {to edit VSI parameters}
1 {partition}
e {enable partition}
512 {VSI min LCNs}
1500 {VSI max LCNs}
240 {VSI starting VPI}
255 {VSI ending VPI}
26000 {VSI min bandwidth}
105000 {VSI max bandwidth}
 

PVC LCN: [256] デフォルト値。 このリンクに 256 本の AutoRoute PVC 用のスペースを確保します(LCN = Logical Connection Numbers; 論理接続番号)。

VSI 最小 LCN: 512
VSI 最大 LCN: 1500

MPLS がこのリンクに 512 の LVC をセットアップできることが保証され、LCN が利用可能かどうかによって、最大 1500 まで使用できます。

VSI 開始 VPI: 240
VSI 終了 VPI: 255

MPLS 用に 240 ~ 255 の範囲の VPI を予約します。 本当に必要な VPI は 1 つだけですが、将来の使用に備えてさらにいくつか確保しておくことができます。 Cisco IGX 8410、8420、8430 では、常に VPI "0" と "1" を MPLS で使わないようにすることをお勧めします。


) VPI はローカルで意味を持ちます。 この例では、各ポートの開始 VPI を 240 としています。 表示されている 6.1、6.2、7.1 の 3 つの各ポートに異なる値を使用することもできます。 ただし、たとえば ATM LSR-1 のポート 6.2 と ATM LSR-2 のポート 6.2 間のように、トランクの各エンドで同じ VPI を割り当てる必要があります。


VSI 最小帯域幅: 26000
VSI 最大帯域幅: 105000

MPLS はこのリンクで 26000 Cps(約 10 MBps)を使用できることが保証され、帯域幅が利用できる場合は最大 105000 Cps(約 40 MBps)まで使用できることになります。 必要に応じてさらに割り当てを増やすことができます。

VSI 最大帯域幅: 26000

PVC は、このリンクで常に最大 26000 Cps(約 10 MBps)まで使用できることが保証されます。

ステップ 4

UXM インターフェイス 3.2 および 4.1 について繰り返します。

cnfrsrc 3.2 256 26000 y 1 e 512 1500 240 255 26000 105000
 
cnfrsrc 4.1 256 26000 y 1 e 512 1500 240 255 26000 105000

ステップ 3 の説明を参照してください。

ステップ 5

UXM での MPLS キューの有効化:

dspqbin 3.1 10

さらに次の出力と一致することを確認:

Qbin Database 3.1 on UXM qbin 10
Qbin State: Enable
Qbin discard threshold: 65536
EPD threshold: 95%
High CLP threshold: 100%
EFCI threshold: 40%
 

設定が正しくない場合は、次のように入力します。

cnfqbin 3.1 10 e n 65536 95 100 40
 

必要に応じて UXM インターフェイス 3.2 および 4.1 について繰り返す:

cnfqbin 3.2 10 e n 65536 95 100 40
cnfqbin 4.1 10 e n 65536 95 100 40

MPLS CoS は Qbin 10 ~ 14 を使用します。

ステップ 6

VSI 制御インターフェイスの有効化:

addctrlr 3.1 vsi 1 1 100 200

"VSI" の後の最初の "1" は VSI コントローラ ID です。IGX と LSC で同じ設定にする必要があります。 LSC でのデフォルトのコントローラ ID は "1" です。

"VSI" の後の 2 番目の "1" は 、これが配分 1 のコントローラであることを示します。

ATM-LSR-2(URM-LSR)の IGX 2 部分の設定

設定手順は次のとおりです。

 

 
コマンド
説明

ステップ 1

カードの状態確認:

dspcds 6

UXM カードの状態が表示されます。設定する UXM カードは "Standby" または "Active" でなければなりません。

ステップ 2

UXM インターフェイスの有効化:

addport 6.1
uptrk 3.2
addport 4.1

この例では、ポート 6.1 は、組み込み UXM-E と URM-LSC の組み込みルータ間の、内部 ATM インターフェイスです。 トランク 3.2 は LVC が使用する相互接続としてセットアップされています。 ポート 4.1 は、組み込み UXM-E とURM-LSR の組み込みルータ間の、内部 ATM インターフェイスです。

ステップ 3

UXM インターフェイスでの VSI 配分の設定:

cnfrsrc 6.1 256 26000 y 1 e 512 1500 240 255 26000 105000
 

個別に入力する場合:

cnfrsrc 6.1
256 {PVC LCNs, accept default value}
26000
y {to edit VSI parameters}
1 {partition}
e {enable partition}
512 {VSI min LCNs}
1500 {VSI max LCNs}
240 {VSI starting VPI}
255 {VSI ending VPI}
26000 {VSI min bandwidth}
105000 {VSI max bandwidth}

--

ステップ 4

UXM インターフェイス 6.2 および 7.1 について繰り返します。

cnfrsrc 3.2 256 26000 y 1 e 512 1500 240 255 26000 105000
 
cnfrsrc 4.1 256 26000 y 1 e 512 1500 240 255 26000 105000

--

ステップ 5

UXM での MPLS キューの有効化:

dspqbin 6.1 10
 

さらに次の出力と一致することを確認:

Qbin Database 6.1 on UXM qbin 10
Qbin State: Enable
Qbin discard threshold: 65536
EPD threshold: 95%
High CLP threshold: 100%
EFCI threshold: 40%
 

設定が正しくない場合は、次のように入力します。

cnfqbin 6.1 10 e n 65536 95 100 40

MPLS CoS は Qbin 10 ~ 14 を使用します。

ステップ 6

必要に応じて UXM インターフェイス 3.2 および 4.1 について繰り返す:

cnfqbin 3.2 10 e n 65536 95 100 40
cnfqbin 4.1 10 e n 65536 95 100 40

ステップ 5 の説明を参照してください。

ステップ 7

VSI コントローラ インターフェイスの有効化:

addctrlr 6.1 vsi 1 1 100 200

"vsi" の後の最初の "1" は vsi コントローラ ID です。IGX と LSC で同じ設定にする必要があります。 LSC でのデフォルトのコントローラ ID は "1" です。

"vsi" の後の 2 番目の "1" は 配分 ID であり、配分 1 のコントローラであることを示します。

Cisco IGX 8410、8420、 8430 の LSC 1 および LSC 2 部分の設定

ルータにラベル スイッチ(MPLS)制御機能を設定するには、まず初期ルータ設定を行う必要があります。 この設定の一環として、ATMアダプタ インターフェイスを設定して有効にする必要があります。

ATMアダプタ インターフェイスを設定すると、拡張 ATM インターフェイスをラベル スイッチング用にセットアップできます。 IGX ポートは、LSC1 および LSC2 用の次の手順に従って、ルータから物理ルータ ATM インターフェイスの拡張 ATM ポートとして設定できます。

ATM-LSR-1 の LSC1 部分の設定

設定手順は次のとおりです。

 

 
コマンド
説明

 

準備作業

 

ステップ 1

Router LSC1(config)# ip routing

IP ルーティング プロトコルを有効にします。

ステップ 2

Router LSC1(config)# ip cef

Cisco エクスプレス転送プロトコルを有効にします。

ステップ 3

Router LSC1(config)# interface ATM3/0

IGX への物理インターフェイス リンクを有効にします。

ステップ 4

Router LSC1(config-if)# no ip address

 

ステップ 5

Router LSC1(config-if)# label-control-protocol vsi [controller ID}

MPLS コントローラとしてルータの ATM ポート ATM3/0 を有効にします。 コントローラ ID のデフォルトは 1 で、IGX での最大は 32 です。

 

スレーブ間制御リンクのセットアップ

 

ステップ 6

Router LSC1(config-if)# interface XmplsATM33

IGX の 3.3 ポートのスレーブ間リンク(スロット 3 の UXM のポート 3)。 これはルータの ATM3/0 vsi 0x00010300 ポートの拡張ポートです。

ステップ 7

Router LSC1(config-if)# extended-port ATM3/0 vsi 0x00010300

拡張ポート XmplsATM13 を IGX スレーブ ポート 1.3 にバインドします。

ステップ 8

Router LSC1(config-if)# ip address 142.4.133.13 255.255.0.0

XmplsATM13 に IP アドレスを割り当てます。

ステップ 9

Router LSC1(config-if)# mpls ip

xtag インターフェイス XmplsATM13 用に MPLS を有効にします。

 

スレーブ間ポートのセットアップ

 

ステップ 10

Router LSC1(config-if)# interface XmplsATM42

IGX のポート 4.2 のスレーブ間リンク(スロット 4 の UXM のポート 2)。 これはルータの ATM3/0 vsi 0x00010300 ポートの拡張ポートです。

ステップ 11

Router LSC1(config-if)# extended-port ATM3/0 vsi 5.2

拡張ポート XmplsATM52 を IGX スレーブ ポート 5.2 にバインドします。

ステップ 12

Router LSC1(config-if)# ip address 142.6.133.22 255.255.0.0

XmplsATM52 に IP アドレスを割り当てます。

ステップ 13

Router LSC1(config-if)# mpls ip

xtag インターフェイス XmplsATM52 用に MPLS を有効にします。

ステップ 14

Router LSC1 (config-if)# exit

 

 

ルーティング プロトコルの設定

Open Shortest Path First(OSPF)ルーティング プロトコル または Enhanced Interior Gateway Routing Protocol(EIGRP)を設定します。

ステップ 15

Router LSC1 (config-if)# Router OSPF 5

OSPF ルーティングのセットアップと、ローカルで意味を持つプロセス ID 5 の割り当て ID は、最大約 32,000 までの空いているプロセス ID から選択できます。

ステップ 16

Router LSC1 (config-router)# network 142.4.0.0 0.0.255.255 area 10

ステップ 17

Router LSC1 (config-router)# network 142.6.0.0 0.0.255.255 area 10

ATM-LSR-2(URM-LSR)の LSC2 部分の設定

設定手順は次のとおりです。

 

 
コマンド
説明

 

準備作業

 

ステップ 1

Router LSC2(config)# ip routing

IP ルーティング プロトコルを有効にします。

ステップ 2

Router LSC2(config)# ip cef

Cisco エクスプレス転送プロトコルを有効にします。

ステップ 3

Router LSC2(config)# interface ATM0/0

組み込み UXM-E と URM カードの組み込みルータ間の内部 ATM インターフェイスを有効にします。

ステップ 4

Router LSC2(config-if)# no ip address

 

ステップ 5

Router LSC2(config-if)# label-control-protocol vsi [controller ID]

MPLS コントローラとしてルータの ATM ポート ATM0/0 を有効にします。 コントローラ ID のデフォルトは 1 で、IGX での最大は 32 です。

 

スレーブ間制御リンクのセットアップ

 

ステップ 6

Router LSC2(config-if)# interface XmplsATM33

IGX の 3.2 ポートのスレーブ間リンク(スロット 3 の URM のポート 2)。 これはルータの ATM0/0 vsi 0x00010300 ポートの拡張ポートです。

ステップ 7

Router LSC2(config-if)# extended-port ATM0/0 igx 3.2

拡張ポート XmplsATM33 を IGX スレーブ ポート 3.2 にバインドします。

ステップ 8

Router LSC2(config-if)# ip address 142.4.133.15 255.255.0.0

XmplsATM1 に IP アドレスを割り当てます。

ステップ 9

Router LSC2(config-if)# mpls ip

xtag インターフェイス XmplsATM1 用に MPLS を有効にします。

 

スレーブ間ポートのセットアップ

 

ステップ 10

Router LSC2(config-if)# interface XmplsATM42

IGX の 4.1 ポートのスレーブ間リンク(スロット 4 の UXM のポート 1)。 これはルータの ATM0/0 vsi 0x00010300 ポートの拡張ポートです。

ステップ 11

Router LSC2(config-if)# extended-port ATM0/0 igx 4.1

拡張ポート XmplsATM42 を IGX スレーブ ポート1 にバインドします。

ステップ 12

Router LSC2(config-if)# ip address 142.7.133.22 255.255.0.0

XmplsATM42 に IP アドレスを割り当てます。

ステップ 13

Router LSC2(config-if)# mpls ip

xtag インターフェイス XmplsATM42 用に MPLS を有効にします。

ステップ 14

Router LSC2 (config-if)# exit

インターフェイス設定モードを終了します。

 

ルーティング プロトコルの設定

OSPF または EIGRP を設定します。

ステップ 15

Router LSC2 (config-if)# Router OSPF 5

OSPF ルーティングのセットアップと、ローカルで意味を持つプロセス ID 5 の割り当て。 ID は、最大約 32,000 までの空いているプロセス ID から選択できます。

ステップ 16

Router LSC2 (config-router)# network 142.4.0.0 0.0.255.255 area 10

 

ステップ 17

Router LSC2 (config-router)# network 142.7.0.0 0.0.255.255 area 10

 

エッジ ラベル スイッチ ルータ、LSR-A および LSR-B の設定

ルータに MPLS 制御機能を設定するには、まず初期ルータ設定を実行する必要があります。 この設定の一環として、ATM アダプタ インターフェイスを有効にして設定する必要があります。

その後、MPLS 用に拡張 ATM インターフェイスをセットアップできます。 IGX ポートは、LSR-A および LSR-C 用の次の手順に従って、ルータから物理ルータ ATM インターフェイスの拡張 ATM ポートとして設定できます。

ラベル エッジ ルータとして動作するルータを設定するには、下の表に記載する手順を実行します。

エッジ ルータ、エッジ LSR-A 用のシスコ製ルータの設定

設定手順は次のとおりです。

 

 
コマンド
説明

ステップ 1

Router LSR-A (config)# ip routing

IP ルーティング プロトコルを有効にします。

ステップ 2

Router LSR-A(config)# ip cef distributed switch

ATM サブインターフェイス用に MPLS を有効にします。

ステップ 3

Router LSR-A(config)# interface ATM4/0/0

 

ステップ 4

Router LSR-A(config-if)# no ip address

 

ステップ 5

Router LSR-A(config-if)# interface ATM4/0/0.9 mpls

インターフェイスは、基本的にATM4/0/0.1、ATM 4/0/0.2の制限範囲内であればいくつでも可能です。

ステップ 6

Router LSR-A(config-if)# ip address 142.6.133.142 255.255.0.0

 

ステップ 7

Router LSR-A(config-if)# mpls ip

 

 

ルーティング プロトコルの設定

OSPF または EIGRP を設定します。

ステップ 8

Router LSR-A (config-if)# Router OSPF 5

OSPF ルーティングのセットアップと、ローカルで意味を持つプロセス ID 5 の割り当て。 ID は、最大約 32,000 までの空いているプロセス ID から選択できます。

ステップ 9

Router LSR-A (config-router)# network 142.6.0.0 0.0.255.255 area 10

 

エッジ ルータ、エッジ LSR-C 用のシスコ製ルータの設定

 

 
コマンド
説明

ステップ 1

Router LSR-C (config)# ip routing

IP ルーティング プロトコルを有効にします。

ステップ 2

Router LSR-C(config)# ip cef

ATM サブインターフェイス用にラベル スイッチングを有効にします。

ステップ 3

Router LSR-C(config)# interface ATM0/0

 

ステップ 4

Router LSR-C(config-if)# no ip address

 

ステップ 5

Router LSR-C(config-if)# i nterface ATM0/0.1 mpls

 

ステップ 6

Router LSR-C(config-if)# ip address 142.7.133.23 255.255.0.0

 

ステップ 7

Router LSR-C(config-if)# mpls ip

 

 

ルーティング プロトコルの設定

OSPF または EIGRP を設定します。

ステップ 8

Router LSR-C (config-if)# Router OSPF 5

OSPF ルーティングのセットアップと、ローカルで意味を持つプロセス ID 5 の割り当て。 ID は、最大約 32,000 までの空いているプロセス ID から選択できます。

ステップ 9

Router LSR-C (config-router)# network 142.7.0.0 0.0.255.255 area 10

 

ルーティング プロトコルによる 、MPLS を使った LVC の設定

IGX とエッジ ルータの初期設定手順が完了すると、ルーティング プロトコル(OSPFなど)が MPLS を使用して LVC をセットアップします(図 10-19を参照)。

図 10-19 MPLS スイッチド ネットワークでの LVC の例

 

MPLS ネットワークの設定のテスト

MPLS ネットワークの予備テストは次のものから成ります。

VSI のステータスの確認

MPLS インターフェイスの確認

MPLS 検出プロセスの確認

MPLS ネットワークの監視とトラブルシューティングには、次の Cisco IOS コマンドが便利です。

show controllers VSI descriptor [ descriptor]

show mpls interfaces

show mpls ldp discovery


) Cisco IOS のコマンドを実行するには、Cisco IOS の CLI でコマンドを入力する必要があります。 スイッチにログインしたら、別の端末セッションを開始して ATM-LSR の LSC ルータ部分またはネットワークのエッジ ルータにログインします。


IGX 拡張 ATM インターフェイスの確認

IGX スイッチ(ATM LSR-1 など)のラベル スイッチング設定をテストする手順は、次のとおりです。


ステップ 1 コントローラがインターフェイスを正しく認識するか確認します。たとえば、LSC1 で次のコマンドを入力します。

コマンド
説明
Router LSC1# show controllers VSI descriptor

拡張 ATM インターフェイスの VSI 情報を表示します。

ATM-LSC-1(Cisco IGX 8410、8420、8430シェルフ)の出力例です。

Phys desc: 3.1
Log intf: 0x00040100 (0.4.1.0)
Interface: slave control port
IF status: N/A IFC state: ACTIVE
Min VPI: 0 Maximum cell rate: 10000
Max VPI: 10 Available channels: xxx
Min VCI: 0 Available cell rate (forward): xxxxxx
Max VCI: 65535 Available cell rate (backward): xxxxxx
 
Phys desc: 3.3
Log intf: 0x00040200 (0.4.2.0)
Interface: ExtTagATM13
IF status: up IFC state: ACTIVE
Min VPI: 0 Maximum cell rate: 10000
Max VPI: 10 Available channels: xxx
Min VCI: 0 Available cell rate (forward): xxxxxx
Max VCI: 65535 Available cell rate (backward): xxxxxx
 
Phys desc: 4.2
Log intf: 0x00040300 (0.4.3.0)
Interface: ExtTagATM22
IF status: up IFC state: ACTIVE
Min VPI: 0 Maximum cell rate: 10000
Max VPI: 10 Available channels: xxx
Min VCI: 0 Available cell rate (forward): xxxxxx
Max VCI: 65535 Available cell rate (backward): xxxxxx
-------

ヒント 最新情報については、オンライン マニュアルを参照してください。関連資料のアクセス方法については、「ユーザ マニュアルへのアクセス方法」を参照してください。


ステップ 2 インターフェイスが存在しない場合は、まずスイッチ ソフトウェアのコマンド dspcds で、カード 3 がアクティブで使用可能か確認します。 カードがアクティブで使用可能でない場合は、スイッチ ソフトウェアのコマンド resetcd でカードをリセットします。 必要に応じてカードを取り外してリセットします。

ステップ 3 スイッチ ソフトウェアのコマンド dsplns で回線の状態を確認します(例10-2を参照)。

例10-2 dsplns の出力例

sanjose TN Cisco IGX 8430 9.3.10 July 12 2000 09:38 PST
 
Line Type Current Line Alarm Status
6.6 T3/636 Clear - OK
7.8 T1/24 Clear - OK
 
Last Command: dsplns
 
Next Command:
 
 

ステップ 4 スイッチ ソフトウェアのコマンド dsptrks でトランクの状態を確認します(例10-3を参照)。


) ATM-LSR-1 に対する dsptrks の出力表示画面では、MPLS インターフェイス 3.1、3.3、4.2 があります。3.1 の "Other End" は、"VSI (VSI)" となっています。


例10-3 dsptrks の出力例

n4 TN SuperUser IGX 15 9.3 March 4 2000 16:45 PST
 
TRK Type Current Line Alarm Status Other End
4.1 OC3 Clear - OK j4a/2.1
5.1 E3 Clear - OK j6a/5.2
5.2 E3 Clear - OK j3b/3
5.3 E3 Clear - OK j5c(IPX/AF)
6.1 T3 Clear - OK j4a/4.1
6.2 T3 Clear - OK j3b/4
3.1 OC3 Clear - OK VSI(VSI)
3.3 OC3 Clear - OK
4.2 OC3 Clear - OK
 
 
Last Command: dsptrks
 
Next Command:
 
 

ステップ 5 ノードに接続したコントローラを確認するには、スイッチ ソフトウェアのコマンド dspctrlrs を使用します(例10-4を参照)。 出力画面では、トランクがタイプ VSI の LSC へのリンクとして表示されます。

例10-4 dspctrlrs の出力例

sanjose TN Cisco IGX 8430 9.3.10 July 31 2000 20:26 PST
 
VSI Controller Information
 
CtrlrId PartId ControlVC Intfc Type CtrlrIP
VPI VCIRange
1 1 0 40-70 6.6 MPLS 192.168.254.1
 
Last Command: dspctrlrs
 
Next Command:
 
 

ステップ 6 インターフェイスの配分の設定を表示するには、スイッチ ソフトウェアのコマンド dsprsr を使用します(例10-5を参照)。

例10-5 dsprsr の出力例

sanjose TN Cisco IGX 8430 9.3.10 July 31 2000 20:29 PST
 
Line : 6.6
Maximum PVC LCNS: 256 Maximum PVC Bandwidth: 48000
(Reserved Port Bandwidth: 150)
 
State MinLCN MaxLCN StartVPI EndVPI MinBW MaxBW
Partition 1: E 0 100 2 10 0 48000
Partition 2: D
Partition 3: D
 
 

ステップ 7 Qbin の設定情報を表示するには、スイッチ ソフトウェアのコマンド dspqbin を使用します(例10-6を参照)。

例10-6 dspqbin の出力例

n4 TN SuperUser IGX 15 9.3 March 4 2000 16:48 PST
 
Qbin Database 3.1 on UXM qbin 10
 
Qbin State: Enabled
 
Minimum Bandwidth: 0
Qbin Discard threshold: 65536
Low CLP threshold: 95%
High CLP threshold: 100%
EFCI threshold: 40%
 
 
Last Command: dspqbin 3.1 10
 
 
Next Command:
 
 

ステップ 8 インターフェイスが存在しているにもかかわらず有効になっていない場合は、前述のインターフェイスのデバッグ手順を実行します。

ステップ 9 Cisco IOS の ping コマンドを使用し、ラベル スイッチ接続上で ping を送信します。 ping が失敗するにもかかわらず、すべてのラベル スイッチングおよびルーティング情報が正しく表示されている場合は、LSC で次の Cisco IOS コマンドを入力して、LSC が VSI インターフェイスを正しく認識しているか確認します。

コマンド
説明

Router LSC1# show mpls interfaces

ラベル インターフェイスを表示します。

インターフェイスが表示されない場合は、前述の手順に従って IGX スイッチのポート 3.1 の設定を再確認します。

ステップ 10 VSI インターフェイスが表示されるもののダウンしている場合は、IGX スイッチに接続した LSR で回線がアップと表示されているか確認します。 アップでない場合は、ケーブルや接続を確認します。

ステップ 11 LSC と IGX スイッチでインターフェイスがアップと表示されていて、LSC ではアップと表示されない場合は、LSC で次のコマンドを入力します。

Router LSC1# reload
 

show mpls interfaces コマンドでインターフェイスがアップしていることが表示されているが、ping が失敗する場合は、LSC で次のコマンドを入力します(例10-7を参照)。

Router LSC1# show tag tdp disc
 

例10-7 show tag tdp disc コマンドの出力例

Local TDP Identifier:
30.30.30.30:0
TDP Discovery Sources:
Interfaces:
ExtTagATM1.3: xmit/recv
ExtTagATM2.2: xmit/recv
-----------------
 
 

ステップ 12 出力画面でインターフェイスが "xmit/recv" でなく "xmit" と表示される場合は、LSC が LDP メッセージを送信しても応答がないということを示します。 近隣の LSR で次のコマンドを入力します。

Router LSC1# sh tag tdp disc
 

その出力画面でも "xmit/recv" でなく "xmit" と表示される場合は、次の 2 つが考えられます。

a. LSC が VSI 接続をセットアップできない。

b. LSC は VSI 接続をセットアップできるが、セルをキューに入れられないため、転送ができない。

ステップ 13 インターフェイス 3.1、3.3、4.2 についてスイッチの VSI 設定を再確認します。次の点に注意します。

a. 最大帯域幅は最低でも数千 Cps となっていること

b. Qbin が有効になっていること

c. すべての Qbin しきい値がゼロでないこと


) VSI 配分とリソースは、LSC に接続されたインターフェイス、インターフェイス 3.1(この例では)、およびラベル スイッチング装置に接続されたインターフェイス上で正しく設定されている必要があります。



 

MPLS VPN の設定例

VPN 動作を設定するには、まずネットワークで次の Cisco IOS サービスが動作している必要があります。

Generic Routing Encapsulation(GRE; 総称ルーティング カプセル化)を使ったラベル スイッチング接続、すべてのプロバイダー(PE)ルータ間で VPN サービスを使って設定されたトンネル、または全プロバイダー(PE)ルータ バックボーンでのラベル スイッチング

エッジ サービス(PE)ルータを使い、すべてのプロバイダー ルータで VPN コードを使ったラベル スイッチング

BGP。VPN サービスを提供するすべてのルータで必要

CEF スイッチング。ラベル対応のすべてのルータで必要

GRE

Cisco シリーズ ルータ

MPLS VPN を運用するための Cisco IGX 8410、8420、8430 ATM LSR の設定

MPLS VPN を運用する場合、最初に Cisco IGX 8410、8420、8430 ATM LSR と、対応するシスコ製ルータ LSC も含め、MPLS または MPLS QoS 用に設定する必要があります。

PE ルータとして機能するエッジ LSR にネットワーク VPN の運用を設定します。

Cisco IGX 8410、8420、8430 とその LSC も含め、MPLS と QoS を有効にする以上の設定は不要です。

MPLS VPN の運用のための VRF の設定

VRF および関連インターフェイスを設定するには、PE ルータで次の手順を実行します。

 

 
コマンド
用途

ステップ 1

Router(config)# ip vrf vrf-name

VRF 設定モードに入り、これ以降のステップでコマンドを適用する VRF 名を指定します。

ステップ 2

Router(config-vrf)# rd route-distinguisher

インスタンスを定義するには、名前と 8 バイトのルート区別子を割り当てます。

ステップ 3

Router(config-if)# ip vrf forwarding vrf-name

インターフェイスを VRF に関連付けます。

ステップ 4

Router(config-router)# address-family ipv4 vrf vrf-name

PE と VRF CE 間で BGP を使用するため、VRF CE セッション用の BGP パラメータを設定します。

auto-summary と synchronization のデフォルト設定は、VRF アドレス ファミリ サブモードでは、オフになっています。

PE ルータで BGP を通じて CE ルータから入手したアドレスが正しく VPN IPv4 アドレスとして取り扱われるようにするには、コマンド no bgp default ipv4-activate を入力してから近隣の CE を設定する必要があります。

ステップ 5

Router(config-router-af)# exit-address-family

VRF 設定モードを終了します。

ステップ 6

Router(config)# ip route [vrf vrf-name]

その VRF 用にスタティック ルートを設定します。

MPLS VPN の運用のための BGP の設定

VPN ルーティング情報を配布するためにプロバイダー ルータ間で BGP を設定するには、PE ルータで次の手順を実行します。

 

 
コマンド
目的

ステップ 1

Router(config-router)# address-family {ipv4|vpn4}
[unicast|multicast]

BGP アドレス ファミリを設定します。

ステップ 2

Router(config-router-af)# neighbor {address|peer-group} remote-as as-number}

BGP セッションを定義します。

ステップ 3

Router(config-router)# no bgp default ipv4-activate

BGP セッションをアクティブにします。 すべての近隣に対しアドレス ファミリー IPv4 の自動アドバタイズメントが行われないようにします。

ステップ 4

Router(config-router)# neighbor address remote-as as-number

VPNv4 NLRI を交換するように IBGP を設定します。

ステップ 5

Router(config-router)# neighbor address update-source interface

IBGP セッションを定義します。

ステップ 6

Router(config-router-af)# neighbor address activate

VPNv4 NLRI のアドバタイズメントをアクティブにします。

MPLS VPN の運用のためのインポートおよびエクスポート ルートの設定

ルーティング情報の配布を制御するためのインポートおよびエクスポート ルートを設定するには、PE ルータで次の手順を実行します。

 

 
コマンド
目的

ステップ 1

Router(config)# ip vrf vrf-name

VRF 設定モードに入り、VRF を指定します。

ステップ 2

Router(config-vrf)# route-target import community-distinguisher

指定した拡張コミュニティに、ルーティング情報をインポートします。

ステップ 3

Router(config-vrf)# route-target export community-distinguisher

指定した拡張コミュニティに、ルーティング情報をエクスポートします。

ステップ 4

Router(config-vrf)# import map route-map

指定したルート マップを VRF に関連付けます。

MPLS VPN の運用の確認

VPN の運用を確認するには、PE ルータで次の手順を実行します。

 

 
コマンド
目的

ステップ 1

Router# show ip vrf

定義済み VRF とインターフェイスを表示します。

ステップ 2

Router# show ip vrf detail

インポートおよびエクスポート コミュニティ リストなどの VRF 情報を表示します。

ステップ 3

Router# show ip route vrf vrf-name

VRF の IP ルーティング テーブルを表示します。

ステップ 4

Router# show ip protocols vrf vrf-name

VRF のルーティング プロトコル情報を表示します。

ステップ 5

Router# show ip cef vrf vrf-name

VRF に関連付けられている CEF 転送テーブルを表示します。

ステップ 6

Router# show ip interface interface-number

インターフェイスに関連付けられている VRF テーブルを表示します。

ステップ 7

Router# show ip bgp vpnv4 all [tags]

VPNv4 NLRI 情報を表示します。

ステップ 8

Router# show mpls forwarding vrf vrf-name [prefix mask/length][detail]

このルータによってアドバタイズされる VRF ルートに対応するラベル転送エントリを表示します。

MPLS VPN 設定ファイルの例

例10-8 は、PE ルータの MPLS-VPN 設定ファイルの例です。

例10-8 BGP を使った PE ルータの MPLS-VPN 設定ファイルの例

Router1# show run
Building configuration...
Current configuration:
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router1
!
boot system tftp svincent/uxmvsi/c7200-p-mz.121-3.T 255.255.255.255
boot system slot0:c7200-p-mz.121-3.T
enable password lab
!
ip subnet-zero
ip cef
!
interface Loopback0
ip address 10.10.10.10 255.255.255.255
no ip route-cache
no ip mroute-cache
!
interface FastEthernet0/0
no ip address
no ip mroute-cache
no keepalive
shutdown
full-duplex
!
interface FastEthernet1/0
ip address 30.0.0.2 255.0.0.0
no ip mroute-cache
no keepalive
full-duplex
!
interface ATM3/0
no ip address
no ip mroute-cache
shutdown
atm clock INTERNAL
no atm ilmi-keepalive
!
router bgp 101
no synchronization
bgp log-neighbor-changes
network 10.0.0.0
network 30.0.0.0
neighbor 30.0.0.1 remote-as 100
!
no ip classless
no ip http server
!
no cdp advertise-v2
!
line con 0
exec-timeout 0 0
transport input none
line aux 0
line vty 0
exec-timeout 0 0
password lab
login
line vty 1 4
password lab
login
!
end
 

例10-9 RIP を使った PE ルータの MPLS-VPN 設定の例

Router2# show run
 
Building configuration...
Current configuration:
!
version 12.1
no service pad
service timestamps debug uptime
no service password-encryption
!
hostname Router2
!
boot system slot1:c7200-tsjpgen-mz.121-1.0.2
boot system tftp /tftpboot/syam/c7200-tsjpgen-mz.121-4.3.T 223.255.254.254
no logging console
enable password lab
!
ip subnet-zero
no ip finger
no ip domain-lookup
ip host PAGENT-SECURITY-V3 87.84.30.96 47.58.0.0
!
ip cef
cns event-service server
!
interface Loopback0
ip address 11.11.11.11 255.255.255.255
!
interface FastEthernet0/0
no ip address
no ip mroute-cache
no keepalive
shutdown
full-duplex
!
interface FastEthernet2/0
ip address 29.0.0.2 255.0.0.0
no ip mroute-cache
no keepalive
full-duplex
!
router rip
version 2
network 11.0.0.0
network 29.0.0.0
!
no ip classless
no ip http server
!
no cdp advertise-v2
!
!
line con 0
exec-timeout 0 0
transport input none
line aux 0
line vty 0 4
password lab
login
!
no scheduler max-task-time
end
 

例10-10 URM-LER 用の MPLS-VPN 設定の例

URM-LER# show run
 
Building configuration...
Current configuration : 3830 bytes
!
version 12.2
no service single-slot-reload-enable
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname URM-LER
!
boot system flash:urm-jk2s-mz
logging rate-limit console 10 except errors
!
ip subnet-zero
!
no ip finger
no ip domain-lookup
!
ip vrf test_1
rd 100:1
route-target export 100:1
route-target import 100:1
!
ip vrf test_2
rd 100:2
route-target export 100:2
route-target export 100:1
route-target import 100:2
route-target import 100:1
ip cef
no ip dhcp-client network-discovery
!
fax interface-type modem
mta receive maximum-recipients 0
!
interface Loopback0
ip address 12.12.12.12 255.255.255.255
no ip mroute-cache
!
interface ATM0/0
no ip address
no ip mroute-cache
no atm ilmi-keepalive
!
interface ATM0/0.1 point-to-point
no ip mroute-cache
!
interface ATM0/0.2 point-to-point
no ip mroute-cache
!
interface ATM0/0.3 tag-switching
ip unnumbered Loopback0
no ip mroute-cache
tag-switching atm vpi 2-5
tag-switching ip
!
interface FastEthernet1/0
no ip address
no ip mroute-cache
no keepalive
speed auto
full-duplex
!
interface FastEthernet1/0.1
encapsulation isl 101
ip vrf forwarding test_1
ip address 30.0.0.1 255.0.0.0
no ip redirects
no ip mroute-cache
!
interface FastEthernet1/0.2
encapsulation isl 102
ip vrf forwarding test_2
ip address 29.0.0.1 255.0.0.0
no ip redirects
no ip mroute-cache
!
interface FastEthernet1/1
ip address 1.7.64.30 255.0.0.0
no ip mroute-cache
no keepalive
shutdown
speed 100
full-duplex
!
router ospf 100
log-adjacency-changes
network 12.0.0.0 0.255.255.255 area 100
!
router rip
version 2
!
address-family ipv4 vrf test_2
version 2
redistribute bgp 100 metric 0
network 29.0.0.0
no auto-summary
exit-address-family
!
router bgp 100
no synchronization
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 15.15.15.15 remote-as 100
neighbor 15.15.15.15 update-source Loopback0
neighbor 17.17.17.17 remote-as 100
neighbor 17.17.17.17 update-source Loopback0
!
address-family ipv4 vrf test_2
redistribute rip
no auto-summary
no synchronization
exit-address-family
!
address-family ipv4 vrf test_1
redistribute rip
neighbor 30.0.0.2 remote-as 101
neighbor 30.0.0.2 activate
no auto-summary
no synchronization
exit-address-family
!
address-family vpnv4
neighbor 15.15.15.15 activate
neighbor 15.15.15.15 send-community extended
neighbor 17.17.17.17 activate
neighbor 17.17.17.17 send-community extended
exit-address-family
!
ip default-gateway 1.7.0.1
ip kerberos source-interface any
ip classless
ip route 223.255.254.254 255.255.255.255 1.7.0.1
no ip http server
!
no cdp advertise-v2
!
call rsvp-sync
!
mgcp modem passthrough voip mode ca
no mgcp timer receive-rtcp
!
mgcp profile default
!
dial-peer cor custom
!
line con 0
exec-timeout 0 0
transport input none
line aux 0
line vty 0 4
password lab
login
!
end
 

例10-11 LSC の MPLS-VPN 設定ファイルの例

SampleLSC# show run
Building configuration...
Current configuration:
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname SampleLSC
!
boot system slot0:c7200-p-mz.121-3.T
enable password lab
!
ip subnet-zero
ip cef
no ip finger
no ip domain-lookup
!
interface Loopback0
ip address 13.13.13.13 255.255.255.255
!
interface FastEthernet0/0
no ip address
no ip mroute-cache
shutdown
half-duplex
!
interface ATM1/0
no ip address
no ip route-cache cef
no atm ilmi-keepalive
!
interface ATM2/0
no ip address
no ip mroute-cache
tag-control-protocol vsi base-vc 0 180 slaves 16
atm clock INTERNAL
no atm ilmi-keepalive
tag-switching ip
!
interface XTagATM103
ip unnumbered Loopback0
shutdown
extended-port ATM2/0 vsi 0x000A0300
tag-switching atm vpi 2-15
!
interface XTagATM104
ip unnumbered Loopback0
extended-port ATM2/0 vsi 0x000A0400
tag-switching atm vpi 2-15
tag-switching ip
!
interface XTagATM151
ip unnumbered Loopback0
extended-port ATM2/0 vsi 0x000F0100
tag-switching atm vpi 2-15
tag-switching ip
!
router ospf 100
log-adjacency-changes
network 13.0.0.0 0.255.255.255 area 100
!
no ip classless
no ip http server
!
line con 0
exec-timeout 0 0
transport input none
line aux 0
line vty 0 4
password lab
login
!
end
 

IP サービスの管理

スレーブ リソースの管理

最大スレーブ数は、16 スロットのスイッチでは 14、32 スロットのスイッチでは 30 です。したがって、あるスレーブをそのノード内のすべての残りのスレーブに接続するのに必要な LCN は最大で 14 または 30 です。 この LCN は、AutoRoute 配分から割り当てられます。

コントローラがインターフェイスに接続されている場合は、そのコントローラのポートとノード内の各スレーブとの間にマスター スレーブ間接続がセットアップされます。

この LCN は AutoRoute 管理プールから割り当てられます。 AutoRoute 管理はこのプールを使用して、接続のために LCN を割り当てます。

VSI コントローラでは、シグナリングのため最低限 150 Cps の帯域幅をポートに確保する必要があります。 この帯域幅は、ポートで利用できる空き帯域幅から割り当てられます(空き帯域幅 = ポート速度 - PVC 最大帯域幅 - VSI 帯域幅)。

VSI 冗長化機能の設定

ホット スレーブ スタンバイにより、スレーブ スタンバイ カードがあらかじめアクティブ カードと同じようにプログラミングされているため、アクティブ カードが故障した場合、スレーブカードへの切り替え操作が 250 ms 以内に実行されます。 UXM カードで VSI の処理を行わない場合でも、NPM から送られてくる内部 IGX プロトコル メッセージをスタンバイ UXM カードも受け取るようにすることで、UXM カードのホット スタンバイ機能を実現できるようになっています。

マスター VSI コントローラはスタンバイ スレーブ カードを認識しないため、アクティブなスレーブ カードは、マスター VSI コントローラから受信した VSI メッセージをスタンバイのスレーブ VSI カードに転送します。

アクティブ カードとスタンバイ カードの間で行われるホット スタンバイ処理をまとめると次のようになります。

1. NPM によって、内部 IGX プロトコル メッセージがホットスタンバイ スレーブ VSI カードにも送られる。

2. アクティブ スレーブ VSI カードは、(マスター VSI コントローラまたは他のスレーブ VSI カードから送られてくる)VSI メッセージをホットスタンバイ スレーブ VSI カードに転送する。 処理 2 は通常のデータ転送で、両方のカードが同期した後で実行されます。

3. ホットスタンバイ スレーブ VSI カードは、立ち上がると、アクティブ スレーブ VSI カードからすべての VSI メッセージを受信します。 処理 3 は初期のデータ転送で、スタンバイ カードが最初に立ち上がったときに実行されます。

アクティブ カードからスタンバイ カードにデータを転送する処理がアクティブ カードの性能に影響を与えるようなことがあってはなりません。そのため、ほとんどの処理をスタンバイ カードが実行し、アクティブ カードの処理が簡単になるようになっています。データ転送の制御と同期処理はスタンバイ カードが行います。アクティブ カードは、VSI メッセージを転送して、スタンバイ カードからの要求に応えます。

Qbin 統計情報

Qbin の統計情報は、CoS ごと(または Qbin ごと)にネットワークを設計し、オーバーブッキングを行う上で役立ちます。 各接続には CoS があり、したがってそれに関連付けられた Qbin が対応しています。

IGX スイッチ ソフトウェアは、トランクでは UXM AutoRoute Qbin 1 ~ 9 の、ポートでは Autoroute Qbin 2、3、7、8、9 の統計情報を収集します。 UXM トランクおよびポート上の VSI Qbin 10 ~ 15 についても、統計情報が収集されます。

次の種類の統計情報が Qbin ごとに収集されます。

処理セル数

受信セル数

廃棄セル数

どの Qbin でも上記の統計情報が取得されます。このため、Qbin 番号とその統計情報を組み合わせて、一意の統計情報タイプとなります。 これら一意の統計情報タイプは Cisco WAN Manager に表示され、CLI を使用して見ることもできます。

次の Qbin に対するトランクおよびポートのカウンタ統計情報(破棄セル統計情報のみ)は、SNMP を使用して収集できます。

UXM トランクの Qbin 1 ~ 15

UXM ポートの Qbin 2、3、7 ~ 15

Qbin の要約とカウンタ統計情報は自動的に収集され、TFTP と USER インターバル統計情報を有効にできます。 UXM トランク Qbin 1 ~ 9 の廃棄セル統計情報は、AUTO 統計情報です。 Qbin 10 ~ 15 と AutoRoute ポート Qbin の廃棄セル統計情報は、AUTO 統計情報ではありません。

インターバル統計情報(Qbin ごと)は、Cisco WAN Manager の Statistics Collection Manager(SCM)および CLI を通じて収集されます。

Qbin 統計情報コマンドの一覧

 

表 10-15 Qbin インターバル、要約、およびカウンタ統計情報の収集、表示用コマンド

コマンド
説明

clrportstats

指定したポートに関するすべての種類の要約統計情報をリセットまたはクリアします。

clrtrkstats

指定したトランクに関するすべての種類の要約統計情報をリセットまたはクリアします。

cnfportstats

指定したポートに関する 1 種類の USER 統計情報を収集します。

cnfstatparms

CLI から TFTP 統計情報を有効にします(SCM を使用するのと同じです)。

cnftrkstats

指定したトランクに関する 1 種類の USER 統計情報を収集します。

dspcntrstats

指定したエンティティの全カウンタ統計情報をリアルタイムで表示します。 この統計情報はクリアできません。

dspportstathist

指定したポートに関する 1 種類の統計情報を表示します。

dspqbinstats

指定したトランクまたはポートに関するすべての Qbin 要約統計情報を表示します。

dsptrkstathist

指定したトランクに関する 1 種類のインターバル統計情報を表示します。

関連情報

IGX 上の MPLS の詳細については、『 MPLS Label Switch Controller and Enhancements 12.2(8)T 』を参照してください。

Cisco IOS の設定とコマンドについては、Cisco IOS Release 12.2T 以降をサポートするマニュアルを参照してください(「Cisco IOS ソフトウェアのマニュアル」を参照)。

スイッチ ソフトウェアのコマンドについての詳細は、『 Cisco WAN Switching Command Reference 』の第 1 章「 Command Line Fundamentals 」を参照してください。

設置と基本設定に関する情報は、『 Cisco IGX 8400 Series Installation Guide 』の第 1 章の「 Cisco IGX 8400 Series Product Overview 」を参照してください。