IP マルチキャスト コンフィギュレーション ガイド、 Cisco IOS Release 15.1S
非 IP マルチキャスト エリアを接続するトンネ リング
非 IP マルチキャスト エリアを接続するトンネリング
発行日;2012/02/01 | 英語版ドキュメント(2011/04/17 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 8MB) | フィードバック

目次

非 IP マルチキャスト エリアを接続するトンネリング

この章の構成

非 IP マルチキャスト エリアを接続するトンネリングの前提条件

非 IP マルチキャスト エリアを接続するトンネリングの概要

非 IP マルチキャスト エリアを接続するトンネリングの利点

IP スタティック マルチキャスト ルート(mroute)

非 IP マルチキャスト エリアの接続方法

非 IP マルチキャスト エリアを接続するトンネリングの設定

非 IP マルチキャスト エリアを接続するトンネリングの設定例

非 IP マルチキャスト エリアを接続するトンネリングの設定:例

その他の参考資料

関連資料

規格

MIB

RFC

シスコのテクニカル サポート

非 IP マルチキャスト エリアを接続するトンネリングの機能情報

非 IP マルチキャスト エリアを接続するトンネリング

このモジュールでは、非 IP マルチキャスト エリア間で IP マルチキャスト パケットをトンネリングするための Generic Route Encapsulation(GRE)トンネルの設定方法を説明します。その利点は、IP マルチキャストをサポートしないエリアを経由して、IP マルチキャスト トラフィックをソースからマルチキャスト グループに送信できることです。

変更履歴

このマニュアルの初版の発行は 2005 年 5 月 2 日で、最終更新日は 2005 年 5 月 2 日です。

このドキュメントで紹介する機能情報の入手方法

ご使用の Cisco IOS ソフトウェア リリースによっては、機能の中に一部サポートされていないものがあります。「非 IP マルチキャスト エリアを接続するトンネリングの機能情報」 を使用すると、サポートされている機能および設定に関する情報を検索できます。

非 IP マルチキャスト エリアを接続するトンネリングの前提条件

このモジュールでは、『IP Multicast Technology Overview』モジュールの概念を理解していることを前提としています。

非 IP マルチキャスト エリアを接続するトンネリングの概要

非 IP マルチキャスト エリアを接続する前に、次の概念を理解する必要があります。

「非 IP マルチキャスト エリアを接続するトンネリングの利点」

「IP スタティック マルチキャスト ルート(mroute)」

非 IP マルチキャスト エリアを接続するトンネリングの利点

ソースとグループ メンバ(宛先)の間のパスが IP マルチキャストをサポートしない場合に、それらの間のトンネルが IP マルチキャスト パケットを転送できる。

パケットごとのロード バランシングが利用できる。IP マルチキャストのロード バランシングは、通常 (S, G) ごとです。したがって、X と Y がパラレル リンクである場合、(S1, G) はリンク X を、(S2, G) はリンク Y を通過します。ルータ間にトンネルを作成すると、ロード バランシングはトンネル ユニキャスト パケットで行われるため、ロード バランシングをパケットごとにすることができます。

IP スタティック マルチキャスト ルート(mroute)

IP スタティック マルチキャスト ルート(mroute)によって、ユニキャスト パスを迂回するマルチキャスト パスが使用できます。Protocol Independent Multicast(PIM)を使用している場合、ルータはユニキャスト パケットをソースに再送信したインターフェイスと同一のインターフェイスでパケットを受信することを予期します。マルチキャスト トポロジとユニキャスト トポロジが一致する場合は、この予測が有益です。しかし、ユニキャスト パケットに使用するパスとは別のパスをマルチキャストに使用することも考えられます。

別々のユニキャスト パスおよびマルチキャスト パス を使用する最も一般的な理由はトンネリングです。ソースと宛先の間のパスがマルチキャスト ルーティングをサポートしない場合、ソリューションはソースと宛先の間に 2 つのルータとルータ間の GRE トンネルを設定することです。図 1 では、各 Unicast Router(UR; ユニキャスト ルータ)はユニキャスト パケットだけをサポートし、各 Multicast Router(MR; マルチキャスト ルータ)はマルチキャスト パケットをサポートします。

図 1 マルチキャスト パケット用のトンネル

 

図 1 では、Source は MR 1 および MR 2 を使用してマルチキャスト パケットを Destination に伝送します。MR 2 は、トンネルを経由して Source に到達できることを確信している場合だけ、マルチキャスト パケットを受け取ります。この状態では、Destination が Source へユニキャスト パケットを送信すると、MR 2 はトンネルを経由してユニキャスト パケットを送信します。MR2 がトンネルを経由して Source に到達できることのチェックは、Reverse Path Forwarding(RPF; リバース パス転送)チェックです。マルチキャスト パケットが到着するインターフェイスがソースへのユニキャスト パスでないとき、スタティック mroute によってこのチェックが成功します。トンネル経由のパケット送信は、元々の UR 2、UR 1、および MR 1 を経由した送信よりも遅くなることがあります。

マルチキャスト スタティック ルートでは、スタティック マルチキャスト ソースを設定することで、図 1 の設定を使用できます。システムは、ユニキャスト ルーティング テーブルの代わりに設定情報を使用してトラフィックをルーティングします。したがって、ユニキャスト パケットにトンネルを使用させることなく、マルチキャスト パケットがトンネルを使用できます。スタティック mroute は、設定されたルータに対してローカルであり、その他のルータにアドバタイズまたは再配布されることはありません。

非 IP マルチキャスト エリアの接続方法

ここでは、次の手順について説明します。

「非 IP マルチキャスト エリアを接続するトンネリングの設定」

非 IP マルチキャスト エリアを接続するトンネリングの設定

ユニキャスト パスとは異なるマルチキャスト パスが必要な場合、マルチキャスト スタティック ルートを設定します。たとえば、ソースと宛先の間のユニキャスト パスがマルチキャスト ルーティングをサポートしないために、2 つのルータの間にトンネルを設定することが考えられます。

手順の概要

1. enable

2. configure terminal

3. interface tunnel number

4. ip unnumbered type number

5. ip pim sparse-mode

6. tunnel source { ip-address | type number }

7. tunnel destination { hostname | ip-address }

8. トンネルの反対側の端のルータで、トンネルのソース アドレスとトンネルの宛先アドレスを逆にして、ステップ 1 ~ 7 を繰り返します。

9. end

10. ip mroute source-address mask tunnel number [ distance ]

11. ip mroute source-address mask tunnel number [ distance ]

12. end

13. show ip mroute [ group-address | group-name ] [ source-address | source-name ] [ interface-type interface-number ] [ summary ] [ count ] [ active kbps ]

14. show ip rpf { source-address | source-name } [ metric ]

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface tunnel number

 

Router(config)# interface tunnel 0

トンネル インターフェイスを設定します。

ステップ 4

ip unnumbered type number

 

Router(config-if)# ip unnumbered ethernet 0

インターフェイスに IP アドレスを割り当てずに、IP 処理をイネーブルにします。

ステップ 5

ip pim sparse-mode

 

Router(config-if)# ip pim sparse-mode

トンネル インターフェイスの PIM スパース モードをイネーブルにします。

ステップ 6

tunnel source { ip-address | type number }

 

Router(config-if)# tunnel source 100.1.1.1

トンネルのソースを設定します。

ステップ 7

tunnel destination { hostname | ip-address }

 

Router(config-if)# tunnel destination 100.1.5.3

トンネルの宛先を設定します。

ステップ 8

トンネルの反対側の端のルータで、トンネルのソース アドレスとトンネルの宛先アドレスを逆にして、ステップ 1 ~ 7 を繰り返します。

ルータ A のトンネルのソース アドレスは、ルータ B のトンネルの宛先アドレスに一致します。ルータ A のトンネルの宛先アドレスは、ルータ B のトンネルのソース アドレスに一致します。

ステップ 9

end

 

Router(config-if)# end

現在のコンフィギュレーション セッションを終了して、特権 EXEC モードに戻ります。

ステップ 10

ip mroute source-address mask tunnel number [ distance ]

 

Router(config)# ip mroute 0.0.0.0 0.0.0.0 tunnel 0

トンネルの反対側に向かってリバース パス転送するために、スタティック マルチキャスト ルートを設定します。

トンネルの使用によって、マルチキャスト トポロジがユニキャスト トポロジと一致しなくなり、マルチキャスト トラフィックだけがトンネルを通過できるため、トンネルを正しくリバース パス転送するようにルータを設定する必要があります。

ソース範囲が指定された場合、それらのソースにだけ mroute が適用されます。

この例では、 source-address および mask は 0.0.0.0、0.0.0.0 であり、これは任意のアドレスを意味します。

より短い距離が優先されます。

デフォルトの距離は、0 です。

ステップ 11

ip mroute source-address mask tunnel number [ distance ]

 

Router(config)# ip mroute 0.0.0.0 0.0.0.0 tunnel 0

アクセス ルータからトンネルの反対側に向かってリバース パス転送するために、スタティック ルートを設定します。

ステップ 12

end

 

Router(config)# end

(任意)現在のコンフィギュレーション セッションを終了して、特権 EXEC モードに戻ります。

ステップ 13

show ip mroute [ group-address | group-name ] [ source-address | source-name ] [ interface-type interface-number ] [ summary ] [ count ] [ active kbps ]

 

Router# show ip mroute

(任意)IP マルチキャスト ルーティング(mroute)テーブルの内容を表示します。

ステップ 14

show ip rpf { source-address | source-name } [ metric ]

 

Router# show ip rpf 10.2.3.4

(任意)IP マルチキャスト ルーティングが RPF を行う状態を表示します。

非 IP マルチキャスト エリアを接続するトンネリングの設定例

ここでは、次の設定例について説明します。

「非 IP マルチキャスト エリアを接続するトンネリングの設定:例」

非 IP マルチキャスト エリアを接続するトンネリングの設定:例

次の例は、オンラインでも次の URL で表示されます。

http://www.cisco.com/en/US/tech/tk828/tk363/technologies_configuration_example09186a00801a5aa2.shtml

図 2 では、マルチキャスト ソース(10.1.1.1)は、R102 に接続されており、マルチキャスト グループ 239.1.1.20 に対して設定されています。マルチキャスト レシーバ(10.2.2.3)は、R104 に接続されており、グループ 239.1.1.20 のマルチキャスト パケットを受信するように設定されています。R102 と R104 は、マルチキャスト ルーティング用に設定されていない IP クラウドで分離されています。

図 2 非 IP マルチキャスト エリアを接続するトンネル

 

ループバック インターフェイスによって、R102 と R104 の間にトンネルが設定されています。トンネル インターフェイスで ip pim sparse-dense-mode コマンドが設定され、R102 および R104 ではマルチキャスト ルーティングがイネーブルです。トンネル インターフェイスの sparse-dense-mode 設定により、スパース モード パケットまたはデンス モード パケットをグループの Rendezvous Point(RP; ランデブー ポイント)設定に応じて、トンネルを経由して転送できます。


) デンス モードの場合:トンネルに PIM デンス モードを設定し、R104 で ip mroute 10.1.1.0 255.255.255.0 tunnel 0 コマンドを設定すると、マルチキャスト ソース アドレス 10.1.1.1 の RPF の正常終了が確実になります。Tunnel0(Tu0)を経由した着信(10.1.1.1, 239.1.1.20)マルチキャスト パケットは、この mroute ステートメントを使用して Reverse Path Forwarding(RPF; リバース パス転送)がチェックされます。チェックの正常終了後、マルチキャスト パケットは Outgoing Interface List(OIL; 発信インターフェイス リスト)インターフェイスに転送されます。



) スパース モードの場合:トンネルに PIM スパース モードを設定し、次の点を確実に対処します。


RP からの共有ツリー (*, G) 上のマルチキャスト トラフィックに対する RPF 確認の正常終了には、トンネル インターフェイスに接続する RP アドレスに対して ip mroute rp-address nexthop コマンドの設定が必要です。

この例では、R102 が RP(RP アドレス 2.2.2.2)であることが前提とされており、mroute には、 ip mroute 2.2.2.2 255.255.255.255 tunnel 0 コマンドが設定されます。これによって、共有ツリー上のトラフィックに対する RPF チェックの正常終了が確実になります。

Shortest Path Tree(SPT; 最短パス ツリー)上のマルチキャスト (S, G) トラフィックに対する RPF 確認の正常終了には、トンネル インターフェイスに接続するマルチキャスト ソースに対して ip mroute source-address nexthop コマンドの設定が必要です。

この例では、SPT トラフィックがトンネル インターフェイスを経由する場合、R104 に ip mroute 10.1.1.0 255.255.255.0 tunnel 0 コマンドが設定されます。これによって、Tunnel 0 を経由する着信(10.1.1.1, 239.1.1.20)マルチキャスト パケットに対する RPF 確認の正常終了が確実になります。

R102#

version 12.2
hostname r102
ip subnet-zero
no ip domain-lookup
!--- It stops IP domain lookup, which improves the show command response time.
!
ip multicast-routing
!--- Enables IP multicast routing.
!
interface Loopback0
ip address 2.2.2.2 255.255.255.255
!--- Tunnel Source interface.
!
interface Tunnel0
!--- Tunnel interface configured for PIM and carrying multicast packets to R104.
ip address 192.168.24.1 255.255.255.252
ip pim sparse-dense-mode
tunnel source Loopback0
tunnel destination 4.4.4.4
!
interface Ethernet0/0
!--- Interface connected to Source.
ip address 10.1.1.2 255.255.255.0
ip pim sparse-dense-mode
!
interface Serial8/0
ip address 192.168.23.1 255.255.255.252
!--- Note IP PIM sparse-dense mode is not configured on Serial interface.
!
router ospf 1
log-adjacency-changes
network 2.2.2.2 0.0.0.0 area 0
network 10.1.1.0 0.0.0.255 area 0
network 192.168.23.0 0.0.0.255 area 0
!
ip classless
ip pim bidir-enable
!
line con 0
line aux 0
line vty 0 4
login
!
end

R104#

version 12.2
!
hostname r104
!
ip subnet-zero
no ip domain-lookup
!--- It stops IP domain lookup, which improves the show command response time.
!
ip multicast-routing
!--- Enables IP multicast routing.
!
interface Loopback0
ip address 4.4.4.4 255.255.255.255
!--- Tunnel Source interface.
!
interface Tunnel0
ip address 192.168.24.2 255.255.255.252
!--- Tunnel interface configured for PIM and carrying multicast packets.
ip pim sparse-dense-mode
tunnel source Loopback0
tunnel destination 2.2.2.2
!
interface Ethernet0/0
ip address 10.2.2.2 255.255.255.0
ip pim sparse-dense-mode
!
interface Serial9/0
ip address 192.168.34.1 255.255.255.252
!--- Note IP PIM sparse-dense mode is not configured on Serial interface.
!
!
router ospf 1
log-adjacency-changes
network 4.4.4.4 0.0.0.0 area 0
network 10.2.2.0 0.0.0.255 area 0
network 192.168.34.0 0.0.0.255 area 0
!
ip classless
no ip http server
ip pim bidir-enable
ip mroute 10.1.1.0 255.255.255.0 Tunnel0
!--- This Mroute ensures a successful RPF check for packets flowing from the source.
!--- 10.1.1.1 over Shared tree in case of Dense more and SPT in case of Sparse mode.
!
ip mroute 2.2.2.2 255.255.255.255 tunnel 0
!--- This Mroute is required for RPF check when Sparse mode multicast traffic is
!--- flowing from RP (assuming R102 with 2.2.2.2 as RP) towards receiver via tunnel
!--- before the SPT switchover.
line con 0
line aux 0
line vty 0 4
login
!
end

その他の参考資料

ここでは、非 IP マルチキャスト エリアを接続するトンネリングに関連する参考資料について説明します。

関連資料

関連項目
参照先

IP マルチキャスト コマンド:コマンド構文の詳細、コマンド モード、コマンド履歴、デフォルト設定、使用に関する注意事項、および例

『Cisco IOS IP Multicast Command Reference』

規格

規格
タイトル

なし

--

MIB

MIB
MIB リンク

なし

選択したプラットフォーム、Cisco IOS リリース、および機能セットの MIB を検索してダウンロードする場合は、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFC

RFC
タイトル

なし

--

シスコのテクニカル サポート

説明
リンク

TAC のホームページには、3 万ページに及ぶ検索可能な技術情報があります。製品、テクノロジー、ソリューション、技術的なヒント、およびツールへのリンクもあります。Cisco.com に登録済みのユーザは、このページから詳細情報にアクセスできます。

http://www.cisco.com/public/support/tac/home.shtml

非 IP マルチキャスト エリアを接続するトンネリングの機能情報

表 1 に、このモジュールで説明した機能をリストし、特定の設定情報へのリンクを示します。この表には、Cisco IOS Release 12.2(1) 以降のリリースで導入または変更された機能だけを示します。

ご使用の Cisco IOS ソフトウェア リリースによっては、コマンドの中に一部使用できないものがあります。特定のコマンドのサポートの導入時期に関する詳細については、コマンド リファレンス マニュアルを参照してください。

Cisco IOS ソフトウェア イメージは、Cisco IOS ソフトウェア リリース、機能セット、プラットフォームそれぞれに固有です。Cisco Feature Navigator を使用すると、プラットフォーム、および Cisco IOS ソフトウェア イメージの各サポート情報を検索できます。Cisco Feature Navigator( http://www.cisco.com/go/fn )にアクセスしてください。アクセスには、Cisco.com のアカウントが必要です。アカウントを持っていないか、ユーザ名またはパスワードが不明の場合は、ログイン ダイアログボックスの [Cancel] をクリックし、表示される指示に従ってください。

表 1 非 IP マルチキャスト エリアを接続するトンネリングの機能情報

機能名
リリース
機能設定情報

Cisco IOS Release 12.2(1) 以降にこのモジュールで導入または変更された機能はないため、この表は空白になっています。モジュールに機能情報が追加されると、この表は更新されます。

--

--