IP マルチキャスト コンフィギュレーション ガイド、 Cisco IOS Release 15.1S
マルチキャスト VPN エクストラネット サ ポートの設定
マルチキャスト VPN エクストラネット サポートの設定
発行日;2012/02/01 | 英語版ドキュメント(2011/06/14 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 8MB) | フィードバック

目次

マルチキャスト VPN エクストラネット サポートの設定

機能情報の入手方法

この章の構成

マルチキャスト VPN エクストラネット サポートの設定に関する前提条件

マルチキャスト VPN エクストラネット サポートの設定に関する制約事項

マルチキャスト VPN エクストラネット サポートに関する情報

MVPN エクストラネット サポートの概要

MVPN エクストラネット サポートの利点

エクストラネット MVPN のコンポーネント

MVPN エクストラネット サポートのソリューション

MVPN エクストラネット サポートの設定ガイドライン

オプション 1 の MVPN エクストラネット サポートの設定ガイドライン

オプション 2 の MVPN エクストラネット サポートの設定ガイドライン

インポートされたルートを使用した MVPN エクストラネット サポートの RPF

スタティック mroute を使用した MVPN エクストラネット サポートの RPF

Catalyst 6500 シリーズ スイッチでのマルチキャスト VPN エクストラネット サポートのハードウェア アクセラレーション

マルチキャスト VPN エクストラネット サポートの設定方法

MVPN エクストラネット サポートの設定

前提条件

制約事項

ソース PE でのレシーバ MVRF の設定(オプション 1)

レシーバ PE でのソース MVRF の設定(オプション 2)

スタティック mroute を使用した MVPN エクストラネット サポートの RPF の設定

スタティック mroute を使用した MVPN エクストラネット サポートの RPF

前提条件

MVPN エクストラネット サポートがあるグループベースの VRF 選択ポリシーの設定

マルチキャスト VPN エクストラネット VRF の選択

前提条件

マルチキャスト VPN エクストラネット サポートの設定例

例:ソース PE ルータでのレシーバ VRF の設定(オプション 1)

例:レシーバ PE でのソース VRF の設定(オプション 2)

例:スタティック mroute を使用した MVPN エクストラネット サポートの RPF の設定

例:MVPN エクストラネット サポートがあるグループベースの VRF 選択ポリシーの設定

その他の参考資料

関連資料

規格

MIB

RFC

シスコのテクニカル サポート

マルチキャスト VPN エクストラネット サポートの設定に関する機能情報

マルチキャスト VPN エクストラネット サポートの設定

マルチキャスト Virtual Private Network(VPN; バーチャル プライベート ネットワーク)エクストラネット サポート機能(MVPN エクストラネット サポート機能と呼ばれることもある)を使用すると、サービス プロバイダーは、1 つの企業サイトから発信された IP マルチキャスト コンテンツを他の企業サイトに配信できます。この機能により、サービス プロバイダーは、次世代の柔軟なエクストラネット サービスを提供でき、異なるエンタープライズ VPN カスタマー間でのビジネス パートナーシップの実現を支援します。

この章では、マルチキャスト VPN エクストラネット サポートの設定に関する概念および作業について説明します。

機能情報の入手方法

ご使用のソフトウェア リリースで、このモジュールで説明されるすべての機能がサポートされているとは限りません。最新の機能情報および警告については、ご使用のプラットフォームおよびソフトウェア リリースのリリースノートを参照してください。このモジュールに記載されている機能に関する情報を検索したり、各機能がサポートされているリリースに関するリストを参照したりするには、「マルチキャスト VPN エクストラネット サポートの設定に関する機能情報」を参照してください。

Cisco Feature Navigator を使用すると、プラットフォームおよび Cisco ソフトウェア イメージのサポート情報を検索できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。

マルチキャスト VPN エクストラネット サポートの設定に関する前提条件

IP マルチキャストの概念および設定作業を熟知している。

マルチキャスト VPN(MVPN)の概念および設定作業を熟知している。

Multiprotocol Label Switching(MPLS; マルチプロトコル ラベル スイッチング)レイヤ 3 VPN の概念および設定作業を熟知している。

マルチキャスト VPN エクストラネット サポートの設定に関する制約事項

マルチキャスト VPN エクストラネット サポート機能は、Protocol Independent Multicast(PIM)スパース モード(PIM-SM)、Source Specific Multicast(SSM)トラフィックのみをサポートします。PIM Dense Mode(PIM-DM; PIM デンス モード)、および Bidirectional PIM(bidir-PIM; 双方向 PIM)トラフィックはサポートされません。

Cisco IOS Release 12.2(33)SRC と、これに続く 12.2SR リリースでは、マルチキャスト VPN エクストラネット サポート機能が Cisco 7600 シリーズ ルータでサポートされません。Cisco IOS Release 15.0(1)S では、マルチキャスト VPN エクストラネット サポート機能が Cisco 7600 シリーズ ルータに導入されました。

PIM-SM 環境でエクストラネット MVPN を設定する場合、ソースと Rendezvous Point(RP; ランデブー ポイント)は、同じ Provider Edge(PE; プロバイダー エッジ)ルータの背後にある MVPN の同じサイトに常駐する必要があります。

マルチキャスト VPN エクストラネット サポートに関する情報

「MVPN エクストラネット サポートの概要」

「MVPN エクストラネット サポートの設定ガイドライン」

「Catalyst 6500 シリーズ スイッチでのマルチキャスト VPN エクストラネット サポートのハードウェア アクセラレーション」

MVPN エクストラネット サポートの概要

エクストラネットは、会社の外部のユーザまで拡張された会社のイントラネットの一部と考えることができます。カスタマーおよび会社に製品とコンテンツを販売する方法、および他の会社とビジネスを行う方法として VPN が使用される「心理状態」として説明されることもあります。エクストラネットは、ビジネスの情報または業務の一部を安全に共有するために、企業サイトまたはサイトを外部のビジネス パートナーまたは供給業者と接続する VPN です。

MPLS VPN は本質的にセキュリティを提供し、ユーザが適切な情報だけにアクセスできるようにします。MPLS VPN エクストラネット サービスは、企業データの一貫性を損なうことなくエクストラネット ユーザにユニキャスト接続を提供します。マルチキャスト VPN エクストラネット サポート機能は、関連のあるエクストラネット コミュニティとのマルチキャスト接続までこのサービスを拡張します。

マルチキャスト VPN エクストラネット サポート機能は、ある企業サイトから他の企業サイトに送信された IP マルチキャスト コンテンツをサービス プロバイダーが配信できるようにします。この機能により、サービス プロバイダーは、次世代の柔軟なエクストラネット サービスを提供でき、異なるエンタープライズ VPN カスタマー間でのビジネス パートナーシップの実現を支援します。この機能を使用すると、サービス プロバイダーは、短期契約、年間契約、および購買契約を含むさまざまなビジネス パートナーシップ要件を満たすために、マルチキャスト エクストラネット契約を提供できます。

MVPN エクストラネット サポートの利点

マルチキャスト VPN エクストラネット サポート機能は、次のようなビジネス上の問題を解決するために使用できます。

企業間の効率的なコンテンツ配信

サービス プロバイダーまたはコンテンツ プロバイダーから異なる企業 VPN カスタマーへの効率的なコンテンツ配信

エクストラネット MVPN のコンポーネント

図 1 に、エクストラネット MVPN を構成するコンポーネントを示します。

MVRF :マルチキャスト VPN Routing and Forwarding(VRF; VPN ルーティングおよび転送)インスタンス。MVRF は、マルチキャストがイネーブルな VRF です。VRF は、IP ルーティング テーブル、取得された転送テーブル、その転送テーブルを使用する一連のインターフェイス、転送テーブルに登録されるものを決定する一連のルールおよびルーティング プロトコルで構成されています。一般に、VRF には、PE ルータに付加されるカスタマー VPN サイトを定義するルーティング情報が格納されています。

ソース MVRF :直接接続された Customer Edge(CE; カスタマー エッジ)ルータを通してソースに到達できる MVRF。

レシーバ MVRF :1 台以上の CE デバイスを通して受信側が接続されている MVRF。

ソース PE :直接接続された CE ルータの背後にあり、マルチキャスト ソースを含む PE ルータ。

レシーバ PE :直接接続された CE ルータの背後にあり、関連する受信先が 1 つ以上存在する PE ルータ。

図 1 エクストラネット MVPN のコンポーネント

 

MVPN エクストラネット サポートのソリューション

ルーティングの観点から見た場合、ユニキャストではイントラネットとエクストラネットの違いはありません。つまり、VRF がプレフィクスをインポートする場合、このプレフィクスは Label-Switched Path(LSP; ラベルスイッチド パス)を介して到達可能です。企業がプレフィクスを所有している場合、プレフィクスは企業イントラネットの一部とみなされます。所有していない場合、プレフィクスはエクストラネットの一部とみなされます。ただしマルチキャストでは、プレフィクスの到達可能性は(特に LSP を経由した場合)、Multicast Distribution Tree(MDT; マルチキャスト配信ツリー)の構築には十分ではありません。

エクストラネット MVPN サービスのサポートを提供するには、ソースおよびレシーバ MVRF に同じデフォルト MDT グループを設定する必要があります。マルチキャスト VPN エクストラネット サポート機能を Cisco IOS Releases 12.2(31)SB2 および 12.2(33)SXH に導入する前に、サービス プロバイダーによるエクストラネット MVPN サービスの提供を阻む課題がありました。

ソース MVRF にデフォルト MDT グループが設定されなかったか、またはレシーバ MVRF とは異なる MDT グループが設定された可能性があります。前者のケースではソース MVRF がマルチキャスト ストリームをエクストラネット サイトに転送する方法がなく、後者の場合は個別の MVRF がリンクする方法がありません。

Reverse Path Forwarding(RPF; リバース パス転送)インターフェイスおよび発信インターフェイスが異なる VRF に属している場合、フォワーディング テーブルを維持できませんでした。

マルチキャスト VPN エクストラネット サポート機能は、これらの問題を次のように解決します。

レシーバおよびソース MVRF マルチキャスト ルート(mroute)エントリがリンクされています。

RPF のチェックは、ソースが到達可能なインターフェイスを決定するために、ユニキャスト ルーティング情報に依存します。このインターフェイスは、RPF インターフェイスとして使用されます。

MVPN エクストラネット サポートの設定ガイドライン

エクストラネット MVPN サービスを提供する 2 つの設定オプションがあります。

オプション 1:ソース PE ルータのレシーバ MVRF を設定します。

オプション 2:レシーバ PE ルータのソース MVRF を設定します。

オプション 1 の MVPN エクストラネット サポートの設定ガイドライン

ソース PE ルータにレシーバ MVRF を設定することによって(オプション 1)、企業 VPN カスタマーにエクストラネット MVPN サービスを提供するには、次の手順を行います。

各エクストラネット サイトで、MVRF がソース PE 上で設定されていない場合は、レシーバ MVRF と同じデフォルト MDT グループを持つソース PE ルータで追加の MVRF を設定します。

レシーバ MVRF の設定では、ソースおよびレシーバ PE ルータに同じユニキャスト ルーティング ポリシーを設定し、ソース MVRF からレシーバ MVRF へのルートをインポートします。

図 2 に、ソース PE ルータにレシーバ MVRF が設定されているエクストラネット MVPN トポロジでのマルチキャスト トラフィックのフローを示します(オプション 1)。トポロジでは、MVRF は、PE1(ソース PE ルータ)上の VPN-Green および VPN-Red に設定されています。PE1 の背後にあるマルチキャスト ソースは、VPN-Green の MVRF にマルチキャスト ストリームを送信し、PE2 と PE3(それぞれ、VPN-Red と VPN-Green のレシーバ PE ルータ)の背後には、該当する受信先があります。PE1 が VPN-Green の MVRF にあるソースからパケットを受信した後、VPN-Green および VPN-Red の MVRF でパケットを別々に複製してカプセル化し、そのパケットを転送します。このソースからパケットを受信した後、PE2 と PE3 は、パケットをカプセル化解除し、それぞれの MVRF に転送します。

図 2 MVPN エクストラネット サポート設定オプション 1 のパケット フロー

 

オプション 2 の MVPN エクストラネット サポートの設定ガイドライン

レシーバ PE ルータにソース MVRF を設定することによって(オプション 2)、企業 VPN カスタマーにエクストラネット MVPN サービスを提供するには、次の手順を行います。

直接接続された CE ルータの背後にある、エクストラネット サイトに関連する受信先が 1 つ以上存在するレシーバ PE ルータでは、MVRF が設定されていない場合、マルチキャスト ソースに接続されたサイトと同じデフォルト MDT グループを持つ追加 MVRF を設定します。

レシーバ PE ルータでは、同じユニキャスト ルーティング ポリシーを設定し、ソース MVRF からレシーバ MVRF へのルートをインポートします。

図 3 に、レシーバ PE ルータにソース MVRF が設定されているエクストラネット MVPN トポロジでのマルチキャスト トラフィックのフローを示します(オプション 2)。トポロジでは、MVRF は、PE2(レシーバ PE ルータ)上の VPN-Green および VPN-Red に設定されています。PE1(ソース PE ルータ)の背後にあるマルチキャスト ソースは、VPN-Green の MVRF にマルチキャスト ストリームを送信し、PE2(VPN-Red のレシーバ PE ルータ)と PE3(VPN-Green のレシーバ PE ルータ)の背後には、該当する受信先があります。PE1 は VPN-Green の MVRF にあるソースからパケットを受信した後、VPN-Green パケットを複製し PE2、PE3 に転送します。これはどちらのルータも VPN-Green のレシーバに接続されているためです。VPN-Green から発信されたパケットは PE2 で複製されて、VPN-Red の該当する受信先に転送されます。また、PE3 で複製されて、VPN-Green の該当する受信先に転送されます。

図 3 MVPN エクストラネット サポート設定オプション 2 のパケット フロー

 

インポートされたルートを使用した MVPN エクストラネット サポートの RPF

エクストラネット リンクを作成するには、ソース PE ルータにレシーバ MVRF を設定するか(オプション 1)、レシーバ PE ルータにソース MVRF を設定する(オプション 2)必要があります。いったん設定されると、RPF は、ソースが到達可能なインターフェイスを決定するために、ユニキャスト ルーティング情報に依存します。このインターフェイスは、RPF インターフェイスとして使用されます。RPF 解決には、追加設定は不要です。マルチキャスト VPN エクストラネット サポート機能は、1 つの VRF から別の VRF、VRF からグローバル ルーティング テーブル、およびグローバル ルーティング テーブルから VRF への RPF をサポートします。

スタティック mroute を使用した MVPN エクストラネット サポートの RPF

デフォルトでは、エクストラネット MVPN は、RPF インターフェイスを決定するために、ユニキャスト ルーティング ポリシーに依存します。RPF ルックアップがレシーバ MVRF から始まり、RPF インターフェイスが同じ MVRF にないことがわかった場合、ルータは、Border Gateway Protocol(BGP; ボーダー ゲートウェイ プロトコル)がインポートしたルート内の情報を使用して、ソース MVRF を決定します。RPF ルックアップは、引き続きソース MVRF で解決します。マルチキャスト トポロジとユニキャスト トポロジが一致しない場合、レシーバ MVRF にスタティック mroute を設定してデフォルトの動作を無効にし、 fallback-lookup キーワードおよび vrf vrf-name のキーワードと引数とともに ip mroute コマンドを使用して、ソース MVRF を明示的に指定します。

ソースが MVRF にあり、レシーバがグローバル テーブルにある場合、スタティック mroute を設定して、エクストラネット MVPN の RPF をサポートすることもできます。この場合、BGP は VPNv4 ルートの IPv4 ルーティング テーブルへのインポートを許可しないので、ユニキャストは、RPF ルックアップを解決するために必要なソース MVRF の情報を取得できません。この場合、RPF ルックアップを解決できるようにするには、 fallback-lookup キーワードおよび global キーワードとともに ip mroute コマンドを使用すると、スタティック mroute がソース MVRF を明示的に指定するように設定できます。

Catalyst 6500 シリーズ スイッチでのマルチキャスト VPN エクストラネット サポートのハードウェア アクセラレーション

Cisco IOS Release 12.2(33)SXH 以降、マルチキャスト VPN エクストラネット サポート機能が Catalyst 6500 シリーズ スイッチに設定されている場合は、ソース MVRF およびレシーバ MVRF 向けのフォワーディング エントリは(この機能用に、これらがソフトウェアにリンクされるのと同じ方法で)ハードウェアにリンクされ、パケットはエクストラネット MVPN サイトに転送される際にハードウェアで複製されます。この機能は、「マルチキャスト VPN エクストラネット サポートのハードウェア アクセラレーション機能」と呼ばれます。

マルチキャスト VPN エクストラネット サポートの設定方法

ここでは、次の作業について説明します。

「MVPN エクストラネット サポートの設定」(必須)

「スタティック mroute を使用した MVPN エクストラネット サポートの RPF の設定」(任意)

「MVPN エクストラネット サポートがあるグループベースの VRF 選択ポリシーの設定」(任意)

MVPN エクストラネット サポートの設定

エクストラネット MVPN サービスのサポートを設定するには、次の作業を実行します。エクストラネット MVPN サービスを使用すると、サービス プロバイダーは、企業サイトから発信された IP マルチキャスト コンテンツを外部のビジネス パートナーまたは供給業者のサイトに配信できます。

エクストラネット MVPN の機能を提供するには、次の作業のいずれかを行います。

「ソース PE でのレシーバ MVRF の設定(オプション 1)」

「レシーバ PE でのソース MVRF の設定(オプション 2)」

前提条件

この作業は、ソースおよびレシーバ VPN にイントラネット VPN が設定されていることを想定しています。VPN の設定の詳細については、『 Cisco IOS Multiprotocol Label Switching Configuration Guide , Release 12.4』の「 MPLS Virtual Private Networks 」を参照してください。

制約事項

マルチキャスト VPN エクストラネット サポート機能は、PIM-SM および SSM トラフィックのみをサポートし、PIM-DM および bidir-PIM トラフィックはサポートされません。

PIM-SM 環境でエクストラネット MVPN を設定する場合、ソースと RP は、同じ PE ルータの背後にある MVPN の同じサイトに常駐する必要があります。

Cisco IOS Release 12.2(33)SXH と、これに続く 12.2SX リリースでは、マルチキャスト VPN エクストラネット サポート機能が Catalyst 6500 シリーズ スイッチに設定されている場合は、ソース MVRF およびレシーバ MVRF 向けのフォワーディング エントリは(マルチキャスト VPN エクストラネット サポート機能用に、これらがソフトウェアにリンクされるのと同じ方法で)ハードウェアにリンクされ、パケットはエクストラネット MVPN サイトに転送される際にハードウェアで複製されます。

Cisco IOS Release 12.2(33)SRC と、これに続く 12.2SR リリースでは、マルチキャスト VPN エクストラネット サポート機能が Cisco 7600 シリーズ ルータでサポートされません。Cisco IOS Release 15.0(1)S では、マルチキャスト VPN エクストラネット サポート機能が Cisco 7600 シリーズ ルータに導入されました。

ソース PE でのレシーバ MVRF の設定(オプション 1)

ソース PE ルータにレシーバ MVRF を設定することによって(オプション 1)、エクストラネット MVPN サービスのサポートを提供するには、次の手順を行います。

この作業の設定は、PE1(ソース PE ルータ)で行います(図 4を参照)。オプション 1 を使用して、1 つの企業 VPN サイト(VPN-Green など)から別の VPN サイト(VPN-Red など)へエクストラネット MVPN サービスを提供するには、ソース PE ルータにレシーバ MVRF を設定します。レシーバ MVRF の設定では、デフォルト MDT グループは、ソースおよびレシーバ PE ルータの両方で同じにする必要があります。さらに、同じユニキャスト ルーティング ポリシーを設定し、ソース MVRF(たとえば、VPN-Green の MVRF)からレシーバ(たとえば、VPN-Red の MVRF)へのルートをインポートします。

図 4 MVPN エクストラネット サポート設定オプション 1 のトポロジ

 


) この作業は、ソースおよびレシーバ VPN にイントラネット VPN が設定されていることを想定しています。VPN の設定の詳細については、『Cisco IOS Multiprotocol Label Switching Configuration Guide』の「MPLS Virtual Private Networks」を参照してください。


手順の概要

1. enable

2. configure terminal

3. ip vrf vrf-name

4. rd route-distinguisher

5. route-target import route-target-ext-community

6. mdt default group-address

7. end

8. show ip mroute [ vrf vrf-name ] group-address

9. show mls ip multicast group group-address

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip vrf vrf-name

 

Router(config)# ip vrf VPN-Red

VRF 名を割り当てることによって VPN ルーティング インスタンスを定義し、VRF コンフィギュレーション モードを開始します。

vrf-name 引数は、VRF に割り当てられる名前です。

ステップ 4

rd route-distinguisher

 

Router(config-vrf)# rd 55:2222

ルーティングとフォワーディング テーブルを作成します。

route-distinguisher 引数を指定し、IPv4 プレフィクスに 8 バイトの値を追加して、VPN IPv4 プレフィクスを作成します。RD は、次のいずれかの形式で入力できます。

16 ビットの自律システム番号、ご使用の 32 ビットの数字(101:3 など)。

32 ビットの IP アドレス:ご使用の 16 ビットの番号(192.168.122.15:1 など)

ステップ 5

route-target import route-target-ext-community

 

Router(config-vrf)# route-target import 55:1111

VRF のルートターゲット拡張コミュニティを作成します。

import キーワードは、ターゲット VPN 拡張コミュニティからルーティング情報をインポートします。

route-target-ext-community 引数は、VRF のインポート、エクスポート、または両方(インポートとエクスポート)のルートターゲット拡張コミュニティのリストに、ルートターゲット拡張コミュニティ アトリビュートを追加します。

(注) ソース MVRF からレシーバ MVRF に配信するコンテンツの場合、ソースおよびレシーバ PE ルータに同じユニキャスト ルーティング ポリシーを設定し、ソース VRF からレシーバ VRF へのルートをインポートする必要があります。

ステップ 6

mdt default group-address

 

Router(config-vrf)# mdt default 232.3.3.3

VRF に、データ MDT グループのマルチキャスト グループ アドレスの範囲を設定します。

このコマンドによって、トンネル インターフェイスが作成されます。

デフォルトでは、トンネル ヘッダーの宛先アドレスは、 group-address 引数です。

ステップ 7

end

 

Router(config-vrf)# end

VRF コンフィギュレーション モードを終了し、特権 EXEC モードに戻ります。

ステップ 8

show ip mroute [ vrf vrf-name ] group-address

 

Router# show ip mroute 232.3.3.3

(任意)特定のグループ アドレスの IP マルチキャスト mroute テーブルの内容を表示します。

ステップ 9

show mls ip multicast group group-address

 

Router# show mls ip multicast group 232.3.3.3

(任意)特定のマルチキャスト グループに関連する Multilayer Switching(MLS; マルチレイヤ スイッチング)情報を表示します。

(注) このコマンドは、Cisco IOS Release 12.2(33)SXH またはこれに続く 12.2SX リリースが稼動する Catalyst 6500 シリーズ スイッチにおける、エクストラネット MVPN サービスのサポートを確認する目的でのみ使用できます。

レシーバ PE でのソース MVRF の設定(オプション 2)

レシーバ PE ルータにソース MVRF を設定することによって(オプション 2)、エクストラネット MVPN サービスのサポートを提供するには、次の手順を行います。

この作業の設定は、PE2(レシーバ PE ルータ)で行います(図 5を参照)。オプション 2 を使用して、1 つの企業 VPN サイト(VPN-Green など)から別の VPN サイト(VPN-Red など)へエクストラネット MVPN サービスのサポートを提供するには、レシーバ PE ルータにソース MVRF を設定します。ソース MVRF の MDT グループ設定は、ソースおよびレシーバ PE ルータの両方で同じにする必要があります。さらに、同じユニキャスト ルーティング ポリシーを設定し、ソース MVRF(たとえば、VPN-Green の MVRF)からレシーバ(たとえば、VPN-Red の MVRF)へのルートをインポートします。

図 5 MVPN エクストラネット サポート設定オプション 2 のトポロジ

 


) この作業は、ソースおよびレシーバ VPN にイントラネット VPN が設定されていることを想定しています。VPN の設定の詳細については、『Cisco IOS Multiprotocol Label Switching Configuration Guide』の「MPLS Virtual Private Networks」を参照してください。


手順の概要

1. enable

2. configure terminal

3. ip vrf vrf-name

4. rd route-distinguisher

5. route-target import route-target-ext-community

6. mdt default group-address

7. end

8. show ip mroute [ vrf vrf-name ] group-address

9. show mls ip multicast group group-address

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip vrf vrf-name

 

Router(config)# ip vrf VPN-Red

VRF 名を割り当てることによって VPN ルーティング インスタンスを定義し、VRF コンフィギュレーション モードを開始します。

vrf-name 引数は、VRF に割り当てられる名前です。

ステップ 4

rd route-distinguisher

 

Router(config-vrf)# rd 55:1111

ルーティングとフォワーディング テーブルを作成します。

route-distinguisher は、IPv4 プレフィクスに 8 バイトの値を追加して、VPN IPv4 プレフィクスを作成します。RD は、次のいずれかの形式で入力できます。

16 ビットの自律システム番号、ご使用の 32 ビットの数字(101:3 など)。

32 ビットの IP アドレス:ご使用の 16 ビットの番号(192.168.122.15:1 など)

ステップ 5

route-target import route-target-ext-community

 

Router(config-vrf)# route-target import 55:1111

VRF のルートターゲット拡張コミュニティを作成します。

import キーワードは、ターゲット VPN 拡張コミュニティにルーティング情報をエクスポートします。

route-target-ext-community 引数は、VRF のインポート、エクスポート、または両方(インポートとエクスポート)のルートターゲット拡張コミュニティのリストに、ルートターゲット拡張コミュニティ アトリビュートを追加します。

(注) ソース MVRF からレシーバ MVRF に配信するコンテンツの場合、ソースおよびレシーバ PE ルータに同じユニキャスト ルーティング ポリシーを設定し、ソース VRF からレシーバ VRF へのルートをインポートする必要があります。

ステップ 6

mdt default group-address

 

Router(config-vrf)# mdt default 232.1.1.1

VRF に、データ MDT グループのマルチキャスト グループ アドレスの範囲を設定します。

このコマンドによって、トンネル インターフェイスが作成されます。

デフォルトでは、トンネル ヘッダーの宛先アドレスは、 group-address 引数です。

ステップ 7

end

 

Router(config-vrf)# end

VRF コンフィギュレーション モードを終了し、特権 EXEC モードに戻ります。

ステップ 8

show ip mroute [ vrf vrf-name ] group-address

 

Router# show ip mroute 232.1.1.1

(任意)特定のグループ アドレスの IP マルチキャスト mroute テーブルの内容を表示します。

ステップ 9

show mls ip multicast group group-address

 

Router# show mls ip multicast group 232.3.3.3

(任意)特定のマルチキャスト グループに関連する MLS 情報を表示します。

(注) このコマンドは、Cisco IOS Release 12.2(33)SXH またはこれに続く 12.2SX リリースが稼動する Catalyst 6500 シリーズ スイッチにおける、エクストラネット MVPN サービスのサポートを確認する目的でのみ使用できます。

スタティック mroute を使用した MVPN エクストラネット サポートの RPF の設定

スタティック mroute を使用して、エクストラネット MVPN の RPF を設定するには、次の作業を実行します。

スタティック mroute を使用した MVPN エクストラネット サポートの RPF

デフォルトでは、エクストラネット MVPN は、RPF インターフェイスを決定するために、ユニキャスト ルーティング ポリシーに依存します。RPF ルックアップがレシーバ MVRF から始まり、RPF インターフェイスが同じ MVRF にないことがわかった場合、ルータは、BGP がインポートしたルート内の情報を使用して、ソース MVRF を決定します。RPF ルックアップは、引き続きソース MVRF で解決します。マルチキャスト トポロジとユニキャスト トポロジが一致しない場合、レシーバ MVRF にスタティック mroute を設定してデフォルトの動作を無効にし、 fallback-lookup キーワードおよび vrf vrf-name のキーワードと引数とともに ip mroute コマンドを使用して、ソース MVRF を明示的に指定します。

ソースが MVRF にあり、レシーバがグローバル テーブルにある場合、スタティック mroute を設定して、エクストラネット MVPN の RPF をサポートすることもできます。この場合、BGP は VPNv4 ルートの IPv4 ルーティング テーブルへのインポートを許可しないので、ユニキャストは、RPF ルックアップを解決するために必要なソース MVRF の情報を取得できません。この場合、RPF ルックアップを解決できるようにするには、 fallback-lookup キーワードおよび global キーワードとともに ip mroute コマンドを使用すると、スタティック mroute がソース MVRF を明示的に指定するように設定できます。

前提条件

この作業を実行する前に、エクストラネット MVPN サービスのサポートを設定する必要があります。詳細については、「MVPN エクストラネット サポートの設定」を参照してください。

手順の概要

1. enable

2. configure terminal

3. ip mroute vrf vrf-name source-address mask fallback-lookup { global | vrf vrf-name } [ distance ]

4. end

5. show ip mroute [ vrf vrf-name ] group-address

6. show mls ip multicast group group-address

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip mroute vrf vrf-name source-address mask fallback-lookup { global | vrf vrf-name } [ distance ]

 

Router(config)# ip mroute vrf VPN-Red 224.100.0.5 255.255.255.255 fallback-lookup vrf VPN-Green

スタティック mroute を使用して、レシーバ MVRF で発生する RPF ルックアップがソース MVRF またはグローバル ルーティング テーブルで継続され、解決されるように設定します。

global キーワードは、ソース MVRF がグローバル ルーティング テーブルにあるように指定するために使用されます。

VRF をソース MVRF として明示的に指定するには、 vrf キーワードと vrf-name 引数を使用します。

ステップ 4

end

 

Router(config)# end

グローバル コンフィギュレーション モードを終了し、特権 EXEC モードを開始します。

ステップ 5

show ip mroute [ vrf vrf-name ] group-address

 

Router# show ip mroute 224.100.0.5

(任意)特定のグループ アドレスの IP マルチキャスト mroute テーブルの内容を表示します。

ステップ 6

show mls ip multicast group group-address

 

Router# show mls ip multicast group 232.3.3.3

(任意)特定のマルチキャスト グループに関連する MLS 情報を表示します。

(注) このコマンドは、Cisco IOS Release 12.2(33)SXH またはこれに続く 12.2SX リリースが稼動する Catalyst 6500 シリーズ スイッチにおける、エクストラネット MVPN サービスのサポートを確認する目的でのみ使用できます。

MVPN エクストラネット サポートがあるグループベースの VRF 選択ポリシーの設定

MVPN があるグループベースの VRF 選択ポリシーを設定するには、次の作業を実行します。

この作業を実行すると、VRF セレクタとしてグループ アドレスを使用して、異なる VRF にある同じソース アドレスに対して、RPF ルックアップを実行できます。この機能は、異なる MVPN から入ってきたコンテンツ ストリームをサービス プロバイダーが再配布できるようにすることによってエクストラネット MVPN を強化します。

マルチキャスト VPN エクストラネット VRF の選択

マルチキャスト VPN エクストラネット VRF の選択機能を Cisco IOS Release 12.2(31)SB2 およびこれに続く 12.2SB リリースに導入する前に、送信元アドレスの RPF ルックアップを 1 つの VRF でのみ実行できます。この VRF とは、Internet Group Management Protocol(IGMP; インターネット グループ管理プロトコル)または PIM 加入を受け取る VRF、BGP がインポートしたルートから学習する VRF、またはスタティック mroute で指定された VRF(エクストラネット MVPN の RPF がスタティック mroute を使用するように設定されている場合)を指します。このような場合、ソース VRF は、単にソース アドレスまたはソース アドレスの学習方法によって決定されます。

マルチキャスト VPN エクストラネット VRF の選択機能は、VRF セレクタとしてグループ アドレスを使用して、異なる VRF で同じソース アドレスに対して RPF ルックアップを実行するための機能を提供します。この機能は、異なる MVPN から入ってきたコンテンツ ストリームをサービス プロバイダーが再配布できるようにすることによってエクストラネット MVPN を強化します。

マルチキャスト VPN VRF 選択機能は、グループベースの VRF 選択ポリシーを作成することによって設定されます。グループベースの VRF 選択ポリシーは、 ip multicast rpf select コマンドを使用して設定されます。 ip multicast rpf select コマンドは、レシーバ MVRF またはグローバル ルーティング テーブルで発生する RPF ルックアップが、ソース MVRF またはグループ アドレス ベースのグローバル ルーティング テーブルで解決されるように設定するために使用されます。Access Control List(ACL; アクセス制御リスト)は、グループベースの VRF 選択ポリシーに適用するグループを定義するために使用されます。

図 6 に、マルチキャスト VPN VRF 選択機能が設定されたエクストラネット MVPN トポロジを示します。このトポロジでは、レシーバ VRF である VPN-Green から発信される (S, G1) および (S, G2) PIM 加入は、レシーバ PE である PE1 に転送されます。設定されたグループベースの VRF 選択ポリシーに基づいて、PE1 は、PIM 加入を G1 および G2 の各グループの VPN-Red と VPN-Blue に送信します。

図 6 グループベースの VRF 選択ポリシーを使用した RPF ルックアップ

 

前提条件

この作業は、Cisco IOS Release 12.2(31)SB2 または 12.2SB リリースが、ルータで実行されている必要があります。

この作業を実行する前に、エクストラネット MVPN サービスのサポートを設定する必要があります。詳細については、「MVPN エクストラネット サポートの設定」を参照してください。

ACL は、グループベースの VRF 選択ポリシーに適用するグループを定義するために使用されます。この作業は、グループベースの VRF 選択ポリシーに適用する ACL が設定されていることを想定しています。アクセス リストの設定に関する詳細については『Cisco IOS Application Service Configuration Guide , Release 12.4』の「 Configuring IP Access Lists 」の章を参照してください。

手順の概要

1. enable

2. configure terminal

3. ip multicast [ vrf receiver-vrf-name ] rpf select { global | vrf source-vrf-name } group-list access-list

4. ステップ 3 を繰り返して、グループベースの追加 VRF 選択ポリシーを作成します。

5. end

6. show ip rpf [ vrf vrf-name ] select

7. show ip rpf [ vrf vrf-name ] source-address [ group-address ]

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip multicast [ vrf receiver- vrf-name ] rpf select { global | vrf source - vrf-name } group-list access-list

 

Router(config)# ip multicast vrf VPN-Green rpf select vrf VPN-Red group-list 1

レシーバ MVRF またはグローバル ルーティング テーブルで発生する RPF ルックアップが、ソース MVRF またはグループ アドレス ベースのグローバル ルーティング テーブルで解決されるように設定します。

オプションの vrf キーワードと receiver-vrf-name 引数は、 receiver-vrf-name 引数に指定された VRF で発生する RPF ルックアップに、グループベースの VRF 選択ポリシーを適用するために使用されます。オプションの vrf キーワードと receiver-vrf-name 引数が指定されない場合、グループベースの VRF 選択ポリシーは、グローバル テーブルで発生する RPF ルックアップに適用されます。

global キーワードは、 group-list キーワードと access-list 引数に指定されたアクセス リストに一致するグループに対する RPF ルックアップが、グローバル ルーティング テーブルで実行されるように指定するために使用されます。

vrf キーワードと source-vrf-name 引数は、 group-list キーワードと access-list 引数に指定されたアクセス リストに一致するグループに対する RPF ルックアップが、 vrf-name 引数に指定された VRF で実行されるように指定するために使用されます。

group-list キーワードおよび access-list 引数は、グループベースの VRF 選択ポリシーに適用するアクセス リストを指定するために使用されます。

ステップ 4

ステップ 3 を繰り返して、グループベースの追加 VRF 選択ポリシーを作成します。

--

ステップ 5

end

 

Router(config)# end

グローバル コンフィギュレーション モードを終了し、特権 EXEC モードを開始します。

ステップ 6

show ip rpf [ vrf vrf-name ] select

 

Router# show ip rpf select

グループと VRF の間でのマッピング情報を表示します。

オプションの vrf キーワードと vrf-name 引数を使用して、 vrf-name 引数に指定された VRF インスタンスのグループと VRF の間のマッピングを表示します。

ステップ 7

show ip rpf [ vrf vrf-name ] source-address [ group-address ]

 

Router# show ip rpf 172.16.10.13

IP マルチキャスト ルーティングで RPF を行う方法に関する情報を表示します。

グループベースの VRF 選択ポリシーを設定後にこのコマンドを使用して、RPF ルックアップがグループ アドレスに基づいて行われることを確認し、RPF ルックアップが行われる VRF を表示します。

オプションの vrf キーワードと vrf-name 引数を使用して、 vrf-name 引数に指定された VRF で IP マルチキャスト ルーティングが RPF を行う方法を表示します。

マルチキャスト VPN エクストラネット サポートの設定例

ここでは、次の設定例について説明します。

「例:ソース PE ルータでのレシーバ VRF の設定(オプション 1)」

「例:レシーバ PE でのソース VRF の設定(オプション 2)」

「例:スタティック mroute を使用した MVPN エクストラネット サポートの RPF の設定」

「例:MVPN エクストラネット サポートがあるグループベースの VRF 選択ポリシーの設定」

例:ソース PE ルータでのレシーバ VRF の設定(オプション 1)

次の例は、PE1(ソース PE ルータ)と PE2(レシーバ PE ルータ)の設定を示します(図 7を参照)。この例では、エクストラネット MVPN サービスは、ソース PE ルータである PE1 の VPN-Red にレシーバ MVRF を設定することによって、VPN-Green と VPN-Red の間でサポートされます。VPN-Red の MVRF 設定は、VPN-Green の MVRF から VPN-Red の MVRF へのルートをインポートするように設定されます。

図 7 MVPN エクストラネット サポート オプション 1 設定例のトポロジ

 

PE1 の設定

ip cef
!
ip vrf VPN-Green
rd 55:1111
route-target export 55:1111
route-target import 55:1111
mdt default 232.1.1.1
!
ip vrf VPN-Red
rd 55:2222
route-target export 55:2222
route-target import 55:2222
route-target import 55:1111
mdt default 232.3.3.3
!
ip multicast-routing
ip multicast-routing vrf VPN-Green
ip multicast-routing vrf VPN-Red
!
interface Loopback0
ip address 10.1.0.1 255.255.255.0
ip pim sparse-dense-mode
!
.
.
.
!
router bgp 55
no synchronization
bgp log-neighbor-changes
neighbor 10.2.0.2 remote-as 55
neighbor 10.2.0.2 update-source Loopback0
!
address-family ipv4 mdt
neighbor 10.2.0.2 activate
neighbor 10.2.0.2 send-community extended
!
address-family vpnv4
neighbor 10.2.0.2 activate
neighbor 10.2.0.2 send-community extended
!

PE2 の設定

!
ip vrf VPN-Red
rd 55:2222
route-target export 55:2222
route-target import 55:2222
route-target import 55:1111
mdt default 232.3.3.3
!
ip multicast-routing
ip multicast-routing vrf VPN-Red
!
interface Loopback0
ip address 10.2.0.2 255.255.255.0
ip pim sparse-dense-mode
!
.
.
.
!
router bgp 55
no synchronization
bgp log-neighbor-changes
neighbor 10.1.0.1 remote-as 55
neighbor 10.1.0.1 update-source Loopback0
!
address-family ipv4 mdt
neighbor 10.1.0.1 activate
neighbor 10.1.0.1 send-community extended
!
address-family vpnv4
neighbor 10.1.0.1 activate
neighbor 10.1.0.1 send-community extended
!

MDT デフォルト グループ 232.3.3.3 の PE1 および PE2 のグローバル テーブルでの状態

次に、PE1 と PE2 での show ip mroute コマンドの出力例を示します。サンプル出力は、PE1 と PE2 での MDT デフォルト グループ 232.3.3.3 のグローバル テーブルを示しています。

PE1# show ip mroute 232.3.3.3
 
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group
V - RD & Vector, v - Vector
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
 
(10.1.0.1, 232.3.3.3), 00:46:27/00:03:27, flags: sT
Incoming interface: Loopback0, RPF nbr 0.0.0.0
Outgoing interface list:
Ethernet0/0, Forward/Sparse-Dense, 00:45:17/00:02:44
 
(10.2.0.2, 232.3.3.3), 00:45:17/00:02:57, flags: sTIZ
Incoming interface: Ethernet0/0, RPF nbr 224.0.1.4
Outgoing interface list:
MVRF VPN-Red, Forward/Sparse-Dense, 00:45:17/00:01:09
 
PE2# show ip mroute 232.3.3.3
 
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group
V - RD & Vector, v - Vector
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
 
(10.1.0.1, 232.3.3.3), 00:45:08/00:02:37, flags: sTIZ
Incoming interface: Ethernet1/0, RPF nbr 224.0.2.4
Outgoing interface list:
MVRF VPN-Red, Forward/Sparse-Dense, 00:45:08/00:01:27
 
(10.2.0.2, 232.3.3.3), 00:46:19/00:03:07, flags: sT
Incoming interface: Loopback0, RPF nbr 0.0.0.0
Outgoing interface list:
Ethernet1/0, Forward/Sparse-Dense, 00:45:08/00:02:49

PE1 と PE2 が MVPN エクストラネット サポートの設定された Catalyst 6500 シリーズ スイッチである場合の MDT デフォルト グループ 232.3.3.3 の PE1 および PE2 のグローバル テーブルでの状態

次に、PE1 と PE2 がエクストラネット MVPN サービスをサポートするように設定された Catalyst 6500 シリーズ スイッチである場合の、PE1 と PE2 での show ip mroute コマンドと show mls ip multicast コマンドの出力例を示します。 show ip mroute コマンドからのサンプル出力は、PE1 と PE2 における MDT デフォルト グループ 232.3.3.3 のグローバル テーブルを示しています。この出力で、「RPF-MFD」フラグはマルチキャスト フローが完全にハードウェアでスイッチングされることを示し、「H」フラグはフローが発信インターフェイスのハードウェアでスイッチングされることを示しています。 show mls ip multicast コマンドからのサンプル出力は、PE1 と PE2 のグループ 232.3.3.3 に関する MLS 情報を示しています。

PE1# show ip mroute 232.3.3.3
 
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group
V - RD & Vector, v - Vector
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
 
(10.1.0.1, 232.3.3.3), 00:46:27/00:03:27, flags: sT
Incoming interface: Loopback0, RPF nbr 0.0.0.0, RPF-MFD
Outgoing interface list:
GigabitEthernet2/16, Forward/Sparse-Dense, 00:45:17/00:02:44, H
 
(10.2.0.2, 232.3.3.3), 00:45:17/00:02:57, flags: sTIZ
Incoming interface: GigabitEthernet2/16, RPF nbr 224.0.1.4, RPF-MFD
Outgoing interface list:
MVRF VPN-Red, Forward/Sparse-Dense, 00:45:17/00:01:09, H
PE1# show mls ip multicast group 232.3.3.3
 
Multicast hardware switched flows:
(10.1.0.1, 232.3.3.3) Incoming interface: Lo0, Packets switched: 28
Hardware switched outgoing interfaces:
Gi2/16
RPF-MFD installed
 
 
(10.2.0.2, 232.3.3.3) Incoming interface: Gi2/16, Packets switched: 28
Hardware switched outgoing interfaces:
MVRF VPN-Red
RPF-MFD installed
 
Total hardware switched flows : 2
 
PE2# show ip mroute 232.3.3.3
 
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group
V - RD & Vector, v - Vector
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
 
(10.1.0.1, 232.3.3.3), 00:45:08/00:02:37, flags: sTIZ
Incoming interface: GigabitEthernet4/1, RPF nbr 224.0.2.4, RPF-MFD
Outgoing interface list:
MVRF VPN-Red, Forward/Sparse-Dense, 00:45:08/00:01:27, H
 
(10.2.0.2, 232.3.3.3), 00:46:19/00:03:07, flags: sT
Incoming interface: Loopback0, RPF nbr 0.0.0.0, RPF-MFD
Outgoing interface list:
GigabitEthernet4/1, Forward/Sparse-Dense, 00:45:08/00:02:49, H
 
PE2# show mls ip multicast group 232.3.3.3
 
Multicast hardware switched flows:
(10.1.0.1, 232.3.3.3) Incoming interface: Gi4/1, Packets switched: 808
Hardware switched outgoing interfaces:
MVRF VPN-Red
RPF-MFD installed
 
 
(10.2.0.2, 232.3.3.3) Incoming interface: Lo0, Packets switched: 808
Hardware switched outgoing interfaces:
Gi4/1
RPF-MFD installed
 
Total hardware switched flows : 2

VPN-Red のレシーバのマルチキャスト グループ 228.8.8.8 への加入後の PE1 の VPN-Green の VRF テーブルにおける状態

次に、PE1 での show ip mroute コマンドの出力例を示します。サンプル出力は、レシーバがマルチキャスト グループ 228.8.8.8 に加入したときの PE1 の VPN-Green の VRF テーブルの状態を示しています。出力は、VPN-Red のエクストラネット レシーバがマルチキャスト グループ 228.8.8.8 に送信している VPN-Green のソースからコンテンツを受信していることを示しています。出力の「E」フラグは、VRF ルーティング テーブル内の (*, G) または (S, G) エントリがソース VRF エントリで、エクストラネット レシーバ MVRF mroute エントリがリンクされていることを示しています。

PE1# show ip mroute vrf VPN-Green 228.8.8.8
 
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group,
V - RD & Vector, v - Vector
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
 
(*, 228.8.8.8), 00:01:38/stopped, RP 10.100.0.5, flags: SE
Incoming interface: Ethernet3/0, RPF nbr 10.1.1.5
Outgoing interface list: Null
 
Extranet receivers in vrf VPN-Red:
(*, 228.8.8.8), 00:01:38/stopped, RP 10.100.0.5, OIF count: 1, flags: S
 
(10.1.1.200, 228.8.8.8), 00:00:05/00:02:54, flags: TE
Incoming interface: Ethernet3/0, RPF nbr 10.1.1.5
Outgoing interface list: Null
 
Extranet receivers in vrf VPN-Red:
(10.1.1.200, 228.8.8.8), 00:00:05/stopped, OIF count: 1, flags:

VPN-Red のレシーバのマルチキャスト グループ 228.8.8.8 への加入後の PE1 の VPN-Green の VRF テーブルにおける状態(PE1 が MVPN エクストラネット サポートに設定された Catalyst 6500 シリーズ スイッチの場合)

次に、PE1 がエクストラネット MVPN サービスをサポートするように設定された Catalyst 6500 シリーズ スイッチである場合の、PE1 での show ip mroute コマンドと show mls ip multicast コマンドの出力例を示します。 show ip mroute コマンドからのサンプル出力は、レシーバがマルチキャスト グループ 228.8.8.8 に加入したときの PE1 の VPN-Green の VRF テーブルの状態を示しています。 show mls ip multicast コマンドからのサンプル出力は、VPN-Red のレシーバがマルチキャスト グループ 228.8.8.8 に加入後の VPN-Green のグループ 228.8.8.8 に関連する MLS 情報を示しています。 show ip mroute コマンドおよび show mls ip multicast コマンドからのサンプル出力は、VPN-Red のエクストラネット レシーバがマルチキャスト グループ 228.8.8.8 に送信している VPN-Green のソースからコンテンツを受信していることを示しています。

PE1# show ip mroute vrf VPN-Green 228.8.8.8
 
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group,
V - RD & Vector, v - Vector
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
 
(*, 228.8.8.8), 00:01:38/stopped, RP 10.100.0.5, flags: SE
Incoming interface: GigabitEthernet3/1, RPF nbr 10.1.1.5, RPF-MFD
Outgoing interface list: Null
 
Extranet receivers in vrf VPN-Red:
(*, 228.8.8.8), 00:01:38/stopped, RP 10.100.0.5, OIF count: 1, flags: S
 
(10.1.1.200, 228.8.8.8), 00:00:05/00:02:54, flags: TE
Incoming interface: GigabitEthernet3/1, RPF nbr 10.1.1.5, RPF-MFD
Outgoing interface list: Null
 
Extranet receivers in vrf VPN-Red:
(10.1.1.200, 228.8.8.8), 00:00:05/stopped, OIF count: 1, flags:
 
PE1# show mls ip multicast vrf VPN-Green group 228.8.8.8
 
vrf VPN-Green tableid 1
Multicast hardware switched flows:
(*, 228.8.8.8) Incoming interface: Gi3/1, Packets switched: 4
Hardware switched outgoing interfaces:
Extranet VPN-Red
RPF-MFD installed
 
 
Extranet receivers in vrf VPN-Red(2):
(*, 228.8.8.8) Incoming interface: Gi3/1, Packets switched: 4
Hardware switched outgoing interfaces:
Tu2
RPF-MFD installed
 
 
(10.1.1.200, 228.8.8.8) Incoming interface: Gi3/1, Packets switched: 2179579
Hardware switched outgoing interfaces:
Extranet VPN-Red
RPF-MFD installed
 
 
Extranet receivers in vrf VPN-Red(2):
(10.1.1.200, 228.8.8.8) Incoming interface: Gi3/1, Packets switched: 2179579
Hardware switched outgoing interfaces:
Tu2
RPF-MFD installed
Total hardware switched flows : 4

VPN-Red のレシーバのマルチキャスト グループ 228.8.8.8 への加入後の PE1 の VPN-Red の VRF テーブルにおける状態

次に、PE1 での show ip mroute コマンドの出力例を示します。サンプル出力は、レシーバがマルチキャスト グループ 228.8.8.8 に加入したときの PE1 の VPN-Red の VRF テーブルの状態を示しています。using vrf VPN-Green フィールドは、ソースが到達可能な RPF インターフェイスを決定するために、VPN-Red が VPN-Green からのユニキャスト ルーティング情報を使用していることを示しています。

PE1# show ip mroute vrf VPN-Red 228.8.8.8
 
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group,
V - RD & Vector, v - Vector
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
 
(*, 228.8.8.8), 00:01:45/stopped, RP 10.100.0.5, flags: S
Incoming interface: Ethernet3/0, RPF nbr 10.1.1.5, using vrf VPN-Green
Outgoing interface list:
Tunnel2, Forward/Sparse-Dense, 00:01:45/00:02:49
 
(10.1.1.200, 228.8.8.8), 00:00:12/00:03:27, flags:
Incoming interface: Ethernet3/0, RPF nbr 10.1.1.5, using vrf VPN-Green
Outgoing interface list:
Tunnel2, Forward/Sparse-Dense, 00:00:12/00:03:18

VPN-Red のレシーバのマルチキャスト グループ 228.8.8.8 への加入後の PE1 の VPN-Red の VRF テーブルにおける状態(PE1 が MVPN エクストラネット サポートに設定された Catalyst 6500 シリーズ スイッチの場合)

次に、PE1 がエクストラネット MVPN サービスをサポートするように設定された Catalyst 6500 シリーズ スイッチである場合の、PE1 での show ip mroute コマンドと show mls ip multicast コマンドの出力例を示します。 show ip mroute コマンドからのサンプル出力は、レシーバがマルチキャスト グループ 228.8.8.8 に加入したときの PE1 の VPN-Red の VRF テーブルの状態を示しています。using vrf VPN-Green フィールドは、ソースが到達可能な RPF インターフェイスを決定するために、VPN-Red が VPN-Green からのユニキャスト ルーティング情報を使用していることを示しています。 show mls ip multicast からのサンプル出力は、VPN-Red のグループ 228.8.8.8 に関連する MLS 情報を示しています。

PE1# show ip mroute vrf VPN-Red 228.8.8.8
 
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group,
V - RD & Vector, v - Vector
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
 
(*, 228.8.8.8), 00:01:45/stopped, RP 10.100.0.5, flags: S
Incoming interface: GigabitEthernet3/1, RPF nbr 10.1.1.5, using vrf VPN-Green, RPF-MFD
Outgoing interface list:
Tunnel2, Forward/Sparse-Dense, 00:01:45/00:02:49, H
 
(10.1.1.200, 228.8.8.8), 00:00:12/00:03:27, flags:
Incoming interface: GigabitEthernet3/1, RPF nbr 10.1.1.5, using vrf VPN-Green, RPF-MFD
Outgoing interface list:
Tunnel2, Forward/Sparse-Dense, 00:00:12/00:03:18, H
 
PE1# show mls ip multicast vrf VPN-Red group 228.8.8.8
 
vrf VPN-Red tableid 2
Multicast hardware switched flows:
(*, 228.8.8.8) Incoming interface: Gi3/1, Packets switched: 4
Hardware switched outgoing interfaces:
Tu2
RPF-MFD installed
 
 
(10.1.1.200, 228.8.8.8) Incoming interface: Gi3/1, Packets switched: 2179579
Hardware switched outgoing interfaces:
Tu2
RPF-MFD installed
 
Total hardware switched flows : 2
PE1#

VPN-Red のレシーバのマルチキャスト グループ 228.8.8.8 への加入後の PE2 の VPN-Red の VRF テーブルにおける状態

次に、PE2 での show ip mroute コマンドの出力例を示します。サンプル出力は、レシーバがマルチキャスト グループ 228.8.8.8 に加入したときの PE2 の VPN-Red の VRF テーブルを示しています。

PE2# show ip mroute vrf VPN-Red 228.8.8.8
 
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group,
V - RD & Vector, v - Vector
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
 
(*, 228.8.8.8), 00:00:28/stopped, RP 10.100.0.5, flags: S
Incoming interface: Tunnel1, RPF nbr 10.1.0.1
Outgoing interface list:
Ethernet9/0, Forward/Sparse-Dense, 00:00:28/00:03:02
 
(10.1.1.200, 228.8.8.8), 00:00:00/00:03:29, flags:
Incoming interface: Tunnel1, RPF nbr 10.1.0.1
Outgoing interface list:
Ethernet9/0, Forward/Sparse-Dense, 00:00:00/00:03:29

VPN-Red のレシーバのマルチキャスト グループ 228.8.8.8 への加入後の PE2 の VPN-Red の VRF テーブルにおける状態(PE2 が MVPN エクストラネット サポートに設定された Catalyst 6500 シリーズ スイッチの場合)

次に、PE2 がエクストラネット MVPN サービスをサポートするように設定された Catalyst 6500 シリーズ スイッチである場合の、PE2 での show ip mroute コマンドと show mls ip multicast コマンドの出力例を示します。 show ip mroute コマンドからのサンプル出力は、レシーバがマルチキャスト グループ 228.8.8.8 に加入したときの PE2 の VPN-Red の VRF テーブルを示しています。 show mls ip multicast コマンドからのサンプル出力は、VPN-Red のグループ 228.8.8.8 に関連する MLS 情報を示しています。

PE2# show ip mroute vrf VPN-Red 228.8.8.8
 
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group,
V - RD & Vector, v - Vector
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
 
(*, 228.8.8.8), 00:00:28/stopped, RP 10.100.0.5, flags: S
Incoming interface: Tunnel1, RPF nbr 10.1.0.1, RPF-MFD
Outgoing interface list:
GigabitEthernet9/1, Forward/Sparse-Dense, 00:00:28/00:03:02, H
 
(10.1.1.200, 228.8.8.8), 00:00:00/00:03:29, flags:
Incoming interface: Tunnel1, RPF nbr 10.1.0.1, RPF-MFD
Outgoing interface list:
GigabitEthernet9/1, Forward/Sparse-Dense, 00:00:00/00:03:29, H
 
PE2# show mls ip multicast vrf VPN-Red group 228.8.8.8
 
vrf VPN-Red tableid 2
Multicast hardware switched flows:
(*, 228.8.8.8) Incoming interface: Tu1, Packets switched: 4
Hardware switched outgoing interfaces:
Gi9/1
RPF-MFD installed
 
 
(10.1.1.200, 228.8.8.8) Incoming interface: Tu1, Packets switched: 2179579
Hardware switched outgoing interfaces:
Gi9/1
RPF-MFD installed
 
Total hardware switched flows : 2

例:レシーバ PE でのソース VRF の設定(オプション 2)

次の設定例は、図 8に示すエクストラネット MVPN トポロジに基づいています。この例は、PE2(レシーバ PE ルータ)と PE1(ソース PE ルータ)の設定を示します。この例では、エクストラネット MVPN サービスは、PE2 の VPN-Green にソース MVRF を設定することによって、VPN-Green と VPN-Red の間でサポートされます。同じユニキャスト ルーティング ポリシーは、VPN-Green から VPN-Red へのルートをインポートするように設定されます。

図 8 MVPN エクストラネット サポート オプション 2 設定例のトポロジ

 

PE2 の設定

ip cef
!
ip vrf VPN-Red
rd 55:2222
route-target export 55:2222
route-target import 55:2222
route-target import 55:1111
mdt default 232.3.3.3
!
ip vrf VPN-Green
rd 55:1111
route-target export 55:1111
route-target import 55:1111
mdt default 232.1.1.1
!
ip multicast-routing
ip multicast-routing vrf VPN-Red
ip multicast-routing vrf VPN-Green
!
interface Loopback0
ip address 10.2.0.2 255.255.255.0
ip pim sparse-dense-mode
!
.
.
.
!
router bgp 55
no synchronization
bgp log-neighbor-changes
neighbor 10.1.0.1 remote-as 55
neighbor 10.1.0.1 update-source Loopback0
!
address-family ipv4 mdt
neighbor 10.1.0.1 activate
neighbor 10.1.0.1 send-community extended
!
address-family vpnv4
neighbor 10.1.0.1 activate
neighbor 10.1.0.1 send-community extended
!

PE1 の設定

ip cef
!
ip vrf VPN-Green
rd 55:1111
route-target export 55:1111
route-target import 55:1111
mdt default 232.1.1.1
!
ip multicast-routing
ip multicast-routing vrf VPN-Green
!
interface Loopback0
ip address 10.1.0.1 255.255.255.0
ip pim sparse-dense-mode
!
.
.
.
!
router bgp 55
no synchronization
bgp log-neighbor-changes
neighbor 10.2.0.2 remote-as 55
neighbor 10.2.0.2 update-source Loopback0
!
address-family ipv4 mdt
neighbor 10.2.0.2 activate
neighbor 10.2.0.2 send-community extended
!
address-family vpnv4
neighbor 10.2.0.2 activate
neighbor 10.2.0.2 send-community extended
!

MDT デフォルト グループ 232.1.1.1 の PE1 および PE2 のグローバル テーブルでの状態

次に、PE1 と PE2 での show ip mroute コマンドの出力例を示します。サンプル出力は、PE1 と PE2 での MDT デフォルト グループ 232.1.1.1 のグローバル テーブルを示しています。

PE1# show ip mroute 232.1.1.1
 
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group,
V - RD & Vector, v - Vector
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
 
(10.2.0.2, 232.1.1.1), 00:01:19/00:02:42, flags: sTIZ
Incoming interface: Ethernet0/0, RPF nbr 10.0.1.4
Outgoing interface list:
MVRF VPN-Green, Forward/Sparse-Dense, 00:01:19/00:02:07
 
(10.1.0.1, 232.1.1.1), 00:02:19/00:03:11, flags: sT
Incoming interface: Loopback0, RPF nbr 0.0.0.0
Outgoing interface list:
Ethernet0/0, Forward/Sparse-Dense, 00:02:00/00:02:36
 
PE2# show ip mroute 232.1.1.1
 
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group,
V - RD & Vector, v - Vector
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
 
(10.1.0.1, 232.1.1.1), 00:02:04/00:02:38, flags: sTIZ
Incoming interface: Ethernet1/0, RPF nbr 10.0.2.4
Outgoing interface list:
MVRF VPN-Green, Forward/Sparse-Dense, 00:02:04/00:02:09
 
(10.2.0.2, 232.1.1.1), 00:02:04/00:03:09, flags: sT
Incoming interface: Loopback0, RPF nbr 0.0.0.0
Outgoing interface list:
Ethernet1/0, Forward/Sparse-Dense, 00:01:22/00:03:09

PE1 と PE2 が MVPN エクストラネット サポートの設定された Catalyst 6500 シリーズ スイッチである場合の MDT デフォルト グループ 232.1.1.1 の PE1 および PE2 のグローバル テーブルでの状態

次に、PE1 と PE2 がエクストラネット MVPN サービスをサポートするように設定された Catalyst 6500 シリーズ スイッチである場合の、PE1 と PE2 での show ip mroute コマンドと show mls ip multicast コマンドの出力例を示します。 show ip mroute コマンドからのサンプル出力は、PE1 と PE2 における MDT デフォルト グループ 232.1.1.1 のグローバル テーブルを示しています。この出力で、「RPF-MFD」フラグはマルチキャスト フローが完全にハードウェアでスイッチングされることを示し、「H」フラグはフローが発信インターフェイスのハードウェアでスイッチングされることを示しています。 show mls ip multicast コマンドからのサンプル出力は、PE1 と PE2 のマルチキャスト グループ 232.1.1.1 に関する MLS 情報を示しています。

PE1# show ip mroute 232.1.1.1
 
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group,
V - RD & Vector, v - Vector
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
 
(10.2.0.2, 232.1.1.1), 00:01:19/00:02:42, flags: sTIZ
Incoming interface: GigabitEthernet2/16, RPF nbr 10.0.1.4, RPF-MFD
Outgoing interface list:
MVRF VPN-Green, Forward/Sparse-Dense, 00:01:19/00:02:07, H
 
(10.1.0.1, 232.1.1.1), 00:02:19/00:03:11, flags: sT
Incoming interface: Loopback0, RPF nbr 0.0.0.0, RPF-MFD
Outgoing interface list:
GigabitEthernet2/16, Forward/Sparse-Dense, 00:02:00/00:02:36, H
 
PE1# show mls ip multicast group 232.1.1.1
 
Multicast hardware switched flows:
(10.2.0.2, 232.1.1.1) Incoming interface: Gi2/16, Packets switched: 28
Hardware switched outgoing interfaces:
MVRF VPN-Green
RPF-MFD installed
 
 
(10.1.0.1, 232.1.1.1) Incoming interface: Lo0, Packets switched: 28
Hardware switched outgoing interfaces:
Gi2/16
RPF-MFD installed
 
Total hardware switched flows : 2
 
PE2# show ip mroute 232.1.1.1
 
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group,
V - RD & Vector, v - Vector
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
 
(10.1.0.1, 232.1.1.1), 00:02:04/00:02:38, flags: sTIZ
Incoming interface: GigabitEthernet4/1, RPF nbr 10.0.2.4, RPF-MFD
Outgoing interface list:
MVRF VPN-Green, Forward/Sparse-Dense, 00:02:04/00:02:09, H
 
(10.2.0.2, 232.1.1.1), 00:02:04/00:03:09, flags: sT
Incoming interface: Loopback0, RPF nbr 0.0.0.0, RPF-MFD
Outgoing interface list:
GigabitEthernet4/1, Forward/Sparse-Dense, 00:01:22/00:03:09, H
 
PE2# show mls ip multicast group 232.1.1.1
Multicast hardware switched flows:
(10.1.0.1, 232.1.1.1) Incoming interface: Gi4/1, Packets switched: 28
Hardware switched outgoing interfaces:
MVRF VPN-Green
RPF-MFD installed
 
 
(10.2.0.2, 232.1.1.1) Incoming interface: Lo0, Packets switched: 28
Hardware switched outgoing interfaces:
Gi4/1
RPF-MFD installed
 
Total hardware switched flows : 2

VPN-Red のレシーバのマルチキャスト グループ 228.8.8.8 への加入後の PE1 の VPN-Green の VRF テーブルにおける状態

次に、PE1 での show ip mroute コマンドの出力例を示します。サンプル出力は、レシーバがマルチキャスト グループ 228.8.8.8 に加入したときの PE1 の VPN-Green の VRF テーブルの状態を示しています。

PE1# show ip mroute vrf VPN-Green 228.8.8.8
 
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group,
V - RD & Vector, v - Vector
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
 
(*, 228.8.8.8), 00:01:43/00:02:52, RP 10.100.0.5, flags: S
Incoming interface: Ethernet3/0, RPF nbr 10.1.1.5
Outgoing interface list:
Tunnel0, Forward/Sparse-Dense, 00:01:43/00:02:52
 
(10.1.1.200, 228.8.8.8), 00:01:15/00:03:26, flags: T
Incoming interface: Ethernet3/0, RPF nbr 10.1.1.5
Outgoing interface list:
Tunnel0, Forward/Sparse-Dense, 00:01:15/00:03:19

VPN-Red のレシーバのマルチキャスト グループ 228.8.8.8 への加入後の PE1 の VPN-Green の VRF テーブルにおける状態(PE1 が MVPN エクストラネット サポートに設定された Catalyst 6500 シリーズ スイッチの場合)

次に、PE1 がエクストラネット MVPN サービスをサポートするように設定された Catalyst 6500 シリーズ スイッチである場合の、PE1 での show ip mroute コマンドと show mls ip multicast コマンドの出力例を示します。 show ip mroute コマンドからのサンプル出力は、レシーバがマルチキャスト グループ 228.8.8.8 に加入したときの PE1 の VPN-Green の VRF テーブルの状態を示しています。 show mls ip multicast コマンドからのサンプル出力は、VPN-Red のマルチキャスト グループ 228.8.8.8 に関連する MLS 情報を示しています。

PE1# show ip mroute vrf VPN-Green 228.8.8.8
 
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group,
V - RD & Vector, v - Vector
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
 
(*, 228.8.8.8), 00:01:43/00:02:52, RP 10.100.0.5, flags: S
Incoming interface: GigabitEthernet3/1, RPF nbr 10.1.1.5, RPF-MFD
Outgoing interface list:
Tunnel0, Forward/Sparse-Dense, 00:01:43/00:02:52, H
 
(10.1.1.200, 228.8.8.8), 00:01:15/00:03:26, flags: T
Incoming interface: GigabitEthernet3/1, RPF nbr 10.1.1.5, RPF-MFD
Outgoing interface list:
Tunnel0, Forward/Sparse-Dense, 00:01:15/00:03:19, H
 
PE1# show mls ip multicast vrf VPN-Green group 228.8.8.8
 
vrf VPN-Red tableid 1
Multicast hardware switched flows:
(*, 228.8.8.8) Incoming interface: Gi3/1, Packets switched: 4
Hardware switched outgoing interfaces:
Tu0
RPF-MFD installed
 
 
(10.1.1.200, 228.8.8.8) Incoming interface: Gi3/1, Packets switched: 2179579
Hardware switched outgoing interfaces:
Tu0
RPF-MFD installed
 
Total hardware switched flows : 2

VPN-Red のレシーバのマルチキャスト グループ 228.8.8.8 への加入後の PE2 の VPN-Green の VRF テーブルにおける状態

次に、PE2 での show ip mroute コマンドの出力例を示します。出力は、レシーバがマルチキャスト グループ 228.8.8.8 に加入したときの PE1 の VPN-Green の VRF テーブルの状態を示しています。出力は、VPN-Red のエクストラネット レシーバがマルチキャスト グループ 228.8.8.8 に送信している VPN-Green のソースからコンテンツを受信していることを示しています。「E」フラグは、VRF ルーティング テーブル内の (*, G) または (S, G) エントリがソース VRF エントリで、エクストラネット レシーバ MVRF mroute エントリがリンクされていることを示しています。

PE2# show ip mroute vrf VPN-Green 228.8.8.8
 
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group,
V - RD & Vector, v - Vector
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
 
(*, 228.8.8.8), 00:01:59/stopped, RP 10.100.0.5, flags: SE
Incoming interface: Tunnel0, RPF nbr 10.1.0.1
Outgoing interface list: Null
 
Extranet receivers in vrf VPN-Red:
(*, 228.8.8.8), 00:01:59/stopped, RP 10.100.0.5, OIF count: 1, flags: S
 
(10.1.1.200, 228.8.8.8), 00:01:31/00:02:59, flags: TE
Incoming interface: Tunnel0, RPF nbr 10.1.0.1
Outgoing interface list: Null
 
Extranet receivers in vrf VPN-Red:
(10.1.1.200, 228.8.8.8), 00:01:31/00:03:29, OIF count: 1, flags:

VPN-Red のレシーバのマルチキャスト グループ 228.8.8.8 への加入後の PE2 の VPN-Green の VRF テーブルにおける状態(PE2 が MVPN エクストラネット サポートに設定された Catalyst 6500 シリーズ スイッチの場合)

次に、PE2 がエクストラネット MVPN サービスをサポートするように設定された Catalyst 6500 シリーズ スイッチである場合の、PE2 での show ip mroute コマンドと show mls ip multicast コマンドの出力例を示します。 show ip mroute コマンドからのサンプル出力は、レシーバがマルチキャスト グループ 228.8.8.8 に加入したときの PE1 の VPN-Green の VRF テーブルの状態を示しています。サンプル出力は、VPN-Red のエクストラネット レシーバがマルチキャスト グループ 228.8.8.8 に送信している VPN-Green のソースからコンテンツを受信していることを示しています。「E」フラグは、VRF ルーティング テーブル内の (*, G) または (S, G) エントリがソース VRF エントリで、エクストラネット レシーバ MVRF mroute エントリがリンクされていることを示しています。 show mls ip multicast コマンドからのサンプル出力は、VPN-Green のマルチキャスト グループ 228.8.8.8 に関連する MLS 情報を示しています。

PE2# show ip mroute vrf VPN-Green 228.8.8.8
 
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group,
V - RD & Vector, v - Vector
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
 
(*, 228.8.8.8), 00:01:59/stopped, RP 10.100.0.5, flags: SE
Incoming interface: Tunnel0, RPF nbr 10.1.0.1, RPF-MFD
Outgoing interface list: Null
 
Extranet receivers in vrf VPN-Red:
(*, 228.8.8.8), 00:01:59/stopped, RP 10.100.0.5, OIF count: 1, flags: S
 
(10.1.1.200, 228.8.8.8), 00:01:31/00:02:59, flags: TE
Incoming interface: Tunnel0, RPF nbr 10.1.0.1, RPF-MFD
Outgoing interface list: Null
 
Extranet receivers in vrf VPN-Red:
(10.1.1.200, 228.8.8.8), 00:01:31/00:03:29, OIF count: 1, flags:
 
PE2# show mls ip multicast vrf VPN-Green group 228.8.8.8
 
vrf VPN-Green tableid 1
Multicast hardware switched flows:
(*, 228.8.8.8) Incoming interface: Tu0, Packets switched: 4
Hardware switched outgoing interfaces:
Extranet VPN-Red
RPF-MFD installed
 
 
Extranet receivers in vrf VPN-Red(2):
(*, 228.8.8.8) Incoming interface: Tu0, Packets switched: 4
Hardware switched outgoing interfaces:
Gi9/1
RPF-MFD installed
 
 
(10.1.1.200, 228.8.8.8) Incoming interface: Tu0, Packets switched: 2179579
Hardware switched outgoing interfaces:
Extranet VPN-Red
RPF-MFD installed
 
 
Extranet receivers in vrf VPN-Red(2):
(10.1.1.200, 228.8.8.8) Incoming interface: Tu0, Packets switched: 2179579
Hardware switched outgoing interfaces:
Gi9/1
RPF-MFD installed
Total hardware switched flows : 4

VPN-Red のレシーバのマルチキャスト グループ 228.8.8.8 への加入後の PE2 の VPN-Red の VRF テーブルにおける状態

次に、PE2 での show ip mroute コマンドの出力例を示します。サンプル出力は、レシーバがマルチキャスト グループ 228.8.8.8 に加入したときの PE2 の VPN-Red の VRF テーブルの状態を示しています。using vrf VPN-Green フィールドは、ソースが到達可能な RPF インターフェイスを決定するために、VPN-Red が VPN-Green からのユニキャスト ルーティング情報を使用していることを示しています。

PE2# show ip mroute vrf VPN-Red 228.8.8.8
 
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group,
V - RD & Vector, v - Vector
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
 
(*, 228.8.8.8), 00:02:00/stopped, RP 10.100.0.5, flags: S
Incoming interface: Tunnel0, RPF nbr 10.1.0.1, using vrf VPN-Green
Outgoing interface list:
Ethernet9/0, Forward/Sparse-Dense, 00:02:00/00:02:34
 
(10.1.1.200, 228.8.8.8), 00:01:32/00:03:28, flags:
Incoming interface: Tunnel0, RPF nbr 10.1.0.1, using vrf VPN-Green
Outgoing interface list:
Ethernet9/0, Forward/Sparse-Dense, 00:01:32/00:03:01

VPN-Red のレシーバのマルチキャスト グループ 228.8.8.8 への加入後の PE2 の VPN-Red の VRF テーブルにおける状態(PE2 が MVPN エクストラネット サポートに設定された Catalyst 6500 シリーズ スイッチの場合)

次に、PE2 がエクストラネット MVPN サービスをサポートするように設定された Catalyst 6500 シリーズ スイッチである場合の、PE2 での show ip mroute コマンドと show mls ip multicast コマンドの出力例を示します。 show ip mroute コマンドからのサンプル出力は、レシーバがマルチキャスト グループ 228.8.8.8 に加入したときの PE2 の VPN-Red の VRF テーブルの状態を示しています。using vrf VPN-Green フィールドは、ソースが到達可能な RPF インターフェイスを決定するために、VPN-Red が VPN-Green からのユニキャスト ルーティング情報を使用していることを示しています。 show mls ip multicast コマンドからのサンプル出力は、VPN-Red のマルチキャスト グループ 228.8.8.8 に関連する MLS 情報を示しています。

PE2# show ip mroute vrf VPN-Red 228.8.8.8
 
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group,
V - RD & Vector, v - Vector
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
 
(*, 228.8.8.8), 00:02:00/stopped, RP 10.100.0.5, flags: S
Incoming interface: Tunnel0, RPF nbr 10.1.0.1, using vrf VPN-Green, RPF-MFD
Outgoing interface list:
GigabitEthernet9/1, Forward/Sparse-Dense, 00:02:00/00:02:34, H
 
(10.1.1.200, 228.8.8.8), 00:01:32/00:03:28, flags:
Incoming interface: Tunnel0, RPF nbr 10.1.0.1, using vrf VPN-Green, RPF-MFD
Outgoing interface list:
GigabitEthernet9/1, Forward/Sparse-Dense, 00:01:32/00:03:01, H
 
PE2# show mls ip multicast vrf VPN-Red group 228.8.8.8
 
vrf VPN-Red tableid 2
Multicast hardware switched flows:
(*, 228.8.8.8) Incoming interface: Tu0, Packets switched: 4
Hardware switched outgoing interfaces:
Gi9/1
RPF-MFD installed
 
 
(10.1.1.200, 228.8.8.8) Incoming interface: Tu0, Packets switched: 2179579
Hardware switched outgoing interfaces:
Gi9/1
RPF-MFD installed
 
Total hardware switched flows : 2

例:スタティック mroute を使用した MVPN エクストラネット サポートの RPF の設定

次の例は、スタティック mroute 192.168.1.1 を使用して、VPN-Red で発生する RPF ルックアップが VPN-Green で解決されるように設定する方法を示します。

ip mroute vrf VPN-Red 192.168.1.1 255.255.255.255 fallback-lookup vrf VPN-Green

例:MVPN エクストラネット サポートがあるグループベースの VRF 選択ポリシーの設定

次の例は、グループベースの VRF 選択ポリシーを使用して、VPN-Green で発生する RPF ルックアップが ACL 1 と一致するグループ アドレスの VPN-Red で行われ、ACL 2 と一致するグループ アドレスの VPN-Blue で行われるように設定する方法を示します。

ip multicast vrf VPN-Green rpf select vrf VPN-Red group-list 1
ip multicast vrf VPN-Green rpf select vrf VPN-Blue group-list 2
!
.
.
.
!
access-list 1 permit 239.0.0.0 0.255.255.255
access-list 2 permit 238.0.0.0 0.255.255.255
!

その他の参考資料

関連資料

関連項目
参照先

基本的な IP マルチキャストの概念、設定作業、および例

Configuring Basic IP Multicast 』モジュール

IP マルチキャストの概要

IP Multicast Technology Overview 』モジュール

MPLS レイヤ 3 VPN の概念および設定作業

Configuring MPLS Layer 3 VPNs 』モジュール

マルチキャスト VPN の概念、設定作業、および例

Configuring Multicast VPN 』モジュール

Catalyst 6500 シリーズ マルチキャスト VPN の概念、設定作業、および例

Catalyst 6500 Release 12.2SX Software Configuration Guide 』の「 Configuring IPv4 Multicast VPN Support 」の章

IP マルチキャスト コマンド:コマンド構文の詳細、コマンド モード、コマンド履歴、コマンド デフォルト設定、使用に関する注意事項、および例

『Cisco IOS IP Multicast Command Reference』

MPLS コマンド:コマンド構文の詳細、コマンド モード、コマンド履歴、コマンド デフォルト設定、使用に関する注意事項、および例

『Cisco IOS Multiprotocol Label Switching Command Reference』

Cisco 7600 シリーズ ルータにおける Multicast Virtual Private Network(MVPN; マルチキャスト バーチャル プライベート ネットワーク)エクストラネットのサポート、設定の詳細、制約事項、および使用上のガイドライン

Cisco 7600 Series Router Software Configuration Guide』 の「 Configuring Multicast VPN Extranet Support 」の章

規格

規格
タイトル

この機能がサポートする新しい規格または変更された規格はありません。また、この機能で変更された既存規格のサポートはありません。

--

MIB

MIB
MIB リンク

この機能がサポートする新しい MIB または変更された MIB はありません。また、この機能で変更された既存 MIB のサポートはありません。

選択したプラットフォーム、Cisco ソフトウェア リリース、および機能セットの MIB の場所を検索しダウンロードするには、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFC

RFC
タイトル

この機能がサポートする新しい RFC または変更された RFC はありません。また、この機能で変更された既存 RFC のサポートはありません。

--

シスコのテクニカル サポート

説明
リンク

右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。

以下を含むさまざまな作業にこの Web サイトが役立ちます。
・テクニカル サポートを受ける
・ソフトウェアをダウンロードする
・セキュリティの脆弱性を報告する、またはシスコ製品のセキュリティ問題に対する支援を受ける
・ツールおよびリソースへアクセスする
- Product Alert の受信登録
- Field Notice の受信登録
- Bug Toolkit を使用した既知の問題の検索
・Networking Professionals(NetPro)コミュニティで、技術関連のディスカッションに参加する
・トレーニング リソースへアクセスする
・TAC Case Collection ツールを使用して、ハードウェアや設定、パフォーマンスに関する一般的な問題をインタラクティブに特定および解決する

この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

http://www.cisco.com/cisco/web/support/index.html

マルチキャスト VPN エクストラネット サポートの設定に関する機能情報

表 1 に、このモジュールで説明した機能をリストし、特定の設定情報へのリンクを示します。

ここに記載されていないこのテクノロジーの機能情報については、『 IP Multicast Features Roadmap 』を参照してください。

Cisco Feature Navigator を使用すると、プラットフォームおよびソフトウェア イメージのサポート情報を検索できます。Cisco Feature Navigator を使用すると、ソフトウェア イメージがサポートする特定のソフトウェア リリース、機能セット、またはプラットフォームを確認できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。


表 1 には、一連のソフトウェア リリースのうち、特定の機能が初めて導入されたソフトウェア リリースだけが記載されています。特に明記されていない限り、Cisco IOS ソフトウェア リリース群の後続のリリースでもこの機能をサポートします。


 

表 1 マルチキャスト VPN エクストラネット サポートの設定に関する機能情報

機能名
リリース
機能情報

マルチキャスト VPN エクストラネット サポート

12.2(31)SB2
12.2(33)SXH
12.2(33)SRC
15.0(1)M
15.0(1)S

マルチキャスト VPN エクストラネット サポート機能は、ある企業サイトから他の企業サイトに送信された IP マルチキャスト コンテンツをサービス プロバイダーが配信できるようにします。この機能により、サービス プロバイダーは、次世代の柔軟なエクストラネット サービスを提供でき、異なるエンタープライズ VPN カスタマー間でのビジネス パートナーシップの実現を支援します。

15.0(1)S では、この機能が Cisco 7600 シリーズ ルータに導入されました。

この機能に関する詳細については、次の各項を参照してください。

「MVPN エクストラネット サポートの概要」

「MVPN エクストラネット サポートの設定ガイドライン」

「MVPN エクストラネット サポートの設定」

「スタティック mroute を使用した MVPN エクストラネット サポートの RPF の設定」

「例:ソース PE ルータでのレシーバ VRF の設定(オプション 1)」

「例:レシーバ PE でのソース VRF の設定(オプション 2)」

この機能により、 ip mroute および show ip mroute コマンドが導入または変更されました。

マルチキャスト VPN エクストラネット VRF の選択

12.2(31)SB2
15.0(1)M

マルチキャスト VPN エクストラネット VRF の選択機能は、VRF セレクタとしてグループ アドレスを使用して、異なる VRF で同じソース アドレスに対して RPF ルックアップを実行するための機能を提供します。この機能は、異なる MVPN から入ってきたコンテンツ ストリームをサービス プロバイダーが再配布できるようにすることによってエクストラネット MVPN を強化します。

この機能に関する詳細については、次の各項を参照してください。

「MVPN エクストラネット サポートがあるグループベースの VRF 選択ポリシーの設定」

「例:MVPN エクストラネット サポートがあるグループベースの VRF 選択ポリシーの設定」

この機能により、 ip multicast rpf select show ip rpf show ip rpf select の各コマンドが導入または変更されました。

マルチキャスト VPN エクストラネット サポート用ハードウェア アクセラレーション

12.2(33)SXH

マルチキャスト VPN エクストラネット サポート用ハードウェア アクセラレーション機能は、Catalyst 6500 シリーズ スイッチ上のエクストラネット MVPN サービス用ハードウェアに転送エントリのリンクとパケットの複製を導入します。

12.2(33)SXH では、この機能が Catalyst 6500 シリーズ スイッチに導入されました。

この機能に関する詳細については、次の各項を参照してください。

「Catalyst 6500 シリーズ スイッチでのマルチキャスト VPN エクストラネット サポートのハードウェア アクセラレーション」

「MVPN エクストラネット サポートの設定」