IP マルチキャスト コンフィギュレーション ガイド、 Cisco IOS Release 15.1S
IGMP のカスタマイズ
IGMP のカスタマイズ
発行日;2012/02/05 | 英語版ドキュメント(2011/04/17 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 8MB) | フィードバック

目次

IGMP のカスタマイズ

機能情報の入手方法

この章の構成

IGMP のカスタマイズの前提条件

IGMP のカスタマイズの制約事項

IGMP のカスタマイズに関する情報

インターネット グループ管理プロトコル(IGMP)の役割

IGMP バージョンの相違

IGMP 加入の処理

IGMP の脱退処理

IGMP マルチキャスト アドレス

IGMP のカスタマイズ方法

直接接続の IGMP ホストがない場合に、マルチキャスト トラフィックが転送されるようにルータを設定する方法

IGMPv3 ホスト スタックのイネーブル化

IGMPv3 ホスト スタック

前提条件

制約事項

IGMPv3 のホスト、グループ、およびチャネルの明示的なトラッキングの設定

IGMPv3 のホスト、グループ、およびチャネルの明示的なトラッキングの利点

制約事項

IGMP 拡張アクセス リストを使用した SSM ネットワークへのアクセスの制御

IPv4 で SSM がサポートされる拡張アクセス リストの利点

IGMP で拡張アクセス リストをチェックする方法

IGMP プロキシの設定

前提条件

IGMP UDLR に対するアップストリーム UDL ルータの設定

IGMP プロキシ サポート付きの IGMP UDLR に対するダウンストリーム UDL ルータの設定

IGMP のカスタマイズ設定例

例:直接接続の IGMP ホストがない場合に、マルチキャスト トラフィックが転送されるようにルータを設定する方法

例:IGMPv3 ホスト スタックのイネーブル化

例:IGMPv3 の設定 - ホスト、グループ、およびチャネルの明示的なトラッキング

例:IGMP 拡張アクセス リストを使用した SSM ネットワークへのアクセスの制御

例:グループ G のすべての状態を拒否

例:ソース S のすべての状態を拒否

例:グループ G のすべての状態を許可

例:ソース S のすべての状態を許可

例:グループ G でソース S をフィルタリング

例:IGMP プロキシの設定

その他の参考資料

関連資料

規格

MIB

RFC

シスコのテクニカル サポート

IGMP のカスタマイズの機能情報

IGMP のカスタマイズ

Internet Group Management Protocol(IGMP; インターネット グループ管理プロトコル)は、特定の LAN セグメント上でマルチキャスト グループに個々のホストを動的に登録する場合に使用されます。インターフェイス上で Protocol Independent Multicast(PIM)をイネーブルにした場合でも、そのインターフェイス上で IGMP の動作がイネーブルにされます。

このモジュールでは、次の方法を含む、IGMP をカスタマイズする方法について説明します。

直接接続の IGMP ホストがない場合に、マルチキャスト トラフィックが転送されるようにルータを設定する方法。

マルチキャスト ネットワーク エンドポイントまたはホストとしてルータが動作できるように、IGMP バージョン 3(IGMPv3)ホスト スタックをイネーブルにする方法。

ルータによって、IGMPv3 環境で特定のグループまたはチャネルに加入している個々のホストそれぞれを追跡できるようにする方法。

IGMP 拡張アクセス リストを使用して SSM ネットワークへのアクセスを制御する方法。

ダウンストリーム ルータに直接接続されていないホストが、アップストリーム ネットワークがソースのマルチキャスト グループに加入できるようにするために、IGMP プロキシを設定する方法。

機能情報の入手方法

ご使用のソフトウェア リリースで、このモジュールで説明されるすべての機能がサポートされているとは限りません。最新の機能情報および警告については、ご使用のプラットフォームおよびソフトウェア リリースのリリースノートを参照してください。このモジュールに記載されている機能に関する情報を検索したり、各機能がサポートされているリリースに関するリストを参照したりするには、「IGMP のカスタマイズの機能情報」を参照してください。

Cisco Feature Navigator を使用すると、プラットフォームおよび Cisco ソフトウェア イメージのサポート情報を検索できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。

IGMP のカスタマイズの前提条件

このモジュールの作業を実行する前に、『 IP Multicast Technology Overview 』モジュールで説明している概念をよく理解しておく必要があります。

このモジュールの作業では、IP マルチキャストがイネーブルに設定され、『 Configuring Basic IP Multicast 』モジュールで説明されている作業を使用して、Protocol Independent Multicast(PIM)インターフェイスが設定されていることを前提とします。

IGMP のカスタマイズの制約事項

SSM モードで設定されていないマルチキャスト グループでのトラフィック フィルタリング

Source Specific Multicast(SSM)モードで設定されていないマルチキャスト グループに対するトラフィックをフィルタリングまたは制限する場合に、Cisco IOS ソフトウェアでは IGMPv3 メンバシップは使用されません。実際には、Cisco IOS ソフトウェアにより、デンス モード、スパース モード、または双方向モードで設定されているグループに対するすべての IGMPv3 メンバシップ レポートが、グループ メンバシップ レポートに解釈され、すべてのアクティブなソースからのトラフィックがネットワークに転送されます。

IGMP スヌーピングとの相互運用性

IGMPv3 メッセージは、IGMP バージョン 1(IGMPv1)およびバージョン 2(IGMPv2)で使用されているメッセージと異なるため、IGMP スヌーピングがサポートされ、IGMP スヌーピングでイネーブルにされているスイッチで IGMPv3 を使用するときには、注意が必要です。IGMPv3 メッセージがスイッチで認識されない場合、IGMPv3 が使用されているときに、ホストではトラフィックが正しく受信されません。この場合は、スイッチ上で IGMP スヌーピングがディセーブルにされているか、または、ルータではインターフェイス上で IGMPv2 に対する設定が行われています。これによって、URL Rendezvous Directory(URD)または IGMP v3lite を使用できないホスト アプリケーションに対して、SSM を使用する機能が削除されます。

CGMP との相互運用性

Cisco Group Management Protocol(CGMP)を使用しているネットワークでは、IGMPv3 で設定されている場合よりも、IGMPv2 で設定されている場合に、より優れたグループ脱退動作が使用されます。IGMPv2 で CGMP が使用され、CGMP 脱退機能でスイッチがイネーブルの場合、マルチキャスト グループに加入しているポートへのトラフィックは、そのポート上の最後のメンバがそのグループに対するメンバシップを廃棄した直後に、ポートから削除されます。この高速脱退メカニズムは、IGMPv2 の一部で、特に CGMP 高速脱退対応スイッチによってサポートされます。

IGMPv3 では、現在、高速脱退をサポートしている CGMP スイッチはありません。IGMPv3 がネットワークで使用される場合、CGMP は動作し続けますが、CGMP 高速脱退サポートは無効で、次の条件が適用されます。

CGMP スイッチの新しいポート上にあるホストがマルチキャスト グループに参加するたびに、そのポートは、このグループのトラフィックが送信される宛先のポートのリストに追加されます。

特定のポート上のすべてのホストがマルチキャスト グループを脱退したが、グループに参加している(同じ仮想 LAN にある)他のポート上にホストがまだある場合は、何も起こりません。つまり、ポートでは、そのマルチキャスト グループからトラフィックを受信し続けます。

仮想 LAN(VLAN)にある最後のホストからマルチキャスト グループを脱退するときにのみ、このグループのトラフィックの VLAN への転送は、転送スイッチのどのポートにも戻りません。

この加入動作は、IGMPv3 モードで実際動作しているマルチキャスト グループにのみ適用されます。IGMPv2 のみをサポートしているレガシー ホストがネットワークにある場合、グループは IGMPv2 に戻され、これらのグループに対して高速脱退が動作します。

CGMP 対応スイッチで高速脱退が必要な場合、IGMPv3 をイネーブルにせず、そのインターフェイス上で IGMPv2 を設定することを、推奨します。

SSM を使用する場合には、IGMPv3 が必要で、次の 2 つの設定方法があります。

IGMPv2 のインターフェイスのみを設定し、IGMP v3lite および URD を使用する。

IGMPv3 をイネーブルにし、CGMP スイッチを介してより高度な脱退遅延を受け入れる。

IGMP のカスタマイズに関する情報

「インターネット グループ管理プロトコル(IGMP)の役割」

「IGMP バージョンの相違」

「IGMP 加入の処理」

「IGMP の脱退処理」

「IGMP マルチキャスト アドレス」

インターネット グループ管理プロトコル(IGMP)の役割

IGMP は、特定の LAN 上のマルチキャスト グループに個々のホストを動的に登録する場合に使用されます。インターフェイス上で PIM をイネーブルにすると、IGMP もイネーブルにされます。IGMP によって、特殊なマルチキャスト クエリアおよびホストが使用されるネットワークを介して、マルチキャスト トラフィックを自動的に制御し、制限する機能が提供されます。

クエリアは、どのネットワーク デバイスが指定されたマルチキャスト グループのメンバであるかを検出するためにクエリー メッセージを送信する、ルータなどのネットワーク デバイスです。

ホストは、ホスト メンバシップのクエリアを通知するために(クエリー メッセージの応答で)レポート メッセージを送信する、ルータなどのレシーバです。ホストでは、IGMP メッセージを使用して、マルチキャスト グループに加入し、マルチキャスト グループを脱退します。

ホストでは、そのローカル マルチキャスト ルータに IGMP メッセージを送信することによって、グループ メンバシップが指定されます。IGMP では、ルータが IGMP メッセージをリッスンし、特定のサブネット上でどのグループがアクティブであるかまたは非アクティブであるかを検出するために、定期的にクエリーを送信します。

IGMP バージョンの相違

表 1 に、3 つの IGMP バージョンの高レベルな説明を示します。

表 1 IGMP のバージョン

IGMP のバージョン
説明

IGMPv1

マルチキャスト ルータで、どのマルチキャスト グループがアクティブであるかを決定できる基本クエリー応答メカニズム、および、ホストがマルチキャスト グループに加入でき、マルチキャスト グループから脱退できる他の処理を、用意します。RFC 1112 は、IP マルチキャストに対する IGMPv1 ホスト拡張を定義します。

IGMPv2

IGMP 脱退処理、グループ固有クエリー、および明示的に最大応答時間フィールドを指定するなどの機能を実行できるよう、IGMP を拡張します。IGMPv2 では、マルチキャスト プロトコルでのこの作業の実行に依存することなく IGMP クエリアを選択できるようにする、ルータへの機能も追加されました。RFC 2236 は、IGMPv2 を定義します。

IGMPv3

ソースのフィルタリングを用意します。これによって、マルチキャスト レシーバ ホストは、マルチキャスト トラフィックを受信する場合にソースとなるのはどのグループか、および、このトラフィックがどのソースから送信されると想定されているかについて、ルータに信号を送信できるようになります。さらに、IGMPv3 はリンク ローカル アドレス 224.0.0.22 をサポートします。これは、IGMPv3 メンバシップ レポートの IP アドレスです。すべての IGMPv3 対応マルチキャスト ルータは、このアドレスをリッスンする必要があります。RFC 3376 は、IGMPv3 を定義します。


) あるインターフェイスで PIM をイネーブルにすると、デフォルトで、そのルータ上で IGMPv2 がイネーブルに設定されます。IGMPv2 は、可能な限り IGMPv1 と下位互換性を保つよう設計されました。この下位互換性を有効にするため、RFC 2236 によって特別な相互運用性規則が定義されました。ネットワークにレガシー IGMPv1 ホストが含まれている場合、これらの運用性規則の知識が必要です。IGMPv1 と IGMPv2 の相互運用性の詳細については、RFC 2236、『Internet Group Management Protocol, Version 2』を参照してください。


IGMPv1 が実行されるルータ

IGMPv1 ルータにより、「all-hosts」マルチキャスト アドレス 224.0.0.1 に IGMP クエリーが送信され、アクティブなマルチキャスト レシーバを使用したマルチキャスト グループが要求されます。マルチキャスト レシーバによっても、IGMP レポートがルータに送信され、特定のマルチキャスト ストリームを受信する必要があることが通知されます。ホストでは、非同期に、または、ルータによって送信された IGMP クエリーに対する応答として、レポートを送信できます。同じマルチキャスト グループに複数のマルチキャスト レシーバが存在する場合、これらのホストの 1 つのみで、IGMP レポート メッセージが送信されます。他のホストでは、レポート メッセージが抑制されます。

IGMPv1 では、IGMP クエリアの選択はありません。セグメント上に複数のルータが存在する場合、すべてのルータにより、定期的な IGMP クエリーが送信されます。IGMPv1 には、ホストがグループを脱退できる特別なメカニズムはありません。ホストで、特定のグループに対するマルチキャスト パケットを受信する必要がなくなった場合、ルータから送信される IGMP クエリー パケットに対する応答は行われません。クエリー パケットは、ルータによって送信し続けられます。ルータで 3 つの IGMP クエリーの応答を受信しなかった場合、グループでタイムアウトが発生し、ルータでは、そのグループのセグメント上でのマルチキャスト パケットの送信が停止されます。タイムアウト期間後にルータでマルチキャスト パケットを受信する必要が生じた場合、ホストでは新たな IGMP 加入がルータに送信され、ルータではマルチキャスト パケットの転送が再度開始されます。

LAN 上に複数のルータがある場合、接続されているホストに対するマルチキャスト トラフィックの重複を避けるため、Designated Router(DR; 代表ルータ)を選択する必要があります。PIM ルータでは、選択処理に従って、DR を選択します。最上位 IP アドレスが使用されている PIM ルータが、DR になります。

DR では、次の作業を担当します。

PIM 登録メッセージ、PIM 加入メッセージ、および PIM プルーニング メッセージを Rendezvous Point(RP; ランデブー ポイント)に送信し、ホスト グループ メンバシップに関する情報を通知する。

IGMP ホスト クエリー メッセージを送信する。

ホスト上およびネットワーク上での IGMP の負荷を非常に低く保つために、デフォルトで 60 秒ごとにホスト クエリー メッセージを送信する。

IGMPv2 が実行されるルータ

IGMPv2 では、IGMPv1 のクエリー メッセージング機能が改善されました。

IGMPv2 のクエリーおよびメンバシップ レポート メッセージは、次の 2 つの例外を除き、IGMPv1 メッセージと同じです。

IGMPv2 クエリー メッセージは、一般クエリー(IGMPv1 クエリーと同じ)とグループ固有クエリーの 2 つのカテゴリに分かれる。

IGMPv1 メンバシップ レポートと IGMPv2 メンバシップ レポートでは、異なる IGMP タイプ コードが使用されている。

IGMPv2 では、次の機能に対するサポートを追加することにより、IGMP の機能の強化も行われました。

クエリア選択処理:処理の実行においてマルチキャスト ルーティング プロトコルに依存することなく IGMP クエリアを選択する、IGMPv2 ルータに対する機能が用意されています。

[Maximum Response Time] フィールド:IGMP クエリアを使用して最大クエリー応答時間を指定できる、クエリー メッセージの新しいフィールド。このフィールドでは、応答バースト性を制御し、脱退遅延を微調整する目的で、クエリー応答処理の調整を行うことができます。

グループ固有クエリー メッセージ:すべてのグループではなく特定の 1 つのグループでクエリー操作を実行する目的で、IGMP クエリアを使用することができます。

脱退グループ メッセージ:ルータがグループを脱退する場合に、ネットワーク上のルータを通知する方法がホストに用意されています。

DR と IGMP クエリアが通常同じルータにある IGMPv1 と異なり、IGMPv2 では、2 つの機能が分離されます。DR と IGMP クエリアは異なる基準で選択され、同じサブネット上の異なるルータである場合があります。DR は、サブネット上で最上位 IP アドレスが使用されているルータで、IGMP クエリアは、最下位 IP アドレスが使用されているルータです。

クエリー メッセージは、IGMP クエリアを選択する場合に次のように使用されます。

1. IGMPv2 ルータが起動されるときに、それぞれのルータによって、メッセージのソース IP アドレス フィールドにあるインターフェイス アドレスを使用して、すべてのシステムのグループ アドレス 224.0.0.1 に、一般クエリー メッセージがマルチキャストされます。

2. IGMPv2 ルータが一般クエリー メッセージを受信するときに、ルータでは、メッセージにあるソース IP アドレスが、そのインターフェイス アドレスと比較されます。サブネット上の最下位 IP アドレスが使用されているルータにより、IGMP クエリアが選択されます。

3. すべてのルータ(クエリアは除く)でクエリー タイマーが開始されます。IGMP クエリアから一般クエリー メッセージを受信するたびに、タイマーはリセットされます。クエリー タイマーの期限が切れると、IGMP クエリアはダウンしたとみなされ、新しい IGMP クエリアを選択するために選択処理が再度実行されます。

タイマーは、デフォルトで、クエリー インターバルの 2 倍です。

IGMPv3 が実行されているルータ

IGMPv3 では、ソースのフィルタリングのサポートが Cisco IOS ソフトウェアに追加されています。これによって、マルチキャスト レシーバ ホストは、マルチキャスト トラフィックを受信する場合にソースとなるのはどのグループか、および、このトラフィックがどのソースから送信されると想定されているかについて、ルータに信号を送信できるようになります。このメンバシップ情報を使用すると、Cisco IOS ソフトウェアでは、レシーバがトラフィックを要求したソースからのみ、トラフィックを転送できます。

IGMPv3 では、トラフィックの受信について明示的に信号を送信したソースがあるアプリケーションがサポートされます。IGMPv3 では、次の 2 つのモードで、レシーバにより、マルチキャスト グループにメンバシップの信号が送信されます。

INCLUDE モード:このモードでは、レシーバによって、グループに対して、メンバシップが通知され、トラフィックの受信先からの IP アドレスのリスト(INCLUDE リスト)が用意されます。

EXCLUDE モード:このモードでは、レシーバによって、グループに対して、メンバシップが通知され、トラフィックの非受信先からの IP アドレスのリスト(EXCLUDE リスト)が用意されます。つまり、ホストでは、EXCLUDE リストに表示されていない IP アドレスのソースからのみ、トラフィックを受信します。Internet Standard Multicast(ISM; インターネット標準マルチキャスト)サービス モデルのように、すべてのソースからトラフィックを受信するには、ホストで、空の EXCLUDE リストを使用して、EXCLUDE モードを示します。

IGMPv3 は、SSM ネットワーク環境でチャネル登録の信号を送信する、ホスト用の業界設計標準プロトコルです。SSM で IGMPv3 を信頼するには、ラスト ホップ ルータおよびホストで実行されているオペレーティング システムのネットワーク スタック部分で IGMPv3 が使用可能であり、また、これらのホストを実行しているアプリケーションによって IGMPv3 が使用される必要があります。

IGMPv3 では、ホストによって 224.0.0.22 にメンバシップ レポートが送信されます。したがって、すべての IGMPv3 ルータでは、このアドレスをリッスンする必要があります。ただし、ホストでは、224.0.0.22 をリッスンせず、224.0.0.22 への応答は行われません。ホストでは、そのアドレスにレポートを送信するのみです。さらに、IGMPv3 では、IGMPv3 ホストは他のホストによって送信されるレポートをリッスンしないため、メンバシップ レポートは抑制されません。したがって、一般クエリーが送信されるときに、ワイヤ上のすべてのホストが応答します。

IGMP 加入の処理

ホストがマルチキャスト グループに加入するときには、加入先のマルチキャスト グループのメンバシップ レポートが 1 つ以上、送信要求されなくてもホストから送信されます。IGMP 加入処理は、IGMPv1 ホストと IGMPv2 ホストで同じです。

IGMPv3 では、ホストの加入処理は次のように処理されます。

ホストがグループに加入するときには、ホストにより、空の EXCLUDE リストが使用されて、IGMPv3 メンバシップ レポートが 224.0.0.22 に送信されます。

ホストが特定のチャネルに加入するときには、ホストにより、特定のアドレスが含まれた INCLUDE リストが使用されて、IGMPv3 メンバシップ レポートが 224.0.0.22 に送信されます。

ホストが特定のソースを除くグループに加入するときには、ホストにより、EXCLUDE リストにあるソースが除外されて IGMPv3 メンバシップ レポートが 224.0.0.22 に送信されます。


) LAN 上の一部の IGMPv3 ホストであるソースを除外し、他のホストでそのソースを含める場合、ルータによって、LAN 上のそのソースにトラフィックが送信されます(つまり、この状況では、含まれることが除外より優先されます)。


IGMP の脱退処理

ホストがグループからの脱退に使用する方法は、動作中の IGMP バージョンにより異なります。

IGMPv1 の脱退処理

IGMPv1 では、あるホストで、特定のグループからマルチキャスト トラフィックの受信を続けたくないことを、サブネット上のルータに通知するための脱退グループ メッセージがありません。ホストでは、マルチキャスト グループに対するトラフィックの処理が停止するだけで、そのグループに対する IGMP メンバシップ レポートを使用した IGMP クエリーへの応答が終了します。この結果、IGMPv1 ルータで、サブネット上の特定のマルチキャスト グループに対するアクティブなレシーバがなくなったことが認識されるのは、ルータでメンバシップ レポートの受信が停止されたときです。この処理を活用するには、IGMPv1 ルータで、サブネット上の IGMP グループにカウントダウン タイマーを関連付けます。サブネット上でそのグループに対するメンバシップ レポートを受信すると、タイマーはリセットされます。IGMPv1 ルータでは、このタイムアウト インターバルは、通常、クエリー インターバルの 3 倍(3 分間)です。このタイムアウト インターバルは、すべてのホストがマルチキャスト グループを脱退した後に、ルータでは、最大 3 分間まで、マルチキャスト トラフィックがそのサブネットに転送されることを意味します。

IGMPv2 の脱退処理

IGMPv2 は、ホストが特定のグループに対してマルチキャスト トラフィックの受信を停止することを示す手段を提供する、脱退グループ メッセージと相互運用されます。IGMPv2 ホストがマルチキャスト グループを脱退するときに、そのホストが、そのグループに対するメンバシップ レポートを使用したクエリーに応答した最後のホストの場合、そのホストによって、すべてのルータのマルチキャスト グループ(224.0.0.2)に、脱退グループ メッセージが送信されます。

IGMPv3 の脱退処理

IGMPv3 では、IGMP の特定のグループ、ソース、またはチャネルからトラフィックの受信を停止する機能を導入することによって、または、IGMPv3 メンバシップ レポートで、ソース、グループ、またはチャネルを含めるか除外することによって、脱退プロセスの機能が強化されました。

IGMP マルチキャスト アドレス

IP マルチキャスト トラフィックでは、グループ アドレスが使用されます。グループ アドレスは、クラス D IP アドレスです。クラス D アドレスの上位 4 ビットは 1110 です。したがって、ホスト グループ アドレスの範囲は 224.0.0.0 ~ 239.255.255.255 であると考えられます。

224.0.0.0 ~ 224.0.0.255 の範囲のマルチキャスト アドレスは、ルーティング プロトコルおよび他のネットワーク制御トラフィックで使用する目的で予約されています。アドレス 224.0.0.0 は、どのグループにも割り当てられないことが保証されています。

IGMP パケットは、次のように IP マルチキャスト グループ アドレスを使用して転送されます。

IGMP 一般クエリーは、アドレス 224.0.0.1(サブネット上のすべてのアドレス)宛てです。

IGMP グループ固有クエリーは、ルータがクエリーを送信しているグループ IP アドレス宛てです。

IGMP グループ メンバシップ レポートは、ルータがレポートを送信しているグループ IP アドレス宛てです。

IGMPv2 脱退グループ メッセージは、アドレス 224.0.0.2(サブネット上のすべてのルータ)宛てです。

IGMPv3 メンバシップ レポートは、224.0.0.22 宛てです。すべての IGMPv3 対応マルチキャスト ルータでは、このアドレスをリッスンします。

IGMP のカスタマイズ方法

ここでは、次の作業について説明します。

「直接接続の IGMP ホストがない場合に、マルチキャスト トラフィックが転送されるようにルータを設定する方法」(任意)

「IGMPv3 ホスト スタックのイネーブル化」(任意)

「IGMPv3 のホスト、グループ、およびチャネルの明示的なトラッキングの設定」(任意)

「IGMP 拡張アクセス リストを使用した SSM ネットワークへのアクセスの制御」(任意)

「IGMP プロキシの設定」(任意)

直接接続の IGMP ホストがない場合に、マルチキャスト トラフィックが転送されるようにルータを設定する方法

直接接続の IGMP ホストがない場合に、マルチキャスト トラフィックが転送されるようにルータを設定する場合は、このオプション作業を実行します。

ネットワーク セグメント上またはホスト上のいずれかにグループ メンバがない場合、IGMP を使用してそのグループ メンバシップをレポートできません。ただし、マルチキャスト トラフィックをそのネットワーク セグメントに送信する必要が生じることがあります。次の 2 つの方法は、マルチキャスト トラフィックをネットワーク セグメントにプルする方法です。

ip igmp join-group インターフェイス コンフィギュレーション コマンド モードを使用する方法。この方法では、ルータは、マルチキャスト パケットの転送に加えて、マルチキャスト パケットを受信します。マルチキャスト パケットを受信することにより、ルータのファースト スイッチングは行われません。

ip igmp static-group インターフェイス コンフィギュレーション コマンド モードを使用する方法。この方法では、ルータは、マルチキャスト パケット自体は受信せず、マルチキャスト パケットを転送するのみです。したがって、この方法では、ファースト スイッチングを実行できます。 ip igmp static-group コマンドを設定するときに、発信インターフェイスは IGMP キャッシュに表示されます。しかし、マルチキャスト ルート エントリに「L」(ローカル)フラグがないため、ルータそのものはグループのメンバにはなりません。

手順の概要

1. enable

2. configure terminal

3. interface type number

4. ip igmp join-group group-address
または
ip igmp static-group { * | group-address [ source source-address ]}

5. end

6. show ip igmp interface [interface-type interface-number]

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface type number

 

Router(config)# interface ethernet 1

インターフェイス コンフィギュレーション モードを開始します。

type 引数および number 引数に、ホストに接続されているインターフェイスを指定します。

ステップ 4

ip igmp join-group group-address

または

ip igmp static-group { * | group-address [ source source-address ]}

 

Router(config-if)# ip igmp join-group 225.2.2.2

または

 

Router(config-if)# ip igmp static-group 225.2.2.2

直接接続の IGMP ホストがない場合に、マルチキャスト トラフィックが転送されるようにルータを設定します。

ip igmp join-group コマンドを使用してルータ上にインターフェイスを設定し、指定されたグループに加入します。

この方法では、ルータは、マルチキャスト パケットの転送に加えて、マルチキャスト パケットを受信します。マルチキャスト パケットを受信することにより、ルータのファースト スイッチングは行われません。

または

ip igmp static-group コマンドを使用して、インターフェイス上にスタティック グループ メンバシップ エントリを設定します。

この方法では、ルータは、マルチキャスト パケット自体は受信せず、マルチキャスト パケットを転送するのみです。したがって、この方法では、ファースト スイッチングを実行できます。発信インターフェイスは IGMP キャッシュに表示されます。しかし、マルチキャスト ルート エントリに「L」(ローカル)フラグがないため、ルータそのものはメンバではありません。

ステップ 5

end

 

Router(config-if)# end

現在のコンフィギュレーション セッションを終了して、特権 EXEC モードに戻ります。

ステップ 6

show ip igmp interface [ interface-type interface-number ]

 

Router# show ip igmp interface

(任意)インターフェイスに関するマルチキャスト関連情報を表示します。

IGMPv3 ホスト スタックのイネーブル化

SSM グループの IGMPv3 ホスト スタックに INCLUDE モード機能を追加する場合は、このオプション作業を実行します。

IGMPv3 ホスト スタック

IGMPv3 ホスト スタック機能は、ルータまたはスイッチがマルチキャスト ネットワークのエンドポイントまたはホストとして機能できるようにします。この機能により、SSM グループの IGMPv3 ホスト スタックに INCLUDE モード機能が追加されます。IGMPv3 ホスト スタックをイネーブル化すると、SSM 配置で迅速なチャネル変更が要求される環境などにおいてルータまたはスイッチが IGMPv3 加入を開始できるようにすることにより、LAN 上のホストが SSM を活用できます。

IGMPv3 ホスト スタック機能がサポートされている場合、 source キーワードと source-address 引数を ip igmp join-group コマンドに追加して、SSM グループの IGMPv3 ホスト スタックに INCLUDE モード機能を追加します。


) 同じグループに対して異なるソース アドレスを使用する、複数の ip igmp join-group コマンド設定がサポートされます。


IGMPv3 ホスト スタック機能が設定されるときに、次のイベントの 1 つが発生すると、IGMPv3 メンバシップ レポートが送信されます。

グループおよびソースに対して ip igmp join-group コマンドが設定され、この (S, G) チャネルに対して既存の状態がない場合、指定されたソースのグループ レコード タイプ ALLOW_NEW_SOURCES の IGMPv3 レポートが、そのインターフェイスに送信されます。

グループおよびソースに対して ip igmp join-group コマンドの no 形式が設定され、この (S, G) チャネルに既存の状態がある場合、指定されたソースのグループ レコード タイプ BLOCK_OLD_SOURCES の IGMPv3 レポートが、そのインターフェイスに送信されます。

クエリーの受信時に、RFC 3376 で定義されている IGMPv3 レポートが送信されます。


) IGMPv3 グループ レコード タイプとメンバシップ レポートの詳細については、RFC 3376、『Internet Group Management Protocol, Version 3』を参照してください。


前提条件

この作業では、Cisco IOS Release 12.3(14)T またはそれ以降のリリースをルータで実行している必要があります。

この作業では、SSM に対してルータが設定されていることが前提となっています。SSM の設定方法については、『 Cisco IOS IP Multicast Configuration Guide 』の『 Configuring Basic IP Multicast 』モジュールを参照してください。

制約事項

インターフェイス上で IGMP バージョン 3 が設定されている必要があります。


) グループおよびソースに対して ip igmp join-group コマンドが設定され、インターフェイス上で IGMPv3 が設定されていない場合、(S, G) 状態は作成されますが IGMPv3 メンバシップ レポートは送信されません。


SSM に対してルータが設定されている必要があります。IGMPv3 メンバシップ レポートは、SSM チャネルに対してのみ送信されます。

手順の概要

1. enable

2. configure terminal

3. interface type number

4. ip igmp version 3

5. ip igmp join-group group - address source source - address

6. 追加 (S, G) チャネルに対して INCLUDE モード機能を指定する場合は、ステップ 5 を繰り返します。

7. end

8. show ip igmp groups detail

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface type number

 

Router(config)# interface FastEthernet 1

インターフェイス コンフィギュレーション モードを開始します。

type 引数および number 引数に、ホストに接続されているインターフェイスを指定します。

ステップ 4

ip igmp version 3

 

Router(config-if)# ip igmp version 3

インターフェイス上で IGMPv3 をイネーブルにします。

ステップ 5

ip igmp join-group group - address source source - address

 

Router(config-if)# ip igmp join-group 232.2.2.2 source 10.1.1.1

指定された (S, G) チャネルに加入するよう、インターフェイスを設定します。

このコマンドを使用すると、ルータでは、 group-address 引数および source-address 引数で指定された (S, G) チャネルに対して、INCLUDE モード機能を提供できます。

ステップ 6

追加 (S, G) チャネルに対して INCLUDE モード機能を指定する場合は、ステップ 5 を繰り返します。

--

ステップ 7

end

 

Router(config-if)# end

現在のコンフィギュレーション セッションを終了して、特権 EXEC モードに戻ります。

ステップ 8

show ip igmp groups detail

 

Router# show ip igmp groups detail

ルータに直接接続されているレシーバと IGMP によって学習されたレシーバを持つマルチキャスト グループを表示します。

ip igmp join group コマンドを使用して設定された (S, G) チャネルに対するメンバシップ レポートを、ルータで受信したことを確認する場合は、このコマンドを使用します。チャネルに対する IGMP メンバシップ レポートをルータで正しく受信すると、「Flags:」出力フィールドで L フラグと SSM フラグが表示されます。

IGMPv3 のホスト、グループ、およびチャネルの明示的なトラッキングの設定

マルチキャスト ルータで、特定のマルチアクセス ネットワークにあるすべてのマルチキャスト ホストのメンバシップを明示的に追跡できるようにする場合は、このオプション作業を実行します。この IGMPv3 の Cisco IOS 実装に対する拡張により、ルータは、特定のグループまたはチャネルに参加している個々のホストを追跡できます。

IGMPv3 のホスト、グループ、およびチャネルの明示的なトラッキングの利点

最小脱退遅延

IGMPv3 の主な利点:ホスト、グループ、およびチャネルの明示的なトラッキング機能を使用すると、ホストがマルチキャスト グループまたはチャネルを脱退するときに、最小脱退遅延が認められます。ルータからのトラフィック受信を要求する最後のホストで、今後はトラフィックを受信しないことが示された場合、IGMPv3 および明示的なトラッキングが設定されているルータでは、トラフィックの転送をただちに停止できます。したがって、脱退遅延は、マルチアクセス ネットワークのパケット転送遅延とルータの処理時間によってのみ、バインドされます。

IGMPv2 では、ホストからの IGMP 脱退メッセージをルータで受信するときに、ルータでは、まず、IGMP グループ固有クエリーを送信して、同じマルチアクセス ネットワーク上にある他のホストで、依然、トラフィックの受信が要求されているかどうかを認識する必要があります。クエリーに対して応答するホストがなくなってから特定の時間後(Cisco IOS ソフトウェアでは、デフォルト値は約 3 秒)、ルータでは、トラフィックの転送が停止されます。IGMPv1 および IGMPv2 では、ネットワーク内の別のホストによって同じレポートがすでに送信済みの場合、IGMP メンバシップ レポートが抑制されるため、このクエリー処理が必要です。したがって、トラフィックの受信を要求しているマルチアクセス ネットワーク上の確かなホスト数を、ルータで認識することは不可能です。

高速チャネル変更

マルチキャスト ルータとホストとの間(DSL 環境など)で帯域幅が制限されているネットワークでは、ルータとホストとの間の帯域幅は、通常、継続可能な程度に大きいため、一般的には、限定された数のマルチキャスト ストリームのみが、並行して受信されます。これらの環境では、各ホストは、通常、1 つのマルチキャスト ストリームにのみ加入し、許可されるホストの全体的な数は、リンクの合計帯域幅によって制限されます。これらの環境で有効な脱退遅延では、レシーバ アプリケーションのチャネル変更時間が定義されます。ある 1 つのホストでは、古いストリームの転送が停止される前に、新しいマルチキャスト ストリームを受信することはできません。アプリケーションで、チャネルを脱退遅延よりも高速に設定しようとした場合、アプリケーションでは、アクセス ネットワークの帯域幅に対する過負荷が発生し、すべてのホストのトラフィック フローが一時的に劣化します。IGMPv3 のホスト、グループ、およびチャネルの明示的なトラッキング機能を使用すると、最小脱退遅延が認められ、したがって、高速チャネル変更機能を使用できます。

診断機能の強化

IGMPv3 のホスト、グループ、およびチャネルの明示的なトラッキング機能を使用すると、ネットワーク管理者は、どのマルチキャスト ホストがどのマルチキャスト グループまたはチャネルに加入したかを、簡単に特定できます。

制約事項

MIB のサポートがない

個々のホストの IGMP メンバシップをモニタリングする Simple Network Management Protocol(SNMP; 簡易ネットワーク管理プロトコル)MIB はありません。Cisco IOS ソフトウェアによってサポートされる MIB は、ルータ上の特定のインターフェイスの集約メンバシップにのみ反映されます。

レガシー ホストが使用されているグループでは最小脱退遅延がない

ネットワーク上に IGMPv1 または IGMPv2 のみがサポートされている 1 つまたは複数のホストがある場合、ホストが加入しているマルチキャスト グループに対する脱退遅延は、ホストの IGMP バージョンの脱退遅延に戻されます。これは、IGMPv2 では約 3 秒間で、IGMPv1 では最大で 180 秒間(3 分間)までです。この条件は、任意の時点でレガシー ホストが実際に参加していたマルチキャスト グループにのみ影響を及ぼします。さらに、IGMPv3 によって送信されるこれらのマルチキャスト グループに対するメンバシップ レポートは、IGMPv1 または IGMPv2 のメンバシップ レポートに戻される場合があり、したがって、これらのホスト メンバシップの明示的なトラッキングはディセーブルになります。

IGMP v3lite および URD では明示的なトラッキングのサポートがない

IGMP Version 3 lite(IGMP v3lite; IGMP バージョン 3 lite)または URL Rendezvous Directory(URD)チャネル メンバシップ レポートの明示的なモニタリングは、Release 12.0(19)S またはそれ以前のリリースではサポートされません。これらのリリースでは、IGMP v3lite または URD を使用したホストにトラフィックを送信しているマルチキャスト グループに対する脱退遅延は、ホスト上に設定されている IGMP のバージョンの脱退遅延によって決まります(IGMPv3 では、明示的なトラッキングが設定されていない場合、脱退遅延は、通常、3 秒間です)。

手順の概要

1. enable

2. configure terminal

3. interface type number

4. ip igmp version 3

5. ip igmp explicit-tracking

6. end

7. show ip igmp membership [ group-address | group-name ] [ tracked ] [ all ]

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface type number

 

Router(config)# interface ethernet 1

インターフェイス コンフィギュレーション モードを開始します。

type 引数および number 引数に、ホストに接続されているインターフェイスを指定します。

ステップ 4

ip igmp version 3

 

Router(config-if)# ip igmp version 3

IGMPv3 をイネーブルにします。

ステップ 5

ip igmp explicit-tracking

 

Router(config-if)# ip igmp explicit-tracking

IGMPv3 のホスト、グループ、およびチャネルに対する明示的なトラッキングをイネーブルにします。

ステップ 6

end

 

Router(config-if)# end

現在のコンフィギュレーション セッションを終了して、特権 EXEC モードに戻ります。

ステップ 7

show ip igmp membership [group-address | group-name ] [tracked] [all]

 

Router# show ip igmp membership

(任意)マルチキャスト グループおよび (S, G) チャネルに対する IGMP メンバシップ情報を表示します。

IGMP 拡張アクセス リストを使用した SSM ネットワークへのアクセスの制御

IGMPv3 には、ソース フィルタリングのサポートが含まれています。これは、特定のマルチキャスト アドレスに送信された特定のソース アドレスからのみ(または、特定のソース アドレスを除くすべてのアドレスから)パケットを受信するかどうかを報告するためのシステム機能です。

ソース アドレス、グループ アドレス、またはその両方に基づいて SSM トラフィックをフィルタリングする IGMP 拡張アクセス リストを使用して、アクセスを制御する場合は、このオプション作業を実行します。SSM の詳細については、『 Configuring Basic IP Multicast 』モジュールを参照してください。アクセス リストの設定方法の全般的な情報については、『 Creating an IP Access List and Applying It to an Interface 』モジュールを参照してください。

IPv4 で SSM がサポートされる拡張アクセス リストの利点

IGMPv3 は、拡張アクセス リストに適応します。これによって、ソース IP アドレスに基づいてアクセスするという、IPv4 での SSM の重要な利点を活用できます。この機能の導入前には、IGMP アクセス リストでは、マルチキャスト グループ アドレスに基づいてのみメンバシップ レポートをフィルタリングできる、標準アクセス リストのみが受け付けられていました。

IGMPv3 では、マルチキャスト レシーバが、グループだけではなく、ソースが含まれるまたは除外されるグループにも、加入できます。したがって、適切なアクセス リストでは、レポートされるグループ アドレスによってだけではなく、グループ アドレスおよびソース アドレスによっても、IGMPv3 メッセージのフィルタリングが許可される必要があります。IGMP 拡張アクセス リストでは、この機能が導入されます。IGMP 拡張 Access List(ACL; アクセス リスト)で SSM を使用すると、IGMPv3 レポートでは、ソース S およびグループ G (S, G) を許可または拒否でき、したがって、ソース アドレス、グループ アドレス、またはソース アドレスとグループ アドレスに基づいて IGMPv3 レポートがフィルタリングされます。

ASM グループの IGMPv3 レポートでのソース アドレス

IGMP 拡張アクセス リストは、(0.0.0.0, G) に基づいてトラフィックを許可またはフィルタリング(拒否)する場合にも使用できます。IGMP レポートでは、(*, G) は、Any Source Multicast(ASM)などの非 SSM です。


) (*, G) に相当する許可および拒否ステートメントは、それぞれ permit host 0.0.0.0 host group-address 、および deny host 0.0.0.0 host group group-address です。


フィルタリングは、ASM グループと SSM グループの両方の IGMPv3 レポートに適用されますが、Cisco IOS IP マルチキャスト ルーティングでは ASM グループに対する IGMPv3 レポートは無視されるため、これは、SSM グループにとって、より非常に重要です。ASM グループに対する IGMPv3 メンバシップ レポートのソース アドレスは、Cisco IOS IGMP キャッシュに保存されます( show ip igmp membership コマンドで表示)が、PIM ベース IP マルチキャスト ルーティングでは、レポートされる ASM グループのみが考慮に入れられます。したがって、ASM グループに対するソース アドレスのフィルタリングの追加により、ASM グループの IGMP キャッシュのみに影響が及ぼされます。

IGMP で拡張アクセス リストをチェックする方法

インターフェイス上で ip igmp access-group コマンドを使用して IGMP 拡張アクセス リストが参照されるときに、拡張アクセス リストの permit ステートメントと deny ステートメントの (S, G) ペアは、インターフェイス上で受信する IGMP レポートの (S, G) と照合されます。たとえば、(S1, S2...Sn, G) が使用されている IGMP レポートが受信されると、最初のグループ (0.0.0.0, G) が、アクセス リスト ステートメントに対してチェックされます。(0.0.0.0, G) の変換は (*, G) を意味し、これは、マルチキャスト グループ番号が使用されたワイルドカード ソースです。グループが拒否される場合、IGMP レポート全体が拒否されます。グループが許可されると、各 (S, G) ペアがアクセス リストに対してチェックされます。拒否されるソースは IGMP から除外されますので、ソースを拒否すると、マルチキャスト トラフィックにアクセスすることになります。

手順の概要

1. enable

2. configure terminal

3. ip multicast-routing [ distributed ]

4. ip pim ssm { default | range access-list }

5. ip access-list extended access-list-name

6. deny igmp source source-wildcard destination destination-wildcard [ igmp-type ] [ precedence precedence ] [ tos tos ] [ log ] [ time-range time-range-name ] [ fragments ]

7. permit igmp source source-wildcard destination destination-wildcard [ igmp-type ] [ precedence precedence ] [ tos tos ] [ log ] [ time-range time-range-name ] [ fragments ]

8. end

9. interface type number

10. ip igmp access-group access-list

11. ip pim sparse-mode

12. SSM チャネル メンバシップのアクセス制御が必要なすべてのインターフェイス上で、ステップ 1 ~ 11 を繰り返します。

13. ip igmp version 3

14. ホスト方向のインターフェイスすべてでステップ 13 を繰り返します。

15. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip multicast-routing [ distributed ]

 

Router(config)# ip multicast-routing

IP マルチキャスト ルーティングをイネーブルにします。

distributed キーワードを使用して、Multicast Distributed Switching(MDS; マルチキャスト分散スイッチング)をイネーブルにします。

ステップ 4

ip pim ssm { default | range access-list }

 

Router(config)# ip pim ssm default

SSM サービスを設定します。

default キーワードは SSM 範囲のアクセス リストを 232/8 と定義します。

range キーワードは標準の IP アクセス リスト番号または SSM 範囲を定義する名前を指定します。

ステップ 5

ip access-list extended access-list -name

 

Router(config)# ip access-list extended mygroup

名前付きの拡張 IP アクセス リストを指定します。

ステップ 6

deny igmp source source-wildcard destination destination-wildcard [ igmp-type ] [ precedence precedence ] [ tos tos ] [ log ] [ time-range time-range-name ] [ fragments ]

 

Router(config-ext-nacl)# deny igmp host 10.1.2.3 any

(任意)IGMP レポートから指定されたソース アドレスまたはグループ アドレスをフィルタリングします。つまり、サブネット上でメンバシップから (S, G) チャネルへのホストを制限します。

サブネット メンバシップで他の (S, G) チャネルに対するホストを制限する場合は、この手順を繰り返します(明示的に許可されていないすべてのソースまたはグループは拒否されるため、これらのソースは、後続の permit ステートメントよりも明確である必要があります)。

アクセス リストは、暗黙の deny ステートメントで終了することに注意してください。

この例では、ソース 10.1.2.3 に対してすべてのグループをフィルタリングする拒否ステートメントが作成されます。ソースは効率的に拒否されます。

ステップ 7

permit igmp source source-wildcard destination destination-wildcard [ igmp-type ] [ precedence precedence ] [ tos tos ] [ log ] [ time-range time-range-name ] [ fragments ]

 

Router(config-ext-nacl)# permit igmp any any

IGMP レポートのソース アドレスまたはグループ アドレスで、IP アクセス リストを渡すことができるようになります。

1 つのアクセス リストには、少なくとも 1 つの permit ステートメントを使用する必要があります。

他のソースが IP アクセス リストを渡せるようにする場合は、この手順を繰り返します。

この例では、ソースおよびグループに対するグループ メンバシップは、前の deny ステートメントによって拒否できません。

ステップ 8

end

 

Router(config-ext-nacl)# end

現在のコンフィギュレーション セッションを終了して、特権 EXEC モードに戻ります。

ステップ 9

interface type number

 

Router(config)# interface ethernet 0

IGMPv3 をイネーブルにできるホストに接続されているインターフェイスを選択します。

ステップ 10

ip igmp access-group access-list

 

Router(config-if)# ip igmp access-group mygroup

IGMP レポートに指定されたアクセス リストが適用されます。

ステップ 11

ip pim sparse-mode

 

Router(config-if)# ip pim sparse-mode

インターフェイス上で PIM-SM をイネーブルにします。

(注) スパース モードを使用する必要があります。

ステップ 12

SSM チャネル メンバシップのアクセス制御が必要なすべてのインターフェイス上で、ステップ 1 ~ 11 を繰り返します。

--

ステップ 13

ip igmp version 3

 

Router(config-if)# ip igmp version 3

このインターフェイス上で IGMPv3 をイネーブルにします。IGMP のデフォルト バージョンはバージョン 2 に設定されます。SSM にはバージョン 3 が必要です。

ステップ 14

ホスト方向のインターフェイスすべてでステップ 13 を繰り返します。

--

ステップ 15

end

 

Router(config-if)# end

現在のコンフィギュレーション セッションを終了して、特権 EXEC モードに戻ります。

IGMP プロキシの設定

Unidirectional Link(UDL; 単方向リンク)ルータを設定し、IGMP プロキシ メカニズムを使用する場合は、このオプション作業を実行します。IGMP プロキシを使用すると、ダウンストリーム ルータに直接接続されていない UniDirectional Link Routing(UDLR; 単方向リンク ルーティング)環境にあるホストは、アップストリーム ネットワークがソースのマルチキャスト グループに加入できます。

IGMP プロキシを設定するには、次の作業を実行する必要があります。

「IGMP UDLR に対するアップストリーム UDL ルータの設定」

「IGMP プロキシ サポート付きの IGMP UDLR に対するダウンストリーム UDL ルータの設定」

図 1 に、2 つの UDLR シナリオを示すトポロジ例を図示します。

伝統的な UDL ルーティング シナリオ:直接接続されているレシーバがない UDL ルータ。

IGMP プロキシ シナリオ:直接接続されているレシーバがある UDL ルータ。


) アップストリーム ルータおよびダウンストリーム ルータでは、IGMP UDL が必要です。IGMP UDL の詳細については、『Configuring IP Multicast Over Unidirectional Links』モジュールを参照してください。



) この作業の例については、「例:IGMP プロキシの設定」の項を参照してください。


図 1 IGMP プロキシ トポロジ

シナリオ 1:伝統的な UDLR シナリオ(直接接続されたレシーバがある UDL ルータ)

シナリオ 1 では、IGMP プロキシ メカニズムは不要です。このシナリオでは、次のイベントが順番に発生します。

1. ユーザ 2 により、グループ G の関連情報を要求する IGMP メンバシップ レポートが送信されます。

2. ルータ B で、IGMP メンバシップ レポートを受信し、LAN B 上のグループ G に対する転送エントリが追加され、ルータ A に対する IGMP レポートがプロキシされます。ルータ A は、UDLR のアップストリーム ルータです。

3. 次に、IGMP レポートがインターネット リンクを介してプロキシされます。

4. ルータ A で、IGMP プロキシを受信し、単方向リンク上で転送エントリが管理されます。

シナリオ 2:IGMP プロキシ シナリオ(直接接続されたレシーバがない UDL ルータ)

シナリオ 2 では、ダウンストリーム ルータに直接接続されていないホストが、アップストリーム ネットワークがソースのマルチキャスト グループに加入できるようにするために、IGMP プロキシ メカニズムが必要です。このシナリオでは、次のイベントが順番に発生します。

1. ユーザ 1 により、グループ G の関連情報を要求する IGMP メンバシップ レポートが送信されます。

2. ルータ C により、ホップバイホップで RP(ルータ B)へ PIM 加入メッセージが送信されます。

3. ルータ B で PIM 加入メッセージを受信し、LAN B 上のグループ G に対する転送エントリが追加されます。

4. ルータ B では、その mroute テーブルが定期的にチェックされ、インターネット リンクを介してアップストリーム UDL ルータに IGMP メンバシップ レポートがプロキシされます。

5. ルータ A で、Unidirectional Link(UDL; 単方向リンク)上で転送エントリが作成され、管理されます。

エンタープライズ ネットワークでは、サテライトを介して IP マルチキャスト トラフィックを受信し、ネットワーク中にトラフィックを転送することができる必要があります。UniDirectional Link Routing(UDLR)単体の場合、受信ホストがダウンストリーム ルータのルータ B に直接接続されている必要があるため、シナリオ 2 は可能ではありません。IGMP プロキシ メカニズムでは、マルチキャスト転送テーブルで (*, G) エントリに対する IGMP レポートを作成することによって、この制限が克服されました。したがって、このシナリオを機能できるようにするには、メンバが存在する可能性がある PIM 対応ネットワークに接続されているインターフェイス上で、プロキシされている (*, G) マルチキャスト スタティック ルート(mroute)エントリの IGMP レポート転送をイネーブルにし( ip igmp mroute-proxy コマンドを使用)、mroute プロキシ サービスをイネーブルにする( ip igmp proxy-service コマンドを使用)必要があります。


) PIM メッセージはアップストリームに転送されないため、各ダウンストリーム ネットワークおよびアップストリーム ネットワークには、別のドメインがあります。


前提条件

IGMP プロキシを設定する前に、次の条件が存在することを確認します。

IGMP UDL 上のすべてのルータに、同じサブネット アドレスがあること。UDL 上のすべてのルータで、同じサブネット アドレスを持つことができない場合、アップストリーム ルータは、ダウンストリーム ルータが接続されているすべてのサブネットに一致するセカンダリ アドレスで設定される必要があります。

IP マルチキャストがイネーブルに設定され、『 Configuring Basic IP Multicast 』モジュールで説明されている作業を使用して、PIM インターフェイスが設定されていること。

IGMP プロキシ シナリオのインターフェイス上で PIM をイネーブルにするときに、次の注意事項に留意してください。

インターフェイスがスパース モード領域で動作中で、スタティック RP、Bootstrap(BSR; ブートストラップ)、または自動 RP リスナー機能付きで自動 RP を実行している場合は、PIM Sparse Mode(PIM-SM; PIM スパース モード)を使用します。

インターフェイスがスパース-デンス モード領域で実行中で、自動 RP リスナー機能なしで自動 RP を実行している場合は、PIM スパース-デンス モードを使用します。

インターフェイスがデンス モードで動作中で、デンス モード領域に加入している場合、この手順では PIM Dense Mode(PIM-DM; PIM デンス モード)を使用します。

スパース モード領域にあるレシーバに到達する必要があるデンス モードから、インターフェイスがソース トラフィックを受信している場合は、プロキシ登録機能付きで PIM-DM を使用します。

IGMP UDLR に対するアップストリーム UDL ルータの設定

IGMP UDLR に対するアップストリーム UDL ルータ(図 1 のルータ A)を設定する場合は、この作業を実行します。

手順の概要

1. enable

2. configure terminal

3. interface type number

4. ip igmp unidirectional-link

5. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface type number

 

Router(config)# interface ethernet 1

インターフェイス コンフィギュレーション モードを開始します。

type 引数および number 引数に、アップストリーム ルータ上で UDL として使用されるインターフェイスを使用します。

ステップ 4

ip igmp unidirectional-link

 

Router(config-if)# ip igmp unidirectional-link

インターフェイス上の IGMP を、IGMP UDLR に対して単方向になるよう設定します。

ステップ 5

end

 

Router(config-if)# end

現在のコンフィギュレーション セッションを終了して、特権 EXEC モードに戻ります。

IGMP プロキシ サポート付きの IGMP UDLR に対するダウンストリーム UDL ルータの設定

IGMP プロキシ サポート付きの IGMP UDLR に対するダウンストリーム UDL ルータ(図 2 のルータ B)を設定する場合は、この作業を実行します。

手順の概要

1. enable

2. configure terminal

3. interface type number

4. ip igmp unidirectional-link

5. exit

6. interface type number

7. ip igmp mroute-proxy type number

8. exit

9. interface type number

10. ip igmp helper-address udl interface-type interface-number

11. ip igmp proxy-service

12. end

13. show ip igmp interface

14. show ip igmp udlr

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface type number

 

Router(config)# interface ethernet 0

インターフェイス コンフィギュレーション モードを開始します。

type 引数および number 引数に、IGMP UDLR に対するダウンストリーム ルータ上で UDL として使用されるインターフェイスを使用します。

ステップ 4

ip igmp unidirectional-link

 

Router(config-if)# ip igmp unidirectional-link

インターフェイス上の IGMP を、IGMP UDLR に対して単方向になるよう設定します。

ステップ 5

exit

 

Router(config-if)# exit

インターフェイス コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードに戻ります。

ステップ 6

interface type number

 

Router(config)# interface ethernet 1

インターフェイス コンフィギュレーション モードを開始します。

type 引数および number 引数に、非直接ホストに直面しているインターフェイスを指定します。

ステップ 7

ip igmp mroute-proxy type number

 

Router(config-if)# ip igmp mroute-proxy loopback 0

プロキシされている (*, G) マルチキャスト スタティック ルート(mroute)エントリの IGMP レポート転送をイネーブルにします。

この手順は、マルチキャスト転送テーブルにあるすべての (*, G) 転送エントリに対するプロキシ サービス インターフェイスへの、IGMP レポートの転送をイネーブルにするために実行されます。

この例では、イーサネット インターフェイス 1 に転送される mroute テーブルにあるすべてのグループに対して、インターフェイス 0 をループバックする目的で、IGMP レポートの送信を要求するために、イーサネット インターフェイス 1 に ip igmp mroute-proxy コマンドが設定されます。

ステップ 8

exit

 

Router(config-if)# exit

インターフェイス コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードに戻ります。

ステップ 9

interface type number

 

Router(config)# interface loopback 0

特定のインターフェイスのインターフェイス コンフィギュレーション モードを開始します。

この例では、ループバック インターフェイス 0 が指定されます。

ステップ 10

ip igmp helper-address udl interface-type interface-number

 

Router(config-if)# ip igmp helper-address udl ethernet 0

UDLR で IGMP ヘルパーを設定します。

この手順を使用すると、 interface-type 引数および interface-number 引数で指定されたインターフェイスに関連付けられている UDL に接続されているアップストリーム ルータに、ホストから受信した IGMP レポートのヘルパーを設定するため、ダウンストリーム ルータが許可されます。

このトポロジ例では、ダウンストリーム ルータ上のループバック インターフェイス 0 を介して、IGMP ヘルパーが設定されます。したがって、ループバック インターフェイス 0 は、ホストから、イーサネット インターフェイス 0 に接続されているアップストリーム ルータへの、IGMP レポートのヘルパーに設定されます。

ステップ 11

ip igmp proxy-service

 

Router(config-if)# ip igmp proxy-service

mroute プロキシ サービスをイネーブルにします。

mroute プロキシ サービスがイネーブルのときに、IGMP クエリー インターバルに基づいて ip igmp mroute-proxy コマンド(ステップ 7 を参照)で設定されたインターフェイスに一致する、(*, G) 転送エントリのスタティック mroute テーブルが、ルータによって定期的にチェックされます。一致があった場合、このインターフェイス上で、1 つの IGMP レポートが作成され、受信されます。

(UDL)コマンドとともに使用されます。

この例では、 ip igmp mroute-proxy コマンドを使用して登録されたインターフェイス上にあるすべてのグループのインターフェイスへの、IGMP レポートの転送をイネーブルにするために、ループバック インターフェイス 0 上で ip igmp proxy-service コマンドが設定されます(ステップ 7 を参照)。

ステップ 12

end

 

Router(config-if)# end

現在のコンフィギュレーション セッションを終了して、特権 EXEC モードに戻ります。

ステップ 13

show ip igmp interface

 

Router# show ip igmp interface

(任意)インターフェイスに関するマルチキャスト関連情報を表示します。

ステップ 14

show ip igmp udlr

 

Router# show ip igmp udlr

(任意)設定された UDL ヘルパー アドレスがあるインターフェイス上で、マルチキャスト グループに直接接続されている UDLR 情報を表示します。

IGMP のカスタマイズ設定例

ここでは、次の設定例について説明します。

「例:直接接続の IGMP ホストがない場合に、マルチキャスト トラフィックが転送されるようにルータを設定する方法」

「例:IGMPv3 ホスト スタックのイネーブル化」

「例:IGMPv3 の設定 - ホスト、グループ、およびチャネルの明示的なトラッキング」

「例:IGMP 拡張アクセス リストを使用した SSM ネットワークへのアクセスの制御」

「例:IGMP プロキシの設定」

例:直接接続の IGMP ホストがない場合に、マルチキャスト トラフィックが転送されるようにルータを設定する方法

次に、直接接続されている IGMP ホストがない場合に、マルチキャスト トラフィックを転送するよう、 ip igmp join-group コマンドを使用してルータを設定する例を示します。この方法では、ルータは、マルチキャスト パケットの転送に加えて、マルチキャスト パケットを受信します。マルチキャスト パケットを受信することにより、ルータのファースト スイッチングは行われません。

この例では、ルータ上のファスト イーサネット インターフェイス 0/0 が、グループ 225.2.2.2 に加入するよう設定されます。

interface FastEthernet0/0
ip igmp join-group 225.2.2.2
 

次に、直接接続されている IGMP ホストがない場合に、マルチキャスト トラフィックを転送するよう、 ip igmp static-group コマンドを使用してルータを設定する例を示します。この方法では、ルータは、マルチキャスト パケット自体は受信せず、マルチキャスト パケットを転送するのみです。したがって、この方法では、ファースト スイッチングを実行できます。発信インターフェイスは IGMP キャッシュに表示されます。しかし、マルチキャスト ルート エントリに「L」(ローカル)フラグがないため、ルータそのものはメンバではありません。

この例では、グループ 225.2.2.2 のスタティック グループ メンバシップ エントリが、ファスト イーサネット インターフェイス 0/1 に設定されます。

interface FastEthernet0/0
ip igmp static-group 225.2.2.2

例:IGMPv3 ホスト スタックのイネーブル化

次に、SSM グループの IGMPv3 ホスト スタックに INCLUDE モード機能を追加する例を示します。

interface FastEthernet0/0
ip igmp join-group 232.2.2.2 source 10.1.1.1
ip igmp join-group 232.2.2.2 source 10.5.5.5
ip igmp join-group 232.2.2.2 source 10.5.5.6
ip igmp join-group 232.2.2.4 source 10.5.5.5
ip igmp join-group 232.2.2.4 source 10.5.5.6
ip igmp version 3
 

次に、この例で示されている設定に基づいた、 debug igmp コマンドの出力例を示します。メッセージにより、IGMPv3 および SSM がイネーブルにされた後で IGMPv3 メンバシップ レポートが送信されたことが、確認されます。

Router# debug igmp
 
*May 4 23:48:34.251: IGMP(0): Group 232.2.2.2 is now in the SSM range, changing
*May 4 23:48:34.251: IGMP(0): Building v3 Report on Ethernet0/0
*May 4 23:48:34.251: IGMP(0): Add Group Record for 232.2.2.2, type 5
*May 4 23:48:34.251: IGMP(0): Add Source Record 10.1.1.1
*May 4 23:48:34.251: IGMP(0): Add Source Record 10.5.5.5
*May 4 23:48:34.251: IGMP(0): Add Source Record 10.5.5.6
*May 4 23:48:34.251: IGMP(0): Add Group Record for 232.2.2.2, type 6
*May 4 23:48:34.251: IGMP(0): No sources to add, group record removed from report
*May 4 23:48:34.251: IGMP(0): Send unsolicited v3 Report with 1 group records on FastEthernet0/0
*May 4 23:48:34.251: IGMP(0): Group 232.2.2.4 is now in the SSM range, changing
*May 4 23:48:34.251: IGMP(0): Building v3 Report on Ethernet0/0
*May 4 23:48:34.251: IGMP(0): Add Group Record for 232.2.2.4, type 5
*May 4 23:48:34.251: IGMP(0): Add Source Record 10.5.5.5
*May 4 23:48:34.251: IGMP(0): Add Source Record 10.5.5.6
*May 4 23:48:34.251: IGMP(0): Add Group Record for 232.2.2.4, type 6
*May 4 23:48:34.251: IGMP(0): No sources to add, group record removed from report
*May 4 23:48:34.251: IGMP(0): Send unsolicited v3 Report with 1 group records on FastEthernet0/0
*May 4 23:48:35.231: IGMP(0): Building v3 Report on Ethernet0/0
*May 4 23:48:35.231: IGMP(0): Add Group Record for 232.2.2.2, type 5
*May 4 23:48:35.231: IGMP(0): Add Source Record 10.1.1.1
*May 4 23:48:35.231: IGMP(0): Add Source Record 10.5.5.5
*May 4 23:48:35.231: IGMP(0): Add Source Record 10.5.5.6
*May 4 23:48:35.231: IGMP(0): Add Group Record for 232.2.2.2, type 6
*May 4 23:48:35.231: IGMP(0): No sources to add, group record removed from report
*May 4 23:48:35.231: IGMP(0): Send unsolicited v3 Report with 1 group records on FastEthernet0/0
*May 4 23:48:35.231: IGMP(0): Building v3 Report on Ethernet0/0
*May 4 23:48:35.231: IGMP(0): Add Group Record for 232.2.2.4, type 5
*May 4 23:48:35.231: IGMP(0): Add Source Record 10.5.5.5
*May 4 23:48:35.231: IGMP(0): Add Source Record 10.5.5.6
*May 4 23:48:35.231: IGMP(0): Add Group Record for 232.2.2.4, type 6
*May 4 23:48:35.231: IGMP(0): No sources to add, group record removed from report
*May 4 23:48:35.231: IGMP(0): Send unsolicited v3 Report with 1 group records on FastEthernet0/0
 

次に、この設定例シナリオで、キーワード detail を指定した show ip igmp groups コマンドの出力例を示します。 ip igmp join group コマンドを使用して設定された (S, G) チャネルに対するメンバシップ レポートを、ルータで受信したことを確認する場合は、 show ip igmp groups コマンドを使用できます。チャネルに対する IGMP メンバシップ レポートをルータで正しく受信すると、「Flags:」出力フィールドで L フラグと SSM フラグが表示されます。

Router# show ip igmp groups detail
 
Flags: L - Local, U - User, SG - Static Group, VG - Virtual Group,
SS - Static Source, VS - Virtual Source
 
Interface: FastEthernet0/0
Group: 232.2.2.2
Flags: L SSM
Uptime: 00:04:12
Group mode: INCLUDE
Last reporter: 10.4.4.7
Group source list: (C - Cisco Src Report, U - URD, R - Remote, S - Static,
V - Virtual, Ac - Accounted towards access control limit,
M - SSM Mapping, L - Local)
Source Address Uptime v3 Exp CSR Exp Fwd Flags
10.1.1.1 00:04:10 stopped stopped Yes L
10.5.5.5 00:04:12 stopped stopped Yes L
10.5.5.6 00:04:12 stopped stopped Yes L
 
Interface: FastEthernet0/0
Group: 232.2.2.3
Flags: L SSM
Uptime: 00:04:12
Group mode: INCLUDE
Last reporter: 10.4.4.7
Group source list: (C - Cisco Src Report, U - URD, R - Remote, S - Static,
V - Virtual, Ac - Accounted towards access control limit,
M - SSM Mapping, L - Local)
Source Address Uptime v3 Exp CSR Exp Fwd Flags
10.5.5.5 00:04:14 stopped stopped Yes L
10.5.5.6 00:04:14 stopped stopped Yes L

例:IGMPv3 の設定 - ホスト、グループ、およびチャネルの明示的なトラッキング

次に、明示的なトラッキングをイネーブルにする例を示します。SSM、IGMPv3、および明示的なトラッキングを使用して IP マルチキャストをイネーブルにする基本設定例を示します。

ip multicast-routing
interface ethernet 0
description access network to desktop systems
ip address 10.1.0.1 255.255.255.0
ip pim sparse-dense-mode
ip mroute-cache
ip igmp version 3
ip igmp explicit-tracking
interface ethernet 1
description backbone interface no connected hosts
ip address 10.10.0.1 255.255.255.0
ip pim sparse-dense-mode
ip mroute-cache
ip pim ssm default

例:IGMP 拡張アクセス リストを使用した SSM ネットワークへのアクセスの制御

ここでは、IGMP 拡張アクセス リストを使用して SSM ネットワーク上でアクセスを制御する、次の設定例について説明します。

「例:グループ G のすべての状態を拒否」

「例:ソース S のすべての状態を拒否」

「例:グループ G のすべての状態を許可」

「例:ソース S のすべての状態を許可」

「例:グループ G でソース S をフィルタリング」


) アクセス リストは、融通性が非常に高いことに注意してください。マルチキャスト トラフィックをフィルタリングする場合、アクセス リストで使用できる permit ステートメントと deny ステートメントの組み合わせは、多数あります。この項では、少しの例を示します。


例:グループ G のすべての状態を拒否

次に、グループ G ですべての状態を拒否する例を示します。この例では、IGMPv3 レポートの SSM グループ 232.2.2.2 に対するすべてのソースがフィルタリングされるよう、ファスト イーサネット インターフェイス 0/0 が設定されます。これにより、このグループが効果的に拒否されます。

ip access-list extended test1
deny igmp any host 232.2.2.2
permit igmp any any
!
interface FastEthernet0/0
ip igmp access-group test1

例:ソース S のすべての状態を拒否

次に、ソース S ですべての状態を拒否する例を示します。この例では、IGMPv3 レポートのソース 10.2.1.32 に対するすべてのグループがフィルタリングされるよう、イーサネット インターフェイス 1/1 が設定されます。これにより、このソースが効果的に拒否されます。

ip access-list extended test2
deny igmp host 10.2.1.32 any
permit igmp any any
!
interface Ethernet1/1
ip igmp access-group test2

例:グループ G のすべての状態を許可

次に、グループ G ですべての状態を許可する例を示します。この例では、IGMPv3 レポートの SSM グループ 232.1.1.10 に対するすべてのソースが受け付けられるよう、イーサネット インターフェイス 1/2 が設定されます。これにより、このグループ全体が効果的に受け付けられます。

ip access-list extended test3
permit igmp any host 232.1.1.10
!
interface Ethernet1/2
ip igmp access-group test3

例:ソース S のすべての状態を許可

次に、ソース S ですべての状態を許可する例を示します。この例では、IGMPv3 レポートのソース 10.6.23.32 に対するすべてのグループが受け付けられるよう、イーサネット インターフェイス 1/2 が設定されます。これにより、このソース全体が効果的に受け付けられます。

ip access-list extended test4
permit igmp host 10.6.23.32 any
!
interface Ethernet1/2
ip igmp access-group test4

例:グループ G でソース S をフィルタリング

次に、グループ G で特定のソース S をフィルタリングする例を示します。この例では、IGMPv3 レポートの SSM グループ 232.2.30.30 に対するソース 232.2.2.2 がフィルタリングされるよう、イーサネット インターフェイス 0/3 が設定されます。

ip access-list extended test5
deny igmp host 10.4.4.4 host 232.2.30.30
permit igmp any any
!
interface Ethernet0/3
ip igmp access-group test5

例:IGMP プロキシの設定

次に、IGMP UDLR に対してアップストリーム UDL ルータを設定し、IGMP プロキシ サポート付きの IGMP UDLR に対してダウンストリーム UDL ルータを設定する例を示します。ダウンストリーム ルータに直接接続されていないホストが、アップストリーム ネットワークがソースのマルチキャスト グループに加入できるようにするために、IGMP プロキシ メカニズムが必要です。

例は、図 2 に示されたトポロジに基づいています。このトポロジ例では、ルータ A はアップストリーム ルータで、ルータ B はダウンストリーム ルータです。


) IGMP プロキシ設定の詳細については、「「IGMP プロキシの設定」」の項を参照してください。


図 2 IGMP プロキシ トポロジ例

ルータ A の設定

interface ethernet 0
ip address 10.1.1.1 255.255.255.0
ip pim dense-mode
!
interface ethernet 1
ip address 10.2.1.1 255.255.255.0
ip pim dense-mode
ip igmp unidirectional-link
!
interface ethernet 2
ip address 10.3.1.1 255.255.255.0

ルータ B の設定

ip pim rp-address 10.5.1.1 5
access-list 5 permit 239.0.0.0 0.255.255.255
!
interface loopback 0
ip address 10.7.1.1 255.255.255.0
ip pim dense-mode
ip igmp helper-address udl ethernet 0
ip igmp proxy-service
!
interface ethernet 0
ip address 10.2.1.2 255.255.255.0
ip pim dense-mode
ip igmp unidirectional-link
!
interface ethernet 1
ip address 10.5.1.1 255.255.255.0
ip pim sparse-mode
ip igmp mroute-proxy loopback 0
!
interface ethernet 2
ip address 10.6.1.1 255.255.255.0

その他の参考資料

関連資料

関連項目
参照先

IP マルチキャスト テクノロジー分野の概要

IP Multicast Technology Overview 』モジュール

基本的な IP マルチキャストの概念、設定作業、および例

Configuring Basic IP Multicast 』モジュール

IGMP UDLR の概念、設定作業、および例

Configuring IP Multicast over Unidirectional Links 』モジュール

IP マルチキャスト コマンド:コマンド構文の詳細、コマンド モード、コマンド履歴、コマンド デフォルト設定、使用に関する注意事項、および例

『Cisco IOS IP Multicast Command Reference』

規格

規格
タイトル

これらの機能のサポート対象の規格には、新規規格も変更された規格もありません。また、これら機能は既存の規格に対するサポートに影響を及ぼしません。

--

MIB

MIB
MIB リンク

これらの機能によってサポートされる新しい MIB または変更された MIB はありません。また、これらの機能による既存 MIB のサポートに変更はありません。

選択したプラットフォーム、Cisco ソフトウェア リリース、および機能セットの MIB の場所を検索しダウンロードするには、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFC

RFC
タイトル

RFC 1112

『Host extensions for IP multicasting』

RFC 2236

『Internet Group Management Protocol, Version 2』

RFC 3376

『Internet Group Management Protocol, Version 3』

シスコのテクニカル サポート

説明
リンク

右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。

以下を含むさまざまな作業にこの Web サイトが役立ちます。
・テクニカル サポートを受ける
・ソフトウェアをダウンロードする
・セキュリティの脆弱性を報告する、またはシスコ製品のセキュリティ問題に対する支援を受ける
・ツールおよびリソースへアクセスする
- Product Alert の受信登録
- Field Notice の受信登録
- Bug Toolkit を使用した既知の問題の検索
・Networking Professionals(NetPro)コミュニティで、技術関連のディスカッションに参加する
・トレーニング リソースへアクセスする
・TAC Case Collection ツールを使用して、ハードウェアや設定、パフォーマンスに関する一般的な問題をインタラクティブに特定および解決する

この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

http://www.cisco.com/cisco/web/support/index.html

IGMP のカスタマイズの機能情報

表 2 に、この機能のリリース履歴を示します。

表 2 に、このモジュールで説明した機能をリストし、特定の設定情報へのリンクを示します。

ここに記載されていないこのテクノロジーの機能情報については、『 IP Multicast Features Roadmap 』を参照してください。

Cisco Feature Navigator を使用すると、プラットフォームおよびソフトウェア イメージのサポート情報を検索できます。Cisco Feature Navigator を使用すると、ソフトウェア イメージがサポートする特定のソフトウェア リリース、機能セット、またはプラットフォームを確認できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。


表 2 には、一連のソフトウェア リリースのうち、特定の機能が初めて導入されたソフトウェア リリースだけが記載されています。特に明記されていない限り、Cisco IOS ソフトウェア リリース群の後続のリリースでもこの機能をサポートします。


 

表 2 IGMP のカスタマイズの機能情報

機能名
リリース
機能情報

IPv4 で SSM をサポートするための IGMP の拡張 ACL サポート

12.0(19)S
12.3(7)T
12.2(25)S
12.2(27)SBC
12.2(33)SRA
12.2(33)SXH
15.0(1)S
Cisco IOS XE 3.1.0SG

IPv4 で SSM をサポートするための IGMP の拡張 ACL サポート機能は、IGMPv3 が拡張アクセス リストに対応できるようにします。IGMPv3 の拡張アクセス リストのサポートにより、IPv4 における SSM の重要な利点、つまりソース アドレス、グループ アドレス、またはその両方に基づいた IGMPv3 レポートのフィルタリングの利点を活用できます。

この機能に関する詳細については、次の各項を参照してください。

「IGMP 拡張アクセス リストを使用した SSM ネットワークへのアクセスの制御」

「例:IGMP 拡張アクセス リストを使用した SSM ネットワークへのアクセスの制御」

この機能により、次のコマンドが導入されました。
ip igmp access-group

IGMPv3 ホスト スタック

12.3(14)T
12.2(33)SRE

IGMPv3 ホスト スタック機能は、ルータおよびスイッチがマルチキャスト ネットワークのエンドポイントまたはホストとして機能できるようにします。この機能により、SSM グループの IGMPv3 ホスト スタックに INCLUDE モード機能が追加されます。IGMPv3 ホスト スタックをイネーブル化すると、SSM 配置で迅速なチャネル変更が要求される環境などにおいてルータが IGMPv3 加入を開始できるようにすることにより、LAN 上のホストが SSM を活用できます。

この機能に関する詳細については、次の各項を参照してください。

「IGMPv3 ホスト スタックのイネーブル化」

「例:IGMPv3 ホスト スタックのイネーブル化」

この機能により、 ip igmp join-group コマンドが変更されました。

IGMPv3 のホスト、グループ、およびチャネルの明示的なトラッキング

12.0(19)S
12.2(8)T
12.2(14)S
15.0(1)S
Cisco IOS XE 3.1.0SG

IGMPv3 のホスト、グループ、およびチャネルの明示的なトラッキング機能は、マルチキャスト ルータが特定のマルチアクセス ネットワーク内のすべてのマルチキャスト ホストのメンバシップを明示的に追跡できるようにします。この IGMPv3 の Cisco IOS 実装に対する拡張により、ルータは、特定のグループまたはチャネルに参加している個々のホストを追跡できます。

この機能に関する詳細については、次の各項を参照してください。

「IGMPv3 のホスト、グループ、およびチャネルの明示的なトラッキングの設定」

「例:IGMPv3 の設定 - ホスト、グループ、およびチャネルの明示的なトラッキング」

この機能によって、次のコマンドが導入されました。
ip igmp explicit-tracking show ip igmp membership