IP マルチキャスト コンフィギュレーション ガイド、 Cisco IOS Release 15.1S
Source Specific Multicastの設定
Source Specific Multicastの設定
発行日;2012/02/05 | 英語版ドキュメント(2011/04/17 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 8MB) | フィードバック

目次

Source Specific Multicastの設定

SSM のコンポーネントの概要

SSM とインターネット標準マルチキャスト(ISM)の違い

SSM IP アドレス範囲

SSM 処理

IGMPv3 ホスト シグナリング

IGMP v3lite ホスト シグナリング

URD ホスト シグナリング

利点

IP マルチキャスト アドレス管理は不要

阻止された望ましくないソースからのサービス拒絶(DoS)攻撃

簡単なインストールと管理

インターネット ブロードキャスト アプリケーションに理想的

制約事項

SSM 範囲内のレガシー アプリケーションの制約

IGMP v3lite および URD には Cisco IOS ラスト ホップ ルータが必要

アドレス管理の制約事項

IGMP スヌーピングと CGMP の制限事項

URD インターセプト URL の制約事項

状態維持の制約事項

HSIL の制限事項

SSM 設定作業リスト

SSM の設定

SSM のモニタリング

SSM の設定例

IGMPv3 を使用した SSM の例

IGMP v3lite と URD を使用した SSM の例

SSM フィルタリング例

Source Specific Multicastの設定

機能の履歴

リリース
変更点

Cisco IOS

Cisco IOS ソフトウェアの機能サポートに関する情報については、Cisco Feature Navigator を使用してください。

Cisco IOS XE Release 2.1

この機能は、Cisco ASR 1000 シリーズ ルータで導入されました。

この章では、Source Specific Multicast(SSM)を設定する手順について説明します。Source Specific Multicast(SSM)機能は、レシーバが明示的に参加したマルチキャスト ソースからのみデータグラム トラフィックがレシーバに転送される IP マルチキャストの拡張機能です。SSM 用に設定されたマルチキャスト グループの場合、(共有ツリーではなく)ソース固有のマルチキャスト配信ツリーのみが作成されます。

機能に関連付けられたハードウェア プラットフォームまたはソフトウェア イメージの情報を識別するには、Cisco.com の Feature Navigator を使用して機能についての情報を検索するか、特定のリリースのソフトウェア リリースノートを参照してください。

SSM のコンポーネントの概要

SSM は、ブロードキャスト アプリケーションとしても知られる 1 対多アプリケーションをサポートする最善のデータグラム配信モデルです。SSM は、音声およびビデオ ブロードキャスト アプリケーション環境を対象としたシスコによる IP マルチキャスト ソリューションの実装のコア ネットワーク テクノロジーです。この章では、SSM の実装をサポートする次の Cisco IOS コンポーネントについて説明します。

Protocol Independent Multicast Source Specific Mode(PIM-SSM)

Internet Group Management Protocol Version 3(IGMPv3; インターネット グループ管理プロトコル バージョン 3)

Internet Group Management Protocol Version 3 lite(IGMP v3lite; インターネット グループ管理プロトコル バージョン 3 ライト)

URL Rendezvous Directory(URD)

PIM-SSM は、SSM の実装をサポートするルーティング プロトコルで、PIM Sparse Mode(PIM-SM; スパース モード)から派生しました。IGMP は、ホストがルータにマルチキャスト グループ メンバシップを伝えるために使用する Internet Engineering Task Force(IETF; インターネット技術特別調査委員会)標準トラック プロトコルです。このプロトコルのバージョン 3 は、SSM に必要なソース フィルタリングをサポートします。IGMPv3 と共に SSM を実行するには、SSM が Cisco IOS ルータ、アプリケーションが実行されるホスト、アプリケーション自体でサポートされる必要があります。IGMP v3lite と URD は、シスコが開発した 2 つの移行ソリューションで、ホスト オペレーティング システムと SSM レシーバ アプリケーションでの IGMPv3 の完全サポート機能を待たずに、即座の配備と SSM サービスの配備を行えます。IGMP v3lite は、アプリケーション開発者のためのソリューションで、使用可能になるとただちに IGMPv3 に切り替える SSM レシーバ アプリケーションの即座の配備を可能にします。URD は、コンテンツ プロバイダーとコンテンツ アグリゲータのためのソリューションです。SSM がイネーブルになっていないレシーバ アプリケーションを(IGMPv3 のサポートによって)配備できるようにします。IGMPv3、IGMP v3lite、および URD は互いに相互運用できるため、IGMP v3lite と URD はどちらもホストでの IGMPv3 の完全サポートに向けた移行ソリューションとして簡単に使用できます。

SSM とインターネット標準マルチキャスト(ISM)の違い

インターネットと多くの企業イントラネットの現在の IP マルチキャスト インフラストラクチャは、PIM-SM プロトコルと Multicast Source Discovery Protocol(MSDP)に基づいています。これらのプロトコルは信頼でき、広範で、効率的であることが証明されています。しかし、Internet Standard Multicast(ISM; インターネット標準マルチキャスト)サービス モデルの複雑さと機能性の制限があります。たとえば、ISM では、ネットワークがマルチキャスト トラフィックをアクティブに送信しているネットワーク内のホストについての知識を維持する必要があります。SSM では、この情報は IGMPv3、IGMP v3lite、または URD によってラスト ホップ ルータにリレーされるソース アドレスを通じてレシーバによって提供されます。SSM は、ISM に関連付けられた問題への対応を強化し、ネットワーク内で ISM 用に開発されたプロトコルと共存することを目的としています、一般的に、SSM は SSM を使用するアプリケーションのためにより利点の多い IP マルチキャスト サービスを提供します。

ISM サービスについては RFC 1112 で説明されています。このサービスは、任意のソースからマルチキャスト ホスト グループと呼ばれるレシーバのグループへの IP データグラムの配信によって構成されています。マルチキャスト ホスト グループのデータグラム トラフィックは、IP 宛先アドレスとして任意の IP ユニキャスト ソース アドレス S とマルチキャスト グループ アドレス G を持つデータグラムで構成されています。システムはホスト グループのメンバになることによってこのトラフィックを受信します。ホスト グループのメンバシップには IGMP バージョン 1、2、または 3 によるホスト グループのシグナリングが必要です。

SSM では、データグラムの配信は (S, G) チャネルに基づいています。1 つの (S, G) チャネルのトラフィックは、IP 宛先アドレスとして IP ユニキャスト ソース アドレス S とマルチキャスト グループ アドレス G を持つデータグラムで構成されています。システムは (S, G) チャネルのメンバになることによってこのトラフィックを受信します。SSM と ISM のどちらでも、ソースになるためにシグナリングは必要ありません。しかし、SSM ではレシーバが特定のソースからトラフィックを受信する、または受信しないために (S, G) チャネルに加入または加入中止する必要があります。つまり、レシーバは加入している (S, G) チャネルからのみトラフィックを受信できます。一方、ISM では、レシーバがトラフィックを受信するソースの IP アドレスを知っている必要はありません。提案されているチャネル加入シグナリングの標準的な方法では、IGMP INCLUDE モード メンバシップ レポートを使用します。これは、IGMP バージョン 3 でのみサポートされています。

SSM IP アドレス範囲

SSM は、SSM デリバリ モデルを IP マルチキャスト グループ アドレス範囲の設定済みのサブセットに適用することによって ISM サービスと共存できます。Internet Assigned Numbers Authority(IANA; インターネット割り当て番号局)は、SSM アプリケーションおよびプロトコル用に 232.0.0.0 ~ 232.255.255.255 のアドレス範囲を確保しています。Cisco IOS ソフトウェアでは、224.0.0.0 ~ 239.255.255.255 の IP マルチキャスト アドレス範囲の任意のサブセットの SSM 設定を許可します。SSM 範囲が定義されると、(アプリケーションが明示的な (S, G) チャネル加入を使用するように変更されているか、URL Rendezvous Directory(URD)によって SSM に対応していない限り)SSM 範囲内でアドレスを使用しようとする場合に既存の IP マルチキャスト レシーバ アプリケーションはトラフィックを受信しません。

SSM 処理

IP マルチキャスト サービスが PIM-SM に基づいている確立されたネットワークは SSM サービスをサポートできます。SSM は、SSM サービスのみが必要な場合、ドメイン間の PIM-SM に必要なプロトコルがすべて揃っていないネットワークで単独で配備することもできます(たとえば、MSDP、Auto-RP、または Bootstrap Router(BSR; ブートストラップ ルータ))。

SSM がすでに PIM-SM 用に設定済みのネットワークで配備されている場合(Cisco IOS Release 12.0 以降のリリースを推奨)、ラスト ホップ ルータのみを SSM をサポートする Cisco IOS ソフトウェア イメージにアップグレードする必要があります。レシーバに直接接続されていないルータを SSM をサポートする Cisco IOS ソフトウェア イメージにアップグレードする必要はありません。一般的に、これらのラスト ホップではないルータは、SSM 範囲で PIM-SM のみを実行する必要があり、MSDP シグナリング、登録、または PIM-SM 共有ツリー動作が SSM 範囲内で発生することを抑制するために、追加のアクセス制御設定を必要とする場合もあります。

SSM モードの動作は、 ip pim ssm グローバル コンフィギュレーション コマンドを使用して SSM 範囲を設定することによってイネーブルにできます。この設定には、次のような効果があります。

SSM 範囲内のグループの場合、(S, G) チャネル加入は IGMPv3 INCLUDE モード メンバシップ レポート、IGMP v3lite、または URD によって受け入れられます(これらの各方法はインターフェイスごとに設定する必要があります)。SSM 範囲外のグループの IGMP v3lite および URD (S, G) チャネル加入は無視されます。

IGMP v3lite と URD は既存のアプリケーション IGMP グループ メンバシップの活用とそれぞれの (S, G) チャネル加入メカニズムによる拡張に基づいています。これは、SSM 範囲外のアドレスの Cisco IOS ソフトウェアには無視されます。SSM 範囲内で IGMP バージョン 1(IGMPv1)またはバージョン 2(IGMPv2)グループ メンバシップ レポートまたは IGMPv3 EXCLUDE モード メンバシップ レポートは、URD または IGMP v3lite の (S, G) 固有のメンバシップ レポートとのみ連動します。

SSM 範囲のアドレス内の PIM 動作は、PIM-SM から派生したモードである PIM-SSM に変更されます。このモードでは、PIM (S, G) 加入およびプルーニング メッセージのみがルータによって生成され、(S, G) Rendezvous Point Tree(RPT; ランデブー ポイント ツリー)または (*, G) RPT メッセージは生成されません。RPT 動作に関連した着信メッセージは無視されるか、拒否され、着信 PIM 登録メッセージは登録停止メッセージによってただちに応答されます。PIM-SSM は、ルータがラスト ホップ ルータでない限り PIM-SM と下位互換性があります。このため、ラスト ホップ ルータでないルータは、SSM グループに対して PIM-SM を実行できます(たとえば、まだ SSM をサポートしていない場合)。

SSM 範囲内の MSDP Source-Active(SA)メッセージは受け入れ、生成、または転送されません。

IGMPv3 ホスト シグナリング

IGMPv3 は、ホストがマルチキャスト グループのラスト ホップ ルータにメンバシップを伝える IETF 標準トラック プロトコルの第 3 バージョンです。IGMPv3 は、ソースに関するフィルタリング機能によって、グループ メンバシップを伝える能力をホストに与えます。ホストは、特定のソースを除いて、グループに送信するすべてのソースからトラフィックを受信したい(EXCLUDE と呼ばれるモード)、またはグループに送信する特定のソースからのみトラフィックを受信したい(INCLUDE と呼ばれるモード)と伝えることができます。

IGMPv3 は ISM と SSM の両方で動作できます。ISM では、EXCLUDE モードと INCLUDE モードの両方のレポートが適用できます。SSM では、INCLUDE モード レポートのみがラスト ホップ ルータによって受け入れられます。EXCLUDE モード レポートは無視されます。

IGMPv3 の詳細については、このマニュアルの「Configuring IP Multicast Routing」の章を参照してください。

IGMP v3lite ホスト シグナリング

IGMP v3lite は、SSM アプリケーションのプログラミングをただちに開始できるよう、シスコが開発したアプリケーション開発者のための移行ソリューションです。これによって、オペレーティング システム カーネルで IGMPv3 をサポートしていないホストで SSM アプリケーションを記述し、実行できます。

IGMP v3lite の場合、アプリケーションは Host Side IGMP Library(HSIL)でコンパイルする必要があります。このソフトウェアは、SSM アプリケーションの記述に必要な IGMPv3 Application Programming Interface(API; アプリケーション プログラミング インターフェイス)のサブセットをアプリケーションに提供します。HSIL は Talarian によってシスコ用に開発され、次の Web ページで入手できます。

http://www.talarianmulticast.com/cgi-bin/igmpdownld

HSIL の一部は SSM アプリケーションにリンクしたクライアント ライブラリです。これは、IGMPv3 API の SSM サブセットを SSM アプリケーションに与えます。可能な場合は、オペレーティング システム カーネルが IGMPv3 をサポートしているかどうかをライブラリがチェックします。サポートしている場合、API コールはそのままカーネルに渡されます。カーネルが IGMPv3 をサポートしていない場合、ライブラリは IGMP v3lite メカニズムを使用します。

IGMP v3lite メカニズムを使用している場合、ライブラリはオペレーティング システム カーネルにマルチキャスト グループ全体に参加するよう呼びかけます。これは、(オペレーティング システム カーネルが IGMPv1 または IGMPv2 しかサポートしていない場合)グループ全体に参加することが、アプリケーションがそのマルチキャスト グループのトラフィックを受信する唯一の方法であるためです。さらに、ライブラリは IGMP v3lite サーバ プロセスに (S, G) チャネル加入を伝えます。これは HSIL の一部でもあります。複数の SSM アプリケーションが同じホスト上にある場合があるため、サーバ プロセスが必要です。このサーバ プロセスは、その後、IGMP v3lite 固有の (S, G) チャネル加入をラスト ホップ Cisco IOS ルータに送ります。これは、IGMP v3lite 用にイネーブルにする必要があります。この Cisco IOS ルータはオペレーティング システム カーネルから IGMPv1 または IGMPv2 グループ メンバシップ レポートを参照し、HSIL デーモンから (S, G) チャネル加入も参照します。ルータが両方のメッセージを参照すると、これらを SSM (S, G) チャネル加入と解釈して、PIM-SSM によってチャネルに参加します。お使いのアプリケーションでの IGMP v3lite の使用方法の詳細については、HSIL ソフトウェアに付属のマニュアルを参照することを推奨します。

IGMP v3lite は、HSIL から独立したルータの機能としてではなく、HSIL による API を使用してのみシスコにサポートされています。デフォルトでは、IGMP v3lite はディセーブルです。IGMP v3lite がインターフェイス上で ip igmp v3lite インターフェイス コンフィギュレーション コマンドによって設定されている場合、SSM 範囲の IP マルチキャスト アドレスに対してのみアクティブになります。

URD ホスト シグナリング

URD はシスコが開発した移行ソリューションで、アプリケーションを変更したり、アプリケーションを実行しているレシーバ ホスト上のソフトウェアを変更または追加することなく、既存の IP マルチキャスト レシーバ アプリケーションを SSM と共に使用できます。URD は、Web ブラウザからレシーバ アプリケーションを開始したり制御できるコンテンツ プロバイダー ソリューションです。

URD は、特殊な URL を Web ブラウザからラスト ホップ ルータに渡すことで機能します。この URL は、URD インターセプト URL と呼ばれます。URD インターセプト URL は、(S, G) チャネル加入で符号化され、ラスト ホップ ルータが簡単に代行受信できる形式になっています。

アプリケーションがマルチキャスト グループ G のメンバシップを維持する限り、ラスト ホップ ルータが URD インターセプト URL で符号化された (S, G) チャネル加入を代行受信し、レシーバ アプリケーションから同じマルチキャスト グループの IGMP グループ メンバシップ レポートを参照するとただちに、ラスト ホップ ルータが PIM-SSM を使用して (S, G) チャネルに参加します。URD インターセプト URL は、当初、参加のためにソースのアドレスをラスト ホップ ルータに提供するためにのみ必要です。

URD インターセプト URL には次の構文があります。

http://webserver:465/path?group=group&source=source1&...source=sourceN&
 

webserver ストリングは、URL がターゲットとする名前または IP アドレスです。Web サーバがラスト ホップ ルータが URD メカニズムをサポートできないことを認識したい場合以外は、このターゲットは既存の Web サーバの IP アドレスである必要はありません。465 という番号は URD ポートを示します。ポート 465 は URD メカニズムのために IANA によって Cisco 用に確保されています。このため、他のアプリケーションはこのポートを使用できません。

ホストのブラウザが URD インターセプト URL を検出すると、ポート 465 上で Web サーバへの TCP 接続を開こうとします。ルータがホストから TCP パケットを受信するインターフェイスで URD 用にラスト ホップ ルータがイネーブルの場合、(Web サーバのアドレスとは関係のない)TCP 接続の実際の宛先アドレスから独立したポート 465 への TCP 接続のすべてのパケットを代行受信します。一度代行受信されると、ラスト ホップ ルータがこの TCP 接続で HTTP の非常に単純なサブセットを伝え、Web サーバをエミュレートします。ラスト ホップ ルータが理解し応答する唯一の HTTP 要求は、次の GET 要求です。

GET argument HTTP/1.0
argument = /path?group=group&source=source1&...source=sourceN&
 

GET コマンドを受信すると、ルータはこの構文に従って引数を解析し、1 つまたは複数の (S, G) チャネル メンバシップを取得しようとします。引数の path ストリングは、最初の疑問符を含まない、最初の疑問符までで、無視されます。 group source1 から sourceN までのストリングは、この引数が加入要求であるチャネルの IP アドレスまたは完全修飾ドメイン名です。引数が表示された構文に一致する場合、ルータは( source1 group )から( sourceN group )チャネルに加入する引数を解釈します。

次の条件が満たされると、ルータはチャネル加入を受け入れます。

マルチキャスト グループの IP アドレスは SSM 範囲内です。

TCP 接続の元となるホストの IP アドレスは、ルータに直接接続されます。

チャネル加入が受け入れられると、ルータは次の HTML ページ形式で TCP 接続に応答します。

HTTP/1.1 200 OK
Server:cisco IOS
Content-Type:text/html
<html>
<body>
Retrieved URL string successfully
</body>
</html>
 

エラー状態が発生すると、返信 HTML ページの <body> 部分が適切なエラー メッセージを表示します。HTML ページは URD メカニズムの副産物です。URD インターセプト URL を表示する Web ページの設計方法に応じて、この返信テキストはユーザに表示されるか、実際の返信 HTML ページが表示されないようにサイズが決定されます。

URD メカニズムの主な影響は、ルータが受信したチャネル加入を記憶し、ホストによって受信された IGMP グループ メンバシップ レポートと一致させます。ルータは、IGMP グループ メンバシップ レポートと一致させずに、URD (S, G) チャネル加入を 3 分まで記憶します。ルータがマルチキャスト グループ G の IGMP グループ メンバシップ レポートと同じグループ G の URD (S, G) チャネル加入の両方を受信したことを確認するとすぐ、PIM-SSM を介して (S, G) チャネルに参加します。ルータは、ホストからの継続中の IGMP メンバシップの存在のみに基づいて (S, G) チャネルへの参加を続けます。このため、当初の URD チャネル加入は、URD で SSM をイネーブルにするために Web ページ経由で唯一追加される必要があります。

レシーバ ホストからのラスト ホップ ルータが URD に対してイネーブルでない場合、ポート 465 の Web サーバへの HTTP 接続は代行受信されません。この状態が Web サーバ上でポート 465 への TCP 接続を引き起こします。Web サーバ上でさらにプロビジョニングが行われない場合、URD インターセプト URL を表示するための Web ページ内のエリアに(Web ページがこの出力を表示するよう設計されている場合)通知(「Connection refused」など)が表示される場合があります。ポート 465 で Web サーバに要求を「リッスン」させ、Web サーバがチャネル加入が失敗したかどうかを知る(たとえば、後でより複雑なエラー説明をユーザに返信する)ことができる Common Gateway Interface(CGI; コモン ゲートウェイ インターフェイス)スクリプトをインストールすることもできます。

ルータはテキストと HTML のコンテンツタイプを返すため、URD インターセプト URL を Web ページに含める最善の方法は、フレームを使用する方法です。フレームのサイズを定義することによって、表示されているページで URD インターセプト URL を非表示にすることもできます。

デフォルトでは、URD はすべてのインターフェイスでディセーブルです。URD がインターフェイス上で ip urd インターフェイス コンフィギュレーション コマンドによって設定されている場合、SSM 範囲の IP マルチキャスト アドレスに対してのみアクティブになります。

利点

IP マルチキャスト アドレス管理は不要

ISM サービスで、トラフィック ディストリビューションは使用する IP マルチキャスト グループ アドレスにのみ基づくため、アプリケーションは一意の IP マルチキャスト グループ アドレスを取得する必要があります。異なるソースとレシーバを持つ 2 つのアプリケーションが同じ IP マルチキャスト グループ アドレスを使用すると、両方のアプリケーションのレシーバが両方のアプリケーションのソースからトラフィックを受信します。適切にプログラムしている場合、レシーバは不要なトラフィックをフィルタできますが、この状態は一般的に許容できないレベルの不要なトラフィックを生み出します。

アプリケーションへの一意の IP マルチキャスト グループ アドレスの割り当ては問題となります。最も短期のアプリケーションは Session Description Protocol(SDP; セッション記述プロトコル)や Session Announcement Protocol(SAP; セッション通知プロトコル)のようなメカニズムを使用して、ランダム アドレスを取得します。これは、インターネット内のアプリケーションの増加によってうまく機能しないソリューションです。長期アプリケーションの現在のベスト ソリューションは、RFC 2770 に説明されていますが、このソリューションは各自律システムが 255 の使用可能な IP マルチキャスト アドレスのみに限定される制限の影響を受けます。

SSM で、他のソースからのトラフィックとは関係なく、各ソースからのトラフィックはネットワーク内のルータ間で転送されます。このため、異なるソースが SSM 範囲のマルチキャスト グループ アドレスを再使用できます。

阻止された望ましくないソースからのサービス拒絶(DoS)攻撃

SSM で、個別の各ソースからのマルチキャスト トラフィックは、(IGMPv3、IGMP v3lite、または URD メンバシップによって)レシーバから要求された場合にのみネットワーク中に転送されます。これに対し、ISM はマルチキャスト グループに送信するアクティブなソースからそのマルチキャスト グループを要求するすべてのレシーバにトラフィックを転送します。インターネット ブロードキャスト アプリケーションで、トラフィックを同じマルチキャスト グループにただ送信するだけで、望ましくないソースが実際のインターネット ブロードキャスト ソースを簡単に妨害できるため、この ISM の動作は非常に望ましくありません。この状況は、レシーバ側で不要なトラフィックによって帯域幅を消耗させるため、インターネット ブロードキャストの無停止の受信を妨害します。SSM では、トラフィックをマルチキャスト グループにただ送信するだけでは、このような種類の DoS 攻撃は行えません。

簡単なインストールと管理

ネットワークがマルチキャスト グループに送信しているアクティブ ソースについての情報を維持する必要がないため、SSM は簡単にインストールし、ネットワークでプロビジョニングできます。この要件は、(IGMPv1、IGMPv2、または IGMPv3 を使用する)ISM でのみ存在します。

ISM サービスの現在の標準ソリューションは PIM-SM と MSDP です。PIM-SM(Auto-RP または BSR の必要性を含む)および MSDP での Rendezvous Point(RP; ランデブー ポイント)管理は、ネットワークがアクティブ ソースについて学習するためにのみ必要です。この管理は SSM では必要ありません。このため、SSM は ISM よりインストールや管理が簡単で、配備での動作面の拡張も ISM より簡単です。SSM のインストールが簡単であるその他の要素は、既存の PIM-SM ネットワークを活用でき、ラスト ホップ ルータをアップグレードするだけで IGMPv3、IGMP v3lite、または URD をサポートできる点です。

インターネット ブロードキャスト アプリケーションに理想的

上記の 3 つの利点により、次の理由で SSM はインターネット ブロードキャスト スタイルのアプリケーションに理想的です。

一意の IP マルチキャスト アドレスなしで SSM によって、インターネット ブロードキャスト サービスを提供できるため、コンテンツ プロバイダーはサービスを簡単に提供できます(コンテンツ プロバイダーにとって、IP マルチキャスト アドレス割り当てはこれまで深刻な問題でした)。

インターネット ブロードキャスト サービスは多数のレシーバに公開されることにより、DoS 攻撃の最も一般的な対象となるため、このような攻撃の阻止はインターネット ブロードキャスト サービスの重要な要素です。

SSM はインストールや動作が簡単なため、特に、コンテンツを複数の独立した PIM ドメイン間で転送する必要のある場合(SSM のために PIM ドメイン間で MSDP を管理する必要がないため)、ネットワーク オペレータにとって理想的です。

制約事項

SSM 範囲内のレガシー アプリケーションの制約

SSM 以前のネットワーク内の既存のアプリケーションは、(S, G) チャネル加入をサポートするように変更されているか、URD によってイネーブルになっていない限り SSM 範囲内で動作しません。このため、ネットワーク内で SSM をイネーブルにすると、既存のアプリケーションが指定された SSM 範囲内のアドレスを使用している場合、問題が生じる場合があります。

IGMP v3lite および URD には Cisco IOS ラスト ホップ ルータが必要

SSM と IGMPv3 は、IETF で標準化されたソリューションです。しかし、IGMP v3lite と URD はシスコが開発したソリューションです。ホストの GMP v3lite と URD が正しく動作するには、そのホスト方向のラスト ホップ ルータが IGMP v3lite または URD がイネーブルになった Cisco IOS ルータである必要があります。


) ホストが IGMPv3 のカーネル サポートを備えている場合、HSIL は IGMP v3lite の代わりにカーネル IGMPv3 を使用するため、この制約は HSIL を使用しているアプリケーションには適用されません。


アドレス管理の制約事項

SSM がレイヤ 2 スイッチング メカニズムで使用される場合でも、アドレス管理はある程度必要です。Cisco Group Management Protocol(CGMP)、IGMP スヌーピング、または Router-Port Group Management Protocol(RGMP)は現在、(S, G) チャネル固有のフィルタリングではなく、グループ固有のフィルタリングのみをサポートしています。スイッチド ネットワークの別のレシーバが、同じグループを共有している別の (S, G) チャネルを要求すると、これらの既存のメカニズムの利点は活用できません。代わりに、両方のレシーバが (S, G) チャネル トラフィックをすべて受信し(入力で不要なトラフィックをフィルタリングし)ます。SSM は SSM 範囲内のグループ アドレスを多くの独立アプリケーションのために再使用できるため、この状況により、スイッチド ネットワークでトラフィック フィルタリングが予想を下回る可能性があります。このため、SSM 範囲内で異なるアプリケーションが同じアドレスを再使用する可能性を最小限に抑えるため、アプリケーションの ために SSM 範囲内のランダム IP アドレスを使用するには、SSM のための IETF ドラフトに明記された推奨事項に従うことが重要です。たとえば、一連のテレビのチャネルを提供するアプリケーション サービスは、SSM を使用する場合でも、各テレビ (S, G) チャネルに別のグループを使用する必要があります。この設定によって、同じアプリケーション サービス内の異なるチャネルの複数のレシーバがレイヤ 2 スイッチを含むネットワーク内でトラフィックのエイリアスを経験することがなくなります。

IGMP スヌーピングと CGMP の制限事項

IGMPv3 は、古い IGMP スヌーピング スイッチに正しく認識されない可能性のある新しいメンバシップ レポート メッセージを使用します。この場合、ホストがトラフックを正しく受信しません。IGMP v3lite と URD は IGMPv1 または IGMPv2 メンバシップ レポートのみに依存するため、この状況は、URD または IGMP v3lite がオペレーティング システムが IGMPv3 用にアップグレードされていないホストで使用されている場合は問題ではありません。IGMP(特に CGMP)に関するスイッチングの問題の詳細については、このマニュアルの「Configuring IP Multicast Routing」の章の「Configuring IGMP Version 3」のセクションを参照してください。

URD インターセプト URL の制約事項

URD インターセプト URL ストリングは長さが 256 バイト未満で、 / path 引数から始まる必要があります。HTTP/TCP 接続で、このストリングは単一の TCP/IP パケット内に含まれている必要もあります。たとえば、256 バイト ストリングの場合、ホストと代行受信ルータ間のリンクの Maximum Transmission Unit(MTU; 最大伝送ユニット)が 128 バイトであると、URD の動作が不正確になる場合があります。

状態維持の制約事項

PIM-SSM で、適切な (S, G) 加入がインターフェイス上にある場合、ラスト ホップ ルータは (S, G)加入メッセージを定期的に送り続けます。このため、レシーバが (S, G) 加入を送信する限り、ソースが長時間(または二度と)トラフィックを送信しなくてもレシーバからソースへの Shortest Path Tree(SPT; 最短パス ツリー)状態が維持されます。

これは、PIM-SM の場合と異なります。PIM-SM の場合、(S, G) 状態はソースがトラフィックを送信し、レシーバがグループに参加している場合にのみ維持されます。PIM-SM でソースがトラフィックの送信を 3 分以上停止すると、(S, G) 状態が削除され、ソースからのパケットが RPT によって再び到着するまで再確立されません。PIM-SSM のメカニズムはレシーバにソースがアクティブであると通知しないため、レシーバがそのチャネルの受信を要求する限り、ネットワークは PIM-SSM で (S, G) 状態を維持する必要があります。

HSIL の制限事項

「IGMP v3lite ホスト シグナリング」で説明したように、HSIL はホスト オペレーティング システムが IGMPv3 をサポートするかどうかを判断しようとします。このチェックは、オペレーティング システムが IGMPv3 にアップグレードされているホストとオペレーティング システムが IGMPv1 または IGMPv2 のみをサポートするホストの両方で単一のアプリケーションが使用できるように行われます。HSIL が提供された時点でこのオペレーティング システムの少なくとも 1 つのバージョンに対して IGMPv3 カーネル サポートが存在する場合、ホスト オペレーティング システムでの IGMPv3 のアベイラビリティのチェックは、HSIL でのみ実行できます。このような IGMPv3 カーネル実装が最近まで使用できなかった場合、HSIL でコンパイルされたアプリケーションが動的に最新バージョンの HSIL にバインドされるように、ユーザはホストで HSIL もアップグレードする必要のある場合があります。最新バージョンの HSIL は、オペレーティング システム カーネルで IGMPv3 のチェックをサポートしています。HSIL のアップグレードは、アプリケーション自体のアップグレードとは別に実行できます。

SSM 設定作業リスト

SSM を設定するには、以降の項で説明する作業を実行します。最初の項の作業は必須ですが、残りの項の作業は任意です。

SSM の設定(必須)

SSM のモニタリング(任意)

SSM の設定

SSM を設定するには、グローバル コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

ステップ 1

Router(config)# ip pim ssm [ default | range access-list ]

IP マルチキャスト アドレスの SSM 範囲を定義します。

ステップ 2

Router(config)# interface type number

IGMPv3、IGMP v3lite、および URD をイネーブルにできるホストに接続されているインターフェイスを選択します。

ステップ 3

Router(config-if)# ip pim { sparse-mode | sparse-dense-mode }

インターフェイスに対して PIM をイネーブルにします。スパース モードまたはスパース-デンス モードを使用する必要があります。

ステップ 4

Router(config-if)# ip igmp version 3

 

 

または

Router(config-if)# ip igmp v3lite

 

 

または

Router(config-if)# ip urd

このインターフェイス上で IGMPv3 をイネーブルにします。IGMP のデフォルト バージョンはバージョン 2 に設定されます。

または

インターフェイスで IGMP v3lite メンバシップ レポートの受け入れと処理をイネーブルにします。

または

インターフェイスで確保された URD ポート 465 に送信された TCP パケットの代行受信と URD チャネル加入レポートの処理をイネーブルにします。

SSM のモニタリング

SSM をモニタリングするには、必要に応じて特権 EXEC モードで次のコマンドを使用します。

 

コマンド
目的

Router# show ip igmp groups detail

IGMPv3、IGMP v3lite、または URD で (S, G) チャネル加入を表示します。

Router# show ip mroute

マルチキャスト グループが SSM サービスをサポートするかどうかと、ソース固有のホスト レポートが受信されたかどうかを表示します。

SSM の設定例

ここでは、次の SSM の設定例について詳しく説明します。

IGMPv3 を使用した SSM の例

IGMP v3lite と URD を使用した SSM の例

SSM フィルタリング例

IGMPv3 を使用した SSM の例

次の例は、SSM 用に(IGMPv3 を実行する)ルータ を設定する方法を示しています。

ip multicast-routing
!
interface Ethernet3/1
ip address 172.21.200.203 255.255.255.0
description backbone interface
ip pim sparse-dense-mode
!
interface Ethernet3/2
ip address 131.108.1.2 255.255.255.0
ip pim sparse-dense-mode
description ethernet connected to hosts
ip igmp version 3
!
ip pim ssm default

IGMP v3lite と URD を使用した SSM の例

次の例は、SSM 用にホストに接続されたインターフェイス上で IGMP v3lite と URD を設定する方法を示しています。IGMP v3lite と URD の設定は、バックボーン インターフェイスでは必須でも推奨事項でもありません。

interface ethernet 3/1
ip address 172.21.200.203 255.255.255.0
ip pim sparse-dense-mode
description ethernet connected to hosts
!
interface ethernet 1
description ethernet connected to hosts
ip address 131.108.1.2 255.255.255.0
ip pim sparse-dense-mode
ip urd
ip igmp v3lite

SSM フィルタリング例

次の例は、SSM ルーティングのために Release 12.1(3)T 以前の Cisco IOS リリースを実行しているレガシー RP ルータでフィルタリングを設定する方法を示しています。このフィルタリングは SSM 範囲で不要な PIM-SM および MSDP トラフィックをすべて抑制します。このフィルタリングがなくても SSM は動作しますが、レガシーのファースト ホップ ルータとラスト ホップ ルータがネットワークに存在する場合、追加の RPT トラフィックがある場合があります。

ip access-list extended no-ssm-range
deny ip any 232.0.0.0 0.255.255.255 ! SSM range
permit ip any any
! Deny registering in SSM range
ip pim accept-register list no-ssm-range
 
ip access-list extended msdp-nono-list
deny ip any 232.0.0.0 0.255.255.255 ! SSM Range
! .
! .
! .
! See ftp://ftpeng.cisco.com/ipmulticast/config-notes/msdp-sa-filter.txt for other SA
! messages that typically need to be filtered.
permit ip any any
 
! Filter generated SA messages in SSM range. This configuration is only needed if there
! are directly connected sources to this router. The “ip pim accept-register” command
! filters remote sources.
ip msdp redistribute list msdp-nono-list
 
! Filter received SA messages in SSM range. “Filtered on receipt” means messages are
! neither processed or forwarded. Needs to be configured for each MSDP peer.
ip msdp sa-filter in msdp-peer1 list msdp-nono-list
! .
! .
! .
ip msdp sa-filter in msdp-peerN list msdp-nono-list