IP マルチキャスト コンフィギュレーション ガイド、 Cisco IOS Release 15.1S
マルチキャスト VPN Inter-AS サポートの 設定
マルチキャスト VPN Inter-AS サポートの設定
発行日;2012/02/01 | 英語版ドキュメント(2011/04/17 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 8MB) | フィードバック

目次

マルチキャスト VPN Inter-AS サポートの設定

この章の構成

マルチキャスト VPN Inter-AS サポートの設定に関する前提条件

マルチキャスト VPN Inter-AS サポートの設定に関する制約事項

マルチキャスト VPN Inter-AS サポートに関する情報

MVPN Inter-AS サポートの概要

MVPN Inter-AS サポートの利点

MVPN Inter-AS サポートの実装要件

マルチキャスト VPN Inter-AS サポートの導入前にオプション B とオプション C のサポートを妨げた制限事項

オプション A の MVPN Inter-AS サポート

オプション B および C の MVPN Inter-AS サポート ソリューション

BGP コネクタ アトリビュート

MVPN Inter-AS サポートのための BGP MDT SAFI アップデート

PIM RPF ベクトル

オプション B での MVPN の AS 間 MDT の確立

オプション C での MVPN の AS 間 MDT の確立

マルチキャスト VPN Inter-AS サポートの設定方法

マルチキャスト VPN Inter-AS サポートでの BGP の MDT アドレス ファミリの設定

サポートされているポリシー

MVPN Inter-AS サポートの PE ルータでの MDT アドレス ファミリ セッションの設定に関するガイドライン

前提条件

制約事項

BGP の IPv4 MDT セッションに関する情報の表示

BGP の IPv4 MDT ピアリング セッションのクリア

BGP MDT アップデートを送信して MVPN Inter-AS サポートのデフォルト MDT を作成する PE ルータの設定(オプション B)

BGP MDT アップデートを送信して MVPN Inter-AS サポートのデフォルト MDT を作成する PE ルータの設定(オプション C)

オプション B とオプション C の導入における AS 間 MDT の確立の確認

マルチキャスト VPN Inter-AS サポートの設定例

マルチキャスト VPN Inter-AS サポートでの IPv4 MDT アドレス ファミリ セッションの設定:例

BGP MDT アップデートを送信して MVPN Inter-AS サポートのデフォルト MDT を作成する PE ルータの設定(オプション B):例

BGP MDT アップデートを送信して MVPN Inter-AS サポートのデフォルト MDT を作成する PE ルータの設定(オプション C):例

バックツーバック ASBR PE の設定(オプション A):例

ASBR 間での VPNv4 ルートの直接交換の設定(オプション B):例

マルチホップ MP-EBGP ピアリング セッションを使用した RR 間の VPNv4 ルートの交換の設定(オプション C):例

その他の参考資料

関連資料

規格

MIB

RFC

シスコのテクニカル サポート

コマンド リファレンス

マルチキャスト VPN Inter-AS サポートの設定に関する機能情報

マルチキャスト VPN Inter-AS サポートの設定

マルチキャスト VPN Inter-AS サポート機能を使用すると、Multicast VPN(MVPN; マルチキャスト VPN)で使用される Multicast Distribution Tree(MDT; マルチキャスト配信ツリー)を複数の自律システムに分散できます。この利点としては、RFC 4364 に記載されたすべてのオプションをサポートするための柔軟性を持たせながら、Multiprotocol Label Switching(MPLS; マルチプロトコル ラベル スイッチング)レイヤ 3 Virtual Private Network(VPN; バーチャル プライベート ネットワーク)サービスにおいてマルチキャストが複数のサービス プロバイダーにわたる必要がある顧客にとって、マルチキャストのカバレッジが向上することがあります。また、企業の合併または買収で見られるように、マルチキャスト VPN Inter-AS サポート機能を使用して既存の MVPN サービスを他の MVPN サービスに統合できます。

この章で紹介する機能情報の入手方法

ご使用の Cisco OS ソフトウェア リリースでは、このモジュールで説明されるすべての機能がサポートされているとは限りません。最新の機能情報および警告については、ご使用のプラットフォームおよびソフトウェア リリースのリリースノートを参照してください。このモジュールで説明される特定機能に関する情報へのリンク、および各機能がサポートされるリリースの一覧については、「マルチキャスト VPN Inter-AS サポートの設定に関する機能情報」を参照してください。

プラットフォームと Cisco IOS および Catalyst OS ソフトウェア イメージのサポート情報の検索

Cisco Feature Navigator を使用すると、プラットフォーム、Cisco IOS ソフトウェア イメージ、および Cisco Catalyst OS ソフトウェア イメージの各サポート情報を検索できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。

マルチキャスト VPN Inter-AS サポートの設定に関する前提条件

IP マルチキャストの概念および設定作業を熟知している。

MVPN の概念および設定作業を熟知している。

Border Gateway Protocol(BGP; ボーダー ゲートウェイ プロトコル)の概念および設定作業を熟知している。

Multiprotocol Label Switching(MPLS; マルチプロトコル ラベル スイッチング)レイヤ 3 VPN の概念および設定作業を熟知している。

マルチキャスト VPN Inter-AS サポートの設定に関する制約事項

マルチキャスト VPN Inter-AS サポート機能では、コア内のすべてのルータで Protocol Independent Multicast(PIM)Source Specific Multicast(SSM)を設定する必要があります。Protocol Independent Multicast Sparse Mode(PIM-SM; スパース モード)および Bidirectional PIM(Bidir-PIM; 双方向 PIM)はサポートされていません。

マルチキャスト VPN Inter-AS サポートに関する情報

マルチキャスト VPN Inter-AS サポート機能を設定するには、次の概念を理解しておく必要があります。

「MVPN Inter-AS サポートの概要」

「MVPN Inter-AS サポートの利点」

「MVPN Inter-AS サポートの実装要件」

「オプション B および C の MVPN Inter-AS サポート ソリューション」

「オプション B での MVPN の AS 間 MDT の確立」

「オプション C での MVPN の AS 間 MDT の確立」

MVPN Inter-AS サポートの概要

一般的な概念として、MVPN Inter-AS サポートによって、サービス プロバイダーは、複数の自律システムにまたがる VPN サイトにマルチキャスト接続を提供できます。次の 2 つのタイプの MVPN Inter-AS 導入シナリオがあります。

シングルプロバイダー方式の Inter-AS:内部ネットワークが複数の自律システムで構成される単一のサービス プロバイダー。

イントラプロバイダー方式の Inter-AS:Inter-AS サポートを提供するためにネットワークの調整が必要な複数のサービス プロバイダー。

マルチキャスト VPN Inter-AS サポート機能のサポートのために追加された拡張機能を使用すると、MVPN に使用される MDT を複数の自律システムに分散できます。

MVPN Inter-AS サポートの利点

MVPN Inter-AS サポート機能は、サービス プロバイダーに次の利点を提供します。

RFC 4364 に記載されたすべてのオプションをサポートするための柔軟性を持たせながら、MPLS レイヤ 3 VPN サービスにおいてマルチキャストが複数のサービス プロバイダーにわたる必要がある顧客にとって、マルチキャストのカバレッジを向上させる。

企業の合併や買収の場合など、既存の MVPN サービスを別の MVPN サービスと統合する。

MVPN Inter-AS サポートの実装要件

マルチキャスト VPN Inter-AS サポート機能は、次の要件に従って、Cisco IOS ソフトウェアに実装されました。

ユニキャスト Inter-AS サポートとのパリティを実現するには、Cisco IOS ソフトウェアは、次の MVPN の Inter-AS オプションをサポートする必要があります(RFC 4364 で定義されている)。

オプション A:Autonomous System Border Router(ASBR; 自律システム境界ルータ)Provider Edge(PE; プロバイダー エッジ)ルータでのバックツーバック VPN Routing and Forwarding(VRF; VPN ルーティングおよび転送)

オプション A モデルは、異なる自律システムの PE ルータ間の直接の接続を想定しています。PE ルータは複数の物理または論理インターフェイスによって接続され、各インターフェイスは特定の VPN に関連しています(VRF インスタンスを通して)。したがって、各 PE ルータは、隣接 PE ルータを Customer Edge(CE; カスタマー エッジ)ルータのように処理し、標準レイヤ 3 MPLS VPN メカニズムは、各自律システムによる経路再配布に使用されます。つまり、PE は、外部 BGP(eBGP)を使用して、ラベルのない IPv4 アドレスを互いに配布します。


) オプション A では、サービス プロバイダーは、各自律システムを他の自律システムから分離できるため、2 つのネットワーク間でのルーティング交換とセキュリティをさらに適切に制御できます。ただし、オプション A は、すべての AS 間接続オプションで最もスケーラブルでないオプションと考えられています。


オプション B:ASBR 間の VPNv4 ルート交換

オプション B モデルでは、PE ルータは、内部 BGP(iBGP)を使用して、ラベルの付いた VPNv4 ルータを ASBR または ASBR がクライアントの Route Reflector(RR; ルート リフレクタ)に再配布します。ASBR は、マルチプロトコル eBGP(MP-eBGP)を使用して、VPNv4 ルートをローカル自律システムにアドバタイズします。

MP-eBGP は、VPNv4 プレフィクスおよびラベルの情報をサービス プロバイダーの境界を越えてアドバタイズする機能を提供します。アドバタイジング ASBR ルータは、VPNv4 ルータをアドバタイズする前に、2 レベル ラベル スタック(ローカル自律システム内の発信 PE ルータと VPN 宛先に到達するために使用する)をローカルに割り当てられたラベルに交換します。2 つのサービス プロバイダーの間でアドバタイズされるすべてのルートのネクスト ホップ アトリビュートは、ASBR ルータのピアリング アドレスにリセットされ、ASBR ルータはアドバタイズされたルートの Label-Switched Path(LSP; ラベル スイッチド パス)の終端地点になるので、この交換は必要です。入力および出力 PE ルータ間の LSP を保存するには、ASBR ルータは、ローカル VPN ネットワーク内のルートのラベル スタックを識別するために使用されるローカル ラベルを割り当てる必要があります。この新しく割り当てられたラベルは、隣接サービス プロバイダーからプレフィクスに送信されるパケットに設定されます。


) オプション B では、サービス プロバイダーは、オプション A よりも高度に変更できるという利点が追加された両方の自律システムを隔離できます。


オプション C:マルチホップ eBGP ピアリング セッションを使用した RR 間の VPNv4 ルートの交換

オプション C モデルでは、異なる自律システムの RR 間での VPNv4 ルートの MP-eBGP 交換を、対応する ASBR ルータ間で交換されるこれらのルートのネクスト ホップと組み合わせます。オプション C モデルでは、VPNv4 ルートは、ASBR によって維持されず、配布されません。ASBR は、自律システム内の PE ルータへのラベル付き IPv4 /32 ルートを維持し、eBGP を使用して、これらのルートを他の自律システムに配布する必要があります。また、中継自律システム内の ASBR は、eBGP を使用して、ラベル付き /32 ルートを伝送する必要があります。これによって、入力 PE ルータから出力 PE ルータに LSP が作成されます。

異なる自律システムの RR は直接接続されないので、MP-eBGP ピアリング セッションを確立するには、マルチホップ機能が必要です。RR はトラフィックをアドバタイズする宛先に引き寄せないために、隣接自律システムにアドバタイズする際に、VPNv4 ルートのネクスト ホップ アトリビュートをリセットしないので、ネクスト ホップの交換が必要です。これらは元のエンドポイントではなく、ソース PE とレシーバ PE の間の単なるリレー ステーションです。このため、VPNv4 の PE ルータ ネクスト ホップ アドレスは、ASBR ルータ間で交換されます。自律システム間のこれらのアドレスの交換は、自律システム間に PE ルータ /32 アドレスを再配布するか、BGP ラベル配布を使用することによって行うことができます。


) オプション C は、通常、世界の異なる地域に自律システムがあるグローバル レイヤ 3 MPLS VPN サービス プロバイダーなど、各自律システムが同じ全体的管轄に属している場合に限り導入されます。オプション B はこの目的に同様に適しており、異なる地域間での自律が望ましいネットワークにおいても導入されます。


シスコのソフトウェアは、AS 間 MDT をサポートする必要があります。AS 間 MDT は、自律システムの境界を越えて拡張される MDT です。MVPN のコンテキストでは、MVPN パケットは ASBR 間を転送中にカプセル化されるので、自律システムの境界を越えて MDT を拡張するには、AS 間 MDT が必要です(オプション B と オプション C の場合)。

マルチキャスト VPN Inter-AS サポートの導入前にオプション B とオプション C のサポートを妨げた制限事項

マルチキャスト VPN Inter-AS サポート機能に関連した拡張機能が導入される前、オプション B とオプション C での MVPN Inter-AS サポートを妨げる制限事項が存在していました。これらの制限事項は、次の領域に関連していました。

AS 間ソースでの Reverse Path Forwarding(RPF; リバース パス転送)のサポート(主にオプション B に適用可能)。

PE ルータがデフォルト MDT の PIM 加入(ソース PE アドレス、MDT グループ アドレス)を送信する場合、ソース PE ルータと宛先 PE ルータの間のパスにある各 P ルータは、ソースで RPF チェックを行う必要があります。Interior Gateway Protocol(IGP)ルート(リモート自律システムにあるソース PE ルータへのルートを含む)は、自律システムを越えてリークされないため、受信側の自律システムにある P ルータは、RPF チェックを実行できませんでした。

PIM 加入が MVPN で受信されると、VRF で IP ルックアップが行われ、宛先へのネクスト ホップが検索されます。この宛先は、MDT トンネル インターフェイスを通して到達できる PIM ネイバーである必要があります。ただし、ASBR は特定の MDT グループの発信 PE ルータのネクスト ホップを変更するため、ソース アドレスが失われ、PE ルータでの RPF チェックは失敗します。


) 一般的なオプション C の Inter-AS の導入では、RR がすべての VPNv4 ルートを保存するため、MVPN Inter-AS サポートのための RPF のサポートに関連した制限事項は適用できませんでした。


AS 間 MDT のサポート(オプション B とオプション C に適用可能)

デフォルト MDT は、デフォルト マルチキャスト グループに加入するために、PE ルータの機能に依存します。グループのソースは、MP-BGP ピアリングで使用される発信 PE ルータ アドレスです。マルチキャスト VPN Inter-AS サポート機能に関連した拡張機能が導入される前、IGP ルートが自律システムを越えて配布できなかったため、このアドレスは、自律システム間で到達できませんでした。このため、AS 間 MVPN のデフォルト MDT を確立できませんでした。

オプション A の MVPN Inter-AS サポート

MVPN Inter-AS サポートのオプション B および C のサポートを妨げた制限事項は、次の理由で、オプション A に適用されたことはありませんでした。

オプション A では、ネイティブ IP の転送は、自律システム間の PE ルータで使用されます。したがって、オプション A では、AS 間 MDT のサポートは必要ありません。

オプション A では、MDT は 1 つの自律システムに限定されます。したがって、自律システム間の MDT グループ アドレスおよび AS 間ソースの RPF の管理に関連する問題は、オプション A には適用されませんでした。


) オプション A では、各 VRF に 1 つの物理または論理インターフェイスを設定する必要があるため、オプション A は、最もスケーラブルでない MVPN Inter-AS ソリューションと考えられています。


オプション B および C の MVPN Inter-AS サポート ソリューション

MVPN Inter-AS サポート機能に関連して導入された次の拡張機能は、オプション B および C の導入における RPF と AS 間 MDT のサポートに関連する MVPN Inter-AS プロトコルの制限事項を解決します。

MP-BGP での BGP コネクタ アトリビュート:このアトリビュートは、VPNv4 プレフィクスを発信する PE ルータの識別情報の保存に役立ちます。この BGP 拡張機能は、リモート自律システム内のソースへの RPF をサポートするチャレンジの解決に役立ちます。

BGP MDT Subaddress Family Identifier(SAFI):この識別情報は、リモート自律システム内のソース PE への ASBR の RPF に役立ちます。また、BGP MDT SAFI は、ASBR およびレシーバ PE がリモート自律システム内のソース PE への AS 間 MDT を作成するために必要な RPF ベクトルを挿入するためにも役立ちます。

PIM RPF ベクトル:PIM RPF ベクトル機能は、P ルータがリモート自律システム内のソース PE への AS 間 MDT を作成するのに役立ちます。

BGP コネクタ アトリビュート

隣接する自律システムでは、特定の MVPN のデフォルト MDT の特定のソースに加入する PE ルータは、ソース PE ルータのソースのアドレスを認識している必要があります。VPNv4 ルートのソース ネクスト ホップは、ネットワークの 1 つまたは複数のポイントで書き換えられるため、これはオプション B の Inter-AS 導入における課題です。この制限事項を解決するには、各 VPNv4 ルートは、ルートのソースを定義する新しいアトリビュート(BGP コネクタ アトリビュート)を持っている必要があります。

BGP コネクタ アトリビュートは、VPNv4 プレフィクスを発信した PE ルータを保存する推移的なアトリビュートです。ローカル自律システムでは、BGP コネクタ アトリビュートは、ネクスト ホップ アトリビュートと同じです。VPNv4 アドバタイズメントの他の ASBR にアドバタイズされると(オプション B の場合のように)、BGP コネクタ アトリビュートの値は、ネクスト ホップ アトリビュートが ASBR によって書き換えられた後も保存されます。BGP コネクタ アトリビュートは、MVPN Inter-AS ソリューションの重要なコンポーネントで、リモート自律システム内のソースへの RPF をイネーブルにできます。


) また、BGP コネクタ アトリビュートは、ASBR およびレシーバ PE がリモート自律システム内のソース PE への AS 間 MDT を作成するために必要な RPF ベクトルを挿入するためにも役立ちます。RPF ベクトルの詳細については、「PIM RPF ベクトル」を参照してください。


図 1に、BGP コネクタ アトリビュートの形式を示します。

図 1 BGP コネクタ アトリビュート

 

MVPN Inter-AS サポートのための BGP MDT SAFI アップデート

BGP MDT SAFI は、PIM 加入に含まれる MDT グループに送信する必要があるソース PE ルータのアドレスを送信するように特別に設計されています。この SAFI で送信される Network Layer Reachability Information(NLRI; ネットワーク レイヤ到着可能性情報)の形式は、{RD:PE-IP-address} です。BGP MDT SAFI は、自律システムの境界を越えてアドバタイズできます。各 MDT グループは、図 2 に示す形式を使用して、MP_REACH アトリビュートで送信されます。

図 2 MDT SAFI 形式

 

RR および MP-eBGP ピアリングを使用する場合、BGP MDT SAFI のアドバタイズメントは、VPNv4 ルートのアドバタイズメントから独立しています。ただし、BGP MDT SAFI は、VPNv4 アドバタイズメントと同様に処理され、フィルタリングされます。

ASBR は、別のテーブルの BGP MDP SAFI アップデートにアドバタイズされたパスを保存します。BGP MDT SAFI をアドバタイズする方法によって、アドバタイズメントを発信した PE ルータへの RPF パスが決定されます。

また、PE は BGP MDT SAFI アップデートを別のテーブルにも保存します。PE ルータは、BGP MDT SAFI に含まれる情報を使用して、隣接する自律システム内のソース PE ルータへの出口ルータとなる ASBR を決定します。

PIM RPF ベクトル

通常、MVPN 環境では、PIM は、特定の MDP グループのソースであるアップストリーム PE ルータの IP アドレスを含む加入メッセージを送信します。ただし、RPF チェックを実行できるようにするには、P ルータには、リモート自律システム内のソース PE ルータへの IPv4 到達可能性がなければなりません。自律システムは、ローカル PE ルータのものも含めて、IGP ルートを交換しないので、この動作は Inter-AS のオプション B および C には適用されません。しかし、P ルータには、PE ルータでの BGP MDT SAFI アップデートで受信された BGP MDT アップデートの BGP ネクスト ホップへの到達可能性があります。したがって、PE ルータが PIM 加入内にリモート PE ルータ IP アドレス(BGP MDT SAFI 内で受信される)とこのアドレスの BGP ネクスト ホップ アドレスを追加した場合、P ルータは、元の PE ルータ アドレスではなく、BGP ネクスト ホップ アドレスで RPF チェックを行い、リモート自律システムの MDT SAFI アップデートを導入した ASBR に加入を転送できるようになります。この機能は、一般的に PIM RPF ベクトル と呼ばれ、PIM 加入に挿入される実際のベクトルは、 RPF ベクトル または プロキシ ベクトル と呼ばれます。したがって、PIM RPF ベクトルを使用すると、P ルータは、リモート自律システム内のソース PE ルータへの出口 ASBR を決定できます。RPF ベクトルを含む加入を受信すると、ASBR は、ネクスト ホップ アドレスが実はそれ自身であり、PIM 加入で送信される発信 PE ルータ アドレスに基づいて、RPF チェックを実行できることを判断できるようになります。

ip multicast rpf proxy vector コマンドを使用して、PE ルータに設定されると、RPF ベクトルは、PIM 加入内の送信アドレスとプルーニング メッセージの一部として符号化されます。RPF ベクトルは、PIM 加入およびプルーニング メッセージ内の PIM RPF ネイバーの IGP ネクスト ホップで、一般的に、リモート自律システム内のプレフィクスへの出口 ASBR ルータです。

図 3に、PIM 加入およびプルーニング メッセージ内のこの PIM RPF ベクトルの符号化の形式を示します。

図 3 PIM 加入およびプルーニング メッセージで符号化された PIM RPF ベクトル

 


) RPF ベクトルは、IP 環境(非 VPN 環境)でネイティブに使用できます。ネイティブ環境での RPF ベクトルの使用は、この章の範囲には含まれません。ネイティブ環境での RPF ベクトルの使用に関する詳細については、RFC 5496、『The Reverse Path Forwarding (RPF) Vector TLV』を参照してください。


RPF ベクトルのソース

PE ルータが RPF ベクトルを発信するかどうかは、設定によって決定されます。つまり、RPF ベクトルを発信するには、すべての PE ルータで ip multicast rpf proxy vector コマンドを設定する必要があります。RPF ベクトルを発信する PE ルータは、常にソースで RPF ルックアップを行います。PE ルータがソースで RPF ルックアップを行うと、PE ルータは、次のいずれかの方法で、RPF ベクトルの発信元を学習します。

MVPN ネットワーク環境では、RPF ベクトルは BGP MDT SAFI アップデートから学習されます。

ネイティブ IP ネットワーク環境では、RPF ベクトルは、IP ユニキャスト ルーティング(AFI=1、SAFI=1)と IP マルチキャスト リバース パス情報(AFI=1、SAFI=2)のいずれかから学習されます。


) ネイティブ IP ネットワーク環境での RPF ベクトルの使用は、この章の範囲には含まれません。ネイティブ環境での RPF ベクトルの使用に関する詳細については、RFC 5496、『The Reverse Path Forwarding (RPF) Vector TLV』を参照してください。



) RPF ベクトル形式を認識するルータは、PIM ハロー メッセージで RPF ベクトルをアドバタイズします。


RPF ベクトルの受信先

ルータが RPF ベクトルを含む PIM 加入を受信すると、そのルータは、出口 ASBR ルータへの PIM 加入を生成できるように、RPF ベクトルを保存します。P ルータは、PIM 加入から RPF ベクトルを学習します。RPF ベクトルは、コアのすべての P ルータにアドバタイズされます。ルータが複数の RPF ベクトルを受信した場合、最も低いソース アドレスを持つ RPF ベクトルが使用されます。RPF ベクトルが存在する場合、その RPF ベクトルが優先されます。その結果、RPF チェックは、RPF ベクトルのアップストリームを定期的に再アドバタイズするようにトリガーされます。ルータがローカル インターフェイス(一般的に ASBR)を参照する RPF ベクトルを受信した場合、RPF ベクトルは廃棄され、通常の RPF ルックアップが行われます。

RPF ベクトルの ASBR での受信

ASBR が RPF ベクトルを受信すると、一般的にローカル インターフェイス(ループバック インターフェイスである可能性が最も高い)を参照します。この場合、RPF ベクトルは廃棄され、通常の RPF ルックアップが行われます。RD タイプが 2 の場合、ASBR は、BGP MDT SAFI アップデートから作成される BGP MDT テーブルで、RPF ルックアップ を行います。このタイプの RPF ルックアップは、PIM 加入に含まれる RD とソース PE アドレスの両方を使用します。

RPF ベクトルとの相互運用性

アップストリーム ルータが新しい符号化を解析できるかどうかを判断するために、PIM RPF ベクトル拡張機能とともに、新しい PIM ハロー オプションが導入されます。RPF ベクトルは、RPF インターフェイス上のすべての PIM ネイバーがサポートしている場合に限り、PIM メッセージに含まれます。

オプション B での MVPN の AS 間 MDT の確立

ここでは、Inter-AS のオプション B のトポロジ例での自律システム間の AS 間 MDT の確立に至る一連のイベントについて説明します(図 4 を参照)。このトポロジでは、すべてのルータがマルチキャスト VPN Inter-AS サポート機能に関連するすべての拡張機能を適切にサポートするように設定されていることを想定しています。

図 4 MVPN Inter-AS サポート オプション B のトポロジ例

 

次の一連のイベントが発生し、この AS 間の MVPN のオプション B トポロジにおける PE1B で、MDT デフォルト ツリーを確立します。

1. 図 5 に示すように、PE1B は、それ自身(PE1B)をネクスト ホップとして BGP MDT SAFI を使用して、VPN blue にデフォルト MDT の情報をアドバタイズします。

図 5 PE1B から ASBR1B への BGP アップデート

 

2. 図 6 に示すように、ASBR1B は MDT SAFI 情報を受信し、それ自身(ASBR1B)をネクスト ホップとして、この情報を ASBR1A にアドバタイズします。

図 6 ASBR1B から ASBR1A への BGP アップデート

 

3. 図 7 に示すように、ASBR1A は、それ自身(ASBR1A)をネクスト ホップとして、MDT SAFI を PE1A にアドバタイズします。

図 7 ASBR1A から PE1A への BGP アップデート

 

4. 図 8 に示すように、PE1A は、BGP MDT SAFI アップデートからソース PE ルータ、RD、およびデフォルト MDT グループ アドレスを学習します。さらに、同じ BGP MDT SAFI アップデートから、PE1A は、RPF ベクトル ASBR1A がソース PE1B RD 55:1111 への出口ルータであることを学習します。PE1A は、IGP を通して、P1A が RPF ネイバーであることを学習します。PE1A は、RPF ベクトルを PIM 加入に挿入し、ソース PE1B に宛てられた PIM 加入を P1A に送信します。

図 8 PE1A から P1A への SSM デフォルト PIM 加入

 

5. 図 9 に示すように、ソース PE1B は P1A では到達可能ではありませんが、RPF ベクトル ASBR1A は到達可能で、ネクスト ホップは ASBR1A(コアで実行される IGP から学習される)です。P1A は PIM 加入を ASBR1A に転送します。

図 9 P1A から ASBR1A への SSM デフォルト MDT PIM 加入

 

6. 図 10 に示すように、RPF ベクトル ASBR1A は、P1A から ASBR1A に送信される PIM 加入に含まれています。ASBR1A が RPF ベクトルを受信すると、RPF ベクトルが RD 55:1111 のソース PE1B の出口ルータであることを学習します。ソース PE1B は ASBR1A では到達可能ではありませんが、ソース PE1B、RD 55:1111、およびグループ 232.1.1.1 は、BGP MDT SAFI アップデートから学習されます。RPF ネイバー P1A は、ASBR1A(RPF ベクトルとして挿入される)に到達するネクスト ホップとして、コアで実行される IGP から学習されます。ASBR1A は、ソース PE1B の PIM 加入を ASBR1B に転送します。

図 10 ASBR1A から ASBR1B への SSM デフォルト MDT PIM 加入

 

7. 図 11 に示すように、ソース PE1B は、AS65 で実行される IGP を通して、ASBR1B で到達可能です。ASBR1B は、PE1B をネクスト ホップとして使用して、PIM 加入をソース PE1B に転送します。この時点では、PE1B にある MDT デフォルト グループ 232.1.1.1 の SSM ツリーのセットアップは完了しています。このため、PE1B にある SSM MDT デフォルト グループは、確立されています。PE1A および PE2A にある MDT デフォルト グループの SSM ツリーは、同じ手順に従います。

図 11 ASBR1B から PE1B への SSM デフォルト MDT PIM 加入

 

オプション C での MVPN の AS 間 MDT の確立

ここでは、Inter-AS のオプション C のトポロジ例での自律システム間の AS 間 MDT の確立に至る一連のイベントについて説明します(図 12 を参照)。このトポロジでは、すべてのルータがマルチキャスト VPN Inter-AS サポート機能に関連するすべての機能を適切にサポートするように設定されていることを想定しています。

図 12 MVPN Inter-AS サポート オプション C のトポロジ例

 

次の一連のイベントが発生し、この AS 間の MVPN のオプション C トポロジにおける PE1B で、MDT デフォルト ツリーを確立します。

1. 図 13 に示すように、PE1B は、VPN blue のデフォルト MDT 情報を BGP MDT SAFI 内の RR1B にアドバタイズします。

図 13 PE1B から RR1B への BGP MDT SAFI アップデート

 

2. 図 14 に示すように、RR1B は MDT SAFI 情報を受信し、この情報を RR1A にアドバタイズします。

図 14 RR1B から RR1A への BGP MDT SAFI アップデート

 

3. 図 15 に示すように、RR1A は MDT SAFI 情報を受信し、この情報を PE1A にアドバタイズします。

図 15 RR1A から PE1A への BGP MDT SAFI アップデート

 

4. 図 16 に示すように、PE1A は、ASBR1A を RD 55:1111 とデフォルト MDT 232.1.1.1 を持つソース PE1B に到達する出口ルータとして識別するプロキシ ベクトルを使用して、PIM 加入を送信します。プロキシ ベクトルは、P1A と P2A に、PE1B に到達するルートがない場合に PE1B に到達する方法についてのヒントを提供します。ソース PE1B は、PE1A での BGP IPv4 学習アップデートによる RPF ネイバー P1A を通して到達可能です。

図 16 PE1A から P1A へのプロキシ ベクトルによるデフォルト MDT の PIM SSM 加入

 

5. 図 17 に示すように、P1A は PE1B に到達する方法を知りません。しかし、PE1A から送信されるプロキシ ベクトルを持つ PIM 加入は、ASBR1A を RD 55:1111 とデフォルト MDT 232.1.1.1 を持つソース PE1B に到達する出口ルータとして識別します。P1A はプロキシ ベクトルを使用して PE1B に到達します。ASBR1A に到達する RPF ネイバーは、P2A を通ります。このため、P1A は PIM SSM 加入を P2A に転送します。

図 17 P1A から P2A へのプロキシ ベクトルによるデフォルト MDT の PIM SSM 加入

 

6. 図 18 に示すように、P2A は PE1B に到達する方法を知りません。しかし、P1A から送信されるプロキシ ベクトルを持つ PIM 加入は、ASBR1A を RD 55:1111 とデフォルト MDT 232.1.1.1 を持つソース PE1B に到達する出口ルータとして識別します。P2A はプロキシ ベクトル ASBR1A を使用して PE1B に到達します。ASBR1B に到達する RPF ネイバー は、ASBR1A(それ自身)を通ります。

図 18 P2A から ASBR1A へのプロキシ ベクトルによるデフォルト MDT の PIM SSM 加入

 

7. 図 19 に示すように、ASBR1A は、P2A からプロキシ ベクトルを持つ PIM 加入を受信します。ASBR1A は、プロキシ ベクトルがそれ自身であり、ASBR1B の RPF ネイバーを持つ PE1B に通常の PIM 加入を送信することを認識します。PIM 加入は、標準 PIM 手順に従って、最終的に PE1B に到達するまで、SSM デフォルト MDT のホップバイホップ ビルディングを継続します。

図 19 ASBR1A から PE1B へのプロキシ ベクトルによるデフォルト MDT の PIM SSM 加入

 

マルチキャスト VPN Inter-AS サポートの設定方法

ここでは、次の作業について説明します。

「マルチキャスト VPN Inter-AS サポートでの BGP の MDT アドレス ファミリの設定」(必須)

「BGP の IPv4 MDT セッションに関する情報の表示」(任意)

「BGP の IPv4 MDT ピアリング セッションのクリア」(任意)

「BGP MDT アップデートを送信して MVPN Inter-AS サポートのデフォルト MDT を作成する PE ルータの設定(オプション B)」(必須)

「BGP MDT アップデートを送信して MVPN Inter-AS サポートのデフォルト MDT を作成する PE ルータの設定(オプション C)」(必須)

「オプション B とオプション C の導入における AS 間 MDT の確立の確認」(任意)

マルチキャスト VPN Inter-AS サポートでの BGP の MDT アドレス ファミリの設定

PE ルータに MDT アドレス ファミリ セッションを設定し、MVPN の MDT ピアリング セッションを確立するには、次の作業を実行します。MDT アドレス ファミリ セッションを設定するために、 mdt キーワードが address-family ipv4 コマンドに追加されました。

サポートされているポリシー

BGP MDT SAFI では、次のポリシー設定パラメータがサポートされています。

AS パス、Multi-Exit Discriminator(MED)、BGP ローカル プレファレンスなどの必須アトリビュートや周知のアトリビュート、およびネクスト ホップ アトリビュート

標準コミュニティ、コミュニティ リスト、およびルート マップ

MVPN Inter-AS サポートの PE ルータでの MDT アドレス ファミリ セッションの設定に関するガイドライン

MVPN Inter-AS サポートにルータを設定する場合は、次の注意事項に従ってください。

MVPN Inter-AS オプション A では、ネイティブ IP の転送が PE ルータによって使用されるため、BGP MDT アドレス ファミリ ピアリング セッションは、PE ルータ間で必要ありません。オプション A では、BGP MDT ピアリング セッションは、AS 内 VPN ピアリング セッションに限り必要です。

MVPN Inter-AS のオプション B では、BGP MDT アドレス ファミリ ピアリング セッションは、PE と ASBR の間に限り必要です。PE ルータが iBGP を使用して、ASBR がクライアントである RR にラベル付き VPNv4 を再配布するオプション B の Inter-AS の場合、BGP MDT アドレス ファミリ ピアリング セッションは、PE、ASBR、および RR の間で必要です。

MVPN Inter-AS のオプション C では、BGP MDT アドレス ファミリ ピアリング セッションは、PE と RR の間に限り必要です。

前提条件

MDT アドレス ファミリを通して AS 間の VPN ピアリングを確立する前に、CE ルータに VPN サービスを提供する PE ルータ上の BGP ネットワークおよびマルチプロトコル BGP に、MPLS および Cisco Express Forwarding(CEF; シスコ エクスプレス フォワーディング)を設定する必要があります。

制約事項

次のポリシー設定パラメータは、サポートされていません。

ルートオリジネータ アトリビュート

Network Layer Reachability Information(NLRI; ネットワーク レイヤ到着可能性情報)プレフィクス フィルタリング(プレフィクス リスト、配信リスト)

拡張コミュニティ アトリビュート(ルート ターゲットおよび発信元サイト)

手順の概要

1. enable

2. configure terminal

3. router bgp as-number

4. address-family ipv4 mdt

5. neighbor neighbor-address activate

6. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router bgp as-number

 

Router(config)# router bgp 65535

ルータ コンフィギュレーション モードを開始し、BGP ルーティング プロセスを作成します。

ステップ 4

address-family ipv4 mdt

 

Router(config-router)# address-family ipv4 mdt

アドレス ファミリ コンフィギュレーションを開始し、IP MDT アドレス ファミリ セッションを作成します。

ステップ 5

neighbor neighbor-address activate

 

Router(config-router-af)# neighbor 192.168.1.1 activate

このネイバーの MDT アドレス ファミリをイネーブルにします。

ステップ 6

end

 

Router(config-router-af)# end

アドレス ファミリ コンフィギュレーション モードを終了し、特権 EXEC モードを開始します。

BGP の IPv4 MDT セッションに関する情報の表示

BGP の IPv4 MDT セッションに関する情報を表示するには、次のオプションの作業を実行します。

手順の概要

1. enable

2. show ip bgp ipv4 mdt { all | rd | vrf }

手順の詳細


ステップ 1 enable

このコマンドを使用して、特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

Router> enable
 

ステップ 2 show ip bgp ipv4 mdt { all | rd | vrf vrf-name }

このコマンドを使用して、IPv4 BGP ルーティング テーブルの IPv4 MDT セッションを表示します。

次に、 all キーワードがある show ip bgp ipv4 mdt コマンドの出力例を示します。

Router# show ip bgp ipv4 mdt all
 
BGP table version is 2, local router ID is 10.1.0.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
 
Network Next Hop Metric LocPrf Weight Path
Route Distinguisher: 55:1111 (default for vrf blue)
*> 10.5.5.5/32 10.1.0.1 55 0 23 24 25 54 ?
* 10.9.9.9/32 0.0.0.0 0 ?


 

BGP の IPv4 MDT ピアリング セッションのクリア

さまざまな形式の clear ip bgp コマンドのいずれかで mdt キーワードを使用して、IPv4 MDT アドレス ファミリ セッションをリセットするには、次のオプションの作業を実行します。 clear ip bgp コマンドで使用できる一部のキーワードが複雑であるため、一部のキーワードは、別のコマンドとして説明します。

手順の概要

1. enable

2. clear ip bgp ipv4 mdt as-number [ in [ prefix-filter ]] [ out ] [ soft [ in [ prefix-filter ] | out ]]
または
clear ip bgp ipv4 mdt peer-group peer-group-name [ in [ prefix-filter ]] [ out ] [ soft [ in [ prefix-filter ] | out ]]
または
clear ip bgp ipv4 mdt update-group [ index-group | neighbor-address ]

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

clear ip bgp ipv4 mdt as-number [ in [ prefix-filter ]] [ out ] [ soft [ in [ prefix-filter ] | out ]]

または

clear ip bgp ipv4 mdt peer-group peer-group-name [ in [ prefix-filter ]] [ out ] [ soft [ in [ prefix-filter ] | out ]]

または

clear ip bgp ipv4 mdt update-group [ index-group | neighbor-address ]

 

Router# clear ip bgp ipv4 mdt 65700

または

Router# clear ip bgp ipv4 mdt peer-group test soft in

または

Router# clear ip bgp ipv4 mdt update-group 3

(任意)IPv4 MDT アドレス ファミリ セッションをリセットします。

as-number 引数とともに clear ip bgp ipv4 mdt コマンドを指定すると、指定された自律システムに関連する IPv4 MDT アドレス ファミリ セッションをリセットします。

この形式の clear ip bgp ipv4 mdt コマンドの例は、65700 という番号が付いた自律システム内のすべての IPv4 MDT アドレス ファミリ セッションのハード リセットを開始する方法を示します。

または

peer-group キーワードとともに clear ip bgp ipv4 mdt コマンドを指定すると、BGP ピア グループのすべてのメンバの IPv4 MDT アドレス ファミリ セッションをリセットします。

この形式の clear ip bgp ipv4 mdt コマンドの例は、ピア グループ テストのメンバを持つインバウンド MDT アドレス ファミリ セッションのソフト リセットを開始する方法を示します。アウトバウンド セッションは影響を受けません。

または

update-group キーワードとともに clear ip bgp ipv4 mdt コマンドを指定すると、BGP アップデート グループのすべてのメンバの IPv4 MDT アドレス ファミリ セッションをリセットします。

この形式の clear ip bgp ipv4 mdt コマンドの例は、アップデート グループ 3 のすべてのメンバをリセットする方法を示します。

BGP MDT アップデートを送信して MVPN Inter-AS サポートのデフォルト MDT を作成する PE ルータの設定(オプション B)

オプション B 導入での PE ルータが BGP MDT アップデートを送信して、MVPN Inter-AS サポートのデフォルト MDT を作成するために必要な拡張機能(BGP コネクタ アトリビュート、BGP MDT SAFI、および RPF ベクトル)をサポートするように設定するには、次の作業を実行します。

手順の概要

1. enable

2. configure terminal

3. ip multicast vrf vrf-name rpf proxy rd vector

4. router bgp as-number

5. neighbor ip-address remote-as as-number

6. address - family ipv4 mdt

7. neighbor neighbor - address activate

8. neighbor neighbor-address next-hop-self

9. exit

10. address-family vpnv4

11. neighbor neighbor-address activate

12. neighbor neighbor - address send - community extended

13. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip multicast vrf vrf-name rpf proxy rd vector

 

Router(config)# ip multicast vrf blue rpf proxy rd vector

特定の VPN の出口ルータで、RPF ベクトルをイネーブルにします。

rd キーワードを使用して、PIM 加入とプルーニング メッセージに挿入された PIM RPF ベクトル符号化に関連する VPN の RD 値を含むように、PE ルータを設定します。オプション B 導入の ASBR は、特定の MDT グループの発信 PE ルータのネクスト ホップを変更するため、PIM RPF ベクトルの符号化に RD 値を含めると、ASBR は RD 値でプレフィクスのルックアップを実行できるようになり、RPF ベクトルが意図されている VPN を識別できるようになります。

キーワードは、MVPN Inter-AS サポート オプション C の導入には必要ありません。

ステップ 4

router bgp as-number

 

Router(config)# router bgp 101

特定のルーティング プロセスのルータ コンフィギュレーション モードを開始します。

ステップ 5

neighbor ip-address remote-as as-number

 

Router(config-router)# neighbor 192.168.1.1 remote-as 45000

ローカル ルータの IPv4 マルチプロトコル BGP ネイバー テーブルに、指定された自律システム内のネイバーの IP アドレスを追加します。

ステップ 6

address-family ipv4 mdt

 

Router(config-router)# address-family ipv4 mdt

アドレス ファミリ コンフィギュレーションを開始し、IPv4 MDT アドレス ファミリ セッションを作成します。

ステップ 7

neighbor neighbor-address activate

 

Router(config-router-af)# neighbor 192.168.1.1 activate

このネイバーの MDT アドレス ファミリをイネーブルにします。

ステップ 8

neighbor neighbor-address next-hop-self

 

Router(config-router-af)# neighbor 192.168.1.1 next-hop-self

ルータの BGP アップデートのネクスト ホップ処理をディセーブルにします。

ステップ 9

exit

 

Router(config-router-af)# exit

アドレス ファミリ コンフィギュレーション モードを終了し、ルータ コンフィギュレーション モードに戻ります。

ステップ 10

address-family vpnv4

 

Router(config-router)# address-family vpnv4

アドレス ファミリ コンフィギュレーション モードを開始し、VPNv4 アドレス ファミリ セッションを作成します。

ステップ 11

neighbor neighbor-address activate

 

Router(config-router-af)# neighbor 192.168.1.1 activate

このネイバーの VPNv4 アドレス ファミリをイネーブルにします。

ステップ 12

neighbor neighbor-address send-community extended

 

Router(config-router-af)# neighbor 192.168.1.1 send-community extended

このネイバーに送信する標準および拡張コミュニティ アトリビュートをイネーブルにします。

ステップ 13

end

 

Router(config-router-af)# end

アドレス ファミリ コンフィギュレーション モードを終了し、特権 EXEC モードに戻ります。

BGP MDT アップデートを送信して MVPN Inter-AS サポートのデフォルト MDT を作成する PE ルータの設定(オプション C)

オプション B 導入での PE ルータが BGP MDT アップデートを送信して、MVPN Inter-AS サポートのデフォルト MDT を作成するために必要な拡張機能(BGP コネクタ アトリビュート、BGP MDT SAFI、および RPF ベクトル)をサポートするように設定するには、次の作業を実行します。

手順の概要

1. enable

2. configure terminal

3. ip multicast rpf proxy vector

4. router bgp as-number

5. neighbor ip-address remote-as as-number

6. address - family ipv4 mdt

7. neighbor neighbor - address activate

8. neighbor neighbor - address send - community extended

9. exit

10. address-family vpnv4

11. neighbor neighbor - address activate

12. neighbor neighbor - address send - community extended

13. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip multicast rpf proxy vector

 

Router(config)# ip multicast rpf proxy vector

出口ルータで、RPF ベクトルをイネーブルにします。

異なる自律システムの PE 間で IGP の到達可能性がない場合、このステップを行います。

ステップ 4

router bgp as-number

 

Router(config)# router bgp 101

特定のルーティング プロセスのルータ コンフィギュレーション モードを開始します。

ステップ 5

neighbor ip-address remote-as as-number

 

Router(config-router)# neighbor 192.168.1.1 remote-as 45000

ローカル ルータの IPv4 マルチプロトコル BGP ネイバー テーブルに、指定された自律システム内のネイバーの IP アドレスを追加します。

ステップ 6

address-family ipv4 mdt

 

Router(config-router)# address-family ipv4 mdt

アドレス ファミリ コンフィギュレーションを開始し、IPv4 MDT アドレス ファミリ セッションを作成します。

ステップ 7

neighbor neighbor-address activate

 

Router(config-router-af)# neighbor 192.168.1.1 activate

このネイバーの MDT アドレス ファミリをイネーブルにします。

ステップ 8

neighbor neighbor-address send-community extended

 

Router(config-router-af)# neighbor 192.168.1.1 send-community extended

このネイバーに送信する標準および拡張コミュニティ アトリビュートをイネーブルにします。

ステップ 9

exit

 

Router(config-router-af)# exit

アドレス ファミリ コンフィギュレーション モードを終了し、ルータ コンフィギュレーション モードに戻ります。

ステップ 10

address-family vpnv4

 

Router(config-router)# address-family vpnv4

アドレス ファミリ コンフィギュレーション モードを開始し、VPNv4 アドレス ファミリ セッションを作成します。

ステップ 11

neighbor neighbor-address activate

 

Router(config-router-af)# neighbor 192.168.1.1 activate

このネイバーの VPNv4 アドレス ファミリをイネーブルにします。

ステップ 12

neighbor neighbor-address send-community extended

 

Router(config-router-af)# neighbor 192.168.1.1 send-community extended

このネイバーに送信する標準および拡張コミュニティ アトリビュートをイネーブルにします。

ステップ 13

end

 

Router(config-router-af)# end

アドレス ファミリ コンフィギュレーション モードを終了し、特権 EXEC モードに戻ります。

オプション B とオプション C の導入における AS 間 MDT の確立の確認

オプション B とオプション C の MVPN Inter-AS 導入での AS 間 MDT の確立を確認するには、次のオプションの作業を実行します。


) このオプションの作業では、各ステップを任意の順序で実行できます。この作業のすべてのステップは任意です。


手順の概要

1. enable

2. show ip mroute proxy

3. show ip pim [ vrf vrf-name ] neighbor [ interface-type interface-number ]

4. show ip rpf [ vrf vrf-name ] { route-distinguisher | source-address [ group-address ] [ rd route-distinguisher ]} [ metric ]

5. show ip pim [ vrf vrf-name ] mdt bgp

手順の詳細


ステップ 1 enable

このコマンドを使用して、特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

Router> enable
 

ステップ 2 show ip mroute proxy

このコマンドを使用して、マルチキャスト ルータで受信される RPF ベクトルに関する情報を表示します。

このコマンドの出力で表示される情報は、RPF ベクトルのプロキシがコア ルータで受信されるかどうかを判断するために使用できます。

次に、 show ip mroute proxy コマンドの出力例を示します。

Router# show ip mroute proxy
 
(192.168.0.8, 232.1.1.1)
Proxy Assigner Origin Uptime/Expire
55:1111/192.168.0.4 10.0.3.1 PIM 00:03:29/00:02:06
55:1111/192.168.0.4 10.0.3.2 PIM 00:17:47/00:02:06
 

ステップ 3 show ip pim [ vrf vrf-name ] neighbor [ interface-type interface-number ]

このコマンドを使用して、PIMv1 ルータ クエリー メッセージまたは PIMv2 ハロー メッセージによって検出された PIM ネイバーを表示します。

P フラグは、ネイバーが PIM 加入メッセージ内の RPF ベクトルを処理する能力を通知した(PIM ハロー メッセージによって)ことを示します。PIM RPF ベクトル機能をサポートするすべての Cisco IOS バージョンは、この PIM ハロー オプションを通知します。RPF ベクトルは、RPF インターフェイス上のすべての PIM ネイバーがサポートしている場合に限り、PIM メッセージに含まれます。

次に、 show ip pim neighbor コマンドの出力例を示します。

Router# show ip pim neighbor
 
PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
S - State Refresh Capable
Neighbor Interface Uptime/Expires Ver DR
Address Prio/Mode
10.0.0.1 GigabitEthernet10/2 00:01:29/00:01:15 v2 1 / S
10.0.0.3 GigabitEthernet10/3 00:01:15/00:01:28 v2 1 / DR S P
 

ステップ 4 show ip rpf [ vrf vrf-name ] { route-distinguisher | source-address [ group-address ] [ rd route-distinguisher ]} [ metric ]

このコマンドを使用して、IP マルチキャスト ルーティングが RPF を行う方法に関する情報を表示します。

次に、 show ip rpf コマンドの出力例を示します。

Router# show ip rpf 10.7.0.7 232.1.1.1 rd 55:1111
 
RPF information for ? (10.7.0.7)
RPF interface: GigabitEthernet2/2
RPF neighbor: ? (10.0.1.3)
RPF route/mask: 10.5.0.5/32
RPF type: unicast (UNKNOWN)
RPF recursion count: 0
Doing distance-preferred lookups across tables
BGP lookup of 55:1111/10.7.0.7 next_hop: 10.5.0.5
PROXY vector: 10.5.0.5
 

ステップ 5 show ip pim [ vrf vrf-name ] mdt bgp

このコマンドを使用して、MDT デフォルト グループの RD の BGP アドバタイズメントに関する情報を表示します。

次に、 show ip pim mdt bgp コマンドの出力例を示します。

Router# show ip pim mdt bgp
 
MDT (Route Distinguisher + IPv4) Router ID Next Hop
MDT group 232.1.1.1
55:1111:192.168.0.2 192.168.0.2 192.168.0.2
55:1111:192.168.0.8 192.168.0.4 192.168.0.4


 

マルチキャスト VPN Inter-AS サポートの設定例

ここでは、次の設定例について説明します。

「マルチキャスト VPN Inter-AS サポートでの IPv4 MDT アドレス ファミリ セッションの設定:例」

「BGP MDT アップデートを送信して MVPN Inter-AS サポートのデフォルト MDT を作成する PE ルータの設定(オプション B):例」

「BGP MDT アップデートを送信して MVPN Inter-AS サポートのデフォルト MDT を作成する PE ルータの設定(オプション C):例」

「バックツーバック ASBR PE の設定(オプション A):例」

「ASBR 間での VPNv4 ルートの直接交換の設定(オプション B):例」

「マルチホップ MP-EBGP ピアリング セッションを使用した RR 間の VPNv4 ルートの交換の設定(オプション C):例」

マルチキャスト VPN Inter-AS サポートでの IPv4 MDT アドレス ファミリ セッションの設定:例

次の例では、10.1.1.2 に BGP ネイバーがある IPv4 MDT アドレス ファミリ セッションをサポートするルータを設定します。

router bgp 1
address-family ipv4 mdt
neighbor 10.1.1.2 activate

BGP MDT アップデートを送信して MVPN Inter-AS サポートのデフォルト MDT を作成する PE ルータの設定(オプション B):例

次の例では、BGP MDT アップデートを送信して、オプション B 導入で MVPN Inter-AS サポートのデフォルト MDT を作成するために必要な拡張機能(BGP コネクタ アトリビュート、BGP MDT SAFI、および RPF ベクトル)をサポートする PE ルータを設定します。この例では、関連する設定だけを示します。

!
ip multicast-routing
ip multicast-routing vrf blue
ip multicast vrf blue rpf proxy rd vector
!
.
.
.
router bgp 55
.
.
.
!
address-family ipv4 mdt
neighbor 192.168.0.2 activate
neighbor 192.168.0.2 next-hop-self
neighbor 192.168.0.4 activate
neighbor 192.168.0.4 next-hop-self
exit-address-family
!
address-family vpnv4
neighbor 192.168.0.2 activate
neighbor 192.168.0.2 send-community extended
neighbor 192.168.0.4 activate
neighbor 192.168.0.4 send-community extended
exit-address-family
!
.
.
.
!
ip pim ssm default
!

BGP MDT アップデートを送信して MVPN Inter-AS サポートのデフォルト MDT を作成する PE ルータの設定(オプション C):例

次の例では、BGP MDT アップデートを送信して、オプション B 導入で MVPN Inter-AS サポートのデフォルト MDT を作成するために必要な拡張機能(BGP コネクタ アトリビュート、BGP MDT SAFI、および RPF ベクトル)をサポートする PE ルータを設定します。この例では、関連する設定だけを示します。

!
ip multicast-routing
ip multicast-routing vrf blue
ip multicast rpf proxy vector
!
.
.
.
!
router bgp 65
.
.
.
!
address-family ipv4
neighbor 10.252.252.10 activate
neighbor 10.252.252.10 send-label
no auto-summary
no synchronization
exit-address-family
!
address-family ipv4 mdt
neighbor 10.252.252.10 activate
neighbor 10.252.252.10 send-community extended
exit-address-family
!
address-family vpnv4
neighbor 10.252.252.10 activate
neighbor 10.252.252.10 send-community extended
exit-address-family
!
.
.
.
!
ip pim ssm default
!

バックツーバック ASBR PE の設定(オプション A):例

次の例では、MVPN Inter-AS サポート オプション A のサポートを設定します。この設定例は、図 20に示す AS 間のネットワーク オプション A のトポロジの例に基づいています。

この設定例では、AS1 内の PE3A は、AS2 内の PE3B に直接接続されています。2 つの PE ルータは、物理インターフェイスによって接続されます。各 VPN(VPN blue と VPN green)に対して 1 つの物理インターフェイスがあり、そのルートは AS1 から AS2 に、または AS2 から AS1 に渡す必要があります。各 PE は、もう 1 つの PE が CE ルータであるかのように処理します。つまり、PE は各インターフェイスを VRF に関連付け、eBGP を使用して、ラベルのない IPv4 アドレスを互いに配布します。Intermediate System-to-Intermediate System(IS-IS)は両方の自律システムの BGP ピアリングに使用されており、Routing Information Protocol(RIP)は、VRF からルートを動的に学習し、これらのルートを VPNv4 ルートとしてリモート PE ルータにアドバタイズするために、CE ルータと向かい合う PE ルータで使用されています。RIP は、eBGP ピアリングを PE3A と PE3B の間にセットアップするために、ASBR 間でも使用されています。


) オプション A では、任意の IGP を使用して、ループバック インターフェイスの IPv4 ルートを交換できます。


図 20 MVPN Inter-AS サポート オプション A 設定例のトポロジ

 

表 1 に、ここで示すオプション A 設定例で使用されるトポロジに関する情報を示します。

 

表 1 MVPN Inter-AS オプション A 設定例のトポロジ情報

PE ルータ
VPN
RD
AS 番号
Loopback0 インターフェイス
デフォルト MDT(PIM-SSM)

PE1A

green

55:1111

1

10.1.1.1/32

232.1.1.1

PE2A

blue

55:1111

1

10.1.1.2/32

232.1.1.1

PE3A

blue/green

55:1111

1

10.1.1.3/32

232.1.1.1

PE1B

green

55:2222

2

10.2.2.1/32

232.2.2.2

PE2B

blue

55:2222

2

10.2.2.2/32

232.2.2.2

PE3B

blue/green

55:2222

2

10.2.2.3/32

232.2.2.2

PE1A

!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname PE1A
!
boot-start-marker
boot-end-marker
!
!
ip subnet-zero
ip cef
no ip domain-lookup
ip vrf green
rd 55:2222
route-target export 55:2222
route-target import 55:2222
mdt default 232.2.2.2
!
ip multicast-routing
ip multicast-routing vrf green
mpls label protocol ldp
!
!
!
interface Loopback0
ip address 10.1.1.1 255.255.255.255
no ip directed-broadcast
ip router isis
ip pim sparse-mode
!
interface Ethernet0/0
ip vrf forwarding green
ip address 172.25.11.1 255.255.255.0
no ip directed-broadcast
ip pim sparse-mode
tag-switching ip
!
interface Ethernet1/0
ip address 172.30.41.1 255.255.255.0
no ip directed-broadcast
ip router isis
ip pim sparse-mode
tag-switching ip
!
router isis
net 49.0000.0000.1111.00
!
router rip
version 2
!
address-family ipv4 vrf green
version 2
network 172.25.0.0
no auto-summary
exit-address-family
!
router bgp 1
no synchronization
bgp log-neighbor-changes
neighbor 10.1.1.2 remote-as 1
neighbor 10.1.1.2 update-source Loopback0
neighbor 10.1.1.3 remote-as 1
neighbor 10.1.1.3 update-source Loopback0
no auto-summary
!
address-family ipv4 mdt
neighbor 10.1.1.2 activate
neighbor 10.1.1.3 activate
exit-address-family
!
address-family vpnv4
neighbor 10.1.1.2 activate
neighbor 10.1.1.2 send-community extended
neighbor 10.1.1.3 activate
neighbor 10.1.1.3 send-community extended
exit-address-family
!
address-family ipv4 vrf green
redistribute rip metric 1
no synchronization
exit-address-family
!
ip classless
!
ip pim ssm default
ip pim vrf green send-rp-announce Ethernet0/0 scope 32
ip pim vrf green send-rp-discovery Ethernet0/0 scope 32
ip pim vrf green register-rate-limit 2
!
!
!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
login
!
no cns aaa enable
end

PE2A

!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname PE2A
!
boot-start-marker
boot-end-marker
!
!
ip subnet-zero
ip cef
no ip domain-lookup
ip vrf blue
rd 55:1111
route-target export 55:1111
route-target import 55:1111
mdt default 232.1.1.1
!
ip multicast-routing
ip multicast-routing vrf blue
mpls label protocol ldp
!
!
!
interface Loopback0
ip address 10.1.1.2 255.255.255.255
no ip directed-broadcast
ip router isis
ip pim sparse-mode
!
interface Ethernet0/0
ip vrf forwarding blue
ip address 172.17.12.2 255.255.255.0
no ip directed-broadcast
ip pim sparse-mode
tag-switching ip
!
interface Ethernet1/0
no ip address
no ip directed-broadcast
shutdown
!
interface Ethernet2/0
ip address 172.19.142.2 255.255.255.0
no ip directed-broadcast
ip router isis
ip pim sparse-mode
tag-switching ip
!
router isis
net 49.0000.0000.2222.00
!
router rip
version 2
!
address-family ipv4 vrf blue
version 2
network 172.17.0.0
no auto-summary
exit-address-family
!
router bgp 1
no synchronization
bgp log-neighbor-changes
neighbor 10.1.1.1 remote-as 1
neighbor 10.1.1.1 update-source Loopback0
neighbor 10.1.1.3 remote-as 1
neighbor 10.1.1.3 update-source Loopback0
no auto-summary
!
address-family ipv4 mdt
neighbor 10.1.1.1 activate
neighbor 10.1.1.3 activate
exit-address-family
!
address-family vpnv4
neighbor 10.1.1.1 activate
neighbor 10.1.1.1 send-community extended
neighbor 10.1.1.3 activate
neighbor 10.1.1.3 send-community extended
exit-address-family
!
address-family ipv4 vrf blue
redistribute rip metric 1
no synchronization
exit-address-family
!
ip classless
!
ip pim ssm default
ip pim vrf blue send-rp-announce Ethernet0/0 scope 32
ip pim vrf blue send-rp-discovery Ethernet0/0 scope 32
ip pim vrf blue ssm default
!
!
!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
login
!
no cns aaa enable
end

PE3A

!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname PE3A
!
boot-start-marker
boot-end-marker
!
!
ip subnet-zero
ip cef
no ip domain-lookup
ip vrf blue
rd 55:1111
route-target export 55:1111
route-target import 55:1111
mdt default 232.1.1.1
!
ip vrf green
rd 55:2222
route-target export 55:2222
route-target import 55:2222
mdt default 232.2.2.2
!
ip multicast-routing
ip multicast-routing vrf blue
ip multicast-routing vrf green
mpls label protocol ldp
!
!
!
interface Loopback0
ip address 10.1.1.3 255.255.255.255
no ip directed-broadcast
ip router isis
ip pim sparse-mode
!
interface Ethernet0/0
no ip address
no ip directed-broadcast
shutdown
!
interface Ethernet1/0
no ip address
no ip directed-broadcast
shutdown
!
interface Ethernet2/0
no ip address
no ip directed-broadcast
shutdown
!
interface Ethernet3/0
ip address 192.168.143.3 255.255.255.0
no ip directed-broadcast
ip router isis
ip pim sparse-mode
tag-switching ip
!
interface Ethernet4/0
ip vrf forwarding blue
ip address 172.20.34.3 255.255.255.0
no ip directed-broadcast
ip pim sparse-dense-mode
tag-switching ip
!
interface Ethernet5/0
ip vrf forwarding green
ip address 172.23.35.3 255.255.255.0
no ip directed-broadcast
ip pim sparse-dense-mode
tag-switching ip
!
router eigrp 1
!
address-family ipv4 vrf blue
network 172.20.0.0
no auto-summary
exit-address-family
!
router isis
net 49.0000.0000.3333.00
!
router rip
version 2
!
address-family ipv4 vrf green
version 2
redistribute bgp 1 metric 2
network 172.23.0.0
no auto-summary
exit-address-family
!
address-family ipv4 vrf blue
version 2
redistribute bgp 1 metric 1
network 172.20.0.0
no auto-summary
exit-address-family
!
router bgp 1
no synchronization
bgp log-neighbor-changes
neighbor 10.1.1.1 remote-as 1
neighbor 10.1.1.1 update-source Loopback0
neighbor 10.1.1.2 remote-as 1
neighbor 10.1.1.2 update-source Loopback0
no auto-summary
!
address-family ipv4 mdt
neighbor 10.1.1.1 activate
neighbor 10.1.1.2 activate
exit-address-family
!
address-family vpnv4
neighbor 10.1.1.1 activate
neighbor 10.1.1.1 send-community extended
neighbor 10.1.1.2 activate
neighbor 10.1.1.2 send-community extended
bgp redistribute-internal
exit-address-family
!
address-family ipv4 vrf green
no synchronization
bgp redistribute-internal
exit-address-family
!
address-family ipv4 vrf blue
redistribute rip
no synchronization
bgp redistribute-internal
exit-address-family
!
ip classless
!
ip pim ssm default
ip pim vrf blue ssm default
!
!
!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
login
!
no cns aaa enable
end

PE3B

!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname PE3B
!
boot-start-marker
boot-end-marker
!
!
ip subnet-zero
ip cef
no ip domain-lookup
ip vrf blue
rd 55:1111
route-target export 55:1111
route-target import 55:1111
mdt default 232.1.1.1
!
ip vrf green
rd 55:2222
route-target export 55:2222
route-target import 55:2222
mdt default 232.2.2.2
!
ip multicast-routing
ip multicast-routing vrf blue
ip multicast-routing vrf green
mpls label protocol ldp
!
!
!
interface Loopback0
ip address 10.2.2.3 255.255.255.255
no ip directed-broadcast
ip router isis
ip pim sparse-mode
!
interface Ethernet0/0
no ip address
no ip directed-broadcast
shutdown
!
interface Ethernet1/0
no ip address
no ip directed-broadcast
shutdown
!
interface Ethernet2/0
no ip address
no ip directed-broadcast
shutdown
!
interface Ethernet3/0
ip address 172.16.43.3 255.255.255.0
no ip directed-broadcast
ip router isis
ip pim sparse-mode
tag-switching ip
!
interface Ethernet4/0
ip vrf forwarding blue
ip address 172.20.34.4 255.255.255.0
no ip directed-broadcast
ip pim sparse-dense-mode
tag-switching ip
!
interface Ethernet5/0
ip vrf forwarding green
ip address 172.23.35.4 255.255.255.0
no ip directed-broadcast
ip pim sparse-dense-mode
tag-switching ip
!
router isis
net 49.0000.0000.3333.00
!
router rip
version 2
!
address-family ipv4 vrf green
version 2
network 172.23.0.0
no auto-summary
exit-address-family
!
address-family ipv4 vrf blue
version 2
network 172.20.0.0
no auto-summary
exit-address-family
!
router bgp 2
no synchronization
bgp log-neighbor-changes
redistribute rip metric 1
neighbor 10.2.2.1 remote-as 2
neighbor 10.2.2.1 update-source Loopback0
neighbor 10.2.2.2 remote-as 2
neighbor 10.2.2.2 update-source Loopback0
no auto-summary
!
address-family ipv4 mdt
neighbor 10.2.2.1 activate
neighbor 10.2.2.2 activate
exit-address-family
!
address-family vpnv4
neighbor 10.2.2.1 activate
neighbor 10.2.2.1 send-community extended
neighbor 10.2.2.2 activate
neighbor 10.2.2.2 send-community extended
exit-address-family
!
address-family ipv4 vrf green
redistribute rip
no synchronization
exit-address-family
!
address-family ipv4 vrf blue
redistribute rip
no synchronization
exit-address-family
!
ip classless
!
ip pim ssm default
ip pim vrf blue ssm default
!
!
!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
login
!
no cns aaa enable
end

PE2B

!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname PE2B
!
boot-start-marker
boot-end-marker
!
!
ip subnet-zero
ip cef
no ip domain-lookup
ip vrf blue
rd 55:1111
route-target export 55:1111
route-target import 55:1111
mdt default 232.1.1.1
!
ip multicast-routing
ip multicast-routing vrf blue
mpls label protocol ldp
!
!
!
interface Loopback0
ip address 10.2.2.2 255.255.255.255
no ip directed-broadcast
ip router isis
ip pim sparse-mode
!
interface Ethernet0/0
ip vrf forwarding blue
ip address 172.18.22.2 255.255.255.0
no ip directed-broadcast
ip pim sparse-mode
tag-switching ip
!
interface Ethernet1/0
no ip address
no ip directed-broadcast
shutdown
!
interface Ethernet2/0
ip address 172.19.42.2 255.255.255.0
no ip directed-broadcast
ip router isis
ip pim sparse-mode
tag-switching ip
!
router isis
net 49.0000.0000.2222.00
!
router rip
!
address-family ipv4 vrf blue
network 172.18.0.0
no auto-summary
exit-address-family
!
router bgp 2
no synchronization
bgp log-neighbor-changes
neighbor 10.2.2.1 remote-as 2
neighbor 10.2.2.1 update-source Loopback0
neighbor 10.2.2.3 remote-as 2
neighbor 10.2.2.3 update-source Loopback0
no auto-summary
!
address-family ipv4 mdt
neighbor 10.2.2.1 activate
neighbor 10.2.2.3 activate
exit-address-family
!
address-family vpnv4
neighbor 10.2.2.1 activate
neighbor 10.2.2.1 send-community extended
neighbor 10.2.2.3 activate
neighbor 10.2.2.3 send-community extended
exit-address-family
!
address-family ipv4 vrf blue
no synchronization
exit-address-family
!
ip classless
!
ip pim ssm default
ip pim vrf blue ssm default
!
!
!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
login
!
no cns aaa enable
end

PE1B

!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname PE1B
!
boot-start-marker
boot-end-marker
!
!
ip subnet-zero
ip cef
no ip domain-lookup
ip vrf green
rd 55:2222
route-target export 55:2222
route-target import 55:2222
mdt default 232.2.2.2
!
ip multicast-routing
ip multicast-routing vrf green
mpls label protocol ldp
!
!
!
interface Loopback0
ip address 10.2.2.1 255.255.255.255
no ip directed-broadcast
ip router isis
ip pim sparse-mode
!
interface Ethernet0/0
ip vrf forwarding green
ip address 172.25.111.1 255.255.255.0
no ip directed-broadcast
ip pim sparse-mode
tag-switching ip
!
interface Ethernet1/0
ip address 172.30.141.1 255.255.255.0
no ip directed-broadcast
ip router isis
ip pim sparse-mode
tag-switching ip
!
router isis
net 49.0000.0000.1111.00
!
router rip
version 2
!
address-family ipv4 vrf green
version 2
network 172.25.0.0
no auto-summary
exit-address-family
!
router bgp 2
no synchronization
bgp log-neighbor-changes
neighbor 10.2.2.2 remote-as 2
neighbor 10.2.2.2 update-source Loopback0
neighbor 10.2.2.3 remote-as 2
neighbor 10.2.2.3 update-source Loopback0
no auto-summary
!
address-family ipv4 mdt
neighbor 10.2.2.2 activate
neighbor 10.2.2.3 activate
exit-address-family
!
address-family vpnv4
neighbor 10.2.2.2 activate
neighbor 10.2.2.2 send-community extended
neighbor 10.2.2.3 activate
neighbor 10.2.2.3 send-community extended
exit-address-family
!
address-family ipv4 vrf green
no synchronization
exit-address-family
!
ip classless
!
ip pim ssm default
!
!
!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
login
!
no cns aaa enable
end

ASBR 間での VPNv4 ルートの直接交換の設定(オプション B):例

次の例では、オプション B の導入に MVPN Inter-AS サポートを設定します。この設定は、図 21に示す Inter-AS トポロジの例に基づいています。

この設定例では、PE1A と PE2A は、iBGP を使用して、ラベル付き VPNv4 ルートを互いと ASBR1A に再配布するように設定され、PE1B は、ラベル付き VPNv4 ルートを ASBR1B に再配布するように設定されています。ASBR1A と ASBR1B は、eBGP を使用して、これらのラベル付き VPNv4 ルートを互いに交換するように設定されています。

図 21 MVPN Inter-AS サポート オプション B 設定例のトポロジ

 

表 2 に、この特定のオプション B 設定例で使用されるトポロジに関する情報を示します。

 

表 2 MVPN Inter-AS サポート オプション B 設定例のトポロジ情報

PE または ASBR ルータ
AS 番号
Loopback0 インターフェイス
デフォルト MDT(PIM-SSM)

PE1A

55

192.168.0.1/32

232.1.1.1

PE2A

55

192.168.0.2/32

232.1.1.1

ASBR1A

55

192.168.0.4/32

232.1.1.1

ASBR1B

65

192.168.0.9/32

232.1.1.1

PE1B

65

192.168.0.8/32

232.1.1.1

PE1A

!
ip vrf blue
rd 55:1111
mdt default 232.1.1.1
!
ip multicast-routing
ip multicast-routing vrf blue
ip multicast vrf blue rpf proxy rd vector
!
.
.
.
!
interface Ethernet0/0
ip vrf forwarding blue
ip pim sparse-mode
!
.
.
.
!
router bgp 55
no synchronization
bgp log-neighbor-changes
neighbor 192.168.0.2 remote-as 55
neighbor 192.168.0.2 update-source Loopback0
neighbor 192.168.0.4 remote-as 55
neighbor 192.168.0.4 update-source Loopback0
no auto-summary
!
address-family ipv4 mdt
neighbor 192.168.0.2 activate
neighbor 192.168.0.2 next-hop-self
neighbor 192.168.0.4 activate
neighbor 192.168.0.4 next-hop-self
exit-address-family
!
address-family vpnv4
neighbor 192.168.0.2 activate
neighbor 192.168.0.2 send-community extended
neighbor 192.168.0.4 activate
neighbor 192.168.0.4 send-community extended
exit-address-family
!
address-family ipv4 vrf blue
redistribute connected
redistribute static
redistribute rip metric 50
no auto-summary
no synchronization
exit-address-family
!
.
.
.
!
ip pim ssm default
!

PE2A

!
ip vrf blue
rd 55:1111
mdt default 232.1.1.1
!
ip multicast-routing
ip multicast-routing vrf blue
ip multicast vrf blue rpf proxy rd vector
!
.
.
.
!
interface Ethernet0/0
ip vrf forwarding blue
ip pim sparse-mode
!
.
.
.
!
router bgp 55
neighbor 192.168.0.1 remote-as 55
neighbor 192.168.0.1 update-source Loopback0
neighbor 192.168.0.4 remote-as 55
neighbor 192.168.0.4 update-source Loopback0
!
address-family ipv4 mdt
neighbor 192.168.0.1 activate
neighbor 192.168.0.1 next-hop-self
neighbor 192.168.0.4 activate
neighbor 192.168.0.4 next-hop-self
exit-address-family
!
address-family vpnv4
neighbor 192.168.0.1 activate
neighbor 192.168.0.1 send-community extended
neighbor 192.168.0.4 activate
neighbor 192.168.0.4 send-community extended
exit-address-family
!
address-family ipv4 vrf blue
redistribute connected
redistribute static
no synchronization
exit-address-family
!
.
.
.
!
ip pim ssm default
!

ASBR1A

!
ip multicast-routing
ip multicast-routing vrf blue
!
.
.
.
!
!
interface Ethernet0/0
ip pim sparse-mode
!
.
.
.
!
router bgp 55
bgp log-neighbor-changes
neighbor 10.0.5.9 remote-as 65
neighbor 192.168.0.1 remote-as 55
neighbor 192.168.0.1 update-source Loopback0
neighbor 192.168.0.2 remote-as 55
neighbor 192.168.0.2 update-source Loopback0
!
address-family ipv4 mdt
neighbor 10.0.5.9 activate
neighbor 192.168.0.1 activate
neighbor 192.168.0.1 next-hop-self
neighbor 192.168.0.2 activate
neighbor 192.168.0.2 next-hop-self
exit-address-family
!
address-family vpnv4
neighbor 10.0.5.9 activate
neighbor 10.0.5.9 send-community extended
neighbor 192.168.0.1 activate
neighbor 192.168.0.1 send-community extended
neighbor 192.168.0.1 next-hop-self
neighbor 192.168.0.2 activate
neighbor 192.168.0.2 send-community extended
neighbor 192.168.0.2 next-hop-self
exit-address-family
!
.
.
.
!
ip pim ssm default
!

ASBR1B

!
ip multicast-routing
ip multicast-routing vrf blue
!
.
.
.
!
interface Ethernet0/0
ip pim sparse-mode
!
.
.
.
!
router bgp 65
bgp log-neighbor-changes
neighbor 10.0.5.4 remote-as 55
neighbor 192.168.0.8 remote-as 65
neighbor 192.168.0.8 update-source Loopback0
!
address-family ipv4 mdt
neighbor 10.0.5.4 activate
neighbor 192.168.0.8 activate
neighbor 192.168.0.8 next-hop-self
exit-address-family
!
address-family vpnv4
neighbor 10.0.5.4 activate
neighbor 10.0.5.4 send-community extended
neighbor 192.168.0.8 activate
neighbor 192.168.0.8 send-community extended
neighbor 192.168.0.8 next-hop-self
exit-address-family
!
.
.
.
!
ip pim ssm default
!

PE1B

!
ip vrf blue
rd 55:1111
mdt default 232.1.1.1
!
ip multicast-routing
ip multicast-routing vrf blue
ip multicast vrf blue rpf proxy rd vector
!
.
.
.
!
interface Ethernet0/0
ip vrf forwarding blue
ip pim sparse-mode
!
.
.
.
!
router bgp 65
neighbor 192.168.0.9 remote-as 65
neighbor 192.168.0.9 update-source Loopback0
!
address-family ipv4 mdt
neighbor 192.168.0.9 activate
neighbor 192.168.0.9 next-hop-self
exit-address-family
!
address-family vpnv4
neighbor 192.168.0.9 activate
neighbor 192.168.0.9 send-community extended
exit-address-family
!
address-family ipv4 vrf blue
redistribute connected
redistribute static
redistribute rip metric 50
no synchronization
exit-address-family
!
.
.
.
!
ip pim ssm default
!
 

次に、PE1A、PE2A、および PE1B の show ip pim mdt bgp コマンドの出力例を示します。サンプル出力は、MDT デフォルト グループ 232.1.1.1 の RD の BGP アドバタイズメントに関する情報を表示します。出力はアドバタイズされた MDT デフォルト グループ、MDT デフォルト グループに送信するソースの RD とソース アドレス、アドバタイジング ルータの BGP ルータ ID、およびアドバタイズメントに含まれる BGP ネクスト ホップ アドレスを表示します。

PE1A# show ip pim mdt bgp
 
MDT (Route Distinguisher + IPv4) Router ID Next Hop
MDT group 232.1.1.1
55:1111:192.168.0.2 192.168.0.2 192.168.0.2
55:1111:192.168.0.8 192.168.0.4 192.168.0.4
 
PE2A# show ip pim mdt bgp
 
MDT (Route Distinguisher + IPv4) Router ID Next Hop
MDT group 232.1.1.1
55:1111:192.168.0.1 192.168.0.1 192.168.0.1
55:1111:192.168.0.8 192.168.0.4 192.168.0.4
 
PE1B# show ip pim mdt bgp
 
MDT (Route Distinguisher + IPv4) Router ID Next Hop
MDT group 232.1.1.1
55:1111:192.168.0.1 192.168.0.9 192.168.0.9
55:1111:192.168.0.2 192.168.0.9 192.168.0.9
 

次に、PE1A、PE2A、および PE1B の show ip mroute proxy コマンドの出力例を示します。出力は、この設定例の各 PE ルータによって学習された RPF ベクトルに関する情報を表示します。RPF ベクトルは、PIM メッセージが AS 間ソースに到達するように送信される ASBR ルータの出口アドレスです。Proxy フィールドは、PE ルータによって学習された RPF ベクトルを表示します。Proxy フィールドの下に表示される各 RPF ベクトルの先頭には、RPF ベクトルに関連する RD が追加されます。PE ルータは RPF ベクトルを割り当てる(PE ルータは RPF ベクトルを PIM 加入に挿入する)ため、0.0.0.0 は、すべてのサンプル出力の Assigner フィールドの下に表示されます。最後に、PE ルータは BGP MDT SAFI アップデートから RPF ベクトルを学習するため、BGP MDT は、すべての出力の Origin フィールドの下に発信元として表示されます。

PE1A# show ip mroute proxy
 
(192.168.0.8, 232.1.1.1)
Proxy Assigner Origin Uptime/Expire
55:1111/192.168.0.4 0.0.0.0 BGP MDT 00:13:07/stopped
 
PE2A# show ip mroute proxy
 
(192.168.0.8, 232.1.1.1)
Proxy Assigner Origin Uptime/Expire
55:1111/192.168.0.4 0.0.0.0 BGP MDT 00:14:28/stopped
 
PE1B# show ip mroute proxy
 
(192.168.0.1, 232.1.1.1)
Proxy Assigner Origin Uptime/Expire
55:1111/192.168.0.9 0.0.0.0 BGP MDT 00:35:19/stopped
 
(192.168.0.2, 232.1.1.1)
Proxy Assigner Origin Uptime/Expire
55:1111/192.168.0.9 0.0.0.0 BGP MDT 00:35:49/stopped
 

次に、P1A の show ip mroute proxy コマンドの出力例を示します。P ルータは PE ルータから送信される PIM 加入から RPF ベクトルを学習するため、PE1A の IP アドレス(10.0.3.1)と PE2A の IP アドレス(10.0.3.2)は、P1A の出力の Assigner フィールドの下に表示されます。P1A は PIM 加入メッセージ内の符号化から RPF ベクトルを学習するため、PIM は Origin フィールドの下に発信元として表示されます。

P1A# show ip mroute proxy
 
(192.168.0.8, 232.1.1.1)
Proxy Assigner Origin Uptime/Expire
55:1111/192.168.0.4 10.0.3.1 PIM 00:03:29/00:02:06
55:1111/192.168.0.4 10.0.3.2 PIM 00:17:47/00:02:06
 

次に、ASBR1A と ASBR1B の show ip mroute proxy コマンドの出力例を示します。ルータがローカル インターフェイス(ASBR がローカル インターフェイスによって所有される RPF ベクトルを受信すると、オプション B の導入で発生する)を参照する RPF ベクトルを受信した場合、ルータは RPF ベクトルを廃棄し、ルータが BGP MDT SAFI アップデートから学習した情報を使用して、通常の RPF ルックアップを行います。ASBR1A と ASBR1B は、ローカル インターフェイスの 1 つを参照する RPF ベクトルを持つ PIM 加入の RPF ルックアップを行うためにローカル インターフェイスを使用しているため、すべての ASBR ルータの出力の Proxy フィールドの下には、RPF ベクトルの代わりに「local」という言葉が表示されます。Assigner フィールドは、ASBR に PIM 加入を送信した RPF アドレスを表示します。ASBR は PIM 加入から RPF ベクトル(その後廃棄される RPF ベクトル)を学習するため、PIM は Origin フィールドの下に発信元として表示されます。

ASBR1A# show ip mroute proxy
 
(192.168.0.1, 232.1.1.1)
Proxy Assigner Origin Uptime/Expire
55:1111/local 10.0.5.9 PIM 00:18:19/00:02:46
 
(192.168.0.2, 232.1.1.1)
Proxy Assigner Origin Uptime/Expire
55:1111/local 10.0.5.9 PIM 00:18:50/00:02:24
 
(192.168.0.8, 232.1.1.1)
Proxy Assigner Origin Uptime/Expire
55:1111/local 10.0.4.3 PIM 00:18:49/00:02:19
 
ASBR1B# show ip mroute proxy
 
(192.168.0.1, 232.1.1.1)
Proxy Assigner Origin Uptime/Expire
55:1111/local 10.0.7.8 PIM 00:37:39/00:02:44
 
(192.168.0.2, 232.1.1.1)
Proxy Assigner Origin Uptime/Expire
55:1111/local 10.0.7.8 PIM 00:38:10/00:02:19
 
(192.168.0.8, 232.1.1.1)
Proxy Assigner Origin Uptime/Expire
55:1111/local 10.0.5.4 PIM 00:38:09/00:02:19
 
 

次に、PE1A、PE2A、P1A、ASBR1A、ASBR1B、および PE1B の show ip mroute コマンドの出力例を示します。サンプル出力は、MDT デフォルト グループ 232.1.1.1 のグローバル テーブルを示しています。このコマンドからの出力によって、3 つのすべてのルータ(PE1A、PE2A、および PE1B)がデフォルト MDT に加入したことを確認します。

PE1A

PE1A# show ip mroute 232.1.1.1
 
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group
V - RD & Vector, v - Vector
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
 
(192.168.0.8, 232.1.1.1), 00:13:11/00:02:41, flags: sTIZV
Incoming interface: Ethernet2/0, RPF nbr 10.0.3.3, vector 192.168.0.4
Outgoing interface list:
MVRF blue, Forward/Sparse-Dense, 00:13:11/00:00:00
 
(192.168.0.2, 232.1.1.1), 00:13:12/00:02:41, flags: sTIZ
Incoming interface: Ethernet2/0, RPF nbr 10.0.3.2
Outgoing interface list:
MVRF blue, Forward/Sparse-Dense, 00:13:12/00:00:00
 
(192.168.0.1, 232.1.1.1), 00:13:12/00:03:27, flags: sT
Incoming interface: Loopback0, RPF nbr 0.0.0.0
Outgoing interface list:
Ethernet2/0, Forward/Sparse-Dense, 00:13:11/00:02:50

PE2A

PE2A# show ip mroute 232.1.1.1
 
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group
V - RD & Vector, v - Vector
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
 
(192.168.0.8, 232.1.1.1), 00:17:05/00:02:46, flags: sTIZV
Incoming interface: Ethernet2/0, RPF nbr 10.0.3.3, vector 192.168.0.4
Outgoing interface list:
MVRF blue, Forward/Sparse-Dense, 00:17:05/00:00:00
 
(192.168.0.1, 232.1.1.1), 00:17:05/00:02:46, flags: sTIZ
Incoming interface: Ethernet2/0, RPF nbr 10.0.3.1
Outgoing interface list:
MVRF blue, Forward/Sparse-Dense, 00:17:05/00:00:00
 
(192.168.0.2, 232.1.1.1), 00:17:06/00:03:15, flags: sT
Incoming interface: Loopback0, RPF nbr 0.0.0.0
Outgoing interface list:
Ethernet2/0, Forward/Sparse-Dense, 00:17:06/00:03:08

P1A

P1A# show ip mroute 232.1.1.1
 
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group
V - RD & Vector, v - Vector
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
 
(192.168.0.1, 232.1.1.1), 00:17:43/00:03:08, flags: sT
Incoming interface: Ethernet2/0, RPF nbr 10.0.3.1
Outgoing interface list:
Ethernet3/0, Forward/Sparse-Dense, 00:17:43/00:02:51
 
(192.168.0.8, 232.1.1.1), 00:18:12/00:03:15, flags: sTV
Incoming interface: Ethernet3/0, RPF nbr 10.0.4.4, vector 192.168.0.4
Outgoing interface list:
Ethernet2/0, Forward/Sparse-Dense, 00:18:12/00:03:15
 
(192.168.0.2, 232.1.1.1), 00:18:13/00:03:18, flags: sT
Incoming interface: Ethernet2/0, RPF nbr 10.0.3.2
Outgoing interface list:
Ethernet3/0, Forward/Sparse-Dense, 00:18:13/00:03:18

ASBR1A

ASBR1A# show ip mroute 232.1.1.1
 
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group
V - RD & Vector, v - Vector
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
 
(10.254.254.8, 232.1.1.1), 00:20:13/00:03:16, flags: sT
Incoming interface: Ethernet6/0, RPF nbr 10.0.7.12
Outgoing interface list:
Ethernet5/0, Forward/Sparse-Dense, 00:20:13/00:02:46
 
(10.254.254.2, 232.1.1.1), 00:20:13/00:03:16, flags: sT
Incoming interface: Ethernet5/0, RPF nbr 10.0.6.5
Outgoing interface list:
Ethernet6/0, Forward/Sparse-Dense, 00:20:13/00:02:39

ASBR1B

ASBR1B# show ip mroute 232.1.1.1
 
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group
V - RD & Vector, v - Vector
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
 
(192.168.0.1, 232.1.1.1), 00:37:43/00:03:16, flags: sTV
Incoming interface: Ethernet4/0, RPF nbr 10.0.5.4, vector 10.0.5.4
Outgoing interface list:
Ethernet6/0, Forward/Sparse-Dense, 00:37:43/00:03:10
 
(192.168.0.8, 232.1.1.1), 00:38:14/00:03:16, flags: sT
Incoming interface: Ethernet6/0, RPF nbr 10.0.7.8
Outgoing interface list:
Ethernet4/0, Forward/Sparse-Dense, 00:38:14/00:02:45
 
(192.168.0.2, 232.1.1.1), 00:38:14/00:03:16, flags: sTV
Incoming interface: Ethernet4/0, RPF nbr 10.0.5.4, vector 10.0.5.4
Outgoing interface list:
Ethernet6/0, Forward/Sparse-Dense, 00:38:14/00:02:45

PE1B

PE1B# show ip mroute 232.1.1.1
 
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group
V - RD & Vector, v - Vector
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
 
(192.168.0.1, 232.1.1.1), 00:35:23/00:02:40, flags: sTIZV
Incoming interface: Ethernet6/0, RPF nbr 10.0.7.9, vector 192.168.0.9
Outgoing interface list:
MVRF blue, Forward/Sparse-Dense, 00:35:23/00:00:00
 
(192.168.0.2, 232.1.1.1), 00:35:53/00:02:40, flags: sTIZV
Incoming interface: Ethernet6/0, RPF nbr 10.0.7.9, vector 192.168.0.9
Outgoing interface list:
MVRF blue, Forward/Sparse-Dense, 00:35:53/00:00:00
 
(192.168.0.8, 232.1.1.1), 00:35:53/00:03:10, flags: sT
Incoming interface: Loopback0, RPF nbr 0.0.0.0
Outgoing interface list:
Ethernet6/0, Forward/Sparse-Dense, 00:35:53/00:02:35

マルチホップ MP-EBGP ピアリング セッションを使用した RR 間の VPNv4 ルートの交換の設定(オプション C):例

次の例では、MVPN Inter-AS オプション C のサポートを設定します。この設定は、図 22に示す Inter-AS トポロジの例に基づいています。

設定例では、MP-eBGP は、対応する ASBR ルータ間で交換されるこれらのルートのネクスト ホップを使用して、異なる自律システムの RR 間で VPNv4 ルートを交換するために使用されます。2 つの自律システムの RR は直接接続されないので、MP-eBGP ピアリング セッションを確立できるようにするには、マルチホップ機能が必要です。VPNv4 の PE ルータ ネクスト ホップ アドレスは、ASBR ルータ間で交換されます。この設定例では、自律システム間でのこれらのアドレスの交換は、IPv4 BGP ラベル配布(ASBR が MPLS ラベル付きの IPv4 ルートを配布できるようにする)を使用して確立されます。

図 22 MVPN Inter-AS サポート オプション C 設定例のトポロジ

 

表 3 に、この AS 間の MVPN オプション C の設定例で使用されるトポロジに関する情報を示します。

 

表 3 MVPN Inter-AS サポート オプション C 設定例のトポロジ情報

PE、RR、または ASBR ルータ
AS 番号
Loopback0 インターフェイス
デフォルト MDT(PIM-SSM)

PE1A

55

10.254.254.2/32

232.1.1.1

RR1A

55

10.252.252.4/32

232.1.1.1

ASBR1A

55

10.254.254.6/32

232.1.1.1

PE1B

65

10.254.254.8/32

232.1.1.1

RR1B

65

10.252.252.10/32

232.1.1.1

ASBR1B

65

10.254.254.12/32

232.1.1.1

PE1A

!
ip vrf blue
rd 55:1111
mdt default 232.1.1.1
!
ip multicast-routing
ip multicast-routing vrf blue
ip multicast rpf proxy vector
!
.
.
.
!
interface Ethernet0/0
ip vrf forwarding blue
ip pim sparse-mode
!
.
.
.
!
router bgp 55
no bgp default route-target filter
bgp log-neighbor-changes
neighbor 10.252.252.4 remote-as 55
neighbor 10.252.252.4 update-source Loopback0
!
address-family ipv4
neighbor 10.252.252.4 activate
neighbor 10.252.252.4 send-label
no auto-summary
no synchronization
exit-address-family
!
address-family ipv4 mdt
neighbor 10.252.252.4 activate
neighbor 10.252.252.4 send-community extended
exit-address-family
!
address-family vpnv4
neighbor 10.252.252.4 activate
neighbor 10.252.252.4 send-community extended
exit-address-family
!
address-family ipv4 vrf blue
redistribute connected
redistribute static
redistribute rip metric 50
no synchronization
exit-address-family
!
.
.
.
!
ip pim ssm default
!

RR1A

!
router bgp 55
neighbor 10.252.252.10 remote-as 65
neighbor 10.252.252.10 ebgp-multihop 255
neighbor 10.252.252.10 update-source Loopback0
neighbor 10.254.254.2 remote-as 55
neighbor 10.254.254.2 update-source Loopback0
neighbor 10.254.254.6 remote-as 55
neighbor 10.254.254.6 update-source Loopback0
!
address-family ipv4
no neighbor 10.252.252.10 activate
neighbor 10.254.254.2 activate
neighbor 10.254.254.2 route-reflector-client
neighbor 10.254.254.2 send-label
neighbor 10.254.254.6 activate
neighbor 10.254.254.6 route-reflector-client
neighbor 10.254.254.6 send-label
no auto-summary
no synchronization
exit-address-family
!
address-family ipv4 mdt
neighbor 10.252.252.10 activate
neighbor 10.252.252.10 next-hop-unchanged
neighbor 10.254.254.2 activate
exit-address-family
!
address-family vpnv4
neighbor 10.252.252.10 activate
neighbor 10.252.252.10 send-community extended
neighbor 10.252.252.10 next-hop-unchanged
neighbor 10.254.254.2 activate
neighbor 10.254.254.2 send-community extended
neighbor 10.254.254.2 route-reflector-client
exit-address-family
!

ASBR1A

!
ip multicast-routing
ip multicast-routing vrf blue
!
.
.
.
!
interface Ethernet7/0
ip vrf forwarding blue
ip pim sparse-mode
!
.
.
.
!
router bgp 55
neighbor 10.0.7.12 remote-as 65
neighbor 10.252.252.4 remote-as 55
neighbor 10.252.252.4 update-source Loopback0
!
address-family ipv4
redistribute isis level-2 route-map inter-as
neighbor 10.0.7.12 activate
neighbor 10.0.7.12 route-map IN in
neighbor 10.0.7.12 route-map OUT out
neighbor 10.0.7.12 send-label
neighbor 10.252.252.4 activate
neighbor 10.252.252.4 next-hop-self
neighbor 10.252.252.4 send-label
no auto-summary
no synchronization
exit-address-family
!
.
.
.
!
ip pim ssm default
!

ASBR1B

!
ip multicast-routing
ip multicast-routing vrf blue
!
.
.
.
!
interface Ethernet6/0
ip vrf forwarding blue
ip pim sparse-mode
!
.
.
.
!
router bgp 65
neighbor 10.0.7.6 remote-as 55
neighbor 10.252.252.10 remote-as 65
neighbor 10.252.252.10 update-source Loopback0
!
address-family ipv4
redistribute isis level-2 route-map inter-as
neighbor 10.0.7.6 activate
neighbor 10.0.7.6 route-map IN in
neighbor 10.0.7.6 route-map OUT out
neighbor 10.0.7.6 send-label
neighbor 10.252.252.10 activate
neighbor 10.252.252.10 next-hop-self
neighbor 10.252.252.10 send-label
no auto-summary
no synchronization
exit-address-family
!
.
.
.
!
ip pim ssm default
!

RR1B

!
router bgp 65
no bgp default route-target filter
bgp log-neighbor-changes
neighbor 10.252.252.4 remote-as 55
neighbor 10.252.252.4 ebgp-multihop 255
neighbor 10.252.252.4 update-source Loopback0
neighbor 10.254.254.8 remote-as 65
neighbor 10.254.254.8 update-source Loopback0
neighbor 10.254.254.12 remote-as 65
neighbor 10.254.254.12 update-source Loopback0
!
address-family ipv4
no neighbor 10.252.252.4 activate
neighbor 10.254.254.8 activate
neighbor 10.254.254.8 route-reflector-client
neighbor 10.254.254.8 send-label
neighbor 10.254.254.12 activate
neighbor 10.254.254.12 route-reflector-client
neighbor 10.254.254.12 send-label
no auto-summary
no synchronization
exit-address-family
!
address-family ipv4 mdt
neighbor 10.252.252.4 activate
neighbor 10.252.252.4 next-hop-unchanged
neighbor 10.254.254.8 activate
exit-address-family
!
address-family vpnv4
neighbor 10.252.252.4 activate
neighbor 10.252.252.4 send-community extended
neighbor 10.252.252.4 next-hop-unchanged
neighbor 10.254.254.8 activate
neighbor 10.254.254.8 send-community extended
neighbor 10.254.254.8 route-reflector-client
exit-address-family
!

PE1B

!
ip vrf blue
rd 55:1111
mdt default 232.1.1.1
!
!
ip multicast-routing
ip multicast-routing vrf blue
ip multicast rpf proxy vector
!
.
.
.
!
interface Ethernet12/0
ip vrf forwarding blue
ip pim sparse-mode
!
.
.
.
!
router bgp 65
no bgp default route-target filter
bgp log-neighbor-changes
neighbor 10.252.252.10 remote-as 65
neighbor 10.252.252.10 update-source Loopback0
!
address-family ipv4
neighbor 10.252.252.10 activate
neighbor 10.252.252.10 send-label
no auto-summary
no synchronization
exit-address-family
!
address-family ipv4 mdt
neighbor 10.252.252.10 activate
neighbor 10.252.252.10 send-community extended
exit-address-family
!
address-family vpnv4
neighbor 10.252.252.10 activate
neighbor 10.252.252.10 send-community extended
exit-address-family
!
address-family ipv4 vrf blue
redistribute connected
redistribute static
redistribute rip metric 50
no synchronization
exit-address-family
!
.
.
.
!
ip pim ssm default
!
 

次に、PE1A と PE2A の show ip pim mdt bgp コマンドの出力例を示します。サンプル出力は、MDT デフォルト グループの RD の BGP アドバタイズメントに関する情報を表示します。出力はアドバタイズされた MDT デフォルト グループ、MDT デフォルト グループに送信するソースの RD とソース アドレス、アドバタイジング ルータの BGP ルータ ID、およびアドバタイズメントに含まれる BGP ネクスト ホップ アドレスを表示します。

 
PE1A# show ip pim mdt bgp
 
MDT (Route Distinguisher + IPv4) Router ID Next Hop
MDT group 232.1.1.1
55:1111:10.254.254.8 10.252.252.4 10.254.254.8
 
PE1B# show ip pim mdt bgp
 
MDT (Route Distinguisher + IPv4) Router ID Next Hop
MDT group 232.1.1.1
55:1111:10.254.254.2 10.252.252.10 10.254.254.2
 

次に、P1A、P2A、P1B、および P2B の show ip mroute proxy コマンドの出力例を示します。P ルータは、PIM 加入メッセージの符号化から RPF ベクトルを学習するため、PIM は Origin フィールドの下に発信元として表示されます。

 
P1A# show ip mroute proxy
 
(10.254.254.8, 232.1.1.1)
Proxy Assigner Origin Uptime/Expire
10.254.254.6 10.0.2.2 PIM 00:15:37/00:02:57
P2A# show ip mroute proxy
 
(10.254.254.8, 232.1.1.1)
Proxy Assigner Origin Uptime/Expire
10.254.254.6 10.0.4.3 PIM 00:20:41/00:02:46
 
P1B# show ip mroute proxy
 
(10.254.254.2, 232.1.1.1)
Proxy Assigner Origin Uptime/Expire
10.254.254.12 10.0.10.9 PIM 00:29:38/00:02:16
 
P2B# show ip mroute proxy
 
(10.254.254.2, 232.1.1.1)
Proxy Assigner Origin Uptime/Expire
10.254.254.12 10.0.12.8 PIM 00:29:58/00:02:09
 

次に、PE1A、P1A、P2A、ASBR1A、ASBR1B、P1B、P2B、および PE1B の show ip mroute コマンドの出力例を示します。サンプル出力は、MDT デフォルト グループ 232.1.1.1 のグローバル テーブルを示しています。このコマンドからの出力によって、3 つのすべてのルータ(PE1A、PE2A、および PE1B)がデフォルト MDT に加入したことを確認します。

PE1A

PE1A# show ip mroute 232.1.1.1
 
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group
V - RD & Vector, v - Vector
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
 
(10.254.254.8, 232.1.1.1), 00:12:27/00:02:43, flags: sTIZv
Incoming interface: Ethernet1/0, RPF nbr 10.0.2.3, vector 10.254.254.6
Outgoing interface list:
MVRF blue, Forward/Sparse-Dense, 00:12:27/00:00:00
 
(10.254.254.2, 232.1.1.1), 00:14:40/00:03:12, flags: sT
Incoming interface: Loopback0, RPF nbr 0.0.0.0
Outgoing interface list:
Ethernet1/0, Forward/Sparse-Dense, 00:12:27/00:03:06

P1A

P1A# show ip mroute 232.1.1.1
 
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group
V - RD & Vector, v - Vector
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
 
(10.254.254.2, 232.1.1.1), 00:15:40/00:03:25, flags: sT
Incoming interface: Ethernet1/0, RPF nbr 10.0.2.2
Outgoing interface list:
Ethernet4/0, Forward/Sparse-Dense, 00:15:40/00:03:24
 
(10.254.254.8, 232.1.1.1), 00:15:40/00:03:25, flags: sTv
Incoming interface: Ethernet4/0, RPF nbr 10.0.4.5, vector 10.254.254.6
Outgoing interface list:
Ethernet1/0, Forward/Sparse-Dense, 00:15:40/00:03:25

P2A

P2A# show ip mroute 232.1.1.1
 
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group
V - RD & Vector, v - Vector
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
 
(10.254.254.2, 232.1.1.1), 00:20:43/00:03:15, flags: sT
Incoming interface: Ethernet4/0, RPF nbr 10.0.4.3
Outgoing interface list:
Ethernet5/0, Forward/Sparse-Dense, 00:20:43/00:03:15
 
(10.254.254.8, 232.1.1.1), 00:20:43/00:03:15, flags: sTv
Incoming interface: Ethernet5/0, RPF nbr 10.0.6.6, vector 10.254.254.6
Outgoing interface list:
Ethernet4/0, Forward/Sparse-Dense, 00:20:43/00:03:14

ASBR1A

ASBR1A# show ip mroute 232.1.1.1
 
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group
V - RD & Vector, v - Vector
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
 
(10.254.254.8, 232.1.1.1), 00:20:13/00:03:16, flags: sT
Incoming interface: Ethernet6/0, RPF nbr 10.0.7.12
Outgoing interface list:
Ethernet5/0, Forward/Sparse-Dense, 00:20:13/00:02:46
 
(10.254.254.2, 232.1.1.1), 00:20:13/00:03:16, flags: sT
Incoming interface: Ethernet5/0, RPF nbr 10.0.6.5
Outgoing interface list:
Ethernet6/0, Forward/Sparse-Dense, 00:20:13/00:02:39

ASBR1B

ASBR1B# show ip mroute 232.1.1.1
 
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group
V - RD & Vector, v - Vector
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
 
(10.254.254.8, 232.1.1.1), 00:25:46/00:03:13, flags: sT
Incoming interface: Ethernet7/0, RPF nbr 10.0.8.11
Outgoing interface list:
Ethernet6/0, Forward/Sparse-Dense, 00:25:46/00:03:04
 
(10.254.254.2, 232.1.1.1), 00:25:46/00:03:13, flags: sT
Incoming interface: Ethernet6/0, RPF nbr 10.0.7.6
Outgoing interface list:
Ethernet7/0, Forward/Sparse-Dense, 00:25:46/00:03:07

P1B

P1B# show ip mroute 232.1.1.1
 
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group
V - RD & Vector, v - Vector
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
 
(10.254.254.8, 232.1.1.1), 00:29:41/00:03:17, flags: sT
Incoming interface: Ethernet10/0, RPF nbr 10.0.10.9
Outgoing interface list:
Ethernet7/0, Forward/Sparse-Dense, 00:29:41/00:02:56
 
(10.254.254.2, 232.1.1.1), 00:29:41/00:03:17, flags: sTv
Incoming interface: Ethernet7/0, RPF nbr 10.0.8.12, vector 10.254.254.12
Outgoing interface list:
Ethernet10/0, Forward/Sparse-Dense, 00:29:41/00:02:44

P2B

P2B# show ip mroute 232.1.1.1
 
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group
V - RD & Vector, v - Vector
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
 
(10.254.254.8, 232.1.1.1), 00:30:01/00:03:25, flags: sT
Incoming interface: Ethernet11/0, RPF nbr 10.0.12.8
Outgoing interface list:
Ethernet10/0, Forward/Sparse-Dense, 00:30:01/00:02:30
 
(10.254.254.2, 232.1.1.1), 00:30:01/00:03:25, flags: sTv
Incoming interface: Ethernet10/0, RPF nbr 10.0.10.11, vector 10.254.254.12
Outgoing interface list:
Ethernet11/0, Forward/Sparse-Dense, 00:30:01/00:02:36

PE1B

PE1B# show ip mroute 232.1.1.1
 
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group
V - RD & Vector, v - Vector
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
 
(10.254.254.2, 232.1.1.1), 00:31:22/00:02:55, flags: sTIZv
Incoming interface: Ethernet11/0, RPF nbr 10.0.12.9, vector 10.254.254.12
Outgoing interface list:
MVRF blue, Forward/Sparse-Dense, 00:31:22/00:00:00
 
(10.254.254.8, 232.1.1.1), 00:33:35/00:03:25, flags: sT
Incoming interface: Loopback0, RPF nbr 0.0.0.0
Outgoing interface list:
Ethernet11/0, Forward/Sparse-Dense, 00:31:22/00:03:22

その他の参考資料

ここでは、MVPN Inter-AS サポート 設定に関連する参考資料を示します。

関連資料

関連項目
参照先

マルチキャスト コマンド:コマンド構文の詳細、コマンド モード、コマンド履歴、デフォルト設定、使用に関する注意事項、および例

『Cisco IOS IP Multicast Command Reference』

規格

規格
タイトル

draft-ietf-pim-rpf-vector

『The RPF Vector TLV』

draft-ietf-l3vpn-rfc2547bis1

『BGP/MPLS IP VPNs』

1.インターネット ドラフト標準 draft-ietf-l3vpn-rfc2547bis は、一般的に RFC 2547bis と呼ばれます。

MIB

MIB
MIB リンク

新しい MIB または変更された MIB はサポートされていません。また、既存の MIB に対するサポートに変更はありません。

選択したプラットフォーム、Cisco IOS リリース、および機能セットの MIB を検索してダウンロードする場合は、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFC

2.RFC 4364 は最新の RFC 標準で、RFC 2547(およびそれ以降の RFC2547bis インターネット ドラフト標準)は廃止されています。

シスコのテクニカル サポート

説明
リンク

右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。

以下を含むさまざまな作業にこの Web サイトが役立ちます。
・テクニカル サポートを受ける
・ソフトウェアをダウンロードする
・セキュリティの脆弱性を報告する、またはシスコ製品のセキュリティ問題に対する支援を受ける
・ツールおよびリソースへアクセスする
- Product Alert の受信登録
- Field Notice の受信登録
- Bug Toolkit を使用した既知の問題の検索
・Networking Professionals(NetPro)コミュニティで、技術関連のディスカッションに参加する
・トレーニング リソースへアクセスする
・TAC Case Collection ツールを使用して、ハードウェアや設定、パフォーマンスに関する一般的な問題をインタラクティブに特定および解決する

この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

http://www.cisco.com/techsupport

コマンド リファレンス

次のコマンドは、このモジュールで説明した機能で導入または修正されたものです。これらのコマンドの詳細については、『 Cisco IOS IP Multicast Command Reference 』( http://www.cisco.com/en/US/docs/ios/ipmulti/command/reference/imc_book.html )を参照してください。すべての Cisco IOS コマンドの詳細については、 http://tools.cisco.com/Support/CLILookup にある Command Lookup Tool を使用するか、 http://www.cisco.com/en/US/docs/ios/mcl/allreleasemcl/all_book.html にある『 Cisco IOS Master Command List, All Releases 』を参照してください。

ip multicast rpf proxy vector

show ip mroute

show ip pim neighbor

show ip rpf

マルチキャスト VPN Inter-AS サポートの設定に関する機能情報

表 4 に、このモジュールで説明した機能をリストし、特定の設定情報へのリンクを示します。この表には、Cisco IOS Release 12.2(1)、12.0(3)S、または以降のリリースで導入または変更された機能だけを示します。

ここに記載されていないこのテクノロジーの機能情報については、『 IP Multicast Features Roadmap 』を参照してください。

ご使用の Cisco IOS ソフトウェア リリースによっては、コマンドの中に一部使用できないものがあります。特定のコマンドに関するリリース情報については、コマンド リファレンス マニュアルを参照してください。

Cisco Feature Navigator を使用すると、プラットフォームおよびソフトウェア イメージのサポート情報を検索できます。Cisco Feature Navigator を使用すると、Cisco IOS および Catalyst OS ソフトウェア イメージがサポートする特定のソフトウェア リリース、機能セット、またはプラットフォームを確認できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。


表 4 には、一連の Cisco IOS ソフトウェア リリースのうち、特定の機能が初めて導入された Cisco IOS ソフトウェア リリースだけが記載されています。特に明記されていない限り、Cisco IOS ソフトウェア リリース群の後続のリリースでもこの機能をサポートします。


 

表 4 マルチキャスト VPN Inter-AS サポートの設定に関する機能情報

機能名
リリース
機能情報

BGP マルチキャスト AS 間 VPN

12.0(29)S
12.2(33)SRA
12.2(31)SB2
12.2(33)SXH
12.4(20)T
15.0(1)S

BGP マルチキャスト AS 間 VPN 機能は、BGP に IPv4 MDT SAFI を導入します。MDT SAFI は、BGP 内で IPv4 アドレス ファミリとして定義された過渡的なマルチキャストに対応したコネクタ属性です。MDT SAFI は、AS 間 VPN ピア セッションをサポートするように設計されています。

この機能に関する詳細については、次の各項を参照してください。

「オプション B および C の MVPN Inter-AS サポート ソリューション」

「BGP コネクタ アトリビュート」

「MVPN Inter-AS サポートのための BGP MDT SAFI アップデート」

「マルチキャスト VPN Inter-AS サポートでの BGP の MDT アドレス ファミリの設定」

「BGP の IPv4 MDT セッションに関する情報の表示」

「BGP の IPv4 MDT ピアリング セッションのクリア」

「マルチキャスト VPN Inter-AS サポートでの IPv4 MDT アドレス ファミリ セッションの設定:例」

この機能により、 address-family ipv4 (BGP)、 clear bgp ipv4 mdt show ip bgp ipv4 の各コマンドが導入または変更されました。

マルチキャスト VPN Inter-AS サポート

12.0(30)S
12.2(33)SRA
12.2(31)SB2
12.2(33)SXH
12.4(20)T
15.0(1)S

マルチキャスト VPN Inter-AS サポート機能は、MVPN に使用される MDT が複数の自律システムにわたることができるようにします。この利点としては、RFC 4364 に記載されたすべてのオプションをサポートするための柔軟性を持たせながら、MPLS レイヤ 3 VPN サービスにおいてマルチキャストが複数のサービス プロバイダーにわたる必要がある顧客にとって、マルチキャストのカバレッジが向上することがあります。また、企業の合併または買収で見られるように、マルチキャスト VPN Inter-AS サポート機能を使用して既存の MVPN サービスを他の MVPN サービスに統合できます。

この機能に関する詳細については、次の各項を参照してください。

「MVPN Inter-AS サポートの概要」

「MVPN Inter-AS サポートの利点」

「MVPN Inter-AS サポートの実装要件」

「オプション B および C の MVPN Inter-AS サポート ソリューション」

「BGP MDT アップデートを送信して MVPN Inter-AS サポートのデフォルト MDT を作成する PE ルータの設定(オプション B):例」

「BGP MDT アップデートを送信して MVPN Inter-AS サポートのデフォルト MDT を作成する PE ルータの設定(オプション C):例」

この機能により、 ip multicast rpf proxy vector show ip mroute show ip pim neighbor show ip rpf の各コマンドが導入または変更されました。

PIM RPF ベクトル

12.0(30)S
12.2(33)SRA
12.2(31)SB2
12.2(33)SXH
12.4(20)T

PIM RPF ベクトル機能は、コア ルータが、ソース ルータの IP アドレスではなく、出口ルータの IP アドレスの RPF チェックを実行できるようにします。出口ルータの IP アドレスは RPF ベクトルであり、PIM 加入メッセージに挿入されます。

この機能に関する詳細については、次の各項を参照してください。

「PIM RPF ベクトル」

「オプション B での MVPN の AS 間 MDT の確立」

「オプション C での MVPN の AS 間 MDT の確立」

この機能により、 ip multicast rpf proxy vector show ip mroute show ip pim neighbor の各コマンドが導入または変更されました。