IP マルチキャスト コンフィギュレーション ガイド、 Cisco IOS Release 15.1S
マルチキャスト VPN の設定
マルチキャスト VPN の設定
発行日;2012/02/01 | 英語版ドキュメント(2011/04/17 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 8MB) | フィードバック

目次

マルチキャスト VPN の設定

この章の構成

マルチキャスト VPN の設定に関する前提条件

マルチキャスト VPN の設定に関する制約事項

マルチキャスト VPN の設定に関する情報

マルチキャスト VPN の操作

マルチキャスト VPN ルーティングおよび転送とマルチキャスト ドメイン

マルチキャスト配信ツリー(MDT)

マルチキャスト トンネル インターフェイス

マルチキャスト VPN に対するマルチキャスト分散スイッチング(MDS)のサポート

マルチキャスト VPN の利点

マルチキャスト VPN の設定方法

VRF でのデフォルト MDT グループの設定

マルチキャスト VPN での BGP の MDT アドレス ファミリの設定

マルチキャスト VPN サポートの BGP アドバタイズメント方式

MDT SAFI への自動移行

MDT SAFI 設定時の注意事項

MDT SAFI サポートのためのネットワーク アップグレード時の注意事項

サポートされているポリシー

前提条件

制約事項

データ マルチキャスト グループの設定

前提条件

マルチキャスト ルートおよび情報の設定

前提条件

MDT デフォルト グループの情報の確認

マルチキャスト VPN の設定例

MVPN および SSM の設定:例

マルチキャスト ルーティングでの VPN のイネーブル化:例

マルチキャスト VPN での BGP の MDT アドレス ファミリの設定:例

データ MDT グループでのマルチキャスト グループ アドレス範囲の設定:例

レジスタ メッセージの IP ソース アドレスの設定:例

MSDP ピアの設定:例

マルチキャスト ルートの数の制限:例

その他の参考資料

関連資料

規格

MIB

RFC

シスコのテクニカル サポート

マルチキャスト VPN の設定に関する機能情報

マルチキャスト VPN の設定

マルチキャスト VPN(MVPN)機能を使用すると、レイヤ 3 Virtual Private Network(VPN; バーチャル プライベート ネットワーク)でのマルチキャストをサポートできます。企業がマルチキャスト アプリケーションの範囲を拡大するにつれて、サービス プロバイダーは、これらの企業に Multiprotocol Label Switching(MPLS; マルチプロトコル ラベル スイッチング)コア ネットワーク上で対応できます。IP マルチキャストは、ビデオ、音声、およびデータを MPLS VPN ネットワーク コアにストリーミングするために使用します。

従来、ポイントツーポイント トンネルは、サービス プロバイダー ネットワークを通して接続する唯一の方法でした。このようなトンネル ネットワークは、スケーラビリティの問題が発生する傾向がありますが、IP マルチキャスト トラフィックを VPN に通過させる唯一の方法でした。

レイヤ 3 VPN はユニキャスト トラフィック接続のみをサポートするため、レイヤ 3 VPN を併用することによって、サービス プロバイダーは、レイヤ 3 VPN のカスタマーにユニキャスト接続とマルチキャスト接続の両方を提供できます。

この章で紹介する機能情報の入手方法

ご使用の Cisco OS ソフトウェア リリースでは、このモジュールで説明されるすべての機能がサポートされているとは限りません。最新の機能情報および警告については、ご使用のプラットフォームおよびソフトウェア リリースのリリースノートを参照してください。このモジュールで説明される特定機能に関する情報へのリンク、および各機能がサポートされるリリースの一覧については、「マルチキャスト VPN の設定に関する機能情報」を参照してください。

プラットフォームと Cisco IOS および Catalyst OS ソフトウェア イメージのサポート情報の検索

Cisco Feature Navigator を使用すると、プラットフォーム、Cisco IOS ソフトウェア イメージ、および Cisco Catalyst OS ソフトウェア イメージの各サポート情報を検索できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。

マルチキャスト VPN の設定に関する前提条件

このモジュールの作業を実行する前に、『 IP Multicast Technology Overview 』モジュールで説明している概念をよく理解しておく必要があります。

このモジュールの作業では、IP マルチキャストがイネーブルに設定され、『 Configuring Basic IP Multicast 』モジュールで説明されている作業を使用して、Protocol Independent Multicast(PIM)インターフェイスが設定されていることを前提とします。

マルチキャスト VPN の設定に関する制約事項

Border Gateway Protocol(BGP; ボーダー ゲートウェイ プロトコル)ピアリングのアップデート ソース インターフェイスは、デフォルト Multicast Distribution Tree(MDT; マルチキャスト配信ツリー)を適切に設定するために、ルータ上に設定されたすべての BGP で同じにする必要があります。BGP ピアリングでループバック アドレスを使用する場合、ループバック アドレスで PIM スパース モードをイネーブルにする必要があります。

分散型マルチキャスト スイッチングがそれをサポートするプラットフォームで機能するには、BGP ピアリング インターフェイスとして使用されるループバック インターフェイスで、 ip mroute-cache コマンドをイネーブルにする必要があります。 no ip mroute-cache コマンドは、これらのインターフェイスでは使用できません。

MVPN は複数の BGP ピアリング アップデート ソースをサポートしません。

デンス モードのマルチキャスト フローにはフラッディングとプルーニングという性質があり、その結果、データ MDT の周期的な始動と分解が発生するため、データ MDT は、VPN Routing and Forwarding(VRF; VPN ルーティングおよび転送)インスタンスの PIM デンス モード マルチキャスト ストリームでは作成されません。

複数の BGP アップデートソースはサポートされておらず、複数の BGP アップデートソースを設定すると、MVPN Reverse Path Forwarding(RPF; リバース パス転送)のチェックが中断する可能性があります。MVPN トンネルのソース IP アドレスは、BGP ピアリング アップデートソースで使用する最も高い IP アドレスによって決定されます。この IP アドレスが Provider Edge(PE; プロバイダー エッジ)ルータで BGP ピアリング アドレスとして使用される IP アドレスではない場合、MVPN は正しく機能しません。

マルチキャスト VPN の設定に関する情報

MVPN を設定する前に、次の概念を理解する必要があります。

「マルチキャスト VPN の操作」

「マルチキャスト VPN ルーティングおよび転送とマルチキャスト ドメイン」

「マルチキャスト配信ツリー(MDT)」

「マルチキャスト トンネル インターフェイス」

「マルチキャスト VPN に対するマルチキャスト分散スイッチング(MDS)のサポート」

「マルチキャスト VPN の利点」

マルチキャスト VPN の操作

MVPN IP では、Multiprotocol Label Switching(MPLS; マルチプロトコル ラベル スイッチング)VPN の環境で、マルチキャスト トラフィックを設定してサポートできます。この機能は、個々の VRF インスタンスでのマルチキャスト パケットのルーティングおよび転送をサポートし、サービス プロバイダーのバックボーンに VPN マルチキャスト パケットを転送するメカニズムも提供します。

VPN は、Internet Service Provider(ISP; インターネット サービス プロバイダー)などの共有インフラストラクチャにおけるネットワーク接続です。その役割は、プライベート ネットワークとして、同じポリシーとパフォーマンスを低い所有コストで提供することによって、業務とインフラストラクチャを通して、多くのコスト削減の機会を作り出すことです。

MVPN を使用すると、企業は、サービス プロバイダーのネットワーク バックボーンを介して、プライベート ネットワークを透過的に相互接続できます。MVPN を使用してエンタープライズ ネットワークをこのような方法で相互接続しても、エンタープライズ ネットワークの管理方法も企業の一般的な接続性も変わりません。

マルチキャスト VPN ルーティングおよび転送とマルチキャスト ドメイン

MVPN は、VPN ルーティングおよび転送テーブルにマルチキャスト ルーティング情報を導入します。Provider Edge(PE; プロバイダー エッジ)ルータが Customer Edge(CE; カスタマー エッジ)ルータからマルチキャスト データまたはコントロール パケットを受信すると、Multicast VPN Routing and Forwarding(MVRF; マルチキャスト VPN ルーティングおよび転送)インスタンス内の情報に応じて転送が行われます。MVPN は、ラベル スイッチングを使用しません。

相互にマルチキャスト トラフィックを送信できる MVRF のセットは、マルチキャスト ドメインを構成します。たとえば、特定のタイプのマルチキャスト トラフィックを世界のすべての従業員に送信するカスタマーのマルチキャスト ドメインは、その企業に関連付けられたすべての CE ルータで構成されます。

マルチキャスト配信ツリー(MDT)

MVPN は、各マルチキャスト ドメインに対してスタティック デフォルト MDT を確立します。デフォルト MDT は、PE ルータが使用するパスを定義し、マルチキャスト ドメインにある他のすべての PE ルータに、マルチキャスト データとコントロール メッセージを送信します。

Source Specific Multicast(SSM)がコアのマルチキャスト ルーティング プロトコルとして使用される場合、デフォルトおよびデータ Multicast Distribution Tree(MDT; マルチキャスト配信ツリー)は、すべての PE ルータと P ルータの SSM の範囲内に設定する必要があります。

また、MVPN は、高帯域幅伝送用の MDT のダイナミックな作成もサポートします。データ MDT は、Cisco IOS ソフトウェアに特有の機能です。データ MDT は、MPLS VPN コアで最適なトラフィック転送を確実に行うために、VPN 内のフルモーション ビデオなどの高帯域幅のソースで使用することを意図しています。データ MDT が作成されるしきい値は、ルータ単位または VRF 単位で設定できます。マルチキャスト伝送が定義されたしきい値を超えると、送信側の PE ルータがデータ MDT を作成し、データ MDT に関する情報を含む User Datagram Protocol(UDP; ユーザ データグラム プロトコル)メッセージをデフォルト MDT のすべてのルータに送信します。マルチキャスト ストリームがデータ MDT しきい値を超えたかどうかを判断する統計情報は、毎秒確認されます。Cisco 7500 や Cisco 12000 などの分散プラットフォームでは、これらの統計情報は、10 秒おきにルート プロセッサにアップデートされます。UDP メッセージを送信後、PE ルータは、スイッチオーバーまでさらに 3 秒待ちます。13 秒が最悪の場合のスイッチオーバー時間で、3 秒が最良の場合の時間です。

データ MDT は、VRF マルチキャスト ルーティング テーブル内の (S, G) マルチキャスト ルート エントリ専用で作成されます。個々のソースデータ レートの値に関係なく、(*, G) エントリ用には作成されません。

次の例のサービス プロバイダーは、San Jose、New York、および Dallas にオフィスがあるマルチキャスト カスタマーを持っています。San Jose では、一方向のマルチキャスト プレゼンテーションが発生しています。サービス プロバイダー ネットワークは、このカスタマーと関連する 3 つのサイトすべて、および別の企業カスタマーの Houston サイトをサポートします。

企業カスタマーのデフォルト MDT は、プロバイダーのルータ P1、P2、P3、およびその関連 PE ルータで構成されています。PE4 は、別のカスタマーと関連しているので、デフォルト MDT の一部ではありません。図 1 は、San Jose の外側でマルチキャストに加入するユーザがいないため、デフォルト MDT でのデータ フローがないことを示しています。

図 1 デフォルト マルチキャスト配信ツリーの概要

 

New York の従業員がマルチキャスト セッションに加入します。New York サイトに関連する PE ルータは、カスタマーのマルチキャスト ドメインのデフォルト MDT に流れる加入要求を送信します。PE1(マルチキャスト セッションソースに関連する PE ルータ)は、この要求を受信します。図 2 は、マルチキャスト ソース(CE1a)に関連する CE ルータに、PE ルータが要求を転送する方法を示します。

図 2 データ MDT の初期化

 

CE ルータ(CE1a)は、デフォルト MDT に沿ってマルチキャスト データを送信する関連 PE ルータ(PE1)に、マルチキャスト データを送信し始めます。マルチキャスト データが送信されるとすぐに、PE1 は、マルチキャスト データがデータ MDT を作成する帯域幅しきい値を超えたことを認識します。したがって、PE1 はデータ MDT を作成し、データ MDT に関する情報を含むデフォルト MDT を使用して、すべてのルータにメッセージを送信し、3 秒後、データ MDT を使用して、その特定のストリームのマルチキャスト データを送信し始めます。このソースに関係する受信先は PE2 だけにあるので、PE2 だけがデータ MDT に加入し、データ MDT でトラフィックを受信します。

PE ルータは、直接接続された PE ルータとの PIM 関係だけでなく、デフォルト MDT の他の PE ルータとの PIM 関係も維持します。

マルチキャスト トンネル インターフェイス

マルチキャスト ドメインごとに作成される MVRF では、ルータは、すべての MVRF トラフィックが発信されるトンネル インターフェイスを作成する必要があります。マルチキャスト トンネル インターフェイスは、MVRF がマルチキャスト ドメインにアクセスするために使用するインターフェイスです。MVRF とグローバル MVRF を接続するコンジットとみなすことができます。MVRF ごとに 1 つのトンネル インターフェイスが作成されます。

マルチキャスト VPN に対するマルチキャスト分散スイッチング(MDS)のサポート

Multicast Distributed Switching(MDS; マルチキャスト分散スイッチング)は、Cisco 7500 シリーズ ルータの MVPN でサポートされています。MDS が設定されている場合、IP マルチキャストでイネーブルなすべてのインターフェイスで、MDSが正しくイネーブル化されていることを確認し、すべてのインターフェイスに no ip mroute-cache コマンドが設定されていない(ループバック インターフェイスを含む)ことを確認します。

マルチキャスト VPN の利点

複数の場所に情報を動的に送信するスケーラブルなソリューションを提供します。

情報を高速で配信します。

共有インフラストラクチャを介して接続します。

マルチキャスト VPN の設定方法

ここでは、次の各手順について説明します。

「VRF でのデフォルト MDT グループの設定」(必須)

「マルチキャスト VPN での BGP の MDT アドレス ファミリの設定」(必須)

「データ マルチキャスト グループの設定」(任意)

「マルチキャスト ルートおよび情報の設定」(任意)

「MDT デフォルト グループの情報の確認」(任意)

VRF でのデフォルト MDT グループの設定

VRF にデフォルト MDT グループを設定するには、次の作業を実行します。

デフォルト MDT グループは、同じ VPN に属するすべてのルータに設定された同じグループである必要があります。ソース IP アドレスは、BGP セッションを送信するために使用するアドレスになります。

手順の概要

1. enable

2. configure terminal

3. ip multicast-routing

4. ip multicast-routing vrf vrf-name

5. ip vrf vrf-name

6. mdt default group-address

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip multicast-routing

 

Router(config)# ip multicast-routing

マルチキャスト ルーティングをイネーブルにします。

ステップ 4

ip multicast-routing vrf vrf-name

 

Router(config)# ip multicast-routing vrf vrf1

マルチキャスト VPN VRF インスタンスをサポートします。

ステップ 5

ip vrf vrf-name

 

Router(config)# ip vrf vrf1

VRF コンフィギュレーション モードを開始し、VRF 名を割り当てることによって、VPN ルーティング インスタンスを定義します。

ステップ 6

mdt default group-address

 

Router(config-vrf)# mdt default 232.0.0.1

VRF に、データ Multicast Distribution Tree(MDT; マルチキャスト配信ツリー)グループのマルチキャスト グループ アドレスの範囲を設定します。

このコマンドによって、トンネル インターフェイスが作成されます。

デフォルトでは、トンネル ヘッダーの宛先アドレスは、 group-address 引数です。

マルチキャスト VPN での BGP の MDT アドレス ファミリの設定

PE ルータに MDT アドレス ファミリ セッションを設定し、MVPN の MDT ピアリング セッションを確立するには、次の作業を実行します。

MDT アドレス ファミリ セッションを設定するために、 mdt キーワードが address-family ipv4 コマンドに追加されました。MDT アドレス ファミリ セッションは、BGP MDT Subaddress Family Identifier(SAFI)のアップデートを使用して、ソース PE アドレスと MDT グループ アドレスを PIM に渡すために使用されます。

マルチキャスト VPN サポートの BGP アドバタイズメント方式

1 つの自律システムで、MVPN のデフォルト MDT が Rendezvous Point(RP; ランデブー ポイント)のある PIM Sparse Mode(PIM-SM; スパース モード)を使用している場合、ソース PE とレシーバ PE は RP を通して互いを検出するため、PIM は、Multicast Tunnel Interface(MTI; マルチキャスト トンネル インターフェイス)に隣接を確立できます。このシナリオでは、ローカル PE(ソース PE)は RP にレジスタ メッセージを送信し、RP はソース PE への Shortest-Path Tree(SPT)を作成します。MDT マルチキャスト グループのレシーバの役割を果たすリモート PE は、RP に (*, G) 加入を送信し、そのグループの配信ツリーに加入します。

ただし、デフォルト MDT グループが PIM-SM 環境ではなく PIM Source Specific Multicast(PIM-SSM)環境で設定されている場合、レシーバ PE には、ソース PE とデフォルト MDT グループに関する情報が必要です。この情報は、ソース PE に (S, G) 加入を送信し、ソース PE からの配信ツリーを作成するために使用されます(RP は不要)。ソース PE アドレスとデフォルト MDT グループ アドレスは、BGP を使用して送信されます。

表 1 に、ソース PE アドレスとデフォルト MDT グループを送信するために(Cisco IOS リリースで)使用できる BGP アドバタイズメント方式を示します。

 

表 1 MVPN の BGP アドバタイズメント方式

Cisco IOS リリース
BGP アドバタイズメント方式

Release 12.0(29)S

Release 12.2(33)SRA1

Release 12.2(31)SB2

Release 12.2(33)SXH

拡張コミュニティ

Release 12.0(29)S およびそれ以降の 12.0S リリース

Release12.2(31)SB2 およびそれ以降の 12.2SB リリース

Release12.2(33)SRA およびそれ以降の 12.2SR リリース

Release12.2(33)SXH およびそれ以降の 12.2SX リリース

BGP アドレス ファミリ MDT SAFI

BGP 拡張コミュニティ

BGP 拡張コミュニティを使用すると、PE ループバック(ソース アドレス)の情報は、Route Distinguisher(RD; ルート識別子)タイプ 2 を使用して(ユニキャスト VPNv4 プレフィクスと区別するため)、VPNv4 として送信されます。MDT グループ アドレスは、BGP 拡張コミュニティで送信されます。VPNv4 アドレスの組み込みソースと拡張コミュニティのグループの組み合わせを使用して、同じ MVRF インスタンス内の PE ルータは、相互に SSM ツリーを確立できます。


) MDT SAFI サポートが導入される前、BGP 拡張コミュニティのアトリビュートは、IETF によって標準化される前のソース PE およびデフォルト MDT グループの IP アドレスをアドバタイズするための暫定的ソリューションとして使用されていました。ただし、MVPN 環境での BGP 拡張コミュニティのアトリビュートには、制約事項があります。このアトリビュートは AS 間でのシナリオには使用できず(アトリビュートが非推移的であるため)、RD タイプ 2(サポートされた標準ではない)を使用します。


BGP MDT SAFI

MDT SAFI をサポートする Cisco IOS リリースでは、ソース PE アドレスと MDT グループ アドレスは、BGP MDT SAFI アップデートを使用して PIM に渡されます。RD のタイプは RD タイプ 0 に変わり、BGP は、情報を PIM に渡す前に、MDT アップデートの最良のパスを決定します。


) 下位互換性の問題を防ぐために、BGP は、MDT SAFI アドレス ファミリを認識できないピアとの旧式アップデートの通信を可能にします。


MDT SAFI をサポートする Cisco IOS リリースでは、MDT SAFI アドレス ファミリは、 address-family ipv4 mdt コマンドを使用して、BGP ネイバーに明示的に設定する必要があります。MDT SAFI をサポートしないネイバーは、ローカル BGP の設定において、MDT SAFI でイネーブルにする必要があります。MDT SAFI が導入される前、VPNv4 ユニキャスト設定からの追加の BGP 設定は、MVPN をサポートするために必要ではありませんでした。

新しい MDT SAFI が BGP ルートターゲット拡張コミュニティを使用しないため、これらのアップデートをフィルタリングする通常の拡張コミュニティは、もはや適用されません。その結果、Access Control List(ACL; アクセス制御リスト)を使用して、MDT グループ アドレスでフィルタリングを行うために、 match mdt-group ルートマップ コンフィギュレーション コマンドが追加されました。これらのルートマップ(インバウンドまたはアウトバウンド)は、IPv4 MDT アドレス ファミリのネイバー設定に適用できます。

MDT SAFI への自動移行

Cisco IOS Release 12.0(30)S3 では、MDT SAFI への移行を容易にするために、MDT SAFI 機能への自動移行が導入されました。この機能は、Cisco IOS Release 12.2(33)SRA1、12.2(31)SB2、および 12.2(33)SXH に統合されました。Cisco IOS リリースを MDT SAFI に移行する場合、既存の VPNv4 ネイバーは、既存のデフォルト MDT 設定の存在に基づいて、起動時に自動的に MDT SAFI に設定されます(つまり、MDT SAFI よりも前の設定は、起動時に自動的に MDT SAFI 設定に変換されます)。さらに、デフォルト MDT 設定が存在し、BGP の VPNv4 ネイバーが設定されている場合、IPv4 MDT アドレス ファミリ内の同様のネイバーは、自動的に設定されます。


) Route Reflector(RR; ルート リフレクタ)には VRF 設定がないため、MDT SAFI への自動移行は、RR でトリガーされません。したがって、MDT SAFI 設定は、RR で手動で設定する必要があります。均一の MDT 伝送方式を使用すると、ルータでの処理時間が短縮されます(MDT SAFI の変換が不要であるため)。


MDT SAFI 設定時の注意事項

MVPN に参加するすべてのルータで MDI SAFI を設定することを推奨しました。MDT SAFI の利点が SSM ツリーの作成のためであったとしても、MDT SAFI は、PIM-SM 用のデフォルト MDT グループとともに MVPN を使用する場合にも設定する必要があります。マルチキャストの観点から見ると、MDT SAFI は、MVPN が PIM-SM コア内で機能するために必要ではありません。ただし、特定のシナリオでは、新しいアドレス ファミリは、MTI を作成するために設定する必要があります。この通知がない場合、MTI は作成されず、MVPN は機能しません(PIM-SM がある場合でも)。

下位互換性のあるセッションでは、拡張コミュニティは、すべての MDT SAFI ピアでイネーブルにする必要があります。純粋な MDT SAFI 環境では、MVPN 用に明示的に拡張コミュニティを設定する必要はありません。ただし、拡張コミュニティは、VPNv4 内部の BGP(iBGP)セッションがルートターゲットをリレーするには必要です。ハイブリッド(MDT SAFI および MDT SAFI よりも前)環境では、拡張コミュニティは、VPNv4 アドレスと MDT グループ アドレスの組み込みソースを MDT SAFI ネイバーに送信するように設定する必要があります。

MDT SAFI サポートのためのネットワーク アップグレード時の注意事項

MDT SAFI よりも前の環境から MDT SAFI 環境に移行する場合、MVPN サービスに対する影響を最小限に抑えるように、細心の注意を払う必要があります。ユニキャスト サービスは、リロードおよび回復による停止を除いて、影響を受けません。MDT SAFI をサポートするようにネットワークをアップグレードするには、次の手順を行うことを推奨します。

1. MVPN 内の PE を、MDT SAFI をサポートする Cisco IOS リリースにアップグレードします。起動時、PE の設定は、MDT SAFI に自動移行されます。MDT SAFI 機能への自動移行の詳細については、「MDT SAFI への自動移行」の項を参照してください。

2. PE のアップグレード後、RR をアップグレードし、MVPN サービスを提供するすべてのピアで MDT SAFI をイネーブルにします。MDT SAFI をディセーブルまたはイネーブルにすると、すべてのアドレス ファミリの BGP ピア関係がリセットされます。このため、ルーティング情報が失われる可能性があります。


) マルチホーム BGP RR シナリオの場合、最後にいずれかの RR をアップグレードし、設定する必要があります。アップグレードされた PE は、その他の RR をアップグレードしている間に、この RR を使用して MDT アドバタイズメントをリレーします。


サポートされているポリシー

MDT SAFI では、次のポリシー設定パラメータがサポートされています。

AS パス、Multi-Exit Discriminator(MED)、BGP ローカル プレファレンスなどの必須アトリビュートや周知のアトリビュート、およびネクスト ホップ アトリビュート

標準コミュニティ、コミュニティ リスト、およびルート マップ

前提条件

MDT アドレス ファミリを通して MVPN ピアリングを確立する前に、CE ルータに VPN サービスを提供する PE ルータ上の BGP ネットワークおよびマルチプロトコル BGP に、MPLS および Cisco Express Forwarding(CEF; シスコ エクスプレス フォワーディング)を設定する必要があります。

制約事項

次のポリシー設定パラメータは、サポートされていません。

ルートオリジネータ アトリビュート

Network Layer Reachability Information(NLRI; ネットワーク レイヤ到着可能性情報)プレフィクス フィルタリング(プレフィクス リスト、配信リスト)

拡張コミュニティ アトリビュート(ルート ターゲットおよび発信元サイト)

手順の概要

1. enable

2. configure terminal

3. router bgp as-number

4. address-family ipv4 mdt

5. neighbor neighbor-address activate

6. neighbor neighbor-address send-community [ both | extended | standard ]

7. exit

8. address-family vpnv4

9. neighbor neighbor-address activate

10. neighbor neighbor-address send-community [ both | extended | standard ]

11. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router bgp as-number

 

Router(config)# router bgp 65535

ルータ コンフィギュレーション モードを開始し、BGP ルーティング プロセスを作成します。

ステップ 4

address-family ipv4 mdt

 

Router(config-router)# address-family ipv4 mdt

アドレス ファミリ コンフィギュレーションを開始し、IP MDT アドレス ファミリ セッションを作成します。

ステップ 5

neighbor neighbor-address activate

 

Router(config-router-af)# neighbor 192.168.1.1 activate

このネイバーの MDT アドレス ファミリをイネーブルにします。

ステップ 6

neighbor neighbor-address send-community [ both | extended | standard ]

 

Router(config-router-af)# neighbor 192.168.1.1 send-community extended

指定されたネイバーとのコミュニティおよび(または)拡張コミュニティの交換をイネーブルにします。

ステップ 7

exit

 

Router(config-router-af)# exit

アドレス ファミリ コンフィギュレーション モードを終了し、ルータ コンフィギュレーション モードに戻ります。

ステップ 8

address-family vpnv4

 

Router(config-router)# address-family vpnv4

アドレス ファミリ コンフィギュレーション モードを開始し、VPNv4 アドレス ファミリ セッションを作成します。

ステップ 9

neighbor neighbor-address activate

 

Router(config-router-af)# neighbor 192.168.1.1 activate

このネイバーの VPNv4 アドレス ファミリをイネーブルにします。

ステップ 10

neighbor neighbor-address send-community [ both | extended | standard ]

 

Router(config-router-af)# neighbor 192.168.1.1 send-community extended

指定されたネイバーとのコミュニティおよび(または)拡張コミュニティの交換をイネーブルにします。

ステップ 11

end

 

Router(config-router-af)# end

アドレス ファミリ コンフィギュレーション モードを終了し、特権 EXEC モードを開始します。

データ マルチキャスト グループの設定

データ MDT グループを設定するには、次の作業を実行します。

データ MDT グループには、1 つの PE ルータにおける 1 つの VRF の 1 つの VPN 当たり、最大 256 のマルチキャスト グループを含めることができます。データ MDT グループを作成するために使用されるマルチキャスト グループは、設定された IP アドレスのプールから動的に選択されます。

前提条件

デフォルト MDT グループを設定する前に、マルチキャスト ルーティングに VPN を設定する必要があります(「VRF でのデフォルト MDT グループの設定」を参照)。

このモジュールの作業に必要なアクセス リストはすべて、設定作業の開始前に設定している必要があります。アクセス リストの設定方法については、『 Creating an IP Access List and Applying It to an Interface 』モジュールを参照してください。

手順の概要

1. enable

2. configure terminal

3. ip vrf vrf-name

4. mdt data group-address-range wildcard-bits [ threshold kb/s ] [ list access-list ]

5. mdt log-reuse

6. exit

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip vrf vrf-name

 

Router(config)# ip vrf vrf1

VRF コンフィギュレーション モードを開始し、VRF 名を割り当てることによって、VPN ルーティング インスタンスを定義します。

ステップ 4

mdt data group-address-range wildcard-bits [ threshold kb/s ] [ list access-list ]

 

Router(config-vrf)# mdt data 239.192.20.32 0.0.0.15 threshold 1

データ MDT プールで使用するアドレスの範囲を指定します。

group-address-range 引数および wildcard-bits 引数には、マルチキャスト グループ アドレスの範囲を指定します。値の範囲は 224.0.0.1 ~ 239.255.255.255 です。データ MDT プールで使用されるアドレスの範囲は、マルチキャスト グループ アドレス(クラス D アドレス)であるため、サブネットの概念がありません。したがって、 wildcard-bits 引数に指定するマスク(ワイルドカード)の範囲にあるすべてのアドレスを使用できます。

しきい値の単位は kb/s です。値の範囲は 1 ~ 4294967 です。

オプションの list キーワードと access-list 引数を使用して、データ MDT プールで使用する (S, G) MVPN エントリを定義します。これによって、データ MDT プールの作成は、 access-list 引数に指定されたアクセス リストで定義された特定の (S, G) MVPN エントリにさらに限定されます。

ステップ 5

mdt log-reuse

 

Router(config-vrf)# mdt log-reuse

(任意)データ Multicast Distribution Tree(MDT; マルチキャスト配信ツリー)再使用の記録をイネーブルにし、データ MDT が再使用された場合に、syslog メッセージを生成します。

ステップ 6

exit

 

Router(config-vrf)# exit

グローバル コンフィギュレーション モードに戻ります。

マルチキャスト ルートおよび情報の設定

ルータに追加できるマルチキャスト ルートの数を制限するには、次の作業を実行します。

前提条件

デフォルト MDT グループを設定する前に、マルチキャスト ルーティングに VPN を設定する必要があります(「VRF でのデフォルト MDT グループの設定」を参照)。

このモジュールの作業に必要なアクセス リストはすべて、設定作業の開始前に設定している必要があります。アクセス リストの設定方法については、『 Creating an IP Access List and Applying It to an Interface 』モジュールを参照してください。

手順の概要

1. enable

2. configure terminal

3. ip multicast vrf vrf-name route-limit limit [ threshold ]

4. ip multicast mrinfo-filter access-list

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip multicast vrf vrf-name route-limit limit [ threshold ]

 

Router(config)# ip multicast vrf cisco route-limit 200000 20000

mroute limit パラメータおよびしきい値パラメータを設定します。

ステップ 4

ip multicast mrinfo-filter access-list

 

Router(config)# ip multicast mrinfo-filter 4

アクセス リストで指定されたすべてのソースのマルチキャスト ルータ情報要求パケットをフィルタリングします。

MDT デフォルト グループの情報の確認

MDT デフォルト グループに関する情報を確認するには、次の作業を実行します。

手順の概要

1. enable

2. show ip msdp [ vrf vrf-name ] peer [ peer-address | peer-name ]

3. show ip msdp [ vrf vrf-name ] summary

4. show ip pim [ vrf vrf-name ] mdt bgp

5. show ip pim [ vrf vrf-name ] mdt send

6. show ip pim mdt history

手順の詳細


ステップ 1 enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

 

Router> enable

 

ステップ 2 show ip msdp [ vrf vrf-name ] peer [ peer-address | peer-name ]

show ip msdp peer コマンドを入力し、MSDP ピア 224.135.250.116 に関する詳細情報を確認します。

Router# show ip msdp peer 224.135.250.116
 
MSDP Peer 224.135.250.116 (rtp5-rp1.cisco.com), AS 109 (configured AS)
Description:
Connection status:
State: Up, Resets: 9, Connection source: Loopback2 (228.69.199.17)
Uptime(Downtime): 1d10h, Messages sent/received: 436765/429062
Output messages discarded: 0
Connection and counters cleared 1w2d ago
SA Filtering:
Input (S,G) filter: none, route-map: none
Input RP filter: none, route-map: none
Output (S,G) filter: none, route-map: none
Output RP filter: none, route-map: none
SA-Requests:
Input filter: none
Sending SA-Requests to peer: disabled
Peer ttl threshold: 0
SAs learned from this peer: 32, SAs limit: 500
Input queue size: 0, Output queue size: 0
 

ステップ 3 show ip msdp [ vrf vrf-name ] summary

show ip msdp summary コマンドを入力し、MSDP ピアのステータスを表示します。

Router# show ip msdp summary
 
MSDP Peer Status Summary
Peer Address AS State Uptime/ Reset SA Peer Name
Downtime Count Count
224.135.250.116 109 Up 1d10h 9 111 rtp5-rp1
*144.228.240.253 1239 Up 14:24:00 5 4010 sl-rp-stk
172.16.253.19 109 Up 12:36:17 5 10 rtp4-rp1
172.16.170.110 109 Up 1d11h 9 12 ams-rp1
 

ステップ 4 show ip pim [ vrf vrf-name ] mdt bgp

MDT デフォルト グループの Route Distinguisher(RD; ルート識別子)の BGP アドバタイズメントに関する情報を表示して確認するには、EXEC モードで show ip pim mdt bgp コマンドを使用します。

Router# show ip pim mdt bgp

MDT-default group 232.2.1.4 rid:1.1.1.1 next_hop:1.1.1.1
 

ステップ 5 show ip pim [ vrf vrf-name ] mdt send

MDT データ グループに関する詳細情報を表示して確認するには、次の手順を行います。

show ip pim mdt send コマンドを入力し、指定されたルータが作成した MDT アドバタイズメントを表示します。

 
Router# show ip pim mdt send
 
MDT-data send list for VRF:vpn8
(source, group) MDT-data group ref_count
(10.100.8.10, 225.1.8.1) 232.2.8.0 1
(10.100.8.10, 225.1.8.2) 232.2.8.1 1
(10.100.8.10, 225.1.8.3) 232.2.8.2 1
(10.100.8.10, 225.1.8.4) 232.2.8.3 1
(10.100.8.10, 225.1.8.5) 232.2.8.4 1
(10.100.8.10, 225.1.8.6) 232.2.8.5 1
(10.100.8.10, 225.1.8.7) 232.2.8.6 1
(10.100.8.10, 225.1.8.8) 232.2.8.7 1
(10.100.8.10, 225.1.8.9) 232.2.8.8 1
(10.100.8.10, 225.1.8.10) 232.2.8.9 1
 

ステップ 6 show ip pim mdt history

show ip pim mdt history コマンドを入力し、過去に設定された間隔で再使用されたデータ MDT を表示します。

Router# show ip pim vrf vrf1 mdt history interval 20
 
MDT-data send history for VRF - vrf1 for the past 20 minutes
 
 
MDT-data group Number of reuse
10.9.9.8 3
10.9.9.9 2

マルチキャスト VPN の設定例

ここでは、次の設定例を示します。

「MVPN および SSM の設定:例」

「マルチキャスト ルーティングでの VPN のイネーブル化:例」

「マルチキャスト VPN での BGP の MDT アドレス ファミリの設定:例」

「データ MDT グループでのマルチキャスト グループ アドレス範囲の設定:例」

「レジスタ メッセージの IP ソース アドレスの設定:例」

「MSDP ピアの設定:例」

「マルチキャスト ルートの数の制限:例」

MVPN および SSM の設定:例

次の例では、PIM-SSM はバックボーンに設定されます。したがって、デフォルトおよびデータ MDT グループは、IP アドレスの SSM 範囲内に設定されます。VPN 内では、PIM-SM が設定され、Auto-RP アナウンスメントだけが受け入れられます。

ip vrf vrf1
rd 1:1
route-target export 1:1
route-target import 1:1
mdt default 232.0.0.1
mdt data 232.0.1.0 0.0.0.255 threshold 500 list 101
!
ip pim ssm default
ip pim vrf vrf1 accept-rp auto-rp

マルチキャスト ルーティングでの VPN のイネーブル化:例

次の例では、マルチキャスト ルーティングは、vrf1 という VPN ルーティング インスタンスを使用してイネーブル化されます。

ip multicast-routing vrf1

マルチキャスト VPN での BGP の MDT アドレス ファミリの設定:例

次の例では、MDT アドレス ファミリ セッションは、MVPN の MDT ピアリング セッションを確立するために、PE ルータに設定されます。

!
ip vrf test
rd 55:2222
route-target export 55:2222
route-target import 55:2222
mdt default 232.0.0.1
!
ip multicast-routing
ip multicast-routing vrf test
!
router bgp 55
.
.
.
!
address-family vpnv4
neighbor 192.168.1.1 activate
neighbor 192.168.1.1 send-community both
!
address-family ipv4 mdt
neighbor 192.168.1.1 activate
neighbor 192.168.1.1 send-community both
!

データ MDT グループでのマルチキャスト グループ アドレス範囲の設定:例

次の例では、VPN ルーティング インスタンスは、blue という VRF が割り当てられます。VPN VRF の MDF デフォルト グループは 239.1.1.1 です。MDT グループのマルチキャスト グループ アドレス範囲は 239.1.2.0 で、0.0.0.3 のワイルドカード ビットがあります。

ip vrf blue
rd 55:1111
route-target both 55:1111
mdt default 239.1.1.1
mdt data 239.1.2.0 0.0.0.3
end

レジスタ メッセージの IP ソース アドレスの設定:例

次の例では、レジスタ メッセージの IP ソース アドレスは、DR のイーサネット インターフェイス 1/0/1 に設定されます。

ip pim register-source Ethernet1/0/1

MSDP ピアの設定:例

次の例では、MSDP ピアは、vrf1 という VPN ルーティング インスタンスおよびイーサネット インターフェイス 1/0/1 からのソース 10.10.0.1 を使用して設定されます。

ip msdp vrf vrf1 peer 10.10.0.1 connect-source Ethernet 1/0/1

マルチキャスト ルートの数の制限:例

次の例では、マルチキャスト ルーティング テーブルに追加できるマルチキャスト ルートの数は 200,000 に設定され、警告メッセージを発生させる mroute の数のしきい値は、20,000 に設定されます。

!
ip multicast-routing distributed
ip multicast-routing vrf cisco distributed
ip multicast cache-headers
ip multicast route-limit 200000 20000
ip multicast vrf cisco route-limit 200000 20000
no mpls traffic-eng auto-bw timers frequency 0
!

その他の参考資料

ここでは、マルチキャスト VPN の設定に関する参考資料について説明します。

関連資料

関連項目
参照先

エクストラネット MVPN の概念、作業、および設定例

Configuring Multicast VPN Extranet Support 』モジュール

AS 間の MVPN の概念、作業、および設定例

Configuring Multicast VPN Inter-AS Support 』モジュール

MVPN MIB の概念と作業

Multicast VPN MIB 』モジュール

IP マルチキャスト コマンド:コマンド構文の詳細、コマンド モード、コマンド履歴、デフォルト設定、使用に関する注意事項、および例

Cisco IOS IP Multicast Command Reference , Release 12.4』

規格

規格
タイトル

この機能がサポートする新しい規格または変更された規格はありません。また、この機能で変更された既存規格のサポートはありません。

--

MIB

MIB
MIB リンク

CISCO_MVPN_MIB.my

選択したプラットフォーム、Cisco IOS リリース、および機能セットの MIB を検索してダウンロードする場合は、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFC

RFC
タイトル

この機能がサポートする新しい RFC または変更された RFC はありません。また、この機能で変更された既存 RFC のサポートはありません。

--

シスコのテクニカル サポート

説明
リンク

右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。

以下を含むさまざまな作業にこの Web サイトが役立ちます。
・テクニカル サポートを受ける
・ソフトウェアをダウンロードする
・セキュリティの脆弱性を報告する、またはシスコ製品のセキュリティ問題に対する支援を受ける
・ツールおよびリソースへアクセスする
- Product Alert の受信登録
- Field Notice の受信登録
- Bug Toolkit を使用した既知の問題の検索
・Networking Professionals(NetPro)コミュニティで、技術関連のディスカッションに参加する
・トレーニング リソースへアクセスする
・TAC Case Collection ツールを使用して、ハードウェアや設定、パフォーマンスに関する一般的な問題をインタラクティブに特定および解決する

この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

http://www.cisco.com/techsupport

マルチキャスト VPN の設定に関する機能情報

表 2 に、この機能のリリース履歴を示します。

表 2 に、このモジュールで説明した機能をリストし、特定の設定情報へのリンクを示します。この表には、Cisco IOS Release 12.2(1)、12.0(3)S、または以降のリリースで導入または変更された機能だけを示します。

ここに記載されていないこのテクノロジーの機能情報については、『 IP Multicast Features Roadmap 』を参照してください。

ご使用の Cisco IOS ソフトウェア リリースによっては、コマンドの中に一部使用できないものがあります。特定のコマンドに関するリリース情報については、コマンド リファレンス マニュアルを参照してください。

Cisco Feature Navigator を使用すると、プラットフォームおよびソフトウェア イメージのサポート情報を検索できます。Cisco Feature Navigator を使用すると、Cisco IOS および Catalyst OS ソフトウェア イメージがサポートする特定のソフトウェア リリース、機能セット、またはプラットフォームを確認できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。


表 2 には、一連の Cisco IOS ソフトウェア リリースのうち、特定の機能が初めて導入された Cisco IOS ソフトウェア リリースだけが記載されています。特に明記されていない限り、Cisco IOS ソフトウェア リリース群の後続のリリースでもこの機能をサポートします。


 

表 2 マルチキャスト VPN の設定に関する機能情報

機能名
リリース
機能情報

マルチキャスト VPN(MPLS VPN の IP マルチキャスト サポート)

12.0(23)S
12.2(13)T
12.2(14)S
12.0(25)S1
12.0(26)S
12.0(32)SY
15.0(1)S

マルチキャスト VPN 機能を使用すると、レイヤ 3 Virtual Private Network(VPN; バーチャル プライベート ネットワーク)でのマルチキャストをサポートできます。企業がマルチキャスト アプリケーションの範囲を拡大するにつれて、サービス プロバイダーは、これらの企業に Multiprotocol Label Switching(MPLS; マルチプロトコル ラベル スイッチング)コア ネットワーク上で対応できます。IP マルチキャストは、ビデオ、音声、およびデータを MPLS VPN ネットワーク コアにストリーミングするために使用します。

この章では、この機能について説明します。