IP マルチキャスト コンフィギュレーション ガイド、 Cisco IOS Release 15.1S
基本 IP マルチキャストの設定
基本 IP マルチキャストの設定
発行日;2012/02/05 | 英語版ドキュメント(2011/04/17 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 8MB) | フィードバック

目次

基本 IP マルチキャストの設定

機能情報の入手方法

この章の構成

基本的な IP マルチキャスト設定の前提条件

基本的な IP マルチキャストの設定方法

自動ランデブー ポイント(Auto-RP)でのスパース モードの設定

PIM ネットワークでの Auto-RP のロール

IP マルチキャスト境界

PIM ネットワークでの Auto-RP の利点

前提条件

制約事項

次の作業

エニーキャスト RP でのスパース モードの設定

Multicast Source Discovery Protocol の概要

エニーキャスト RP の概要

次の作業

ブートストラップ ルータでのスパース モードの設定

BSR の選定と機能

BSR 境界インターフェイス

次の作業

単一のスタティック RP でのスパース モードの設定

スタティック RP

前提条件

制約事項

次の作業

Source Specific Multicast(SSM)の設定

SSM のコンポーネント

SSM とインターネット標準マルチキャスト(ISM)の違い

SSM 処理

Source Specific Multicast の利点

前提条件

制約事項

次の作業

双方向 PIM(Bidir-PIM)の設定

双方向 PIM の利点

マルチキャスト グループ モード

双方向共有ツリー

DF 選定

双方向グループ ツリー ビルディング

パケット転送

前提条件

基本的な IP マルチキャストの設定例

例:Auto-RP でのスパース モード

例:エニーキャスト RP でのスパース モード

例:ブートストラップ ルータでのスパース モード

例:BSR および RFC 2362 の相互利用可能な候補 RP

例:単一のスタティック RP でのスパース モード

例:IGMPv3 を使用した SSM

例:SSM フィルタリング

例:Bidir-PIM

その他の参考資料

関連資料

規格

MIB

RFC

シスコのテクニカル サポート

基本的な IP マルチキャスト設定の機能情報

基本 IP マルチキャストの設定

IP マルチキャストは、単一の情報ストリームを何千もの潜在的な企業および家庭に同時に配信することによってトラフィックを削減する帯域幅節約テクノロジーです。マルチキャストを利用するアプリケーションには、ビデオ会議、企業コミュニケーション、通信教育、およびソフトウェア、株価情報、ニュースの配信などが含まれます。このモジュールでは、基本的な IP マルチキャストの設定に使用する作業について説明します。

機能情報の入手方法

ご使用のソフトウェア リリースで、このモジュールで説明されるすべての機能がサポートされているとは限りません。最新の機能情報および警告については、ご使用のプラットフォームおよびソフトウェア リリースのリリースノートを参照してください。このモジュールに記載されている機能に関する情報を検索したり、各機能がサポートされているリリースに関するリストを参照したりするには、「基本的な IP マルチキャスト設定の機能情報」を参照してください。

Cisco Feature Navigator を使用すると、プラットフォームおよび Cisco ソフトウェア イメージのサポート情報を検索できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。

基本的な IP マルチキャスト設定の前提条件

このモジュールの作業を実行する前に、『 IP Multicast Technology Overview 』モジュールで説明している概念をよく理解しておく必要があります。

このモジュールに含まれているうちのどの作業を実行する必要があるのか判断するには、どの Protocol Independent Multicast(PIM)モードを使用するかを決定する必要があります。この決定は、ネットワーク上でサポートするアプリケーションによって異なります。

このモジュールの作業で使用するアクセス リストはすべて、設定作業の開始前に設定している必要があります。アクセス リストの設定方法については、『 Creating an IP Access List and Applying It to an Interface 』モジュールを参照してください。

基本的な IP マルチキャストの設定方法

ここで説明する作業では、基本的な IP マルチキャスト モードを設定します。ここでの作業はどれも必須ではありません。しかし、ネットワーク内の IP マルチキャストを設定するためには、少なくとも 1 つは作業を実行する必要があります。複数の作業が必要な場合もあります。ここでは、次の作業について説明します。

「自動ランデブー ポイント(Auto-RP)でのスパース モードの設定」

「エニーキャスト RP でのスパース モードの設定」

「ブートストラップ ルータでのスパース モードの設定」

「単一のスタティック RP でのスパース モードの設定」

「Source Specific Multicast(SSM)の設定」

「双方向 PIM(Bidir-PIM)の設定」

自動ランデブー ポイント(Auto-RP)でのスパース モードの設定

ここでは、Auto-Rendezvous Point(Auto-RP; 自動ランデブー ポイント)とその設定方法について説明します。Auto-RP は任意でエニーキャスト RP でも使用できます。これについては、「エニーキャスト RP でのスパース モードの設定」で説明しています。


) Auto-RP と Bootstrap Router(BSR; ブートストラップ ルータ)の同時配備はサポートされていません。


PIM ネットワークでの Auto-RP のロール

Auto-RP は、PIM ネットワークにおけるグループから Rendezvous Point(RP; ランデブー ポイント)へのマッピングの配信を自動化します。Auto-RP が機能するためには、RP 通知メッセージを RP から受信して競合を解決する RP マッピング エージェントとしてルータが指定されている必要があります。その後、RP マッピング エージェントは、デンス モード フラッディングにより、グループから RP への一貫したマッピングを他のすべてのルータに送信するようになります。

これにより、すべてのルータは、サポート対象のグループに使用する RP を自動的に検出します。インターネット割り当て番号局(IANA)は、224.0.1.39 と 224.0.1.40 という 2 つのグループ アドレスを Auto-RP 用に割り当てています。

マッピング エージェントは Candidate-RP(C-RP; 候補 RP)から RP になりたいという通知を受けます。その後、マッピング エージェントが RP 選定の結果を通知します。この通知は、他のマッピング エージェントによる決定とは別に行われます。

IP マルチキャスト境界

図 1 に示すように、アドレス スコーピングによってドメイン境界が定義されます。このため、同じ IP アドレスの RP を持つドメインは互いにリークしません。スコーピングは大規模なドメイン内のサブネット境界とドメインとインターネット間の境界で実行されます。

図 1 境界でのアドレス スコーピング

 

ip multicast boundary コマンドと access-list 引数を使用して、マルチキャスト グループ アドレスに対してインターフェイス上で管理用スコープの境界を設定できます。標準のアクセス リストは影響を受けるアドレスの範囲を定義します。境界が設定されると、境界を越えるいずれの方向からのマルチキャスト データ パケットのフローも許可されません。境界は異なる管理ドメインで同じマルチキャスト グループ アドレスの再使用を許可します。

Internet Assigned Numbers Authority(IANA; インターネット割り当て番号局)はマルチキャスト アドレス範囲 239.0.0.0 ~ 239.255.255.255 を管理用スコープのアドレスとして指定しています。このアドレス範囲は、別の組織に管理されているドメインで再使用できます。これらは、グローバルに一意ではなくローカルとみなされます。

filter-autorp キーワードを設定して、管理用スコープの境界で Auto-RP 検出と通知メッセージを検査し、フィルタできます。境界の Access Control List(ACL; アクセス制御リスト)に拒否された Auto-RP パケットからの Auto-RP グループ範囲通知は削除されます。Auto-RP グループ範囲のアドレスがすべて境界 ACL によって許可された場合にのみ、Auto-RP グループ範囲通知は境界によって許可され、渡されます。いずれかのアドレスが許可されないと、グループ範囲全体がフィルタリングされ、Auto-RP メッセージが転送される前に Auto-RP メッセージから削除されます。

PIM ネットワークでの Auto-RP の利点

Auto-RP では、リーフ ルータではなく、RP のルータ上でのみ設定される RP 割り当てを変更できます。

Auto-RP では、ドメイン内の RP アドレスをスコーピングできます。スコーピングは、 ip multicast boundary コマンドと filter-autorp キーワードを使用して実行できます。

前提条件

Auto-RP を設定する場合、 ip pim autorp listener コマンドを使用して Auto-RP リスナー機能を設定し(ステップ 5)、 ip pim sparse-mode コマンドを使用してスパース モードを指定する(ステップ 7)か、 ip pim sparse-dense mode コマンドを使用してスパース-デンス モードを指定します(ステップ 8)。


) スパース-デンス モードを指定する場合、デンス モードのフェールオーバーがネットワークのデンス モードのフラッディングを引き起こす可能性があります。これを避けるために、Auto-RP リスナー機能では PIM スパース モードを使用します。


スパース-デンス モードで設定されたインターフェイスは、マルチキャスト グループの動作モードに応じてスパース モードまたはデンス モードで処理されます。インターフェイスを設定する方法を決定する必要があります。

Auto-RP の設定時に必要なアクセス リストすべてを、設定作業の開始前に設定する必要があります。アクセス リストの設定方法については、『 Creating an IP Access List and Applying It to an Interface 』モジュールを参照してください。

制約事項

グループに既知の RP がなく、インターフェイスがスパース-デンス モードに設定される場合、インターフェイスはデンス モードであるかのように処理され、データはインターフェイスでフラッディングされます。このデータのフラッディングを避けるために、 ip pim autorp listener コマンドを使用して Auto-RP リスナーを設定してから、 ip pim sparse mode コマンドを使用してインターフェイスをスパース モードとして設定します。

手順の概要

1. enable

2. configure terminal

3. ip multicast-routing [ distributed ]

4. ステップ 5 ~ 7 またはステップ 6 と 8 を実行します。

5. ip pim autorp listener

6. interface type number

7. ip pim sparse-mode

8. ip pim sparse-dense-mode

9. exit

10. すべての PIM インターフェイスでステップ 1 ~ 9 を繰り返します。

11. ip pim send-rp-announce { interface-type interface-number | ip-address } scope ttl-value [ group-list access-list ] [ interval seconds ] [ bidir ]

12. ip pim send-rp-discovery [ interface-type interface-number ] scope ttl-value [ interval seconds ]

13. ip pim rp-announce-filter rp-list access-list group-list access-list

14. no ip pim dm-fallback

15. interface type number

16. ip multicast boundary access-list [ filter-autorp ]

17. end

18. show ip pim autorp

19. show ip pim rp [ mapping ] [ rp-address ]

20. show ip igmp groups [group-name | group-address | interface-type interface-number] [ detail ]

21. show ip mroute [ group-address | group-name ] [ source-address | source-name ] [ interface-type interface-number ] [ summary ] [ count ] [ active kbps ]

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip multicast-routing [ distributed ]

 

Router(config)# ip multicast-routing

IP マルチキャスト ルーティングをイネーブルにします。

distributed キーワードを使用して、Multicast Distributed Switching(MDS; マルチキャスト分散スイッチング)をイネーブルにします。

ステップ 4

ステップ 5 ~ 7 またはステップ 6 と 8 を実行します。

--

ステップ 5

ip pim autorp listener

 

Router(config)# ip pim autorp listener

2 つの Auto-RP グループ 224.0.1.39 と 224.0.1.40 の IP マルチキャスト トラフィックを PIM スパース モードで動作しているインターフェイスでフラッディングされる PIM デンス モードにします。

ステップ 8 でスパース-デンス モードを設定している場合、このステップはスキップします。

ステップ 6

interface type number

 

Router(config)# interface ethernet 1

PIM をイネーブルにできるホストに接続されているインターフェイスを選択します。

ステップ 7

ip pim sparse-mode

 

Router(config-if)# ip pim sparse-mode

インターフェイスで PIM スパース モードをイネーブルにします。スパース モードで Auto-RP を設定している場合、次のステップで Auto-RP リスナーも設定する必要があります。

ステップ 8 でスパース-デンス モードを設定している場合、このステップはスキップします。

ステップ 8

ip pim sparse-dense-mode

 

Router(config-if)# ip pim sparse-dense-mode

インターフェイスで PIM スパース-デンス モードをイネーブルにします。

ステップ 7 でスパース モードを設定している場合、このステップはスキップします。

ステップ 9

exit

 

Router(config-if)# exit

インターフェイス コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードに戻ります。

ステップ 10

すべての PIM インターフェイスでステップ 1 ~ 9 を繰り返します。

--

ステップ 11

ip pim send-rp-announce { interface-type interface-number | ip-address } scope ttl-value [ group-list access-list ] [ interval seconds ] [ bidir ]

 

Router(config)# ip pim send-rp-announce loopback0 scope 31 group-list 5

PIM 対応のすべてのインターフェイスに RP 通知を送信します。

RP ルータでのみこのステップを実行します。

RP アドレスとして使用する IP アドレスを定義するには、 interface-type 引数と interface-number 引数を使用します。

直接接続されている IP アドレスを RP アドレスとして指定するには、 ip-address 引数を使用します。

引数が設定されている場合、RP 通知メッセージがこのアドレスが接続されているインターフェイスによって送信されます(つまり、RP 通知メッセージの IP ヘッダーのソース アドレスがそのインターフェイスの IP アドレスです)。

この例は最大 31 のホップでインターフェイスがイネーブルになっていることを示しています。ルータは、ループバック インターフェイス 0 に関連付けられた IP アドレスによって RP として識別されることを望みます。アクセス リスト 5 はこのルータが RP として機能しているグループを示しています。

ステップ 12

ip pim send-rp-discovery [interface-type interface-number] scope ttl-value [ interval seconds ]

 

Router(config)# ip pim send-rp-discovery loopback 1 scope 31

ルータを RP マッピング エージェントとして設定します。

RP マッピング エージェント ルータ、または複合 RP/RP マッピング エージェント ルータでのみこのステップを実行します。

(注) Auto-RP により、RP 機能を 1 つのルータで別々に実行できるようになり、RP マッピング エージェントを 1 つまたは複数のルータ上で実行できるようになります。複合 RP/RP マッピング エージェント ルータに、RP および RP マッピング エージェントを展開することができます。

RP マッピング エージェントのソース アドレスとして使用する IP アドレスを定義するには、オプションの interface-type 引数と interface-number 引数を使用します。

Auto-RP 検出メッセージの IP ヘッダーで Time-to-Live(TTL; 存続可能時間)値を指定するには、 scope キーワードと ttl-value 引数を使用します。

Auto-RP 検出メッセージが送信される間隔を指定するには、オプションの interval キーワードと seconds 引数を使用します。

(注) Auto-RP 検出メッセージが送信される間隔をデフォルト値の 60 より短くすると、グループと RP のマッピングのフラッディングがより頻繁になります。一部のネットワーク環境では、間隔を短縮する欠点(コントロール パケット オーバーヘッドの増加)が利点(グループと RP のマッピングのより頻繁な更新)を上回る場合があります。

例では、ループバック インターフェイス 1 で Auto-RP 検出メッセージを 31 ホップに制限していることを示しています。

ステップ 13

ip pim rp-announce-filter rp-list access-list group-list access-list

 

Router(config)# ip pim rp-announce-filter rp-list 1 group-list 2

Candidate RP(C-RP; 候補 RP)から RP マッピング エージェントに送信される着信 RP 通知メッセージをフィルタリングします。

RP マッピング エージェントでのみこのステップを実行します。

ステップ 14

no ip pim dm-fallback

 

Router(config)# no ip pim dm-fallback

(任意)PIM デンス モードのフォールバックを阻止します。

すべてのインターフェイスが PIM スパース モードで動作するよう設定されている場合、このステップはスキップします。

コマンド動作はイネーブルになります。

ステップ 15

interface type number

 

Router(config)# interface ethernet 1

PIM をイネーブルにできるホストに接続されているインターフェイスを選択します。

ステップ 16

ip multicast boundary access-list [ filter-autorp ]

 

Router(config-if)# ip multicast boundary 10 filter-autorp

管理用スコープの境界を設定します。

このステップは、他のルータとの境界であるインターフェイス上で実行します。

この作業ではアクセス リストは表示されません。

deny キーワードを使用するアクセス リスト エントリはそのエントリに一致するパケットのマルチキャスト境界を作成します。

ステップ 17

end

 

Router(config-if)# end

グローバル コンフィギュレーション モードに戻ります。

ステップ 18

show ip pim autorp

 

Router# show ip pim autorp

(任意)Auto-RP 情報を表示します。

ステップ 19

show ip pim rp [ mapping ] [ rp-address ]

 

Router# show ip pim rp mapping

(任意)ネットワークで既知の RP を表示し、ルータが各 RP について学習する方法を示します。

ステップ 20

show ip igmp groups [group-name | group-address | interface-type interface-number] [detail]

 

Router# show ip igmp groups

(任意)ルータに直接接続されているレシーバと Internet Group Management Protocol(IGMP; インターネット グループ管理プロトコル)によって学習されたレシーバを持つマルチキャスト グループを表示します。

レシーバ情報が結果の画面に表示されるには、レシーバがこのコマンドが発行された時点でネットワーク上でアクティブである必要があります。

ステップ 21

show ip mroute [ group-address | group-name ] [ source-address | source-name ] [ interface-type interface-number ] [ summary ] [ count ] [ active kbps ]

 

Router# show ip mroute cbone-audio

(任意)IP マルチキャスト ルーティング(mroute)テーブルの内容を表示します。

次の作業

Verifying IP Multicast Operation 』モジュールに進みます。

エニーキャスト RP でのスパース モードの設定

ここでは、RP 冗長性のためにエニーキャスト RP でスパース モードを設定する手順について説明します。

エニーキャスト RP は静的に設定され、インターフェイスは Protocol Independent Multicast-Sparse Mode(PIM-SM; Protocol Independent Multicast スパース モード)で動作するように設定されます。エニーキャスト RP 設定では、ループバック インターフェイス上で同じ IP アドレスを使用して複数の RP を設定します。エニーキャスト RP ループバック アドレスは、32 ビット マスクを使用して設定し、ホスト アドレスにする必要があります。エニーキャスト RP 設定は、設定されているルータに関係なく、同じホスト アドレスが RP アドレスとして使用されるため、設定やトラブルシューティングが簡単です。

エニーキャスト RP では、ソース登録のための負荷を複数の Rendezvous Point(RP; ランデブー ポイント)で共有でき、互いのホット バックアップ ルータとして機能できます。Multicast Source Discovery Protocol(MSDP)はエニーキャスト RP を可能にするキー プロトコルです。

Multicast Source Discovery Protocol の概要

PIM スパース モード モデルでは、マルチキャスト ソースおよびレシーバはローカルの Rendezvous Point(RP; ランデブー ポイント)に登録します。動作上、ソースまたはレシーバに最も近いルータを RP に登録します。他のドメインの RP が他のドメインに存在するソースについて知る方法はありません。

MSDP は、アクティブなソースに関する情報を RP が共有できるようにするメカニズムです。RP は、ローカル ドメイン内のレシーバを登録しています。リモート ドメインの RP は、アクティブなソースについてヒアリングすると、その情報をそれぞれのローカル レシーバに渡すことができます。その後、ドメイン間でマルチキャスト データを転送できるようになります。MSDP の別の機能は、各ドメインが他のドメインに依存しない独立した RP を維持できるようにします。MSDP は RP がドメイン間でアクティブ ソースについての知識を共有できるようにします。マルチキャスト ドメイン間でのトラフィックの転送には、PIM-SM が使用されます。

各ドメインの RP は、TCP 接続を使用して、他のドメインの RP または他のドメインに接続する境界ルータとの MSDP ピアリング セッションを確立します。RP は、(正規の PIM 登録メカニズムを通じて)自身のドメイン内にある新しいマルチキャスト ソースについて知ると、Source-Active(SA)メッセージの最初のデータ パケットをカプセル化し、その SA をすべての MSDP ピアに送信します。各受信側ピアは、相互接続されたネットワーク(理論的には、マルチキャスト インターネット全体)内のすべての MSDP ルータに SA が到達するまで、修正された Reverse Path Forwarding(RPF; リバース パス転送)チェックを使用して SA を転送します。受信側の MSDP ピアが RP であり、その RP に SA 内のグループに対する (*, G) エントリがある(該当する受信先が存在する)場合、RP はソースに対して (ソース, グループ) (S, G) ステートを作成し、ソースの最短パス ツリーに加入します。このカプセル化されたデータはカプセル化解除され、その RP の共有ツリーを下方向に転送されます。ラスト ホップ ルータ(レシーバに最も近いルータ)は、マルチキャスト パケットを受信すると、ソースへの最短パス ツリーに加入できるようになります。MSDP スピーカーは、その RP のドメイン内のすべてのソースを含む SA を定期的に送信します。 は、ドメイン A のソースからドメイン E のレシーバへのデータのフロー方法を示しています。

MSDP は、Internet Service Provider(ISP; インターネット サービス プロバイダー)間のピアリングを実現するために開発されました。ISP は、競合する ISP によって管理された RP に依存して顧客にサービスを提供することを望んでいませんでした。MSDP は、各 ISP が独自のローカル RP を持ち、マルチキャスト トラフィックをインターネットに転送し、インターネットからマルチキャスト トラフィックを受信し続けられるようにします。

図 2 各ドメインの RP 間でソース情報を共有する MSDP

 

エニーキャスト RP の概要

エニーキャスト RP は、MSDP の有益な応用です。本来、MDSP は、ドメイン間マルチキャスト アプリケーションに開発されたものですが、冗長性および負荷分散機能を提供するドメイン間機能としてエニーキャスト RP にも使用されます。エンタープライズ カスタマーは、通常、単一のマルチキャスト ドメイン内の耐障害性要件を満たすために、エニーキャスト RP を使用して Protocol Independent Multicast Sparse Mode(PIM-SM; Protocol Independent Multicast スパース モード)ネットワークを設定します。

エニーキャスト RP では、ループバック インターフェイス上で同じ IP アドレスを使用して複数の RP を設定します。エニーキャスト RP ループバック アドレスは、32 ビット マスクを使用して設定し、ホスト アドレスにする必要があります。すべてのダウンストリーム ルータは、このエニーキャスト RP ループバック アドレスがローカル RP の IP アドレスであるように設定する必要があります。IP ルーティングでは、トポロジ的に最も近い RP が各ソースおよびレシーバに自動的に選択されます。ソースはネットワークの周囲に等間隔に配置されていると仮定すると、各 RP には同数のソースが登録されます。つまり、ソースを登録するプロセスは、ネットワーク内のすべての RP によって均等に共有されます。

ソースは 1 つの RP に登録でき、レシーバは異なる RP に加入できるため、RP にはアクティブなソースに関する情報を交換するための手段が必要です。この情報の交換は、MSDP を使用して行われます。

エニーキャスト RP では、すべての RP が互いに MSDP ピアになるように設定されます。ソースが 1 つの RP に登録すると、特定のマルチキャスト グループにアクティブなソースが存在することを通知する SA メッセージが他の RP に送信されます。その結果、各 RP は、他の RP のエリア内に存在するアクティブなソースを認識します。いずれかの RP で障害が発生すると、IP ルーティングが収束し、他の RP のいずれかが複数のエリアのアクティブ RP になります。新しいソースは、バックアップ RP に登録します。レシーバはこれらの新しい RP に加入し、接続が維持されます。

RP は、通常、ソースおよびレシーバとの新しいセッションを開始するためだけに必要になります。RP は、ソースとレシーバが直接的なマルチキャスト データ フローを確立できるように、共有ツリーを支援します。すでにソースとレシーバの間にマルチキャスト データ フローが確立されている場合、そのセッションは RP 障害による影響を受けません。エニーキャスト RP を使用すると、いつでもソースおよびレシーバとの新しいセッションを開始できます。

手順の概要

1. enable

2. configure terminal

3. ip multicast-routing [ distributed ]

4. interface type number

5. ip pim sparse-mode

6. ip pim rp-address rp-address

7. それぞれに同じ RP アドレスを割り当てる複数のルータでステップ 1 ~ 6 を繰り返します。

8. interface loopback [ interface-number ] ip address [ ip-address ] [ mask ]

9. interface loopback [ interface-number ] ip address [ ip-address ] [ mask ]

10. exit

11. ip msdp peer {peer-name | peer-address} [ connect-source interface-type interface-number ] [ remote-as as-number]

12. ip msdp originator-id loopback [interface]

13. 冗長 RP 上でステップ 8 ~ 12 を繰り返します。

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip multicast-routing [ distributed ]

 

Router(config)# ip multicast-routing

IP マルチキャスト ルーティングをイネーブルにします。

distributed キーワードを使用して、マルチキャスト分散スイッチングをイネーブルにします。

ステップ 4

interface type number

 

Router(config)# interface ethernet 1

PIM をイネーブルにできるホストに接続されているインターフェイスを選択します。

ステップ 5

ip pim sparse-mode

 

Router(config-if)# ip pim sparse-mode

スパース モードをイネーブルにします。

ステップ 6

ip pim rp-address rp-address

 

Router(config-if)# ip pim rp-address 10.0.0.1

特定のグループの PIM RP のアドレスを設定します。

ステップ 7

それぞれに同じ RP アドレスを割り当てる複数のルータでステップ 1 ~ 6 を繰り返します。

--

ステップ 8

interface loopback [ interface-number ] ip address [ ip-address ] [ mask ]

 

Router(config-if)# interface loopback 0

ip address 10.0.0.1 255.255.255.255

RP ルータにインターフェイス ループバック IP アドレスを設定します。

RP ルータでこのステップを実行します。

ステップ 9

interface loopback [ interface-number ] ip address [ ip-address ] [ mask ]

 

Router(config-if)# interface loopback 1

ip address 10.1.1.1 255.255.255.255

MSDP ピアリングにインターフェイス ループバック IP アドレスを設定します。

ステップ 10

exit

 

Router(config-if)# exit

インターフェイス コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードに戻ります。

ステップ 11

ip msdp peer {peer-name | peer-address} [connect-source interface-type interface-number] [remote-as as-number]

 

Router(config)# ip msdp peer 10.1.1.2 connect-source loopback 1

MSDP ピアを設定します。

RP ルータでこのステップを実行します。

ステップ 12

ip msdp originator-id loopback [interface]

 

Router(config)# ip msdp originator-id loopback 1

SA メッセージのソースの MSDP スピーカーがインターフェイスの IP アドレスを SA メッセージ内で RP アドレスとして使用できるようにします。

RP ルータでこのステップを実行します。

ステップ 13

冗長 RP 上でステップ 8 ~ 12 を繰り返します。

--

次の作業

Verifying IP Multicast Operation 』モジュールに進みます。

ブートストラップ ルータでのスパース モードの設定

ここでは、ルータがグループと RP のマッピングを動的に学習するように、耐障害性、自動 RP 検出、ディストリビューション メカニズムを備えた Bootstrap Router(BSR; ブートストラップ ルータ)を設定する方法を説明します。


) Auto-RP と BSR の同時配備はサポートされていません。


BSR の選定と機能

PIM は BSR を使用して、各グループ プレフィクスの RP セット情報を検出し、PIM ドメイン内のすべてのルータに通知します。これは、Auto-RP による機能と同じですが、BSR は PIM バージョン 2 仕様の一部です。BSR メカニズムは Cisco ルータ上で Auto-RP と相互運用できます。

シングル ポイント障害を避けるために、PIM ドメイン内で複数の候補 BSR を設定できます。BSR は候補 BSR の中から自動的に選定されます。これらはブートストラップ メッセージを使用して、最も優先度の高い BSR を検出します。その後、このルータが BSR であると PIM ドメイン内のすべての PIM ルータに通知します。

BSR の選定の後、候補 RP はユニキャストを使用して RP になりたいという要求を BSR に通知します。BSR はグループと RP のマッピング セット全体をルータ リンク ローカル アドレス 224.0.0.13 にアドバタイズします。RP を選択するために Auto-RP によって使用される Auto-RP の RP マッピング エージェントとは異なり、BSR ネットワークのすべてのルータに RP を選択する責任があります。

BSR は RP アドバタイズメントをスコーピングする能力に欠けますが、BSR はベンダーの相互運用性またはオープン スタンダードの遵守が必要な場合に使用されます。

BSR 境界インターフェイス

PIM スパース モードのドメインの境界インターフェイスには、特にそのインターフェイスによって到達可能な隣接ドメインも PIM スパース モードを実行している場合、そのドメインとの特定のトラフィックのやりとりを阻止する防止策が必要です。あるドメインのルータが他のドメインで RP を選定する場合があり、プロトコルの誤作動やドメイン間の隔離の失敗の原因となるため、BSR および Auto-RP メッセージを異なるドメイン間でやりとりしないでください。インターフェイスでの BSR メッセージの送受信を防ぐために BSR 境界インターフェイスを設定します。

手順の概要

1. enable

2. configure terminal

3. ip multicast-routing [ distributed ]

4. interface type number

5. ip pim sparse-mode

6. end

7. すべてのルータのすべてのマルチキャスト対応インターフェイス上でステップ 1 ~ 6 を繰り返します。

8. ip pim bsr-candidate interface-type interface-number [hash-mask-length [ priority ]]

9. ip pim rp-candidate interface-type interface-number [ group-list access-list] [ interval seconds ] [ priority value ]

10. すべての RP および BSR ルータ上でステップ 8 および 9 を繰り返します。

11. interface type number

12. ip pim bsr-border

13. end

14. メッセージを送受信すべきではない境界インターフェイスを持つすべてのルータでステップ 11 ~ 13 を繰り返します。

15. show ip pim rp [ mapping ] [rp-address]

16. show ip pim rp-hash [group-address] [group-name]

17. show ip pim bsr-router

18. show ip igmp groups [group-name | group-address | interface-type interface-number] [ detail ]

19. show ip mroute

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip multicast-routing [ distributed ]

 

Router(config)# ip multicast-routing

IP マルチキャスト ルーティングをイネーブルにします。

distributed キーワードを使用して、マルチキャスト分散スイッチングをイネーブルにします。

ステップ 4

interface type number

 

Router(config)# interface ethernet 1

PIM をイネーブルにできるホストに接続されているインターフェイスを選択します。

ステップ 5

ip pim sparse-mode

 

Router(config-if)# ip pim sparse-mode

スパース モードをイネーブルにします。

ステップ 6

end

 

Router(config-if)# end

グローバル コンフィギュレーション モードに戻ります。

ステップ 7

すべてのルータのすべてのマルチキャスト対応インターフェイス上でステップ 1 ~ 6 を繰り返します。

--

ステップ 8

ip pim bsr-candidate interface-type interface-number [ hash-mask-length [ priority ]]

 

Router(config)# ip pim bsr-candidate ethernet 1 0 192

Bootstrap Router(BSR; ブートストラップ ルータ)としての立候補を通知するようルータを設定します。

RP または複合 RP/BSR ルータでこのステップを実行します。

(注) BSR により、RP 機能を 1 つのルータで別々に実行できるようになり、BSR を 1 つまたは複数のルータ上で実行できるようになります。複合 RP/BSR ルータに、RP および BSR を展開することができます。

このコマンドは、( interface-type および interface-number 引数に設定された)BSR アドレスとしての指定されたインターフェイスのアドレスで、BSR メッセージをすべての PIM ネイバーに送信するようにルータを設定します。

PIMv2 ハッシュ関数が呼び出される前にグループ アドレスと AND で連結されるマスクの長さ(最大 32 ビット)を設定するには、 オプションの hash-mask-length 引数を使用します。ハッシュ元が同じであるすべてのグループは、同じ RP に対応します。たとえば、マスク長が 24 の場合、グループ アドレスの最初の 24 ビットだけが使用されます。ハッシュ マスク長により、1 つの RP を複数のグループで使用できるようになります。デフォルトのハッシュ マスク長は 0 です。

BSR の C-RP としてのプライオリティを指定するには、オプションの priority 引数を(ハッシュ マスク長を設定したあとに)使用します。プライオリティの範囲は 0 ~ 255 です。最もプライオリティ値が高い BSR C-RP が優先されます。デフォルトのプライオリティ値は 0 です。

(注) Cisco IOS および IOS XE に PIM BSR を実装する場合は、候補 BSR のデフォルト プライオリティとして値 0 が使用されます。この実装は、デフォルトのプライオリティ値として 64 を指定する RFC 5059 より前から存在します。このため、Cisco IOS および Cisco IOS XE の実装は RFC 5059 に反します。RFC で指定されたデフォルトのプライオリティに準拠するには、プライオリティ値を明示的に 64 に設定する必要があります。

ステップ 9

ip pim rp-candidate interface-type interface-number [ group-list access-list] [ interval seconds] [ priority value ]

 

Router(config)# ip pim rp-candidate ethernet 2 group-list 4 priority 192

自分が PIM バージョン 2 候補 RP であると BSR に通知アドバタイズするようルータを設定します。

RP または複合 RP/BSR ルータでこのステップを実行します。

(注) BSR により、RP 機能を 1 つのルータで別々に実行できるようになり、BSR を 1 つまたは複数のルータ上で実行できるようになります。複合 RP/BSR ルータに、RP および BSR を展開することができます。

RP アドレスに関連してアドバタイズされる標準 IP アクセス リスト番号、またはグループ プレフィクスを定義する名前を指定するには、オプションの group-list キーワードと access-list 引数を使用します。アクセス リストの名前は、スペースまたは引用符を使用せず、番号付きアクセス リストとの混同を避けるため、アルファベットで始める必要があります。

RP 候補のアドバタイズメント間隔を指定するには、オプションの interval キーワードと seconds 引数を使用します。有効値の範囲は 1 ~ 16383 秒です。間隔が指定されている場合、候補 RP アドバタイズメント間隔は指定された秒数に設定されます。デフォルトの間隔は、60 秒です。この間隔を短くすると、PIMv2 メッセージの発生を増加させて、セカンダリ RP へのフェールオーバーに必要な時間が短縮できます。

C-RP のプライオリティを指定するには、オプションの priority キーワードと value 引数を使用します。有効な範囲は 0 ~ 255 の整数値です。最もプライオリティ値が低い BSR C-RP が優先されます。デフォルトのプライオリティ値は 0 です。

Cisco IOS および Cisco IOS XE に PIM BSR を実装する場合は、RFC 2362 の仕様に準拠しない方法を使用して、1 組の候補 RP から RP を選択します。設定の回避策については、「例:BSR および RFC 2362 の相互利用可能な候補 RP」を参照してください。詳細については、Cisco Bug Toolkit を使用して CSCdy56806 を参照してください。

(注) Cisco IOS および Cisco IOS XE に PIM BSR を実装する場合は、候補 RP および BSR のデフォルト プライオリティとして値 0 が使用されます。この実装は、デフォルト優先値として 192 を指定する最初の IETF ドラフトである draft-ietf-pim-sm-bsr IETF ドラフト以前から存在します。このため、Cisco IOS および Cisco IOS XE の実装は IETF ドラフトに反します。ドラフトで指定されたデフォルト優先値を遵守するには、優先値を明示的に 192 に設定する必要があります。

ステップ 10

すべての RP および BSR ルータ上でステップ 8 および 9 を繰り返します。

--

ステップ 11

interface type number

 

Router(config)# interface ethernet 1

PIM をイネーブルにできるホストに接続されているインターフェイスを選択します。

ステップ 12

ip pim bsr-border

 

Router(config-if)# ip pim bsr-border

インターフェイスでの Bootstrap Router(BSR; ブートストラップ ルータ)メッセージの送受信を防ぎます。

詳細については、「BSR 境界インターフェイス」を参照してください。

ステップ 13

end

 

Router(config-if)# end

現在のコンフィギュレーション セッションを終了して、特権 EXEC モードに戻ります。

ステップ 14

メッセージを送受信すべきではない境界インターフェイスを持つすべてのルータでステップ 11 から 13 を繰り返します。

--

ステップ 15

show ip pim rp [mapping] [rp-address]

 

Router# show ip pim rp

(任意)関連付けられたマルチキャスト ルーティング エントリでキャッシュされたアクティブなRendezvous Point(RP; ランデブー ポイント)を表示します。

ステップ 16

show ip pim rp-hash [group-address] [group-name]

 

Router# show ip pim rp-hash 239.1.1.1

(任意)指定されたグループに対して選択されたRendezvous Point(RP; ランデブー ポイント)を表示します。

ステップ 17

show ip pim bsr-router

 

Router# show ip pim bsr-router

(任意)Bootstrap Router(BSR; ブートストラップ ルータ)情報を表示します。

ステップ 18

show ip igmp groups [group-name | group-address | interface-type interface-number] [detail]

 

Router# show ip igmp groups

(任意)ルータに直接接続されているレシーバと IGMP によって学習されたレシーバを持つマルチキャスト グループを表示します。

レシーバ情報が結果の画面に表示されるには、レシーバがこのコマンドが発行された時点でネットワーク上でアクティブである必要があります。

ステップ 19

show ip mroute

 

Router# show ip mroute cbone-audio

(任意)IP mroute テーブルの内容を表示します。

次の作業

Verifying IP Multicast Operation 』モジュールに進みます。

単一のスタティック RP でのスパース モードの設定

Rendezvous Point(RP; ランデブー ポイント)は、Protocol Independent Multicast Sparse Mode(PIM-SM; Protocol Independent Multicast スパース モード)を実行しているネットワークで必要です。PIM-SM でトラフィックは、明示的にマルチキャスト データを要求したアクティブなレシーバを持つネットワーク セグメントにのみ転送されます。

ここでは、単一のスタティック RP でスパース モードを設定する手順について説明します。

スタティック RP

PIM スパース モードを設定している場合、マルチキャスト グループに PIM RP を設定する必要があります。RP は各デバイスで静的に設定するか、ダイナミック メカニズムによって学習できます。この作業は、Auto-RP のようにダイナミック メカニズムによってルータが RP を学習するのではなく、RP を静的に設定する方法を説明しています。

PIM Designated Routers(DR; 代表ルータ)は共有ツリーに分散するために、直接接続されたマルチキャスト ソースから RP にデータを転送します。データは RP に 2 つの方法のいずれかで転送されます。データは登録パケットにカプセル化され、直接 RP にユニキャストされます。または、RP がソース ツリーに参加している場合は、RPF 転送アルゴリズムによってマルチキャスト転送されます。レシーバに直接接続されたラスト ホップ ルータは、それぞれの判断でソース ツリーに参加し、共有ツリーから自身をプルーニングできます。

アクセス リストによって定義された複数のグループに単一の RP を設定できます。グループに RP が設定されていない場合、ルータは PIM デンス モード技術を使用してグループをデンスとして処理します( no ip pim dm-fallback コマンドを設定するとこれを防げます)。

ダイナミックとスタティックのグループと RP のマッピングが共に使用され、RP アドレスが競合している場合、スタティックのグループと RP のマッピングに設定された RP アドレスが( ip pim rp-address override コマンドによって)優先されます。


override キーワードが指定されておらず、RP アドレスが競合している場合、ダイナミックのグループと RP のマッピングがスタティックのグループと RP のマッピングに優先されます。


前提条件

単一のスタティック RP でのスパース モードの設定時に必要なアクセス リストすべてを、設定作業の開始前に設定する必要があります。アクセス リストの設定方法については、『 Creating an IP Access List and Applying It to an Interface 』モジュールを参照してください。

制約事項

双方向とスパース モード PIM グループの両方に同じ RP アドレスは使用できません。

手順の概要

1. enable

2. configure terminal

3. ip multicast-routing [ distributed ]

4. interface type number

5. ip pim sparse-mode

6. IP マルチキャストを使用するすべてのインターフェイスでステップ 1 ~ 5 を繰り返します。

7. exit

8. ip pim rp-address rp-address [ access-list ] [ override ]

9. end

10. show ip pim rp [ mapping ] [ rp-address ]

11. show ip igmp groups [group-name | group-address | interface-type interface-number] [ detail ]

12. show ip mroute

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip multicast-routing [ distributed ]

 

Router(config)# ip multicast-routing

IP マルチキャスト ルーティングをイネーブルにします。

distributed キーワードを使用して、マルチキャスト分散スイッチングをイネーブルにします。

ステップ 4

interface type number

 

Router(config)# interface ethernet 1

PIM をイネーブルにできるホストに接続されているインターフェイスを選択します。

ステップ 5

ip pim sparse-mode

 

Router(config-if)# ip pim sparse-mode

インターフェイスに対して PIM をイネーブルにします。スパース モードを使用する必要があります。

ステップ 6

IP マルチキャストを使用するすべてのインターフェイスでステップ 1 ~ 5 を繰り返します。

--

ステップ 7

exit

 

Router(config-if)# exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 8

ip pim rp-address rp-address [access-list] [override]

 

Router(config)# ip pim rp-address 192.168.0.1

特定のグループの PIM RP のアドレスを設定します。

マルチキャスト グループを RP に静的にマッピングされるよう定義する標準アクセス リストに名前を付けたり、番号を指定するために、オプションの access-list 引数が使用されます。

(注) アクセス リストが定義されていない場合、RP がすべてのマルチキャスト グループ 224/4 にマッピングされます。

ダイナミックとスタティックのグループと RP のマッピングが共に使用され、RP アドレスが競合している場合、スタティックのグループと RP のマッピングに設定された RP アドレスが優先されるよう指定するには、オプションの override キーワードを使用します。

キーワードが指定されておらず、RP アドレスが競合している場合、ダイナミックのグループと RP のマッピングがスタティックのグループと RP のマッピングに優先されます。

ステップ 9

end

 

Router(config)# end

現在のコンフィギュレーション セッションを終了して、EXEC モードに戻ります。

ステップ 10

show ip pim rp [ mapping ] [ rp-address ]

 

Router# show ip pim rp mapping

(任意)ネットワークで既知の RP を表示し、ルータが各 RP について学習する方法を示します。

ステップ 11

show ip igmp groups [group-name | group-address | interface-type interface-number] [detail]

 

Router# show ip igmp groups

(任意)ルータに直接接続されているレシーバと IGMP によって学習されたレシーバを持つマルチキャスト グループを表示します。

レシーバ情報が結果の画面に表示されるには、レシーバがこのコマンドが発行された時点でネットワーク上でアクティブである必要があります。

ステップ 12

show ip mroute

 

Router# show ip mroute

(任意)IP mroute テーブルの内容を表示します。

次の作業

Verifying IP Multicast Operation 』モジュールに進みます。

Source Specific Multicast(SSM)の設定

ここでは、Source Specific Multicast(SSM)とその設定方法について説明します。SSM は、レシーバが明示的に参加したマルチキャスト ソースからのみデータグラム トラフィックがレシーバに転送される IP マルチキャストの拡張機能です。SSM 用に設定されたマルチキャスト グループの場合、(共有ツリーではなく)ソース固有のマルチキャスト配信ツリーのみが作成されます。

SSM のコンポーネント

SSM は、ブロードキャスト アプリケーションとしても知られる 1 対多アプリケーションをサポートする最善のデータグラム配信モデルです。SSM は、オーディオおよびビデオ ブロードキャスト アプリケーション環境を対象とした IP マルチキャスト ソリューションの Cisco 実装のコア ネットワーキング テクノロジーで、RFC 3569 に説明されています。次の 2 つの Cisco IOS コンポーネントは共に SSM の実装をサポートします。

Protocol Independent Multicast Source-Specific Mode(PIM-SSM)

Internet Group Management Protocol Version 3(IGMPv3; インターネット グループ管理プロトコル バージョン 3)

Protocol Independent Multicast(PIM)SSM(PIM-SSM)は、SSM の実装をサポートするルーティング プロトコルで、PIM スパース モード(PIM-SM)から派生しました。IGMP は、ホストがルータにマルチキャスト グループ メンバシップを伝えるために使用する Internet Engineering Task Force(IETF; インターネット技術特別調査委員会)標準トラック プロトコルです。IGMP バージョン 3 は、SSM に必要なソース フィルタリングをサポートします。SSM を IGMPv3 と共に実行するには、SSM が Cisco IOS ルータ、アプリケーションが実行されるホスト、およびアプリケーション自体でサポートされる必要があります。

SSM とインターネット標準マルチキャスト(ISM)の違い

インターネットと多くの企業イントラネットの標準 IP マルチキャスト インフラストラクチャは、PIM-SM プロトコルと Multicast Source Discovery Protocol(MSDP)に基づいています。これらのプロトコルは信頼でき、広範で、効率的であることが証明されています。しかし、Internet Standard Multicast(ISM; インターネット標準マルチキャスト)サービス モデルの複雑さと機能性の制限があります。たとえば、ISM では、ネットワークがマルチキャスト トラフィックをアクティブに送信しているネットワーク内のホストについての知識を維持する必要があります。SSM では、この情報は IGMPv3 によってラスト ホップ ルータにリレーされるソース アドレスを通じてレシーバによって提供されます。SSM は、ISM に関連付けられた問題への対応を強化し、ネットワーク内で ISM 用に開発されたプロトコルと共存することを目的としています。一般的に、SSM は SSM を使用するアプリケーションのために IP マルチキャスト サービスを提供します。

ISM サービスについては RFC 1112 で説明されています。このサービスは、任意のソースからマルチキャスト ホスト グループと呼ばれるレシーバのグループへの IP データグラムの配信によって構成されています。マルチキャスト ホスト グループのデータグラム トラフィックは、IP 宛先アドレスとして任意の IP ユニキャスト ソース アドレス S とマルチキャスト グループ アドレス G を持つデータグラムで構成されています。システムはホスト グループのメンバになることによってこのトラフィックを受信します。ホスト グループのメンバシップには IGMP バージョン 1、2、または 3 によるホスト グループのシグナリングが必要です。

SSM では、データグラムの配信は (S, G) チャネルに基づいています。1 つの (S, G) チャネルのトラフィックは、IP 宛先アドレスとして IP ユニキャスト ソース アドレス S とマルチキャスト グループ アドレス G を持つデータグラムで構成されています。システムは (S, G) チャネルのメンバになることによってこのトラフィックを受信します。SSM と ISM のどちらでも、ソースになるためにシグナリングは必要ありません。しかし、SSM ではレシーバが特定のソースからトラフィックを受信する、または受信しないために (S, G) チャネルに加入または加入中止する必要があります。つまり、レシーバは加入している (S, G) チャネルからのみトラフィックを受信できます。一方、ISM では、レシーバがトラフィックを受信するソースの IP アドレスを知っている必要はありません。提案されているチャネル加入シグナリングの標準的な方法では、IGMP INCLUDE モード メンバシップ レポートを使用します。これは、IGMP バージョン 3 でのみサポートされています。

SSM は、SSM デリバリ モデルを IP マルチキャスト グループ アドレス範囲の設定済みのサブセットに適用することによって ISM サービスと共存できます。インターネット割り当て番号局(IANA)は、SSM アプリケーションおよびプロトコル用に 232.0.0.0 ~ 232.255.255.255 のアドレス範囲を確保しています。Cisco IOS ソフトウェアでは、224.0.0.0 ~ 239.255.255.255 の IP マルチキャスト アドレス範囲の任意のサブセットの SSM 設定を許可します。SSM 範囲が定義されると、アプリケーションが明示的な (S, G) チャネル加入を使用するように変更されているか、URL Rendezvous Directory(URD)によって SSM に対応していない限り、SSM 範囲内でアドレスを使用しようとする場合に既存の IP マルチキャスト レシーバ アプリケーションはトラフィックを受信しません。

SSM 処理

IP マルチキャスト サービスが PIM-SM に基づいている確立されたネットワークは SSM サービスをサポートできます。SSM は、ドメイン間の PIM-SM に必要なプロトコルがすべて揃っていないネットワークで単独で配備することもできます。つまり、SSM には RP は必要ありません。このため、Auto-RP、MSDP、または Bootstrap Router(BSR; ブートストラップ ルータ)のような RP メカニズムは必要ありません。

SSM がすでに PIM-SM 用に設定済みのネットワークで配備されている場合、ラスト ホップ ルータのみを SSM をサポートする Cisco IOS ソフトウェア イメージにアップグレードする必要があります。レシーバに直接接続されていないルータを SSM をサポートする Cisco IOS ソフトウェア イメージにアップグレードする必要はありません。一般的に、これらのラスト ホップではないルータは、SSM 範囲で PIM-SM のみを実行する必要があります。これらは、MSDP シグナリング、登録、または PIM-SM 共有ツリー動作が SSM 範囲内で発生することを抑制するために、追加のアクセス制御設定を必要とする場合もあります。

SSM の影響

SSM モードの動作は、 ip pim ssm グローバル コンフィギュレーション コマンドを使用して SSM 範囲を設定することによってイネーブルできます。この設定には、次のような効果があります。

SSM 範囲内のグループの場合、(S, G) チャネル加入は IGMPv3 INCLUDE モード メンバシップ レポートによって受け入れられます。

SSM 範囲のアドレス内の PIM 動作は、PIM-SM から派生したモードである PIM-SSM に変更されます。このモードでは、PIM (S, G) 加入およびプルーニング メッセージのみがルータによって生成されます。Rendezvous Point Tree(RPT; ランデブー ポイント ツリー)動作に関連した着信メッセージは無視されるか、拒否され、着信 PIM 登録メッセージは登録停止メッセージによってただちに応答されます。PIM-SSM は、ルータがラスト ホップ ルータでない限り PIM-SM と下位互換性があります。このため、ラスト ホップ ルータでないルータは、SSM グループに対して PIM-SM を実行できます(たとえば、まだ SSM をサポートしていない場合)。

SSM 範囲内のグループの場合、SSM 範囲内の MSDP Source-Active(SA)メッセージは受け入れ、生成、または転送されません。

IGMPv3 ホスト シグナリング

IGMPv3 は、ホストがマルチキャスト グループのラスト ホップ ルータにメンバシップを伝える IETF 標準トラック プロトコルの第 3 バージョンです。IGMPv3 は、グループ メンバシップを伝える能力をホストに与えます。これによってソースに関するフィルタリングが可能になります。ホストは、特定のソースを除いて、グループに送信するすべてのソースからトラフィックを受信したい(EXCLUDE と呼ばれるモード)、またはグループに送信する特定のソースからのみトラフィックを受信したい(INCLUDE と呼ばれるモード)と伝えることができます。

IGMPv3 は ISM と SSM の両方で動作できます。ISM では、EXCLUDE モードと INCLUDE モードの両方のレポートがラスト ホップ ルータによって受け入れられます。SSM では、INCLUDE モード レポートのみがラスト ホップ ルータによって受け入れられます。

Source Specific Multicast の利点

IP マルチキャスト アドレス管理

ISM サービスで、トラフィック ディストリビューションは使用する IP マルチキャスト グループ アドレスにのみ基づくため、アプリケーションは一意の IP マルチキャスト グループ アドレスを取得する必要があります。異なるソースとレシーバを持つ 2 つのアプリケーションが同じ IP マルチキャスト グループ アドレスを使用すると、両方のアプリケーションのレシーバが両方のアプリケーションのソースからトラフィックを受信します。適切にプログラムしている場合、レシーバは不要なトラフィックをフィルタできますが、この状態は一般的に許容できないレベルの不要なトラフィックを生み出します。

アプリケーションへの一意の IP マルチキャスト グループ アドレスの割り当ては問題となります。最も短期のアプリケーションは Session Description Protocol(SDP; セッション記述プロトコル)や Session Announcement Protocol(SAP; セッション通知プロトコル)のようなメカニズムを使用して、ランダム アドレスを取得します。これは、インターネット内のアプリケーションの増加によってうまく機能しないソリューションです。長期アプリケーションの現在のベスト ソリューションは、RFC 2770 に説明されていますが、このソリューションは各自律システムが 255 の使用可能な IP マルチキャスト アドレスのみに限定される制限の影響を受けます。

SSM で、他のソースからのトラフィックとは関係なく、各ソースからのトラフィックはネットワーク内のルータ間で転送されます。このため、異なるソースが SSM 範囲のマルチキャスト グループ アドレスを再使用できます。

サービス拒絶(DoS)攻撃の阻止

SSM で、個別の各ソースからのマルチキャスト トラフィックは、(IGMPv3 または URD メンバシップによって)レシーバから要求された場合にのみネットワーク中に転送されます。これに対し、ISM はマルチキャスト グループに送信するアクティブなソースからそのマルチキャスト グループを要求するすべてのレシーバにトラフィックを転送します。インターネット ブロードキャスト アプリケーションで、トラフィックを同じマルチキャスト グループにただ送信するだけで、望ましくないソースが実際のインターネット ブロードキャスト ソースを簡単に妨害できるため、この ISM の動作は非常に望ましくありません。この状況は、レシーバ側で不要なトラフィックによって帯域幅を消耗させるため、インターネット ブロードキャストの無停止の受信を妨害します。SSM では、トラフィックをマルチキャスト グループにただ送信するだけでは、このような種類の Denial-of-Service(DoS; サービス拒絶)攻撃は行えません。

インストールと管理

ネットワークがマルチキャスト グループに送信しているアクティブ ソースについての情報を維持する必要がないため、SSM は簡単にインストールし、ネットワークでプロビジョニングできます。この要件は、(IGMPv1、IGMPv2、または IGMPv3 を使用する)ISM でのみ存在します。

ISM サービスの現在の標準ソリューションは PIM-SM と MSDP です。PIM-SM(Auto-RP または BSR の必要性を含む)および MSDP での Rendezvous Point(RP; ランデブー ポイント)管理は、ネットワークがアクティブ ソースについて学習するためにのみ必要です。この管理は SSM では必要ありません。このため、SSM は ISM よりインストールや管理が簡単で、配備での動作面の拡張も簡単です。SSM のインストールが簡単であるその他の要素は、既存の PIM-SM ネットワークを活用できる点です。

インターネット ブロードキャスト アプリケーション

上記の 3 つの利点により、次の理由で SSM はインターネット ブロードキャスト スタイルのアプリケーションに理想的です。

一意の IP マルチキャスト アドレスなしで SSM によって、インターネット ブロードキャスト サービスを提供できるため、コンテンツ プロバイダーはサービスを簡単に提供できます。コンテンツ プロバイダーにとって、IP マルチキャスト アドレス割り当てはこれまで深刻な問題でした。

インターネット ブロードキャスト サービスは多数のレシーバに公開されることにより、DoS 攻撃の最も一般的な対象となるため、このような攻撃の阻止はインターネット ブロードキャスト サービスの重要な要素です。

SSM はインストールや動作が簡単なため、特に、コンテンツを複数の独立した PIM ドメイン間で転送する必要のある場合(SSM のために PIM ドメイン間で MSDP を管理する必要がないため)、ネットワーク オペレータにとって理想的です。

前提条件

SSM 範囲の定義にアクセス リストを使用したい場合、ip pim ssm コマンドでアクセス リストを参照する前にアクセス リストを設定します。アクセス リストの設定方法については、『 Creating an IP Access List and Applying It to an Interface 』モジュールを参照してください。

制約事項

アドレス管理の制約事項

SSM がレイヤ 2 スイッチング メカニズムで使用される場合、アドレス管理はある程度必要です。Cisco Group Management Protocol(CGMP)、IGMP スヌーピング、および Router-Port Group Management Protocol(RGMP)は現在、(S, G) チャネル固有のフィルタリングではなく、グループ固有のフィルタリングのみをサポートしています。スイッチド ネットワークの別のレシーバが、同じグループを共有している別の (S, G) チャネルを要求すると、これらの既存のメカニズムの利点は活用できません。代わりに、両方のレシーバが (S, G) チャネル トラフィックをすべて受信(入力で不要なトラフィックをフィルタリング)します。SSM は SSM 範囲内のグループ アドレスを多くの独立アプリケーションのために再使用できるため、この状況はスイッチド ネットワークで予期せぬトラフィック フィルタリングを招く可能性があります。このため、異なるアプリケーションが同じアドレスを再使用する可能性を最小限に抑えるため、SSM 範囲内のランダム IP アドレスの使用に関して、SSM のための IETF ドラフトに明記された推奨事項に従うことが重要です。たとえば、一連のテレビのチャネルを提供するアプリケーション サービスは、SSM を使用する場合でも、各テレビ (S, G) チャネルに別のグループを使用する必要があります。この設定によって、同じアプリケーション サービス内の異なるチャネルの複数のレシーバがレイヤ 2 スイッチを含むネットワーク内でトラフィックのエイリアスを経験することがなくなります。

IGMP スヌーピングと CGMP の制限事項

IGMPv3 は、古い IGMP スヌーピング スイッチに正しく認識されない可能性のある新しいメンバシップ レポート メッセージを使用します。この場合、ホストがトラフックを正しく受信しません。IGMP はこれらのメッセージの宛先に新しいリンクローカル アドレスを使用します。この新しいリンクローカル アドレスは 224.0.0.22 です。

状態維持の制約事項

PIM-SSM で、適切な (S, G) 加入がインターフェイス上にある場合、ラスト ホップ ルータは (S, G)加入メッセージを定期的に送り続けます。このため、レシーバが (S, G) 加入を送信する限り、ソースが長時間(または二度と)トラフィックを送信しなくてもレシーバからソースへの Shortest Path Tree(SPT; 最短パス ツリー)状態が維持されます。

これは、PIM-SM の場合と異なります。PIM-SM の場合、(S, G) 状態はソースがトラフィックを送信し、レシーバがグループに参加している場合にのみ維持されます。PIM-SM でソースがトラフィックの送信を 3 分以上停止すると、(S, G) 状態が削除され、ソースからのパケットが RPT によって再び到着するまで再確立されません。PIM-SSM のメカニズムはレシーバにソースがアクティブであると通知しないため、レシーバがそのチャネルの受信を要求する限り、ネットワークは PIM-SSM で (S, G) 状態を維持する必要があります。

手順の概要

1. enable

2. configure terminal

3. ip multicast-routing [ distributed ]

4. ip pim ssm { default | range access-list }

5. interface type number

6. ip pim sparse-mode

7. IP マルチキャストを使用するすべてのインターフェイスでステップ 1 ~ 6 を繰り返します。

8. ip igmp version 3

9. ホスト方向のインターフェイスすべてでステップ 8 を繰り返します。

10. end

11. show ip igmp groups [ group-name | group-address | interface-type interface-number ] [ detail ]

12. show ip mroute

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip multicast-routing [ distributed ]

 

Router(config)# ip multicast-routing

IP マルチキャスト ルーティングをイネーブルにします。

distributed キーワードを使用して、マルチキャスト分散スイッチングをイネーブルにします。

ステップ 4

ip pim ssm { default | range access-list }

 

Router(config)# ip pim ssm default

SSM サービスを設定します。

default キーワードは SSM 範囲のアクセス リストを 232/8 と定義します。

range キーワードは標準の IP アクセス リスト番号または SSM 範囲を定義する名前を指定します。

ステップ 5

interface type number

 

Router(config)# interface ethernet 1

IGMPv3 をイネーブルにできるホストに接続されているインターフェイスを選択します。

ステップ 6

ip pim sparse-mode

 

Router(config-if)# ip pim sparse-mode

インターフェイスに対して PIM をイネーブルにします。スパース モードを使用する必要があります。

ステップ 7

IP マルチキャストを使用するすべてのインターフェイスでステップ 1 ~ 6 を繰り返します。

--

ステップ 8

ip igmp version 3

 

Router(config-if)# ip igmp version 3

このインターフェイス上で IGMPv3 をイネーブルにします。IGMP のデフォルト バージョンはバージョン 2 に設定されます。SSM にはバージョン 3 が必要です。

ステップ 9

ホスト方向のインターフェイスすべてでステップ 8 を繰り返します。

--

ステップ 10

end

 

Router(config-if)# end

現在のコンフィギュレーション セッションを終了して、特権 EXEC モードに戻ります。

ステップ 11

show ip igmp groups [group-name | group-address | interface-type interface-number] [detail]

 

Router# show ip igmp groups

(任意)ルータに直接接続されているレシーバと IGMP によって学習されたレシーバを持つマルチキャスト グループを表示します。

レシーバ情報が結果の画面に表示されるには、レシーバがこのコマンドが発行された時点でネットワーク上でアクティブである必要があります。

ステップ 12

show ip mroute

 

Router# show ip mroute

(任意)IP mroute テーブルの内容を表示します。

このコマンドは、マルチキャスト グループが SSM サービス用に設定されているのか、ソース固有のホスト レポートを受信しているのかを示します。

次の作業

Verifying IP Multicast Operation 』モジュールに進みます。

双方向 PIM(Bidir-PIM)の設定

ここでは、Bidirectional PIM(Bidir-PIM; 双方向 PIM)の設定方法について説明します。Bidir-PIM は Shortest Path Tree(SPT; 最短パス ツリー)動作の多くを PIM-SM と共有します。Bidir-PIM にも、共有ツリーのアップストリームにある RP に向けてソース トラフィックを無条件に転送する機能がありますが、PIM-SM のようなソースの登録プロセスはありません。これらの変更によって、(*, G) マルチキャスト ルーティング エントリのみに基づいてすべてのルータでトラフィックを転送できます。この転送形式では、ソース固有のステートは不要であり、スケーリング機能を使用して任意の数のソースに対応できます。

双方向 PIM の利点

Bidir-PIM は、多数のソースのルーティング ステート テーブルを維持するパフォーマンス コストをなくします。

Bidir-PIM は、各 PM ドメイン内の多対多のアプリケーションで使用するよう設計されています。双方向 PIM モードのマルチキャスト グループは、ソースの数によりオーバーヘッドを引き起こすことなく、任意の数のソースに拡張できます。

マルチキャスト グループ モード

PIM では、マルチキャスト グループのパケット トラフィックは、そのマルチキャスト グループのために設定されたモードのルールに従ってルーティングされます。PIM の Cisco IOS 実装は、マルチキャスト グループ用に次の 4 つのモードをサポートしています。

PIM 双方向モード

PIM デンス モード

PIM スパース モード

PIM Source Specific Mode(SSM)

ルータは、異なるマルチキャスト グループに対して、4 つのモードすべて、またはそれらの任意の組み合わせを同時にサポートできます。

双方向共有ツリー

双方向モードでは、トラフィックは、グループの Rendezvous Point(RP; ランデブー ポイント)をルートとする双方向共有ツリーに沿ってのみ、ルーティングされます。Bidir-PIM では、RP の IP アドレスは、すべてのルータがその IP アドレスをルートとするループフリーのスパニング ツリー トポロジを確立するうえで重要な役割を果たします。この IP アドレスはルータである必要はなく、PIM ドメイン内のどこからでも到達可能なネットワーク上の任意の未割り当て IP アドレスを使用できます。この技術は、Bidir-PIM の冗長 RP 設定を確立するための優先設定方式です。

双方向グループのメンバシップは、明示的な加入メッセージによって伝えられます。ソースからのトラフィックは、無条件で、共有ツリーの上方向にある RP に向けて送信され、ツリーの下方向にある各ブランチ上のレシーバに渡されます。

図 3 および 図 4 は、単方向共有ツリーおよびソース ツリーに対する双方向共有ツリーのルータごとの状態の違いを示しています。

図 3 単方向共有ツリーおよびソース ツリー

 

図 4 双方向共有ツリー

 

RP からレシーバ方向へダウンストリームで転送されるパケットの場合、Bidir-PIM と PIM-SM 間の基本的な違いはありません。ソースからアップストリームで RP 方向に渡されるトラフィックの場合、Bidir-PIM は実質的に PIM-SM から逸脱します。

PIM-SM は、トラフィックを 1 つの Reverse Path Forwarding(RPF; リバース パス転送)インターフェイスからのみ受け入れるため、ツリーのアップストリーム方向にトラフィックを転送できません。(共有ツリーの)このインターフェイスは RP 方向を指し、そのため、ダウンストリーム トラフィック フローのみを許可します。アップストリーム トラフィックはまずユニキャスト登録メッセージにカプセル化され、これがソースの Designated Router(DR; 代表ルータ)から RP に渡されます。次に、RP がソースをルートとする SPT に参加します。このため、PIM-SM で RP 方向のソースからのトラフィックは共有ツリーでアップストリームにはフローせず、RP に達するまで、ソースの SPT に沿ってダウンストリームにフローします。RP から、トラフィックは共有ツリーに沿ってすべてのレシーバに向けてフローします。

Bidir-PIM では、パケット転送ルールが PIM-SM から改善され、トラフィックを共有ツリーで RP 方向にアップストリームに渡せるようになりました。マルチキャスト パケット ルーピングを避けるために、Bidir-PIM は Designated Forwarder(DF; 指定フォワーダ)選定と呼ばれる新しいメカニズムを導入します。これは、RP をルートとするループフリー SPT を確立します。

DF 選定

すべてのネットワーク セグメントとポイントツーポイント リンクで、PIM ルータはすべて Designated Forwarder(DF; 指定フォワーダ)選定と呼ばれる手順に参加します。この手順では、双方向グループのすべての RP で DF としてルータを 1 つ選定します。このルータは、そのネットワークで受信されたマルチキャスト パケットの転送を担当します。

DF 選定は、ユニキャスト ルーティング メトリックに基づきます。RP への最も望ましいユニキャスト ルーティング メトリックを持つルータが DF になります。この方法を使用することによって、RP へのパラレル等価コスト パスがある場合にも、すべてのパケットのコピー 1 つだけが RP に送信されます。

DF は双方向グループのすべての RP に対して選定されます。結果として、ネットワーク セグメント上で各 RP に 1 つずつ複数のルータが DF として選定されます。複数のインターフェイスで特定のルータが DF として選定される場合があります。

双方向グループ ツリー ビルディング

双方向グループの共有ツリーに参加する手順は、PIM-SM での手順とほとんど同じです。1 つ大きな違いは、双方向グループの場合、DR のロールが RP の DF によって仮定される点です。

ローカル レシーバを持つネットワークでは、DF として選定されたルータのみが Internet Group Management Protocol(IGMP; インターネット グループ管理プロトコル)加入メッセージの受信時に Outgoing Interface List(olist; 発信インターフェイス リスト)を読み込み、(*, G) 加入および脱退メッセージを RP 方向にアップストリームに送信します。ダウンストリーム ルータが共有ツリーに参加したい場合、PIM 加入および脱退メッセージの RPF ネイバーが常に RP に向かうインターフェイスの DF に選定されます。

ルータが加入または脱退メッセージを受け取り、ルータが受信インターフェイスの DF でない場合、メッセージは無視されます。そうでない場合、ルータは共有ツリーをスパース モードと同じように更新します。

ルータがすべて双方向共有ツリーをサポートしているネットワークでは、(S, G) 加入および脱退メッセージは無視されます。DF 選定手順は RP からパラレル ダウンストリーム パスをなくすため、PIM アサート メッセージを送信する必要もありません。RP はソースへのパスに参加することなく、登録停止も送信しません。

パケット転送

ルータは双方向グループに対してのみ (*, G) エントリを作成します。(*, G) エントリの olist には、ルータが選定された DF であり、IGMP または PIM 加入メッセージを受信したインターフェイスがすべて含まれます。ルータが送信者専用ブランチにある場合、(*, G) ステートも作成されますが、olist にはいずれのインターフェイスも含まれません。

パケットを RP 方向の RPF インターフェイスから受信した場合、(*, G) エントリの olist に従って、パケットはダウンストリームに転送されます。それ以外の場合、受信インターフェイスの DF であるルータのみがパケットを RP 方向にアップストリームに転送します。その他のルータはすべてパケットを廃棄する必要があります。

前提条件

双方向 PIM の設定時に必要なアクセス リストすべてを、設定作業の開始前に設定する必要があります。アクセス リストの設定方法については、『 Creating an IP Access List and Applying It to an Interface 』モジュールを参照してください。

手順の概要

1. enable

2. configure terminal

3. ip multicast-routing [ distributed ]

4. interface type number

5. ip pim sparse-mode

6. exit

7. ip pim bidir-enable

8. ip pim rp-address rp-address [access-list] [ override ] bidir

9. end

10. すべてのルータのすべてのマルチキャスト対応インターフェイス上でステップ 2 ~ 9 を繰り返します。

11. show ip pim rp [mapping] [rp-address]

12. show ip mroute

13. show ip pim interface [type number] [df | count] [rp-address]

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip multicast-routing [ distributed ]

 

Router(config)# ip multicast-routing

IP マルチキャスト ルーティングをイネーブルにします。

distributed キーワードを使用して、マルチキャスト分散スイッチングをイネーブルにします。

ステップ 4

interface type number

 

Router(config)# interface ethernet 1

PIM をイネーブルにできるホストに接続されているインターフェイスを選択します。

ステップ 5

ip pim sparse-mode

 

Router(config-if)# ip pim sparse-mode

スパース モードをイネーブルにします。

ステップ 6

exit

 

Router(config-if)# exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 7

ip pim bidir-enable

 

Router(config)# ip pim bidir-enable

ルータの Bidir-PIM をイネーブルにします。

すべてのルータでこのステップを実行します。

ステップ 8

ip pim rp-address rp-address [ access-list ] [ override ] bidir

 

Router(config)# ip pim rp-address 10.0.1.1 45 bidir

特定のグループの PIM RP のアドレスを設定します。

すべてのルータでこのステップを実行します。

このコマンドは、RP を双方向に定義し、アクセス リストの方法で双方向グループを定義します。

ダイナミックとスタティックのグループと RP のマッピングが共に使用され、RP アドレスが競合している場合、スタティックのグループと RP のマッピングに設定された RP アドレスが優先されるよう指定するには、オプションの override キーワードを使用します。

キーワードが指定されておらず、RP アドレスが競合している場合、ダイナミックのグループと RP のマッピングがスタティックのグループと RP のマッピングに優先されます。

ステップ 9

end

 

Router(config-if)# end

インターフェイス コンフィギュレーション モードを終了し、特権 EXEC モードに戻ります。

ステップ 10

すべてのルータのすべてのマルチキャスト対応インターフェイス上でステップ 2 ~ 9 を繰り返します。

--

ステップ 11

show ip pim rp [mapping] [rp-address]

 

Router# show ip pim rp

(任意)関連付けられたマルチキャスト ルーティング エントリでキャッシュされたアクティブな RP を表示します。

ステップ 12

show ip mroute

 

Router# show ip mroute

(任意)IP mroute テーブルの内容を表示します。

ステップ 13

show ip pim interface [type number] [ df | count ] [ rp-address ]

 

Router# show ip pim interface

(任意)DF に関連付けられたユニキャスト ルーティング メトリックと共に、インターフェイスの各 RP の選定された DF についての情報を表示します。

基本的な IP マルチキャストの設定例

ここでは、次の例について説明します。

「例:Auto-RP でのスパース モード」

「例:エニーキャスト RP でのスパース モード」

「例:ブートストラップ ルータでのスパース モード」

「例:BSR および RFC 2362 の相互利用可能な候補 RP」

「例:単一のスタティック RP でのスパース モード」

「例:IGMPv3 を使用した SSM」

「例:SSM フィルタリング」

「例:Bidir-PIM」

例:Auto-RP でのスパース モード

次の例では、Auto-RP でスパース モードを設定しています。

ip multicast-routing
ip pim autorp listener
ip pim send-rp-announce Loopback0 scope 16 group-list 1
ip pim send-rp-discovery Loopback1 scope 16
access-list 1 permit 239.254.2.0 0.0.0.255
access-list 1 permit 239.254.3.0 0.0.0.255
.
.
.
access-list 10 permit 224.0.1.39
access-list 10 permit 224.0.1.40
access-list 10 permit 239.254.2.0 0.0.0.255
access-list 10 permit 239.254.3.0 0.0.0.255

例:エニーキャスト RP でのスパース モード

エニーキャスト RP 実装の主な目的は、ダウンストリーム マルチキャスト ルータが RP に対してアドレスを 1 つだけ持つことです。 の例は、RP(RP1 および RP2)のループバック インターフェイス 0 が 10.0.0.1 IP アドレスで設定される方法を示しています。この 10.0.0.1 アドレスがすべての RP でループバック インターフェイス 0 のアドレスとして設定され、RP アドレスとして設定される場合、IP ルーティングが最も近い RP 上で収束します。このアドレスは、ホスト ルートである必要があります。255.255.255.255 サブネット マスクです。

ダウンストリーム ルータは 10.0.0.1 RP アドレスについて通知される必要があります。 で、ルータは ip pim rp-address 10.0.0.1 グローバル コンフィギュレーション コマンドによって静的に設定されます。この設定は、Auto-RP またはブートストラップ ルータ(BSR)機能を使用して行うこともできます。

内の RP は MSDP を使用してソース情報を共有する必要もあります。この例で、RP(RP1 および RP2)のループバック インターフェイス 1 は MSDP ピアリング用に設定されています。MSDP ピアリング アドレスはエニーキャスト RP アドレスとは異なる必要があります。

図 5 エニーキャスト RP の設定

 

多くのルーティング プロトコルがルータ ID に対してループバック インターフェイス上で最も高い IP アドレスを選択します。ルータがルータ ID に対してエニーキャスト RP アドレスを選択すると、問題が発生する場合があります。RP 上でルータ ID を MSDP ピアリング アドレスと同じアドレスに手動で設定して、この問題を回避することを推奨します(たとえば、 のループバック 1 アドレス)。Open Shortest Path First(OSPF)では、ルータ ID は router-id ルータ コンフィギュレーション コマンドを使用して設定されます。Border Gateway Protocol(BGP; ボーダー ゲートウェイ プロトコル)では、ルータ ID は bgp router-id ルータ コンフィギュレーション コマンドを使用して設定されます。多くの BGP トポロジでは、RPF チェックをパスするために、MSDP ピアリング アドレスと BGP ピアリング アドレスが同じである必要があります。BGP ピアリング アドレスは、 neighbor update-source ルータ コンフィギュレーション コマンドを使用して設定できます。

上記のエニーキャスト RP の例は、RFC 1918 からの IP アドレスを使用します。これらの IP アドレスは通常ドメイン間の境界でブロックされ、このため、他の ISP にはアクセスできません。RP に他のドメインから到達できるようにするには、有効な IP アドレスを使用する必要があります。

次の例は、エニーキャスト RP 設定の実行方法を示しています。

RP 1 上で

ip pim rp-address 10.0.0.1
interface loopback 0
ip address 10.0.0.1 255.255.255.255
!
interface loopback 1
ip address 10.1.1.1. 255.255.255.255
!
ip msdp peer 10.1.1.2 connect-source loopback 1
ip msdp originator-id loopback 1
 

RP 2 上で

ip pim rp-address 10.0.0.1
interface loopback 0
ip address 10.0.0.1 255.255.255.255
 
interface loopback 1
ip address 10.1.1.2. 255.255.255.255
!
ip msdp peer 10.1.1.1 connect-source loopback 1
ip msdp originator-id loopback 1
 

その他のすべてのルータ

ip pim rp-address 10.0.0.1
no ip pim dm-fallback

例:ブートストラップ ルータでのスパース モード

次の例は、候補 BSR の設定です。これは、候補 RP の場合も同様です。

!
ip multicast-routing
!
interface Ethernet0
ip address 172.69.62.35 255.255.255.240
ip pim sparse-mode
!
interface Ethernet1
ip address 172.21.24.18 255.255.255.248
ip pim sparse-mode
!
interface Ethernet2
ip address 172.21.24.12 255.255.255.248
ip pim sparse-mode
!
ip pim bsr-candidate Ethernet2 30 10
ip pim rp-candidate Ethernet2 group-list 5
access-list 5 permit 239.255.2.0 0.0.0.255

例:BSR および RFC 2362 の相互利用可能な候補 RP

シスコ製およびシスコ製以外のルータが PIM バージョン 2 BSR を備えた単一の PIM ドメイン内で動作している場合、BSR RP 選択の Cisco IOS 実装は RFC 2362 と完全には互換性がないため候補 RP の設定時には注意が必要です。

RFC 2362 は BSR RP が次のように選択されるよう指定しています(RFC 2362, 3.7)。

1. 最も高い優先度(最も低く設定された優先値)の候補 RP を選択します。

2. 優先度が同点の場合、ハッシュ関数値が最も高い候補 RP を選択します。

3. ハッシュ関数値が同点の場合、IP アドレスが最も高い候補 RP を選択します。

Cisco ルータは、優先度、ハッシュ関数、IP アドレスに基づいて RP を選択する前に、常に通知されたグループ アドレス プレフィクスの最長一致に基づいて候補 RP を選択します。

部分的に重複するグループ アドレス範囲で複数の候補 RP が設定されると、同じドメイン内のシスコ製およびシスコ製以外の RFC 2362 互換ルータ間で候補 RP 選択が矛盾する可能性があります。候補 RP 選択の矛盾は、PIM ドメイン内のソースとレシーバ間の接続を妨げる可能性があります。ソースがある候補 RP を登録し、レシーバが同じグループ内であっても別の候補 RP に接続する可能性があります。

次の例は、PIM バージョン 2 BSR を備えた単一の PIM ドメイン内のシスコ製およびシスコ製以外のルータ間で RP 選択の矛盾を招く可能性のある設定を示しています。

access-list 10 permit 224.0.0.0 7.255.255.255
ip pim rp-candidate ethernet1 group-list 10 priority 20
 
access-list 20 permit 224.0.0.0 15.255.255.255
ip pim rp-candidate ethernet2 group-list 20 priority 10

 

この例では、イーサネット インターフェイス 1 の候補 RP がより低い優先度 20 を持つより長いグループ プレフィクス 224.0.0.0/5 を通知します。イーサネット インターフェイス 2 の候補 RP がより高い優先度 10 を持つより短いグループ プレフィクス 224.0.0.0/4 を通知します。両方の範囲に一致するすべてのグループで、イーサネット インターフェイス 1 の候補 RP はより長いグループ プレフィクスを通知するため、Cisco ルータは常にこれを選択します。イーサネット インターフェイス 2 の候補 RP はより高い優先度で設定されているため、シスコ製以外の RFC 2362 に完全準拠したルータは常にこれを選択します。

この相互運用性の問題を避けるには、部分的に重複するグループ アドレス プレフィクスを通知する別の候補 RP を設定しないでください。同じグループ プレフィクス長を持つ複数の候補 RP から通知する場合は、任意のグループ プレフィクスを設定します。

次の例は、PIM バージョン 2 BSR を備えた単一の PIM ドメイン内の Cisco ルータとシスコ製以外のルータの間に互換性が生じるように以前の例を設定する方法を示します。

access-list 10 permit 224.0.0.0 7.255.255.255
ip pim rp-candidate ethernet1 group-list 10 priority 20
 
access-list 20 permit 224.0.0.0 7.255.255.255
access-list 20 permit 232.0.0.0 7.255.255.255
ip pim rp-candidate ethernet2 group-list 20 priority 10

 

この設定では、イーサネット インターフェイス 2 の候補 RP がグループ アドレス 224.0.0.0/5 と 224.0.0.0/4 に等しい 232.0.0.0/5 を通知しますが、インターフェイスにイーサネット 1 の候補 RP と同じグループ プレフィクス長(5)を与えます。結果として、Cisco ルータと RFC 2362 互換ルータの両方が RP イーサネット インターフェイス 2 を選択します。

例:単一のスタティック RP でのスパース モード

次の例は、すべてのマルチキャスト グループ(224/4)の PIM RP アドレスを 192.168.0.1 に設定し、すべてのグループをスパース モードで動作するよう定義する方法を示しています。

ip pim rp-address 192.168.0.1
 

次の例は、すべてのマルチキャスト グループ範囲 239/8 の PIM RP アドレスを 172.16.0.2 に設定する方法を示しています。

access list 10 239.0.0.0 0.255.255.255
ip pim rp-address 172.16.0.2 10

例:IGMPv3 を使用した SSM

次の例は、SSM 用に(IGMPv3 を実行する)ルータ を設定する方法を示しています。

ip multicast-routing
!
interface Ethernet3/1
ip address 172.21.200.203 255.255.255.0
description backbone interface
ip pim sparse-mode
!
interface Ethernet3/2
ip address 131.108.1.2 255.255.255.0
ip pim sparse-mode
description ethernet connected to hosts
ip igmp version 3
!
ip pim ssm default

例:SSM フィルタリング

次の例は、SSM ルーティングをサポートしない Cisco IOS ソフトウェア リリースを実行しているレガシー RP ルータでフィルタリングを設定する方法を示しています。このフィルタリングは SSM 範囲で不要な PIM-SM および MSDP トラフィックをすべて抑制します。このフィルタリングがなくても SSM は動作しますが、レガシーのファースト ホップ ルータとラスト ホップ ルータがネットワークに存在する場合、追加の RPT トラフィックがある場合があります。

ip access-list extended no-ssm-range
deny ip any 232.0.0.0 0.255.255.255
permit ip any any
! Deny sources registering in SSM range
ip pim accept-register list no-ssm-range
ip access-list extended msdp-nono-list
deny ip any 232.0.0.0 0.255.255.255
permit ip any any
! Filter generated SA messages in SSM range. This configuration is needed only if there
! are sources directly connected to this router. The ip pim accept-register command
! filters remote sources. See http://www.cisco.com/warp/public/105/49.html for other SA
! messages that typically need to be filtered.
ip msdp redistribute list msdp-nono-list
! Filter received SA messages in SSM range. "Filtered on receipt" means messages are
! neither processed nor forwarded. This filter needs to be configured for each MSDP peer.
ip msdp sa-filter in msdp-peer1 list msdp-nono-list
.
.
.
ip msdp sa-filter in msdp-peerN list msdp-nono-list

例:Bidir-PIM

デフォルトで、双方向 RP はすべてのグループを双方向としてアドバタイズします。RP 上のアクセス リストは、双方向とアドバタイズされるグループのリストを指定するために使用できます。 deny キーワードを持つグループはデンス モードで動作します。単一のアクセス リストは permit または deny キーワード のみを許可するために、スパース モードで動作するグループには別の非双方向 RP アドレスが必要です。

次の例は、スパース モードと双方向モードの両方のグループで RP を設定する方法を示しています。224/8 および 227/8 と特定されたグループは双方向グループで、226/8 はスパース モード グループです。RP は、スパース モード動作と双方向モード動作に異なる IP アドレスを使用するよう必要があります。2 つのループバック インターフェイスはこの設定を許可するよう使用します。これらのループバック インターフェイスのアドレスは、PIM ドメイン内の他のルータが RP と通信できる方法で、PIM ドメイン中にルーティングする必要があります。

ip multicast-routing
!
.
.
.
!
interface loopback 0
description One loopback address for this router’s Bidir Mode RP function
ip address 10.0.1.1 255.255.255.0
!
interface loopback 1
description One loopback address for this router’s Sparse Mode RP function
ip address 10.0.2.1 255.255.255.0
!
.
.
.
!
ip pim bidir-enable
ip pim rp-address 10.0.1.1 45 bidir
ip pim rp-address 10.0.2.1 46
!
access-list 45 permit 224.0.0.0 0.255.255.255
access-list 45 permit 227.0.0.0 0.255.255.255
access-list 46 permit 226.0.0.0 0.255.255.255

その他の参考資料

関連資料

関連項目
参照先

IP マルチキャスト コマンド:コマンド構文の詳細、コマンド モード、コマンド履歴、デフォルト設定、使用に関する注意事項、および例

『Cisco IOS IP Multicast Command Reference』

規格

規格
タイトル

draft-kouvelas-pim-bidir-new-00.txt

『A New Proposal for Bi-directional PIM』

MIB

MIB
MIB リンク

この機能がサポートする新しい MIB または変更された MIB はありません。また、この機能で変更された既存 MIB のサポートはありません。

選択したプラットフォーム、Cisco ソフトウェア リリース、および機能セットの MIB の場所を検索しダウンロードするには、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

シスコのテクニカル サポート

説明
リンク

右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。

以下を含むさまざまな作業にこの Web サイトが役立ちます。
・テクニカル サポートを受ける
・ソフトウェアをダウンロードする
・セキュリティの脆弱性を報告する、またはシスコ製品のセキュリティ問題に対する支援を受ける
・ツールおよびリソースへアクセスする
- Product Alert の受信登録
- Field Notice の受信登録
- Bug Toolkit を使用した既知の問題の検索
・Networking Professionals(NetPro)コミュニティで、技術関連のディスカッションに参加する
・トレーニング リソースへアクセスする
・TAC Case Collection ツールを使用して、ハードウェアや設定、パフォーマンスに関する一般的な問題をインタラクティブに特定および解決する

この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

http://www.cisco.com/cisco/web/support/index.html

基本的な IP マルチキャスト設定の機能情報

表 1 に、このモジュールで説明した機能をリストし、特定の設定情報へのリンクを示します。

ここに記載されていないこのテクノロジーの機能情報については、『 IP Multicast Features Roadmap 』を参照してください。

Cisco Feature Navigator を使用すると、プラットフォームおよびソフトウェア イメージのサポート情報を検索できます。Cisco Feature Navigator を使用すると、ソフトウェア イメージがサポートする特定のソフトウェア リリース、機能セット、またはプラットフォームを確認できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。


表 1 には、一連のソフトウェア リリースのうち、特定の機能が初めて導入されたソフトウェア リリースだけが記載されています。特に明記されていない限り、Cisco IOS ソフトウェア リリース群の後続のリリースでもこの機能をサポートします。


 

表 1 基本的な IP マルチキャスト設定の機能情報

機能名
リリース
機能情報

ネットワークにおける RP 情報損失後の PIM デンス モード フォールバック回避

12.3(4)T
12.0(28)S
12.2(33)SRA
12.2(33)SXH
15.0(1)S

ネットワークにおける RP 情報損失後の PIM デンス モード フォールバック回避機能は、すべての RP で障害が発生したときに PIM-DM のフォールバックを回避できるようにします。信頼性が重大な意味を持つマルチキャスト ネットワークにとって、デンス モードの使用を回避することは非常に重要です。この機能は、スパース モードでマルチキャスト グループを保持するためのメカニズムを提供し、それによってデンス モード フラッディングを回避します。

この機能に関する詳細については、次の各項を参照してください。

「自動ランデブー ポイント(Auto-RP)でのスパース モードの設定」

この機能により、次のコマンドが導入されました。
ip pim dm-fallback

Source Specific Multicast(SSM)

12.3(4)T
12.2(25)S
12.0(28)S
12.2(33)SXH
12.2(33)SRA
15.0(1)S
Cisco IOS XE 3.1.0SG

SSM は、レシーバが明示的に参加したマルチキャスト ソースからのみデータグラム トラフィックがレシーバに転送される IP マルチキャストの拡張機能です。SSM 用に設定されたマルチキャスト グループは、(共有ツリーではなく)ソース固有のマルチキャスト配信ツリーのみが作成されます。

この機能に関する詳細については、次の各項を参照してください。

「Source Specific Multicast(SSM)の設定」

「例:IGMPv3 を使用した SSM」

「例:SSM フィルタリング」