Cisco Nexus Cloud Services Platform ソフトウェア インストレーション/アップグレード ガイド リリース 4.2(1)SP1(6.2)
Cisco Nexus Cloud Services Platform ソフトウェアのインストール
Cisco Nexus Cloud Services Platform ソフトウェアのインストール
発行日;2013/12/16 | 英語版ドキュメント(2013/10/16 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 1MB) | フィードバック

目次

Cisco Nexus Cloud Services Platform ソフトウェアのインストール

ソフトウェアのインストールについて

前提条件

注意事項および制約事項

Cisco Host Upgrade Utility に関する情報

Cisco CIMC ソフトウェアのバージョンの確認

管理ソフトウェアについての情報の収集

管理者クレデンシャル

High Availability(HA; ハイ アベイラビリティ)冗長ロール

HA 冗長ステート

ドメイン ID

ネットワーク アップリンク

VLAN

管理 VLAN

制御 VLAN

プライマリ の設定

セカンダリ の設定

ネットワーク アップリンクの設定例

設定の確認

の準備

ソフトウェア インストールの機能の履歴

Cisco Nexus Cloud Services Platform ソフトウェアのインストール

この章では、Cisco Nexus Cloud Services Platform ソフトウェアのインストール手順を説明します。内容は次のとおりです。

「ソフトウェアのインストールについて」

「前提条件」

「注意事項および制約事項」

「Cisco Host Upgrade Utility に関する情報」

「Cisco CIMC ソフトウェアのバージョンの確認」

「管理ソフトウェアについての情報の収集」

「プライマリ Cisco Nexus Cloud Services Platform の設定」

「セカンダリ Cisco Nexus Cloud Services Platform の設定」

「ネットワーク アップリンクの設定例」

「Cisco Nexus Cloud Services Platform 設定の確認」

「Cisco Nexus Cloud Services Platform の準備」

「ソフトウェア インストールの機能の履歴」


) 仮想サービス ブレード(VSB)としての Cisco Nexus 1000V ソフトウェアのアップグレードについては、『Cisco Nexus 1000V Software Installation and Upgrade Guide, Release 4.2(1)SV2(2.1)』を参照してください。


Cisco Nexus Cloud Services Platform 製品ファミリの概要と、インストール後のソフトウェアの設定手順については、『 Cisco Nexus Cloud Services Platform Software Configuration Guide 』を参照してください。

ソフトウェアのインストールについて

Cisco Nexus Cloud Services Platform ソフトウェアは、ISO イメージとしてあらかじめインストールされています。


ステップ 1 正しいバージョンの Cisco Integrated Management Controller(CIMC)ソフトウェアがインストールされていることを確認します。「Cisco CIMC ソフトウェアのバージョンの確認」を参照してください。

ステップ 2 管理ソフトウェアについての情報を収集します。「管理ソフトウェアについての情報の収集」を参照してください。

ステップ 3 プライマリ Cisco Nexus Cloud Services Platform を設定します。「プライマリ Cisco Nexus Cloud Services Platform の設定」を参照してください。

ステップ 4 セカンダリ Cisco Nexus Cloud Services Platform を設定します。「セカンダリ Cisco Nexus Cloud Services Platform の設定」を参照してください。


 

前提条件

Cisco Nexus Cloud Services Platform Release 4.2(1)SP1(6.2) をインストールする前に、次の点を理解または実行しておく必要があります。

最新のファームウェア リリースを搭載していること。


注意 Cisco Host Upgrade Utility(HUU)を使用して、ファームウェアをアップグレードすることを推奨します。そうしないと、ネットワーク設定の失敗やシステムの再起動という結果になる可能性があります。HUU アップグレード メニューを使用する場合、CIMC、BIOS およびハードウェアの他のすべてのコンポーネントをアップグレードするオプションを選択します。Cisco HUU ファイルの詳細については、「Cisco Host Upgrade Utility に関する情報」を参照してください。

次の Cisco Integrated Management Controller(CIMC)ソフトウェアをインストールします。

Cisco Nexus 1110 製品ファミリのバージョン 1.5(1f)

Cisco Nexus 1010 製品ファミリのバージョン 1.4(3s)4

正しいバージョンの CIMC がインストールされていることを確認するには、 Cisco CIMC ソフトウェアのバージョンの確認を参照してください。


) • 1.4(3) より前のファームウェア リリースの場合、Cisco HUU は Cisco Nexus 1010 および Cisco Nexus 1010-X をサポートしません。このような場合、Cisco Virtual Services Appliance CIMC GUI を使用して手動で CIMC バージョン 1.4(3) にアップデートしてから、Cisco Host Upgrade Utility を使用してファームウェア バージョン 1.4(3s)4 にアップグレードします。

最新の CIMC バージョンにアップグレードするには、『Cisco UCS C-Series Servers Integrated Management Controller CLI Configuration Guide, Release 1.4.』にある手動の手順に従います。

BIOS ファームウェア バージョンをアップグレードするには、『Cisco UCS C-Series Rack-Mount Server BIOS Upgrade Guide』にある手動の手順に従います。

ファームウェア リリース 1.4(3) 以降では、Cisco UCS Host Upgrade Utility ツールで Cisco Nexus Virtual Services Appliance がサポートされます。詳細については、 Cisco UCS Host Upgrade Utility ツールのマニュアルを参照してください。


 

注意事項および制約事項

Cisco Nexus Cloud Services Platform 製品ファミリの制約事項およびガイドラインは次のとおりです。

ドメイン ID は制御 VLAN 内で一意である必要があります。

他の Cisco Nexus Cloud Services Platform または Cisco Nexus 1000V が同じ制御 VLAN に存在する場合も、ドメイン ID は全体で一意である必要があります。

ソフトウェアの設定時に、使用しているシステムのアップリンク タイプを設定します。アップリンク タイプを設定した場合、アップリンク タイプを変更するにはソフトウェアをリロードする必要があります。

HA スタンドアロン ロールは Cisco Nexus Cloud Services Platform ではサポートされていません。

Cisco Nexus Cloud Services Platform は HA モード以外ではサポートされていません。

プライマリ Cisco Nexus Cloud Services Platform をセカンダリ バックアップと同時に設定することを推奨します。プライマリ Cisco Nexus Cloud Services Platform は、セカンダリ バックアップなしで設定してもかまいませんが、この設定は実働環境ではサポートされていません。

プライマリおよびセカンダリの両方の Cisco Nexus Cloud Services Platform で、ドメイン ID、アップリンク タイプ、制御 VLAN、管理 VLAN、制御アップリンク、管理アップリンクを同じものに設定する必要があります。

Cisco Nexus Cloud Services Platform のペアリングは、ハードウェア プラットフォームと一致している必要があります。たとえば、Cisco Nexus 1010-X は別の Cisco Nexus 1010-X に限りペアを組み、Cisco Nexus 1110-X は Cisco Nexus 1110-X に限りペアを組みます。Cisco Nexus 1010 と Cisco Nexus 1010-X をペアにすることや、Cisco Nexus 1110-S と Cisco Nexus 1110-X または他のモデルをペアにすることはできません。

Cisco Host Upgrade Utility に関する情報

Cisco Host Upgrade Utility(HUU)は、1 つまたは複数の Cisco UCS C シリーズ サーバ上でファームウェアをアップグレードするツールです。HUU はすでにインストールした次のコンポーネントの現在バージョンを検出し、これらを最新バージョンにアップグレードするように促します。

Cisco Integrated Management Controller(CIMC)

システム BIOS

LAN 機能搭載マザーボード(LOM)

RAID コントローラ

Cisco UCS P81E 仮想インターフェイス カード(VIC)

Cisco UCS VIC 1225

Cisco UCS VIC 1225-T

ネットワーク アダプタ

Cisco HUU の最低限必要なバージョンおよび HUU ISO のダウンロード方法に関する情報は、次の入手先から入手できます。 

Cisco Nexus 1010 製品ファミリについては、『 Cisco Host Upgrade Utility Release 1.4(3) Quick Start Guide 』を参照してください。

Cisco Nexus 1110 製品ファミリについては、『 Cisco Host Upgrade Utility 1.5(1) User Guide 』を参照してください。

Cisco Nexus Cloud Services Platform リリース 4.2(1)SP1(6.2) をインストールする前に、ファームウェアをアップグレードするには、HUU のマニュアルの手順を使用する必要があります。


注意 ファームウェアのアップグレードのために、適切な HUU バージョンを使用していることを確認します。Cisco Nexus 1010 および Cisco Nexus 1110 製品ファミリで HUU バージョンは互いに置き換えて使用できません。

Cisco CIMC ソフトウェアのバージョンの確認

CIMC ソフトウェア バージョンが Cisco Nexus Cloud Services Platform にインストールされていることを確認します。

はじめる前に

この手順を開始する前に、次のことを確認または実行する必要があります。

コマンドライン インターフェイス(CLI)または Web ブラウザから、Cisco Nexus Cloud Services Platform にログインします。

CIMC ソフトウェア 1.4(3s)4 以降がインストールされている場合、show hardware コマンドの出力で、Cisco Nexus 1010 では製品 ID N1K-C1010、Cisco Nexus 1010-X では製品 ID N1K-C1010X が得られます。

CIMC ソフトウェア バージョン 1.5(1f) 以降がインストールされている場合、show hardware コマンドの出力で、Cisco Nexus 1110-S では製品 ID N1K-1110-S、Cisco Nexus 1110-X では製品 ID N1K-1110-X が得られます。


ステップ 1 Cisco Nexus Cloud Services Platform から、次のいずれかを実行して製品 ID(PID)を表示します。

コマンドライン インターフェイス(CLI)から、 show hardware コマンドを入力します。
「Switch Hardware ID information」の下にある PID を探します。

Example:
switch# show hardware
unset
Software
loader: version unset
kickstart: version unset
system: version unset
kickstart image file is: unset
kickstart compile time: unset [unset]
system image file is: unset
system compile time: unset [unset]
 
 
Hardware
cisco unset ("unset")
unset with unset unset of memory.
Processor Board ID unset
 
Device name: unset
bootflash: unset kB
Disk Storage capacity for VM virtual disks: 345945 MB
Number of physical 1Gbps ethernet ports: 6
Number of CPU Cores: 16
CPU Cores details:
model name : Intel(R) Xeon(R) CPU E5-2650 0 @ 2.00GHz
model name : Intel(R) Xeon(R) CPU E5-2650 0 @ 2.00GHz
model name : Intel(R) Xeon(R) CPU E5-2650 0 @ 2.00GHz
model name : Intel(R) Xeon(R) CPU E5-2650 0 @ 2.00GHz
model name : Intel(R) Xeon(R) CPU E5-2650 0 @ 2.00GHz
model name : Intel(R) Xeon(R) CPU E5-2650 0 @ 2.00GHz
model name : Intel(R) Xeon(R) CPU E5-2650 0 @ 2.00GHz
model name : Intel(R) Xeon(R) CPU E5-2650 0 @ 2.00GHz
model name : Intel(R) Xeon(R) CPU E5-2650 0 @ 2.00GHz
model name : Intel(R) Xeon(R) CPU E5-2650 0 @ 2.00GHz
model name : Intel(R) Xeon(R) CPU E5-2650 0 @ 2.00GHz
model name : Intel(R) Xeon(R) CPU E5-2650 0 @ 2.00GHz
model name : Intel(R) Xeon(R) CPU E5-2650 0 @ 2.00GHz
model name : Intel(R) Xeon(R) CPU E5-2650 0 @ 2.00GHz
model name : Intel(R) Xeon(R) CPU E5-2650 0 @ 2.00GHz
model name : Intel(R) Xeon(R) CPU E5-2650 0 @ 2.00GHz
 
 
Kernel uptime is unset day(s), unset hour(s), unset minute(s), unset second(s)
 
 
plugin
Core Plugin, Ethernet Plugin, Virtualization Plugin
--------------------------------
Switch hardware ID information
--------------------------------
 
Switch is booted up
Switch type is : Nexus 1110-S (Virtual Services Appliance) 2 slot Chassis
Model number is Nexus 1110-S
PID-VID-SN: N1K-C1110-S-2.0-1846886525134693056
 
--------------------------------
Chassis has 2 Module slots
--------------------------------
 
Module1 ok
Module type is : Cisco Virtual Services Appliance
0 submodules are present
Model number is Nexus 1110-S
H/W version is 2.0
UUID is 0F823778-D54A-4970-E999-2077C67F0133
Manufacture date is 02/22/2012
Serial number is
 
Module2 ok
Module type is : Cisco Virtual Services Appliance
0 submodules are present
Model number is Nexus 1110-S
H/W version is 2.0
UUID is 68143FE5-207B-4989-F297-0937998C9424
Manufacture date is 02/22/2012
Serial number is QCI1410A4LP

 

Web ブラウザで、[Server Summary] ウィンドウを開いてサーバ プロパティを表示します。例については、図 2-1 を参照してください。

図 2-1 CIMC のウィンドウに表示される製品 ID(PID)

 

 

ステップ 2 次のいずれかの手順を実行します。

表示される PID が、Cisco Nexus 1110-S で N1K-1110-S、Cisco Nexus 1110-X で N1K-1110-X、Cisco Nexus 1010 で N1K-C1010、あるいは Cisco Nexus 1010-X で N1K-C1010-X の場合は、Cisco Nexus Cloud Services Platform Release 4.2(1)SP1(6.2) のインストールまたはアップグレードに進みます。

表示された PID が上記のものでない場合は、Release 4.2(1)SP1(6.2) のインストールまたはアップグレードに進まないでください。代わりに、RMA プロセスを使用して Cisco Nexus Cloud Services Platform を置き換える必要があります。詳細については、Cisco Nexus Cloud Services Platform の交換の項を参照してください。

管理ソフトウェアについての情報の収集

インストールを開始する前に、Cisco Nexus Cloud Services Platform について以下の情報が必要です。

「管理者クレデンシャル」

「High Availability(HA; ハイ アベイラビリティ)冗長ロール」

「HA 冗長ステート」

「ドメイン ID」

「ネットワーク アップリンク」

「VLAN」

管理者クレデンシャル

システム ソフトウェアを設定する場合は、管理者パスワードを作成する必要があります。 表 2-1 に、パスワード強化のためのガイドラインを示します。

 

表 2-1 パスワード強化ためのガイドライン

強力なパスワードの特性
脆弱なパスワードの特性

最低 8 文字

大文字の英字

小文字の英字

数字

特殊文字

連続する文字(例:abcd)

文字の繰り返し(例:aaabbb)

辞書に載っている単語

固有名詞

High Availability(HA; ハイ アベイラビリティ)冗長ロール

Cisco Nexus Cloud Services Platform 製品ファミリは、ハイ アベイラビリティを実現するために冗長なペアで提供されます。デバイスを設定する場合に、ハイ アベイラビリティ ロール(プライマリまたはセカンダリ)を設定します。 表 2-2 に、これらのロールの説明を示します。


) HA スタンドアロン ロールは Cisco Nexus Cloud Services Platform 製品ファミリではサポートされていません。Cisco Nexus Cloud Services Platform は HA モード以外ではサポートされていません。


 

表 2-2 HA 冗長ロール

ロール
説明

プライマリ

プライマリ ロールは、セカンダリ Cisco Nexus Cloud Services Platform とアクティブまたはスタンバイ冗長ステートを調整します。

アクティブまたはスタンバイ冗長ステートをネゴシエートする場合は、ブートアップ中にプライマリ ロールが優先されます。つまり、ブートアップ時にセカンダリ Cisco Nexus Cloud Services Platform がアクティブ ステートでない場合は、プライマリ Cisco Nexus Cloud Services Platform がアクティブ冗長ステートになります。

プライマリ ロールを、デュアル システムで最初にインストールした Cisco Nexus Cloud Services Platform に割り当てます。

セカンダリ

セカンダリ ロールは、プライマリ Cisco Nexus Cloud Services Platform とアクティブまたはスタンバイ ステートを調整します。

セカンダリ ロールを、デュアル システムで 2 番目にインストールした Cisco Nexus Cloud Services Platform に割り当てます。

HA 冗長ステート

表 2-3 に、HA 冗長ステートの説明を示します。

 

表 2-3 HA 冗長ステート

冗長性状態
説明

アクティブ

システムを制御し、外部から可視できます。

アクティブ システムは、初期設定後にネットワークからリモートでアクセスされます。

Cisco Nexus Cloud Services Platform を管理するためのユーザ インターフェイスを使用できるのは、アクティブ システムだけです。

スタンバイ

設定をアクティブ Cisco Nexus Cloud Services Platform のものと同期し、障害発生時や手動スイッチオーバーが必要な場合に設定を引き続き使用できるようにします。

Telnet または Secure Shell(SSH; セキュア シェル)プロトコルを使用してスタンバイ Cisco Nexus Cloud Services Platform と通信することはできません。

スタンバイ Cisco Nexus Cloud Services Platform はネットワークを介してアクセスできず、シリアル ポートを使用してアクセスされます。

Cisco Nexus Cloud Services Platform を管理するためのユーザ インターフェイスは、スタンバイ システムから利用できません。

ドメイン ID

プライマリおよびセカンダリ Cisco Nexus Cloud Services Platform は、ドメイン ID を使用してお互いを識別します。Cisco Nexus Cloud Services Platform は同じスイッチング ドメインに属し、同じ管理 IP アドレスを共有する必要があります。

ネットワーク アップリンク

Cisco Nexus Cloud Services Platform 製品ファミリは、ネットワークに接続するため次の 2 つのタイプのネットワーク アップリンク設定をサポートします。

フレキシブル ネットワーク アップリンク:フレキシブル ネットワーク設定により、Cisco Nexus Cloud Services Platform 製品ファミリをネットワークに接続する完全な柔軟性が得られ、最大 6 個のアップリンクを設置できるようになります。

スタティック ネットワーク アップリンク:スタティック ネットワーク アップリンク設定では、Cisco Nexus Cloud Services Platform 製品ファミリは 4 個の固定ネットワーク アップリンク設定を使用してネットワークに接続します。「ネットワーク アップリンク タイプ」 を参照してください。

上記の設定により、サポート対象の次の 5 つのアップリンク タイプのいずれかを使用してシステムをネットワークに接続できます。

1 つのアップリンク

共通の管理および制御トラフィックを持つ 2 つのアップリンク

共通の制御およびデータ トラフィックを持つ 2 つのアップリンク

3 つのアップリンク

フレキシブル ネットワーク アップリンク


) アップリンク タイプを設定後に、アップリンク タイプを変更するにはソフトウェアをリロードする必要があります。


ネットワーク アップリンクのタイプについて詳しくは、『 Cisco Nexus Cloud Services Platform Software Configuration Guide 』を参照してください。

Cisco Nexus Cloud Services Platform 製品ファミリのインストール時に、フレキシブル ネットワーク アップリンク タイプかスタティック ネットワーク アップリンク タイプのいずれかを設定できます。アップリンク タイプを変更する場合、アップリンク タイプを変更するたびにリロードして変更内容を反映させる必要があります。

ネットワーク アップリンクのタイプの移行について詳しくは、『 Cisco Nexus Cloud Services Platform Software Configuration Guide 』を参照してください。

表 2-4 に、サポートされた 4 つのネットワーク アップリンク タイプと各タイプの VLAN トラフィックを伝送するポートを示します。

表 2-4 ネットワーク アップリンク タイプ

アップリンク タイプ
アップリンクの説明
管理 VLAN
制御 VLAN
データ VLAN

1

すべてのトラフィックが 1 つのアップリンクを共有します。

ポート 1 とポート 2

ポート 1 とポート 2

ポート 1 とポート 2

2

共通の管理および制御トラフィックを持つ 2 つのアップリンク

ポート 1 とポート 2

ポート 1 とポート 2

ポート 3 ~ 6

3

共通の制御およびデータ トラフィックを持つ 2 つのアップリンク

ポート 1 とポート 2

ポート 3 ~ 6

ポート 3 ~ 6

4

管理トラフィック、制御トラフィック、およびデータ トラフィックが 3 つとも別々のアップリンクで伝送されます。

ポート 1 とポート 2

ポート 3 ~ 4

ポート 5 ~ 6

フレキシブル

トラフィック クラスに基づいたトラフィック分離はありません

VLAN

Cisco Nexus Cloud Services Platform 製品ファミリでは、仮想サービス ブレードに対する管理と通信を行うために制御 VLAN と管理 VLAN が使用されます。これらの VLAN は、管理ソフトウェアの初期設定の一部として追加されます。制御 VLAN とパケット VLAN も、VSB が作成されたときに各仮想サービス ブレードに追加されます。管理 VLAN は、各仮想サービス ブレードによって Cisco Nexus Cloud Services Platform 製品ファミリから継承されます。

Cisco Nexus Cloud Services Platform 製品ファミリで制御 VLAN、パケット VLAN、または管理 VLAN を変更する場合、変更はすぐに反映されます。制御 VLAN および管理 VLAN へのすべての変更を Cisco Nexus Cloud Services Platform で適用するには、スイッチをリロードする必要があります。ただし、サービスの持続性のため、ホストされた Virtual Supervisor Module(VSM)で同じ制御 VLAN とパケット VLAN を設定する必要があります。このように設定しないと、Cisco Nexus Cloud Services Platform が VSM との通信を失います。

この項では、次のトピックについて取り上げます。

「管理 VLAN」

「制御 VLAN」

管理 VLAN

管理 VLAN は、Cisco Nexus Cloud Services Platform の管理ポートに対するトラフィックを転送する VLAN です。仮想サービス ブレードがトラフィックの管理クラスを使用する場合、仮想サービス ブレードは Cisco Nexus Cloud Services Platform から管理 VLAN を継承します。

管理 VLAN は外部から使用され、Cisco Nexus Cloud Services Platform の管理 0 インターフェイスに到達します。

Cisco Nexus Cloud Services Platform とそれにホストされた Cisco Nexus 1000 Virtual Supervisor Module(VSM)は、スタティック トポロジで同じ管理 VLAN を共有します。仮想サービス ブレードの作成時に設定される制御 VLAN およびパケット VLAN とは異なり、管理 VLAN は継承されます。スタティック トポロジでは、VSB の管理 VLAN は変更できません。管理 VLAN は Cisco Nexus Cloud Services Platform から継承されるため、Cisco Nexus Cloud Services Platform の管理 VLAN を変更すると、変更は次回のリロードで Cisco Nexus Cloud Services Platform とそれにホストされたすべての Cisco Nexus 1000 VSM とに適用されます。

ただし、フレキシブル トポロジにはこの制約は存在せず、VSB の管理 VLAN が Cisco Nexus Cloud Services Platform ホストと異なっていても問題ありません。

制御 VLAN

制御 VLAN は、冗長な Cisco Nexus Cloud Services Platform 間の通信に使用されるレイヤ 2 インターフェイスです。このインターフェイスは、ハートビートなどの下位の制御パケットと Cisco Nexus Cloud Services Platform 間で交換する必要があるすべての設定データを処理します。

プライマリ Cisco Nexus Cloud Services Platform の設定

次に対して管理ソフトウェアを設定できます。

冗長 HA ペアのプライマリ Cisco Nexus Cloud Services Platform

プライマリ Cisco Nexus Cloud Services Platform をセカンダリ バックアップと同時に設定することを推奨します。プライマリ Cisco Nexus Cloud Services Platform は、セカンダリ バックアップなしで設定してもかまいませんが、この設定は実働環境ではサポートされていません。

はじめる前に

この Cisco Nexus Cloud Services Platform に対して次の情報が利用可能であること。

管理者パスワード

HA ロール(プライマリまたはセカンダリ)
HA ロールを指定しないと、ロールはプライマリとして設定されます。

ネットワーク アップリンク タイプ

制御 VLAN ID

ドメイン ID

管理 VLAN ID

管理 0 IP アドレス
この IP アドレスは、アプライアンスで mgmt0 ポートとして扱われます。

デフォルト ゲートウェイの IP アドレス

SSH サービスのキー タイプとキー ビット数

手順の詳細


ステップ 1 次のいずれかの方法を使用して、Cisco Nexus Cloud Services Platform CLI にログインします。

ターミナル サーバからログインします。

Example:
telnet 172.25.182.99 2005
Trying 172.25.182.99...
Connected to 172.25.182.99.
Escape character is '^]'
switch#
 
---- System Admin Account Setup ----
Enter the password for "admin":
Confirm the password for "admin":
 

CIMC で Serial over LAN(SoL)接続からログインします。

Example:
ssh admin@172.25.182.230
admin@172.25.182.230's password:
switch# connect host
CISCO Serial Over LAN:
Close Network Connection to Exit
 
---- System Admin Account Setup ----
Enter the password for "admin":
Confirm the password for "admin":
 

セットアップウイザードが自動的にスタートします。

 

ステップ 2 管理者パスワードを入力して確認します。

例:

---- System Admin Account Setup ----
Enter the password for "admin":
Confirm the password for "admin":

ステップ 3 HA ロールを入力します。ロールを指定しない場合は、プライマリ ロールが割り当てられます。

例:

Enter HA role[primary/secondary]: primary


) HA スタンドアロン ロールは Cisco Nexus Cloud Services Platform 製品ファミリではサポートされていません。Cisco Nexus Cloud Services Platform は HA モード以外ではサポートされていません。


ステップ 4 アップリンク タイプを入力します。スタティック ネットワーク アップリンクを指定するには、1 ~ 4 の値を入力します。フレキシブル ネットワーク アップリンクを指定するには、5 の値を入力します。


) アップリンク タイプを設定後に、アップリンク タイプを変更するにはソフトウェアをリロードする必要があります。


Example:
Enter network-uplink type <1-5>:
1. Ports 1-2 carry all management, control and data vlans
2. Ports 1-2 management and control, ports 3-6 data
3. Ports 1-2 management, ports 3-6 control and data
4. Ports 1-2 management, ports 3-4 control, ports 5-6 data
5. Flexible
5
 

ステップ 5 制御 VLAN の VLAN ID を入力します。

例:

Enter control vlan <1-3967, 4048-4093>: 1481
 

ステップ 6 制御アップリンクを入力します。

例:

Enter control uplink <1-6>: 1
 

ステップ 7 ドメイン ID を入力します。

例:

Enter the domain id<1-4095>: 121
 

ステップ 8 管理 VLAN の VLAN ID を入力します。

例:

Enter management vlan<1-3967,4048-4093>: 1490
 

ステップ 9 管理アップリンクを入力します。

例:

Enter management uplink <1-6>: 1
 

このプロセスを完了すると、Cisco Nexus Cloud Services Platform ソフトウェアは設定を保存し、ネットワーク アップリンクを設定するために自動的にリブートします。

新しい設定が不揮発性ストレージに保存された後、実行コンフィギュレーションとスタートアップ コンフィギュレーションが同一になります。

Saving boot configuration. Please wait...
 
[########################################] 100%
System is going to reboot to configure network uplinks
 

スイッチのリブート後、デフォルトのスタティック トポロジまたはフレキシブル トポロジが設定されます。vPC および VSS を含まないデフォルトのフレキシブル ネットワーク アップリンク設定の例については、図 2-2 を参照してください。vPC および VSS を含むデフォルトのフレキシブル ネットワーク設定の例については、図 2-3 を参照してください。

図 2-2 デフォルトのフレキシブル ネットワーク アップリンク設定(vPC および VSS を含まない)

 
 

図 2-3 デフォルトのフレキシブル ネットワーク アップリンク設定(vPC および VSS を含む)

詳細については、『 Cisco Nexus Cloud Services Platform Software Configuration Guide 』を参照してください。

ステップ 10 基本設定ダイアログボックスを開始する場合は、yes と入力します。

Example:
Would you like to enter the basic configuration dialog (yes/no): yes
 
---- Basic System Configuration Dialog ----
 
This setup utility will guide you through the basic configuration of
the system. Setup configures only enough connectivity for management
of the system.
 
*Note: setup is mainly used for configuring the system initially,
when no configuration is present. So setup always assumes system
defaults and not the current system configuration values.
 
Press Enter at anytime to skip a dialog. Use ctrl-c at anytime
to skip the remaining dialogs.
 

ステップ 11 別のログイン アカウントを作成しない場合は、no と入力します。

例:

Create another login account (yes/no) [n]: no
 

ステップ 12 読み取り専用 SNMP コミュニティ ストリングを設定しない場合は、no と入力します。

例:

Configure read-only SNMP community string (yes/no) [n]: no
 

ステップ 13 読み取りと書き込み SNMP コミュニティ ストリングを設定しない場合は、no と入力します。

Example:
Configure read-write SNMP community string (yes/no) [n]:
 

ステップ 14 アプライアンスの名前を入力します。

Example:
Enter the VSA name [Nexus1010]:
 

ステップ 15 アウトオブバンド管理を設定する場合は、yes と入力します。続いて管理 0 IPv4 または IPv6 アドレスを入力します。

この IP アドレスは、アプライアンスで mgmt0 ポートとして扱われます。

Example:
Continue with Out-of-band (mgmt0) management configuration? [yes/no] [y]: yes
Mgmt0 IP address type V4/V6? (V4): V4
Mgmt0 IPv4 address: 45.45.45.3
Mgmt0 IPv4 netmask prefix : 255.255.255.0

 

ステップ 16 デフォルト ゲートウェイを設定する場合は、yes 答えます。

Example:
Configure the default-gateway: (yes/no) [y]: yes
IPv4 address of the default gateway: 45.45.45.1
 

ステップ 17 拡張 IP オプションを設定しない場合は、no と入力します。

Example:
Configure Advanced IP options (yes/no)? [n]: no
 

ステップ 18 Telnet サービスをイネーブルにしない場合は、no と入力します。

Example:
Enable the telnet service? (yes/no) [y]: no
 

ステップ 19 SSH サービスをイネーブルにするには、yes と入力します。続いてキー タイプとキー ビット数を入力します。

Example:
Enable the ssh service? (yes/no) [y]: yes
Type of ssh key you would like to generate (dsa/rsa) : rsa
Number of key bits <768-2048> : 1024
 

ステップ 20 HTTP サーバを設定する場合は、yes と入力します。

Example:
Configure http-server?9yes/no) (y): yes
 

ステップ 21 NTP サーバを設定しない場合は、no と入力します。

設定の概要が表示されます。

Example:
Configure NTP server? (yes/no) [n]: no
The following configuration will be applied:
switchname N1010
interface mgmt0
ip address 45.45.45.3 255.255.255.0
no shutdown
vrf context management
ip route 0.0.0.0/0 45.45.45.1
no telnet server enable
ssh key rsa 1024 force
ssh server enable
feature http-server
 

ステップ 22 次のいずれかの手順を実行します。

設定を編集しない場合は、 no と入力して次のステップに進みます。

設定を編集する場合は、 yes と入力してステップ 11 に戻り、各コマンドを再度実行します。

Example:
Would you like to edit the configuration? (yes/no) [n]:no
 

ステップ 23 この設定を使用および保存するには、yes と入力します。


注意 ここで設定を保存しておかないと、次回のスイッチ起動時に設定が更新されません。新しい設定を保存し、キックスタートおよびシステム イメージが自動的に設定されたことを確認するには、yes と入力します。

Example:
Use this configuration and save it? (yes/no) [y]: yes
[########################################] 100%
 

新しい設定が不揮発性ストレージに保存された後、実行コンフィギュレーションとスタートアップ コンフィギュレーションが同一になります。


) EXEC モードで setup コマンドを入力すると、ステップ 23 からステップ 11 で実行した設定を更新するセットアップ ルーチンをいつでも使用できます。セットアップが開始されたら、Enter キーを押してコマンドをスキップします。Ctrl キーを押した状態で C キーを押して、残りのコマンドをスキップします。


ステップ 24 設定を確認します。

switch# show running configuration
!Command: show running-config
!Time: Thu Feb 27 02:57:25 2014
 
version 4.2(1)SP1(6.1)
no feature telnet
 
username admin password 5 $1$BzSSk6qR$m.FMEvkOXzutuLwrmVeUe/ role network-admin
 
banner motd #Cisco VSA#
 
ip domain-lookup
ip domain-lookup
hostname N1010
snmp-server user admin network-admin auth md5 0xb64ad6879970f0e57600c443287a79f0
priv 0xb64ad6879970f0e57600c443287a79f0 localizedkey
 
vrf context management
ip route 0.0.0.0/0 45.45.45.1
vlan 1,1481,1490
port-channel load-balance ethernet source-mac
port-profile default max-ports 32
 
vdc N1010 id 1
limit-resource vlan minimum 16 maximum 2049
limit-resource monitor-session minimum 0 maximum 2
limit-resource vrf minimum 16 maximum 8192
limit-resource port-channel minimum 0 maximum 768
limit-resource u4route-mem minimum 32 maximum 32
limit-resource u6route-mem minimum 16 maximum 16
limit-resource m4route-mem minimum 58 maximum 58
limit-resource m6route-mem minimum 8 maximum 8
network-uplink type 5
interface GigabitEthernet1
interface GigabitEthernet2
interface GigabitEthernet3
interface GigabitEthernet4
interface GigabitEthernet5
interface GigabitEthernet6
svs-domain
control uplink GigabitEthernet1
management uplink GigabitEthernet1
 
interface mgmt0
ip address 45.45.45.3/24
 
interface control0
line console
svs-domain
domain id 121
control vlan 1481
management vlan 1490
svs mode L2
switch#


 

セカンダリ Cisco Nexus Cloud Services Platform の設定

冗長ペアのセカンダリ Cisco Nexus Cloud Services Platform に対して管理ソフトウェアを設定できます。

プライマリおよびセカンダリの両方の Cisco Nexus Cloud Services Platform で、ドメイン ID、アップリンク タイプ、制御 VLAN、管理 VLAN、制御アップリンク、管理アップリンクを同じものに設定することをお勧めします。

手順の詳細


ステップ 1 管理者パスワードを入力して確認します。

例:

---- System Admin Account Setup ----
Enter the password for "admin":

ステップ 2 HA ロールを入力します。

Example:

Enter HA role[primary/secondary]: secondary

 

ステップ 3 アップリンク タイプを入力します。


) アップリンク タイプを設定後に、アップリンク タイプを変更するにはソフトウェアをリロードする必要があります。


Example:
Enter network-uplink type <1-5>:
1. Ports 1-2 carry all management, control and data vlans
2. Ports 1-2 management and control, ports 3-6 data
3. Ports 1-2 management, ports 3-6 control and data
4. Ports 1-2 management, ports 3-4 control, ports 5-6 data
5. Flexible
5

 

ステップ 4 制御 VLAN の VLAN ID を入力します。

例:

Enter control vlan <1-3967, 4048-4093>: 347
 

ステップ 5 制御アップリンク タイプを入力します。

例:

Enter control uplink <1-6>: 1
 

ステップ 6 ドメイン ID を入力します。

例:

Enter the domain id<1-4095>: 3477
 

ステップ 7 管理 VLAN の VLAN ID を入力します。

例:

Enter management vlan<1-3967,4048-4093>: 180
 

ステップ 8 管理アップリンク タイプを入力します。

例:

Enter management uplink <1-6>: 2
 

スイッチでは次のことが起こります。

新しい設定が不揮発性ストレージに保存された後、実行コンフィギュレーションとスタートアップ コンフィギュレーションが同一になります。

ネットワーク アップリンクを設定するためにシステムがリブートします。

システムが再起動し、プライマリ Cisco Nexus 1000V と設定を同期します。

Example:
Saving boot configuration. Please wait...
 
[########################################] 100%
 
System is going to reboot to configure network uplinks
HA mode set to secondary. Rebooting now...
 

ステップ 9 設定を確認するには、次のコマンドを実行します。

show running configuration

ネットワーク アップリンクの設定例

この例では、インストール時にフレキシブル ネットワーク アップリンクを設定する方法を示します。

---- System Admin Account Setup ----
Enter the password for "admin":
Confirm the password for "admin":
Enter HA role[primary/secondary]: secondary
_
Enter network-uplink type <1-5>:
1. Ports 1-2 carry all management, control and data vlans
2. Ports 1-2 management and control, ports 3-6 data
3. Ports 1-2 management, ports 3-6 control and data
4. Ports 1-2 management, ports 3-4 control, ports 5-6 data
5. Flexible
5
_
Enter control vlan <1-3967, 4048-4093>: 347
Enter control uplink <1-6>: 1
_
Enter the domain id<1-4095>: 3477
_
Enter management vlan <1-3967, 4048-4093>: 180
Enter management uplink <1-6>: 2
_
Saving boot configuration. Please wait...
[########################################] 100%
System is going to reboot to configure network uplinks

 

この例では、インストール時にスタティック ネットワーク アップリンクを設定する方法を示します。

---- System Admin Account Setup ----
Enter the password for "admin":
Confirm the password for "admin":
Enter HA role[primary/secondary]: secondary
_
Enter network-uplink type <1-5>:
1. Ports 1-2 carry all management, control and data vlans
2. Ports 1-2 management and control, ports 3-6 data
3. Ports 1-2 management, ports 3-6 control and data
4. Ports 1-2 management, ports 3-4 control, ports 5-6 data
5. Flexible
1
_
Enter control vlan <1-3967, 4048-4093>: 300
_
Enter the domain id<1-4095>: 300
_
Enter management vlan <1-3967, 4048-4093>: 233
_
Saving boot configuration. Please wait...
[########################################] 100%
System is going to reboot to configure network uplinks

 

Cisco Nexus Cloud Services Platform 設定の確認

Cisco Nexus Cloud Services Platform 設定を確認するには、次のコマンドを使用します。

 

コマンド
目的

show running-configuration

Cisco Nexus Cloud Services Platform の実行コンフィギュレーションを表示します。

例 2-1(P.2-19) を参照してください。

show system redundancy status

Cisco Nexus Cloud Services Platform の冗長ステート(アクティブまたはスタンバイ)と冗長ロール(プライマリまたはセカンダリ)を表示します。

例 2-2(P.2-21) を参照してください。

show svs domain

Cisco Nexus Cloud Services Platform のドメイン情報を表示します。

例 2-3(P.2-22) を参照してください。

show network cdp neighbors

アクティブまたはスタンバイ Cisco Nexus Cloud Services Platform のアップリンク接続を表示します。

例 2-4(P.2-22) を参照してください。

例 2-1 設定

次に、Cisco Nexus Cloud Services Platform 設定を表示および確認する例を示します。

switch# show running-configuration
!Command: show running-config
!Time: Mon Sep 10 21:31:34 2012
 
version 4.2(1)SP1(5.1)
feature telnet
 
username admin password 5 $1$8oEF.umL$mRRZTm3.sWL2ED5KZydz61 role network-admin
 
banner motd #Cisco VSA#
 
ip domain-lookup
ip domain-lookup
hostname N1110-S
snmp-server user admin network-admin auth md5 0xb64ad6879970f0e57600c443287a79f0 priv 0xb64ad6879970f0e57600c443287a79f0 localizedkey
snmp-server community public group network-admin
 
vrf context management
ip route 0.0.0.0/0 10.78.109.97
vlan 1,1352,1360
port-channel load-balance ethernet source-mac
port-profile default max-ports 32
 
vdc N1110-S id 1
limit-resource vlan minimum 16 maximum 2049
limit-resource monitor-session minimum 0 maximum 2
limit-resource vrf minimum 16 maximum 8192
limit-resource port-channel minimum 0 maximum 768
limit-resource u4route-mem minimum 32 maximum 32
limit-resource u6route-mem minimum 16 maximum 16
limit-resource m4route-mem minimum 58 maximum 58
limit-resource m6route-mem minimum 8 maximum 8
network-uplink type 4
interface GigabitEthernet1
interface GigabitEthernet2
interface GigabitEthernet3
interface GigabitEthernet4
interface GigabitEthernet5
interface GigabitEthernet6
interface PortChannel1
interface PortChannel2
interface PortChannel3
virtual-service-blade VSM1
virtual-service-blade-type name VSM-1.1
interface control vlan 1361
interface packet vlan 1362
ramsize 2048
disksize 3
numcpu 1
cookie 1555871292
no shutdown
interface VsbEthernet1/1
interface VsbEthernet1/2
interface VsbEthernet1/3
virtual-service-blade NAMC-1
virtual-service-blade-type name NAM-1.1
interface data vlan 1352
ramsize 2048
disksize 53
numcpu 2
cookie 753232953
no shutdown secondary
interface VsbEthernet2/1
virtual-service-blade DCNM61
virtual-service-blade-type name DCNM-VSB-6.1
interface eth1 vlan 0
ramsize 8192
disksize 80
numcpu 2
cookie 969732378
no shutdown primary
interface VsbEthernet3/1
virtual-service-blade VSG12
virtual-service-blade-type name VSG-1.2
interface data vlan 1365
interface ha vlan 1364
ramsize 2048
disksize 3
numcpu 1
cookie 2051820775
no shutdown primary
no shutdown secondary
interface VsbEthernet4/1
interface VsbEthernet4/2
interface VsbEthernet4/3
virtual-service-blade VSM-OVA
virtual-service-blade-type name VSM-1.2
interface control vlan 1364
interface packet vlan 1366
ramsize 2048
disksize 3
numcpu 1
cookie 448734513
no shutdown primary
no shutdown secondary
interface VsbEthernet5/1
interface VsbEthernet5/2
interface VsbEthernet5/3
virtual-service-blade VSG-OVA
virtual-service-blade-type name VSG-1.2
interface data vlan 1356
interface ha vlan 1355
ramsize 2048
disksize 3
numcpu 1
cookie 2105102293
no shutdown
interface VsbEthernet6/1
interface VsbEthernet6/2
interface VsbEthernet6/3
 
 
interface mgmt0
ip address 10.78.109.100/28
 
interface control0
line console
boot kickstart bootflash:/nexus-1010-kickstart-mz.4.2.1.SP1.5.1.bin
boot system bootflash:/nexus-1010-mz.4.2.1.SP1.5.1.bin
boot kickstart bootflash:/nexus-1010-kickstart-mz.4.2.1.SP1.5.1.bin
boot system bootflash:/nexus-1010-mz.4.2.1.SP1.5.1.bin
svs-domain
domain id 2222
control vlan 1360
management vlan 1352
svs mode L2
 

例 2-2 冗長ステート

switch# show system redundancy status
Redundancy role
---------------
administrative: primary
operational: primary
Redundancy mode
---------------
administrative: HA
operational: None
This supervisor (sup-1)
-----------------------
Redundancy state: Active
Supervisor state: Active
Internal state: Active with no standby
Other supervisor (sup-2)
------------------------
Redundancy state: Not present
---- ----
switch#
 

例 2-3 ドメイン

switch# show svs domain
SVS domain config:
Domain id: 3555
Control vlan: 305
Management vlan: 233
L2/L3 Control mode: L2
L3 control interface: NA
Status: Config not pushed to VC.
switch#

例 2-4 CDP ネイバー(スタンバイ)

switch# show network cdp neighbors
....
Device-ID Local Intrfce Hldtme Capability Platform Port ID
 
sfish-cat3k-K5-stack2 eth2 166 R T B S I r cisco WS-C375 GigabitEthernet1/0/23
switch#
 

Cisco Nexus Cloud Services Platform の準備

ソフトウェアのインストールが完了すると、Cisco Nexus Cloud Services Platform 製品ファミリを設定することができます。


ステップ 1 フレキシブル ネットワーク アップリンク用ポート チャネルを設定します。フレキシブル ネットワーク アップリンク タイプの設定後、ポート チャネルを設定するにはこの手順を使用します。

ステップ 2 リモート管理を設定します。到達不能 Cisco Nexus Cloud Services Platform のリカバリで使用するスタートアップ コンフィギュレーションにリモート管理を設定するにはこの手順を使用します。

ステップ 3 新規 Cisco Nexus Cloud Services Platform にサービス ブレードを追加するには、以下のいずれかを実行します。

仮想サービス ブレードを新たに作成する。

既存の VSM を VM から Cisco Nexus Cloud Services Platform に移行する。


 

詳細については、『 Cisco Nexus Cloud Services Platform Software Configuration Guide 』を参照してください。

ソフトウェア インストールの機能の履歴

ここでは、ソフトウェア インストールおよびアップグレードのリリース履歴について説明します。

 

機能名
リリース
機能情報

Cisco Nexus 1110-SおよびCisco Nexus 1110-X

4.2(1)SP1(5.1a)

このハードウェアが導入されました。

フレキシブル ネットワーク アップリンク

4.2(1)SP1(4)

この機能が導入されました。

Cisco Nexus 1010-X

4.2(1)SP1(3)

このハードウェアが導入されました。

ソフトウェア アップグレード

4.2(1)SP1(2)

この機能が導入されました。