Cisco Nexus 1000V VXLAN コンフィギュレーション ガイド リリース 4.2(1)SV2(2.1)
VXLAN ゲートウェイのインストールおよび設定
VXLAN ゲートウェイのインストールおよび設定

VXLAN ゲートウェイのインストールおよび設定

この章の内容は、次のとおりです。

VXLAN ゲートウェイの導入について

VXLAN ゲートウェイには次の導入要件があります。

  • VXLAN ゲートウェイは Cisco Cloud Services Platform リリース 4.2(1)SP1(6.1) 以降のリリースでのみ導入されます。
  • クラウド サービス プラットフォームのアプライアンスを、Link Aggregation Control Protocol(LACP)に基づいたまたは静的に設定されたポート チャネルおよび VLAN ベースのトランク インターフェイスをサポートするスイッチに接続する必要があります。
  • 仮想スーパーバイザ モジュール(VSM)を確実にインストール、または Cisco Nexus 1000V ソフトウェアの現在のバージョンにアップグレードしてください。 VSM の以前のバージョンからアップグレードする場合、show system vem feature level コマンドを使用して Cisco Nexus 1000V ソフトウェアの現在のバージョンがあるかどうかを確認します。
  • VSM をセット アップするには、拡張モード ライセンスがなければなりません。
  • vCPU またはメモリ要件:各 VXLAN ゲートウェイの仮想サービス ブレード(VSB)につき、3 つの vCPU、2 GB RAM、および 3 GB の仮想ディスク領域が必要です。

次の図は、VXLAN ゲートウェイの導入を示しています。

図 1. VXLAN ゲートウェイの導入



注意事項と制約事項

VXLAN ゲートウェイの設定に関する注意事項と制約事項は次のとおりです。

  • レイヤ 3 コントロールを使用するよう VSM を設定する必要があります。 VSM レイヤ 3 コントロールは mgmt 0 を介していることを強く推奨します。 レイヤ 3 コントロールの詳細については、『Cisco Nexus 1000V Installation and Upgrade Guide』および『Cisco Nexus 1000V System Management Configuration Guide』を参照してください。
  • LACP またはスタティック ポート チャネルとしてゲートウェイ モジュールのアップリンクを設定する必要があります。 VXLAN のゲートウェイは、ゲートウェイが MAC-pinning モードに設定されている場合は動作しません。
  • 単一 VSM は最大 4 つの VXLAN ゲートウェイのハイ アベイラビリティ(HA)クラスタを管理できます。
  • 柔軟なアップリンク タイプ(タイプ 5)を持つ基本的なクラウド サービス プラットフォームを設定する必要があります。 VXLAN ゲートウェイでは、2 つの物理インターフェイスを使用します。 インターフェイスをパススルー モードに設定する必要があります。 さらに、少なくとも 1 つの物理またはポート チャネル インターフェイスを管理トラフィックを伝送するように設定する必要があります。
  • VXLAN-VLAN マッピングに使用される VLAN に PVLAN を設定していないことを確認してください。

次の図には、単一 VSM で管理する許可 VXLAN ゲートウェイ導入の最大数を示しています。 図では、4 台のクラウド サービス プラットフォーム デバイスがあり、各クラウド サービス プラットフォーム デバイスが 2 つの VXLAN ゲートウェイ モジュールのホストになっています。 ゲートウェイ モジュールの 4 台の HA クラスタは、アクティブ/スタンバイ モジュールのペアで構成されるクラスタごとに設定されます。

図 2. VXLAN ゲートウェイの HA ペア



VSM の設定

クラウド サービス プラットフォームで VXLAN ゲートウェイ モジュールをインストールする前に、VSM に 2 つのポート プロファイル(1 つはゲートウェイのアップリンク用、もう 1 つは VTEP インターフェイス用)を作成する必要があります。


(注)  


複数のデバイスにまたがる VXLAN ゲートウェイを設定できます。 この章では、次のプロンプトを使用して異なるデバイスで実行できるコマンドを説明します。
  • VSM:仮想スーパーバイザ モジュール
  • CSP:クラウド サービス プラットフォーム
  • GW:VXLAN ゲートウェイ VSB

VXLAN ゲートウェイ サービス モジュールのアップリンクに適用できる適切なポート プロファイルを作成するには、次の手順を実行します。

はじめる前に
  • 拡張モードを有効にする svs switch edition advanced コンフィギュレーション コマンドを入力して VSM が拡張モードに設定されていることを確認します。
  • VSM で feature lacp コンフィギュレーション コマンドを入力して LACP が設定されることを確認します。
  • VSM で lacp offload コンフィギュレーション コマンドを入力して LACP 処理をオフロードします。
  • VSM で VXLAN をイネーブルにする feature segmentation コンフィギュレーション コマンドを入力して、VSM で VXLAN 機能がイネーブルになっていることを確認します。
  • feature vxlan-gateway コンフィギュレーション コマンドを入力して、VSM で VXLAN ゲートウェイがイネーブルになっていることを確認します。
  • アップストリーム スイッチのインターフェイスがマッチング ポート チャネルおよび VLAN トランク コンフィギュレーションを使って設定されていることを確認します。
手順
     コマンドまたはアクション目的
    ステップ 1vsm# configure terminal  

    グローバル コンフィギュレーション モードを開始します。

     
    ステップ 2 vsm(config)# port profile type ethernet <name> 

    VXLAN ゲートウェイのアップリンク用イーサネットのタイプのポート プロファイルを作成します。

    (注)     

    Setup Script to Configure the VXLAN Gateway」に基づいて記述されたセットアップ スクリプトの実行中にプロンプトが表示されたとき、ポート プロファイル名を入力する必要があります。

     
    ステップ 3vsm(config-port-prof)# switchport mode trunk 

    インターフェイスがトランキング ポートとして使用されることを指定します。 トランク ポートは、ネイティブ VLAN に対しては非タグ付きパケットを伝送し、他のすべての VLAN に対してはカプセル化されたタグ付きパケットを伝送します。

     
    ステップ 4 vsm(config-port-prof)# switchport trunk allowed vlan <vlan list> 

    ゲートウェイ アップリンク上で許可される VLAN のリストを指定します。 このリストはマッピングされた VLAN すべておよび VTEP 仮想インターフェイスに対する VLAN で構成される必要があります。

     
    ステップ 5vsm(config-port-prof)# mtu <mtu size in bytes> 

    MTU サイズを指定します。 VXLAN トラフィックが機能するには MTU サイズを 1550 に設定する必要があります。 MTU サイズを設定しない場合は、デフォルトの 1500 が使用されます。 サイズは 1500 ~ 9000 の範囲の偶数である必要があります。 インターフェイスで設定された MTU はポート プロファイルで設定された MTU よりも優先されます。

     
    ステップ 6vsm(config-port-prof)# service instance <1-4096>  (任意)

    マッピングのプレース ホルダを定義します。 指定できる範囲は 1 ~ 4096 です。

    (注)     

    この段階ではゲートウェイを起動するためにサービス インスタンスおよびカプセル化コマンドを実行する必要はありません。 これらは任意に選択でき、ポート プロファイルが設定されればマッピングを後から追加できます。

     
    ステップ 7vsm(config-port-prof-srv)# encapsulation dot1q <vlan id> bridge-domain <bd-name>  (任意)

    VLAN を VXLAN にマッピングします。 VXLAN は、ブリッジ ドメイン名で指定されます。

    指定したブリッジ ドメイン名と VLAN-ID はポート プロファイル設定時には作成されません。 指定したブリッジ ドメイン名と VLAN ID はアクティブ ステートになる必要があり、そうでなければ、ブリッジ ドメイン名と VLAN ID を作成するまでマッピングは保留状態のままです。

     
    ステップ 8vsm(config-port-prof-srv)# exit
     
    (任意)

    サービス インスタンス モードを終了します。

     
    ステップ 9vsm(config-port-prof)# channel-group auto mode active 

    ポート チャネル モードを LACP として設定します。

     
    ステップ 10vsm(config-port-prof)# no shutdown 

    管理上の目的でプロファイル内のすべてのポートをイネーブルにします。

     
    ステップ 11vsm(config-port-prof)# state enabled 

    ポート プロファイルをイネーブルにし、割り当てられたポートに設定を適用します。

     

    次に、ゲートウェイ マッピングを設定し表示する例を示します。

    vsm(config)# port-profile type ethernet gw-uplink
    vsm(config)# switchport mode trunk
    vsm(config)# switchport trunk allowed vlan 1545
    vsm(config)# mtu 1550
    vsm(config-port-prof)# service instance 1
    vsm(config-port-prof-srv)# encapsulation dot1q 753 bridge-domain bd-753
    vsm(config-port-prof-srv)# exit
    vsm(config-port-prof)# channel-group auto mode active
    vsm(config-port-prof)# no shutdown
    vsm(config-port-prof)# state enabled
    
    

    VXLAN ゲートウェイ上の VXLAN 終端/VTEP の設定

    VTEP の仮想インターフェイスに適用できる適切なポート プロファイルを作成するには、次の手順を実行します。

    手順
       コマンドまたはアクション目的
      ステップ 1vsm# configure terminal  

      グローバル コンフィギュレーション モードを開始します。

       
      ステップ 2 vsm(config) # port-profile type vethernet <port-profile name>  

      VXLAN ゲートウェイの VTEP のポート プロファイルを設定します。

      (注)     

      Setup Script to Configure the VXLAN Gateway」に基づいて記述されたセットアップ スクリプトの実行中にプロンプトが表示されたとき、ポート プロファイル名を入力する必要があります。

       
      ステップ 3vsm(config-port-prof) # switchport mode access 

      インターフェイスがトランキング ポートとして使用されるものであることを指定します。 トランク ポートは、ネイティブ VLAN に対しては非タグ付きパケットを伝送し、他のすべての VLAN に対してはカプセル化されたタグ付きパケットを伝送します。

       
      ステップ 4vsm(config-port-prof) # switchport access vlan <vlan-id-access> 

      このポート プロファイルにアクセス VLAN ID を割り当てます。 指定された VLAN ID はアップリンク ポート プロファイルの許可 VLAN セットに追加する必要があります。 この VLAN はどの VXLAN にもマッピングしないでください。

      (注)     

      VLAN ID を指定しない場合、VLAN 1 が自動的に使用されます。

       
      ステップ 5vsm(config-port-prof ) # capability vxlan 

      指定した仮想イーサネット ポート上で対応できる VXLAN 機能を設定し、VXLAN パケットのカプセル化/カプセル開放をイネーブルにします。

       
      ステップ 6 vsm(config-port-prof) # transport ip address <IP address> <network mask> gateway < IP address> 

      VXLAN ゲートウェイに VXLAN 終端または VTEP を設定します。

      VTEP ポート プロファイルの作成は、VXLAN のゲートウェイでサポートされていない vmware port-group コマンドを除き、「VXLAN カプセル化用の vmknics の設定」で説明された手順に似ています。

       
      ステップ 7vsm(config-port-prof)# no shutdown 

      管理上の目的でプロファイル内のすべてのポートをイネーブルにします。

       
      ステップ 8vsm(config-port-prof)# state enabled 

      ポート プロファイルをイネーブルにし、割り当てられたポートに設定を適用します。

       

      次に、VXLAN ゲートウェイ上で VXLAN 終端または VTEP を設定する例を示します。

      vsm# configure terminal
      vsm(config)# port-profile type vethernet gw-vtep
      vsm(config-port-prof)# switchport mode access
      vsm(config-port-prof)# switchport access vlan 760
      vsm(config-port-prof)# capability vxlan
      vsm(config-port-prof)# transport ip address 182.168.1.253 255.255.255.0 gateway 182.168.1.1
      vsm(config-port-prof)# no shutdown
      vsm(config-port-prof)# state enabled 

      仮想サービス ブレードとしての VXLAN ゲートウェイのインストール

      すべてのシスコのクラウド サービス プラットフォームで VSB として VXLAN ゲートウェイをインストールできます。 これを行うには、クラウド サービス プラットフォームにログインし、以下の手順を実行します。

      手順
         コマンドまたはアクション目的
        ステップ 1CSP# copy scp:// <server where the VXGW image is located> < source path > < iso image of vxlan gw > < bootflash:repository >
         

        CCPA Manager のブートフラッシュ/リポジトリに VXLAN ゲートウェイのイメージをコピーします。

         
        ステップ 2CSP# configure terminal  

        グローバル コンフィギュレーション モードを開始します。

         
        ステップ 3CSP(config) # virtual-service-blade <name of the VXLAN GW VSB> 

        VXLAN ゲートウェイ VSB を作成します。

         
        ステップ 4CSP(config-vsb-config) # virtual-service-blade-type new <iso image of the vxlan gw> 

        ダウンロード済みの VXLAN ゲートウェイを導入します。 イメージは常にブートフラッシュまたはリポジトリから読み込まれ、パスを指定する必要はありません。

         
        ステップ 5CSP(config-vsb-config) # interface gw-uplink1 uplink <ANPhysical-Interface Cloud Services Platform> 

        ゲートウェイ アップリンクにクラウド サービス プラットフォームの物理インターフェイスを割り当てます。 GigabitEthernet3 から GigabitEthernet6 はフレキシブル モードの物理インターフェイスで使用できます。 アップストリーム スイッチの LACP を使用してポート チャネルを設定する必要があります。

         
        ステップ 6CSP(config-vsb-config) # interface gw-uplink1 mode passthrough 

        パススルーとしてゲートウェイ アップリンクを設定します。 対応するギガビット イーサネットのインターフェイスはクラウド サービス プラットフォームの他の VSB と共有することはできません。

         
        ステップ 7CSP(config-vsb-config) # interface gw-uplink2 uplink <ANPhysical-Interface Cloud Services Platform> 

        ゲートウェイ アップリンクにクラウド サービス プラットフォームの物理インターフェイスを割り当てます。 GigabitEthernet3 から GigabitEthernet6 はフレキシブル モードの物理インターフェイスで使用できます。 アップストリーム スイッチの LACP を使用してポート チャネルを設定する必要があります。

         
        ステップ 8CSP(config-vsb-config) # interface gw-uplink2 mode passthrough 

        パススルーとしてゲートウェイ アップリンクを設定します。 対応するギガビット イーサネットのインターフェイスはクラウド サービス プラットフォームの他の VSB と共有することはできません。

         
        ステップ 9CSP(config-vsb-config) # interface management vlan <vlan id> 

        指定した VLAN ID の使用を管理アップリンク上で許可します。 VLAN の範囲は 1 ~ 4096 です。

         
        ステップ 10CSP(config-vsb-config) # interface management uplink <interface> 

        interface は、クラウド サービス プラットフォームの物理インターフェイスまたは以前にクラウド サービス プラットフォームで作成したポート チャネル インターフェイスのいずれかです。

         
        ステップ 11ゲートウェイを導入するには、次のコマンドの 1 つを使用します。
        • CSP(config-vsb-config) # enable
        • CSP(config-vsb-config) # enable primary
        • CSP(config-vsb-config) # enable secondary
         

        enable コマンドを使用して 2 つの VSB(1 つはプライマリ クラウド サービス プラットフォーム上で、もう 1 つはセカンダリ クラウド サービス プラットフォーム上)をインストールします。

        enable primary コマンドを使用して、プライマリ クラウド サービス プラットフォーム上でスタンドアロン モードでゲートウェイを導入します。

        enable secondary コマンドを使用して、セカンダリ クラウド サービス プラットフォーム上でスタンドアロン モードでゲートウェイを導入します。

        セットアップ スクリプトを開始して、VXLAN ゲートウェイ、IP アドレス、サブネット マスク、ゲートウェイ、ホスト名、および VXLAN ゲートウェイ VSB のパスワードを設定します。 さらに、コントロール インターフェイスで VSM のドメイン ID、IP アドレス、プライマリおよびセカンダリ MAC アドレスの詳細を指定する必要があります。 詳細については、「Setup Script to Configure the VXLAN Gateway」を参照してください。

         

        次に、VSA ペア上の VSB としてゲートウェイをインストールする例を示します。

        CSP(config)# virtual-service-blade VXLAN-GW
        CSP(config-vsb-config)# virtual-service-blade-type new vxgw.4.2.1.SV2.2.0.264.iso
        CSP(config-vsb-config)# interface gw-uplink1 uplink GigabitEthernet3
        CSP(config-vsb-config)# interface gw-uplink2 uplink GigabitEthernet4
        CSP(config-vsb-config)# interface gw-uplink1  mode passthrough 
        CSP(config-vsb-config)# interface gw-uplink2  mode passthrough 
        CSP(config-vsb-config)# interface management uplink GigabitEthernet1
        CSP(config-vsb-config)# interface management vlan 751
        CSP(config-vsb-config)# enable
        
        

        VXLAN ゲートウェイを設定するセットアップ スクリプト

        VXLAN を VSB としてインストールしている際にイネーブルを入力後に、VXLAN ゲートウェイを設定するセットアップ スクリプトが実行されます。 ここでは、VXLAN ゲートウェイ上の次のパラメータを設定するセットアップ スクリプトについて説明します。

        • プライマリおよびセカンダリの VXLAN ゲートウェイ管理インターフェイス両方の IP アドレス、ネットワーク マスク、およびデフォルト ゲートウェイ
        • VSM 詳細:VSM コントロール インターフェイスのドメイン ID、IP アドレス、プライマリ MAC アドレス、およびセカンダリ MAC アドレス
        • VXLAN ゲートウェイのアップリンクおよび VTEP に使用されるポート プロファイル
        手順
          ステップ 1   コマンド プロンプトで、VSB イメージを入力し、Enter キーを押します。

          Enter VSB image:x.x.x.x.x.x.x.iso: [vxgw.4.2.1.SV2.1.0.246.iso] 

          ステップ 2   VSM ドメイン ID を入力します 指定できる範囲は 1 ~ 4095 です。
          Enter domain [1-4095]:405
          (注)     

          VSM で show svs domain コマンドを入力して、ドメイン ID を取得できます。

          ステップ 3   管理 IP バージョンを入力します。
          Management IP version [V4]:v4
          ステップ 4   プライマリ クラウド サービス プラットフォームに導入されている VXLAN ゲートウェイ上のインターフェイス mgmt 0 に管理 IP アドレスを設定します。
          Enter management IP address of service module on primary: 192.168.1.104
          (注)     

          セカンダリ クラウド サービス プラットフォーム上でゲートウェイをスタンドアロン モードで導入している場合は、プライマリの IP アドレス、ネットワーク マスク、およびデフォルト ゲートウェイ アドレスを 0.0.0.0 として入力します。

          ステップ 5   管理サブネット マスクを入力します。
          Enter management subnet mask of service module on primary: 255.255.255.0
          ステップ 6   管理デフォルト ゲートウェイを入力します。
          Enter default gateway IP address of service module on primary: 192.168.1.1
          ステップ 7   セカンダリ クラウド サービス プラットフォームに導入されている VXLAN ゲートウェイ上のインターフェイス mgmt 0 に管理 IP アドレスを設定します。
          Enter management IP address of service module on secondary: 192.168.1.105
          (注)     

          プライマリ クラウド サービス プラットフォーム上でゲートウェイをスタンドアロン モードで導入している場合は、セカンダリの IP アドレス、ネットワーク マスク、およびデフォルト ゲートウェイ アドレスを 0.0.0.0 として入力します。

          (注)     

          HA 導入では、指定する IP アドレスは手順 5 で指定したものと同じサブネット内の IP アドレスを指定することを推奨します。

          ステップ 8   管理サブネット マスクを入力します。
          Enter management subnet mask of service module on secondary: 255.255.255.0
          ステップ 9   管理インターフェイス デフォルト ゲートウェイを入力します。
          Enter default gateway IP address of service module on secondary: 192.168.1.1
          ステップ 10   VXLAN ゲートウェイのホスト名を入力します。
          Enter hostname: VXLAN-GW-DOCS
          ステップ 11   ログイン クレデンシャルを入力します。
          Enter the password for admin:Sfish123
          ステップ 12   VSM の IP アドレスを入力します。
          VSM L3 Ctrl IPv4 address:192.168.1.210
          
          ステップ 13   プライマリ VSM 上のコントロール インターフェイスの MAC アドレスを設定します。
          VSM Primary MAC address: 0050.56b5.07d0
          (注)     

          プライマリ VSM で show interface control 0 コマンドを使用して、MAC アドレスを取得できます。

          ステップ 14   セカンダリ VSM の MAC アドレスを入力します。
          VSM Standby MAC address: 0050.56b5.07d3
          (注)     

          セカンダリ VSM で show vms internal info コマンドを入力して、MAC アドレスを取得できます。

          ステップ 15   VSM に設定されているアップリンク トランク ポート プロファイルを入力します。
          Enter VSM uplink port-profile name: gw-uplink 
          (注)     

          VSM 上で作成された VXLAN ゲートウェイ ペア用の専用アップリンク トランク ポート プロファイルを入力します。

          ステップ 16   VTEP プロファイル名を入力します。
          Enter VTEP port-profile name: gw-vtep 
          (注)     

          VSM 上で作成したものと同じ VTEP ポート プロファイル名を入力します。


          次に、VXLAN ゲートウェイを設定する例を示します。

          CSP(config-vsb-config)# enable 
          Enter vsb image: [vxgw.4.2.1.SV2.2.0.264.iso] 
          Enter the VSM domain id[1-4095]: 405
          Enter Management IP version [V4]: [V4] 
          Enter Management IP address of service module on primary: 192.168.1.104
          Enter Management subnet mask of service module on primary: 255.255.255.0
          Enter default gateway IP address of service module on primary: 192.168.1.1
          Enter management IP address of service module on secondary: 192.168.1.105
          Enter management subnet mask of service module on secondary: 255.255.255.0
          Enter default gateway IP address of service module on secondary: 192.168.1.1
          Enter HostName: VXLAN-GW-DOCS
          Enter the password for 'admin': Sfish123
          VSM L3 Ctrl IPv4 address : 192.168.1.210
          VSM Primary MAC Address: 0050.56b5.07d0
          VSM Standby MAC Address: 0050.56b5.07d3
          Enter VSM uplink port-profile name: gw-uplink
          Enter VTEP port-profile name: gw-vtep
          Note: VSB installation is in progress, please use show virtual-service-blade commands to check the installation status.
          CSP(config-vsb-config)# 

          セットアップ スクリプトの初期パラメータの変更

          最初にセットアップ スクリプトを実行した後でセットアップ パラメータを変更する必要がある場合は、VSM で次のコマンドを使用します。


          (注)  


          HA ペアがインストールされている場合は、確実に両方のゲートウェイ モジュールで同じ変更を個別に適用するようにしてください。



          (注)  


          更新するポート プロファイルが最初に VSM に保存されていることを確認します。


          手順
             コマンドまたはアクション目的
            ステップ 1vsm(config)# service <module> update port-profile type ethernet name <VXLAN Gateway Uplink port-profile name> 

            VSM からの VXLAN ゲートウェイ アップリンク ポート プロファイルを変更します。

             
            ステップ 2vsm(config)# service <module> update port-profile type vethernet name <VXLAN Gateway VTEP port-profile name> 

            VSM からの VXLAN ゲートウェイ VTEP ポート プロファイルを変更します。

             

            ハイ アベイラビリティの設定

            ハイ アベイラビリティ(HA)の操作では、次の用語を使用します。

            • クラスタ:クラスタは単一の高可用性のモジュールとして連携して動作するゲートウェイ モジュールのペアです。 各クラスタは、一意のクラスタ ID によって識別されます。 スタンドアロン動作モードで導入されるゲートウェイ モジュールにはダミー クラスタ ID の 0 が割り当てられます。
            • HA ロール:HA クラスタを構成するゲートウェイ モジュールには個別にロールが割り当てられます。 一方がプライマリに指定され、もう一方がセカンダリに指定されます。 このロールによって、2 つのモジュールのどちらが最初にアクティブ ステートになり、どちらがスタンバイ ステートに留まるかが決定します。 これらのステートはアクティブ側に障害が発生するまで継続します。 アクティブ ゲートウェイ モジュールに何らかの障害が発生した場合に、スタンバイ ゲートウェイが障害を検出しアクティブ ステートに移行します。 この方法によって、2 つのモジュールのうちの 1 つがアクティブなサービスを常に提供します。
            • HA ステート:どのような時でも、任意のクラスタの 1 つのゲートウェイ モジュールだけがゲートウェイ機能を実行しています。 もう 1 つのゲートウェイ モジュールはアクティブ モジュールの障害が発生するまでスタンバイ ステートを維持します。 1 つのゲートウェイ モジュールはアクティブまたはスタンバイのステートになることが可能です。 さらに、Init ステートと呼ばれる一時的な初期ステートがあります。 このステートでは、ゲートウェイがロールが割り当てられるのを待っているか、ピアとステートをネゴシエートしているかのどちらかです。

            ゲートウェイ モジュールをインストールして設定した後、VSM がゲートウェイ モジュールにロールを割り当て、その結果は次の推移のどれかになる可能性があります。

            • Unconfigured Init から Standalone-Active へ
            • Unconfigured Init から Primary-Active へ
            • Unconfigured Init から Secondary-Standby へ
            • Standalone-Active から Primary-Active へ
            • Standalone-Active から Secondary-Active へ

            他のすべての組み合わせでは、最初に no service VXLAN Gateway module コマンドを使用して Unconfigured-Init モードにフォールバックすることを推奨します。


            (注)  


            ロールは VSM でのモジュール番号に事前に割り当てられている必要があります。 VXLAN ゲートウェイがそのモジュールの VSM に接続されている場合、VSM によって割り当てられたロールとステートを継承します。


            スタンドアロン モードでは、サービス モジュールを作成できます。

            手順
               コマンドまたはアクション目的
              ステップ 1 vsm(config)# service mod role standalone  

              スタンドアロン アクティブとしてサービス モジュールを設定します。

               
              ステップ 2vsm(config)# show module service-module 

              サービス モジュール番号、クラスタ ID、ロール、HA モード、およびステートを表示します。

               

              次に、クラスタ ID マッピングと、アクティブ、スタンバイ、およびスタンドアロンのサービス モジュールについての詳細を表示する例を示します。

              vsm(config)# show module service-module
              Mod  Cluster-id  Role            HA Mode       Status
              ---  ----------  -----------     ----------    -------
              36        0      Standalone      Standalone    Active
              

              次の手順を実行して、ハイ アベイラビリティ(HA)ペアとしてサービス モジュールを作成できます。

              手順
                 コマンドまたはアクション目的
                ステップ 1 vsm(config)# service modNo1 role primary ha-cluster clusterNo 

                HA でサービス モジュールを設定し、クラスタにプライマリ サービス モジュールを追加します。

                 
                ステップ 2 vsm(config)# service modNo2 role secondary ha-cluster clusterNo 

                別のサービス モジュールを同じクラスタ内のセカンダリとして設定します。

                 
                ステップ 3vsm(config)# show module service-module 

                サービス モジュール番号、クラスタ ID、ロール、HA モード、およびステートを表示します。

                 

                次に、クラスタ ID マッピングと、アクティブ、スタンバイ、およびスタンドアロンのサービス モジュールについての詳細を表示する例を示します。

                vsm(config)# show module service-module
                Mod  Cluster-id  Role        HA Mode    Status
                --- ---------- ----------- ---------- -------
                9    1        Primary          HA       Active
                10   1        Secondary        HA       Standby
                

                アクティブとスタンバイの VXLAN ゲートウェイ間で切替えを行うには、VSM から次のコマンドを入力します。

                vsm# service ha-cluster <1-8> switchover

                VXLAN ゲートウェイのインストールおよび設定の確認

                VXLAN ゲートウェイ(GW)のインストールおよび設定情報を表示するには、VSM で次のいずれかの作業を行います。

                コマンド 目的

                show running-config port-profile gw-uplink

                VXLAN ゲートウェイ アップリンクに割り当てられるポート プロファイルの設定を表示します。

                show running-config port-profile gw-vtep

                VXLAN VTEP に割り当てられるポート プロファイルの設定を表示します。

                show module

                VXLAN ゲートウェイ サービス モジュールを表示します。

                show module service-module

                VXLAN ゲートウェイ モジュールのロールを確認し、クラスタ ID マッピングとアクティブ、スタンバイ、およびスタンドアロンのサービス モジュールに関すると詳細を表示します。

                show vxlan gateway interface

                VTEP が適切に設定されているかどうかが表示されます。

                show interface vethernet 6

                VTEP の仮想イーサネット インターフェイスの両方がアップ状態にあるかどうかが表示されます。

                show port-channel summary

                ポート チャネルがゲートウェイ サービス モジュールに対してアップ状態かどうかが表示されます。

                show bridge-domain mappings

                サービス モジュール/VXLAN ゲートウェイのイーサネット アップリンク ポート プロファイル上または VXLAN トランク機能の vEthernet アクセス ポート プロファイル上の VSM に設定されている VLAN-VXLAN マッピングを表示します。

                show switch edition

                VSM が拡張モードであるかどうかが表示されます。

                show feature

                VXLAN ゲートウェイが VSM 上でイネーブルかどうかが表示されます。

                show virtual-service-blade summary
                (注)     

                このコマンドは、クラウド サービス プラットフォームから実行する必要があります。

                VXLAN ゲートウェイ VSB の状態が VSB DEPLOY IN PROGRESS から VSB POWERED ON に推移する状態を表示します。

                show virtual-service-blade

                (注)     

                このコマンドは、クラウド サービス プラットフォームから実行する必要があります。

                VXLAN ゲートウェイのコンフィギュレーションを表示します。

                この例は、VXLAN ゲートウェイ VSB の状態を表示します。

                CSP# show virtual-service-blade summary
                
                -------------------------------------------------------------------------------
                Name                HA-Role     HA-Status   Status                   Location
                -------------------------------------------------------------------------------
                VXLAN-GW            PRIMARY     ACTIVE      VSB POWERED ON           PRIMARY
                VXLAN-GW            SECONDARY   ACTIVE      VSB POWERED ON           SECONDARY
                 
                

                この例は、VXLAN ゲートウェイのコンフィギュレーションを表示します。

                CSP# show virtual-service-blade
                virtual-service-blade VXLAN-GW
                  Description:  
                  Slot id:        1
                  Host Name:      VXLAN-GW-DOCS
                  Management IP:  192.168.1.104
                  VSB Type Name :  vx-gw-1.5
                  Configured vCPU:           3
                  Operational vCPU:           3
                  Configured Ramsize:        2048
                  Operational Ramsize:        2048
                  Disksize:       3
                  Heartbeat:      154764
                
                  Legends:   P -  Passthrough
                  --------------------------------------------------------------------------
                   Interface           Type         MAC     VLAN    State   Uplink-Int
                                                                  Pri  Sec Oper  Adm
                  --------------------------------------------------------------------------
                  VsbEthernet1/1  gw-uplink1 0002.3d71.a303        up   up Gi3(P) Gi3(P)
                  VsbEthernet1/2  management 0002.3d71.a302  751   up   up Gi1    Gi1   
                  VsbEthernet1/3  gw-uplink2 0002.3d71.a304        up   up Gi4(P) Gi4(P)
                        internal          NA        NA       NA    up   up              
                  HA Role: Primary  
                    HA Status: ACTIVE
                    Status:       VSB POWERED ON
                    Location:     PRIMARY
                    SW version:   
                  HA Role: Secondary  
                    HA Status: ACTIVE
                    Status:       VSB POWERED ON
                    Location:     SECONDARY
                    SW version:   
                  VSB Info:  
                    Domain ID : 405
                
                

                この例は、VXLAN ゲートウェイ アップリンクに割り当てられるポート プロファイル コンフィギュレーションを表示します。

                vsm# show running-config port-profile gw-uplink
                
                port-profile type ethernet gw-uplink
                  switchport mode trunk
                  switchport trunk allowed vlan 1,81,751-760
                  mtu 1550
                  channel-group auto mode active
                  no shutdown
                  state enabled
                
                

                この例は、VXLAN VTEP に割り当てられるポート プロファイル コンフィギュレーションを表示します。

                vsm# show running-config port-profile gw-vtep
                
                port-profile type vethernet gw-vtep
                  switchport mode access
                  switchport access vlan 760
                  capability vxlan
                  transport ip address 182.168.1.253 255.255.255.0 gateway 182.168.1.1
                  no shutdown
                  state enabled
                 
                

                次に、VXLAN ゲートウェイ サービス モジュールがオンラインになると即座に表示するための例を示します。

                vsm# show module
                Mod  Ports  Module-Type                       Model               Status
                ---  -----  --------------------------------  ------------------  ------------
                1    0      Virtual Supervisor Module         Nexus1000V          ha-standby
                2    0      Virtual Supervisor Module         Nexus1000V          active *
                3    332    Virtual Ethernet Module           NA                  ok
                4    332    Virtual Ethernet Module           NA                  ok
                5    332    Virtual Ethernet Module           NA                  ok
                6    332    Virtual Ethernet Module           NA                  ok
                7    332    Virtual Ethernet Module           NA                  ok
                8    332    Virtual Ethernet Module           NA                  ok
                9    4      Virtual Service Module            VXLAN Gateway       ok
                10   4      Virtual Service Module            VXLAN Gateway       ok
                
                Mod  Sw                  Hw      
                ---  ------------------  ------------------------------------------------  
                1    4.2(1)SV2(2.0.284)  0.0                                              
                2    4.2(1)SV2(2.0.284)  0.0                                              
                3    4.2(1)SV2(2.1)      VMware ESXi 5.0.0 Releasebuild-623860 (3.0)      
                4    4.2(1)SV2(2.1)      VMware ESXi 5.0.0 Releasebuild-469512 (3.0)      
                5    4.2(1)SV2(2.1)      VMware ESXi 5.0.0 Releasebuild-469512 (3.0)      
                6    4.2(1)SV2(2.1)      VMware ESXi 5.0.0 Releasebuild-469512 (3.0)      
                7    4.2(1)SV2(2.1)      VMware ESXi 5.0.0 Releasebuild-469512 (3.0)      
                8    4.2(1)SV2(2.1)      VMware ESXi 5.0.0 Releasebuild-469512 (3.0)      
                9    4.2(1)SV2(2.1)      Linux 2.6.27.10                                  
                10   4.2(1)SV2(2.1)      Linux 2.6.27.10                                  
                
                Mod  Server-IP        Server-UUID                           Server-Name
                ---  ---------------  ------------------------------------  --------------------
                1    10.193.81.210    NA                                    NA
                2    10.193.81.210    NA                                    NA
                3    10.193.81.201    3f6ebef1-90f3-11e0-a977-e8b7487bbf50  10.193.81.201
                4    10.193.81.202    56ae0e11-98a8-11e0-b2a9-e8b7487c00e4  10.193.81.202
                5    10.193.81.203    1abbf23b-9c26-11e0-ab53-e8b7487c26be  10.193.81.203
                6    10.193.81.204    64faccd8-9c11-11e0-ba93-e8b7487c24ea  10.193.81.204
                7    10.193.81.205    1abbf245-9c26-11e0-ab53-e8b7487c2712  10.193.81.205
                8    10.193.81.169    0ea13991-e32f-11e0-bd1d-ccef48b424a0  10.193.81.169
                9    192.168.1.104    56fa6753-4dc5-4a7d-ad07-cc817114f838  VXLAN-GW-DOCS
                10   192.168.1.105    4cbd05df-b3e5-468a-9497-89aa3fae8153  VXLAN-GW-DOCS
                
                * this terminal session 
                

                次に、クラスタ ID マッピングと、アクティブ、スタンバイ、およびスタンドアロンのサービス モジュールについての詳細を表示する例を示します。

                vsm# show module service-module
                Mod  Cluster-id  Role        HA Mode    Status
                --- ---------- ----------- ---------- -------
                9    1        Primary          HA       Active
                10   1        Secondary        HA       Standby
                

                次に、仮想イーサネット インターフェイスのバインディングのモジュールの検索方法を示します。

                vsm(config-if)# show vxlan gateway interface
                -----------------------------------------------------------------
                Port 	IPAddress 	Netmask 	Gateway Mod Status Role
                -----------------------------------------------------------------
                Veth6 	192.168.1.253  255.255.255.0	192.168.1.1 9 	up Active
                Veth22 	192.168.1.253  255.255.255.0	192.168.1.1 10  up Standby 
                

                この例は、VTEP 仮想イーサネットの両方がアップ状態にあるかどうかを表示します。

                vsm# show interface vethernet 6
                Vethernet6 is up
                  Port description is VXLANGW VTEP, Network Adapter 1
                  Hardware: Virtual, address: 0002.3d71.a303 (bia 0002.3d71.a303)
                  Owner is VM "VXLANGW VTEP", adapter is Network Adapter 1
                  Active on module 9
                  Port-Profile is gw-vtep
                  Port mode is access
                  5 minute input rate 8 bits/second, 0 packets/second
                  5 minute output rate 0 bits/second, 0 packets/second
                  Rx
                    6 Input Packets 6 Unicast Packets
                    0 Multicast Packets 588 Broadcast Packets
                    468 Bytes
                  Tx
                    34321 Output Packets 34321 Unicast Packets
                    33609 Multicast Packets 24 Broadcast Packets 33633 Flood Packets
                    2193700 Bytes
                    0 Input Packet Drops 0 Output Packet Drops
                
                vsm# show interface vethernet 22
                Vethernet22 is up
                  Port description is VXLANGW VTEP, Network Adapter 1
                  Hardware: Virtual, address: 0002.3d71.a383 (bia 0002.3d71.a383)
                  Owner is VM "VXLANGW VTEP", adapter is Network Adapter 1
                  Active on module 10
                  Port-Profile is gw-vtep
                  Port mode is access
                  5 minute input rate 8 bits/second, 0 packets/second
                  5 minute output rate 0 bits/second, 0 packets/second
                  Rx
                    6 Input Packets 6 Unicast Packets
                    0 Multicast Packets 25 Broadcast Packets
                    468 Bytes
                  Tx
                    33742 Output Packets 33742 Unicast Packets
                    33609 Multicast Packets 133 Broadcast Packets 33742 Flood Packets
                    2158956 Bytes
                    0 Input Packet Drops 0 Output Packet Drops
                
                

                この例は、ポート チャネルがゲートウェイ サービス モジュールに対してアップ状態かどうかを表示します。

                vsm# show port-channel summary 
                Flags:  D - Down        P - Up in port-channel (members)
                        I - Individual  H - Hot-standby (LACP only)
                        s - Suspended   r - Module-removed
                        S - Switched    R - Routed
                        U - Up (port-channel)
                --------------------------------------------------------------------------------
                Group Port-       Type     Protocol  Member Ports
                      Channel
                --------------------------------------------------------------------------------
                1     Po1(SU)     Eth      NONE      Eth3/3(P)    Eth3/4(P)    Eth3/5(P)
                                                     Eth3/6(P)    
                2     Po2(SU)     Eth      NONE      Eth4/3(P)    Eth4/4(P)    Eth4/5(P)
                                                     Eth4/6(P)    
                3     Po3(SU)     Eth      NONE      Eth5/3(P)    Eth5/4(P)    Eth5/5(P)
                                                     Eth5/6(P)    
                4     Po4(SU)     Eth      NONE      Eth6/3(P)    Eth6/4(P)    Eth6/5(P)
                                                     Eth6/6(P)    
                5     Po5(SU)     Eth      NONE      Eth7/3(P)    Eth7/4(P)    Eth7/5(P)
                                                     Eth7/6(P)    
                6     Po6(SU)     Eth      NONE      Eth8/4(P)    
                7     Po7(SU)     Eth      LACP      Eth9/1(P)    Eth9/3(P)    
                8     Po8(SU)     Eth      LACP      Eth10/1(P)   Eth10/3(P)   
                
                

                この例は、VXLAN ゲートウェイのマッピングを表示します。

                vsm# show bridge-domain mappings
                -------------------------------------------------------------------------------
                Interface       Module  Serv Inst  Vlan  BD-Name 
                -------------------------------------------------------------------------------
                port-channel7   9       753        753   bd-753
                port-channel8   10      753        753   bd-753
                
                

                (注)  


                [Interface] 列の値は、VXLAN ゲートウェイまたは VXLAN トランク機能によって異なります。 [Interface] 列の vEhternet<number> は VXLAN トランク機能のマッピングを示します。[Interface] 列の port-channel<number> は VXLAN ゲートウェイで設定されたマッピングを示します。


                次に、バインディングするモジュールの IP アドレスの検索方法を示します。

                vsm(config-if)# show service-module mgmt-int
                	--------------------------------------------------------------------------------
                Mod Interface-Name IP-address Speed MTU
                --------------------------------------------------------------------------------
                4 Mgmt0 10.10.10.2             0     0
                5 Mgmt0 10.10.10.3             0     0
                Remember the management IP address user installs gateway with 
                (in this example 10.10.10.2, which occupies module slot 4)

                この例は、VSM が拡張モードであるかどうかを表示します。

                vsm# show switch edition
                Switch Edition: Advanced
                
                Advanced Features
                Feature Name    Feature State
                -----------------------------
                vxlan-gateway   enabled
                
                Licenses Available: 1020
                Licenses In Use: 4
                License Expiry Date: 13 Jun 2013
                
                
                

                この例は、VXLAN のゲートウェイが VSM 上でイネーブルかどうかを表示します。

                vsm# show feature
                Feature Name          Instance  State
                --------------------  --------  --------
                cts                   1         enabled
                dhcp-snooping         1         enabled
                http-server           1         enabled
                lacp                  1         enabled
                netflow               1         disabled
                network-segmentation  1         enabled
                port-profile-roles    1         disabled
                private-vlan          1         enabled
                segmentation          1         enabled
                sshServer             1         enabled
                tacacs                1         disabled
                telnetServer          1         disabled
                vtracker              1         enabled
                vxlan-gateway         1         enabled

                VXLAN ゲートウェイで次のタスクのいずれかを実行してください。 VSM が管理を介してレイヤ 3 にあり、ゲートウェイも同じ管理サブネットにある場合は、attach module <service module number> コマンドを使用してゲートウェイの CLI にアクセスしてください。 VSM がコントロールを介してレイヤ 3 にある場合は、そのコントロール サブネット上のすべてのマシンからゲートウェイの CLI にアクセスできます。 この例では、L3 コントロールにある VSM を使用しています。

                コマンド 目的

                show redundancy config

                ハイ アベイラビリティのステータスを表示します。

                この例では、ハイ アベイラビリティのステータスを表示します。

                gw# show redundancy config 
                
                HA Manager Node Information:
                
                    Cluster Node Count: 2
                
                    Local Node:
                      state          : Active
                      HA mode        : High Availability
                      uuid           : 56fa6753-4dc5-4a7d-ad07-cc817114f838
                      cluster_id     : 1
                      node_priority  : 2
                      node_type      : VXLAN Gateway
                      ipaddr [mgmt]  : 192.168.1.104
                
                    Peer Node 1:
                      state          : Standby
                      uuid           : 4cbd05df-b3e5-468a-9497-89aa3fae8153
                      node_type      : VXLAN Gateway
                      ipaddr [mgmt]  : 192.168.1.105
                
                

                VXLAN ゲートウェイの VXLAN から VLAN へのマッピングの管理

                ゲートウェイ モジュールで設定された VLAN から VXLAN へのマッピングは、ゲートウェイのアップリンク モジュールに適用されているポート プロファイルを編集して管理できます。 マッピングを追加または削除するには、次の手順を実行します。

                手順
                   コマンドまたはアクション目的
                  ステップ 1 vsm(config)# port-profile port-profile-name  

                  Installing a VXLAN Gateway as a Virtual Service Blade」の中の gw-uplink1 および gw-uplink2 に適用されるポート プロファイルの名前を指定します。

                   
                  ステップ 2 vsm(config-port-prof)# service instance 1 to 4096  

                  マッピングのプレース ホルダを定義します。 指定できる範囲は 1 ~ 4096 です。

                  (注)     

                  service instance キーワードを含むポート プロファイルは、非 VXLAN ゲートウェイ モジュールには使用できません。

                   
                  ステップ 3 vsm(config-port-prof-srv)# encapsulation dot1q 1-4094 bridge-domain name  

                  新しいマッピングを追加します。

                   
                  ステップ 4 vsm(config-port-prof-srv)# no encapsulation dot1q 1-4094 bridge-domain name  

                  既存のマッピングを削除します。

                   

                  次に、VXLAN ゲートウェイ上で VXLAN から VLAN へのマッピングを設定する例を示します。

                  vsm(config)# show run port-profile Uplink-All-VXGW
                  port-profile type ethernet Uplink-All-VXGW
                    vmware port-group
                    switchport mode trunk
                    switchport trunk allowed vlan 1545-1575,1577-1605
                    mtu 1550
                    service instance 2
                      encapsulation dot1q 1557 bridge-domain vxlan6002
                      encapsulation dot1q 1555 bridge-domain vxlan6000
                      encapsulation dot1q 1558 bridge-domain vxlan6003
                      encapsulation dot1q 1559 bridge-domain vxlan6004
                       channel-group auto mode active
                    no shutdown
                    state enabled
                  vsm(config)# show port-profile usage
                  port-profile Uplink-All-VXGW
                   port-channel1
                   port-channel5
                   Ethernet7/1
                   Ethernet7/3
                  
                  vsm(config)# show run interface ethernet 7/1 expand-port-profile
                  interface Ethernet7/1
                    switchport mode trunk
                    switchport trunk allowed vlan 1545-1575,1577-1605
                    mtu 1550
                    channel-group auto mode active
                    service instance 2
                      no shutdown
                      encapsulation dot1q 1557 bridge-domain vxlan6002
                      encapsulation dot1q 1555 bridge-domain vxlan6000
                      encapsulation dot1q 1558 bridge-domain vxlan6003
                      no shutdown

                  VXLAN ゲートウェイの削除

                  クラウド サービス プラットフォームから VXLAN ゲートウェイを削除するには、次の手順を使用します。

                  手順
                     コマンドまたはアクション目的
                    ステップ 1configure terminal
                     

                    クラウド サービス プラットフォーム上でグローバル コンフィギュレーション モードを開始します。

                     
                    ステップ 2 csp(config)# virtual-service-blade <vsb name> 

                    virtual-service-blade サブ コマンドを開始します。

                     
                    ステップ 3 csp(config-vsb-config)# shutdown 

                    仮想サービス ブレードをシャット ダウンします。

                     
                    ステップ 4 csp(config)# no virtual-service-blade <vsb name> 

                    クラウド サービス プラットフォームから仮想サービス ブレードを削除します。

                     

                    VSM から VXLAN ゲートウェイを削除するには、次の手順を使用します。


                    (注)  


                    関連付けられた VEM および VXLAN ゲートウェイ VSB に関連付けられたポートチャネル情報を削除する必要があります。


                    手順
                       コマンドまたはアクション目的
                      ステップ 1configure terminal
                       

                      クラウド サービス プラットフォーム上でグローバル コンフィギュレーション モードを開始します。

                       
                      ステップ 2 vsm(config)# no vem <vem number associated with the primary vxlan-gw VSB> 

                      削除されたプライマリ VXLAN ゲートウェイに関連付けられている未使用 VEM を削除します。

                       
                      ステップ 3 vsm(config)# no vem <vem number associated with the secondary vxlan-gw VSB> 

                      削除されたセカンダリ VXLAN ゲートウェイに関連付けられている未使用 VEM を削除します。

                       
                      ステップ 4 vsm(config)# no interface port-channel <po number associated with the primary vxlan-gw VSB> 

                      削除されたプライマリ VXLAN ゲートウェイ VEM に関連付けられている未使用のポートチャネル インターフェイスを削除します。

                       
                      ステップ 5 vsm(config)# no interface port-channel <po number associated with the secondary vxlan-gw VSB> 

                      削除されたセカンダリ VXLAN ゲートウェイ VEM に関連付けられている未使用のポートチャネル インターフェイスを削除します。

                       

                      VXLAN ゲートウェイの機能履歴

                      機能名

                      リリース

                      機能情報

                      VXLAN ゲートウェイ

                      4.2(1)SV2(2.1)

                      Virtual Extensible Local Area Network(VXLAN)ゲートウェイ機能が追加されました。