Cisco Nexus 1000V VXLAN コンフィギュレーション ガイド リリース 4.2(1)SV2(2.1)
拡張機能の設定
拡張機能の設定

拡張機能の設定

この章の内容は、次のとおりです。

VXLAN トランクは、個別に .1Q タグ値を VXLAN にマッピングできるポートを設定するために使用されます。 ポートは .1Q タグの付いたパケットを受信し、VXLAN に入るパケットのマッピングで使用されます。 VMware が VM 上でサポートする VNIC の数より多い VXLAN にアクセスする必要のあるネットワーク サービス VM をサポートするために VXLAN トランク機能を使用できます。

VXLAN トランクの設定

単一の vEthernet インターフェイス上に複数の VXLAN をトランクできます。

手順
     コマンドまたはアクション目的
    ステップ 1switch# configure terminal 

    グローバル コンフィギュレーション モードを開始します。

     
    ステップ 2 switch(config )# port-profile type vethernet name 

    名前付きポート プロファイルのポート プロファイル コンフィギュレーション モードを開始します。 ポート プロファイルがない場合は、次の特性を使用して作成されます。

    • name:ポート プロファイルの名前は最大 80 文字で、Cisco Nexus 1000V 上の各ポート プロファイルに対して一意である必要があります。
    • type:(任意)ポート プロファイル タイプはイーサネットまたは vEthernet です。
     
    ステップ 3 switch(config -port-profile)# switchport access bridge-domain name-string 

    非 dot1q トラフィックのこのポート プロファイルに VXLAN のブリッジ ドメインを割り当てます。

     
    ステップ 4 switch(config -port-profile)# [no] service instance 1 to 4096 

    マッピングのプレース ホルダを定義します。 指定できる範囲は 1 ~ 4096 です。

     
    ステップ 5 switch(config -port-profile)# [no] encapsulation dot1q 1-4094 bridge-domain name  

    マッピングを作成します。 有効な範囲は 1 ~ 4094 です。

     

    次に、VXLAN トランクを設定する例を示します。

    switch# configure terminal 
    Enter configuration commands, one per line.  End with CNTL/Z.
    switch(config)# port-profile type vethernet csr-access
    switch(config-port-prof)# switchport mode access 
    switch(config-port-prof)# switchport access bridge-domain bd-701
    switch(config-port-prof)# service instance 10
    switch(config-port-prof-srv)# encapsulation dot1q 600 bridge-domain bd-600
    switch(config-port-prof-srv)# encapsulation dot1q 601 bridge-domain bd-601
    switch(config-port-prof-srv)# encapsulation dot1q 602 bridge-domain bd-602
    switch(config-port-prof-srv)# no shutdown 
    cswitch(config-port-prof-srv)# state enabled 
    switch(config-port-prof)# end
    
    switch# show run port-profile csr-access
    port-profile type vethernet csr-access
      switchport mode access
      switchport access bridge-domain bd-701
      service instance 10
        encapsulation dot1q 600 bridge-domain bd-600
        encapsulation dot1q 601 bridge-domain bd-601
        encapsulation dot1q 602 bridge-domain bd-602
      state enabled
    

    次に、VXLAN トランク インターフェイスのマッピングを表示する例を示します。

    switch(config-bd)# show bridge-domain mappings 
    
    -------------------------------------------------------------------------------
    Interface      Service Instance ID      Module ID    Vlan ID      Segment ID   
    -------------------------------------------------------------------------------
    Vethernet2                 10            3            600            5000         
    Vethernet2                 10            3            601            5001        
    Vethernet2                 10            3            602            5002         
    
    switch(config-bd)#
    

    (注)  


    [Interface] 列の値は、VXLAN ゲートウェイまたは VXLAN トランク機能によって異なります。 [Interface] 列の vEhternet<number> は VXLAN トランク機能のマッピングを示します。[Interface] 列の port-channel<number> は VXLAN ゲートウェイで設定されたマッピングを示します。


    Multi-MAC 対応の設定

    複数の MAC アドレスからのパケットを送出できる仮想イーサネット インターフェイスを指定するために使用できます。

    はじめる前に

    MAC 配信(セグメント配信 MAC)がイネーブルになっている場合は、Multi-MAC 対応機能を使用しないでください。

    手順
       コマンドまたはアクション目的
      ステップ 1switch# configure terminal 

      グローバル コンフィギュレーション モードを開始します。

       
      ステップ 2 switch(config )# port-profile type vethernet name  

      名前付きポート プロファイルのポート プロファイル コンフィギュレーション モードを開始します。 ポート プロファイルがない場合は、次の特性を使用して作成されます。

      • name:ポート プロファイルの名前は最大 80 文字で、Cisco Nexus 1000V 上の各ポート プロファイルに対して一意である必要があります。
      • type:(任意)ポート プロファイル タイプはイーサネットまたは vEthernet です。
       
      ステップ 3 Switch(config )# [no] capability multi- mac  

      vEthernet ポート Multi-MAC 対応として指定します。

       

      次に、Multi-MAC 対応機能を設定する例を示します。

      switch# configure terminal 
      Enter configuration commands, one per line.  End with CNTL/Z.
      switch(config-port-prof)# port-profile type vethernet csr-multi-mac-access
      switch(config-port-prof)# switchport mode access 
      switch(config-port-prof)# switchport access bridge-domain bd-701
      switch(config-port-prof)# capability multi-mac 
      switch(config-port-prof)# state enabled 
      switch(config-port-prof)# no shutdown 
      switch(config-port-prof)# end 
      
      switch# show running-config port-profile csr-multi-mac-access
      port-profile type vethernet csr-multi-mac-access
        switchport mode access
        switchport access bridge-domain bd-701
        capability multi-mac
        no shutdown
        state enabled