Cisco ME 3400 イーサネット アクセス スイッチ ソフトウェア コンフィギュレーション ガイド
スイッチの IP アドレスおよびデフォルト ゲー トウェイの割り当て
スイッチの IP アドレスおよびデフォルト ゲートウェイの割り当て
発行日;2012/02/03 | 英語版ドキュメント(2009/11/11 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 11MB) | フィードバック

目次

スイッチの IP アドレスおよびデフォルト ゲートウェイの割り当て

起動プロセスの概要

スイッチ情報の割り当て

デフォルトのスイッチ情報

DHCP ベースの自動設定の概要

DHCP クライアントの要求プロセス

DHCP ベースの自動設定およびイメージ アップデートの概要

DHCP 自動設定

DHCP 自動イメージ アップデート

注意事項および制限事項

DHCP ベースの自動設定機能の設定

DHCP サーバ設定時の注意事項

TFTP サーバの設定

DNS の設定

リレー デバイスの設定

コンフィギュレーション ファイルの取得

設定例

DHCP の自動設定機能およびイメージ アップデート機能の設定

DHCP 自動設定機能の設定(コンフィギュレーション ファイルだけ)

DHCP 自動イメージ アップデート機能の設定(コンフィギュレーション ファイルとイメージ)

クライアントの設定

手動での IP 情報の割り当て

実行コンフィギュレーションの確認と保存

スタートアップ コンフィギュレーションの変更

デフォルトのブート コンフィギュレーション

コンフィギュレーション ファイルの自動ダウンロード

ファイル名の指定によるシステム コンフィギュレーションの読み取りと書き込み

手動による起動

特定のソフトウェア イメージの起動

環境変数の管理

ソフトウェア イメージのリロードのスケジューリング

リロードのスケジューリング設定

リロードのスケジューリング情報の表示

スイッチの IP アドレスおよびデフォルト ゲートウェイの割り当て

この章では、自動および手動による方法で、Cisco Metro Ethernet(ME)3400 イーサネット アクセス スイッチの初期設定(スイッチ IP アドレスの割り当てやデフォルトのゲートウェイ情報など)を作成する方法について説明します。また、スイッチのスタートアップ コンフィギュレーションの変更方法についても説明します。


) この章で使用するコマンドの構文および使用方法の詳細については、このリリースのコマンド リファレンス、および『Cisco IOS Software Documentation, 12.2 Mainline Release, Command References, Volume 1 of 3: Addressing and Services』を参照してください。


この章で説明する内容は、次のとおりです。

「起動プロセスの概要」

「スイッチ情報の割り当て」

「実行コンフィギュレーションの確認と保存」

「スタートアップ コンフィギュレーションの変更」

「ソフトウェア イメージのリロードのスケジューリング」


) IP アドレスおよび DHCP の設定に関するこの章の情報は、IP バージョン 4(IPv4)に特化したものです。


起動プロセスの概要

スイッチを起動するには、まず、ハードウェア インストレーション ガイドに記載された手順に従って、スイッチを設置し、電源を投入して、スイッチの初期設定(IP アドレス、サブネット マスク、デフォルト ゲートウェイ、シークレット パスワード、Telnet パスワードなど)を行う必要があります。

通常の起動プロセスにはブートローダ ソフトウェアの操作も含まれます。ブートローダは次の機能を実行します。

下位レベル CPU の初期化。CPU レジスタを初期化することにより、物理メモリのマッピング領域、容量、速度などを制御します。

CPU サブシステムの Power-On Self-Test(POST; 電源投入時セルフテスト)。CPU DRAM と、フラッシュ デバイスのうちフラッシュ ファイル システムを構成する部分をテストします。

システム ボード上のフラッシュ ファイル システムを初期化します。

デフォルトのオペレーティング システム ソフトウェア イメージをメモリにロードし、スイッチを起動します。

ブートローダによってフラッシュ ファイル システムにアクセスしてから、オペレーティング システムをロードします。通常、ブートローダによって行われるのは、オペレーティング システムのロードから、圧縮解除、および起動までです。オペレーティング システムが CPU を制御できるようになると、ブートローダは、次にシステムがリセットされるか電源が投入されるまでは非アクティブになります。

オペレーティング システムが重大な障害によって使用不能になった場合は、ブートローダがシステムへのトラップドア アクセスを行います。トラップドア メカニズムによるシステムへのアクセス機能により、必要に応じて、フラッシュ ファイル システムのフォーマット、XMODEM プロトコルによるオペレーティング システム ソフトウェアイメージの再インストール、失ったパスワードの回復を行ってから最終的にオペレーティング システムを再起動できます。詳細については、「XMODEM プロトコルによるソフトウェア障害からの回復」および「パスワードを忘れた場合の回復」を参照してください。


) パスワード回復はディセーブルにすることができます。詳細については、「パスワード回復のディセーブル化」を参照してください。


スイッチ情報を割り当てるには、まず PC または端末がコンソール ポートに接続されており、かつ PC または端末エミュレーション ソフトウェアのボー レートおよび文字フォーマットがスイッチのコンソール ポートのものと一致していることを確認します。

ボー レートのデフォルトは 9600 です。

データ ビットのデフォルトは 8 です。


) データ ビット オプションが 8 に設定されている場合、パリティ オプションは none(なし)に設定します。


ストップ ビットのデフォルトは 1 です。

パリティ設定のデフォルトは none(なし)です。

スイッチ情報の割り当て

IP 情報の割り当ては、スイッチのセットアップ プログラムまたは DHCP サーバを使用して行えるほか、手動で行うこともできます。

特定の IP 情報をプロンプトから指定する場合は、スイッチのセットアップ プログラムを使用します。このプログラムを使用すると、ホスト名とイネーブル シークレット パスワードを設定することもできます。任意で、Telnet パスワードを割り当てることもできます(リモート管理時のセキュリティ用)。セットアップ プログラムの詳細については、ハードウェア インストレーション ガイドの付録「Configuring the Switch with the CLI-Based Setup Program」を参照してください。

サーバの設定後は、DHCP サーバを使用して、IP 情報の一元管理と自動割り当てを行います。


) DHCP を使用している場合は、スイッチがダイナミックに割り当てられた IP アドレスを受信してコンフィギュレーション ファイルを読み取るまでは、セットアップ プログラムからの質問に応答しないでください。


スイッチの設定手順について十分な知識がある場合は、手動でスイッチを設定してください。そうでない場合は、前述のセットアップ プログラムを使用します。

ここでは、次の設定情報について説明します。

「デフォルトのスイッチ情報」

「DHCP ベースの自動設定の概要」

「手動での IP 情報の割り当て」

デフォルトのスイッチ情報

表 3-1 に、デフォルトのスイッチ情報を示します。

 

表 3-1 デフォルトのスイッチ情報

機能
デフォルト設定

IP アドレスおよびサブネット マスク

IP アドレスまたはサブネット マスクは定義されていません。

デフォルト ゲートウェイ

デフォルト ゲートウェイは定義されていません。

イネーブル シークレット パスワード

パスワードは定義されていません。

ホスト名

出荷時に割り当てられているデフォルトのホスト名は Switch です。

Telnet パスワード

パスワードは定義されていません。

DHCP ベースの自動設定の概要

DHCP は、インターネット ホストおよびインターネットワーキング デバイスに設定情報を提供します。このプロトコルは、2 つのコンポーネントで構成されています。1 つは DHCP サーバからデバイスにコンフィギュレーション パラメータを提供するコンポーネント、もう 1 つはデバイスにネットワーク アドレスを割り当てるコンポーネントです。DHCP はクライアント サーバ モデルに基づいています。指定された DHCP サーバが、ダイナミックに設定されるデバイスに対して、ネットワーク アドレスを割り当て、コンフィギュレーション パラメータを提供します。スイッチは、DHCP クライアントとしても DHCP サーバとしても機能させることが可能です。

DHCP ベースの自動設定が機能している場合、スイッチ(DHCP クライアント)は起動時に、IP アドレス情報およびコンフィギュレーション ファイルに基づいて自動で設定されます。

DHCP ベースの自動設定では、スイッチ上で DHCP クライアント側の設定を行う必要はありません。ただし、DHCP サーバには、IP アドレスに関する各種のリース オプションを設定する必要があります。DHCP を使用してネットワーク上のコンフィギュレーション ファイルをリレーする場合は、Trivial File Transfer Protocol(TFTP; 簡易ファイル転送プロトコル)サーバおよび Domain Name System(DNS; ドメイン ネーム システム)サーバの設定が必要なこともあります。

スイッチの DHCP サーバは、スイッチと同じ LAN 上であっても、異なる LAN 上にあってもかまいません。DHCP サーバが別の LAN 上で実行されている場合は、スイッチと DHCP サーバとの間に DHCP リレー デバイスを設定する必要があります。リレー デバイスは、直接接続されている 2 つの LAN 間でブロードキャスト トラフィックを転送します。ルータでは、受信したパケットの宛先 IP アドレスに基づくパケットの転送は行われますが、ブロードキャスト パケットの転送は行われません。

DHCP ベースの自動設定は、スイッチの BOOTP クライアント機能に代わるものです。

DHCP クライアントの要求プロセス

スイッチの起動時、そのスイッチにコンフィギュレーション ファイルがない場合は、DHCP クライアントが起動し、DHCP サーバに対して設定情報を要求します。コンフィギュレーション ファイルが存在し、そのコンフィギュレーションに特定のルーテッド インターフェイス上の ip address dhcp インターフェイス コンフィギュレーション コマンドが含まれている場合は、DHCP クライアントが起動し、これらのインターフェイスの IP アドレス情報を要求します。

図 3-1 に、DHCP クライアントと DHCP サーバの間でメッセージが交換される順序を示します。

図 3-1 DHCP クライアントとサーバのメッセージ交換

 

クライアントであるスイッチ A は、DHCPDISCOVER メッセージをブロードキャストし、DHCP サーバを検索します。DHCP サーバは、DHCPOFFER ユニキャスト メッセージによって、コンフィギュレーション パラメータ(IP アドレス、サブネット マスク、ゲートウェイ IP アドレス、DNS IP アドレス、IP アドレスのリースなど)をクライアントに提供します。

クライアントは、DHCPREQUEST ブロードキャスト メッセージにより、DHCP サーバに対して、提供された設定情報の正式な要求を返します。この要求は、クライアントから DHCPDISCOVER ブロードキャスト メッセージを受信した他の DHCP サーバすべてにブロードキャストされます。これは、これらのサーバが、クライアントに提供した IP アドレスを再要求できるようにするためです。

DHCP サーバは、クライアントに DHCPACK ユニキャスト メッセージを返すことによって、クライアントに IP アドレスが割り当てられたことを確認します。このメッセージにより、クライアントとサーバがバインドされ、クライアントは、サーバから受信した設定情報を使用します。スイッチが受信する情報量は、DHCP サーバの設定方法によって異なります。詳細については、「TFTP サーバの設定」を参照してください。

クライアントに対して送信された DHCPOFFER ユニキャスト メッセージのコンフィギュレーション パラメータが無効の場合(コンフィギュレーション エラーがある場合)、クライアントは DHCP サーバに DHCPDECLINE ブロードキャスト メッセージを返します。

この場合 DHCP サーバは、クライアントに DHCPNAK 拒否ブロードキャスト メッセージを送信します。これは、提供されたコンフィギュレーション パラメータが割り当てられておらず、パラメータのネゴシエーション中にエラーが発生したこと、または DHCPOFFER メッセージに対するクライアントからの応答が遅いこと(DHCP サーバが同じパラメータを他のクライアントに割り当てたこと)を意味します。

DHCP クライアントは、複数の DHCP サーバまたは BOOTP サーバから提供される情報を受信することがあります。いずれの情報も取得できますが、通常は最初に受信した情報が取得されます。DHCP サーバから提供される情報は、クライアントに IP アドレスが割り当てられることを保証するものではありません。ただし、サーバは通常、クライアントがアドレスを正式に要求するまでアドレスを予約しています。スイッチは、BOOTP サーバからの応答を受け入れて設定を行う際、TFTP 要求を(ユニキャストするのではなく)ブロードキャストすることで、スイッチ コンフィギュレーション ファイルを取得します。

DHCP ベースの自動設定およびイメージ アップデートの概要

DHCP イメージ アップグレード機能を使用すると、ネットワーク内の 1 つまたは複数のスイッチに新しいイメージおよびコンフィギュレーション ファイルがダウンロードされるよう、DHCP サーバを設定できます。これにより、スイッチを新たにネットワークへ追加した場合、各スイッチが受け取るイメージおよびコンフィギュレーションを統一できます。

DHCP イメージ アップグレードには 2 つの種類があります。1 つは DHCP 自動設定、もう 1 つは DHCP 自動イメージ アップデートです。

DHCP 自動設定

DHCP 自動設定を使用すると、ネットワーク内の 1 つまたは複数のスイッチに対して、DHCP サーバからコンフィギュレーションをダウンロードできます。ダウンロードされたコンフィギュレーション ファイルは、そのスイッチの実行コンフィギュレーションとなります。フラッシュ内に保存されているブートアップ コンフィギュレーションは、スイッチがリロードされるまで上書きされません。

DHCP 自動イメージ アップデート

DHCP 自動設定と DHCP 自動イメージ アップデートを併用すると、ネットワーク内の 1 つまたは複数のスイッチに、コンフィギュレーションおよび新しいイメージの両方をダウンロードできます。新しいコンフィギュレーションおよびイメージをダウンロードするスイッチ(または複数のスイッチ)は、コンフィギュレーションやイメージが未設定の状態(または出荷時のデフォルト設定がロードされただけの状態)でも構いません。

コンフィギュレーションがすでに存在するスイッチに新しいコンフィギュレーションがダウンロードされると、そのコンフィギュレーションは、スイッチに格納されているコンフィギュレーション ファイルに追加されます(ダウンロードされたコンフィギュレーションにより既存のコンフィギュレーションが上書きされることはありません)。


) スイッチ上で DHCP 自動イメージ アップデートをイネーブルにするには、イメージ ファイルおよびコンフィギュレーション ファイルがロードされる TFTP サーバに、オプション 67(コンフィギュレーション ファイルの名前)、オプション 66(DHCP サーバのホスト名)、オプション 150(TFTP サーバのアドレス)、およびオプション 125(ファイルの内容説明)を適切に設定する必要があります。

スイッチを DHCP サーバとして設定するときの手順については、「DHCP ベースの自動設定機能の設定」および『Cisco IOS IP Configuration Guide, Release 12.2』の「IP addressing and Services」の章の「Configuring DHCP」を参照してください。


ネットワーク内にスイッチを設置したら、自動イメージ アップデート機能が始動します。ダウンロードされたコンフィギュレーション ファイルは、スイッチの実行コンフィギュレーションに保存されます。また、新しいイメージがスイッチにダウンロードされ、インストールされます。このコンフィギュレーションは、スイッチを再起動した時点で、そのスイッチに保存されているコンフィギュレーションに格納されます。

注意事項および制限事項

注意事項は次のとおりです。

ネットワーク内でアップ状態にあるレイヤ 3 インターフェイスの中に、割り当てられた IP アドレスを持たないものが 1 つも存在しない場合、保存済みコンフィギュレーションによる DHCP ベースの自動設定プロセスは停止します。

保存済みコンフィギュレーションによる DHCP ベースの自動設定機能を使用する場合、タイムアウト時間を設定しないと、IP アドレスのダウンロードの試行が無制限に繰り返されます。

コンフィギュレーション ファイルがダウンロードできない、または破損した場合、自動インストール プロセスは停止します。


) TFTP からダウンロードされたコンフィギュレーション ファイルは、実行コンフィギュレーション内の既存コンフィギュレーションとマージされますが、write memory 特権 EXEC コマンドまたは copy running-configuration startup-configuration 特権 EXEC コマンドを実行しない限り、NVRAM には保存されません。ダウンロードされたコンフィギュレーションがスタートアップ コンフィギュレーションに保存された場合、それに続くシステムの再起動時に、この機能はトリガーされません。


DHCP ベースの自動設定機能の設定

ここでは、次の設定情報について説明します。

「DHCP サーバ設定時の注意事項」

「TFTP サーバの設定」

「DNS の設定」

「リレー デバイスの設定」

「コンフィギュレーション ファイルの取得」

「設定例」

DHCP サーバとしてシスコ製デバイスを使用している場合の DHCP 設定に関する詳細については、『 Cisco IOS IP Configuration Guide, Release 12.2 』の「IP Addressing and Services」にある「Configuring DHCP」を参照してください。

DHCP サーバ設定時の注意事項

デバイスを DHCP サーバとして設定する場合は、次の注意事項に従ってください。

DHCP サーバには、スイッチのハードウェア アドレスにより各スイッチにバインドされている予約済みリースを設定する必要があります。

スイッチに IP アドレス情報を受信させるには、DHCP サーバに次のリース オプションを設定する必要があります

クライアントの IP アドレス(必須)

クライアントのサブネット マスク(必須)

DNS サーバの IP アドレス(任意)

ルータの IP アドレス(スイッチが使用するデフォルト ゲートウェイの アドレス)(必須)

スイッチに TFTP サーバからのコンフィギュレーション ファイルを受信させる場合は、DHCP サーバに次のリース オプションを設定する必要があります。

TFTP サーバ名(必須)

ブート ファイル名(クライアントに必要なコンフィギュレーション ファイルの名前)(推奨)

ホスト名(任意)

DHCP サーバの設定によっては、スイッチは IP アドレス情報またはコンフィギュレーション ファイルあるいはその両方を受信できます。

DHCP サーバに前述のリース オプションを設定しない場合、サーバはクライアント要求に対して設定済みパラメータだけで応答します。応答に IP アドレスおよびサブネット マスクが含まれていない場合は、スイッチを設定できません。ルータの IP アドレスまたは TFTP サーバ名が見つからない場合、スイッチは TFTP 要求をユニキャストではなく、ブロードキャストで送信することがあります。他のリース オプションについては、使用できない場合でも自動設定に影響はありません。

TFTP サーバの設定

スイッチは、DHCP サーバの設定に基づいて、TFTP サーバから 1 つまたは複数のコンフィギュレーション ファイルをダウンロードしようとします。TFTP サーバへの IP 接続に必要なオプションをすべて備えたスイッチに応答するよう DHCP を設定している場合、また TFTP サーバの名前、アドレス、およびコンフィギュレーション ファイル名を指定して DHCP サーバを設定している場合、スイッチは指定された TFTP サーバから指定されたコンフィギュレーション ファイルをダウンロードしようとします。

コンフィギュレーション ファイル名および TFTP サーバを指定しなかった場合、またはコンフィギュレーション ファイルをダウンロードできなかった場合、スイッチはさまざまなファイル名と TFTP サーバ アドレスの組み合せによりコンフィギュレーション ファイルをダウンロードしようとします。このようなファイル名としては、指定されたコンフィギュレーション ファイル名(存在する場合)のほか、network-config、cisconet.cfg 、 hostname .config、 hostname .cfg などのファイル名が使用されます。ただし、 hostname はスイッチの現在のホスト名を表します。また TFTP サーバ アドレスとしては、指定された TFTP サーバのアドレス(存在する場合)およびブロードキャスト アドレス(255.255.255.255)が使用されます。

スイッチがコンフィギュレーション ファイルを正常にダウンロードするには、TFTP サーバのベース ディレクトリに 1 つまたは複数のコンフィギュレーション ファイルが存在する必要があります。該当するファイルは、次のとおりです。

DHCP 応答に指定されるコンフィギュレーション ファイル(スイッチの実際のコンフィギュレーション ファイル)

network-confg ファイルまたは cisconet.cfg ファイル(デフォルトのコンフィギュレーション ファイル)

router-confg ファイルまたは ciscortr.cfg ファイル(これらのファイルには、すべてのスイッチに共通のコマンドが含まれています。通常、DHCP サーバと TFTP サーバが適正に設定されていれば、これらのファイルは使用されません)

DHCP サーバ リース データベースに TFTP サーバ名を指定する場合は、DNS サーバのデータベースに TFTP サーバ名と IP アドレスのマッピングを設定する必要もあります。

使用する TFTP サーバがスイッチとは異なる LAN 上にある場合、またはスイッチから TFTP サーバへのアクセスにブロードキャスト アドレスが使用される場合(前述のすべての必須情報が DHCP サーバの応答に含まれていない場合に発生)は、リレーを設定して TFTP サーバに TFTP パケットを転送する必要があります。詳細については、「リレー デバイスの設定」を参照してください。こうした状況に対する対処方法としては、必要な情報をすべて使用して DHCP サーバを設定することが推奨されます。

DNS の設定

DHCP サーバでは、DNS サーバを使用して、TFTP サーバ名から IP アドレスを取得します。DNS サーバには、TFTP サーバ名から IP アドレスへのマッピングを設定する必要があります。TFTP サーバには、スイッチのコンフィギュレーション ファイルが保持されています。

DHCP サーバのリース データベースには、DNS サーバの IP アドレスを設定できます。DNS サーバからは、DHCP 応答により IP アドレスが取得されます。リース データベースには、DNS サーバの IP アドレスを 2 つまで入力できます。

DNS サーバは、スイッチと同じ LAN 上にあっても、異なる LAN 上にあってもかまいません。異なる LAN 上にある場合、スイッチはルータ経由で DHCP サーバにアクセス可できることが必要です。

リレー デバイスの設定

別の LAN 上にあるホストからの応答が必要なブロードキャスト パケットをスイッチが送信するときは、リレー デバイス( リレー エージェント )を設定する必要があります。スイッチが送信する可能性のあるブロードキャスト パケットの例として DHCP、DNS パケット、場合によっては TFTP パケットが挙げられます。リレー デバイスは、インターフェイス上で受信したブロードキャスト パケットが宛先ホストに転送されるように設定します。

リレー デバイスがシスコ ルータの場合には、IP ルーティングをイネーブルにし( ip routing グローバル コンフィギュレーション コマンド)、 ip helper-address インターフェイス コンフィギュレーション コマンドを使用してヘルパー アドレスを設定します。

たとえば、図 3-2 では、ルータ インターフェイスを次のように設定しています。

インターフェイス 10.0.0.2

router(config-if)# ip helper-address 20.0.0.2
router(config-if)# ip helper-address 20.0.0.3
router(config-if)# ip helper-address 20.0.0.4
 

インターフェイス 20.0.0.1

router(config-if)# ip helper-address 10.0.0.1

スイッチをリレー デバイスとして機能させる場合は、インターフェイスをルーテッド ポートとして設定してください。詳細については、「ルーテッド ポート」および「レイヤ 3 インターフェイスの設定」を参照してください。


図 3-2 自動設定で使用されるリレー デバイス

 

コンフィギュレーション ファイルの取得

DHCP の予約済みリースで IP アドレスおよびコンフィギュレーション ファイル名を取得できるかどうかに応じて、スイッチは次の方法で設定情報を取得します。

スイッチ用の IP アドレスおよびコンフィギュレーション ファイル名が予約され、DHCP 応答に含まれている場合(1 ファイル読み込み方式)

スイッチは、DHCP サーバから IP アドレス、サブネット マスク、TFTP サーバ アドレス、およびコンフィギュレーション ファイル名を取得します。さらにスイッチは、TFTP サーバのベース ディレクトリから指定のコンフィギュレーション ファイルを取得するために、TFTP サーバへユニキャスト メッセージを送信します。指定のコンフィギュレーション ファイルを受信すると、スイッチの起動プロセスは完了します。

スイッチ用の IP アドレスおよびコンフィギュレーション ファイル名は予約されているが、DHCP 応答に TFTP サーバ アドレスが含まれていない場合(1 ファイル読み込み方式)

スイッチは、DHCP サーバから IP アドレス、サブネット マスク、およびコンフィギュレーション ファイル名を取得します。さらにスイッチは、TFTP サーバのベース ディレクトリから指定のコンフィギュレーション ファイルを取得するために、TFTP サーバへブロードキャスト メッセージを送信します。指定のコンフィギュレーション ファイルを受信すると、スイッチの起動プロセスは完了します。

スイッチ用の IP アドレスだけが予約されており、DHCP 応答にはその IP アドレスだけが含まれ、コンフィギュレーション ファイル名は含まれていない場合(2 ファイル読み込み方式)

スイッチは、DHCP サーバから IP アドレス、サブネット マスク、および TFTP サーバ アドレスを取得します。スイッチは、デフォルトのコンフィギュレーション ファイル network-confg または cisconet.cfg を取得するために、TFTP サーバにユニキャスト メッセージを送信します(network-confg ファイルを読み込めない場合、スイッチは cisconet.cfg ファイルを読み込みます)。

デフォルトのコンフィギュレーション ファイルには、スイッチのホスト名と IP アドレスのマッピング情報が含まれています。スイッチは、ファイル内の情報を自身のホスト テーブルに読み込み、ホスト名を取得します。ファイルにホスト名が含まれていない場合、スイッチは DHCP 応答に含まれているホスト名を使用します。DHCP 応答にホスト名が指定されていない場合、スイッチはホスト名としてデフォルトの Switch を使用します。

デフォルトのコンフィギュレーション ファイルまたは DHCP 応答からホスト名を取得すると、スイッチは TFTP サーバからホスト名と同名のコンフィギュレーション ファイルを読み込みます(network-confg または cisconet.cfg のどちらを先に読み込んだかによって、ファイル名は hostname -confg または hostname .cfg になります)。cisconet.cfg ファイルを読み込んだ場合、ホストのファイル名は 8 文字に切り詰められます。

network-confg、cisconet.cfg、またはホスト名のファイルを読み込めなかった場合、スイッチは router-confg ファイルを読み込みます。router-confg ファイルが読み込めない場合、スイッチは ciscortr.cfg ファイルを読み込みます。


) DHCP 応答から TFTP サーバを取得できなかった場合、ユニキャスト送信によるコンフィギュレーション ファイルの読み込みにすべて失敗した場合、または TFTP サーバ名から IP アドレスを取得できなかった場合、スイッチは TFTP サーバ要求をブロードキャストします。


設定例

図 3-3 は、DHCP ベースの自動設定を使用して IP 情報を取得するネットワークの例を示したものです。

図 3-3 DHCP ベースの自動設定ネットワークの例

 

表 3-2 は、DHCP サーバの予約済みリースの設定を示したものです。

 

表 3-2 DHCP サーバの設定

スイッチ A
スイッチ B
スイッチ C
スイッチ D

バインド キー(ハードウェア アドレス)

00e0.9f1e.2001

00e0.9f1e.2002

00e0.9f1e.2003

00e0.9f1e.2004

IP アドレス

10.0.0.21

10.0.0.22

10.0.0.23

10.0.0.24

サブネット マスク

255.255.255.0

255.255.255.0

255.255.255.0

255.255.255.0

ルータ アドレス

10.0.0.10

10.0.0.10

10.0.0.10

10.0.0.10

DNS サーバ アドレス

10.0.0.2

10.0.0.2

10.0.0.2

10.0.0.2

TFTP サーバ名

tftpserver または 10.0.0.3

tftpserver または 10.0.0.3

tftpserver または 10.0.0.3

tftpserver または 10.0.0.3

ブート ファイル名(コンフィギュレーション ファイル)(任意)

switcha-confg

switchb-confg

switchc-confg

switchd-confg

ホスト名(任意)

switcha

switchb

switchc

switchd

DNS サーバの設定

DNS サーバは、TFTP サーバ名の tftpserver を IP アドレス 10.0.0.3 にマッピングします。

TFTP サーバの設定(UNIX 上)

TFTP サーバのベース ディレクトリは、/tftpserver/work/ に設定されています。このディレクトリには、2 ファイル読み込み方式で使用される network-confg ファイルが含まれています。このファイルには、IP アドレスに基づいてスイッチに割り当てられるホスト名が含まれています。また、次に示すように、スイッチのコンフィギュレーション ファイル( switcha-confg switchb-confg など)もベース ディレクトリに含まれています。

prompt> cd /tftpserver/work/
prompt> ls
network-confg
switcha-confg
switchb-confg
switchc-confg
switchd-confg
prompt> cat network-confg
ip host switcha 10.0.0.21
ip host switchb 10.0.0.22
ip host switchc 10.0.0.23
ip host switchd 10.0.0.24
 

DHCP クライアントの設定

スイッチ A ~ D には、コンフィギュレーション ファイルは存在しません。

設定の説明

図 3-3 では、スイッチ A はコンフィギュレーション ファイルを次のように取得します。

DHCP サーバから IP アドレス 10.0.0.21 を取得します。

DHCP サーバ応答にコンフィギュレーション ファイル名が含まれていない場合、スイッチ A は TFTP サーバのベース ディレクトリから network-confg ファイルを読み込みます。

スイッチ A は、network-confg ファイルの内容をホスト テーブルに追加します。

IP アドレス 10.0.0.21 をホスト名(switcha)にインデックス付けすることによって、ホスト テーブルを読み込みます。

ホスト名に対応するコンフィギュレーション ファイルを読み込みます。たとえば、TFTP サーバから switch1-confg ファイルを読み込みます。

スイッチ B ~ D も同じ要領で、それぞれのコンフィギュレーション ファイルおよび IP アドレスを取得します。

DHCP の自動設定機能およびイメージ アップデート機能の設定

DHCP を使用してスイッチに新しいイメージおよび新しいコンフィギュレーションをダウンロードする場合は、スイッチを少なくとも 2 つ設定する必要があります。1 つは DHCP サーバ、1 つは TFTP サーバとして機能させます。クライアント スイッチは、新しいコンフィギュレーション ファイルだけをダウンロードするか、新しいコンフィギュレーション ファイルと新しいイメージ ファイルの両方をダウンロードするかのどちらかに設定します。

DHCP 自動設定機能の設定(コンフィギュレーション ファイルだけ)

新しいスイッチ上で新しいコンフィギュレーション ファイルをダウンロードするために TFTP 設定および DHCP 設定に対する DHCP 自動設定機能を設定するには、特権 EXEC モードで次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

ip dhcp poolname

DHCP サーバのアドレス プールの名前を作成し、DHCP プール コンフィギュレーション モードを開始します。

ステップ 3

bootfile filename

ブート イメージとして使用するコンフィギュレーション ファイルの名前を指定します。

ステップ 4

network network-number mask prefix-length

DHCP アドレス プールのサブネット ネットワーク番号およびサブネット マスクを指定します。

(注) prefix length には、アドレス プレフィクスのビット数(プレフィクス長)を指定します。プレフィクスは、クライアントのネットワーク マスクを指定するための代替手段です。プレフィクス長はスラッシュ(/)に続けて指定します。

ステップ 5

default-router address

DHCP クライアントのデフォルト ルータの IP アドレスを指定します。

ステップ 6

option 150 address

TFTP サーバの IP アドレスを指定します。

ステップ 7

exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 8

tftp-server flash :filename.text

TFTP サーバ上にあるコンフィギュレーション ファイルを指定します。

ステップ 9

interface interface-id

コンフィギュレーション ファイルを受け取るクライアントのアドレスを指定します。

ステップ 10

no switchport

インターフェイスをレイヤ 3 モードにします。

ステップ 11

ip address address mask

インターフェイスの IP アドレスおよびマスクを指定します。

ステップ 12

end

特権 EXEC モードに戻ります。

ステップ 13

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

  • 次に、コンフィギュレーション ファイルをダウンロードするためにスイッチを DHCP サーバとして設定する方法の例を示します。
Switch# configure terminal
Switch(config)# ip dhcp pool pool1
Switch(dhcp-config)# network 10.10.10.0 255.255.255.0
Switch(dhcp-config)# bootfile config-boot.text
Switch(dhcp-config)# default-router 10.10.10.1
Switch(dhcp-config)# option 150 10.10.10.1
Switch(dhcp-config)# exit
Switch(config)# tftp-server flash:config-boot.text
Switch(config)# interface gigabitethernet1/0/4
Switch(config-if)# no switchport
Switch(config-if)# ip address 10.10.10.1 255.255.255.0
Switch(config-if)# end

DHCP 自動イメージ アップデート機能の設定(コンフィギュレーション ファイルとイメージ)

新しいスイッチ上で新しいイメージおよび新しいコンフィギュレーション ファイルをダウンロードするために TFTP 設定および DHCP 設定に対する DHCP 自動設定機能を設定するには、特権 EXEC モードで次の手順を実行します。


) この表に示した手順を実行する場合は、スイッチにアップロードするテキスト ファイル(autoinstall_dhcp など)を事前に作成しておく必要があります。このテキスト ファイルには、ダウンロードするイメージの名前を記述します。このイメージは、bin ファイルではなく、tar ファイルであることが必要です。


 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

ip dhcp pool name

DHCP サーバのアドレス プールの名前を作成し、DHCP プール コンフィギュレーション モードを開始します。

ステップ 3

bootfile filename

ブート イメージとして使用するファイルの名前を指定します。

ステップ 4

network network-number mask prefix-length

DHCP アドレス プールのサブネット ネットワーク番号およびサブネット マスクを指定します。

(注) prefix length には、アドレス プレフィクスのビット数(プレフィクス長)を指定します。プレフィクスは、クライアントのネットワーク マスクを指定するための代替手段です。プレフィクス長はスラッシュ(/)に続けて指定します。

ステップ 5

default-router address

DHCP クライアントのデフォルト ルータの IP アドレスを指定します。

ステップ 6

option 150 address

TFTP サーバの IP アドレスを指定します。

ステップ 7

option 125 hex

イメージ ファイルへのパスを記述したテキスト ファイルへのパスを指定します。

ステップ 8

copy tftp flash filename.txt

テキスト ファイルをスイッチにアップロードします。

ステップ 9

copy tftp flash imagename.tar

新しいイメージ用の tar ファイルをスイッチにアップロードします。

ステップ 10

exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 11

tftp-server flash:config.text

TFTP サーバ上にある Cisco IOS コンフィギュレーション ファイルを指定します。

ステップ 12

tftp-server flash:imagename.tar

TFTP サーバ上にあるイメージの名前を指定します。

ステップ 13

tftp-server flash:filename.txt

ダウンロードするイメージ ファイルの名前が記述されたテキスト ファイルを指定します。

ステップ 14

interface interface-id

コンフィギュレーション ファイルを受け取るクライアントのアドレスを指定します。

ステップ 15

no switchport

インターフェイスをレイヤ 3 モードにします。

ステップ 16

ip address address mask

インターフェイスの IP アドレスおよびマスクを指定します。

ステップ 17

end

特権 EXEC モードに戻ります。

ステップ 18

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

  • 次に、コンフィギュレーション ファイルをダウンロードするためにスイッチを DHCP サーバとして設定する方法の例を示します。
Switch# config terminal
Switch(config)# ip dhcp pool pool1
Switch(dhcp-config)# network 10.10.10.0 255.255.255.0
Switch(dhcp-config)# bootfile config-boot.text
Switch(dhcp-config)# default-router 10.10.10.1
Switch(dhcp-config)# option 150 10.10.10.1
Switch(dhcp-config)# option 125 hex 0000.0009.0a05.08661.7574.6f69.6e73.7461.6c6c.5f64.686370
Switch(dhcp-config)# exit
Switch(config)# tftp-server flash:config-boot.text
Switch(config)# tftp-server flash:-image-name-mz.122-44.3.SE.tar
Switch(config)# tftp-server flash:boot-config.text
Switch(config)# tftp-server flash: autoinstall_dhcp
Switch(config)# interface gigabitEthernet1/0/4
Switch(config-if)# no switchport
Switch(config-if)# ip address 10.10.10.1 255.255.255.0
Switch(config-if)# end

クライアントの設定

DHCP サーバからコンフィギュレーション ファイルおよび新しいイメージをダウンロードするようにスイッチを設定するには、特権 EXEC モードで次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

boot host dhcp

保存済み設定による自動設定をイネーブルにします。

ステップ 3

boot host retry timeout timeout-value

(任意)システムがコンフィギュレーション ファイルのダウンロードを試行する時間を設定します。

(注) タイムアウト時間を設定しないと、DHCP サーバからの IP アドレスのダウンロード試行が無制限に繰り返されます。

ステップ 4

banner config-save ^C warning-message ^C

(任意)コンフィギュレーション ファイルを NVRAM に保存する際に表示する警告メッセージを作成します。

ステップ 5

end

特権 EXEC モードに戻ります。

ステップ 6

show boot

設定を確認します。

次に、VLAN 99 のレイヤ 3 SVI インターフェイスを使用して、保存済みコンフィギュレーションによる DHCP ベースの自動設定をイネーブルにする例を示します。

Switch# configure terminal
Switch(conf)# boot host dhcp
Switch(conf)# boot host retry timeout 300
Switch(conf)# banner config-save ^C Caution - Saving Configuration File to NVRAM May Cause You to Nolonger Automatically Download Configuration Files at Reboot^C
Switch(config)# vlan 99
Switch(config-vlan)# interface vlan 99
Switch(config-if)# no shutdown
Switch(config-if)# end
Switch# show boot
BOOT path-list:
Config file: flash:/config.text
Private Config file: flash:/private-config.text
Enable Break: no
Manual Boot: no
HELPER path-list:
NVRAM/Config file
buffer size: 32768
Timeout for Config
Download: 300 seconds
Config Download
via DHCP: enabled (next boot: enabled)
Switch#

) 設定およびイネーブル化の対象となるのは、レイヤ 3 インターフェイスだけです。IP アドレスおよび保存済みコンフィギュレーションによる DHCP ベースの自動設定は割り当てないでください。


手動での IP 情報の割り当て

Switch Virtual Interface(SVI; スイッチ仮想インターフェイス)に手動で IP 情報を割り当てるには、特権 EXEC モードで次の手順を実行します。スイッチでメトロ IP サービス イメージを実行している場合は、 no switchport コマンドを使用してポートをレイヤ 3 モードにすれば、そのポートに IP 情報を手動で割り当てることもできます。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface vlan vlan-id

インターフェイス コンフィギュレーション モードを開始し、IP 情報を割り当てる VLAN を入力します。有効な範囲は 1 ~ 4094 です。ただし、先行ゼロは使用しないでください。

ステップ 3

ip address ip-address subnet-mask

IP アドレスおよびサブネット マスクを入力します。

ステップ 4

exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 5

ip default-gateway ip-address

デフォルト ゲートウェイが設定されたスイッチに直接接続されているネクスト ホップ ルータ インターフェイスの IP アドレスを入力します。デフォルト ゲートウェイは、スイッチから宛先 IP アドレスが解決されていない IP パケットを受信します。

デフォルト ゲートウェイが設定されると、スイッチは、ホストが通信する必要のあるリモート ネットワークに接続できます。

(注) IP でルーティングするようにスイッチを設定した場合は、デフォルト ゲートウェイを設定する必要はありません。

ステップ 6

end

特権 EXEC モードに戻ります。

ステップ 7

show interfaces vlan vlan-id

設定されている IP アドレスを確認します。

ステップ 8

show ip redirects

設定されているデフォルト ゲートウェイを確認します。

ステップ 9

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

スイッチの IP アドレスを削除する場合は、 no ip address インターフェイス コンフィギュレーション コマンドを使用します。Telnet セッションを介してアドレスを削除すると、スイッチへの接続は切断されます。デフォルト ゲートウェイのアドレスを削除するときは、 no ip default-gateway グローバル コンフィギュレーション コマンドを使用します。

スイッチのシステム名の設定、特権 EXEC コマンドへのアクセスの保護、時刻およびカレンダーの設定については、「スイッチの管理」を参照してください。

実行コンフィギュレーションの確認と保存

次の特権 EXEC コマンドを使用すると、入力した設定内容や変更した内容を確認できます。

Switch# show running-config
Building configuration...
 
Current configuration : 2010 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname 3400-3
!
enable password cisco
!
no aaa new-model
ip subnet-zero
no ip domain-lookup
!
table-map test
default copy
!
no file verify auto
!
spanning-tree mode rapid-pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
vlan 2,10
!
class-map match-all test1
class-map match-all class2
class-map match-all class1
!
!
policy-map test
class class1
police cir percent 30
policy-map test2
class class2
police cir 8500 bc 1500
policy-map test3
!
!
interface FastEthernet0/1
!
interface FastEthernet0/2
shutdown
!
interface FastEthernet0/3
shutdown
!
interface FastEthernet0/4
shutdown
!
interface FastEthernet0/5
shutdown
!
interface FastEthernet0/6
shutdown
!
interface FastEthernet0/7
shutdown
 
<output truncated>
 
interface GigabitEthernet0/1
port-type nni
!
interface GigabitEthernet0/2
port-type nni
!
interface Vlan1
no ip address
no ip route-cache
no ip mroute-cache
shutdown
!
interface Vlan10
ip address 192.168.1.76 255.255.255.0
!
ip default-gateway 192.168.1.3
no ip http server
ip classless
!
!
!
control-plane
!
!
line con 0
session-timeout 120
exec-timeout 120 0
speed 115200
line vty 0 4
password cisco
no login
line vty 5 15
no login
!
!
end
 

スタートアップ コンフィギュレーションに対して行った設定や変更の内容をフラッシュ メモリに保存するには、次の特権 EXEC コマンドを使用します。

Switch# copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
 

このコマンドを実行すると、設定の内容が保存されます。保存できなかった設定は、次回システム リロード時に失われます。フラッシュ メモリの NVRAM セクションに保存されている情報を表示するには、 show startup-config 権 EXEC コマンドまたは more startup-config 特権 EXEC コマンドを使用します。

コンフィギュレーション ファイルのコピーの代替保管場所については、 付録 B「Cisco IOS ファイル システム、コンフィギュレーション ファイル、およびソフトウェア イメージの操作」 を参照してください。

スタートアップ コンフィギュレーションの変更

「デフォルトのブート コンフィギュレーション」

「コンフィギュレーション ファイルの自動ダウンロード」

「手動による起動」

「特定のソフトウェア イメージの起動」

「環境変数の管理」

スイッチのコンフィギュレーション ファイルに関する詳細については、 付録 B「Cisco IOS ファイル システム、コンフィギュレーション ファイル、およびソフトウェア イメージの操作」 を参照してください。

デフォルトのブート コンフィギュレーション

表 3-3 は、デフォルトのブート コンフィギュレーションについての説明をまとめたものです。

 

表 3-3 デフォルトのブート コンフィギュレーション

機能
デフォルト設定

オペレーティング システムのソフトウェア イメージ

スイッチは、BOOT 環境変数内の情報を使用して自動的にシステムを起動しようとします。変数が設定されていない場合、スイッチは、フラッシュ ファイル システム全体に再帰的な縦型検索を行って、最初に検出された実行可能イメージをロードして実行しようとします。

Cisco IOS イメージは、イメージ ファイル(拡張子 .bin を除く)と同じ名前のディレクトリに保存されています。

ディレクトリの縦型検索では、検出した各サブディレクトリを完全に検索してから元のディレクトリでの検索を続けます。

コンフィギュレーション ファイル

設定済みのスイッチは、フラッシュ メモリのシステム ボードに保存されている config.text ファイルを使用します。

新しいスイッチには、コンフィギュレーション ファイルはありません。

コンフィギュレーション ファイルの自動ダウンロード

DHCP ベースの自動設定機能を使用すれば、スイッチにコンフィギュレーション ファイルを自動的にダウンロードできます。詳細については、「DHCP ベースの自動設定の概要」を参照してください。

ファイル名の指定によるシステム コンフィギュレーションの読み取りと書き込み

デフォルトでは、Cisco IOS ソフトウェアは、 config.text ファイルを使用して、システム コンフィギュレーションの不揮発性コピーを読み書きします。ただし、別のファイル名を指定することもでき、これは次回起動時にロードされます。

別のコンフィギュレーション ファイル名を指定するには、特権 EXEC モードで次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

boot config-file flash:/ file-url

次回の起動時にロードするコンフィギュレーション ファイルを指定します。

file-url には、パス(ディレクトリ)とコンフィギュレーション ファイル名を指定します。

ファイル名およびディレクトリ名では、大文字と小文字が区別されます。

ステップ 3

end

特権 EXEC モードに戻ります。

ステップ 4

show boot

設定を確認します。

boot config-file グローバル コンフィギュレーション コマンドを使用すると、環境変数 CONFIG_FILE の設定を変更できます。

ステップ 5

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

設定をデフォルトに戻すときは、 no boot config-file グローバル コンフィギュレーション コマンドを使用します。

手動による起動

デフォルトでは、スイッチは自動的に起動しますが、手動で起動するように設定することもできます。

次回の起動時に手動で起動するようにスイッチを設定するには、特権 EXEC モードで次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

boot manual

次回の起動時にスイッチを手動で起動できるようにします。

ステップ 3

end

特権 EXEC モードに戻ります。

ステップ 4

show boot

設定を確認します。

boot manual グローバル コマンドを使用すると、環境変数 MANUAL_BOOT の設定を変更できます。

システムの次回の再起動時には、スイッチはブートローダ モードになります。このことは、 switch: プロンプトで確認できます。システムを起動するには、 boot filesystem :/ file-url ブートローダ コマンドを使用します。

システム ボード フラッシュ デバイスの場合は、 filesystem : flash: を指定します。

file-url には、ブート可能イメージのパス(ディレクトリ)および名前を指定します。

ファイル名およびディレクトリ名では、大文字と小文字が区別されます。

ステップ 5

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

手動での起動をディセーブルにするには、 no boot manual グローバル コンフィギュレーション コマンドを使用します。

特定のソフトウェア イメージの起動

デフォルトでは、スイッチは、BOOT 環境変数内の情報を使用して自動的にシステムを起動しようとします。この変数が設定されていない場合、スイッチは、フラッシュ ファイル システム全体に再帰的な縦型検索を行って、最初の実行可能イメージをロードして実行しようとします。ディレクトリの縦型検索では、検出した各サブディレクトリを完全に検索してから元のディレクトリでの検索を続けます。ただし、特定のイメージを指定して起動することもできます。

次回の起動時に特定のイメージを起動するようにスイッチを設定するには、特権 EXEC モードで次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

boot system filesystem :/ file-url

次回の起動時にフラッシュ メモリ内の特定のイメージを起動するようにスイッチを設定します。

システム ボード フラッシュ デバイスの場合は、 filesystem : flash: を指定します。

file-url には、ブート可能イメージのパス(ディレクトリ)および名前を指定します。

ファイル名およびディレクトリ名では、大文字と小文字が区別されます。

ステップ 3

end

特権 EXEC モードに戻ります。

ステップ 4

show boot

設定を確認します。

boot system グローバル コマンドを使用すると、環境変数 BOOT の設定を変更できます。

次回の起動時にスイッチは、BOOT 環境変数内の情報を使用して自動的にシステムを起動しようとします。

ステップ 5

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

設定をデフォルトに戻す場合は、 no boot system グローバル コンフィギュレーション コマンドを使用します。

環境変数の管理

通常の操作スイッチを使用してブート ローダ モードを開始するには、スイッチのコンソール接続を 9600 bps に設定します。スイッチの電源コードを取り外して、接続し直します。スイッチは、POST を実行してから、自動ブート プロセスを開始します。ブート ローダは、ブートアップ シーケンス中にユーザにブレーク キーの文字を求めるプロンプトを表示します(次の例を参照)。

***** The system will autoboot in 5 seconds *****
 
Send a break key to prevent autobooting.
 

ブレーク キーの文字は、オペレーティング システムごとに異なります。

UNIX を実行する SUN ワークステーションでは、Ctrl+C がブレーク キーとなります。

Windows 2000 を実行する PC では、Ctrl+Break がブレーク キーとなります。

Cisco TAC では、一般的なオペレーティング システムのブレーク キー、およびブレーク キーをサポートしていない端末エミュレータで使用できる代替ブレーク キー シーケンスに関するリストが用意されています。このリストを参照する場合は、次の URL にアクセスしてください。

http://www.cisco.com/warp/public/701/61.html#how-to

ブレーク キーを入力すると、ブート ローダの switch: プロンプトが表示されます。

スイッチのブートローダ ソフトウェアは、不揮発性環境変数をサポートしています。これらの環境変数を使用することで、ブートローダをはじめ、システム上で稼動するソフトウェアの動作を制御できます。ブートローダの環境変数は、UNIX システムや DOS システム上で設定できる環境変数とほぼ同じものです。

値が設定された環境変数は、フラッシュ ファイル システム外のフラッシュ メモリに保存されています。

これらのファイルの各行には、環境変数名、等号に続いて変数の値が指定されています。このファイルに表示されていない変数には値がありません。表示されていればヌル ストリングであっても値があります。ヌル ストリング(たとえば " ")に設定されている変数は、値を持つ変数です。多くの環境変数は事前に定義されており、デフォルト値が設定されています。

環境変数には、次の 2 種類のデータが保持されます。

Cisco IOS コンフィギュレーション ファイルの読み取りを行わないコードを制御するためのデータ。環境変数として保存できるブートローダの機能を拡張または補強するブートローダ ヘルパー ファイルの名前などが、こうしたデータに該当します。

Cisco IOS コンフィギュレーション ファイルの読み取りを行うコードを制御するためのデータ。環境変数として保存できる Cisco IOS コンフィギュレーション ファイルの名前などが、こうしたデータに該当します。

環境変数の設定は、ブートローダにアクセスするか Cisco IOS コマンドを使用して変更できます。通常の環境では、環境変数の設定を変更する必要はありません。


) ブートローダ コマンドおよび環境変数の構文および使用方法の詳細については、このリリースのコマンド リファレンスを参照してください。


表 3-4 は、使用頻度の高い環境変数とその機能に関する説明をまとめたものです。

 

表 3-4 環境変数

変数
ブートローダ コマンド
Cisco IOS グローバル コンフィギュレーション コマンド

BOOT

set BOOT filesystem :/ file-url ...

自動起動時にロードおよび実行を試みる実行可能ファイルのリストを指定します。区切り文字にはセミコロンを使用します。BOOT 環境変数が設定されていない場合、システムは、フラッシュ ファイル システム全体に再帰的な縦型検索を行って、最初に検出された実行可能イメージをロードして実行を試みます。BOOT 環境変数が設定されているにもかかわらず指定されたイメージをロードできない場合、システムはフラッシュ ファイル システムで最初に検出されたブートファイルの起動を試みます。

boot system f ilesystem:/file-url ...

次回の起動時にロードする Cisco IOS イメージを指定します。このコマンドは、BOOT 環境変数の設定を変更します。

MANUAL_BOOT

set MANUAL_BOOT yes

スイッチを自動で起動するか手動で起動するかを指定します。

有効値は 1、yes、0、および no です。no または 0 に設定した場合、ブートローダはシステムを自動的に起動しようとします。それ以外に設定した場合は、スイッチをブートローダ モードから手動で起動する必要があります。

boot manual

次回の起動時に手動でスイッチを起動できるようにし、環境変数 MANUAL_BOOT の設定を変更します。

システムの次回の再起動時には、スイッチはブートローダ モードになります。システムを起動するには、 boot flash: filesystem :/ file-url ブート ローダ コマンドを使用し、コマンドにはブート イメージの名前を指定します。

CONFIG_FILE

set CONFIG_FILE flash:/ file-url

Cisco IOS がシステム コンフィギュレーションの不揮発性コピーの読み書きに使用するファイル名を変更します。

boot config-file flash: / file-url

Cisco IOS がシステム設定の不揮発性コピーの読み書きに使用するファイル名を指定します。このコマンドを使用すると、環境変数 CONFIG_FILE を変更できます。

ソフトウェア イメージのリロードのスケジューリング

スイッチ上へのソフトウェア イメージのリロードを、時間を置いて(たとえば、スイッチの使用が少ない夜間や週末に)実行するようにスケジューリングできます。また、ネットワーク全体でリロードを同期化できます(たとえば、ネットワークのすべてのスイッチ上でソフトウェアのアップグレードを実行)。


) リロードは、およそ 24 日以内に実行されるようにスケジューリングする必要があります。


リロードのスケジューリング設定

ソフトウェア イメージのリロードを、時間を置いて実行するようにスイッチを設定する場合は、特権 EXEC モードで次のいずれかのコマンドを使用します。

reload in [ hh : ] mm [ text ]

このコマンドを使用すると、ソフトウェアのリロードを、指定した時間内(時間および分で指定)に実行するようにスケジューリングできます。リロードは、およそ 24 日以内に実行される必要があります。リロードの理由を最大 255 文字の文字列として指定できます。

reload at hh : mm [ month day | day month ] [ text ]

このコマンドを使用すると、ソフトウェアのリロードを、指定した時刻(24 時間制)に実行するようにスケジューリングできます。月日を指定すると、リロードは指定された日時に実行されるようスケジューリングされます。月日を指定しない場合、リロードは当日の指定された時刻(指定された時刻が現在の時刻よりあとの場合)または翌日(指定された時刻が現在の時刻よりも前の場合)に実行されます。00:00 を指定すると、リロードは午前 0 時にスケジューリングされます。


) キーワード at を使用するのは、Network Time Protocol(NTP; ネットワーク タイム プロトコル)、ハードウェアのカレンダー、または手動によってスイッチのシステム クロックが設定されている場合だけです。時刻は、スイッチに設定されているタイム ゾーンが基準となります。複数のスイッチでリロードが同時に実行されるようスケジューリングするには、各スイッチの時刻が NTP によって同期している必要があります。


reload コマンドを使用すると、システムを一時停止できます。手動で起動するように設定されていない場合、システムは自動的に再起動します。 reload コマンドを使用する場合は、あらかじめスイッチの設定情報をスタートアップ コンフィギュレーション( copy running-config startup-config )に保存してください。

スイッチが手動で起動するように設定されている場合、仮想端末からのリロードは行わないでください。これは、スイッチがブートローダ モードになり、リモート ユーザがスイッチを制御できるようになるのを回避するためです。

コンフィギュレーション ファイルを変更すると、リロードする前に設定を保存するよう求めるプロンプトが表示されます。存在しないスタートアップ コンフィギュレーション ファイルが環境変数 CONFIG_FILE に指定されていると、保存の際に保存を続行するかどうかを尋ねるメッセージが表示されます。続行すると、システムはリロードのセットアップ モードを開始します。

次に、当日の 7:30 PM にソフトウェアをリロードする手順の例を示します。

Switch# reload at 19:30
Reload scheduled for 19:30:00 UTC Wed Jun 5 1996 (in 2 hours and 25 minutes)
Proceed with reload? [confirm]
 

次に、未来の時刻にソフトウェアをリロードする手順の例を示します。

Switch# reload at 02:00 jun 20
Reload scheduled for 02:00:00 UTC Thu Jun 20 1996 (in 344 hours and 53 minutes)
Proceed with reload? [confirm]
 

リロードのスケジューリングを取り消すときは、 reload cancel 特権 EXEC コマンドを使用します。

リロードのスケジューリング情報の表示

リロードのスケジューリングに関する情報を表示してスイッチ上でリロードがスケジューリングされているかどうかを調べるときは、 show reload 特権 EXEC コマンドを使用します。

リロードの予定実行時刻、リロードの理由(指定されている場合)など、リロードに関する情報が表示されます。