Cisco ME 3400 イーサネット アクセス スイッチ ソフトウェア コンフィギュレーション ガイド
HSRP の設定
HSRP の設定
発行日;2012/02/03 | 英語版ドキュメント(2009/11/11 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 11MB) | フィードバック

目次

HSRP の設定

HSRP の概要

HSRP のバージョン

Multiple HSRP

HSRP の設定

HSRP のデフォルト設定

HSRP 設定時の注意事項

HSRP のイネーブル化

HSRP のプライオリティの設定

MHSRP の設定

HSRP 認証およびタイマーの設定

ICMP リダイレクト メッセージの HSRP サポートのイネーブル化

HSRP 設定の表示

HSRP の設定

この章では、Cisco ME 3400 イーサネット アクセス スイッチで Hot Standby Router Protocol(HSRP; ホット スタンバイ ルータ プロトコル)を使用する方法について説明します。HSRP は、IP トラフィック ルーティングに冗長性を提供し、1 台のルータのアベイラビリティに依存しないルーティングを実現します。HSRP をサポートするには、スイッチでメトロ IP アクセス イメージが稼動している必要があります。


) この章で使用するコマンドの構文および使用方法の詳細については、このリリースのスイッチ コマンド リファレンス、および『Cisco IOS IP Command Reference, Volume 1 of 3: Addressing and Services, Release 12.2』を参照してください。


「HSRP の概要」

「HSRP の設定」

「HSRP 設定の表示」

HSRP の概要

HSRP は、デフォルト ゲートウェイ IP アドレスが設定された IEEE 802 LAN 上の IP ホスト ファースト ホップに冗長性を確保しネットワークのアベイラビリティを高めるシスコの標準方式です。HSRP を使用すると、特定のルータのアベイラビリティに依存せず IP トラフィックをルーティングできます。また、一連のルータ インターフェイスを組み合せることで、1 台の仮想ルータ、または LAN 上のホストへのデフォルト ゲートウェイのように機能させることができます。ネットワークまたはセグメント上に HSRP を設定すると、仮想 Media Access Control(MAC; メディア アクセス制御)アドレス、および設定されたルータ グループ間で共有される IP アドレスを使用できるようになり、HSRP が設定された複数のルータは、仮想ルータの MAC アドレスおよび IP ネットワーク アドレスを使用できるようになります。仮想ルータは実際には存在しません。相互にバックアップ機能を提供するように設定されている複数のルータの共通のターゲットとなるルータです。1 台のルータがアクティブなルータとして、もう 1 台のルータがスタンバイ ルータとして選択されます。スタンバイ ルータは、指定されたアクティブ ルータが故障した場合に、グループの MAC アドレスおよび IP アドレスを制御するルータです。


) HSRP グループ内のルータには、スイッチのルーテッド ポートや Switch Virtual Interface(SVI; スイッチ仮想インターフェイス)など、HSRP をサポートする任意のルータ インターフェイスを指定できます。


HSRP は、ネットワーク上のホストからの IP トラフィックに冗長性を提供することで、ネットワークのアベイラビリティを高めます。アクティブ ルータは、ルータ インターフェイスのグループ内でパケットのルーティングを実行するために選択されたルータです。スタンバイ ルータは、アクティブ ルータが故障した場合、または設定条件が満たされた場合に、ルーティング作業を引き継ぐルータです。

HSRP は、ホストがルータ ディスカバリ プロトコルをサポートしておらず、選択されたルータのリロードや電源故障時に新しいルータに切り替えることができない場合に有効です。HSRP をネットワーク セグメントに設定すると、HSRP は仮想 MAC アドレスと IP アドレスを 1 つずつ提供します。このアドレスは、HSRP が動作するルータ インターフェイス グループ内のルータ インターフェイス間で共有できます。プロトコルによってアクティブ ルータとして選択されたルータは、グループの MAC アドレス宛のパケットを受信し、ルーティングします。 n 台のルータで HSRP が稼動している場合、 n +1 個の IP アドレスおよび MAC アドレスが割り当てられます。

指定されたアクティブ ルータの故障を HSRP が検出すると、選択されているスタンバイ ルータがホット スタンバイ グループの MAC アドレスおよび IP アドレスの制御を引き継ぎます。この時点で新しいスタンバイ ルータも選択されます。HSRP が稼動しているデバイスは、マルチキャスト UDP ベースの hello パケットを送受信することにより、ルータ障害の検出、アクティブ ルータおよびスタンバイ ルータの指定を行います。インターフェイスに HSRP が設定されている場合、そのインターフェイスでは Internet Control Message Protocol(ICMP; インターネット制御メッセージ プロトコル)のリダイレクト メッセージがデフォルトでディセーブルとなっています。

レイヤ 3 で動作するスイッチ間で複数のホット スタンバイ グループを設定すると、冗長ルータをさらに活用できます。そのためには、インターフェイスに設定するホット スタンバイ コマンド グループごとにグループ番号を指定します。たとえば、スイッチ 1 のインターフェイスをアクティブ ルータ、スイッチ 2 のインターフェイスをスタンバイ ルータとして設定できます。また、スイッチ 2 の別のインターフェイスをアクティブ ルータ、スイッチ 1 の別のインターフェイスをスタンバイ ルータとして設定することもできます。

図 38-1 に、HSRP 用に設定されたネットワークのセグメントを示します。各ルータには、仮想ルータの MAC アドレスおよび IP ネットワーク アドレスが設定されています。ルータ A の IP アドレスをネットワーク上のホストに設定する代わりに、デフォルト ルータである仮想ルータの IP アドレスを設定します。ホスト C からホスト B にパケットが送信される場合、ホスト C は仮想ルータの MAC アドレスにパケットを送信します。何らかの理由により、ルータ A がパケットの転送を停止すると、ルータ B が仮想 IP アドレスおよび仮想 MAC アドレスに応答してアクティブ ルータとなり、アクティブ ルータの作業を行います。ホスト C は引き続き仮想ルータの IP アドレスを使用し、ホスト B 宛のパケットをアドレッシングします。ルータ B はそのパケットを受信し、ホスト B に送信します。ルータ B は HSRP の機能を使用し、ルータ A が動作を再開するまで、ホスト B のセグメント上のユーザと通信する必要があるホスト C のセグメント上のユーザに連続的にサービスを提供します。また、ホスト A セグメントとホスト B の間で、引き続き通常のパケット処理機能を実行します。

図 38-1 HSRP の一般的な構成

 

HSRP のバージョン

スイッチでサポートされている HSRP のバージョンは次のとおりです。

HSRPv1:HSRP のバージョン 1。これが HSRP のデフォルト バージョンです。機能は次のとおりです。

HSRP グループ番号は、0 ~ 255 の範囲で指定できます。

HSRPv1 では、hello パケットの送信にマルチキャスト アドレス 224.0.0.2 が使用されますが、これは Cisco Group Management Protocol(CGMP)の脱退処理と競合する可能性があります。HSRPv1 と CGMP は相互に排他的で、同時には使用できません。

HSRPv2:HSRP のバージョン 2。HSRPv2 の機能は次のとおりです。

HSRPv2 では、HSRP グループ番号とサブインターフェイスの VLAN ID を一致させるため、グループ番号として 0 ~ 4095 の値、MAC アドレスとして 0000.0C9F.F000 ~ 0000.0C9F.FFFF の値をそれぞれ使用できます。

HSRPv2 では、hello パケットの送信にマルチキャスト アドレス 224.0.0.102 が使用されます。HSRPv2 と CGMP の脱退処理は相互に排他的ではないため、同時にイネーブルにできます。

HSRPv2 のパケット形式は HSRPv1 とは異なります。

HSRPv1 を実行しているスイッチでは、hello パケットを送信した物理ルータを特定できません。これはルータの送信元 MAC アドレスが仮想 MAC アドレスであることに起因します。

HSRPv2 のパケット形式は HSRPv1 とは異なります。HSRPv2 パケットには、Type Length Value(TLV)形式が使用され、パケットを送信した物理ルータの MAC アドレスが 6 バイトの識別子フィールドに格納されます。

HSRPv1 を実行しているインターフェイスが HSRPv2 パケットを取得した場合、このタイプ フィールドは無視されます。

HSRPv2 と HSRPv1 は相互に排他的です。同じインターフェイス上では、HSRPv2 と HSRPv1 を同時に使用できません。

Multiple HSRP

スイッチでは、HSRP の拡張機能である Multiple HSRP(MHSRP)がサポートされています。これにより 2 つ以上の HSRP グループ間で負荷分散が行えます。MHSRP を設定すると、ホスト ネットワークからサーバ ネットワークまで、ロード バランシングを実現して複数のスタンバイ グループ(およびパス)を使用できます。図 38-2 では、半数のクライアントがルータ A として設定され、もう半数のクライアントがルータ B として設定されています。それと同時に、ルータ A およびルータ B に対する設定により、2 つの HSRP グループが確立されています。グループ 1 では、ルータ A に最高のプライオリティが割り当てられているので、ルータ A がデフォルトのアクティブ ルータになり、ルータ B がスタンバイ ルータとなります。グループ 2 では、ルータ B に最高のプライオリティが割り当てられているので、ルータ B がデフォルトのアクティブ ルータになり、ルータ A がスタンバイ ルータとなります。通常の運用では、この 2 つのルータが IP トラフィック負荷を分担します。一方のルータが使用できなくなると、もう一方のルータがアクティブになり、使用できないルータのパケット転送機能を引き継ぎます。

設定手順の例については、「MHSRP の設定」を参照してください。


) MHSRP では、障害が発生したルータが再び稼動状態へ戻った場合にプリエンプトが発生して負荷分散が復元されるように、standby preempt インターフェイス コンフィギュレーション コマンドを HSRP インターフェイスで入力する必要があります。


図 38-2 MHSRP 負荷分散

 

HSRP の設定

「HSRP のデフォルト設定」

「HSRP 設定時の注意事項」

「HSRP のイネーブル化」

「HSRP のプライオリティの設定」

「MHSRP の設定」

「HSRP 認証およびタイマーの設定」

「ICMP リダイレクト メッセージの HSRP サポートのイネーブル化」

HSRP のデフォルト設定

表 38-1 は、HSRP のデフォルト設定をまとめたものです。

 

表 38-1 HSRP のデフォルト設定

機能
デフォルト設定

HSRP バージョン

バージョン 1

HSRP グループ

設定なし

スタンバイ グループ番号

0

スタンバイ MAC アドレス

システムへの割り当て:0000.0c07.acXX( XX は HSRP グループ番号)

スタンバイ プライオリティ

100

スタンバイ遅延

0(遅延なし)

スタンバイでのインターフェイス プライオリティの追跡

10

スタンバイ hello 時間

3 秒

スタンバイ ホールドタイム

10 秒

HSRP 設定時の注意事項

HSRP を設定できる VLAN インターフェイスまたはルーティング インターフェイスは合わせて 32 個までです。

以下の手順では、次のレイヤ 3 インターフェイスのうちいずれか 1 つを指定する必要があります。

ルーテッド ポート: no switchport インターフェイス コンフィギュレーション コマンドを入力して、レイヤ 3 ポートとして設定された物理ポートです。

SVI: interface vlan vlan_id グローバル コンフィギュレーション コマンドを使用して作成された VLAN インターフェイス。デフォルトではレイヤ 3 インターフェイスです。

レイヤ 3 モードの EtherChannel ポート チャネル: interface port-channel port- channel-number グローバル コンフィギュレーション コマンドを使用し、イーサネット インターフェイスをチャネル グループにバインドして作成されたポートチャネル論理インターフェイスです。詳細については、「レイヤ 3 EtherChannel の設定」を参照してください。

すべてのレイヤ 3 インターフェイスに IP アドレスを割り当てる必要があります。「レイヤ 3 インターフェイスの設定」を参照してください。

HSRPv1 が設定されているインターフェイスとは異なるインターフェイスに HSRPv2 を設定する場合、HSRPv2 と HSRPv1 を同一のスイッチ上に設定できます。

HSRP グループのバージョンは、そのグループの番号が 256 未満である場合に限って HSRPv2 から HSRPv1 に変更できます。

インターフェイス上で HSRP のバージョンを変更すると、新しい仮想 MAC アドレスが割り当てられるため、各 HSRP グループはリセットされます。

HSRP のイネーブル化

standby ip インターフェイス コンフィギュレーション コマンドを実行すると、設定されたインターフェイスで HSRP がアクティブになります。IP アドレスを指定すると、その IP アドレスがホット スタンバイ グループの指定アドレスとして使用されます。IP アドレスを指定しなければ、スタンバイ機能によってアドレスが学習されます。指定アドレスを使用し、LAN 上に少なくとも 1 つのレイヤ 3 ポートを設定する必要があります。IP アドレスを設定すると、常に、現在使用されている別の指定アドレスが、設定した IP アドレスに変更されます。

standby ip コマンドがインターフェイス上でイネーブルに設定され、プロキシ Address Resolution Protocol(ARP; アドレス解決プロトコル)がイネーブルの場合、インターフェイスのホット スタンバイ ステートがアクティブになると、プロキシ ARP 要求に対する応答は、ホット スタンバイ グループの MAC アドレスを使用して実行されます。インターフェイスが別のステートの場合、プロキシ ARP の応答は抑制されます。

レイヤ 3 インターフェイス上で HSRP を作成する場合、またはイネーブルにする場合は、特権 EXEC モードで次の手順を実行します。

 

 
コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface-id

インターフェイス コンフィギュレーション モードを開始し、HSRP をイネーブルにするレイヤ 3 インターフェイスを入力します。

ステップ 3

no shutdown

必要に応じて、ポートをイネーブルにします。デフォルトでは、User Network Interface(UNI; ユーザ ネットワーク インターフェイス)と Enhanced Network Interface(ENI; 拡張ネットワーク インターフェイス)はディセーブルに、Network Node Interface(NNI; ネットワーク ノード インターフェイス)はイネーブルに設定されています。

ステップ 4

no switchport

必要であれば、ポート上でレイヤ 2 スイッチングをディセーブルにし、レイヤ 3 インターフェイスをイネーブルにします。

ステップ 5

standby version { 1 | 2 }

(任意)インターフェイスに HSRP バージョンを設定します。

1:HSRPv1 を選択する場合に指定します。

2:HSRPv2 を選択する場合に指定します。

このコマンドを入力しないか、またはキーワードを指定しない場合、そのインターフェイスではデフォルト バージョンの HSRP である HSRP v1 が実行されます。

ステップ 6

standby [ group-number ] ip [ ip-address [ secondary ]]

HSRP グループの番号および仮想 IP アドレスを使用して、HSRP グループを作成(またはイネーブルに)します。

(任意) group-number :HSRP をイネーブルにするインターフェイスのグループ番号を指定します。指定できる範囲は 0 ~ 255 で、デフォルト値は 0 です。HSRP グループが 1 つだけであれば、グループ番号を指定する必要はありません。

(1 つのインターフェイスで必須、それ以外は任意) ip-address :ホット スタンバイ ルータ インターフェイスの仮想 IP アドレスを指定します。少なくとも 1 つのインターフェイスに対して仮想 IP アドレスを入力する必要があります。他のインターフェイスは、その仮想 IP アドレスを学習します。

(任意) secondary :指定した IP アドレスが、セカンダリ ホット スタンバイ ルータ インターフェイスの IP アドレスとなります。ルータがセカンダリ ルータとスタンバイ ルータのいずれにも指定されず、かつプライオリティも設定されていない場合は、プライマリ IP アドレスが比較され、IP アドレスが大きいルータがアクティブ ルータ、IP アドレスが 2 番目に大きいルータがスタンバイ ルータになります。

ステップ 7

end

特権 EXEC モードに戻ります。

ステップ 8

show standby [ interface-id [ group ]]

設定を確認します。

ステップ 9

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

HSRP をディセーブルにする場合は、 no standby [ group-number ] ip [ ip-address ] インターフェイス コンフィギュレーション コマンドを使用します。

次に、インターフェイスのグループ 1 で HSRP をアクティブにする例を示します。ホット スタンバイ グループで使用される IP アドレスは、HSRP を使用して学習されます。


) これは、HSRP をイネーブルにするために最低限必要な手順です。その他の設定は任意です。


Switch# configure terminal
Switch(config)# interface gigabitethernet0/1
Switch(config-if)# no switchport
Switch(config-if)# standby 1 ip
Switch(config-if)# end
Switch# show standby

HSRP のプライオリティの設定

standby priority standby preempt 、および standby track の各インターフェイス コンフィギュレーション コマンドはいずれも、アクティブ ルータとスタンバイ ルータ、および新しいアクティブ ルータが処理を引き継いだ場合の動作を検索する際の手掛かりとなる特性を設定するためのものです。

HSRP プライオリティを設定するときの注意事項は、次のとおりです。

プライオリティを割り当てると、アクティブ ルータおよびスタンバイ ルータを選択できるようになります。プリエンプトがイネーブルの場合は、プライオリティが最高のルータがアクティブ ルータになります。プライオリティが同じであれば、現在のアクティブ ルータがそのまま使用されます。

最も大きな値(1 ~ 255)が、最高のプライオリティ(アクティブ ルータになる可能性が最も高い)を表します。

プライオリティ、プリエンプト、またはその両方を設定するときは、少なくとも 1 つのキーワード( priority preempt 、または両方)を指定する必要があります。

インターフェイスが standby track コマンドによって設定されている場合、ルータ上の別のインターフェイスがダウンすると、デバイスのプライオリティはダイナミックに変更されます。

standby track インターフェイス コンフィギュレーション コマンドを実行すると、ルータのホット スタンバイ プライオリティとインターフェイスのアベイラビリティが関連付けられます。この機能は、HSRP 用に設定されていないインターフェイスを追跡する場合に有効です。追跡対象のインターフェイスが故障すると、追跡が設定されていたデバイスのホット スタンバイ プライオリティが 10 減少します。追跡対象でないインターフェイスの場合は、そのステートが変わっても、設定済みデバイスのホット スタンバイ プライオリティは変わりません。ホット スタンバイ用に設定されたインターフェイスごとに、追跡するインターフェイスのリストを個別に設定できます。

standby track interface-priority インターフェイス コンフィギュレーション コマンドを使用すると、追跡対象のインターフェイスがダウンした場合のホット スタンバイ プライオリティの減少幅を指定できます。インターフェイスが稼動状態に戻ると、プライオリティは同じ分だけ増加します。

interface-priority の値が設定されている場合、複数の追跡対象インターフェイスがダウンすると、設定済みプライオリティの減少幅が累積されます。プライオリティ値が設定されていない追跡対象インターフェイスが故障した場合、デフォルトの減少幅は 10 です。この値は累積されません。

インターフェイスに対しルーティングを初めてイネーブルにした時点では、完全なルーティング テーブルは存在しません。preempt に設定されたインターフェイスはアクティブ ルータになりますが、十分なルーティング処理はできません。この問題を解決するには、ルータがルーティング テーブルを更新できるように遅延時間を設定します。

インターフェイスに HSRP プライオリティ特性を設定するには、特権 EXEC モードで次の手順を実行します。

 

 
コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface-id

インターフェイス コンフィギュレーション モードを開始し、プライオリティを設定する HSRP インターフェイスを入力します。

ステップ 3

no shutdown

必要に応じて、ポートをイネーブルにします。デフォルトでは、UNI および ENI はディセーブルに、NNI はイネーブルに設定されています。

ステップ 4

standby [ group-number ] priority priority [ preempt [ delay delay ]]

アクティブ ルータを選択するときに使用される priority 値を設定します。指定できる範囲は 1 ~ 255 で、デフォルト値は 100 です。最も大きな値が、最高のプライオリティを表します。

(任意) group-number :コマンドが適用されるグループ番号を指定します。

(任意) preempt :ローカル ルータのプライオリティがアクティブ ルータよりも高い場合、そのローカル ルータがアクティブ ルータとして制御を行います。

(任意) delay :ローカル ルータがアクティブ ルータの役割を引き継ぐまでの時間を、指定された秒数だけ延期します。指定できる範囲は 0 ~ 3600(1 時間)で、デフォルトは 0 です(引き継ぐ前の遅延はありません)。

デフォルト値に戻すには、このコマンドの no 形式を使用します。

ステップ 5

standby [ group-number ] [ priority priority ] preempt [ delay delay ]

ルータを preempt に設定します(つまりローカル ルータのプライオリティがアクティブ ルータよりも高い場合は、そのローカル ルータがアクティブ ルータとして制御を行います)。

(任意) group-number :コマンドが適用されるグループ番号を指定します。

(任意) priority :グループ プライオリティを設定または変更する場合に入力します。指定できる値の範囲は 1 ~ 255 で、デフォルト値は 100 です。

(任意) delay :ローカル ルータがアクティブ ルータの役割を引き継ぐまでの時間を、指定された秒数だけ延期します。指定できる範囲は 0 ~ 3600(1 時間)で、デフォルトは 0 です(引き継ぐ前の遅延はありません)。

デフォルト値に戻すには、このコマンドの no 形式を使用します。

ステップ 6

standby [ group-number ] track type number [ interface-priority ]

他のインターフェイスを追跡するようにインターフェイスを設定します。この設定により、他のインターフェイスの 1 つがダウンした場合は、そのデバイスのホット スタンバイ プライオリティが減少します。

(任意) group-number :コマンドが適用されるグループ番号を指定します。

type :追跡対象のインターフェイス タイプを(インターフェイス番号とともに)入力します。

number :追跡対象のインターフェイス番号を(インターフェイス タイプとともに)入力します。

(任意) interface-priority :インターフェイスがダウンした場合、または稼動状態に戻った場合に、ルータのホット スタンバイ プライオリティを減少または増加させる幅を入力します。デフォルト値は 10 です。

ステップ 7

end

特権 EXEC モードに戻ります。

ステップ 8

show running-config

スタンバイ グループの設定を確認します。

ステップ 9

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

プライオリティ、プリエンプト、および遅延の値をデフォルト値に戻すには、 no standby [ group-number ] priority priority [ preempt [ delay delay ]] および no standby [ group-number ] [ priority priority ] preempt [ delay delay ] の各インターフェイス コンフィギュレーション コマンドを使用します。

追跡を解除するには、 no standby [ group-number ] track type number [ interface-priority ] インターフェイス コンフィギュレーション コマンドを使用します。

次の例では、ポートがアクティブになり、IP アドレスおよびプライオリティ 120(デフォルト値よりも高いプライオリティ)が設定されます。アクティブ ルータになるまでの待機時間は 300 秒(5 分間)です。

Switch# configure terminal
Switch(config)# interface gigabitethernet0/1
Switch(config-if)# no switchport
Switch(config-if)# standby ip 172.20.128.3
Switch(config-if)# standby priority 120 preempt delay 300
Switch(config-if)# end

MHSRP の設定

MHSRP およびロード バランシングをイネーブルにするには、グループのアクティブ ルータとして 2 つのルータを設定し、仮想ルータをスタンバイ ルータとして設定します。次は、図 38-2 の MHSRP 設定をイネーブルにする例です。障害が発生したルータが稼動状態へ戻った場合にプリエンプトを発生させてロード バランシングが復元されるよう、 standby preempt インターフェイス コンフィギュレーション コマンドをそれぞれの HSRP インターフェイスで入力する必要があります。

ルータ A はグループ 1 のアクティブ ルータとして、ルータ B はグループ 2 のアクティブ ルータとして設定されています。ルータ A の HSRP インターフェイスの IP アドレスは 10.0.0.1、グループ 1 スタンバイ プライオリティは 110 です(デフォルトは 100)。ルータ B の HSRP インターフェイスの IP アドレスは 10.0.0.2、グループ 2 スタンバイ プライオリティは 110 です。

グループ 1 は仮想 IP アドレス 10.0.0.3 を使用し、グループ 2 は仮想 IP アドレス 10.0.0.4 を使用します。

ルータ A の設定

Switch# configure terminal
Switch(config)# interface gigabitethernet0/1
Switch(config-if)# no switchport
Switch(config-if)# ip address 10.0.0.1 255.255.255.0
Switch(config-if)# standby 1 ip 10.0.0.3
Switch(config-if)# standby 1 priority 110
Switch(config-if)# standby 1 preempt
Switch(config-if)# standby 2 ip 10.0.0.4
Switch(config-if)# standby 2 preempt
Switch(config-if)# end
 

ルータ B の設定

Switch# configure terminal
Switch(config)# interface gigabitethernet0/1
Switch(config-if)# no switchport
Switch(config-if)# ip address 10.0.0.2 255.255.255.0
Switch(config-if)# standby 1 ip 10.0.0.3
Switch(config-if)# standby 1 preempt
Switch(config-if)# standby 2 ip 10.0.0.4
Switch(config-if)# standby 2 priority 110
Switch(config-if)# standby 2 preempt
Switch(config-if)# end

HSRP 認証およびタイマーの設定

必要であれば、HSRP 認証文字列を設定できるほか、hello 時間インターバルやホールドタイムを変更することもできます。

これらのアトリビュートを設定するときの注意事項は次のとおりです。

認証文字列はすべての HSRP メッセージに暗号化されずに送信されます。相互運用できるように、接続されたすべてのルータおよびアクセス サーバに同じ認証文字列を設定する必要があります。認証文字列が一致しないと、HSRP が設定された他のルータから、指定されたホット スタンバイ IP アドレスおよびタイマー値を取得することができません。

スタンバイ タイマー値が設定されていないルータまたはアクセス サーバは、アクティブ ルータまたはスタンバイ ルータからタイマー値を取得できます。アクティブ ルータに設定されたタイマーは、常に他のタイマー設定よりも優先されます。

同じホット スタンバイ グループに属するルータにはすべて、同じタイマー値を使用する必要があります。通常、 holdtime hellotime の 3 倍以上です。

インターフェイスに HSRP の認証とタイマーを設定するには、特権 EXEC モードで次の手順を実行します。

 

 
コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface-id

インターフェイス コンフィギュレーション モードを開始し、認証を設定する HSRP インターフェイスを入力します。

ステップ 3

no shutdown

必要に応じて、ポートをイネーブルにします。デフォルトでは、UNI および ENI はディセーブルに、NNI はイネーブルに設定されています。

ステップ 4

standby [ group-number ] authentication string

(任意) authentication string :すべての HSRP メッセージで伝達される文字列を入力します。認証文字列として指定できる文字数は最大 8 文字です。デフォルトの文字列は cisco です。

(任意) group-number :コマンドが適用されるグループ番号を指定します。

ステップ 5

standby [ group-number ] timers hellotime holdtime

(任意)hello パケット インターバル、およびアクティブ ルータのダウンを他のルータが宣言するまでの時間を設定します。

group-number :コマンドが適用されるグループ番号を指定します。

hellotime :hello インターバルを秒単位で指定します。指定できる範囲は 1 ~ 255 秒で、デフォルトは 3 秒です。

holdtime :アクティブ ルータまたはスタンバイ ルータのダウンが宣言されるまでの時間を秒単位で指定します。指定できる範囲は 1 ~ 255 秒で、デフォルトは 10 秒です。

ステップ 6

end

特権 EXEC モードに戻ります。

ステップ 7

show running-config

スタンバイ グループの設定を確認します。

ステップ 8

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

認証文字列を削除する場合は、 no standby [ group-number ] authentication string インターフェイス コンフィギュレーション コマンドを使用します。タイマーをデフォルト値に戻す場合は、 no sta ndby [ group-number ] timers hellotime holdtime インターフェイス コンフィギュレーション コマンドを使用します。

次に、グループ 1 のホット スタンバイ ルータを相互運用させるために必要な認証文字列として、 word を設定する例を示します。

Switch# configure terminal
Switch(config)# interface gigabitethernet0/1
Switch(config-if)# no switchport
Switch(config-if)# standby 1 authentication word
Switch(config-if)# end
 

次に、hello パケット インターバルが 5 秒、ルータがダウンしたと見なされるまでの時間が 15 秒となるように、スタンバイ グループ 1 のタイマーを設定する例を示します。

Switch# configure terminal
Switch(config)# interface gigabitethernet0/1
Switch(config-if)# no switchport
Switch(config-if)# standby 1 ip
Switch(config-if)# standby 1 timers 5 15
Switch(config-if)# end

ICMP リダイレクト メッセージの HSRP サポートのイネーブル化

ICMP リダイレクト メッセージは、HSRP が設定されたインターフェイス上で自動的にイネーブルになります。この機能により、HSRP を介した発信 ICMP リダイレクト メッセージがフィルタリングされます。その際、ネクスト ホップ IP アドレスが HSRP 仮想 IP アドレスに変更される場合があります。ICMP は、メッセージ パケットにより IP 処理に関するエラーなどの情報がレポートされるネットワーク レイヤ インターネット プロトコルです。ICMP は、エラー パケットをホストに送信するなどの診断機能も備えています。

スイッチで HSRP が実行されている場合、ホストでは HSRP グループ内のルータのインターフェイス(または実際の)MAC アドレスが検出されないようにしてください。ICMP によってホストがルータの実際の MAC アドレスへリダイレクトされて、そのルータに障害が発生した場合、ホストからのパケットは消失します。

詳細については、『 Cisco IOS IP Configuration Guide, Release 12.2 』を参照してください

HSRP 設定の表示

HSRP 設定を表示するには、特権 EXEC モードで次のコマンドを実行します。

show standby [ interface-id [ group ]] [ brief ] [ detail ]

スイッチ全体、特定のインターフェイス、HSRP グループ、またはインターフェイスの HSRP グループに関する HSRP 情報を表示できます。HSRP 情報の概要と詳細のどちらを表示するかを指定することもできます。デフォルト表示は detail です。HSRP グループが多数ある場合、修飾子を指定しないで show standby コマンドを使用すると、正確に表示されないことがあります。

次に、 show standby 特権 EXEC コマンドを実行して、2 つのスタンバイ グループ(グループ 1 およびグループ 100)の HSRP 情報を表示する例を示します。

Switch# show standby
VLAN1 - Group 1
Local state is Standby, priority 105, may preempt
Hellotime 3 holdtime 10
Next hello sent in 00:00:02.182
Hot standby IP address is 172.20.128.3 configured
Active router is 172.20.128.1 expires in 00:00:09
Standby router is local
Standby virtual mac address is 0000.0c07.ac01
Name is bbb
VLAN1 - Group 100
Local state is Active, priority 105, may preempt
Hellotime 3 holdtime 10
Next hello sent in 00:00:02.262
Hot standby IP address is 172.20.138.51 configured
Active router is local
Standby router is unknown expired
Standby virtual mac address is 0000.0c07.ac64
Name is test