Cisco ME 3400E イーサネット アクセス スイッチ ソ フトウェア コンフィギュレーション ガイド,12.2(52)SE
IEEE 802.1Q トンネリング、 VLAN マッピン グ、 およびレイヤ 2 プロトコル トンネリング の設定
IEEE 802.1Q トンネリング、VLAN マッピング、およびレイヤ 2 プロトコル トンネリングの設定
発行日;2012/01/30 | 英語版ドキュメント(2009/10/01 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 17MB) | フィードバック

目次

IEEE 802.1Q トンネリング、VLAN マッピング、およびレイヤ 2 プロトコル トンネリングの設定

802.1Q トンネリングの概要

802.1Q トンネリングの設定

802.1Q トンネリングのデフォルト設定

802.1Q トンネリング設定時の注意事項

ネイティブ VLAN

システム MTU

802.1Q トンネリングおよびその他の機能

802.1Q トンネリング ポートの設定

VLAN マッピングの概要

カスタマー VLAN のサービス プロバイダー VLAN へのマッピング

VLAN マッピングの設定

VLAN マッピングのデフォルト設定

VLAN マッピング設定時の注意事項

VLAN マッピングの設定

One-to-One マッピング

トランク ポートの従来の QinQ

トランク ポートの選択した QinQ

レイヤ 2 プロトコル トンネリングの概要

レイヤ 2 プロトコル トンネリングの設定

レイヤ 2 プロトコル トンネリングのデフォルト設定

レイヤ 2 プロトコル トンネリング設定時の注意事項

レイヤ 2 プロトコル トンネリングの設定

EtherChannel のレイヤ 2 トンネリングの設定

サービス プロバイダー エッジ スイッチの設定

カスタマー スイッチの設定

トンネリングおよびマッピング ステータスのモニタおよびメンテナンス

IEEE 802.1Q トンネリング、VLAN マッピング、およびレイヤ 2 プロトコル トンネリングの設定

Virtual Private Network(VPN; バーチャル プライベート ネットワーク)では、多くの場合にイーサネットベースの共有インフラストラクチャである企業規模の接続に、プライベート ネットワークと同じセキュリティ、プライオリティ、信頼性、管理の容易さが提供されます。トンネリングは、サービス プロバイダーのネットワークを越えて複数のカスタマーのトラフィックを運び、その他のカスタマーのトラフィックに影響を与えずに、それぞれのカスタマーの VLAN(仮想 LAN)およびレイヤ 2 プロトコルの設定を維持する必要があるサービス プロバイダー用に設計された機能です。Cisco ME 3400E イーサネット アクセス スイッチは、IEEE 802.1Q トンネリングおよびレイヤ 2 プロトコル トンネリングをサポートします。また、トランクポート上での VLAN マッピング(または VLAN ID トランスレーション)もサポートしています。


) この章で使用するコマンドの構文および使用方法の詳細については、このリリースのコマンド リファレンスを参照してください。


「802.1Q トンネリングの概要」

「802.1Q トンネリングの設定」

「VLAN マッピングの概要」

「VLAN マッピングの設定」

「レイヤ 2 プロトコル トンネリングの概要」

「レイヤ 2 プロトコル トンネリングの設定」

「トンネリングおよびマッピング ステータスのモニタおよびメンテナンス」

802.1Q トンネリングの概要

サービス プロバイダーのビジネス カスタマーには、多くの場合、サポートする VLAN ID および VLAN の数に固有の要件があります。同じサービス プロバイダー ネットワークのさまざまなカスタマーが必要とする VLAN 範囲は重複し、インフラストラクチャを通るカスタマーのトラフィックは混在することがあります。それぞれのカスタマーに VLAN ID の固有の範囲を割り当てると、カスタマーの設定が制限され、802.1Q 仕様の VLAN 制限(4096)を簡単に越えてしまうことがあります。

サービス プロバイダーは、802.1Q トンネリング(QinQ)機能を使用すると、単一の VLAN を使用して、複数の VLAN を含むカスタマーをサポートできます。カスタマーの VLAN ID(C-VLAN)は、同一 VLAN 内にあるように見えても保護され、さまざまなカスタマーのトラフィックは、サービス プロバイダー ネットワーク内で区別されます。802.1Q トンネリングを使用すると、VLAN 内の VLAN 階層を使用してタグ付きパケットにタグを再び付けることで、VLAN 容量が拡大します。802.1Q トンネリングをサポートするように設定したポートは、 トンネル ポート と呼ばれます。トンネリングを設定する場合は、トンネリング専用の VLAN ID にトンネル ポートを割り当てます。それぞれのカスタマーには個別のサービス プロバイダー VLAN ID(S-VLAN)が必要ですが、その VLAN ID ではすべてのカスタマーの VLAN がサポートされます。トンネル ポートでの 802.1Q トンネリングの設定は、従来の QinQ と呼ばれます。

適切な VLAN ID で通常どおりにタグ付けされたカスタマーのトラフィックは、カスタマー デバイスの 802.1Q トランク ポートからサービス プロバイダー側のエッジ スイッチのトンネル ポートに発信されます。カスタマー デバイスおよびエッジ スイッチの間のリンクは、片方が 802.1Q トランク ポートとして設定され、もう一方がトンネル ポートとして設定されているので非対称です。それぞれのカスタマーに固有のアクセス VLAN ID には、トンネル ポート インターフェイスを割り当てます。図 14-1 を参照してください。


) デフォルトでは、スイッチ上に設定された VLAN は、User Network Interface-Enhanced Network Interface(UNI-ENI)独立 VLAN です。UNI-ENI 独立 VLAN では、スイッチ上で 802.1Q トンネリングされたアクセス ポートが相互に独立しています。uni-vlan community VLAN コンフィギュレーション コマンドを使用して、VLAN を UNI-ENI コミュニティ VLAN に変更すると、これらのポート間でローカル スイッチングが行われます。UNI-ENI VLAN の詳細については、第 12 章「VLAN の設定」 を参照してください。


図 14-1 サービス プロバイダー ネットワークの 802.1Q トンネル ポート

 

カスタマーのトランク ポートからサービス プロバイダー側のエッジ スイッチのトンネル ポートに発信されるパケットには、通常、適切な VLAN ID とともに 802.1Q タグが付いています。タグ付きパケットはスイッチ内にそのまま残り、トランク ポートからサービス プロバイダー ネットワークに発信されると、カスタマーに固有の VLAN ID を含む 802.1Q タグの別のレイヤ( メトロタグ )でカプセル化されます。カスタマーの元の 802.1Q タグは、カプセル化されたパケット内で保護されます。このため、サービス プロバイダー ネットワークに入るパケットには、カスタマーのアクセス VLAN ID を含む外部(メトロ)タグ、および着信トラフィックのものである内部 VLAN ID という、2 重のタグが付いています。

2 重タグ パケットがサービス プロバイダー コア スイッチの別のトランク ポートに入ると、スイッチがパケットを処理する間に外部タグが外されます。パケットが、そのコア スイッチの別のトランク ポートを出るとき、同じメトロ タグがパケットに再び追加されます。図 14-2 は、2 重タグ パケットのタグ構造を示しています。


) 着信したカプセル化パケットによってトランク ポートが errdisable に変更されるため、レイヤ 2 プロトコル設定をトランク ポートから削除します。発信カプセル化 VTP(CDP および STP)パケットは同じトランクでドロップされます。


図 14-2 元の(通常)イーサネット パケット、802.1Q イーサネット パケット、2 重タグ イーサネット パケットの形式

 

パケットがサービス プロバイダー出力スイッチのトランク ポートに入ると、スイッチがパケットを内部処理する間に外部タグは再び外されます。しかし、パケットがエッジ スイッチのトンネル ポートからカスタマー ネットワークに送信されるとき、メトロ タグは追加されません。パケットは通常の 802.1Q タグ フレームとして送信され、カスタマー ネットワーク内で元の VLAN 番号は保護されます。

図 14-1 では、カスタマー A に VLAN 30 が、カスタマー B に VLAN 40 が割り当てられています。エッジ スイッチのトンネル ポートに入る、802.1Q タグが付いたパケットには、サービス プロバイダー ネットワークに入るとき、VLAN ID 30 または 40 のどちらかを含む外部タグ、および VLAN 100 などの元の VLAN 番号を含む内部タグが付いて 2 重タグになります。カスタマー A とカスタマー B の両方が、それぞれのネットワーク内で VLAN 100 を含んでいても、外部タグが異なるので、トラフィックはサービス プロバイダー ネットワーク内で区別されます。それぞれのカスタマーは、その他のカスタマーが使用する VLAN 番号スペース、およびサービス プロバイダー ネットワークが使用する VLAN 番号スペースから独立した、独自の VLAN 番号スペースを制御します。

発信トンネル ポートでは、カスタマーのネットワーク上の元の VLAN 番号が回復されます。トンネリングおよびタグ付けを複数のレベルにすることもできますが、このリリースのスイッチでは 1 レベルだけがサポートされます。

カスタマー ネットワークから発信されるトラフィックにタグ(ネイティブ VLAN フレーム)が付いていない場合、そのパケットのブリッジまたはルートは通常パケットとして行われます。エッジ スイッチのトンネル ポートを通ってサービス プロバイダー ネットワークに入るすべてのパケットは、タグが付いていないか、802.1Q ヘッダーですでにタグが付いているかに関係なく、タグなしパケットとして扱われます。パケットは、802.1Q トランク ポートでサービス プロバイダー ネットワークを通じて送信される場合、メトロ タグ VLAN ID(トンネル ポートのアクセス VLAN に設定)でカプセル化されます。メトロ タグのプライオリティ フィールドは、トンネル ポートで設定されているインターフェイス Class of Service(CoS; サービス クラス)プライオリティに設定されます (設定されていない場合、デフォルトはゼロです)。

802.1Q トンネリングの設定

「802.1Q トンネリングのデフォルト設定」

「802.1Q トンネリング設定時の注意事項」

「802.1Q トンネリングおよびその他の機能」

「802.1Q トンネリング ポートの設定」

802.1Q トンネリングのデフォルト設定

デフォルトでは、デフォルト switchport モードが access であるため、802.1Q トンネルはディセーブルです。すべての 802.1Q トランク ポートにおける 802.1Q ネイティブ VLAN パケットのタグ付けもディセーブルです。デフォルトでは、スイッチ上の VLAN は UNI-ENI 独立 VLAN です。

802.1Q トンネリング設定時の注意事項

802.1Q トンネリングを設定する場合は、カスタマー デバイスおよびエッジ スイッチの間で非対称リンクを常に使用する必要があります。カスタマー デバイスのポートを 802.1Q トランク ポートに、エッジ スイッチのポートをトンネル ポートとして設定してください。

トンネリングに使用する VLAN だけにトンネル ポートを割り当ててください。

ネイティブ VLAN および Maximum Transmission Unit(MTU; 最大伝送ユニット)の設定要件については、次のセクションで説明します。

ネイティブ VLAN

エッジ スイッチで 802.1Q トンネリングを設定する場合は、サービス プロバイダー ネットワークにパケットを送信するために、802.1Q トランク ポートを使用する必要があります。しかしサービス プロバイダー ネットワークのコアを通過するパケットは、802.1Q トランク、ISL(スイッチ間リンク)トランク、非トランキング リンクのいずれかで送信できます。コア スイッチで 802.1Q トランクを使用する場合、802.1Q トランクのネイティブ VLAN を、同一スイッチの非トランキング(トンネリング)ポートのネイティブ VLAN と照合させることはできません。ネイティブ VLAN のトラフィックに、802.1Q 送信トランク ポートでタグが付かないためです

図 14-3 を参照してください。VLAN 40 は、サービス プロバイダー ネットワークの入力エッジ スイッチ(スイッチ B)において、カスタマー X からの 802.1Q トランク ポートのネイティブ VLAN として設定されています。カスタマー X のスイッチ A は、VLAN 30 のタグ付きパケットを、アクセス VLAN 40 に属す、サービス プロバイダー ネットワークのスイッチ B の入力トンネル ポートに送信します。トンネル ポートのアクセス VLAN(VLAN 40)は、エッジ スイッチのトランク ポートのネイティブ VLAN(VLAN 40)と同じなので、トンネル ポートから受信したタグ付きパケットにメトロ タグは追加されません。パケットには VLAN 30 タグだけが付いて、サービス プロバイダー ネットワークで出力エッジ スイッチ(スイッチ C)のトランク ポートに送信され、出力スイッチ トンネルによってカスタマー Y に間違えて送信されます。

この問題の解決方法は次のとおりです。

サービス プロバイダー ネットワークのコア スイッチ間で ISL トランクを使用します。エッジ スイッチに接続されているカスタマー インターフェイスは 802.1Q トランクとしますが、コア レイヤのスイッチの接続には ISL トランクの使用を推奨します。Cisco ME スイッチでは、ISL トランクをサポートしていません。

vlan dot1q tag native グローバル コンフィギュレーション コマンドを使用し、ネイティブ VLAN を含む、802.1Q トランクから発信されるすべてのパケットがタグ付けされるようにエッジ スイッチを設定します。すべての 802.1Q トランクでネイティブ VLAN パケットにタグを付けるようにスイッチを設定した場合、スイッチはタグなしパケットを受信しますが、タグ付きパケットだけを送信します。

エッジ スイッチのトランク ポートのネイティブ VLAN ID が、カスタマー VLAN 範囲内でないことを確認します。たとえばトランク ポートが VLAN 100 ~ 200 のトラフィックを運ぶ場合は、この範囲以外の番号をネイティブ VLAN に割り当てます。

図 14-3 802.1Q トンネリングおよびネイティブ VLAN に潜在する問題

 

システム MTU

スイッチのトラフィックのデフォルト システム MTU は 1500 バイトです。 system mtu グローバル コンフィギュレーション コマンドを使用すると、1500 バイトより大きいフレームをサポートするようにファスト イーサネット ポートを設定できます。 system mtu jumbo グローバル コンフィギュレーション コマンドを使用すると、1500 バイトより大きいフレームをサポートするようにギガビット イーサネット ポートを設定できます。802.1Q トンネリング機能では、メトロ タグが追加されると、フレーム サイズが 4 バイト増加するので、スイッチ システム MTU サイズを最低 1504 バイトに増加して最大フレームを処理できるように、サービス プロバイダー ネットワークのすべてのスイッチを設定する必要があります。ギガビット イーサネット インターフェイスの最大許容システム MTU は 9000 バイトです。ファスト イーサネット インターフェイスの最大システム MTU は 1998 バイトです。

802.1Q トンネリングおよびその他の機能

802.1Q トンネリングはレイヤ 2 パケット スイッチングで適切に動作しますが、一部のレイヤ 2 機能およびレイヤ 3 スイッチングの間には非互換性があります。


) レイヤ 3 スイッチングは、スイッチ上でメトロ IP アクセス イメージが稼動している場合に限りサポートされます。


トンネル ポートはルーテッド ポートにできません。

802.1Q トンネル ポートを含む VLAN では IP ルーティングがサポートされません。トンネル ポートから受信したパケットは、レイヤ 2 情報だけに基づいて転送されます。トンネル ポートを含む Switch Virtual Interface(SVI; スイッチ仮想インターフェイス)でルーティングがイネーブルである場合、トンネル ポートから受信したタグなし IP パケットは、スイッチに認識されてルーティングされます。カスタマーは、ネイティブ VLAN でインターネットにアクセスできます。このアクセスが必要ない場合は、トンネル ポートを含む VLAN で SVI を設定しないでください。

トンネル ポートでは IP Access Control List(ACL; アクセス コントロール リスト)がサポートされません。

レイヤ 3 QoS(Quality Of Service)ACL およびレイヤ 3 に関連するその他の QoS 機能の情報は、トンネル ポートでサポートされません。MAC ベース QoS はトンネル ポートでサポートされます。

802.1Q 設定が EtherChannel ポート グループ内で矛盾しない場合、EtherChannel ポート グループにはトンネル ポートとの互換性があります。

802.1Q トンネル ポートでは、Unidirectional Link Detection(UDLD; 単一方向リンク検出)がサポートされます。

Port Aggregation Protocol(PAgP; ポート集約プロトコル)および Link Aggregation Control Protocol(LACP; リンク集約制御プロトコル)は、Network Node Interface(NNI; ネットワーク ノード インターフェイス)またはEnhanced Network Interface(ENI; 拡張ネットワーク インターフェイス)である 802.1Q トンネル ポート上でだけサポートされます。UNI では、PAgP および LACP をサポートしません。

802.1Q トンネル ポートでは、ループバック検出がサポートされます。

802.1Q トンネル ポートとして NNI または ENI ポートを設定すると、スパニングツリー Bridge Protocol Data Unit(BPDU; ブリッジ プロトコル データ ユニット)フィルタリングはインターフェイスで自動的にイネーブルになり、Cisco Discovery Protocol(CDP)および Layer Link Discovery Protocol(LLDP)はインターフェイスで自動的にディセーブルになります。UNI では、BPDU フィルタリング、CDP、または LLDP をサポートしていません。

UNI-ENI 独立 VLAN では、802.1Q トンネリングされたアクセス ポートは相互に独立していますが、UNI-ENI コミュニティ VLAN では、これらのポート間でローカル スイッチングが行われます。UNI-ENI VLAN の詳細については、 第 12 章「VLAN の設定」 を参照してください。

802.1Q トンネリング ポートの設定

802.1Q トンネル ポートとしてポート設定するには、特権 EXEC モードで次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface-id

トンネル ポートとして設定するインターフェイスのインターフェイス コンフィギュレーション モードを開始します。これは、カスタマー スイッチに接続するサービス プロバイダー ネットワークのエッジ ポートである必要があります。有効なインターフェイスには、物理インターフェイスおよびポートチャネル論理インターフェイス(ポート チャネル 1 ~ 48)が含まれます。

ステップ 3

no shutdown

必要に応じて、ポートをイネーブルにします。デフォルトでは、UNI および ENI はディセーブルに、NNI はイネーブルに設定されています。

ステップ 4

switchport access vlan vlan-id

デフォルト VLAN を指定します。これは、インターフェイスがトランキングを停止した場合に使用されます。この VLAN ID は特定カスタマーに固有です。

(注) VLAN が UNI-ENI 独立 VLAN である場合、スイッチの UNI と ENI 間でのローカル スイッチングは行われません。VLAN が UNI-ENI コミュニティ VLAN である場合、ローカル スイッチングが許可されます。

ステップ 5

switchport mode dot1q-tunnel

802.1Q トンネル ポートとしてインターフェイスを設定します。

ステップ 6

exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 7

vlan dot1q tag native

(任意)すべての 802.1Q トランク ポートでネイティブ VLAN パケットのタグ付けをイネーブルにするようにスイッチを設定します。これを設定せず、カスタマー VLAN ID がネイティブ VLAN と同じである場合、トランク ポートはメトロ タグを適用せず、パケットは誤った宛先に送信される可能性があります。

ステップ 8

end

特権 EXEC モードに戻ります。

ステップ 9

show running-config

show dot1q-tunnel

802.1Q トンネリング用に設定したポートを表示します。

トンネリング モードになっているポートを表示します。

ステップ 10

show vlan dot1q tag native

802.1Q ネイティブ VLAN タグ付けステータスを表示します。

ステップ 11

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

access のデフォルト状態にポートを戻すには、 no switchport mode dot1q-tunnel インターフェイス コンフィギュレーション コマンドを使用します。ネイティブ VLAN パケットのタグ付けをディセーブルにするには、 no vlan dot1q tag native グローバル コンフィギュレーション コマンドを使用します。

以下は、トンネル ポートとしてインターフェイスを設定してネイティブ VLAN パケットのタグ付けをイネーブルにし、設定を確認する方法の例です。この設定では、ギガビット イーサネット インターフェイス 2 に接続されているカスタマーの VLAN ID が VLAN 22 になっています。この VLAN は、デフォルトで UNI-ENI 独立 VLAN です。

Switch(config)# interface gigabitethernet0/2
Switch(config-if)# switchport access vlan 22
% Access VLAN does not exist. Creating vlan 22
Switch(config-if)# switchport mode dot1q-tunnel
Switch(config-if)# exit
Switch(config)# vlan dot1q tag native
Switch(config)# end
Switch# show dot1q-tunnel interface gigabitethernet0/2
dot1q-tunnel mode LAN Port(s)
-----------------------------
Gi0/1
Switch# show vlan dot1q tag native
dot1q native vlan tagging is enabled

VLAN マッピングの概要

S-VLAN を設定するもう 1 つの方法として、カスタマー ネットワークに接続しているトランク ポートに VLAN マッピング(または VLAN ID トランスレーション)を設定して、カスタマー VLAN をサービス プロバイダーの VLAN にマッピングします。ポートに入るパケットは、パケットのポート番号と元のカスタマー VLAN-ID(C-VLAN)に基づいて、サービス プロバイダーの VLAN(S-VLAN)にマッピングされます。

通常のメトロ展開では、カスタマー ネットワーク側の VLAN マッピングは UNI または ENI で行われます。ただし、ネットワーク ノート インターフェイス(NNI)で VLAN マッピングを設定できないわけではありません。

VLAN ID は受信時に S-VLAN にマッピングされるため、ME-3400E では、転送はすべて C-VLAN 情報ではなく S-VLAN 情報を使用して実行されます。


) VLAN マッピングが設定されているポートに機能を設定する場合は常に、カスタマー VLAN-ID(C-VLAN)ではなく、S-VLAN(変換された VLAN)ID が使用されます。


VLAN マッピングが設定されているインターフェイスでは、指定された C-VLAN パケットはポートに入るとき、指定された S-VLAN にマッピングされます。パケットがポートから出る場合も同様に、カスタマー C-VLAN にマッピングが行われます。

スイッチは UNI トランク ポートにおける次の種類の VLAN マッピングをサポートします。

One-to-One VLAN マッピング。ポートへの入出時に実行され、802.1Q タグの C-VLAN ID が S-VLAN ID にマッピングされます。他のすべての VLAN ID のパケットがドロップされるよう指定することもできます。

選択した QinQ は、UNI に入る指定のカスタマー VLAN を指定の S-VLAN ID にマッピングします。S-VLAN は、変更されない受信 C-VLAN に追加されます。他のすべての VLAN ID を転送するトラフィックがドロップされるよう指定することもできます。

従来の 802.1Q トンネリング(QinQ)は、ポートの 1 つの S-VLAN ID に対して C-VLAN ID への All-to-one バンドリングを実行します。S-VLAN は、変更されない受信 C-VLAN に追加されます。UNI を従来の QinQ の 802.1Q トンネルとして設定することも、またはより柔軟な実装のトランク ポートに選択した QinQ を設定することもできます。マッピングは、ポートの入出時に実行されます。ポートのすべてのパケットは指定の S-VLAN にバンドルされます。


) タグなしパケットはトランク ネイティブ VLAN のスイッチに入り、マッピングされません。


Quality of Service(QoS)については、スイッチは C-CoS または C-DSCP および S-CoS の間で柔軟なマッピングを行い、従来の QinQ によるトラフィックまたは選択した QinQ VLAN マッピングでは内部 CoS から外部 CoS にマッピングします。詳細については、「802.1Q トンネリング CoS マッピング」を参照してください。

カスタマー VLAN のサービス プロバイダー VLAN へのマッピング

図 14-4 では、カスタマーがサービス プロバイダー ネットワークの両端の複数のサイトで同じ VLAN を使用する場合のトポロジを示します。サービス プロバイダーのバックボーンを通るパケットについて、カスタマー VLAN ID をサービス プロバイダー VLAN ID にマッピングします。カスタマー VLAN ID は、サービス プロバイダー バックボーンの一方の端で取得され、他のカスタマーサイトで使用されます。サービス プロバイダー ネットワークのそれぞれの側のカスタマー接続ポートで同じ VLAN マッピング セットを設定します。

One-to-One マッピング、従来の QinQ、または選択した QinQ を使用してカスタマー VLAN 1 ~ 5 をサービス プロバイダー VLAN にマッピングする設定手順については、例を参照してください。

図 14-4 カスタマー VLAN のマッピング

 

VLAN マッピングの設定

「VLAN マッピングのデフォルト設定」

「VLAN マッピング設定時の注意事項」

「VLAN マッピングの設定」

VLAN マッピングのデフォルト設定

デフォルトでは、VLAN マッピングは設定されていません。

VLAN マッピング設定時の注意事項

従来の QinQ では 802.1Q トンネル ポートを使用します。802.1Q トランク ポートには、One-to-One VLAN マッピングと選択した QinQ を設定します。

カスタマー トラフィックが混在しないようにするためには、トランク ポートに従来の Q-in-Q を設定する場合、トランク ポートの許可 VLAN としてサービス プロバイダー S-VLAN ID を設定する必要があります。

VLAN マッピングが設定された ME-3400E インターフェイスでは、スイッチに入るトラフィックで S-VLAN へのマッピングが行われます。そのため、VLAN マッピングが設定されているインターフェイスにその他の機能を設定する場合、VLAN マッピングとイーサネット E-LMI を設定する場合を除いて、S-VLAN ID を使用する必要があります。インターフェイスに E-LMI を設定する場合、C-VLAN を使用して ethernet lmi ce-vlan map vlan-id サービス インスタンス コンフィギュレーション モード コマンドを入力します。

EtherChannel に VLAN マッピングを設定すると、マッピングはポート チャネルのすべてのポートに適用されます。

ソース ポートがトンネル ポートとして設定されている、またはソース ポートに 1-to-2 マッピングが設定されている場合、SPAN 宛先ポートにカプセル化レプリケーションは設定できません。カプセル化レプリケーションは 1-to-1 VLAN マッピングでサポートされています。

VLAN マッピングに使用するスイッチ リソースを決定するには、 show vlan mapping usage または show platform vlan mapping 特権 EXEC コマンドを入力します。

VLAN マッピングの設定

次の手順では、トランク ポートに各種類の VLAN マッピングを設定する方法を示します。設定を確認するには、 show interfaces interface-id vlan mapping または show vlan mapping の各特権 EXEC コマンドを入力します。これらのコマンドの構文については、「トンネリングおよびマッピング ステータスのモニタおよびメンテナンス」を参照してください。ここで示すコマンドの詳細については、このリリースのコマンド リファレンスを参照してください。

One-to-One マッピング

One-to-One VLAN マッピングを設定して VLAN ID をサービス プロバイダーの VLAN ID にマッピングするには、特権 EXEC モードで次の手順を実行します。指定されたC-VLAN ID と S-VLAN ID の組み合せが明示的にマッピングされていない限り、トラフィックがドロップされるよう指定するには default drop キーワードを使用できます。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface-id

サービス プロバイダー ネットワークに接続するインターフェイスのインターフェイス コンフィギュレーション モードを開始します。物理インターフェイスまたは EtherChannel ポート チャネルを入力できます。

ステップ 3

switchport mode trunk

インターフェイスをトランク ポートとして設定します。

ステップ 4

switchport vlan mapping vlan-id translated-id

マッピングする VLAN ID を入力します。

vlan-id: カスタマー ネットワークからスイッチに入るカスタマー VLAN ID(C-VLAN)。指定できる範囲は 1 ~ 4094 です。

translated-id: 割り当てられた VLAN ID(S-VLAN)。指定できる範囲は 1 ~ 4094 です。

ステップ 5

switchport vlan mapping default drop

(任意)ステップ 4 で指定した VLAN に一致しない場合、ポートのすべてのパケットがドロップされるよう指定します。

ステップ 6

end

特権 EXEC モードに戻ります。

ステップ 7

show vlan mapping

設定を確認します。

ステップ 8

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

VLAN マッピング情報を削除するには、no switchport vlan mapping vlan-id translated-id コマンドを使用します。 no switchport vlan mapping all を入力すると、すべてのマッピング情報が削除されます。

この例では、図 14-4 で示すように、カスタマー ネットワークの VLAN ID 1 ~ 5 をサービス プロバイダー ネットワークの VLAN ID 101 ~ 105 にマッピングする方法を示します。スイッチ A とスイッチ B のポートに次の同じ VLAN マッピング コマンドを設定します。その他の VLAN ID のトラフィックはドロップされます。

Switch(config)# interface gigabiethernet0/1
Switch(config-if)# switchport vlan mapping 1 101
Switch(config-if)# switchport vlan mapping 2 102
Switch(config-if)# switchport vlan mapping 3 103
Switch(config-if)# switchport vlan mapping 4 104
Switch(config-if)# switchport vlan mapping 4 105
Switch(config-if)# switchport vlan mapping default drop
Switch(config-if)# exit
 

前の例では、サービス プロバイダー ネットワークの入力側でカスタマー ネットワークの VLAN ID 1 ~ 5 は、サービス プロバイダー ネットワーク内の VLAN ID 101 ~ 105 にそれぞれマッピングされます。サービス プロバイダー ネットワークの出力側でサービス プロバイダー ネットワークの VLANs 101 ~ 105 は、カスタマー ネットワークの VLAN ID 1 ~ 5 にそれぞれマッピングされます。

トランク ポートの従来の QinQ

トランク ポートまたはデフォルトのトンネリングで従来の QinQ に VLAN マッピングを設定するには、特権 EXEC モードで次の手順を実行します。デフォルトでトンネリングを設定すると、ポートのすべてのパケットが、設定された S-VLAN にバンドルされます。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface-id

サービス プロバイダー ネットワークに接続するインターフェイスのインターフェイス コンフィギュレーション モードを開始します。物理インターフェイスまたは EtherChannel ポート チャネルを入力できます。

ステップ 3

switchport mode trunk

インターフェイスをトランク ポートとして設定します。

ステップ 4

switchport trunk allowed vlan vlan-id

サービス プロバイダー ネットワークの外部 VLAN (S-VLAN)がインターフェイスで許可されるよう設定します。これは、次のステップで入力されるものと同じ外部 VLAN ID である必要があります。

ステップ 5

switchport vlan mapping default dot1q-tunnel outer vlan-id

ポートに入るすべてのパケットが、指定された S-VLAN にバンドルされるよう、VLAN マッピングを設定します。

outer-vlan-id: サービス プロバイダー ネットワークの外部 VLAN ID(S-VLAN)を入力します。指定できる範囲は 1 ~ 4094 です。

ステップ 6

end

特権 EXEC モードに戻ります。

ステップ 7

show interfaces interface-id vlan mapping

設定を確認します。

ステップ 8

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

VLAN マッピング設定を削除するには、no switchport vlan mapping tunnel default outer vlan-id コマンドを使用します。 no switchport vlan mapping all を入力すると、すべてのマッピング情報が削除されます。

次の例では、ポートのすべてのトラフィックをバンドルして、S-VLAN ID が 100 のスイッチを出るようにする方法を示します。

Switch(config)# interface gigabiethernet0/1
Switch(config-if)# switchport mode trunk
Switch(config-if)# switchport trunk allowed 100
Switch(config-if)# switchport vlan mapping default dot1q-tunnel 100
Switch(config-if)# exit

トランク ポートの選択した QinQ

トランク ポートで、選択した QinQ に VLAN マッピングを設定するには、特権 EXEC モードで次の手順を実行します。One-to-One マッピングと選択した QinQ は同じインターフェイスに設定できますが、両方の設定で同じ C-VLAN ID を使用できない点に注意してください。指定されたC-VLAN ID と S-VLAN ID の組み合せが明示的にマッピングされていない限り、トラフィックがドロップされるよう指定するには、キーワード default drop を使用できます。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface-id

サービス プロバイダー ネットワークに接続するインターフェイスのインターフェイス コンフィギュレーション モードを開始します。物理インターフェイスまたは EtherChannel ポート チャネルを入力できます。

ステップ 3

switchport mode trunk

インターフェイスをトランク ポートとして設定します。

ステップ 4

switchport vlan mapping vlan-id dot1q-tunnel outer vlan-id

マッピングする VLAN ID を入力します。

vlan-id :カスタマー ネットワークからスイッチに入るカスタマー VLAN ID(C-VLAN)。指定できる範囲は 1 ~ 4094 です。VLAN-ID の文字列を入力できます。

outer-vlan-id :サービス プロバイダー ネットワークの外部 VLAN ID(S-VLAN)を入力します。指定できる範囲は 1 ~ 4094 です。

ステップ 5

switchport vlan mapping default drop

(任意)ステップ 4 で指定した VLAN に一致しない場合、ポートのすべてのパケットがドロップされるよう指定します。

ステップ 6

end

特権 EXEC モードに戻ります。

ステップ 7

show interfaces interface-id vlan mapping

設定を確認します。

ステップ 8

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

VLAN マッピング設定を削除するには、no switchport vlan mapping vlan-id dot1q-tunnel outer vlan-id コマンドを使用します。 no switchport vlan mapping all を入力すると、すべてのマッピング情報が削除されます。

次の例では、ポートに選択した QinQ マッピングを設定して、C-VLAN ID が 1 ~ 5 のトラフィックが、S-VLAN ID が 100 であるスイッチに入るようにする方法を示します。その他の VLAN ID のトラフィックはドロップされます。

Switch(config)# interface gigabiethernet0/1
Switch(config-if)# switchport vlan mapping 1-5 dot1q-tunnel 100
Switch(config-if)# switchport vlan mapping default drop
Switch(config-if)# exit

レイヤ 2 プロトコル トンネリングの概要

サービス プロバイダー ネットワークを越えて接続されている、さまざまなサイトに散在するカスタマーは、さまざまなレイヤ 2 プロトコルを使用してトポロジをスケールし、すべてのリモート サイトおよびローカル サイトを含める必要があります。STP は適切に動作させる必要があり、すべての VLAN は、サービス プロバイダー ネットワークを越えたローカル サイトおよびすべてのリモート サイトを含む、適切なスパニングツリーを構築する必要があります。CDP では、隣接するシスコ製デバイスをローカル サイトおよびリモート サイトから検出する必要があります。VLAN Trunking Protocol(VTP; VLANトランキング プロトコル)では、VTP に参加しているカスタマー ネットワークのすべてのサイトで矛盾しない VLAN 設定を提供する必要があります。


) Cisco ME スイッチでは、VTP をサポートしていません。デフォルトでは、CDP および STP は NNI ではサポートされておらず、ENI でイネーブルにできます。ただし、レイヤ 2 プロトコル トンネリングはスイッチ上のすべてのポートでサポートされます。


プロトコル トンネリングがイネーブルである場合、サービス プロバイダー ネットワークの着信側のエッジ スイッチでは、特殊 MAC アドレスでレイヤ 2 プロトコル パケットがカプセル化され、サービス プロバイダー ネットワークを越えて送信されます。ネットワークのコア スイッチでは、このパケットが処理されずに通常のパケットとして転送されます。CDP、STP、VTP のレイヤ 2 Protocol Data Unit(PDU; プロトコル データ ユニット)は、サービス プロバイダー ネットワークをまたがり、サービス プロバイダー ネットワークの発信側のカスタマー スイッチに配信されます。同一パケットは同じ VLAN のすべてのカスタマー ポートで受信され、次のような結果になります。

それぞれのカスタマー サイトのユーザは STP を適切に実行でき、すべての VLAN では、ローカル サイトだけではなく、すべてのサイトからのパラメータに基づいて、正しいスパニングツリーが構築されます。

CDP では、サービス プロバイダー ネットワークによって接続されているその他のシスコ製デバイスに関する情報が検出されて表示されます。

VTP ではカスタマー ネットワーク全体で矛盾しない VLAN 設定が提供され、VTP をサポートするサービス プロバイダーを通してすべてのスイッチに伝播されます。


) サードパーティ ベンダーとの相互運用性を提供するには、レイヤ 2 プロトコル トンネル バイパス機能を使用します。バイパス モードでは、プロトコル トンネリングの制御方法が異なるベンダー スイッチに制御 PDU が透過的に転送されます。バイパス モードを実装するには、出力トランク ポートでレイヤ 2 プロトコル トンネリングをイネーブルにします。トランク ポートでレイヤ 2 プロトコル トンネリングがイネーブルである場合、カプセル化されたトンネル MAC アドレスは削除され、プロトコル パケットには通常の MAC アドレスが割り当てられます。


レイヤ 2 プロトコル トンネリングは個別に使用できます。レイヤ 2 プロトコル トンネリングでは、802.1Q トンネリングを向上させることができます。802.1Q トンネリング ポートでプロトコル トンネリングをイネーブルにしていない場合、サービス プロバイダー ネットワークの受信側のリモート スイッチでは PDU を受信せず、STP、CDP、VTP を適切に実行できません。プロトコル トンネリングがイネーブル である 場合、それぞれのカスタマー ネットワークのレイヤ 2 プロトコルは、サービス プロバイダー ネットワーク内で動作しているものから完全に区別されます。802.1Q トンネリングでサービス プロバイダー ネットワークを通してトラフィックを送信する、さまざまなサイトのカスタマー スイッチでは、カスタマー VLAN が完全に認識されます。802.1Q トンネリングを使用しない場合は、アクセスまたはトランク ポートでカスタマー スイッチに接続し、サービス プロバイダーのアクセス ポートでトンネリングをイネーブルにすることで、レイヤ 2 プロトコル トンネリングをイネーブルにできます。

たとえば 図 14-5の場合、カスタマー X には同一 VLAN に 4 つのスイッチがあり、サービス プロバイダー ネットワークで接続されています。ネットワークで PDU がトンネルされない場合、ネットワークの向こう側のスイッチでは、STP、CDP、VTP を適切に実行できません。たとえばカスタマー X、サイト 1 にあるスイッチの VLAN の STP では、サイト 2 のカスタマー X のスイッチに基づくコンバージェンス パラメータが考慮されずに、そのサイトにあるスイッチでスパニング ツリーが構築されます。これにより、図 14-6のようなトポロジとなります。

図 14-5 レイヤ 2 プロトコル トンネリング

 

図 14-6 適切なコンバージェンスを含まないレイヤ 2 ネットワーク トポロジ

 

サービス プロバイダー ネットワークでは、レイヤ 2 プロトコル トンネリングを使用し、ポイントツーポイント ネットワーク トポロジをエミュレートして、EtherChannel の作成を向上させることができます。サービス プロバイダー スイッチでプロトコル トンネリング(PAgP または LACP)をイネーブルにすると、リモート カスタマー スイッチでは PDU が受信され、EtherChannel の自動作成をネゴシエーションできるようになります。

たとえば 図 14-7の場合、カスタマー A には同一 VLAN に 2 つのスイッチがあり、サービス プロバイダー ネットワークで接続されています。ネットワークで PDU がトンネリングされると、ネットワークの向こう側のスイッチでは、専用回線を必要とせずに、EtherChannel の自動作成をネゴシエーションできます。手順については、「EtherChannel のレイヤ 2 トンネリングの設定」を参照してください。

図 14-7 EtherChannel のレイヤ 2 プロトコル トンネリング

 

レイヤ 2 プロトコル トンネリングの設定

サービス プロバイダー ネットワークのエッジ スイッチで、カスタマーに接続されているポートにおいて、レイヤ 2 プロトコル トンネリングをプロトコルごとにイネーブルにできます。カスタマー スイッチに接続されているサービス プロバイダー エッジ スイッチでは、トンネリング処理が実行されます。エッジ スイッチ トンネル ポートは、カスタマーの 802.1Q トランク ポートに接続します。エッジ スイッチ アクセス ポートは、カスタマー アクセス ポートに接続します。カスタマー スイッチに接続されているエッジ スイッチでは、トンネリング処理が実行されます。

アクセス ポート、トンネル ポート、またはトランク ポートとして設定されているポートでは、レイヤ 2 プロトコル トンネリングをイネーブルにできます。スイッチでは、CDP、STP、VTP のレイヤ 2 プロトコル トンネリングがサポートされます。ポイントツーポイント ネットワーク トポロジのエミュレートの場合は、PAgP、LACP、UDLD のプロトコルもサポートされます。スイッチでは、LLDP のレイヤ 2 プロトコル トンネリングがサポートされません。


注意 PAgP、LACP、UDLD プロトコル トンネリングでは、ポイントツーポイント トポロジのエミュレートだけが目的です。設定を間違えたことによりトンネリング パケットが多くのポートに送信されると、ネットワーク障害が発生する可能性があります。

レイヤ 2 プロトコルがイネーブルになっているポートでサービス プロバイダーの着信エッジ スイッチに入ったレイヤ 2 PDU が、トランク ポートからサービス プロバイダー ネットワークに出る場合、スイッチでは、カスタマー PDU 宛先 MAC アドレスが、周知のシスコ固有のマルチキャスト アドレス(01-00-0c-cd-cd-d0)で上書きされます。802.1Q トンネリングがイネーブルである場合、パケットにはタグが 2 重に付きます。外部タグはカスタマーのメトロ タグであり、内部タグはカスタマーの VLAN タグです。コア スイッチでは内部タグが無視され、同じメトロ VLAN のすべてのトランク ポートにパケットが転送されます。発信側のエッジ スイッチでは、適切なレイヤ 2 プロトコル情報および MAC アドレス情報が復元され、同じメトロ VLAN のすべてのレイヤ 2 プロトコル対応アクセス ポート、トンネル ポートおよびトランク ポートにパケットが転送されます。このため、レイヤ 2 PDU はそのまま残り、サービス プロバイダー インフラストラクチャを越えてカスタマー ネットワークの反対側に配信されます。

図 14-5を参照してください。カスタマー X およびカスタマー Y が、それぞれアクセス VLAN 30 および 40 になっています。非対称リンクにより、サイト 1 のカスタマーは、サービス プロバイダー ネットワークのエッジ スイッチに接続されています。サイト 1 のカスタマー Y からスイッチ B に発信されたレイヤ 2 PDU(たとえば BPDU)は、周知の MAC アドレスが宛先 MAC アドレスになっている 2 重タグ パケットとしてインフラストラクチャに転送されます。この 2 重タグ パケットには、40 というメトロ VLAN タグ、および VLAN 100 などの内部 VLAN タグが付いています。2 重タグ パケットがスイッチ D に入ると、外部 VLAN タグ 40 が外されて周知の MAC アドレスがそれぞれのレイヤ 2 プロトコル MAC アドレスで置き換わり、パケットは、VLAN 100 の 1 重タグ フレームとしてサイト 2 のカスタマー Y に送信されます。

カスタマー スイッチのアクセス ポートまたはトランク ポートに接続されているエッジ スイッチのアクセス ポートでも、レイヤ 2 プロトコル トンネリングをイネーブルにできます。この場合は、カプセル化プロセスとカプセル開放プロセスが、前の段落で説明したものと同じですが、パケットはサービス プロバイダー ネットワークで 2 重タグになりません。カスタマー固有のアクセス VLAN タグの 1 重タグになります。

ここでは、次の設定情報について説明します。

「レイヤ 2 プロトコル トンネリングのデフォルト設定」

「レイヤ 2 プロトコル トンネリング設定時の注意事項」

「レイヤ 2 プロトコル トンネリングの設定」

「EtherChannel のレイヤ 2 トンネリングの設定」

レイヤ 2 プロトコル トンネリングのデフォルト設定

表 14-1 に、レイヤ 2 プロトコル トンネリングのデフォルト設定を示します。

 

表 14-1 レイヤ 2 イーサネット インターフェイス VLAN のデフォルト設定

機能
デフォルト設定

レイヤ 2 プロトコル トンネリング

ディセーブル。

シャットダウンしきい値

未設定

ドロップしきい値

未設定

CoS 値

インターフェイスに CoS 値が設定されている場合、その値を使用してレイヤ 2 プロトコル トンネリングに BPDU CoS 値を設定します。インターフェイス レベルで CoS 値が設定されていない場合、L2 プロトコル トンネリング BPDU の CoS マーキングのデフォルト値は 5 になります。これは、データ トラフィックには適用されません。

レイヤ 2 プロトコル トンネリング設定時の注意事項

以下は、レイヤ 2 プロトコル トンネリングの設定時の注意事項および動作特性です。

スイッチでは、CDP、STP(Multiple STP [MSTP]を含む)、VTP のトンネリングがサポートされます。プロトコル トンネリングはデフォルトでディセーブルになっていますが、802.1Q トンネル ポート、アクセス ポート、またはトランク ポートでプロトコルごとにイネーブルにできます。

サービス プロバイダー ネットワークの発信側のエッジ スイッチでは、適切なレイヤ 2 プロトコル情報および MAC アドレス情報が復元され、同じメトロ VLAN のすべてのレイヤ 2 プロトコル対応トンネル ポート、アクセス ポート、トランク ポートにパケットが転送されます。

サードパーティ ベンダー スイッチとの相互運用性のため、スイッチではレイヤ 2 プロトコルトンネル バイパス機能がサポートされます。バイパス モードでは、プロトコル トンネリングの制御方法が異なるベンダー スイッチに制御 PDU が透過的に転送されます。スイッチの入力ポートでレイヤ 2 プロトコル トンネルがイネーブルである場合は、出力トランク ポートにより、トンネリングされたパケットが特殊なカプセル化で転送されます。出力トランク ポートでもレイヤ 2 プロトコル トンネリングをイネーブルにすると、この動作がバイパスされて、スイッチによって、処理や修正が行われずに制御 PDU が転送されます。

スイッチでは、ポイントツーポイント ネットワーク トポロジのエミュレートの場合、PAgP、LACP、UDLD のトンネリングがサポートされます。プロトコル トンネリングはデフォルトでディセーブルになっていますが、802.1Q トンネル ポート、アクセス ポート、またはトランク ポートでプロトコルごとにイネーブルにできます。

PAgP トンネリングまたは LACP トンネリングの場合は、リンク障害検出を高速にするため、インターフェイスで UDLD もイネーブルにするよう推奨します。

PAgP パケット、LACP パケット、UDLD パケットのうちいずれかのレイヤ 2 プロトコル トンネリングでは、ループバック検出がサポートされません。

802.1Q 設定が EtherChannel ポート グループ内で矛盾しない場合、EtherChannel ポート グループにはトンネル ポートとの互換性があります。

独自の宛先 MAC アドレスでカプセル化された PDU が、レイヤ 2 トンネリングがイネーブルになっているトンネル ポート、アクセス ポート、またはトランク ポートから受信される場合、トンネル ポートは、ループを防止するためにシャットダウンされます。このポートは、プロトコル用に設定されたシャットダウンしきい値に達した場合にもシャットダウンされます。 shutdown コマンドに続けて no shutdown コマンドを入力すると、ポートを再び手動でイネーブルにできます。errdisable recovery がイネーブルの場合は、指定された間隔で動作が再試行されます。

カプセル化が解除された PDU だけがカスタマー ネットワークに転送されます。サービス プロバイダー ネットワーク上で動作しているスパニングツリー インスタンスでは、BPDU がトンネル ポートに転送されません。CDP パケットはトンネル ポートから転送されません。

インターフェイスでプロトコル トンネリングがイネーブルの場合は、カスタマー ネットワークによって生成された PDU 用に、プロトコルごとのシャットダウンしきい値やポートごとのシャットダウンしきい値を設定できます。制限を越えると、ポートはシャットダウンされます。QoS ACL およびポリシー マップをトンネル ポートで使用すると、BPDU レートを制限することもできます。

インターフェイスでプロトコル トンネリングがイネーブルである場合は、カスタマー ネットワークによって生成された PDU 用に、プロトコルごとの廃棄しきい値やポートごとの廃棄しきい値を設定できます。制限を越えると、ポートが PDU を受信するレートが廃棄しきい値未満になるまで、ポートで PDU が廃棄されます。

トンネリングされた PDU(とくに STP BPDU)は、カスタマーの仮想ネットワークが正しく動作するためにすべてのリモート サイトに配信される必要があるので、同じトンネル ポートから受信されるデータ パケットよりも PDU のプライオリティをサービス プロバイダー ネットワーク内で高くできます。デフォルトの場合、PDU ではデータ パケットと同じ CoS 値が使用されます。

レイヤ 2 プロトコル トンネリングの設定

レイヤ 2 プロトコル トンネリング用にポートを設定するには、特権 EXEC モードで次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface-id

インターフェイス コンフィギュレーション モードを開始し、トンネル ポートとして設定するインターフェイスを入力します。これは、カスタマー スイッチに接続するサービス プロバイダー ネットワークのエッジ ポートである必要があります。有効なインターフェイスは、物理インターフェイスおよびポートチャネル論理インターフェイス(ポート チャネル 1 ~ 48)です。

ステップ 3

no shutdown

必要に応じて、ポートをイネーブルにします。デフォルトでは、UNI および ENI はディセーブルに、NNI はイネーブルに設定されています。

ステップ 4

switchport mode access
または
switchport mode dot1q-tunnel

または
switchport mode trunk

アクセス ポート、802.1Q トンネル ポート、またはトランク ポートとしてインターフェイスを設定します。デフォルトのスイッチ ポート モードは、access です。

ステップ 5

l2protocol-tunnel [ cdp | stp | vtp ]

目的のプロトコルのプロトコル トンネリングをイネーブルにします。キーワードを入力しない場合、トンネリングは 3 つすべてのレイヤ 2 プロトコルでイネーブルになります。

ステップ 6

l2protocol-tunnel shutdown-threshold [ cdp | stp | vtp ] value

(任意)カプセル化用に 1 秒間に受信するパケット数のしきい値を設定します。設定したしきい値を超えると、インターフェイスはディセーブルになります。プロトコル オプションを指定しない場合、しきい値は、それぞれのトンネリングされたレイヤ 2 プロトコル タイプに適用されます。指定できる範囲は 1 ~ 4096 です。デフォルトでは、しきい値 が設定されていません。

(注) このインターフェイスで廃棄しきい値も設定する場合、シャットダウンしきい値は、廃棄しきい値以上とする必要があります。

ステップ 7

l2protocol-tunnel drop-threshold [ cdp | stp | vtp ] value

(任意)カプセル化用に 1 秒間に受信するパケット数のしきい値を設定します。設定したしきい値を超えると、インターフェイスによってパケットが廃棄されます。プロトコル オプションを指定しない場合、しきい値は、それぞれのトンネリングされたレイヤ 2 プロトコル タイプに適用されます。指定できる範囲は 1 ~ 4096 です。デフォルトでは、しきい値 が設定されていません。

このインターフェイスでシャットダウンしきい値も設定する場合、廃棄しきい値は、シャットダウンしきい値以下でなければなりません。

ステップ 8

exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 9

errdisable recovery cause l2ptguard

(任意)インターフェイスを再びイネーブルにして再試行できるようにするため、レイヤ 2 最大レート エラーからの回復メカニズムを設定します。errdisable recovery はデフォルトでディセーブルになっています。イネーブルにした場合、デフォルトの間隔は 300 秒です。

ステップ 10

l2protocol-tunnel cos value

(任意)トンネリングされたすべてのレイヤ 2 PDU の CoS 値を設定します。範囲は 0 ~ 7 です。デフォルトは、インターフェイスのデフォルト CoS 値です。設定されていない場合、デフォルトは 5 です。

ステップ 11

end

特権 EXEC モードに戻ります。

ステップ 12

show l2protocol

設定されているプロトコル、しきい値、カウンタを含めた、スイッチのレイヤ 2 トンネル ポートを表示します。

ステップ 13

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

いずれかのレイヤ 2 プロトコルまたは 3 つすべてのレイヤ 2 プロトコルのプロトコル トンネリングをディセーブルにするには、 no l2protocol-tunnel [ cdp | stp | vtp ] インターフェイス コンフィギュレーション コマンドを使用します。シャットダウンしきい値および廃棄しきい値をデフォルト設定に戻すには、 no l2protocol-tunnel shutdown-threshold [ cdp | stp | vtp ] コマンドおよび no l2protocol-tunnel drop-threshold [ cdp | stp | vtp ] コマンドを使用します。

次は、CDP、STP、VTP のレイヤ 2 プロトコル トンネリングを設定し、設定を確認する方法の例です。

Switch(config)# interface gigatethernet0/1
Switch(config-if)# l2protocol-tunnel cdp
Switch(config-if)# l2protocol-tunnel stp
Switch(config-if)# l2protocol-tunnel vtp
Switch(config-if)# l2protocol-tunnel shutdown-threshold 1500
Switch(config-if)# l2protocol-tunnel drop-threshold 1000
Switch(config-if)# exit
Switch(config)# l2protocol-tunnel cos 7
Switch(config)# end
Switch# show l2protocol
COS for Encapsulated Packets: 7
Port Protocol Shutdown Drop Encapsulation Decapsulation Drop
Threshold Threshold Counter Counter Counter
------- -------- --------- --------- ------------- ------------- -------------
Gi 0/1 cdp 1500 1000 2288 2282 0
stp 1500 1000 116 13 0
vtp 1500 1000 3 67 0
pagp ---- ---- 0 0 0
lacp ---- ---- 0 0 0
udld ---- ---- 0 0 0

EtherChannel のレイヤ 2 トンネリングの設定

レイヤ 2 ポイントツーポイント トンネリングを設定して EtherChannel の自動作成を容易にするには、サービス プロバイダー エッジ スイッチおよびカスタマー スイッチの両方を設定する必要があります。

サービス プロバイダー エッジ スイッチの設定

EtherChannel のレイヤ 2 プロトコル トンネリング用にサービス プロバイダー エッジ スイッチを設定するには、特権 EXEC モードで次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface-id

インターフェイス コンフィギュレーション モードを開始し、トンネル ポートとして設定するインターフェイスを入力します。これは、カスタマー スイッチに接続するサービス プロバイダー ネットワークのエッジ ポートである必要があります。有効なインターフェイスは物理インターフェイスです。

ステップ 3

no shutdown

必要に応じて、ポートをイネーブルにします。デフォルトでは、UNI および ENI はディセーブルに、NNI はイネーブルに設定されています。

ステップ 4

switchport mode dot1q-tunnel

802.1Q トンネル ポートとしてインターフェイスを設定します。

ステップ 5

l2protocol-tunnel point-to-point [ pagp | lacp | udld ]

(任意)目的のプロトコルのポイントツーポイント プロトコル トンネリングをイネーブルにします。キーワードを入力しない場合、トンネリングは、3 つすべてのプロトコルでイネーブルになります。


注意 ネットワーク障害を避けるため、ネットワークがポイントツーポイント トポロジになっていることを確認してから、PAgP パケット、LACP パケット、UDLD パケットのうちいずれかのトンネリングをイネーブルにしてください。

ステップ 6

l2protocol-tunnel shutdown-threshold [ point-to-point [ pagp | lacp | udld ]] value

(任意)カプセル化用に 1 秒間に受信するパケット数のしきい値を設定します。設定したしきい値を超えると、インターフェイスはディセーブルになります。プロトコル オプションを指定しない場合、しきい値は、それぞれのトンネリングされたレイヤ 2 プロトコル タイプに適用されます。指定できる範囲は 1 ~ 4096 です。デフォルトでは、しきい値 が設定されていません。

(注) このインターフェイスで廃棄しきい値も設定する場合、シャットダウンしきい値は、廃棄しきい値以上とする必要があります。

ステップ 7

l2protocol-tunnel drop-threshold [ point-to-point [ pagp | lacp | udld ]] value

(任意)カプセル化用に 1 秒間に受信するパケット数のしきい値を設定します。設定したしきい値を超えると、インターフェイスによってパケットが廃棄されます。プロトコル オプションを指定しない場合、しきい値は、それぞれのトンネリングされたレイヤ 2 プロトコル タイプに適用されます。指定できる範囲は 1 ~ 4096 です。デフォルトでは、しきい値 が設定されていません。

(注) このインターフェイスでシャットダウンしきい値も設定する場合、廃棄しきい値は、シャットダウンしきい値以下でなければなりません。

ステップ 8

no cdp enable

インターフェイスが NNI の場合、インターフェイス上で CDP をディセーブルにします。デフォルトでは、CDP は ENI 上でディセーブルに設定されています。UNI では、CDP をサポートしません。

ステップ 9

spanning-tree bpdufilter enable

インターフェイスが NNI または ENI の場合、インターフェイス上で BPDU フィルタリングをディセーブルにします。UNI は、STP PBDU フィルタリングをサポートしません。

ステップ 10

exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 11

errdisable recovery cause l2ptguard

(任意)インターフェイスを再びイネーブルにして再試行できるようにするため、レイヤ 2 最大レート エラーからの回復メカニズムを設定します。errdisable recovery はデフォルトでディセーブルになっています。イネーブルにした場合、デフォルトの間隔は 300 秒です。

ステップ 12

l2protocol-tunnel cos value

(任意)トンネリングされたすべてのレイヤ 2 PDU の CoS 値を設定します。範囲は 0 ~ 7 です。デフォルトは、インターフェイスのデフォルト CoS 値です。設定されていない場合、デフォルトは 5 です。

ステップ 13

end

特権 EXEC モードに戻ります。

ステップ 14

show l2protocol

設定されているプロトコル、しきい値、カウンタを含めた、スイッチのレイヤ 2 トンネル ポートを表示します。

ステップ 15

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

いずれかのレイヤ 2 プロトコルまたは 3 つすべてのレイヤ 2 プロトコルのポイントツーポイント プロトコル トンネリングをディセーブルにするには、 no l2protocol-tunnel [ point-to-point [ pagp | lacp | udld ]] インターフェイス コンフィギュレーション コマンドを使用します。シャットダウンしきい値および廃棄しきい値をデフォルト設定に戻すには、 no l2protocol-tunnel shutdown-threshold [ point-to-point [ pagp | lacp | udld ]] コマンドおよび no l2protocol-tunnel drop-threshold [ [ point-to-point [ pagp | lacp | udld ]] コマンドを使用します。

カスタマー スイッチの設定

サービス プロバイダー エッジ スイッチを設定したら、特権 EXEC モードで次の手順を実行し、EtherChannel のレイヤ 2 プロトコル トンネリング用にカスタマー スイッチを設定します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface-id

インターフェイス コンフィギュレーション モードを開始します。これは、カスタマー スイッチ ポートにする必要があります。

ステップ 3

no shutdown

必要に応じて、ポートをイネーブルにします。デフォルトでは、UNI と ENI はディセーブルに、NNI はイネーブルに設定されています。

ステップ 4

switchport mode trunk

インターフェイス上でトランキングをイネーブルにします。

ステップ 5

udld enable

インターフェイスの 通常 モードで UDLD をイネーブルにします。

ステップ 6

channel-group channel-group-number mode desirable

チャネル グループにインターフェイスを割り当て、インターフェイスが NNI または ENI である場合に PAgP モードに desirable を指定します。EtherChannel の設定の詳細については、 第 35 章「EtherChannel およびリンクステート トラッキングの設定」 を参照してください。

ステップ 7

exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 8

interface port-channel port-channel number

ポートチャネル インターフェイス モードを開始します。

ステップ 9

shutdown

インターフェイスをシャットダウンします。

ステップ 10

no shutdown

インターフェイスをイネーブルにします。

ステップ 11

end

特権 EXEC モードに戻ります。

ステップ 12

show l2protocol

設定されているプロトコル、しきい値、カウンタを含めた、スイッチのレイヤ 2 トンネル ポートを表示します。

ステップ 13

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

インターフェイスをデフォルト設定に戻すには、 no switchport mode trunk no udld enable no channel group channel-group-number mode desirable インターフェイス コンフィギュレーション コマンドを使用します。

EtherChannel の場合は、サービス プロバイダー エッジ スイッチおよびカスタマー スイッチをレイヤ 2 プロトコル トンネリング用に設定する必要があります (図 14-7 を参照)。

以下は、サービス プロバイダーのエッジ スイッチ 1 およびエッジ スイッチ 2 を設定する方法の例です。VLAN 17、18、19、20 はアクセス VLAN、ギガビット イーサネット インターフェイス 1 および 2 は PAgP および UDLD がイネーブルになっているポイントツーポイント トンネル ポート、廃棄しきい値は 1000、ファスト イーサネット インターフェイス 3 はトランク ポートです。

サービス プロバイダー エッジ スイッチ 1 の設定は次のとおりです。

Switch(config)# interface gigabitethernet0/1
Switch(config-if)# switchport access vlan 17
Switch(config-if)# switchport mode dot1q-tunnel
Switch(config-if)# l2protocol-tunnel point-to-point pagp
Switch(config-if)# l2protocol-tunnel point-to-point udld
Switch(config-if)# l2protocol-tunnel drop-threshold point-to-point pagp 1000
Switch(config-if)# exit
Switch(config)# interface gigabitethernet0/2
Switch(config-if)# switchport access vlan 18
Switch(config-if)# switchport mode dot1q-tunnel
Switch(config-if)# l2protocol-tunnel point-to-point pagp
Switch(config-if)# l2protocol-tunnel point-to-point udld
Switch(config-if)# l2protocol-tunnel drop-threshold point-to-point pagp 1000
Switch(config-if)# exit
Switch(config)# interface fastethernet0/3
Switch(config-if)# no shutdown
Switch(config-if)# switchport mode trunk
 

サービス プロバイダー エッジ スイッチ 2 の設定は次のとおりです。

Switch(config)# interface gigabitethernet0/1
Switch(config-if)# switchport access vlan 19
Switch(config-if)# switchport mode dot1q-tunnel
Switch(config-if)# l2protocol-tunnel point-to-point pagp
Switch(config-if)# l2protocol-tunnel point-to-point udld
Switch(config-if)# l2protocol-tunnel drop-threshold point-to-point pagp 1000
Switch(config-if)# exit
Switch(config)# interface gigabitethernet0/2
Switch(config-if)# switchport access vlan 20
Switch(config-if)# switchport mode dot1q-tunnel
Switch(config-if)# l2protocol-tunnel point-to-point pagp
Switch(config-if)# l2protocol-tunnel point-to-point udld
Switch(config-if)# l2protocol-tunnel drop-threshold point-to-point pagp 1000
Switch(config-if)# exit
Switch(config)# interface fastethernet0/3
Switch(config-if)# no shutdown
Switch(config-if)# switchport mode trunk
 

次は、サイト 1 のカスタマー スイッチを設定する方法の例です。ファスト イーサネット インターフェイス 1、2、3、4 は 802.1Q トランキング用に設定されており、UDLD はイネーブル、EtherChannel グループ 1 はイネーブル、ポート チャネルはシャットダウンされたあとでイネーブルになって EtherChannel 設定がアクティブになります。

Switch(config)# interface fastethernet0/1
Switch(config-if)# no shutdown
Switch(config-if)# switchport mode trunk
Switch(config-if)# udld enable
Switch(config-if)# channel-group 1 mode desirable
Switch(config-if)# exit
Switch(config)# interface fastethernet0/2
Switch(config-if)# no shutdown
Switch(config-if)# switchport mode trunk
Switch(config-if)# udld enable
Switch(config-if)# channel-group 1 mode desirable
Switch(config-if)# exit
Switch(config)# interface fastethernet0/3
Switch(config-if)# no shutdown
Switch(config-if)# switchport mode trunk
Switch(config-if)# udld enable
Switch(config-if)# channel-group 1 mode desirable
Switch(config-if)# exit
Switch(config)# interface fastethernet0/4
Switch(config-if)# no shutdown
Switch(config-if)# switchport mode trunk
Switch(config-if)# udld enable
Switch(config-if)# channel-group 1 mode desirable
Switch(config-if)# exit
Switch(config)# interface port-channel 1
Switch(config-if)# shutdown
Switch(config-if)# no shutdown
Switch(config-if)# exit

トンネリングおよびマッピング ステータスのモニタおよびメンテナンス

表 14-2 は、802.1Q トンネリングおよびレイヤ 2 プロトコル トンネリングおよび VLAN マッピングのモニタとメンテナンスを行う特権 EXEC コマンドの説明です。

 

表 14-2 トンネリングのモニタおよびメンテナンスのためのコマンド

コマンド
目的

clear l2protocol-tunnel counters

レイヤ 2 プロトコル トンネリング ポートのプロトコル カウンタをクリアします。

show dot1q-tunnel

スイッチの 802.1Q トンネル ポートを表示します。

show dot1q-tunnel interface interface-id

特定インターフェイスがトンネル ポートであるかどうかを確認します。

show interfaces [ interface interface-id ] vlan mapping

すべてのインターフェイスまたは指定されたインターフェイスの VLAN マッピング情報を表示します。

show l2protocol-tunnel

レイヤ 2 プロトコル トンネリング ポートに関する情報を表示します。

show errdisable recovery

レイヤ 2 プロトコル トンネル エラー ディセーブル状態からの回復タイマーがイネーブルかどうかを確認します。

show l2protocol-tunnel interface interface-id

特定レイヤ 2 プロトコル トンネリング ポートに関する情報を表示します。

show l2protocol-tunnel summary

レイヤ 2 プロトコルのサマリー情報だけを表示します。

show platform vlan mapping

プラットフォーム VLAN マッピング情報を表示します。

show vlan dot1q tag native

スイッチのネイティブ VLAN タグのステータスを表示します。

show vlan mapping [ interface-id ]

すべてのインターフェイスまたは指定されたインターフェイスの VLAN マッピング情報を表示します。

show vlan mapping usage

VLAN マッピング専用のスイッチのハードウェア リソースの使用に関する情報を表示します。

この表示の詳細については、このリリースのコマンド リファレンスを参照してください。