Catalyst 3750 Metro スイッチ ソフトウェア コンフィギュレーション ガイド
IEEE 802.1Q およびレイヤ 2 プロトコル トン ネリングの設定
IEEE 802.1Q およびレイヤ 2 プロトコル トンネリングの設定
発行日;2012/02/04 | 英語版ドキュメント(2011/06/02 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 12MB) | フィードバック

目次

IEEE 802.1Q およびレイヤ 2 プロトコル トンネリングの設定

IEEE 802.1Q トンネリングの概要

IEEE 802.1Q トンネリングの設定

IEEE 802.1Q トンネリングのデフォルト設定

IEEE 802.1Q トンネリング設定時の注意事項

ネイティブ VLAN

システム MTU

IEEE 802.1Q トンネリングおよびその他の機能

IEEE 802.1Q トンネリング ポートの設定

VLAN マッピングの設定

VLAN マッピングのデフォルト設定

カスタマー VLAN からサービスプロバイダー VLAN へのマッピング

カスタマー IEEE 802.1Q トンネル VLAN からサービスプロバイダー VLAN へのマッピング

IEEE 802.1ad の設定

802.1ad 設定時の注意事項

EtherChannel への 802.1ad の設定

CE デバイス間の 802.1ad エンドツーエンド PAgP EtherChannel の設定例

レイヤ 2 プロトコル トンネリングの概要

レイヤ 2 プロトコル トンネリングの設定

レイヤ 2 プロトコル トンネリングのデフォルト設定

レイヤ 2 プロトコル トンネリング設定時の注意事項

レイヤ 2 トンネリングの設定

EtherChannel のレイヤ 2 トンネリングの設定

サービスプロバイダー エッジ スイッチの設定

カスタマー スイッチの設定

トンネリングおよびマッピング ステータスのモニタリングおよびメンテナンス

IEEE 802.1Q およびレイヤ 2 プロトコル トンネリングの設定

Virtual Private Network(VPN; バーチャル プライベート ネットワーク)では、多くの場合にイーサネットベースの共有インフラストラクチャである企業規模の接続に、プライベート ネットワークと同じセキュリティ、プライオリティ、信頼性、管理の容易さが提供されます。トンネリングは、サービスプロバイダーのネットワークを越えて複数のカスタマーのトラフィックを運び、その他のカスタマーのトラフィックに影響を与えずに、それぞれのカスタマーの VLAN およびレイヤ 2 プロトコルの設定を維持する必要があるサービスプロバイダー用に設計された機能です。Catalyst 3750 Metro スイッチは、IEEE 802.1Q トンネリングおよびレイヤ 2 プロトコル トンネリングとともに、VLAN マッピング(VLAN ID 変換)をサポートします。


) この章で使用するコマンドの構文および使用方法の詳細については、このリリースに対応するコマンド リファレンスを参照してください。


この章の内容は次のとおりです。

「IEEE 802.1Q トンネリングの概要」

「IEEE 802.1Q トンネリングの設定」

「VLAN マッピングの設定」

「IEEE 802.1ad の設定」

「レイヤ 2 プロトコル トンネリングの概要」

「レイヤ 2 プロトコル トンネリングの設定」

「トンネリングおよびマッピング ステータスのモニタリングおよびメンテナンス」


) Multiprotocol Label Switching(MPLS; マルチプロトコル ラベル スイッチング)での VPN の使用方法については、「MPLS、MPLS VPN、MPLS OAM、および EoMPLS の設定」 を参照してください。


IEEE 802.1Q トンネリングの概要

サービスプロバイダーのビジネス カスタマーには、VLAN ID およびサポートされる VLAN 数について固有の要件がある場合が多くあります。同一サービスプロバイダー ネットワークのさまざまなカスタマーが必要とする VLAN 範囲は重複し、インフラストラクチャを通るカスタマーのトラフィックは混在することがあります。それぞれのカスタマーに VLAN ID の固有の範囲を割り当てると、カスタマーの設定が制限され、IEEE 802.1Q 仕様の VLAN 制限(4096)を簡単に超えてしまうことがあります。

サービスプロバイダーは、IEEE 802.1Q トンネリング機能を使用すると、単一の VLAN を使用して、複数の VLAN を含むカスタマーをサポートできます。サービスプロバイダーのインフラストラクチャ上でカスタマー VLAN ID が保持され、同じ VLAN 上に存在するように見えても、異なるカスタマーからのトラフィックが分離されます。IEEE 802.1Q トンネリングを使用する場合、VLAN-in-VLAN 階層構造およびタグ付きパケットへのタグ付けによって、VLAN スペースを拡張できます。IEEE 802.1Q トンネリングをサポートするように設定したポートは、 トンネル ポート と呼ばれます。トンネリングを設定する場合、トンネリング専用の VLAN にトンネル ポートを割り当てます。それぞれのカスタマーには別個のサービスプロバイダー VLAN ID が必要ですが、その VLAN ID ではすべてのカスタマーの VLAN がサポートされます。

カスタマー デバイスの IEEE 802.1Q トランク ポートから、通常どおりに適切な VLAN ID でタグ付けされたカスタマー トラフィックが、サービスプロバイダー エッジ スイッチのトンネル ポートに着信します。カスタマー デバイスとエッジ スイッチの間のリンクは、一方の端が IEEE 802.1Q トランク ポート、反対側がトンネル ポートとして設定されているので、非対称リンクです。それぞれのカスタマーに固有のアクセス VLAN ID には、トンネル ポート インターフェイスを割り当てます。図 15-1 を参照してください。

図 15-1 サービスプロバイダー ネットワークの IEEE 802.1Q トンネル ポート

 

カスタマー トランク ポートからサービスプロバイダー エッジ スイッチのトンネル ポートに着信するパケットは、通常、適切な VLAN ID で IEEE 802.1Q タグ付けされています。これらのタグ付きパケットは、スイッチ内部ではそのまま保持され、トランク ポートを出てサービスプロバイダー ネットワークに入る時点で、カスタマーに固有の VLAN ID を含む、IEEE 802.1Q タグのもう 1 つのレイヤ( メトロ タグ と呼ばれる)でカプセル化されます。このカプセル化されたパケットの中に、カスタマーからの元の IEEE 802.1Q タグが残されます。したがって、パケットはサービスプロバイダー インフラストラクチャに入る時点で、二重のタグが付いていることになります。外側のタグはカスタマーのアクセス VLAN ID を含み、内側の VLAN ID は着信トラフィックの VLAN です。

二重タグ付きパケットがサービスプロバイダー コア スイッチ上の別のトランク ポートに着信すると、スイッチ内部でパケットが処理されるときに、外側のタグが削除されます。パケットが同じコア スイッチ上の別のトランク ポートから発信される時点で、同じメトロ タグが再びパケットに追加されます。図 15-2 に、二重タグ付きパケットの構造を示します。

図 15-2 標準、IEEE 802.1Q、および二重タグ付きイーサネット パケットのフォーマット

 

パケットがサービスプロバイダー出力スイッチ上のトランク ポートに着信すると、スイッチ内部でパケットが処理されるときに、外側のタグが再び削除されます。ただし、エッジ スイッチ上のトンネル ポートからカスタマー ネットワークに送出される時点では、メトロ タグは追加されず、パケットは通常の IEEE 802.1Q タグ付きフレームとして送信され、カスタマー ネットワーク上での元の VLAN 番号が保持されます。

図 15-1 の場合、カスタマー A には VLAN 30、カスタマー B には VLAN 40 が割り当てられています。エッジ スイッチのトンネル ポートに IEEE 802.1Q タグ付きで着信するパケットは、サービスプロバイダー ネットワークに入る時点で二重にタグ付けされます。外側のタグにはそれぞれ VLAN ID 30 または 40 が含まれ、内側のタグには元の VLAN 番号(たとえば、VLAN 100)が含まれます。カスタマー A および B の両方のネットワークに VLAN 100 があっても、外側のタグが違うため、サービスプロバイダー ネットワーク内ではトラフィックが分離されています。IEEE 802.1Q トンネリングを使用する場合、各カスタマーはそれぞれ独自の VLAN 番号スペースを管理します。この VLAN 番号スペースは、他のカスタマーが使用する VLAN 番号スペースや、サービスプロバイダー ネットワークで使用される VLAN 番号スペースとは無関係です。

アウトバウンド トンネル ポートでは、カスタマーのネットワーク上の元の VLAN 番号が回復されます。トンネリングおよびタグ付けを複数のレベルにすることもできますが、このリリースのスイッチでは 1 レベルだけがサポートされます。

カスタマー ネットワークから着信するトラフィックにタグが付いていない場合(ネイティブ VLAN フレーム)、これらのパケットは通常のパケットと同じようにブリッジングまたはルーティングされます。エッジ スイッチのトンネル ポートを通ってサービスプロバイダー ネットワークに入るすべてのパケットは、タグが付いていないか、IEEE 802.1Q ヘッダーですでにタグが付いているかに関係なく、タグなしパケットとして扱われます。パケットは、IEEE 802.1Q トランク ポートでサービスプロバイダー ネットワークを通じて送信される場合、メトロ タグ VLAN ID(トンネル ポートのアクセス VLAN に設定)でカプセル化されます。メトロ タグのプライオリティ フィールドは、トンネル ポートに設定されているインターフェイスの Class of Service(CoS; サービス クラス)プライオリティに設定されます(プライオリティが設定されていない場合、デフォルトは 0 です)。

スイッチは、インテリジェント IEEE 802.1Q トンネリング Quality of Service(QoS)、つまり内側の CoS 値を外側の CoS 値にコピーする機能をサポートしています。詳細については、「QoS ドメイン内のポートの信頼状態の設定」および「インターフェイスの CoS 値の設定」を参照してください。

IEEE 802.1Q トンネリングの設定

ここでは、IEEE 802.1Q トンネリングの設定に関する次の事項について説明します。

「IEEE 802.1Q トンネリングのデフォルト設定」

「IEEE 802.1Q トンネリング設定時の注意事項」

「IEEE 802.1Q トンネリングおよびその他の機能」

「IEEE 802.1Q トンネリング ポートの設定」

IEEE 802.1Q トンネリングのデフォルト設定

デフォルトの場合、デフォルトの switchport モードが dynamic auto であるため、IEEE 802.1Q トンネルはディセーブルです。すべての IEEE 802.1Q トランク ポートにおける IEEE 802.1Q ネイティブ VLAN パケットのタグ付けもディセーブルです。

IEEE 802.1Q トンネリング設定時の注意事項

IEEE 802.1Q トンネリング(QinQ)を設定する場合は、カスタマー デバイスおよびエッジ スイッチの間で非対称リンクを常に使用する必要があります。カスタマー デバイスのポートを IEEE 802.1Q トランク ポートに、エッジ スイッチのポートをトンネル ポートとして設定してください。

トンネリングに使用する VLAN だけにトンネル ポートを割り当ててください。

2 つのプライベート VLAN 間でトンネル経由でデータが交換されるようにするには、エッジ スイッチの Enhanced-Services(ES)ポートで VLAN 変換を設定し、スイッチのプライベート VLAN ポートで同じ VLAN ID を使用します。

ネイティブ VLAN および Maximum Transmission Unit(MTU; 最大伝送ユニット)の設定上の要件について、次に説明します。


) スイッチでは、QinQ 信頼などの特定の ES ポート固有の機能を含む IPv6 機能はサポートされていません。


ネイティブ VLAN

エッジ スイッチに IEEE 802.1Q トンネリングを設定する場合、IEEE 802.1Q トランク ポートを使用してサービスプロバイダー ネットワークにパケットを送出する必要があります。ただし、サービスプロバイダー ネットワークのコアを通過するパケットは、IEEE 802.1Q トランク、Inter Switch Link(ISL; スイッチ間リンク)トランク、または非トランキング リンクで伝送される場合があります。これらのコア スイッチで IEEE 802.1Q トランクを使用する場合、IEEE 802.1Q トランクのネイティブ VLAN は、同じスイッチ上の非トランキング(トンネリング)ポートのネイティブ VLAN と同じであってはなりません。ネイティブ VLAN 上のトラフィックは、IEEE 802.1Q 送信側トランク ポートでタグ付けされていない場合があるためです。

図 15-3 を参照してください。VLAN 40 は、サービスプロバイダー ネットワークの入力エッジ スイッチ(スイッチ B)において、カスタマー X からの IEEE 802.1Q トランク ポートのネイティブ VLAN として設定されています。カスタマー X のスイッチ A は、VLAN 30 でタグ付きパケットをサービスプロバイダー ネットワークのスイッチ B の入力トンネル ポート(アクセス VLAN 40 に所属)に送信します。トンネル ポートのアクセス VLAN(VLAN 40)は、エッジ スイッチのトランク ポートのネイティブ VLAN(VLAN 40)と同じであるため、トンネル ポートから受信したタグ付きパケットには、メトロ タグが追加されません。パケットはサービスプロバイダー ネットワーク経由で出力エッジ スイッチ(スイッチ C)のトランク ポートまで VLAN 30 タグだけで伝送され、この出力スイッチのトンネル ポートを通じて、不正にカスタマー Y へ送信されます。

この問題の解決方法は次のとおりです。

サービスプロバイダー ネットワーク上のコア スイッチの間の標準ポートで ISL トランクを使用します。エッジ スイッチに接続されているカスタマー インターフェイスは IEEE 802.1Q トランクとしますが、コア レイヤのスイッチの接続には ISL トランクの使用を推奨します。

vlan dot1q tag native グローバル コンフィギュレーション コマンドを使用し、ネイティブ VLAN を含む、IEEE 802.1Q トランクから発信されるすべてのパケットがタグ付けされるようにエッジ スイッチを設定します。すべての IEEE 802.1Q トランクでネイティブ VLAN パケットにタグを付けるようにスイッチを設定した場合、スイッチはタグなしパケットを受信しますが、タグ付きパケットだけを送信します。

エッジ スイッチのトランク ポートのネイティブ VLAN ID が、カスタマー VLAN 範囲に属さないようにします。たとえばトランク ポートが VLAN 100 ~ 200 のトラフィックを運ぶ場合は、この範囲以外の番号をネイティブ VLAN に割り当てます。

図 15-3 IEEE 802.1Q トンネリングおよびネイティブ VLAN に潜在する問題

 

システム MTU

Catalyst 3750 Metro スイッチでは、トラフィックのデフォルトのシステム MTU は、1500 バイトです。 system mtu グローバル コンフィギュレーション コマンドを使用すると、1500 バイトより大きいフレームをサポートするようにファスト イーサネット ポートを設定できます。 system mtu jumbo グローバル コンフィギュレーション コマンドを使用すると、1500 バイトより大きいフレームをサポートするようにギガビット イーサネット ポートを設定できます。IEEE 802.1Q トンネリング機能では、メトロ タグが追加されると、フレーム サイズが 4 バイト増加するので、スイッチのシステム MTU サイズを最低でも 1504 バイトに増加して最大フレームを処理できるように、サービスプロバイダー ネットワークのすべてのスイッチを設定する必要があります。ギガビット イーサネット インターフェイスの許容可能な最大システム MTU は 9000 バイトです。ファスト イーサネット インターフェイスの最大システム MTU は 1998 バイトです。

IEEE 802.1Q トンネリングおよびその他の機能

IEEE 802.1Q トンネリングは、レイヤ 2 パケット スイッチングに関しては適切に動作しますが、一部のレイヤ 2 機能およびレイヤ 3 スイッチングとは非互換です。

トンネル ポートはルーテッド ポートにはできません。

IEEE 802.1Q ポートを含む VLAN では IP ルーティングがサポートされません。トンネル ポートから受信したパケットは、レイヤ 2 情報だけに基づいて転送されます。トンネル ポートを含む Switch Virtual Interface(SVI; スイッチ仮想インターフェイス)上でルーティングがイネーブルの場合、トンネル ポートから受信したタグなし IP パケットはスイッチによって認識され、ルーティングされます。したがって、カスタマーはネイティブ VLAN 経由でインターネットにアクセスできます。このアクセスが不要な場合には、トンネル ポートを含む VLAN 上に SVI を設定しないようにします。

フォールバック ブリッジングは、トンネル ポートでサポートされません。トンネル ポートから受信したすべての IEEE 802.1Q タグ付きパケットは IP 以外のパケットとして扱われるので、トンネル ポートが設定されている VLAN でフォールバック ブリッジングがイネーブルである場合、IP パケットは VLAN を越えて不適切にブリッジングされます。このため、トンネル ポートを含む VLAN ではフォールバック ブリッジングをイネーブルに しないでください

トンネル ポートでは IP Access Control List(ACL; アクセス コントロール リスト)がサポートされません。

レイヤ 3 Quality Of Service(QoS)ACL およびレイヤ 3 に関連するその他の QoS 機能の情報は、トンネル ポートでサポートされません。Media Access Control(MAC; メディア アクセス制御)ベースの QoS ACL は、トンネル ポート上でサポートされます。

IEEE 802.1Q 設定が EtherChannel ポート グループ内で矛盾しない場合、EtherChannel ポート グループにはトンネル ポートとの互換性があります。

Port Aggregation Protocol(PAgP; ポート集約プロトコル)、Link Aggregation Control Protocol(LACP)、UniDirectional Link Detection(UDLD; 単一方向リンク検出)は、IEEE 802.1Q トンネリング ポートでサポートされます。

トンネル ポートとトランク ポートで非対称リンクを手動で設定する必要があるので、Dynamic Trunking Protocol(DTP; ダイナミック トランキング プロトコル)には IEEE 802.1Q トンネリングとの互換性がありません。

VLAN Trunking Protocol(VTP; VLAN トランキング プロトコル)は、非対称リンクで接続されているデバイス間、またはトンネルを通して通信を行うデバイス間で動作しません。

IEEE 802.1Q トンネル ポートでは、ループバック検出がサポートされます。

IEEE 802.1Q トンネル ポートとしてポートを設定すると、スパニング ツリー Bridge Protocol Data Unit(BPDU; ブリッジ プロトコル データ ユニット)フィルタリングがインターフェイスで自動的にイネーブルになります。Cisco Discovery Protocol(CDP; シスコ検出プロトコル)および Layer Link Discovery Protocol(LLDP)は、インターフェイスで自動的にディセーブルになります。

IEEE 802.1Q トンネリング ポートの設定

IEEE 802.1Q トンネル ポートとしてポート設定するには、特権 EXEC モードで次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface-id

トンネル ポートとして設定するインターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。これは、カスタマー スイッチに接続するサービスプロバイダー ネットワークのエッジ ポートである必要があります。有効なインターフェイスには、物理インターフェイスおよびポートチャネル論理インターフェイス(ポート チャネル 1 ~ 12)が含まれます。

ステップ 3

switchport access vlan vlan-id

デフォルト VLAN を指定します。これは、インターフェイスがトランキングを停止した場合に使用されます。この VLAN ID は個々のカスタマーに固有です。

ステップ 4

switchport mode dot1q-tunnel

IEEE 802.1Q トンネル ポートとしてインターフェイスを設定します。

ステップ 5

exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 6

vlan dot1q tag native

(任意)すべての IEEE 802.1Q トランク ポートでネイティブ VLAN パケットのタグ付けをイネーブルにするようにスイッチを設定します。設定しない場合、カスタマー VLAN ID がネイティブ VLAN と同じであれば、トランク ポートはメトロ タグを適用せず、パケットが不正な宛先に送信される可能性があります。

ステップ 7

end

特権 EXEC モードに戻ります。

ステップ 8

show dot1q-tunnel

スイッチ上のトンネル ポートを表示します。

ステップ 9

show vlan dot1q tag native

IEEE 802.1Q ネイティブ VLAN タグ付けステータスを表示します。

ステップ 10

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

ポートをデフォルトの状態(dynamic auto)に戻すには、 no switchport mode dot1q-tunnel インターフェイス コンフィギュレーション コマンドを使用します。ネイティブ VLAN パケットのタグ付けをディセーブルにするには、 no vlan dot1q tag native グローバル コンフィギュレーション コマンドを使用します。

次に、ポートをトンネル ポートとして設定し、ネイティブ VLAN パケットのタグ付けをイネーブルにして、設定を確認する例を示します。この設定では、ファスト イーサネット ポート 7 に接続するカスタマーの VLAN ID は VLAN 22 です。

Switch(config)# interface fastethernet1/0/7
Switch(config-if)# switchport access vlan 22
% Access VLAN does not exist. Creating vlan 22
Switch(config-if)# switchport mode dot1q-tunnel
Switch(config-if)# exit
Switch(config)# vlan dot1q tag native
Switch(config)# end
Switch# show dot1q-tunnel interface fastethernet1/0/7
Port
-----
Fa1/0/7
-----
Switch# show vlan dot1q tag native
dot1q native vlan tagging is enabled

VLAN マッピングの設定

VLAN マッピング(または VLAN ID 変換)は、カスタマー VLAN をサービスプロバイダー VLAN にマッピングするために、サービスプロバイダー ネットワークに接続する Enhanced-Services(ES)ポート上に設定できる機能です。VLAN マッピングは、スイッチの内部動作やカスタマー VLAN に影響を与えずに、ES ポート上でフィルタとして動作します。スイッチ上の VLAN の多くは予約済みであったり、または VLAN 範囲がかぎられていたりする場合があります。カスタマーが予約済み範囲内の VLAN 番号を希望している場合、VLAN マッピングを使用して、カスタマー トラフィックを IEEE 802.1Q トンネル内でカプセル化することにより、カスタマー VLAN を重複させることができます。

VLAN マッピングを使用すると、パケットを送信する直前、およびパケットを受信した直後に、IEEE 802.1Q タグ内のカスタマー VLAN ID、または IEEE 802.1Q トンネル フレームの外側および内側タグのマッピング(変換)が実行されます。サービスプロバイダー VLAN はスイッチによって認識されないため、すべての設定および統計処理は、カスタマー側の VLAN を使用して行われます。

スイッチは次の 3 種類の VLAN マッピングをサポートします。

1 対 1 のマッピング:IEEE 802.1Q タグ内のカスタマー VLAN ID をサービスプロバイダー VLAN ID にマッピングします。

2 対 1 のマッピング:外側および内側の VLAN ID を持った IEEE 802.1Q トンネリング トラフィックをサービスプロバイダー VLAN ID にマッピングします。

2 対 2 のマッピング:外側および内側の VLAN ID を持った IEEE 802.1Q トンネリング トラフィックをサービスプロバイダーの外側および内側の VLAN ID にマッピングします。

カスタマー側の IEEE 802.1Q VLAN ID を使用してスイッチ内のパケットをスイッチングします。サービスプロバイダー VLAN ID は ES ポートで送受信されます。

ES ポートのポート チャネル上で VLAN 変換を設定するには、ES ポートごとに switchport vlan mapping インターフェイス コンフィギュレーション コマンドを入力します。ES ポートで変換を設定する場合は、VLAN 変換が両方の ES ポートで同一である必要があります。


) MPLS または Ethernet over Multiprotocol Label Switching(EoMPLS)用に設定されているインターフェイス上では、VLAN マッピングを設定しないでください。


ここでは、次の設定について説明します。

「VLAN マッピングのデフォルト設定」

「カスタマー VLAN からサービスプロバイダー VLAN へのマッピング」

「カスタマー IEEE 802.1Q トンネル VLAN からサービスプロバイダー VLAN へのマッピング」

VLAN マッピングのデフォルト設定

デフォルトで、VLAN マッピングは設定されていません。

カスタマー VLAN からサービスプロバイダー VLAN へのマッピング

図 15-4 に、サービスプロバイダー ネットワークのそれぞれの側に接続する複数のサイトでカスタマーが同じ VLAN を使用しているトポロジを示します。サービスプロバイダー バックボーン経由でパケットを伝送できるように、カスタマー VLAN ID をサービスプロバイダー VLAN ID にマッピングします。サービスプロバイダー バックボーンの反対側でカスタマー VLAN ID が取り出され、別のカスタマー サイトで使用できます。サービスプロバイダー ネットワークの各側にある ES ごとに、同じ VLAN マッピングのセットを設定します。設定手順のあとに示す例を参照してください。

図 15-4 VLAN マッピングの例

 

ES ポート上でカスタマー VLAN ID をサービスプロバイダー VLAN ID にマッピングするには、特権 EXEC モードで次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface-id

サービスプロバイダー ネットワークに接続された ES インターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

switchport vlan mapping vlan-id translated-id

マッピングする VLAN ID を入力します。

vlan-id :カスタマー ネットワークからスイッチに着信する VLAN ID。指定できる範囲は 1 ~ 4094 です。

translated-id :割り当てられるサービスプロバイダー VLAN ID。指定できる範囲は 1 ~ 4094 です。

ステップ 4

end

特権 EXEC モードに戻ります。

ステップ 5

show vlan mapping

設定を確認します。

ステップ 6

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

VLAN 変換情報を削除するには、no switchport vlan mapping vlan-id translated-id コマンドを使用します。

次に、図 15-4 に示すカスタマー ネットワークの VLAN ID 1、2、3、4、5 を、サービスプロバイダー ネットワークの VLAN 1001、1002、1003、1004、1005 にマッピングする例を示します。スイッチ A およびスイッチ B の ES ポートに、同じ VLAN マッピング コマンドを設定します。

Switch(config)# interface gigabiethernet1/1/1
Switch(config-if)# switchport vlan mapping 1 1001
Switch(config-if)# switchport vlan mapping 2 1002
Switch(config-if)# switchport vlan mapping 3 1003
Switch(config-if)# switchport vlan mapping 4 1004
Switch(config-if)# switchport vlan mapping 5 1005
Switch(config-if)# exit
 

前述の例では、サービスプロバイダー ネットワークの入口では、カスタマー ネットワークの VLAN ID 1、2、3、4、5 はサービスプロバイダー ネットワークの VLAN 1001、1002、1003、1004、1005 にマッピングされます。サービスプロバイダー ネットワークの出口では、サービスプロバイダー ネットワークの VLAN 1001、1002、1003、1004、1005 はカスタマー ネットワークの VLAN ID 1、2、3、4、5 にマッピングされます。

カスタマー IEEE 802.1Q トンネル VLAN からサービスプロバイダー VLAN へのマッピング

switchport vlan mapping インターフェイス コンフィギュレーション コマンドで dot1qtunnel キーワードを使用すると、特定の外側および内側 VLAN ID を持つ IEEE 802.1Q トラフィックを、サービスプロバイダー ネットワーク上の特定の外側および内側 VLAN ID にマッピングすることもできます。 drop キーワードを使用して、特定の内側および外側 VLAN ID の組み合わせを明示的に変換しないかぎり、特定の外側 VLAN ID 上のトラフィックをドロップするように指定できます。

ES ポート上で IEEE 802.1Q タグ付きトラフィックをドロップまたは変換するようにスイッチを設定するには、特権 EXEC モードで次の作業を実行します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface-id

サービスプロバイダー ネットワークに接続された ES インターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

switchport vlan mapping dot1q-tunnel outer-vlan-id { inner-vlan-id translated-vlan-id | drop}

VLAN マッピングを 2 対 1 のマッピングとして設定し、元の IEEE 802.1Q パケットの外側 VLAN ID が特定の値と一致した場合に実行されるアクションを指定します。

outer-vlan-id :元の IEEE 802.1Q パケットの外側 VLAN ID を入力します。指定できる VLAN ID の範囲は 1 ~ 4094 です。

inner-vlan-id translated-vlan-id :元の IEEE 802.1Q パケットの内側 VLAN ID と、変換後のサービスプロバイダー ネットワーク VLAN ID を入力します。指定できる VLAN ID の範囲は 1 ~ 4094 です。

drop :内側 VLAN ID が既存の VLAN マッピングで一致しないかぎり、指定した外側 VLAN ID を持つトラフィックをドロップすることを指定します。

ステップ 4

switchport vlan mapping internal dot1q-tunnel internal-outer-vlan-id internal-inner-vlan-id external dot1q-tunnel external-outer-vlan-id external-inner-vlan-id

VLAN マッピングを 2 対 2 のマッピングとして設定し、マッピングされる外側および内側 VLAN ID を指定します。

internal-outer-vlan-id :元の IEEE 802.1Q パケットの外側 VLAN ID を入力します。

internal-inner-vlan-id :元の IEEE 802.1Q パケットの内側 VLAN ID を入力します。

external-outer-vlan-id :サービスプロバイダー ネットワークの外側 VLAN ID を入力します。

external-inner-vlan-id :サービスプロバイダー ネットワークの内側 VLAN ID を入力します。

指定できる VLAN ID の範囲は 1 ~ 4094 です。

(注) サービスプロバイダー ネットワークの内側 VLAN ID は、元の IEEE 802.1Q パケットの VLAN ID と一致する必要があります。

ステップ 5

end

特権 EXEC モードに戻ります。

ステップ 6

show vlan mapping

設定を確認します。

ステップ 7

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

2 対 1 のマッピング情報を削除するには、 no switchport vlan mapping dot1qtunnel outer-vlan-id {inner-vlan-id translated-vlan-id | drop } インターフェイス コンフィギュレーション コマンドを使用します。2 対 2 のマッピング情報を削除するには、 switchport vlan mapping internal dot1q-tunnel internal-outer-vlan-id internal-inner-vlan-id external dot1q-tunnel external-outer-vlan-id external-inner-vlan-id インターフェイス コンフィギュレーション コマンドを使用します。

次に、外側 VLAN ID が 5、内側 VLAN ID が 6 である IEEE 802.1Q トラフィックを、VLAN ID 10 でスイッチから送信するように ES ポートで 2 対 1 のマッピングを設定する例を示します。外側 VLAN ID が 5 で、内側 VLAN ID が 6 以外の IEEE 802.1Q トラフィックはドロップします。VLAN 5 のその他のトラフィックもドロップします。

Switch(config)# interface gigabiethernet1/1/1
Switch(config-if)# switchport vlan mapping dot1q-tunnel 5 6 10
Switch(config-if)# switchport vlan mapping dot1q-tunnel 5 drop
Switch(config-if)# exit
 

次に、外側 VLAN ID が 5、内側 VLAN ID が 6 である IEEE 802.1Q トラフィックを、外側 VLAN ID 15 および内側 VLAN ID 16 でスイッチから送信するように ES ポートで 2 対 2 のマッピングを設定する例を示します。

Switch(config)# interface gigabitethernet1/1/1
Switch(config-if)# switchport vlan mapping internal dot1q-tunnel 5 6 external dot1q tunnel 15 6

IEEE 802.1ad の設定

QinQ は、二重タグ付けを有効にしてプロバイダー ネットワークに VLAN スケーラビリティを提供するシスコ独自のシステムです。一方、IEEE 802.1ad は、標準プロトコルを使用してプロバイダー ネットワークに VLAN スケーラビリティを提供します。QinQ と同様に、カスタマー インターフェイスから入るデータ トラフィックは、サービスプロバイダー タグでタグ付けされます。カスタマー フレームは、2 つのタグが付いた状態でプロバイダー ネットワークを横断します。内側のタグはカスタマー タグ(C タグ)で、外側のタグはサービスプロバイダー タグ(S タグ)です。制御パケットは、プロバイダー ネットワーク内でデータとして現れます。

シスコ プロバイダー ブリッジでの IEEE 802.1ad サポートの説明と関連するコマンドについては、次のマニュアルを参照してください。
http://www.cisco.com/en/US/docs/ios/cether/configuration/guide/ce_cfm-ieee_802_1ad.html

Catalyst 3750 Metro スイッチでは、次の IEEE 802.1ad 機能がサポートされます。

スイッチポートベースのモデル

all-to-one バンドリング

サービス多重化(複合 UNI)

802.1ad では、スイッチポートは Customer User-Network Interface(C-UNI; カスタマー ユーザネットワーク インターフェイス)、Service-Provider UNI(S-UNI; サービスプロバイダー UNI)、Network-to-Network Interface(NNI; ネットワーク間インターフェイス)のいずれかとして設定されます。802.1ad ポートとして使用できるのはレイヤ 2 インターフェイスだけです。

C-UNI:アクセス ポートまたは 802.1Q トランク ポートのいずれかを使用できます。このポートはカスタマー ブリッジ アドレスを使用します。C-UNI ポートを設定するには、 ethernet dot1ad uni c-port インターフェイス コンフィギュレーション コマンドを入力します。インターフェイスが 802.1ad トランク C-UNI ポートとして設定されている場合は、 switchport vlan mapping インターフェイス コンフィギュレーション コマンドに追加された新しいキーワードを使用して、カスタマー VLAN に all-to-one または選択的バンドリング機能を提供できます。

Catalyst 3750 Metro スイッチでは、ES ポートを C-UNI ポートとして設定できません。

S-UNI:インターフェイスに入るすべてのカスタマー VLAN に同じサービスを提供するアクセス ポート。ポートに入るすべての C-VLAN に同じ S-VLAN のマーキングをします。このモードでは、カスタマーのポートがトランク ポートとして設定され、S-UNI に入るトラフィックがタグ付けされます。S-UNI では、CDP と LLDP がディセーブルに設定され、STP BPDU フィルタリングと PortFast がイネーブルに設定されます。このポートはアクセス ポートとしてのみ設定できます。トランク設定を行うことはできません。

S-UNI では、CFM C-VLAN 設定を行うことはできません。

ポートを dot1q-tunnel モードに設定するには、 ethernet dot1ad uni s-port インターフェイス コンフィギュレーション コマンドを入力します。ES ポートを S-UNI として設定することはできません。

NNI:トランク ポート上で ethernet dot1ad nni インターフェイス コマンドを入力すると、802.1ad EtherType(0x88a8)が作成され、CPU によって生成されたレイヤ 2 プロトコル PDU に S-bridge アドレスが使用されます。NNI として使用できるのはトランク ポートのみです。NNI では、CFM C-VLAN 設定を行うことはできません。


) Catalyst 3750 Metro スイッチでは、ES ポートでのみ 802.1ad NNI を設定できます。ES ポート以外のポートは、C-UNI または S-UNI として設定できます。


802.1ad をサポートするコマンドの詳細については、コマンド リファレンスを参照してください。

802.1ad 設定時の注意事項

S-UNI にはアクセス ポートを使用する必要があります。

NNI にはトランク ポートを使用する必要があります。

A C-UNI にはアクセス ポートまたはトランク ポートのいずれかを使用できます。

Catalyst 3750 Metro スイッチでは、ES ポートのみを NNI として設定します。ES ポート以外のポートのみを UNI として設定します。

802.1ad はポートベースの機能です。802.1ad をイネーブルにするグローバル コマンドはありません。デフォルトでは、802.1ad がイネーブルになっていない場合、スイッチポートはすべて従来の 802.1Q ポートです。

802.1ad がイネーブルになっている場合、カスタマー データ フレームのトンネリングはソフトウェアで行われます。着信 BPDU のレートが高い場合、CPU 使用率に何らかの影響が及ぶ可能性があります。

EVC または 802.1ad レイヤ 3 終端では、スイッチは 802.1ad をサポートしません。

802.1ad インターフェイスでは、スイッチはスプリット ホライズンをサポートしません。

802.1ad インターフェイスでは、レイヤ 2 プロトコル トンネリングをイネーブルにできません。これらの機能は相互に排他的です。

Catalyst 3750 Metro スイッチは、802.1ad の混在コンフィギュレーション モデルをサポートします。混在コンフィギュレーション モデルを使用すると、ブリッジで従来の QinQ トンネルと 802.1ad トンネルを同時に使用できます。スイッチを混在コンフィギュレーション モードに設定する場合は、従来の 802.1Q トンネリング用のブロードキャスト ドメインと 802.1ad トンネリング用のブロードキャスト ドメインを分離する必要があります。機能を確保するために、802.1ad NNI トランク ポートと 802.1Q 出力トランクに許可された VLAN のセットを重複して設定しないでください。

デフォルトでは、カスタマー UDLD パケットは 802.1ad S-UNI ポートでトンネリングされ、C-UNI ポートで処理(検証)されます。802.1ad C-UNI ポートでは、エンドツーエンド UDLD はサポートされません。

802.1ad のサービスプロバイダー ネットワークを設定する場合は、すべての相互接続トランク ポートに 802.1ad NNI を設定する必要があります。これは、サービスプロバイダー ネットワークでカスタマー レイヤ 2 PDU のエンドツーエンド機能を確保するために必要です。

EtherChannel への 802.1ad の設定

ポート チャネルに 802.1ad を設定する場合は、最初に EtherChannel グループを設定し、次にバンドルされたポート(ポート チャネル)に 802.1ad ポート コンフィギュレーションを設定します。EtherChannel ポート チャネルに 802.1ad コンフィギュレーションを設定すると、ポート チャネル内のすべてのポートに 802.1ad コンフィギュレーションが適用されます。

ポートで 802.1ad がすでにイネーブルになっている場合、そのポートを EtherChannel に追加できません。

CE デバイスと PE デバイスの両方が PAgP または LACP EtherChannel にアクティブに参加している場合は、次の設定手順に従ってください。

CE デバイス間の 802.1ad エンドツーエンド PAgP EtherChannel の設定例

図 15-5 を参照してください。PE デバイスで EtherChannel が on モードになっていない場合に CE デバイス間でエンドツーエンド PAgP EtherChannel トンネリングを行うには、CE 接続をサービスプロバイダー ネットワーク経由のポイントツーポイント サービスに拡張する必要があります。ソフトウェア コンフィギュレーション ガイドの「IEEE 802.1Q およびレイヤ 2 プロトコル トンネリングの設定」の章の「EtherChannel のレイヤ 2 トンネリングの設定」を参照してください。同じ手順が 802.1ad トンネルに適用されます。

図 15-5 802.1ad エンドツーエンド PAgP EtherChannel

 

カスタマー A1 での設定:

Switch #show etherchannel summary
Flags: D - down P - bundled in port-channel
I - stand-alone s - suspended
H - Hot-standby (LACP only)
R - Layer3 S - Layer2
U - in use f - failed to allocate aggregator
 
M - not in use, minimum links not met
u - unsuitable for bundling
w - waiting to be aggregated
d - default port
Number of channel-groups in use: 2
Number of aggregators: 2
Group Port-channel Protocol Ports
------+-------------+-----------+-----------------------------------------------
23 Po23(SU) PAgP (desirable) Fa1/0/2(P) Fa1/0/3(P) Fa1/0/4(P)

PE-1 での設定:

Switch (config)# interface GigabitEthernet0/2
Switch (config-if)# switchport access vlan 4002
Switch (config-if)# ethernet dot1ad uni s-port
 
Switch (config)# interface GigabitEthernet0/2
Switch (config-if)# switchport access vlan 4002
Switch (config-if)# switchport mode trunk
 
Switch (config)# interface GigabitEthernet0/3
Switch (config-if)# switchport access vlan 4001
Switch (config-if)# ethernet dot1ad uni s-port
Switch (config-if)# switchport trunk allowed vlan 4002
Switch (config-if)# switchport vlan mapping default dot1ad-bundle
Switch (config-if)# Ethernet dot1ad uni c-port
 
Switch (config)# interface GigabitEthernet0/4
Switch (config-if)# switchport access vlan 4003
Switch (config-if)# ethernet dot1ad uni s-port
 
Switch (config)# interface GigabitEthernet0/10
Switch (config-if)# switchport trunk allowed vlan 4001-4094
Switch (config-if)# switchport mode trunk
Switch (config-if)# media-type sfp
Switch (config-if)# ethernet dot1ad nni

PE-3 での設定

Switch (config)# interface GigabitEthernet1/1/1
Switch (config-if)# switchport trunk allowed vlan 4001-4094
Switch (config-if)# switchport mode trunk
Switch (config-if)# switchport trunk dot1q ethertype 88A8
Switch (config-if)# udld port aggressive
Switch (config-if)# ethernet dot1ad nni
 
Switch (config)# interface GigabitEthernet1/1/2
Switch (config-if)# switchport trunk allowed vlan 4001-4094
Switch (config-if)# switchport mode trunk
Switch (config-if)# switchport trunk dot1q ethertype 88A8
Switch (config-if)# udld port aggressive
Switch (config-if)# ethernet dot1ad nni

PE-2 での設定

Switch (config)# interface GigabitEthernet0/9
Switch (config-if)# switchport access vlan 4002
Switch (config-if)# ethernet dot1ad uni s-port
 
Switch (config)# interface GigabitEthernet0/10
Switch (config-if)# switchport access vlan 4001
Switch (config-if)# ethernet dot1ad uni s-port
 
Switch (config)# interface GigabitEthernet0/11
Switch (config-if)# switchport access vlan 4003
Switch (config-if)# ethernet dot1ad uni s-port
 
Switch (config)# interface GigabitEthernet0/13
Switch (config-if)# switchport trunk allowed vlan 4001-4094
Switch (config-if)# switchport mode trunk
Switch (config-if)# ethernet dot1ad nni

カスタマー A3 での設定

Switch (config)# interface Port-channel23
Switch (config-if)# switchport trunk encapsulation dot1q
Switch (config-if)# switchport mode trunk
 
Switch (config)# interface FastEthernet1/0/21
Switch (config-if)# switchport trunk encapsulation dot1q
Switch (config-if)# switchport mode trunk
Switch (config-if)# channel-protocol pagp
Switch (config-if)# channel-group 23 mode desirable
 
Switch (config)# interface FastEthernet1/0/22
Switch (config-if)# switchport trunk encapsulation dot1q
Switch (config-if)# switchport mode trunk
Switch (config-if)# channel-protocol pagp
Switch (config-if)# channel-group 23 mode desirable
 
Switch (config-if)# interface FastEthernet1/0/23
Switch (config-if)# switchport trunk encapsulation dot1q
Switch (config-if)# switchport mode trunk
Switch (config-if)# channel-protocol pagp
Switch (config-if)# channel-group 23 mode desirable

PE-2 および PE-3 での 802.1ad C-UNI ポートを含めた設定

Switch (config)# interface GigabitEthernet0/2
Switch (config-if)# switchport access vlan 4002
Switch (config-if)# switchport mode trunk
Switch (config-if)# switchport trunk allowed vlan 4002
Switch (config-if)# switchport vlan mapping default dot1ad-bundle 4002
Switch (config-if)# Ethernet dot1ad uni c-port
 
Switch (config)# interface GigabitEthernet0/3
Switch (config-if)# switchport access vlan 4001
Switch (config-if)# switchport mode trunk
Switch (config-if)# switchport trunk allowed vlan 4001
Switch (config-if)# switchport vlan mapping default dot1ad-bundle 4001
Switch (config-if)# Ethernet dot1ad uni c-port
 
Switch (config)# interface GigabitEthernet0/4
Switch (config-if)# switchport access vlan 4003
Switch (config-if)# switchport mode trunk
Switch (config-if)# switchport trunk allowed vlan 4003
Switch (config-if)# switchport vlan mapping default dot1ad-bundle 4003
Switch (config-if)# Ethernet dot1ad uni c-port
 

他のスイッチの設定は、802.1ad C-UNI シナリオと同じです。

レイヤ 2 プロトコル トンネリングの概要

サービスプロバイダー ネットワーク経由で接続される複数のサイトのカスタマーは、さまざまなレイヤ 2 プロトコルを実行して、すべてのリモート サイトおよびローカル サイトを含むようにトポロジを拡大する必要があります。STP が適切に稼動している必要があり、すべての VLAN で、ローカル サイトおよびサービスプロバイダー インフラストラクチャ経由のすべてのリモート サイトを含む、適切なスパニング ツリーを構築する必要があります。Cisco 検出プロトコル(CDP)では、隣接するシスコ デバイスをローカル サイトおよびリモート サイトから検出する必要があります。VLAN トランキング プロトコル(VTP)では、カスタマー ネットワークのすべてのサイトで矛盾しない VLAN 設定を提供する必要があります。

プロトコル トンネリングをイネーブルにした場合、サービスプロバイダー インフラストラクチャの着信側にあるエッジ スイッチは、レイヤ 2 プロトコル パケットを特殊な MAC アドレスでカプセル化し、それらをサービスプロバイダー ネットワーク経由で送信します。ネットワークのコア スイッチでは、このパケットが処理されずに通常のパケットとして転送されます。CDP、STP、または VTP のレイヤ 2 Protocol Data Unit(PDU; プロトコル データ ユニット)は、サービスプロバイダー インフラストラクチャを通過し、サービスプロバイダー ネットワークの発信側にあるカスタマー スイッチまで配信されます。同一パケットは同じ VLAN のすべてのカスタマー ポートで受信され、次のような結果になります。

カスタマーの各サイトのユーザは適切に STP を実行でき、すべての VLAN で、ローカル サイトだけでなく全サイトからのパラメータに基づく適正なスパニング ツリーを構築できます。

CDP では、サービスプロバイダー ネットワークによって接続されているその他のシスコ デバイスに関する情報が検出されて表示されます。

VTP は、カスタマー ネットワーク全体で一貫性のある VLAN 設定を提供し、サービスプロバイダーを通じてすべてのスイッチに伝播します。


) サードパーティ ベンダーとの相互運用性を提供するには、レイヤ 2 プロトコルトンネル バイパス機能を使用します。バイパス モードでは、プロトコル トンネリングの制御方法が異なるベンダー スイッチに制御 PDU が透過的に転送されます。バイパス モードを実装するには、出力トランク ポートでレイヤ 2 プロトコル トンネリングをイネーブルにします。レイヤ 2 プロトコル トンネリングがトランク ポートでイネーブルの場合、カプセル化された MAC アドレスが削除され、プロトコル パケットに通常の MAC アドレスが含まれるようになります。


レイヤ 2 プロトコル トンネリングは個別に使用できます。レイヤ 2 プロトコル トンネリングでは、IEEE 802.1Q トンネリングを向上させることができます。IEEE 802.1Q トンネリング ポートでプロトコル トンネリングをイネーブルにしていない場合、サービスプロバイダー ネットワークの受信側のリモート スイッチでは PDU が受信されず、STP、CDP、VTP を適切に実行できません。プロトコル トンネリングがイネーブル である 場合、それぞれのカスタマー ネットワークのレイヤ 2 プロトコルは、サービスプロバイダー ネットワーク内で動作しているものから完全に区別されます。IEEE 802.1Q トンネリングでサービスプロバイダー ネットワークを通してトラフィックを送信する、さまざまなサイトのカスタマー スイッチでは、カスタマー VLAN が完全に認識されます。IEEE 802.1Q トンネリングを使用しない場合にも、アクセス ポートまたはトランク ポート経由でカスタマー スイッチに接続し、サービスプロバイダーのアクセス ポートまたはトランク ポート上でトンネリングをイネーブルにすることによって、レイヤ 2 プロトコル トンネリングをイネーブルにできます。

たとえば図 15-6 の場合、カスタマー X には、サービスプロバイダー ネットワーク経由で接続された同じ VLAN 上のスイッチが 4 つあります。ネットワークで PDU がトンネルされない場合、ネットワークの向こう側のスイッチでは、STP、CDP、VTP を適切に実行できません。たとえば、カスタマー X、サイト 1 のスイッチ上の VLAN で動作する STP は、カスタマー X、サイト 2 のスイッチに基づくコンバージェンス パラメータを考慮せずに、このサイトのスイッチのスパニング ツリーを構築します。その結果、図 15-7 に示すトポロジになる可能性があります。

図 15-6 レイヤ 2 プロトコル トンネリング

 

図 15-7 BPDU トンネリングを使用しない仮想ネットワーク トポロジ

 

サービスプロバイダー ネットワークでは、ポイントツーポイント ネットワーク トポロジをエミュレートして EtherChannel の作成を強化するのに、レイヤ 2 プロトコル トンネルを使用できます。プロトコル トンネリング(PAgP または LACP)をサービスプロバイダー スイッチでイネーブルにすると、リモート カスタマー スイッチが PDU を受信し、EtherChannel の自動作成をネゴシエーションします。

たとえば図 15-8 の場合、カスタマー A には同一 VLAN に 2 つのスイッチがあり、Service Provider(SP; サービスプロバイダー)ネットワークで接続されています。ネットワークで PDU がトンネリングされると、ネットワークの向こう側のスイッチでは、専用回線を必要とせずに、EtherChannel の自動作成をネゴシエーションできます。EtherChannel のレイヤ 2 プロトコル トンネリングの設定については「EtherChannel のレイヤ 2 トンネリングの設定」を参照してください。

図 15-8 EtherChannel のレイヤ 2 プロトコル トンネリング

 

レイヤ 2 プロトコル トンネリングの設定

サービスプロバイダー ネットワークのエッジ スイッチ上のカスタマーに接続されたポートで、(プロトコル別に)レイヤ 2 プロトコル トンネリングをイネーブルにします。エッジ スイッチのトンネル ポートは、カスタマーの IEEE 802.1Q トランク ポートに接続され、エッジ スイッチのアクセス ポートは、カスタマーのアクセス ポートに接続されます。カスタマー スイッチに接続されているエッジ スイッチで、トンネリング処理が実行されます。

レイヤ 2 プロトコル トンネリングは、アクセス ポート、トンネル ポート、またはトランク ポートとして設定されたポート上でイネーブルにできます。スイッチポート モードを dynamic auto (デフォルト モード)または dynamic desirable に設定したポート上では、レイヤ 2 プロトコル トンネリングをイネーブルにできません。スイッチでは、CDP、STP、VTP のレイヤ 2 プロトコル トンネリングがサポートされます。ポイントツーポイント ネットワーク トポロジのエミュレートの場合は、PAgP、LACP、UDLD のプロトコルもサポートされます。スイッチでは、LLDP のレイヤ 2 プロトコル トンネリングはサポートされません。


注意 PAgP、LACP、および UDLD プロトコル トンネリングは、ポイントツーポイント トポロジをエミュレートすることだけを目的としています。設定を間違えたことによりトンネリング パケットが多くのポートに送信されると、ネットワーク障害が発生する可能性があります。

入力エッジ スイッチのレイヤ 2 プロトコル対応ポートに着信したレイヤ 2 PDU がトランク ポート経由でサービスプロバイダー ネットワークに送信されるとき、スイッチはカスタマー PDU 宛先 MAC アドレスを、シスコ独自の well-known マルチキャスト アドレス(01-00-0c-cd-cd-d0)で上書きします。IEEE 802.1Q トンネリングがイネーブルに設定されていなければ、パケットには二重タグも付けられます(外側のタグはカスタマー メトロ タグ、内側のタグはカスタマー VLAN タグ)。コア スイッチでは内部タグが無視され、同じメトロ VLAN のすべてのトランク ポートにパケットが転送されます。出力側のエッジ スイッチは適切なレイヤ 2 プロトコルおよび MAC アドレス情報を復元し、同じメトロ VLAN 上のすべてのトンネル ポート、アクセス ポート、およびレイヤ 2 プロトコル対応トランク ポートにパケットを転送します。したがって、レイヤ 2 PDU はそのまま維持され、サービスプロバイダー インフラストラクチャ経由でカスタマー ネットワークの反対側まで配信されます。

図 15-6 を参照してください。カスタマー X およびカスタマー Y が、それぞれアクセス VLAN 30 および 40 になっています。非対称リンクにより、サイト 1 のカスタマーは、サービスプロバイダー ネットワークのエッジ スイッチに接続されています。サイト 1 のカスタマー Y からスイッチ B に着信するレイヤ 2 PDU(たとえば、BPDU など)は、宛先 MAC アドレスとして well-known MAC アドレスを使用した二重タグ付きパケットとしてインフラストラクチャに転送されます。これらの二重タグ付きパケットには、外側 VLAN タグ 40 以外に、内側 VLAN タグ(たとえば、VLAN 100 など)があります。二重タグ付きパケットがスイッチ D に到達すると、外側 VLAN タグ 40 が削除され、well-known MAC アドレスが該当するレイヤ 2 プロトコル MAC アドレスに置き換えられ、パケットは VLAN 100 上で一重のタグ付きパケットとしてサイト 2 のカスタマー Y に送信されます。

カスタマー スイッチのアクセス ポートまたはトランク ポートに接続されたエッジ スイッチのアクセスまたはトランク ポート上で、レイヤ 2 プロトコル トンネリングをイネーブルにすることもできます。この場合、カプセル化およびカプセル化解除の動作は、パケットがサービスプロバイダー ネットワーク上で二重にタグ付けされない点を除いて、上記と同様です。カスタマー固有のアクセス VLAN タグの一重タグになります。

ここでは、レイヤ 2 プロトコル トンネリングの設定手順を説明します。具体的な内容は次のとおりです。

「レイヤ 2 プロトコル トンネリングのデフォルト設定」

「レイヤ 2 プロトコル トンネリング設定時の注意事項」

「レイヤ 2 トンネリングの設定」

「EtherChannel のレイヤ 2 トンネリングの設定」

レイヤ 2 プロトコル トンネリングのデフォルト設定

表 15-1 に、レイヤ 2 プロトコル トンネリングのデフォルト設定を示します。

 

表 15-1 レイヤ 2 イーサネット インターフェイス VLAN のデフォルト設定

機能
デフォルト設定

レイヤ 2 プロトコル トンネリング

CDP、STP、および VTP に関してディセーブル。

シャットダウンしきい値

ポートをシャットダウンするしきい値(ポート単位でのレイヤ 2 PDU のパケット/秒)は、設定なし。

ドロップしきい値

ポートが PDU をドロップするしきい値(ポート単位でのレイヤ 2 PDU のパケット/秒)は、設定なし。

サービス クラス(CoS)値

インターフェイスで CoS 値が設定されている場合は、その値がレイヤ 2 プロトコル トンネリングの BPDU CoS 値の設定に使用されます。インターフェイス レベルで CoS 値が設定されていない場合、L2 プロトコル トンネリング BPDU の CoS マーキングのデフォルト値は 5 です。このことはデータ トラフィックには適用されません。

レイヤ 2 プロトコル トンネリング設定時の注意事項

次に、レイヤ 2 プロトコル トンネリングの設定時の注意事項および動作特性を示します。

スイッチでは、CDP、STP(Multiple STP(MSTP)を含む)、VTP のトンネリングがサポートされます。プロトコル トンネリングはデフォルトでディセーブルですが、IEEE 802.1Q トンネル ポート、アクセス ポート、またはトランク ポート上で個々のプロトコルについてイネーブルに設定できます。

スイッチでは、ポイントツーポイント ネットワーク トポロジのエミュレートの場合、PAgP、LACP、UDLD のトンネリングがサポートされます。プロトコル トンネリングはデフォルトでディセーブルですが、IEEE 802.1Q トンネル ポート、アクセス ポート、またはトランク ポート上で個々のプロトコルについてイネーブルに設定できます。

スイッチは、スイッチポート モードが dynamic auto または dynamic desirable のポート上でのレイヤ 2 プロトコル トンネリングはサポートしません。

PAgP トンネリングまたは LACP トンネリングの場合は、リンク障害検出を高速にするため、インターフェイスで UDLD もイネーブルにするよう推奨します。

PAgP パケット、LACP パケット、または UDLD パケットのレイヤ 2 プロトコル トンネリングでは、ループバック検出がサポートされません。

ダイナミック トランキング プロトコル(DTP)は、レイヤ 2 プロトコル トンネリングとは非互換です。トンネル ポートとトランク ポートのある非対称リンクを手動で設定する必要があるからです。

出力側のエッジ スイッチは適切なレイヤ 2 プロトコルおよび MAC アドレス情報を復元し、同じメトロ VLAN 上のすべてのトンネル ポート、アクセス ポート、およびレイヤ 2 プロトコル対応トランク ポートにパケットを転送します。

サードパーティ ベンダー スイッチとの相互運用性のため、スイッチではレイヤ 2 プロトコルトンネル バイパス機能がサポートされます。バイパス モードでは、プロトコル トンネリングの制御方法が異なるベンダー スイッチに制御 PDU が透過的に転送されます。スイッチの入力ポートでレイヤ 2 プロトコル トンネルがイネーブルである場合は、出力トランク ポートにより、トンネリングされたパケットが特殊なカプセル化で転送されます。出力トランク ポート上でもレイヤ 2 プロトコル トンネリングをイネーブルに設定すると、この動作はバイパスされ、スイッチは制御 PDU を処理または変更することなく転送します。

IEEE 802.1Q 設定が EtherChannel ポート グループ内で矛盾しない場合、EtherChannel ポート グループにはトンネル ポートとの互換性があります。

トンネル ポートまたはレイヤ 2 トンネリングがイネーブルに設定されているアクセスまたはトランク ポートから(独自の宛先 MAC アドレスを使用して)カプセル化された PDU を受信した場合、ループを防ぐために、そのポートはシャットダウンされます。このポートは、プロトコル用に設定されたシャットダウンしきい値に達した場合にもシャットダウンされます。ポートを手動で再びイネーブルにする( shutdown および no shutdown コマンド シーケンスを使用する)ことができます。また、errdisable 回復機能をイネーブルに設定している場合、所定のタイム インターバルが経過したあとに動作が再試行されます。

カプセル化が解除された PDU だけがカスタマー ネットワークに転送されます。サービスプロバイダー ネットワーク上で動作しているスパニング ツリー インスタンスでは、BPDU がトンネル ポートに転送されません。トンネル ポートから CDP パケットが転送されることはありません。

インターフェイスでプロトコル トンネリングがイネーブルである場合は、カスタマー ネットワークによって生成された PDU 用に、プロトコルごとのシャットダウンしきい値やポートごとのシャットダウンしきい値を設定できます。制限を超えると、ポートはシャットダウンされます。また、トンネル ポート上で QoS ACL およびポリシー マップを使用して BPDU を速度制限することもできます。

インターフェイスでプロトコル トンネリングがイネーブルである場合は、カスタマー ネットワークによって生成された PDU 用に、プロトコルごとのドロップしきい値やポートごとのドロップしきい値を設定できます。この限界を超過すると、ポートは PDU を受信する速度がドロップしきい値より下になるまで、PDU をドロップします。

カスタマーの仮想ネットワークが正常に動作するには、トンネリングされる PDU(特に STP BPDU)をすべてのリモート サイトに配信する必要があるため、サービスプロバイダー ネットワーク上で同じトンネル ポートから受信するデータ パケットより高いプライオリティを PDU に与えることができます。デフォルトの場合、PDU ではデータ パケットと同じ CoS 値が使用されます。

レイヤ 2 トンネリングの設定

レイヤ 2 プロトコル トンネリング用にポートを設定するには、特権 EXEC モードで次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface-id

トンネル ポートとして設定するインターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。これは、カスタマー スイッチに接続するサービスプロバイダー ネットワークのエッジ ポートである必要があります。有効なインターフェイスには、物理インターフェイスおよびポートチャネル論理インターフェイス(ポート チャネル 1 ~ 12)が含まれます。

ステップ 3

switchport mode access
または
switchport mode dot1q-tunnel

または
switchport mode trunk

インターフェイスをアクセス ポート、IEEE 802.1Q トンネル ポート、またはトランク ポートとして設定します。

ステップ 4

l2protocol-tunnel [ cdp | stp | vtp ]

目的のプロトコルのプロトコル トンネリングをイネーブルにします。キーワードを入力しない場合、トンネリングは、3 つすべてのレイヤ 2 プロトコルでイネーブルになります。

ステップ 5

l2protocol-tunnel shutdown-threshold [ cdp | stp | vtp ] value

(任意)カプセル化用の受信について、インターフェイスをシャットダウンするまでのしきい値(パケット/秒)を設定します。設定したしきい値を超過すると、ポートがディセーブルになります。プロトコル オプションを指定しない場合、トンネリングされる各レイヤ 2 プロトコル タイプにしきい値が適用されます。指定できる範囲は 1 ~ 4096 です。デフォルトでは、しきい値は設定されていません。

(注) このインターフェイスでドロップしきい値も設定する場合、シャットダウンしきい値は、ドロップしきい値以上とする必要があります。

ステップ 6

l2protocol-tunnel drop-threshold [ cdp | stp | vtp ] value

(任意)カプセル化用の受信について、インターフェイスがパケットをドロップするまでのしきい値(パケット/秒)を設定します。設定したしきい値を超過すると、ポートはパケットをドロップします。プロトコル オプションを指定しない場合、トンネリングされる各レイヤ 2 プロトコル タイプにしきい値が適用されます。指定できる範囲は 1 ~ 4096 です。デフォルトでは、しきい値は設定されていません。

(注) このインターフェイスでシャットダウンしきい値も設定する場合、ドロップしきい値は、シャットダウンしきい値以下である必要があります。

ステップ 7

exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 8

errdisable recovery cause l2ptguard

(任意)レイヤ 2 最大レート エラーからの回復メカニズムを設定し、インターフェイスがディセーブル ステートから復帰して再試行できるようにします。タイム インターバルも設定できます。errdisable recovery はデフォルトでディセーブルになっています。イネーブルにした場合、デフォルトの間隔は 300 秒です。

ステップ 9

l2protocol-tunnel cos value

(任意)トンネリングされたすべてのレイヤ 2 PDU の CoS 値を設定します。範囲は 0 ~ 7 です。デフォルトは、インターフェイスのデフォルト CoS 値です。設定されていない場合、デフォルトは 5 です。

ステップ 10

end

特権 EXEC モードに戻ります。

ステップ 11

show l2protocol

スイッチ上のレイヤ 2 トンネル ポートを、設定されているプロトコル、しきい値、およびカウンタも含めて表示します。

ステップ 12

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

いずれかのレイヤ 2 プロトコル、または 3 つのプロトコル全部について、プロトコル トンネリングをディセーブルにするには、 no l2protocol-tunnel [ cdp | stp | vtp ] インターフェイス コンフィギュレーション コマンドを使用します。シャットダウンしきい値およびドロップしきい値をデフォルト設定に戻すには、 no l2protocol-tunnel shutdown-threshold [ cdp | stp | vtp ] コマンドおよび no l2protocol-tunnel drop-threshold [ cdp | stp | vtp ] コマンドを使用します。

次に、CDP、STP、VTP のレイヤ 2 プロトコル トンネリングを設定し、設定を確認する方法の例を示します。

Switch(config)# interface gigabitethernet1/0/2
Switch(config-if)# l2protocol-tunnel cdp
Switch(config-if)# l2protocol-tunnel stp
Switch(config-if)# l2protocol-tunnel vtp
Switch(config-if)# l2protocol-tunnel shutdown-threshold 1500
Switch(config-if)# l2protocol-tunnel drop-threshold 1000
Switch(config-if)# exit
Switch(config)# l2protocol-tunnel cos 7
Switch(config)# end
Switch# show l2protocol
COS for Encapsulated Packets: 7
 
Port Protocol Shutdown Drop Encapsulation Decapsulation Drop
Threshold Threshold Counter Counter Counter
------- -------- --------- --------- ------------- ------------- -------------
Gi1/0/2 cdp 1500 1000 0 0 0
stp 1500 1000 0 0 0
vtp 1500 1000 0 0 0

EtherChannel のレイヤ 2 トンネリングの設定

レイヤ 2 ポイントツーポイント トンネリングを設定して EtherChannel の自動作成を容易にするには、サービスプロバイダー エッジ スイッチおよびカスタマー スイッチの両方を設定する必要があります。

サービスプロバイダー エッジ スイッチの設定

EtherChannel のレイヤ 2 プロトコル トンネリング用にサービスプロバイダー エッジ スイッチを設定するには、特権 EXEC モードで次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface-id

インターフェイス コンフィギュレーション モードを開始し、トンネル ポートとして設定するインターフェイスを入力します。これは、カスタマー スイッチに接続するサービスプロバイダー ネットワークのエッジ ポートである必要があります。有効なインターフェイスは物理インターフェイスです。

ステップ 3

switchport mode dot1q-tunnel

IEEE 802.1Q トンネル ポートとしてインターフェイスを設定します。

ステップ 4

l2protocol-tunnel point-to-point [ pagp | lacp | udld ]

希望するプロトコルのポイントツーポイント プロトコル トンネリングをイネーブルにします。キーワードを入力しない場合、トンネリングは、3 つすべてのプロトコルでイネーブルになります。


注意 ネットワーク障害を避けるため、ネットワークがポイントツーポイント トポロジになっていることを確認してから、PAgP パケット、LACP パケット、または UDLD パケットのトンネリングをイネーブルにしてください。

ステップ 5

l2protocol-tunnel shutdown-threshold [ point-to-point [ pagp | lacp | udld ]] value

(任意)カプセル化用に 1 秒間に受信するパケット数のしきい値を設定します。設定したしきい値を超えると、インターフェイスはディセーブルになります。プロトコル オプションを指定しない場合、しきい値は、それぞれのトンネリングされたレイヤ 2 プロトコル タイプに適用されます。指定できる範囲は 1 ~ 4096 です。デフォルトでは、しきい値は設定されていません。

(注) このインターフェイスでドロップしきい値も設定する場合、シャットダウンしきい値は、ドロップしきい値以上とする必要があります。

ステップ 6

l2protocol-tunnel drop-threshold [ point-to-point [ pagp | lacp | udld ]] value

(任意)カプセル化用に 1 秒間に受信するパケット数のしきい値を設定します。設定したしきい値を超えると、インターフェイスによってパケットがドロップされます。プロトコル オプションを指定しない場合、しきい値は、それぞれのトンネリングされたレイヤ 2 プロトコル タイプに適用されます。指定できる範囲は 1 ~ 4096 です。デフォルトでは、しきい値は設定されていません。

(注) このインターフェイスでシャットダウンしきい値も設定する場合、ドロップしきい値は、シャットダウンしきい値以下である必要があります。

ステップ 7

no cdp enable

インターフェイス上で CDP をディセーブルにします。

ステップ 8

spanning-tree bpdufilter enable

インターフェイス上で BPDU フィルタリングをイネーブルにします。

ステップ 9

exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 10

errdisable recovery cause l2ptguard

(任意)インターフェイスを再びイネーブルにして再試行できるようにするため、レイヤ 2 最大レート エラーからの回復メカニズムを設定します。errdisable recovery はデフォルトでディセーブルになっています。イネーブルにした場合、デフォルトの間隔は 300 秒です。

ステップ 11

l2protocol-tunnel cos value

(任意)トンネリングされたすべてのレイヤ 2 PDU の CoS 値を設定します。範囲は 0 ~ 7 です。デフォルトは、インターフェイスのデフォルト CoS 値です。設定されていない場合、デフォルトは 5 です。

ステップ 12

end

特権 EXEC モードに戻ります。

ステップ 13

show l2protocol

設定されているプロトコル、しきい値、カウンタを含めた、スイッチのレイヤ 2 トンネル ポートを表示します。

ステップ 14

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

いずれかのレイヤ 2 プロトコルまたは 3 つすべてのレイヤ 2 プロトコルのポイントツーポイント プロトコル トンネリングをディセーブルにするには、 no l2protocol-tunnel [ point-to-point [ pagp | lacp | udld ]] インターフェイス コンフィギュレーション コマンドを使用します。シャットダウンしきい値およびドロップしきい値をデフォルト設定に戻すには、 no l2protocol-tunnel shutdown-threshold [ point-to-point [ pagp | lacp | udld ]] コマンドおよび no l2protocol-tunnel drop-threshold [ [ point-to-point [ pagp | lacp | udld ]] コマンドを使用します。

カスタマー スイッチの設定

サービスプロバイダー エッジ スイッチを設定したら、特権 EXEC モードで次の手順を実行し、EtherChannel のレイヤ 2 プロトコル トンネリング用にカスタマー スイッチを設定します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface-id

インターフェイス コンフィギュレーション モードを開始します。これは、カスタマー スイッチ ポートにする必要があります。

ステップ 3

switchport trunk encapsulation dot1q

トランキング カプセル化形式を IEEE 802.1Q に設定します。

キーワードは認識されません。

ステップ 4

switchport mode trunk

インターフェイス上でトランキングをイネーブルにします。

ステップ 5

udld enable

インターフェイスの 通常モード で UDLD をイネーブルにします。

ステップ 6

channel-group channel-group-number mode desirable

チャネル グループにインターフェイスを割り当て、PAgP モードに desirable を指定します。EtherChannel の設定の詳細については、「EtherChannel およびリンクステート トラッキングの設定」を参照してください。

ステップ 7

exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 8

interface port-channel port-channel number

ポートチャネル インターフェイス モードに入ります。

ステップ 9

shutdown

インターフェイスをシャットダウンします。

ステップ 10

no shutdown

インターフェイスをイネーブルにします。

ステップ 11

end

特権 EXEC モードに戻ります。

ステップ 12

show l2protocol

スイッチ上のレイヤ 2 トンネル ポートを、設定されているプロトコル、しきい値、およびカウンタも含めて表示します。

ステップ 13

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

インターフェイスをデフォルト設定に戻すには、 no switchport mode trunk no udld enable no channel group channel-group-number mode desirable インターフェイス コンフィギュレーション コマンドを使用します。

EtherChannel の場合は、サービスプロバイダー エッジ スイッチおよびカスタマー スイッチをレイヤ 2 プロトコル トンネリング用に設定する必要があります。

次に、図 15-8 にあるサービスプロバイダーのエッジ スイッチ A およびエッジ スイッチ B を設定する方法を示します。VLAN 17、18、19、20 はアクセス VLAN、ファスト イーサネット ポート 1 および 2 は PAgP および UDLD がイネーブルになっているポイントツーポイント トンネル ポート、ドロップしきい値は 1000、ファスト イーサネット ポート 3 はトランク ポートです。

サービスプロバイダー エッジ スイッチ A の設定

Switch(config)# interface fastethernet1/0/1
Switch(config-if)# switchport access vlan 17
Switch(config-if)# switchport mode dot1q-tunnel
Switch(config-if)# l2protocol-tunnel point-to-point pagp
Switch(config-if)# l2protocol-tunnel point-to-point udld
Switch(config-if)# l2protocol-tunnel drop-threshold point-to-point pagp 1000
Switch(config-if)# exit
Switch(config)# interface fastethernet1/0/2
Switch(config-if)# switchport access vlan 18
Switch(config-if)# switchport mode dot1q-tunnel
Switch(config-if)# l2protocol-tunnel point-to-point pagp
Switch(config-if)# l2protocol-tunnel point-to-point udld
Switch(config-if)# l2protocol-tunnel drop-threshold point-to-point pagp 1000
Switch(config-if)# exit
Switch(config)# interface fastethernet1/0/3
Switch(config-if)# switchport trunk encapsulation isl
Switch(config-if)# switchport mode trunk
 

サービスプロバイダー エッジ スイッチ B の設定

Switch(config)# interface fastethernet1/0/1
Switch(config-if)# switchport access vlan 19
Switch(config-if)# switchport mode dot1q-tunnel
Switch(config-if)# l2protocol-tunnel point-to-point pagp
Switch(config-if)# l2protocol-tunnel point-to-point udld
Switch(config-if)# l2protocol-tunnel drop-threshold point-to-point pagp 1000
Switch(config-if)# exit
Switch(config)# interface fastethernet1/0/2
Switch(config-if)# switchport access vlan 20
Switch(config-if)# switchport mode dot1q-tunnel
Switch(config-if)# l2protocol-tunnel point-to-point pagp
Switch(config-if)# l2protocol-tunnel point-to-point udld
Switch(config-if)# l2protocol-tunnel drop-threshold point-to-point pagp 1000
Switch(config-if)# exit
Switch(config)# interface fastethernet1/0/3
Switch(config-if)# switchport trunk encapsulation isl
Switch(config-if)# switchport mode trunk
 

次に、サイト 1 のカスタマー スイッチを設定する例を示します。ファスト イーサネット ポート 1、2、3、4 は IEEE 802.1Q トランキング用に設定されており、UDLD はイネーブル、EtherChannel グループ 1 はイネーブル、ポート チャネルはシャットダウンされたあとでイネーブルになって EtherChannel 設定がアクティブになります。

Switch(config)# interface fastethernet1/0/1
Switch(config-if)# switchport trunk encapsulation dot1q
Switch(config-if)# switchport mode trunk
Switch(config-if)# udld enable
Switch(config-if)# channel-group 1 mode desirable
Switch(config-if)# exit
Switch(config)# interface fastethernet1/0/2
Switch(config-if)# switchport trunk encapsulation dot1q
Switch(config-if)# switchport mode trunk
Switch(config-if)# udld enable
Switch(config-if)# channel-group 1 mode desirable
Switch(config-if)# exit
Switch(config)# interface fastethernet1/0/3
Switch(config-if)# switchport trunk encapsulation dot1q
Switch(config-if)# switchport mode trunk
Switch(config-if)# udld enable
Switch(config-if)# channel-group 1 mode desirable
Switch(config-if)# exit
Switch(config)# interface fastethernet1/0/4
Switch(config-if)# switchport trunk encapsulation dot1q
Switch(config-if)# switchport mode trunk
Switch(config-if)# udld enable
Switch(config-if)# channel-group 1 mode desirable
Switch(config-if)# exit
Switch(config)# interface port-channel 1
Switch(config-if)# shutdown
Switch(config-if)# no shutdown
Switch(config-if)# exit

トンネリングおよびマッピング ステータスのモニタリングおよびメンテナンス

表 15-2 に、IEEE 802.1Q およびレイヤ 2 プロトコル トンネリングと VLAN マッピングのモニタリングおよびメンテナンスに使用する特権 EXEC コマンドを示します。

 

表 15-2 トンネリングおよび VLAN マッピングのモニタリングおよびメンテナンス用コマンド

 

コマンド
目的

clear l2protocol-tunnel counters

レイヤ 2 プロトコル トンネリング ポートのプロトコル カウンタをクリアします。

show dot1q-tunnel

スイッチの IEEE 802.1Q トンネル ポートを表示します。

show dot1q-tunnel interface interface-id

特定インターフェイスがトンネル ポートであるかどうかを確認します。

show l2protocol-tunnel

レイヤ 2 プロトコル トンネリング ポートに関する情報を表示します。

show errdisable recovery

レイヤ 2 プロトコル トンネル エラー ディセーブル状態からの回復タイマーがイネーブルかどうかを確認します。

show interface interface-id vlan mapping

指定したインターフェイスの VLAN マッピング情報を表示します。インターフェイスには、ES ポートまたは VLAN を指定できます。

show l2protocol-tunnel interface interface-id

特定レイヤ 2 プロトコル トンネリング ポートに関する情報を表示します。

show l2protocol-tunnel summary

レイヤ 2 プロトコルのサマリー情報だけを表示します。

show vlan dot1q native

スイッチのネイティブ VLAN タグのステータスを表示します。

show vlan mapping

ES ポートの VLAN マッピング情報(VLAN マッピング テーブルの内容)を表示します。

この表示の詳細については、このリリースのコマンド リファレンスを参照してください。