Catalyst 3750 Metro スイッチ ソフトウェア コンフィギュレーション ガイド
スイッチの IP アドレスおよびデフォルト ゲートウェイの割り当て
スイッチの IP アドレスおよびデフォルト ゲートウェイの割り当て
発行日;2012/02/04 | 英語版ドキュメント(2011/06/02 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 12MB) | フィードバック

目次

スイッチの IP アドレスおよびデフォルト ゲートウェイの割り当て

ブート プロセスの概要

スイッチ情報の割り当て

デフォルトのスイッチ情報

DHCP ベースの自動設定の概要

DHCP クライアントの要求プロセス

DHCP ベースの自動設定およびイメージ アップデートの概要

DHCP 自動設定

DHCP の自動イメージ アップデート

制限事項および制約事項

DHCP ベースの自動設定の設定

DHCP サーバ設定時の注意事項

TFTP サーバの設定

DNS の設定

リレー デバイスの設定

コンフィギュレーション ファイルの入手方法

構成例

DHCP の自動設定およびイメージ アップデート機能の設定

DHCP 自動設定の設定(コンフィギュレーション ファイルだけ)

DHCP 自動イメージ アップデートの設定(コンフィギュレーション ファイルおよびイメージ)

クライアントの設定

手動での IP 情報の割り当て

実行コンフィギュレーションの確認および保存

スタートアップ コンフィギュレーションの変更

デフォルトのブート設定

コンフィギュレーション ファイルの自動ダウンロード

システム コンフィギュレーションを読み書きするためのファイル名の指定

手動でブートする場合

特定のソフトウェア イメージをブートする場合

環境変数の制御

ソフトウェア イメージ リロードのスケジュール設定

リロードのスケジュール設定

リロード スケジュール情報の表示

スイッチの IP アドレスおよびデフォルト ゲートウェイの割り当て

この章では、自動および手動による各種方法で、Catalyst 3750 Metro スイッチの初期設定(たとえば、スイッチ IP アドレスの割り当てやデフォルト ゲートウェイ情報)を作成する方法について説明します。スイッチのスタートアップ コンフィギュレーションを変更する方法についても説明します。


) この章で使用するコマンドの構文および使用方法の詳細については、このリリースのコマンド リファレンスおよび『Cisco IOS IP Command Reference, Volume 1 of 3: Addressing and Services, Release 12.2』 を参照してください。


この章で説明する内容は、次のとおりです。

「ブート プロセスの概要」

「スイッチ情報の割り当て」

「実行コンフィギュレーションの確認および保存」

「スタートアップ コンフィギュレーションの変更」

「ソフトウェア イメージ リロードのスケジュール設定」

ブート プロセスの概要

スイッチを起動するには、まず、ハードウェア インストレーション ガイドに記載された手順に従い、スイッチを設置し、電源を投入して、スイッチの初期設定(IP アドレス、サブネット マスク、デフォルト ゲートウェイ、シークレットおよび Telnet パスワードなど)を行う必要があります。

通常のブート プロセスにはブート ローダ ソフトウェアの動作が含まれます。ブート ローダは以下のアクティビティを実行します。

下位レベルの CPU 初期化を行います。CPU レジスタを初期化することにより、物理メモリがマッピングされる場所、容量、速度などを制御します。

CPU サブシステムの Power-on Self-Test(POST; 電源投入時自己診断テスト)を行います。CPU DRAM と、フラッシュ ファイル システムを構成するフラッシュ デバイスの部分をテストします。

システム ボード上のフラッシュ ファイル システムを初期化します。

デフォルトのオペレーティング システム ソフトウェア イメージをメモリにロードし、スイッチをブートします。

ブート ローダによってフラッシュ ファイル システムにアクセスしてから、オペレーティング システムをロードします。ブート ローダの使用目的は通常、オペレーティング システムのロード、圧縮解除、および起動に限定されます。オペレーティング システムが CPU を制御できるようになると、ブート ローダは、次にシステムがリセットされるか電源が投入されるまでは非アクティブになります。

また、オペレーティング システムが使用不可能になるほどの重大な障害が発生した場合は、ブート ローダはシステムにトラップドアからアクセスします。トラップドア メカニズムによるシステムへのアクセス機能を使用することで、必要に応じて、フラッシュ ファイル システムをフォーマットし、XMODEM プロトコルを使用してオペレーティング システムのソフトウェア イメージを再インストールし、失ったパスワードを回復して、最終的にオペレーティング システムを再起動できます。詳細については、「XMODEM プロトコルによるソフトウェア障害からの回復」および「パスワードを忘れた場合の回復」を参照してください。


) パスワードの回復をディセーブルにできます。詳細については、「パスワード回復のディセーブル化」を参照してください。


スイッチ情報を割り当てるには、PC または端末をコンソール ポートに接続し、PC またはターミナル エミュレーション ソフトウェアのボー レートおよびキャラクタ フォーマットをスイッチのコンソール ポートの設定と一致させておく必要があります。

デフォルトのボー レートは 9600 です。

デフォルトのデータ ビットは 8 です。


) データ ビット オプションを 8 に設定した場合、パリティ オプションは「なし」に設定します。


デフォルトのストップ ビットは 1 です。

デフォルトのパリティ設定は「なし」です。

スイッチ情報の割り当て

IP 情報を割り当てるには、スイッチのセットアップ プログラムを使用する方法、Dynamic Host Configuration Protocol(DHCP)サーバを使用する方法、または手動で実行する方法があります。

特定の IP 情報の設定が必要な場合、スイッチのセットアップ プログラムを使用してください。このプログラムを使用すると、ホスト名とイネーブル シークレット パスワードを設定することもできます。また、任意で、Telnet パスワードを割り当てたり(リモート管理中のセキュリティ確保のため)、スイッチをクラスタのコマンドまたはメンバー スイッチとして、あるいはスタンドアロン スイッチとして設定したりできます。セットアップ プログラムの詳細については、ハードウェアのインストール ガイドを参照してください。

サーバの設定後は DHCP サーバを使用して、IP 情報の集中管理と自動割り当てを行います。


) DHCP を使用している場合は、ダイナミックに割り当てられた IP アドレスをスイッチが受信してコンフィギュレーション ファイルを読み込むまでは、セットアップ プログラムの質問に応答しないでください。


スイッチの設定手順を熟知している経験豊富なユーザの場合は、スイッチを手動で設定してください。それ以外のユーザは、前述のセットアップ プログラムを使用してください。

ここでは、次の設定情報について説明します。

「デフォルトのスイッチ情報」

「DHCP ベースの自動設定の概要」

「手動での IP 情報の割り当て」

デフォルトのスイッチ情報

表 3-1 に、デフォルトのスイッチ情報を示します。

 

表 3-1 デフォルトのスイッチ情報

機能
デフォルト設定

IP アドレスおよびサブネット マスク

IP アドレスまたはサブネット マスクは定義されていません。

デフォルト ゲートウェイ

デフォルト ゲートウェイは定義されていません。

イネーブル シークレット パスワード

パスワードは定義されていません。

ホスト名

出荷時に割り当てられたデフォルトのホスト名は Switch です。

Telnet パスワード

パスワードは定義されていません。

クラスタ コマンド スイッチ機能

ディセーブル。

クラスタ名

クラスタ名は定義されません。

DHCP ベースの自動設定の概要

DHCP は、インターネット ホストおよびインターネットワーキング デバイスに設定情報を提供します。このプロトコルは、2 つのコンポーネントからなります。1 つは DHCP サーバからデバイスにコンフィギュレーション パラメータを提供するコンポーネント、もう 1 つはデバイスにネットワーク アドレスを割り当てるコンポーネントです。DHCP はクライアント/サーバ モデルに基づいています。指定された DHCP サーバが、ダイナミックに設定されるデバイスに対して、ネットワーク アドレスを割り当て、コンフィギュレーション パラメータを提供します。スイッチは、DHCP クライアントおよび DHCP サーバとして機能できます。

DHCP ベースの自動設定では、スイッチ(DHCP クライアント)は起動時に、IP アドレス情報およびコンフィギュレーション ファイルを使用して自動的に設定されます。

DHCP ベースの自動設定を使用すると、スイッチ上で DHCP クライアント側の設定を行う必要はありません。ただし、DHCP サーバで、IP アドレスに関連した各種リース オプションを設定する必要があります。DHCP を使用してネットワーク上でコンフィギュレーション ファイルをリレーする場合は、Trivial File Transfer Protocol(TFTP; 簡易ファイル転送プロトコル)サーバおよび Domain Name System(DNS; ドメイン ネーム システム)サーバの設定が必要なこともあります。

スイッチの DHCP サーバは、スイッチと同じ LAN 上に配置することも、そのスイッチとは別の LAN 上に配置することもできます。DHCP サーバが異なる LAN 上で動作している場合、スイッチと DHCP サーバ間に、DHCP のリレー デバイスを設定する必要があります。リレー デバイスは、直接接続されている 2 つの LAN 間でブロードキャスト トラフィックを転送します。ルータはブロードキャスト パケットを転送しませんが、受信したパケットの宛先 IP アドレスに基づいてパケットを転送します。

DHCP ベースの自動設定は、スイッチの BOOTP クライアント機能に代わるものです。

DHCP クライアントの要求プロセス

スイッチを起動したときに、スイッチにコンフィギュレーション ファイルがない場合は、DHCP クライアントが起動され、DHCP サーバに対して設定情報を要求します。コンフィギュレーション ファイルが存在し、その設定に特定のルーテッド インターフェイスの ip address dhcp インターフェイス コンフィギュレーション コマンドが含まれる場合、DHCP クライアントが呼び出され、DHCP クライアントがインターフェイスの IP アドレス情報を要求します。

図 3-1 に、DHCP クライアントと DHCP サーバ間で交換される一連のメッセージを示します。

図 3-1 DHCP クライアント/サーバ間のメッセージ交換

 

クライアントであるスイッチ A は、DHCP サーバの場所を特定するために、DHCPDISCOVER メッセージをブロードキャストします。DHCP サーバは、DHCPOFFER ユニキャスト メッセージによって、使用可能なコンフィギュレーション パラメータ(IP アドレス、サブネット マスク、ゲートウェイ IP アドレス、DNS IP アドレス、IP アドレス用のリースなど)をクライアントに提示します。

DHCPREQUEST ブロードキャスト メッセージでは、クライアントは、提示された設定情報に対して、DHCP サーバに正式な要求を戻します。この正式な要求はブロードキャストされるため、クライアントから DHCPDISCOVER ブロードキャスト メッセージを受信した他のすべての DHCP サーバは、クライアントに提示した IP アドレスを再利用できます。

DHCP サーバは、DHCPACK ユニキャスト メッセージをクライアントに戻すことで、IP アドレスがクライアントに割り当てられたことを確認します。このメッセージによって、クライアントとサーバはバインドされ、クライアントはサーバから受信した設定情報を使用します。スイッチの受信する情報量は、DHCP サーバの設定方法によって異なります。詳細については、「DHCP サーバの設定」を参照してください。

DHCPOFFER ユニキャスト メッセージによってクライアントに送信されたコンフィギュレーション パラメータが無効である(コンフィギュレーション エラーがある)場合、クライアントは DHCP サーバに、DHCPDECLINE ブロードキャスト メッセージを戻します。

DHCP サーバはクライアントに、提示されたコンフィギュレーション パラメータが割り当てられていない、パラメータのネゴシエーション中にエラーが発生した、または DHCPOFFER メッセージに対するクライアントの応答が遅れている(DHCP サーバがパラメータを別のクライアントに割り当てた)という意味の DHCPNAK 拒否ブロードキャスト メッセージを送信します。

DHCP クライアントは、複数の DHCP サーバまたは BOOTP サーバから提示を受け取り、そのうちの任意の 1 つを受け入れることができますが、通常は最初に受け取った提示を受け入れます。DHCP サーバから提示された IP アドレスが必ずしもクライアントに割り当てられるわけではありません。ただし、サーバは通常、クライアントが正式にアドレスを要求するまではアドレスを確保しておきます。スイッチが BOOTP サーバからの応答を受け入れて、自身を設定する場合、スイッチはスイッチ コンフィギュレーション ファイルを入手するために、TFTP 要求をユニキャストするのではなくブロードキャストします。

DHCP ホスト名オプションを使用すると、スイッチのグループが集中管理 DHCP サーバからホスト名および標準設定を取得できます。クライアント(スイッチ)の DCHPDISCOVER メッセージには、ホスト名およびその他のコンフィギュレーション パラメータを DHCP サーバから要求するために使用される Option 12 フィールドが含まれます。すべてのクライアントのコンフィギュレーション ファイルは、DHCP から取得したホスト名を除いて同一です。

クライアントのホスト名がデフォルトである( hostname name グローバル コンフィギュレーション コマンドが設定されていない、またはホスト名を削除する no hostname グローバル コンフィギュレーション コマンドが入力される)場合は、 ip address dhcp インターフェイス コンフィギュレーション コマンドを入力するときに、DHCP ホスト名オプションはパケットに含まれません。この場合、インターフェイスの IP アドレスを取得するときにクライアントが DHCP との相互作用から DCHP ホスト名オプションを受信すると、クライアントは DCHP ホスト名オプションを受け入れ、システムでホスト名が設定されることを示すフラグを設定します。

DHCP ベースの自動設定およびイメージ アップデートの概要

DHCP のイメージ アップデート機能を使用すると、新しいイメージおよび新しいコンフィギュレーション ファイルの両方をネットワーク内の 1 つまたは複数のスイッチにダウンロードするように DHCP サーバを設定できます。これにより、ネットワークに追加された新しいスイッチはそれぞれ同じイメージおよびコンフィギュレーションを受け取ることができます。

DHCP イメージ アップグレードには、DHCP 自動設定と DHCP 自動イメージ アップデートの 2 種類があります。

DHCP 自動設定

DHCP 自動設定により、コンフィギュレーション ファイルは DHCP サーバからネットワーク内の 1 つまたは複数のスイッチにダウンロードされます。ダウンロードされたコンフィギュレーション ファイルは、スイッチの実行コンフィギュレーションとなります。フラッシュに保存されている起動コンフィギュレーションは、スイッチをリロードするまで上書きされません。

DHCP の自動イメージ アップデート

DHCP 自動イメージ アップデート機能を DHCP 自動設定と併用することにより、コンフィギュレーションおよび新しいイメージの両方をネットワーク内の 1 つまたは複数のスイッチにダウンロードできます。新しいコンフィギュレーションおよび新しいイメージがダウンロードされるスイッチ(または複数のスイッチ)は、ブランク(または、工場出荷時のデフォルト設定だけがロードされた状態)である場合があります。

すでにコンフィギュレーションを持っているスイッチに新しいコンフィギュレーションがダウンロードされる場合、ダウンロードされたコンフィギュレーションはスイッチにストアされているコンフィギュレーション ファイルに追加されます(既存のコンフィギュレーションはいずれも、ダウンロードされたコンフィギュレーションにより上書きされません)。


) スイッチ上で DHCP 自動イメージ アップデートをイネーブルにするには、イメージおよびコンフィギュレーション ファイルが配置されている TFTP サーバを Option 67(コンフィギュレーション ファイル名)、Option 66(DHCP サーバのホスト名)、Option 150(TFTP サーバのアドレス)、および Option 125(ファイルの説明)により適切に設定する必要があります。

スイッチを DHCP サーバとして設定する場合の手順については、「DHCP ベースの自動設定の設定」および『Cisco IOS IP Configuration Guide, Release 12.2』 の「IP Addressing and Services」の章にある「Configuring DHCP」を参照してください。


ネットワークにスイッチを設置したあと、自動イメージ アップデート機能が開始されます。ダウンロードされたコンフィギュレーション ファイルは、スイッチの実行コンフィギュレーションに保存され、新しいイメージはスイッチにダウンロードされ、インストールされます。スイッチをリブートすると、このコンフィギュレーションはスイッチに保存されたコンフィギュレーションにストアされます。

制限事項および制約事項

次に、制限事項について説明します。

保存コンフィギュレーション付き DHCP ベースの自動設定プロセスを実行するには、ネットワーク内に IP アドレスが割り当てられていないアップ状態のレイヤ 3 インターフェイスが最低 1 つは存在している必要があります。

タイムアウトが設定されないかぎり、保存コンフィギュレーション付き DHCP ベースの自動設定機能では無限に IP アドレスをダウンロードしようとします。

コンフィギュレーション ファイルをダウンロードできない場合、またはコンフィギュレーション ファイルが破損している場合、自動インストール プロセスは停止します。


) TFTP からダウンロードされるコンフィギュレーション ファイルは、実行コンフィギュレーション中の既存のコンフィギュレーションと統合されます。ただし、NVRAM に保存するには、write memory または copy running-configuration startup-configuration 特権 EXEC コマンドを入力する必要があります。ダウンロードされたコンフィギュレーションがスタートアップ コンフィギュレーションに保存された場合、そのあとのシステム再起動時にこの機能はトリガーされません。


DHCP ベースの自動設定の設定

ここでは、DHCP ベースの自動設定機能を設定する方法について説明します。

「DHCP サーバ設定時の注意事項」

「TFTP サーバの設定」

「DNS の設定」

「リレー デバイスの設定」

「コンフィギュレーション ファイルの入手方法」

「構成例」

DHCP サーバがシスコのものである場合、DHCP 設定に関する詳細は、『 Cisco IOS IP Configuration Guide, Release 12.2 』の「IP Addressing and Services」の章にある「Configuring DHCP」の部分を参照してください。

DHCP サーバ設定時の注意事項

デバイスを DHCP サーバとして設定する場合、次の注意事項に従ってください。

DHCP サーバには、スイッチのハードウェア アドレスによって各スイッチとバインドされている予約済みのリースを設定する必要があります。

スイッチに IP アドレス情報を受信させるには、DHCP サーバに次のリース オプションを設定する必要があります。

クライアントの IP アドレス(必須)

クライアントのサブネット マスク(必須)

DNS サーバの IP アドレス(任意)

ルータの IP アドレス(スイッチで使用するデフォルト ゲートウェイ アドレス)(必須)

スイッチに TFTP サーバからコンフィギュレーション ファイルを受信させる場合は、DHCP サーバに次のリース オプションを設定する必要があります。

TFTP サーバ名(必須)

ブート ファイル名(クライアントが必要とするコンフィギュレーション ファイル名)(推奨)

ホスト名(任意)

DHCP サーバの設定によっては、スイッチは IP アドレス情報またはコンフィギュレーション ファイル、あるいはその両方を受信できます。

前述のリース オプションを設定しなかった場合、DHCP サーバは、設定されたパラメータだけを使用してクライアントの要求に応答します。IP アドレスおよびサブネット マスクが応答に含まれていないと、スイッチは設定されません。ルータの IP アドレスまたは TFTP サーバ名が見つからなかった場合、スイッチは TFTP 要求をユニキャストしないでブロードキャストする場合があります。その他のリース オプションは、使用できなくても自動設定には影響しません。

スイッチは DHCP サーバとして機能します。デフォルトでは、Cisco IOS DHCP サーバおよびリレー エージェント機能はスイッチ上でイネーブルですが、設定されていません。これらの機能は動作しません。DHCP サーバがシスコのものである場合、DHCP 設定に関する詳細は、『 Cisco IOS IP Configuration Guide 』の「IP Addressing and Services」の章にある「Configuring DHCP」の部分を参照してください。このマニュアルには、Cisco.com の [Documentation] > [Cisco IOS Software] > [12.2 Mainline] > [Configuration Guides] からアクセスできます。

TFTP サーバの設定

DHCP サーバの設定に基づいて、スイッチは TFTP サーバから 1 つまたは複数のコンフィギュレーション ファイルをダウンロードしようとします。TFTP サーバへの IP 接続に必要なすべてのオプションについてスイッチに応答するよう DHCP サーバを設定している場合で、なおかつ、TFTP サーバ名、アドレス、およびコンフィギュレーション ファイル名を指定して DHCP サーバを設定している場合、スイッチは指定された TFTP サーバから指定されたコンフィギュレーション ファイルをダウンロードしようとします。

コンフィギュレーション ファイル名、および TFTP サーバを指定しなかった場合、またはコンフィギュレーション ファイルをダウンロードできなかった場合は、スイッチはファイル名と TFTP サーバ アドレスをさまざまに組み合わせてコンフィギュレーション ファイルをダウンロードしようとします。ファイルには、(存在する場合)特定のコンフィギュレーション ファイル名と次のファイルが指定されています。network-config、cisconet.cfg、 hostname .config、または hostname .cfg です。この場合、 hostname はスイッチの現在のホスト名です。使用される TFTP サーバアドレスには、(存在する場合)指定された TFTP サーバのアドレス、およびブロードキャスト アドレス(255.255.255.255)が含まれています。

スイッチが正常にコンフィギュレーション ファイルをダウンロードするには、TFTP サーバのベース ディレクトリに 1 つまたは複数のコンフィギュレーション ファイルが含まれていなければなりません。含めることのできるファイルは、次のとおりです。

DHCP 応答で指定されているコンフィギュレーション ファイル(実際のスイッチ コンフィギュレーション ファイル)

network-confg または cisconet.cfg ファイル(デフォルトのコンフィギュレーション ファイル)

router-confg または ciscortr.cfg ファイル(これらのファイルには、すべてのスイッチに共通のコマンドが含まれています。通常、DHCP および TFTP サーバが適切に設定されていれば、これらのファイルはアクセスされません)

DHCP サーバ リース データベースに TFTP サーバ名を指定する場合は、DNS サーバのデータベースに TFTP サーバ名と IP アドレスのマッピングを設定することも必要です。

使用する TFTP サーバが、スイッチとは異なる LAN 上にある場合、またはスイッチがブロードキャスト アドレスを使用してアクセスした場合(前述のすべての必須情報が DHCP サーバの応答に含まれていない場合に発生)は、リレーを設定して TFTP サーバに TFTP パケットを転送する必要があります。詳細については、「リレー デバイスの設定」を参照してください。適切な解決方法は、必要なすべての情報を使用して DHCP サーバを設定することです。

DNS の設定

DHCP サーバは、DNS サーバを使用して TFTP サーバ名を IP アドレスに変換します。DNS サーバ上で、TFTP サーバ名から IP アドレスへのマッピングを設定する必要があります。TFTP サーバには、スイッチのコンフィギュレーション ファイルが存在します。

DHCP の応答時に IP アドレスを取得する DHCP サーバのリース データベースに、DNS サーバの IP アドレスを設定できます。リース データベースには、DNS サーバの IP アドレスを 2 つまで入力できます。

DNS サーバは、スイッチと同じ LAN 上に配置することも、そのスイッチとは別の LAN 上に配置することもできます。DHCP サーバが別の LAN 上に存在する場合、スイッチはルータを介して DHCP サーバにアクセスできなければなりません。

リレー デバイスの設定

異なる LAN 上にあるホストからの応答が必要なブロードキャスト パケットをスイッチが送信する場合は、リレー デバイス( リレー エージェント )を設定する必要があります。スイッチが送信する可能性のあるブロードキャスト パケットの例として DHCP パケット、DNS パケット、場合によっては TFTP パケットが挙げられます。リレー デバイスは、インターフェイス上の受信ブロードキャスト パケットを宛先ホストに転送するように設定しなければなりません。

リレー デバイスが Cisco ルータである場合、IP ルーティングをイネーブルにし( ip routing グローバル コンフィギュレーション コマンド)、 ip helper-address インターフェイス コンフィギュレーション コマンドを使用して、ヘルパー アドレスを設定します。

図 3-2 では、ルータ インターフェイスを次のように設定しています。

インターフェイス 10.0.0.2 では、

router(config-if)# ip helper-address 20.0.0.2
router(config-if)# ip helper-address 20.0.0.3
router(config-if)# ip helper-address 20.0.0.4
 

インターフェイス 20.0.0.1 では、

router(config-if)# ip helper-address 10.0.0.1

図 3-2 自動設定でのリレー デバイスの使用

 

コンフィギュレーション ファイルの入手方法

IP アドレスおよびコンフィギュレーション ファイル名が DHCP で予約済みのリースとして取得できるかどうかに応じて、スイッチは次の方法で設定情報を入手します。

IP アドレスおよびコンフィギュレーション ファイル名が、スイッチ用に予約され、DHCP 応答(1 ファイル読み込み方式)で提供されている場合

スイッチは DHCP サーバから、IP アドレス、サブネット マスク、TFTP サーバ アドレス、およびコンフィギュレーション ファイル名を受信します。さらにスイッチは、TFTP サーバのベース ディレクトリから指定のコンフィギュレーション ファイルを検索するために、TFTP サーバにユニキャスト メッセージを送信します。指定されたコンフィギュレーション ファイルを受信すると、スイッチの起動プロセスは完了します。

スイッチの IP アドレスおよびコンフィギュレーション ファイル名が予約されているが、DHCP 応答に TFTP サーバ アドレスが含まれていない場合(1 ファイル読み込み方式)

スイッチは DHCP サーバから、IP アドレス、サブネット マスク、およびコンフィギュレーション ファイル名を受信します。さらにスイッチは、TFTP サーバにブロードキャスト メッセージを送信してサーバのベース ディレクトリから指定のコンフィギュレーション ファイルを検索します。指定されたコンフィギュレーション ファイルを受信すると、スイッチのブート プロセスは完了します。

IP アドレスだけがスイッチ用に予約され、DHCP 応答で提供されており、コンフィギュレーション ファイル名は提供されない場合(2 ファイル読み込み方式)

スイッチは DHCP サーバから、IP アドレス、サブネット マスク、および TFTP サーバ アドレスを受信します。スイッチは、TFTP サーバにユニキャスト メッセージを送信し、network-confg または cisconet.cfg のデフォルト コンフィギュレーション ファイルを取得します(network-confg ファイルが読み込めない場合、スイッチは cisconet.cfg ファイルを読み込みます)。

デフォルト コンフィギュレーション ファイルには、スイッチのホスト名から IP アドレスへのマッピングが含まれています。スイッチは、ファイルの情報をホスト テーブルに書き込み、ホスト名を入手します。ファイルにホスト名がない場合、スイッチは DHCP 応答で指定されたホスト名を使用します。DHCP 応答でホスト名が指定されていない場合、スイッチはデフォルトの Switch をホスト名として使用します。

デフォルトのコンフィギュレーション ファイルまたは DHCP 応答からホスト名を入手したあと、スイッチはホスト名と同じ名前のコンフィギュレーション ファイル(network-confg または cisconet.cfg のどちらが読み込まれたかに応じて、 hostname -confg または hostname .cfg)を TFTP サーバから読み込みます。cisconet.cfg ファイルが読み込まれている場合は、ホストのファイル名は 8 文字に切り捨てられます。

network-confg、cisconet.cfg、またはホスト名と同じ名前のファイルを読み込むことができない場合、スイッチは router-confg ファイルを読み込みます。router-confg ファイルを読み込むことができない場合、スイッチは ciscortr.cfg ファイルを読み込みます。


) DHCP 応答から TFTP サーバを入手できなかった場合、ユニキャスト伝送によるコンフィギュレーション ファイルの読み込みに失敗した場合、または TFTP サーバ名を IP アドレスに変換できない場合には、スイッチは TFTP サーバ要求をブロードキャストします。


構成例

図 3-3 に、DHCP ベースの自動設定を使用して IP 情報を検索するネットワークの構成例を示します。

図 3-3 DHCP ベースの自動設定を使用するネットワークの構成例

 

表 3-2 は、DHCP サーバ上の予約済みリースの設定例です。

 

表 3-2 DHCP サーバ コンフィギュレーション

スイッチ A
スイッチ B
スイッチ C
スイッチ D

バインディング キー(ハードウェア アドレス)

00e0.9f1e.2001

00e0.9f1e.2002

00e0.9f1e.2003

00e0.9f1e.2004

IP アドレス

10.0.0.21

10.0.0.22

10.0.0.23

10.0.0.24

サブネット マスク

255.255.255.0

255.255.255.0

255.255.255.0

255.255.255.0

ルータ アドレス

10.0.0.10

10.0.0.10

10.0.0.10

10.0.0.10

DNS サーバ アドレス

10.0.0.2

10.0.0.2

10.0.0.2

10.0.0.2

TFTP サーバ名

tftpserver または 10.0.0.3

tftpserver または 10.0.0.3

tftpserver または 10.0.0.3

tftpserver または 10.0.0.3

ブート ファイル名(コンフィギュレーション ファイル)(任意)

switcha-confg

switchb-confg

switchc-confg

switchd-confg

ホスト名(任意)

switcha

switchb

switchc

switchd

DNS サーバ コンフィギュレーション

DNS サーバは、TFTP サーバ名の maritsu を IP アドレス 10.0.0.3 にマッピングします。

TFTP サーバ コンフィギュレーション(UNIX)

TFTP サーバのベース ディレクトリは、/tftpserver/work/ に設定されています。このディレクトリには、2 ファイル読み込み方式で使用される network-confg ファイルがあります。このファイルには、IP アドレスに基づいてスイッチに割り当てられるホスト名が含まれています。ベース ディレクトリには、次に示すように、各スイッチのコンフィギュレーション ファイル( switcha-confg switchb-confg など)も含まれています。

prompt> cd /tftpserver/work/
prompt> ls
network-confg
switcha-confg
switchb-confg
switchc-confg
switchd-confg
prompt> cat network-confg
ip host switcha 10.0.0.21
ip host switchb 10.0.0.22
ip host switchc 10.0.0.23
ip host switchd 10.0.0.24
 

DHCP クライアント コンフィギュレーション

スイッチ A ~ D には、コンフィギュレーション ファイルは存在しません。

コンフィギュレーションの説明

図 3-3 の場合、スイッチ A はコンフィギュレーション ファイルを次のようにして読み込みます。

DHCP サーバから IP アドレス 10.0.0.21 を入手します。

DHCP サーバの応答でコンフィギュレーション ファイル名が提供されない場合、スイッチ A は TFTP サーバのベース ディレクトリから network-confg ファイルを読み込みます。

ホスト テーブルに network-confg ファイルの内容を追加します。

IP アドレス 10.0.0.21 をもとにホスト テーブルを検索し、ホスト名(switcha)を取得します。

ホスト名に対応するコンフィギュレーション ファイルを読み取ります。たとえば、TFTP サーバから switcha-confg ファイルを読み取ります。

スイッチ B ~ D も、同様にコンフィギュレーション ファイルおよび IP アドレスを取得します。

DHCP の自動設定およびイメージ アップデート機能の設定

DHCP を使用して、新しいイメージおよび新しいコンフィギュレーションをスイッチにダウンロードするには、少なくとも 2 つのスイッチ(1 つのスイッチは DHCP サーバおよび TFTP サーバとして動作)を設定する必要があります。クライアント スイッチは、新しいコンフィギュレーション ファイルまたは新しいコンフィギュレーション ファイルおよび新しいイメージ ファイルをダウンロードするように設定されます。

DHCP 自動設定の設定(コンフィギュレーション ファイルだけ)

新しいスイッチで TFTP 設定および DHCP 設定の DHCP 自動設定を設定して、新しいコンフィギュレーション ファイルをダウンロードするには、特権 EXEC モードで次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

ip dhcp poolname

DHCP サーバ アドレス プールの名前を作成し、DHCP プール コンフィギュレーション モードを開始します。

ステップ 3

bootfile filename

ブート イメージとして使用されるコンフィギュレーション ファイルの名前を指定します。

ステップ 4

network network-number mask prefix-length

DHCP アドレス プールのサブネット ネットワーク番号およびマスクを指定します。

(注) プレフィクス長により、アドレス プレフィクスを構成するビット数が指定されます。プレフィクスは、クライアントのネットワーク マスクを指定する代替方法です。プレフィクス長は、フォワード スラッシュ(/)が前に付く必要があります。

ステップ 5

default-router address

DHCP クライアントのデフォルト ルータの IP アドレスを指定します。

ステップ 6

option 150 address

TFTP サーバの IP アドレスを指定します。

ステップ 7

exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 8

tftp-server flash :filename.text

TFTP サーバ上のコンフィギュレーション ファイルを指定します。

ステップ 9

interface interface-id

コンフィギュレーション ファイルを受信するクライアントのアドレスを指定します。

ステップ 10

no switchport

インターフェイスをレイヤ 3 モードにします。

ステップ 11

ip address address mask

インターフェイスの IP アドレスおよびマスクを指定します。

ステップ 12

end

特権 EXEC モードに戻ります。

ステップ 13

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

  • 次に、DHCP サーバとして設定されたスイッチがコンフィギュレーション ファイルをダウンロードする例を示します。
Switch# configure terminal
Switch(config)# ip dhcp pool pool1
Switch(dhcp-config)# network 10.10.10.0 255.255.255.0
Switch(dhcp-config)# bootfile config-boot.text
Switch(dhcp-config)# default-router 10.10.10.1
Switch(dhcp-config)# option 150 10.10.10.1
Switch(dhcp-config)# exit
Switch(config)# tftp-server flash:config-boot.text
Switch(config)# interface gigabitethernet1/0/4
Switch(config-if)# no switchport
Switch(config-if)# ip address 10.10.10.1 255.255.255.0
Switch(config-if)# end

DHCP 自動イメージ アップデートの設定(コンフィギュレーション ファイルおよびイメージ)

新しいスイッチで TFTP および DHCP の設定を行う DHCP 自動設定を設定して、新しいイメージおよび新しいコンフィギュレーション ファイルをダウンロードするには、特権 EXEC モードで次の手順を実行します。


) このテーブルの手順を実行する前に、スイッチにアップロードされるテキスト ファイル(autoinstall_dhcp など)を作成する必要があります。テキスト ファイルには、ダウンロードするイメージの名前を入力します(c3750m-ipservices-mz.122-44.3.SE.tar など)。このイメージは、tar ファイルであり、bin ファイルではありません。


 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

ip dhcp pool name

DHCP サーバ アドレス プールの名前を作成し、DHCP プール コンフィギュレーション モードを開始します。

ステップ 3

bootfile filename

ブート イメージとして使用されるファイルの名前を指定します。

ステップ 4

network network-number mask prefix-length

DHCP アドレス プールのサブネット ネットワーク番号およびマスクを指定します。

(注) プレフィクス長により、アドレス プレフィクスを構成するビット数が指定されます。プレフィクスは、クライアントのネットワーク マスクを指定する代替方法です。プレフィクス長は、フォワード スラッシュ(/)が前に付く必要があります。

ステップ 5

default-router address

DHCP クライアントのデフォルト ルータの IP アドレスを指定します。

ステップ 6

option 150 address

TFTP サーバの IP アドレスを指定します。

ステップ 7

option 125 hex

イメージ ファイルへのパスを記述するテキスト ファイルへのパスを指定します。

ステップ 8

copy tftp flash filename.txt

テキスト ファイルをスイッチにアップロードします。

ステップ 9

copy tftp flash imagename.tar

スイッチに新しいイメージの tar ファイルをアップロードします。

ステップ 10

exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 11

tftp-server flash:config.text

TFTP サーバ上の Cisco IOS コンフィギュレーション ファイルを指定します。

ステップ 12

tftp-server flash:imagename.tar

TFTP サーバ上のイメージ名を指定します。

ステップ 13

tftp-server flash:filename.txt

ダウンロードするイメージ ファイルの名前を含むテキスト ファイルを指定します。

ステップ 14

interface interface-id

コンフィギュレーション ファイルを受信するクライアントのアドレスを指定します。

ステップ 15

no switchport

インターフェイスをレイヤ 3 モードにします。

ステップ 16

ip address address mask

インターフェイスの IP アドレスおよびマスクを指定します。

ステップ 17

end

特権 EXEC モードに戻ります。

ステップ 18

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

  • 次に、DHCP サーバとして設定されたスイッチがコンフィギュレーション ファイルをダウンロードする例を示します。
Switch# config terminal
Switch(config)# ip dhcp pool pool1
Switch(dhcp-config)# network 10.10.10.0 255.255.255.0
Switch(dhcp-config)# bootfile config-boot.text
Switch(dhcp-config)# default-router 10.10.10.1
Switch(dhcp-config)# option 150 10.10.10.1
Switch(dhcp-config)# option 125 hex 0000.0009.0a05.08661.7574.6f69.6e73.7461.6c6c.5f64.686370
Switch(dhcp-config)# exit
Switch(config)# tftp-server flash:config-boot.text
Switch(config)# tftp-server flash:c3750m-ipservices-mz.122-44.3.SE.tar
Switch(config)# tftp-server flash:boot-config.text
Switch(config)# tftp-server flash: autoinstall_dhcp
Switch(config)# interface gigabitEthernet1/0/4
Switch(config-if)# no switchport
Switch(config-if)# ip address 10.10.10.1 255.255.255.0
Switch(config-if)# end

クライアントの設定

DHCP サーバからコンフィギュレーション ファイルおよび新しいイメージをダウンロードするようにスイッチを設定するには、特権 EXEC モードで次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

boot host dhcp

保存コンフィギュレーション付き自動設定をイネーブルにします。

ステップ 3

boot host retry timeout timeout-value

(任意)システムがコンフィギュレーション ファイルのダウンロードを試行する時間を設定します。

(注) タイムアウトを設定しなければ、システムは無限に DHCP サーバから IP アドレスを取得しようとします。

ステップ 4

banner config-save ^C warning-message ^C

(任意)コンフィギュレーション ファイルを NVRAM に保存しようとした場合に表示される、警告メッセージを作成します。

ステップ 5

end

特権 EXEC モードに戻ります。

ステップ 6

show boot

設定を確認します。

次に、VLAN 99 のレイヤ 3 SVI インターフェイスを使用して、保存コンフィギュレーション付き DHCP ベースの自動設定をイネーブルにする例を示します。

Switch# configure terminal
Switch(conf)# boot host dhcp
Switch(conf)# boot host retry timeout 300
Switch(conf)# banner config-save ^C Caution - Saving Configuration File to NVRAM May Cause You to Nolonger Automatically Download Configuration Files at Reboot^C
Switch(config)# vlan 99
Switch(config-vlan)# interface vlan 99
Switch(config-if)# no shutdown
Switch(config-if)# end
Switch# show boot
BOOT path-list:
Config file: flash:/config.text
Private Config file: flash:/private-config.text
Enable Break: no
Manual Boot: no
HELPER path-list:
NVRAM/Config file
buffer size: 32768
Timeout for Config
Download: 300 seconds
Config Download
via DHCP: enabled (next boot: enabled)
Switch#

) レイヤ 3 インターフェイスだけを設定してイネーブルにする必要があります。IP アドレスまたは保存コンフィギュレーション付き DHCP ベースの自動設定を割り当てないでください。


手動での IP 情報の割り当て

複数の Switched Virtual Interface(SVI; スイッチ仮想インターフェイス)またはポートに手動で IP 情報を割り当てるには、特権 EXEC モードで次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface vlan vlan-id

インターフェイス コンフィギュレーション モードを開始し、IP 情報を割り当てる VLAN を入力します。指定できる範囲は 1 ~ 4094 です。先行ゼロは入力しないでください。

ステップ 3

ip address ip-address subnet-mask

IP アドレスおよびサブネット マスクを入力します。

ステップ 4

exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 5

ip default-gateway ip-address

スイッチに直接接続しているネクスト ホップのルータ インターフェイスの IP アドレスを入力します。このスイッチにはデフォルト ゲートウェイが設定されています。デフォルト ゲートウェイは、スイッチから宛先 IP アドレスを取得していない IP パケットを受信します。

デフォルト ゲートウェイが設定されると、スイッチは、ホストが接続する必要のあるリモート ネットワークに接続できます。

(注) IP でルーティングするようにスイッチを設定した場合、デフォルト ゲートウェイの設定は不要です。

ステップ 6

end

特権 EXEC モードに戻ります。

ステップ 7

show running-config

設定を確認します。

ステップ 8

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

スイッチの IP アドレスを削除するには、 no ip address インターフェイス コンフィギュレーション コマンドを使用します。Telnet セッションからアドレスを削除すると、スイッチの接続は切断されます。デフォルト ゲートウェイのアドレスを削除するには、 no ip default-gateway グローバル コンフィギュレーション コマンドを使用します。

スイッチのシステム名の設定、特権 EXEC コマンドへのアクセスの保護、時刻および日付の設定については、「スイッチの管理」を参照してください。

実行コンフィギュレーションの確認および保存

入力または変更した設定内容を確認するには、 show running-config 特権 EXEC コマンドを使用します。このコマンドの出力についての詳細は、『 Cisco IOS Configuration Fundamental Command Reference, Release 12.2 』 を参照してください。

スタートアップ コンフィギュレーションに対して行った設定や変更をフラッシュ メモリに保存するには、 copy running-config startup-config 特権 EXEC コマンドを使用します。このコマンドにより、入力した設定値が保存されます。保存できなかった場合、設定は次のシステム リロード時に失われます。フラッシュ メモリの NVRAM セクションに保存されている情報を表示するには、 show startup-config または more startup-config 特権 EXEC コマンドを使用します。

コンフィギュレーション ファイルのコピーの代替保存場所については、 付録 B「Cisco IOS ファイル システム、コンフィギュレーション ファイル、およびソフトウェア イメージの操作」 を参照してください。

スタートアップ コンフィギュレーションの変更

ここでは、スイッチのスタートアップ コンフィギュレーションの変更方法について説明します。具体的な設定情報は次のとおりです。

「デフォルトのブート設定」

「コンフィギュレーション ファイルの自動ダウンロード」

「手動でブートする場合」

「特定のソフトウェア イメージをブートする場合」

「環境変数の制御」

デフォルトのブート設定

表 3-3 に、デフォルトのブート設定を示します。

 

表 3-3 デフォルトのブート設定

機能
デフォルト設定

オペレーティング システム ソフトウェア イメージ

スイッチは、BOOT 環境変数内の情報を使用して自動的にシステムを起動しようとします。この変数が設定されていない場合、スイッチはフラッシュ ファイル システム全体に再帰的な縦型検索を行って、最初に検出した実行可能イメージをロードして実行しようとします。

IOS イメージは、イメージ ファイル(拡張子 .bin を除く)と同じ名前のディレクトリに保存されています。

ディレクトリの縦型検索では、検出した各サブディレクトリを完全に検索してから元のディレクトリでの検索を続けます。

コンフィギュレーション ファイル

設定されているスイッチは、システム ボードのフラッシュ メモリに保存されている config.text ファイルを使用します。

新しいスイッチの場合、コンフィギュレーション ファイルはありません。

コンフィギュレーション ファイルの自動ダウンロード

DHCP ベースの自動設定機能を使用することによって、スイッチにコンフィギュレーション ファイルを自動的にダウンロードできます。詳細については、「DHCP ベースの自動設定の概要」を参照してください。

システム コンフィギュレーションを読み書きするためのファイル名の指定

デフォルトでは、IOS ソフトウェアは、 config.text ファイルを使用して、システム コンフィギュレーションの不揮発性コピーを読み書きします。ただし、別のファイル名を指定することもでき、これは次のブート時にロードされます。

別のコンフィギュレーション ファイル名を指定するには、特権 EXEC モードで次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

boot config-file flash:/ file-url

次回のブート時にロードするコンフィギュレーション ファイルを指定します。

file-url に、パス(ディレクトリ)およびコンフィギュレーション ファイル名を指定します。

ファイル名およびディレクトリ名では、大文字と小文字が区別されます。

ステップ 3

end

特権 EXEC モードに戻ります。

ステップ 4

show boot

設定を確認します。

boot config-file グローバル コンフィギュレーション コマンドによって、CONFIG_FILE 環境変数の設定が変更されます。

ステップ 5

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

デフォルトの設定に戻すには、 no boot config-file グローバル コンフィギュレーション コマンドを使用します。

手動でブートする場合

デフォルトでは、スイッチは自動的にブートしますが、手動でブートするように設定できます。

次のブート時に手動でブートするようにスイッチを設定するには、特権 EXEC モードで次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

boot manual

次回のブート時にスイッチを手動でブートできるようにします。

ステップ 3

end

特権 EXEC モードに戻ります。

ステップ 4

show boot

設定を確認します。

boot manual グローバル コンフィギュレーション コマンドによって、MANUAL_BOOT 環境変数の設定が変更されます。

次回、システムをリブートしたときには、スイッチはブート ローダ モードになり、ブート ローダ モードであることが switch: プロンプトによって示されます。システムをブートするには、 boot filesystem :/ file-url ブート ローダ コマンドを使用します。

filesystem : には、システム ボードのフラッシュ デバイスを指定する場合は、 flash: を使用します。

file-url には、パス(ディレクトリ)およびブート可能なイメージの名前を指定します。

ファイル名およびディレクトリ名では、大文字と小文字が区別されます。

ステップ 5

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

手動でのブートをディセーブルにするには、 no boot manual グローバル コンフィギュレーション コマンドを使用します。

特定のソフトウェア イメージをブートする場合

デフォルトでは、スイッチは、BOOT 環境変数内の情報を使用して自動的にシステムをブートしようとします。この変数が設定されていない場合、スイッチは、フラッシュ ファイル システム全体に再帰的な縦型検索を行って、最初の実行可能イメージをロードして実行しようとします。ディレクトリの縦型検索では、検出した各サブディレクトリを完全に検索してから元のディレクトリでの検索を続けます。ただし、ブートする特定のイメージを指定できます。

次回のブート時に特定のイメージをブートするようにスイッチを設定するには、特権 EXEC モードで次の手順を実行します。

 

コマンド
目的

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

boot system filesystem :/ file-url

次回のブート時に、フラッシュ メモリ内の特定のイメージをブートするようにスイッチを設定します。

filesystem : には、システム ボードのフラッシュ デバイスを指定する場合は、 flash: を使用します。

file-url には、パス(ディレクトリ)およびブート可能なイメージの名前を指定します。

ファイル名およびディレクトリ名では、大文字と小文字が区別されます。

ステップ 3

end

特権 EXEC モードに戻ります。

ステップ 4

show boot

設定を確認します。

boot system グローバル コンフィギュレーション コマンドによって、BOOT 環境変数の設定が変更されます。

次のブート時、スイッチは、BOOT 環境変数内の情報を使用して自動的にシステムをブートしようとします。

ステップ 5

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

デフォルトの設定に戻すには、 no boot system グローバル コンフィギュレーション コマンドを使用します。

環境変数の制御

正常に動作しているスイッチでは、9600 bps 対応で設定されたスイッチ コンソール接続でだけブート ローダ モードが開始されます。スイッチの電源コードを取り外し、電源コードの再接続中に Mode ボタンを押します。ポート 1 の上の LED が消灯してから 1 ~ 2 秒後に、Mode ボタンを放します。ブート ローダの switch: プロンプトが表示されます。

スイッチのブート ローダ ソフトウェアは不揮発性の環境変数をサポートするので、これらの環境変数を使用して、ブート ローダまたはシステムで稼動する他のソフトウェアの動作を制御できます。ブート ローダの環境変数は、UNIX または DOS システムで設定できる環境変数と類似しています。

値が設定された環境変数は、フラッシュ ファイル システム外のフラッシュ メモリに保存されています。

ファイルの各行には、環境変数名と等号に続いて、その変数の値が指定されます。このファイルに表示されていない変数には値がありません。表示されていればヌル ストリングであっても値があります。ヌル ストリング(たとえば " ")に設定されている変数は、値が設定された変数です。多くの環境変数は事前に定義されており、デフォルト値が設定されています。

環境変数には 2 種類のデータが保存されます。

IOS コンフィギュレーション ファイルを読み取らない、コードを制御するデータ。たとえば、ブート ローダの機能を拡張したり、パッチを適用したりするブート ローダ ヘルパー ファイルの名前は、環境変数として保存できます。

IOS コンフィギュレーション ファイルを読み取る、コードを制御するデータ。たとえば、IOS コンフィギュレーション ファイルの名前は、環境変数として保存できます。

ブート ローダにアクセスするか IOS コマンドを使用して、環境変数の設定を変更できます。通常の環境では、環境変数の設定を変更する必要はありません。


) ブート ローダ コマンドおよび環境変数の構文および使用方法の詳細については、このリリースに対応するコマンド リファレンスを参照してください。


表 3-4 で、代表的な環境変数の機能について説明します。

 

表 3-4 環境変数

変数
ブート ローダ コマンド
IOS グローバル コンフィギュレーション コマンド

BOOT

set BOOT filesystem :/ file-url ...

自動ブート時にロードして実行を試みる、セミコロンで区切られた実行可能ファイルのリスト。BOOT 環境変数が設定されていない場合、システムは、フラッシュ ファイル システム全体に再帰的な縦型検索を行って、最初に検出された実行可能イメージをロードして実行を試みます。BOOT 変数が設定されていても、指定されたイメージをロードできなかった場合、システムはフラッシュ ファイル システムで最初に検出したブート可能なファイルをブートしようとします。

boot system filesystem :/ file-url

次のブート時にロードする IOS イメージを指定します。このコマンドは、BOOT 環境変数の設定を変更します。

MANUAL_BOOT

set MANUAL_BOOT yes

スイッチが自動または手動でブートするかどうかを決定します。

有効値は 1、yes、0、および no です。no または 0 に設定すると、ブート ローダは自動的にシステムをブートしようとします。それ以外に設定した場合は、ブート ローダ モードから手動でスイッチをブートする必要があります。

boot manual

次回のブート時にスイッチを手動でブートできるようにします。MANUAL_BOOT 環境変数の設定が変更されます。

次回のシステムのリブート時には、スイッチはブート ローダ モードになります。システムをブートするには、 boot flash: filesystem :/ file-url コマンドを使用し、ブート可能なイメージの名前を指定します。

CONFIG_FILE

set CONFIG_FILE flash:/ file-url

IOS がシステム コンフィギュレーションの不揮発性コピーの読み書きに使用するファイル名を変更します。

boot config-file flash: / file-url

IOS がシステム コンフィギュレーションの不揮発性コピーの読み書きに使用するファイル名を指定します。このコマンドによって、CONFIG_FILE 環境変数が変更されます。

ソフトウェア イメージ リロードのスケジュール設定

スイッチ上でソフトウェア イメージのリロードをあとで(深夜、週末などスイッチをあまり使用しないときに)行うように、スケジュールを設定できます。または(ネットワーク内のすべてのスイッチでソフトウェアをアップグレードする場合など)ネットワーク全体でリロードを同時に行うことができます。


) リロードのスケジュールは、約 24 日以内に設定する必要があります。


リロードのスケジュール設定

ソフトウェア イメージをあとでリロードするようにスイッチを設定するには、特権 EXEC モードで次のいずれかのコマンドを使用します。

reload in [ hh : ] mm [ text ]

指定した分数、または時間および分数が経過したときに、ソフトウェアがリロードされるようにスケジュールを設定します。リロードは、約 24 日以内に実行する必要があります。最大 255 文字で、リロードの理由を指定できます。

reload at hh : mm [ month day | day month ] [ text ]

指定した時刻(24 時間形式を使用)にソフトウェアがリロードされるように、スケジュールを設定します。月日を指定すると、指定された日時にリロードが行われるようにスケジュールが設定されます。月日を指定しなかった場合、リロードは当日の指定時刻に行われます(指定時刻が現時刻よりあとの場合)。または翌日の指定時刻に行われます(指定時刻が現在時刻よりも前の場合)。00:00 を指定すると、深夜 0 時のリロードが設定されます。


at キーワードを使用するのは、スイッチのシステム クロックが(Network Time Protocol(NTP; ネットワーク タイム プロトコル)、ハードウェア カレンダ、または手動で)設定されている場合だけです。時刻は、スイッチに設定された時間帯に基づきます。複数のスイッチで同時にリロードが行われるように設定する場合は、各スイッチの時刻を NTP によって同期させる必要があります。


reload コマンドはシステムを停止させます。手動でブートするように設定されていない場合、システムは自動的にリロードします。 reload コマンドは、スタートアップ コンフィギュレーションにスイッチの設定情報を保存( copy running-config startup-config )したあとで使用します。

手動でブートするようにスイッチが設定されている場合、仮想端末からリロードを実行しないでください。これは、スイッチがブート ローダ モードになり、その結果、リモート ユーザが制御を失うことを防止するためです。

コンフィギュレーション ファイルを変更すると、リロードの前にコンフィギュレーションを保存するように指示するプロンプトが表示されます。保存操作時に、CONFIG_FILE 環境変数がすでに存在しないスタートアップ コンフィギュレーション ファイルを示していた場合、保存を続行するかどうかという問い合せがシステムから出されます。その状況のまま続けると、リロード時にセットアップ モードが開始されます。

次に、当日の午後 7 時 30 分にソフトウェアをスイッチにリロードする例を示します。

Switch# reload at 19:30
Reload scheduled for 19:30:00 UTC Wed Jun 5 2003 (in 2 hours and 25 minutes)
Proceed with reload? [confirm]
 

次に、先の日時を指定して、ソフトウェアをスイッチにリロードする例を示します。

Switch# reload at 02:00 jun 20
Reload scheduled for 02:00:00 UTC Thu Jun 20 2003 (in 344 hours and 53 minutes)
Proceed with reload? [confirm]
 

スケジュールがすでに設定されたリロードを取り消すには、 reload cancel 特権 EXEC コマンドを使用します。

リロード スケジュール情報の表示

リロードのスケジューリングに関する情報を表示してスイッチにリロードがスケジューリングされているかどうかを調べるには、 show reload 特権 EXEC コマンドを使用します。

リロードが予定されている時刻、リロードの理由を含め(リロードのスケジュール設定時に指定されている場合)、リロード情報が表示されます。