Catalyst 3750 Metro スイッチ ソフトウェア コンフィギュレーション ガイド Cisco IOS Release 12.2(37)SE
MPLS および EoMPLS の設定
MPLS および EoMPLS の設定
発行日;2012/01/07 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 9MB) | フィードバック

目次

MPLS および EoMPLS の設定

MPLS サービスの概要

MPLS VPN の概要

VPN の利点

VPN ルーティング情報の配信

MPLS VPN の設定

MPLS のデフォルト設定

MPLS VPN 設定時の注意事項

MPLS のイネーブル化

VPN の定義

BGP ルーティング セッションの設定

PE/PE ルーティング セッションの設定

BGP PE/CE ルーティング セッションの設定

RIP PE/CE ルーティング セッションの設定

スタティック ルート PE/CE ルーティング セッションの設定

MPLS VPN 内のパケットフロー

MPLS OAM の概要

LSP Ping

LSP Traceroute

AToM VCCV(pseudowire の LSP ping)

IP SLA MPLS LSP

MPLS OAM の設定

MPLS OAM のデフォルト設定

MPLS OAM 設定時の注意事項

IPv4 の LSP ping の設定

LSP Traceroute の設定

pseudowire の LSP ping(AtoM VCCV)の設定

IP SLA MPLS の手動設定

IP SLA LSP Health Monitor の設定

EoMPLS の概要

他の機能との相互作用

EoMPLS および IEEE 802.1Q トンネリング

EoMPLS およびレイヤ 2 トンネリング

EoMPLS および QoS

EoMPLS の制限

EoMPLS のイネーブル化

EoMPLS のデフォルト設定

EoMPLS 設定時の注意事項

EoMPLS の設定

EoMPLS ネットワークのパケット フロー

MPLS および EoMPLS QoS の設定

MPLS QoS の概要

MPLS および EoMPLS QoS のイネーブル化

MPLS および EoMPLS QoS のデフォルト設定

EXP ビットによるパケットのプライオリティの設定

MPLS および EoMPLS のモニタおよびメンテナンス

MPLS および EoMPLS の設定

この章では、Catalyst 3750 Metro スイッチに Multiprotocol Label Switching(MPLS; マルチプロトコル ラベル スイッチング)および Ethernet over MPLS(EoMPLS)を設定する方法について説明します。MPLS は、リンク レイヤ(レイヤ 2)スイッチングとネットワーク レイヤ(レイヤ 3)ルーティングを統合するパケットスイッチング テクノロジーです。MPLS がイネーブルの場合、データは任意のレイヤ 3 プロトコルを使用し、複数のレイヤ 2 テクノロジーを任意に組み合わせて転送されるため、スケーラビリティが高まります。MPLS は、ルータベース インターネット バックボーンを介して送信元と宛先を接続する複数のルートをサポートします。

Cisco IOS Release 12.2(37)SE から、スイッチが MPLS Operations, Administration, and Maintenance(OAM)機能もサポートしています。これにより、サービス プロバイダーは Label Switched Path(LSP; ラベル スイッチド パス)の整合性を監視し、MPLS 転送の問題を迅速に隔離できます。

EoMPLS は、MPLS ネットワークを介してレイヤ 2 イーサネット フレームを転送するトンネリング メカニズムです。ブリッジ、ルータ、またはスイッチを配置しなくても、離れた位置にある 2 つのレイヤ 2 ネットワークを接続することができます。MPLS バックボーンをイネーブルにして、レイヤ 2 トラフィックを受信できるようにするには、MPLS バックボーンの両端にある Label Edge Router(LER; ラベル エッジ ルータ)を設定します。

MPLS 機能がサポートされるのは Enhanced-Services(ES)ポート上のみです。EoMPLS は標準ポートおよび ES ポート上でサポートされます。


) MPLS の詳細については、『Cisco IOS Switching Services Configuration Guide』 Release 12.2 の「Multiprotocol Label Switching」を参照してください。この章で使用する MPLS コマンドの構文および使用方法の詳細については、『Cisco IOS Switching Services Command Reference』 Release 12.2 を参照してください。
EoMPLS コマンドの詳細については、このリリースのコマンド リファレンスを参照してください。


この章で説明する内容は、次のとおりです。

「MPLS サービスの概要」

「MPLS VPN の概要」

「MPLS VPN の設定」

「MPLS OAM の概要」

「MPLS OAM の設定」

「EoMPLS の概要」

「EoMPLS のイネーブル化」

「MPLS および EoMPLS QoS の設定」

「MPLS および EoMPLS のモニタおよびメンテナンス」

Cisco IOS Release 12.2(25)SED 以降のリリースでは、スイッチで Hierarchical Virtual Private LAN Service(H-VPLS; 階層構造の仮想プライベート LAN サービス)アーキテクチャがサポートされ、MPLS ネットワーク上の LAN サービスがシミュレーションされます。スイッチは、IEEE 802.1Q トンネリングまたは EoMPLS を使用して H-VPLS をサポートします。詳細については、次のソフトウェア マニュアルを参照してください。

EoMPLS の詳細については、「EoMPLS の概要」を参照してください。

EoMPLS の設定の詳細については、「EoMPLS のイネーブル化」、および「MPLS および EoMPLS QoS の設定」を参照してください。

IEEE 802.1Q トンネリングの詳細については、 「IEEE 802.1Q およびレイヤ 2 プロトコル トンネリングの設定」 の章を参照してください。

Cisco 7600 ルータでの H-VPLS の設定の詳細については、次の URL にある『 OSM Configuration Note 』12.2SX の「Configuring Multiprotocol Label Switching on the Optical Services Modules」を参照してください。

http://www.cisco.com/en/US/products/hw/routers/ps368/products_configuration_guide_chapter09186a00801e5c06.html

MPLS サービスの概要

従来のレイヤ 3 転送では、パケットがネットワークを通過するときに、各ルータでレイヤ 3 ヘッダーからパケット転送情報を抽出します。この情報をインデックスに使用して、ルーティング テーブル検索を実行し、パケットのネクストホップを判別します。通常はヘッダー内の宛先アドレス フィールドのみが関連しますが、他のヘッダー フィールドが関連することもあります。このため、パケットが通過する各ルータではパケット ヘッダーを分析する必要があります。

MPLS を使用すると、レイヤ 3 ヘッダーは 1 回のみ分析され、構造化されていない固定長の値( ラベル )にマッピングされます。複数の異なるヘッダーで同じネクストホップが選択される場合は、これらのヘッダーを同じラベルにマッピングすることができます。実際は、ラベルは 転送同等クラス を表します。つまり、外見が異なるにもかかわらず、転送機能に関して区別できない一連のパケットを表します。

最初のラベル選択は、レイヤ 3 ヘッダーの内容のみを基準として行うことができます。また、ポリシーを基準とすることにより、後続ホップでの転送判断をポリシーベースで行うこともできます。ラベルが選択されると、レイヤ 3 パケットの前に短いラベル ヘッダーが付加され、パケットの一部としてネットワーク内で伝達されます。ネットワーク内の各 MPLS ルータを経由する後続ホップでは、ラベルが交換されます。ルータはラベルに関する MPLS 転送テーブル検索を実行して、転送判断を行います。パケット ヘッダーを再び分析する必要はありません。ラベルは構造化されていない固定長の値であるため、MPLS 転送テーブル検索プロセスは簡単かつ高速です。

ネットワーク内の各 Label Switching Router(LSR; ラベル スイッチング ルータ)は、転送同等クラスを表すために使用されるラベル値に関して、独立したローカルな判断を行います。この対応関係は、 ラベル バインディング といいます。各 LSR は、自身が行ったラベル バインディングをネイバーに通知します。ラベルの付いたパケットが LSR A から近接する LSR B に送信されると、パケットで伝達されるラベル値は、パケットの転送同等クラスを表すために B が割り当てたラベル値になります。このため、IP パケットがネットワークを通過するにつれて、ラベル値は変更されます。


) Catalyst 3750 Metro スイッチはサービスプロバイダー コア ルータとしてでなく、サービスプロバイダー エッジの顧客配置機器(PE-CLE)として使用されるため、LSR として正常に動作しません。スイッチがラベル スイッチングを実行するのは、ES ポートを介して 2 つの異なるプロバイダー コア ルータに接続されて、冗長パスを実現している場合のみです。この場合、スイッチは QoS(Quality of Service)ポリシーを使用して出力側で MPLS パケットを分類し、ラベル スイッチングを行います。


ラベルは転送同等クラスを表しますが、ネットワーク内の特定のパスは表しません。一般に、ネットワーク内のパスは OSPF、Enhanced Interior Gateway Protocol(EIGRP)、
Intermediate-System-to-Intermediate-System(IS-IS)、Border Gateway Protocol(BGP)など、既存のレイヤ 3 ルーティング プロトコルによって常に選択されます。各ホップでラベルを検索する場合、ネクストホップはダイナミック ルーティング アルゴリズムによって決定されます。

MPLS VPN の概要

MPLS Virtual Private Network(VPN; バーチャル プライベート ネットワーク)を使用すると、ビジネス カスタマー向けのスケーラブルなレイヤ 3 VPNバックボーン サービスの導入や管理を行うことができます。VPN は、1 つまたは複数の物理ネットワーク上でリソースを共有するセキュアな IP ベース ネットワークです。VPN に含まれる地理的に離れたサイトでは、共有バックボーンを介して安全に通信することができます。

VPN ルートは Multiprotocol BGP(MP-BGP)を使用して、MPLS ネットワークを介して配信されます。MP-BGP は各 VPN ルートに対応付けられたラベルも配信します。MPLS VPN は VPN Routing/Forwarding(VRF)サポートを使用して、ルーティング ドメインを相互に隔離します。MPLS VPN を介してルートが取得された場合、スイッチは新しいルートを標準 VRF ルートとして学習します。ただし、ネクストホップの宛先 MAC アドレスは実際のアドレスでなく、ルートに割り当てられた ID を含む特殊な形式のアドレスです。MPLS-VPN パケットがポートに着信すると、スイッチはルーティング テーブル内でラベルを検索し、パケットの処理内容を決定します。

各 VPN は 1 つまたは複数の VPN VRF インスタンスに対応付けられます。VRF にはルーティング テーブル、転送テーブル、および Customer Edge(CE; カスタマー エッジ)デバイスに接続されたカスタマー デバイスの VPN メンバーシップを定義する規則が格納されています。カスタマー サイトは複数の VPN に属することができますが、1 つのサイトに対応付けることができる VRF は 1 つのみです。VRF には次の要素があります。

IP ルーティング テーブル

Cisco Express Forwarding(CEF)テーブル

転送テーブルを使用するインターフェイスのセット

ルーティング テーブル内の情報を制御する規則およびルーティング プロトコル パラメータのセット

カスタマーサイト VRF には、そのサイトで使用可能な、そのサイトが属する VPN のすべてのルートが格納されます。VPN ルーティング情報は、各 VRF の IP ルーティング テーブルおよび CEF テーブルに格納されます。各テーブル セットは VRF ごとに維持されます。これにより、情報が VPN 外部に転送されたり、VPN 外部のパケットが VPN 内のルータに転送されることがなくなります。パケットは VRF IP ルーティング テーブルおよび VRF CEF テーブルに格納されたルーティング情報に基づいて、宛先に転送されます。

PE ルータは CE デバイスから取得された各カスタマー プレフィクスにラベルをバインドし、他の(PE)ルータにアドバタイズされるプレフィクスのネットワーク到達可能性情報にラベルを追加します。プロバイダー ネットワークを介して CE デバイスから着信したパケットが PE ルータによって転送されると、そのパケットには宛先 PE ルータから取得されたラベルが付加されます。宛先 PE ルータは、ラベルの付いたパケットを受信すると、ラベルを調べて、正しい CE デバイスにパケットを転送するために使用します。バックボーンを通過するカスタマー データパケットが伝達するラベルには、2 つのレベルがあります。

上位ラベルは正しい PE ルータにパケットを転送します。

2 番めのラベルは、PE ルータが CE デバイスにパケットを転送する方法を定義します。

VPN の利点

MPLS VPN を使用すると、サービス プロバイダーはスケーラブルな VPN を導入したり、次のような付加価値のあるサービスを提供するための基礎を構築することができます。

コネクションレス サービス ― MPLS VPN はコネクションレスです。つまり、ホスト間の通信を確立する場合に、事前の処理が不要です。コネクションレス VPN では、トンネルおよび暗号化を使用してネットワークのプライバシーを確保する必要がありません。

中央集中型サービス ― MPLS VPN はプライベート イントラネットとして使用されます。プライベート イントラネットでは、VPN で表されるユーザ グループに目的の IP サービスを提供することができます。

スケーラビリティ ― MPLS ベース VPN ではピア モデルおよびレイヤ 3 コネクションレス アーキテクチャを使用して、スケーラビリティの高いソリューションを利用することができます。ピア モデルでは、カスタマー サイトは 1 つの PE ルータに対するピアとして機能する必要があります。これは、VPN に属する他のすべてのカスタマー PE デバイスまたは CE デバイスと異なります。PE ルータには、メンバーである VPN の VPN ルートが保持されます。コア ネットワーク内のルータには、VPN ルートは保持されません。

セキュリティ ― MPLS VPN はコネクション型 VPN と同じレベルのセキュリティを提供します。特定の VPN からのパケットが、誤って別の VPN に送信されることはありません。プロバイダー ネットワークのエッジに実装されたセキュリティにより、カスタマーから着信したパケットは正しい VPN に送信されます。バックボーンに実装されたセキュリティにより、VPN トラフィックは互いに分離されます。

作成が容易 ― MPLS VPN はコネクションレスであるため、特定のポイントツーポイント接続マップやトポロジは不要です。サイトをイントラネットおよびエクストラネットに追加して、閉じたユーザ グループを形成することができます。

柔軟なアドレス指定 ― Network Address Translation(NAT; ネットワーク アドレス変換)を使用しなくても、カスタマーは引き続き現在のアドレス スペースを使用することができます。MPLS VPN によって、パブリック アドレスとプライベート アドレスが対応付けられるためです。NAT が必要となるのは、アドレス スペースが重複する 2 つの VPN が通信する場合のみです。

移行が容易 ― 複数のネットワーク アーキテクチャ上に MPLS VPN を構築することができます。MPLS をサポートするために CE ルータを配置したり、カスタマーのイントラネットを変更する必要がないため、エンド カスタマーは簡単に移行することができます。

MPLS VPN を導入すると、BGP の機能も拡張されます。

図38-1に、サービスプロバイダー バックボーン ネットワーク、PE-CLE ルータ、および CE デバイスを含む VPN の例を示します。

図38-1 VPN およびサービス プロバイダー バックボーン

 

各 VPN には、CE デバイスに接続されたカスタマー デバイスが含まれています。カスタマー デバイスは VPN を使用してデバイス間で情報を交換します。プロバイダー ルータ(P)は VPN を認識しません。

図38-2に、3 つの VPN 内で通信を行う 5 つのカスタマー サイトを示します。VPN は次のサイトと通信することができます。

VPN1:サイト 2 および 4

VPN2:サイト 1、3、および 4

VPN3:サイト 1、3、および 5

図38-2 カスタマー サイトおよび VPN

 

VPN ルーティング情報の配信

VPN ルーティング情報の配信を制御するには、BGP 拡張コミュニティによって実装される VPN ルート ターゲット コミュニティを使用します。VPN ルーティング情報は、次の方法で配信されます。

CE デバイスから取得された VPN ルートが BGP プロセスに追加されると、VPN ルート ターゲット拡張コミュニティ アトリビュートのリストが VPN ルートに対応付けられます。アトリビュート値は、ルート取得元の VRF に対応付けられたルート ターゲットのエクスポート リストから取得されます。

各 VRF には、ルート ターゲット拡張コミュニティのインポート リストも対応付けられます。インポート リストは、ルートを VRF にインポートする場合にルータに格納されていなければならないルート ターゲット拡張コミュニティ アトリビュートを定義します。たとえば、特定の VRF のインポート リストにルート ターゲット コミュニティ A、B、および C が含まれている場合、これらのルート ターゲット拡張コミュニティ(A、B、または C)のいずれかを伝達するすべての VPN ルートが、この VRF にインポートされます。

PE ルータはスタティックな設定を使用して CE デバイスから IP プレフィクスを取得することができます。そのためには、CE デバイスとの BGP セッション、または CE ルータとの Routing Information Protocol(RIP)交換を使用します。IP プレフィクスは IPv4 アドレス ファミリのメンバーです。IP プレフィクスを取得すると、PE ルータは IP プレフィクスと 8 バイトのルート識別子を組み合わせて、IP プレフィクスを VPN-IPv4 プレフィクスに変換します。生成されたプレフィクスは VPN-IPv4 アドレス ファミリのメンバーです。カスタマー サイトがグローバルに一意でない(未登録のプライベート)IP アドレスを使用している場合でも、カスタマー アドレスを一意に識別します。

BGP は、VPN ごとに VPN-IPv4 プレフィクスの到達可能性情報を配信します。BGP 通信は、IP ドメイン内(別名 Autonomous System [AS; 自律システム])(Internal BGP [IBGP])および AS 間(External BGP [EBGP])の 2 つのレベルで実行されます。PE/PE セッションは IBGP セッションです。PE/CE セッションは EBGP セッションです。

BGP は、IPv4 以外のアドレス ファミリのサポートを定義する BGP マルチプロトコル拡張機能を使用して、PE ルータ間で VPN-IPv4 プレフィクスの到達可能性情報を伝播します。この方法では、指定された VPN のルートは、この VPN の他のメンバーによってのみ学習されるため、VPN のメンバー間で相互に通信できます。

MPLS VPN の設定

ここでは、PE ルータとして使用される Catalyst 3750 Metro スイッチに MPLS VPN を設定する方法について説明します。

「MPLS のデフォルト設定」

「MPLS VPN 設定時の注意事項」

ここでは、必要な作業について説明します。

「MPLS のイネーブル化」

「VPN の定義」

「BGP ルーティング セッションの設定」

「PE/PE ルーティング セッションの設定」

PE/CE ルーティング セッションも設定する必要があります。ここでは、設定例を示します。

「BGP PE/CE ルーティング セッションの設定」

「RIP PE/CE ルーティング セッションの設定」

「スタティック ルート PE/CE ルーティング セッションの設定」

MPLS VPN 内のパケット フローの例については、「MPLS VPN 内のパケットフロー」を参照してください。

MPLS のデフォルト設定

通常のルーテッド パスでの IPv4 パケットのラベル スイッチングは、デフォルトでグローバルにイネーブル化されています。インターフェイスでの IPv4 パケットの MPLS 転送は、デフォルトでディセーブルです。

mpls label protocol グローバル コンフィギュレーション コマンドで配信プロトコルが明示的に設定されていない場合は、Tag Distribution Protocol(TDP)がスイッチのデフォルトのラベル配信プロトコルになります。MPLS を使用する場合は、Label Distribution Protocol(LDP)を設定することを推奨します。

インターフェイスにプロトコルが明示的に設定されていない場合は、スイッチのデフォルトのラベル配信プロトコルが使用されます。デフォルトでは、すべての宛先のラベルがすべての LDP ネイバーにアドバタイズされます。

VRF は未定義です。インターフェイスのデフォルト ルーティング テーブルは、グローバル ルーティング テーブルです。

MPLS VPN 設定時の注意事項

MPLS を使用するには、スイッチ上で CEF をイネーブルにする必要があります。CEF はデフォルトでイネーブルに設定されています。CEF の詳細については、「CEF の設定」を参照してください。

スイッチは ES ポートを介して MPLS ネットワークと接続する必要があります。MPLS 設定がサポートされるのは、ES ポートのみです。

MPLS が設定されているインターフェイスには、VLAN マッピングを設定しないでください。

スイッチは合計 26 の VRF および VPN をサポートします。

VRF には PBR テンプレートとの互換性はありません。 sdm prefer routing-pbr コマンドを入力して PBR テンプレートを設定した場合は、コンフィギュレーションから設定済み VRF がすべて削除されます。PBR および VRF を同じスイッチ上で機能させることはできません。

MPLS のイネーブル化

図38-1のようなネットワーク内で MPLS を使用する場合は、MPLS をグローバルにイネーブル化し、PE-CLE ルータ上で明示的に設定する必要があります。

すべての宛先プレフィクスへのパケットに対してラベルスイッチングを行う場合に、ネットワークを介して MPLS を追加導入するには、特権 EXEC モードで次の手順を実行します。

 

コマンド
説明

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

ip routing

スイッチ上で IP ルーティングがディセーブルの場合は、イネーブルにします。

ステップ 3

ip cef distributed

デバイス上で CEF がディセーブルの場合は、イネーブルにします。

ステップ 4

mpls ip

通常のルーテッド パスで IPv4 パケットの MPLS 転送がディセーブルの場合は、イネーブルにします。

ステップ 5

mpls label protocol ldp

スイッチのラベル プロトコルを LDP に設定します。デフォルト プロトコルは TDP です。

ステップ 6

mpls ldp advertise-labels [ for prefix-access-list [ to peer-access-list ]]

スイッチ上で MPLS ラベル アドバタイズをイネーブルにします。キーワードを指定しない場合は、アドバタイズされるラベルに制限は課せられません。

(任意) for prefix-access-list ― ラベルをアドバタイズする必要がある宛先を指定します。

(任意) to peer-access-list ― ラベル アドバタイズを受信する必要がある LDP ネイバーを指定します。LSR は、6 バイトの LDP ID の最初の 4 バイトからなるルータ ID によって識別されます。

ステップ 7

interface interface-id

インターフェイス コンフィギュレーション モードを開始し、MPLS ネットワークに接続されているレイヤ 3 ES インターフェイスを指定します。有効な ES インターフェイスは、igabitethernet1/1/1、gigabitethernet1/1/2、および VLAN です。

ステップ 8

mpls ip

インターフェイスの通常のルーテッド パスで IPv4 パケットの MPLS 転送をイネーブルにします。

ステップ 9

end

特権 EXEC モードに戻ります。

ステップ 10

show mpls forwarding-table

show mpls interfaces

設定を確認します。

ステップ 11

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

ネットワーク内のすべての PE-CLE ルータおよび該当するインターフェイスに対して上記ステップを繰り返し、すべてのルータおよび接続先インターフェイスを MPLS に対してイネーブルに設定します。

スイッチ上で MPLS をディセーブルにするには、 no mpls ip グローバル コンフィギュレーション コマンドを使用します。デフォルト TDP に戻すには、 no mpls label protocol ldp グローバル コンフィギュレーション コマンドを使用します。

VPN の定義

PE-CLE ルータ上で VPN ルーティング インスタンスを定義するには、特権 EXEC モードで次の手順を実行します。

 

コマンド
説明

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

ip routing

IP ルーティングをイネーブルにします(IP ルーティングがディセーブルになっている場合にのみ必須)。

ステップ 3

ip vrf vrf-name

VRF コンフィギュレーション モードを開始し、VRF 名を割り当てて VPN ルーティング インスタンスを定義します。

ステップ 4

rd route-distinguisher

ルート識別子を指定して、VRF テーブルを作成します。AS 番号と任意の番号(xxx:y)、または IP アドレスと任意の番号
(A.B.C.D:y)を入力します。

ステップ 5

route-target { export | import | both } route-target-ext-community

指定された VRF のインポート、エクスポート、またはインポート/エクスポート ルート ターゲット コミュニティのリストを作成します。AS 番号と任意の番号(xxx:y)、または IP アドレスと任意の番号(A.B.C.D:y)を入力します。 route-target-ext-community に、ステップ 4 で入力した route-distinguisher と同じ値を設定する必要があります。

ステップ 6

import map route-map

(任意)VRF に、指定されたインポート ルート マップを関連付けます。

ステップ 7

export map route-map

(任意)VRF に、指定されたエクスポート ルート マップを関連付けます。

ステップ 8

exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 9

interface interface-id

インターフェイス コンフィギュレーション モードを開始し、VRF に関連付けるレイヤ 3 ES または VLAN インターフェイスを指定します。

ステップ 10

ip vrf forwarding vrf-name

VRF にレイヤ 3 インターフェイスを関連付けます。

ステップ 11

end

特権 EXEC モードに戻ります。

ステップ 12

show ip vrf

定義された VRF およびインターフェイスを表示します。

ステップ 13

show ip route vrf

show ip cef vrf vrf-name

VRF の IP ルーティング テーブルを表示します。

VRF に関連付けられた CEF 転送テーブルを表示します。

ステップ 14

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

VRF を削除し、VRF からすべてのインターフェイスを削除するには、 no ip vrf vrf-name グローバル コンフィギュレーション コマンドを使用します。VRF から特定のインターフェイスを削除するには、 no ip vrf forwarding インターフェイス コンフィギュレーション コマンドを使用します。

BGP ルーティング セッションの設定

プロバイダー ネットワークに BGP ルーティング セッションを設定するには、PE-CLE ルータ上で特権 EXEC モードを開始し、次の手順を実行します。

 

コマンド
説明

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

ip routing

IP ルーティングをイネーブルにします(IP ルーティングがディセーブルになっている場合にのみ必須)。

ステップ 3

router bgp autonomous-system-number

BGP ルーティング プロセスをイネーブルにし、他の BGP ルータに渡された AS 番号を割り当てて、ルータ コンフィギュレーション モードを開始します。指定できる AS 番号は 1 ~ 65535 です。64512 ~ 65535 は、プライベート AS 番号専用です。

ステップ 4

neighbor { ip-address | peer-group-name } remote-as as-number

ローカル AS に対して識別されるネイバー IP アドレスまたは BGP ピア グループを指定します。指定できる AS 番号の範囲は 1 ~ 65535 です。

ステップ 5

neighbor ip-address activate

IPv4 アドレス ファミリのアドバタイズをアクティブにします。

ステップ 6

end

特権 EXEC モードに戻ります。

ステップ 7

show ip bgp neighbor

設定を確認します。

ステップ 8

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

BGP ルーティング セッションを削除するには、 no router bgp autonomous-system グローバル コンフィギュレーション コマンドを使用します。

PE/PE ルーティング セッションの設定

IBGP を使用するプロバイダー ネットワークに PE/PE ルーティング セッションを設定するには、PE-CLE ルータ上で特権 EXEC モードを開始し、次の手順を実行します。

 

コマンド
説明

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

router bgp autonomous-system-number

ルータ コンフィギュレーション モードを開始します。

ステップ 3

address-family vpnv4 [ unicast ]

アドレス ファミリ コンフィギュレーション モードを開始して、標準 VPNv4 アドレス プレフィクスを使用するルーティング セッションを設定します。

(任意) unicast ― VPNv4 ユニキャスト アドレス プレフィクスを指定します。

ステップ 4

neighbor ip-address remote-as as-number

PE ルータ間の IBGP セッションを定義します。

ステップ 5

neighbor ip-address activate

IPv4 アドレス ファミリのアドバタイズをアクティブにします。

ステップ 6

end

特権 EXEC モードに戻ります。

ステップ 7

show ip bgp [ ipv4 ] [ neighbors ] [ vpnv4 ]

BGP の設定を確認します。すべての BGP IPv4 プレフィクスの情報を表示します。

ステップ 8

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

BGP ルーティング セッションを削除するには、 no router bgp autonomous-system グローバル コンフィギュレーション コマンドを使用します。

BGP PE/CE ルーティング セッションの設定

BGP PE/CE ルーティング セッションを設定するには、PE-CLE ルータ上で特権 EXEC モードを開始し、次の手順を実行します。

 

コマンド
説明

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

router bgp autonomous-system-number

BGP ルーティング プロセスに、他の BGP ルータに渡された AS 番号を設定して、ルータ コンフィギュレーション モードを開始します。

ステップ 3

address-family ipv4 [ unicast ] vrf vrf-name

PE/CE ルーティング セッション用の EBGP パラメータを定義して、VRF アドレスファミリ コンフィギュレーション モードを開始します。


) VRF アドレスファミリ コンフィギュレーション モードでの自動サマリーおよび同期については、デフォルトは off です。


ステップ 4

neighbor address remote-as as-number

PE および CE ルータ間の EBGP セッションを定義します。

ステップ 5

neighbor address activate

IPv4 アドレス ファミリのアドバタイズをアクティブにします。

ステップ 6

end

特権 EXEC モードに戻ります。

ステップ 7

show ip bgp [ ipv4 ] [ neighbors ]

BGP の設定を確認します。すべての BGP IPv4 プレフィクスの情報を表示します。

ステップ 8

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

BGP ルーティング セッションを削除するには、 no router bgp as-number グローバル コンフィギュレーション コマンドを使用します。

RIP PE/CE ルーティング セッションの設定


) PE/CE ルーティング セッションには、OSPF ルーティング プロトコルも使用できます。


RIP PE/CE ルーティングを設定するには、PE-CLE ルータ上で特権 EXEC モードを開始し、次の手順を実行します。

 

コマンド
説明

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

router rip

RIP ルーティングをイネーブルにし、ルータ コンフィギュレーション モードを開始します。

ステップ 3

address-family ipv4 [ unicast ] vrf -name

PE/CE ルーティング セッション用の RIP パラメータを定義して、VRF アドレスファミリ コンフィギュレーション モードを開始します。


) VRF アドレスファミリ コンフィギュレーション モードでの自動サマリーおよび同期については、デフォルトは off です。


ステップ 4

network prefix

PE/CE リンク上で RIP をイネーブルに設定します。

ステップ 5

end

特権 EXEC モードに戻ります。

ステップ 6

show ip rip database [ network-prefix ]

設定を確認します。

ステップ 7

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

RIP ルーティングをディセーブルにするには、 no router rip グローバル コンフィギュレーション コマンドを使用します。

スタティック ルート PE/CE ルーティング セッションの設定

スタティック ルーティングを設定するには、PE-CLE ルータ上で特権 EXEC モードを開始し、次の手順を実行します。

 

コマンド
説明

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

ip route vrf vrf-name prefix mask

PE/CE セッションに使用する VRF スタティック ルーティング テーブルを定義します。

ステップ 3

router bgp autonomous-system-number

BGP ルーティング プロセス AS 番号を入力し、ルータ コンフィギュレーション モードを開始します。

ステップ 4

address-family ipv4 [ unicast ] vrf vrf-name

PE/CE ルーティング セッションごとにスタティック ルート パラメータを定義して、VRF アドレスファミリ コンフィギュレーション モードを開始します。


) VRF アドレスファミリ コンフィギュレーション モードでの自動サマリーおよび同期については、デフォルトは off です。


ステップ 5

redistribute static

VRF スタティック ルートを VRF BGP テーブルに再配信します。

ステップ 6

redistribute connected

直接接続されたネットワークを VRF BGP テーブルに再配信します。

ステップ 7

end

特権 EXEC モードに戻ります。

ステップ 8

show ip bgp [ ipv4 ]

設定を確認します。

ステップ 9

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

MPLS VPN 内のパケットフロー

図38-3に、MPLS VPN ネットワークの 2 つのカスタマー サイト間のパケット フローの例を示します。

図38-3 MPLS VPN パケット フローの例

 

スイッチ PE1 のカスタマー(ファスト イーサネット)ポートは、VPN でのルーテッド動作用に設定されています。このポートではスタティック ルーティングまたはルーティング プロトコル(RIP、OSPF、EIGRP、または BGP)を使用して、パケットを転送します。カスタマーの VPN に関連付けられたルート識別子を持つ PE1 スイッチの ES ポートには、MP-BGP が設定されています。MP-BGP は、このルート識別子を使用している ES ポートを介して、ルートおよび関連付けられた VPN ラベルを再配信するように設定されています。

パケット フローに関する手順は、次のとおりです。


ステップ 1 PE スイッチ PE1(Catalyst 3750 Metro スイッチなど)は、サイト 1 のカスタマー スイッチからパケットを受信します。スイッチは検索テーブルから、VRF が MPLS を実行している VLAN であることを判別し、MPLS 検索テーブルを使用して、パケットの処理内容を判別します。MPLS 検索テーブルには、宛先 MAC アドレスとしてピア LSR、および送信元 MAC アドレスとしてローカル インターフェイスが格納されています。

ステップ 2 PE1 は適切なネクストホップおよびラベルが設定された BGP ルートを検出し、パケットに適切なラベルを追加して、ES ポートからネクストホップ ルータ(P3)にパケットを転送します。

ステップ 3 P3 ルータはこのパケットを受信し、パケットの上位ラベル(Interior Gateway Protocol[IGP; 内部ゲートウェイ プロトコル])に基づいて MPLS-VPN ネットワークを介してパケットを転送してから、上位ラベルを削除します。

ステップ 4 PE3 はパケットを受信し、MPLS カプセル化を解除して、パケットを転送します。転送する場合は、宛先として CE スイッチ CE2 が設定されたパケット内の VPN ラベルに関連付けられた VRF インターフェイスを使用します。


 

MPLS OAM の概要

MPLS OAM は、MPLS ネットワークの障害検出とトラブルシューティングに役立ちます。これを使用することで、サービス プロバイダーは LSP を監視して MPLS 転送の問題を迅速に隔離できます。Cisco IOS Release 12.2(37)SE では、Catalyst 3750 Metro スイッチは、次の MPLS OAM 機能をサポートしています。

LSP ping/traceroute IPv4 バージョン 3

Any Transport over MPLS(AToM)Virtual Circuit Connection Verification(VCCV) ― MPLS LSP ping を使用して、AToM Virtual Circuit(VC; 仮想回線)の pseudowire セクションをテストします。

IP Service Level Agreements(IP SLA) ― MPLS LSP ネットワークおよび IP SLA Health Monitor を監視し、BGP VPN ネイバーに LSP ping traceroute を自動的に生成します。


) スイッチは IP SLA をサポートしていますが、このリリースのコンフィギュレーションは、非標準の IP SLA CLI コマンドを使用します。ip sla グローバル コンフィギュレーション コマンドを使用してスイッチの IP SLA コンフィギュレーション モードを開始する代わりに、rtr グローバル コンフィギュレーション コマンドを使用して Response Time Reporter(RTR)コンフィギュレーション モードを開始してください。これらのモードのコマンドは同じです。


LSP Ping

MPLS LSP ping は、Internet Control Message Protocol(ICMP; インターネット制御メッセージ プロトコル)エコー要求と応答メッセージと同様に、LSP の検証に MPLS エコーの要求と応答パケットを使用します。ICMP のエコー要求と応答メッセージが IP ネットワークを検証するのに対し、MPLS OAM エコー要求と応答メッセージは MPLS LDP ネットワークを検証します。LSP ping および追跡機能では、UDP ポート番号 3503 で IPv4 UDP パケットを使用します。 ping mpls 特権 EXEC コマンドを使用すれば、IPv4 LDP または AToM Forwarding Equivalence Classes(FEC)の検証に MPLS LSP ping を使用できます。検証する LSP に関連付けられたラベル スタックを使用すると、MPLS エコー要求パケットがターゲット ルータに送信されます。

LSP エコー要求の送信元アドレスは、LSP 要求を生成している LDP ルータの IP アドレスです。宛先 IP アドレスは 127.x.y.z/8 というアドレスで、LSP が壊れている場合に IP パケットが自身の宛先に切り替わることを防止します。127.0.0.x 宛先アドレス範囲を使用することで、出力 PE ルータからのOAM パケットの流出を防ぐことができます。つまり、サービス プロバイダー ネットワークからカスタマー ネットワークへの流出を防止します。

MPLS エコー要求に応じて、MPLS エコー応答が IP や MPLS(またはその両方)を使用して IP パケットとして転送されます。MPLS エコー応答パケットの送信元アドレスは、エコー応答を生成しているルータから取得されるアドレスです。宛先アドレスは、MPLS エコー要求パケットを送信したルータの送信元アドレスです。MPLS エコー応答の宛先ポートは、エコー要求の送信元ポートです。

LSP Traceroute

MPLS LSP traceroute も MPLS エコー要求およびエコー応答パケットを使用して LSP を検証します。 trace mpls 特権 EXEC コマンドを使用すれば、IPv4 LDP の検証に MPLS LSP traceroute を使用できます。traceroute の Time To Live(TTL)値を設定すると、LSP の TTL が強制的に期限切れになります。MPLS LSP traceroute は、連続した各ホップのダウンストリーム マッピングを検出するために、自身の MPLS エコー要求の TTL 値(TTL = 1、2、3、4)を付加的に増加させます。MPLS エコー要求を処理する中継ルータは、TTL 期限の切れた MPLS パケットに応じて中継ホップの情報を持つ MPLS エコー応答を戻します。MPLS エコー応答の宛先ポートが、エコー要求の送信元ポートに送信されます。

AToM VCCV(pseudowire の LSP ping)

AToM VCCV のルータ アラートを使用すれば、送信元 PE ルータから AToM pseudowire インバンド(またはアウトオブバンド)制御パケットを送信できます。Catalyst 3750 Metro スイッチは、アウトオブバンド VCCV をサポートしています。この設定には、 ping mpls pseudowire 特権 EXEC コマンドを使用します。この転送は、CE ルータに転送されずに、宛先 PE ルータで代行受信されます。AToM VCCV および MPLS LSP ping を使用することで、AToM 仮想回線の pseudowire セクションをテストできます。

AToM VCCV は、次のコンポーネントで構成されています。

信号コンポーネント ― 仮想回線ラベル信号の送信中、AToM VCCV 機能がアドバタイズされます。

スイッチング コンポーネント ― AToM VC ペイロードが制御パケットとして処理されます。

レイヤ 2 pseudowire の LSP ping は、仮想回線ラベルの交換中、送信元ルータがまず pseudowire 制御チャネル機能の検証を行うよう要求します。Catalyst 3750 Metro スイッチの場合、これはルータ アラート ラベルで実行されます。ルータ アラート ラベルは、LSP ping や traceroute パケットを出力ルータに転送する代わりに、ルータ プロセッサに送信します。スイッチは、制御文字を使用したインバンド VCCV の検証をサポートしていません。

IP SLA MPLS LSP

IP SLA MPLS LSP は、MPLS ネットワークに参加している PE ルータ間の統計情報を生成したり、測定したりする方法を提供します。IP SLA MPLS LSP は LSP ping と traceroute を使用して、PE ルータ間におけるネットワーク アベイラビリティの判断、およびネットワークの接続性やパフォーマンスの測定を行います。IP SLA LSP ping や traceroute は手動で設定することも、IP SLA Health Monitor から設定することもできます。

手動で設定する場合、VPN エンドポイントを明示的に指定します。

MPLS LSP Health Monitor を使用する場合、VRF を指定すれば、モニタが自動的に VPN エンドポイントを検出します。LSP Health Monitor を設定すると、ネットワーク トポロジに基づいて、自動的に IP SLA LSP ping または LSP traceroute 処理を生成または削除できます。Health Monitor は隣接したすべての BGP ネクストホップ PE ルータを自動的に検出し、該当する BGP ネクストホップ ネイバーごとに個々の IP SLA LSP ping 処理を生成します。

LSP Health Monitor の設定に関する詳細については、次の URL を参照してください。

http://www.cisco.com/en/US/products/ps6441/products_feature_guide09186a0080612885.html#wp1051129


) Catalyst 3750 Metro スイッチでは、ip sla グローバル コンフィギュレーション コマンドを使用してスイッチの IP SLA コンフィギュレーション モードを開始する代わりに、rtr グローバル コンフィギュレーション コマンドを使用して RTR コンフィギュレーション モードを開始してください。これらのコンフィギュレーション モードにおける mpls コマンドは同じです。


MPLS OAM の設定

次のセクションでは、Catalyst 3750 Metro スイッチに MPLS OAM の設定について説明します。

「MPLS OAM のデフォルト設定」

「MPLS OAM 設定時の注意事項」

次のセクションでは、必須(または任意の)作業について説明します。

「IPv4 の LSP ping の設定」

「LSP Traceroute の設定」

「pseudowire の LSP ping(AtoM VCCV)の設定」

「IP SLA MPLS の手動設定」

「IP SLA LSP Health Monitor の設定」

MPLS OAM のデフォルト設定

MPLS OAM LSP ping および traceroute は設定されていません。

MPLS OAM 設定時の注意事項

MPLS OAM の設定時は、次の注意事項に従ってください。

ping mpls traffic-eng traceroute mpls traffic-eng コマンドが CLI に表示されますが、Catalyst 3750 Metro スイッチではサポートされていません。

MPLS OAM を使用すると MPLS LSP ネットワーク内の問題を検出できるため、MPLS LSP と IP ネットワーク間、または MPLS コントロール プレーンとデータ プレーン間で不一致がある場合に役立ちます。

IPv4 の LSP ping の設定

ping mpls 特権 EXEC コマンドを入力して LSP ping 処理を開始する場合、キーワードで Forwarding Equivalence Class(FEC)を指定します。FEC は、接続性を検証する LCP ping の対象となります。

LSP IPv4 ping を設定するには、特権 EXEC モードで次の手順を実行します。

 

コマンド
説明

ステップ 1

ping mpls ipv4 destination-address destination-mask [ destination address-start address-end increment ] [ exp exp-bits ] [ interval ms ] [ pad pattern ] [ repeat count ] [ reply dscp dscp-value ] [ reply mode { ipv4 | router-alert }] [ revision { 1 | 2 | 3 }] [ size packet-size | sweep minimum maximum size-increment ] [ source source-address ] [ timeout seconds ] [ ttl time-to-live ] [ verbose ]

LSP IPv4 ping を設定します。キーワードの意味は次のとおりです。

destination-address destination-mask ― 目的の FEC のアドレスとネットワーク マスクを指定します。

(任意) destination address-start address-end increment ― 宛先のネットワーク アドレス範囲 127 を入力します。

(任意) exp exp-bits ― エコー応答のMPLS ヘッダーにある MPLS EXP フィールド値を指定します。指定できる範囲は 0 ~ 7 です。デフォルト値は 0 です。

(任意) interval ms ― 連続した MPLS エコー要求の間隔をミリ秒単位で指定します。指定できる範囲は 0 ~ 3600000 ミリ秒で、デフォルトは 0 ミリ秒です。

(任意) pad pattern ― MPLS エコー要求が指定サイズになるようにデータグラムを満たすパッド TLV の使用を指定します。

(任意) repeat count ― パケットを再送信する回数を指定します。指定できる範囲は 1 ~ 2147483647 です。デフォルト値は 1 です。 repeat キーワードを指定しない場合、パケットは 5 回送信されます。

(任意) reply dscp dscp-value ― Differentiated Services Code Point(DSCP)値を使用することで、エコー応答における特定の Class of Service(CoS; サービス クラス)を指定します。

(任意) reply mode { ipv4 | router-alert } ― エコー要求パケットの応答モードを指定します。IPv4 UDP パケット(デフォルト)で応答する場合 ipv4 を、ルータ アラート付きの IPv4 UDP パケットで応答する場合
router-alert
を入力します。

(任意) revision ― IEFT MPLS ping ドラフト リビジョン番号を入力します( 1 2 3 )。

(任意) size packet-size ― ラベル スタックを持ったパケット サイズを各 ping のバイト単位で指定します。指定できる範囲は 40 ~ 18024 です。デフォルト値は 100 です。

(任意) source source-address ― 送信元アドレスまたは名前を指定します。これは、MPLS エコー応答の宛先アドレスです。デフォルトのアドレスは loopback0 です。

(任意) sweep minimum maximum size-increment ― 送信するパケット サイズの範囲を、開始サイズと終了サイズで指定します。スイープ範囲の下限は LSP タイプによって異なります。最小値と最大値の範囲は 100 ~ 18024 で、1 ~ 8993 の範囲で増加できます。

(任意) timeout seconds ― MPLS 要求パケットのタイムアウト間隔を指定します。指定できる範囲は 0 ~ 3600 秒です。デフォルト値は 2 秒です。

(任意) ttl time-to-live ― TTL 値を指定します。指定できる範囲は 1 ~ 255 です。

(任意) verbose ― パケットとリターン コードの MPLS エコー応答送信元アドレスを表示します。


force-explicit-null キーワードがコマンドライン ヘルプに表示されますが、サポートはされていません。


次に、LSP ping の例を示します。

Switch# ping mpls ipv4 10.131.159.251/32 destination 127.0.0.1 127.0.0.2 0.0.0.1 repeat 2 sweep 1450 1475 25

LSP Traceroute の設定

LSP traceroute の送信元は、増分 MPLS エコー要求を送信して、連続した各ホップのダウンストリーム マッピングを検出します。送信元 PE ルータは、中間ルータから応答を受信した場合、同一の対象 FEC を持った別の MPLS エコー要求を作成します。TTL は 1 つずつ増加されます。

LSP IPv4 traceroute を設定するには、特権 EXEC モードで次の手順を実行します。

 

コマンド
説明

ステップ 1

traceroute mpls ipv4 destination-address destination-mask [ destination address-start address-end increment ] [ exp exp-bits ] [ reply dscp dscp-value ] [ reply mode { ipv4 | router-alert }] [ revision { 1 | 2 | 3 }] [ source source-address ] [ timeout seconds ] [ ttl time-to-live ] [ verbose ]

LSP IPv4 raceroute を設定します。キーワードの意味は次のとおりです。

destination-address destination-mask ― 目的の FEC のアドレスとネットワーク マスクを指定します。

(任意) destination address-start address-end increment ― 宛先の 127 ネットワーク アドレス範囲を入力します。

(任意) exp exp-bits ― エコー応答のMPLS ヘッダーにある MPLS EXP フィールド値を指定します。指定できる範囲は 0 ~ 7 です。デフォルト値は 0 です。

(任意) reply dscp dscp-value ― Differentiated Services Code Point(DSCP)値を使用することで、エコー応答における特定の Class of Service(CoS; サービス クラス)を指定します。

(任意) reply mode { ipv4 | router-alert } ― エコー要求パケットの応答モードを指定します。IPv4 UDP パケット(デフォルト)で応答する場合 ipv4 を、ルータ アラート付きの IPv4 UDP パケットで応答するする場合 router-alert を入力します。

(任意) revision ― ドラフト リビジョン番号を入力します( 1 2 3 )。

(任意) source source-address ― 送信元アドレスまたは名前を指定します。これは、MPLS エコー応答の宛先アドレスです。デフォルトのアドレスは loopback0 です。

(任意) timeout seconds ― MPLS 要求パケットのタイムアウト間隔を指定します。指定できる範囲は 0 ~ 3600 秒です。デフォルト値は 2 秒です。

(任意) ttl time-to-live ― TTL 値を指定します。指定できる範囲は 1 ~ 255 です。

(任意) verbose ― パケットとリターン コードの MPLS エコー応答送信元アドレスを表示します。


force-explicit-null キーワードがコマンドライン ヘルプに表示されますが、サポートはされていません。


次に、LSP traceroute の設定例を示します。

Switch# traceroute mpls ipv4 10.131.159.251/32 destination 127.0.0.1 127.0.0.2 1 ttl5

pseudowire の LSP ping(AtoM VCCV)の設定

ping mpls pseudowire 特権 EXEC コマンドを入力すると、MPLS VCCV の機能が起動します。これは、トラフィック制御を AToM 仮想回線に取り入れることで、切り替え用の接続回線を通過させずにリモート PE ルータに代行受信させる機能です。このコマンドには、出力 PE の IP アドレスと仮想回線 ID の入力が必要です。

pseudowire の LSP ping を設定するには、特権 EXEC モードで次の手順を実行します。

 

コマンド
説明

ステップ 1

ping mpls pseudowire ipv4-address vc-id [ destination start-address [ end-address [ address - increment ]] [ exp exp-bits ] [ interval ms ] [ pad pattern ] [ repeat count ] [ reply dscp dscp-value ] [ reply mode { ipv4 | router-alert }] [ revision { 1 | 2 | 3 }] [ size packet-size ] [ source source-address ] [ sweep minimum maximum size-increment ] [ timeout seconds ] [ verbose ]

pseudowire の LSP ping を設定します。キーワードの意味は次のとおりです。

ipv4-address ― ピアの IPv4 アドレスを指定します。

vc-id ― 仮想回線 ID 番号を指定します。指定できる範囲は 1 ~ 4294967295 です。

(任意) destination start-address [ end-address [ increment ]] ― 宛先のネットワーク アドレス 127 と増分アドレス範囲を入力します。

(任意) exp exp-bits ― MPLS ヘッダーにある MPLS EXP フィールド値を指定します。指定できる範囲は 0 ~ 7 です。デフォルト値は 0 です。

(任意) interval ms ― 連続した MPLS エコー要求の間隔をミリ秒単位で指定します。指定できる範囲は 0 ~ 3600000 です。デフォルト値は 0 です。

(任意) pad pattern ― MPLS エコー要求が指定サイズになるようにデータグラムを満たすパッド TLV の使用を指定します。

(任意) repeat count ― パケットを再送信する回数を指定します。指定できる範囲は 1 ~ 2147483647 です。デフォルト値は 1 です。 repeat キーワードを指定しない場合、同じパケットが 5 回送信されます。

(任意) reply dscp dscp-value ― Differentiated Services Code Point(DSCP)値を使用することで、エコー応答における特定の Class of Service(CoS; サービス クラス)を指定します。

(任意) reply mode { ipv4 | router-alert } ― エコー要求パケットの応答モードを指定します。IPv4 UDP パケット(デフォルト)で応答する場合 ipv4 を、ルータ アラート付きの IPv4 UDP パケットで応答する場合 router-alert を入力します。

(任意) revision ― IEFT MPLS ping ドラフト リビジョン番号( 1 2 3 )を入力します。

(任意) size packet-size ― ラベル スタックを持ったパケット サイズを各 ping のバイト単位で指定します。指定できる範囲は 40 ~ 18024 です。デフォルト値は 100 です。

(任意) sweep minimum maximum size-increment ― サイズの異なるパケットを多数送信します。

(任意) timeout seconds ― MPLS 要求パケットのタイムアウト間隔を指定します。指定できる範囲は 0 ~ 3600 秒です。デフォルト値は 2 秒です。

(任意) verbose ― パケットとリターン コードの MPLS エコー応答送信元アドレスを表示します。

次に、pseudowire の LSP ping の例を示します。

Switch# ping mpls pseudowire 10.131.159.251 22 127.0.0.1 127.0.0.2 1 exp 5

IP SLA MPLS の手動設定

CLI を使用して、IP SLA MPLS LSP モニタを手動で設定できます。各モニタは、IP SLA 設定の処理番号と類似した ID 番号を保有しています。

Catalyst 3750 Metro スイッチでは、 ip sla グローバル コンフィギュレーション コマンドを使用してスイッチの IP SLA コンフィギュレーション モードを開始する代わりに、 rtr グローバル コンフィギュレーション コマンドを使用して RTR コンフィギュレーション モードを開始してください。IP SLA と RTR コンフィギュレーション モードにおける mpls コマンドは同じです。

rtr コマンドに関する詳細については、次の URL を参照してください。

http://www.cisco.com/en/US/products/sw/iosswrel/ps1835/products_command_reference_chapter09186a00800ca72e.html

schedule キーワードは任意ですが、開始時間を設定していない場合、動作が中断されます。コマンド自体は有効ですが、主体的な情報収集は行われません。

ping や traceroute で MPLS LSP モニタを手動設定するには、特権 EXEC モードで次の手順を実行します。

 

コマンド
説明

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

rtr entry_number

RTR エントリ番号を入力し、RTR コンフィギュレーション モードを開始します。指定できる範囲は 1 ~ 2147483647 です。

ステップ 3

type mpls lsp { ping | trace } ipv4 destination_address destination_mask [ lsp-selector ip_address ] [ reply dscp ] [ reply mode { ipv4 | router-alert }] [ source_ipaddr source_address ]

IP SLA LSP モニタを手動設定します。

ping ― LSP モニタの ping 動作を選択します。

trace ― LSP モニタの traceroute 動作を選択します。

destination_address destination_mask ― 対象のアドレスとネットワーク マスクを入力します。

(任意) lsp-selector ip_address ― LSP の選択に使用するローカル ホスト アドレスを指定します。

(任意) reply dscp dscp-value ― Differentiated Services Code Point(DSCP)値を使用することで、エコー応答における特定の Class of Service(CoS; サービス クラス)を指定します。

(任意) reply mode { ipv4 | router-alert } ― エコー要求パケットの応答モードを指定します。IPv4 UDP パケット(デフォルト)で応答する場合 ipv4 を、ルータ アラート付きの IPv4 UDP パケットで応答する場合
router-alert
を入力します。

(任意) source_ipaddr source_address ― エコー要求送信元の送信元 IP アドレスを指定します。

ステップ 4

rtr schedule entry_number [ ageout seconds ] [ life { forever | seconds }] [ recurring ] [ start-time { hh:mm {:ss } [ month day | day month ] | pending | now | after hh:mm:ss }]

MPLS LSP モニタの時間パラメータをスケジューリングします。

entry ― RTR エントリ番号を入力します。

(任意) ageout seconds ― 主体的な情報収集が行われていない場合、その動作をメモリに存続させる秒数を入力します。デフォルト値は 0 秒(エージング アウトしない)です。指定できる範囲は 0 ~ 2073600 秒です。

(任意) life ― 永続的な動作の実行を設定するか( forever )、または動作させる 秒数 を指定します。指定できる範囲は 0 ~ 2147483647 秒で、デフォルトは 3600 秒(1 時間)です。

(任意) recurring ― 毎日自動的にスケジュールされるようにプローブを設定します。

(任意) start-time ― 情報収集を開始する時間を入力します。

特定の時間に開始するには、時間、分、秒(24 時間表記)、および月単位の日付を入力します。月を指定しない場合、現在の月がデフォルトで入力されます。

開始時間が選択されるまで情報収集を行わない場合、 pending を入力します。

処理をただちに開始する場合、 now を入力します。

指定時間経過後に処理を開始するように指定する場合、 after hh:mm:ss を入力します。

ステップ 5

end

特権 EXEC モードに戻ります。

ステップ 6

show rtr configuration [ entry_number ]

設定された LSP モニタ動作を表示します。

ステップ 7

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

ステップ 8

show rtr collection-statistics [ entry_number ]

スケジュールされた LSP モニタ動作の統計情報を表示します。

次に、MPLS LSP モニタ ping 処理に 300 を設定し、午後 1 時 30 分(現在の月と日付)に開始させる例を示します。

Switch# config t
Switch(config)# rtr 300
Switch(config-rtr)# type mpls ping ipv4 127.0.0.1 255.255.255.0
Switch(config-rtr)# exit
Switch(config)# rtr schedule 300 start-time 13:30
Switch(config)# exit
 

IP SLA LSP Health Monitor の設定

LSP Health Monitor を設定すると、BGP VPN ネクストホップを検出して、IP SLA LSP ping または traceroute 処理を自動的に作成できるようになります。RTR MPLS モニタ コンフィギュレーション モードを開始するには、 rtr mpls-lsp-monitor グローバル コンフィギュレーション コマンドを使用します。このコンフィギュレーション モード内で、IP SLA LSP Health Monitor の設定に使用したものと同じキーワードを使用します。IP SLA LSP Health Monitor の設定とコマンドに関する詳細については、次の URL を参照してください。

http://www.cisco.com/en/US/products/ps6441/products_feature_guide09186a0080612885.html

LSP ping または traceroute 処理を指定したあと、Virtual Routing and Forwarding(VRF)テーブルを指定できます。デフォルトでは、LSP Health Monitor は、送信元 PE ルータに関連付けられたすべての VRF を使用してすべての BGP ネクストホップ ネイバーを検出します。また、RTR MPLS パラメータ コンフィギュレーション モードでは、LSP Health Monitor エントリの他のオプション パラメータを指定することもできます。このモードで使用できるコマンドは、IP SLA LSP Health Monitor と同じです。

ping や traceroute で MPLS LSP Health Monitor を設定するには、特権 EXEC モードで次の手順を実行します。

 

コマンド
説明

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

rtr mpls-lsp-monitor entry_number

RTR エントリ番号を入力し、RTR LSP Health Monitor コンフィギュレーション モードを開始します。

ステップ 3

type { echo | pathEcho } { saa-vrf-all | vrf vrf_name }

LSP ping または traceroute 処理および監視する VPN を選択し、RTR MPLS パラメータ コンフィギュレーション モードを開始します。

MPLS LSP ping を選択するには、 echo を入力します。

MPLS LSP ping を選択するには、 pathEcho を入力します。

すべての VPN に MPLS LSP モニタを設定するには、 saa-vrf-all を入力します。

指定の VRF のみに MPLS LSP モニタを設定するには、 vrf vrf_name を入力します。

ステップ 4

access-list access-list-number

(任意)LSP モニタに適用するアクセス リストを指定します。

ステップ 5

delete-scan-factor factor

(任意)LSP Health Monitor が、有効でなくなった BGP ネクストホップ ネイバーの IP SLA 処理を自動的に削除する前に、スキャン キューのテストを実行する回数を指定します。 factor の範囲は 0 ~ 2147483647 です。デフォルトのスキャン ファクタは 1 です。

アップデート時に LSP Health Monitor がスキャン キューをテストするたびに、有効でなくなった BGP ネクストホップ ネイバーの IP SLA 処理は削除されます。スキャン ファクタを 0 に設定すると、Health Monitor が IP SLA 処理を自動的に削除しなくなります。スキャン ファクタを 0 に設定することは推奨しません。


) この設定には、このコマンドの scan-interval を使用する必要があります。


ステップ 6

exp exp-bits

(任意)エコー要求パケット ヘッダー内の EXP フィールド値を指定します。指定できる範囲は 0 ~ 7 で、デフォルト値は 0 です。

ステップ 7

lsp-selector ip-address

(任意)IP SLA 処理の LSP 選択に使用するローカル ホストの IP アドレスを指定します。デフォルト値は 127.0.0.1 です。

ステップ 8

reply dscp-value

(任意)IP SLA 処理のエコー応答パケットの DSCP 値を指定します。デフォルト値は 0 です。

ステップ 9

reply { ipv4 | router-alert }

(任意)IP SLA エコー要求応答モードを ipv4 または router-alert に指定します。デフォルト値は IPv4 UDP パケットです。

ステップ 10

request-data-size bytes

(任意)ping 処理の IP SLA 要求パケット プロトコル データ サイズを指定します。指定できる範囲は 100 ~ 1500 バイトです。デフォルトは 100 バイトです。

ステップ 11

scan-interval minutes

(任意)LSP Health Monitor が BGP ネクストホップのアップデートのためにスキャン キューをチェックする間隔を指定します。指定できる範囲は 1 ~ 70560 で、デフォルト値は 240 分です。

ステップ 12

secondary-frequency { connection-loss | timeout } frequency

(任意)予備の頻度(より高い測定頻度)を設定します。反応条件が存在する場合、IP SLA 処理の頻度はこの値に変更されます。指定できる頻度の範囲は 1 ~ 604800 です。

ステップ 13

tag text

(任意)IP SLA 処理のユーザ指定 ID を作成します。

ステップ 14

threshold milliseconds

(任意)IP SLA 処理の反応イベントを生成して履歴情報を保存する上昇しきい値(ヒステリシス)を指定します。指定できる範囲は 0 ~ 2147483647 ミリ秒で、デフォルトは 5000 ミリ秒です。

ステップ 15

timeout milliseconds

(任意)要求パケットの応答に対する IP SLA 処理の待機時間を指定します。指定できる範囲は 0 ~ 604800000 ミリ秒で、デフォルトは 5000 ミリ秒です。

ステップ 16

ttl time-to-live

(任意)IP SLA 処理のエコー要求パケットの最大ホップ カウントを指定します。指定できる範囲は 1 ~ 255 です。

ステップ 17

exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 18

rtr mpls-lsp-monitor reaction-configuration entry_number react monitored-element [ action-type option ] [ threshold-type { consecutive [ average [ occurrences ]] | immediate | never }]


action-type キーワードが CLI に表示されますが、しきい値タイプを never に設定している場合、無効になります。


(任意)その他の LSP Health Monitor アクションを設定します。

entry_number ― Health Monitor エントリ番号を入力します。

react monitored-element ― 違反の監視対象となる要素を指定します。たとえば、ある動作の単方向の接続損失に対する反応を設定するには、 connectionLoss を入力し、単方向のタイムアウトに対する反応を設定するには timeout を入力します。

(任意) action-type option ― しきい値イベント発生時に実行されるアクションを指定します。たとえば、アクションを実行しない場合は none を、SMNP ロギング トラップを送信する場合は trapOnly を入力します。

(任意) threshold-type consecutive [ average [ occurrences ]] ― 反応条件が指定時間継続して満たされた場合、または平均以上の回数が試行された場合に発生させる action-type を指定します。有効な範囲は 1 ~ 16 で、デフォルトは 5 です。

(任意) threshold-type immediate ― 反応条件が満たされたらただちに action-type を発生させるように指定します。

(任意) threshold-type never ― しきい値を計算しません。これがデフォルトのしきい値タイプです。

ステップ 19

rtr mpls-lsp-monitor schedule entry_number schedule-period seconds [ frequency [ seconds ]] [ start-time { hh:mm [ :ss } [ month day | day month ] | pending | now | after hh:mm:ss }

LSP Health Monitor エントリの時間パラメータをスケジューリングします。

operation_number ― Health Monitor 処理番号を入力します。

schedule-period seconds ― Health Monitor のスケジュールにかかる時間を入力します。指定できる範囲は 1 ~ 604800 です。

(任意) frequency [ seconds ] ― 各処理を再開するまでの秒数を指定します。デフォルトにはスケジュール期間が入ります。指定できる範囲は 1 ~ 604800 です。

(任意) start-time ― 情報収集を開始する時間を入力します。

特定の時間に開始するには、時間、分、秒(24 時間表記)、および月単位の日付を入力します。月を指定しない場合、現在の月がデフォルトで入力されます。

開始時間が選択されるまで情報収集をしない場合、 pending を入力します。

処理を即座に開始する場合、 now を入力します。

指定時間の経過後に処理を開始するように指定する場合、 after hh:mm:ss を入力します。

ステップ 20

end

特権 EXEC モードに戻ります。

ステップ 21

show rtr mpls-lsp-monitor configuration [ entry_number ]

設定された LSP モニタ動作を表示します。

ステップ 22

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

ステップ 23

show rtr collection-statistics [ entry_number ]

スケジュールされた LSP モニタ動作の統計情報を表示します。

次に、すべての VPN に対する MPLS LSP Health Monitor の設定例を示します。

Switch# config t

Switch(config)# rtr mpls-lsp-monitor 300

Switch(config-saa-mpls)# type echo saa-vrf-all

Switch(config-saa-mpls-params)# lsp-selector 127.0.0.10

Switch(config-saa-mpls-params)# request-data-size 150

Switch(config-saa-mpls-params)# exit

Switch(config)# rtr mpls-lsp-monitor reaction-configuration 300 react timeout action-type trapOnly threshold-type immediate

Switch(config)# rtr mpls-lsp-monitor schedule 300 schedule-period 1000 start-time after 1:30:00

Switch(config)# end

EoMPLS の概要

Any Transport over MPLS(AToM)は MPLS ネットワーク上でレイヤ 2 パケットを転送するためのソリューションです。サービス プロバイダーは MPLS ネットワークを使用して、既存のレイヤ 2 ネットワークが設定されたカスタマー サイト間を接続することができます。サービス プロバイダーは、ネットワーク管理環境によってネットワークを分離しなくても、MPLS ネットワークを使用して、各カスタマーにすべてのタイプのトラフィックを転送することができます。Catalyst 3750 Metro スイッチは、トンネリング メカニズムを使用してレイヤ 2 イーサネット トラフィックを搬送する AToM のサブセットである EoMPLS をサポートしています。

EoMPLS は、MPLS パケットをイーサネット フレームにカプセル化し、MPLS ネットワーク上で転送します。各フレームは単一のパケットとして転送されます。バックボーンに接続された PE ルータは、必要に応じてパケット カプセル化用ラベルを追加したり、削除したりします。

入力 PE ルータはイーサネット フレームを受信し、プリアンブル、Start of Frame Delimiter(SFD)、およびFrame Check Sequence(FCS)を削除して、パケットをカプセル化します。それ以外のパケット ヘッダーは変更されません。

入力 PE ルータはポイントツーポイント Virtual Connection(VC)ラベルおよび Label Switched Path(LSP; ラベル スイッチド パス)トンネル ラベルを追加して、MPLS バックボーンを介して通常の MPLS ルーティングを行います。

ネットワーク コア ルータは LSP トンネル ラベルを使用して、MPLS バックボーンを介してパケットを送信します。MPLS バックボーンでは、イーサネット トラフィックと他のタイプのパケットを区別しません。

MPLS バックボーンの反対側では、出力 PE ルータがパケットを受信し、LSP トンネル ラベルが付加されている場合はこれを削除して、パケットのカプセル化を解除します。PE ルータは、パケットから VC ラベルも削除します。

PE ルータは必要に応じてヘッダーを更新し、該当するインターフェイスから宛先スイッチにパケットを送信します。

MPLS バックボーンはトンネル ラベルを使用して、PE ルータ間でパケットを転送します。出力 PE ルータは VC ラベルを使用して、イーサネット パケットの発信インターフェイスを選択します。EoMPLS トンネルは単一方向です。双方向の EoMPLS を実現するには、各方向にトンネルを 1 つずつ設定する必要があります。

ポイントツーポイント VC を使用するには、2 つの PE ルータに VC エンドポイントを設定する必要があります。レイヤ 2 トラフィックの転送専用 VC に関する情報を取得するのは、MPLS バックボーンの入口および出口にある PE ルータのみです。その他のルータには、これらの VC のテーブル エントリは格納されません。

ここでは、次の内容について説明します。

「他の機能との相互作用」

「EoMPLS の制限」

他の機能との相互作用

ここでは、EoMPLS と他の機能との相互作用について説明します。具体的な内容は次のとおりです。

「EoMPLS および IEEE 802.1Q トンネリング」

「EoMPLS およびレイヤ 2 トンネリング」

「EoMPLS および QoS」

EoMPLS および IEEE 802.1Q トンネリング

IEEE 802.1Q トンネリングを使用すると、サービス プロバイダーは単一の VLAN を使用して、複数の VLAN を持つカスタマーをサポートすることができます。この際に、カスタマーの VLAN ID は保護され、複数の VLAN のトラフィックが集約されます。IEEE 802.1Q トンネリングの詳細については、 第16章「IEEE 802.1Q およびレイヤ 2 プロトコル トンネリングの設定」 を参照してください。

図38-4に、MPLS ネットワーク上で EoMPLS を使用して、IEEE 802.1Q トンネリング トラフィックを転送する設定の例を示します。PE-CLE として機能するスイッチを介してレイヤ 2 デバイスが MPLS ネットワークに接続されているトポロジ内で、IEEE 802.1Q トンネリングをサポートするには、IEEE 802.1Q トンネリング カプセル化トラフィック(PE1)を受信する PE-CLE の入力 LAN ポートを、VLAN 100 トラフィックを受信するトンネル ポートとして設定します。PE1 のインターフェイスはポートベース EoMPLS 転送用に、PE2 のインターフェイスは宛先 IP アドレスとして設定されます。CE1 から着信した VLAN 10 ~ 50 のパケットは、VLAN 100 でカプセル化されて、MPLS ネットワークに接続された PE1 出力ポートに送信されます。出力ポートでは、MPLS タグがフレーム ヘッダーに追加されたあと、VC にマッピングされ、次の MPLS PE-CLE(PE2)に転送されます。

図38-4 EoMPLS の例

 

VLAN ベース EoMPLS の場合は VLAN に、ポートベース EoMPLS の場合はイーサネット ポートに mpls l2transport route または xconnect インターフェイス コンフィギュレーション コマンドを入力すると、カスタマー VLAN またはイーサネット ポートに基づいてトラフィックを転送するように、EoMPLS トンネルを設定することができます。

MPLS コアを介して、MPLS ネットワークの反対側の特定の受信側に、IEEE 802.1Q トンネルによってカプセル化されたトラフィックを転送するには、ポートベース EoMPLS を設定します。

IEEE 802.1Q トンネルによってカプセル化されたトラフィックをアクセス デバイスから PE ルータに転送するには、VLAN ベース EoMPLS を設定します。

EoMPLS およびレイヤ 2 トンネリング

EoMPLS リンクを介してレイヤ 2 プロトコル トンネリングを行うと、CDP、STP、および VTP Protocol Data Unit(PDU; プロトコル データ ユニット)を MPLS ネットワークを介してトンネリングすることができます。レイヤ 2 デバイスが PE として機能するスイッチを介して MPLS ネットワークに接続されている場合に、レイヤ 2 プロトコル トンネリングをサポートするには、レイヤ 2 プロトコル トラフィックを受信する PE の入力ポートをトンネル ポートとして設定します。レイヤ 2 プロトコル トラフィックがカプセル化されてから、MPLS ネットワークを介して転送されます。レイヤ 2 プロトコル トンネリングの詳細については、 第16章「IEEE 802.1Q およびレイヤ 2 プロトコル トンネリングの設定」 を参照してください。

EoMPLS および QoS

EoMPLS はラベル内の 3 つの EXP(試験)ビットを使用してパケットのプライオリティを判別することにより、QoS をサポートします。LER 間で QoS をサポートするには、VC とトンネル ラベルの両方に EXP ビットを設定します。EoMPLS QoS 分類は入力側で実行されます。照合できるのはレイヤ 3 パラメータ(IP や DSCP など)のみであり、レイヤ 2 パラメータ(CoS[サービス クラス])は照合されません。EoMPLS および QoS の詳細については、「MPLS および EoMPLS QoS の設定」を参照してください。

EoMPLS の制限

EoMPLS に適用される制限事項は、次とのとおりです。

EoMPLS を使用するには、MPLS 用として少なくとも 1 つの ES ポートを設定する必要があります。したがって、ES ポートで EoMPLS を稼働させる場合に、EoMPLS を設定できるのは、MPLS が設定されていない ES ポート上のみです。

MTU(最大伝送ユニット) ― EoMPLS はパケットの分割および再組み立てをサポートしていません。したがって、受信された最大のレイヤ 2 VLAN を伝達できるように、エンドポイント間のすべての中間リンクの MTU を設定する必要があります。入力および出力 PE ルータには、同じ MTU 値を設定する必要があります。

アドレス形式 ― MPLS 転送を適切に動作させるには、PE ルータのすべてのループバック アドレスに 32 ビット マスクを設定する必要があります。OSPF では、ループバック アドレスを使用する必要があります。

パケット形式 ― EoMPLS は、IEEE 802.1Q 標準に準拠する VLAN パケットをサポートします。PE および CE ルータ間では、ISL カプセル化はサポートされません。

スイッチ上で EoMPLS を使用する VLAN の最大数は 1005 です。

レイヤ 2 接続に関する制限:

EoMPLS を使用する場合は、PE ルータ間を直接レイヤ 2 で接続することはできません。

MPLS バックボーンを介してイーサネット VLAN を転送するようにルータが設定されている場合は、これらのルータ間に複数のレイヤ 2 接続を設定することはできません。別のレイヤ 2 接続を追加すると、ピア ルータ上でスパニングツリーがディセーブルの場合、スパニングツリー ステートが頻繁に切り替わります。

EoMPLS およびトランキングに関する制限:

EoMPLS バックボーンでイーサネット スパニングツリー Bridge Protocol Data Unit(BPDU; ブリッジ プロトコル データ ユニット)をサポートするには、EoMPLS VLAN のスパニングツリーをディセーブルにする必要があります。このようにすると、EoMPLS VLAN の伝達経路がカスタマー スイッチへのトランクに限定されます。

トランクのネイティブ VLAN を EoMPLS VLAN にすることはできません。

IEEE 802.1Q インターフェイス上で EoMPLS をイネーブルにするには、 mpls l2transport route または xconnect インターフェイス コンフィギュレーション コマンドを使用します。

EoMPLS が設定されているインターフェイスには、VLAN マッピングを設定しないでください。

プライベート VLAN インターフェイスで EoMPLS を設定しないでください。

EoMPLS のイネーブル化

ここでは、PE ルータとして使用されるスイッチに EoMPLS を設定する方法について説明します。

「EoMPLS のデフォルト設定」

「EoMPLS 設定時の注意事項」

「EoMPLS の設定」

「EoMPLS ネットワークのパケット フロー」

EoMPLS のデフォルト設定

デフォルトで、EoMPLSは設定されていません。

mpls ldp router-id コマンドはディセーブルです。VC は設定されていません。

EoMPLS 設定時の注意事項

EoMPLS を設定する場合は、次の注意事項を考慮してください。

EoMPLS を使用するには、MPLS 用として少なくとも 1 つの ES ポートを設定する必要があります。したがって、ES ポートで EoMPLS を稼働させる場合に、EoMPLS を設定できるのは、MPLS が設定されていない ES ポート上のみです。

EoMPLS をイネーブルにする前に、インポジション LER とディスポジション LER の間のすべてのパスに対して mpls ip インターフェイス コンフィギュレーション コマンドを使用して、ダイナミック MPLS ラベリングをイネーブルにする必要があります。デフォルトで、MPLS はグローバルにイネーブルに設定されています。

VLAN ベース EoMPLS の場合は、スイッチに VLAN を設定する必要があります。

2 つの PE ルータ間で EoMPLS を稼働させるには、ルータ間の LDP セッションが必要です。各ルータで LDP ルータ ID として使用される IP アドレスは、他のルータから IP を介して到達可能でなければなりません。IP アドレスを使用する必要があるインターフェイスを指定して、LDP ルータ ID の選択を制御するには、任意の mpls ldp router-id グローバル コンフィギュレーション コマンドを使用します。

指定されたインターフェイスが起動していて、IP アドレスが設定されている場合は、このコマンドを使用するときに任意の force キーワードを省略できます。ルータ ID を選択する場合は、この IP アドレスがルータ ID として選択されます。

指定されたインターフェイスが起動していないか、または IP アドレスが設定されていない場合に、指定されたインターフェイスの IP アドレスがインターフェイスの起動時に使用されるように設定するには、 force キーワードを指定してこのコマンドを使用します。

両方の PE ルータに、ルータ間の VC を作成する場合に使用できるループバック アドレスを設定する必要があります。OSPF を IGP として使用する場合に、PE ルータ間で MPLS 転送を適切に稼働させるには、PE ルータのすべてのループバック アドレスに 32 ビット マスクを設定する必要があります。

VLAN マッピングが設定されているインターフェイスには、EoMPLS を設定しないでください。

EoMPLS の設定

VLAN インターフェイスには、VLAN ベース EoMPLS を設定します。VLAN ベース EoMPLS がイネーブルの場合、スイッチは VLAN ID に基づいてトンネルと VC ラベルを関連付けます。ES インターフェイス上でポートベース EoMPLS をイネーブルにする場合は、同じコマンドを使用します。

2 つのエンドポイント間でレイヤ 2 パケットを転送するように EoMPLS を設定するには、PE-CLE ルータ上で特権 EXEC モードを開始し、次の手順を実行します。

 

コマンド
説明

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

mpls label protocol ldp

すべてのインターフェイスで LDP をイネーブルにします。デフォルトで、TDP はイネーブルに設定されます。このコマンドを使用すると、すべてのインターフェイスが LDP を使用するように設定されます。

ステップ 3

interface loopback0

ループバック インターフェイスに対して、インターフェイス コンフィギュレーション モードを開始します。

ステップ 4

ip address ip-address subnet mask

ループバック インターフェイスに IP アドレスを割り当てます。

ステップ 5

exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 6

mpls ldp router-id loopback0 force

(任意)ループバック インターフェイス 0 の IP アドレスをルータ ID として使用するように強制的に設定します。

ステップ 7

interface interface-id

レイヤ 3 VLAN(VLAN ベース EoMPLS の場合)または ES ポートのインターフェイス ID(ポートベース EoMPLS の場合)を入力して、インターフェイス コンフィギュレーション モードを開始します。

ステップ 8

mpls l2transport route destination vc-id

または

xconnect destination vc-id encapsulation mpls

MPLS を介してレイヤ 2 VLAN パケットを転送するようにインターフェイスを設定します。

destination ― VC の反対側にある PE ルータの IP アドレス

vc-id ― VC に定義された一意の値。vc-id は VC のエンドポイントに関連付けられます。この値は、VC の両端で同じでなければなりません。指定できる範囲は 1 ~ 4294967295 です。

ステップ 9

end

特権 EXEC モードに戻ります。

ステップ 10

show mpls l2transport vc

設定を確認します。

ステップ 11

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

EoMPLS トンネルを削除するには、 no mpls l2transport route destination vc-id または no xconnect destination vc-id encapsulation mpls インターフェイス コマンドを使用します。

次に、スイッチ PE1 の VLAN 3 インターフェイスと PE2 の VLAN 4 インターフェイス間に EoMPLS トンネルを設定する例を示します。

PE1 の IP アドレスは 10.0.0.1/32、PE2 の IP アドレスは 20.0.0.1/32 です。両方の PE ルータに、MPLS コアとの MPLS 接続が設定されています。VC ID は 123 です。

PE1 スイッチに、次のコマンドを入力します。

Switch(config)# interface loopback0
Switch(config-if)# ip address 10.10.10.10 255.255.255.255
Switch(config-if)# exit
Switch(config)# interface vlan 3
Switch(config-if)# mpls l2transport route 20.0.0.1 123
 

PE2 スイッチに、次のコマンドを入力します。

Switch(config)# interface loopback0
Switch(config-if)# ip address 20.20.20.20 255.255.255.255
Switch(config-if)# exit
Switch(config)# interface vlan 4
Switch(config-if)# mpls l2transport route 10.0.0.1 123

EoMPLS ネットワークのパケット フロー

図38-5に、EoMPLS ネットワークのパケット フローの例を示します。PE1 のカスタマー ポートは、PE2 のリモート カスタマー ポートへのポート単位 EoMPLS トンネル用に設定されています。この設定により、これらのポートに接続された、物理的に離れている 2 つのカスタマー スイッチ(A および B)は、同じ物理 LAN 上で直接接続されているかのように認識されます。

EoMPLS トンネルにはスイッチ B の IP アドレス、およびリモート カスタマー ポートに関連付けられた VC ID が設定されています。PE1 は、ルータ A(PE1 の ES ポートに接続)から LDP によってアドバタイズするラベルを使用して、PE2 とのトンネル LSP を確立します。次に、PE1 は PE2 とのターゲット LDP セッションを確立して、VC ID に関連付けられた VC ラベルをアドバタイズします。PE2 に EoMPLS トンネルが設定されている場合、PE2 もターゲット LDP セッションを確立して、VC ID に関連付けられた VC ラベルをアドバタイズします。これにより、スイッチ PE1 とスイッチ PE2 の 2 つの ES ポート間に、EoMPLS トンネルが確立されます。

図38-5 EoMPLS パケット フローの例

 

ホスト A が VLAN 3 上のカスタマー スイッチに接続されていて、この VLAN 3 のトランク ポートが IEEE 802.1Q タギング用に設定された PE1 に接続されているとします。ホスト A は、MAC アドレス、ラベル、および VLAN の特定の値を使用して(図を参照)、パケットをホスト B に送信します。カスタマー スイッチはホスト パケットにタグを付加し、トランク ポートを介して PE1 に転送します。

タグ付きパケットは、ポート単位 EoMPLS トンネリング用に設定された CE ポートに着信します。PE1 スイッチはパケット ヘッダーを調べて、スイッチに格納されたテーブルを検索し、パケットの処理内容を判別します。ポートにはポート単位 EoMPLS トンネリングが設定されているため、スイッチはパケット内の VLAN タグを削除しないで、内部 VLAN にパケットを割り当てます。カスタマー ポートおよび ES ポートにのみ、内部 VLAN が設定されています。したがって、PE1 ES ポートがパケットの唯一の宛先となります。

ES ポートはトンネル ラベルおよび VC ラベルを含めてパケット ヘッダーをカプセル化し、パケットをネクストホップ(この場合はルータ A)に転送し、そこから MPLS ネットワークにパケットを送信します。

ルータはパケットを受信し、MPLS ネットワークを介してリモート PE2 スイッチに転送します。PE2 は MPLS カプセル化を解除し、VC ラベルに関連付けられたポートからパケットを送信します。カスタマー スイッチ B は最終的な VLAN タグを削除し、パケットをリモート ホスト B に転送します。

VLAN ベース EoMPLS パケット フローは、基本的にポートベース EoMPLS と同じです。ただし、内部 VLAN でなく、カスタマー VLAN が使用されます。PE1 スイッチはカスタマー VLAN ID を検索して、パケットを ES ポートに転送するかを判別します。ここで、パケットは再び調べられ、該当する VLAN の EoMPLS に基づいて、トンネル ラベルおよび VC ラベルとともにカプセル化されます。

MPLS および EoMPLS QoS の設定

MPLS および EoMPLS で QoS を使用すると、ネットワーク管理者は MPLS ネットワーク上で異なる Type of Service(ToS; タイプ オブ サービス)を提供することができます。各パケットは、パケット QoS によって指定された特定の種類のサービスを受信できます。QoS IP precedence ビットを保護するには、QoS をグローバルにディセーブルにする必要があります。

QoS をイネーブルにしたあとで、Differentiated Services Code Point(DSCP)または IP precedence ビットを保護するには、インターフェイス レベルの信頼設定を使用します。詳細については、 「ポートの信頼状態による入力分類の設定」 を参照してください。ただし、保護されていないビットは、保護されたビットの値によって自動的に上書きされます。たとえば、DSCP ビットが保護されている場合、IP precedence および CoS ビットは DSCP ビットの値によって上書きされます。また、MPLS ラベル内の 3 つの EXP ビットを使用してパケットのプライオリティを判別することにより、MPLS および EoMPLS QoS プライオリティを設定することもできます。


) スイッチでサポートされるのは、MPLS および EoMPLS の DSCP および IP precedence 分類のみです。


ここでは、次の情報について説明します。

「MPLS QoS の概要」

「MPLS および EoMPLS QoS のイネーブル化」

MPLS QoS の概要

MPLSネットワークでは、サービスを複数の方法で指定することができます。たとえば、IP パケット内の IP precedence ビット設定を使用します。サイト間で IP パケットを送信する場合は、IP precedence フィールド(IP パケットのヘッダー内の DSCP フィールドの最初の 3 ビット)によって QoS が指定されます。IP precedence のマーキングに基づいて、遅延や帯域幅などの目的の処理がパケットに設定されます。ネットワークが MPLS ネットワークの場合、IP precedence ビットはネットワーク エッジの MPLS EXP フィールドにコピーされます。

サービス プロバイダーは MPLS パケットの QoS 値を別の値に設定することもできます。サービス プロバイダーはカスタマーに属する IP precedence フィールドの値を上書きしないで、MPLS EXP フィールドを設定することができます。カスタマーは引き続き IP ヘッダーを使用することができます。パケットが MPLS ネットワークを通過するときに、IP パケットの QoS は変化しません。

MPLS EXP フィールドに別の値を選択することにより、レートやタイプなどの特性に基づいてパケットにマーキングすることができます。これにより、輻輳期間中に必要となるプライオリティをパケットに設定することができます。

図38-6に、カスタマーに属する IP ネットワークの 2 つのサイトを接続する MPLS ネットワークを示します。

図38-6 2 つのカスタマー サイトを接続する MPLS ネットワーク

 

PE1 および PE2 は MPLS ネットワークと IP ネットワークの境界に配置された顧客配置ルータであり、入力および出力 PE デバイスです。CE1 および CE2 は CE デバイスです。P1 および P2 は、サービスプロバイダー ネットワークの中心にあるサービス プロバイダー ルータです。

パケットはPE1(入力 PE-CLE ルータ)に IP パケットとして着信します。PE1 は着信したパケットを MPLS パケットとして MPLS ネットワークに送信します。サービスプロバイダー ネットワーク内では、パケットは MPLS パケットであるため、キューイング メカニズムが検索する IP precedence フィールドは存在しません。パケットは PE2(出力 PE-CLE ルータ)に着信するまで、MPLS パケットのままです。PE2 は各パケットからラベルを削除し、パケットを IP パケットとして転送します。

サービス プロバイダーは MPLS QoS を使用することにより、タイプ、入力インターフェイス、およびその他の要素に従ってパケットを分類できます。その場合には、IP precedence または DSCP フィールドを変更しないで、MPLS EXP フィールド内に各パケットを設定(マーキング)します。IP precedence または DSCP ビットを使用すると、IP パケットに対して QoS を指定できます。MPLS EXP ビットを使用すると、MPLS パケットに対して QoS を指定できます。MPLS ネットワーク内の MPLS パケットに QoS 値を設定するには、PE1(入力ルータ)で MPLS EXP フィールド値を設定します

パケットに正しいプライオリティを割り当てることが重要です。パケットのプライオリティは、輻輳期間中のパケットの処理方法に影響します。たとえば、サービス プロバイダーとカスタマーとの間に、サービス プロバイダーが提供するトラフィック量を指定するサービスレベル契約が交わされているとします。契約に準拠するには、カスタマーは合意したレートを超えるレートで送信しないようにする必要があります。パケットはレートに適合するか、または適合しないかのどちらかです。ネットワークに輻輳が発生した場合は、レートに適合しないパケットをより積極的に廃棄することができます。

MPLS および EoMPLS QoS のイネーブル化

ここでは、入力 PE ルータに MPLS QoS を設定する方法について説明します。具体的な内容は次のとおりです。

「MPLS および EoMPLS QoS のデフォルト設定」

「EXP ビットによるパケットのプライオリティの設定」

QoS の詳細については、 第33章「QoS の設定」 を参照してください。

MPLS および EoMPLS QoS のデフォルト設定

QoS はディセーブルに設定されています。パケットは変更されません。また、パケット内の CoS、DSCP、および IP precedence 値も変更されません。トラフィックはパススルー モードでスイッチングされます(パケットは書き換えられずにスイッチングされ、ポリシングを伴わないベストエフォート型として分類されます)。

VLAN ベース EoMPLS パケットのデフォルトの動作では、802.1p ビットがVC およびトンネル ラベルの EXP ビットにリレーされます。ポートベース EoMPLS パケットのデフォルトの動作では、VC およびトンネル ラベルの EXP ビットに値 0 が使用されます。階層型 QoS ポリシーを ES ポートに適用すれば、VLAN ベースまたはポートベースの EoMPLS のデフォルト動作を変更できます。

mls qos グローバル コンフィギュレーション コマンドを使用して QoS をイネーブルにし、その他のすべての QoS 設定がデフォルトである場合、トラフィックはポリシングを伴わないベストエフォート型として分類されます(DSCP は 0 に設定されます)。ポリシー マップは設定されていません。


) MPLS および EoMPLS QoS の場合、照合できるのはレイヤ 3 パラメータ(IP または DSCP 値)のみです。レイヤ 2 パラメータ(CoS 値)は照合されません。


EXP ビットによるパケットのプライオリティの設定

MPLS および EoMPLS を使用すると、ラベル内の 3 つの EXP ビットを使用してパケットのプライオリティを判別し、入力ルータで QoS を実行することができます。LER 間で QoS をサポートするには、VC とトンネル ラベルの両方に EXP ビットを設定します。EXP ビットに値を割り当てない場合は、IEEE 802.1Q ヘッダー タグ制御情報フィールドのプライオリティ ビットが EXP ビット フィールドに書き込まれます。

このプロセスでは、入力ルータで次の作業を行います。

DSCP または IP precedence 分類に従って IP パケットを分類するように、クラス マップを設定します。


) スイッチでサポートされるのは、MPLS および EoMPLS の DSCP および IP precedence 分類のみです。


MPLS パケットをマーキングするように(分類情報を MPLS EXP フィールドに書き込むように)、ポリシー マップを設定します。

サービス ポリシーを付加するように、入力インターフェイスを設定します。

EoMPLS または MPLS QoS 用に EXP ビットを設定するには、特権 EXEC モードで次の手順を実行します。

 

コマンド
説明

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

mls qos

QoS をグローバルにイネーブルにします。

デフォルト設定における QoS の動作については、 第33章「QoS の設定」 を参照してください。

ステップ 3

class-map class-map-name

トラフィック クラスの名前を指定し、クラスマップ コンフィギュレーション モードを開始します。

ステップ 4

match {ip dscp dscp-list | ip precedence ip-precedence-list }

IEEE 802.1Q パケットの一致条件を指定します。

ip dscp dscp-list ― 着信パケットと比較する最大 8 つの IP DSCP 値。指定できる範囲は 0 ~ 63 です。

ip precedence ip-precedence-list ― 着信パケットと比較する最大 8 つの IP precedence 値。各値はスペースで区切ります。指定できる範囲は 0 ~ 7 です。


) MPLS および EoMPLS に対して、cos および vlan キーワードはサポートされません。


ステップ 5

exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 6

policy-map policy-map-name

設定するトラフィック ポリシーの名前を指定し、ポリシーマップ コンフィギュレーション モードを開始します。

ステップ 7

class class-name

class-map コマンドを使用して事前に設定されたトラフィック クラスの名前を指定し、ポリシーマップ クラス コンフィギュレーション モードを開始します。

ステップ 8

set mpls experimental exp-number

指定されたポリシー マップとパケットが一致する場合に、MPLS ビットに設定する値を指定します。指定できる範囲は 0 ~ 7 です。

ステップ 9

exit

ポリシーマップ コンフィギュレーション モードに戻ります。

ステップ 10

exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 11

interface interface-id

インターフェイス ID を入力し、インターフェイス コンフィギュレーション モードを開始します。インターフェイスは入力ルータの ES 出力ポートでなければなりません。

ステップ 12

service-policy output policy-map-name

指定されたポリシー マップを出力インターフェイスに付加します。

ステップ 13

end

特権 EXEC モードに戻ります。

ステップ 14

show policy-map [ policy-map-name [ class class-map-name ]]
show policy-map interface interface-id

設定を確認します。

ステップ 15

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

既存のポリシー マップを削除するには、 no policy-map policy-map-name グローバル コンフィギュレーション コマンドを使用します。既存のクラスを削除するには、 no class class-name ポリシーマップ コンフィギュレーション コマンドを使用します。

次に、クラスおよびポリシー マップを使用して、MPLS QoS の DSCP および IP precedence 用に異なる各 EXP ビットを設定する例を示します。

Switch(config)# class-map match-all gold-class
Switch(config-cmap)# match ip dscp 1
Switch(config-cmap)# exit
Switch(config)# class-map match-all silver-class
Switch(config-cmap)# match ip precedence 2
Switch(config-cmap)# exit
 
Switch(config)# policy-map out-policy
Switch(config-pmap)# class gold-class
Switch(config-pmap-c)# set mpls experimental 5
Switch(config-pmap-c)# exit
Switch(config-pmap)# class silver-class
Switch(config-pmap-c)# set mpls experimental 4
Switch(config-pmap-c)# exit
 
Switch(config)# interface gigabitethernet1/1/1
Switch(config-if)# service-policy output out-policy
Switch(config-if)# end

MPLS および EoMPLS のモニタおよびメンテナンス

MPLS カウンタを消去したり、MPLS および EoMPLS 情報を表示したりするには、 表38-1 に記載された特権 EXEC コマンドを使用します。

 

表38-1 MPLS および EoMPLS 情報表示用のコマンド

コマンド
説明

clear mpls counters

MPLS 転送カウンタをクリアします。

show mpls forwarding-table

MPLS Label Forwarding Information Base(LFIB)の内容を表示します。

show mpls interfaces

ラベル スイッチング用に設定されたインターフェイスの情報を表示します。

show mpls ip binding

LDP によって取得されたラベル バインディングに関する指定された情報を表示します。

show mpls l2transport vc [ detail ] [ summary ]

PE デバイスでレイヤ 2 パケットをルーティングするためにイネーブル化された EoMPLS VC に関する詳細情報、またはサマリー情報を表示します。

show mpls l2transport vc [ vc-id ] [ vc-id-min - vc-id-max ]

指定の VC または VC 範囲に関する情報を表示します。指定できる範囲は 1 ~ 4294967295 です。

show mpls label range

パケット インターフェイスで使用可能なローカル ラベルの範囲を表示します。

show mpls ldp bindings

Label Information Base(LIB)の内容を表示します。

show mpls ldp discovery

LDP 検出プロセスのステータスを表示します。

show mpls ldp neighbor

LDP セッションのステータスを表示します。

show mpls ldp parameters

現在の LDP パラメータを表示します。

show mpls prefix-map

標準 IP アクセス リストを照合するネットワーク プレフィクスに QoS マップを割り当てるためのプレフィクス マップを表示します。

show mpls ldp backoff

設定済みのセッション設定バックオフ パラメータ、およびセッション設定をスロットリングするときに使用される任意の LDP ピアに関する情報を表示します。