Catalyst 3750 Metro スイッチ ソフトウェア コンフィギュレーション ガイド Cisco IOS Release 12.2(37)SE
IEEE 802.1Q およびレイヤ 2 プロトコ ル トンネリングの設定
IEEE 802.1Q およびレイヤ 2 プロトコル トンネリングの設定
発行日;2012/01/07 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 9MB) | フィードバック

目次

IEEE 802.1Q およびレイヤ 2 プロトコル トンネリングの設定

IEEE 802.1Q トンネリングの概要

IEEE 802.1Q トンネリングの設定

IEEE 802.1Q トンネリングのデフォルト設定

IEEE 802.1Q トンネリング設定時の注意事項

ネイティブ VLAN

システム MTU

IEEE 802.1Q トンネリングおよび他の機能

IEEE 802.1Q トンネリング ポートの設定

VLAN マッピングの設定

VLAN マッピングのデフォルト設定

カスタマー VLAN からサービス プロバイダー VLAN へのマッピング

カスタマー IEEE 802.1Q トンネル VLAN からサービス プロバイダー VLAN へのマッピング

レイヤ 2 プロトコル トンネリングの概要

レイヤ 2 プロトコル トンネリングの設定

レイヤ 2 プロトコル トンネリングのデフォルト設定

レイヤ 2 プロトコル トンネリング設定時の注意事項

レイヤ 2 トンネリングの設定

EtherChannel のレイヤ 2 トンネリングの設定

サービスプロバイダー エッジ スイッチの設定

カスタマー スイッチの設定

トンネリングおよびマッピング ステータスのモニタおよびメンテナンス

IEEE 802.1Q およびレイヤ 2 プロトコル トンネリングの設定

Virtual Private Networks(VPN; バーチャル プライベート ネットワーク)は、共有のインフラストラクチャ(多くの場合、イーサネット ベース)上で、セキュリティ、プライオリティ、信頼性、管理性に関して専用ネットワークと同じレベルの要件を満たす企業規模の接続を提供します。トンネリング機能は、ネットワーク上で複数のカスタマー トラフィックを伝送し、各カスタマーの VLAN およびレイヤ 2 プロトコル設定を他のカスタマー トラフィックへの影響なしで維持する必要のあるサービス プロバイダー向けに設計された機能です。Catalyst 3750 Metro スイッチは、IEEE 802.1Q トンネリングおよびレイヤ 2 プロトコル トンネリングとともに、VLAN マッピング(VLAN ID 変換)をサポートします。


) ここで使用されるコマンドの構文および使用方法の詳細については、このリリースのコマンド リファレンスを参照してください。


この章で説明する内容は、次のとおりです。

「IEEE 802.1Q トンネリングの概要」

「IEEE 802.1Q トンネリングの設定」

「VLAN マッピングの設定」

「レイヤ 2 プロトコル トンネリングの概要」

「レイヤ 2 プロトコル トンネリングの設定」

「トンネリングおよびマッピング ステータスのモニタおよびメンテナンス」


) Multiprotocol Label Switching(MPLS; マルチプロトコル ラベル スイッチング)での VPN の使用方法については、第38章「MPLS および EoMPLS の設定」を参照してください。


IEEE 802.1Q トンネリングの概要

サービス プロバイダーのビジネス カスタマーには、VLAN ID およびサポートされる VLAN 数について固有の要件がある場合が多くあります。同じサービス プロバイダー ネットワーク上で異なるカスタマーが必要とする VLAN 範囲が重複したり、インフラストラクチャを経由する各カスタマーのトラフィックが混在する可能性があります。カスタマー別に固有の VLAN ID 範囲を割り当てる方法では、カスタマー側の設定に制約が生じ、IEEE 802.1Q 仕様に定められている VLAN の上限(4096)をすぐに超過する可能性があります。

IEEE 802.1Q トンネリング機能を使用すると、サービス プロバイダーは 1 つの VLAN を使用して、それぞれ複数の VLAN を持つカスタマーをサポートできます。サービス プロバイダーのインフラストラクチャ上でカスタマー VLAN ID が保持され、同じ VLAN 上に存在するように見えても、異なるカスタマーからのトラフィックが分離されます。IEEE 802.1Q トンネリングを使用する場合、VLAN-in-VLAN 階層構造およびタグ付きパケットへのタグ付けによって、VLAN スペースを拡張できます。IEEE 802.1Q トンネリングをサポートするように設定されたポートを、 トンネル ポート といいます。トンネリングを設定する場合、トンネリング専用の VLAN にトンネル ポートを割り当てます。カスタマーごとに個別のサービス プロバイダー VLAN ID が必要ですが、その VLAN ID によってカスタマーのすべての VLAN がサポートされます。

カスタマー デバイスの IEEE 802.1Q トランク ポートから、通常どおりに適切な VLAN ID でタグ付けされたカスタマー トラフィックが、サービス プロバイダー エッジ スイッチのトンネル ポートに着信します。カスタマー デバイスとエッジ スイッチの間のリンクは、一方の端が IEEE 802.1Q トランク ポート、反対側がトンネル ポートとして設定されているので、非対称リンクです。カスタマーごとに固有のアクセス VLAN ID に、トンネル ポートを割り当てます。図16-1 を参照してください。

図16-1 サービス プロバイダー ネットワークの IEEE 802.1Q トンネル ポート

 

カスタマー トランク ポートからサービス プロバイダー エッジ スイッチのトンネル ポートに着信するパケットは、通常、適切な VLAN ID で IEEE 802.1Q タグ付けされています。これらのタグ付きパケットは、スイッチ内部ではそのまま保持され、トランク ポートを出てサービス プロバイダー ネットワークに入る時点で、カスタマーに固有の VLAN ID を含む、IEEE 802.1Q タグのもう 1 つのレイヤ( メトロ タグ と呼ばれる)でカプセル化されます。このカプセル化されたパケットの中に、カスタマーからの元の IEEE 802.1Q タグが残されます。したがって、パケットはサービス プロバイダー インフラストラクチャに入る時点で、二重のタグが付いていることになります。外側のタグはカスタマーのアクセス VLAN ID を含み、内側の VLAN ID は着信トラフィックの VLAN です。

二重タグ付きパケットがサービス プロバイダー コア スイッチ上の別のトランク ポートに着信すると、スイッチ内部でパケットが処理されるときに、外側のタグが削除されます。パケットが同じコア スイッチ上の別のトランク ポートから発信される時点で、同じメトロ タグが再びパケットに追加されます。図16-2に、二重タグ付きパケットの構造を示します。

図16-2 標準、IEEE 802.1Q、および二重タグ付きイーサネット パケットのフォーマット

 

パケットがサービス プロバイダー出力スイッチ上のトランク ポートに着信すると、スイッチ内部でパケットが処理されるときに、外側のタグが再び削除されます。ただし、エッジ スイッチ上のトンネル ポートからカスタマー ネットワークに送出される時点では、メトロ タグは追加されず、パケットは通常の IEEE 802.1Q タグ付きフレームとして送信され、カスタマー ネットワーク上での元の VLAN 番号が保持されます。

図16-1の場合、カスタマー A には VLAN 30、カスタマー B には VLAN 40 が割り当てられています。エッジ スイッチのトンネル ポートに IEEE 802.1Q タグ付きで着信するパケットは、サービス プロバイダー ネットワークに入る時点で二重にタグ付けされます。外側のタグにはそれぞれ VLAN ID 30 または 40 が含まれ、内側のタグには元の VLAN 番号(たとえば、VLAN 100)が含まれます。カスタマー A および B の両方のネットワークに VLAN 100 があっても、外側のタグが違うため、サービス プロバイダー ネットワーク内ではトラフィックが分離されています。IEEE 802.1Q トンネリングを使用する場合、各カスタマーはそれぞれ独自の VLAN 番号スペースを管理します。この VLAN 番号スペースは、他のカスタマーが使用する VLAN 番号スペースや、サービス プロバイダー ネットワークで使用される VLAN 番号スペースとは無関係です。

出力側のトンネル ポートでは、カスタマー ネットワーク上での元の VLAN 番号が回復されます。複数レベルのトンネリングおよびタグ付けを使用することもできますが、このリリースでスイッチがサポートするのは 1 つのレベルだけです。

カスタマー ネットワークから着信するトラフィックにタグが付いていない場合(ネイティブ VLAN フレーム)、これらのパケットは通常のパケットと同じようにブリッジングまたはルーティングされます。エッジ スイッチ上のトンネル ポート経由でサービス プロバイダー ネットワークに着信するパケットは、タグが付いていない場合でも、すでに IEEE 802.1Q ヘッダーでタグ付けされている場合でも、すべてタグなしパケットとして扱われます。サービス プロバイダー ネットワーク上の IEEE 802.1Q トランク ポートで送信されるとき、パケットはメトロ タグ VLAN ID(トンネル ポートのアクセス VLAN に設定)でカプセル化されています。メトロ タグのプライオリティ フィールドは、トンネル ポートに設定されているインターフェイスの Class of Service(CoS; サービス クラス)プライオリティに設定されます(プライオリティが設定されていない場合、デフォルトは 0 です)。

スイッチは、インテリジェント IEEE 802.1Q トンネリング QoS(Quality of Service)、すなわち内側の CoS 値を外側の CoS 値にコピーする機能をサポートしています。詳細については、「QoS ドメイン内のポートの信頼状態の設定」および「インターフェイスの CoS 値の設定」を参照してください。

IEEE 802.1Q トンネリングの設定

ここでは、IEEE 802.1Qトンネリングに関する次の事項について説明します。

「IEEE 802.1Q トンネリングのデフォルト設定」

「IEEE 802.1Q トンネリング設定時の注意事項」

「IEEE 802.1Q トンネリングおよび他の機能」

「IEEE 802.1Q トンネリング ポートの設定」

IEEE 802.1Q トンネリングのデフォルト設定

デフォルトのスイッチポート モードは dynamic auto であるため、デフォルトでは、IEEE 802.1Q トンネリングはディセーブルに設定されています。IEEE 802.1Q ネイティブ VLAN パケットのタグ付けも、すべての IEEE 802.1Q トランク ポート上でディセーブルです。

IEEE 802.1Q トンネリング設定時の注意事項

IEEE 802.1Q トンネリング設定する場合、カスタマー デバイスとエッジ スイッチの間の非対称リンク(カスタマー デバイス ポートは IEEE 802.1Qトランク ポート、エッジ スイッチ ポートはトンネル ポートとして設定されている)を常に使用する必要があります。

トンネル ポートは、トンネリングに使用する VLAN にのみ割り当ててください。

2 つのプライベート VLAN 間でトンネル経由でデータが交換されるようにするには、スイッチのエッジの ES ポートで VLAN 変換を設定し、スイッチのプライベート VLAN ポートで同じ VLAN ID を使用します。

ネイティブ VLAN および Maximum Transmission Unit(MTU; 最大伝送ユニット)の設定上の要件について、次に説明します。

ネイティブ VLAN

エッジ スイッチに IEEE 802.1Q トンネリングを設定する場合、IEEE 802.1Q トランク ポートを使用してサービス プロバイダー ネットワークにパケットを送出する必要があります。ただし、サービス プロバイダー ネットワークのコアを通過するパケットは、IEEE 802.1Q トランク、ISL トランク、または非トランキング リンクで伝送される場合があります。これらのコア スイッチで IEEE 802.1Q トランクを使用する場合、IEEE 802.1Q トランクのネイティブ VLAN は、同じスイッチ上の非トランキング(トンネリング)ポートのネイティブ VLAN と同じであってはなりません。ネイティブ VLAN 上のトラフィックは、IEEE 802.1Q 送信側トランク ポートでタグ付けされていない場合があるためです。

図16-3 を参照してください。サービス プロバイダー ネットワークの入力エッジ スイッチ(スイッチ B)で、カスタマー X からの IEEE 802.1Q トランク ポートのネイティブ VLAN として、VLAN 40 が設定されています。カスタマー X のスイッチ A は、VLAN 30 でタグ付きパケットをサービス プロバイダー ネットワークのスイッチ B の入力トンネル ポート(アクセス VLAN 40 に所属)に送信します。トンネル ポートのアクセス VLAN(VLAN 40)は、エッジ スイッチのトランク ポートのネイティブ VLAN(VLAN 40)と同じであるため、トンネル ポートから受信したタグ付きパケットには、メトロ タグが追加されません。パケットはサービス プロバイダー ネットワーク経由で出力エッジ スイッチ(スイッチ C)のトランク ポートまで VLAN 30 タグのみで伝送され、この出力スイッチのトンネル ポートを通じて、不正にカスタマー Y へ送信されます。

この問題を解決するには、いくつかの方法があります。

サービス プロバイダー ネットワーク上のコア スイッチの間の標準ポートで ISL トランクを使用します。エッジ スイッチに接続されたカスタマー インターフェイスは IEEE 802.1Q トランクでなければなりませんが、コア レイヤのスイッチ間の接続には、ISL トランクを使用することを推奨します。

vlan dot1q tag native グローバル コンフィギュレーション コマンドを使用して、ネイティブ VLAN も含めて、IEEE 802.1Q トランクから出て行くすべてのパケットにタグ付けするように、エッジ スイッチを設定します。スイッチがすべての IEEE 802.1Q トランク上でネイティブ VLAN パケットにタグ付けするように設定されている場合、スイッチはタグなしパケットを受け入れますが、送信するのはタグ付きパケットのみです。

エッジ スイッチのトランク ポートのネイティブ VLAN ID が、カスタマー VLAN 範囲に属さないようにします。たとえば、トランク ポートが VLAN 100 ~ 200 のトラフィックを伝送する場合、ネイティブ VLAN には、この範囲外の番号を割り当てます。

図16-3 IEEE 802.1Q トンネリングおよびネイティブ VLAN の潜在的な問題

 

システム MTU

Catalyst 3750 Metro スイッチでは、トラフィックのデフォルトのシステム MTU は、1500 バイトです。1500 バイトより大きいフレームをサポートするようにファスト イーサネット ポートを設定するには、 system mtu グローバル コンフィギュレーション コマンドを使用します。1500 バイトより大きいフレームをサポートするようにギガビット イーサネット ポートを設定するには、 system mtu jumbo グローバル コンフィギュレーション コマンドを使用します。IEEE 802.1Q トンネリング機能では、メトロ タグを追加するときにフレーム サイズが 4 バイトだけ増えます。したがって、スイッチのシステム MTU サイズを最低でも 1504 バイトに増やして、サービス プロバイダー ネットワーク上のすべてのスイッチが最大のフレームを処理できるように設定する必要があります。許容される最大のシステム MTU は、ギガビット イーサネット インターフェイスの場合は 9000 バイト、ファスト イーサネット インターフェイスの場合は 1546 バイトです。

IEEE 802.1Q トンネリングおよび他の機能

IEEE 802.1Q トンネリングは、レイヤ2パケット スイッチングに関しては適切に動作しますが、一部のレイヤ 2 機能およびレイヤ 3 スイッチングとは非互換です。

トンネル ポートをルーテッド ポートにすることはできません。

IEEE 802.1Q ポートを含む VLAN上 では、IP ルーティングはサポートされません。トンネル ポートから受信したパケットは、レイヤ 2 情報のみに基づいて転送されます。トンネル ポートを含む Switch Virtual Interface(SVI; スイッチ仮想インターフェイス)上でルーティングがイネーブルの場合、トンネル ポートから受信したタグなし IP パケットはスイッチによって認識され、ルーティングされます。したがって、カスタマーはネイティブ VLAN 経由でインターネットにアクセスできます。このアクセスが不要な場合には、トンネル ポートを含む VLAN 上に SVI を設定すべきではありません。

トンネル ポート上では、代替ブリッジングはサポートされません。トンネル ポートから受信された IEEE 802.1Q タグ付きパケットはすべて非 IP パケットとして扱われるため、トンネル ポートが設定されている VLAN 上で代替ブリッジングがイネーブルであれば、IP パケットは VLAN 上で不正にブリッジングされることになります。したがって、トンネル ポートのある VLAN 上では代替ブリッジングをイネーブルに しないでください

トンネル ポートは IP Access Control List(ACL; アクセス コントロール リスト)をサポートしません。

レイヤ 3 QoS ACL、およびレイヤ 3 情報に関連するその他の QoS 機能は、トンネル ポート上ではサポートされません。MAC ベースの QoS ACL は、トンネル ポート上でサポートされます。

EtherChannel ポート グループがトンネル ポートと互換性を持つのは、EtherChannel ポート グループ内で IEEE 802.1Q 設定が一貫している場合に限られます。

IEEE 802.1Q トンネル ポート上では、Port Aggregation Protocol(PAgP)、Link Aggregation Control Protocol(LACP)、および UniDirectional Link Detection(UDLD; 単一方向リンク検出)がサポートされます。

Dynamic Trunking Protocol(DTP; ダイナミック トランキング プロトコル)は、IEEE 802.1Q トンネリングとは非互換です。トンネル ポートとトランク ポートのある非対称リンクを手動で設定しなければならないためです。

VLAN Trunking Protocol(VTP; VLAN トランキング プロトコル)は、非対称リンクで接続されたデバイス間、またはトンネル経由で通信するデバイス間では動作しません。

IEEE 802.1Q トンネル ポート上では、ループバック検出がサポートされます。

ポートが IEEE 802.1Q トンネル ポートとして設定されている場合、インターフェイス上でスパニングツリー Bridge Protocol Data Unit(BPDU; ブリッジ プロトコル データ ユニット)フィルタリングが自動的にイネーブルになります。このインターフェイス上では Cisco Discovery Protocol(CDP)および Layer Link Discovery Protocol(LLDP)は自動的にディセーブルになります。

IEEE 802.1Q トンネリング ポートの設定

ポートを IEEE 802.1Q トンネル ポートとして設定するには、特権 EXEC モードで次の手順を実行します。

 

コマンド
説明

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface-id

トンネル ポートとして設定するインターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。このポートは、カスタマー スイッチに接続するサービス プロバイダー ネットワーク上のエッジ ポートでなければなりません。有効なインターフェイスは、物理インターフェイスやポートチャネル論理インターフェイス(ポートチャネル 1 ~ 12)などです。

ステップ 3

switchport access vlan vlan-id

デフォルト VLAN を指定します。これは、インターフェイスがトランキングを停止した場合に使用されます。この VLAN ID は、各カスタマーに固有の ID です。

ステップ 4

switchport mode dot1q-tunnel

インターフェイスを IEEE 802.1Q トンネル ポートとして設定します。

ステップ 5

exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 6

vlan dot1q tag native

(任意)すべての IEEE 802.1Q トランク ポートでネイティブ VLAN パケットのタグ付けをイネーブルにするように、スイッチを設定します。設定しない場合、カスタマー VLAN ID がネイティブ VLAN と同じであれば、トランク ポートはメトロ タグを適用せず、パケットが不正な宛先に送信される可能性があります。

ステップ 7

end

特権 EXEC モードに戻ります。

ステップ 8

show dot1q-tunnel

スイッチ上のトンネル ポートを表示します。

ステップ 9

show vlan dot1q tag native

IEEE 802.1Q ネイティブ VLAN のタグ付けステータスを表示します。

ステップ 10

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

ポートをデフォルトの状態(dynamic auto)に戻すには、 no switchport mode dot1q-tunnel インターフェイス コンフィギュレーション コマンドを使用します。ネイティブ VLAN パケットのタグ付けをディセーブルにするには、 no vlan dot1q tag native グローバル コンフィギュレーション コマンドを使用します。

次に、ポートをトンネル ポートとして設定し、ネイティブ VLAN パケットのタグ付けをイネーブルにして、設定を確認する例を示します。この設定では、ファスト イーサネット ポート7に接続するカスタマーの VLAN ID は VLAN 22 です。

Switch(config)# interface fastethernet1/0/7
Switch(config-if)# switchport access vlan 22
% Access VLAN does not exist. Creating vlan 22
Switch(config-if)# switchport mode dot1q-tunnel
Switch(config-if)# exit
Switch(config)# vlan dot1q tag native
Switch(config)# end
Switch# show dot1q-tunnel interface fastethernet1/0/7
Port
-----
Fa1/0/7
-----
Switch# show vlan dot1q tag native
dot1q native vlan tagging is enabled

VLAN マッピングの設定

VLAN マッピング(または VLAN ID 変換)は、カスタマー VLAN をサービス プロバイダー VLAN にマッピングするために、サービス プロバイダー ネットワークに接続する Enhanced-Services(ES)ポート上に設定できる機能です。VLAN マッピングは、スイッチの内部動作やカスタマー VLAN に影響を与えずに、ES ポート上でフィルタとして動作します。スイッチ上の VLAN の多くは予約済みであったり、または VLAN 範囲が限られていたりする場合があります。カスタマーが予約済み範囲内のVLAN番号を希望している場合、VLAN マッピングを使用して、カスタマー トラフィックを IEEE 802.1Q トンネル内でカプセル化することにより、カスタマー VLAN を重複させることができます。

VLAN マッピングを使用すると、パケットを送信する直前、およびパケットを受信した直後に、IEEE 802.1Q タグ内のカスタマー VLAN ID、または IEEE 802.1Q トンネル フレームの外側および内側タグのマッピング(変換)が実行されます。サービス プロバイダー VLAN はスイッチによって認識されないため、すべての設定および統計処理は、カスタマー側の VLAN を使用して行われます。

スイッチは次の 3 種類の VLAN マッピングをサポートします。

1 対 1 のマッピング ― IEEE 802.1Q タグ内のカスタマー VLAN ID をサービス プロバイダー VLAN ID にマッピングします。

2 対 1 のマッピング ― 外側および内側の VLAN ID を持った IEEE 802.1Q トンネリング トラフィックをサービス プロバイダー VLAN ID にマッピングします。

2 対 2 のマッピング ― 外側および内側の VLAN ID を持った IEEE 802.1Q トンネリング トラフィックをサービス プロバイダーの外側および内側の VLAN ID にマッピングします。

カスタマー側の IEEE 802.1Q VLAN ID を使用してスイッチ内のパケットをスイッチングします。サービス プロバイダー VLAN ID は ES ポートで送受信されます。


) MPLS または EoMPLS 用に設定されているインターフェイス上では、VLAN マッピングを設定しないでください。


ここでは、次の設定について説明します。

「VLAN マッピングのデフォルト設定」

「カスタマー VLAN からサービス プロバイダー VLAN へのマッピング」

「カスタマー IEEE 802.1Q トンネル VLAN からサービス プロバイダー VLAN へのマッピング」

VLAN マッピングのデフォルト設定

デフォルトで、VLAN マッピングは設定されていません。

カスタマー VLAN からサービス プロバイダー VLAN へのマッピング

図16-4に、サービス プロバイダー ネットワークの別々の側に接続する複数のサイトでカスタマーが同じ VLAN を使用しているトポロジを示します。サービス プロバイダー バックボーン経由でパケットを伝送できるように、カスタマー VLAN ID をサービス プロバイダー VLAN ID にマッピングします。サービス プロバイダー バックボーンの反対側でカスタマー VLAN ID が取り出され、別のカスタマー サイトで使用できます。サービス プロバイダー ネットワークの各側にあるESごとに、同じ VLAN マッピングのセットを設定します。設定手順のあとに示す例を参照してください。

図16-4 VLAN マッピングの例

 

ES ポート上でカスタマー VLAN ID をサービス プロバイダー VLAN ID にマッピングするには、特権 EXEC モードで次の手順を実行します。

 

コマンド
説明

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface-id

サービス プロバイダー ネットワークに接続された ES インターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

switchport vlan mapping vlan-id translated-id

マッピングする VLAN ID を入力します。

vlan-id ― カスタマー ネットワークからスイッチに着信する VLAN ID。指定できる範囲は 1 ~ 4094 です。

translated-id ― 割り当てられるサービス プロバイダー VLAN ID。指定できる範囲は 1 ~ 4094 です。

ステップ 4

end

特権 EXEC モードに戻ります。

ステップ 5

show vlan mapping

設定を確認します。

ステップ 6

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

VLAN 変換情報を削除するには、no switchport vlan mapping vlan-id translated-id コマンドを使用します。

次に、図16-4に示すカスタマー ネットワークの VLAN ID 1、2、3、4、5 を、サービス プロバイダー ネットワークの VLAN 1001、1002、1003、1004、1005 にマッピングする例を示します。スイッチ A およびスイッチ B の ES ポートに、同じ VLAN マッピング コマンドを設定します。

Switch(config)# interface gigabiethernet1/1/1
Switch(config-if)# switchport vlan mapping 1 1001
Switch(config-if)# switchport vlan mapping 2 1002
Switch(config-if)# switchport vlan mapping 3 1003
Switch(config-if)# switchport vlan mapping 4 1004
Switch(config-if)# switchport vlan mapping 5 1005
Switch(config-if)# exit
 

前述の例では、サービスプロバイダー ネットワークの入口では、カスタマー ネットワークの VLAN ID 1、2、3、4、5 はサービスプロバイダー ネットワークの VLAN 1001、1002、1003、1004、1005 にマッピングされます。サービスプロバイダー ネットワークの出口では、サービスプロバイダー ネットワークの VLAN 1001、1002、1003、1004、1005 はカスタマー ネットワークの VLAN ID 1、2、3、4、5 にマッピングされます。

カスタマー IEEE 802.1Q トンネル VLAN からサービス プロバイダー VLAN へのマッピング

switchport vlan mapping インターフェイス コンフィギュレーション コマンドで dot1qtunnel キーワードを使用すると、特定の外側および内側 VLAN ID を持つ IEEE 802.1Q トラフィックを、サービス プロバイダー ネットワーク上の特定の外側および内側 VLAN ID にマッピングすることもできます。 drop キーワードを使用して、特定の内側および外側 VLAN ID の組み合わせを明示的に変換しない限り、特定の外側 VLAN ID 上のトラフィックを廃棄するように指定できます。

ES ポート上で IEEE 802.1Q タグ付きトラフィックを廃棄または変換するようにスイッチを設定するには、特権 EXEC モードで次の作業を実行します。

 

コマンド
説明

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface-id

サービス プロバイダー ネットワークに接続された ES インターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

switchport vlan mapping dot1q-tunnel outer-vlan-id { inner-vlan-id translated-vlan-id | drop}

VLAN マッピングを 2 対 1 のマッピングとして設定し、元の IEEE 802.1Q パケットの外側 VLAN ID が特定の値と一致した場合に実行されるアクションを指定します。

outer-vlan-id ― 元の IEEE 802.1Q パケットの外側 VLAN ID を入力します。指定できる VLAN ID の範囲は 1 ~ 4094 です。

inner-vlan-id translated-vlan-id ― 元の IEEE 802.1Q パケットの内側 VLAN ID と、変換後のサービス プロバイダー ネットワーク VLAN ID を入力します。指定できる VLAN ID の範囲は 1 ~ 4094 です。

drop ― 内側 VLAN ID が既存の VLAN マッピングで一致しないかぎり、指定した外側 VLAN ID を持つトラフィックを廃棄することを指定します。

ステップ 4

switchport vlan mapping internal dot1q-tunnel internal-outer-vlan-id internal-inner-vlan-id external dot1q-tunnel external-outer-vlan-id external-inner-vlan-id

VLAN マッピングを 2 対 2 のマッピングとして設定し、マッピングされる外側および内側 VLAN ID を指定します。

internal-outer-vlan-id ― 元の IEEE 802.1Q パケットの外側 VLAN ID を入力します。

internal-inner-vlan-id ― 元の IEEE 802.1Q パケットの内側 VLAN ID を入力します。

external-outer-vlan-id ― サービスプロバイダー ネットワークの外側 VLAN ID を入力します。

external-inner-vlan-id ― サービスプロバイダー ネットワークの内側 VLAN ID を入力します。

指定できる VLAN ID の範囲は 1 ~ 4094 です。


) サービスプロバイダー ネットワークの内側 VLAN ID は、元の IEEE 802.1Q パケットの VLAN ID と一致する必要があります。


ステップ 5

end

特権 EXEC モードに戻ります。

ステップ 6

show vlan mapping

設定を確認します。

ステップ 7

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

2 対 1 のマッピング情報を削除するには、 no switchport vlan mapping dot1qtunnel outer-vlan-id {inner-vlan-id translated-vlan-id | drop } インターフェイス コンフィギュレーション コマンドを使用します。2 対 2 のマッピング情報を削除するには、 switchport vlan mapping internal dot1q-tunnel internal-outer-vlan-id internal-inner-vlan-id external dot1q-tunnel external-outer-vlan-id external-inner-vlan-id インターフェイス コンフィギュレーション コマンドを使用します。

次に、外側 VLAN ID が 5、内側 VLAN ID が 6 である IEEE 802.1Q トラフィックを、VLAN ID 10 でスイッチから送信するように ES ポートで 2 対 1 のマッピングを設定する例を示します。外側 VLAN ID が 5 で、内側 VLAN ID が 6 以外の IEEE 802.1Q トラフィックは廃棄します。VLAN 5 のその他のトラフィックも廃棄します。

Switch(config)# interface gigabiethernet1/1/1
Switch(config-if)# switchport vlan mapping dot1q-tunnel 5 6 10
Switch(config-if)# switchport vlan mapping dot1q-tunnel 5 drop
Switch(config-if)# exit
 

次に、外側 VLAN ID が 5、内側 VLAN ID が 6 である IEEE 802.1Q トラフィックを、外側 VLAN ID 15 および内側 VLAN ID 16 でスイッチから送信するように ES ポートで 2 対 2 のマッピングを設定する例を示します。

Switch(config)# interface gigabitethernet1/1/1

Switch(config-if)# switchport vlan mapping internal dot1q-tunnel 5 6 external dot1q tunnel 15 6

レイヤ 2 プロトコル トンネリングの概要

サービス プロバイダー ネットワーク経由で接続される複数のサイトのカスタマーは、さまざまなレイヤ 2 プロトコルを実行して、すべてのリモート サイトおよびローカル サイトを含むようにトポロジを拡大する必要があります。Spanning Tree Protocol(STP; スパニングツリー プロトコル)が適切に稼働している必要があり、すべての VLAN が、ローカル サイトおよびサービス プロバイダー インフラストラクチャ経由ですべてのリモート サイトを含む、適切なスパニングツリーを構築する必要があります。Cisco Discovery Protocol(CDP)は、ローカル サイトおよびリモート サイトから近接するシスコ製デバイスを検出する必要があります。VLAN Trunking Protocol(VTP; VLAN トランキング プロトコル)は、カスタマー ネットワーク上の全サイトで一貫性のある VLAN 設定を提供する必要があります。

プロトコル トンネリングをイネーブルにした場合、サービス プロバイダー インフラストラクチャの着信側にあるエッジ スイッチは、レイヤ 2 プロトコル パケットを特殊な MAC アドレスでカプセル化し、それらをサービス プロバイダー ネットワーク経由で送信します。ネットワークのコア スイッチは、これらのパケットを処理せず、通常のパケットと同じように転送します。CDP、STP、または VTP のレイヤ 2 Protocol Data Unit(PDU; プロトコル データ ユニット)は、サービス プロバイダー インフラストラクチャを通過し、サービス プロバイダー ネットワークの発信側にあるカスタマー スイッチまで配信されます。同じ VLAN 上のすべてのカスタマー ポートで同様のパケットが受信され、次のような結果になります。

カスタマーの各サイトのユーザは適切に STP を実行でき、すべての VLAN が、ローカル サイトだけでなく全サイトからのパラメータに基づく適正なスパニングツリーを構築できます。

CDP は、サービス プロバイダー ネットワーク経由で接続された他のシスコ製デバイスに関する情報を検出して表示します。

VTP は、カスタマー ネットワーク全体で一貫性のある VLAN 設定を提供し、サービス プロバイダーを通じてすべてのスイッチに伝播します。


) サードパーティ ベンダーとの相互運用性を提供するには、レイヤ 2 プロトコル トンネル バイパス機能を使用できます。バイパス モードでは、プロトコル トンネリングの制御方法が異なる他社製スイッチに対して、制御PDUが透過的に転送されます。バイパス モードを実装するには、出力トランク ポート上でレイヤ 2 プロトコル トンネリングをイネーブルに設定します。レイヤ 2 プロトコル トンネリングがトランク ポートでイネーブルである場合、カプセル化されたトンネル MAC アドレスは削除され、プロトコル パケットの MAC アドレスは通常の MAC アドレスとなります。


レイヤ 2 プロトコル トンネリングは単独で使用することも、IEEE 802.1Q トンネリングの機能を拡張することもできます。IEEE 802.1Q トンネリング ポート上でプロトコル トンネリングをイネーブルに設定しない場合、サービス プロバイダー ネットワークの受信側の終端にあるリモート スイッチは PDU を受信せず、STP、CDP、および VTP を適切に実行することができません。プロトコル トンネリングが イネーブル の場合、各カスタマーのネットワーク上のレイヤ 2 プロトコルは、サービス プロバイダー ネットワーク上で稼働しているレイヤ 2 プロトコルから完全に隔離されます。IEEE 802.1Q トンネリング機能のあるサービス プロバイダー ネットワーク経由でトラフィックを送信する各サイトのカスタマー スイッチは、カスタマーのVLANを完全に認識できます。IEEE 802.1Q トンネリングを使用しない場合にも、アクセス ポートまたはトランク ポート経由でカスタマー スイッチに接続し、サービス プロバイダーのアクセス ポートまたはトランク ポート上でトンネリングをイネーブルにすることによって、レイヤ 2 プロトコル トンネリングをイネーブルにできます。

たとえば図16-5の場合、カスタマー X には、サービス プロバイダー ネットワーク経由で接続された同じ VLAN 上の 4 台のスイッチがあります。このネットワークが PDU をトンネリングしない場合、ネットワークの遠端にあるスイッチは、STP、CDP、および VTP を適切に実行することができません。たとえば、カスタマー X、サイト 1 のスイッチ上の VLAN で動作する STP は、カスタマー X、サイト 2 のスイッチに基づくコンバージェンス パラメータを考慮せずに、このサイトのスイッチのスパニングツリーを構築します。その結果、図16-6に示すトポロジになる可能性があります。

図16-5 レイヤ 2 プロトコル トンネリング

 

図16-6 BPDU トンネリングを使用しない仮想ネットワーク トポロジ

 

サービスプロバイダー ネットワークでは、レイヤ 2 プロトコル トンネリングを使用して、ポイントツーポイント ネットワーク トポロジをエミュレートすることで EtherChannel の作成機能を拡張します。プロトコル トンネリング(PAgP または LACP)をサービスプロバイダー スイッチでイネーブルにすると、リモート カスタマー スイッチが PDU を受信し、EtherChannel の自動作成をネゴシエーションします。

たとえば図16-7の場合、カスタマー A には、サービス プロバイダー ネットワーク経由で接続された同じ VLAN 上の 2 台のスイッチがあります。ネットワークが PDU をトンネリングする場合、ネットワークの遠端にあるスイッチは、専用回線を必要とすることなく EtherChannel の自動作成をネゴシエーションできます。EtherChannel のレイヤ 2 プロトコル トンネリングの設定については「EtherChannel のレイヤ 2 トンネリングの設定」を参照してください。

図16-7 EtherChannel のレイヤ 2 プロトコル トンネリング

 

レイヤ 2 プロトコル トンネリングの設定

サービス プロバイダー ネットワークのエッジ スイッチ上のカスタマーに接続されたポート上で、(プロトコル別の)レイヤ 2 プロトコル トンネリングをイネーブルにします。エッジ スイッチのトンネル ポートは、カスタマーの IEEE 802.1Q トランク ポートに接続されています。エッジ スイッチのアクセス ポートは、カスタマーのアクセス ポートに接続されています。カスタマー スイッチに接続するエッジ スイッチが、トンネリング処理を実行します。

レイヤ 2 プロトコル トンネリングは、アクセス ポート、トンネル ポート、またはトランク ポートとして設定されたポート上でイネーブルにできます。スイッチポート モード dynamic auto (デフォルト モード)または dynamic desirable に設定されたポート上でレイヤ 2 プロトコル トンネリングをイネーブルにすることはできません。スイッチは CDP、STP、および VTP に対応するレイヤ 2 プロトコル トンネリングをサポートしています。エミュレートされたポイントツーポイント ネットワーク トポロジの場合、スイッチは PAgP、LACP、UDLD プロトコルもサポートします。LLDP のレイヤ 2 プロトコル トンネリングはサポートされません。


注意 PAgP、LACP、UDLD プロトコル トンネリングはポイントツーポイント トポロジをエミュレートするためだけのものです。トンネリングされたパケットを多くのポートに送信する誤った設定では、ネットワーク障害となることがあります。

入力エッジ スイッチのレイヤ 2 プロトコル対応ポートに着信したレイヤ 2 PDU がトランク ポート経由でサービス プロバイダー ネットワークに送信されるとき、スイッチはカスタマー PDU 宛先 MAC アドレスを、シスコ独自の well-known マルチキャスト アドレス(01-00-0c-cd-cd-d0)で上書きします。IEEE 802.1Q トンネリングがイネーブルに設定されていなければ、パケットには二重タグも付けられます(外側のタグはカスタマー メトロ タグ、内側のタグはカスタマー VLAN タグ)。コア スイッチは内側のタグを無視し、同じメトロ VLAN 上のすべてのトランク ポートにパケットを転送します。出力側のエッジ スイッチは適切なレイヤ 2 プロトコルおよび MAC アドレス情報を復元し、同じメトロ VLAN 上のすべてのトンネル ポート、アクセス ポート、およびレイヤ 2 プロトコル対応トランク ポートにパケットを転送します。したがって、レイヤ 2 PDU はそのまま維持され、サービス プロバイダー インフラストラクチャ経由でカスタマー ネットワークの反対側まで配信されます。

図16-5を参照してください。アクセス VLAN 30 および 40 に、それぞれカスタマー X およびカスタマー Y が存在しています。サイト 1 のカスタマーは、非対称リンクによってサービス プロバイダー ネットワークのエッジ スイッチに接続されています。サイト 1 のカスタマー Y のスイッチ B に着信するレイヤ 2 PDU(たとえば、BPDU など)は、宛先 MAC アドレスとして well-known MAC アドレスを使用した二重タグ付きパケットとしてインフラストラクチャに転送されます。これらの二重タグ付きパケットには、外側 VLAN タグ 40 のほかに、内側 VLAN タグ(たとえば、VLAN 100 など)があります。二重タグ付きパケットがスイッチ D に到達すると、外側 VLAN タグ 40 が削除され、well-known MAC アドレスが該当するレイヤ 2 プロトコル MAC アドレスに置き換えられ、パケットは VLAN 100 上で一重のタグ付きパケットとしてサイト 2 のカスタマー Y に送信されます。

カスタマー スイッチのアクセス ポートまたはトランク ポートに接続されたエッジ スイッチのアクセスまたはトランク ポート上で、レイヤ 2 プロトコル トンネリングをイネーブルにすることもできます。この場合、カプセル化およびカプセル化解除の動作は、パケットがサービス プロバイダー ネットワーク上で二重にタグ付けされない点を除いて、上記と同様です。この一重タグとはカスタマー固有のアクセス VLAN タグです。

ここでは、レイヤ 2 プロトコル トンネリングの設定手順を説明します。具体的な内容は次のとおりです。

「レイヤ 2 プロトコル トンネリングのデフォルト設定」

「レイヤ 2 プロトコル トンネリング設定時の注意事項」

「レイヤ 2 トンネリングの設定」

「EtherChannel のレイヤ 2 トンネリングの設定」

レイヤ 2 プロトコル トンネリングのデフォルト設定

表16-1 に、レイヤ 2 プロトコル トンネリングのデフォルト設定を示します。

 

表16-1 レイヤ 2 プロトコル トンネリングのデフォルト設定

機能
デフォルト設定

レイヤ 2 プロトコル トンネリング

CDP、STP、および VTP に関してディセーブル

シャットダウンしきい値

ポートをシャットダウンするしきい値(ポート単位でのレイヤ 2 PDU のパケット/秒)は、設定なし

ドロップしきい値

ポートが PDU を廃棄するしきい値(ポート単位でのレイヤ 2 PDU のパケット/秒)は、設定なし

CoS 値

インターフェイス上でデータ パケットの CoS 値が設定されている場合、その値がデフォルトとしてレイヤ 2 PDU に使用されます。設定しない場合、デフォルトは 5 です。

レイヤ 2 プロトコル トンネリング設定時の注意事項

レイヤ 2 プロトコル トンネリングの設定時の注意事項および動作特性は、次のとおりです。

スイッチは CDP、STP(Multiple STP [MSTP] を含む)、および VTP のトンネリングをサポートしています。プロトコル トンネリングはデフォルトでディセーブルですが、IEEE 802.1Q トンネル ポート、アクセス ポート、またはトランク ポート上で個々のプロトコルについてイネーブルに設定できます。

ポイントツーポイント ネットワーク トポロジがエミュレートされた場合、スイッチは PAgP、LACP、UDLD トンネリングをサポートします。プロトコル トンネリングはデフォルトでディセーブルですが、IEEE 802.1Q トンネル ポート、アクセス ポート、またはトランク ポート上で個々のプロトコルについてイネーブルに設定できます。

スイッチは、スイッチポート モードが dynamic auto または dynamic desirable のポート上でのレイヤ 2 プロトコル トンネリングはサポートしません。

PAgP または LACP トンネリングをイネーブルにする場合、リンク障害検出を高速にするためインターフェイス上で UDLD もイネーブルにすることを推奨します。

PAgP パケット、LACP パケット、または UDLD パケットのレイヤ 2 プロトコル トンネリングでは、ループバック検出がサポートされません。

DTP は、レイヤ 2 プロトコル トンネリングとは非互換です。トンネル ポートとトランク ポートのある非対称リンクを手動で設定しなければならないからです。

出力側のエッジ スイッチは適切なレイヤ 2 プロトコルおよび MAC アドレス情報を復元し、同じメトロ VLAN 上のすべてのトンネル ポート、アクセス ポート、およびレイヤ 2 プロトコル対応トランク ポートにパケットを転送します。

サードパーティ ベンダー製スイッチとの相互運用性を確保するために、スイッチはレイヤ 2 プロトコル トンネル バイパス機能をサポートしています。バイパス モードでは、プロトコル トンネリングの制御方法が異なるベンダー製スイッチに対して、制御 PDU が透過的に転送されます。スイッチの入力ポート上でレイヤ 2 プロトコル トンネリングがイネーブルの場合、出力トランク ポートは特殊なカプセル化を使用してトンネリングされたパケットを転送します。出力トランク ポート上でもレイヤ 2 プロトコル トンネリングをイネーブルに設定すると、この動作はバイパスされ、スイッチは制御 PDU を処理または変更することなく転送します。

EtherChannel ポート グループがトンネル ポートと互換性を持つのは、EtherChannel ポート グループ内で IEEE 802.1Q 設定が一貫している場合に限られます。

トンネル ポートまたはレイヤ 2 トンネリングがイネーブルに設定されているアクセスまたはトランク ポートから(独自の宛先 MAC アドレスを使用して)カプセル化された PDU を受信した場合、ループを防ぐために、そのポートはシャットダウンされます。また、プロトコルに関して設定されているシャットダウンしきい値に達した場合にも、ポートはシャットダウンされます。ポートを手動で再びイネーブルにする( shutdown および no shutdown コマンドシーケンスを使用する)ことができます。また、errdisable 回復機能をイネーブルに設定している場合、所定のタイム インターバルが経過したあとに動作が再試行されます。

カスタマー ネットワークに転送されるのは、カプセル化解除された PDU のみです。サービス プロバイダー ネットワーク上で動作しているスパニングツリー インスタンスは、トンネル ポートに BPDU を転送しません。トンネル ポートから CDP パケットが転送されることはありません。

インターフェイス上でプロトコル トンネリングがイネーブルに設定されている場合、カスタマー ネットワークが生成する PDU のプロトコル単位およびポート単位でのシャットダウンしきい値を設定できます。この限界を超過すると、ポートがシャットダウンされます。また、トンネル ポート上で QoS ACL およびポリシー マップを使用して BPDU を速度制限することもできます。

インターフェイス上でプロトコル トンネリングがイネーブルに設定されている場合、カスタマー ネットワークが生成する PDU のプロトコル単位およびポート単位でのドロップしきい値を設定できます。この限界を超過すると、ポートは PDU を受信する速度がドロップしきい値より下になるまで、PDU を廃棄します。

カスタマーの仮想ネットワークが正常に動作するには、トンネリングされる PDU(特に STP BPDU)をすべてのリモート サイトに配信する必要があるため、サービス プロバイダー ネットワーク上で同じトンネル ポートから受信するデータ パケットより高いプライオリティを PDU に与えることができます。デフォルトでは、PDU はデータ パケットと同じ CoS 値を使用します。

レイヤ 2 トンネリングの設定

ポートをレイヤ 2 プロトコル トンネリング用に設定するには、特権 EXEC モードで次の手順を実行します。

 

コマンド
説明

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface-id

トンネル ポートとして設定するインターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。このポートは、カスタマー スイッチに接続するサービス プロバイダー ネットワーク上のエッジ ポートでなければなりません。有効なインターフェイスは、物理インターフェイスやポートチャネル論理インターフェイス(ポートチャネル 1 ~ 12)などです。

ステップ 3

switchport mode access
または
switchport mode dot1q-tunnel

または
switchport mode trunk

インターフェイスをアクセス ポート、IEEE 802.1Q トンネル ポート、またはトランク ポートとして設定します。

ステップ 4

l2protocol-tunnel [ cdp | stp | vtp ]

希望するプロトコルのプロトコル トンネリングをイネーブルにします。キーワードを指定しない場合、3 つのレイヤ 2 プロトコル全部でトンネリングがイネーブルになります。

ステップ 5

l2protocol-tunnel shutdown-threshold [ cdp | stp | vtp ] value

(任意)カプセル化用の受信について、インターフェイスをシャットダウンするまでのしきい値(パケット/秒)を設定します。設定したしきい値を超過すると、ポートがディセーブルになります。プロトコル オプションを指定しない場合、トンネリングされる各レイヤ 2 プロトコル タイプにしきい値が適用されます。指定できる範囲は 1 ~ 4096 です。デフォルトでは、しきい値は設定されません。


) このインターフェイスに対してドロップしきい値も設定する場合、シャットダウンしきい値は、ドロップしきい値以上でなければなりません。


ステップ 6

l2protocol-tunnel drop-threshold [ cdp | stp | vtp ] value

(任意)カプセル化用の受信について、インターフェイスがパケットを廃棄するまでのしきい値(パケット/秒)を設定します。設定したしきい値を超過すると、ポートはパケットを廃棄します。プロトコル オプションを指定しない場合、トンネリングされる各レイヤ 2 プロトコル タイプにしきい値が適用されます。指定できる範囲は 1 ~ 4096 です。デフォルトでは、しきい値は設定されません。


) このインターフェイスに対してシャットダウンしきい値も設定する場合、ドロップしきい値は、シャットダウンしきい値以下でなければなりません。


ステップ 7

exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 8

errdisable recovery cause l2ptguard

(任意)レイヤ 2 最大レート エラーからの回復メカニズムを設定し、インターフェイスがディセーブル ステートから復帰して再試行できるようにします。タイム インターバルも設定できます。errdisable 回復は、デフォルトではディセーブルに設定されています。イネーブルに設定する場合、デフォルトのタイム インターバルは 300 秒です。

ステップ 9

l2protocol-tunnel cos value

(任意)トンネリングされるすべてのレイヤ 2 PDU の CoS 値を設定します。指定できる範囲は 0 ~ 7 です。デフォルトでは、インターフェイスのデフォルトの CoS 値が使用されます。設定しない場合、デフォルトは 5 です。

ステップ 10

end

特権 EXEC モードに戻ります。

ステップ 11

show l2protocol

スイッチ上のレイヤ 2 トンネル ポートを、設定されているプロトコル、しきい値、およびカウンタも含めて表示します。

ステップ 12

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

いずれかのレイヤ 2 プロトコル、または 3 つのプロトコル全部について、プロトコル トンネリングをディセーブルにするには、 no l2protocol-tunnel [ cdp | stp | vtp ] インターフェイス コンフィギュレーション コマンドを使用します。シャットダウンおよびドロップしきい値をデフォルト設定に戻すには、 no l2protocol-tunnel shutdown-threshold [ cdp | stp | vtp ] および no l2protocol-tunnel drop-threshold [ cdp | stp | vtp ] コマンドを使用します。

次に、CDP、STP、および VTP についてレイヤ 2 プロトコル トンネリングを設定し、設定を確認する例を示します。

Switch(config)# interface gigabitethernet1/0/2
Switch(config-if)# l2protocol-tunnel cdp
Switch(config-if)# l2protocol-tunnel stp
Switch(config-if)# l2protocol-tunnel vtp
Switch(config-if)# l2protocol-tunnel shutdown-threshold 1500
Switch(config-if)# l2protocol-tunnel drop-threshold 1000
Switch(config-if)# exit
Switch(config)# l2protocol-tunnel cos 7
Switch(config)# end
Switch# show l2protocol
COS for Encapsulated Packets: 7
 
Port Protocol Shutdown Drop Encapsulation Decapsulation Drop
Threshold Threshold Counter Counter Counter
------- -------- --------- --------- ------------- ------------- -------------
Gi1/0/2 cdp 1500 1000 0 0 0
stp 1500 1000 0 0 0
vtp 1500 1000 0 0 0

EtherChannel のレイヤ 2 トンネリングの設定

レイヤ 2 ポイントツーポイント トンネリングを設定して EtherChannel の自動作成を容易にするには、サービスプロバイダー エッジ スイッチおよびカスタマー スイッチの両方を設定する必要があります。

サービスプロバイダー エッジ スイッチの設定

EtherChannel のレイヤ 2 プロトコル トンネリング用にサービスプロバイダー エッジ スイッチを設定するには、特権 EXEC モードで次の手順を実行します。

 

コマンド
説明

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface-id

トンネル ポートとして設定するインターフェイスを入力し、インターフェイス コンフィギュレーション モードを開始します。このポートは、カスタマー スイッチに接続するサービス プロバイダー ネットワーク上のエッジ ポートでなければなりません。有効なインターフェイスは物理インターフェイスです。

ステップ 3

switchport mode dot1q-tunnel

インターフェイスを IEEE 802.1Q トンネル ポートとして設定します。

ステップ 4

l2protocol-tunnel point-to-point [ pagp | lacp | udld ]

希望するプロトコルのポイントツーポイント プロトコル トンネリングをイネーブルにします。キーワードを指定しない場合、3 つのプロトコル全部でトンネリングがイネーブルになります。


注意 ネットワーク障害を避けるため、ネットワークがポイントツーポイント トポロジになっていることを確認してから、PAgP パケット、LACP パケット、または UDLD パケットのトンネリングをイネーブルにしてください。

ステップ 5

l2protocol-tunnel shutdown-threshold [ point-to-point [ pagp | lacp | udld ]] value

(任意)カプセル化用に 1 秒間に受信するパケット数のしきい値を設定します。設定したしきい値を超過すると、インターフェイスがディセーブルになります。プロトコル オプションを指定しない場合、トンネリングされる各レイヤ 2 プロトコル タイプにしきい値が適用されます。指定できる範囲は 1 ~ 4096 です。デフォルトでは、しきい値は設定されません。


) このインターフェイスに対してドロップしきい値も設定する場合、シャットダウンしきい値は、ドロップしきい値以上でなければなりません。


ステップ 6

l2protocol-tunnel drop-threshold [ point-to-point [ pagp | lacp | udld ]] value

(任意)カプセル化用に 1 秒間に受信するパケット数のしきい値を設定します。設定したしきい値を超過すると、インターフェイスはパケットを廃棄します。プロトコル オプションを指定しない場合、トンネリングされる各レイヤ 2 プロトコル タイプにしきい値が適用されます。指定できる範囲は 1 ~ 4096 です。デフォルトでは、しきい値は設定されません。


) このインターフェイスに対してシャットダウンしきい値も設定する場合、ドロップしきい値は、シャットダウンしきい値以下でなければなりません。


ステップ 7

no cdp enable

インターフェイスの CDP をディセーブルにします。

ステップ 8

spanning-tree bpdufilter enable

インターフェイス上で BPDU フィルタリングをイネーブルにします。

ステップ 9

exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 10

errdisable recovery cause l2ptguard

(任意)インターフェイスを再びイネーブルにして再試行できるようにするため、レイヤ 2 最大レート エラーからの回復メカニズムを設定します。errdisable 回復は、デフォルトではディセーブルに設定されています。イネーブルに設定する場合、デフォルトのタイム インターバルは 300 秒です。

ステップ 11

l2protocol-tunnel cos value

(任意)トンネリングされるすべてのレイヤ 2 PDU の CoS 値を設定します。指定できる範囲は 0 ~ 7 です。デフォルトでは、インターフェイスのデフォルトの CoS 値が使用されます。設定しない場合、デフォルトは 5 です。

ステップ 12

end

特権 EXEC モードに戻ります。

ステップ 13

show l2protocol

スイッチ上のレイヤ 2 トンネル ポートを、設定されているプロトコル、しきい値、およびカウンタも含めて表示します。

ステップ 14

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

いずれかのレイヤ 2 プロトコルまたは 3 つすべてのレイヤ 2 プロトコルのポイントツーポイント プロトコル トンネリングをディセーブルにするには、 no l2protocol-tunnel [ point-to-point [ pagp | lacp | udld ]] インターフェイス コンフィギュレーション コマンドを使用します。シャットダウンしきい値およびドロップしきい値をデフォルト設定に戻すには、 no l2protocol-tunnel shutdown-threshold [ point-to-point [ pagp | lacp | udld ]]および no l2protocol-tunnel drop-threshold [[ point-to-point [ pagp | lacp | udld ]] コマンドを使用します。

カスタマー スイッチの設定

サービスプロバイダー エッジ スイッチを設定したら、特権 EXEC モードで次の手順を実行し、EtherChannel のレイヤ 2 プロトコル トンネリング用にカスタマー スイッチを設定します。

 

コマンド
説明

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface-id

インターフェイス コンフィギュレーション モードを開始します。これは、カスタマー スイッチ ポートにする必要があります。

ステップ 3

switchport trunk encapsulation dot1q

トランキング カプセル化フォーマットを IEEE 802.1Q に設定します。


) Cisco IOS Release 12.2(22)EY 以降のリリースでは、このステップは ES ポートでは不要です。ES ポートは IEEE 802.1Q トランキングのみをサポートするため、encapsulation キーワードは認識されません。


ステップ 4

switchport mode trunk

インターフェイス上でトランキングをイネーブルにします。

ステップ 5

udld enable

インターフェイスの 通常モード で UDLD をイネーブルにします。

ステップ 6

channel-group channel-group-number mode desirable

チャネル グループにインターフェイスを割り当て、PAgP モードに desirable を指定します。EtherChannel の設定の詳細については、 第34章「EtherChannel および リンクステート トラッキングの設定」 を参照してください。

ステップ 7

exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 8

interface port-channel port-channel number

ポートチャネル インターフェイス モードを開始します。

ステップ 9

shutdown

インターフェイスをシャットダウンします。

ステップ 10

no shutdown

インターフェイスをイネーブルにします。

ステップ 11

end

特権 EXEC モードに戻ります。

ステップ 12

show l2protocol

スイッチ上のレイヤ 2 トンネル ポートを、設定されているプロトコル、しきい値、およびカウンタも含めて表示します。

ステップ 13

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

インターフェイスをデフォルト設定に戻すには、 no switchport mode trunk no udld enable および no channel group channel-group-number mode desirable インターフェイス コンフィギュレーション コマンドを使用します。

EtherChannel の場合は、サービスプロバイダー エッジ スイッチおよびカスタマー スイッチをレイヤ 2 プロトコル トンネリング用に設定する必要があります。

次に、図16-7のサービス プロバイダーのエッジ スイッチ A およびエッジ スイッチ B を設定する方法を示します。VLAN 17、18、19、20 はアクセス VLAN、ファスト イーサネット ポート 1 および 2 は PAgP および UDLD がイネーブルになっているポイントツーポイント トンネル ポート、ドロップしきい値は 1000、ファスト イーサネット ポート 3 はトランク ポートです。

サービスプロバイダー エッジ スイッチ A の設定

Switch(config)# interface fastethernet1/0/1
Switch(config-if)# switchport access vlan 17
Switch(config-if)# switchport mode dot1q-tunnel
Switch(config-if)# l2protocol-tunnel point-to-point pagp
Switch(config-if)# l2protocol-tunnel point-to-point udld
Switch(config-if)# l2protocol-tunnel drop-threshold point-to-point pagp 1000
Switch(config-if)# exit
Switch(config)# interface fastethernet1/0/2
Switch(config-if)# switchport access vlan 18
Switch(config-if)# switchport mode dot1q-tunnel
Switch(config-if)# l2protocol-tunnel point-to-point pagp
Switch(config-if)# l2protocol-tunnel point-to-point udld
Switch(config-if)# l2protocol-tunnel drop-threshold point-to-point pagp 1000
Switch(config-if)# exit
Switch(config)# interface fastethernet1/0/3
Switch(config-if)# switchport trunk encapsulation isl
Switch(config-if)# switchport mode trunk
 

サービスプロバイダー エッジ スイッチ B の設定

Switch(config)# interface fastethernet1/0/1
Switch(config-if)# switchport access vlan 19
Switch(config-if)# switchport mode dot1q-tunnel
Switch(config-if)# l2protocol-tunnel point-to-point pagp
Switch(config-if)# l2protocol-tunnel point-to-point udld
Switch(config-if)# l2protocol-tunnel drop-threshold point-to-point pagp 1000
Switch(config-if)# exit
Switch(config)# interface fastethernet1/0/2
Switch(config-if)# switchport access vlan 20
Switch(config-if)# switchport mode dot1q-tunnel
Switch(config-if)# l2protocol-tunnel point-to-point pagp
Switch(config-if)# l2protocol-tunnel point-to-point udld
Switch(config-if)# l2protocol-tunnel drop-threshold point-to-point pagp 1000
Switch(config-if)# exit
Switch(config)# interface fastethernet1/0/3
Switch(config-if)# switchport trunk encapsulation isl
Switch(config-if)# switchport mode trunk
 

次に、サイト 1 のカスタマー スイッチを設定する例を示します。ファスト イーサネット ポート 1、2、3、4 は IEEE 802.1Q トランキング用に設定されており、UDLD はイネーブル、EtherChannel グループ 1 はイネーブル、ポート チャネルはシャットダウンされたあとでイネーブルになって EtherChannel 設定がアクティブになります。

Switch(config)# interface fastethernet1/0/1
Switch(config-if)# switchport trunk encapsulation dot1q
Switch(config-if)# switchport mode trunk
Switch(config-if)# udld enable
Switch(config-if)# channel-group 1 mode desirable
Switch(config-if)# exit
Switch(config)# interface fastethernet1/0/2
Switch(config-if)# switchport trunk encapsulation dot1q
Switch(config-if)# switchport mode trunk
Switch(config-if)# udld enable
Switch(config-if)# channel-group 1 mode desirable
Switch(config-if)# exit
Switch(config)# interface fastethernet1/0/3
Switch(config-if)# switchport trunk encapsulation dot1q
Switch(config-if)# switchport mode trunk
Switch(config-if)# udld enable
Switch(config-if)# channel-group 1 mode desirable
Switch(config-if)# exit
Switch(config)# interface fastethernet1/0/4
Switch(config-if)# switchport trunk encapsulation dot1q
Switch(config-if)# switchport mode trunk
Switch(config-if)# udld enable
Switch(config-if)# channel-group 1 mode desirable
Switch(config-if)# exit
Switch(config)# interface port-channel 1
Switch(config-if)# shutdown
Switch(config-if)# no shutdown
Switch(config-if)# exit

トンネリングおよびマッピング ステータスのモニタおよびメンテナンス

表16-2 に、IEEE 802.1Q およびレイヤ 2 プロトコル トンネリングと VLAN マッピングのモニタおよびメンテナンスに使用する特権 EXEC コマンドを示します。

 

表16-2 トンネリングおよび VLAN マッピングのモニタおよびメンテナンス用コマンド

コマンド
説明

clear l2protocol-tunnel counters

レイヤ 2 プロトコル トンネリング ポート上のプロトコル カウンタをクリアします。

show dot1q-tunnel

スイッチ上の IEEE 802.1Q トンネル ポートを表示します。

show dot1q-tunnel interface interface-id

特定のインターフェイスがトンネル ポートであるかどうかを確認します。

show l2protocol-tunnel

レイヤ 2 プロトコル トンネリング ポートに関する情報を表示します。

show errdisable recovery

レイヤ 2 プロトコル トンネルの errdisable ステートからの回復タイマーがイネーブルかどうかを確認します。

show interface interface-id vlan mapping

指定したインターフェイスの VLAN マッピング情報を表示します。インターフェイスは、ES ポートまたは VLAN にすることができます。

show l2protocol-tunnel interface interface-id

特定のレイヤ 2 プロトコル トンネリング ポートに関する情報を表示します。

show l2protocol-tunnel summary

レイヤ 2 プロトコル サマリー情報のみを表示します。

show vlan dot1q native

スイッチ上のネイティブ VLAN タギングのステータスを表示します。

show vlan mapping

ES ポートの VLAN マッピング情報(VLAN マッピング テーブルの内容)を表示します。

これらのコマンド出力の詳細については、このリリースのコマンド リファレンスを参照してください。