Catalyst 3750 Metro スイッチ ソフトウェア コンフィギュレーション ガイド Cisco IOS Release 12.2(25)SEG
VLAN の設定
VLAN の設定
発行日;2012/01/06 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 10MB) | フィードバック

目次

VLAN の設定

VLAN の概要

サポートされる VLAN

VLAN ポート メンバーシップ モード

標準範囲 VLAN の設定

トークン リング VLAN

標準範囲 VLAN の設定時の注意事項

VLAN 設定モードのオプション

config-vlan モードでの VLAN 設定

VLAN データベース コンフィギュレーション モードでの VLAN 設定

VLAN 設定の保存

イーサネット VLAN のデフォルト設定

イーサネット VLAN の作成または変更

VLAN の削除

VLAN へのスタティック アクセス ポートの割り当て

拡張範囲 VLAN の設定

VLAN のデフォルト設定

拡張範囲 VLAN の設定時の注意事項

拡張範囲 VLAN の作成

内部 VLAN ID を指定した拡張範囲 VLAN の作成

VLAN の表示

VLAN トランクの設定

トランキングの概要

カプセル化タイプ

IEEE 802.1Q の設定に関する注意事項

レイヤ 2 イーサネット インターフェイス VLAN のデフォルト設定

トランク ポートとしてのイーサネット インターフェイスの設定

他の機能との相互作用

トランク ポートの設定

トランク上での許可 VLAN の定義

プルーニング適格リストの変更

タグなしトラフィック用ネイティブ VLAN の設定

トランク ポートのロード シェアリングの設定

STP ポート プライオリティによるロード シェアリング

STP パス コストによるロード シェアリング

VMPS の設定

VMPS の概要

ダイナミック アクセス ポート VLAN メンバーシップ

VMPS クライアントのデフォルト設定

VMPS 設定時の注意事項

VMPS クライアントの設定

VMPS の IP アドレスの入力

VMPS クライアントのダイナミック アクセス ポートの設定

VLAN メンバーシップの確認

再確認インターバルの変更

再試行回数の変更

VMPS のモニタ

ダイナミック アクセス ポート VLAN メンバーシップのトラブルシューティング

VMPS の構成例

VLAN の設定

この章では、Catalyst 3750 Metro スイッチに、標準範囲の VLAN(仮想 LAN)(VLAN ID が 1 ~ 1005)および拡張範囲の VLAN(VLAN ID が 1006 ~ 4094)を設定する方法について説明します。VLAN メンバーシップ モード、VLAN コンフィギュレーション モード、VLAN トランク、VLAN Membership Policy Server(VMPS; VLAN メンバーシップ ポリシー サーバ)からのダイナミック VLAN 割り当てについても説明します。


) この章で使用されるコマンドの構文および使用方法の詳細については、このリリースのコマンド リファレンスを参照してください。


この章で説明する内容は、次のとおりです。

「VLAN の概要」

「標準範囲 VLAN の設定」

「拡張範囲 VLAN の設定」

「VLAN の表示」

「VLAN トランクの設定」

「VMPS の設定」

VLAN の概要

VLAN は、ユーザの物理的な位置に関係なく、機能、プロジェクト チーム、またはアプリケーションによって論理的に分割されたスイッチド ネットワークです。VLAN は物理 VLAN と同じアトリビュートを備えていますが、エンド ステーションが物理的に同一の LAN セグメントにない場合でもグループ化できます。どのスイッチ ポートも VLAN に割り当てることができます。ユニキャスト、ブロードキャスト、およびマルチキャスト パケットは、VLAN 内のエンド ステーションにだけフォワーディングおよびフラッディングが行われます。各 VLAN は 1 つの論理ネットワークとみなされ、VLAN に属さないステーション宛のパケットは、ルータまたは代替ブリッジングをサポートするスイッチを経由して伝送しなければなりません(図12-1を参照)。VLAN はそれぞれが独立した論理ネットワークとみなされるので、VLAN ごとに独自のブリッジ MIB(管理情報ベース)情報があり、それぞれが独自にスパニングツリーの実装をサポートします。 第 17 章「STP の設定」 を参照してください。


) VLAN を作成するには、まず VLAN Trunking Protocol(VTP; VLAN トランキング プロトコル)を使用してネットワークのグローバル VLAN 設定をメンテナンスするかどうかを決定する必要があります。VTP の詳細については、第 13 章「VTP の設定」を参照してください。


図12-1に、論理的に定義されたネットワークに分割した VLAN の例を示します。

図12-1 論理的に定義されたネットワークとしての VLAN

 

VLAN は、多くの場合、IP サブネットワークと対応付けられます。たとえば、特定の IP サブネットのすべてのエンド ステーションを同一の VLAN に属させることがあります。スイッチ上のインターフェイス VLAN メンバーシップは、インターフェイスごとに手動で割り当てます。この方法で VLAN にスイッチ インターフェイスを割り当てることを、インターフェイスベースまたはスタティック VLAN メンバーシップと呼びます。

VLAN 間のトラフィックはルーティングするか代替ブリッジングする必要があります。スイッチは、Switch Virtual Interface(SVI)を使用して、VLAN 間でトラフィックをルーティングできます。VLAN 間でトラフィックをルーティングするには、SVI を明示的に設定して IP アドレスを割り当てる必要があります。詳細については、「SVI」および「レイヤ 3 インターフェイスの設定」を参照してください。


) スイッチに多数の VLAN を設定し、ルーティングをイネーブル化しない予定の場合は、sdm prefer vlan グローバル コンフィギュレーション コマンドを使用して Switch Database Management(SDM)機能を VLAN テンプレートに設定できます。このテンプレートは、最大数のユニキャスト MAC(メディア アクセス制御)アドレスをサポートするようにシステム リソースを設定します。SDM テンプレートの詳細については、第 7 章「SDM テンプレートの設定」、またはこのリリースのコマンド リファレンスのsdm prefer コマンドを参照してください。


サポートされる VLAN

スイッチは、VTP クライアント、サーバ、およびトランスペアレント モードの 1 ~ 1005 の VLAN をサポートします。VLAN は、1 ~ 4094 の番号で識別されます。VLAN ID の 1002 ~ 1005 は、トークン リングおよび FDDI VLAN 用です。VTP は、VLAN ID が 1 ~ 1005 の標準範囲 VLAN のみを学習します。1005 を超える VLAN ID は拡張範囲 VLAN であり、VLAN データベースには保存されません。1006 ~ 4094 の VLAN ID を作成するときには、スイッチは VTP トランスペアレント モードである必要があります。

スイッチは合計 1005(標準範囲および拡張範囲)の VLAN をサポートしますが、ルーテッド ポート、SVI、その他の設定済み機能の個数によって、スイッチのハードウェアの使用は左右されます。

このスイッチは、Per-VLAN Spanning-Tree plus(PVST+)と最大 128 のスパニングツリー インスタンスをサポートします。VLAN ごとに 1 つのスパニングツリー インスタンスがサポートされます。スパニングツリー インスタンスの数と VLAN 番号の詳細については、「標準範囲 VLAN の設定時の注意事項」を参照してください。スイッチは、イーサネットポート経由の VLAN トラフィックの送信方式として、ISL(スイッチ間リンク)および IEEE 802.1Q トランキングの両方をサポートしています。

VLAN ポート メンバーシップ モード

VLAN に属するポートは、メンバーシップ モードを指定して設定します。メンバーシップ モードにより、各ポートが搬送できるトラフィックの種類、および属することができる VLAN の数が決まります。 表12-1 に、各種メンバーシップ モード、メンバーシップ、VTP 特性を示します。

 

表12-1 ポート メンバーシップ モード

メンバーシップ モード
VLAN メンバーシップの特性
VTP 特性

スタティック アクセス

スタティック アクセス ポートは 1 つの VLAN のみに属し、手動でその VLAN に割り当てられます。詳細については、「VLAN へのスタティック アクセス ポートの割り当て」を参照してください。

VTP は必須ではありません。VTP にグローバルに情報を伝播させないようにする場合は、VTP モードをトランスペアレントに設定して VTP をディセーブルにします。VTP に加入するには、あるスイッチのトランク ポートに接続した別のスイッチ上に最低 1 つのトランク ポートがなければなりません。

トランク(ISL または IEEE 802.1Q)

トランク ポートは、拡張範囲 VLAN も含めて、デフォルトで全 VLAN のメンバーですが、許可 VLAN リストを設定することにより、メンバーシップを制限できます。プルーニング適格リストを変更して、リストに含まれるトランク ポート上で VLAN に対するフラッディング トラフィックをブロックすることもできます。トランク ポートの設定の詳細については、「トランク ポートとしてのイーサネット インターフェイスの設定」を参照してください。


) Cisco IOS Release 12.2(22)EY 以降のリリースでは、ISL トランキングは ES ポートでサポートされません。ES ポートは IEEE 802.1Q カプセル化のみをサポートします。


VTP は、推奨はしますが、必須ではありません。VTP は、ネットワーク全体にわたって VLAN の追加、削除、名前変更を管理することにより、VLAN 設定の整合性を維持します。VTP はトランク リンクを通じて他のスイッチと VLAN コンフィギュレーション メッセージを交換します。

ダイナミック アクセス

ダイナミック アクセス ポートは、1 つの VLAN(VLAN ID が 1 ~ 4094)のみに属し、VMPS によってダイナミックに割り当てられます。たとえば、Catalyst 5000 または Catalyst 6500 シリーズ スイッチは VMPS として使用できますが、Catalyst 3750 Metro スイッチは VMPS として使用することはできません。Catalyst 3750 Metro スイッチは、VMPS クライアントです。

同じスイッチ上にダイナミック アクセス ポートとトランク ポートを設定できますが、ダイナミック アクセス ポートはエンド ステーションまたはハブに接続する必要があります。別のスイッチに接続することはできません。

設定の詳細については、「VMPS クライアントのダイナミック アクセス ポートの設定」を参照してください。

VTP は必須です。

VMPS とクライアントは、同じ VTP ドメイン名で設定してください。

VTP に加入するには、あるスイッチのトランク ポートに接続した別のスイッチ上に最低 1 つのトランク ポートがなければなりません。

プライベート VLAN

プライベート VLAN は、プライベート VLAN のプライマリまたはセカンダリ VLAN に属する、ホストまたは混合ポートです。この機能を使用するには、Enhanced Multilayer Image(EMI; 拡張マルチレイヤ ソフトウェア イメージ)がスイッチ上で稼働している必要があります。

プライベート VLAN の詳細については、 第 14 章「プライベート VLAN の設定」 を参照してください。

プライベート VLAN を設定する場合、スイッチは VTP トランスペアレント モードでなければなりません。プライベート VLAN がスイッチで設定されている場合、VTP モードをトランスペアレントからクライアントまたはサーバ モードに変更しないでください。

音声 VLAN

音声 VLAN ポートは、Cisco IP Phone に接続されたアクセス ポートです。Cisco IP Phone は、音声トラフィック用に 1 つの VLAN を使用し、電話に接続されたデバイスからのデータ トラフィック用には別の VLAN を使用するように設定されています。音声 VLAN ポートの詳細については、 第 15 章「音声 VLAN の設定」 を参照してください。

VTP は必須ではなく、音声 VLAN には影響しません。

トンネル( dot1q-tunnel

トンネル ポートは、サービス プロバイダー ネットワーク上でカスタマー VLAN の完全性を保つための IEEE 802.1Q トンネリングに使用されます。トンネル ポートは、サービス プロバイダー ネットワークのエッジ スイッチ上に設定し、カスタマー インターフェイスの IEEE 802.1Q トランク ポートに接続して、非対称リンクを作成します。トンネル ポートは、トンネリング専用の 1 つの VLAN にのみ所属します。

トンネル ポートの詳細については、 第 16 章「IEEE 802.1Q およびレイヤ 2 プロトコル トンネリングの設定」 を参照してください。

VTP は必須ではありません。トンネル ポートを手動で VLAN に割り当てるには、 switchport access vlan インターフェイス コンフィギュレーション コマンドを使用します。

モードおよびその機能の詳細については、 表12-4 を参照してください。

VLAN にポートを割り当てると、スイッチは VLAN 単位で、ポートに対応するアドレスを学習して管理します。詳細については、「MAC アドレス テーブルの管理」を参照してください。

標準範囲 VLAN の設定

標準範囲 VLAN とは、VLAN ID が 1 ~ 1005 の VLAN のことです。スイッチが VTP サーバまたはトランスペアレント モードにある場合は、VLAN データベース内の VLAN 2 ~ 1001 について設定を追加、変更、または削除できます(VLAN ID の 1 と 1002 ~ 1005 は、自動作成され、削除できません)。


) スイッチが VTP トランスペアレント モードにある場合は、拡張範囲 VLAN(ID が 1006 ~ 4094 の VLAN)を作成することもできますが、この VLAN は VLAN データベースには保存されません。「拡張範囲 VLAN の設定」を参照してください。


VLAN ID が 1 ~ 1005 の設定はファイル vlan.dat (VLAN データベース)に保存され、 show vlan イネーブル EXEC コマンドを入力すると表示できます。 vlan.dat ファイルは、NVRAM(不揮発性 RAM)に保存されます。


注意 vlan.dat ファイルを手動で削除しようとすると、VLAN データベースに不整合が生じる可能性があります。VLAN 設定を変更する場合は、ここに記載されているコマンド、およびこのリリースのコマンド リファレンスを使用してください。VTP 設定を変更する場合は、第 13 章「VTP の設定」を参照してください。

さらに、インターフェイス コンフィギュレーション モードを使用して、ポートのメンバーシップ モードの定義、VLAN に対するポートの追加および削除を行います。このモードのコマンド実行結果は実行コンフィギュレーション ファイルに書き込まれ、 show running-config イネーブル EXEC コマンドを入力することによって表示できます。

VLAN データベースに新しい標準範囲 VLAN を作成する場合、または VLAN データベース内の既存の VLAN を変更する場合、次のパラメータを設定できます。

VLAN ID

VLAN 名

VLAN タイプ(イーサネット、Fiber Distributed Data Interface [FDDI]、FDDI Network Entity Title [NET]、TrBRF[トークンリング ブリッジ リレー機能]または TrCRF[トークンリング コンセントレータ リレー機能]、トークン リング、トークン リングネット)

VLAN ステート(アクティブまたはサスペンド)

VLAN の Maximum Transmission Unit(MTU; 最大伝送ユニット)

Security Association Identifier(SAID)

TrBRF VLAN のブリッジ識別番号

FDDI および TrCRF VLAN のリング番号

TrCRF VLAN の親 VLAN 番号

TrCRF VLAN の Spanning-Tree Protocol(STP; スパニングツリープロトコル)タイプ

ある VLAN タイプから別の VLAN タイプに変換するときに使用する VLAN 番号


) ここでは、これらのパラメータのほとんどについて設定の詳細は説明しません。VLAN 設定を制御するコマンドおよびパラメータの詳細については、このリリースのコマンド リファレンスを参照してください。


ここでは標準範囲 VLAN について説明します。内容は次のとおりです。

「トークン リング VLAN」

「標準範囲 VLAN の設定時の注意事項」

「VLAN 設定モードのオプション」

「VLAN 設定の保存」

「イーサネット VLAN のデフォルト設定」

「イーサネット VLAN の作成または変更」

「VLAN の削除」

「VLAN へのスタティック アクセス ポートの割り当て」

トークン リング VLAN

スイッチはトークンリング接続をサポートしていませんが、トークンリング接続を行っている Catalyst 5000 シリーズ スイッチなどのリモート デバイスを、サポート対象スイッチのうちの 1 台から管理できます。VTP バージョン 2 が稼働するスイッチは、次のトークン リング VLAN に関する情報をアドバタイズします。

トークン リング TrBRF VLAN

トークン リング TrCRF VLAN

トークン リング VLAN の設定の詳細については、『 Catalyst 5000 Series Software Configuration Guide 』を参照してください。

標準範囲 VLAN の設定時の注意事項

ネットワーク内で標準範囲 VLAN を作成または変更する場合には、次の注意事項に従ってください。

スイッチは、VTP クライアント、サーバ、およびトランスペアレント モードの 1 ~ 1005 の VLAN をサポートします。

標準範囲 VLAN は、1 ~ 1001 の番号で識別されます。VLAN 番号の 1002 ~ 1005 は、トークン リングおよび FDDI VLAN 用です。

1 ~ 1005 の VLAN 設定は、常に VLAN データベースに保存されます。VTP モードがトランスペアレントの場合、VTP と VLAN の設定もスイッチの実行コンフィギュレーション ファイルに保存されます。

スイッチは、VTP トランスペアレント モード(VTP がディセーブル)の VLAN ID 1006 ~ 4094 もサポートします。これらは拡張範囲 VLAN で、設定オプションに制限があります。拡張範囲 VLAN は、VLAN データベースに追加されません。「拡張範囲 VLAN の設定」を参照してください。

VLAN を作成する前に、スイッチを VTP サーバ モードまたは VTP トランスペアレント モードにしておく必要があります。スイッチが VTP サーバの場合は、VTP ドメインを定義する必要があります。そうしないと VTP が機能しません。

スイッチは、トークンリングまたは FDDI メディアをサポートしません。このスイッチは FDDI、FDDI-Net、TrCRF、または TrBRF トラフィックを伝送しませんが、VTP を介して VLAN 設定を伝播させます。

128 のスパニングツリー インスタンスが、このスイッチによってサポートされます。サポートされるスパニングツリー インスタンスを超える数のアクティブ VLAN がスイッチに設定されている場合は、128 の VLAN でスパニングツリーをイネーブルに設定できますが、残りの VLAN ではディセーブルに設定します。スイッチ上で使用できるすべてのスパニングツリー インスタンスを使用している場合、VTP ドメインに VLAN をさらに 1 つ追加すると、そのスイッチにスパニングツリーを実行しない VLAN が作成されます。(すべての VLAN を許可するための)スイッチのトランク ポートにデフォルトの許可リストが設定されていると、すべてのトランク ポートに新しい VLAN が割り当てられます。ネットワークのトポロジーに応じて、新しい VLAN 内に阻止されないループが作成されることがあります。特に、複数の隣接スイッチでスパニングツリー インスタンスをすべて使用してしまっている場合は、注意してください。このような事態を防ぐには、スパニングツリー インスタンスの割り当てを使い切っているスイッチのトランク ポートに、許可リストを設定します。

スイッチ上の VLAN 数がサポートされるスパニング ツリー インスタンス数を超える場合は、IEEE 802.1s Multiple STP(MSTP)をスイッチに設定して、複数の VLAN を単一の STP インスタンスにマッピングすることを推奨します。MSTP の詳細については、 第 18 章「MSTP の設定」 を参照してください。

VLAN 設定モードのオプション

標準範囲 VLAN(VLAN ID が 1 ~ 1005)は、次の 2 つの設定モードを使用して設定できます。

「config-vlan モードでの VLAN 設定」

config-vlan モードは、 vlan vlan-id グローバル コンフィギュレーション コマンドを入力するとアクセスできます。

「VLAN データベース コンフィギュレーション モードでの VLAN 設定」

VLAN データベース コンフィギュレーション モードは、 vlan database イネーブル EXEC コマンドを入力するとアクセスできます。

config-vlan モードでの VLAN 設定

config-vlan モードにアクセスするには、VLAN ID を指定して vlan グローバル コンフィギュレーション コマンドを入力します。VLAN を新規に作成するには、新しい VLAN ID を入力します。既存の VLAN を変更するには、その VLAN ID を入力します。デフォルトの VLAN 設定( 表12-2 を参照)を使用するか、複数のコマンドを入力して VLAN を設定します。このモードで使用できるコマンドの詳細については、このリリースのコマンド リファレンスに記載されている vlan グローバル コンフィギュレーション コマンドを参照してください。設定が終了したら、設定が有効になるように config-vlan モードを終了する必要があります。VLAN 設定を表示するには、 show vlan イネーブル EXEC コマンドを入力します。

拡張範囲 VLAN(1005 を超える VLAN ID)の作成時は、この config-vlan モードを使用する必要があります。「拡張範囲 VLAN の設定」を参照してください。

VLAN データベース コンフィギュレーション モードでの VLAN 設定

VLAN データベース コンフィギュレーション モードにアクセスするには、 vlan database イネーブル EXEC コマンドを入力します。VLAN を新規に作成するには、新しい VLAN ID を指定して vlan コマンドを入力します。既存の VLAN を変更するには、その VLAN ID を入力します。デフォルトの VLAN 設定( 表12-2 を参照)を使用するか、複数のコマンドを入力して VLAN を設定します。このモードで使用できるキーワードの詳細については、このリリースのコマンド リファレンスに記載されている vlan VLAN データベース コンフィギュレーション コマンドを参照してください。設定が終了したら、設定が有効になるように apply または exit を入力する必要があります。 exit コマンドを入力すると、すべてのコマンドが適用され、VLAN データベースが更新されます。VTP ドメイン内の他のスイッチに VTP メッセージが送信され、イネーブル EXEC モード プロンプトが表示されます。

VLAN 設定の保存

ID が 1 ~ 1005 の VLAN の設定は、常に VLAN データベース(vlan.dat ファイル)に保存されます。VTP モードがトランスペアレントな場合は、スイッチの実行コンフィギュレーション ファイルへの保存も行われるため、 copy running-config startup-config イネーブル EXEC コマンドを入力して設定をスタートアップ コンフィギュレーション ファイルに保存できます。 show running-config イネーブル EXEC コマンドを使用して、スイッチの実行コンフィギュレーションを表示できます。VLAN 設定を表示するには、 show vlan イネーブル EXEC コマンドを入力します。

スタートアップ コンフィギュレーション ファイルに VLAN および VTP 情報(拡張範囲 VLAN 設定も含む)を保存してスイッチを再起動すると、スイッチの設定が次のように決定されます。

スタートアップ コンフィギュレーションで、VTP モードがトランスペアレントであり、VLAN データベースと VLAN データベースからの VTP ドメイン名がスタートアップ コンフィギュレーション ファイルのものと一致する場合は、VLAN データベースは無視(消去)され、スタートアップ コンフィギュレーション ファイルの VTP および VLAN 設定が使用されます。VLAN データベースでは、VLAN データベースのリビジョン番号は元のままです。

スタートアップ コンフィギュレーションの VTP モードまたはドメイン名が VLAN データベースと一致しない場合は、ドメイン名、VTP モード、最初の 1005 の VLAN の設定は、VLAN データベースの情報を使用します。

VTP モードがサーバである場合は、ドメイン名と最初の 1005 の VLAN の設定は、VLAN データベースの情報を使用します。


注意 スタートアップ時に VLAN データベースの設定が使用され、スタートアップ コンフィギュレーション ファイルに拡張範囲 VLAN 設定が含まれている場合は、システムの起動時にこの情報は失われます。

イーサネット VLAN のデフォルト設定

表12-2 に、イーサネット VLAN のデフォルト設定を示します。


) スイッチは、イーサネット インターフェイスのみをサポートします。FDDI およびトークン リング VLAN は、ローカルではサポートされないので、FDDI およびトークン リングのメディア固有の特性は、他のスイッチに対する VTP グローバル アドバタイズにのみ設定します。


 

表12-2 イーサネット VLAN のデフォルト値および範囲

パラメータ
デフォルト値
範囲

VLAN ID

1

1 ~ 4094


) 拡張範囲 VLAN(VLAN ID が 1006 ~ 4094)は VLAN データベースに保存されません。


VLAN 名

VLANxxxx 、ここで xxxx は VLAN ID である 4 桁の数字(先頭の 0 を含む)

範囲なし

802.10 SAID

100001(100000 + VLAN ID)

1 ~ 4294967294

MTU サイズ

1500

1500 ~ 18190

トランスレーショナル ブリッジ 1

0

0 ~ 1005

トランスレーショナル ブリッジ 2

0

0 ~ 1005

VLAN ステート

active

アクティブ、サスペンド

Remote SPAN

ディセーブル

イネーブル、ディセーブル

プライベート VLAN

設定なし

2 ~ 1001、1006 ~ 4094

イーサネット VLAN の作成または変更

VLAN データベースの各イーサネット VLAN は一意の 4 桁(1 ~ 1001)の ID を持ちます。VLAN ID の 1002 ~ 1005 はトークン リングおよび FDDI VLAN 用です。VLAN データベースに VLAN 標準範囲 VLAN を追加するには、VLAN に番号と名前を割り当てます。


) スイッチが VTP トランスペアレント モードにある場合は、1006 を超える VLAN ID を割り当てることができますが、VLAN データベースには追加されません。「拡張範囲 VLAN の設定」を参照してください。


VLAN の追加時に指定されるデフォルト パラメータの一覧は、「標準範囲 VLAN の設定」を参照してください。

config-vlan モードを使用してイーサネット VLAN を作成または変更するには、イネーブル EXEC モードで次の手順を実行します。

 

コマンド
説明

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

vlan vlan-id

VLAN ID を入力し、config-vlan モードを開始します。VLAN を新規に作成するには新しい VLAN ID を、既存の VLAN を変更するには、その VLAN ID を入力します。


) このコマンドに指定可能な VLAN ID 範囲は、1 ~ 4094 です。1005 を超える VLAN ID(拡張範囲 VLAN)の詳細については、「拡張範囲 VLAN の設定」を参照してください。


ステップ 3

name vlan-name

(任意)VLAN の名前を入力します。VLAN 名を指定しない場合には、デフォルトとして、VLAN という文字列の後ろに先頭の 0 付きで vlan-id が付加されます。たとえば、VLAN 4 のデフォルトの VLAN 名は VLAN0004 です。

ステップ 4

mtu mtu-size

(任意)MTU サイズ(またはその他の VLAN 特性)を変更します。

ステップ 5

remote-span

(任意)VLAN をリモート SPAN セッションの RSPAN VLAN として設定します。リモート SPAN の詳細については、 第 27 章「SPAN および RSPAN の設定」 を参照してください。

ステップ 6

end

イネーブル EXEC モードに戻ります。

ステップ 7

show vlan { name vlan-name | id vlan-id }

設定を確認します。

ステップ 8

copy running-config startup config

(任意)スイッチが VTP トランスペアレント モードにある場合は、VLAN 設定は、VLAN データベースだけでなく実行コンフィギュレーション ファイルにも保存されます。これは、スイッチのスタートアップ コンフィギュレーション ファイルに設定を保存します。

VLAN 名をデフォルト設定に戻すには、 no name no mtu 、または no remote-span config-vlan コマンドを使用します。

次に、config-vlan モードを使用してイーサネット VLAN 20 を作成し、 test20 と名前を付け、VLAN データベースに追加する例を示します。

Switch# configure terminal
Switch(config)# vlan 20
Switch(config-vlan)# name test20
Switch(config-vlan)# end
 

VLAN データベース コンフィギュレーション モードを使用すると、イーサネット VLAN を作成または変更することもできます。


) VLAN データベース コンフィギュレーション モードは、RSPAN VLAN 設定または拡張範囲 VLAN をサポートしていません。


VLAN データベース コンフィギュレーション モードを使用してイーサネット VLAN を作成または変更するには、イネーブル EXEC モードで次の手順を実行します。

 

コマンド
説明

ステップ 1

vlan database

VLAN データベース コンフィギュレーション モードを開始します。

ステップ 2

vlan vlan-id name vlan-name

番号を割り当てることによって、イーサネット VLAN を追加します。指定可能な範囲は、1 ~ 1001 です。 vlan first-vlan-id end last-vlan-id を指定すると、連続する VLAN の範囲を作成または変更できます。


) VLAN データベース コンフィギュレーション モードで VLAN ID を入力する場合は、先頭の 0 は入力しないでください。


VLAN 名を指定しない場合には、デフォルトとして、VLAN という文字列の後ろに先頭の 0 付きで vlan-id が付加されます。たとえば、VLAN 4 のデフォルトの VLAN 名は VLAN0004 です。

ステップ 3

vlan vlan-id mtu mtu-size

(任意)VLAN を変更するには、VLAN を特定して MTU サイズなどの特性を変更します。

ステップ 4

exit

VLAN データベースをアップデートし、アップデート情報を管理ドメイン全体に伝播させて、イネーブル EXEC モードに戻ります。

ステップ 5

show vlan { name vlan-name | id vlan-id }

設定を確認します。

ステップ 6

copy running-config startup config

(任意)スイッチが VTP トランスペアレント モードにある場合は、VLAN 設定は、VLAN データベースだけでなく実行コンフィギュレーション ファイルにも保存されます。これは、スイッチのスタートアップ コンフィギュレーション ファイルに設定を保存します。

VLAN 名をデフォルト設定に戻すには、 no vlan vlan-id name または no vlan vlan-id mtu VLAN データベース コンフィギュレーション コマンドを使用します。

次の例は、VLAN 設定モードを使用してイーサネット VLAN 20 を作成し、 test20 と名前を付け、VLAN データベースに追加する方法を示しています。

Switch# vlan database
Switch(vlan)# vlan 20 name test20
Switch(vlan)# exit
APPLY completed.
Exiting....

VLAN の削除

VTP サーバ モードのスイッチから VLAN を削除すると、VTP ドメイン内にあるすべてのスイッチの VLAN データベースからその VLAN が削除されます。VTP トランスペアレント モードのスイッチから VLAN を削除した場合、そのスイッチ上に限り VLAN が削除されます。

メディア タイプが異なるデフォルトの VLAN を削除することはできません。たとえば、イーサネット VLAN 1、および FDDI またはトークン リング VLAN の 1002 ~ 1005 を削除することはできません。


注意 VLAN を削除すると、その VLAN に割り当てられていたすべてのポートが非アクティブになります。これらのポートは、新しい VLAN に割り当てられるまで、元の VLAN に(非アクティブな状態で)対応付けられたままとなります。

スイッチ上で VLAN を削除するには、イネーブル EXEC モードでグローバル コンフィギュレーション モードを使用して次の手順を実行します。

 

コマンド
説明

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

no vlan vlan-id

VLAN ID を入力して VLAN を削除します。

ステップ 3

end

イネーブル EXEC モードに戻ります。

ステップ 4

show vlan brief

VLAN が削除されたことを確認します。

ステップ 5

copy running-config startup config

(任意)スイッチが VTP トランスペアレント モードにある場合は、VLAN 設定は、VLAN データベースだけでなく実行コンフィギュレーション ファイルにも保存されます。これは、スイッチのスタートアップ コンフィギュレーション ファイルに設定を保存します。

VLAN データベース コンフィギュレーション モードを使用して VLAN を削除するには、VLAN データベース コンフィギュレーション モードを開始する vlan database イネーブル EXEC コマンドと、 no vlan vlan-id VLAN データベース コンフィギュレーション コマンドを使用します。

VLAN へのスタティック アクセス ポートの割り当て

VTP をディセーブルにして(VTP トランスペアレント モード)、VTP によって VLAN 設定情報をグローバルに伝播させずに、スタティック アクセス ポートを VLAN に割り当てることができます。

VLAN にクラスタ メンバー スイッチのポートを割り当てる場合は、最初に rcommand イネーブル EXEC コマンドを使用して、クラスタ メンバー スイッチにログインします。


) 存在しない VLAN にインターフェイスを割り当てると、新しく VLAN が作成されます(イーサネット VLAN の作成または変更を参照)。


VLAN データベース内の VLAN にポートを割り当てるには、イネーブル EXEC モードで次の手順を実行します。

 

コマンド
説明

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface-id

VLAN に追加されるインターフェイスを入力します。

ステップ 3

switchport mode access

ポート(レイヤ 2 アクセス ポート)の VLAN メンバーシップ モードを定義します。

ステップ 4

switchport access vlan vlan-id

VLAN にポートを割り当てます。有効な VLAN ID は 1 ~ 4094 です。

ステップ 5

end

イネーブル EXEC モードに戻ります。

ステップ 6

show running-config interface interface-id

インターフェイスの VLAN メンバーシップ モードを確認します。

ステップ 7

show interfaces interface-id switchport

表示された Administrative Mode および Access Mode VLAN フィールドの設定を確認します。

ステップ 8

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

インターフェイスの設定をデフォルトに戻すには、 default interfac e interface-id インターフェイス コンフィギュレーション コマンドを使用します。

次に、ポートを VLAN 2 のアクセス ポートとして設定する例を示します。

Switch# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)# interface gigabitethernet1/0/1
Switch(config-if)# switchport mode access
Switch(config-if)# switchport access vlan 2
Switch(config-if)# end

拡張範囲 VLAN の設定

スイッチが VTP トランスペアレント モード(VTP がディセーブル)にある場合は、拡張範囲 VLAN(1006 ~ 4094 の範囲)を作成できます。拡張範囲 VLAN により、サービス プロバイダーはインフラストラクチャをさらに多数のカスタマーに拡張できます。拡張範囲 VLAN ID は、VLAN ID を許可するどのスイッチポート コマンドでも許可されます。拡張範囲 VLAN は、常に config-vlan モード( vlan vlan-id グローバル コンフィギュレーション コマンドを入力してアクセス)を使用して設定します。拡張範囲は、VLAN データベース コンフィギュレーション モード( vlan database イネーブル EXEC コマンドを入力してアクセス)ではサポートされていません。

拡張範囲 VLAN の設定は、VLAN データベースには保存されませんが、VTP モードがトランスペアレントなので、スイッチの実行コンフィギュレーション ファイルに保存されます。また、 copy running-config startup-config イネーブル EXEC コマンドを使用するとスタートアップ コンフィギュレーション ファイルに設定を保存できます。


) スイッチは 4094 の VLAN ID をサポートしますが、サポートされる VLAN の実数については「サポートされる VLAN」を参照してください。


ここでは拡張範囲 VLAN について説明します。内容は次のとおりです。

「VLAN のデフォルト設定」

「拡張範囲 VLAN の設定時の注意事項」

「拡張範囲 VLAN の作成」

「内部 VLAN ID を指定した拡張範囲 VLAN の作成」

VLAN のデフォルト設定

イーサネット VLAN のデフォルト設定については、 表12-2 を参照してください。拡張範囲 VLAN については MTU サイズと RSPAN 設定ステートしか変更できません。残りの特性はデフォルト状態のままでなければなりません。

拡張範囲 VLAN の設定時の注意事項

拡張範囲 VLAN 作成時は、次の注意事項に従ってください。

拡張範囲 VLAN を追加するには、 vlan vlan-id グローバル コンフィギュレーション コマンドを使用して config-vlan モードにアクセスする必要があります。拡張範囲 VLAN は、VLAN データベース コンフィギュレーション モード( vlan database イネーブル EXEC コマンドを入力してアクセス)では追加できません。

拡張範囲の VLAN ID は VLAN データベースに保存されず、VTP によって認識されません。

プルーニング適格範囲に拡張範囲 VLAN を入れることはできません。

拡張範囲 VLAN の作成時は、スイッチは VTP トランスペアレント モードでなければなりません。VTP モードがサーバまたはクライアントの場合は、エラー メッセージが生成され、拡張範囲 VLAN は拒否されます。

グローバル コンフィギュレーション モードまたは VLAN データベース コンフィギュレーション モードで、VTP モードをトランスペアレントに設定できます。「VTP のディセーブル化(VTP トランスペアレント モード)」を参照してください。この設定をスタートアップ コンフィギュレーションに保存して、スイッチが VTP トランスペアレント モードで起動するようにする必要があります。そうしないとスイッチをリセットした場合に、拡張範囲 VLAN の設定が失われます。

拡張範囲 VLAN では、STP はデフォルトでイネーブルに設定されていますが、no spanning-tree vlan vlan-id グローバル コンフィギュレーション コマンドを使用するとディセーブルにできます。スイッチ上にスパニングツリー インスタンスの最大数(128)がある場合、新たに作成されたどの VLAN でもスパニングツリーはディセーブルになっています。スイッチ上の VLAN 数がサポートされるスパニング ツリー インスタンスの最大数を超える場合は、IEEE 802.1s MSTP をスイッチに設定して、複数の VLAN を単一の STP インスタンスにマッピングすることを推奨します。MSTP の詳細については、 第 18 章「MSTP の設定」 を参照してください。

スイッチ上の各ルーテッド ポートは、内部 VLAN を作成して使用します。この内部 VLAN は拡張範囲 VLAN 番号を使用し、その内部 VLAN ID は拡張範囲 VLAN には使用できません。内部 VLAN として割り当て済みの VLAN ID を指定して拡張範囲 VLAN を作成すると、エラー メッセージが生成され、コマンドは拒否されます。

内部 VLAN ID は拡張範囲の下部の方なので、拡張範囲 VLAN を作成するには最大の番号(4094)から始めて最小値(1006)へと動いて、内部 VLAN ID を使用する可能性を減らすことを推奨します。

拡張範囲 VLAN を設定する前に、 show vlan internal usage イネーブル EXEC コマンドを入力して、どの VLAN が内部 VLAN として割り当てられているかを確認します。

必要に応じて内部 VLAN に割り当てられたルーテッド ポートをシャットダウンできます。これにより、内部 VLAN が解放され、拡張範囲 VLAN を作成してポートを再度イネーブルにし、別の VLAN を内部 VLAN として使用します。「内部 VLAN ID を指定した拡張範囲 VLAN の作成」を参照してください。

スイッチは合計 1005(標準範囲および拡張範囲)の VLAN をサポートしますが、ルーテッド ポート、SVI、その他の設定済み機能の個数によって、スイッチのハードウェアの使用は左右されます。拡張範囲の VLAN を作成しようとしたときに、使用可能なハードウェア リソースが不十分な場合は、エラー メッセージが生成され、拡張範囲の VLAN は拒否されます。

拡張範囲 VLAN の作成

拡張範囲 VLAN は、グローバル コンフィギュレーション モードで、1006 ~ 4094 の VLAN ID を指定して vlan グローバル コンフィギュレーション コマンドを入力して作成します。このコマンドで config-vlan モードにアクセスします。拡張範囲 VLAN はイーサネット VLAN のデフォルトの特性を備えており( 表12-2 を参照)、変更できるパラメータは MTU サイズと RSPAN 設定のみです。全パラメータのデフォルト設定については、コマンド リファレンスに記載されている vlan グローバル コンフィギュレーション コマンドを参照してください。スイッチが VTP トランスペアレント モードにない場合に拡張範囲 VLAN ID を入力すると、config-vlan モードの終了時にエラー メッセージが生成され、拡張範囲 VLAN は作成されません。

拡張範囲 VLAN は VLAN データベースに保存されません。スイッチの実行コンフィギュレーション ファイルに保存されます。 copy running-config startup-config イネーブル EXEC コマンドを使用すると、スイッチのスタートアップ コンフィギュレーション ファイルに拡張範囲 VLAN の設定を保存できます。


) 拡張範囲 VLAN を作成する前に、show vlan internal usage イネーブル EXEC コマンドを入力して、VLAN ID が内部的に使用されていないことを確認します。VLAN ID が内部的に使用されている場合に、それを解放するには、「内部 VLAN ID を指定した拡張範囲 VLAN の作成」を参照してから拡張範囲 VLAN を作成してください。


拡張範囲 VLAN を作成するには、イネーブル EXEC モードで次の手順を実行します。

 

コマンド
説明

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

vtp mode transparent

スイッチを VTP トランスペアレント モードに設定し、VTP をディセーブルにします。

ステップ 3

vlan vlan-id

拡張範囲 VLAN ID を入力し、config-vlan モードを開始します。指定できる範囲は 1006 ~ 4094 です。

ステップ 4

mtu mtu-size

(任意)MTU サイズを変更して VLAN を変更します。


) config-vlan モードでは CLI(コマンドライン インターフェイス)ヘルプにすべての VLAN コマンドが表示されますが、拡張範囲 VLAN にサポートされているのは、mtu mtu-size コマンドと remote-span コマンドだけです。


ステップ 5

remote-span

(任意)VLAN を RSPAN VLAN として設定します。「RSPAN VLAN としての VLAN の設定」を参照してください。

ステップ 6

end

イネーブル EXEC モードに戻ります。

ステップ 7

show vlan id vlan-id

VLAN が作成されていることを確認します。

ステップ 8

copy running-config startup config

スイッチのスタートアップ コンフィギュレーション ファイルに設定を保存します。拡張範囲 VLAN 設定を保存するには、スイッチのスタートアップ コンフィギュレーション ファイルに VTP トランスペアレント モード設定と拡張範囲 VLAN 設定を保存する必要があります。そうしないと、スイッチをリセットした場合にデフォルトで VTP サーバ モードになり、拡張範囲 VLAN ID は保存されません。

拡張範囲 VLAN を削除するには、 no vlan vlan-id グローバル コンフィギュレーション コマンドを使用します。

拡張範囲 VLAN にスタティック アクセス ポートを割り当てる手順は、標準範囲 VLAN に対するものと同じです。「VLAN へのスタティック アクセス ポートの割り当て」を参照してください。

次に、すべてのデフォルト特性を備えた新しい拡張範囲 VLAN を作成し、config-vlan モードを開始し、スイッチのスタートアップ コンフィギュレーション ファイルに新しい VLAN を保存する例を示します。

Switch(config)# vtp mode transparent
Switch(config)# vlan 2000
Switch(config-vlan)# end
Switch# copy running-config startup config
 

内部 VLAN ID を指定した拡張範囲 VLAN の作成

内部 VLAN に割り当て済みの拡張範囲 VLAN ID を入力すると、エラー メッセージが生成され、拡張範囲 VLAN は拒否されます。内部 VLAN ID を手動で解放するには、内部 VLAN ID を使用しているルーテッド ポートを一時的にシャットダウンする必要があります。

内部 VLAN に割り当てられた VLAN ID を解放してその ID で拡張範囲 VLAN を作成するには、イネーブル EXEC モードで次の手順を実行します。

 

コマンド
説明

ステップ 1

show vlan internal usage

スイッチが内部的に使用している VLAN ID を表示します。使用する VLAN ID が内部 VLAN である場合は、その VLAN ID を使用しているルーテッド ポートが表示されます。そのポート番号をステップ 3 で入力してください。

ステップ 2

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface interface-id

その VLAN ID を使用しているルーテッド ポートのインターフェイス ID を入力します。

ステップ 4

shutdown

ポートをシャットダウンして内部 VLAN ID を解放します。

ステップ 5

exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 6

vtp mode transparent

VTP モードをトランスペアレントに設定して拡張範囲 VLAN を作成します。

ステップ 7

vlan vlan-id

新しい拡張範囲 VLAN ID を入力し、config-vlan モードを開始します。

ステップ 8

exit

config-vlan モードを終了してグローバル コンフィギュレーション モードに戻ります。

ステップ 9

interface interface-id

ステップ 4 でシャットダウンしたルーテッド ポートのインターフェイス ID を入力します。

ステップ 10

no shutdown

ルーテッド ポートを再度イネーブルにします。新しい内部 VLAN ID が割り当てられます。

ステップ 11

end

イネーブル EXEC モードに戻ります。

ステップ 12

copy running-config startup config

スイッチのスタートアップ コンフィギュレーション ファイルに設定を保存します。拡張範囲 VLAN 設定を保存するには、スイッチのスタートアップ コンフィギュレーション ファイルに VTP トランスペアレント モード設定と拡張範囲 VLAN 設定を保存する必要があります。そうしないと、スイッチをリセットした場合にデフォルトで VTP サーバ モードになり、拡張範囲 VLAN ID は保存されません。

VLAN の表示

拡張範囲 VLAN を含めてスイッチ上のすべての VLAN のリストを表示するには、 show vlan イネーブル EXEC コマンドを使用します。表示には、VLAN のステータス、ポート、およびコンフィギュレーション情報が含まれます。VLAN データベースの標準範囲 VLAN(1 ~ 1005)を表示するには、 show VLAN データベース コンフィギュレーション コマンド( vlan database イネーブル EXEC コマンドを入力してアクセス)を使用します。スイッチ上の VLAN ID のリストを表示するには、 show vlan イネーブル EXEC コマンドを使用します。

表12-3 に、VLAN モニタ用のコマンドを示します。

 

表12-3 VLAN モニタ コマンド

コマンド
コマンド モード
説明

show

VLAN データベース コンフィギュレーション

VLAN データベース内の VLAN のステータスを表示します。

show current [ vlan-id ]

VLAN データベース コンフィギュレーション

VLAN データベース内のすべての、または指定された VLAN のステータスを表示します。

show interfaces [ vlan vlan-id ]

イネーブル EXEC

スイッチに設定されたすべてのインターフェイス、または指定されたインターフェイスの特性を表示します。

show vlan [ id vlan-id ]

イネーブル EXEC

スイッチのすべての、または指定された VLAN のパラメータを表示します。

show コマンドのオプションと出力フィールドの詳細については、このリリースのコマンド リファレンスを参照してください。

VLAN トランクの設定

ここでは、スイッチ上の VLAN トランクの機能について説明します。

「トランキングの概要」

「カプセル化タイプ」

「レイヤ 2 イーサネット インターフェイス VLAN のデフォルト設定」

「トランク ポートとしてのイーサネット インターフェイスの設定」

「トランク ポートのロード シェアリングの設定」

トランキングの概要

トランクは、1 つまたは複数のイーサネット スイッチ インターフェイスと、ルータやスイッチといった他のネットワーキング デバイス間のポイントツーポイント リンクです。イーサネット トランクは 1 つのリンクを介して複数の VLAN トラフィックを搬送するので、VLAN をネットワーク全体に拡張できます。

トランキング カプセル化方式は、802.1Q イーサネット インターフェイスで使用できます。802.1Q は、業界標準のトランキング カプセル化方式です。

トランクを設定できるのは、1 つのイーサネット インターフェイスまたは 1 つの EtherChannel バンドルに対してです。EtherChannel の詳細については、 第 33 章「EtherChannel およびリンクステート トラッキングの設定」 を参照してください。

イーサネット トランク インターフェイスは、数種類のトランキング モードをサポートしています( 表12-4 を参照)。インターフェイスをトランキングまたは非トランキングとして設定することも、あるいは近接インターフェイスとトランキングをネゴシエーションするように設定することもできます。トランキングの自動ネゴシエーションを設定するには、インターフェイスが同じ VTP ドメイン内にある必要があります。

トランク ネゴシエーションは、PPP(ポイントツーポイント プロトコル)である Dynamic Trunking Protocol(DTP)によって管理されます。ただし、一部のインターネットワーキング デバイスは、不正に DTP フレームを伝送することがあり、これによって誤った設定になることがあります。

これを避けるには、DTP をサポートしないデバイスに接続しているインターフェイスが DTP フレームを転送しないように設定する(DTP をオフにする)必要があります。

これらのリンクをトランキングしない場合は、 switchport mode access インターフェイス コンフィギュレーション コマンドを使用してトランキングをディセーブルにします。

DTP をサポートしないデバイスに対するトランキングをイネーブルにするには、 switchport mode trunk および switchport nonegotiate インターフェイス コンフィギュレーション コマンドを使用します。これにより、インターフェイスがトランクになりますが DTP フレームは生成されません。 switchport trunk encapsulation dot1q インターフェイス コンフィギュレーション コマンドを使用して、トランク ポートのカプセル化タイプを選択できます。


) Cisco IOS Release 12.2(22)EY 以降のリリースでは、ES ポートは 802.1 カプセル化のみをサポートします。ES ポートでカプセル代を設定することはできません。


また、標準 DTP インターフェイスで、トランクでの ISL または 802.1Q カプセル化の使用、あるいはカプセル化タイプの自動ネゴシエーションを指定できます。DTP は、802.1Q トランクの自動ネゴシエーションをサポートします。


) DTP はプライベート VLAN ポートまたはトンネル ポートではサポートされていません。



) トンネル ポートは DTP をサポートしません。トンネル ポートの詳細については、第 16 章「IEEE 802.1Q およびレイヤ 2 プロトコル トンネリングの設定」を参照してください。


 

表12-4 レイヤ 2 インターフェイス モード

モード
説明

switchport mode access

インターフェイス(アクセス ポート)は永続的な非トランキング モードになり、リンクを非トランク リンクに変換するようにネゴシエーションします。インターフェイスは、近接インターフェイスがトランク インターフェイスであるかどうかに関係なく、非トランク インターフェイスになります。

switchport mode dynamic auto

インターフェイスがリンクをトランク リンクに変換できるようにします。近接インターフェイスが trunk または desirable モードに設定されていれば、インターフェイスはトランク インターフェイスになります。すべてのイーサネット インターフェイスのデフォルトのスイッチポート モードは、 dynamic auto です。

switchport mode dynamic desirable

インターフェイスがリンクのトランク リンクへの変換をアクティブに試行するようにします。近接インターフェイスが trunk desirable 、または auto モードに設定されていれば、インターフェイスはトランク インターフェイスになります。

switchport mode trunk

インターフェイスは永続的なトランキング モードになり、近接リンクをトランク リンクに変換するようにネゴシエーションします。近接インターフェイスがトランク インターフェイスでなくても、インターフェイスはトランク インターフェイスになります。

switchport nonegotiate

インターフェイスが DTP フレームを生成しないようにします。このコマンドを使用できるのは、インターフェイスのスイッチポート モードが access または trunk の場合のみです。近接インターフェイスを手動でトランク インターフェイスとして設定して、トランク リンクを確立する必要があります。

switchport mode dot1q-tunnel

802.1Q トランク ポートと非対称リンクで接続するトンネル(非トランキング)ポートとして、インターフェイスを設定します。802.1Q トンネリングは、サービス プロバイダー ネットワーク上でカスタマー VLAN の完全性を保つために使用します。トンネル ポートの詳細については、 第 16 章「IEEE 802.1Q およびレイヤ 2 プロトコル トンネリングの設定」 を参照してください。

カプセル化タイプ

表12-5 に、イーサネット トランクのカプセル化タイプおよびキーワードを示します。


) Cisco IOS Release 12.2(22)EY 以降のリリースでは、ES ポートで ISL トランクはサポートされません。encapsulation キーワードは、ES ポートには認識されなくなっています。


 

表12-5 イーサネット トランクのカプセル化タイプ

カプセル化
説明

switchport trunk encapsulation dot1q

トランク リンクに 802.1Q カプセル化を指定します。

switchport trunk encapsulation dot1q

トランク リンクに ISL カプセル化を指定します。

switchport trunk encapsulation negotiate

インターフェイスが近接インターフェイスとネゴシエーションを行い、近接インターフェイスの設定および機能に応じて、ISL トランク(優先)または 802.1Q トランクになるように指定します。これは、スイッチの標準ポートのデフォルトです。

switchport trunk dot1q ethertype value

802.1Q カプセル化の ethertype 値を設定します。802.1Q タグ付きフレームを識別する、標準外(非デフォルト)の 2 バイトの ethertype を選択する場合に使用します。デフォルトの ethertype 値は 0x8100 です。

このオプションは、Enhanced-Services(ES)ポート上でのみサポートされます。


) スイッチはレイヤ 3 トランクをサポートしません。したがって、サブインターフェイスを設定したり、レイヤ 3 インターフェイスで encapsulation キーワードを使用したりすることはできません。ただし、スイッチは、同等の機能を備えたレイヤ 2 トランクおよびレイヤ 3 VLAN インターフェイスをサポートします。


IEEE 802.1Q の設定に関する注意事項


) Cisco IOS Release 12.2(22)EY 以降のリリースでは、ES ポートは IEEE 802.1Q トランキングのみをサポートします。


802.1Q トランクでは、ネットワークのトランキング方式に次の制約があります。

802.1Q トランクを使用して接続したシスコのスイッチのネットワークでは、スイッチはトランク上で許可された VLAN ごとに 1 つのスパニングツリー インスタンスを維持します。他社製のデバイスは、すべての VLAN に対して 1 つのスパニングツリー インスタンスをサポートする場合があります。

IEEE 802.1Q トランクを使用して他社製のデバイスにシスコのスイッチを接続する場合、シスコのスイッチは、トランクの VLAN のスパニングツリー インスタンスを他社製 802.1Q スイッチのスパニングツリー インスタンスと結合します。ただし、各 VLAN のスパニングツリー情報は、他社製の 802.1Q スイッチからなるクラウドにより分離されたシスコのスイッチによって維持されます。シスコのスイッチを分離する他社製の 802.1Q スイッチ クラウドは、スイッチ間の 1 つのトランク リンクとして取り扱われます。

IEEE 802.1Q トランクに対応するネイティブ VLAN が、トランク リンクの両端で一致していなければなりません。トランクの一方のネイティブ VLAN ともう一方のネイティブ VLAN が異なっていると、スパニングツリー ループが発生する可能性があります。

ネットワーク内のすべての VLAN でスパニングツリーをディセーブルにしないまま、IEEE 802.1Q トランクのネイティブ VLAN でスパニングツリーをディセーブルにすると、スパニングツリー ループが発生する可能性があります。802.1Q トランクのネイティブ VLAN でスパニングツリーをイネーブルのままにしておくか、または、ネットワーク内のすべての VLAN でスパニングツリーをディセーブルにしてください。また、ネットワークにループがないことを確認してから、スパニングツリーをディセーブルにしてください。

ES ポート上では、 switchport trunk dot1q ethertype value インターフェイス コンフィギュレーション コマンドを使用して、インターフェイス用のカスタムの ethertype 値を設定できます。この機能を使用すると、スイッチは 802.1Q タグ付きフレームを識別するために標準の 0x8100 ethertype を使用しないサードパーティ ベンダー製スイッチと相互運用できるようになります。たとえば、トランク ポートでカスタムの IEEE 802.1Q ethertype として 0x1234 を設定すると、この ethertype を含む着信フレームは、標準 802.1Q トランクの場合と同じように、ethertype の後ろのタグに含まれる VLAN に割り当てられます。標準 ethertype(0x8100)またはカスタム ethertype 値を設定したトランク ポートに着信するフレームは、有効な IEEE 802.1Q トラフィックとして取り扱われます。それ以外の ethertype を含むフレームは、そのトランクのネイティブ VLAN に割り当てられます。ethertype 値 0x8100 を持った出力トラフィックは、カスタマー ethertype にマッピングされます。

レイヤ 2 イーサネット インターフェイス VLAN のデフォルト設定

表12-6 に、レイヤ 2 イーサネット インターフェイス VLAN のデフォルト設定を示します。

 

表12-6 レイヤ 2 イーサネット インターフェイス VLAN のデフォルト設定

機能
デフォルト設定

インターフェイス モード

switchport mode dynamic auto

トランク カプセル化

switchport trunk encapsulation negotiate


) Cisco IOS リリース以降のリリースでは、これは標準ポートにのみ適用されます。ES ポートは 802.1Q カプセル化のみをサポートします。


802.1Q カプセル化の ethertype 値

0x8100

許可 VLAN 範囲

VLAN 1 ~ 4094

プルーニング適格の VLAN 範囲

VLAN 2 ~ 1001

デフォルト VLAN(アクセス ポート用)

VLAN 1

ネイティブ VLAN(802.1Q トランク用)

VLAN 1

トランク ポートとしてのイーサネット インターフェイスの設定

トランク ポートは VTP アドバタイズを送受信するので、VTP を使用するためには、スイッチに少なくとも 1 つのトランクポートが設定されており、そのトランク ポートが別のスイッチのトランク ポートに接続されていることを確認する必要があります。そうでない場合、スイッチは VTP アドバタイズを受信できません。

ここでは、スイッチ上でイーサネット インターフェイスをトランク ポートとして設定する手順について説明します。

「他の機能との相互作用」

「トランク上での許可 VLAN の定義」

「プルーニング適格リストの変更」

「タグなしトラフィック用ネイティブ VLAN の設定」


) デフォルトでは、インターフェイスはレイヤ 2 モードです。レイヤ 2 インターフェイスのデフォルト モードは、switchport mode dynamic auto です。近接インターフェイスがトランキングをサポートし、トランキングを許可するように設定されている場合、リンクはレイヤ 2 トランクです。また、インターフェイスがレイヤ 3 モードの場合は、switchport インターフェイス コンフィギュレーション コマンドを入力するとレイヤ 2 トランクになります。デフォルトでは、標準ポート トランク(またはリリース 12.1(14) AX の ES ポート トランク)はカプセル化をネゴシエーションします。近接インターフェイスが ISL および 802.1Q カプセル化の両方をサポートし、両方のインターフェイスがカプセル化タイプをネゴシエーションするように設定されている場合は、トランクは ISL カプセル化を使用します。Cisco IOS Release 12.2(22)EY 以降のリリースでは、ES ポートは 802.1Q カプセル化のみをサポートします。


他の機能との相互作用

トランキングは、次のように他の機能と相互作用します。

トランク ポートをセキュア ポートにすることはできません。

トランク ポートをトンネル ポートにすることはできません。

トランク ポートは EtherChannel ポート グループにまとめることができますが、グループ内のすべてのトランクは同じ設定にしておく必要があります。グループを初めて作成したときは、そのグループに最初に追加されたポートのパラメータ設定値をすべてのポートが引き継ぎます。次に示すパラメータのいずれかの設定を変更すると、スイッチは、入力された設定をグループ内のすべてのポートに伝播します。

許可 VLAN リスト

各 VLAN の STP ポート プライオリティ

STP PortFast の設定値

トランク ステータス:ポート グループ内の 1 つのポートがトランクでなくなった場合、すべてのポートがトランクでなくなります。

設定するトランク ポート数は、PVST モードでは 24 まで、MST モードでは 40 までにすることを推奨します。

トランク ポートで 802.1x をイネーブルにしようとすると、エラー メッセージが表示され、802.1x はイネーブルになりません。802.1x 対応ポートのモードをトランクに変更しようとしても、ポート モードは変更されません。

ダイナミック モードのポートは、近接ポートとネゴシエーションしてトランク ポートになることができます。ダイナミック ポートで 802.1x をイネーブルにしようとすると、エラー メッセージが表示され、802.1x はイネーブルになりません。802.1x 対応ポートのモードをダイナミックに変更しようとしても、ポート モードは変更されません。

トランク ポートの設定

ポートをトランク ポートとして設定するには、イネーブル EXEC モードで次の手順を実行します。

 

コマンド
説明

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface-id

インターフェイス コンフィギュレーション モードを開始し、トランキング用に設定するポートを入力します。

ステップ 3

switchport trunk encapsulation { isl | dot1q | negotiate }

(ES ポートでは認識できなくなりました)

ISL または 802.1Q カプセル化をサポートするように、またはカプセル化タイプについて近接インターフェイスとネゴシエーションする(デフォルト)ようにポートを設定します。

リンクの各終端に同じカプセル化タイプを設定する必要があります。


) Cisco IOS Release 12.2(22)EY 以降のリリースでは、encapsulation キーワードは ES ポートではサポートされません。ES ポートは 802.1Q カプセル化のみをサポートします。


ステップ 4

switchport mode { dynamic { auto | desirable } | trunk }

インターフェイスをレイヤ 2 トランクとして設定します(インターフェイスがレイヤ 2 アクセス ポートまたはトンネル ポートである場合、またはトランキング モードを設定する場合に限り必要となります)。

dynamic auto -- 近接インターフェイスが trunk または desirable モードに設定されている場合に、トランク リンクとしてインターフェイスを設定します。これはデフォルト設定です。

dynamic desirable -- 近接インターフェイスが trunk、desirable、または auto モードに設定されている場合に、トランク リンクとしてインターフェイスを設定します。

trunk -- 近接インターフェイスがトランク インターフェイスではない場合でも、インターフェイスを永続的なトランキング モードに設定し、リンクをトランク リンクに変換するようネゴシエーションします。

ステップ 5

switchport access vlan vlan-id

(任意)デフォルト VLAN を指定します。これは、インターフェイスがトランキングを停止した場合に使用されます。

ステップ 6

switchport trunk native vlan vlan-id

802.1Q トランク用にネイティブ VLAN を指定します。

ステップ 7

end

イネーブル EXEC モードに戻ります。

ステップ 8

show interfaces interface-id switchport

表示された Administrative Mode および Administrative Trunking Encapsulation フィールドにインターフェイスのスイッチポート設定を表示します。

ステップ 9

show interfaces interface-id trunk

インターフェイスのトランク設定を表示します。

ステップ 10

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

インターフェイスの設定をデフォルトに戻すには、 default interface interface-id インターフェイス コンフィギュレーション コマンドを使用します。トランキング インターフェイスのすべてのトランキング特性をデフォルトにリセットするには、 no switchport trunk インターフェイス コンフィギュレーション コマンドを使用します。トランキングをディセーブルにするには、 switchport mode access インターフェイス コンフィギュレーション コマンドを使用してポートをスタティック アクセス ポートとして設定します。

次に、標準ポートを IEEE 802.1Q トランクとして設定する例を示します。ここでは、近接インターフェイスが IEEE 802.1Q トランキングをサポートするよう設定されていると仮定しています。

Switch# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)# interface gigabitethernet1/0/2
Switch(config-if)# switchport mode dynamic desirable
Switch(config-if)# switchport trunk encapsulation dot1q
Switch(config-if)# end

トランク上での許可 VLAN の定義

デフォルトでは、トランク ポートはすべての VLAN に対してトラフィックの送受信を行います。各トランクで、すべての VLAN ID(1 ~ 4094)が許可されます。ただし、許可リストから VLAN を削除することにより、それらの VLAN からのトラフィックがトランク上を流れないようにできます。トランクが伝送するトラフィックを制限するには、 switchport trunk allowed vlan remove vlan-list インターフェイス コンフィギュレーション コマンドを使用して、許可リストから特定の VLAN を削除します。


) VLAN 1 は、すべてのシスコのスイッチ内のすべてのトランクポートのデフォルト VLAN です。以前は、すべてのトランク リンクで VLAN 1 を常にイネーブルにしておく必要がありました。VLAN 1 上でユーザ トラフィック(スパニング ツリー アドバタイズを含む)が送受信されないように、VLAN 1 最小化機能を使用して、任意の個々の VLAN トランク リンクで VLAN 1 をディセーブルにすることができます。


スパニングツリー ループまたはストームのリスクを削減するために、許可リストから VLAN 1 を削除して、いずれかの個々の VLAN トランク ポートの VLAN 1 をディセーブルにすることができます。トランク ポートから VLAN 1 を削除しても、インターフェイスは、たとえば、Cisco Discovery Protocol(CDP)、Port Aggregation Protocol(PAgP)、Link Aggregation Control Protocol(LACP)、DTP、VLAN 1 内の VTP などの管理トラフィックの送受信を続けます。

VLAN 1 がディセーブルなトランク ポートが非トランク ポートに変換された場合は、アクセス VLAN に追加されます。アクセス VLAN が 1 に設定されている場合、 switchport trunk allowed 設定に関係なく、ポートは VLAN 1 に追加されます。ポート上でディセーブルなすべての VLAN について、同じことが当てはまります。

トランクポートは、VLAN がイネーブルになっており、VTP が VLAN を認識し、かつポートの許可リストにその VLAN が登録されている場合に、VLAN のメンバーになることができます。VTP が新しくイネーブルにされた VLAN を認識し、その VLAN がトランク ポートの許可リストに登録されている場合、トランク ポートは自動的にそのイネーブルにされた VLAN のメンバーになります。VTP が新しい VLAN を認識し、その VLAN がトランク ポートの許可リストに登録されていない場合には、トランク ポートはその新しい VLAN のメンバーにはなりません。

ISL トランクまたは 802.1Q トランクの許可リストを変更するには、イネーブル EXEC モードで次の手順を実行します。

 

コマンド
説明

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface-id

設定するポートを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

switchport mode trunk

インターフェイスを VLAN トランク ポートとして設定します。

ステップ 4

switchport trunk allowed vlan { add | all | except | remove } vlan-list

(任意)トランク上で許可される VLAN のリストを設定します。

add all except remove キーワードの使用法については、このリリースのコマンド リファレンスを参照してください。

vlan-list パラメータは、1 ~ 4094 のうち、いずれか 1 つの VLAN 番号か、値の小さい方を先にしてハイフンで区切られた 2 つの VLAN 番号で指定する一定範囲の VLAN です。カンマで区切られた VLAN パラメータやハイフンで指定された範囲の間には、スペースは入れないでください。

デフォルトではすべての VLAN が許可されています。

ステップ 5

end

イネーブル EXEC モードに戻ります。

ステップ 6

show interfaces interface-id switchport

表示された Trunking VLANs Enabled フィールドの設定を確認します。

ステップ 7

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

すべての VLAN の許可 VLAN リストをデフォルトに戻すには、 no switchport trunk allowed vlan インターフェイス コンフィギュレーション コマンドを使用します。

次に、ポートの許可 VLAN リストから VLAN 2 を削除する例を示します。

Switch(config)# interface gigabitethernet1/0/1
Switch(config-if)# switchport trunk allowed vlan remove 2
Switch(config-if)# end
 

プルーニング適格リストの変更

プルーニング適格リストは、トランク ポートのみに適用されます。各トランク ポートには、それぞれ独自の適格リストがあります。次の手順を有効にするためには、VTP プルーニングがイネーブルに設定されている必要があります。VTP プルーニングをイネーブルにする手順については、「VTP プルーニングのイネーブル化」を参照してください。

トランク ポートのプルーニング適格リストから VLAN を削除するには、イネーブル EXEC モードで次の手順を実行します。

 

コマンド
説明

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface-id

インターフェイス コンフィギュレーション モードを開始し、VLAN プルーニングを適用するトランク ポートを選択します。

ステップ 3

switchport trunk pruning vlan { add | except | none | remove } vlan-list [ ,vlan [ ,vlan [ ,,, ]]

トランクからのプルーニングが許可されている VLAN のリストを設定します( VTP プルーニングを参照)。

add except none 、および remove キーワードの使用法については、このリリースのコマンド リファレンスを参照してください。

連続しない VLAN ID は、スペースを入れずにカンマで区切ります。ID の範囲を表すには、ハイフンを使用します。有効な ID は、2 ~ 1001 です。拡張範囲 VLAN(VLAN ID が 1006 ~ 4094)はプルーニングできません。

プルーニング不適格とされた VLAN は、フラッディング トラフィックを受信します。

デフォルトでは、プルーニングが許可される VLAN のリストには、VLAN 2 ~ 1001 が含まれています。

ステップ 4

end

イネーブル EXEC モードに戻ります。

ステップ 5

show interfaces interface-id switchport

表示された Pruning VLANs Enabled フィールドの設定を確認します。

ステップ 6

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

すべての VLAN のプルーニング適格リストをデフォルトに戻すには、 no switchport trunk pruning vlan インターフェイス コンフィギュレーション コマンドを使用します。

タグなしトラフィック用ネイティブ VLAN の設定

802.1Q タギングが設定されたトランク ポートは、タグ付きトラフィックおよびタグなしトラフィックの両方を受信できます。デフォルトでは、スイッチはタグなしトラフィックをポートに設定されたネイティブ VLAN に伝送します。ネイティブ VLAN は、デフォルトでは VLAN 1 です。


) ネイティブ VLAN には任意の VLAN ID を割り当てることができます。


802.1Q 設定の詳細については、「IEEE 802.1Q の設定に関する注意事項」を参照してください。

802.1Q トランクでネイティブ VLAN を設定するには、イネーブル EXEC モードで次の手順を実行します。

 

コマンド
説明

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface-id

インターフェイス コンフィギュレーション モードを開始し、802.1Q トランクとして設定するインターフェイスを定義します。

ステップ 3

switchport trunk native vlan vlan-id

トランク ポート上でタグなしトラフィックを送受信している VLAN を設定します。

vlan-id に指定できる範囲は、1 ~ 4094 です。

ステップ 4

end

イネーブル EXEC モードに戻ります。

ステップ 5

show interfaces interface-id switchport

表示された Trunking Native Mode VLAN フィールドの設定を確認します。

ステップ 6

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

ネイティブ VLAN をデフォルトの VLAN 1 に戻すには、 no switchport trunk native vlan インターフェイス コンフィギュレーション コマンドを使用します。

パケットの VLAN ID が発信ポートのネイティブ VLAN ID と同じであれば、そのパケットはタグなしで伝送されます。同じでない場合、スイッチはそのパケットをタグ付きで伝送します。

トランク ポートのロード シェアリングの設定

ロード シェアリングにより、スイッチに接続しているパラレル トランクの提供する帯域幅が分割されます。STP は通常、ループを防止するために、スイッチ間で 1 つのパラレル リンク以外のすべてのリンクをブロックします。ロード シェアリングを行うと、トラフィックが属する VLAN に基づいて、リンク間でトラフィックが分割されます。

トランクポートでロード シェアリングを設定するには、STP ポート プライオリティまたは STP パス コストを使用します。STP ポート プライオリティを使用してロード シェアリングを設定する場合には、両方のロード シェアリング リンクを同じスイッチに接続する必要があります。STP パスコストを使用してロード シェアリングを設定する場合には、それぞれのロード シェアリング リンクを同じスイッチに、または 2 台の異なるスイッチに接続できます。STP の詳細については、 第 17 章「STP の設定」 を参照してください。

STP ポート プライオリティによるロード シェアリング

同一スイッチ上の 2 つのポートがループを形成すると、STP ポート プライオリティの設定により、イネーブルになるポートとブロッキング ステートになるポートが決まります。パラレル トランク ポートにプライオリティを設定すると、そのポートは、特定の VLAN のすべてのトラフィックを搬送させることができます。VLAN に対するプライオリティがより高い(より小さい値)トランク ポートがその VLAN のトラフィックを伝送します。同じ VLAN に対してプライオリティのより低い(より大きい値)トランク ポートは、その VLAN に対してブロッキング ステートのままです。1 つのトランク ポートが特定の VLAN に関するすべてのトラフィックを送受信することになります。

図12-2に、サポート対象スイッチを接続する 2 つのトランクを示します。この例では、スイッチは次のように設定されています。

VLAN 8 ~ 10 は、トランク 1 でポート プライオリティ 16 が与えられています。

VLAN 3 ~ 6 は、トランク 1 でデフォルトのポート プライオリティ 128 のままです。

VLAN 3 ~ 6 は、トランク 2 でポート プライオリティ 16 が与えられています。

VLAN 8 ~ 10 は、トランク 2 でデフォルトのポート プライオリティ 128 のままです。

このように設定すると、トランク 1 が VLAN 8 ~ 10 のトラフィックを搬送し、トランク 2 が VLAN 3 ~ 6 のトラフィックを搬送します。アクティブ トランクで障害が起きた場合には、プライオリティのより低いトランクが引き継ぎ、すべての VLAN のトラフィックを搬送します。どのトランク ポート上でも、トラフィックの重複は発生しません。

図12-2 STP ポート プライオリティによるロード シェアリング

 

図12-2に示すネットワークを設定するには、イネーブル EXEC モードで次の手順を実行します。

 

コマンド
説明

ステップ 1

configure terminal

スイッチ A で、グローバル コンフィギュレーション モードを開始します。

ステップ 2

vtp domain domain-name

VTP 管理ドメインを設定します。

1 ~ 32 文字のドメイン名を使用できます。

ステップ 3

vtp mode server

スイッチ A を VTP サーバとして設定します。

ステップ 4

end

イネーブル EXEC モードに戻ります。

ステップ 5

show vtp status

スイッチ A および B の両方で、VTP 設定を確認します。

表示された VTP Operating Mode および VTP Domain Name フィールドをチェックします。

ステップ 6

show vlan

スイッチ A のデータベースに VLAN が存在していることを確認します。

ステップ 7

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 8

interface gigabitethernet1/ 0/1

インターフェイス コンフィギュレーション モードを開始し、トランクに設定するインターフェイスとしてギガビット イーサネット ポート 1 を定義します。

ステップ 9

switchport trunk encapsulation { isl | dot1q | negotiate }

ISL カプセル化または 802.1Q カプセル化をサポートするように、または近接インターフェイスとネゴシエーションするようにポートを設定します。リンクの各終端に同じカプセル化タイプを設定する必要があります。


) Cisco IOS Release 12.2(22)EY 以降のリリースでは、ES ポートは 802.1Q トランキングのみをサポートします。そのため、次のキーワードは標準ポートでのみ認識されます。


ステップ 10

switchport mode trunk

ポートをトランク ポートとして設定します。

ステップ 11

end

イネーブル EXEC モードに戻ります。

ステップ 12

show interfaces gigabitethernet1/ 0/1 switchport

VLAN 設定を確認します。

ステップ 13

スイッチの 2 番めのインターフェイスに対して、スイッチ A 上でステップ 7 ~ 11 を実行します。

ステップ 14

スイッチ A に設定されたトランク ポートに接続するトランク ポートを設定するため、スイッチ B でステップ 7 ~ 11 を実行します。

ステップ 15

show vlan

トランク リンクがアクティブになると、VTP がスイッチ B に VTP および VLAN 情報を流します。スイッチ B が VLAN 設定を学習したことを確認します。

ステップ 16

configure terminal

スイッチ A で、グローバル コンフィギュレーション モードを開始します。

ステップ 17

interface gigabitethernet1/ 0/1

インターフェイス コンフィギュレーション モードを開始し、STP ポート プライオリティを設定するインターフェイスを定義します。

ステップ 18

spanning-tree vlan 8-10 port-priority 16

VLAN 8 ~ 10 にポート プライオリティ 16 を割り当てます。

ステップ 19

exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 20

interface gigabitethernet1/ 0/2

インターフェイス コンフィギュレーション モードを開始し、STP ポート プライオリティを設定するインターフェイスを定義します。

ステップ 21

spanning-tree vlan 3-6 port-priority 16

VLAN 3 ~ 6 にポート プライオリティ 16 を割り当てます。

ステップ 22

end

イネーブル EXEC モードに戻ります。

ステップ 23

show running-config

設定を確認します。

ステップ 24

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

STP パス コストによるロード シェアリング

トランクに異なるパス コストを設定し、各パス コストを異なる VLAN セットに対応付け、VLAN ごとに異なるポートをブロッキングすることにより、VLAN トラフィックを分担するようにパラレル トランクを設定できます。VLAN は、トラフィックを個別に保持し、リンクが失われても冗長性を維持します。

図12-3で、トランク ポート 1 および 2 は 100BASE-T ポートとして設定されています。次の VLAN パス コストが割り当てられています。

VLAN 2 ~ 4 には、トランク ポート 1 でパス コスト 30 が割り当てられています。

VLAN 8 ~ 10 は、トランク ポート 1 で 100BASE-T のデフォルトのパス コスト 19 のままになっています。

VLAN 8 ~ 10 には、トランク ポート 2 でパス コスト 30 が割り当てられています。

VLAN 2 ~ 4 は、トランク ポート 2 で 100BASE-T のデフォルトのパス コスト 19 のままになっています。

図12-3 パス コストによってトラフィックが分散されるロード シェアリング トランク

 

図12-3に示すネットワークを設定するには、イネーブル EXEC モードで次の手順を実行します。

 

コマンド
説明

ステップ 1

configure terminal

スイッチ A で、グローバル コンフィギュレーション モードを開始します。

ステップ 2

interfa c e gigabitethernet1/0/1

インターフェイス コンフィギュレーション モードを開始し、トランクに設定するインターフェイスとしてギガビット イーサネット ポート 1 を定義します。

ステップ 3

switchport trunk encapsulation { isl | dot1q | negotiate }

ISL カプセル化または 802.1Q カプセル化をサポートするようにポートを設定します。リンクの各終端に同じカプセル化タイプを設定する必要があります。


) Cisco IOS Release 12.2(22)EY 以降のリリースでは、ES ポートは 802.1Q トランキングのみをサポートします。そのため、次のキーワードは標準ポートでのみ認識されます。


ステップ 4

switchport mode trunk

ポートをトランク ポートとして設定します。

トランクは、デフォルトで ISL トランキングが設定されます。

ステップ 5

exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 6

スイッチ A の 2 番めのインターフェイスについて、ステップ 2 ~ 4 を繰り返します。

ステップ 7

end

イネーブル EXEC モードに戻ります。

ステップ 8

show running-config

設定を確認します。ステップ 2 ~ 6 で設定したインターフェイスがトランク ポートになっていることを出力で確認します。

ステップ 9

show vlan

トランク リンクがアクティブになると、スイッチ A が他のスイッチから VTP 情報を受信します。スイッチ A が VLAN 設定を学習したことを確認します。

ステップ 10

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 11

interface gigabitethernet1/ 0/1

インターフェイス コンフィギュレーション モードを開始し、STP コストを設定するインターフェイスとしてギガビット イーサネット ポート 1 を定義します。

ステップ 12

spanning-tree vlan 2-4 cost 30

VLAN 2 ~ 4 に対し、スパニングツリー パス コストを 30 に設定します。

ステップ 13

end

グローバル コンフィギュレーション モードに戻ります。

ステップ 14

スイッチ A に設定済みのその他のトランク インターフェイスに対してステップ 9 ~ 11 を繰り返し、VLAN 8、9、10 に対して、スパニングツリー パス コストを 30 に設定します。

ステップ 15

exit

イネーブル EXEC モードに戻ります。

ステップ 16

show running-config

設定を確認します。両方のトランク インターフェイスにパス コストが正しく設定されていることを出力で確認します。

ステップ 17

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

VMPS の設定

VLAN Query Protocol(VQP)は、ダイナミック アクセス ポートをサポートするために使用します。ダイナミック アクセス ポートは、永続的に VLAN に割り当てられるのではなく、ポート上で認識された MAC 送信元アドレスに基づいて VLAN に割り当てられます。スイッチは、不明の MAC アドレスを認識するたびに、VQP クエリーをリモート VMPS へ送信します。クエリーには、新たに認識された MAC アドレスと認識元のポートが含まれます。VMPS は、ポートの VLAN 割り当てと一緒に応答を返します。このスイッチは VMPS サーバとしては使用できませんが、VMPS のクライアントとして動作し、VQP を介して VMPS と通信します。

ここでは VMPS の設定について説明します。

「VMPS の概要」

「VMPS クライアントのデフォルト設定」

「VMPS 設定時の注意事項」

「VMPS クライアントの設定」

「VMPS のモニタ」

「ダイナミック アクセス ポート VLAN メンバーシップのトラブルシューティング」

「VMPS の構成例」

VMPS の概要

クライアント スイッチは、新たなホストの MAC アドレスを受け取るたびに、VQP クエリーを VMPS に送信します。VMPS は、このクエリーを受信すると、自身のデータベースで MAC アドレス/VLAN 間のマッピングを検索します。サーバはこのマッピングと、サーバがオープン モードかセキュア モードであるかに基づいて応答を返します。セキュア モードでは、サーバは、違法なホストを検出すると、そのポートをシャットダウンします。オープン モードでは、サーバは単にポートへのホストのアクセスを拒否するだけです。

ポートが現在 未割り当て unassigned )の場合(つまり、まだ VLAN に割り当てられていない)、VMPS は次の応答のいずれかを返します。

ホストがポート上で許可されている場合、VMPS は、割り当てられた VLAN 名を含み、ホストへのアクセスを許可する VLAN 割り当て vlan-assignment )の応答をクライアントへ送信します。

ホストがポート上で許可されておらず、かつ、VMPS がオープン モードである場合、VMPS は アクセス拒否 access-denied )の応答を送信します。

VLAN がポート上で許可されておらず、かつ、VMPS がセキュア モードの場合、VMPS は ポート シャットダウン port-shutdown )の応答を送信します。

ポートがすでに VLAN 割り当てを持つ場合は、VMPS は次の応答のいずれかを返します。

データベース内の VLAN がポート上の現在の VLAN と一致する場合、VMPS は 成功 success )の応答を返し、ホストへのアクセスを許可します。

データベースの VLAN とポート上の現在の VLAN が一致せず、かつ、ポート上にアクティブなホストがある場合、VMPS のセキュア モードに応じて、VMPS は アクセス拒否 または ポート シャットダウン の応答を送信します。

VMPS から アクセス拒否 の応答を受信したスイッチは、引き続き、そのホスト MAC アドレスとやり取りされるトラフィックをブロックします。また、スイッチは引き続きそのポート宛てのパケットをモニタし、新しいホスト アドレスを検出するたびに、VMPS にクエリーを送ります。VMPS から ポート シャットダウン の応答を受け取ったスイッチは、ポートをディセーブルにします。このポートは、CLI または SNMP(簡易ネットワーク管理プロトコル)を使用して、手動で再びイネーブルにする必要があります。

ダイナミック アクセス ポート VLAN メンバーシップ

ダイナミック アクセス ポートは ID が 1 ~ 4094 の 1 つの VLAN にしか属せません。リンクがアクティブになっても、VMPS によって VLAN 割り当てが行われるまで、スイッチとこのポート間ではトラフィックの伝送は行われません。VMPS はダイナミック アクセス ポートに接続された新しいホストの最初のパケットから送信元 MAC アドレスを受信し、VMPS データベースに登録されている VLAN とその MAC アドレスを照合します。

MAC アドレスと VMPS データベース内の VLAN が一致した場合には、VMPS がそのポートの VLAN 番号を送信します。クライアント スイッチがまだ設定されていない場合には、クライアント スイッチは、トランク ポートで VMPS から受信した最初の VTP パケットに指定されているドメイン名を使用します。クライアント スイッチがすでに設定されている場合には、VMPS へのクエリー パケットに自身のドメイン名を指定して、VLAN 番号を取得します。VMPS はパケットに指定されたドメイン名が自身のドメイン名と一致することを確認してから、要求を受け入れ、そのクライアント用に割り当てた VLAN 番号を使用してクライアントに応答します。一致しなかった場合、VMPS は(VMPS のセキュア モードの設定に応じて)要求を拒否するか、またはポートをシャットダウンします。

ダイナミック アクセス ポート上で複数のホスト(MAC アドレス)がアクティブになるのは、それらのホストがすべて同じ VLAN に属する場合に限られます。ただし、同一ポート上でアクティブのホストが 20 を超えると、VMPS はそのポートをシャットダウンします。

ダイナミック アクセス ポート上でリンクがダウンすると、そのポートは切り離された状態に戻り、VLAN から離脱します。このポートを介してオンラインになるホストは、VQP により再び VMPS のチェックを受けた後に、ポートが VLAN に割り当てられます。

ダイナミック アクセス ポートは、直接ホストに接続できます。また、ネットワークへ接続することもできます。スイッチ上のポートあたり最大 20 の MAC アドレスが許可されます。ダイナミック アクセス ポートは 1 度に 1 つの VLAN にしか属せません。ただし、VLAN は認識された MAC アドレスに応じて時間の経過とともに変更されることがあります。

VMPS クライアントのデフォルト設定

表12-7 に、クライアント スイッチ上の VMPS およびダイナミック アクセス ポートのデフォルト設定を示します。

 

表12-7 VMPS クライアントおよびダイナミック アクセス ポートのデフォルト設定

機能
デフォルト設定

VMPS ドメイン サーバ

なし

VMPS 再確認インターバル

60 分

VMPS サーバへの再試行回数

3

ダイナミック アクセス ポート

設定なし

VMPS 設定時の注意事項

ダイナミック アクセス ポート VLAN メンバーシップには、次の注意事項および制限事項があります。

VMPS を先に設定してから、ダイナミック アクセス ポートとしてポートを設定する必要があります。

ポートをダイナミック アクセス ポートとして設定すると、そのポートに対してスパニングツリーの PortFast 機能が自動的にイネーブルになります。PortFast モードにより、ポートがフォワーディング ステートになるプロセスが短縮されます。

802.1x ポートは、ダイナミック アクセス ポートとして設定できません。ダイナミック アクセス(VQP)ポートで 802.1x をイネーブルにしようとすると、エラー メッセージが表示され、802.1x はイネーブルになりません。802.1x 対応ポートをダイナミック VLAN 割り当てに変更しようとすると、エラー メッセージが表示され、VLAN 設定は変更されません。

トランク ポートをダイナミック アクセス ポートにすることはできません。ただし、トランク ポートに対して switchport access vlan dynamic インターフェイス コンフィギュレーション コマンドを入力できます。この場合、スイッチは設定値を保持し、後にポートがアクセス ポートとして設定された場合にはその設定値が適用されます。

ダイナミック アクセスの設定を有効にするには、ポートのトランキングをオフにする必要があります。

ダイナミック アクセス ポートをモニタ ポートにすることはできません。

セキュア ポートをダイナミック アクセス ポートにすることはできません。ダイナミックになる前にポートでのポート セキュリティをディセーブルにする必要があります。

プライベート VLAN ポートはダイナミック アクセス ポートにすることはできません。

ダイナミック アクセス ポートは、EtherChannel グループのメンバーになることはできません。

ポート チャネルは、ダイナミック アクセス ポートとして設定できません。

ダイナミック アクセス ポートは、代替ブリッジングに加入できます。

VMPS クライアントと VMPS サーバの VTP 管理ドメインは同じである必要があります。

VMPS サーバ上に設定された VLAN は、音声 VLAN にしないでください。

VMPS クライアントの設定

ダイナミック VLAN は VMPS(サーバ)を使用して設定します。スイッチは VMPS クライアントにすることはできますが、VMPS サーバにはできません。

VMPS の IP アドレスの入力

スイッチをクライアントとして設定するには、最初にサーバの IP アドレスを入力する必要があります。


) スイッチ クラスタに VMPS を定義する場合は、コマンド スイッチ上でアドレスを入力します。


VMPS の IP アドレスを入力するには、イネーブル EXEC モードで次の手順を実行します。

 

コマンド
説明

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

vmps server ipaddress primary

プライマリ VMPS サーバとして動作するスイッチの IP アドレスを入力します。

ステップ 3

vmps server ipaddress

(任意)セカンダリ VMPS サーバとして動作するスイッチの IP アドレスを入力します。

最大 3 つのセカンダリ サーバ アドレスを入力できます。

ステップ 4

end

イネーブル EXEC モードに戻ります。

ステップ 5

show vmps

表示された VMPS Domain Server フィールドの設定を確認します。

ステップ 6

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。


) ダイナミック アクセス ポートを動作させるには、VMPS への IP 接続を確立する必要があります。VMPS の IP アドレスへ ping し、応答の受信を確認することで、IP 接続をテストできます。


VMPS クライアントのダイナミック アクセス ポートの設定

クラスタ メンバー スイッチのポートをダイナミック アクセス ポートとして設定する場合は、最初に rcommand イネーブル EXEC コマンドを使用してクラスタ メンバー スイッチにログインします。


注意 ダイナミック アクセス ポート VLAN メンバーシップは、エンド ステーション用、またはエンド ステーションに接続しているハブ用です。ダイナミック アクセス ポートを他のスイッチに接続すると、接続が切断される可能性があります。

VMPS クライアント スイッチにダイナミック アクセス ポートを設定するには、イネーブル EXEC モードで次の手順を実行します。

 

コマンド
説明

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface-id

エンド ステーションに接続しているスイッチ ポートのインターフェイス コンフィギュレーション モードを開始します。

ステップ 3

switchport mode access

ポートをアクセス モードに設定します。

ステップ 4

switchport access vlan dynamic

ダイナミック VLAN メンバーシップ適格としてポートを設定します。

ダイナミック アクセス ポートはエンド ステーションに接続されている必要があります。

ステップ 5

end

イネーブル EXEC モードに戻ります。

ステップ 6

show interfaces interface-id switchport

表示された Operational Mode フィールドを確認します。

ステップ 7

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

インターフェイスの設定をデフォルトに戻すには、 default interface interface-id インターフェイス コンフィギュレーション コマンドを使用します。インターフェイスのスイッチポート モードの設定をデフォルト(dynamic auto)に戻すには、 no switchport mode インターフェイス コンフィギュレーション コマンドを使用します。アクセス モードをスイッチのデフォルト VLAN にリセットするには、 no switchport access vlan インターフェイス コンフィギュレーション コマンドを使用します。

VLAN メンバーシップの確認

スイッチが VMPS から受信したダイナミック アクセス ポート VLAN メンバーシップの割り当てを確認するには、イネーブル EXEC モードで次の手順を実行します。

 

コマンド
説明

ステップ 1

vmps reconfirm

ダイナミック アクセス ポート VLAN メンバーシップを再確認します。

ステップ 2

show vmps

ダイナミック VLAN の再確認ステータスを調べます。

再確認インターバルの変更

VMPS クライアントは、VMPS から受信した VLAN メンバーシップ情報を定期的に再確認します。この再確認を行う間隔を分単位で設定できます。

クラスタ内のメンバー スイッチを設定する場合、このパラメータをコマンド スイッチ上の再確認設定値以上にする必要があります。この場合もまた、 rcommand イネーブル EXEC コマンドを使用してメンバー スイッチにログインする必要があります。

再確認インターバルを変更するには、イネーブル EXEC モードで次の手順を実行します。

 

コマンド
説明

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

vmps reconfirm minutes

ダイナミック VLAN メンバーシップを再確認する間隔を分単位で指定します。指定できる範囲は 1 ~ 120 です。デフォルト値は 60 分です。

ステップ 3

end

イネーブル EXEC モードに戻ります。

ステップ 4

show vmps

表示されている Reconfirm Interval フィールドのダイナミック VLAN の再確認ステータスを確認します。

ステップ 5

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

スイッチをデフォルト設定に戻すには、 no vmps reconfirm グローバル コンフィギュレーション コマンドを使用します。

再試行回数の変更

スイッチが次のサーバにクエリー送信するまでに、VMPS との接続を試みる試行回数を変更するには、イネーブル EXEC モードで次の手順を実行します。

 

コマンド
説明

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

vmps retry count

再試行回数を変更します。再試行回数は 1 ~ 10 回の範囲で指定できます。デフォルトは 3 回です。

ステップ 3

end

イネーブル EXEC モードに戻ります。

ステップ 4

show vmps

表示された Server Retry Count フィールドを確認します。

ステップ 5

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

スイッチをデフォルト設定に戻すには、 no vmps retry グローバル コンフィギュレーション コマンドを使用します。

VMPS のモニタ

VMPS 情報を表示するには、 show vmps イネーブル EXEC コマンドを使用します。VMPS について、次の情報が表示されます。

VMPS VQP バージョン -- VMPS との通信に使用される VQP のバージョン。スイッチは VQP バージョン 1 を使用する VMPS にクエリー送信をします。

再確認インターバル -- VLAN と MAC アドレスとの割り当てを再確認するまでにスイッチが待機する時間(分単位)。

サーバ再試行回数 -- VQP から VMPS にクエリーを再送信する回数。この回数だけ試行しても応答がない場合、スイッチはセカンダリ VMPS に対してクエリー送信を開始します。

VMPS ドメイン サーバ -- 設定されている VMPS の IP アドレス。スイッチは、current の指定があるサーバにクエリーを送信しています。primary と表示されたサーバがプライマリ サーバです。

VMPS アクション -- 最新の再確認試行の結果。再確認は、再確認インターバルとして設定された時間が経過すると自動的に行われます。また、 vmps reconfirm イネーブル EXEC コマンドを入力するか、CMS または SNMP の同等のコマンドを使用することによって、強制的に再確認できます。

 

次に、 show vmps イネーブル EXEC コマンドの出力例を示します。

Switch# show vmps
 
VQP Client Status:
--------------------
VMPS VQP Version: 1
Reconfirm Interval: 60 min
Server Retry Count: 3
VMPS domain server: 172.20.128.86 (primary, current)
172.20.128.87
 
Reconfirmation status
---------------------
VMPS Action: other

ダイナミック アクセス ポート VLAN メンバーシップのトラブルシューティング

VMPS は次の条件が発生したときに、ダイナミック アクセス ポートをシャットダウンします。

VMPS がセキュア モードで、かつ、ホストにポートへの接続を許可しない場合。VMPS は、ホストがネットワークに接続しないように、ポートをシャットダウンします。

1 つのダイナミック アクセス ポート上に 20 を超えるアクティブ ホストが存在する場合。

ディセーブルのダイナミック アクセス ポートを再度イネーブルにするには、 shutdown インターフェイス コンフィギュレーション コマンドに続けて、 no shutdown インターフェイス コンフィギュレーション コマンドを入力します。

VMPS の構成例

図12-4に、VMPS サーバ スイッチと、ダイナミック アクセス ポートの設定された VMPS クライアント スイッチで構成されるネットワークを示します。この例の前提条件は次のとおりです。

VMPS サーバと VMPS クライアントは、それぞれ別個のスイッチです。

Catalyst 6500 シリーズ スイッチ A がプライマリの VMPS サーバです。

Catalyst 6500 シリーズ スイッチ C およびスイッチ J が、セカンダリの VMPS サーバです。

エンド ステーションは、クライアント、スイッチ B、およびスイッチ I に接続されます。

データベース コンフィギュレーション ファイルは、IP アドレス 172.20.22.7 の TFTP(簡易ファイル転送プロトコル)サーバに保存されます。

図12-4 ダイナミック ポート VLAN メンバーシップの構成