Catalyst 3750 Metro スイッチ ソフトウェア コンフィギュレーション ガイド Cisco IOS Release 12.2(25)EY
IEEE 802.1Qおよびレイヤ2プロトコ ル トンネリングの設定
IEEE 802.1Qおよびレイヤ2プロトコル トンネリングの設定
発行日;2012/02/07 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 9MB) | フィードバック

目次

IEEE 802.1Qおよびレイヤ2プロトコル トンネリングの設定

802.1Qトンネリングの概要

802.1Qトンネリングの設定

802.1Qトンネリングのデフォルト設定

802.1Qトンネリング設定時の注意事項

ネイティブVLAN

システムMTU

802.1Qトンネリングおよび他の機能

802.1Qトンネリング ポートの設定

VLANマッピングの設定

VLANマッピングのデフォルト設定

カスタマーVLANからサービス プロバイダーVLANへのマッピング

カスタマー802.1QトンネルVLANからサービス プロバイダーVLANへのマッピング

レイヤ2プロトコル トンネリングの概要

レイヤ2プロトコル トンネリングの設定

レイヤ2プロトコル トンネリングのデフォルト設定

レイヤ2プロトコル トンネリング設定時の注意事項

レイヤ2トンネリングの設定

EtherChannelのレイヤ2トンネリングの設定

サービスプロバイダー エッジ スイッチの設定

カスタマー スイッチの設定

トンネリングおよびマッピング ステータスのモニタおよびメンテナンス

IEEE 802.1Qおよびレイヤ2プロトコル トンネリングの設定

Virtual Private Networks(VPN;仮想私設網)は、共有のインフラストラクチャ(多くの場合、イーサネット ベース)上で、セキュリティ、プライオリティ、信頼性、管理性に関して専用ネットワークと同じレベルの要件を満たす企業規模の接続を提供します。トンネリング機能は、ネットワーク上で複数のカスタマー トラフィックを伝送し、各カスタマーのVLAN(仮想LAN)およびレイヤ2プロトコル設定を他のカスタマー トラフィックへの影響なしで維持する必要のあるサービス プロバイダー向けに設計された機能です。Catalyst 3750 Metroスイッチは、802.1Qトンネリングおよびレイヤ2プロトコル トンネリングとともに、VLANマッピング(VLANおよびID間の変換)をサポートします。


) ここで使用されるコマンドの構文および使用方法の詳細については、このリリースのコマンド リファレンスを参照してください。


この章で説明する内容は、次のとおりです。

「802.1Qトンネリングの概要」

「802.1Qトンネリングの設定」

「VLANマッピングの設定」

「レイヤ2プロトコル トンネリングの概要」

「レイヤ2プロトコル トンネリングの設定」

「トンネリングおよびマッピング ステータスのモニタおよびメンテナンス」


) Multiprotocol Label Switching(MPLS;マルチプロトコル ラベル スイッチング)でのVPNの使用方法については、「MPLSおよびEoMPLSの設定」を参照してください。


802.1Qトンネリングの概要

サービス プロバイダーのビジネス カスタマーには、VLAN IDおよびサポートされるVLAN数について固有の要件がある場合が多くあります。同じサービス プロバイダー ネットワーク上で異なるカスタマーが必要とするVLAN範囲が重複したり、インフラストラクチャを経由する各カスタマーのトラフィックが混在する可能性があります。カスタマー別に固有のVLAN ID範囲を割り当てる方法では、カスタマー側の設定に制約が生じ、802.1Q仕様に定められているVLANの上限(4096)をすぐに超過する可能性があります。

802.1Qトンネリング機能を使用すると、サービス プロバイダーは1つのVLANを使用して、それぞれ複数のVLANを持つカスタマーをサポートできます。サービス プロバイダーのインフラストラクチャ上でカスタマーVLAN IDが保持され、同じVLAN上に存在するように見えても、異なるカスタマーからのトラフィックが分離されます。802.1Qトンネリングを使用する場合、VLAN-in-VLAN階層構造およびタグ付きパケットへのタグ付けによって、VLANスペースを拡張できます。802.1Qトンネリングをサポートするように設定されたポートを、 トンネル ポート といいます。トンネリングを設定する場合、トンネリング専用のVLANにトンネル ポートを割り当てます。カスタマーごとに個別のサービス プロバイダーVLAN IDが必要ですが、そのVLAN IDによってカスタマーのすべてのVLANがサポートされます。

カスタマー デバイスの802.1Qトランク ポートから、通常どおりに適切なVLAN IDでタグ付けされたカスタマー トラフィックが、サービス プロバイダー エッジ スイッチのトンネル ポートに着信します。カスタマー デバイスとエッジ スイッチの間のリンクは、一方の端が802.1Qトランク ポート、反対側がトンネル ポートとして設定されているので、非対称リンクです。カスタマーごとに固有のアクセスVLAN IDに、トンネル ポートを割り当てます。図16-1を参照してください。

図16-1 サービス プロバイダー ネットワークの802.1Qトンネル ポート

 

カスタマー トランク ポートからサービス プロバイダー エッジ スイッチのトンネル ポートに着信するパケットは、通常、適切なVLAN IDで802.1Qタグ付けされています。これらのタグ付きパケットは、スイッチ内部ではそのまま保持され、トランク ポートを出てサービス プロバイダー ネットワークに入る時点で、カスタマーに固有のVLAN IDを含む、802.1Qタグのもう1つのレイヤ( メトロ タグ と呼ばれる)でカプセル化されます。このカプセル化されたパケットの中に、カスタマーからの元の802.1Qタグが残されます。したがって、パケットはサービス プロバイダー インフラストラクチャに入る時点で、二重のタグが付いていることになります。外側のタグはカスタマーのアクセスVLAN IDを含み、内側のVLAN IDは着信トラフィックのVLANです。

二重タグ付きパケットがサービス プロバイダー コア スイッチ上の別のトランク ポートに着信すると、スイッチ内部でパケットが処理されるときに、外側のタグが削除されます。パケットが同じコア スイッチ上の別のトランク ポートから発信される時点で、同じメトロ タグが再びパケットに追加されます。図16-2に、二重タグ付きパケットの構造を示します。

図16-2 標準、802.1Q、および二重タグ付きイーサネット パケットのフォーマット

 

パケットがサービス プロバイダー出力スイッチ上のトランク ポートに着信すると、スイッチ内部でパケットが処理されるときに、外側のタグが再び削除されます。ただし、エッジ スイッチ上のトンネル ポートからカスタマー ネットワークに送出される時点では、メトロ タグは追加されず、パケットは通常の802.1Qタグ付きフレームとして送信され、カスタマー ネットワーク上での元のVLAN番号が保持されます。

図16-1の場合、カスタマーAにはVLAN 30、カスタマーBにはVLAN 40が割り当てられています。エッジ スイッチのトンネル ポートに802.1Qタグ付きで着信するパケットは、サービス プロバイダー ネットワークに入る時点で二重にタグ付けされます。外側のタグにはそれぞれVLAN ID 30または40が含まれ、内側のタグには元のVLAN番号(たとえば、VLAN 100)が含まれます。カスタマーAおよびBの両方のネットワークにVLAN 100があっても、外側のタグが違うので、サービス プロバイダー ネットワーク内ではトラフィックが分離されています。802.1Qトンネリングを使用する場合、各カスタマーはそれぞれ独自のVLAN番号スペースを管理します。このVLAN番号スペースは、他のカスタマーが使用するVLAN番号スペースや、サービス プロバイダー ネットワークで使用されるVLAN番号スペースとは無関係です。

出力側のトンネル ポートでは、カスタマー ネットワーク上での元のVLAN番号が回復されます。複数レベルのトンネリングおよびタグ付けを使用することもできますが、このリリースでスイッチがサポートするのは1つのレベルだけです。

カスタマー ネットワークから着信するトラフィックにタグが付いていない場合(ネイティブVLANフレーム)、これらのパケットは通常のパケットと同じようにブリッジングまたはルーティングされます。エッジ スイッチ上のトンネル ポート経由でサービス プロバイダー ネットワークに着信するパケットは、タグが付いていない場合でも、すでに802.1Qヘッダーでタグ付けされている場合でも、すべてタグなしパケットとして扱われます。サービス プロバイダー ネットワーク上の802.1Qトランク ポートで送信されるとき、パケットはメトロ タグVLAN ID(トンネル ポートのアクセスVLANに設定)でカプセル化されています。メトロ タグのプライオリティ フィールドは、トンネル ポートに設定されているインターフェイスのClass of Service(CoS;サービス クラス)プライオリティに設定されます(プライオリティが設定されていない場合、デフォルトは0です)。

スイッチは、インテリジェント802.1QトンネリングQuality of Service(QoS;サービス品質)、すなわち内側のCoS値を外側のCoS値にコピーする機能をサポートしています。詳細については、「QoSドメイン内のポートの信頼状態の設定」および「インターフェイスのCoS値の設定」を参照してください。

802.1Qトンネリングの設定

ここでは、802.1Qトンネリングに関する次の事項について説明します。

「802.1Qトンネリングのデフォルト設定」

「802.1Qトンネリング設定時の注意事項」

「802.1Qトンネリングおよび他の機能」

「802.1Qトンネリング ポートの設定」

802.1Qトンネリングのデフォルト設定

デフォルトのスイッチポート モードはdynamic autoなので、デフォルトでは、802.1Qトンネリングはディセーブルに設定されています。802.1QネイティブVLANパケットのタグ付けも、すべての802.1Qトランク ポート上でディセーブルです。

802.1Qトンネリング設定時の注意事項

802.1Qトンネリング設定する場合、カスタマー デバイスとエッジ スイッチの間の非対称リンク(カスタマー デバイス ポートは802.1Qトランク ポート、エッジ スイッチ ポートはトンネル ポートとして設定されている)を常に使用する必要があります。

トンネル ポートは、トンネリングに使用するVLANだけに割り当ててください。

ネイティブVLANおよびMaximum Transmission Unit(MTU;最大伝送ユニット)の設定上の要件について、次に説明します。

ネイティブVLAN

エッジ スイッチに802.1Qトンネリングを設定する場合、802.1Qトランク ポートを使用してサービス プロバイダー ネットワークにパケットを送出する必要があります。ただし、サービス プロバイダー ネットワークのコアを通過するパケットは、802.1Qトランク、ISL(スイッチ間リンク)トランク、または非トランキング リンクで伝送される場合があります。これらのコア スイッチで802.1Qトランクを使用する場合、802.1QトランクのネイティブVLANは、同じスイッチ上の非トランキング(トンネリング)ポートのネイティブVLANと同じであってはなりません。ネイティブVLAN上のトラフィックは、802.1Q送信側トランク ポートでタグ付けされていない場合があるからです。

図16-3を参照してください。サービス プロバイダー ネットワークの入力エッジ スイッチ(スイッチB)で、カスタマーXからの802.1Qトランク ポートのネイティブVLANとして、VLAN 40が設定されています。カスタマーXのスイッチAは、VLAN 30でタグ付きパケットをサービス プロバイダー ネットワークのスイッチBの入力トンネル ポート(アクセスVLAN 40に所属)に送信します。トンネル ポートのアクセスVLAN(VLAN 40)は、エッジ スイッチのトランク ポートのネイティブVLAN(VLAN 40)と同じなので、トンネル ポートから受信したタグ付きパケットには、メトロ タグは追加されません。パケットはサービス プロバイダー ネットワーク経由で出力エッジ スイッチ(スイッチC)のトランク ポートまでVLAN 30タグだけで伝送され、この出力スイッチのトンネル ポートを通じて、不正にカスタマーYへ送信されます。

この問題を解決するには、いくつかの方法があります。

サービス プロバイダー ネットワーク上のコア スイッチの間の標準ポートでISLトランクを使用します。エッジ スイッチに接続されたカスタマー インターフェイスは802.1Qトランクでなければなりませんが、コア レイヤのスイッチ間の接続には、ISLトランクを使用することを推奨します。

vlan dot1q tag native グローバル コンフィギュレーション コマンドを使用して、ネイティブVLANも含めて、802.1Qトランクから出て行くすべてのパケットにタグ付けするように、エッジ スイッチを設定します。スイッチがすべての802.1Qトランク上でネイティブVLANパケットにタグ付けするように設定されている場合、スイッチはタグなしパケットを受け入れますが、送信するのはタグ付きパケットだけです。

エッジ スイッチのトランク ポートのネイティブVLAN IDが、カスタマーVLAN範囲に属さないようにします。たとえば、トランク ポートがVLAN 100~200のトラフィックを伝送する場合、ネイティブVLANには、この範囲外の番号を割り当てます。

図16-3 802.1QトンネリングおよびネイティブVLANの潜在的な問題

 

システムMTU

Catalyst 3750 Metroスイッチでは、トラフィックのデフォルトのシステムMTUは、1500バイトです。1500バイトより大きいフレームをサポートするようにファスト イーサネット ポートを設定するには、 system mtu グローバル コンフィギュレーション コマンドを使用します。1500バイトより大きいフレームをサポートするようにギガビット イーサネット ポートを設定するには、 system mtu jumbo グローバル コンフィギュレーション コマンドを使用します。802.1Qトンネリング機能では、メトロ タグを追加するときにフレーム サイズが4バイトだけ増えます。したがって、スイッチのシステムMTUサイズを最低でも1504バイトに増やして、サービス プロバイダー ネットワーク上のすべてのスイッチが最大のフレームを処理できるように設定する必要があります。許容される最大のシステムMTUは、ギガビット イーサネット インターフェイスの場合は9000バイト、ファスト イーサネット インターフェイスの場合は1546バイトです。

802.1Qトンネリングおよび他の機能

802.1Qトンネリングは、レイヤ2パケット スイッチングに関しては適切に動作しますが、一部のレイヤ2機能およびレイヤ3スイッチングとは非互換です。

トンネル ポートはルーテッド ポートにできません。

802.1Qポートを含むVLAN上では、IPルーティングはサポートされません。トンネル ポートから受信したパケットは、レイヤ2情報のみに基づいて転送されます。トンネル ポートを含むSwitch Virtual Interface(SVI)上でルーティングがイネーブルの場合、トンネル ポートから受信したタグなしIPパケットはスイッチによって認識され、ルーティングされます。したがって、カスタマーはネイティブVLAN経由でインターネットにアクセスできます。このアクセスが不要な場合には、トンネル ポートを含むVLAN上にSVIを設定すべきではありません。

トンネル ポート上では、代替ブリッジングはサポートされません。トンネル ポートから受信された802.1Qタグ付きパケットはすべて非IPパケットとして扱われるので、トンネル ポートが設定されているVLAN上で代替ブリッジングがイネーブルであれば、IPパケットはVLAN上で不正にブリッジングされることになります。したがって、トンネル ポートのあるVLAN上では代替ブリッジングをイネーブルに しないでください

トンネル ポートはIP Access Control List(ACL;アクセス制御リスト)をサポートしません。

レイヤ3 QoS ACL、およびレイヤ3情報に関連するその他のQoS機能は、トンネル ポート上ではサポートされません。MAC(メディア アクセス制御)ベースのQoS ACLは、トンネル ポート上でサポートされます。

EtherChannelポート グループがトンネル ポートと互換性を持つのは、EtherChannelポート グループ内で802.1Q設定が一貫している場合に限られます。

802.1Qトンネル ポート上では、Port Aggregation Protocol(PAgP)、Link Aggregation Control Protocol(LACP)、およびUnidirectional Link Detection(UDLD;単一方向リンク検出)がサポートされます。

Dynamic Trunking Protocol(DTP)は、802.1Qトンネリングとは非互換です。トンネル ポートとトランク ポートのある非対称リンクを手動で設定しなければならないからです。

VLAN Trunk Protocol(VTP;VLANトランク プロトコル)は、非対称リンクで接続されたデバイス間、またはトンネル経由で通信するデバイス間では動作しません。

802.1Qトンネル ポート上では、ループバック検出がサポートされます。

ポートが802.1Qトンネル ポートとして設定されている場合、インターフェイス上でスパニングツリーBridge Protocol Data Unit(BPDU;ブリッジ プロトコル データ ユニット)フィルタリングが自動的にイネーブルになります。このインターフェイス上ではCisco Discovery Protocol(CDP)は自動的にディセーブルになります。

802.1Qトンネリング ポートの設定

ポートを802.1Qトンネル ポートとして設定するには、イネーブルEXECモードで次の手順を実行します。

 

コマンド
説明

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface-id

トンネル ポートとして設定するインターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。このポートは、カスタマー スイッチに接続するサービス プロバイダー ネットワーク上のエッジ ポートでなければなりません。有効なインターフェイスは、物理インターフェイスやポートチャネル論理インターフェイス(ポートチャネル1~12)などです。

ステップ 3

switchport access vlan vlan-id

デフォルトVLANを指定します。これは、インターフェイスがトランキングを停止した場合に使用されます。このVLAN IDは、各カスタマーに固有のIDです。

ステップ 4

switchport mode dot1q-tunnel

インターフェイスを802.1Qトンネル ポートとして設定します。

ステップ 5

exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 6

vlan dot1q tag native

(任意)すべての802.1Qトランク ポートでネイティブVLANパケットのタグ付けをイネーブルにするように、スイッチを設定します。設定しない場合、カスタマーVLAN IDがネイティブVLANと同じであれば、トランク ポートはメトロ タグを適用せず、パケットが不正な宛先に送信される可能性があります。

ステップ 7

end

イネーブルEXECモードに戻ります。

ステップ 8

show dot1q-tunnel

スイッチ上のトンネル ポートを表示します。

ステップ 9

show vlan dot1q tag native

802.1QネイティブVLANのタグ付けステータスを表示します。

ステップ 10

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

ポートをデフォルトの状態(dynamic auto)に戻すには、 no switchport mode dot1q-tunnel インターフェイス コンフィギュレーション コマンドを使用します。ネイティブVLANパケットのタグ付けをディセーブルにするには、 no vlan dot1q tag native グローバル コンフィギュレーション コマンドを使用します。

次に、ポートをトンネル ポートとして設定し、ネイティブVLANパケットのタグ付けをイネーブルにして、設定を確認する例を示します。この設定では、ファスト イーサネット ポート7に接続するカスタマーのVLAN IDはVLAN 22です。

Switch(config)# interface fastethernet1/0/7
Switch(config-if)# switchport access vlan 22
% Access VLAN does not exist. Creating vlan 22
Switch(config-if)# switchport mode dot1q-tunnel
Switch(config-if)# exit
Switch(config)# vlan dot1q tag native
Switch(config)# end
Switch# show dot1q-tunnel interface fastethernet1/0/7
Port
-----
Fa1/0/7
-----
Switch# show vlan dot1q tag native
dot1q native vlan tagging is enabled

VLANマッピングの設定

VLANマッピング(またはVLAN ID変換)は、カスタマーVLANをサービス プロバイダーVLANにマッピングするために、サービス プロバイダー ネットワークに接続するEnhanced-Services(ES)ポート上に設定できる機能です。VLANマッピングは、スイッチの内部動作やカスタマーVLANに影響を与えずに、ESポート上でフィルタとして動作します。スイッチ上のVLANの多くは予約済みであったり、またはVLAN範囲が限られていたりする場合があります。カスタマーが予約済み範囲内のVLAN番号を希望している場合、VLANマッピングを使用して、カスタマー トラフィックを802.1Qトンネル内でカプセル化することにより、カスタマーVLANを重複させることができます。

VLANマッピングを使用すると、パケットを送信する直前、およびパケットを受信した直後に、802.1Qタグ内のカスタマーVLAN ID、または802.1Qトンネル フレームの外側および内側タグのマッピング(変換)が実行されます。サービス プロバイダーVLANはスイッチによって認識されないので、すべての設定および統計処理は、カスタマー側のVLANを使用して行われます。

スイッチは次の3種類のVLANマッピングをサポートします。

1対1のマッピング ― 802.1Qタグ内のカスタマーVLAN IDをサービス プロバイダーVLAN IDにマッピングします。

2対1のマッピング ― 外側および内側のVLAN IDを持った802.1Qトンネリング トラフィックをサービス プロバイダーVLAN IDにマッピングします。

2対2のマッピング ― 外側および内側のVLAN IDを持った802.1Qトンネリング トラフィックをサービス プロバイダーの外側および内側のVLAN IDにマッピングします。

カスタマー側の802.1Q VLAN IDを使用してスイッチ内のパケットをスイッチングします。サービス プロバイダーVLAN IDはESポートで送受信されます。


) MPLSまたはEoMPLS用に設定されているインターフェイス上では、VLANマッピングを設定しないでください。


ここでは、次の設定について説明します。

「VLANマッピングのデフォルト設定」

「カスタマーVLANからサービス プロバイダーVLANへのマッピング」

「カスタマー802.1QトンネルVLANからサービス プロバイダーVLANへのマッピング」

VLANマッピングのデフォルト設定

デフォルトで、VLANマッピングは設定されていません。

カスタマーVLANからサービス プロバイダーVLANへのマッピング

図16-4に、サービス プロバイダー ネットワークの別々の側に接続する複数のサイトでカスタマーが同じVLANを使用しているトポロジーを示します。サービス プロバイダー バックボーン経由でパケットを伝送できるように、カスタマーVLAN IDをサービス プロバイダーVLAN IDにマッピングします。サービス プロバイダー バックボーンの反対側でカスタマーVLAN IDが取り出され、別のカスタマー サイトで使用できます。サービス プロバイダー ネットワークの各側にあるESごとに、同じVLANマッピングのセットを設定します。設定手順の後に示す例を参照してください。

図16-4 VLANマッピングの例

 

ESポート上でカスタマーVLAN IDをサービス プロバイダーVLAN IDにマッピングするには、イネーブルEXECモードで次の手順を実行します。

 

コマンド
説明

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface-id

サービス プロバイダー ネットワークに接続されたESインターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

switchport vlan mapping vlan-id translated-id

マッピングするVLAN IDを入力します。

vlan-id ― カスタマー ネットワークからスイッチに着信するVLAN ID。指定できる範囲は1~4094です。

translated-id ― 割り当てられるサービス プロバイダーVLAN ID。指定できる範囲は1~4094です。

ステップ 4

end

イネーブルEXECモードに戻ります。

ステップ 5

show vlan mapping

設定を確認します。

ステップ 6

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

VLAN変換情報を削除するには、no switchport vlan mapping vlan-id translated-id コマンドを使用します。

次に、図16-4に示すカスタマー ネットワークのVLAN ID 1、2、3、4、5を、サービス プロバイダー ネットワークのVLAN 1001、1002、1003、1004、1005にマッピングする例を示します。スイッチAおよびスイッチBのESポートに、同じVLANマッピング コマンドを設定します。

Switch(config)# interface gigabiethernet1/1/1
Switch(config-if)# switchport vlan mapping 1 1001
Switch(config-if)# switchport vlan mapping 2 1002
Switch(config-if)# switchport vlan mapping 3 1003
Switch(config-if)# switchport vlan mapping 4 1004
Switch(config-if)# switchport vlan mapping 5 1005
Switch(config-if)# exit
 

前述の例では、サービスプロバイダー ネットワークの入口では、カスタマー ネットワークのVLAN ID 1、2、3、4、5はサービスプロバイダー ネットワークのVLAN 1001、1002、1003、1004、1005にマッピングされます。サービスプロバイダー ネットワークの出口では、サービスプロバイダー ネットワークのVLAN 1001、1002、1003、1004、1005はカスタマー ネットワークのVLAN ID 1、2、3、4、5にマッピングされます。

カスタマー802.1QトンネルVLANからサービス プロバイダーVLANへのマッピング

switchport vlan mapping インターフェイス コンフィギュレーション コマンドで dot1qtunnel キーワードを使用すると、特定の外側および内側VLAN IDを持つ802.1Qトラフィックを、サービス プロバイダー ネットワーク上の特定の外側および内側VLAN IDにマッピングすることもできます。 drop キーワードを使用して、特定の内側および外側VLAN IDの組み合わせを明示的に変換しない限り、特定の外側VLAN ID上のトラフィックを廃棄するように指定できます。

ESポート上で802.1Qタグ付きトラフィックを廃棄または変換するようにスイッチを設定するには、イネーブルEXECモードで次の作業を実行します。

 

コマンド
説明

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface-id

サービス プロバイダー ネットワークに接続されたESインターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

switchport vlan mapping dot1q-tunnel outer-vlan-id { inner-vlan-id translated-vlan-id | drop}

VLANマッピングを2対1のマッピングとして設定し、元の802.1Qパケットの外側VLAN IDが特定の値と一致した場合に実行されるアクションを指定します。

outer-vlan-id ― 元の802.1Qパケットの外側VLAN IDを入力します。指定できるVLAN IDの範囲は1~4094です。

inner-vlan-id translated-vlan-id ― 元の802.1Qパケットの内側VLAN IDと、変換後のサービス プロバイダー ネットワークVLAN IDを入力します。指定できるVLAN IDの範囲は1~4094です。

drop ― 内側VLAN IDが既存のVLANマッピングで一致しない限り、指定した外側VLAN IDを持つトラフィックを廃棄することを指定します。

ステップ 4

switchport vlan mapping internal dot1q-tunnel internal-outer-vlan-id internal-inner-vlan-id external dot1q-tunnel external-outer-vlan-id external-inner-vlan-id

VLANマッピングを2対2のマッピングとして設定し、マッピングされる外側および内側VLAN IDを指定します。

internal-outer-vlan-id ― 元の802.1Qパケットの外側VLAN IDを入力します。

internal-inner-vlan-id ― 元の802.1Qパケットの内側VLAN IDを入力します。

external-outer-vlan-id ― サービスプロバイダー ネットワークの外側VLAN IDを入力します。

external-inner-vlan-id ― サービスプロバイダー ネットワークの内側VLAN IDを入力します。

指定できるVLAN IDの範囲は1~4094です。


) サービスプロバイダー ネットワークの内側VLAN IDは、元の802.1QパケットのVLAN IDと一致する必要があります。


 

ステップ 5

end

イネーブルEXECモードに戻ります。

ステップ 6

show vlan mapping

設定を確認します。

ステップ 7

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

2対1のマッピング情報を削除するには、 no switchport vlan mapping dot1qtunnel outer-vlan-id
{inner-vlan-id translated-vlan-id | drop }インターフェイス コンフィギュレーション コマンドを使用します。2対2のマッピング情報を削除するには、 switchport vlan mapping internal dot1q-tunnel
internal-outer-vlan-id internal-inner-vlan-id external dot1q-tunnel external-outer-vlan-id
external-inner-vlan-id
インターフェイス コンフィギュレーション コマンドを使用します。

次に、外側VLAN IDが5、内側VLAN IDが6である802.1Qトラフィックを、VLAN ID 10でスイッチから送信するようにESポートで2対1のマッピングを設定する例を示します。外側VLAN IDが5で、内側VLAN IDが6以外の802.1Qトラフィックは廃棄します。VLAN 5のその他のトラフィックも廃棄します。

Switch(config)# interface gigabiethernet1/1/1
Switch(config-if)# switchport vlan mapping dot1q-tunnel 5 6 10
Switch(config-if)# switchport vlan mapping dot1q-tunnel 5 drop
Switch(config-if)# exit
 

次に、外側VLAN IDが5、内側VLAN IDが6である802.1Qトラフィックを、外側VLAN ID 15および内側VLAN ID 16でスイッチから送信するようにESポートで2対2のマッピングを設定する例を示します。

Switch(config)# interface gigabitethernet1/1/1
Switch(config-if)# switchport vlan mapping internal dot1q-tunnel 5 6 external dot1q tunnel 15 6

レイヤ2プロトコル トンネリングの概要

サービス プロバイダー ネットワーク経由で接続される複数のサイトのカスタマーは、さまざまなレイヤ2プロトコルを実行して、すべてのリモート サイトおよびローカル サイトを含むようにトポロジーを拡大する必要があります。STPが適切に稼働している必要があり、すべてのVLANが、ローカル サイトおよびサービス プロバイダー インフラストラクチャ経由ですべてのリモート サイトを含む、適切なスパニングツリーを構築する必要があります。Cisco Discovery Protocol(CDP)は、ローカル サイトおよびリモート サイトから近接するシスコ製デバイスを検出する必要があります。VLAN Trunk Protocol(VTP;VLANトランク プロトコル)は、カスタマー ネットワーク上の全サイトで一貫性のあるVLAN設定を提供する必要があります。

プロトコル トンネリングをイネーブルにした場合、サービス プロバイダー インフラストラクチャの着信側にあるエッジ スイッチは、レイヤ2プロトコル パケットを特殊なMACアドレスでカプセル化し、それらをサービス プロバイダー ネットワーク経由で送信します。ネットワークのコア スイッチは、これらのパケットを処理せず、通常のパケットと同じように転送します。CDP、STP、またはVTPのレイヤ2 Protocol Data Unit(PDU;プロトコル データ ユニット)は、サービス プロバイダー インフラストラクチャを通過し、サービス プロバイダー ネットワークの発信側にあるカスタマー スイッチまで配信されます。同じVLAN上のすべてのカスタマー ポートで同様のパケットが受信され、次のような結果になります。

カスタマーの各サイトのユーザは適切にSTPを実行でき、すべてのVLANが、ローカル サイトだけでなく全サイトからのパラメータに基づく適正なスパニングツリーを構築できます。

CDPは、サービス プロバイダー ネットワーク経由で接続された他のシスコ製デバイスに関する情報を検出して表示します。

VTPは、カスタマー ネットワーク全体で一貫性のあるVLAN設定を提供し、サービス プロバイダーを通じてすべてのスイッチに伝播します。


) サードパーティ ベンダーとのインターオペラビリティを提供するには、レイヤ2プロトコル トンネル バイパス機能を使用できます。バイパス モードでは、プロトコル トンネリングの制御方法が異なる他社製スイッチに対して、制御PDUがトランスペアレントに転送されます。バイパス モードを実装するには、出力トランク ポート上でレイヤ2プロトコル トンネリングをイネーブルに設定します。


レイヤ2プロトコル トンネリングは単独で使用することもできますし、802.1Qトンネリングの機能を拡張することもできます。802.1Qトンネリング ポート上でプロトコル トンネリングをイネーブルに設定しない場合、サービス プロバイダー ネットワークの受信側の終端にあるリモート スイッチはPDUを受信せず、STP、CDP、およびVTPを適切に実行することができません。プロトコル トンネリングが イネーブル の場合、各カスタマーのネットワーク上のレイヤ2プロトコルは、サービス プロバイダー ネットワーク上で稼働しているレイヤ2プロトコルから完全に隔離されます。802.1Qトンネリング機能のあるサービス プロバイダー ネットワーク経由でトラフィックを送信する各サイトのカスタマー スイッチは、カスタマーのVLANを完全に認識できます。802.1Qトンネリングを使用しない場合にも、アクセス ポートまたはトランク ポート経由でカスタマー スイッチに接続し、サービス プロバイダーのアクセス ポートまたはトランク ポート上でトンネリングをイネーブルにすることによって、レイヤ2プロトコル トンネリングをイネーブルにできます。

たとえば図16-5の場合、カスタマーXには、サービス プロバイダー ネットワーク経由で接続された同じVLAN上の4台のスイッチがあります。このネットワークがPDUをトンネリングしない場合、ネットワークの遠端にあるスイッチは、STP、CDP、およびVTPを適切に実行することができません。たとえば、カスタマーX、サイト1のスイッチ上のVLANで動作するSTPは、カスタマーX、サイト2のスイッチに基づくコンバージェンス パラメータを考慮せずに、このサイトのスイッチのスパニングツリーを構築します。その結果、図16-6に示すトポロジーになる可能性があります。

図16-5 レイヤ2プロトコル トンネリング

 

図16-6 BPDUトンネリングを使用しない仮想ネットワーク トポロジー

 

サービスプロバイダー ネットワークでは、レイヤ2プロトコル トンネリングを使用して、ポイントツーポイント ネットワーク トポロジーをエミュレートすることでEtherChannelの作成機能を拡張します。プロトコル トンネリング(PAgPまたはLACP)をサービスプロバイダー スイッチでイネーブルにすると、リモート カスタマー スイッチがPDUを受信し、EtherChannelの自動作成をネゴシエーションします。

たとえば図16-7の場合、カスタマーAには、サービス プロバイダー ネットワーク経由で接続された同じVLAN上の2台のスイッチがあります。ネットワークがPDUをトンネリングする場合、ネットワークの遠端にあるスイッチは、専用回線を必要とすることなくEtherChannelの自動作成をネゴシエーションできます。EtherChannelのレイヤ2プロトコル トンネリングの設定については
「EtherChannelのレイヤ2トンネリングの設定」を参照してください。

図16-7 EtherChannelのレイヤ2プロトコル トンネリング

 

レイヤ2プロトコル トンネリングの設定

サービス プロバイダー ネットワークのエッジ スイッチ上のカスタマーに接続されたポート上で、(プロトコル別の)レイヤ2プロトコル トンネリングをイネーブルにします。エッジ スイッチのトンネル ポートは、カスタマーの802.1Qトランク ポートに接続されています。エッジ スイッチのアクセス ポートは、カスタマーのアクセス ポートに接続されています。カスタマー スイッチに接続するエッジ スイッチが、トンネリング処理を実行します。

レイヤ2プロトコル トンネリングは、アクセス ポート、トンネル ポート、またはトランク ポートとして設定されたポート上でイネーブルにできます。スイッチポート モード dynamic auto または
dynamic desirable に設定されたポート上でレイヤ2プロトコル トンネリングをイネーブルにすることはできません。スイッチはCDP、STP、およびVTPに対応するレイヤ2プロトコル トンネリングをサポートしています。エミュレートされたポイントツーポイント ネットワーク トポロジーの場合、スイッチはPAgP、LACP、UDLDプロトコルもサポートします。


注意 PAgP、LACP、UDLDプロトコル トンネリングはポイントツーポイント トポロジーをエミュレートするためだけのものです。トンネリングされたパケットを多くのポートに送信する誤った設定では、ネットワーク障害となることがあります。

入力エッジ スイッチのレイヤ2プロトコル対応ポートに着信したレイヤ2 PDUがトランク ポート経由でサービス プロバイダー ネットワークに送信されるとき、スイッチはカスタマーPDU宛先MACアドレスを、シスコ独自のwell-knownマルチキャスト アドレス(01-00-0c-cd-cd-d0)で上書きします。802.1Qトンネリングがイネーブルに設定されていなければ、パケットには二重タグも付けられます(外側のタグはカスタマー メトロ タグ、内側のタグはカスタマーVLANタグ)。コア スイッチは内側のタグを無視し、同じメトロVLAN上のすべてのトランク ポートにパケットを転送します。出力側のエッジ スイッチは適切なレイヤ2プロトコルおよびMACアドレス情報を復元し、同じメトロVLAN上のすべてのトンネル ポート、アクセス ポート、およびレイヤ2プロトコル対応トランク ポートにパケットを転送します。したがって、レイヤ2 PDUはそのまま維持され、サービス プロバイダー インフラストラクチャ経由でカスタマー ネットワークの反対側まで配信されます。

図16-5を参照してください。アクセスVLAN 30および40に、それぞれカスタマーXおよびカスタマーYが存在しています。サイト1のカスタマーは、非対称リンクによってサービス プロバイダー ネットワークのエッジ スイッチに接続されています。サイト1のカスタマーYのスイッチBに着信するレイヤ2 PDU(たとえば、BPDUなど)は、宛先MACアドレスとしてwell-known MACアドレスを使用した二重タグ付きパケットとしてインフラストラクチャに転送されます。これらの二重タグ付きパケットには、外側VLANタグ40のほかに、内側VLANタグ(たとえば、VLAN 100など)があります。二重タグ付きパケットがスイッチDに到達すると、外側VLANタグ40が削除され、well-known MACアドレスが該当するレイヤ2プロトコルMACアドレスに置き換えられ、パケットはVLAN 100上で一重のタグ付きパケットとしてサイト2のカスタマーYに送信されます。

カスタマー スイッチのアクセス ポートまたはトランク ポートに接続されたエッジ スイッチのアクセスまたはトランク ポート上で、レイヤ2プロトコル トンネリングをイネーブルにすることもできます。この場合、カプセル化およびカプセル化解除の動作は、パケットがサービス プロバイダー ネットワーク上で二重にタグ付けされない点を除いて、上記と同様です。この一重タグとはカスタマー固有のアクセスVLANタグです。

ここでは、レイヤ2プロトコル トンネリングの設定手順を説明します。具体的な内容は次のとおりです。

「レイヤ2プロトコル トンネリングのデフォルト設定」

「レイヤ2プロトコル トンネリング設定時の注意事項」

「レイヤ2トンネリングの設定」

「EtherChannelのレイヤ2トンネリングの設定」

レイヤ2プロトコル トンネリングのデフォルト設定

表16-1 に、レイヤ2プロトコル トンネリングのデフォルト設定を示します。

 

表16-1 レイヤ2プロトコル トンネリングのデフォルト設定

機能
デフォルト設定

レイヤ2プロトコル トンネリング

CDP、STP、およびVTPに関してディセーブル

シャットダウン スレッシュホールド

ポートをシャットダウンするスレッシュホールド(ポート単位でのレイヤ2 PDUのパケット/秒)は、設定なし

廃棄スレッシュホールド

ポートがPDUを廃棄するスレッシュホールド(ポート単位でのレイヤ2 PDUのパケット/秒)は、設定なし

CoS値

インターフェイス上でデータ パケットのCoS値が設定されている場合、その値がデフォルトとしてレイヤ2 PDUに使用されます。設定しない場合、デフォルトは5です。

レイヤ2プロトコル トンネリング設定時の注意事項

レイヤ2プロトコル トンネリングの設定時の注意事項および動作特性は、次のとおりです。

スイッチはCDP、STP(Multiple STP [MSTP]を含む)、およびVTPのトンネリングをサポートしています。プロトコル トンネリングはデフォルトでディセーブルですが、802.1Qトンネル ポート、アクセス ポート、またはトランク ポート上で個々のプロトコルについてイネーブルに設定できます。

ポイントツーポイント ネットワーク トポロジーがエミュレートされた場合、スイッチはPAgP、LACP、UDLDトンネリングをサポートします。プロトコル トンネリングはデフォルトでディセーブルですが、802.1Qトンネル ポート、アクセス ポート、またはトランク ポート上で個々のプロトコルについてイネーブルに設定できます。

スイッチは、スイッチポート モードが dynamic auto または dynamic desirable のポート上でのレイヤ2プロトコル トンネリングはサポートしません。

PAgPまたはLACPトンネリングをイネーブルにする場合、リンク障害検出を高速にするためインターフェイス上でUDLDもイネーブルにすることを推奨します。

PAgPパケット、LACPパケット、またはUDLDパケットのレイヤ2プロトコル トンネリングでは、ループバック検出がサポートされません。

DTPは、レイヤ2プロトコル トンネリングとは非互換です。トンネル ポートとトランク ポートのある非対称リンクを手動で設定しなければならないからです。

出力側のエッジ スイッチは適切なレイヤ2プロトコルおよびMACアドレス情報を復元し、同じメトロVLAN上のすべてのトンネル ポート、アクセス ポート、およびレイヤ2プロトコル対応トランク ポートにパケットを転送します。

サードパーティ ベンダー製スイッチとのインターオペラビリティを確保するために、スイッチはレイヤ2プロトコル トンネル バイパス機能をサポートしています。バイパス モードでは、プロトコル トンネリングの制御方法が異なるベンダー製スイッチに対して、制御PDUがトランスペアレントに転送されます。スイッチの入力ポート上でレイヤ2プロトコル トンネリングがイネーブルの場合、出力トランク ポートは特殊なカプセル化を使用してトンネリングされたパケットを転送します。出力トランク ポート上でもレイヤ2プロトコル トンネリングをイネーブルに設定すると、この動作はバイパスされ、スイッチは制御PDUを処理または変更することなく転送します。

EtherChannelポート グループがトンネル ポートと互換性を持つのは、EtherChannelポート グループ内で802.1Q設定が一貫している場合に限られます。

トンネル ポートまたはレイヤ2トンネリングがイネーブルに設定されているアクセスまたはトランク ポートから(独自の宛先MACアドレスを使用して)カプセル化されたPDUを受信した場合、ループを防ぐために、そのポートはシャットダウンされます。また、プロトコルに関して設定されているシャットダウン スレッシュホールドに達した場合にも、ポートはシャットダウンされます。ポートを手動で再びイネーブルにする( shutdown および no shutdown コマンドシーケンスを使用する)ことができます。また、errdisable回復機能をイネーブルに設定している場合、所定のタイム インターバルが経過したあとに動作が再試行されます。

カスタマー ネットワークに転送されるのは、カプセル化解除されたPDUだけです。サービス プロバイダー ネットワーク上で動作しているスパニングツリー インスタンスは、トンネル ポートにBPDUを転送しません。トンネル ポートからCDPパケットが転送されることはありません。

インターフェイス上でプロトコル トンネリングがイネーブルに設定されている場合、カスタマー ネットワークが生成するPDUのプロトコル単位およびポート単位でのシャットダウン スレッシュホールドを設定できます。この限界を超過すると、ポートがシャットダウンされます。また、トンネル ポート上でQoS ACLおよびポリシー マップを使用してBPDUを速度制限することもできます。

インターフェイス上でプロトコル トンネリングがイネーブルに設定されている場合、カスタマー ネットワークが生成するPDUのプロトコル単位およびポート単位での廃棄スレッシュホールドを設定できます。この限界を超過すると、ポートはPDUを受信する速度が廃棄スレッシュホールドより下になるまで、PDUを廃棄します。

カスタマーの仮想ネットワークが正常に動作するには、トンネリングされるPDU(特にSTP BPDU)をすべてのリモート サイトに配信する必要があるので、サービス プロバイダー ネットワーク上で同じトンネル ポートから受信するデータ パケットより高いプライオリティをPDUに与えることができます。デフォルトでは、PDUはデータ パケットと同じCoS値を使用します。

レイヤ2トンネリングの設定

ポートをレイヤ2プロトコル トンネリング用に設定するには、イネーブルEXECモードで次の手順を実行します。

 

コマンド
説明

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface-id

トンネル ポートとして設定するインターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。このポートは、カスタマー スイッチに接続するサービス プロバイダー ネットワーク上のエッジ ポートでなければなりません。有効なインターフェイスは、物理インターフェイスやポートチャネル論理インターフェイス(ポートチャネル1~12)などです。

ステップ 3

switchport mode access

または
switchport mode dot1q-tunnel

または
switchport mode trunk

インターフェイスをアクセス ポート、802.1Qトンネル ポート、またはトランク ポートとして設定します。

ステップ 4

l2protocol-tunnel [ cdp | stp | vtp ]

希望するプロトコルのプロトコル トンネリングをイネーブルにします。キーワードを指定しない場合、3つのレイヤ2プロトコル全部でトンネリングがイネーブルになります。

ステップ 5

l2protocol-tunnel shutdown-threshold [ cdp | stp | vtp ] value

(任意)カプセル化用の受信について、インターフェイスをシャットダウンするまでのスレッシュホールド(パケット/秒)を設定します。設定したスレッシュホールドを超過すると、ポートがディセーブルになります。プロトコル オプションを指定しない場合、トンネリングされる各レイヤ2プロトコル タイプにスレッシュホールドが適用されます。指定できる範囲は1~4096です。デフォルトでは、スレッシュホールドは設定されません。


) このインターフェイスに対して廃棄スレッシュホールドも設定する場合、シャットダウン スレッシュホールド値は、廃棄スレッシュホールド値以上でなければなりません。


 

ステップ 6

l2protocol-tunnel drop-threshold [ cdp | stp | vtp ] value

(任意)カプセル化用の受信について、インターフェイスがパケットを廃棄するまでのスレッシュホールド(パケット/秒)を設定します。設定したスレッシュホールドを超過すると、ポートはパケットを廃棄します。プロトコル オプションを指定しない場合、トンネリングされる各レイヤ2プロトコル タイプにスレッシュホールドが適用されます。指定できる範囲は1~4096です。デフォルトでは、スレッシュホールドは設定されません。


) このインターフェイスに対してシャットダウン スレッシュホールドも設定する場合、廃棄スレッシュホールド値は、シャットダウン スレッシュホールド値以下でなければなりません。


 

ステップ 7

exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 8

errdisable recovery cause l2ptguard

(任意)レイヤ2最大レート エラーからの回復メカニズムを設定し、インターフェイスがディセーブル ステートから復帰して再試行できるようにします。タイム インターバルも設定できます。errdisable回復は、デフォルトではディセーブルに設定されています。イネーブルに設定する場合、デフォルトのタイム インターバルは300秒です。

ステップ 9

l2protocol-tunnel cos value

(任意)トンネリングされるすべてのレイヤ2 PDUのCoS値を設定します。指定できる範囲は0~7です。デフォルトでは、インターフェイスのデフォルトのCoS値が使用されます。設定しない場合、デフォルトは5です。

ステップ 10

end

イネーブルEXECモードに戻ります。

ステップ 11

show l2protocol

スイッチ上のレイヤ2トンネル ポートを、設定されているプロトコル、スレッシュホールド、およびカウンタも含めて表示します。

ステップ 12

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

いずれかのレイヤ2プロトコル、または3つのプロトコル全部について、プロトコル トンネリングをディセーブルにするには、 no l2protocol-tunnel [ cdp | stp | vtp ]インターフェイス コンフィギュレーション コマンドを使用します。シャットダウンおよび廃棄スレッシュホールドをデフォルト設定に戻すには、 no l2protocol-tunnel shutdown-threshold [ cdp | stp | vtp ]および no l2protocol-tunnel
drop-threshold
[ cdp | stp | vtp ]コマンドを使用します。

次に、CDP、STP、およびVTPについてレイヤ2プロトコル トンネリングを設定し、設定を確認する例を示します。

Switch(config)# interface gigabitethernet1/0/2
Switch(config-if)# l2protocol-tunnel cdp
Switch(config-if)# l2protocol-tunnel stp
Switch(config-if)# l2protocol-tunnel vtp
Switch(config-if)# l2protocol-tunnel shutdown-threshold 1500
Switch(config-if)# l2protocol-tunnel drop-threshold 1000
Switch(config-if)# exit
Switch(config)# l2protocol-tunnel cos 7
Switch(config)# end
Switch# show l2protocol
COS for Encapsulated Packets: 7
 
Port Protocol Shutdown Drop Encapsulation Decapsulation Drop
Threshold Threshold Counter Counter Counter
------- -------- --------- --------- ------------- ------------- -------------
Gi1/0/2 cdp 1500 1000 0 0 0
stp 1500 1000 0 0 0
vtp 1500 1000 0 0 0
 

EtherChannelのレイヤ2トンネリングの設定

レイヤ2ポイントツーポイント トンネリングを設定してEtherChannelの自動作成を容易にするには、サービスプロバイダー エッジ スイッチおよびカスタマー スイッチの両方を設定する必要があります。

サービスプロバイダー エッジ スイッチの設定

EtherChannelのレイヤ2プロトコル トンネリング用にサービスプロバイダー エッジ スイッチを設定するには、イネーブルEXECモードで次の手順を実行します。

 

コマンド
説明

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface-id

トンネル ポートとして設定するインターフェイスを入力し、インターフェイス コンフィギュレーション モードを開始します。このポートは、カスタマー スイッチに接続するサービス プロバイダー ネットワーク上のエッジ ポートでなければなりません。有効なインターフェイスは物理インターフェイスです。

ステップ 3

switchport mode dot1q-tunnel

インターフェイスを802.1Qトンネル ポートとして設定します。

ステップ 4

l2protocol-tunnel point-to-point [ pagp | lacp | udld ]

希望するプロトコルのポイントツーポイント プロトコル トンネリングをイネーブルにします。キーワードを指定しない場合、3つのプロトコル全部でトンネリングがイネーブルになります。


注意 ネットワーク障害を避けるため、ネットワークがポイントツーポイント トポロジーになっていることを確認してから、PAgPパケット、LACPパケット、またはUDLDパケットのトンネリングをイネーブルにしてください。

 

ステップ 5

l2protocol-tunnel shutdown-threshold [ point-to-point [ pagp | lacp | udld ]] value

(任意)カプセル化用に1秒間に受信するパケット数のスレッシュホールドを設定します。設定したスレッシュホールドを超過すると、インターフェイスがディセーブルになります。プロトコル オプションを指定しない場合、トンネリングされる各レイヤ2プロトコル タイプにスレッシュホールドが適用されます。指定できる範囲は1~4096です。デフォルトでは、スレッシュホールドは設定されません。


) このインターフェイスに対して廃棄スレッシュホールドも設定する場合、シャットダウン スレッシュホールド値は、廃棄スレッシュホールド値以上でなければなりません。


 

ステップ 6

l2protocol-tunnel drop-threshold [ point-to-point [ pagp | lacp | udld ]] value

(任意)カプセル化用に1秒間に受信するパケット数のスレッシュホールドを設定します。設定したスレッシュホールドを超過すると、インターフェイスはパケットを廃棄します。プロトコル オプションを指定しない場合、トンネリングされる各レイヤ2プロトコル タイプにスレッシュホールドが適用されます。指定できる範囲は1~4096です。デフォルトでは、スレッシュホールドは設定されません。


) このインターフェイスに対してシャットダウン スレッシュホールドも設定する場合、廃棄スレッシュホールド値は、シャットダウン スレッシュホールド値以下でなければなりません。


 

ステップ 7

no cdp enable

インターフェイスのCDPをディセーブルにします。

ステップ 8

spanning-tree bpdufilter enable

インターフェイス上でBPDUフィルタリングをイネーブルにします。

ステップ 9

exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 10

errdisable recovery cause l2ptguard

(任意)インターフェイスを再びイネーブルにして再試行できるようにするため、レイヤ2最大レート エラーからの回復メカニズムを設定します。errdisable回復は、デフォルトではディセーブルに設定されています。イネーブルに設定する場合、デフォルトのタイム インターバルは300秒です。

ステップ 11

l2protocol-tunnel cos value

(任意)トンネリングされるすべてのレイヤ2 PDUのCoS値を設定します。指定できる範囲は0~7です。デフォルトでは、インターフェイスのデフォルトのCoS値が使用されます。設定しない場合、デフォルトは5です。

ステップ 12

end

イネーブルEXECモードに戻ります。

ステップ 13

show l2protocol

スイッチ上のレイヤ2トンネル ポートを、設定されているプロトコル、スレッシュホールド、およびカウンタも含めて表示します。

ステップ 14

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

いずれかのレイヤ2プロトコルまたは3つすべてのレイヤ2プロトコルのポイントツーポイント プロトコル トンネリングをディセーブルにするには、 no l2protocol-tunnel [ point-to-point [ pagp | lacp | udld ]] インターフェイス コンフィギュレーション コマンドを使用します。シャットダウン スレッシュホールドおよび廃棄スレッシュホールドをデフォルト設定に戻すには、 no l2protocol-tunnel
shutdown-threshold
[ point-to-point [ pagp | lacp | udld ]]および no l2protocol-tunnel drop-threshold [ [ point-to-point [ pagp | lacp | udld ]] コマンドを使用します。

カスタマー スイッチの設定

サービスプロバイダー エッジ スイッチを設定したら、イネーブルEXECモードで次の手順を実行し、EtherChannelのレイヤ2プロトコル トンネリング用にカスタマー スイッチを設定します。

 

コマンド
説明

ステップ 1

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface interface-id

インターフェイス コンフィギュレーション モードを開始します。これは、カスタマー スイッチ ポートにする必要があります。

ステップ 3

switchport trunk encapsulation dot1q

トランキング カプセル化フォーマットを802.1Qに設定します。

ステップ 4

switchport mode trunk

インターフェイス上でトランキングをイネーブルにします。

ステップ 5

udld enable

インターフェイスの 通常モード でUDLDをイネーブルにします。

ステップ 6

channel-group channel-group-number mode desirable

チャネル グループにインターフェイスを割り当て、PAgPモードに
desirable を指定します。EtherChannelの設定の詳細については、「EtherChannelの設定」を参照してください。

ステップ 7

exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 8

interface port-channel port-channel number

ポートチャネル インターフェイス モードを開始します。

ステップ 9

shutdown

インターフェイスをシャットダウンします。

ステップ 10

no shutdown

インターフェイスをイネーブルにします。

ステップ 11

end

イネーブルEXECモードに戻ります。

ステップ 12

show l2protocol

スイッチ上のレイヤ2トンネル ポートを、設定されているプロトコル、スレッシュホールド、およびカウンタも含めて表示します。

ステップ 13

copy running-config startup-config

(任意)コンフィギュレーション ファイルに設定を保存します。

インターフェイスをデフォルト設定に戻すには、 no switchport mode trunk no udld enable および
no channel group
channel-group-number mode desirable インターフェイス コンフィギュレーション コマンドを使用します。

EtherChannelの場合は、サービスプロバイダー エッジ スイッチおよびカスタマー スイッチをレイヤ2プロトコル トンネリング用に設定する必要があります。

次に、図16-7のサービス プロバイダーのエッジ スイッチAおよびエッジ スイッチBを設定する方法を示します。VLAN 17、18、19、20はアクセスVLAN、ファスト イーサネット ポート1および2はPAgPおよびUDLDがイネーブルになっているポイントツーポイント トンネル ポート、廃棄スレッシュホールドは1000、ファスト イーサネット ポート3はトランク ポートです。

サービスプロバイダー エッジ スイッチAの設定

Switch(config)# interface fastethernet1/0/1
Switch(config-if)# switchport access vlan 17
Switch(config-if)# switchport mode dot1q-tunnel
Switch(config-if)# l2protocol-tunnel point-to-point pagp
Switch(config-if)# l2protocol-tunnel point-to-point udld
Switch(config-if)# l2protocol-tunnel drop-threshold point-to-point pagp 1000
Switch(config-if)# exit
Switch(config)# interface fastethernet1/0/2
Switch(config-if)# switchport access vlan 18
Switch(config-if)# switchport mode dot1q-tunnel
Switch(config-if)# l2protocol-tunnel point-to-point pagp
Switch(config-if)# l2protocol-tunnel point-to-point udld
Switch(config-if)# l2protocol-tunnel drop-threshold point-to-point pagp 1000
Switch(config-if)# exit
Switch(config)# interface fastethernet1/0/3
Switch(config-if)# switchport trunk encapsulation isl
Switch(config-if)# switchport mode trunk
 

サービスプロバイダー エッジ スイッチBの設定

Switch(config)# interface fastethernet1/0/1
Switch(config-if)# switchport access vlan 19
Switch(config-if)# switchport mode dot1q-tunnel
Switch(config-if)# l2protocol-tunnel point-to-point pagp
Switch(config-if)# l2protocol-tunnel point-to-point udld
Switch(config-if)# l2protocol-tunnel drop-threshold point-to-point pagp 1000
Switch(config-if)# exit
Switch(config)# interface fastethernet1/0/2
Switch(config-if)# switchport access vlan 20
Switch(config-if)# switchport mode dot1q-tunnel
Switch(config-if)# l2protocol-tunnel point-to-point pagp
Switch(config-if)# l2protocol-tunnel point-to-point udld
Switch(config-if)# l2protocol-tunnel drop-threshold point-to-point pagp 1000
Switch(config-if)# exit
Switch(config)# interface fastethernet1/0/3
Switch(config-if)# switchport trunk encapsulation isl
Switch(config-if)# switchport mode trunk
 

次に、サイト1のカスタマー スイッチを設定する例を示します。ファスト イーサネット ポート1、2、3、4は802.1Qトランキング用に設定されており、UDLDはイネーブル、EtherChannelグループ1はイネーブル、ポート チャネルはシャットダウンされたあとでイネーブルになってEtherChannel設定がアクティブになります。

Switch(config)# interface fastethernet1/0/1
Switch(config-if)# switchport trunk encapsulation dot1q
Switch(config-if)# switchport mode trunk
Switch(config-if)# udld enable
Switch(config-if)# channel-group 1 mode desirable
Switch(config-if)# exit
Switch(config)# interface fastethernet1/0/2
Switch(config-if)# switchport trunk encapsulation dot1q
Switch(config-if)# switchport mode trunk
Switch(config-if)# udld enable
Switch(config-if)# channel-group 1 mode desirable
Switch(config-if)# exit
Switch(config)# interface fastethernet1/0/3
Switch(config-if)# switchport trunk encapsulation dot1q
Switch(config-if)# switchport mode trunk
Switch(config-if)# udld enable
Switch(config-if)# channel-group 1 mode desirable
Switch(config-if)# exit
Switch(config)# interface fastethernet1/0/4
Switch(config-if)# switchport trunk encapsulation dot1q
Switch(config-if)# switchport mode trunk
Switch(config-if)# udld enable
Switch(config-if)# channel-group 1 mode desirable
Switch(config-if)# exit
Switch(config)# interface port-channel 1
Switch(config-if)# shutdown
Switch(config-if)# no shutdown
Switch(config-if)# exit

トンネリングおよびマッピング ステータスのモニタおよびメンテナンス

表16-2 に、802.1Qおよびレイヤ2プロトコル トンネリングとVLANマッピングのモニタおよびメンテナンスに使用するイネーブルEXECコマンドを示します。

 

表16-2 トンネリングおよびVLANマッピングのモニタおよびメンテナンス用コマンド

 

コマンド
説明

clear l2protocol-tunnel counters

レイヤ2プロトコル トンネリング ポート上のプロトコル カウンタをクリアします。

show dot1q-tunnel

スイッチ上の802.1Qトンネル ポートを表示します。

show dot1q-tunnel interface interface-id

特定のインターフェイスがトンネル ポートであるかどうかを確認します。

show l2protocol-tunnel

レイヤ2プロトコル トンネリング ポートに関する情報を表示します。

show errdisable recovery

レイヤ2プロトコル トンネルのerrdisableステートからの回復タイマーがイネーブルかどうかを確認します。

show interface interface-id vlan mapping

指定したインターフェイスのVLANマッピング情報を表示します。インターフェイスは、ESポートまたはVLANにできます。

show l2protocol-tunnel interface interface-id

特定のレイヤ2プロトコル トンネリング ポートに関する情報を表示します。

show l2protocol-tunnel summary

レイヤ2プロトコル サマリー情報のみを表示します。

show vlan dot1q native

スイッチ上のネイティブVLANタギングのステータスを表示します。

show vlan mapping

ESポートのVLANマッピング情報(VLANマッピング テーブルの内容)を表示します。

これらのコマンド出力の詳細については、このリリースのコマンド リファレンスを参照してください。