Catalyst 6500 シリーズ スイッチ SIP、SSC、およ び SPA ソフトウェア コンフィギュレーション ガイド
SIP および SSC の設定
SIP および SSC の設定
発行日;2012/02/02 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 18MB) | フィードバック

目次

SIP および SSC の設定

設定作業

必要な設定作業

、SSC、および のスロットおよびサブスロットの識別

または SSC のスロット位置の指定

SPA の SIP または SSC サブスロットの位置の指定

CRTP の設定

フレームリレー機能の設定

での Distributed Multilink Frame Relay(FRF.16)の設定

での dML PPP の設定

フレームリレーおよび ATM インターフェイスの dLFI の設定

VoFR(FRF.11 および FRF.12)の設定

でのレイヤ 2 インターワーキング機能の設定

MPB の設定

PPP BCP サポートの設定

Virtual Private LAN Service(VPLS)の設定

非対称キャリア遅延の設定

での MPLS 機能の設定

での AToM の設定

エッジに対して MPLS を使用する H-VPLS の設定

での QoS 機能の設定

QoS 機能設定時の一般的な注意事項

MQC による QoS 機能の設定

SIP での QoS トラフィック クラスの設定

SIP での QoS クラス ベース マーキング ポリシーの設定

SIP での QoS 輻輳管理および回避ポリシーの設定

でのデュアル プライオリティ キューイングの設定

SIP での QoS トラフィック シェーピング ポリシーの設定

SIP での QoS トラフィック ポリシング ポリシーの設定

インターフェイスへの QoS トラフィック ポリシーの結合

NBAR および dNBAR の設定

SIP での階層型 QoS の設定

での PFC QoS の設定

SIP のリセット

設定例

トランク モード BCP の設定例

QoS の設定例

MPB を使用する QoS の設定例

2 レベルのポリシー マップを使用する階層型 QoS の設定例

SIP および SSC の設定

この章では、Catalyst 6500 シリーズ スイッチに SIP および SSC を設定する方法について説明します。具体的な内容は次のとおりです。

「設定作業」

「設定例」

システム イメージおよびコンフィギュレーション ファイルの管理については、『 Cisco IOS Configuration Fundamentals Configuration Guide Release 12.2 および『 Cisco IOS Configuration Fundamentals Command Reference Release 12.2 を参照してください。

この章で使用するコマンドの詳細については、『 Catalyst 6500 Series Cisco IOS Command Reference 12.2SX を参照してください また、関連する Cisco IOS Release 12.2 ソフトウェア コマンド リファレンスおよびマスター インデックス資料も参照してください。これらの資料の入手方法については、「関連資料」を参照してください。

設定作業

ここでは、SIP および SSC の設定方法、および設定の確認方法について説明します。

内容は、次のとおりです。

「必要な設定作業」

「SIP、SSC、および SPA のスロットおよびサブスロットの識別」

「CRTP の設定」

「フレームリレー機能の設定」

「SIP でのレイヤ 2 インターワーキング機能の設定」

「SIP での MPLS 機能の設定」

「SIP での QoS 機能の設定」

「SIP のリセット」

ここでは、ユーザが考慮すべき SIP 固有の設定時の注意事項がある機能を特定し、サポート対象プラットフォーム マニュアルへのリンクを示します。

FlexWAN および Enhanced FlexWAN モジュールがサポートするCatalyst 6500 シリーズ スイッチの Cisco IOS ソフトウェア機能の多くは、SIPでもサポートされます。この章および SIP でサポートされる機能のリストが記載されている「SIP および SSC の概要」を参照してください。


) その他のプラットフォームのマニュアルを参照する場合は、このマニュアルに記載された SIP 固有の設定時の注意事項に注意してください。


Catalyst 6500 シリーズ スイッチでサポートされているにもかかわらず、このマニュアルに記載されていないその他の機能の設定方法の詳細は、次の URL にある『 Catalyst 6500 Series Cisco IOS Software Configuration Guide, 12.2SX 』を参照してください。

http://www.cisco.com/en/US/docs/switches/lan/catalyst6500/ios/12.2SX/configuration/guide/book.html

必要な設定作業

Cisco IOS Release 12.2(18)SXE には、SIPまたは SSC を直接設定する必要のある機能はありません。したがって、機能を設定する場合に、SIP または SSC に接続する必要はありません。

ただし、Cisco 7600 SIP-200 および Cisco 7600 SIP-400 では、Route Processor(RP; ルート プロセッサ)上でシステム レベルの設定が可能な特定の機能が実装され、サポートされています。

SIP、SSC、および SPA のスロットおよびサブスロットの識別

ここでは、CLI(コマンドライン インターフェイス)を使用して、SPAに搭載された SIP および Catalyst 6500 シリーズ スイッチ の物理的な場所を指定し、これらのデバイスを設定またはモニタする方法を示します。


) わかりやすくするために、このセクションでは SSC も SIP で表します。


SIP または SSC のスロット位置の指定

Catalyst 6500 シリーズ スイッチは、それぞれの一定数のシャーシ スロットをサポートする複数のシャーシ モデルをサポートします。


) Catalyst 6500 シリーズ スイッチ SIP と supported with a Supervisor Engine 1、Supervisor Engine 1A、Supervisor Engine 2、または Supervisor Engine 720-3A は併用できません。


図 4-1 に、Catalyst 6509 のスロット 6 に搭載された SIP の例を示します。Cisco 6509 スイッチには、シャーシ スロットが水平方向に 9 つあり、右から左に 1 ~ 9 の番号が付いています。

図 4-1 Catalyst 6509 スイッチに搭載された SIP および SPA

 

 

1

SIP サブスロット 0

4

SIP サブスロット 3

2

SIP サブスロット 1

5

シャーシ スロット 1 ~ 9(上から下に付番)

3

SIP サブスロット 2

show module show sip-disk show idprom module show hw-module slot 、および show diagbus など一部のコマンドを使用すると、SIP 自体の情報を表示できます。これらのコマンドでは、情報を必要とする SIP が搭載されたシャーシ スロットの位置を指定する必要があります。

たとえば、SIP のようにスロット 6 に搭載された 図 4-1 のステータスおよび情報を表示するには、次のコマンドを入力します。

Router# show module 6
 

SIP コマンドの詳細は、『 Catalyst 6500 Series Cisco IOS Command Reference, 12.2SX 』を参照してください。

SPA の SIP または SSC サブスロットの位置の指定

SIP サブスロットの番号は「0」から開始し、ルータ シャーシ スロットの SIP の向きに応じて、横または縦に配置されています。

図 4-1 に、Cisco 7609 ルータに縦向きに搭載された Cisco 7600 SIP-200 の例を示します。Cisco 7600 SIP-200 では、SPA を搭載するためのサブスロットが 4 つサポートされています。この例では、サブスロットは次のように縦に並んでいます。

SIPサブスロット 0:上部右サブスロット

SIPサブスロット 1:下部右サブスロット

SIPサブスロット 2:上部左サブスロット

SIPサブスロット 3:下部左サブスロット

図 4-2 に、横型の Cisco 7600 SIP-200 の前面プレートを示します。

図 4-2 Cisco 7600 SIP-200 の前面プレート

 

この図では、横型のサブスロットの位置は次のようになります。

SIPサブスロット 0:上部左サブスロット

SIPサブスロット 1:上部右サブスロット

SIPサブスロット 2:下部左サブスロット

SIPサブスロット 3:下部右サブスロット

SIP のサブスロットの番号は、前面プレートのサブスロットの横に貼付された小さい数字ラベルで示されます。

SIP の場合と同様に、 show idprom module show hw-module subslot などの一部のコマンドを使用すると、SPA 自体の情報を表示できます。これらのコマンドでは、SIP および SPA の物理的な位置を slot / subslot のフォーマットで指定する必要があります。

slot :SIP が搭載された Catalyst 6500 シリーズ スイッチのシャーシ スロット番号を指定します。

subslot :SPA が搭載された SIP のセカンダリ スロットを指定します。

たとえば、SIP のように、シャーシ スロット 6 に 図 4-1 が搭載され、その最初のサブスロットに SPA が搭載されている場合に、SPA の動作ステータスを表示するには、次のコマンドを入力します。

Router# show hw-module subslot 6/0 oir
 

SPA コマンドの詳細は、『 Catalyst 6500 Series Cisco IOS Command Reference, 12.2SX 』を参照してください。

CRTP の設定

Compressed Real-Time Protocol(cRTP)は、RFC 1889(『 RTP: A Transport Protocol for Real-Time Applications 』)で既定されています。CRTP は音声を転送するときに UDP/RTP/IP ヘッダーを圧縮して、低速リンクでの帯域幅効率を高めます。cRTP では、Voice over IP トラフィックのヘッダーが 40 バイトから 2 ~ 5 バイト前後に縮小され、低速リンクに適した高い帯域幅効率が得られます。cRTP はフレームリレー、ATM、PPP、MLPPP、および HDLC(ハイレベル データ リンク制御)を介してカプセル化されるインターフェイスでサポートされます。


) cRTP がサポートされるのは、8 ポート チャネライズド T1/E1 SPA、2 ポートおよび 4 ポート チャネライズド T3 SPA、2 ポートおよび 4 ポート クリア チャネル T3/E3 SPA、および 1 ポート チャネライズド OC-3/STM-1 SPA を搭載した Cisco 7600 SIP-200 に限定されます。


cRTP の設定方法の詳細は、次の URL にある『 Configuring Distributed Compressed Real-Time Protocol 』を参照してください。

http://www.cisco.com/en/US/docs/ios/12_2/qos/configuration/guide/qcfdcrtp.html

フレームリレー機能の設定

Catalyst 6500 シリーズ スイッチの FlexWAN および Enhanced FlexWAN モジュールでサポートされているフレームリレー機能の多くは、SIP でもサポートされています。SIP でサポートされているフレームリレー機能のリストは、「SIP および SSC の概要」を参照してください。

ここでは、SIP 固有の設定時の注意事項があるフレームリレー機能について説明します。このマニュアルに記載された SIP 固有の注意事項を確認してから、記載された URL を参照して、フレームリレー機能の設定に関する詳細を確認してください。

SIP および SPA に対応するフレームリレー機能は、SIP または SPA、あるいはその両方が結合して機能の処理を実行するため、 分散機能 と性格付けられます。

Cisco 7600 SIP-200 での Distributed Multilink Frame Relay(FRF.16)の設定

distributed Multilink Frame Relay(dMLFR)機能は複数のシリアル リンクを 1 つの帯域幅に集約して、特定のアプリケーションの帯域幅を優れた費用対効果で増加させます。Multilink Frame Relay(MLFR)は、フレームリレー ネットワーク内の User-Network Interface(UNI)および Network-to-Network Interface(NNI)でサポートされています。


) dMLFR はリンク構成に応じて、Cisco 7600 SIP-200 上でソフトウェア ベースにすることも、8 ポート チャネライズド T1/E1 SPA、2 ポートおよび 4 ポート チャネライズド T3 SPA、および 1 ポート チャネライズド OC-3/STM-1 SPA 上でハードウェア ベースにすることもできます。ハードウェア ベース設定の詳細は、「8 ポート チャネライズド T1/E1 SPA の設定」「2 ポートおよび 4 ポート チャネライズド T3 SPA の設定」および「1 ポート チャネライズド OC-3/STM-1 SPA の設定」を参照してください。


表 4-1 に、SPA インターフェイスの dMLFR 機能がサポートされる状況を示します。

 

表 4-1 SIP および SPA の組み合わせに基づく dMLFR 機能の互換性

機能
Cisco 7600 SIP-200
Cisco 7600 SIP-400
Cisco 7600 SIP-600

ハードウェア ベースの dMLFR

Cisco IOS Release 12.2(18)SXE 以上

8 ポート チャネライズド T1/E1 SPA

2 ポートおよび 4 ポート チャネライズド T3 SPA

サポートされていません。

サポートされていません。

ハードウェアおよびソフトウェア ベースの dMLFR

Cisco IOS Release 12.2(33)SXH 以上

8 ポート チャネライズド T1/E1 SPA

2 ポートおよび 4 ポート チャネライズド T3 SPA

1 ポート チャネライズド OC-3/STM-1 SPA

サポートされていません。

サポートされていません。

この項の内容は、次のとおりです。

「dMLFR の概要」

「dMLFR の設定時の注意事項」

「dMLFR の設定作業」

「dMLFR の確認」

dMLFR の概要

Distributed Multilink Frame Relay(dMLFR)機能を使用すると、 バンドル または バンドル インターフェイス という名前の仮想インターフェイスを作成できます。バンドル インターフェイスは、フレーム トランスポート用の物理インターフェイスをエミュレートします。フレームリレー データ リンクはバンドル インターフェイスで動作し、この上にフレームリレー仮想回線が構築されます。

バンドルは バンドル リンク という名前の複数のシリアル リンクで構成されます。バンドル内の各バンドル リンクは、特定の物理インターフェイスに対応しています。バンドル リンクはフレームリレー データリンク レイヤからは参照できないため、これらのインターフェイスにフレームリレー機能を設定できません。これらのリンクに適用する正規のフレームリレー機能は、バンドル インターフェイスに設定する必要があります。バンドル リンクはピア デバイスから参照できます。ローカル スイッチおよびピア デバイスはリンク インテグリティ プロトコル制御メッセージを交換して、動作可能なバンドル リンクを判別し、バンドル リンクとバンドルの対応関係を同期化します。

リンク管理のために、バンドル リンクの両端は dMLFR リンク インテグリティ プロトコルに従い、リンク制御メッセージをピア(バンドル リンクの他端)と交換します。バンドル リンクを起動するには、リンクの両端で ADD_LINK および ADD_LINK_ACK メッセージの交換を完了する必要があります。リンクを維持するには、リンクの両端で定期的に HELLO および HELLO_ACK メッセージを交換します。この hello メッセージおよび確認応答の交換は、リンクのキープアライブ メカニズムとして機能します。スイッチが hello メッセージを送信しているにもかかわらず、確認応答を受信しない場合は、設定された最大回数を上限として hello メッセージを再送信します。スイッチの試行回数が最大値に達すると、バンドル リンク ライン プロトコルはダウンしている(動作不能)と見なされます。

ピア デバイスがバンドルと同じリンクを使用することを確認応答した場合、バンドル リンク インターフェイスのライン プロトコル ステータスはアップ(動作可能)と見なされます。ピア デバイスがローカル スイッチからの hello メッセージに確認応答した場合、ライン プロトコルはアップのままです。

バンドル リンクのライン プロトコル ステータスが 1 つでもアップになると、バンドル インターフェイスのライン ステータスもアップになります。アップ状態のバンドル リンクがなくなると、バンドル インターフェイスのライン ステータスはダウンになります。この動作は、FRF.16 で定義されたクラス A 帯域幅の要件に適合します。

Local Management Interface(LMI; ローカル管理インターフェイス)がイネーブル化されているときに、ローカル スイッチおよびピア デバイスのフレームリレー データリンク レイヤが LMI を使用して同期化している場合は、バンドル インターフェイスのライン プロトコル ステータスはアップと見なされます。LMI キープアライブに成功している間は、バンドル ライン プロトコルはアップのままです。

dMLFR の設定時の注意事項

Cisco 7600 SIP-200 で dMLFR をサポートするには、次の注意事項に従ってください。

ピア デバイスに dMLFR を設定する必要があります。

アセンブリが必要なフレームを dMLFR ピア デバイスから送信しないでください。

Cisco 7600 SIP-200 は次の場合に分散リンクをサポートします。

すべてのリンクが同じ Cisco 7600 SIP-200 上にある。

バンドル内に T1 および E1 リンクを混在できない。

バンドル内の T1 リンクまたは E1 リンクに同じ帯域幅を設定することが推奨されている。

QoS は dMLFR 対応の Cisco 7600 SIP-200 で実装されます。

dMLFR は、Cisco 7600 SIP-200 ではソフトウェアで、またはサポート対象の 2 ポートおよび 4 ポート チャネライズド T3 SPA、8 ポート チャネライズド T1/E1 SPA、および 1 ポート チャネライズド OC-3/STM-1 SPA ではハードウェアでサポートされます。このサポートはリンク設定によって異なります。

ソフトウェア ベースの注意事項

次の いずれか の条件が満たされた場合、dMLFR はソフトウェアで実行されます。

いずれか 1 つのバンドル リンク メンバーがフラクショナル T1 または E1 リンクである。

バンドルに 12 より多くの T1 または E1 リンクが含まれている。

バンドル リンクは SPA で設定されているが、すべてのリンクが SPA の同じ タイプ 上にある。たとえば、8 ポート チャネライズド T1/E1 SPA 上のリンクは、2 ポートおよび 4 ポート チャネライズド T3 SPA 上のリンクに分散できません。

ハードウェア ベースの注意事項

次の条件が すべて 満たされると、dMLFR はハードウェアで実行されます。

すべてのバンドル リンク メンバーが T1 または E1 に限られる。

すべてのバンドル リンクが同じ SPA上にある。

バンドル内のリンク数が 12 以内である。

dMLFR の制約事項

Cisco 7600 SIP-200 上で dMLFR を設定する場合は、次の制約事項に配慮してください。

FRF.9 ハードウェア圧縮はサポートされません。

ソフトウェア圧縮はサポートされません。

暗号化はサポートされません。

ハードウェアでサポートされている最大差分遅延は 50 ms、ソフトウェアでサポートされている最大差分遅延は 100 ms です。

送信側では、フラグメンテーションはサポートされません。

Frame Relay fragmentation(FRF.12)はサポートされません。

dMLFR の設定作業

ここでは dMLFR の設定方法について説明します。

「dCEF スイッチングのイネーブル設定」(必須)

「マルチリンク フレームリレー バンドルの作成」(必須)

「dMLFR バンドルへのインターフェイスの割り当て」(必須)

dCEF スイッチングのイネーブル設定

dMLFR をイネーブルにするには、先に distributed CEF(dCEF)スイッチングをイネーブルにする必要があります。Catalyst 6500 シリーズ スイッチ上では、dCEF スイッチングはデフォルトでイネーブルになります。

dCEF をイネーブルにするには、グローバル コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

Router(config)# ip cef distributed

dCEF スイッチングをイネーブルにします。

マルチリンク フレームリレー バンドルの作成

dMLFR バンドル インターフェイスを設定するには、グローバル コンフィギュレーション モードから次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# interface mfr number

マルチリンク フレームリレー バンドル インターフェイスを設定し、インターフェイス コンフィギュレーション モードを開始します。

number :フレームリレー バンドルの番号を指定します。

ステップ 2

Router(config-if)# frame-relay multilink bid name

(任意)MLFR バンドルにバンドル識別名を割り当てます。

name :フレームリレー バンドルの名前を指定します。

コマンドを使用します。

ステップ 3

Router(config-if)# frame-relay intf-type dce

Digital Communications Equipment(DCE)装置として、またはスイッチとして動作するようにスイッチを設定します。

dMLFR バンドルへのインターフェイスの割り当て


) この手順で、同じバンドルの一部として 12 より多くの T1 または E1 インターフェイス リンクを割り当てた場合、またはいずれかの T1/E1 インターフェイス リンクがフラクショナル T1/E1 である場合、または同じバンドルに含まれるいずれかのリンクが複数の SPA に配置されている場合、Cisco 7600 SIP-200 によってソフトウェア ベースの MLFR が自動的に実装されます。


インターフェイス リンクを設定し、そのリンクを dMLFR バンドルのメンバーとして関連付けるには、グローバル コンフィギュレーション モードから次の作業を行います。この手順を繰り返して、dMLFR バンドルに複数のリンクを割り当てます。

 

コマンド
目的

ステップ 1

2 ポートおよび 4 ポート チャネライズド T3 SPA

Router(config)# interface serial slot/subslot/port/t1-number:channel-group

8 ポート チャネライズド T1/E1 SPA

Router(config)# interface serial slot/subslot/port:channel-group

シリアル インターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

slot :SIP が搭載されたシャーシ スロット番号を指定します。

subslot :SIP が搭載された SPA のセカンダリ スロット番号を指定します。

port :SPA のインターフェイス ポートの番号を指定します。

t1-number :チャネライズド モードの論理 T1 番号を指定します。

channel-group :T1/E1 グループ内のタイム スロットに割り当てる論理チャネル グループを指定します。

(注) チャネル グループを使用して SPA 上でフラクショナル T1/E1 インターフェイスを設定し、そのフラクショナル T1/E1 チャネル グループをこの手順で指定した場合は、dMLFR バンドルにインターフェイスを割り当てた時点で、Cisco 7600 SIP-200 によってソフトウェア ベースの dMLFR が自動的に実装されます。

ステップ 2

Router(config-if)# encapsulation frame-relay mfr number [name]

MLFR バンドル リンクを作成し、このリンクにバンドルを対応付けます。

number :フレームリレー バンドルの番号を指定します。この番号は、 interface mfr コマンドで指定した dMLFR インターフェイス番号と一致させる必要があります。

name :(任意)フレームリレー バンドルの名前を指定します。

ステップ 3

Router(config-if)# frame-relay multilink lid name

(任意)MLFR バンドル リンクにバンドル リンク識別名を割り当てます。

name :フレームリレー バンドルの名前を指定します。

コマンドを使用します。

ステップ 4

Router(config-if)# frame-relay multilink hello seconds

(任意)バンドル リンクが hello メッセージを送信する間隔を設定します。

seconds :マルチリンク バンドルを介して送信される hello メッセージの送信間隔を秒数で指定します。デフォルトは 10 秒です。

ステップ 5

Router(config-if)# frame-relay multilink ack seconds

(任意)バンドル リンクが hello メッセージを再送信するまで、hello メッセージの確認応答を待機する秒数を設定します。

seconds :バンドル リンクが hello メッセージを再送信するまで、hello メッセージの確認応答を待機する秒数を設定します。デフォルトは 4 秒です。

ステップ 6

Router(config-if)# frame-relay multilink retry number

(任意)バンドル リンクが確認応答を待機している間に、hello メッセージを再送信する最大回数を設定します。

number :バンドル リンクが確認応答を待機している間に、hello メッセージを再送信する最大回数を指定します。デフォルトは 2 回です。

dMLFR の確認

dMLFR の設定を確認するには、 show frame-relay multilink コマンドを使用します。オプションを指定しないで show frame-relay multilink コマンドを使用した場合は、すべてのバンドルおよびバンドル リンクの情報が表示されます。

次に、 serial number および detailed オプションを指定した場合の show frame-relay multilink コマンドの出力例を示します。指定したバンドル リンクの詳細情報が表示されます。

Router# show frame-relay multilink serial6 detailed
 
Bundle: MFR49, State = down, class = A, fragmentation disabled
BID = MFR49
No. of bundle links = 1, Peer's bundle-id =
Bundle links:
 
Serial6/0/0:0, HW state = up, link state = Add_sent, LID = test
Cause code = none, Ack timer = 4, Hello timer = 10,
Max retry count = 2, Current count = 0,
Peer LID = , RTT = 0 ms
Statistics:
Add_link sent = 21, Add_link rcv'd = 0,
Add_link ack sent = 0, Add_link ack rcv'd = 0,
Add_link rej sent = 0, Add_link rej rcv'd = 0,
Remove_link sent = 0, Remove_link rcv'd = 0,
Remove_link_ack sent = 0, Remove_link_ack rcv'd = 0,
Hello sent = 0, Hello rcv'd = 0,
Hello_ack sent = 0, Hello_ack rcv'd = 0,
outgoing pak dropped = 0, incoming pak dropped = 0

Cisco 7600 SIP-200 での dML PPP の設定

distributed Multilink Point-to-Point Protocol(dMLPPP)機能を使用すると、T1/E1 回線をバンドルに結合して、複数の T1/E1 回線の帯域幅を束ねることができます。この機能は dMLPPP リンクを使用して実行されます。バンドルごとにバンドル数および T1/E1 回線数を選択します。これにより、T3 回線を購入しなくても、ネットワーク リンクの帯域幅を単一 T1/E1 回線の帯域幅よりも大きくすることができます。


) dMLPPP はリンク構成に応じて、Cisco 7600 SIP-200 上でソフトウェア ベースにすることも、8 ポート チャネライズド T1/E1 SPA および 2 ポートおよび 4 ポート チャネライズド T3 SPA 上でハードウェア ベースにすることもできます。ハードウェア ベース設定の詳細は、「8 ポート チャネライズド T1/E1 SPA の設定」「2 ポートおよび 4 ポート チャネライズド T3 SPA の設定」および「1 ポート チャネライズド OC-3/STM-1 SPA の設定」を参照してください。


この項の内容は、次のとおりです。

「dMLPPP の設定時の注意事項」

「dMLPPP の設定作業」

「MLPPP の確認」

dMLPPP の設定時の注意事項

dMLPPP は、Cisco 7600 SIP-200 ではソフトウェアで、またはサポート対象の 2 ポートおよび 4 ポート チャネライズド T3 SPA、8 ポート チャネライズド T1/E1 SPA、および 1 ポート チャネライズド OC-3/STM-1 SPA ではハードウェアでサポートされます。このサポートはリンク設定によって異なります。

Cisco 7600 SIP-200 は次の場合に分散リンクをサポートします。

すべてのリンクが同じ Cisco 7600 SIP-200 上にある。

バンドル内に T1 および E1 リンクを混在できない。

バンドル内の T1 リンクまたは E1 リンクに同じ帯域幅を設定することが推奨されている。

QoS は dMLPPP 対応の Cisco 7600 SIP-200 で実装されます。

ソフトウェア ベースの注意事項

次の いずれかの 条件が満たされた場合、dMLPPP はソフトウェアで実装されます。

いずれか 1 つのバンドル リンク メンバーがフラクショナル T1 または E1 リンクである。

バンドルに 12 より多くの T1 または E1 リンクが含まれている。

バンドル リンクが SPA で設定されている。

ソフトウェア ベース dMLPPP のフラグメンテーションをイネーブルにするには、 ppp multilink interleave コマンドを設定する必要があります。ハードウェア ベース dMLPPP でフラグメンテーションをイネーブルにする場合は、このコマンドは不要です。

ハードウェア ベースの注意事項

次の条件がすべて満たされると、dMLPPP はハードウェアで実行されます。

すべてのバンドル リンク メンバーが T1 または E1 に限られる。

すべてのバンドル リンクが同じ SPA上にある。

バンドル内のリンク数が 12 以内である。

dMLPPP の制約事項

Cisco 7600 SIP-200 上で dMLPPP を設定する場合は、次の制約事項に配慮してください。

SPA 上 で dMLPPP がサポートされません。

ハードウェア圧縮およびソフトウェア圧縮はサポートされません。

暗号化はサポートされません。

ハードウェアでサポートされている最大差分遅延は 50 ms、ソフトウェアでサポートされている最大差分遅延は 100 ms です。

dMLPPP の設定作業

ここでは MLPPP の設定方法について説明します。

「dCEF スイッチングのイネーブル設定」(必須)

「dMLPPP バンドルの作成」(必須)

「dMLPPP バンドルへのインターフェイスの割り当て」(必須)

「LFI over dMLPPP の設定」(任意)

dCEF スイッチングのイネーブル設定

dMLPPP をイネーブルにするには、先に distributed CEF(dCEF)スイッチングをイネーブルにする必要があります。Cisco 7600 シリーズ ルータ上では、dCEF スイッチングはデフォルトでイネーブルになります。

dCEF をイネーブルにするには、グローバル コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

Router(config)# ip cef distributed

dCEF スイッチングのイネーブル設定

dMLPPP バンドルの作成

dMLPPP バンドルを設定するには、グローバル コンフィギュレーション モードから次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# interface multilink group-number

マルチリンク インターフェイスを作成し、インターフェイス コンフィギュレーション モードを開始します。

group-number :マルチリンク バンドルのグループ番号を指定します。

ステップ 2

Router(config-if)# ip address ip-address mask

マルチリンク グループの IP アドレスを設定します。

ip-address :インターフェイスの IP アドレスを指定します。

mask :対応する IP サブネットのマスクを指定します。

ステップ 3

Router(config-if)# ppp multilink interleave

(任意:ソフトウェア ベースの LFI)マルチリンク バンドルに割り当てたインターフェイスに対して、フラグメンテーションをイネーブルにします。フラグメンテーションは、ソフトウェア ベース LFI ではディセーブルがデフォルトです。

ステップ 4

Router(config-if)# ppp multilink fragment-delay delay

(任意)マルチリンク バンドルに設定された遅延を満たすフラグメンテーション サイズを設定します。

delay :遅延をミリ秒で指定します。

dMLPPP バンドルへのインターフェイスの割り当て


) この手順で、同じバンドルとして 12 より多くの T1 または E1 インターフェイス リンクを割り当てた場合、またはいずれかの T1/E1 インターフェイス リンクがフラクショナル T1/E1 である場合、または同じバンドルに含まれるいずれかのリンクが複数の SPA に配置されている場合、Cisco 7600 SIP-200 によってソフトウェア ベースの dMLPPP が自動的に実装されます。


インターフェイス PPP リンクを設定し、そのリンクをマルチリンク バンドルのメンバーとして関連付けるには、グローバル コンフィギュレーション モードから次の作業を行います。この手順を繰り返して、dMLPPP バンドルに複数のリンクを割り当てます。

 

コマンド
目的

ステップ 1

2 ポートおよび 4 ポート チャネライズド T3 SPA

Router(config)# interface serial slot/subslot/port/t1-number:channel-group

8 ポート チャネライズド T1/E1 SPA

Router(config)# interface serial slot/subslot/port:channel-group

シリアル インターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

slot :SIP が搭載されたシャーシ スロット番号を指定します。

subslot :SIP が搭載された SPA のセカンダリ スロット番号を指定します。

port :SPA のインターフェイス ポートの番号を指定します。

t1-number :チャネライズド モードの論理 T1 番号を指定します。

channel-group :T1 または E1 グループ内のタイム スロットに割り当てる論理チャネル グループを指定します。

(注) チャネル グループを使用して SPA 上でフラクショナル T1/E1 インターフェイスを設定し、そのフラクショナル T1/E1 チャネル グループをこの手順で指定した場合は、MLPPP バンドルにインターフェイスを割り当てた時点で、Cisco 7600 SIP-200 によってソフトウェア ベースの MLPPP が自動的に実装されます。

ステップ 2

Router(config-if)# encapsulation ppp

PPP カプセル化をイネーブルにします。

ステップ 3

Router(config-if)# ppp multilink

(任意)インターフェイス上で MLPPP をイネーブルにします。

ステップ 4

Router(config-if)# multilink-group group-number

マルチリンク バンドルにインターフェイスを割り当てます。

group-number :マルチリンク バンドルのグループ番号を指定します。この番号は、 interface multilink コマンドで指定した MLPPP インターフェイス番号と一致させる必要があります。

ステップ 5

Router(config-if)# ppp authentication chap

(任意)Challenge Handshake Authentication Protocol(CHAP)認証をイネーブルにします。

LFI over dMLPPP の設定

Link fragmentation and interleaving(LFI)over dMLPPP は、Cisco 7600 SIP-200 上ではソフトウェアで、2 ポートおよび 4 ポート チャネライズド T3 SPA および 8 ポート チャネライズド T1/E1 SPA ではハードウェアでサポートされます。このサポートはリンク設定によって異なります。

ソフトウェア ベースの注意事項

LFI over dMLPPP を設定する場合は、ソフトウェア ベース LFI に関する次の注意事項に従ってください。

dMLPPP バンドルに複数のリンクを割り当てた場合、LFI over dMLPPP はソフトウェアで設定されます。

LFI は、ソフトウェア ベース LFI ではディセーブルがデフォルトです。マルチリンク インターフェイスで LFI をイネーブルにするには、 ppp multilink interleave コマンドを使用します。

フラグメンテーション サイズは、設定した遅延およびメンバー リンクの帯域幅に基づいて算出されます。

マルチリンク インターフェイスの下のプライオリティ クラスを指定して、ポリシー マップを設定する必要があります。

ハードウェア ベースの注意事項

LFI over dMLPPP を設定する場合は、ハードウェア ベース LFI に関する次の注意事項に従ってください。

MLPPP バンドルにリンク(T1/E1 またはフラクショナル T1/E1)を 1 つだけ割り当てた場合、LFI over dMLPPP はハードウェアで設定されます。

ハードウェア ベース LFI では LFI がイネーブルにデフォルト設定されており、デフォルト サイズは 512 バイトです。シリアル インターフェイスで LFI をイネーブルにするには、 ppp multilink interleave コマンドを使用します。

マルチリンク インターフェイスには、特定のプライオリティ クラスを含むポリシー マップを適用する必要があります。

MLPPP の確認

dMLPPP の設定を確認するには、 show ppp multilink コマンドを使用します。次の例を参照してください。

Router# show ppp multilink
 
Multilink2, bundle name is group2
Bundle up for 00:01:21
Bundle is Distributed
0 lost fragments, 0 reordered, 0 unassigned
0 discarded, 0 lost received, 1/255 load
0x0 received sequence, 0x0 sent sequence
Member links: 2 active, 0 inactive (max not set, min not set)
Se4/3/0/1:0, since 00:01:21, no frags rcvd
Se4/3/0/1:1, since 00:01:19, no frags rcvd
 

SPA 上でハードウェア ベースの MLPPP を設定した場合、 show ppp multilink コマンドを実行すると、「Multilink in Hardware」が表示されます。次の例を参照してください。

Router# show ppp multilink
 
Multilink1, bundle name is group1
Bundle up for 00:00:13
Bundle is Distributed
0 lost fragments, 0 reordered, 0 unassigned
0 discarded, 0 lost received, 206/255 load
0x0 received sequence, 0x0 sent sequence
Member links: 2 active, 0 inactive (max not set, min not set)
Se4/2/0/1:0, since 00:00:13, no frags rcvd
Se4/2/0/2:0, since 00:00:10, no frags rcvd
Distributed fragmentation on. Fragment size 512. Multilink in Hardware.
 

フレームリレーおよび ATM インターフェイスの dLFI の設定

distributed Link Fragmentation and Interleaving(dLFI)機能は、低速のフレームリレー Virtual Circuit(VC; 仮想回線)や ATM VC 上、および専用線上で、音声などのリアルタイム トラフィックや、データなどの非リアルタイム トラフィックのトランスポートをサポートします。リアルタイム トラフィックに極端な遅延は発生しません。

この機能はフレームリレー、ATM、および専用線を介した dMLPPP を使用して実行されます。この機能を使用すると、サイズの大きいデータ パケットを一連の小さいデータ パケット(フラグメント)に分割して、遅延に依存するリアルタイム パケットと非リアルタイム パケットで同じリンクを共有できるようにします。その後、フラグメントはリアルタイム パケットとインターリーブされます。リンクの受信側では、フラグメントが再度組み立てられ、パケットが再構築されます。

通常、dLFI 機能が役立つのは、Distributed Low Latency Queueing を使用して音声などのリアルタイム トラフィックを送信するネットワークですが、帯域幅問題(時間に依存しない大きいデータ パケットの転送によって、このリアルタイム トラフィックに遅延が生じる)が発生します。これらのネットワークで dLFI 機能を使用すると、サイズの大きいデータ パケットを複数のセグメントに分割できます。これらのデータ パケット セグメントの合間に、リアルタイム トラフィック パケットを送信できます。この場合、リアルタイム トラフィックは、低いプライオリティのデータ パケットがネットワークを通過するまで長時間待機しなくて済みます。データ パケットはリンクの受信側で再度組み立てられるため、データは完全な形で配信されます。

dMLPPP を使用している場合に、Modular QoS CLI(MQC; モジュラ QoS CLI)を使用して Quality of Service(QoS)を設定する機能も、dLFI 機能の一部として導入されています。

dLFI の設定方法は、次の URL にある『 FlexWAN and Enhanced FlexWAN Module Installation and Configuration Note 』を参照してください。

http://www.cisco.com/en/US/docs/routers/7600/install_config/flexwan_config/flexwan-config-guide.html

ATM SPA 上での dLFI の設定は、「ATM SPA の設定」「仮想テンプレートを使用する LFI の設定」を参照してください。

表 4-2 に、SPA インターフェイスの dLFI 機能がサポートされる状況を示します。

 

表 4-2 SIP および SPA の組み合わせに基づく dLFI 機能の互換性

機能
Cisco 7600 SIP-200
Cisco 7600 SIP-400
Cisco 7600 SIP-600

ハードウェア ベースの dLFI

Cisco IOS Release 12.2(18)SXE 以上

8 ポート チャネライズド T1/E1 SPA

2 ポートおよび 4 ポート チャネライズド T3 SPA

サポートされていません。

サポートされていません。

ハードウェアおよびソフトウェア ベースの dLFI

Cisco IOS Release 12.2(33)SXH 以上

8 ポート チャネライズド T1/E1 SPA

2 ポートおよび 4 ポート チャネライズド T3 SPA

1 ポート チャネライズド OC-3/STM-1 SPA

サポートされていません。

サポートされていません。

MPLS を使用する dLFI

サポートされていません。

サポートされていません。

サポートされていません。

Catalyst 6500 シリーズ スイッチの LFI に関する制約事項

Catalyst 6500 シリーズ スイッチ上で LFI を設定する場合は、次の制約事項に配慮してください。

Catalyst 6500 シリーズ スイッチに搭載されたすべての ATM SPA(またはその他の ATM モジュール)では、Link Fragmentation and Interleaving(LFI)を使用する PVC または SVC を最大 200 まで設定できます。

FRF.12 を使用する LFI は、2 ポートおよび 4 ポート チャネライズド T3 SPA および 8 ポート チャネライズド T1/E1 SPA のハードウェアでだけサポートされます。

LFI over dMLPPP は、ご使用のリンク設定に応じて、ソフトウェアまたはハードウェアでサポートされます。ソフトウェア ベース LFI over dMLPPP の詳細は、「LFI over dMLPPP の設定」を参照してください。ハードウェア ベース LFI over dMLPPP の詳細は、「8 ポート チャネライズド T1/E1 SPA の設定」「2 ポートおよび 4 ポート チャネライズド T3 SPA の設定」および「1 ポート チャネライズド OC-3/STM-1 SPA の設定」を参照してください。

QoS は dLFI 対応の Cisco 7600 SIP-200 で実装されます。

VoFR(FRF.11 および FRF.12)の設定

Voice over Frame Relay(VoFR)は、スイッチが FRF.11 プロトコルを使用して、フレームリレー ネットワークを介して音声トラフィック(電話コール、Fax など)を伝送できるようにします。この仕様では、多重化データ、音声、Fax、Dual-Tone Multi-Frequency(DTMF)ディジット リレー、および Channel-Associated Signaling(CAS)/Robbed-Bit Signaling(RBS)フレーム フォーマットが定義されています。マップ クラスおよび LMI を含むように、フレームリレー バックボーンを設定する必要があります。

Cisco VoFR を実装すると、ダイナミックスイッチド コールとタンデムスイッチド コール、およびシスコ トランク コールがイネーブルになります。ダイナミックスイッチド コールには、電話番号に基づいてコールを処理およびルーティングするダイヤルプラン情報が含まれています。ダイヤルプラン情報はダイヤルピア エントリに格納されています。


) Catalyst 6500 シリーズ スイッチは音声モジュールをサポートしないため、SIP 上で FRF.11 または FRF.12 を設定した場合、Catalyst 6500 シリーズ スイッチは VoFR タンデム スイッチとしてだけ動作可能です。


タンデム スイッチド コールは、着信 VoFR から発信 VoFR 対応の Data-Link Connection Identifier(DLCI)にスイッチングされます。このプロセスはタンデム ノードでイネーブルになります。シスコ トランク コールもタンデム ノードでスイッチングされます。

永続的なコールは、フレームリレー ネットワーク上の音声トラフィックのフレーム フォーマットおよびコーダー タイプを指定する、シスコの専用線トランクおよびスタティック FRF.11 トランクを介して処理されます。

VoFR 接続は、ハードウェア プラットフォームおよびコール タイプによって決まります。コール タイプは次のとおりです。

スイッチド(ユーザがダイヤルしたコール、または自動リングダウン コールやタンデム コール)

パーマネント(シスコ トランク コールまたはスタティック FRF.11 トランク コール)

VoFR(FRF.11 および FRF.12)の設定方法は、次の URL にある『 Cisco IOS Voice, Video, and Fax Configuration Guide 』を参照してください。

http://www.cisco.com/en/US/docs/ios/12_2/voice/configuration/guide/vvfvofr.html

SIP でのレイヤ 2 インターワーキング機能の設定

ここでは、SIPでのレイヤ 2 インターワーキング機能の設定に関するCatalyst 6500 シリーズ スイッチ固有の情報を示します。内容は、次のとおりです。

「MPB の設定」

「PPP BCP サポートの設定」

「Virtual Private LAN Service(VPLS)の設定」

「非対称キャリア遅延の設定」

MPB の設定


) Cisco IOS Release 12.2(18)SXE からは、MPB は、2 ポートおよび 4 ポート OC-3c/STM-1 ATM SPA および Cisco 7600 SIP-200 が搭載された Catalyst 6500 シリーズ スイッチ でサポートされています。また、8 ポート チャネライズド T1/E1 SPA、1 ポート チャネライズド OC-3/STM-1 SPA、2 ポートおよび 4 ポート クリア チャネル T3/E3 SPA、および 2 ポートおよび 4 ポート チャネライズド T3 SPA を含め、Cisco 7600 SIP-200 を搭載したシリアル SPA でサポートされます。


Multipoint bridging(MPB)を使用すると、ATM Permanent Virtual Circuit(PVC; 相手先固定接続)のポイントツーマルチポイントと、フレームリレー Data-Link Connection Identifier(DLCI)がイネーブルになります。これはサポート対象の WAN ラインカード上でのブリッジングで、複数の VC または DLCI を VLAN ごとに使用できる機能です。MPB を使用することにより、サービス プロバイダーは、既存の ATM レガシー ネットワークやフレームリレー レガシー ネットワークの実績のあるテクノロジーに、イーサネットベース レイヤ 2 サービスのサポートを追加できます。カスタマーは ATM またはフレームリレー クラウドを介して、現在の VLAN ベース ネットワークを使用できます。これにより、サービス プロバイダーは既存のカスタマー ベースをサポートしながら、コア ネットワークを最新のギガビット イーサネット光テクノロジーへと段階的に移行できます。

ATM インターフェイスでは RFC 1483 ブリッジングを、フレームリレー インターフェイスでは RFC 1490 ブリッジングを使用します。どちらも、各タイプのレイヤ 2 ネットワークを介してイーサネット フレームを転送するためのカプセル化方式を提供します。


) RFC 1483 は廃止されていて、RFC 2684『Multiprotocol Encapsulation over ATM Adaptation Layer 5』に置き換えられています。RFC 1490 は廃止されていて、RFC 2427『Multiprotocol Interconnect over Frame Relay』に置き換えられています。混乱を避けるために、このマニュアルでは元の RFC 番号を引き続き使用します。


MPB の設定方法の詳細は、次の URL にある『 FlexWAN and Enhanced FlexWAN Module Installation and Configuration Note 』を参照してください。

http://www.cisco.com/en/US/docs/routers/7600/install_config/flexwan_config/flexwan-config-guide.html

PPP BCP サポートの設定

SIP および SPA の Bridging Control Protocol(BCP)機能は、シリアルおよび SONET ネットワークを介したイーサネット フレームの転送を可能にし、メトロポリタン エリアを通過するエンタープライズ LAN バックボーン トラフィックを高速で拡散させます。SPA に BCP を実装すると、IEEE 802.1D スパニング ツリー プロトコル、IEEE 802.1Q VLAN(仮想 LAN)、および高速スイッチング LAN のサポートも実装されます。

BCP 機能は、RFC 3518『 Point-to-Point Protocol (PPP) Bridging Control Protocol (BCP) 』で規定されている BCP サポートをシスコの装置に提供します。シスコの BCP は、イーサネット 802.1Q トランクおよび対応する PPP リンクのグループ化にサブインターフェイスを使用する必要のない、VLAN インフラストラクチャです。この方式により、ユーザは使用する可能性のあるあらゆる VLAN 構成にサブインターフェイスを設定しなくても、VLAN カプセル化パケットを処理できます。

さらに、Cisco IOS Release 12.2(33) SXH 以降では、Cisco 7600 SIP-200 および 2 ポートおよび 4 ポート チャネライズド T3 SPA を搭載した 8 ポート チャネライズド T1/E1 SPA の dMLPPP リンク上で BCP がサポートされます。dMLPPP を介した BCP がサポートされるのは、トランク モード( switchport )の場合だけです。ここでは 1 つの BCP リンクで複数の VLAN を伝送できます。

BCP の設定時の注意事項

Cisco 7600 SIP-200 上で SPA で BCP サポートを設定する場合は、次の注意事項に従ってください。

ブリッジド インターフェイス上での QoS は、Cisco IOS Release 12.2(33)SXH およびそれ以降のリリースでサポートされています。それ以前のリリースでは、ブリッジド インターフェイス上で QoS はサポートされません。

トランク モードでの BCP の設定

トランク モードで BCP を設定すると、1 つの BCP リンクで複数の VLAN を伝送できるようになります。BCP トランク モードの動作は、標準のイーサネット トランク ポートの動作と整合性があります。

トランク モード BCP の設定時の注意事項

Cisco 7600 SIP-200 上で SPA にトランク モードの BCP サポートを設定する場合は、次の注意事項に従ってください。

イーサネット トランク ポートと BCP トランク ポートには、いくつか相違があります。

イーサネット トランク ポートは Inter Switch Link(ISL; スイッチ間リンク)および 802.1Q カプセル化をサポートしますが、BCP トランク ポートがサポートするのは 802.1Q だけです。

イーサネット トランク ポートは Dynamic Trunk Protocol(DTP; ダイナミック トランク プロトコル)をサポートします。DTP を使用してリンクのトランキング ステータスが自動的に判別されます。BCP トランク ポートは常にトランク ステートであり、DTP ネゴシエーションは実行されません。

イーサネット トランク ポートは、トランク上のすべての VLAN を許可するのがデフォルトの動作です。BCP トランクの場合は、すべての VLAN を禁止するのがデフォルトの動作です。したがって、許可すべき VLAN を BCP トランク ポート上で明示的に設定する必要があります。

トランク モード BCP を設定する場合は、WAN インターフェイスで switchport コマンドを使用します。

SIP が 1 つの VLAN でサポートする BCP ポートの最大数は、次のとおりです。

Cisco IOS Release 12.2(18)SXE 以上:最大 60 の BCP ポート

Cisco IOS Release 12.2(33)SXH 以上:Cisco 7600 SIP-200 の最大 112 の BCP ポート

トランク モード BCP で VLAN を使用するには、 vlan コマンドで VLAN データベースに VLAN を手動で追加する必要があります。トランク モード BCP はデフォルトの動作として、VLAN をどれも許可しません。

トランク モード BCP は、VLAN ID 0、1006 ~ 1023、および 1025 ではサポートされません。

ネイティブ VLAN(1)は、トランク モード BCP に関して次の制約事項があります。

Cisco IOS 12.2SX ソフトウェア リリース:ネイティブ VLAN はサポートされていません。

Cisco IOS Release 12.2(33)SXH およびそれ以降のリリース:ネイティブ VLAN はサポートされます。

トランク モード BCP(スイッチ ポート)の場合、STP のインターオペラビリティはイーサネットのスイッチ ポートの場合と同じです。したがって、WAN リンクの STP パス コストを変更できます。また、BPDU Guard、PortFast など、その他の STP 機能が WAN リンク上で動作します。しかし、デフォルト値を変更しないことをお勧めします。

VLAN Trunking Protocol(VTP; VLAN トランキング プロトコル)はサポートされます。


) 管理 VLAN である VLAN 1 をトランク上で明示的にイネーブルにして、VTP アドバタイズを送信する必要があります。


トランク モードで BCP を設定するには、グローバル コンフィギュレーション モードから次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# vlan dot1q tag native

(任意)トランクのすべての VLAN に対して dot1q タギングをイネーブルにします。デフォルトでは、ネイティブ VLAN 上のパケットはタグなしで送信されます。dot1q タギングをイネーブルにすると、ネイティブ VLAN ID を使用してパケットにタグが付けられます。

ステップ 2

2 ポートおよび 4 ポート チャネライズド T3 SPA

Router(config)# interface serial slot/subslot/port/t1-number:channel-group

8 ポート チャネライズド T1/E1 SPA

Router(config)# interface serial slot/subslot/port:channel-group

インターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

slot :SIP が搭載されたシャーシ スロット番号を指定します。

subslot :SIP が搭載された SPA のセカンダリ スロット番号を指定します。

port :SPA のインターフェイス ポートの番号を指定します。

t1-number :チャネライズド モードの論理 T1 番号を指定します。

channel-group :T1 または E1 グループ内のタイム スロットに割り当てる論理チャネル グループを指定します。

ステップ 3

Router(config-if)# switchport

レイヤ 3 モードのインターフェイスをレイヤ 2 コンフィギュレーションに対応するレイヤ 2 モードにします。PPP カプセル化が自動的に設定され、トランク モードで非ネゴシエーション ステータスとして、インターフェイスが自動的に設定されます。

ステップ 4

Router(config-if)# shutdown

インターフェイスをディセーブルにします。

ステップ 5

Router(config-if)# no shutdown

ディセーブル化されたインターフェイスを再起動します。

ステップ 6

Router(config-if)# switchport trunk allowed vlan { all | { add | remove | except } vlan-list [, vlan-list ...] | vlan-list [, vlan-list ...]}

(任意)トランク上でトラフィックを送受信できる VLAN を制御します。

all :該当するすべての VLAN をイネーブルにします。

add vlan-list [ , vlan-list ... ] :指定した VLAN リストに置き換えるのではなく、そのリストを現在のセットに付加します。

remove vlan-list [ , vlan-list... ] :VLAN リストを置き換えるのではなく、指定したリストを現在のセットから削除します。

except vlan-list [ , vlan-list... ] :VLAN リストを置き換えるのではなく、指定したリストを現在のセットから除外します。

vlan-list [ , vlan-list... ] 1 ~ 4094 の VLAN 番号を 1 つ指定するか、または 1 ~ 4094 の 2 つの VLAN 番号で規定した、連続する VLAN の範囲を指定します。カンマで区切ったリストを使用することによって、複数の VLAN 番号または範囲を指定できます。

VLAN 範囲を指定する場合は、小さい方の VLAN 番号を先に入力してハイフンで区切り、範囲の終わりとして大きい方の VLAN 番号を入力します。

(注) スーパーバイザ エンジンと MSFC の両方で Cisco IOS ソフトウェアが動作している Cisco 7600 シリーズ ルータを Catalyst オペレーティング システムが動作している Cisco 7600 シリーズ ルータに接続する場合は、トランク上で予約済みの VLAN 範囲(1006 ~ 1024)をイネーブルにできません。これらの VLAN は、Catalyst オペレーティング システムが動作している Cisco 7600 シリーズ ルータで予約済みです。これらの VLAN をイネーブルにすると、これらのシステム間にトランキング チャネルが存在した場合に、Catalyst オペレーティング システムが動作している Cisco 7600 シリーズ ルータがポートを error-disable 処理する可能性があります。

トランク モードの BCP の確認

PPP リンクはフラップ(ダウンさせた後に再ネゴシエーション)する必要があるため、トランク モードで BCP を設定した後で、次の show コマンドを実行して設定を確認することが重要です。

 

コマンド
目的

2 ポートおよび 4 ポート チャネライズド T3 SPA

Router# show interfaces [ serial slot/subslot/port/t1-number:channel-group ] trunk [ module number ]

8 ポート チャネライズド T1/E1 SPA

Router# show interfaces [ serial slot/subslot/port:channel-group ] trunk [ module number ]

インターフェイス トランク情報を表示します。

slot :SIP が搭載されたシャーシ スロット番号を指定します。

subslot :SIP が搭載された SPA のセカンダリ スロット番号を指定します。

port :SPA のインターフェイス ポートの番号を指定します。

t1-number :チャネライズド モードの論理 T1 番号を指定します。

channel-group :T1 または E1 グループ内のタイム スロットに割り当てる論理チャネル グループを指定します。

module number :(任意)SIP のシャーシ スロット番号を指定し、その SIP に搭載された SPA のすべてのインターフェイスについて情報を表示します。

 

コマンド
目的

2 ポートおよび 4 ポート チャネライズド T3 SPA

Router# show interfaces [ serial slot/subslot/port/t1-number:channel-group ] switchport [ module number ]

8 ポート チャネライズド T1/E1 SPA

Router# show interfaces [ serial slot/subslot/port:channel-group ] switchport [ module number ]

スイッチング(非ルーティング)ポートの管理ステータスおよび動作ステータスを表示します。

slot :SIP が搭載されたシャーシ スロット番号を指定します。

subslot :SIP が搭載された SPA のセカンダリ スロット番号を指定します。

port :SPA のインターフェイス ポートの番号を指定します。

t1-number :チャネライズド モードの論理 T1 番号を指定します。

channel-group :T1 または E1 グループ内のタイム スロットに割り当てる論理チャネル グループを指定します。

module number :(任意)SIP のシャーシ スロット番号を指定し、その SIP に搭載された SPA のすべてのインターフェイスについて情報を表示します。

show interfaces コマンドの出力例を示します。BCP がトランク モードで設定されている場合に表示される情報の例です。


) スイッチ ポートが設定されている場合は、カプセル化が PPP に自動的に変更されます。


Router# show interfaces trunk
Port Mode Encapsulation Status Native vlan
PO4/1/0 on 802.1q trunking 1
 
Port Vlans allowed on trunk
PO4/1/0 1-1005,1025-1026,1028-4094
 
Port Vlans allowed and active in management domain
PO4/1/0 1,100,200
 
Port Vlans in spanning tree forwarding state and not pruned
PO4/1/0 1,100,200
 
Router# show interfaces switchport
 
Name: PO4/1/0
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: down
Administrative Trunking Encapsulation: dot1q
Negotiation of Trunking: Off
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Voice VLAN: none
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk private VLANs: none
Operational private-vlan: none
Trunking VLANs Enabled: 100
Pruning VLANs Enabled: 2-1001
Capture Mode Disabled
Capture VLANs Allowed: ALL
 
Unknown unicast blocked: disabled
Unknown multicast blocked: disabled
 

Virtual Private LAN Service(VPLS)の設定

Virtual Private LAN Service(VPLS)はプロバイダー コアを使用して、地理的に分離された LAN セグメントをまとめる仮想ブリッジをシミュレートします。カスタマーから見ると、VPLS のトポロジは存在しません。すべての CE デバイスは、プロバイダー コアでエミュレートされる論理ブリッジに接続されているように見えます。

VPLS を使用すると、IP、MPLS、または両方のハイブリッドといったパケット スイッチド ネットワークを介して、地理的に分離された LAN セグメントを 1 つのブリッジド ドメインとして相互接続できます。

SIP 上で VPLS を設定する詳細は、次の URL にある、Cisco 7600 シリーズ ルータの『 OSM Configuration Note 』の「Virtual Private LAN Services on the Optical Services Modules」を参照してください。

http://www.cisco.com/en/US/docs/routers/7600/install_config/12.2SR_OSM_config/mpls.html#wp1423607

フルメッシュ、ハブ アンド スポーク、MPLS エッジを伴う Hierarchical VPLS(H-VPLS)の設定を使用できます。

フルメッシュの設定

フルメッシュの設定では、VPLS に参加するすべての PE 間でトンネル Label Switched Path(LSP; ラベル スイッチド パス)のフルメッシュが必要です。フルメッシュでは、シグナリングのオーバーヘッドと、PE 上でプロビジョニング対象の各 VC に対するパケット複製の要件が多くなる場合があります。

VPLS のセットアップは、まず参加する各 PE ルータで Virtual Forwarding Instance(VFI)を作成して行います。VFI によって VPLS ドメインの VPN ID、そのドメインの他の PE ルータのアドレス、トンネルのシグナリングのタイプ、各ピア PE ルータのカプセル化のメカニズムが指定されます。

エミュレーテッド VC の相互接続で形成される VFI のセットは、VPLS インスタンスと呼ばれます。これは、パケット スイッチド ネットワークを介して論理ブリッジを構成する VPLS インスタンスです。VPLS インスタンスには、一意の VPN ID が割り当てられます。

PE ルータは、VFI を使用して、エミュレートされた VC から VPLS インスタンスの他のすべての PE ルータまでのフルメッシュ LPS を確立します。PE ルータは、Cisco IOS CLI を使用して、スタティック設定を通じた VPLS インスタンスのメンバーシップを取得します。

ハブおよびスポーク

ハブアンドスポーク型モデルでは、ハブとして動作する PE ルータは、スポーク サイトのすべての PE ルータとのポイントツーマルチポイント フォワーディング関係を確立します。このハブ PE のカスタマー ネットワークから受信したイーサネット パケットまたは VLAN パケットは、エミュレートされた VC のいずれかまたは複数の VC に転送できます。

スポークとして動作する PE ルータは、ハブ サイトで PE とのポイントツーポイント接続を確立します。スポーク PE のカスタマー ネットワークから受信したイーサネット パケットまたは VLAN パケットは、このハブの VFI または VPLS インスタンスに転送されます。

Cisco IOS Release 12.2(33)SXH およびそれ以降のリリースでは、スポークに接続する複数のカスタマー サイトがある場合は、スピークごとに複数の VC をハブの同じ VFI または VPLS インスタンスに終端することができます。

エッジに対して MPLS を使用する H-VPLS

フラットつまり非階層型の VPLS 構成では、すべての PE ノード間に pseudowire(PW; 擬似回線)のフル メッシュが必要です。 擬似回線 では、VLAN および対応する擬似ポートを定義します。

H-VPLS は、フル メッシュとハブアンドスポーク型構成を組み合わせることによって、シグナリングと複製の両方のオーバーヘッドを軽減します。ハブアンドスポーク型構成は、スプリット ホライズンと連動して PW 間でパケットをスイッチングさせるため、PE 間の PW 数が事実上、少なくなります。

図 4-3 エッジ ネットワークに対して MPLS を使用する H-VPLS

 

エッジ アーキテクチャに対して MPLS を使用する H-VPLS では、Ethernet Access Island(EAI)が VPLS コア ネットワークと連動し、さらに基礎のトランスポート メカニズムとしての MPLS と連動します。EAI は標準のイーサネット ネットワークと同様に動作します。図 4-3 では、EAI にデバイス CE1、CE2a、および CE2b が配置されています。EAI 内の CE デバイスからのトラフィックは、算出されたスパニング ツリー パス上で User-facing Provider Edge(UPE; ユーザ方向のプロバイダー エッジ)デバイスによって、EAI 内でローカルにスイッチングされます。各 UPE デバイスは、PW を使用して、1 つ以上の Network-facing Provider Edge(NPE; ネットワーク方向のプロバイダー エッジ)に接続されています。UPE のローカル トラフィックは、NPE デバイスに転送されません。

VPLS の設定時の注意事項

SIP 上で VPLS を設定する場合は、次の注意事項に従ってください。

個々の VPLS 機能に対する SIP のサポートは、 表 4-3 を参照してください。

SIP は Catalyst 6500 シリーズ スイッチあたり最大 4000 の VPLS ドメインをサポートします。

SIP は Catalyst 6500 シリーズ スイッチあたりドメインごとに最大 60 の VPLS ピアをサポートします。

SIP は最大 30,000 の擬似回線をサポートします。任意のドメインおよびピアの組み合わせで使用可能であり、ドメインの最大数は 4000、ピアの最大数は 60 です。たとえば、7 つのピアで最大 4000 ドメイン、または 500 ドメインで最大 60 ピアがサポートされます。

Cisco 7600 SIP-600 上で VPLS を設定する場合は、次の注意事項に従ってください。

Q-in-Q(単一 802.1Q タグまたはランダム ダブル タグの組み合わせを VPLS インスタンス、レイヤ 3 MPLS VPN、または EoMPLS VC にマッピングする機能)はサポートされません。

Q-in-Q エッジを使用する H-VPLS:アップリンクに Cisco 7600 SIP-600、ダウンリンクに任意の LAN ポートまたは Cisco 7600 SIP-600 が必要です。

MPLS エッジを含む H-VPLS では、ダウンリンク(UPE 方向)およびアップリンク(MPLS コア)の両方に OSM モジュール、Cisco 7600 SIP-600、または Cisco 7600 SIP-400 を配置する必要があります。

Cisco 7600 SIP-400 および Cisco 7600 SIP-600 は、Transparent LAN Services(TLS; 透過型 LAN サービス)および Ethernet Virtual Connection Services(EVCS)を提供します。

Cisco 7600 SIP-400 は、UPE から複数の NPE への冗長 PW リンクをサポートしません。

SIP 上で VPLS を設定する場合は、このマニュアルに記載された注意事項を確認し、さらに次の URL にアクセスして、Cisco 7600 シリーズ ルータの『 OSM Configuration Note 』の「Virtual Private LAN Services on the Optical Services Modules」を参照してください。

http://www.cisco.com/en/US/docs/routers/7600/install_config/12.2SR_OSM_config/mpls.html#wp1423607

VPLS 機能の互換性

表 4-3 に、VPLS 機能がサポートされる状況を示します。

 

表 4-3 SIP および SPA の組み合わせに基づく VPLS 機能の互換性

機能
Cisco 7600 SIP-200
Cisco 7600 SIP-400
Cisco 7600 SIP-6001

MPLS エッジでの H-VPLS

サポートされていません。

Cisco IOS Release 12.2(33)SXH 以上

2 ポート ギガビット イーサネット SPA

2 ポートおよび 4 ポート OC-3c/STM-1 POS SPA

1 ポート OC-12c/STM-4 POS SPA

1 ポート OC-48c/STM-16 POS SPA

Cisco IOS Release 12.2(18)SXF1 以上

1 ポート 10 ギガビット イーサネット SPA

5 ポート ギガビット イーサネット SPA

10 ポート ギガビット イーサネット SPA

1 ポート OC-192c/STM-64 POS/RPR SPA

2 ポートおよび 4 ポート OC-48c/STM-16 POS SPA

Cisco 7600 SIP-600 のサポートは、Cisco IOS Release 12.2(33)SXH から削除され、Cisco IOS Release 12.2(33)SXI 以降のリリースに再追加されました。

Q-in-Q エッジを含む H-VPLS

サポートされていません。

サポートされていません。

Cisco IOS Release 12.2(18)SXF1 以上

1 ポート 10 ギガビット イーサネット SPA

5 ポート ギガビット イーサネット SPA

10 ポート ギガビット イーサネット SPA

1 ポート OC-192c/STM-64 POS/RPR SPA

2 ポートおよび 4 ポート OC-48c/STM-16 POS SPA

Cisco 7600 SIP-600 のサポートは、Cisco IOS Release 12.2(33)SXH から削除され、Cisco IOS Release 12.2(33)SXI 以降のリリースに再追加されました。

スポークあたりの VPLS の複数 VC

Cisco IOS Release 12.2(33)SXH で追加されています。

Cisco IOS Release 12.2(33)SXI で追加されています。

ポイントツーマルチポイント EoMPLS およびフルメッシュ PE 構成を使用する VPLS

サポートされていません。

Cisco IOS Release 12.2(33)SXH 以上

2 ポート ギガビット イーサネット SPA

2 ポートおよび 4 ポート OC-3c/STM-1 POS SPA

1 ポート OC-12c/STM-4 POS SPA

1 ポート OC-48c/STM-16 POS SPA

Cisco IOS Release 12.2(18)SXF1 以上

1 ポート 10 ギガビット イーサネット SPA

5 ポート ギガビット イーサネット SPA

10 ポート ギガビット イーサネット SPA

1 ポート OC-192c/STM-64 POS/RPR SPA

2 ポートおよび 4 ポート OC-48c/STM-16 POS SPA

Cisco 7600 SIP-600 のサポートは、Cisco IOS Release 12.2(33)SXH から削除され、Cisco IOS Release 12.2(33)SXI 以降のリリースに再追加されました。

1.Cisco 7600 SIP-600 のサポートは、Cisco IOS Release 12.2(33)SXH から削除され、Cisco IOS Release 12.2(33)SXI 以降のリリースに再追加されました。

非対称キャリア遅延の設定

冗長リンクのスイッチオーバー後、ポートがデータ転送の準備完了前に、ローカル リンクまたはポートが、リンクアップと宣言される場合があります。この状況によってエラー状態のルーティング テーブルのコンバージェンスが引き起こされ、トラフィックが失われることがあります。Cisco IOS リリース 12.2(33)SXI およびそれ以降のリリースでは、非対称キャリア遅延(ACD)機能により、SIP-200 または SIP-400 の物理インターフェイスに対するアップリンクやリンクダウンのイベント通知ごとに個別の遅延値を設定できます。この機能を使用すると、リンクダウン イベントを迅速に通知でき、一方のリンクアップ イベントは、リブートしたポートの準備が確実に完了する十分な遅延時間が経過してから通知できます。

ACD の制約事項および注意事項

ACD を設定する場合は、次の制約事項および注意事項に従ってください。

ACD は、従来型のキャリア遅延がインターフェイスに設定されている場合( up キーワードまたは down キーワードを指定しない carrier-delay コマンドを使用)、このインターフェイスに設定できない。

リンクアップ キャリア遅延時間は秒単位で設定する。リンクダウン キャリア遅延時間は msec キーワードを使用してミリ秒単位で設定するか、秒単位で指定します。

Line Card(LC; ラインカード)は、リンクアップ イベントに 4 秒のデバウンス タイマーを実装する。設定されたリンクアップ キャリア遅延はこの LC デバウンス タイマーと同時に実行しますが、4 秒以上にする必要があります。

ルート プロセッサ(RP)は、リンクアップとリンクダウンの両イベントに対して 2 秒の遅延を実装する。リンクダウンのキャリア遅延時間を設定すると、リンクアップおよびリンクダウンのイベントに対する 2 秒の RP 遅延がキャンセルされます。

ファスト リンク機能とキャリア遅延機能は互いに排他的である。インターフェイスにいずれかの機能を設定する場合、他の機能はディセーブルになります。

インターフェイスが管理上のシャットダウンになると、どのようなキャリア遅延が設定されていても、強制的に即時のリンクダウン イベントになります。

表 4-4 に、各設定のキャリア遅延の結果とインターフェイス イベントを示します。

表 4-4 ACD の動作

ACD の設定
インターフェイスでのイベント
合計のキャリア遅延時間

carrier-delay down t_down

(リンクダウン遅延が設定されているため、RP 遅延はキャンセルされます)。

ダウン ステートに移行

t_down

アップ ステートに移行

4 秒間(LC デバウンス タイマー)

管理上のシャットダウン

0(即時のシャットダウン)

管理上の起動

4 秒間(LC デバウンス タイマー)

carrier-delay up t_up

(リンクダウン遅延が設定されていないため、RP 遅延が適用されます)。

ダウン ステートに移行

2 秒(RP 遅延)

アップ ステートに移行

t_up + 2 秒(RP 遅延)

管理上のシャットダウン

0(即時のシャットダウン)

管理上の起動

t_up + 2 秒(RP 秒)最短で 4 秒

carrier-delay down t_down
carrier-delay up t_up

(リンクダウン遅延が設定されているため、RP 遅延はキャンセルされます)。

ダウン ステートに移行

t_down

アップ ステートに移行

t_up 、最短で 4 秒

管理上のシャットダウン

0(即時のシャットダウン)

管理上の起動

t_up 、最短で 4 秒

ACD 設定の手順

SIP-200 または SIP-400 の物理インターフェイスで、リンクアップおよびリンクダウンのイベントに対するキャリア遅延値を個別に設定するには、次の作業を行います。

コマンドまたはアクション
目的

ステップ 1

Router(config)# interface type slot/subslot/port

設定するインターフェイスを選択します。

ステップ 2

Router(config-if)# carrier-delay { up seconds | down { seconds | msec milliseconds }}

ACD のアップまたはダウンの通知遅延を設定します。

up :リンクアップ通知遅延を指定します。

down :リンクダウン通知遅延を指定します。

seconds :システムがステートを変更するまでの待機時間を秒数で指定します。範囲は 0 ~ 60 です。アップ ステートに移行するまでのデフォルトは 4 秒、ダウン ステートに移行するまでのデフォルトは 2 秒です。

msec milliseconds :リンクダウン通知遅延時間をミリ秒単位で指定します。

ステップ 3

Router(config-if)# end

コンフィギュレーション モードを終了します。

次の例に、リンクアップへの移行を 8 秒、リンクダウンへの移行を 50 ミリ秒とするキャリア遅延の設定方法を示します。

Router(config)# interface Gi2/0/0
Router(config-if)# carrier-delay up 8
Router(config-if)# carrier-delay down msec 50
 

ACD の設定の確認

SIP-200 または SIP-400 の物理インターフェイスのキャリア遅延設定を表示するには、次のように show running-config コマンドを入力します。

Router# show running-config interface Gi2/0/0
Building configuration...
 
Current configuration: 219 bytes
!
interface GigabitEthernet2/0/0
ip address 32.0.0.1 255.255.255.0
logging event link-status
carrier-delay up 8
carrier-delay down msec 50
end
 

SIP での MPLS 機能の設定

Catalyst 6500 シリーズ スイッチ上の FlexWan および Enhanced FlexWAN モジュールでサポートされる多くの MPLS 機能は、SIP でもサポートされます。SIP 上でサポートされる MPLS 機能の一覧は、「SIP および SSC の概要」を参照してください。

ここでは、SIP 固有の設定時の注意事項がある MPLS 機能について説明します。このマニュアルに記載された SIP 固有の注意事項を確認してから、次の URL を参照して、MPLS 機能の設定に関する詳細を確認してください。

http://www.cisco.com/en/US/docs/routers/7600/install_config/flexwan_config/flexmpls.html

SIP での AToM の設定

Any Transport over MPLS(AToM)は MPLS バックボーン上でレイヤ 2 パケットを転送します。AToM はエッジ スイッチ間で転送された Label Distribution Protocol(LDP; ラベル配信プロトコル)セッションを使用して、接続の設定およびメンテナンスを行います。2 つのレベルのラベルを使用して、エッジ スイッチ間でスイッチングを行うと、転送が生じます。外部ラベル(トンネル ラベル)は、MPLS バックボーンを介して入力 PE から出力 PE にパケットをルーティングします。VC ラベルは、トンネル エンドポイント(出力 PE の特定の出力インターフェイス、および ATM Adaptation Layer 5 [AAL5] Protocol Data Unit [PDU; プロトコル データ ユニット] の VPI/VCI)値、フレームリレー PDU の DLCI 値、またはイーサネット フレームの VLAN ID)で接続を判別する Demux ラベルです。

AToM 機能の設定方法の詳細は、次の URL にある『 FlexWAN and Enhanced FlexWAN Module Installation and Configuration Note 』を参照してください。

http://www.cisco.com/en/US/docs/routers/7600/install_config/flexwan_config/flexmpls.html


) FlexWAN のマニュアルを参照する場合は、このマニュアルに記載された SIP 固有の設定時の注意事項に注意してください。


Cisco 7600 SIP-200 の AToM 機能

Cisco 7600 SIP-200 は、次の AToM 機能をサポートします。

ATM over MPLS(ATMoMPLS):AAL5 モード

Ethernet over MPLS(EoMPLS):ポート モード

EoMPLS:VLAN モード

Frame Relay over MPLS(FRoMPLS)

EoMPLS VC の 階層型 QoS

Cisco 7600 SIP-400 の AToM 機能

Cisco 7600 SIP-400 は、次の AToM 機能をサポートします。

ATMoMPLS:AAL0 モード(単一セル リレーに限る)

ATMoMPLS:AAL5 モード

EoMPLS:ポート モード

EoMPLS:VLAN モード

FRoMPLS:DLCI モード

Cisco IOS Release 12.2(33)SXH およびそれ以降のリリース

EoMPLS VC の 階層型 QoS

HDLCoMPLS

PPPoMPLS

Cisco IOS Release 12.2(33)SXI およびそれ以降のリリース

AToM over GRE

Cisco 7600 SIP-400 の AToM 設定時の注意事項

Cisco 7600 SIP-400 に AToM を設定する場合は、次の注意事項に従ってください。

Cisco 7600 SIP-400 と Supervisor Engine 1、Supervisor Engine 1A、Supervisor Engine 2、または Supervisor Engine 720 PFC3A は併用できません。

Cisco 7600 SIP-400 と PFC-2 ベース システムは併用できません。

Cisco IOS Release 12.2(33)SXH 以前のリリースの AToM では、Cisco 7600 SIP-400 はデータ パス上の次の機能をサポートしません。SIP が Customer Edge(CE; カスタマー エッジ)または MPLS コア方向にある場合は、次の機能を設定しないでください。

HDLCoMPLS

PPPoMPLS

VPLS

Cisco IOS Release 12.2(33)SXH およびそれ以降のリリースで AToM を使用する場合、Cisco 7600 SIP-400 は CE 方向のインターフェイスで次の機能をサポートします。

HDLCoMPLS

PPPoMPLS

VPLS

Cisco 7600 SIP-400 がネットワークの MPLS コア側にあり、PE デバイスが直接接続されている場合、Cisco 7600 SIP-400 は EoMPLS をサポートします。

Cisco IOS Release 12.2(33)SXH およびそれ以降のリリースでは、Cisco 7600 SIP-400 は、GRE を介して AToM をサポートします。

Cisco 7600 SIP-400 は、VLAN Trunking Protocol(VTP; VLAN トランキング プロトコル)、Cisco Discovery Protocol(CDP)、Bridge Protocol Data Unit(BPDU; ブリッジ プロトコル データ ユニット)など、レイヤ 2 パケットのトンネリングをイネーブルまたはディセーブルにする機能をサポートしません。Cisco 7600 SIP-400 は BPDU をトンネリングし、このトンネルからの VTP パケットおよび CDP パケットを常にブロックします。

ATMoMPLS AAL5 およびセル モードの Cisco 7600 SIP-400 がネットワークの両端に配置されている場合、Cisco 7600 SIP-400 は PE 間で VPI/VCI が一致しなくても対応できます。

Cisco 7600 SIP-400 は、FRoMPLS 用の MPLS-EXP を設定するために、FR-DE 上のマッチングをサポートします。

Cisco 7600 SIP-400 では、 xconnect コマンドを使用して、AToM 回線に ATMoMPLS を除くすべての AToM 接続タイプを設定できます。ATMoMPLS の場合は、 mpls l2 transport route コマンドを使用する必要があります。

ATM 回線に対する xconnect コマンドの設定方法は、次の URL にある xconnect コマンドを使用した MPLS の例を参照してください。

http://www.cisco.com/en/US/docs/routers/7600/install_config/flexwan_config/flexmpls.html

Cisco 7600 SIP-400 は、ATM インターフェイスのローカル スイッチングをサポートしませんが、フレームリレー インターフェイスのローカル スイッチングはサポートします。

Cisco 7600 SIP-400 は、AToM を使用した次の QoS 分類機能をサポートしません。

DLCI のマッチングはサポートされません

VLAN のマッチングはサポートされません

CoS のマッチングは Cisco IOS Release 12.2(18)SXE および Cisco IOS Release 12.2(18)SXE2 ではサポートされません。Cisco IOS Release 12.2(18)SXF 以降、2 ポート ギガビット イーサネット SPA を搭載した場合は、この機能がサポートされます。

入力インターフェイスのマッチングはサポートされません

パケット長のマッチングはサポートされません

Media Access Control(MAC; メディア アクセス制御)アドレスのマッチングはサポートされません

Border Gateway Protocol(BGP; ボーダー ゲートウェイ プロトコル)などのプロトコル タイプのマッチングはサポートされません

MPLS EXP ビットを設定するための Cisco 7600 SIP-400 の MPLS インポジションの概要

MPLS インポジション機能は、非 MPLS フレーム(イーサネット、VLAN、フレームリレー、ATM または IP など)を MPLS フレームにカプセル化します。MPLS ディスポジションはこの逆の機能を実行します。

入力 QoS ポリシー マップが入力パケットに適用されて から 、MPLS インポジションが実行されます。つまり、パケットは非 MPLS フレームとして処理されるため、MPLS 関連のすべてのマッチングは無効です。 set mpls experimental コマンドを使用して EXP ビットにマーキングを行うと、AToM または MPLS コンポーネントに情報が渡されて、EXP ビットが設定されます。インポジションが実行されると、フレームが MPLS フレームになり、出力 QoS ポリシー マップ(存在する場合)は MPLS 関連基準を適用できます。

出力側では、MPLS ディスポジションが実行されて から 、出力 QoS ポリシー マップが出力パケットに適用されます。つまり、パケットは非 MPLS フレームとして処理されるため、MPLS 関連のすべての基準は無効です。ディスポジション前では、フレームは MPLS フレームであり、入力 QoS ポリシー マップ(存在する場合)は MPLS 関連基準を適用できます。

Encoded Address Recognition Logic(EARL)は、Catalyst 6500 シリーズ スイッチ スーパーバイザ エンジンの MAC アドレスに基づいてパケットを学習および転送する、中央集中型の処理エンジンです。EARL は VLAN、MAC アドレス、およびポートの関係を格納します。これらの関係は、ハードウェアでのスイッチング判断に使用されます。EARL エンジンは MPLS インポジションも実行します。MPLS EXP ビットは IP TOS フィールド( trust dscp モードまたは trust precedence モードを使用)、または DBUS ヘッダーの QoS フィールド( trust cos モードを使用)からコピーされます。

2 ポート ギガビット イーサネット SPA と Cisco 7600 SIP-400 をカスタマー側インターフェイスとして使用し、このインターフェイスに、MPLS による IP インポジションのための 802.1Q カプセル化を設定した場合、レイヤ 2 CoS 値は対応する MPLS パケットの EXP ビットに自動的にはコピーされません。代わりに、IP precedence ビット値がコピーされます。

802.1Q CoS 値を維持するには、入力方向のカスタマー側ギガビット イーサネット インターフェイスでインポジション トラフィックを分類し、CoS 値を照合してから、次の例のように、このクラスに MPLS の experimental アクションを設定します。

Router(config)# class-map cos0
Router(config-cmap)# match cos 0
Router(config-cmap)# exit
!
Router(config)# class-map cos1
Router(config-cmap)# match cos 1
Router(config-cmap)# exit
!
Router(config)# policy-map policy1
Router(config-pmap)# class cos0
Router(config-pmap-c)# set mpls experimental imposition 0
Router(config-pmap-c)# exit
Router(config-pmap)# class cos1
Router(config-pmap-c)# set mpls experimental imposition 1

Cisco 7600 SIP-600 の AToM 機能

Cisco 7600 SIP-600 は、次の AToM 機能をサポートします。

AToM サポート:EoMPLS だけ(EARL ベースおよび SIP ベース EoMPLS)

エッジに対して MPLS を使用する H-VPLS の設定

Cisco 7600 SIP-400 および Cisco 7600 SIP-600 はエッジに対して MPLS を使用する H-VPLS 機能をサポートします。SIP における VPLS サポートの詳細は、「Virtual Private LAN Service(VPLS)の設定」を参照してください。

SIP での QoS 機能の設定

ここでは、SIP 特有の QoS 機能の設定について説明します。Catalyst 6500 シリーズ スイッチの FlexWAN および Enhanced FlexWAN モジュールでサポートされている QoS 機能の多くは、SIP でもサポートされます。SIP でサポートされる QoS 機能の一覧は、「SIP および SSC の概要」を参照してください。

ここでは、SIP 固有の設定時の注意事項がある QoS 機能について説明します。このマニュアルに記載された SIP 固有の注意事項を検討してから、次の URL にある『 FlexWAN and Enhanced FlexWAN Module Installation and Configuration Note 』を参照してください。

http://www.cisco.com/en/US/docs/routers/7600/install_config/flexwan_config/flexwan-config-guide.html

この項の内容は、次のとおりです。

「QoS 機能設定時の一般的な注意事項」

「MQC による QoS 機能の設定」

「SIP での QoS トラフィック クラスの設定」

「SIP での QoS クラス ベース マーキング ポリシーの設定」

「SIP での QoS 輻輳管理および回避ポリシーの設定」

「Cisco 7600 SIP-400 でのデュアル プライオリティ キューイングの設定」

「SIP での QoS トラフィック シェーピング ポリシーの設定」

「SIP での QoS トラフィック ポリシング ポリシーの設定」

「インターフェイスへの QoS トラフィック ポリシーの結合」

「NBAR および dNBAR の設定」

「SIP での階層型 QoS の設定」

「Cisco 7600 SIP-600 での PFC QoS の設定」

QoS 機能設定時の一般的な注意事項

ここでは、一部の SPA タイプについて、QoS 機能の一般的な注意事項を示します。その他の機能固有の SIP および SPA 設定時の注意事項および制約事項は、この章で他の QoS の項を参照してください。

ATM SPA QoS の設定時の注意事項

2 ポートおよび 4 ポート OC-3c/STM-1 ATM SPA には、次が適用されます。

入力方向では、すべての QoS 機能が Cisco 7600 SIP-200 でサポートされます。

出力方向では次のようになります。

すべてのキューイング ベース機能(CBWFQ や ATM VC 単位 WFQ、および WRED など)は、SPA の Segmentation and Reassembly(SAR)プロセッサで実行されます。

ポリシングは SIP で実行されます。

クラス キュー シェーピングはサポートされません。

ギガビット イーサネット SPA QoS の設定時の注意事項

2 ポート ギガビット イーサネット SPA イーサネット SPA には、次の QoS 動作が適用されます。

すべての QoS 機能は、Catalyst 6500 シリーズ スイッチの FlexWAN および Enhanced FlexWAN モジュールのパケット サイズ計算方法と同様の方法で、入出力方向のパケット サイズを計算します。

具体的には、すべての機能が IEEE 802.3 レイヤ 2 ヘッダーおよびレイヤ 3 プロトコル ペイロードを考慮します。Cyclic Redundancy Check(CRC; 巡回冗長検査)、インターフレーム ギャップ、およびプリアンブルは、パケット サイズ計算で使用されません。


) ファスト イーサネット SPA の場合、QoS ではインターフェイス速度を変更できません(たとえば、ファスト イーサネット SPA は、インターフェイス速度が 100 Mpbs から 10 Mpbs に変更されるつど、QoS の設定値を変更できません)。速度を変更する場合は、ユーザが QoS の設定値も相応に調整する必要があります。


MQC による QoS 機能の設定

モジュラ QoS CLI(MQC)は、ユーザがトラフィック ポリシーを作成し、そのポリシーをインターフェイスに結合できる CLI 構造です。トラフィック ポリシーには、トラフィック クラスおよび 1 つまたは複数の QoS 機能を指定します。トラフィック クラスは、トラフィックを選択するために使用されるのに対して、トラフィック ポリシーの QoS 機能は分類されたトラフィックの取り扱いを決定します。

サブインターフェイスが含まれるメイン インターフェイスにトラフィック ポリシーを適用すると、サブインターフェイスを経由するすべてのトラフィックがメイン インターフェイスのポリシーに基づいて処理されます。たとえば、メイン インターフェイスでトラフィック シェーピング ポリシーを設定した場合、サブインターフェイスを通過するすべてのトラフィックが集約され、メイン インターフェイスのトラフィック シェーピング ポリシーで定義された速度にシェーピングされます。

SIP 上で MQC を使用して QoS 機能を設定するには、次の基本的な作業を行います。


ステップ 1 class-map コマンドを使用して、トラフィック クラスを定義します。

ステップ 2 トラフィック クラスと 1 つ以上の QoS 機能を対応付けることによって、トラフィック ポリシーを作成します( policy-map コマンドを使用)。

ステップ 3 service-policy コマンドを使用して、インターフェイスにトラフィック ポリシーを結合します。


 

MQC の詳細は、次の URL にアクセスし、『 Cisco IOS Quality of Service Solutions Configuration Guide 』Release 12.2 の「Modular Quality of Service Command-Line Interface Overview」の章を参照してください。

http://www.cisco.com/en/US/docs/ios/12_2/qos/configuration/guide/qcfmdcli.html

SIP での QoS トラフィック クラスの設定

QoS の分類機能を使用して、ネットワーク トラフィックを選択し、クラス別に分類して、一定の一致条件に基づいてその後の QoS 処理が実行されるようにします。デフォルト クラスである class-default は、設定されているクラス マップのどの選択条件とも一致しないトラフィックが振り分けられるクラスです。

QoS トラフィック クラスの設定時の注意事項

SIP 上でトラフィック クラスを設定する場合は、次の注意事項に従ってください。

一意のクラス マップを 256 まで定義できます。

1 つのクラス マップに最大 8 つの異なる match コマンド ステートメントを指定できます。

ATM ブリッジング、フレームリレー ブリッジング、MPB、および BCP の各機能に関しては、Cisco IOS Release 12.2(33) SXH および以降のリリース、ブリッジド フレームで次のマッチング機能がサポートされます。

ATM CLP ビットのマッチング(入力インターフェイスに限る)

COS のマッチング

フレームリレー DE ビットのマッチング(入力インターフェイスに限る)

フレームリレー DLCI のマッチング

インナー COS のマッチング

インナー VLAN のマッチング

IP DSCP のマッチング

IP precedence のマッチング

VLAN のマッチング

Cisco 7600 SIP-600 は、同じクラスまたはポリシー マップにおける QoS グループまたは入力 VLAN のマッチングと他タイプの一致基準(ACL など)との組み合わせをサポートしません。

Cisco 7600 SIP-400 は、ルーテッド トラフィックに限り、ACL のマッチングをサポートします。ブリッジド トラフィックに関しては、ACL のマッチングはサポートされません。

Cisco 7600 SIP-600 上で階層型 QoS を設定しているときに、親ポリシーで入力 VLAN のマッチングを設定した場合、子ポリシーでサポートされるのは、QoS グループのマッチングだけです。

SIP による具体的な一致基準のサポートは、 表 4-5 を参照してください。

ユーザ定義の QoS トラフィック クラスを作成する場合は、グローバル コンフィギュレーション モードから次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# class-map [ match-all | match-any ] class-name

トラフィック クラスを作成します。

match-all :(任意)クラスで定義されたすべてのマッチング ステートメントの論理積を使用し、クラス マップのすべての一致基準と一致しなければならないことを指定します。これがデフォルト設定です。

match-any :(任意)クラスで定義されたすべてのマッチング ステートメントの論理和を使用し、1 つ以上の一致基準と一致しなければならないことを指定します。

class-name :ユーザ定義のクラス名を指定します。

(注) 一意のクラス マップを 256 まで定義できます。

ステップ 2

Router(config-cmap)# match type

トラフィックに適用する一致基準を指定します。 type は、 表 4-5 に示されている SIP がサポートする match コマンドの形式の 1 つです。

コマンド ステートメントを指定できます。

表 4-5 に、Catalyst 6500 シリーズ スイッチ上で SIP に関してサポートされる QoS 分類機能の情報を示します。このテーブルに記載されているコマンドの詳細は、『 Cisco IOS Quality of Service Solutions Command Reference 』を参照してください。

 

表 4-5 SIP に基づいた QoS 分類機能の互換性

機能(match コマンド)
Cisco 7600 SIP-200
Cisco 7600 SIP-400
Cisco 7600 SIP-6002

アクセス リスト(ACL)番号のマッチング

match access-group コマンド)

次のタイプの ACL を使用した場合に、すべての SPA についてサポートされます。

プロトコル:ICMP、IGMP、EIGRP、OSPF、PIM、および GRE

送信元および宛先ポート

TCP フラグ

ToS(DSCP および precedence)

次のタイプの ACL を使用した場合に、すべての SPA についてサポートされます。

送信元および宛先ポート

TCP フラグ(IPv4 に限る)

IP アドレス(IPv6 圧縮モードに限る)

次のタイプの ACL を使用した場合に、すべての SPA1 についてサポートされます。

IPv4 および IPv6

プロトコル:ICMP、IGMP、UDP、および MAC

送信元および宛先ポート

TCP フラグ

ToS

注:Cisco 7600 SIP-600 のサポートは、Cisco IOS Release 12.2(33)SXH から削除され、Cisco IOS Release 12.2(33)SXI 以降のリリースに再追加されました。

ACL 名のマッチング( match access-group name コマンド)

すべての SPA でサポートされます。

すべての SPA でサポートされます。

すべての SPA でサポートされます。1

注:Cisco 7600 SIP-600 のサポートは、Cisco IOS Release 12.2(33)SXH から削除され、Cisco IOS Release 12.2(33)SXI 以降のリリースに再追加されました。

任意のパケットのマッチング

match any コマンド)

(注) ユーザ定義のクラス マップに関してはサポートされません。

すべての SPA でサポートされます。

すべての SPA でサポートされます。

すべての SPA でサポートされます。1

注:Cisco 7600 SIP-600 のサポートは、Cisco IOS Release 12.2(33)SXH から削除され、Cisco IOS Release 12.2(33)SXI 以降のリリースに再追加されました。

ATM Cell Loss Priority(CLP; セル損失)( match atm clp コマンド)

すべての ATM SPA でサポートされます。

Cisco IOS Release 12.2(33)SXH:RFC 1483 ブリッジング機能を使用する ATM CLP マッチング サポートが追加されました。

ATM 入力インターフェイスに限り、すべての ATM SPA でサポートされます。

Cisco IOS Release 12.2(33)SXH:ATM 入力インターフェイスに限り、RFC 1483 ブリッジング機能を使用する ATM CLP マッチング サポートが追加されました。

サポートされていません。

クラス マップのマッチング

match class-map コマンド)

すべての SPA でサポートされます。

サポートされていません。

サポートされていません。

COS のマッチング( match cos コマンド)

dot1q カプセル化を使用する場合に、4 ポートおよび 8 ポート ファスト イーサネット SPA 上の Cisco IOS Release 12.2(33)SXH でサポートされます。

2 ポート ギガビット イーサネット SPA だけ:入力および出力 802.1Q タグ付きフレーム

Cisco IOS Release 12.2(33)SXH:ブリッジング機能を使用するインナー COS マッチング サポートが追加されました。

サポートされていません。

インナー COS のマッチング( match cos inner コマンド)

すべての SPA でサポートされます。

Cisco IOS Release 12.2(33)SXH:ブリッジング機能を使用するインナー COS マッチング サポートが追加されました。

2 ポート ギガビット イーサネット SPA 上の Cisco IOS Release 12.2(33)SXH でサポートされます。

入力および出力インターフェイス

ブリッジング機能を使用するインナー COS マッチング

サポートされていません。

フレームリレー DE(廃棄適性)ビットのマッチング( match fr-de コマンド)

フレームリレー入力および出力インターフェイスでサポートされます。

Cisco IOS Release 12.2(33)SXH:フレームリレー ブリッジング機能を使用するフレームリレー DE マッチング サポートが追加されました。

フレームリレー入力インターフェイスに限りサポートされます。

Cisco IOS Release 12.2(33)SXH:入力フレームリレー インターフェイスに限り、フレームリレー ブリッジング機能を使用するフレームリレー DE マッチング サポートが追加されました。

(注) Cisco 7600 SIP-400 はフレームリレー Data Terminal Equipment(DTE; データ端末装置)として動作するだけで、Data Communication Equipment(DCE; データ通信装置)としては動作しないため、Cisco 7600 SIP-400 は FR DE ビットと一致するフレームのドロップをサポートしません。ただし、その他の QoS アクションはサポートします。

サポートされていません。

フレームリレー Data-Link Connection Identifier(DLCI)のマッチング( match fr-dlci コマンド)

フレームリレー入力および出力インターフェイスでサポートされます。

Cisco IOS Release 12.2(33)SXH:フレームリレー ブリッジング機能を使用するフレームリレー DLCI マッチング サポートが追加されました。

Cisco IOS Release 12.2(33) SXH において、フレームリレー入力および出力インターフェイス上、およびフレームリレー ブリッジング機能を使用した場合にサポートされます。

サポートされていません。

入力 VLAN のマッチング

match input vlan コマンド:入力インターフェイスからの VLAN を一致させます)

EoMPLS インターフェイスでサポートされます。

Cisco IOS Release 12.2(33)SXH でのサポート:出力インターフェイスだけ、ブリッジング機能使用

(注) Cisco 7600 SIP-400 の出力インターフェイス上でサービス ポリシーが適用され、入力インターフェイスからの VLAN とのマッチングが行われます。

サポートされていません。

IP DSCP のマッチング( match ip dscp コマンド)

すべての SPA でサポートされます。

Cisco IOS Release 12.2(33)SXH:入力インターフェイスに限り、ブリッジング機能を使用する IP DSCP マッチング サポートが追加されました。

すべての SPA でサポートされます。

Cisco IOS Release 12.2(33)SXH:ブリッジング機能を使用する IP DSCP マッチング サポートが追加されました。

すべての SPA でサポートされます。1

注:Cisco 7600 SIP-600 のサポートは、Cisco IOS Release 12.2(33)SXH から削除され、Cisco IOS Release 12.2(33)SXI 以降のリリースに再追加されました。

IP precedence のマッチング( match ip precedence コマンド)

すべての SPA でサポートされます。

すべての SPA でサポートされます。

Cisco IOS Release 12.2(33)SXH:ブリッジング機能を使用する IP precedence マッチング サポートが追加されました。

すべての SPA でサポートされます。1

注:Cisco 7600 SIP-600 のサポートは、Cisco IOS Release 12.2(33)SXH から削除され、Cisco IOS Release 12.2(33)SXI 以降のリリースに再追加されました。

IP Real-Time Protocol(RTP)のマッチング

match ip rtp コマンド)

すべての SPA でサポートされます。

サポートされていません。

サポートされていません。

ACL 名に関する MAC アドレスのマッチング

match mac address コマンド)

サポートされていません。

サポートされていません。

サポートされていません。

宛先 MAC アドレスのマッチング

match destination-address mac コマンド)

サポートされていません。

サポートされていません。

サポートされていません。

送信元 MAC アドレスのマッチング

match source-address mac コマンド)

サポートされていません。

サポートされていません。

サポートされていません。

MPLS EXP ビットのマッチング( match mpls experimental コマンド)

すべての SPA でサポートされます。

すべての SPA でサポートされます。

すべての SPA でサポートされます。

IP ヘッダーのレイヤ 3 パケット長のマッチング( match packet length コマンド)

すべての SPA でサポートされます。

サポートされていません。

サポートされていません。

QoS グループのマッチング( match qos-group コマンド)

サポートされていません。

Cisco IOS Release 12.2(33)SXH でのサポート:出力インターフェイスだけ

階層型 QoS を使用している場合に、ソフトウェア ベース EoMPLS の設定に限りサポートされます。その場合、親ポリシーで入力 VLAN にマッチングを設定し、子ポリシーでは QoS グループのマッチングを設定します。1

注:Cisco 7600 SIP-600 のサポートは、Cisco IOS Release 12.2(33)SXH から削除され、Cisco IOS Release 12.2(33)SXI 以降のリリースに再追加されました。

プロトコルのマッチング

match protocol コマンド)

NBAR でサポートされます。

サポートされていません。

IP および IPv6 のマッチングがサポートされます。1

注:Cisco 7600 SIP-600 のサポートは、Cisco IOS Release 12.2(33)SXH から削除され、Cisco IOS Release 12.2(33)SXI 以降のリリースに再追加されました。

VLAN のマッチング

match vlan コマンド:レイヤ 2 802.1Q フレームのアウター VLAN のマッチング)

サポートされていません。

Cisco IOS Release 12.2(33)SXH でサポートされます。

入力および出力インターフェイス

802.1Q タグ付きフレームのアウター VLAN ID のマッチング

サポートされていません。

インナー VLAN のマッチング

match vlan inner コマンド:レイヤ 2 フレームに含まれる 802.1Q タグの最も内側の VLAN のマッチング)

すべての SPA でサポートされます。

Cisco IOS Release 12.2(33)SXH:ブリッジング機能を使用するインナー VLAN ID マッチング サポートが追加されました。

Cisco IOS Release 12.2(33)SXH でサポートされます。

入力および出力インターフェイス

ブリッジング機能を使用するインナー VLAN ID マッチング

サポートされていません。

指定条件の非マッチング

match not コマンド)

すべての SPA でサポートされます。

すべての SPA でサポートされます。

サポートされていません。

2.Cisco 7600 SIP-600 のサポートは、Cisco IOS Release 12.2(33)SXH から削除され、Cisco IOS Release 12.2(33)SXI 以降のリリースに再追加されました。

SIP での QoS クラス ベース マーキング ポリシーの設定

トラフィック クラスの作成後、トラフィック ポリシーを設定することによって、これらのクラスで選択されたトラフィックに特定のアクションを適用するように、マーキング機能を設定できます。

通常、パケット マークは識別用です。パケットがマーキングされたあと、ダウンストリーム デバイスはマーキングに基づいてトラフィックを識別し、ネットワーク要求に従ってトラフィックを分類します。この分類が発生するのは、マークを基準としてパケットを識別するようにトラフィック クラス内の match コマンド( match ip precedence match ip dscp match cos など)が設定されている場合です。その後、このトラフィック クラスを使用するトラフィック ポリシーによって、マーキング済みトラフィックに適した QoS 機能が設定されます。

場合によっては、識別以外の目的にマーキングを使用できます。たとえば、Distributed WRED では IP precedence、IP DSCP、または MPLS EXP 値を使用して、パケットを検出したり、ドロップしたりすることができます。ATM ネットワークでは、パケットの CLP ビットを使用して、輻輳環境におけるパケットの優先順位が判別されます。ATM ネットワークで輻輳が発生すると、CLI ビットが 0 のパケットより先に、CLP ビットが 1 のパケットがドロップされます。同様に、フレームリレー フレームの DE ビットを使用すると、輻輳状態のフレームリレー ネットワークにおけるフレームの優先順位が判別されます。フレームリレー ネットワークでは、DE ビットが 0 のフレームより先に、DE ビットが 1 のフレームがドロップされます。

QoS クラス ベース マーキング ポリシーの設定時の注意事項

SIP 上でクラス ベース マーキングを設定する場合は、次の注意事項に従ってください。

パケット マーキングはインターフェイス、サブインターフェイス、および ATM VC でサポートされます。ATM PVC の場合は、キューイング アクションを設定する場合と同じトラフィック ポリシー内に、VC 単位でパケット マーキングを設定できます。ただし、MPB 一致基準を使用する場合、サポートされるのはサービス ポリシーの PVC 設定だけです。

ATM ブリッジング、フレームリレー ブリッジング、MPB、および BCP の各機能に関しては、Cisco IOS Release 12.2(33) SXH 以降、ブリッジド フレームで次のマーキング機能がサポートされます。

ATM CLP ビットの設定(出力インターフェイスに限る)

フレームリレー DE ビットの設定(出力インターフェイスに限る)

インナー COS の設定

サービス ポリシーで、ポリシング アクションの一部としてクラス ベース マーキングとマーキングの両方を設定した場合、ポリシングを使用するマーキングがクラス ベース マーキングより優先されます。

Cisco 7600 SIP-600 は、入力インターフェイスに限ってマーキングをサポートします。

SIP による具体的なマーキング条件のサポートは、 表 4-6 を参照してください。

クラス ベース マーキングを指定して QoS トラフィック ポリシーを設定する場合は、グローバル コンフィギュレーション モードから次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# policy-map policy-map-name

トラフィック ポリシーを作成または変更し、ポリシー マップ コンフィギュレーション モードを開始します。

policy-map-name :設定するトラフィック ポリシーの名前を指定します。最大 40 の英数字を使用できます。

ステップ 2

Router (config-pmap)# class { class-name | class-default }

このポリシーを適用するトラフィック クラスの名前を指定し、ポリシー マップ クラス コンフィギュレーション モードを開始します。

class-name :設定済みのユーザ定義クラス名にポリシーを適用することを指定します。

class-default :デフォルトのトラフィック クラスにポリシーを適用することを指定します。

ステップ 3

Router(config-pmap-c)# set type

トラフィックに適用するマーキング アクションを指定します。 type は、 表 4-6 に示す SIP がサポートする set コマンドの形式の 1 つです。

表 4-6 に、Catalyst 6500 シリーズ スイッチ上の SIP でサポートされる QoS クラス ベース マーキング機能の情報を示します。

 

表 4-6 SIP に基づく QoS クラス ベース マーキング機能の互換性

マーキング機能
(set コマンド)
Cisco 7600 SIP-200
Cisco 7600 SIP-400
Cisco 7600 SIP-6003

ATM CLP ビットの設定

set atm-clp コマンド:1 の値で ATM セル損失ビットをマーキング)

ATM 出力インターフェイスに限りサポートされます。

Cisco IOS Release 12.2(33)SXH:RFC 1483 ブリッジング機能を使用した場合、出力インターフェイスに限り、ATM CLP マーキング サポートが追加されました。

ATM SPA 出力インターフェイスに限りサポートされます。

サポートされていません。

廃棄クラスの設定

set discard-class コマンド:ホップ単位の動作に対応する廃棄クラス値を使用してパケットをマーキング)

サポートされていません。

サポートされていません。

サポートされていません。

フレームリレー DE ビットの設定

set fr-de コマンド:1 の値でフレームリレー DE ビットをマーキング)

フレームリレー出力インターフェイスに限りサポートされます。

Cisco IOS Release 12.2(33)SXH:フレームリレー ブリッジング機能を使用した場合、出力インターフェイスに限り、フレームリレー DE マーキング サポートが追加されました。

フレームリレー出力インターフェイスに限りサポートされます。

サポートされていません。

IP DSCP の設定

set ip dscp コマンド:0 ~ 63 の値を使用して、Type of Service(ToS; サービス タイプ)バイトで IP Differentiated Services Code Point(DSCP)をマーキング)

すべての SPA でサポートされます。

すべての SPA でサポートされます。

すべての SPA において入力インターフェイスでサポートされます。

注:Cisco 7600 SIP-600 のサポートは、Cisco IOS Release 12.2(33)SXH から削除され、Cisco IOS Release 12.2(33)SXI 以降のリリースに再追加されました。

IP precedence の設定

set ip precedence コマンド:IP ヘッダーの precedence 値を 0 ~ 7 でマーキング)

すべての SPA でサポートされます。

すべての SPA でサポートされます。

すべての SPA において入力インターフェイスでサポートされます。

注:Cisco 7600 SIP-600 のサポートは、Cisco IOS Release 12.2(33)SXH から削除され、Cisco IOS Release 12.2(33)SXI 以降のリリースに再追加されました。

レイヤ 2 802.1Q COS の設定

set cos コマンド:802.1Q タグ付きフレームで COS 値に 0 ~ 7 でマーキング)

すべての SPA でサポートされます。

Cisco IOS Release 12.2(33)SXH:同じインターフェイス上で set cos-inner コマンドを指定した場合はサポートされません。

Cisco IOS Release 12.2(33)SXH でサポートされます。

サポートされていません。

レイヤ 2 802.1Q COS の設定

set cos-inner コマンド:ブリッジド フレームで 0 ~ 7 のインナー CoS フィールドをマーキング)

4 ポートおよび 8 ポート ファスト イーサネット SPA 上でブリッジング機能を使用する場合に、Cisco IOS Release 12.2(33)SXH でサポートされます。

ブリッジング機能を使用する場合に、Cisco IOS Release 12.2(33)SXH でサポートされます。

サポートされていません。

ラベル インポジションでの MPLS EXP ビットの設定

set mpls experimental imposition コマンド)

すべての SPA でサポートされます。

任意の SPA IP 入力インターフェイスでサポートされます。

キーワードはサポートされません。

すべての SPA において入力インターフェイスでサポートされます。1

注:Cisco 7600 SIP-600 のサポートは、Cisco IOS Release 12.2(33)SXH から削除され、Cisco IOS Release 12.2(33)SXI 以降のリリースに再追加されました。

MPLS EXP topmost の設定

set mpls experimental topmost コマンド)

すべての SPA でサポートされます。

任意の SPA MPLS インターフェイスでサポートされます。

サポートされていません。

QoS グループの設定

set qos-group コマンド:QoS グループ アソシエーションでパケットにマーキング)

サポートされていません。

サポートされていません。

ソフトウェア ベース EoMPLS の場合に限り、入力 SPA switchport インターフェイスでサポートされます。1

注:Cisco IOS Release 12.2(33)SXH で Cisco 7600 SIP-600 のサポートが削除されました。

3.Cisco 7600 SIP-600 のサポートは、Cisco IOS Release 12.2(33)SXH から削除され、Cisco IOS Release 12.2(33)SXI 以降のリリースに再追加されました。

クラス ベース マーキング機能の設定の詳細は、次の URL にある『 Class-Based Marking 』を参照してください。

http://www.cisco.com/en/US/docs/ios/12_1t/12_1t5/feature/guide/cbpmark2.html


) クラス ベース マーキングのマニュアルを参照する場合は、このマニュアルに記載された SIP 固有の設定時の注意事項に留意してください。


SIP での QoS 輻輳管理および回避ポリシーの設定

ここでは、輻輳管理および回避機能に関して QoS トラフィック ポリシーを設定する場合に考慮すべき、SIP および SPA 固有の注意事項について説明します。これらの機能は総称として、キューイング機能と呼ばれます。

QoS 輻輳管理および回避ポリシーの設定時の注意事項

SIP 上でキューイング機能を設定する場合は、次の注意事項に従ってください。

Catalyst 6500 シリーズ スイッチ は、さまざまな形式のキューイング機能をサポートします。SIP タイプ別にサポートされるキューイング機能は、 表 4-7 を参照してください。

Cisco 7600 SIP-200 および Cisco 7600 SIP-400 は、入力キューイング機能をサポートしません。

Cisco 7600 SIP-400 上でキューイングを設定する場合は、次の注意事項に従ってください。

Cisco 7600 SIP-400 上のキューは、最小限の帯域幅が保証されません。

Cisco 7600 SIP-400 上では、サービス ポリシーの同じクラスで、キューイングとともに帯域幅またはシェーピングを設定できません。

Cisco 7600 SIP-400 上で、同じサービス ポリシーの異なるクラスにおいて帯域幅パラメータを定義する場合、使用できるコマンドは bandwidth remaining percent だけです。Cisco 7600 SIP-400 は同じサービス ポリシーでキューイングを使用した場合、他の形式の bandwidth コマンドをサポートしません。

キューイングを指定してポリシングを使用すると、トラフィック レートを制限できます。

Cisco 7600 SIP-400 上では、precedence および DSCP 値による分類を使用した場合に、ブリッジド VC で WRED がサポートされます。その他の SIP の場合、ブリッジド VC(MPB を実装する VC など)では WRED は動作しません。

Cisco 7600 SIP-400 上で WRED を設定する場合は、次の注意事項に従ってください。

WRED は、precedence および DSCP 値による分類を使用した場合に、ブリッジド VC でサポートされます。

ATM SPA の出力トラフィックに関して、WRED Explicit Congestion Notification(ECN; 明示的輻輳通知)はサポートされません。

IP トラフィックに関しては、出力 POS インターフェイスに限って ECN がサポートされます。

WRED の ECN に IP ヘッダーの下位 ToS ビットを使用できます。サービス ポリシーに random-detect ecn を設定し、POS インターフェイスまたは POS インターフェイス上の VC に適用し、1 つまたは複数の ECN ビットが設定されていてパケットがドロップ候補になった場合、Cisco 7600 SIP-400 は両方の ECN ビットをマーキングします。いずれか一方の ECN ビットが設定されている場合、Cisco 7600 SIP-400 はパケットをドロップしません。

MPLS パケットに関しては、WRED ECN はサポートされません。

Cisco 7600 SIP-400 上では、SIP が 0.5 秒間に伝送できる 250 バイト パケットの数に基づいて、デフォルトのキュー限度が算出されます。たとえば、速度が 155 Mbps の OC-3 SPA の場合、デフォルトのキュー限度は 38,750 パケットです(155000000 × 0.5 / 250 × 8)。

輻輳管理機能の設定の詳細は、ご使用の Cisco IOS ソフトウェア リリースに対応する『 Cisco IOS Quality of Service Solutions Configuration Guide 』を参照してください

表 4-7 に、Catalyst 6500 シリーズ スイッチ上の SIP でサポートされる QoS キューイング機能の情報を示します。

 

表 4-7 SIP および SPA の組み合わせに基づく QoS 輻輳管理および回避機能

輻輳管理および回避機能
Cisco 7600 SIP-200
Cisco 7600 SIP-400
Cisco 7600 SIP-6004

集約 WRED

random-detect aggregate random-detect dscp [aggregate] 、および random-detect precedence [aggregate] コマンド)

ATM SPA PVC に限ってサポート:Cisco IOS Release 12.2(18)SXE およびそれ以降。

ATM SPA PVC に限ってサポート:Cisco IOS Release 12.2(18)SXE およびそれ以降。

すべての SPA でサポートされます。1

集約 WRED の設定手順の詳細は、「PVC 対応集約 WRED の設定」を参照してください。

CBWFQ

bandwidth queue-limit コマンド)

すべての SPA でサポートされます。

すべての SPA でサポートされます。

すべての SPA でサポートされます。1

デュアルキュー サポート

priority および priority level コマンド)

サポートされていません。

ATM SPA を除くすべての SPA でサポート対象:Cisco IOS Release 12.2(33)SXI およびそれ以降

サポートされていません。

フローベース キューイング(均等化キューイング/WFQ)

fair-queue コマンド)

すべての SPA でサポートされます。

サポートされていません。

サポートされていません。

Low Latency Queueing(LLQ; 低遅延キューイング)/キューイング

bandwidth コマンド)

完全優先だけ:すべての SPA でサポートされます。

完全優先だけ:すべての SPA でサポートされます。

すべての SPA でサポートされます。1

Random Early Detection(RED; ランダム早期検出)

random-detect コマンド)

すべての SPA でサポートされます。

すべての SPA でサポートされます。

ATM SPA:最大 106 の一意の WRED 最小しきい値(min-th)、最大しきい値(max-th)、およびマーク ポータビリティ プロファイルがサポートされます。

その他の SPA:最大 128 の固有の WRED min-th、max-th、およびマーク ポータビリティ プロファイルがサポートされます。

サポートされていません。

Weighted RED(WRED; 重み付け RED)

次の例外を除き、すべての SPA でサポートされます。

WRED はブリッジド VC ではサポートされません。

次の制限付きで、すべての SPA でサポートされます。

WRED は、precedence および DSCP 値による分類を使用した場合に、ブリッジド VC でサポートされます。

サポートされていません。

4.Cisco 7600 SIP-600 のサポートは、Cisco IOS Release 12.2(33)SXH から削除され、Cisco IOS Release 12.2(33)SXI 以降のリリースに再追加されました。

QoS CBWFQ ポリシーを設定するには、グローバル コンフィギュレーション モードから次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# policy-map policy-map-name

トラフィック ポリシーを作成または変更し、ポリシー マップ コンフィギュレーション モードを開始します。

policy-map-name :設定するトラフィック ポリシーの名前を指定します。最大 40 の英数字を使用できます。

ステップ 2

Router (config-pmap)# class { class-name | class-default }

このポリシーを適用するトラフィック クラスの名前を指定し、ポリシー マップ クラス コンフィギュレーション モードを開始します。

class-name :設定済みのユーザ定義クラス名にポリシーを適用することを指定します。

class-default :デフォルトのトラフィック クラスにポリシーを適用することを指定します。

ステップ 3

Router(config-pmap-c)# bandwidth { bandwidth-kbps | percent percent }

ポリシー マップに属するクラスに割り当てる帯域幅を指定します。

(注) レイヤ 2 のオーバーヘッドにも対応できるだけの帯域幅容量を設定する必要があります。

bandwidth-kbps :クラスに割り当てる帯域幅容量(kbps)を指定します。

percent :使用可能な帯域幅の絶対パーセントに基づき、帯域幅保証の量を指定します。

percentage :percent キーワード(プライオリティ クラス用に設定する使用可能な総帯域幅の割合)と組み合わせて使用します。

ステップ 4

Router(config-pmap-c)# queue-limit number-of-packets

ポリシー マップに設定されたクラス ポリシー用にキューが保持できる最大パケット数を指定します。

number-of-packets :このクラスのキューが蓄積できるパケットの最大数を指定します。範囲は 1 ~ 64 です。

Cisco 7600 SIP-400 でのデュアル プライオリティ キューイングの設定

デュアル プライオリティ キューイングを設定する場合は、次の注意事項に従ってください。

2 つのプライオリティ レベルだけがサポートされます。

レベル 2 よりレベル 1 の方が高くなります。

伝播はどちらのレベルでもサポートされます。

レベルなしのプライオリティは、レベル 1 にマッピングされます。

帯域幅パーセントおよび他のキューの帯域幅予約の合計は、帯域幅の 100% を超えてはいけません。

ポリシング レートには、レイヤ 2 ヘッダーが含まれますが、CRC、プリアンブル、またはインターフェイス ギャップは含まれません。

デュアル プライオリティ キューイングは、ATM SPA でサポートされていません。

デュアル プライオリティ キューイングを設定するには、グローバル コンフィギュレーション モードから次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# policy-map policy-map-name

トラフィック ポリシーを作成または変更し、ポリシー マップ コンフィギュレーション モードを開始します。

policy-map-name :設定するトラフィック ポリシーの名前を指定します。最大 40 の英数字を使用できます。

ステップ 2

Router (config-pmap)# class { class-name | class-default }

このポリシーを適用するトラフィック クラスの名前を指定し、ポリシー マップ クラス コンフィギュレーション モードを開始します。

class-name :設定済みのユーザ定義クラス名にポリシーを適用することを指定します。

class-default :デフォルトのトラフィック クラスにポリシーを適用することを指定します。

ステップ 3

Router(config-pmap-c)# priority level [ 1 | 2 ]

ポリシー マップに属するトラフィック クラスにプライオリティを与えます。2 つのプライオリティ レベルがサポートされます。:1(高プライオリティ)および 2 (低プライオリティ)。レベルを指定しない場合、デフォルトのプライオリティ レベル 1 が割り当てられます。

Router(config-pmap-c)# priority [ level 1 | 2 ] kbps [ burst ]

条件別ポリシング レートを、トラフィックのクラスに指定するデータ レートとしてイネーブルにします。条件別ポリシングは、論理または物理リンクで輻輳が発生している場合に使用されます。

kbps :レートを kbps で指定します。範囲は 1 ~ 2480000 kbps です。

burst :(任意)バースト サイズをバイト数で指定します。範囲は 18 ~ 2000000 バイトです。バースト サイズはネットワークを設定し、トラフィックの一時バーストに対応させます。

Router(config-pmap-c)# priority [ level 1 | 2 ] percent percentage [ burst ]

条件別ポリシング レートを、トラフィックのクラスに指定する合計の帯域幅割合としてイネーブルにします。条件別ポリシングは、論理または物理リンクで輻輳が発生している場合に使用されます。

percentage :合計の帯域幅割合を指定します。範囲は 1 ~ 100 パーセントです。

burst :(任意)バースト サイズをバイト数で指定します。範囲は 18 ~ 2000000 バイトです。バースト サイズはネットワークを設定し、トラフィックの一時バーストに対応させます。

level キーワードは、次の例のように、ポリシング設定と組み合わせることができます。

Router(config-pmap-c)# priority level 2 1024 10000
Router(config-pmap-c)# priority level 2 percent 20 2000
 

SIP での QoS トラフィック シェーピング ポリシーの設定

ここでは、トラフィック シェーピングに関して QoS トラフィック ポリシーを設定する場合に考慮すべき、SIP および SPA 固有の注意事項について説明します。

QoS トラフィック シェーピング ポリシーの設定時の注意事項

SIP 上でキューイング機能を設定する場合は、次の注意事項に従ってください。

Catalyst 6500 シリーズ スイッチ は、さまざまな形式のキューイング機能をサポートします。SIP タイプ別にサポートされるトラフィック シェーピング機能は、 表 4-8 を参照してください。

フレームリレー マップ クラスで CBWFQ を使用し、最小帯域幅保証を実現する必要がある場合は、階層型ポリシーを使用します。最初に、必要な総帯域幅に合わせてシェーピングされるように親ポリシーを設定します(Cisco 7600 SIP-400 上で、Cisco IOS Release 12.2(18)SXF ではデフォルト クラス、Cisco IOS Release 12.2(33)SXH 以降はユーザ定義のクラスを使用)。次に、最小帯域幅割合について、CBWFQ を使用して子ポリシーを定義します。

ATM SPA は MQC ベースのトラフィック シェーピングをサポートしません。ATM レイヤ 2 VC シェーピングを使用して、ATM インターフェイスのトラフィック シェーピングを設定する必要があります。

輻輳管理機能の設定の詳細は、ご使用の Cisco IOS ソフトウェア リリースに対応する『 Cisco IOS Quality of Service Solutions Configuration Guide 』を参照してください

表 4-8 に、Catalyst 6500 シリーズ スイッチ上で SIP に関してサポートされる QoS トラフィック シェーピングの情報を示します。

 

表 4-8 SIP および SPA の組み合わせに基づく QoS トラフィック シェーピング機能の互換性

トラフィック シェーピング機能(shape コマンド)
Cisco 7600 SIP-200
Cisco 7600 SIP-400
Cisco 7600 SIP-6005

フレームリレーのアダプティブ シェーピング

shape adaptive コマンド)

すべての SPA でサポートされます。

サポートされていません。

サポートされていません。

クラス ベース シェーピング

shape average shape peak コマンド)

すべての SPA でサポートされます。

次の例外を除き、すべての SPA でサポートされます。

Committed Burst(Bc; 認定):サポートされません。

Excess Burst(Be; 超過バースト):サポートされません。

すべての SPA でサポートされるのは shape average だけです。1

帯域幅割合に基づいたトラフィックの平均速度に関するポリシー マップ クラス シェーピング

shape average percent コマンド)

サポートされていません。

すべての SPA でサポートされます。

サポートされていません。

Backward Explicit Congestion Notification(BECN; 逆方向明示的輻輳通知)に適応するポリシー マップ クラス シェーピング

shape adaptive コマンド)

すべての SPA でサポートされます。

サポートされていません。

サポートされていません。

Forward Explicit Congestion Notification(FECN; 順方向明示的輻輳通知)の反転を BECN として使用するポリシー マップ クラス シェーピング

shape fecn-adapt コマンド)

すべての SPA でサポートされます。

サポートされていません。

サポートされていません。

帯域幅割合に基づいたトラフィックのピーク速度に関するポリシー マップ クラス シェーピング

shape peak percent コマンド)

サポートされていません。

サポートされていません。

サポートされていません。

5.Cisco 7600 SIP-600 のサポートは、Cisco IOS Release 12.2(33)SXH から削除され、Cisco IOS Release 12.2(33)SXI 以降のリリースに再追加されました。

SIP での QoS トラフィック ポリシング ポリシーの設定

ここでは、QoS トラフィック ポリシング ポリシーを設定する場合に考慮すべき、SIP および SPA 固有の注意事項について説明します。

QoS トラフィック ポリシング ポリシーの設定時の注意事項

SIP 上でトラフィック ポリシングを設定する場合は、次の注意事項に従ってください。

Catalyst 6500 シリーズ スイッチは、 police コマンドを使用したさまざまな形式のポリシングをサポートします。SIP タイプ別にサポートされるポリシング機能は、 表 4-9 を参照してください。

Cisco 7600 SIP-600 上でポリシングを設定する場合は、次の注意事項に従ってください。

Cisco 7600 SIP-600 が conform-action ポリシングをサポートするのは、キューイングとともに実装しないかぎり、入力インターフェイスに限られます。

入力インターフェイス上で exceed-action または violate-action キーワードを使用した場合、Cisco 7600 SIP-600 は( 表 4-10 に記載された)いかなるポリシング アクションもサポートしません。

キューイングとともにポリシングを実装する場合、Cisco 7600 SIP-600 は drop アクションに限り、出力インターフェイス上で exceed-action ポリシングをサポートします。

Cisco 7600 SIP-600 は、 set-dscp-transmit コマンドを使用した場合、 exceed-action ポリシングのマーキングに限ってサポートします。

ポリシング サービス ポリシーを設定し、オプションの適合(bc)またはピーク(be)バーストをバイト数として指定せず、CIR を bps で指定した場合、Cisco 7600 SIP-400 は CIR 値を使用して 250 ms で伝送できるバイト数に基づき、バースト サイズを計算します。たとえば、1 Mbps(つまり 1,000,000 bps)の CIR は、125,000 bps、つまり 125 バイト/ミリ秒に相当します。計算上のバーストは、250 × 125 = 31250 バイトになります。計算上のバーストがインターフェイスの MTU に満たない場合は、インターフェイスの MTU がバースト サイズとして使用されます。

キューイングを指定してポリシングを使用すると、トラフィック レートを制限できます。

サービス ポリシーで、ポリシング アクションの一部としてクラス ベース マーキングとマーキングの両方を設定した場合、ポリシングを使用するマーキングがクラス ベース マーキングより優先されます。

Cisco 7600 SIP-200 および Cisco 7600 SIP-400 上で MPB 機能を設定した場合、 set-cos-inner-transmit アクションは Cisco IOS Release 12.2(33)SXH 以上でサポートされます。

表 4-9 に、Catalyst 6500 シリーズ スイッチ上で SIP に関してサポートされるポリシング機能の情報を示します。

 

表 4-9 SIP および SPA の組み合わせに基づく QoS ポリシング機能の互換性

ポリシング機能(police コマンド)
Cisco 7600 SIP-200
Cisco 7600 SIP-400
Cisco 7600 SIP-6006

集約 ポリサーによるポリシング

police agregate コマンド)

サポートされていません。

サポートされていません。

すべての SPA でサポートされます。1

トークン バケット アルゴリズムを使用する帯域幅に基づくポリシング

police コマンド)

すべての SPA でサポートされます。

すべての SPA でサポートされます。

すべての SPA でサポートされます。1

Committed Information Rate(CIR; 認定情報速度)の割合に基づくポリシング

police [percent] コマンド: police cir percent 形式)

すべての SPA でサポートされます。

すべての SPA でサポートされます。

サポートされていません。

2 色マーカーによるポリシング(CIR および PIR [Peak Information Rate; 最大情報レート])

police [two rates] コマンド: police cir pir 形式)

すべての SPA でサポートされます。

すべての SPA でサポートされます。

すべての SPA でサポートされます。1

フロー マスクによるポリシング

police flow mask コマンド)

サポートされていません。

サポートされていません。

すべての SPA でサポートされます。1

マイクロフローによるポリシング

police flow コマンド)

サポートされていません。

サポートされていません。

すべての SPA でサポートされます。1

6.Cisco 7600 SIP-600 のサポートは、Cisco IOS Release 12.2(33)SXH から削除され、Cisco IOS Release 12.2(33)SXI 以降のリリースに再追加されました。

ポリシングを指定して QoS トラフィック ポリシーを作成するには、グローバル コンフィギュレーション モードから次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# policy-map policy-map-name

トラフィック ポリシーを作成または変更し、ポリシー マップ コンフィギュレーション モードを開始します。

policy-map-name :設定するトラフィック ポリシーの名前を指定します。最大 40 の英数字を使用できます。

ステップ 2

Router (config-pmap)# class { class-name | class-default }

このポリシーを適用するトラフィック クラスの名前を指定し、ポリシー マップ クラス コンフィギュレーション モードを開始します。

class-name :設定済みのユーザ定義クラス名にポリシーを適用することを指定します。

class-default :デフォルトのトラフィック クラスにポリシーを適用することを指定します。

次のいずれかの形式の police コマンドを使用して、指定されたクラスのトラフィックを評価します。各種ポリシング機能をサポートする SIP は、 表 4-9 を参照してください。

ステップ 3

Router(config-pmap-c)# police bps [ burst-normal ] [ burst-max ] conform-action action exceed-action action violate-action action

トークン バケット アルゴリズムを使用してトラフィック クラスが使用できる最大帯域幅を指定します。

bps :平均速度をビット/秒で指定します。有効値は、8000 ~ 200000000です。

burst-normal :(任意)標準バースト サイズをバイト数で指定します。有効値は、1000 ~ 51200000です。デフォルトの標準バースト サイズは 1500 バイトです。

burst-max :(任意)超過バースト サイズをバイト数で指定します。有効値は、1000 ~ 51200000です。

action :対応する適合、超過、または違反トラフィックに適用するアクションを表すポリシング コマンド( 表 4-10 に記載)を指定します。

ステップ 4

Router(config-pmap-c)# police cir percent percentage [ burst-in-msec ] [ bc conform-burst-in-msec ] [ pir percent percentage ] [ be peak-burst-in-msec ] [ conform-action action [ exceed-action action [ violate-action action ]]]

インターフェイスで使用可能な帯域幅の割合に基づくトラフィック ポリシングを設定します。

cir percent percentage :CIR 帯域幅の割合を指定します。有効値は、1 ~ 100 です。

burst-i-msec :(任意)ミリ秒でバーストを表します。有効値は、1 ~ 2000 です。

bc conform-burst-in-msec :(任意)最初のトークン バケットがトラフィック ポリシングに使用する適合バースト(bc)サイズをミリ秒で指定します。有効値は、1 ~ 2000 です。

pir percent percentage :(任意)PIR 帯域幅割合を指定します。有効値は、1 ~ 100です。

be peak-burst-in-msec :(任意)2 番めのトークン バケットがトラフィック ポリシングに使用するピーク バースト(be)サイズをミリ秒で指定します。有効値は、1 ~ 2000 です。

action :対応する適合、超過、または違反トラフィックに適用するアクションを表すポリシング コマンド( 表 4-10 に記載)を指定します。

ステップ 5

Router(config-pmap-c)# police { cir cir } [ bc conform-burst ] { pir pir } [ be peak-burst ] [ conform-action action [ exceed-action action [ violate-action action ]]]

CIR および PIR という 2 つのレートを使用してトラフィック ポリシングを設定します。

cir cir :最初のトークン バケットが更新される CIR を bps の値として指定します。有効値は、8000 ~ 200000000です。

bc conform-burst :(任意)最初のトークン バケットがポリシングに使用する適合バースト(bc)サイズをバイト数で指定します。有効値は、1000 ~ 51200000です。

pir pir :2 番めのトークン バケットが更新される PIR を bps の値として指定します。有効値は、8000 ~ 200000000です。

be peak-burst :(任意)2 番めのトークン バケットがポリシングに使用するピーク バースト(be)サイズをバイト数で指定します。このサイズは、使用中のインターフェイスやプラットフォームによって異なります。

action :(任意)対応する適合、超過、または違反トラフィックに適用するアクションを表すポリシング コマンド( 表 4-10 に記載)を指定します。

ステップ 6

Router(config-pmap-c)# police flow { bits-per-second [ normal-burst-bytes ] [ maximum-burst-bytes ] [ pir peak-rate-bps ]} | [ conform-action action ] [ exceed-action action ] [ violate-action action ]

マイクロフロー ポリサーを設定します。

bits-per-second :CIR をビット/秒で指定します。有効値は 32000 ~ 4000000000 bps です。

normal-burst-bytes :(任意)CIR トークン バケット サイズを指定します。有効値は、1000 ~ 512000000 バイトです。

maximum-burst-bytes :(任意)PIR トークン バケット サイズを指定します。有効値は、1000 ~ 32000000 バイトです。

pir peak-rate-bps :(任意)PIR を bps で指定します。有効値は 32000 ~ 4000000000 bps です。

action :対応する適合、超過、または違反トラフィックに適用するアクションを表すポリシング コマンド( 表 4-10 に記載)を指定します。

ステップ 7

Router(config-pmap-c)# police flow mask { dest-only | full-flow | src-only } { bits-per-second [ normal-burst-bytes ] [ maximum-burst-bytes ]} [ conform-action action ] [ exceed-action action ]

ポリシングに使用するフロー マスクを設定します。

dest-only :宛先だけのフロー マスクを指定します。

full-flow :フルフロー マスクを指定します。

src-only :送信元だけのフロー マスクを指定します。

bits-per-second :CIR をビット/秒で指定します。有効値は 32000 ~ 4000000000 bps です。

normal-burst-bytes :(任意)CIR トークン バケット サイズを指定します。有効値は、1000 ~ 512000000 バイトです。

maximum-burst-bytes :(任意)PIR トークン バケット サイズを指定します。有効値は、1000 ~ 32000000 バイトです。

action :対応する適合または超過トラフィックに適用するアクションを表すポリシング コマンド( 表 4-10 に記載)を指定します。

ステップ 8

Router(config-pmap-c)# police aggregate name

定義済みの集約 ポリサー名を指定し、指定された集約 ポリサーの 名前 を使用するようにポリシー マップを設定します。

表 4-10 に、Catalyst 6500 シリーズ スイッチ上で SIP に関してサポートされるポリシング アクションの情報を示します。


「QoS トラフィック ポリシング ポリシーの設定時の注意事項」を参照し、各種ポリシング アクション(適合、超過、または違反アクション)と特定のマーキング機能を組み合わせて使用する場合の制約事項を確認してください。


 

表 4-10 SIP および SPA の組み合わせに基づく QoS ポリシング アクションの互換性

ポリシング アクション
(set コマンド)
Cisco 7600 SIP-200
Cisco 7600 SIP-400
Cisco 7600 SIP-6007

パケットをドロップします。

drop コマンド)

すべての SPA でサポートされます。

すべての SPA でサポートされます。

すべての SPA でサポートされます:入力インターフェイスだけ

ATM CLP ビットを 1 に設定し送信します。

set-clp-transmit コマンド)

すべての SPA でサポートされます。

すべての SPA でサポートされます。

サポートされていません。

インナー CoS 値を設定し送信します。

set-cos-inner-transmit コマンド)

ブリッジング機能を使用する場合に、Cisco IOS Release 12.2(33)SXH でサポートされます。

ブリッジング機能を使用する場合に、Cisco IOS Release 12.2(33)SXH でサポートされます。

サポートされていません。

フレームリレー DE ビットを 1 に設定し送信します。

set-frde-transmit コマンド)

すべての SPA でサポートされます。

すべての SPA でサポートされます。

サポートされていません。

IP precedence を設定し送信します。

set-prec-transmit コマンド)

すべての SPA でサポートされます。

すべての SPA でサポートされます。

すべての SPA でサポートされます:入力インターフェイスだけ1

IP DSCP を設定し送信します。

set-dscp-transmit コマンド)

すべての SPA でサポートされます。

すべての SPA でサポートされます。

すべての SPA でサポートされます:入力インターフェイスだけ1

インポジションの MPLS EXP ビット(0 ~ 7)を設定し送信します。

set-mpls-experimental-imposition-transmit コマンド)

すべての SPA でサポートされます。

すべての SPA でサポートされます。

すべての SPA でサポートされます。1

topmost ラベルの MPLS EXP ビットを設定し送信します。

set-mpls-experimental-topmost-transmit コマンド)

すべての SPA でサポートされます。

すべての SPA でサポートされます。

すべての SPA でサポートされます。1

変更しないですべてのパケットを送信します。

transmit コマンド)

すべての SPA でサポートされます。

すべての SPA でサポートされます。

すべての SPA でサポートされます。1

7.Cisco 7600 SIP-600 のサポートは、Cisco IOS Release 12.2(33)SXH から削除され、Cisco IOS Release 12.2(33)SXI 以降のリリースに再追加されました。

インターフェイスへの QoS トラフィック ポリシーの結合

トラフィック クラスでトラフィック ポリシーをイネーブルにするには、インターフェイス上でトラフィック ポリシーを設定しておく必要があります。ATM PVC サブインターフェイス、フレームリレー DLCI、およびイーサネット サブインターフェイスにトラフィック ポリシーを結合することもできます。

トラフィック ポリシーは、インターフェイス(入力)に着信するトラフィックおよびそのインターフェイス(出力)から送信されるトラフィックに適用できます。

入力インターフェイスへの QoS トラフィック ポリシーの結合

入力インターフェイスにトラフィック ポリシーを結合すると、そのインターフェイスに着信したトラフィックにポリシーが適用されます。入力インターフェイスにトラフィック ポリシーを結合するには、インターフェイス コンフィギュレーション モードから次のコマンドを使用します。

 

コマンド
目的

Router(config-if)# service-policy input policy-map-name

インターフェイスの入力方向にトラフィック ポリシーを結合します。

policy-map-name :設定するトラフィック ポリシーの名前を指定します。

出力インターフェイスへの QoS トラフィック ポリシーの結合

出力インターフェイスにトラフィック ポリシーを結合すると、そのインターフェイスから送信されるトラフィックにポリシーが適用されます。出力インターフェイスにトラフィック ポリシーを結合するには、インターフェイス コンフィギュレーション モードから次のコマンドを使用します。

 

コマンド
目的

Router(config-if)# service-policy output policy-map-name

インターフェイスの出力方向にトラフィック ポリシーを結合します。

policy-map-name :設定するトラフィック ポリシーの名前を指定します。

NBAR および dNBAR の設定


) Network-Based Application Recognition(NBAR)および distributed Network-Based Application Recognition(dNBAR)は Cisco 7600 SIP-200 でだけサポートされます。


IP QoS の目的は、アプリケーションに適切なネットワーク リソース(帯域幅、遅延、ジッタ、およびパケット損失)を提供することです。QoS は、ミッション クリティカルなアプリケーションが必要とするパフォーマンスを実現し、非クリティカル アプリケーションがクリティカル アプリケーションのパフォーマンスを阻害しないようにして、ネットワーク インフラストラクチャの ROI(投資収益率)を最大化します。

IP QoS を配置するには、アプリケーションのクラスまたはカテゴリを定義します。これらのクラスは、Cisco IOS ソフトウェアで使用可能なさまざまな分類技術を使用して定義されます。これらのクラスを定義して、インターフェイスに関連付けたら、マーキング、輻輳管理、輻輳回避、リンク効率化メカニズム、ポリシングやシェーピングなど、目的の QoS 機能を分類済みトラフィックに適用して、定義されたクラスに適切なネットワーク リソースを提供できます。

したがって、分類はネットワーク インフラストラクチャに QoS を設定するうえで重要な最初のステップとなります。

NBAR は、ダイナミック TCP/UDP ポート割り当てを利用する Web ベース プロトコルや、分類しにくいその他のプロトコルを含む、さまざまなアプリケーションを認識する分類エンジンです。アプリケーションが NBAR によって認識および分類されると、ネットワークはそのアプリケーションに応じたサービスを起動できます。NBAR により、パケットが分類され、分類されたトラフィックに QoS が適用されて、ネットワーク帯域幅が効率的に使用されます。NBAR によるトラフィック分類後にトラフィックで使用できるクラス ベース QoS 機能の例を、次に示します。

クラス ベース マーキング( set コマンド)

CBWFQ( bandwidth および queue-limit コマンド)

LLQ( priority コマンド)

トラフィック ポリシング( police コマンド)

トラフィック シェーピング( shape コマンド)


) NBAR 機能は、プロトコルを基準としてトラフィックを分類する場合に使用します。その他のクラス ベース QoS 機能は、分類されたトラフィックの転送方法を決定します。これらの機能は、NBAR とは別に記述されています。

また、NBAR はネットワーク トラフィックを分類して、QoS 機能を分類済みトラフィックに適用できるようにする唯一の機能ではありません。

NBAR で分類されたトラフィックの転送に使用できるクラス ベース機能の詳細は、各クラス ベース機能の各機能モジュール、および『Cisco IOS Quality of Service Solutions Configuration Guide』を参照してください。

QoS の NBAR 以外の分類オプションの多くは、『Cisco IOS Quality of Service Solutions Configuration Guide』の「Modular Quality of Service Command-Line Interface」に記載されています。これらのコマンドは、クラス マップ コンフィギュレーション モードで match コマンドを使用して設定します。


NBAR は、レイヤ 4 からレイヤ 7 でアプリケーションおよびプロトコルを識別する新しい分類機能をいくつか導入します。

静的に割り当てられた TCP および UDP ポート番号

非 UDP および非 TCP IP プロトコル

動的に割り当てられた TCP および UDP ポート番号。このようなアプリケーションの分類には、ポートが割り当てられた接続を解析して、分類するデータ接続を検出する、ステートフル インスペクション機能が必要です。

サブポートの分類、またはディープ パケット インスペクション(パケットの中身をさらに詳しく参照して行う分類)に基づく分類

NBAR は、スタティック ポート プロトコルを分類できます。Access Control List(ACL; アクセス コントロール リスト)をこの目的のために使用することもできますが、設定は NBAR の方が容易で、ACL を使用すると取得できない分類統計情報が得られます。

NBAR には、インターフェイスを通過するアプリケーション プロトコルを簡単に検出できるプロトコル ディスカバリ機能があります。プロトコル ディスカバリ機能は、NBAR でサポートされているすべてのプロトコル トラフィックを検出します。プロトコル ディスカバリは、イネーブル化されたインターフェイスに関する統計情報(入出力パケットおよびバイトの総数、入出力ビット レート)をプロトコル単位で維持します。プロトコル ディスカバリ機能は、ネットワーク内の各プロトコルに対応する主要統計情報を取得します。これらの統計情報は、トラフィック クラスおよび各トラフィック クラスの QoS ポリシーを定義する場合に使用できます。

NBAR および dNBAR の設定方法の詳細は、次の URL にある『 Network-Based Application Recognition and Distributed Network-Based Application Recognition 』を参照してください。

http://www.cisco.com/en/US/docs/ios/12_1/12_1e11/feature/guide/dtnbarad.html

SIP での階層型 QoS の設定

表 4-11 に、SPA インターフェイスの階層型 QoS 機能がサポートされる状況を示します。

 

表 4-11 SIP および SPA の組み合わせに基づく階層型 QoS 機能の互換性

機能
Cisco 7600 SIP-200
Cisco 7600 SIP-400
Cisco 7600 SIP-6008

EoMPLS VC の 階層型 QoS

Cisco IOS Release 12.2(18)SXE 以上および Cisco IOS Release 12.2(33)SXH のすべての SPA でサポートされます。

Cisco IOS Release 12.2(33)SXH 以降、すべての SPA でサポートされます。

Cisco IOS Release 12.2(18)SXF ではすべての SPA でサポートされます。1

Cisco 7600 SIP-600 のサポートは、Cisco IOS Release 12.2(33)SXH から削除され、Cisco IOS Release 12.2(33)SXI 以降のリリースに再追加されました。

階層型 QoS:メイン インターフェイスでデフォルト クラスだけを使用する、親ポリシーの設定された層構造のポリシー マップ

該当しません。

Cisco IOS Release 12.2(18)SXF 以降、すべての SPA でサポートされます。

Cisco IOS Release 12.2(18)SXF でサポートされます。1

Cisco 7600 SIP-600 のサポートは、Cisco IOS Release 12.2(33)SXH から削除され、Cisco IOS Release 12.2(33)SXI 以降のリリースに再追加されました。

階層型 QoS:メイン インターフェイスでユーザ定義クラスまたはデフォルト クラスを使用する、親ポリシーの設定された層構造のポリシー マップ

Cisco IOS Release 12.2(18)SXF 以上および Cisco IOS Release 12.2(33)SXH のすべての SPA でサポートされます。

Cisco IOS Release 12.2(33)SXH ではすべての SPA でサポートされます。

サポートされていません。

8.Cisco 7600 SIP-600 のサポートは、Cisco IOS Release 12.2(33)SXH から削除され、Cisco IOS Release 12.2(33)SXI 以降のリリースに再追加されました。

層構造ポリシー マップを使用する階層型 QoS の設定

層構造ポリシー マップを使用する階層型 QoS は、クラスと対応付けられたアクションにキューイング アクション(シェーピングなど)およびネストのサービス ポリシー(それ自体がクラスおよびアクションを伴うポリシー マップ)が含まれる設定です。この QoS ポリシー マップの階層はさらに、対応するキューの階層に変換されます。

層構造ポリシー マップを使用する階層型 QoS の設定時の注意事項

SIP 上で層構造ポリシー マップを使用する階層型 QoS を設定する場合は、次の注意事項に従ってください。

層構造ポリシー マップを使用する階層型 QoS がサポートされる状況の詳細は、表 4-11を参照してください。

ポリシー マップ内に最大 3 段階の階層を設定できます。

親ポリシー マップは、メイン インターフェイスに関して次の制約事項があります。

Cisco IOS Release 12.2(18)SFX 以上:シェープ キューイング アクションがサポートされるのは、デフォルト クラス(class-default)だけです。

Cisco IOS Release 12.2(33)SXH:VLAN または ACL マッチングがサポートされます。さらに、ユーザ定義またはデフォルト クラスのあらゆるクラスで、シェープまたは帯域幅キューイング アクションがサポートされます。

Cisco 7600 SIP-600 上でソフトウェア ベース EoMPLS 対応の階層型 QoS を設定し、親ポリシーに match input vlan を設定した場合、子ポリシーに設定できるのは match qos-group だけです。

階層型 QoS の場合、親ポリシーに set コマンドを単独で設定できません。 set コマンドが有効なのは、ポリシーに他のコマンドを設定した場合に限られます。

子ポリシー マップでは、シェープ、帯域幅、および WRED QoS 機能がサポートされます。

サブインターフェイス上の階層型 QoS の場合、親ポリシー マップで階層型 QoS がサポートされるのは、デフォルト クラス(class-default)のキューイング アクションとして shape average コマンドを使用した場合だけです。

親ポリシーと子ポリシーの両方にシェーピングを設定した場合、トラフィックは先に親ポリシーで定義されたパラメータに基づいてシェーピングされ、その後で子ポリシーのパラメータに基づいてシェーピングされます。

メイン インターフェイス、サブインターフェイス、および VC レベルでサービス ポリシーを設定した場合、VC レベルで適用されるポリシーがインターフェイスのポリシーより優先されます。

フレームリレー設定では、インターフェイス、サブインターフェイス、および PVC で同時にサービス ポリシーを定義しなければならない場合は、マップ クラスを使用できます。

フレームリレー PVC が設定された POS サブインターフェイスの場合、サブインターフェイスまたは PVC のいずれかで、サービス ポリシーを適用できます。両方では適用できません。

マップ クラスで CBWFQ を使用し、最小帯域幅保証を達成する必要がある場合は、階層型ポリシーを使用します。最初に、必要な総帯域幅に合わせてシェーピングされるように親ポリシーを設定します(Cisco IOS Release 12.2(18)SXF ではデフォルト クラス、Cisco IOS Release 12.2(33)SXH 以降はユーザ定義のクラスを使用)。次に、最小帯域幅割合について、CBWFQ を使用して子ポリシーを定義します。

設定できる階層型 QoS の最大数は、現在の Cisco IOS ソフトウェアの制限に従って次のようになります。

最大 1024 のクラス マップ

最大 1024 のポリシー マップ

ポリシー マップ内で最大 256 のクラス

EoMPLS VC の HQoS の設定

EoMPLS VC の HQoS 機能は、現在のサポート機能を QoS ポリシー マップ内の階層的な親子関係に対応するように拡張します。また、ポイントツーポイント VC の VC QoS ごとに EoMPLS も提供します。

新機能は、パケットがスイッチで最初に受信されたときに、パケット上の VLAN ID を照合する機能を追加します。また、同じ IP precedence 値に設定された QoS グループ、または着信インターフェイスで受信された 802.1P CoS ビットに基づいて照合する機能もサポートします。サービス プロバイダーはこの機能を使用して、特定の EoMPLS ネットワークのすべてまたは一部についてトラフィックを簡単に分類したり、カスタマーの元の Differentiated Services(DiffServ; 差別化サービス)QoS 値を保護したりすることができます。

EoMPLS アプリケーションでは、親ポリシー マップは通常、EoMPLS ネットワーク内の特定の VC グループの最大帯域幅または最小帯域幅を指定します。ポリシー内の子ポリシー マップは別の帯域幅を実装したり、選択された VC のサブセットに別の QoS 処理(トラフィック シェーピングなど)を実行したりすることができます。

サービス プロバイダーはこの機能を使用して、より精密な QoS サービスをカスタマーに提供できます。また、カスタマーの IP precedence または CoS 値をネットワーク内で保護することもできます。


) EoMPLS VC 対応の HQoS がサポートされる状況の詳細は、表 4-11を参照してください。


EoMPLS VC 対応 HQoS の設定の詳細は、次の URL にアクセスして、Cisco 7600 シリーズ ルータの『 OSM Configuration Note 』の「HQoS for EoMPLS Virtual Circuit」を参照してください。

http://www.cisco.com/en/US/docs/routers/7600/install_config/12.2SR_OSM_config/mpls.html#wp1159857

Cisco 7600 SIP-600 での PFC QoS の設定


) Cisco 7600 SIP-600 のサポートは、Cisco IOS Release 12.2(33)SXH から削除され、Cisco IOS Release 12.2(33)SXI 以降のリリースに再追加されました。


Cisco 7600 SIP-600 は、Catalyst 6500 シリーズ スイッチの Policy Feature Card(PFC; ポリシー フィーチャ カード)でサポートされているのと同じ QoS 機能をほとんどサポートしています。

ここでは、SIP 固有の設定時の注意事項がある QoS 機能について説明します。このマニュアルに記載された SIP 固有の注意事項を検討してから、次の URL にある『 Cisco 7600 Series Cisco IOS Software Configuration Guide 12.2SX を参照してください。

http://www.cisco.com/en/US/docs/routers/7600/ios/12.2SXF/configuration/guide/swcg.html

Cisco 7600 SIP-600 上での PFC QoS 設定時の注意事項

Cisco 7600 SIP-600 には、次のように適用されます。

出力ポリシングはサポートされません。

SIP のリセット

SIP をリセットするには、特権 EXEC コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

Router# hw-module module slot reset

 

指定されたスロットの SIP の電源をオフおよびオンにします。

slot SIP が搭載されたシャーシ スロット番号を指定します。

設定例

ここでは、Catalyst 6500 シリーズ スイッチに搭載された SIP の設定例を示します。

「トランク モード BCP の設定例」

「QoS の設定例」

トランク モード BCP の設定例

トランク モードで BCP を設定する例を示します。

! Enter global configuration mode.
!
Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
!
! Specify the interface address.
!
Router(config)# interface pos4/1/0
!
! Put the interface in Layer 2 mode for Layer 2 configuration.
 
Router(config-if)# switchport
%Please shut/no shut POS4/1/0 to bring up BCP
!
! When the switchport command is configured, the interface is automatically configured for ! trunk mode and nonegotiate status.
! Restart the interface to enable BCP.
!
Router(config-if)# shutdown
Router(config-if)# no shutdown
!
! Enable all VLANs for receiving and transmitting traffic on the trunk.
!
Router(config-if)# switchport trunk allowed vlan all
%Internal vlans not available for bridging:1006-1018,1021
 

次に、この設定に対応する、 show running-config コマンドの出力例を示します。 switchport コマンドが設定されている場合、 switchport mode trunk および switchport nonegotiate コマンドは自動的に生成されます。

Router# show running-config interface pos4/1/0
Building configuration...
Current configuration : 191 bytes
!
interface POS4/1/0
switchport
switchport trunk allowed vlan all
switchport mode trunk
switchport nonegotiate
no ip address
encapsulation ppp
clock source internal
end

QoS の設定例

ここでは、次の QoS 設定の例を示します。

「MPB を使用する QoS の設定例」

「2 レベルのポリシー マップを使用する階層型 QoS の設定例」

MPB を使用する QoS の設定例

SIP および SPA は、MPB 設定で QoS 機能のサブセットをサポートします。

Cisco 7600 SIP-200 および Cisco 7600 SIP-400 上の ATM ブリッジング、フレームリレー ブリッジング、MPB、および BCP の各機能に関しては、Cisco IOS Release 12.2(33) SXH 以降、ブリッジド フレームで次のマッチング機能がサポートされます。

ATM CLP ビットのマッチング

フレームリレー DE ビットのマッチング

フレームリレー DLCI のマッチング

インナー VLAN のマッチング

インナー COS のマッチング

IP DSCP のマッチング(入力インターフェイスに限る)

Cisco 7600 SIP-200 および Cisco 7600 SIP-400 上の ATM ブリッジング、フレームリレー ブリッジング、MPB、および BCP の各機能に関しては、Cisco IOS Release 12.2(33) SXH 以降、ブリッジド フレームで次のマーキング機能がサポートされます。

ATM CLP ビットの設定(出力インターフェイスに限る)

フレームリレー DE ビットの設定(出力インターフェイスに限る)

インナー COS の設定

Cisco 7600 SIP-200 および Cisco 7600 SIP-400 上の ATM ブリッジング、フレームリレー ブリッジング、MPB、および BCP の各機能に関しては、Cisco IOS Release 12.2(33) SXH 以降、ブリッジド フレームでポリシングとともに次のマーキング機能がサポートされます。

インナー COS の設定

SIP および SPA 上での QoS 設定の詳細は、「SIP での QoS 機能の設定」を参照してください。

ここでは、MPB を使用する QoS の設定例を示します。

「SIP および SPA で MPB を使用してすべてのトラフィックのインナー VLAN タグをマッチングする例」

「SIP および SPA で MPB を使用してインナー COS 値をマーキングする例」

「SIP および SPA で MPB を使用する場合の QoS マッチング、シェーピング、およびマーキングの設定例」

「SIP および SPA に対応する ポリシング アクションとしてインナー CoS 値を設定する例」

SIP および SPA で MPB を使用してすべてのトラフィックのインナー VLAN タグをマッチングする例

SPA 上でブリッジング機能を使用している場合、パケットのインナー VLAN ID についてトラフィックをマッチングできます。次に、vlan-inner-100 というクラスに分類される、VLAN 100 のすべてのブリッジド トラフィックをフィルタリングする、QoS クラスの設定例を示します。その後、clan-inner-100 クラスから VLAN 100 へのすべての送信トラフィックをブリッジングする SPA インターフェイスに、出力サービス ポリシーが適用されます。

! Configure the class maps with your matching criteria.
!
Router(config)# class-map match-all vlan-inner-100
Router(config-cmap)# match vlan inner 100
!
! Apply the service policy to an input or output bridged interface or VC.
!
Router(config)# interface atm3/0/0
Router(config-if)# pvc 100/100
Router(config-if-atm-vc)# bridge-domain 100 dot1q
Router(config-if-atm-vc)# service-policy output vlan-inner-100
Router(config-if)# end

SIP および SPA で MPB を使用してインナー COS 値をマーキングする例

次に、VLAN 100 で一致するすべてのトラフィックをクラス vlan-inner-100 にフィルタリングする QoS(サービス品質)クラスを設定する例を示します。この設定では、vlan-inner-100 クラスに属するトラフィックに内部 CoS 値として 3 をマークするポリシーマップ(vlan-inner-100)の定義を示します。インナー CoS 値のマーキングはブリッジング 機能を使用する場合に限ってサポートされるため、 bridge-domain コマンドを使用して VLAN 100 にトラフィックをブリッジングするシリアル SPA インターフェイスに、出力ポリシーとして適用されるサービス ポリシーも示します。

! Configure the class maps with your matching criteria.
!
Router(config)# class-map match-all vlan-inner-100
Router(config-cmap)# match vlan inner 100
Router(config-cmap)# exit
!
! Configure the policy map to mark all traffic in a class.
!
Router(config)# policy-map vlan-inner-100
Router(config-pmap)# class vlan-inner-100
Router(config-pmap-c)# set cos-inner 3
Router(config-pmap-c)# exit
Router(config-pmap)# exit
!
! Apply the service policy to an input or output bridged interface or VC.
!
Router(config)# interface serial3/0/0
Router(config-if)# no ip address
Router(config_if)# encapsulation ppp
Router(config-if)# bridge-domain 100 dot1q
Router(config-if)# service-policy output vlan-inner-100
Router(config-if)# shutdown
Router(config-if)# no shutdown
Router(config-if)# end

SIP および SPA で MPB を使用する場合の QoS マッチング、シェーピング、およびマーキングの設定例

次に、SIP および SPA 上で MPB を使用する場合の、マッチング、シェーピング、およびマーキングに関する QoS 設定全体の例を示します。

! Configure the class maps with your matching criteria.
! The following class maps configure matching on the inner VLAN ID.
!
Router(config)# class-map match-all vlan100
Router(config-cmap)# match vlan inner 100
Router(config-cmap)# exit
Router(config)# class-map match-all vlan200
Router(config-cmap)# match vlan inner 200
Router(config-cmap)# exit
Router(config)# class-map match-all vlan300
Router(config-cmap)# match vlan inner 300
Router(config-cmap)# exit
!
! The following class maps configure matching on the inner COS value.
!
Router(config)# class-map match-all cos0
Router(config-cmap)# match cos inner 0
Router(config-cmap)# exit
Router(config)# class-map match-all cos1
Router(config-cmap)# match cos inner 1
Router(config-cmap)# exit
Router(config)# class-map match-all cos2
Router(config-cmap)# match cos inner 2
Router(config-cmap)# exit
Router(config)# class-map match-all cos7
Router(config-cmap)# match cos inner 7
Router(config-cmap)# exit
!
! Configure a policy map for the defined classes.
! The following policies define shaping characteristics for classes
! on different VLANs
!
Router(config)# policy-map vlan100
Router(config-pmap)# class cos1
Router(config-pmap-c)# bandwidth percent 10
Router(config-pmap-c)# exit
Router(config-pmap)# class cos2
Router(config-pmap-c)# bandwidth percent 20
Router(config-pmap-c)# exit
Router(config-pmap)# class cos7
Router(config-pmap-c)# percent 30
Router(config-pmap-c)# exit
Router(config-pmap)# exit
Router(config)# policy-map vlan200
Router(config-pmap)# class cos1
Router(config-pmap-c)# bandwidth percent 10
Router(config-pmap-c)# exit
Router(config-pmap)# class cos2
Router(config-pmap-c)# bandwidth percent 20
Router(config-pmap-c)# exit
Router(config-pmap)# class cos7
Router(config-pmap-c)# percent 30
Router(config-pmap-c)# exit
Router(config-pmap)# exit
!
! The following policy map defines criteria for an output interface using MPB
!
Router(config)# policy-map egress_mpb
Router(config-pmap)# class vlan100
Router(config-pmap-c)# bandwidth percent 30
Router(config-pmap-c)# service-policy vlan100
Router(config-pmap-c)# exit
Router(config-pmap)# class vlan200
Router(config-pmap-c)# bandwidth percent 40
Router(config-pmap-c)# service-policy vlan200
!
! The following policy map defines criteria for an input interface using MPB
!
Router(config)# policy-map ingress_mpb
Router(config-pmap)# class vlan100
Router(config-pmap-c)# set cos-inner 5
Router(config-pmap-c)# exit
Router(config-pmap)# class vlan200
Router(config-pmap-c)# set cos-inner 3
!
! The following policy map defines criteria for an ATM output interface using MPB
! Note: You can only mark ATM CLP on an ATM output interface with MPB
!
Router(config)# policy-map atm_clp
Router(config-pmap)# class cos1
Router(config-pmap-c)# set atm-clp
Router(config-pmap-c)# exit
Router(config-pmap)# class cos2
Router(config-pmap-c)# set atm-clp
Router(config-pmap-c)# exit
Router(config-pmap)# exit
!
! Configure an interface for MPB and apply the service policies.
! The following example configures a POS interface in BCP trunk mode and applies two
! different service policies for the output and input traffic on the interface.
!
Router(config)# interface POS3/0/0
Router(config-if)# switchport
Router(config-if)# shutdown
Router(config-if)# no shutdown
Router(config-if)# switchport trunk allowed vlan 100,200,300
Router(config-if)# service-policy output egress_mpb
Router(config-if)# service-policy input ingress_mpb
!
! The following example configures an ATM interface with bridging on VLAN 100
! and applies a service policy for setting the ATM CLP for the output traffic.
!
Router(config)# interface ATM 4/1/0
Router(config-if)# pvc 1/100
Router(config-if-atm-vc)# bridge-domain 100
Router(config-if-atm-vc)# service-policy output atm-clp

SIP および SPA に対応する ポリシング アクションとしてインナー CoS 値を設定する例

次に、VLAN 100 のすべてのトラフィックをクラス vlan-inner-100 にフィルタリングし、vlan-inner-100 クラスのトラフィック シェーピング ポリシーを確立する QoS クラスの設定例を示します。サービス ポリシーで CIR は 20%、PIR は 40% にトラフィックを制限し、適合バースト(bc)を 300 ms、ピーク バースト(be)を 400 ms とし、インナー CoS 値を 3 に設定します。インナー CoS 値はブリッジング 機能を使用する場合に限ってサポートされるため、 bridge-domain コマンドを使用して VLAN 100 にトラフィックをブリッジングする ATM SPA インターフェイスの Permanent Virtual Circuit(PVC; 相手先固定接続)に、出力ポリシーとして適用されるサービス ポリシーも示します。

! Configure the class maps with your matching criteria
!
Router(config)# class-map match-all vlan-inner-100
Router(config-cmap)# match vlan inner 100
Router(config-cmap)# exit
!
! Configure the policy map to police all traffic in a class and mark conforming traffic
! (marking traffic whose rate is less than the conform burst)
!
Router(config)# policy-map vlan-inner-100
Router(config-pmap-c)# police cir percent 20 bc 300 ms be 400 ms pir percent 40 conform-action set-cos-inner-transmit 3
Router(config-pmap-c)# exit
Router(config-pmap)# exit
!
! Apply the service policy to an input or output bridged interface or VC.
!
Router(config)# interface atm3/0/0
Router(config-if)# pvc 100/100
Router(config-if-atm-vc)# bridge-domain 100 dot1q
Router(config-if-atm-vc)# service-policy output vlan-inner-100
Router(config-if)# end

2 レベルのポリシー マップを使用する階層型 QoS の設定例

次に、2 レベルの階層型キュー(3 レベルまで設定可能)にマッピングされる階層型 QoS の設定例を示します。第 1 レベルのポリシー(親ポリシー)で、class-default クラスに関して、集約データ レートを 1 Mbps にシェーピングする設定をします。第 2 レベルのポリシー(子ポリシー)で、User-A クラスのトラフィックを帯域幅の 40%、User-B クラスのトラフィックを帯域幅の 60% に設定します。

この例では、class-default クラスに適用される親ポリシーが示されているため、Cisco IOS Release 12.2(33)SXF 以上、および Cisco IOS Release 12.2(33)SXH でサポートされます。

! Configure the class maps with your matching criteria
!
Router(config)# class-map match-any User-A
Router(config-cmap)# match access-group A
Router(config-cmap)# exit
Router(config)# class-map match-any User-B
Router(config-cmap)# match access-group B
Router(config-cmap)# exit
!
! Configure the parent policy for class-default to shape
! all traffic in that class and apply a second-level policy.
!
Router(config)# policy-map parent
Router(config-pmap)# class class-default
Router(config-pmap-c)# shape 1000000
Router(config-pmap-c)# service-policy child
Router(config-pmap-c)# exit
Router(config-pmap)# exit
!
! Configure the child policy to allocate different percentages of
! bandwidth by class.
!
Router(config)# policy-map Child
Router(config-pmap)# class User-A
Router(config-pmap-c)# bandwidth percent 40
Router(config-pmap-c)# exit
Router(config-pmap)# class User-B
Router(config-pmap-c)# bandwidth percent 60
Router(config-pmap-c)# exit
Router(config-pmap)# exit
!
! Apply the parent service policy to an input or output interface.
!
Router(config)# interface GigabitEthernet 2/0/0
Router(config-if)# service-policy output parent
 

次に、2 レベルの階層型キューにマッピングされる、階層型 QoS の設定例を示します。親ポリシーで、user-defined クラスと class-default クラスの両方に平均トラフィック シェーピング レートを設定します。この設定は、Cisco IOS Release 12.2(33)SXH およびそれ以降のリリースでサポートされます。この設定には、対応するクラス マップの設定が含まれていませんが、これらのポリシー マップをサポートするには、クラス マップも必要です。

! Configure the parent policy for user-defined and class-default classes to shape
! traffic in those classes and apply a second-level policy.
!
Router(config)# policy-map parent
Router(config-pmap)# class input-vlan100
Router(config-pmap-c)# shape average 100000
Router(config-pmap-c)# service-policy child-pm
Router(config-pmap-c)# exit
Router(config-pmap)# class input-vlan200
Router(config-pmap-c)# shape average 100000
Router(config-pmap-c)# service-policy child-pm
Router(config-pmap-c)# exit
Router(config-pmap)# class class-default
Router(config-pmap-c)# shape average 200000
Router(config-pmap-c)# service-policy child-pm
Router(config-pmap-c)# exit
Router(config-pmap)# exit
!
! Configure the child policy to allocate different percentages of
! bandwidth by class.
!
Router(config)# policy-map child-pm
Router(config-pmap)# class cos0
Router(config-pmap-c)# bandwidth percent 10
Router(config-pmap-c)# exit
Router(config-pmap)# class cos1
Router(config-pmap-c)# bandwidth percent 10
Router(config-pmap-c)# exit
Router(config-pmap)# exit
!
! Apply the parent service policy to an input or output interface.
!
Router(config)# interface gigabitethernet 2/0/0
Router(config-if)# service-policy output parent-pm