Catalyst 6500 シリーズ スイッチ SIP、SSC、およ び SPA ソフトウェア コンフィギュレーション ガイド
ファスト イーサネットおよびギガビット イー サネット SPA の設定
ファスト イーサネットおよびギガビット イーサネット SPA の設定
発行日;2012/02/01 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 18MB) | フィードバック

目次

ファスト イーサネットおよびギガビット イーサネット SPA の設定

設定作業

必要な設定作業

SPA のインターフェイス アドレスの指定

インターフェイスの MAC アドレスの変更

MAC アドレスの確認

MAC アドレス アカウンティング統計情報の取得

HSRP の設定

HSRP の確認

インターフェイスの MTU サイズの変更

インターフェイス MTU の設定時の注意事項

レイヤ 2 ポートのインターフェイス MTU に関する注意事項

インターフェイス MTU の設定作業

MTU サイズの確認

カプセル化タイプの設定

インターフェイスの自動ネゴシエーションの設定

自動ネゴシエーションのディセーブル化

自動ネゴシエーションのイネーブル化

イーサネット VLAN の設定

VLAN でのサブインターフェイスの設定

VLAN のサブインターフェイス設定の確認

レイヤ 2 スイッチング機能の設定

MPLSoGRE および mVPNoGRE の設定

AToM over GRE の設定

のインターフェイスまたはサブインターフェイスの設定

ユニキャスト ルートの表示

マルチキャスト ルートの表示

トンネル/インターフェイス マッピングの表示

スケーラブル EoMPLS

リンクのフロー制御サポートの設定

SIP-200 上のイーサネット SPA インターフェイスのフロー制御ステータスの確認

SIP-400 上のイーサネット SPA インターフェイスのフロー制御ステータスの確認

SIP-600 のイーサネット SPA インターフェイスのフロー制御の設定

EtherChannel の設定

H-VPLS の設定

H-VPLS の制約事項

イーサネット OAM の設定

イーサネット OAM の設定時の注意事項

イーサネット OAM の設定作業

イーサネット SPA での QoS 機能の設定

イーサネット SPA の QoS 設定に関する注意事項

設定の保存

SPA のインターフェイスのシャットダウンおよび再起動

インターフェイスの設定の確認

ポート単位のインターフェイス ステータスの確認

設定例

基本的なインターフェイス設定例

MAC アドレスの設定例

MTU の設定例

VLAN の設定例

MPLSoGRE および mVPNoGRE の設定例

EoMPLS の設定例

ファスト イーサネット SPA の速度設定を変更する例

ファスト イーサネットおよびギガビット イーサネット SPA の設定

この章では、4 ポート ファスト イーサネット SPA、8 ポート ファスト イーサネット SPA、1 ポート 10 ギガビット イーサネット SPA、2 ポート ギガビット イーサネット SPA、5 ポート ギガビット イーサネット SPA、10 ポート ギガビット イーサネット SPA を Catalyst 6500 シリーズ スイッチで設定することについて説明します。具体的な内容は次のとおりです。

「設定作業」

「インターフェイスの設定の確認」

「設定例」

この章で使用するコマンドの詳細については、『 Catalyst 6500 Series Cisco IOS Command Reference 12.2SX を参照してください また、関連する Cisco IOS Release 12.2 ソフトウェア コマンド リファレンスおよびマスター インデックス資料も参照してください。これらの資料の入手方法については、「関連資料」を参照してください。

システム イメージおよびコンフィギュレーション ファイルの管理については、『 Cisco IOS Configuration Fundamentals Configuration Guide Release 12.2 および『 Cisco IOS Configuration Fundamentals Command Reference Release 12.2 を参照してください。

設定作業

ここでは、ファスト イーサネットおよびギガビット イーサネット Shared Port Adapter(SPA)の設定方法、および設定の確認方法について説明します。

この項の内容は、次のとおりです。

「必要な設定作業」

「SPA のインターフェイス アドレスの指定」

「インターフェイスの MAC アドレスの変更」

「MAC アドレス アカウンティング統計情報の取得」

「HSRP の設定」

「インターフェイスの MTU サイズの変更」

「カプセル化タイプの設定」

「インターフェイスの自動ネゴシエーションの設定」

「イーサネット VLAN の設定」

「VLAN でのサブインターフェイスの設定」

「レイヤ 2 スイッチング機能の設定」

「リンクのフロー制御サポートの設定」

「EtherChannel の設定」

「H-VPLS の設定」

「イーサネット OAM の設定」

「イーサネット SPA の QoS 設定に関する注意事項」

「設定の保存」

「SPA のインターフェイスのシャットダウンおよび再起動」

「ポート単位のインターフェイス ステータスの確認」

必要な設定作業

ここでは、ファスト イーサネットおよびギガビット イーサネット SPA を設定するために必要な手順を示します。ここで紹介するコマンドは、ファスト イーサネットおよびギガビット イーサネット SPA の両方に使用できますが、例ではギガビット イーサネット SPA を設定する場合を想定しています。ファスト イーサネット SPA を設定する場合は、 gigabitethernet コマンドを fastethernet コマンドに置き換えてください。

必須の設定コマンドの中には、ネットワークに最適なデフォルト値を提供するものがあります。そのデフォルト値がネットワークに適している場合は、そのコマンドを設定する必要はありません。このようなコマンドの説明カラムには、「(必要に応じて)」と示されています。


) Cisco 7600 SIP-400 インターフェイス上では、Cisco Discovery Protocol(CDP)はデフォルトでディセーブルです。


ファスト イーサネットまたはギガビット イーサネット SPA を設定するには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

Router(config)# interface fastethernet slot/subslot/port [ . subinterface-number ]

 

または

Router(config)# interface gigabitethernet slot/subslot/port [ . subinterface-number ]

 

または

Router(config)# interface tengigabitethernet slot/subslot/port [ . subinterface-number ]

設定するファスト イーサネット、ギガビット イーサネット、または 10 ギガビット イーサネット インターフェイスを指定します。

slot / subslot / port :インターフェイスの場所を指定します。「SPA のインターフェイス アドレスの指定」を参照してください。

. subinterface-number :(任意)セカンダリ インターフェイス(サブインターフェイス)の番号を指定します。

ステップ 3

Router(config-if)# ip address [ ip-address mask { secondary } | dhcp { client-id interface-name }{ hostname host-name }]

IPv4 を使用するインターフェイスのプライマリまたはセカンダリ IP アドレスを設定します。

ip-address :インターフェイスの IP アドレスを指定します。

mask :対応する IP サブネットのマスクを指定します。

secondary :(任意)設定されたアドレスがセカンダリ IP アドレスになるように指定します。このキーワードを省略すると、設定されたアドレスはプライマリ IP アドレスとなります。

dhcp :DHCP を使用して IP アドレスを動的に割り当てるように指定します。

client-id interface-name :クライアント ID を指定します。 interface-name は、クライアント ID を名前付きインターフェイスの 16 進 MAC(メディア アクセス制御)アドレスに設定します。

hostname host-name :DHCP 用のホスト名を指定します。 host-name は DHCP Option 12 フィールドに表示するホスト名です。

(注) すべてのギガビット イーサネット SPA およびファスト イーサネット SPA で、このコマンドに DHCP オプションを指定できるわけではありません。

ステップ 4

Router(config)# ip accounting mac-address { input | output }

(任意)MAC アドレス アカウンティングをイネーブルにします。MAC アドレス アカウンティングは、LAN インターフェイスの送信元および宛先 MAC アドレスに基づいて、IP トラフィックのアカウンティング情報を提供します。

input :インターフェイスに着信するトラフィックに対して MAC アドレス アカウンティングを指定します。

output :インターフェイスから送信されるトラフィックに対して MAC アドレス アカウンティングを指定します。

ステップ 5

Router(config-if)# mtu bytes

(必要に応じて)インターフェイスの最大パケット サイズを指定します。

bytes :パケットの最大バイト数を指定します。

デフォルト値は 1500 バイトです。

ステップ 6

Router(config-if)# standby [ group-number ] ip [ ip-address [ secondary ]]

(HSRP 設定の場合に限り必須)HSRP グループの番号および仮想 IP アドレスを使用して、HSRP グループを作成(またはイネーブルに)します。

(任意) group-number :HSRP をイネーブルにするインターフェイスのグループ番号。指定できる範囲は 0 ~ 255 で、デフォルトは 0 です。HSRP グループが 1 つしかない場合は、グループ番号を入力する必要はありません。

HSRP を設定する場合は、1 つのインターフェイスで必須、それ以外は任意 ip-address :ホット スタンバイ スイッチ インターフェイスの仮想 IP アドレス。少なくとも 1 つのインターフェイスに対して仮想 IP アドレスを入力する必要があります。入力した仮想 IP アドレスを他のインターフェイスで学習することができます。

(任意) secondary :セカンダリ ホット スタンバイ スイッチ インターフェイスの IP アドレスを指定します。スイッチがセカンダリとスタンバイ スイッチのいずれにも指定されていなくて、プライオリティも設定されていない場合は、プライマリ IP アドレスが比較され、最も大きい IP アドレスがアクティブ スイッチ、2 番めに大きい IP アドレスがスタンバイ スイッチになります。

このコマンドは HSRP をイネーブルにしますが、それ以上の設定は行いません。HSRP 設定の詳細については、『 Cisco IP Configuration Guide 』Release 12.2 の「 Configuring Hot Standby Router Protocol 」を参照してください。

ステップ 7

Router(config-if)# no shutdown

インターフェイスをイネーブルにします。

SPA のインターフェイス アドレスの指定

SPA インターフェイス ポートの番号は、左から右に向かって「0」から順に付けられます。単一ポートの SPA では、ポート番号 0 だけを使用します。SPA インターフェイスを設定またはモニタするには、CLI で SIP、SPA、およびインターフェイスの物理位置を指定する必要があります。インターフェイス アドレス フォーマットは、 slot / subslot / port です。

slot :SIP が搭載された Catalyst 6500 シリーズ スイッチのシャーシ スロット番号を指定します。

subslot :SPA が搭載された SIP のセカンダリ スロットを指定します。

port :SPA の各インターフェイス ポートの番号を指定します。

次に、シャーシ スロット 3 に SIP(0)が搭載されていて、その最初のサブスロットに SPA が搭載されている場合、この SPA の最初のインターフェイス(0)を指定する例を示します。

Router(config)# interface serial 3/0/0
 

このコマンドは代表的な例としてシリアル SPA を表示していますが、その他の SPA(ATM や POS など)およびその他の非チャネライズド SPA でも、これと同じ slot / subslot / port を同様に使用します。

インターフェイスの MAC アドレスの変更

ギガビット イーサネット SPA は、ポートごとにデフォルト MAC アドレスを使用します。このアドレスは、Catalyst 6500 シリーズ スイッチのバックプレーン上にある Electrically Erasable Programmable Read-Only Memory(EEPROM; 電気的消去再書き込み可能 ROM)に格納された基本アドレスから取得されます。

インターフェイスのデフォルト MAC アドレスをユーザ定義アドレスに変更するには、インターフェイス コンフィギュレーション モードで次の作業を行います。

 

コマンド
目的

Router(config-if)# mac-address ieee-address

インターフェイスのデフォルト MAC アドレスをユーザ定義アドレスに変更します。

ieee-address :48 ビットの Institute of Electrical and Electronics Engineers(IEEE; 電気電子学会)MAC アドレスを、3 つの 4 桁 16 進数のドット形式で指定します( xxxx.yyyy.zzzz )。

インターフェイスのデフォルト MAC アドレスに戻すには、このコマンドの no 形式を使用します。

MAC アドレスの確認

インターフェイスの MAC アドレスを確認するには、 show interfaces gigabitethernet 特権 EXEC コマンドを使用して、[address is] フィールドの値を調べます。

次に、Catalyst 6500 シリーズ スイッチのスロット 2 に SIP が搭載されていて、そのサブスロット 0 に SPA が搭載されている場合、この SPA のインターフェイス 1 の MAC アドレスが 000a.f330.2e40 である例を示します。

Router# show interfaces gigabitethernet 2/0/1
GigabitEthernet2/0/1 is down, line protocol is down
Hardware is GigEther SPA, address is 000a.f330.2e40 (bia 000a.f330.2e40)
Internet address is 2.2.2.1/24
MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive not supported
Full-duplex, 1000Mb/s, link type is force-up, media type is SX
output flow-control is on, input flow-control is on
(Additional output removed for readability)

MAC アドレス アカウンティング統計情報の取得

ip accounting mac-address [ input | output ] コマンドを入力すると、インターフェイス上で MAC アドレス アカウンティングをイネーブルにできます。

MAC アドレス アカウンティングをイネーブルにしたら、 show interfaces mac-accounting コマンドを入力して、MAC アドレス統計情報を取得できます。

HSRP の設定

Hot Standby Router Protocol(HSRP; ホット スタンバイ ルータ プロトコル)を使用すると、個々のスイッチのアベイラビリティに依存することなくホストから IP トラフィックがルーティングされるため、ネットワーク アベイラビリティが高まります。HSRP はスイッチ グループ内で、アクティブ スイッチおよびスタンバイ スイッチを選択する場合に使用されます ( アクティブ スイッチ は、パケットをルーティングするために選択されるスイッチです。 スタンバイ スイッチ は、アクティブ スイッチが故障した場合、または事前に設定された条件が満たされた場合に、スイッチング処理を引き継ぐスイッチです)。

インターフェイス上で HSRP をイネーブルにするには、 standby [ group-number ] ip [ ip-address [ secondary ]] コマンドを使用します。 standby コマンドは、さまざまな HSRP 要素を設定する場合にも使用します。このマニュアルでは、複雑な HSRP 設定は扱いません。HSRP 設定の詳細については、『 Cisco IP Configuration Guide 』Release 12.2 の「 Configuring Hot Standby Router Protocol 」を参照してください。

次の HSRP 設定では、ポート GigabitEthernet 2/1/0 のスタンバイ グループ 2 にプライオリティ 110 が設定されています。また、このポートにスイッチオーバーが発生した場合に、プリエンプティブな遅延が発生するように設定されています。

Router(config)# interface GigabitEthernet 2/1/0
Router(config-if)# standby 2 ip 120.12.1.200
Router(config-if)# standby 2 priority 110
Router(config-if)# standby 2 preempt

HSRP の確認

HSRP 情報を表示するには、EXEC モードで show standby コマンドを使用します。

Router# show standby
Ethernet0 - Group 0
Local state is Active, priority 100, may preempt
Hellotime 3 holdtime 10
Next hello sent in 0:00:00
Hot standby IP address is 198.92.72.29 configured
Active router is local
Standby router is 198.92.72.21 expires in 0:00:07
Standby virtual mac address is 0000.0c07.ac00
Tracking interface states for 2 interfaces, 2 up:
UpSerial0
UpSerial1

インターフェイスの MTU サイズの変更

Cisco IOS ソフトウェアは、プロトコル スタックのレベルに応じて、3 つの異なるタイプの設定可能な Maximum Transmission Unit(MTU; 最大伝送ユニット)オプションをサポートします。

インターフェイス MTU:ネットワークから着信したトラフィックが、SPA によって調べられます。インターフェイス タイプごとに、サポートされるインターフェイス MTU サイズおよびデフォルト値は異なります。インターフェイス MTU は、ドロップされる前にインターフェイスで受信可能な最大パケット サイズ(バイト数)を定義します。フレームがインターフェイス MTU サイズよりも小さく、インターフェイス タイプの最小フレーム サイズ(イーサネットの場合は 64 バイトなど)以上である場合、フレームの処理は継続されます。

IP MTU:サブインターフェイスに設定できます。パケットを分割するかどうかを判別するために、Cisco IOS ソフトウェアで使用されます。IP パケットが IP MTU サイズを超過すると、パケットは分割されます。

タグまたは Multiprotocol Label Switching(MPLS; マルチプロトコル ラベル スイッチング)MTU:サブインターフェイスに設定できます。最大 6 つの異なるラベル(タグ ヘッダー)をパケットに付加できます。ラベルの最大数は、Cisco IOS ソフトウェア リリースによって異なります。

カプセル化方式および MPLS MTU ラベル数に応じて、パケットに余分なオーバーヘッドが追加されます。たとえば、Subnetwork Access Protocol(SNAP; サブネットワーク アクセス プロトコル)カプセル化の場合は 8 バイト ヘッダーが追加されますが、dot1q カプセル化の場合は 2 バイト ヘッダーが追加されます。また、MPLS ラベルごとに、4 バイト ヘッダーが追加されます(ラベル数 n × 4 バイト)。

Catalyst 6500 シリーズ スイッチに搭載されたファスト イーサネットまたはギガビット イーサネット SPA のデフォルト MTU サイズは、1,500 バイトです。インターフェイスがレイヤ 2 ポートとして使用されている場合、設定可能な最大 MTU は 9,216 バイトです。SPA は追加オーバーヘッドを格納できるように、設定された MTU サイズに 38 バイトを自動的に追加します。

インターフェイス MTU の設定時の注意事項

Catalyst 6500 シリーズ スイッチのファスト イーサネットおよびギガビット イーサネット SPA にインターフェイス MTU サイズを設定する場合は、次の注意事項に従ってください。

デフォルトのインターフェイス MTU サイズは、1,500 バイト パケットに、次に示す追加オーバーヘッドを格納するための追加の 38 バイトを加えた値です。

レイヤ 2 ヘッダー:14 バイト

SNAP ヘッダー:8 バイト

dot1q ヘッダー:4 バイト

2 MPLS ラベル:8 バイト

CRC:4 バイト


) ご使用の Cisco IOS ソフトウェア リリースに応じて、サポートされる MPLS ラベルの最大数は異なります。3 つ以上の MPLS ラベルをサポートする必要がある場合は、インターフェイスのデフォルト MTU サイズを増加させる必要があります。


MPLS を使用している場合は、 mpls mtu コマンドをインターフェイス MTU 以下の値に設定してください。

MPLS ラベルを使用している場合は、MPLS ラベルを格納できるように、デフォルトのインターフェイス MTU サイズを増加させる必要があります。MPLS ラベル数が 1 増えるごとに、パケットに 4 バイトのオーバーヘッドが追加されます。

レイヤ 2 ポートのインターフェイス MTU に関する注意事項

レイヤ 2 ポートでは、「ジャンボ MTU」の概念について理解することが重要です。「ジャンボ MTU」を設定するには、 system jumbomtu コマンドを使用します。ただし、このコマンドがサポートされるのは、次の状況だけです。

ポートがレイヤ 2 EtherChannel のメンバーである場合

レイヤ 2 ポートの新しい MTU サイズが、ポートに現在設定されている最大 MTU 未満である場合


) ファスト イーサネット SPA はレイヤ 2 ポートとして動作できません。


インターフェイス MTU の設定作業

インターフェイスの MTU サイズを変更するには、インターフェイス コンフィギュレーション モードで次の作業を行います。

 

コマンド
目的

Router(config-if)# mtu bytes

インターフェイスの最大パケット サイズを設定します。

bytes :パケットの最大バイト数を指定します。

デフォルトは 1,500 バイト、設定可能な最大 MTU は 9,216 バイトです。

デフォルトの MTU サイズに戻すには、このコマンドの no 形式を使用します。

MTU サイズの確認

インターフェイスの MTU サイズを確認するには、 show interfaces gigabitethernet 特権 EXEC コマンドを使用して、[MTU] フィールドの値を調べます。

次に、Catalyst 6500 シリーズ スイッチのスロット 2 に SIP が搭載され、SIP の上部サブスロット(0)にギガビット イーサネット SPA が搭載されている場合、この SPA のインターフェイス ポート 1(2 番めのポート)の MTU サイズが 1,500 バイトである例を示します。

Router# show interfaces gigabitethernet 2/0/1
GigabitEthernet2/0/1 is down, line protocol is down
Hardware is GigEther SPA, address is 000a.f330.2e40 (bia 000a.f330.2e40)
Internet address is 2.2.2.1/24
MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive not supported

カプセル化タイプの設定

ファスト イーサネットおよびギガビット イーサネット SPA のインターフェイスは、デフォルトで Advanced Research Projects Agency(ARPA)カプセル化をサポートします。これらのインターフェイスでは、フレームを送信するために Service Access Point(SAP; サービス アクセス ポイント)または SNAP カプセル化を設定できません。ただし、SAP および SNAP カプセル化を使用するフレームは正常に受信されます。

SPA インターフェイスでサポートされるその他のカプセル化方式は、Virtual LAN(VLAN; 仮想 LAN)の場合、IEEE 802.1Q カプセル化だけです。

インターフェイスの自動ネゴシエーションの設定

ファスト イーサネットおよびギガビット イーサネット インターフェイスは、 自動ネゴシエーション と呼ばれる接続設定アルゴリズムを使用します。ローカルおよびリモート デバイスは自動ネゴシエーションを使用して、リンクを介した通信設定の互換性を保つことができます。各デバイスは自動ネゴシエーションを使用して送信機能をアドバタイズし、リンクで使用する設定について合意します。

Catalyst 6500 シリーズ スイッチ上のファスト イーサネットおよびギガビット イーサネット インターフェイスでは、自動ネゴシエーションがイネーブルな場合、フロー制御は自動ネゴシエーションになります。自動ネゴシエーションはデフォルトでイネーブルです。

自動ネゴシエーションに関して、次の注意事項に従う必要があります。

リンクの一端で自動ネゴシエーションがディセーブルである場合は、リンクの反対側でもディセーブルにする必要があります。リンクの一端で自動ネゴシエーションがディセーブルであるにもかかわらず、反対側でイネーブルである場合、リンクは両端で適切に起動しません。

Cisco 7600 SIP-600に搭載された 10 ポート ギガビット イーサネット SPA では、自動ネゴシエーションはサポートされません。

SIP-600 にイーサネット SPA が搭載されている場合は、自動ネゴシエーションと別個にフロー制御を設定できます。

フロー制御はデフォルトでイネーブルです。

自動ネゴシエーションがリンク両端でディセーブルな場合、フロー制御は有効です。

ファスト イーサネット SPA では、フロー制御をディセーブルにできません。

自動ネゴシエーションのディセーブル化

Cisco 7600 SIP-200 上のファスト イーサネット インターフェイスおよび Cisco 7600 SIP-400 または Cisco 7600 SIP-600 上のギガビット イーサネット インターフェイスでは、自動ネゴシエーションは自動的にイネーブルになりますが、ディセーブルにもできます。自動ネゴシエーション中に、フロー制御、速度、およびデュプレックスがアドバタイズされます。自動ネゴシエーションがディセーブル化されたリンクにギガビット イーサネット インターフェイスが接続されている場合は、リンクの反対側で自動ネゴシエーションを再度イネーブルにするか、可能であれば、ファスト イーサネットまたはギガビット イーサネット SPA で自動ネゴシエーションをディセーブルにする必要があります。リンクの一端だけで自動ネゴシエーションがディセーブルになっている場合は、リンクの両端が適切に起動しません。


) 速度およびデュプレックス設定は自動ネゴシエーションを使用してネゴシエートされます。ただし、ネゴシエーションが行われる値は、ファスト イーサネット SPA の場合、速度が 100 Mbps、デュプレックスが全二重だけです。ギガビット イーサネット SPA の場合は、速度が 1000 Mbps、デュプレックスが全二重だけです。ユーザにとっては、これらの設定はネゴシエートされたというよりは、自動ネゴシエーションを使用してイネーブル化されたと見なされます。


ファスト イーサネットまたはギガビット イーサネット SPA で自動ネゴシエーションをディセーブルにするには、インターフェイス コンフィギュレーション モードで次の作業を行います。1 ポート 10 ギガビット イーサネット SPA と 10 ポート ギガビット イーサネット SPA を SIP-400 で使用する場合は、自動ネゴシエーションをディセーブルにできません。

 

コマンド
目的

ステップ 1

Router(config-if)# no negotiation auto

Cisco 7600 SIP-200 上のファスト イーサネット SPA インターフェイス、または Cisco 7600 SIP-400 上のギガビット イーサネット SPA インターフェイスで自動ネゴシエーションをディセーブルにします。フロー制御はアドバタイズされません。

ステップ 2

Router(config-if)# speed nonegotiate

速度の自動ネゴシエーションをディセーブルにします。このコマンドは、SPA を SIP-600 で実行するときに最初に使用可能になり、多くの設定では使用できません。

自動ネゴシエーションのイネーブル化

自動ネゴシエーションは自動的にイネーブルになり、ディセーブルにできません (10 ポート ギガビット イーサネット SPA の自動ネゴシエーションは、SPA が SIP-600 に搭載されている場合はディセーブルにできます)。自動ネゴシエーション中に、フロー制御、速度、およびデュプレックスがアドバタイズされます(ギガビット イーサネット SPA が SIP-600 に搭載されている場合は、フロー制御を自動ネゴシエーションと独立して設定できます。「SIP-600 のイーサネット SPA インターフェイスのフロー制御の設定」を参照してください。ファスト イーサネットまたはギガビット イーサネット インターフェイスで自動ネゴシエーションを再度イネーブルにするには、インターフェイス コンフィギュレーション モードで次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config-if)# negotiation auto

Cisco 7600 SIP-200 上のファスト イーサネット SPA インターフェイス、または Cisco 7600 SIP-400 上のギガビット イーサネット SPA インターフェイスで自動ネゴシエーションをイネーブルにします。フロー制御がアドバタイズされます。

ステップ 2

Router(config-if)# no speed nonegotiate

速度の自動ネゴシエーションを再度イネーブルにします。このコマンドは、SPA を SIP-600 で実行するときに最初に使用可能になり、多くの設定では使用できません。

イーサネット VLAN の設定

イーサネット VLAN の設定については、『 Cisco IOS Software Configuration Guide 』( Release 12.2(33)SXH 以降のリリース )の「Configuring VLANs」の章にある「Creating or Modifying an Ethernet VLAN」を参照してください。

VLAN でのサブインターフェイスの設定

VLAN のファスト イーサネット SPA インターフェイスおよびギガビット イーサネット SPA インターフェイスのサブインターフェイスを設定するには、IEEE 802.1Q カプセル化を使用します。Cisco 7600 SIP-400 の 2 ポート ギガビット イーサネット SPA インターフェイスおよびサブインターフェイスでは、デフォルトで Cisco Discovery Protocol(CDP)がディセーブルになっています。


) VLAN を使用するすべての Cisco 7600 SIP-600 イーサネット ポート サブインターフェイスに、一意の VLAN ID を割り当てる必要があります。この VLAN ID は、Catalyst 6500 シリーズ スイッチのその他のインターフェイスでは使用できません。


VLAN の SPA サブインターフェイスを設定するには、インターフェイス コンフィギュレーション モードで次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# interface fastethernet slot/subslot/port.subinterface-number

または

Router(config)# interface gigabitethernet slot/subslot/port.subinterface-number

または

Router(config)# interface tengigabitethernet slot/subslot/port.subinterface-number

設定するファスト イーサネット、ギガビット イーサネット、または 10 ギガビット イーサネット インターフェイスを指定します。

slot/subslot/port :インターフェイスの場所を指定します。「SPA のインターフェイス アドレスの指定」を参照してください。

.subinterface-number :セカンダリ インターフェイス(サブインターフェイス)の番号を指定します。

ステップ 2

Router(config-subif)# encapsulation dot1q vlan-id

カプセル化フォーマットを IEEE 802.1Q(「dot1q」)として定義します。 vlan-id は VLAN の番号(1 ~ 4095)です。

ステップ 3

Router(config-if)# ip address ip-address mask [ secondary ]

 

インターフェイスのプライマリまたはセカンダリ IP アドレスを設定します。

ip-address :インターフェイスの IP アドレスを指定します。

mask :対応する IP サブネットのマスクを指定します。

secondary :(任意)設定されたアドレスがセカンダリ IP アドレスになるように指定します。このキーワードを省略すると、設定されたアドレスはプライマリ IP アドレスとなります。

VLAN のサブインターフェイス設定の確認

VLAN のサブインターフェイスの設定およびステータスを確認するには、 show vlans 特権 EXEC コマンドを使用します。

次に、VLAN 200 に搭載された SPA のポート 0 のサブインターフェイス 1 のステータス例を示します。

Router# show vlans
VLAN ID:200 (IEEE 802.1Q Encapsulation)
 
Protocols Configured: Received: Transmitted:
IP 0 14
 
VLAN trunk interfaces for VLAN ID 200:
 
GigabitEthernet4/1/0.1 (200)
 
IP:12.200.21.21
 
Total 0 packets, 0 bytes input
Total 2 packets, 120 bytes output

レイヤ 2 スイッチング機能の設定

Catalyst 6500 シリーズ スイッチは、レイヤ 2 イーサネット セグメント間の同時並行接続をサポートします。このマニュアルに記載された SPA 固有の注意事項を検討してから、『 Cisco IOS Software Configuration Guide 』( Release 12.2(33)SXH 以降のリリース )の「Configuring Layer 2 Ethernet Interfaces」でレイヤ 2 スイッチング機能の設定方法を参照してください。

MPLSoGRE および mVPNoGRE の設定

MPLS over Generic Routing Encapsulation(MPLSoGRE)および multicast Virtual Private Network over Generic Routing Encapsulation(mVPNoGRE)は、非 MPLS ネットワークでユニキャストおよびマルチキャスト パケットを送信するためのメカニズムを提供します。それには、非 MPLS ネットワーク上に GRE トンネルを作成します。非 MPLS ネットワーク上で送信される MPLS(ユニキャスト VPN Routing and Forwarding [VRF])または mVPN(マルチキャスト VRF)パケットは、GRE パケットにカプセル化され、GRE トンネルを介して非 MPLS ネットワークを通過します。非 MPLS ネットワークの反対側に GRE パケットが着信すると、GRE ヘッダーが削除され、内部 MPLS、またはユニキャスト VRF や mVPN パケットが最終宛先に転送されます。


) mVPNoGRE の場合は、外部パケットが 1 つ、内部パケットが 2 つあります。外部パケットはユニキャスト GRE です。最初のインナー パケットはマルチキャスト GRE(mVPN)です。2 番めのインナー パケットは標準(カスタマー)マルチキャストです。



) MPLSoGRE および mVPNoGRE は、Cisco 7600 SIP-200 上のファスト イーサネット SPA ではサポートされません。


MPLSoGRE のサポート

MPLSoGRE は次の機能をサポートします。

VRF ユニキャストおよびマルチキャスト パケットの PE-to-PE トンネリング

CE 方向インターフェイスでの IPv4

コア方向インターフェイスでの IPv4

GRE 4 バイト ヘッダー(オプション フィールドなし)

トンネリング トラフィックと非トンネリング トラフィックの両方をサポートする汎用物理インターフェイス

Cisco 7600 SIP-400 物理インターフェイスまたはサブインターフェイスと IP クラウド間に存在するトンネル ルートは 1 つだけ可能です。

最大トンネル数に関するソフトウェア制限はありません。SIP-400 は、最大 128 のトンネルをサポートします。トンネル トラフィックは SIP-400 のメイン インターフェイスまたはサブインターフェイス経由でルーティングできます。

MPLSoGRE の制約事項

MPLSoGRE では次の機能がサポートされていません。

入出力機能はトンネル インターフェイスではサポートされません。物理インターフェイスまたはサブインターフェイスでサポートされます。

GRE オプション:シーケンス、チェックサム、キー、ソース ルート。

Carry Security Options of Client Packet、Unidirectional Link Routing、Mobile IP Path MTU Discovery などの一部のトンネル オプション。

トンネル エンドポイントで使用される Cisco 7600 SIP-400 の物理インターフェイスまたはサブインターフェイスは、ネイティブ MPLS またはそのバリエーション(たとえば、AToMoMPLS、EoMPLS、FRoMPLS、および PPPoMPLS)の伝送には使用できません。

IPv6。

Carrier Supporting Carrier(CSC)、Inter-Autonomous Systems(Inter-AS)などの高度な機能。

Cisco 7600 SIP-400 インターフェイスまたはサブインターフェイス。

PE-to-PE トンネリング

MPLSoGRE および mVPNoGRE はプロバイダー エッジ間(PE-to-PE)トンネリング派生を使用しています。この機能は、単一の GRE トンネルを介して複数のカスタマー ネットワーク宛のトラフィックを多重化することで、非 MPLS ネットワーク上で複数のカスタマー ネットワークを接続するためのスケーラブルな手法を提供するものです。

非 MPLS ネットワークの両側では、PE スイッチから各 Customer Edge(CE; カスタマー エッジ)スイッチに VPN Routing and Forwarding(VRF; VPN ルーティング/転送)番号が割り当てられます。CE スイッチの背後にある IP ネットワークは、BGP、OSPF、RIP などのルーティング プロトコルを通して、PE スイッチで学習されます。これらのネットワークへのルートは、該当する CE スイッチの VRF ルーティング テーブルに格納されます。

非 MPLS ネットワークの片側にある PE スイッチは、非 MPLS ネットワークで稼動しているルーティング プロトコルを通して、非 MPLS ネットワークの反対側にある PE スイッチで学習されます。PE スイッチ間のルートは、メイン ルーティング テーブルまたはデフォルト ルーティング テーブルに格納されます。

PE スイッチの背後にあるカスタマー ネットワークのルートは、BGP を通して他の PE スイッチで学習されますが、非 MPLS ネットワークでは認識されません。このようにするには、非 MPLS ネットワーク上の GRE トンネルを通して、BGP ネイバ(反対側の PE スイッチ)へのスタティック ルートを定義します。BGP ネイバから学習されたルートには GRE トンネルのネクストホップが設定されるため、すべてのカスタマー ネットワーク トラフィックは GRE トンネルを使用して送信されます。

Cisco 7600 SIP-400 インターフェイスまたはサブインターフェイスに設定された GRE トンネル

Catalyst 6500 シリーズ スイッチに MPLS および mVPN 処理を実行させ、Cisco 7600 SIP-400 に GRE 処理を実行させるには、GRE トンネルが、Cisco 7600 SIP-400 MPLS および PIM(マルチキャスト)がイネーブルにされたインターフェイスまたはサブインターフェイスに設定されている必要があります。Catalyst 6500 シリーズ スイッチは、Cisco 7600 SIP-400 メイン インターフェイスまたはサブインターフェイスを MPLS または PIM インターフェイスとして認識することによって、MPLS および mVPN 処理を実行します。また、Cisco 7600 SIP-400 に、GRE 処理の実行に必要な相関情報を提供します。

トンネル インターフェイスの設定

ip pim sparse-mode コマンドはトンネル インターフェイス上で設定されません。Cisco 7600 SIP-400 インターフェイスまたはサブインターフェイスにトンネルを設定すると、このインターフェイスまたはサブインターフェイスにこのコマンドが自動設定されます。

トンネル送信元 IP アドレスは、Cisco 7600 SIP-400 インターフェイスまたはサブインターフェイスの IP アドレスです。次に、Catalyst 6500 シリーズ スイッチのトンネル インターフェイスの設定例を示します。

Router(config)# interface Tunnel1
Router(config-if)# ip address 8.0.0.1 255.0.0.0
Router(config-if)# mpls label protocol ldp
Router(config-if)# tag-switching ip
Router(config-if)# tunnel source 6.0.0.1
Router(config-if)# tunnel destination 7.0.0.1
 

AToM over GRE の設定

MPLS over Generic Routing Encapsulation(MPLSoGRE)は、IP トンネル内の MPLS パケットをカプセル化して、非 MPLS ネットワーク上でのポイントツーポイント リンクを作成します。これにより、MPLS への移行が可能になるまで、プライマリ MPLS ネットワークのユーザが既存の非 MPLS レガシー ネットワークを継続して使用することができます。Any Transport over MPLS over GRE(AToMoGRE)は、次の転送をサポートしています。

ATM over MPLS

Frame Relay over MPLS(FRoMPLS)

High-Level Data Link Control(HDLC; ハイレベル データリンク コントロール)over MPLS

Scalable Ethernet Over MPLS(EoMPLS)

Circuit Emulation over Packet(CEoP)

ハードウェア ベースの EoMPLS

AToMoGRE は、Cisco IOS Release 12.2(33)SXI 以降のリリースでサポートされ、次のハードウェアだけでサポートされます。

Cisco 7600 SIP-400、5 ポート ギガビット イーサネット SPA、2 ポート ギガビット イーサネット SPA(コア方向)

ATM SPA(2 ポート OC-3c/STM-1 ATM SPA、4 ポート OC-3c/STM-1 ATM SPA、1 ポート OC-12c/STM-4 ATM SPA、1 ポート OC-48c/STM-16 ATM SPAなど)、Inverse Multiplexing(IMA)サポートのある CEoP SPA(24 ポート チャネライズド T1/E1/J1 CEoP SPAなど)、およびすべてのイーサネット インターフェイス

Supervisor 32、Supervisor 720、または RSP720

AToMoGRE は次の機能をサポートします。

MPLS パケットの PE(プロバイダー エッジ)-to-PE、P(プロバイダー)-to-PE、P-to-P トンネリング(図 10-1図 10-2および図 10-3を参照)

図 10-1 PE-to-PE GRE トンネリング

 

図 10-2 P-to-PE GRE トンネリング

 

図 10-3 P-to-P GRE トンネリング

 

カスタマー エッジ(CE)方向インターフェイスでの IPv4

コア方向インターフェイスでの IPv4

GRE 4 バイト ヘッダー(オプション フィールドなし)

トンネリング トラフィックと非トンネリング トラフィックの両方をサポートする汎用物理インターフェイス

Cisco 7600 SIP-400 物理インターフェイスまたはサブインターフェイスと IP クラウド間に存在するトンネル ルートは複数可能です。ルーティング プロトコルが MPLSoGRE トラフィック用のルートを 1 つだけ選択します。

最大トンネル数に関するソフトウェア制限はありません。Cisco 7600 SIP-400 は、最大 128 のトンネルをサポートします。トンネル トラフィックは Cisco 7600 SIP-400 のメイン インターフェイスまたはサブインターフェイス経由でルーティングできます。

トンネル エンドポイントで使用される Cisco 7600 SIP-400 の物理インターフェイスまたはサブインターフェイスは、ネイティブ MPLS および AToMoMPLS とそのバリエーション(ハードウェア ベースの EoMPLS、FRoMPLS、PPPoMPLS、HDLCoMPLS、スケーラブル EoMPLS、および CEoP)の伝送に使用できます。

AToMoGRE 設定時の注意事項

AToMoGRE の注意事項は次のとおりです。

入出力機能はトンネル インターフェイスではサポートされません。物理インターフェイスまたはサブインターフェイスでサポートされます。

サポートされていない GRE オプションは、シーケンス、チェックサム、キー、ソース ルートです。

サポートされていないトンネル オプションは、Carry Security Options of Client Packet、Unidirectional Link Routing、および Mobile IP Path MTU Discovery です。

トンネル エンドポイントで使用される Cisco 7600 SIP-400 の物理インターフェイスまたはサブインターフェイスは、ソフトウェア ベースの EoMPLS と VPLS の伝送には使用できません。Carrier Supporting Carrier(CSC)、Inter-Autonomous Systems(Inter-AS)などの高度な機能はサポートされません。

AToM over GRE は、AToM トンネル選択機能と組み合わせることはできません。

Cisco 7600 SIP-400 のインターフェイスまたはサブインターフェイスの設定

Cisco 7600 SIP-400 のインターフェイスまたはサブインターフェイスを設定するには、2 つのコンフィギュレーション コマンドが必要です。コマンドのキーワードは、パーサー ポリシーからの入力に応じて変化することがありますが、その配置とパラメータは同じです。インターフェイスまたはサブインターフェイスを設定するには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config-subif)# tunnel-interface tunnel-name

GRE トンネルを Cisco 7600 SIP-400 サブインターフェイスに接続します。Cisco 7600 SIP-400 インターフェイスがサブインターフェイスをサポートしている場合、コマンドはサブインターフェイス コンフィギュレーション モードで使用できます。Cisco 7600 SIP-400 インターフェイスがサブインターフェイスをサポートしていない場合、コマンドはインターフェイス コンフィギュレーション モードだけで使用できます。

ステップ 2

Router(config-subif)# ip route a.b.c.d e.f.g.h [ i.j.k.l ]

トンネルする IP トラフィックを定義します。これは、通常は BGP ネイバの IP アドレスです。このコマンドは、 tunnel-interface コマンドのサブモードだけで使用できます。 a.b.c.d は IP アドレスです。 e.f.g.h は IP マスクです。 i.j.k.l はネクストホップ スイッチの IP アドレスです。

次に、Cisco 7600 SIP-400 のインターフェイスまたはサブインターフェイスで、MPLSoGRE および mVPNoGRE 機能を設定する例を示します。ただし、この例では、サブインターフェイスをサポートして いない Cisco 7600 SIP-400 インターフェイスを使用しています。

Router# configure terminal
Router(config)# int pos2/0/0
Router(config-if)# tunnel-interface tu1
Router(config-if-ti)# ip route 4.0.0.1 255.255.255.255
Router(config-if-ti)# exit
Router(config-if)# end
Router#
 

Cisco 7600 SIP-400 インターフェイスまたはサブインターフェイスに tunnel-interface が設定されている場合は、インターフェイスに ip pim sparse-mode および tag-switching ip が自動的に追加されます。 ip route コマンドで指定された IP アドレスへのスタティック ルートは内部で作成されます。次に、 tunnel-interface の追加または設定後の show running interface の出力例を示します。ただし、この例では、サブインターフェイスをサポートして いない Cisco 7600 SIP-400 インターフェイスを使用しています。

Router# show run int pos2/0/0
!
interface POS2/0/0
ip address 6.0.0.1 255.0.0.0
ip pim sparse-mode
no keepalive
tunnel-interface Tunnel1
ip route 4.0.0.1 255.255.255.255
exit-tunnel-interface
tag-switching ip
clock source internal
end

) Catalyst 6500 シリーズ スイッチの BGP ネイバへのスタティック ルートを(グローバルに、またはトンネル上に)設定する必要はありません。Cisco 7600 SIP-400 インターフェイスまたはサブインターフェイスに tunnel-interface コマンドおよび ip route コマンドを実行すると、このスタティック ルートは自動的に設定されます。


ユニキャスト ルートの表示

ユニキャスト ルート(メイン ルーティング テーブル)には、Cisco 7600 SIP-400 インターフェイスまたはサブインターフェイスとなる BGP ネイバのネクスト ホップが示されています。この機能をネイティブにサポートしているスイッチでは、BGP ネイバのネクスト ホップはトンネル インターフェイスです。

次に、 show ip route コマンドの出力例を示します。

Router# show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
 
Gateway of last resort is not set
 
17.0.0.0/32 is subnetted, 1 subnets
O 17.0.0.2 [110/3] via 6.0.0.2, 00:09:55, POS2/0/0
2.0.0.0/32 is subnetted, 1 subnets
C 2.0.0.1 is directly connected, Loopback0
3.0.0.0/32 is subnetted, 1 subnets
O 3.0.0.1 [110/2] via 6.0.0.2, 00:09:55, POS2/0/0
S 64.0.0.0/8 [1/0] via 172.18.20.1
4.0.0.0/32 is subnetted, 2 subnets
S 4.0.0.1 is directly connected, POS2/0/0
O 4.0.0.3 [110/3] via 6.0.0.2, 00:09:55, POS2/0/0
C 6.0.0.0/8 is directly connected, POS2/0/0
 

マルチキャスト ルートの表示

マルチキャスト ルート(グループ)の出力には、Cisco 7600 SIP-400 インターフェイスまたはサブインターフェイスとなる 239.0.0.0/8 グループの出力インターフェイスが示されます。この機能をネイティブにサポートしているスイッチでは、出力インターフェイスはトンネル インターフェイスです。

次に、 show ip mroute コマンドの出力例を示します。

Router# show ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report, Z - Multicast Tunnel
Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
 
(2.0.0.1, 239.1.1.1), 00:02:02/00:03:02, flags: sTZ
Incoming interface: Loopback0, RPF nbr 0.0.0.0, RPF-MFD
Outgoing interface list:
POS2/0/0, Forward/Sparse, 00:00:58/00:03:02, H
 
(4.0.0.1, 239.1.1.1), 00:00:58/00:02:02, flags: sTIZ
Incoming interface: POS2/0/0, RPF nbr 8.0.0.2, RPF-MFD
Outgoing interface list:
MVRF vpn1, Forward/Sparse, 00:00:58/00:02:02, H

トンネル/インターフェイス マッピングの表示

show cwan mplsogre コマンドはトンネル/インターフェイスのマッピングを表示します。インターフェイスまたはサブインターフェイスに show cwan mplsogre コマンドの出力例を示します。このコマンドはトンネル/インターフェイスのマッピングを表示します。

Router# show cwan mplsogre
POS2/0/0
Tunnel1 is attached
Interface
VLAN: 1022, STATE: UP
IP Address: 6.0.0.1 IP Mask: 255.0.0.0
Tunnel
VLAN: 1017, STATE: UP
IP Address: 8.0.0.1 IP Mask: 255.0.0.0
Src Address: 6.0.0.1, Dst Address: 7.0.0.1
Static Routes to Tunnel: 1
IP Address: 4.0.0.1 IP Mask: 255.255.255.255

スケーラブル EoMPLS

12.2(33)SXH リリースから、スケーラブル EoMPLS では、Cisco 7600 SIP-400 ベースのラインカードを CE 方向に配置できます。この設定により、プラットフォームは EoMPLS(VC)数の拡張が可能になり、4 K ~ 12 K をサポートできます。Cisco 7600 SIP-400 のサブインターフェイスに AToM xconnect コマンドを設定すると、ラインカードが AToM インポジションおよびディスポジションを実行します。スーパーバイザ エンジンが実行するのは、これらのインターフェイスからのトラフィックに対する MPLS スイッチングだけです。さらに、Cisco 7600 SIP-400 のサブインターフェイス上で xconnect コマンドを設定した場合、xconnect 単位で消費される VLAN は、全体から見ると多くはありません。この変更により、他の CEF/MFI ベース AToM 設定と同じモデルで、EoMPLS VC 上の FRR をサポートできるようになります。

このスケーラビリティを実現するには、CE 方向の LAN ラインカードという現在のモデルとは逆に、Cisco 7600 SIP-400 を CE 方向のラインカードにする必要があります。Cisco 7600 SIP-400 をスケーラブル EoMPLS 対応として設定すると、MPLS パケットのスイッチングが可能な任意のラインカードをコア方向にできます。

Supervisor Engine 720 システム上で非 VLAN インターフェイスに EoMPLS を設定すると、ハードウェア ベースの EoMPLS と見なされます。VLAN インターフェイスに EoMPLS を設定した場合は、ソフトウェア ベースの MPLS と見なされます。Cisco 7600 SIP-400 のサブインターフェイスに EoMPLS を設定した場合は、スケーラブル EoMPLS と見なされます。

リンクのフロー制御サポートの設定

Cisco 7600 SIP-400 上では、フロー制御は自動ネゴシエーションの結果に基づいてオンまたはオフになります。Cisco 7600 SIP-600 上では、自動ネゴシエーションとは無関係にフロー制御を設定できます。このプロセスの詳細については、「インターフェイスの自動ネゴシエーションの設定」を参照してください。

ここで説明する内容は次のとおりです。

「SIP-200 上のイーサネット SPA インターフェイスのフロー制御ステータスの確認」

「SIP-400 上のイーサネット SPA インターフェイスのフロー制御ステータスの確認」

「SIP-600 のイーサネット SPA インターフェイスのフロー制御の設定」

SIP-200 上のイーサネット SPA インターフェイスのフロー制御ステータスの確認

次に、Cisco 7600 SIP-200 上のファスト イーサネット SPA について、フロー制御ポーズ フレームが送受信されているかどうかを確認する例を示します。

Router# show hw sub 2 counter mac
Show counters info for Subslot 2:
port:0
good_octets_received: 2046026640038
bad_octets_received: 0
good_frames_received: 31969140675
bad_frames_received: 0
broadcast_frames_received: 2
multicast_frames_received: 3562
good_octets_sent: 1373554315151
good_frames_sent: 22892514199
broadcast_frames_sent: 0
multicast_frames_sent: 0
mac_transfer_error: 0
excessive_collision: 0
unrecog_mac_control_received: 0
fc_sent: 11232431
good_fc_received: 0
rx_over_flow_events: 234082101
undersize: 0
fragments: 0
oversize: 0
jabber: 0
mac_rcv_error: 0
bad_crc: 0
collisions: 0
late_collision: 0
rate_limit_dropped: 0
tx_fifo_full_packet_drops : 0
spi4_rx_frames: 2814271686
spi4_tx_frames: 1328805298

SIP-400 上のイーサネット SPA インターフェイスのフロー制御ステータスの確認

SPA のギガビット イーサネット インターフェイスのフロー制御ステータスを確認するには、 show interfaces gigabitethernet 特権 EXEC コマンドを使用し、[output flow-control is] および [input flow-control is] 出力行を表示して、入出力フロー制御がオンになっているか、またはオフになっているかを確認します。このコマンド出力の [pause input] および [pause output] カウンタは、インターフェイスで送受信されるポーズ フレーム数を表示する場合に使用できます。

次に、Catalyst 6500 シリーズ スイッチのスロット 2 に SIP が搭載され、そのサブスロット 0 に SPA が搭載されている場合に、SPA のインターフェイス ポート 1(2 番めのポート)の MAC デバイスで送受信されたポーズ フレーム数がゼロである例を示します。

Router# show interfaces gigabitethernet 2/0/1
GigabitEthernet2/0/1 is down, line protocol is down
Hardware is GigEther SPA, address is 000a.f330.2e40 (bia 000a.f330.2e40)
Internet address is 2.2.2.1/24
MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive not supported
Full-duplex, 1000Mb/s, link type is force-up, media type is SX
output flow-control is on, input flow-control is on
ARP type: ARPA, ARP Timeout 04:00:00
Last input 03:18:49, output 03:18:44, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
1703 packets input, 638959 bytes, 0 no buffer
Received 23 broadcasts (0 IP multicasts)
0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 watchdog, 1670 multicast, 0 pause input
1715 packets output, 656528 bytes, 0 underruns
0 output errors, 0 collisions, 4 interface resets
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier, 0 pause output
0 output buffer failures, 0 output buffers swapped out

SIP-600 のイーサネット SPA インターフェイスのフロー制御の設定

Cisco 7600 SIP-600 上でイーサネット SPA インターフェイスにフロー制御を設定するには、 flowcontrol send コマンドを入力して、ポーズ フレームを送信するようにインターフェイスを設定するか、または flowcontrol receive コマンドを入力して、ポーズ フレームを受信するようにインターフェイスを設定します。

イーサネット インターフェイスにフロー制御を設定するには、インターフェイス コンフィギュレーション モードで次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config-if)# flowcontrol send { desired | off | on }

発信ポーズ フレームの送信をイネーブルにします。このコマンドでは、次のオプションを設定できます。

desired :インターフェイスからの発信ポーズ フレームの送信を許可しますが必須ではありません。

off :発信ポーズ フレームの送信をディセーブルにします。

off :発信ポーズ フレームの送信をイネーブルにします。

ステップ 2

Router(config-if)# flowcontrol receive { desired | off | on }

インターフェイスでの着信ポーズ フレームの受信をイネーブルにします。このコマンドでは、次のオプションを設定できます。

desired :インターフェイスでの着信ポーズ フレームの受信を許可しますが必須ではありません。

off :インターフェイスでの着信ポーズ フレームの受信をディセーブルにします。

on :インターフェイスでの着信ポーズ フレームの受信をイネーブルにします。


) ユーザが送信方向または受信方向のいずれかにフロー制御を設定すると、送信方向と受信方法の両方で同時にその設定が自動的にイネーブルになります。

ファスト イーサネット SPA はデフォルトでフロー制御がイネーブルであり、ディセーブルにできません。


EtherChannel の設定

EtherChannel は、個々のイーサネット リンクを 1 つの論理リンクにバンドルすることによって、最大 8 つの物理リンクを合計した帯域幅を提供します。


) EtherChannel がサポートされるのは、10 ポート ギガビット イーサネット SPAに搭載された 1 ポート 10 ギガビット イーサネット SPA および Cisco 7600 SIP-600 に限られます。Cisco 7600 SIP-400 に搭載された 2 ポート ギガビット イーサネット SPA または Cisco 7600 SIP-200 に搭載されたファスト イーサネット SPA では、EtherChannel はサポートされません。


EtherChannel の詳細については、『 Cisco IOS Software Configuration Guide, Release 12.2(33)SXH and Later Releases 』の「Configuring Layer 3 and Layer 2 EtherChannel」の章にある「Configuring EtherChannels」を参照してください。

H-VPLS の設定

Hierarchal Virtual Private LAN Services(H-VPLS)は、プロバイダー コアを使用して複数の接続回線をまとめ、複数の接続回線を接続する仮想ブリッジをシミュレートします。カスタマーから見ると、VPLS のトポロジは存在しません。すべての CE デバイスは、プロバイダー コアでエミュレートされる論理ブリッジに接続されているように見えます。

VPLS および H-VPLS 機能の詳細については、「Virtual Private LAN Service(VPLS)の設定」を参照してください。

H-VPLS 機能は、ギガビット イーサネット SPA 上で、Cisco 7600 シリーズ ルータ上の OSM モジュールと同様に動作します。SIP 上での VPLS と H-VPLS の設定については、次の URL にある、Cisco 7600 シリーズ ルータ用の『 OSM Configuration Note 』の「Virtual Private LAN Services on the Optical Services Modules」を参照してください。

http://www.cisco.com/en/US/docs/routers/7600/install_config/12.2SR_OSM_config/mpls.html#wp1423607


) ファスト イーサネット SPA では H-VPLS を使用できません。


H-VPLS の制約事項

Cisco 7600 シリーズ ルータ用の『 OSM Configuration Note 』の「 Restrictions for VPLS 」に記載されている制限事項に加え 、H-VPLS のすべてのトランスポート タイプに対して次の制限事項が適用されます。

スプリット ホライズンはディセーブルにできますが、ハブ アンド スポーク型構成でだけ使用してください。

ハブ アンド スポークおよび H-VPLS がサポートされています。

Catalyst 6500 シリーズ スイッチは、最大 60 の ピア PE と、最大 32,000 の VC をサポートしています。

イーサネット OAM の設定

Cisco IOS Release 12.2(33)SXI 以降のリリースでは、ギガビット イーサネット SPA は、IEEE 802.3ah『 Ethernet in the First Mile 』で規定されている Operations, Administration, and Maintenance(OAM; 運用管理および保守)をサポートしています。IEEE 802.3ah は、転送されることのない OAM Protocol Data Unit(OAMPDU)という低速プロトコル パケットを使用して、2 つのデバイス間の単一ポイントツーポイント リンクで動作します。

IEEE 802.3ah では 5 つの機能エリアが定義されていて、Catalyst 6500 シリーズ スイッチに搭載されたギガビット イーサネット SPA はそのうち、次の 3 つの機能エリアをサポートします。

OAM ディスカバリ:ピア デバイスの OAM サポートおよび機能の識別をサポートします。

リンク モニタリング:イベント通知とリンク情報を提供します。802.3ah MIB のポーリングおよび応答もサポートします。書き込みはサポートしません。

リモート障害表示:受信パスのダウンについて、ピア デバイスへの通知をサポートします。ただし、リンク上で単一方向動作がサポートされることが必要です。

イーサネット OAM の設定時の注意事項

SPA 上でイーサネット OAM を設定する場合は、次の注意事項に従ってください。

ギガビット イーサネット リンク上では、OAM の単一方向障害シグナリング サポートとギガビット イーサネットの自動ネットワーク機能(IEEE 802.3z)を同時に設定できません。単一方向リンク上で OAM 障害シグナリングが送信されるようにするには、自動ネゴシエーションをディセーブルにする必要があります。

イーサネット OAM には、OAM PDU を作成し、終端させるポイントツーポイント リンクが必要です。

イーサネット OAM インターフェイス モードを設定する場合は、次の注意事項に従ってください。

1 つ以上のピア インターフェイスがアクティブ モードでなければなりません。

ピア インターフェイスは、両方ともアクティブ モードにすることも、一方をアクティブ モードに、他方をパッシブ モードにすることもできます。

イーサネット OAM モードは、OAM をディセーブルにしなくても変更できます。

テンプレートを使用してイーサネット OAM インターフェイスを設定する場合は、次の注意事項に従ってください。

テンプレートを使用して共通(つまりグローバル)な OAM 特性を設定し、インターフェイスに適用する場合は、インターフェイスで異なる値を指定して同じコマンドを設定することにより、テンプレートのコンフィギュレーション ステートメントをどれでも上書きできます。

複数のテンプレートを定義すると、さまざまなリンク モニタリング特性セットを作成できます。

1 つのイーサネット OAM インターフェイスに適用できるテンプレートは 1 つだけです。

表 10-1 に、SPA インターフェイスの OAM 機能がサポートされる状況を示します。

 

表 10-1 SIP および SPA の組み合わせに基づくイーサネット OAM 機能の互換性

機能
Cisco 7600 SIP-200
Cisco 7600 SIP-400
Cisco 7600 SIP-600

OAM ディスカバリ

リンク モニタリング

リモート障害表示(Dying Gasp 限定)

サポートされていません。

Cisco IOS Release 12.2(33)SXI:

2 ポート ギガビット イーサネット SPA

Cisco IOS Release 12.2(33)SXI:

1 ポート 10 ギガビット イーサネット SPA

5 ポート ギガビット イーサネット SPA

10 ポート ギガビット イーサネット SPA

リモート ループバック

サポートされていません。

サポートされていません。

サポートされていません。

MIB 変数検索

サポートされていません。

サポートされていません。

サポートされていません。

インターフェイスでの OAM のイネーブル化

インターフェイス上で OAM はデフォルトでディセーブルです。インターフェイス上で OAM をイネーブルにすると、OAM ディスカバリ時にリンク モニタリングをサポートすることが、そのインターフェイスからリモート ピアに自動的にアドバタイズされます。リンク モニタリング サポートは、リンクを介してモニタリングを行うことについて、ピア インターフェイスによる合意が必要です。

ピア インターフェイス間でリンク モニタリング サポートが成立すると、インターフェイスはリンク モニタリング動作を開始し、ローカル エラーが発生したときにイベント OAM PDU を送信し、リモート ピアによって受信されたイベント OAM PDU を解析します。

インターフェイス上でモニタリング サポートまたは動作がすでにディセーブルになっている場合を除き、ユーザがリンク モニタリング サポートを明示的に設定したり、リンク上でリンク モニタリング動作を開始したりする必要はありません。

ギガビット イーサネット インターフェイスの OAM 値を変更するには、グローバル コンフィギュレーション モードから次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# interface type slot / subslot / port

イーサネット SPA インターフェイスを指定します。

type gigabitethernet または tengigabitethernet などのイーサネット インターフェイスのタイプを指定します。

slot / subslot / port :インターフェイスの場所を指定します。「SPA のインターフェイス アドレスの指定」を参照してください。

(注) イーサネット OAM を定義できるのは、メイン ギガビット イーサネット インターフェイスに限られます。サブインターフェイス上では定義できません。

ステップ 2

Router(config-if)# ethernet oam [ max-rate oampdus | min-rate num-seconds | mode { active | passive } | timeout seconds ]

ギガビット イーサネット インターフェイス上で OAM をイネーブルにします。

max-rate oampdus :(任意)1 秒間に送信できる OAMPDU の最大数を 1 ~ 10 の整数で指定します。デフォルト値は 10 です。

min-rate num-seconds :(任意)1 つ以上の OAMPDU を送信しなければならない時間の長さを 1 ~ 10 の秒数として指定します。デフォルトは 1 秒です。

mode { active | passive }:(任意)OAM ディスカバリおよびリンク ネゴシエーションに対応するクライアント モードを指定します。

active :インターフェイスがアクティブになると同時に、インターフェイスがプロトコル ネゴシエーション用の OAMPDU を開始することを指定します。これがデフォルト設定です。1 つ以上の OAM ピアをアクティブ モードで設定する必要があります。

passive :インターフェイスがピアからプロトコル ネゴシエーション用の着信 OAMPDU の受信をリスニング モードで待機することを指定します。パッシブ インターフェイスは、ピアから OAMPDU を受信した時点で、OAMPDU の送信を開始します。

 

(注) パッシブ モードでインターフェイスを設定する場合は、正常な OAM 動作を保証するために、ピアがアクティブ モードになっていることを確認する必要があります。

timeout seconds :OAM ピアが動作不能であり、ステート マシンをリセットすることをデバイスが宣言するまでの時間の長さを秒数(2 ~ 30)で指定します。デフォルトは 5 秒です。

リンク モニタリング セッションのイネーブル化およびディセーブル化

OAM ピア インターフェイスがリンク モニタリング セッションを確立してからでなければ、実際のリンク モニタリング動作を開始できません。インターフェイス上で OAM をイネーブルにしていて、インターフェイス上でリンク モニタリング サポートを明示的にディセーブルにしていない場合は、セッションを確立するためにインターフェイス上でリンク モニタリング サポートを明示的に設定する必要はありません。

インターフェイス コンフィギュレーション コマンド ethernet oam を設定すると、 ethernet oam link-monitor supported コマンドがバックグラウンドで自動的に実行されます。セッションを確立できるように、必ず、1 つ以上の OAM ピアをアクティブ モードとして設定してください。

インターフェイス上でリンク モニタリング セッションを明示的に設定してイネーブルにするには、インターフェイス コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

Router(config-if)# ethernet oam link-monitor supported

イーサネット OAM インターフェイス上でリンク モニタリング サポートをイネーブルにします。

インターフェイス上でリンク モニタリング セッションをディセーブルにするには、インターフェイス コンフィギュレーション モードで次の作業を行います。

 

コマンド
目的

Router(config-if)# no ethernet oam link-monitor supported

イーサネット OAM インターフェイス上でリンク モニタリング サポートをディセーブルにします。

リンク モニタリング動作の開始および停止

イーサネット OAM ピア インターフェイス間でリンク モニタリング セッションが確立されている場合、ピア間でイベント通知 OAMPDU の送受信を開始できます。リンクを介したこのリンク モニタリング動作は、インターフェイス上で OAM をイネーブルにした時点で、自動的に開始されます。

インターフェイス コンフィギュレーション コマンド ethernet oam を設定すると、 ethernet oam link-monitor on コマンドがバックグラウンドで自動的に実行されます。

リンク モニタリング動作、つまりリンク上でのイベント通知 OAMPDU の送受信は、ユーザが停止したり再開したりできます。リンク モニタリング動作を停止することと、リンク モニタリング サポートをディセーブルにすることは異なります。リンク モニタリング動作を停止しても、インターフェイスはピアとのリンク モニタリングをサポートするように設定されたままであり、イベント通知 OAMPDU を積極的に送受信しないというだけです。

インターフェイス上でリンク モニタリング動作を明示的に設定して開始するには、インターフェイス コンフィギュレーション モードで次の作業を行います。

 

コマンド
目的

Router(config-if)# ethernet oam link-monitor on

イーサネット OAM インターフェイス上でリンク モニタリングを開始します。

インターフェイス上でリンク モニタリング動作を停止するには、インターフェイス コンフィギュレーション モードで次の作業を行います。

 

コマンド
目的

Router(config-if)# no ethernet oam link-monitor on

イーサネット OAM インターフェイス上でリンク モニタリングを停止します。

リンク モニタリング オプションの設定

OAM リンク モニタリングがアクティブの場合は、ローカル エラーが検出されたときに、リモート OAM クライアントにイベント通知 OAMPDU が送信されます。特定のウィンドウおよびしきい値を設定すると、エラー イベント通知が発生する条件を定義できます。リンク モニタリング オプションを変更しなかった場合は、ウィンドウ期間および下限しきい値にデフォルト値が使用されます。

ギガビット イーサネット SPA は、IEEE 802.3ah で定義されている次のエラー イベント タイプをサポートします。

Errored Symbol Period(エラーの発生したシンボル/秒):このイベントは、指定期間内のシンボル エラー数がしきい値を超えた場合に発生します。これはシンボル符号化エラー(4B/5B 符号化違反など)です。

Errored Frame(エラーの発生したフレーム/秒):このイベントは、指定期間内のフレーム エラー数がしきい値を超えた場合に発生します。

Errored Frame Period(N フレームあたりのフレーム エラー数):このイベントは、最後の N フレーム内のフレーム エラー数がしきい値を超えた場合に発生します。

Errored Frame Seconds Summary(M 秒の間にエラーが発生した秒数):このイベントは、最後の M 秒間にエラーになった秒数(1 つ以上のフレーム エラーが発生した 1 秒のインターバル数)がしきい値を超えた場合に発生します。

シスコシステムズでは、ベンダー固有のエラー イベントとして、次のタイプを追加しています。

Receive CRC(エラーの発生したフレーム/秒):このイベントは、指定期間内に CRC エラーとなった受信フレーム数がしきい値を超えた場合に発生します。

Transmit CRC(エラーの発生したフレーム/秒):このイベントは、指定期間内に CRC エラーとなった送信フレーム数がしきい値を超えた場合に発生します。

リンク モニタリング オプションは、グローバル テンプレートで設定して、そのテンプレートを 1 つ以上のインターフェイスに適用することも、インターフェイスで明示的に設定することもできます。

Errored Symbol Period リンク モニタリング オプションの指定

Errored Symbol Period リンク モニタリング オプションには、エラーを追跡またはカウントするシンボル数を指定する機能、さらに Errored Symbol Period Link Event を発生させる上限および下限しきい値が含まれます。

Errored Symbol Period リンク モニタリング オプションを指定するには、インターフェイス コンフィギュレーション モードまたはテンプレート コンフィギュレーション モードで次の作業を行います。

 

コマンド
目的

Router(config-if)# ethernet oam link-monitor symbol-period window million-symbol-units

(任意)指定されたしきい値に従ってエラー カウントに含めるシンボル数(100 万シンボルの倍数として 1 ~ 65535 の範囲)を指定します。デフォルトのウィンドウ ユニットは 100、つまり 1 億シンボルです。

Router(config-if)# ethernet oam link-monitor symbol-period threshold low low-symbols

(任意)エラー シンボルの下限しきい値をシンボル エラー数(0 ~ 65535)で指定します。ウィンドウ期間のエラー シンボル数が low-symbols 以上になると、Errored Symbol Period Link Event が発生します。デフォルトの下限しきい値は 0 です。

Router(config-if)# ethernet oam link-monitor symbol-period threshold high {none | high-symbols }

(任意)エラー シンボルの上限しきい値をエラー シンボル数(1 ~ 65535)で指定します。ウィンドウ期間のエラー シンボル数が high-symbols 以上になると、ユーザが定義したアクションが実行されます。デフォルトでは、上限しきい値の設定はされていないため、イネーブルにするには、ユーザが明示的に値を設定する必要があります。

ユーザ定義アクション設定の詳細については、「上限しきい値のアクションの指定」を参照してください。

Errored Frame リンク モニタリング オプションの指定

Errored Frame リンク モニタリング オプションには、フレーム エラーを追跡またはをカウントする期間を指定する機能、さらに Errored Frame Link Event を発生させる上限および下限しきい値が含まれます。Catalyst 6500 シリーズ スイッチ上のギガビット イーサネット SPA は、CRC エラー、破損パケットなどの一般的なフレーム エラーをエラー フレームとしてカウントします。

Errored Frame リンク モニタリング オプションを指定するには、インターフェイス コンフィギュレーション モードまたはテンプレート コンフィギュレーション モードで次の作業を行います。

 

コマンド
目的

Router(config-if)# ethernet oam link-monitor frame window 100-millisecond-units

(任意)指定されたしきい値に従ってエラー カウントを実行する時間間隔(100 ミリ秒の倍数として 10 ~ 600 の範囲)を指定します。デフォルトのウィンドウ ユニットは 10、つまり 1000 ミリ秒です。

Router(config-if)# ethernet oam link-monitor frame threshold low low-frames

(任意)エラー フレームの下限しきい値をフレーム数(0 ~ 65535)で指定します。ウィンドウ期間のエラー フレーム数が low-frames 以上になると、Errored Frame Link Event が発生します。デフォルトの下限しきい値は 0 フレーム エラーです。

Router(config-if)# ethernet oam link-monitor frame threshold high {none | high-frames }

(任意)エラー フレームの上限しきい値をエラー フレーム数(1 ~ 65535)で指定します。ウィンドウ期間のエラー フレーム数が high-frames 以上になると、ユーザが定義したアクションが実行されます。デフォルトでは、上限しきい値の設定はされていないため、イネーブルにするには、ユーザが明示的に値を設定する必要があります。

上限しきい値をディセーブルにするには、 none キーワードを使用します。

ユーザ定義アクション設定の詳細については、「上限しきい値のアクションの指定」を参照してください。

Errored Frame Period リンク モニタリング オプションの指定

Errored Frame Period リンク モニタリング オプションには、エラーを追跡またはカウントするエラー フレームの数を指定する機能、さらに Errored Frame Period Link Event を発生させる上限および下限しきい値が含まれます。Catalyst 6500 シリーズ スイッチ上のギガビット イーサネット SPA は、CRC エラー、破損パケットなどの一般的なフレーム エラーをエラー フレームとしてカウントします。

Errored Frame Period リンク モニタリング オプションを指定するには、インターフェイス コンフィギュレーション モードまたはテンプレート コンフィギュレーション モードで次の作業を行います。

 

コマンド
目的

Router(config-if)# ethernet oam link-monitor frame-period window 10000-frame-units

(任意)指定されたしきい値に従ってエラー カウントに含めるフレーム数(1 万フレームの倍数として 1000 ~ 65535 の範囲)を指定します。デフォルトのウィンドウ ユニットは 1000、つまり 1 千万フレームです。

Router(config-if)# ethernet oam link-monitor frame-period threshold low low-frames

(任意)エラー フレームの下限しきい値をフレーム数(0 ~ 65535)で指定します。ウィンドウ期間のエラー フレーム数が low-frames 以上になると、Errored Frame Period Link Event が発生します。デフォルトの下限しきい値は 0 フレーム エラーです。

Router(config-if)# ethernet oam link-monitor frame-period threshold high {none | high-frames }

(任意)エラー フレームの上限しきい値をフレーム数(1 ~ 65535)で指定します。ウィンドウ期間のエラー フレーム数が high-frames 以上になると、ユーザが定義したアクションが実行されます。デフォルトでは、上限しきい値の設定はされていないため、イネーブルにするには、ユーザが明示的に値を設定する必要があります。

上限しきい値をディセーブルにするには、 none キーワードを使用します。

ユーザ定義アクション設定の詳細については、「上限しきい値のアクションの指定」を参照してください。

Errored Frame Seconds Summary リンク モニタリング オプションの指定

Errored Frame Seconds Summary リンク モニタリング オプションには、1 つ以上のフレーム エラーがある 1 秒のインターバルが何回あるかを追跡する期間指定機能、さらに Errored Frames Seconds Summary Link Event が発生する上限および下限しきい値が含まれます。

Errored Frame Seconds Summary リンク モニタリング オプションを指定するには、インターフェイス コンフィギュレーション モードまたはテンプレート コンフィギュレーション モードで次の作業を行います。

 

コマンド
目的

Router(config-if)# ethernet oam link-monitor frame-seconds window 100-millisecond-units

(任意)指定されたしきい値に従ってエラー秒数のインターバルを追跡する時間間隔(100 ミリ秒の倍数として 100 ~ 9000 の範囲)を指定します。デフォルトのウィンドウ ユニットは 100、つまり 10000 ミリ秒です。

Router(config-if)# ethernet oam link-monitor frame-seconds threshold low low-errored-seconds

(任意)エラー秒数の下限しきい値をエラー秒数(0 ~ 900)として指定します。ウィンドウ期間のエラー秒数が low-errored-seconds 以上になると、Errored Frame Seconds Summary Link Event が発生します。デフォルトの下限しきい値は 0 エラー秒です。

Router(config-if)# ethernet oam link-monitor frame-seconds threshold high {none | high-errored-seconds }

(任意)エラー秒数の上限しきい値をエラー秒数(1 ~ 900)として指定します。ウィンドウ期間のエラー 秒数が high-errored-seconds 以上になると、ユーザが定義したアクションが実行されます。デフォルトでは、上限しきい値の設定はされていないため、イネーブルにするには、ユーザが明示的に値を設定する必要があります。

上限しきい値をディセーブルにするには、 none キーワードを使用します。

ユーザ定義アクション設定の詳細については、「上限しきい値のアクションの指定」を参照してください。

Receive CRC リンク モニタリング オプションの指定

Receive CRC リンク モニタリング オプションには、CRC で受信したフレームを追跡する時間間隔を指定する機能、さらにエラーが発生する上限および下限しきい値が含まれます。Receive CRC リンク モニタリングは、シスコ固有であり、Catalyst 6500 シリーズ スイッチ上のイーサネット OAM インターフェイスに限定されたローカルな意味があるだけです。

Receive CRC リンク モニタリング オプションを指定するには、インターフェイス コンフィギュレーション モードまたはテンプレート コンフィギュレーション モードで次の作業を行います。

 

コマンド
目的

Router(config-if)# ethernet oam link-monitor receive-crc window 100-millisecond-units

(任意)指定されたしきい値に従って CRC エラーとして受信したフレームを追跡する時間間隔(100 ミリ秒の倍数として 10 ~ 1800 の範囲)を指定します。デフォルトのウィンドウ ユニットは 10、つまり 1000 ミリ秒です。

Router(config-if)# ethernet oam link-monitor receive-crc threshold low low-frames

(任意)CRC の下限しきい値をフレーム数(0 ~ 65535)で指定します。ウィンドウ期間の CRC エラー フレーム数が low-frames 以上になると、Receive CRC エラーが発生します。デフォルトの下限しきい値は 1 フレームです。

Router(config-if)# ethernet oam link-monitor receive-crc threshold high {none | high-frames }

(任意)CRC の上限しきい値をフレーム数(1 ~ 65535)で指定します。ウィンドウ期間の CRC エラー フレーム数が high-frames 以上になると、ユーザが定義したアクションが実行されます。デフォルトでは、上限しきい値の設定はされていないため、イネーブルにするには、ユーザが明示的に値を設定する必要があります。

上限しきい値をディセーブルにするには、 none キーワードを使用します。

ユーザ定義アクション設定の詳細については、「上限しきい値のアクションの指定」を参照してください。

Transmit CRC リンク モニタリング オプションの指定

Transmit CRC リンク モニタリング オプションには、CRC で送信されたフレームを追跡する時間間隔を指定する機能、さらにエラーが発生する上限および下限しきい値が含まれます。Transmit CRC リンク モニタリングは、シスコ固有のエラー イベントであり、Catalyst 6500 シリーズ スイッチ上のイーサネット OAM インターフェイスに限定されたローカルな意味があります。

Transmit CRC リンク モニタリング オプションを指定するには、インターフェイス コンフィギュレーション モードまたはテンプレート コンフィギュレーション モードで次の作業を行います。

 

コマンド
目的

Router(config-if)# ethernet oam link-monitor transmit-crc window 100-millisecond-units

(任意)指定されたしきい値に従って CRC エラーとして受信したフレームを追跡する時間間隔(100 ミリ秒の倍数として 10 ~ 1800 の範囲)を指定します。デフォルトのウィンドウ ユニットは 10、つまり 1000 ミリ秒です。

Router(config-if)# ethernet oam link-monitor transmit-crc threshold low low-frames

(任意)CRC の下限しきい値をフレーム数(0 ~ 65535)で指定します。ウィンドウ期間に送信された CRC エラー フレーム数が low-frames 以上になると、Receive CRC エラーが発生します。デフォルトの下限しきい値は 1 フレームです。

Router(config-if)# ethernet oam link-monitor transmit-crc threshold high {none | high-frames }

(任意)CRC の上限しきい値をフレーム数(1 ~ 65535)で指定します。ウィンドウ期間内に送信された CRC エラー フレーム数が high-frames 以上になると、ユーザが定義したアクションが実行されます。デフォルトでは、上限しきい値の設定はされていないため、イネーブルにするには、ユーザが明示的に値を設定する必要があります。

上限しきい値をディセーブルにするには、 none キーワードを使用します。

ユーザ定義アクション設定の詳細については、「上限しきい値のアクションの指定」を参照してください。

上限しきい値のアクションの指定

OAM リンク モニタリングに上限しきい値を設定する場合は、上限しきい値超過時に実行するアクションを指定できます。

上限しきい値のアクションを設定する場合は、次の注意事項に従ってください。

デフォルトのアクションはありません。

上限しきい値を設定しても、対応するアクションを設定しなかった場合は、Syslog にメッセージが含まれるだけで、インターフェイスに対するアクションは実行されません。

リンク モニタリング機能の種類ごとに異なる上限しきい値 アクションを対応付ける場合は、コンフィギュレーション テンプレートを使用できます。ただし、イーサネット OAM インターフェイスに適用できるコンフィギュレーション テンプレートは 1 つだけです。

イーサネット OAM インターフェイスに設定できる上限しきい値 アクションは 1 つだけです。

イーサネット OAM インターフェイス上でエラーの上限しきい値を超過したときに実行するアクションを設定するには、インターフェイス コンフィギュレーション モードまたはテンプレート コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

Router(config-if)# ethernet oam link-monitor high-threshold action { error-disable-interface | failover }

(任意)エラーの上限しきい値を超えたときのアクションを設定します。

error-disable-interface :イーサネット OAM インターフェイスをシャットダウンします。

failover :(EtherChannel インターフェイス限定)EtherChannel 内のポートの 1 つが指定されたインターバル以内にエラーの上限しきい値を超えた場合、EtherChannel のあるポートから同じ EtherChannel の別のポートに、トラフィックの自動フェールオーバーを行うようにインターフェイスを設定します。ポートのフェールオーバーが行われるのは、EtherChannel に使用可能な動作状態のポートが 1 つ以上ある場合だけです。

障害ポートは、エラー ディセーブル ステートになります。障害ポートが EtherChannel で最後のポートだった場合、そのポートはエラー ディセーブル ステートにはならず、受信したエラーのタイプに関係なく、引き続きトラフィックを通過させます。個々の非チャネリング ポートがエラー ディセーブル ステートになるのは、エラー しきい値が指定のインターバルの間に超過した場合です。

RFI アクションの設定

ローカルな Remote Failure Indication(RFI; リモート障害表示)イベントが発生した場合、ローカル クライアントは障害のタイプを示すビットを選択して、Information OAMPDU をピアに送信します。Catalyst 6500 シリーズ スイッチ上のギガビット イーサネット SPA は、IEEE 802.3ah で定義されている、次のタイプの Remote Failure Indication(RFI; リモート障害表示)条件をすべて処理します。

Critical Event:このタイプの RFI は、未指定のクリティカル イベントが発生した場合に送信されます。これらのイベントはベンダー固有であり、障害表示が即座に連続して送信されることがあります。

Dying Gasp:このタイプの RFI は、回復不能な条件(電源障害など)が発生した場合に送信されます。Dying Gasp RFI の条件はベンダー固有であり、障害表示が即座に連続して送信されることがあります。Catalyst 6500 シリーズ スイッチ上のギガビット イーサネット SPA は、インターフェイスがエラー ディセーブルまたは管理上のシャットダウン ステートになったときに、Dying Gasp RFI を生成します。これは、Catalyst 6500 シリーズ スイッチ上のギガビット イーサネット SPA が生成する唯一の RFI タイプです。

Link Fault:このタイプの RFI は、受信側が信号損失(ピアのレーザー誤動作など)を検出した場合に送信されます。Link Fault は Information OAMPDU で毎秒 1 回ずつ送信されます。Link Fault RFI が適用されるのは、物理サブレイヤが独立して送受信を行える場合だけです。

ギガビット イーサネット SPA が RFI ビットの選択された OAMPDU を受信すると、障害理由を示した Syslog メッセージが作成されます。次の例を参照してください。

%ETHERNET_OAM-SP-6-RFI: The client on interface Gi1/1 has received a remote failure indication from its remote peer (failure reason = remote client administratively turned off)
 

Dying Gasp RFI ビットの選択された Information OAMPDU を受信した場合、ローカル クライアントが OAM インターフェイスをシャットダウンするように、対応(つまりアクション)を設定できます。

ローカル イーサネット OAM インターフェイスのエラー ディセーブル時のアクションを設定するには、インターフェイス コンフィギュレーション モードまたはテンプレート コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

Router(config-if)# ethernet oam remote-failure dying-gasp action error-disable-interface

(オプション)ピアから Dying Gasp を示す Information OAMPDU を受信した場合、ローカル イーサネット OAM インターフェイスをシャットダウンすることを指定します。

テンプレートを使用したグローバル イーサネット OAM オプションの設定

一連の共通するリンク モニタリング特性またはリモート障害特性を複数のイーサネット OAM インターフェイスに適用する場合は、コンフィギュレーション テンプレートを作成します。テンプレートを使用すると、イーサネット OAM インターフェイスの設定が簡単になります。

複数のコンフィギュレーション テンプレートを設定できますが、1 つのイーサネット OAM インターフェイスに対応付けることができるテンプレートは 1 つだけです。インターフェイス コンフィギュレーション モードで、テンプレートで定義されているのと同じコマンドを明示的に設定することによって、テンプレートで定義されている任意のコマンドを上書きできます。

テンプレートを使用してグローバル イーサネット OAM インターフェイスを設定するには、グローバル コンフィギュレーション モードから次のコマンドを使用します。

 

コマンド
目的

ステップ 1

Router(config)# template template-name

テンプレートを作成または選択して、テンプレート コンフィギュレーション モードを開始します。この場合、 template-name は、テンプレート名を定義する最大 32 文字のストリングです。

ステップ 2

Router(config-template)# ethernet oam link-monitor command

or

Router(config-template)# ethernet oam remote-failure command

1 つ以上の ethernet oam コンフィギュレーション コマンドを指定します。設定するコマンドの数だけこの手順を繰り返します。リンク モニタリング コマンドについては、「リンク モニタリング オプションの設定」を参照してください。

ステップ 3

Router(config-template)# exit

テンプレート コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードに戻ります。

ステップ 4

Router(config)# interface type slot / subslot / port

イーサネット SPA インターフェイスを指定します。

type gigabitethernet または tengigabitethernet などのイーサネット インターフェイスのタイプを指定します。

slot / subslot / port :インターフェイスの場所を指定します。「SPA のインターフェイス アドレスの指定」を参照してください。

(注) イーサネット OAM を定義できるのは、メイン ギガビット イーサネット インターフェイスに限られます。サブインターフェイス上では定義できません。

ステップ 5

Router(config-if)# source template template-name

template-name というテンプレートを結合し、名前付きテンプレートで定義された一連のコンフィギュレーション コマンドを指定のインターフェイスに適用します。

イーサネット OAM の設定の確認

イーサネット OAM の設定を確認するには、特権 EXEC コンフィギュレーション モードで次の作業を行います。

 

コマンド
目的

Router# show ethernet oam discovery [ interface type slot/subslot/port ]

OAM セッション確立時の OAM ディスカバリ フェーズでネゴシエーションが行われた OAM 機能について、情報を表示します。

type gigabitethernet または tengigabitethernet などのイーサネット インターフェイスのタイプを指定します。

slot / subslot / port :インターフェイスの場所を指定します。「SPA のインターフェイス アドレスの指定」を参照してください。

Router# show ethernet oam statistics [ interface type slot/subslot/port ]

Information OAMPDU、ローカル障害、およびリモート障害に関する統計情報を表示します。

type gigabitethernet または tengigabitethernet などのイーサネット インターフェイスのタイプを指定します。

slot / subslot / port :インターフェイスの場所を指定します。「SPA のインターフェイス アドレスの指定」を参照してください。

Router# show ethernet oam status [ interface type slot/subslot/port ]

ローカル OAM クライアントのリンク モニタリング設定およびステータスに関する情報を表示します。

type gigabitethernet または tengigabitethernet などのイーサネット インターフェイスのタイプを指定します。

slot / subslot / port :インターフェイスの場所を指定します。「SPA のインターフェイス アドレスの指定」を参照してください。

Router# show ethernet oam summary

リモート OAM クライアントとの OAM セッションに関する情報を表示します。

type gigabitethernet または tengigabitethernet などのイーサネット インターフェイスのタイプを指定します。

slot / subslot / port :インターフェイスの場所を指定します。「SPA のインターフェイス アドレスの指定」を参照してください。

この項の内容は、次のとおりです。

「OAM セッションの確認」

「OAM ディスカバリ ステータスの確認」

「Information OAMPDU および障害統計情報の確認」

「リンク モニタリングの設定およびステータスの確認」

OAM セッションの確認

OAM セッションを確認するには、 show ethernet oam summary コマンドを使用します。

下記に、Catalyst 6500 シリーズ スイッチのシャーシ スロット 6 に搭載された SIP のサブスロット 1 にある、第 2 ギガビット イーサネット SPA インターフェイス(1)上(Gi6/1/1)に設定された、ローカル OAM クライアントの例を示します。

ローカル クライアント インターフェイスは、MAC アドレスが 0012.7fa6.a700、Organizationally Unique Identifier(OUI; 組織固有識別子)が 00000C のリモート クライアントとセッション中です。この場合 OUI はシスコシステムズを表します。リモート クライアントはアクティブ モードであり、OAM セッションのリンク モニタリングおよびリモート ループバック機能が設定されています。

Router# show ethernet oam summary
Symbols: * - Master Loopback State, # - Slave Loopback State
Capability codes: L - Link Monitor, R - Remote Loopback
U - Unidirection, V - Variable Retrieval
 
Local Remote
Interface MAC Address OUI Mode Capability
 
Gi6/1/1 0012.7fa6.a700 00000C active L R

OAM ディスカバリ ステータスの確認

ローカル クライアントおよびリモート ピアの OAM ディスカバリ ステータスを確認するには、 show ethernet oam discovery コマンドを使用します。次の例を参照してください。

Router# show ethernet oam discovery interface gigabitethernet6/1/1
 
GigabitEthernet6/1/1
Local client
------------
Administrative configurations:
Mode: active
Unidirection: not supported
Link monitor: supported (on)
Remote loopback: not supported
MIB retrieval: not supported
Mtu size: 1500
 
Operational status:
Port status: operational
Loopback status: no loopback
PDU permission: any
PDU revision: 1
 
Remote client
-------------
MAC address: 0030.96fd.6bfa
Vendor(oui): 0x00 0x00 0x0C (cisco)
 
Administrative configurations:
Mode: active
Unidirection: not supported
Link monitor: supported
Remote loopback: not supported
MIB retrieval: not supported
Mtu size: 1500

Information OAMPDU および障害統計情報の確認

Information OAMPDU、ローカル障害およびリモート障害に関する統計情報を確認するには、 show ethernet oam statistics コマンドを使用します。次の例を参照してください。

Router# show ethernet oam statistics interface gigabitethernet6/1/1
 
GigabitEthernet6/1/1
Counters:
---------
Information OAMPDU Tx : 588806
Information OAMPDU Rx : 988
Unique Event Notification OAMPDU Tx : 0
Unique Event Notification OAMPDU Rx : 0
Duplicate Event Notification OAMPDU TX : 0
Duplicate Event Notification OAMPDU RX : 0
Loopback Control OAMPDU Tx : 1
Loopback Control OAMPDU Rx : 0
Variable Request OAMPDU Tx : 0
Variable Request OAMPDU Rx : 0
Variable Response OAMPDU Tx : 0
Variable Response OAMPDU Rx : 0
Cisco OAMPDU Tx : 4
Cisco OAMPDU Rx : 0
Unsupported OAMPDU Tx : 0
Unsupported OAMPDU Rx : 0
Frames Lost due to OAM : 0
 
Local Faults:
-------------
0 Link Fault records
2 Dying Gasp records
Total dying gasps : 4
Time stamp : 00:30:39
 
Total dying gasps : 3
Time stamp : 00:32:39
 
0 Critical Event records
 
Remote Faults:
--------------
0 Link Fault records
0 Dying Gasp records
0 Critical Event records
 
Local event logs:
-----------------
0 Errored Symbol Period records
0 Errored Frame records
0 Errored Frame Period records
0 Errored Frame Second records
 
Remote event logs:
------------------
0 Errored Symbol Period records
0 Errored Frame records
0 Errored Frame Period records
0 Errored Frame Second records

リンク モニタリングの設定およびステータスの確認

ローカル クライアントのリンク モニタリングの設定およびステータスを確認するには、 show ethernet oam status コマンドを使用します 次の例の [Status] フィールドは、リンク モニタリング ステータスがサポートされていてイネーブル(on)であることを示しています。

Router# show ethernet oam status interface gigabitethernet6/1/1
 
GigabitEthernet6/1/1
General
-------
Mode: active
PDU max rate: 10 packets per second
PDU min rate: 1 packet per 1 second
Link timeout: 5 seconds
High threshold action: no action
 
Link Monitoring
---------------
Status: supported (on)
 
Symbol Period Error
Window: 1 million symbols
Low threshold: 1 error symbol(s)
High threshold: none
 
Frame Error
Window: 10 x 100 milliseconds
Low threshold: 1 error frame(s)
High threshold: none
Frame Period Error
Window: 1 x 100,000 frames
Low threshold: 1 error frame(s)
High threshold: none
 
Frame Seconds Error
Window: 600 x 100 milliseconds
Low threshold: 1 error second(s)
High threshold: none

リモート OAM クライアントのステータスの確認

リモート OAM クライアントのステータスを確認するには、 show ethernet oam summary コマンドおよび show ethernet oam status コマンドを使用します。

リモート クライアント モードおよび OAM セッションの機能を確認するには、 show ethernet oam summary コマンドを使用し、[Mode] フィールドおよび [Capability] フィールドの値を調べます。次に、ローカル クライアント(ローカル インターフェイス Gi6/1/1)がリモート クライアントに接続している例を示します。

Router# show ethernet oam summary
Symbols: * - Master Loopback State, # - Slave Loopback State
Capability codes: L - Link Monitor, R - Remote Loopback
U - Unidirection, V - Variable Retrieval
 
Local Remote
Interface MAC Address OUI Mode Capability
 
Gi6/1/1 0012.7fa6.a700 00000C active L R
 

イーサネット SPA での QoS 機能の設定

イーサネット SPA でサポートされる QoS 機能については、「SIP および SSC の設定」「SIP での QoS 機能の設定」を参照してください。

イーサネット SPA の QoS 設定に関する注意事項

ファスト イーサネット SPA および 2 ポート ギガビット イーサネット SPA には、次の QoS 動作が適用されます。

すべての QoS 機能は、Catalyst 6500 シリーズ スイッチの FlexWAN および Enhanced FlexWAN モジュールのパケット サイズ計算方法と同様の方法で、入出力方向のパケット サイズを計算します。

具体的には、すべての機能が IEEE 802.3 レイヤ 2 ヘッダーおよびレイヤ 3 プロトコル ペイロードを考慮します。Cyclic Redundancy Check(CRC; 巡回冗長検査)、インターフレーム ギャップ、およびプリアンブルは、パケット サイズ計算で使用されません。


) ファスト イーサネット SPA の場合、QoS ではインターフェイス速度を変更できません(たとえば、ファスト イーサネット SPA は、インターフェイス速度が 100 Mbps から 10 Mbps に変更される都度、QoS の設定値を変更できません)。速度を変更する場合は、ユーザが QoS の設定値も相応に調整する必要があります。


設定の保存

実行コンフィギュレーションを Nonvolatile Random-Access Memory(NVRAM; 不揮発性 RAM)に保存するには、特権 EXEC コンフィギュレーション モードで次の作業を行います。

 

コマンド
目的

Router# copy running-config startup-config

新しい設定を NVRAM に書き込みます。

システム イメージおよびコンフィギュレーション ファイルの管理については、『 Cisco IOS Configuration Fundamentals Configuration Guide Release 12.2 および『 Cisco IOS Configuration Fundamentals Command Reference Release 12.2 を参照してください。

SPA のインターフェイスのシャットダウンおよび再起動

SPA の任意のインターフェイス ポートは、個別にシャットダウンしたり再起動したりすることができます。インターフェイスをシャットダウンすると、トラフィックが停止し、インターフェイスは「管理上のダウン」ステートになります。

ファスト イーサネットおよびギガビット イーサネット SPA での Online Insertion and Removal(OIR; 活性挿抜)に関する制限はありません。ファスト イーサネットおよびギガビット イーサネット SPA は、いつでも SIP から取り外すことができます。任意のタイプの SPA が搭載された SIP を、いつでもスイッチから取り外すことができます。

SPA の活性挿抜の準備を行っている場合は、SPA を非アクティブにする前に、各インターフェイスを個別にシャットダウンする必要はありません。 hw-module subslot shutdown コマンドを使用すると、インターフェイスのトラフィックは自動的に停止し、SPA とともにインターフェイスが非アクティブになって、活性挿抜を実行できるようになります。

また、SPA または SIP の活性挿抜後に、SPA のインターフェイスを個別に再起動する必要はありません。

SPA のインターフェイスをシャットダウンするには、インターフェイス コンフィギュレーション モードで次の作業を行います。

 

コマンド
目的

Router(config-if)# shutdown

インターフェイスをディセーブルにします。

SPA のインターフェイスを再起動するには、インターフェイス コンフィギュレーション モードで次の作業を行います。

 

コマンド
目的

Router(config-if)# no shutdown

ディセーブル化されたインターフェイスを再起動します。

インターフェイスの設定の確認

show running-configuration コマンドでスイッチ コンフィギュレーションの設定値を表示する以外に、 show interfaces gigabitethernet コマンドを使用することによって、ギガビット イーサネット SPA の詳細情報がポート単位で得られます。また、 show interfaces fastethernet コマンドを使用すると、ファスト イーサネット SPA の詳細情報がポート単位で得られます。

ポート単位のインターフェイス ステータスの確認

ファスト イーサネットおよびギガビット イーサネット SPA のポート単位の詳細情報を参照するには、それぞれ show interfaces fastethernet コマンドおよび show interfaces gigabitethernet コマンドを使用します。コマンド出力の説明については『 Catalyst 6500 Series Cisco IOS Command Reference, Release 12.2SX 』を参照してください。

次に、Catalyst 6500 シリーズ スイッチのスロット 2 に SIP が搭載され、この上部サブスロット(0)に SPA が搭載されている場合の、SPA のインターフェイス ポート 1 の出力例を示します。

Router# show interfaces gigabitethernet 2/0/1
GigabitEthernet2/0/1 is down, line protocol is down
Hardware is GigEther SPA, address is 000a.f330.2e40 (bia 000a.f330.2e40)
Internet address is 2.2.2.1/24
MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive not supported
Full-duplex, 1000Mb/s, link type is force-up, media type is SX
output flow-control is on, input flow-control is on
ARP type: ARPA, ARP Timeout 04:00:00
Last input 03:18:49, output 03:18:44, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
1703 packets input, 638959 bytes, 0 no buffer
Received 23 broadcasts (0 IP multicasts)
0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 watchdog, 1670 multicast, 0 pause input
1715 packets output, 656528 bytes, 0 underruns
0 output errors, 0 collisions, 4 interface resets
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier, 0 PAUSE output
0 output buffer failures, 0 output buffers swapped out

設定例

ここでは、次の設定例を示します。

「基本的なインターフェイス設定例」

「MAC アドレスの設定例」

「MTU の設定例」

「VLAN の設定例」

「MPLSoGRE および mVPNoGRE の設定例」

「EoMPLS の設定例」

「ファスト イーサネット SPA の速度設定を変更する例」

基本的なインターフェイス設定例

次に、グローバル コンフィギュレーション モードを開始し、設定するインターフェイスを指定し、インターフェイスに IP アドレスを設定して、設定を保存する例を示します。次に、Catalyst 6500 シリーズ スイッチのスロット 3 に SIP が搭載され、そのサブスロット 0 に搭載されている SPA に、インターフェイス ポート 1 を設定する例を示します。

!Enter global configuration mode

!

Router# configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

!

! Specify the interface address

!

Router(config)# interface gigabitethernet 3/0/1

!

! Configure an IP address

!

Router(config-if)# ip address 192.168.50.1 255.255.255.0

!

! Start the interface

!

Router(config-if)# no shutdown

!

! Save the configuration to NVRAM

!

Router(config-if)# exit

Router# copy running-config startup-config

MAC アドレスの設定例

次に、インターフェイスのデフォルト MAC アドレスを 1111.2222.3333 に変更する例を示します。

!Enter global configuration mode

!

Router# configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

!

! Specify the interface address

!

Router(config)# interface gigabitethernet 3/0/1

!

! Modify the MAC address

!

Router(config-if)# mac-address 1111.2222.3333

MTU の設定例

次に、インターフェイス MTU を 9216 バイトに設定する例を示します。


) SPA は設定されたインターフェイス MTU サイズに 38 バイトを自動的に追加します。


!Enter global configuration mode

!

Router# configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

!

! Specify the interface address

!

Router(config)# interface gigabitethernet 3/0/1

!

! Configure the interface MTU

!

Router(config-if)# mtu 9216

VLAN の設定例

次に、SPA のインターフェイス ポート 2(3 番めのポート)にサブインターフェイス 268 を作成し、IEEE 802.1Q カプセル化を使用して、ID が 268 の VLAN にサブインターフェイスを設定する例を示します。


) SPA は ISL(スイッチ間リンク)カプセル化をサポートしません。


!Enter global configuration mode

!

Router# configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

!

! Specify the interface address

!

Router(config)# interface gigabitethernet 3/0/1.268

!

! Configure dot1q encapsulation and specify the VLAN ID

!

Router(config-subif)# encapsulation dot1q 268

 

MPLSoGRE および mVPNoGRE の設定例

次に、Cisco 7600 SIP-400 インターフェイスまたはサブインターフェイスに MPLSoGRE および mVPNoGRE 機能を設定する例を示します。ただし、この例ではサブインターフェイスをサポート しない Cisco 7600 SIP-400 インターフェイスを使用しています。

! Enter global configuration mode.

!

Router# configure terminal

! Enter configuration commands, one per line. End with CNTL/Z.

!

! Specify the Gigabit Ethernet interface to configure.
!
Router(config)# interface gigabitethernet 2/0/0
! Attach a GRE Tunnel to a Cisco 7600 SIP-400 subinterface.
!
Router(config-if)# tunnel-interface tu1
! Define the IP traffic that should be tunneled.
!
Router(config-if-ti)# ip route 10.0.0.1 255.255.255.0
Router(config-if-ti)# exit
 
 

Cisco 7600 SIP-400 インターフェイスまたはサブインターフェイスに tunnel-interface が設定されている場合は、インターフェイスに ip pim sparse-mode および tag-switching ip が自動的に追加されます。 ip route コマンドで指定された IP アドレスへのスタティック ルートは内部で作成されます。次に、 tunnel-interface の追加または設定後の show running interface の出力例を示します。ただし、この例では、サブインターフェイスをサポート しない Cisco 7600 SIP-400 インターフェイスを使用しています。

Router# show running interface gigabitethernet 2/0/0
!
interface gigabitethernet2/0/0
ip address 10.1.0.1 255.255.255.0
ip pim sparse-mode
no keepalive
tunnel-interface Tunnel1
ip route 10.11.0.1 255.255.255.0
exit-tunnel-interface
tag-switching ip
clock source internal
end

) Catalyst 6500 シリーズ スイッチの BGP ネイバへのスタティック ルートを(グローバルに、またはトンネル上に)設定する必要はありません。Cisco 7600 SIP-400 インターフェイスまたはサブインターフェイスに tunnel-interface コマンドおよび ip route コマンドを実行すると、このスタティック ルートは自動的に設定されます。


次に、Catalyst 6500 シリーズ スイッチのトンネル インターフェイスの設定例を示します。

interface Tunnel0
ip address 10.0.0.1 255.255.255.0
ip pim sparse-dense-mode
mpls ip
tunnel source 22.22.22.22
tunnel destination 44.44.44.44
 

EoMPLS の設定例

次に、ソフトウェア ベースの EoMPLS を設定する例を示します。

! Enter global configuration mode.

!

Router# configure terminal

! Enter configuration commands, one per line. End with CNTL/Z.
Router# vlan 101
!
Router(config)# interface VLAN101
Router(config-if)# xconnect 7.7.7.7 73829 encapsulation MPLS
!
Router(config)# interface gigabitethernet 4/1/0.1
Router(config-subif)# encapsulation dot1Q 100
 
 

次に、スケーラブル EoMPLS を設定するコマンドの例を示します(Cisco 7600 SIP-400 イーサネット インターフェイスの場合に限る)。

Router(config)# interface GigabitEthernet 1/2/1
Router(config-if)# no ip address
Router(config-if)# no cdp enable
!
Router(config-if)# interface GigabitEthernet 1/2/1.2
Router(config-subif)# encapsulation dot1Q 2
Router(config-subif)# xconnect 5.5.5.5 20002 encapsulation mpls
!
[Snip ...]
!
Router(config-if)# interface GigabitEthernet 1/2/1.4095
Router(config-subif)# encapsulation dot1Q 4095
Router(config-subif)# xconnect 5.5.5.5 24095 encapsulation mpls
 
 

次に、ハードウェア ベースの EoMPLS を設定する例を示します(その他のイーサネット インターフェイス)。

Router(config)# interface GigabitEthernet 1/1
Router(config-if)# no ip address
Router(config-if)# no cdp enable
!
Router(config-subif)# interface GigabitEthernet 1/1.2
Router(config-subif)# encapsulation dot1Q 2
Router(config-subif)# xconnect 5.5.5.5 10002 encapsulation mpls
!
[Snip ...]
Router(config)# interface GigabitEthernet 1/1.3095
Router(config-subif)# encapsulation dot1Q 3095
Router(config-subif)# xconnect 5.5.5.5 13095 encapsulation mpls
!
 

ファスト イーサネット SPA の速度設定を変更する例

次に、ファスト イーサネット SPA の速度を変更する例を示します。


) ファスト イーサネット SPA の速度を変更するには、自動ネゴシエーションをディセーブルにする必要があります。


Router# show run interface fastethernet 5/0/1
Building configuration...
Current configuration : 86 bytes
!
! Disable Autonegotiation
!
interface FastEthernet5/0/1
ip address 10.1.0.2 255.255.0.0
negotiation auto
end
Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# interface fastethernet 5/0/1
Router(config-if)# no negotiation auto
Router(config-if)# speed 10
Router(config-if)# end
Router# show run interface fastethernet 5/01
Building configuration...
Current configuration : 112 bytes
!
interface FastEthernet 5/0/1
ip address 10.1.0.2 255.255.0.0
speed 10
duplex full
no negotiation auto
end
Router# show interface fastethernet 5/0/1
FastEthernet5/0/1 is up, line protocol is up
Hardware is FastEthernet SPA, address is 000a.8b3e.cc00 (bia 000a.8b3e.cc00)
Internet address is 10.1.0.2/16
MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive not supported
Full-duplex, 10Mb/s
ARP type: ARPA, ARP Timeout 04:00:00
Last input 00:00:04, output 00:00:04, output hang never
Last clearing of "show interface" counters 1d00h
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
1608 packets input, 547102 bytes, 0 no buffer
Received 1 broadcasts (0 IP multicasts)
0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 watchdog
0 input packets with dribble condition detected
1606 packets output, 548403 bytes, 0 underruns
 
Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# interface fastethernet 5/0/1
Router(config-if)# speed 100
Router(config-if)# end
Router#
*Apr 25 21:10:36: %SYS-5-CONFIG_I: Configured from console by console
Router# show interface fastethernet 5/0/1
FastEthernet5/0/1 is down, line protocol is down
Hardware is FastEthernet SPA, address is 000a.8b3e.cc00 (bia 000a.8b3e.cc00)
Internet address is 10.1.0.2/16
MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive not supported
Full-duplex, 100Mb/s
ARP type: ARPA, ARP Timeout 04:00:00
Last input 00:00:23, output 00:00:22, output hang never
Last clearing of "show interface" counters 1d00h
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
1608 packets input, 547102 bytes, 0 no buffer
Received 1 broadcasts (0 IP multicasts)
0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored