Catalyst 6500 シリーズ スイッチ コンテント スイッチング モジュール インストレーション コンフィギュレーション ノート Software Release 4.1(2)
冗長接続の設定
冗長接続の設定
発行日;2012/01/07 | ドキュメントご利用ガイド | ダウンロード ; この章pdf | フィードバック

目次

冗長接続の設定

フォールトトレランスの設定

HSRPの設定

HSRPの設定の概要

HSRPゲートウェイの作成

フォールトトレラントHSRPコンフィギュレーションの作成

接続の冗長性の設定

ヒットレス アップグレードの設定

冗長接続の設定

この章では、冗長接続の設定方法について説明します。この章の構成は次のとおりです。

「フォールトトレランスの設定」

「HSRPの設定」

「接続の冗長性の設定」

「ヒットレス アップグレードの設定」

フォールトトレランスの設定

ここでは、フォールトトレランスの設定について説明します。この設定では、2 つの異なる Catalyst 6500 シリーズ シャーシにそれぞれ CSM を取り付けます。


) 1 つの Catalyst 6500 シリーズ シャーシに CSM を 2 つ取り付けて、フォールトトレラント コンフィギュレーションを作成することもできます。フォールトトレラントは、セキュア(ルータ)モードまたは非セキュア(ブリッジ)モードのどちらでも設定できます。


セキュア(ルータ)モードでは、クライアント側およびサーバ側 VLAN によって、CSM とクライアント側のルータとの間、および CSM とサーバ側のサーバとの間にフォールトトレラント(冗長)な接続パスが確立されます。冗長構成では、2つのCSMはアクティブCSMおよびセカンダリCSMとして機能します。各CSMには同じIP、仮想サーバ、サーバ プール、および実サーバ情報が組み込まれています。各CSMは、クライアント側およびサーバ側ネットワークで同じように設定されます。ネットワークは、フォールトトレラント コンフィギュレーションを単一CSMとして認識します。


) 複数のフォールトトレラント CSM ペアを設定する場合、同一フォールトトレラント VLAN を使用する CSM ペアを複数設定しないでください。フォールトトレラント CSM ペアごとに異なるフォールトトレラント VLAN を使用してください。


フォールトトレランスを設定するための条件は、次のとおりです。

Catalyst 6500 シリーズ シャーシに 2 つの CSM が取り付けられている。

2つのCSMが同じ設定である。一方の CSM はアクティブとして、他方のCSMはスタンバイとして設定します。

各CSMが同じクライアント側およびサーバ側VLANに接続されている。

CSM間の通信が共有プライベートVLANによって提供されている。

ネットワークが冗長CSMを単一のエンティティとして認識している。

1 GB/秒の容量のリンク設定によって接続の冗長性が得られる。CSMのステート変化に正しい時刻のスタンプが与えられるように、スイッチのCisco IOSソフトウェアでカレンダーをイネーブルにします。

カレンダーをイネーブルにするには、次のコマンドを使用します。

Cat6k-2# configure terminal
Cat6k-2(config)# clock timezone WORD offset from UTC
Cat6k-2(config)# clock calendar-valid
 

各 CSM のクライアント側およびサーバ側 VLAN には異なる IP アドレスが設定されているので、CSM はネットワークにヘルス モニタ プローブを送信して(ヘルス モニタリング情報については、「ヘルス モニタリング用プローブの設定」 を参照)、応答を受信できます。アクティブおよびスタンバイの両方のCSMが、動作中にプローブを送信します。パッシブCSMが制御している場合、そのCSMは受信したプローブ応答からサーバのステータスを認識します。

接続レプリケーション機能は、非 TCP 接続と TCP 接続の両方をサポートしています。CSM にレプリケーションを設定するには、仮想サーバ モードで replicate csrp {sticky | connection} コマンドを入力します。


replicateコマンドは、ディセーブルがデフォルトの設定です。


接続の冗長性を得るために接続レプリケーション機能を使用する場合には、次のコマンドを使用します。

Cat6k-2# configure terminal
Cat6k-2(config)# no ip igmp snooping
 

複製フレームには、ユニキャストIPアドレスと同様マルチキャスト タイプの宛先MACがあるので、 no ip igmp snooping コマンドを入力する必要があります。スイッチが、Internet Group Management Protocol(IGMP)にマルチキャスト グループ メンバーシップの検索およびマルチキャストForwarding Information Base(FIB;転送情報ベース)の確立を待ち受ける場合、スイッチはグループ メンバーを検索せずにマルチキャスト テーブルをプルーニングします。アクティブからスタンバイまですべてのマルチキャスト フレームは、エラー結果の原因となるため廃棄されます。

サーバ側 VLAN にルータがない場合、各サーバのデフォルト ルートはエイリアス IP アドレスを示します。

図 7-1 では、セキュア(ルータ)モードのフォールトトレラント コンフィギュレーションの設定方法を示しています。

図 7-1 フォールトトレラントの設定

 


図 7-1のアドレスは、次の2種類の手順に対応しています。


アクティブ(A)CSM をフォールトトレランスとして設定する手順は、次のとおりです。

 

コマンド
目的

ステップ 1

Router(config-module-csm)# vlan 2 client

クライアント側VLAN 2を作成し、SLB VLANモードを開始します1

ステップ 2

Router(config-slb-vlan-client)# ip addr 192.158.38.10 255.255.255.0

VLAN 2にコンテント スイッチングIPアドレスを割り当てます。

ステップ 3

Router(config-slb-vlan-client)# gateway 192.158.38.20

(オプション)クライアント側VLANのゲートウェイをHSRP対応ゲートウェイとして定義します。

ステップ 4

Router(config-module-csm)# vserver vip1

仮想サーバを作成し、SLB vserverモードを開始します。

ステップ 5

Router(config-slb-vserver)# virtual 192.158.38.30 tcp www

仮想IPアドレスを作成します。

ステップ 6

Router(config-module-csm)# inservice

サーバをイネーブルにします。

ステップ 7

Router(config-module-csm)# vlan 3 server

サーバ側VLAN 3を作成し、SLB VLANモードを開始します。

ステップ 8

Router(config-slb-vlan-server)# ip addr 192.158.39.10 255.255.255.0

VLAN 3にCSM IPアドレスを割り当てます。

ステップ 9

Router(config-slb-vlan-server)# alias ip addr 192.158.39.20 255.255.255.0

VLAN 3のデフォルト ルートを割り当てます。

ステップ 10

Router(config-slb-vlan-server)# vlan 9

VLAN 9 をフォールトトレラント VLAN として定義します。

ステップ 11

Router(config-module-csm)# ft group ft-group-number vl an 9

コンテント スイッチングのアクティブおよびスタンバイ(A/B)グループであるVLAN 9を作成します。

ステップ 12

Router(config-module-csm)# vlan

VLANモードを開始します1

ステップ 13

Router(vlan)# vlan 2

クライアント側 VLAN 2 を設定します2

ステップ 14

Router(vlan)# vlan 3

サーバ側VLAN 3を設定します。

ステップ 15

Router(vlan)# vlan 9

フォールトトレラントのVLAN 9を設定します。

ステップ 16

Router(vlan)# exit

exit コマンドを入力して、設定を有効にします。

1.モードまたはサブモードを終了するには、exitコマンドを入力します。メニューのトップ レベルに戻るには、end コマンドを入力します。

2.デフォルトの設定に戻すには、このコマンドのno形式を使用します。

スタンバイ(B)CSM をフォールトトレランスとして設定する手順は、次のとおりです(図 7-1 を参照)。

 

コマンド
目的

ステップ 1

Router(config-module-csm)# vlan 2 client

クライアント側VLAN 2を作成し、SLB VLANモードを開始します3

ステップ 2

Router(config-slb-vlan-client)# ip addr 192.158.38.40 255.255.255.0

VLAN 2にコンテント スイッチングIPアドレスを割り当てます。

ステップ 3

Router(config-slb-vlan-client)# gateway 192.158.38.20

クライアント側VLANゲートウェイを定義します。

ステップ 4

Router(config-module-csm)# vserver vip1

仮想サーバを作成し、SLB仮想サーバ モードを開始します。

ステップ 5

Router(config-slb-vserver)# virtual 192.158.38.30 tcp www

仮想IPアドレスを作成します。

ステップ 6

Router(config-module-csm)# inservice

サーバをイネーブルにします。

ステップ 7

Router(config-module-csm)# vlan 3 s erver

サーバ側VLAN 3を作成し、SLB VLANモードを開始します。

ステップ 8

Router(config-slb-vserver)# ip addr 192.158.39.30 255.255.255.0

VLAN 3にCSM IPアドレスを割り当てます。

ステップ 9

Router(config-slb-vserver)# alias 192.158.39.20 255.255.255.0

VLAN 2のデフォルト ルートを割り当てます。

ステップ 10

Router(config-module-csm) vlan 9

VLAN 9をフォールトトレラントVLANとして定義します。

ステップ 11

Router(config-module-csm)# ft group ft-group-number vlan 9

CSMアクティブおよびスタンバイ(A/B)グループであるVLAN 9を作成します。

ステップ 12

Router(config-module-csm)# show module csm all

フォールトトレラント システムのステートを表示します。

3.モードまたはサブモードを終了するには、exitコマンドを入力します。メニューのトップ レベルに戻るには、end コマンドを入力します。

HSRPの設定

ここでは Hot Standby Router Protocol(HSRP)設定の概要を説明し(図 7-2を参照)、Catalyst 6500 シリーズ スイッチで HSRP および CSM フェールオーバーを指定して CSM を設定する方法について説明します。

HSRPの設定の概要

図 7-2では、HSRP ゲートウェイ(10.100.0.1)を介してクライアント側ネットワーク(10.100/16)から内部 CSM クライアント ネットワーク(10.6/16、VLAN 136)にルーティングするように、Catalyst 6500シリーズ スイッチのスイッチ 1 およびスイッチ 2 を設定しています。設定では次の点に留意してください。

クライアント側ネットワークには、HSRP ID 2というHSRPグループIDが割り当てられています。

内部CSMクライアント ネットワークには、HSRP ID 1というHSRPグループIDが割り当てられています。


) HSRP グループ 1 は、HSRP グループ 2 のクライアント ネットワーク ポートを追跡できるように、トラッキングをオンにしておく必要があります。HSRP グループ 1 がこれらのポートのアクティブ ステート変化を検出すると、その変化を複製し、HSRP アクティブ スイッチ(スイッチ 1)と HSRP スタンバイ スイッチ(スイッチ 2)の両方で、同じネットワーク情報が共有されるようにします。


この設定例では、クライアント側とサーバ側VLANの間でトラフィックを転送するように2つのCSM(スイッチ1およびスイッチ2に1つずつ)が設定されています。

クライアントVLAN 136


) クライアントVLANは、実際は内部CSM VLANネットワークです。実際のクライアント ネットワークはスイッチの反対側にあります。


サーバVLAN 272

サーバ ネットワーク(10.5/1)上の実際のサーバは、エイリアス ゲートウェイ(10.5.0.1)を介してCSMサーバ ネットワークを示しているため、サーバは安全なサブネットを実現できます。

設定例では、EtherChannel はトランキングがイネーブルになるようにセットアップされているため、内部 CSM クライアント ネットワークのトラフィックを 2 つのCatalyst 6500 シリーズ スイッチ間で送受信できます。図 7-2では設定を示しています。


) EtherChannel はアクティブ スイッチへのリンクの切断、および CSM 以外のスイッチ コンポーネントの故障を保護します。また、スイッチ内のアクティブな CSM と別のスイッチとの間でパスを確立して、CSM およびスイッチが独立してフェールオーバーできるようにします。これによって、フォールトトレランス レベルがさらに向上します。


図 7-2 HSRPの設定

 

HSRPゲートウェイの作成

次の手順で、クライアント側ネットワーク用のHSRPゲートウェイを作成する方法について説明します。クライアント側ネットワークのゲートウェイはHSRP ID 2です。


) この例では、HSRPはファスト イーサネット ポート3/6に設定されています。


HSRPゲートウェイを作成する手順は、次のとおりです。


ステップ 1 スイッチ 1:FT1(HSRP アクティブ)を設定します。

Router(config)# interface FastEthernet3/6
Router(config)# ip address 10.100.0.2 255.255.0.0
Router(config)# standby 2 priority 110 preempt
Router(config)# standby 2 ip 10.100.0.1
 

ステップ 2 スイッチ 2:FT2(HSRP スタンバイ)を設定します。

Router(config)# interface FastEthernet3/6
Router(config)# ip address 10.100.0.3 255.255.0.0
Router(config)# standby 2 priority 100 preempt
Router(config)# standby 2 ip 10.100.0.1
 


 

フォールトトレラントHSRPコンフィギュレーションの作成

ここでは、フォールトトレラントHSRPセキュア モードを設定する方法について説明します。非セキュア モードを設定するには、次の例外に従ってコマンドを入力します。

サーバ側およびクライアント側 VLAN の両方に同じ IP アドレスを割り当てます。

サーバ側VLANにデフォルト ゲートウェイを割り当てる場合は、 alias コマンドを使用しないでください。

フォールトトレラントHSRPコンフィギュレーションを作成する手順は、次のとおりです。


ステップ 1 HSRP FT1のVLANを設定します。

Router(config)# module csm 5
Router(config-module-csm)# vlan 136 client
Router(config-slb-vlan-client)# ip address 10.6.0.245 255.255.0.0
Router(config-slb-vlan-client)# gateway 10.6.0.1
Router(config-slb-vlan-client)# exit
 
Router(config-module-csm)# vlan 272 server
Router(config-slb-vlan-server)# ip address 10.5.0.2 255.255.0.0
Router(config-slb-vlan-server)# alias 10.5.0.1 255.255.0.0
Router(config-slb-vlan-server)# exit
 
Router(config-module-csm)# vlan 71
 
Router(config-module-csm)# ft group 88 vlan 71
Router(config-slb-ft)# priority 30
Router(config-slb-ft)# preempt
Router(config-slb-ft)# exit
 
Router(config-module-csm)# interface Vlan136
ip address 10.6.0.2 255.255.0.0
standby 1 priority 100 preempt
standby 1 ip 10.6.0.1
standby 1 track Fa3/6 10
 

ステップ 2 HSRP FT2のVLANを設定します。

Router(config)# module csm 6
Router(config-module-csm)# vlan 136 client
Router(config-slb-vlan-client)# ip address 10.6.0.246 255.255.0.0
Router(config-slb-vlan-client)# gateway 10.6.0.1
Router(config-slb-vlan-client)# exit
 
Router(config-module-csm)# vlan 272 server
Router(config-slb-vlan-server)# ip address 10.5.0.3 255.255.0.0
Router(config-slb-vlan-server)# alias 10.5.0.1 255.255.0.0
Router(config-slb-vlan-server)# exit
 
Router(config-module-csm)# vlan 71
 
 
Router(config-module-csm)# ft group 88 vlan 71
Router(config-slb-ft)# priority 20
Router(config-slb-ft)# preempt
Router(config-slb-ft)# exit
 
Router(config-module-csm)# interface Vlan136
ip address 10.6.0.3 255.255.0.0
standby 1 priority 100 preempt
standby 1 ip 10.6.0.1
standby 1 track Fa3/6 10

トラッキングを作動させるには、preempt をオンにしておく必要があります。


ステップ 3 両方のスイッチでEtherChannelを設定します。

Router(console)# interface Port-channel100
Router(console)# switchport
Router(console)# switchport trunk encapsulation dot1q
Router(console)# switchport trunk allowed vlan 136
 

) デフォルトでは、ポート チャネル上ですべてのVLANが許可されます。


ステップ 4 問題が発生しないように、サーバおよびフォールトトレラントCSMのVLANを削除します。

Router(console)# switchport trunk remove vlan 71
Router(console)# switchport trunk remove vlan 272
 

ステップ 5 EtherChannelにポートを追加します。

Router(console)# interface FastEthernet3/25
Router(console)# switchport
Router(console)# channel-group 100 mode on
 


 

接続の冗長性の設定

接続の冗長性によって、アクティブ CSM で障害が発生し、スタンバイ CSM がアクティブになるときに、オープンな接続が応答しなくなる事態を防止できます。接続の冗長性によって、アクティブ CSM からスタンバイ CSM へのフェールオーバー時にオープンなままにしておくべき各接続について、アクティブ CSM はスタンバイ CSM に転送情報をコピーします。

接続の冗長性を設定する手順は、次のとおりです。

 

コマンド
目的

ステップ 1

Router# configure terminal

ルータ コンフィギュレーション モードを開始します。

ステップ 2

Router(config)# no ip igmp snooping

設定からIGMPスヌーピングを削除します。

ステップ 3

Router(config-module-csm)# vserver virtserver-name

仮想サーバを特定し、仮想サーバ サブモードを開始します。

ステップ 4

Router(config-slb-vserver)# virtual ip-address [ip-mask] protocol port-number [service ftp ]

仮想サーバの属性を設定します。

ステップ 5

Router(config-slb-vserver)# serverfarm serverfarm-name

サーバ ファームと仮想サーバを関連付けます。

ステップ 6

Router(config-slb-vserver)# sticky duration [ group group-id ] [ netmask ip-netmask ]

同一クライアントからの接続には同一実サーバが使用されるようにします。

ステップ 7

Router(config-slb-vserver)# replicate csrp sticky

スティッキーのレプリケーションをイネーブルにします。

ステップ 8

Router(config-slb-vserver)# replicate csrp connection

接続のレプリケーションをイネーブルにします。

ステップ 9

Router(config-slb-vserver)# inservice

仮想サーバのロードバランシングをイネーブルにします。

ステップ 10

Router(config-module-csm)# ft group group-id vlan vlanid

フォールトトレランスを設定し、フォールトトレランス サブモードを開始します。

ステップ 11

Router(config-slb-ft)# priority value

CSMのプライオリティを設定します。

ステップ 12

Router(config-slb-ft)# failover failover-time

スタンバイCSMがアクティブCSMになるまでの待機時間を設定します。

ステップ 13

Router(config-slb-ft)# preempt

オンラインになったときに、プライオリティの高いCSMがフォールトトレラント グループを制御するようにします。

次に、接続の冗長性を目的として、フォールトトレランスを設定する例を示します。

Router(config-module-csm)# vserver VS_LINUX-TELNET
Router(config-slb-vserver)# virtual 10.6.0.100 tcp telnet
Router(config-slb-vserver)# serverfarm SF_NONAT
Router(config-slb-vserver)# sticky 100 group 35
Router(config-slb-vserver)# replicate csrp sticky
Router(config-slb-vserver)# replicate csrp connection
Router(config-slb-vserver)# inservice
Router(config-slb-vserver)# exit
Router(config-module-csm)# ft group 90 vlan 111
Router(config-slb-ft)# priority 10
Router(config-slb-ft)# failover 3
Router(config-slb-ft)# preempt
Router(config-slb-ft)# exit

ヒットレス アップグレードの設定

ヒットレス アップグレード機能を使用すると、アップグレードのためのダウンタイムが原因で主要なサービスが停止する事態を招かずに、新しいバージョンにアップグレードできます。ヒットレス アップグレードを設定する手順は、次のとおりです。


ステップ 1 preemptがイネーブルになっている場合は、オフにします。

ステップ 2 スタンバイ CSM で write memory コマンドを実行します。

ステップ 3 新しいリリースでスタンバイ システムをアップグレードし、CSM を再起動します。

スタンバイCSMは、新しいリリースのスタンバイとして起動します。スティッキー バックアップをイネーブルにしている場合、スタンバイCSMは5分間以上、スタンバイ モードが続きます。

ステップ 4 アクティブCSMをアップグレードします。

ステップ 5 アクティブCSMを再起動します。

アクティブCSMを再起動すると、スタンバイCSMが新しいアクティブCSMになり、サービスを引き継ぎます。

ステップ 6 再起動した CSM はスタンバイとして起動します。