Catalyst 6500 シリーズ スイッチ コンテント スイッチング モジュール インストレーション コンフィギュレーション ノート Software Release 4.1(2)
設定前の作業
設定前の作業
発行日;2012/01/07 | ドキュメントご利用ガイド | ダウンロード ; この章pdf | フィードバック

目次

設定前の作業

オペレーティング システムのサポート

CSMの設定準備

コマンドライン インターフェイスの使用方法

オンライン ヘルプの利用方法

設定の保存および復元

SLBモードの設定

モードのコマンド構文

モード間の切り替え

CSM モードと RP モードの相違

CSM モード

RPモード

モードの変更

CSM モードから RP モードへの変更

RPモードからCSMモード

設定の確認

設定の概要

新しいソフトウェア リリースへのアップグレード

スーパーバイザ エンジンのブートフラッシュからのアップグレード

PCMCIAカードからのアップグレード

外部 TFTP サーバからのアップグレード

設定前の作業

この章では、CSM の設定を始める前の必要事項について説明します。この章の構成は次のとおりです。

「オペレーティング システムのサポート」

「CSMの設定準備」

「設定の保存および復元」

「SLBモードの設定」

「設定の概要」

「新しいソフトウェア リリースへのアップグレード」

オペレーティング システムのサポート

CSMは、スーパーバイザ エンジン上の Catalyst オペレーティング システム ソフトウェアおよび MSFC 上の Cisco IOS ソフトウェアの両方が稼働するスイッチでサポートされています。またCSMは、スーパーバイザ エンジンおよびMSFCの両方でCisco IOSソフトウェアが稼働するスイッチでもサポートされます。

CSM は MSFC CLI 経由で設定されるので、Catalyst オペレーティング システムと Cisco IOS ソフトウェアの両方が稼働するスイッチを使用している場合、最初のセッションは CSM を設定するMSFC CLI にアクセスして設定する必要があります。MSFC CLI では、CSM の設定だけでなく、Catalystオペレーティング システムおよび Cisco IOS スイッチの設定もできます。

Catalyst オペレーティング システムおよび Cisco IOS ソフトウェアの両方が稼働するスイッチを使用する場合は、レイヤ 2 の設定(VLAN およびポート アソシエーションなど)はすべて、スーパーバイザ エンジン上で実行されます。


) Cisco IOS ソフトウェアのみが稼働するスイッチで CSM を実行すると、設定された VLAN は CSM とスイッチのバックプレーンを接続するトランクまたはチャネルに自動的に追加されます。Catalyst オペレーティング システムと Cisco IOS ソフトウェアの両方が稼働するスイッチでは、CSM VLAN を手作業でトランクまたはチャネルに追加する必要があります。


CSMの設定準備

CSM を設定するときは事前に、次の作業を終えておく必要があります。

スイッチとモジュールの Cisco IOS バージョンが一致していることを確認します。『Catalyst 6500 Series Switch Content Switching Module Installation Guide』を参照してください。

SLB を設定するには、次の情報を入手しておく必要があります。

導入先で使用するネットワーク トポロジー

実サーバのIPアドレス

Domain Name Server(DNS;ドメイン ネーム サーバ)で使用するCSM VIP用エントリ(名前を使用してDNSにアクセスする必要がある場合)

各仮想サーバのIPアドレス

先にCatalyst 6500シリーズ スイッチでVLANを設定してから、CSMに対してVLANを設定する必要があります。スイッチとモジュールのVLAN IDは同じにしておきます。詳細については、『 Catalyst 6500 Series Software Configuration Guide 』を参照してください。

次に、VLANを設定する例を示します。

Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# vlan 130
Router(config-vlan)# name CLIENT_VLAN
Router(config-vlan)# exit
Router(config)# vlan 150
Router(config-vlan)# name SERVER_VLAN
Router(config-vlan)# end
 

サーバまたはクライアントに接続する物理インターフェイスを、対応する VLAN 内に配置します。

次に、物理インターフェイスをレイヤ2インターフェイスとして設定して、VLAN に割り当てる例を示します。

Router>
Router> enable
Router# config
Router(config)# interface 3/1
Router(config-if)# switchport
Router(config-if)# switchport access vlan 150
Router(config-if)# no shutdown
Router(vlan)# exit
 

クライアント側またはサーバ側 VLAN 上のネクスト ホップ ルータ上で MSFC を使用する場合は、対応するレイヤ 3 VLAN インターフェイスを設定する必要があります。


注意 ポリシー ベース ルーティングまたは送信元 NAT を使用し、CSM をルータ モードとして設定しないかぎり、クライアント側とサーバ側の両方に対して、MSFC をルータとして同時に使用することはできません。このような状況が発生するのは、CSM がロードバランスまたは転送する両方向のフローを確認する必要があるためです。ブリッジ(シングル サブネット)モードでCSMを使用する場合は、クライアント側とサーバ側の両方に対して、MSFC 上でレイヤ 3 VLAN インターフェイスを設定しないでください。CSM をルータ モードで使用する場合は、戻りトラフィックがCSMに送り返されるように、ポリシー ベース ルーティングまたは送信元 NAT を適切に設定しないかぎり、クライアント側とサーバ側の両方に対して、MSFC 上でレイヤ 3 VLAN インターフェイスを設定しないでください。

次に、レイヤ3 VLANインターフェイスを設定する例を示します。

Router>
Router> enable
Router# config
Router(config)# interface vlan 130
Router(config-if)# ip address 10.10.1.10 255.255.255.0
Router(config-if)# no shutdown
Router(vlan)# exit
 

コマンドライン インターフェイスの使用方法

CSM のソフトウェア インターフェイスは Cisco IOS CLI です。Cisco IOS CLIおよびCisco IOSコマンド モードの詳細については、『Catalyst 6500 Series Switch Cisco IOS Software Configuration Guide』の第 2 章を参照してください。


) プロンプトに入力できる文字数に制限があるため、プロンプトが切り捨てられる場合があります。たとえば、Router(config-slb-vlan-server)#はRouter(config-slb-vlan-serve)#のように表示されます。


オンライン ヘルプの利用方法

どのコマンド モードでも、疑問符(?)を入力すると、使用できるコマンドのリストが表示されます。

Router> ?
 

または

Router(config)# module csm 5
Router(config-module-csm)# ?
 

) オンライン ヘルプでは、コマンドで使用できるデフォルトのコンフィギュレーション値、および値の範囲が表示されます。


設定の保存および復元

設定の保存および復元の詳細については、『 Catalyst 6500 Series Switch Cisco IOS Software Configuration Guide 』を参照してください。

SLBモードの設定

Catalyst 6500シリーズ スイッチのSLB機能は、2種類のモードで設定されます。Routed Processor(RP)モードおよびCSMモードです。スイッチの設定は、CSMの動作に影響しません。CSM はデフォルトで、RP モードで設定されます。RP モードを使用すると、同一シャーシ内で 1 つまたは複数の CSM を設定でき、同一スイッチ上で Cisco IOS SLB を実行できます。


) RP モードはデフォルト モードで、推奨されているモードです。CSM モードは、2.1 より前の CSM ソフトウェア イメージとの下位互換性を確保するためだけに使用されます。新規に CSM または CSM イメージを搭載する場合は、RP モードを使用してください。


CMS モードの場合、設定できる CSM は 1 つだけです。CSMモードをサポートしているのは、旧ソフトウェア リリースとの下位互換性を確保するためです。単一CSM設定では、同一スイッチでCisco IOS SLBを実行できません。

次に、モードについて説明します。

「モードのコマンド構文」

「モード間の切り替え」

「CSM モードと RP モードの相違」

「モードの変更」

モードのコマンド構文

スイッチにCSMコンフィギュレーション コマンドを入力するには、その前に設定対象のCSMを指定しなければなりません。設定するCSMを指定するには、 module csm slot-number コマンドを使用します。 slot-number 値は、設定対象のCSMが搭載されているシャーシ スロットです。

module csm コマンドを使用して CSM コンフィギュレーション サブモードを開始します。以後、入力したすべてのコンフィギュレーション コマンドは、指定したスロットのCSMに適用されます。


) 特に明記していないかぎり、このマニュアルの例ではすべて、このコマンドが入力済みで、設定対象のCSMに対応するコンフィギュレーション モードがすでに開始されていることが前提です。


CSM モードおよび RP モードを設定するコマンドの構文は、次の点を除いて同じです。

CSM モードで設定する場合、上位レベルのコマンドごとに、プレフィクスとして ip slb を指定する必要があります。

CSM モードの設定と RP モードの設定では、プロンプトが異なります。

スロット 5 に取り付けられている CSM に仮想サーバを設定する手順は、次のとおりです。

 

コマンド
目的

ステップ 1

Router(config)# module csm 5

設定するCSMの位置を指定します。

ステップ 2

Router(config-module-csm)# vserver VS1

仮想サーバを設定します。

次に、config-module-csm モードですべての CSM コマンドをリストする例を表示します。

Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# module csm 5
Router(config-module-csm)# ?
SLB CSM module config
arp configure a static ARP entry
capp configure Content Application Peering Protocol
default Set a command to its defaults
dfp configure Dynamic Feedback Protocol manager
exit exit SLB CSM module submode
ft configure CSM fault tolerance (ft) feature
map configure an SLB map
natpool configure client nat pool
no Negate a command or set its defaults
owner configure server owner
policy configure an SLB policy
probe configure an SLB probe
real configure module real server
script configure script files and tasks
serverfarm configure a SLB server farm
static configure static NAT for server initiated connections
sticky configure a sticky group
variable configure an environment variable
vlan configure a vlan
vserver configure an SLB virtual server
xml-config settings for configuration via XML
 

モード間の切り替え

ip slb mode コマンドを使用してモードをCSMからRPに切り替えると、既存のCSM設定が新しい設定に移行します。既存のCSM設定がある場合は、スロット番号が要求されます。

Catalyst 6500 シリーズ スイッチでは、RP モードの設定から CSM モードの設定に移行できます。Cisco IOS SLB の設定から CSM の設定への移行は、手作業にかぎって可能です。

CSM モードと RP モードの相違

CSM モードとRPモードは、CSM が CLI から設定される方法に影響するだけで、CSM 自体の動作および機能に影響するわけではありません。CSM と同一シャーシ内の Cisco IOS SLB の場合と同様に、1 つのシャーシ内の複数の CSM を設定するには、RP モードを使用する必要があります。

CSM モード

ip slb mode csm コマンド モードを使用して、1.xリリースの CSM を設定することができます。このモードの場合、シャーシに設定できる CSM は 1 つです(他の CSM または Cisco IOS SLB を同一のシャーシ内に設定できません)。

このモードでは、すべての CSM コンフィギュレーション コマンドは ip slb で始まります。

CSM の show コマンドは、 show ip slb で始まります。

CSM 2.1以降のリリースを使用している場合は、このモードは推奨できません。このモードは、Cisco IOS CLIで下位互換性を確保するためにオプションとして提供されているからです。

次に、シャーシ内で 1 つの CSM を設定する例を示します。

Cat6k# show running-config
Building configuration...
Current configuration : 5617 bytes
 
ip slb mode csm
ip slb vlan 110 server
ip address 10.10.110.1 255.255.255.0
 
ip slb vlan 111 client
ip address 10.10.111.2 255.255.255.0
gateway 10.10.111.1
 
ip slb probe HTTP_TEST http
request method get url /probe/http_probe.html
expect status 200
interval 5
failed 5
 
ip slb serverfarm WEBFARM
nat server
no nat client
real 10.10.110.10
inservice
real 10.10.110.20
inservice
probe HTTP_TEST
 
ip slb vserver HTTPVIP
virtual 10.10.111.100 tcp www
persistent rebalance
serverfarm WEBFARM
inservice
 

RPモード

Cisco IOS SLBが稼働するシャーシで複数のCSMを設定するには、 ip slb mode rp コマンド モード(デフォルト)を使用します。このモードで設定できるのは、リリース2.1以降のCSMだけです。

このモードでは、CSMは次のコマンド サブモードから設定されます。

mod csm X
 

X は設定するCSMのスロット番号です。

CSMのshowコマンドは、 show mod csm X で始まります。

CSM ソフトウェア リリース 2.1 以降で CSM を設定する場合は、RP モードを使用することをお勧めします。このモードでも、Cisco IOS SLB に適用されるコマンドはすべて、シャーシの CSM に適用できるわけではありません。これらのコマンドは、 ip slb で始まります。

次に、シャーシ内の 1 つの CSM の設定例を示します。

Cat6k# show running-config
Building configuration...
 
Current configuration : 5597 bytes
!---
 
module ContentSwitchingModule 5
vlan 110 server
ip address 10.10.110.1 255.255.255.0
 
vlan 111 client
ip address 10.10.111.2 255.255.255.0
gateway 10.10.111.1
 
probe HTTP_TEST http
request method get url /probe/http_probe.html
expect status 200
interval 5
failed 5
 
serverfarm WEBFARM
nat server
no nat client
real 10.10.110.10
inservice
real 10.10.110.20
inservice
probe HTTP_TEST
 
vserver HTTPVIP
virtual 10.10.111.100 tcp www
persistent rebalance
serverfarm WEBFARM
inservice

モードの変更

CSMの動作モードをCSMモードからRPモードに、またはRPモードからCSMモードに変更することができます。次に、モードの変更方法を示します。

CSM モードから RP モードへの変更

次に CSM モードから RP モードに変更する例を示します。これは CSM 1.x から 2.1 以降のリリースへの一般的な移行例で、モジュールをリセットする必要はありません。

Cat6k# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
 
Cat6k(config)# ip slb mode ?
csm SLB in Content Switching Module
rp SLB in IOS system
 
Cat6k(config)# ip slb mode rp
% The current SLB mode is CSM-SLB.
% You are selecting RP-SLB mode.
% All configuration for CSM-SLB will be moved to module submode.
% Confirm switch to RP-SLB mode? [no]: yes
% Enter slot number for CSM module configuration, 0 for none [5]: 5
% Please save the configuration.
Cat6k(config)# end
 
Cat6k# write
Building configuration...
[OK]
Cat6k#

RPモードからCSMモード

次に RP モードから CSM モードに変更する例を示します。モジュールをリセットする必要はありません。

Cat6k# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
 
Cat6k(config)# ip slb mode ?
csm SLB in Content Switching Module
rp SLB in IOS system
 
Cat6k(config)# ip slb mode csm
% The current SLB mode is RP-SLB.
% You are selecting CSM-SLB.
% All SLB configurations for RP will be ERASED.
% After execution of this command, you must
% write the configuration to memory and reload.
% CSM-SLB module configuration will be moved to ip slb submodes.
% Confirm switch to CSM-SLB mode? [no]: yes
% Enter slot number for CSM module configuration, 0 for none [5]: 5
% Please save the configuration and reload.
 
Cat6k(config)# end
Cat6k# write
Building configuration...
Cat6k# reload
Proceed with reload? [confirm] y
Verify Mode Operation
 

設定の確認

設定が適切に機能することを確認するには、RP モードから次のコマンドを使用します。

Cat6k# show ip slb mode
SLB configured mode = rp
 
Cat6k# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
 
Catk6-1(config)# ip slb ?
dfp configure Dynamic Feedback Protocol manager
entries initial and maximum SLB entries
firewallfarm configure an SLB firewall farm
mode configure SLB system mode
natpool define client nat pool
probe configure an SLB probe
serverfarm configure an SLB server farm
vserver configure an SLB virtual server
 

設定が適切に機能することを確認するには、Cisco IOS SLB モードから次のコマンドを使用します。

Cat6k(config)# module csm 5
Cat6k(config-module-csm)# ?
SLB CSM module config
default Set a command to its defaults
dfp configure Dynamic Feedback Protocol manager
exit exit SLB CSM module submode
ft configure CSM fault tolerance (ft) feature
map configure an SLB map
natpool configure client nat pool
no Negate a command or set its defaults
policy configure an SLB policy
probe configure an SLB probe
serverfarm configure an SLB server farm
static configure static NAT for server initiated connections
sticky configure a sticky group
vlan configure a vlan
vserver configure an SLB virtual server
 

シャーシ内の 1 つの CSM 設定が適切に機能することを確認するには、CSM モードから次のコマンドを使用します。

Cat6k# show ip slb mode
SLB configured mode = csm
 
Catk6-1# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
 
Cat6k(config)# ip slb ?
dfp configure Dynamic Feedback Protocol manager
ft configure CSM fault tolerance (ft) feature
map configure an SLB map
mode configure SLB system mode
natpool configure client nat pool
policy configure an SLB policy
probe configure an SLB probe
serverfarm configure an SLB server farm
static configure static NAT for server initiated connections
sticky configure a sticky group
vlan configure a vlan
vserver configure an SLB virtual server

設定の概要

ここで説明する設定手順は、スイッチがRPモードであることが前提です。図 3-1 では、設定プロセスの必須作業および任意で行う作業の概要を示しています。


) レイヤ4ロードバランシングの場合、ポリシーの設定は不要です。


図 3-1 設定の概要

 

必要なパラメータを設定するには、次の各項を参照してください。

「クライアント側VLANの設定」

「サーバ側VLANの設定」

「サーバ ファームの設定」

「実サーバの設定」

「仮想サーバの設定」

必要なロードバランシング パラメータを CSM 上で設定すると、オプションのパラメータを設定することができます。次の各項を参照してください。

「リダイレクト仮想サーバの設定」

「クライアントNATプールの設定」

「サーバ開始型接続の設定」

「TCPパラメータの設定」

高度な設定と連動するには、第2章から第11章の次の項目を参照してください。

「シングル サブネット(ブリッジ)モードの設定」

「セキュア(ルータ)モードの設定」

「URL ハッシュの設定」

「一般ヘッダー解析の設定」

「RHIの設定」

「フォールトトレランスの設定」

「永続接続の設定」

「HSRPの設定」

「接続の冗長性の設定」

「実サーバの SNMP トラップの設定」

「ヘルス モニタリング用プローブの設定」

「帯域内ヘルス モニタリングの設定」

「HTTP リターン コード チェックの設定」

「CSM の TCL スクリプトの使用」

「ステルス ファイアウォール ロードバランシングの設定」

「標準ファイアウォール ロードバランシングの設定」

「ファイアウォール用リバーススティッキの設定」

新しいソフトウェア リリースへのアップグレード

ここでは、CSMをアップグレードする3種類の方法について説明します。

「スーパーバイザ エンジンのブートフラッシュからのアップグレード」

「PCMCIAカードからのアップグレード」

「外部 TFTP サーバからのアップグレード」


新しいソフトウェア リリースにアップグレードする場合は、CSM イメージをアップグレードしてからCisco IOS イメージをアップグレードする必要があります。そうしないと、スーパーバイザ エンジンがCSMを認識しません。スーパバイザ エンジンがCSMを認識しない場合は、Cisco IOSイメージをダウングレードし、CSMイメージをアップグレードしてから、Cisco IOSイメージをアップグレードする必要があります。


CSMをアップグレードするには、アップグレードするCSMモジュールとのセッションを開始する必要があります。アップグレード中は、スーパーバイザ エンジンに接続されたコンソールにすべてのコマンドを入力します。コンフィギュレーション コマンドは、それぞれ異なるコマンドラインに入力してください。アップグレードを完了するには、 exit コマンドを入力して、スーパーバイザ エンジン プロンプトに戻ります。「SLBモードの設定」を参照してください。


注意 アップグレードしているCSMとのセッションを終了するには、exitコマンドを入力する必要があります。セッションを終了しないでCSMをCatalyst 6500シリーズ シャーシから取り外した場合は、CSMにコンフィギュレーション コマンドを入力するために、Ctrl + ^を押して、xを入力し、プロンプトにdisconnectコマンドを入力する必要があります。

スーパーバイザ エンジンのブートフラッシュからのアップグレード


) ブートフラッシュにイメージをロードする手順については、『Catalyst 6500 Series Supervisor Engine Flash PC Card Installation Note』を参照してください。


スーパーバイザ エンジンのブートフラッシュからCSMをアップグレードする手順は、次のとおりです。


ステップ 1 TFTPサーバをイネーブルにして、次のようにブートフラッシュからイメージを供給します。

Router>
Router> enable
Router# configure terminal
Router(config)# tftp-server sup-bootflash:c6slb-apc.revision-num.bin
Router(config)
 

ステップ 2 スーパーバイザ エンジンとCSM間のセッションを確立します。

Router# session slot csm-slot-number processor 0
 

ステップ 3 スーパーバイザ エンジンからCSMにイメージをロードします。

CSM> upgrade 127.0.0.zz c6slb-apc.revision-num.bin
 

zz = 12(スーパーバイザ エンジンがシャーシ スロット 1 に取り付けられている場合)。
zz = 22(スーパーバイザ エンジンがシャーシ スロット 2 に取り付けられている場合)。


) スーパーバイザ エンジンを取り付けできるのは、シャーシのスロット 1 またはスロット 2 だけです。


ステップ 4 CSM とのセッションを終了し、Cisco IOS プロンプトに戻ります。

CSM> exit
 

ステップ 5 CSM の電源を切断してから電源を投入するか、またはスーパーバイザ エンジンのコンソールから次のコマンドを入力して、CSM を再起動します。

Router(config)# hw-module module csm-slot-number reset
 


 

PCMCIAカードからのアップグレード


) このマニュアル全体で、PCMCIA カードの代わりにフラッシュ PC カードという言葉を使用します。


スーパーバイザ エンジンに装着された着脱式フラッシュ PC カードから CSM をアップグレードする手順は、次のとおりです。


ステップ 1 TFTPサーバをイネーブルにして、着脱式フラッシュPCカードからイメージを供給します。

Router>
Router> enable
Router# configure terminal
Router(config)# tftp-server slotx:c6slb-apc.revision-num.bin
 

x 値 = 0(フラッシュ PC カードがスーパーバイザ エンジンの PCMCIA スロット 0 に取り付けられている場合)。

ステップ 2 スーパーバイザ エンジンと CSM 間のセッションを確立します。

Router# session slot csm-slot-number processor 0
 

ステップ 3 スーパーバイザ エンジンから CSM にイメージをロードします。

CSM> upgrade slot0: c6slb-apc.revision-num.bin
 

) スーパーバイザ エンジンを取り付けできるのはシャーシのスロット1またはスロット2だけです。


ステップ 4 CSM とのセッションを終了し、Cisco IOS プロンプトに戻ります。

CSM> exit
 

ステップ 5 CSM の電源を切断してから電源を投入するか、またはスーパーバイザ エンジンのコンソールから次のコマンドを入力して、CSM を再起動します。

Router# hw-module module csm-slot-number reset
 


 

外部 TFTP サーバからのアップグレード

外部TFTPサーバから CSM をアップグレードする手順は、次のとおりです。


ステップ 1 TFTP CSM ランタイム イメージ ダウンロード用の VLAN をスーパーバイザ エンジン上に作成します。


) 既存の VLAN も使用できますが、確実にダウンロードするには、TFTP 接続専用の VLAN を作成する必要があります。


ステップ 2 TFTPサーバに接続するインターフェイスを設定します。

ステップ 3 インターフェイスをVLANに追加します。

ステップ 4 CSMの vlan コマンドを入力します。

詳細については、 第 4 章「VLANの設定」 を参照してください。

ステップ 5 CSM用VLANにIPアドレスを追加します。

ステップ 6 show csm slot vlan detail コマンドを入力し、設定を確認します。

詳細については、 第 4 章「VLANの設定」 を参照してください。

ステップ 7 CSMからTFTPサーバに接続できるかどうかを確認します。

Router# ping module csm csm-slot-number TFTP-server-IP-address
 

ステップ 8 スーパーバイザ エンジンとCSM間のセッションを確立します。

Router# session slot csm-slot-number processor 0
 

ステップ 9 イメージをアップグレードします。

CSM> upgrade TFTP-server-IP-address c6slb-apc.rev-number.bin
 

ステップ 10 CSMとのセッションを終了し、Cisco IOSプロンプトに戻ります。

CSM> exit
 

ステップ 11 CSMの電源を切断してから電源を投入するか、またはスーパーバイザ エンジンのコンソールから次のコマンドを入力して、CSMを再起動します。

Router# hw-module module csm-slot-number reset