Catalyst 6500 シリーズ スイッチ CSM-S インストレーション コンフィギュレーション ノート Software Release 2.1(1)
冗長性の設定
冗長性の設定
発行日;2012/01/07 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 3MB) | フィードバック

目次

冗長性の設定

フォールトトレランスの設定

HSRPの設定

HSRPの設定の概要

HSRPゲートウェイの作成

フォールトトレラントHSRPコンフィギュレーションの作成

インターフェイスおよびデバイスのトラッキングの設定

HSRPグループのトラッキング

ゲートウェイのトラッキング

インターフェイスのトラッキング

トラッキング モードの設定

接続の冗長性の設定

設定の同期化

ヒットレス アップグレードの設定

フォールトトレランスの設定

ここでは、フォールトトレラントの設定について説明します。この設定では、2つの異なるCatalyst 6500シリーズ シャーシのそれぞれにContent Switching Module with SSL(CSM-S)を搭載します。


) 1つのCatalyst 6500シリーズ シャーシにCSM-Sを2つ搭載して、フォールトトレラント コンフィギュレーションを作成することもできます。フォールトトレラントは、セキュア(ルータ)モードまたは非セキュア(ブリッジ)モードのどちらでも設定できます。


セキュア(ルータ)モードでは、クライアント側およびサーバ側VLAN(仮想LAN)によって、CSM-Sとクライアント側のルータとの間、およびCSM-Sとサーバ側のサーバとの間にフォールトトレラント(冗長性のある)な接続パスが確立されます。冗長構成では、2つのCSM-SはアクティブCSMおよびセカンダリCSMとして機能します。各CSM-Sには同じIP、仮想サーバ、サーバ プール、および実サーバ情報が格納されます。各CSM-Sは、クライアント側およびサーバ側ネットワークで同じように設定されます。ネットワークは、フォールトトレラント コンフィギュレーションを単一CSM-Sとして認識します。


) 複数のフォールトトレラントCSM-Sペアを設定する場合、同じフォールトトレラントVLANを使用するCSM-Sペアを複数設定しないでください。フォールトトレラントCSM-Sペアごとに異なるフォールトトレラントVLANを使用してください。


フォールトトレランスを設定するための条件は、次のとおりです。

Catalyst 6500シリーズ シャーシに2つのCSM-Sが搭載されている。

2つのCSM-Sモジュールが同じ設定である。一方のCSM-Sはアクティブとして、他方はスタンバイとして設定します。

各CSM-Sが同じクライアント側およびサーバ側VLANに接続されている。

CSM-Sモジュール間の通信が共有プライベートVLANによって提供されている。

ネットワークが冗長CSM-Sモジュールを単一のエンティティとして認識している。

1 GB/秒の容量のリンク設定によって接続の冗長性が得られる。CSM-Sのステート変化に正しい時刻のスタンプが与えられるように、スイッチのCisco IOSソフトウェアでカレンダーをイネーブルにします。

カレンダーをイネーブルにするには、次のコマンドを使用します。

Cat6k-2# configure terminal
Cat6k-2(config)# clock timezone WORD offset from UTC
Cat6k-2(config)# clock calendar-valid
 

各CSM-Sのクライアント側およびサーバ側VLANには異なるIPアドレスが設定されているので、CSM-Sはネットワークにヘルス モニタ プローブを送信して(ヘルス モニタリング情報については、 ヘルス モニタリング用プローブの設定を参照)、応答を受信できます。アクティブおよびスタンバイの両方のCSM-Sモジュールが、動作中にプローブを送信します。スタンバイCSM-Sが制御している場合、そのCSM-Sは受信したプローブ応答からサーバのステータスを認識します。

接続複製機能は、非TCP接続とTCP接続の両方をサポートします。CSM-Sモジュールに複製を設定するには、仮想サーバ モードで replicate csrp{sticky | connection} コマンドを入力します。


replicateコマンドは、ディセーブルがデフォルトの設定です。


接続の冗長性を得るために接続複製機能を使用する場合には、次のコマンドを使用します。

Cat6k-2# configure terminal
Cat6k-2(config)# no ip igmp snooping
 

複製フレームには、ユニキャストIPアドレスと同様マルチキャスト タイプの宛先MACがあるので、 no ip igmp snooping コマンドを入力する必要があります。スイッチが、Internet Group Management Protocol(IGMP)にマルチキャスト グループ メンバーシップの検索およびマルチキャストForwarding Information Base(FIB;転送情報ベース)の確立を待ち受ける場合、スイッチはグループ メンバーを検索せずにマルチキャスト テーブルをプルーニングします。アクティブからスタンバイまですべてのマルチキャスト フレームは、エラー結果の原因となるため廃棄されます。

サーバ側VLANにルータがない場合、各サーバのデフォルト ルートはエイリアスIPアドレスを示します。

図9-1に、セキュア(ルータ)モードのフォールトトレラント コンフィギュレーションの設定方法を示します。

図9-1 フォールトトレラントの設定

 


図9-1のアドレスは、次の2種類の手順に関連します。


アクティブ(A)CSM-Sをフォールトトレランスとして設定する手順は、次のとおりです。

 

コマンド
目的

ステップ 1

Router(config-module-csm)# vlan 2 client

クライアント側VLAN 2を作成し、SLB VLANモードを開始します1

ステップ 2

Router(config-slb-vlan-client)# ip addr 192.158.38.10 255.255.255.0

VLAN 2にコンテント スイッチングIPアドレスを割り当てます。

ステップ 3

Router(config-slb-vlan-client)# gateway 192.158.38.20

(任意)クライアント側VLANのゲートウェイをHSRP対応ゲートウェイとして定義します。

ステップ 4

Router(config-module-csm)# vserver vip1

仮想サーバを作成し、SLB vserverモードを開始します。

ステップ 5

Router(config-slb-vserver)# virtual 192.158.38.30 tcp www

仮想IPアドレスを作成します。

ステップ 6

Router(config-module-csm)# inservice

サーバをイネーブルにします。

ステップ 7

Router(config-module-csm)# vlan 3 server

サーバ側VLAN 3を作成し、SLB VLANモードを開始します。

ステップ 8

Router(config-slb-vlan-server)# ip addr 192.158.39.10 255.255.255.0

VLAN 3にCSM-SのIPアドレスを割り当てます。

ステップ 9

Router(config-slb-vlan-server)# alias ip addr 192.158.39.20 255.255.255.0

VLAN 3のデフォルト ルートを割り当てます。

ステップ 10

Router(config-slb-vlan-server) vlan 9

VLAN 9をフォールトトレラントVLANとして定義します。

ステップ 11

Router(config-module-csm)# ft group ft-group-number vl an 9

コンテント スイッチングのアクティブおよびスタンバイ(A/B)グループであるVLAN 9を作成します。

ステップ 12

Router(config-module-csm)# vlan

VLANモードを開始します1

ステップ 13

Router(vlan)# vlan 2

クライアント側VLAN 2を設定します2

ステップ 14

Router(vlan)# vlan 3

サーバ側VLAN 3を設定します。

ステップ 15

Router(vlan)# vlan 9

フォールトトレラントのVLAN 9を設定します。

ステップ 16

Router(vlan)# exit

exit コマンドを入力して、設定を有効にします。

1.モードまたはサブモードを終了するには、exitコマンドを入力します。メニューのトップ レベルに戻るには、endコマンドを入力します。

2.デフォルトの設定に戻すには、このコマンドのno形式を使用します。

スタンバイ(B)CSM-Sをフォールトトレランスとして設定する手順は、次のとおりです(図9-1を参照)。

 

コマンド
目的

ステップ 1

Router(config-module-csm)# vlan 2 client

クライアント側VLAN 2を作成し、SLB VLANモードを開始します3

ステップ 2

Router(config-slb-vlan-client)# ip addr 192.158.38.40 255.255.255.0

VLAN 2にコンテント スイッチングIPアドレスを割り当てます。

ステップ 3

Router(config-slb-vlan-client)# gateway 192.158.38.20

クライアント側VLANゲートウェイを定義します。

ステップ 4

Router(config-module-csm)# vserver vip1

仮想サーバを作成し、SLB仮想サーバ モードを開始します。

ステップ 5

Router(config-slb-vserver)# virtual 192.158.38.30 tcp www

仮想IPアドレスを作成します。

ステップ 6

Router(config-module-csm)# inservice

サーバをイネーブルにします。

ステップ 7

Router(config-module-csm)# vlan 3 s erver

サーバ側VLAN 3を作成し、SLB VLANモードを開始します。

ステップ 8

Router(config-slb-vserver)# ip addr 192.158.39.30 255.255.255.0

VLAN 3にCSM-SのIPアドレスを割り当てます。

ステップ 9

Router(config-slb-vserver)# alias 192.158.39.20 255.255.255.0

VLAN 2のデフォルト ルートを割り当てます。

ステップ 10

Router(config-module-csm) vlan 9

VLAN 9をフォールトトレラントVLANとして定義します。

ステップ 11

Router(config-module-csm)# ft group ft-group-number vlan 9

CSM-Sアクティブおよびスタンバイ(A/B)グループであるVLAN 9を作成します。

ステップ 12

Router(config-module-csm)# show module csm all

フォールトトレラント システムのステートを表示します。

3.モードまたはサブモードを終了するには、exitコマンドを入力します。メニューのトップ レベルに戻るには、endコマンドを入力します。

HSRPの設定

ここではHot Standby Router Protocol(HSRP)の設定を概説し(図9-2を参照)、Catalyst 6500シリーズ スイッチでHSRPおよびCSM-Sフェールオーバーを指定してCSM-Sモジュールを設定する方法について説明します。

HSRPの設定の概要

図9-2では、HSRPゲートウェイ(10.100.0.1)を介してクライアント側ネットワーク(10.100/16)から内部CSM-Sクライアント ネットワーク(10.6/16、VLAN 136)にルーティングするように、Catalyst 6500シリーズ スイッチのスイッチ1およびスイッチ2を設定しています。次の点に留意して設定してください。

クライアント側ネットワークには、HSRP ID 2というHSRPグループIDが割り当てられています。

内部CSM-Sクライアント ネットワークには、HSRP ID 1というHSRPグループIDが割り当てられています。


) HSRPグループ1は、HSRPグループ2のクライアント ネットワーク ポートを追跡できるように、トラッキングをオンにしておく必要があります。HSRPグループがこれらのポートのアクティブ ステート変化を検出すると、その変化を複製し、HSRPアクティブ スイッチ(スイッチ1)とHSRPスタンバイ スイッチ(スイッチ2)の両方で、同じネットワーク情報が共有されるようにします。


この設定例では、クライアント側とサーバ側VLANの間でトラフィックを転送するように2つのCSM-Sモジュール(スイッチ1およびスイッチ2に1つずつ)が設定されています。

クライアントVLAN 136


) クライアントVLANは、実際は内部CSM-S VLANネットワークです。実際のクライアント ネットワークはスイッチの反対側にあります。


サーバVLAN 272

サーバ ネットワーク(10.5/1)上の実際のサーバは、エイリアス ゲートウェイ(10.5.0.1)を介してCSM-Sサーバ ネットワークを示しているため、サーバは安全なサブネットを実現できます。

設定例では、EtherChannelはトランキングがイネーブルになるようにセットアップされているため、内部CSM-Sクライアント ネットワークのトラフィックを2つのCatalyst 6500シリーズ スイッチ間で送受信できます。図9-2に設定を示します。


) EtherChannelはアクティブ スイッチへのリンクの切断、およびCSM-S以外のスイッチ コンポーネントの故障に対して保護します。また、スイッチ内のアクティブなCSM-Sと別のスイッチとの間でパスを確立して、CSM-Sモジュールとスイッチが独立してフェールオーバーできるようにします。これによって、フォールトトレランス レベルがさらに向上します。


図9-2 HSRPの設定

 

HSRPゲートウェイの作成

ここでは、クライアント側ネットワーク用のHSRPゲートウェイを作成する方法について説明します。クライアント側ネットワークのゲートウェイはHSRP ID 2です。


) この例では、HSRPはファスト イーサネット ポート3/6に設定されています。


HSRPゲートウェイを作成する手順は、次のとおりです。


ステップ 1 スイッチ1 ― FT1(HSRPアクティブ)を設定します。

Router(config)# interface FastEthernet3/6
Router(config)# ip address 10.100.0.2 255.255.0.0
Router(config)# standby 2 priority 110 preempt
Router(config)# standby 2 ip 10.100.0.1
 

ステップ 2 スイッチ2 ― FT2(HSRPスタンバイ)を設定します。

Router(config)# interface FastEthernet3/6
Router(config)# ip address 10.100.0.3 255.255.0.0
Router(config)# standby 2 priority 100 preempt
Router(config)# standby 2 ip 10.100.0.1
 


 

フォールトトレラントHSRPコンフィギュレーションの作成

ここでは、フォールトトレラントHSRPセキュア モードを設定する方法について説明します。非セキュア モードを設定するには、次の例外に従ってコマンドを入力します。

サーバ側およびクライアント側VLANの両方に同じIPアドレスを割り当てます。

サーバ側VLANにデフォルト ゲートウェイを割り当てる場合は、 alias コマンドを使用しないでください。

フォールトトレラントHSRPコンフィギュレーションを作成する手順は、次のとおりです。


ステップ 1 HSRP FT1のVLANを設定します。

Router(config)# module csm 5
Router(config-module-csm)# vlan 136 client
Router(config-slb-vlan-client)# ip address 10.6.0.245 255.255.0.0
Router(config-slb-vlan-client)# gateway 10.6.0.1
Router(config-slb-vlan-client)# exit
 
Router(config-module-csm)# vlan 272 server
Router(config-slb-vlan-server)# ip address 10.5.0.2 255.255.0.0
Router(config-slb-vlan-server)# alias 10.5.0.1 255.255.0.0
Router(config-slb-vlan-server)# exit
 
Router(config-module-csm)# vlan 71
 
Router(config-module-csm)# ft group 88 vlan 71
Router(config-slb-ft)# priority 30
Router(config-slb-ft)# preempt
Router(config-slb-ft)# exit
 
Router(config-module-csm)# interface Vlan136
ip address 10.6.0.2 255.255.0.0
standby 1 priority 100 preempt
standby 1 ip 10.6.0.1
standby 1 track Fa3/6 10
 

ステップ 2 HSRP FT2のVLANを設定します。

Router(config)# module csm 6
Router(config-module-csm)# vlan 136 client
Router(config-slb-vlan-client)# ip address 10.6.0.246 255.255.0.0
Router(config-slb-vlan-client)# gateway 10.6.0.1
Router(config-slb-vlan-client)# exit
 
Router(config-module-csm)# vlan 272 server
Router(config-slb-vlan-server)# ip address 10.5.0.3 255.255.0.0
Router(config-slb-vlan-server)# alias 10.5.0.1 255.255.0.0
Router(config-slb-vlan-server)# exit
 
Router(config-module-csm)# vlan 71
 
Router(config-module-csm)# ft group 88 vlan 71
Router(config-slb-ft)# priority 20
Router(config-slb-ft)# preempt
Router(config-slb-ft)# exit
 
Router(config-module-csm)# interface Vlan136
ip address 10.6.0.3 255.255.0.0
standby 1 priority 100 preempt
standby 1 ip 10.6.0.1
standby 1 track Fa3/6 10
 

) トラッキングを作動させるには、preemptをオンにする必要があります。


ステップ 3 両方のスイッチでEtherChannelを設定します。

Router(console)# interface Port-channel100
Router(console)# switchport
Router(console)# switchport trunk encapsulation dot1q
Router(console)# switchport trunk allowed vlan 136
 

) デフォルトでは、ポート チャネル上ですべてのVLANが許可されます。


ステップ 4 問題が発生しないように、サーバおよびフォールトトレラントCSM-SのVLANを削除します。

Router(console)# switchport trunk remove vlan 71
Router(console)# switchport trunk remove vlan 272
 

ステップ 5 EtherChannelにポートを追加します。

Router(console)# interface FastEthernet3/25
Router(console)# switchport
Router(console)# channel-group 100 mode on
 


 

インターフェイスおよびデバイスのトラッキングの設定

フォールトトレラントHSRPを設定すると、CSM-Sのアクティブおよびスタンバイ状態は、アクティブHSRPグループの状態に従いません。アクティブHSRPとアクティブCSM-Sが異なるシャーシ内にある場合、トラフィックは2つのシャーシ間のトランク ポートを経由します。

HSRPグループ、物理インターフェイス、およびゲートウェイの状態を追跡するためにトラッキングを設定できます。

HSRPグループのトラッキング

指定された追跡対象のグループのHSRP状態が変化したときに、Cisco IOSソフトウェアがCSM-Sにメッセージを送信して、アクティブ スイッチ オーバーを実行するようにHSRPグループのトラッキングを設定できます。

HSRPグループのトラッキングを設定するには、フォールトトレラント サブモードで次の手順を実行します。

 

コマンド
目的
Router(config-slb-ft)# track group group_number

追跡対象のHSRPグループを指定します。

ゲートウェイのトラッキング

ゲートウェイのトラッキングを設定すると、Cisco IOSソフトウェアがCSM-Sに設定されたゲートウェイIPアドレスおよびネクスト ホップIPアドレスを送信します。次に、CSM-Sはゲートウェイのアベイラビリティを定期的に確認します。ゲートウェイが使用不可能な場合、CSM-Sは強制的にアクティブ スイッチオーバーを実行します。

ゲートウェイのトラッキングを設定するには、フォールトトレラント サブモードで次の手順を実行します。

 

コマンド
目的
Router(config-slb-ft)# track gateway ip_addr

追跡対象のゲートウェイIPアドレスを設定します。

インターフェイスのトラッキング

指定された物理インターフェイスがダウンした場合に、Cisco IOSソフトウェアがCSM-Sにメッセージを送信して、アクティブ スイッチオーバーを実行するようにインターフェイスのトラッキングを設定できます。

インターフェイスのトラッキングを設定するには、フォールトトレラント サブモードで次の手順を実行します。

 

コマンド
目的
Router(config-slb-ft)# track interface { async | ctunnel | dialer | fastethernet | gigabitethernet }

追跡対象のインターフェイスを指定します。

トラッキング モードの設定

トラッキング モードを設定するには、フォールトトレラント サブモードで次の手順を実行します。

 

コマンド
目的
Router(config-slb-ft)# track mode
{ any | all }

追跡対象のモードを指定します。

追跡中のデバイスのいずれかがダウンした場合、またはHSRP状態がスタンバイに変化した場合は、anyキーワードにより強制的にスイッチオーバーが実行されます。

設定されたすべてのトラッキング機能(グループ、ゲートウェイ、およびインターフェイス)に関して追跡中のデバイスの少なくとも1つがダウンした場合、 all キーワードにより強制的にスイッチオーバーが実行されます。

接続の冗長性の設定

接続の冗長性によって、アクティブCSM-Sで障害が発生し、スタンバイCSM-Sがアクティブになった場合に、オープンな接続が応答を停止する事態を防止できます。接続の冗長性によって、アクティブCSM-SからスタンバイCSM-Sへのフェールオーバー時にオープンなままにしておくべき各接続について、アクティブCSM-SはスタンバイCSM-Sに転送情報をコピーします。

接続の冗長性を設定する手順は、次のとおりです。

 

コマンド
目的

ステップ 1

Router# configure terminal

ルータ コンフィギュレーション モードを開始します。

ステップ 2

Router(config)# no ip igmp snooping

設定からIGMPスヌーピングを削除します。

ステップ 3

Router(config-module-csm)# vserver virtserver-name

仮想サーバを特定し、仮想サーバ サブモードを開始します。

ステップ 4

Router(config-slb-vserver)# virtual ip-address [ip-mask] protocol port-number [service ftp ]

仮想サーバの属性を設定します。

ステップ 5

Router(config-slb-vserver)# serverfarm serverfarm-name

サーバ ファームと仮想サーバを関連付けます。

ステップ 6

Router(config-slb-vserver)# sticky duration [ group group-id ] [ netmask ip-netmask ]

同じクライアントからの接続には同じ実サーバが使用されるようにします。

ステップ 7

Router(config-slb-vserver)# replicate csrp sticky

スティッキの複製をイネーブルにします。

ステップ 8

Router(config-slb-vserver)# replicate csrp connection

接続の複製をイネーブルにします。

ステップ 9

Router(config-slb-vserver)# inservice

仮想サーバのロードバランシングをイネーブルにします。

ステップ 10

Router(config-module-csm)# ft group group-id vlan vlanid

フォールトトレランスを設定し、フォールトトレランス サブモードを開始します。

ステップ 11

Router(config-slb-ft)# priority value

CSM-Sのプライオリティを設定します。

ステップ 12

Router(config-slb-ft)# failover failover-time

スタンバイCSM-SがアクティブCSM-Sになるまでの待機時間を設定します。

ステップ 13

Router(config-slb-ft)# preempt

オンラインになったときに、プライオリティの高いCSM-Sがフォールトトレラント グループを制御するようにします。

次に、接続の冗長性を目的として、フォールトトレランスを設定する例を示します。

Router(config-module-csm)# vserver VS_LINUX-TELNET
Router(config-slb-vserver)# virtual 10.6.0.100 tcp telnet
Router(config-slb-vserver)# serverfarm SF_NONAT
Router(config-slb-vserver)# sticky 100 group 35
Router(config-slb-vserver)# replicate csrp sticky
Router(config-slb-vserver)# replicate csrp connection
Router(config-slb-vserver)# inservice
Router(config-slb-vserver)# exit
Router(config-module-csm)# ft group 90 vlan 111
Router(config-slb-ft)# priority 10
Router(config-slb-ft)# failover 3
Router(config-slb-ft)# preempt
Router(config-slb-ft)# exit
 

設定の同期化

単一のシャーシまたは別々のシャーシのアクティブCSM-SおよびスタンバイCSM-S間で設定を同期化できます。同期化は、フォールトトレラントVLAN上で実行されます。


) フォールトトレラントVLAN上のトラフィックは、ブロードキャスト パケットを使用します。そのため、アクティブCSM-SおよびスタンバイCSM-S間の通信に必要なデバイス以外のすべてのデバイスをフォールトトレラントVLANから削除することを推奨します。



) 次に示す手順を記述通りに実行することが重要です。設定を同期化する前に、(下記のステップ 4で記述されているとおり)アクティブCSM-S上でalt standby_ip_addressコマンドを入力しない場合、スタンバイCSM-S上のVLAN IPアドレスは削除されます。


アクティブCSM-Sで同期化を設定する手順は、次のとおりです。

 

コマンド
目的

ステップ 1

Router# configure terminal

ルータ コンフィギュレーション モードを開始します。

ステップ 2

Router(config)# module csm slot-number

アクティブCSM-Sのスロット番号を指定します。

ステップ 3

Router(config-module-csm)# vlan vlan_ID { client | server }

クライアント側VLANおよびサーバ側VLANを設定します。

ステップ 4

Router(config-slb-vlan-client)# ip addr active_ip_addr netmask alt standby_ip_addr netmask

特定のVLAN上のCSM-SにIPアドレスを設定します。 alt キーワードを入力して、スタンバイCSM-Sに送信される代替IPアドレスを指定します。


) 設定を同期化する前に、アクティブCSM-S上でalt standby_ip_addressコマンドを入力しない場合、バックアップCSM-S上のVLAN IPアドレスは削除されます。


 

ステップ 5

Router(config-slb-vlan-client)# exit

VLANコンフィギュレーション モードを終了します。

ステップ 6

Router(config-module-csm)# ft group group-id vlan vlanid

フォールトトレランスを設定し、フォールトトレランス サブモードを開始します。

ステップ 7

Router(config-slb-ft)# priority active_value alt standby_value

CSM-Sのプライオリティを設定します。 alt キーワードを入力して、スタンバイCSM-Sに送信される代替プライオリティ値を指定します。

スタンバイCSM-Sで同期化を設定する手順は、次のとおりです。

 

コマンド
目的

ステップ 1

Router# configure terminal

ルータ コンフィギュレーション モードを開始します。

ステップ 2

Router(config)# module csm slot-number

スタンバイCSM-Sのスロット番号を指定します。

ステップ 3

Router(config-module-csm)# ft group group-id vlan vlanid

フォールト トレランスを設定し、フォールト トレラントVLANを指定します。

設定を同期化する手順には、アクティブCSM-Sで次の手順を実行します。

 

コマンド
目的
Router# hw- module csm slot-number standby config-sync

設定を同期化します。設定を同期化するたびに、このコマンドを入力します。

次に、アクティブCSM-SおよびスタンバイCSM-Sの両方で同期化を設定する例を示します。

アクティブCSM-S

Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# module csm 5
Router(config-module-csm)# vlan 130 client
Router(config-slb-vlan-client)# ip addr 123.44.50.5 255.255.255.0 alt 123.44.50.7 255.255.255.0
Router(config-slb-vlan-client)# gateway 123.44.50.1
Router(config-slb-vlan-client)# exit
Router(config-module-csm)# vlan 150 server
Router(config-slb-vlan-server)# ip addr 123.46.50.6 255.255.255.0 alt 123.44.40.8 255.255.255.0
Router(config-slb-vlan-server)# alias 123.60.7.6 255.255.255.0
Router(config-slb-vlan-server)# route 123.50.0.0 255.255.0.0 gateway 123.44.50.1
Router(config-slb-vlan-server)# exit
Router(config-module-csm)# ft group 90 vlan 111
Router(config-slb-ft)# priority 10 alt 15
Router(config-slb-ft)# end
 

スタンバイCSM-S

Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# module csm 6
Router(config-module-csm)# ft group 90 vlan 111
Router(config-slb-ft)# end
 

次に、アクティブCSM-SとスタンバイCSM-S間で設定を同期化する例を示します。

Router# hw-module csm 5 standby config-sync
%CSM_SLB-6-REDUNDANCY_INFO:Module 5 FT info:Active:Bulk sync started
%CSM_SLB-6-REDUNDANCY_INFO:Module 5 FT info:Active:Manual bulk sync completed

ヒットレス アップグレードの設定

ヒットレス アップグレード機能を使用すると、アップグレードのためのダウンタイムが原因で主要なサービスが停止する事態を招かずに、新しいソフトウェア バージョンにアップグレードできます。ヒットレス アップグレードを設定する手順は、次のとおりです。


ステップ 1 preemptがイネーブルになっている場合は、オフにします。

ステップ 2 スタンバイCSM-Sでwrite memoryを実行します。

ステップ 3 新しいリリースでスタンバイCSM-Sをアップグレードし、CSM-Sを再起動します。

スタンバイCSM-Sは、新しいリリースのスタンバイとして起動します。スティッキ バックアップをイネーブルにしている場合、スタンバイCSM-Sは5分間以上、スタンバイ モードが続きます。

ステップ 4 アクティブCSM-Sをアップグレードします。

ステップ 5 アクティブCSM-Sを再起動します。

アクティブCSM-Sを再起動すると、スタンバイCSM-Sが新しいアクティブCSM-Sになり、サービスを引き受けます。

ステップ 6 再起動したCSM-SはスタンバイCSMとして起動します。