Catalyst Supervisor Engine 32 PISA Cisco IOS ソフトウェア コマンド リファレンス
Supervisor Engine 32 Programmable Intelligent Services Accelerator(PISA) が設定された Catalyst 6500 シリーズ スイッチの Cisco IOS コマンド-14
shutdown vlan
発行日;2012/02/01 | 英語版ドキュメント(2012/01/24 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 14MB) | フィードバック

目次

shutdown vlan

snmp ifindex clear

snmp ifindex persist

snmp-server enable traps

snmp-server enable traps transceiver type all

snmp-server ifindex persist

snmp-server source-interface

snmp-server trap authentication unknown-context

snmp-server trap link switchover

spanning-tree backbonefast

spanning-tree bpdufilter

spanning-tree bpduguard

spanning-tree cost

spanning-tree etherchannel guard misconfig

spanning-tree extend system-id

spanning-tree guard

spanning-tree link-type

spanning-tree loopguard default

spanning-tree mode

spanning-tree mst

spanning-tree mst configuration

spanning-tree mst forward-time

spanning-tree mst hello-time

spanning-tree mst max-age

spanning-tree mst max-hops

spanning-tree mst pre-standard

spanning-tree mst root

spanning-tree pathcost method

spanning-tree portfast (interface configuration mode)

spanning-tree portfast bpdufilter default

spanning-tree portfast bpduguard default

spanning-tree portfast default

spanning-tree port-priority

spanning-tree transmit hold-count

spanning-tree uplinkfast

spanning-tree vlan

speed

squeeze

stack-mib portname

standby delay minimum reload

standby track

standby use-bia

storm-control level

switchport

switchport access vlan

switchport autostate exclude

switchport backup

switchport block unicast

switchport capture

switchport capture allowed vlan

switchport dot1q ethertype

switchport mode

switchport port-security

switchport port-security aging

switchport port-security mac-address

switchport port-security maximum

switchport port-security violation

switchport private-vlan host-association

switchport private-vlan mapping

switchport trunk

switchport vlan mapping

switchport vlan mapping enable

switchport voice vlan

sync-restart-delay

system flowcontrol bus

system jumbomtu

tcam priority

test cable-diagnostics

time-range

shutdown vlan

指定された VLAN 上でローカル トラフィックを遮断するには、 shutdown vlan コマンドを使用します。VLAN のローカル トラフィックを再開するには、このコマンドの no 形式を使用します。

shutdown vlan vlan-id

no shutdown vlan vlan-id

 
シンタックスの説明

vlan-id

ローカルに遮断する VLAN の VLAN 番号。 有効値は 2 ~ 1001 です。

 
コマンドのデフォルト

このコマンドにはデフォルト設定がありません。

 
コマンド モード

グローバル コンフィギュレーション(config)

 
コマンドの履歴

リリース
変更内容

12.2(18)ZY

このコマンドのサポートが追加されました。

 
使用上のガイドライン

このコマンドは、拡張範囲 VLAN をサポートしません。

次に、VLAN 2 でトラフィックを遮断する例を示します。

Router(config)# shutdown vlan 2
Router(config)#

snmp ifindex clear

特定のインターフェイスに対して実行された設定済みの snmp ifindex コマンドをクリアするには、 snmp ifindex clear コマンドを使用します。

snmp ifindex clear

 
シンタックスの説明

このコマンドには、キーワードまたは引数はありません。

 
コマンドのデフォルト

このコマンドにはデフォルト設定がありません。

 
コマンド モード

インターフェイス コンフィギュレーション(config-if)

 
コマンドの履歴

リリース
変更内容

12.2(18)ZY

このコマンドのサポートが追加されました。

 
使用上のガイドライン

IF-MIB の ifIndex 値が再起動後も保持され、SNMP を使用することにより特定のインターフェイスを一貫して識別できる場合は、インターフェイス インデックスの永続性が確保されます。

特定のインターフェイスで ifIndex 永続性に関するグローバル コンフィギュレーション設定を使用する場合は、このインターフェイス上で snmp ifindex clear コマンドを使用します。このコマンドは、特定のインターフェイスに入力されたすべての ifIndex コンフィギュレーション コマンドを削除します。

ifIndex 設定を削除した場合、グローバル コンフィギュレーション モードで snmp-server ifindex persist コマンドによって指定したように、ifIndex 永続性がすべてのインターフェイスについてイネーブル化されます。

次に、すべてのインターフェイスの ifIndex 永続性をイネーブルにする例を示します。

Router(config)# snmp ifindex persist
 

次に、イーサネット 0/1 の IfIndex 永続性だけをディセーブルにする例を示します。

Router(config)# interface ethernet 0/1
Router(config-if)# no snmp ifindex persist
Router(config-if)# exit
 

次に、イーサネット 0/1 設定から ifIndex 設定を削除する例を示します。

Router(config)# interface ethernet 0/1
Router(config-if)# snmp ifindex clear
Router(config-if)# exit

 
関連コマンド

コマンド
説明

snmp ifindex persist

再起動後も保持される Interfaces MIB(IF-MIB)内の ifIndex 値(ifIndex 永続性)を特定のインターフェイス上だけでイネーブルにします。

snmp-server ifindex persist

ifIndex 値を、SNMP で使用するために再起動後も一定となるようにグローバルにイネーブル化します。

 

snmp ifindex persist

再起動後も保持される Interfaces MIB(IF-MIB)内の ifIndex 値(ifIndex 永続性)を特定のインターフェイス上だけでイネーブルにするには、 snmp ifindex persist コマンドを使用します。ifIndex 永続性を特定のインターフェイス上だけでディセーブルにするには、このコマンドの no 形式を使用します。

snmp ifindex persist

no snmp ifindex persist

 
シンタックスの説明

このコマンドには、キーワードまたは引数はありません。

 
コマンドのデフォルト

ディセーブル

 
コマンド モード

インターフェイス コンフィギュレーション(config-if)

 
コマンドの履歴

リリース
変更内容

12.2(18)ZY

このコマンドのサポートが追加されました。

 
使用上のガイドライン

IF-MIB の ifIndex 値が再起動後も保持され、SNMP )を使用することにより特定のインターフェイスを一貫して識別できる場合は、インターフェイス インデックスの永続性が確保されます。

snmp ifindex persist コマンドをインターフェイス コンフィギュレーション モードで使用すると、IF-MIB の ifIndex テーブル内のエントリ(各インターフェイスに対応するエントリ)ごとに、ifIndex 永続性をイネーブルにしたり、ディセーブルにしたりすることができます。

snmp-server ifindex persist コマンドをグローバル コンフィギュレーション モードで 使用すると、ルーティング装置のすべてのインターフェイスに対して、ifIndex 永続性をイネーブルにしたり、ディセーブルにしたりできます。このアクションは、IF-MIB の ifIndex テーブル内に ifDescr および ifIndex エントリがあるインターフェイスにだけ適用されます。

特定のインターフェイスに設定した ifIndex コマンドは、そのインターフェイスのすべてのサブインターフェイスに適用されます。

次に、インターフェイス イーサネット 0/1 の ifIndex 永続性だけをイネーブルにする例を示します。

Router(config)# interface ethernet 0/1
Router(config-if)# snmp ifindex persist
Router(config-if)# exit
 

次に、すべてのインターフェイスの ifIndex 永続性をイネーブルにし、インターフェイス イーサネット 0/1 のifIndex 永続性だけをディセーブルにする例を示します。

Router(config)# snmp ifindex persist
Router(config)# interface ethernet 0/1
Router(config-if)# no snmp ifindex persist
Router(config-if)# exit

 
関連コマンド

コマンド
説明

snmp ifindex clear

特定のインターフェイスに対して実行された設定済みの snmp ifindex コマンドをクリアします。

snmp-server ifindex persist

ifIndex 値を、SNMP で使用するために再起動後も一定となるようにグローバルにイネーブル化します。

 

snmp-server enable traps

システムで使用できる SNMP )通知(トラップまたはインフォーム)をイネーブルにするには、 snmp-server enable traps コマンドを使用します。使用できるすべての SNMP 通知をディセーブルにするには、このコマンドの no 形式を使用します。

snmp-server enable traps [ notification-type ]

no snmp-server enable traps [ notification-type ]

 
シンタックスの説明

notification-type

(任意)イネーブルまたはディセーブルにする通知(トラップまたはインフォーム)のタイプです。タイプを指定しなければ、装置で使用可能なすべての通知がイネーブルまたはディセーブルになります。有効値については、「使用上のガイドライン」を参照してください。

 
コマンドのデフォルト

このコマンドは、デフォルトではディセーブルです。ほとんどの通知タイプはディセーブルです。しかし、一部の通知タイプはこのコマンドでは制御できません。

このコマンドを notification-type の指定なしで入力すると、このコマンドで制御されるすべての通知タイプがイネーブルになります。

 
コマンド モード

グローバル コンフィギュレーション(config)

 
コマンドの履歴

リリース
変更内容

12.2(18)ZY

このコマンドのサポートが追加されました。

 
使用上のガイドライン

他の通知タイプについては、『 Cisco IOS Release 12.2 Command Reference 』を参照してください。

SNMP 通知は、トラップまたはインフォーム要求として送信できます。このコマンドはトラップおよびインフォーム要求の両方を、指定された通知タイプについてイネーブル化します。送信される通知がトラップかインフォームかを指定するには、 snmp-server host [ traps | informs ] コマンドを使用します。

snmp-server enable traps コマンドを入力しなければ、このコマンドで制御される通知は送信されません。これらの SNMP 通知を送信するようにルータを設定するには、少なくとも 1 回 snmp-server enable traps コマンドを入力する必要があります。このコマンドをキーワードなしで入力すると、すべての通知タイプがイネーブルになります。このコマンドをキーワード付きで入力すると、そのキーワードに関係する通知タイプだけがイネーブルになります。複数の通知タイプをイネーブルにするには、 snmp-serverenabletraps コマンドを各通知タイプおよび通知オプションについて別々に実行する必要があります。

snmp-server enable traps コマンドは、 snmp-server host コマンドとともに使用します。 snmp-server host コマンドは、SNMP 通知を受信するホストの指定に使用します。通知を送信するためには、少なくとも 1 回 snmp-server host コマンドを設定する必要があります。

トラップに使用される MIB の一覧を示します。

chassis :CISCO-STACK-MIB からの chassisAlarm トラップを制御します。

flash :CISCO-FLASH-MIB からの SNMP Flash トラップを制御します。

insertion :SNMP Flash 挿入トラップ通知を制御します。

removal :SNMP Flash 削除トラップ通知を制御します。

fru-ctrl :CISCO-ENTITY-FRU-CONTROL-MIB からの FRU 制御トラップを制御します。

module :CISCO-STACK-MIB からの SNMP モジュール トラップを制御します。

stpx :CISCO-STP-EXTENSIONS-MIB からのすべてのトラップを制御します。

vlancreate :SNMP VLAN 作成トラップ通知を制御します。

vlandelete :SNMP VLAN 削除トラップ通知を制御します。

vtp :CISCO-VTP-MIB からの VTP トラップを制御します。

次の SNMP サーバ対応トラップがサポートされています。

bridge :STP Bridge MIB トラップを制御します。

c6kxbar :c6kxbar intbus-crcexcd intbus-crcrcvrd swbus トラップを制御します。

csg :CSG エージェント クォータ データベース トラップを制御します。

flex-links :フレックスリンクス ステータス トラップを制御します。

mac-notification :MAC-Notification 移動しきい値トラップを制御します。

stpx :STPX 不一致/ルート不一致/ループ不一致 トラップを制御します。

vlan-mac-limit :レイヤ 2 制御 VLAN MAC 制限通知トラップを制御します。

次に、public と定義されたコミュニティ ストリングを使用して、名前 myhost.cisco.com で指定されたホストにすべてのトラップを送信する例を示します。

Router(config)# snmp-server enable traps
Router(config)# snmp-server host myhost.cisco.com public

 

snmp-server enable traps transceiver type all

すべてのトランシーバ タイプでサポートされているすべての SNMP トランシーバ トラップをイネーブルにするには、 snmp-server enable traps transceiver type all コマンドを使用します。トランシーバの SNMP トラップ通知をディセーブルにするには、このコマンドの no 形式を使用します。

snmp-server enable traps transceiver type all

no snmp-server enable traps transceiver type all

 
シンタックスの説明

このコマンドには、キーワードまたは引数はありません。

 
コマンドのデフォルト

ディセーブル

 
コマンド モード

グローバル コンフィギュレーション(config)

 
コマンドの履歴

リリース
変更内容

12.2(18)ZY

このコマンドのサポートが追加されました。

 
使用上のガイドライン

snmp-server enable traps コマンドは、 snmp-server host コマンドとともに使用します。 snmp-server host コマンドは、SNMP 通知を受信するホストの指定に使用します。通知を送信するためには、少なくとも 1 回 snmp-server host コマンドを設定する必要があります。

次に、すべてのトランシーバ タイプでサポートされているすべての SNMP トランシーバ トラップをイネーブルにする例を示します。

Router(config)# snmp-server enable traps transceiver type all
Router(config)#

 
関連コマンド

コマンド
説明

show interfaces transceiver

DOM がイネーブルになっているオプティカル トランシーバに関する情報を表示します。

 

snmp-server ifindex persist

ifIndex 値を、SNMP )で使用するために再起動後も一定となるようにグローバルにイネーブル化するには、 snmp-server ifindex persist コマンドを使用します。ifIndex 永続性をグローバルにディセーブルにするには、このコマンドの no 形式を使用します。

snmp-server ifindex persist

no snmp-server ifindex persist

 
シンタックスの説明

このコマンドには、キーワードまたは引数はありません。

 
コマンドのデフォルト

ディセーブル

 
コマンド モード

グローバル コンフィギュレーション(config)

 
コマンドの履歴

リリース
変更内容

12.2(18)ZY

このコマンドのサポートが追加されました。

 
使用上のガイドライン

IF-MIB の ifIndex 値が再起動後も保持され、SNMP を使用することにより特定のインターフェイスを一貫して識別できる場合は、インターフェイス インデックスの永続性が確保されます。

グローバル コンフィギュレーション モードの snmp-server ifindex persist コマンドは、インターフェイス固有の設定を上書きしません。ifIndex 永続性に関するインターフェイス固有の設定を上書きするには、 [ no ] snmp ifindex persist および snmp ifindex clear コマンドをインターフェイス コンフィギュレーション モードで入力します。

[ no ] snmp-server ifindex persist コマンドをグローバル コンフィギュレーション モードで入力すると、IF-MIB の ifIndex テーブル内の ifDescr および ifIndex エントリを使用するルーティング装置のすべてのインターフェイスで、ifIndex 永続性をイネーブルにしたり、ディセーブルにできます。

次に、すべてのインターフェイスの ifIndex 永続性をイネーブルにする例を示します。

Router(config)# snmp-server ifindex persist
Router(config)#

) この例は、no snmp ifindex persist コマンドをインターフェイス コンフィギュレーション モードで使用して特定のインターフェイスで ifIndex 永続性がディセーブル化されている場合に、ifIndex 永続性がこのインターフェイス上でディセーブルのまま保持されることを示します。グローバル ifIndex コマンドは、インターフェイス固有のコマンドを上書きしません。


 
関連コマンド

コマンド
説明

snmp ifindex clear

特定のインターフェイスに対して実行された設定済みの snmp ifindex コマンドをクリアします。

snmp ifindex persist

再起動後も保持される Interfaces MIB(IF-MIB)内の ifIndex 値(ifIndex 永続性)を特定のインターフェイス上だけでイネーブルにします。

 

snmp-server source-interface

SNMP トラップがインフォームやトラップの送信元とするインターフェイスを指定するには、 snmp-server source-interface コマンドを使用します。送信元指定を削除するには、このコマンドの no 形式を使用します。

snmp-server source-interface { traps | informs } interface

no snmp-server source-interface { traps | informs } [ interface ]

 
シンタックスの説明

traps

SNMP トラップを指定します。

informs

SNMP インフォームを指定します。

interface

送信元インターフェイスのインターフェイス タイプ、およびモジュールとポート番号を指定します。

 
コマンドのデフォルト

インターフェイスは指定されません。

 
コマンド モード

グローバル コンフィギュレーション(config)

 
コマンドの履歴

リリース
変更内容

12.2(18)ZY

このコマンドのサポートが追加されました。

 
使用上のガイドライン

送信元インターフェイスには IP アドレスが設定されている必要があります。

interface-type / module / port のフォーマットで、 interface 引数を入力します。

Cisco SNMP サーバから送信された SNMP トラップまたはインフォームには、その時点で送出されたインターフェイスの通知 IP アドレスが設定されています。特定のインターフェイスからの通知をモニタするには、このコマンドを使用します。

次に、インターフェイス gigabitethernet5/2 をすべてのインフォームの送信元として指定する例を示します。

Router(config)# snmp-server source-interface informs gigabitethernet5/2
Router(config)#
 

次に、インターフェイス gigabitethernet5/3 をすべてのトラップの送信元として指定する例を示します。

Router(config)# snmp-server source-interface traps gigabitethernet5/3
Router(config)#
 

次に、特定のインターフェイスの全トラップの送信元指定を削除する例を示します。

Router(config)# no snmp-server source-interface traps gigabitethernet5/3
Router(config)#

 
関連コマンド

コマンド
説明

snmp-server trap-source interface

SNMP トラップの送信元とするインターフェイスを指定します。このコマンドが、 snmp-server source-interface コマンドに置き換えられました。

snmp-server enable traps

ルータからの SNMP トラップおよびインフォームの送信をイネーブルにします。

snmp-server host

SNMP 通知動作の受信者を指定します。

snmp-server trap authentication unknown-context

不明なコンテキスト エラー発生時の許可失敗トラップをイネーブルにするには、 snmp-server trap authentication unknown-context コマンドを使用します。許可失敗トラップをディセーブルにするには、このコマンドの no 形式を使用します。

snmp-server trap authentication unknown-context

no snmp-server trap authentication unknown-context

 
シンタックスの説明

このコマンドには、キーワードまたは引数はありません。

 
コマンドのデフォルト

authFail トラップは生成されません。

 
コマンド モード

グローバル コンフィギュレーション(config)

 
コマンドの履歴

リリース
変更内容

12.2(18)ZY

このコマンドのサポートが追加されました。

次に、不明なコンテキスト エラー発生時の許可失敗トラップをイネーブルにする例を示します。

Router(config)# snmp-server trap authentication unknown-context
Router(config)#
 

次に、不明なコンテキスト エラー発生時の許可失敗トラップをディセーブルにする例を示します。

Router(config)# no snmp-server trap authentication unknown-context
Router(config)#

 

snmp-server trap link switchover

スイッチ フェールオーバー時に、リンクアップ トラップによって引き継がれるリンクダウン トラップの送信をスイッチのすべてのインターフェイスでイネーブルにするには、 snmp-server trap link switchover コマンドを使用します。スイッチ フェールオーバー時のリンクダウンをディセーブルにするには、このコマンドの no 形式を使用します。

snmp-server trap link switchover

no snmp-server trap link switchover

 
シンタックスの説明

このコマンドには、キーワードまたは引数はありません。

 
コマンドのデフォルト

イネーブル

 
コマンド モード

グローバル コンフィギュレーション(config)

 
コマンドの履歴

リリース
変更内容

12.2(18)ZY

このコマンドのサポートが追加されました。

 
使用上のガイドライン

デフォルトでは、スイッチオーバー時にリンク トラップが生成されません。

次に、デフォルト設定に戻す例を示します。

Router(config)# snmp-server trap link switchover
Router(config)#
 

次に、スイッチ フェールオーバー時に、リンクアップ トラップによって引き継がれるリンクダウンをスイッチのすべてのインターフェイスでディセーブルにする例を示します。

Router(config)# no snmp-server trap link switchover
Router(config)#
 

spanning-tree backbonefast

すべてのイーサネット VLAN 上で BackboneFast 機能をイネーブルにするには、 s panning-tree backbonefast コマンドを使用します。BackboneFast をディセーブルにするには、このコマンドの no 形式を使用します。

spanning-tree backbonefast

no spanning-tree backbonefast

 
シンタックスの説明

このコマンドには、キーワードまたは引数はありません。

 
コマンドのデフォルト

BackboneFast はディセーブルです。

 
コマンド モード

グローバル コンフィギュレーション(config)

 
コマンドの履歴

リリース
変更内容

12.2(18)ZY

このコマンドのサポートが追加されました。

 
使用上のガイドライン

間接リンク障害の検出を可能にして、スパニングツリーをより短時間で再設定できるようにするには、すべての Catalyst 6500 シリーズ スイッチ上で BackboneFast をイネーブルにします。

次に、すべてのイーサネット VLAN で BackboneFast をイネーブルにする例を示します。

Router(config)# spanning-tree backbonefast
Router(config)#

 
関連コマンド

コマンド
説明

show spanning-tree

スパニングツリー ステートに関する情報を表示します。

 

spanning-tree bpdufilter

インターフェイス上で BPDU フィルタリングをイネーブルにするには、 spanning-tree bpdufilter コマンドを使用します。デフォルト設定に戻すには、このコマンドの no 形式を使用します。

spanning-tree bpdufilter { enable | disable }

no spanning-tree bpdufilter

 
シンタックスの説明

enable

現在のインターフェイス上で BPDU フィルタリングをイネーブルにします。

disable

現在のインターフェイス上で BPDU フィルタリングをディセーブルにします。

 
コマンドのデフォルト

spanning-tree portfast bpdufilter default コマンドの入力時に設定された設定です。

 
コマンド モード

インターフェイス コンフィギュレーション(config-if)

 
コマンドの履歴

リリース
変更内容

12.2(18)ZY

このコマンドのサポートが追加されました。

 
使用上のガイドライン


注意 spanning-tree bpdufilter enable コマンドを入力する場合は、慎重に行ってください。インターフェイス上で BPDU フィルタリングをイネーブルにすることは、このインターフェイスのスパニングツリーをディセーブルにすることと類似しています。このコマンドを正しく使用しない場合、ブリッジング ループが発生する可能性があります。

spanning-tree bpdufilter enable コマンドを入力して BPDU フィルタリングをイネーブルにすると、PortFast 設定が無効になります。

すべてのサービス プロバイダー エッジ スイッチにレイヤ 2 プロトコル トンネリングを設定する場合は、 spanning-tree bpdufilter enable コマンドを入力して、802.1Q トンネル ポート上でスパニングツリー BPDU フィルタリングをイネーブルにする必要があります。

BPDU フィルタリングにより、ポートは BPDU を送受信できなくなります。その設定は、トランキングであるかどうかに関係なく、インターフェイス全体に適用されます。このコマンドには、3 つの状態があります。

spanning-tree bpdufilter enable インターフェイス上で BPDU フィルタリングが無条件にイネーブルになります。

spanning-tree bpdufilter disable インターフェイス上で BPDU フィルタリングが無条件にディセーブルになります。

no spanning-tree bpdufilter インターフェイスが PortFast 動作ステートにある場合、および spanning-tree portfast bpdufilter default コマンドを設定する場合、インターフェイス上で BPDU フィルタリングがイネーブルになります。

PortFast 用に設定済みのすべてのポートで BPDU フィルタリングをイネーブルにするには、 spanning-tree portfast bpdufilter default コマンドを使用します。

次に、現在のインターフェイス上で BPDU フィルタリングをイネーブルにする例を示します。

Router(config-if)# spanning-tree bpdufilter enable
Router(config-if)#

 
関連コマンド

コマンド
説明

show spanning-tree

スパニングツリー ステートに関する情報を表示します。

spanning-tree portfast bpdufilter default

すべての PortFast ポートで、BPDU フィルタリングをデフォルトでイネーブルにします。

 

spanning-tree bpduguard

インターフェイス上で BPDU ガードをイネーブルにするには、 spanning-tree bpduguard コマンドを使用します。デフォルト設定に戻すには、このコマンドの no 形式を使用します。

spanning-tree bpduguard { enable | disable }

no spanning-tree bpduguard

 
シンタックスの説明

enable

現在のインターフェイス上で BPDU ガードをイネーブルにします。

disable

現在のインターフェイス上で BPDU ガードをディセーブルにします。

 
コマンドのデフォルト

spanning-tree portfast bpduguard default コマンドの入力時に設定された設定です。

 
コマンドのデフォルト

インターフェイス コンフィギュレーション(config-if)

 
コマンドの履歴

リリース
変更内容

12.2(18)ZY

このコマンドのサポートが追加されました。

 
使用上のガイドライン

BPDU ガードを使用すると、ポートは BPDU を受信できなくなります。通常、この機能はサービス プロバイダー環境で使用されます。ネットワーク管理者はこの機能を使用して、アクセス ポートがスパニングツリーに参加しないようにできます。この機能を使用してもポートが BPDU を受信する場合は、その対策として、ポートは errdisable ステートになります。このコマンドには、3 つの状態があります。

spanning-tree bpduguard enable インターフェイス上で BPDU ガードが無条件にイネーブルになります。

spanning-tree bpduguard disable インターフェイス上で BPDU ガードが無条件にディセーブルになります。

no spanning-tree bpduguard インターフェイスが PortFast 動作ステートにある場合、および spanning-tree portfast bpduguard default コマンドが設定されている場合、インターフェイス上で BPDU ガードがイネーブルになります。

次に、現在のインターフェイス上で BPDU ガードをイネーブルにする例を示します。

Router(config-if)# spanning-tree bpduguard enable
Router(config-if)#

 
関連コマンド

コマンド
説明

show spanning-tree

スパニングツリー ステートに関する情報を表示します。

spanning-tree portfast bpduguard default

すべての PortFast ポートで、BPDU ガードをデフォルトでイネーブルにします。

spanning-tree cost

STP 計算に使用するインターフェイスのパス コストを設定するには、 spanning-tree cost コマンドを使用します。デフォルト設定に戻すには、このコマンドの no 形式を使用します。

spanning-tree cost cost

no spanning-tree cost

 
シンタックスの説明

cost

パス コスト。有効値は 1 ~ 200,000,000 です。

 
コマンドのデフォルト

デフォルト パス コストは、インターフェイスの帯域幅設定から計算されます。デフォルト パス コストは次のとおりです。

イーサネット:100

16 Mb トークンリング:62

FDDI:10

FastEthernet:10

ATM 155:6

GigabitEthernet:1

10 ギガビット イーサネット:2

HSSI:647

 
コマンド モード

インターフェイス コンフィギュレーション(config-if)

 
コマンドの履歴

リリース
変更内容

12.2(18)ZY

このコマンドのサポートが追加されました。

 
使用上のガイドライン

cost を設定する場合は、値が大きいほどコストが高くなります。指定されたプロトコル タイプに関係なく、この値が適用されます。

次に、インターフェイスにアクセスし、このインターフェイスに対応付けられたスパニングツリー VLAN にパス コスト値 250 を設定する例を示します。

Router(config)# interface ethernet 2/0
Router(config-if)# spanning-tree cost 250
Router(config-if)#

 
関連コマンド

コマンド
説明

show spanning-tree

スパニングツリー ステートに関する情報を表示します。

spanning-tree etherchannel guard misconfig

チャネルの設定ミスによるループが検出された場合に、エラー メッセージを表示するには、 spanning-tree etherchannel guard misconfig コマンドを使用します。エラー メッセージをディセーブルにするには、このコマンドの no 形式を使用します。

spanning-tree etherchannel guard misconfig

no spanning-tree etherchannel guard misconfig

 
シンタックスの説明

このコマンドには、キーワードまたは引数はありません。

 
コマンドのデフォルト

イネーブル

 
コマンド モード

グローバル コンフィギュレーション(config)

 
コマンドの履歴

リリース
変更内容

12.2(18)ZY

このコマンドのサポートが追加されました。

 
使用上のガイドライン

EtherChannel は PAgP または LACP を使用し、インターフェイスの EtherChannel モードが channel-group group-number mode on コマンドを使用してイネーブル化されている場合は機能しません。

EtherChannel ガードの設定ミスが検出されると、次のエラー メッセージが表示されます。

msgdef(CHNL_MISCFG, SPANTREE, LOG_CRIT, 0, "Detected loop due to etherchannel misconfiguration of %s %s")
 

設定ミスに関連するローカル ポートを判別するには、 show interfaces status err-disabled コマンドを入力します。リモート装置の EtherChannel 設定を調べるには、リモート装置上で show etherchannel summary コマンドを入力します。

設定を訂正したら、対応付けられたポート チャネル インターフェイス上で shutdown および no shutdown コマンドを入力します。

次に、EtherChannel ガードの設定ミス機能をイネーブルにする例を示します。

Router(config)# spanning-tree etherchannel guard misconfig

Router(config)#

 
関連コマンド

コマンド
説明

show etherchannel summary

チャネルの EtherChannel 情報を表示します。

show interfaces status err-disabled

インターフェイス ステータスを表示したり、LAN ポートで errdisable ステートにあるインターフェイスだけのリストを表示したりします。

shutdown

インターフェイスをディセーブルにします。

 

spanning-tree extend system-id

1024 個の MAC アドレスをサポートするシャーシ上で拡張システム ID 機能をイネーブルにするには、 spanning-tree extend system-id コマンドを使用します。拡張システム ID をディセーブルにするには、このコマンドの no 形式を使用します。

spanning-tree extend system-id

no spanning-tree extend system-id

 
シンタックスの説明

このコマンドには、キーワードまたは引数はありません。

 
コマンドのデフォルト

1024 個の MAC アドレスをサポートしないシステム上でイネーブルです。

 
コマンドのデフォルト

グローバル コンフィギュレーション(config)

 
コマンドの履歴

リリース
変更内容

12.2(18)ZY

このコマンドのサポートが追加されました。

 
使用上のガイドライン

Catalyst 6500 シリーズ スイッチは、64 または最大 1024 個の MAC アドレスをサポートできます。64 個の MAC アドレスを持つ Catalyst 6500 シリーズ スイッチの場合、STP は拡張システム ID と MAC アドレスを使用して、VLAN ごとに一意のブリッジ ID を作成します。

64 個の MAC アドレスをサポートする Catalyst 6500 シリーズ スイッチでは、拡張システム ID をディセーブルにできません。

拡張システム ID をイネーブルまたはディセーブルにすると、すべてのアクティブな STP インスタンスのブリッジ ID が更新されるため、これによってスパニングツリー トポロジーが変更される場合があります。

次に、拡張システム ID をイネーブルにする例を示します。

Router(config)# spanning-tree extend system-id
Router(config)#

 
関連コマンド

コマンド
説明

show spanning-tree

スパニングツリー ステートに関する情報を表示します。

 

spanning-tree guard

ガード モードをイネーブルまたはディセーブルにするには、 spanning-tree guard コマンドを使用します。デフォルト設定に戻すには、このコマンドの no 形式を使用します。

spanning-tree guard { loop | root | none }

no spanning-tree guard

 
シンタックスの説明

loop

インターフェイスでループ ガード モードをイネーブルにします。

root

インターフェイスでルートガード モードをイネーブルにします。

none

ガード モードをなしに設定します。

 
コマンドのデフォルト

ガード モードはディセーブルです。

 
コマンド モード

インターフェイス コンフィギュレーション(config-if)

 
コマンドの履歴

リリース
変更内容

12.2(18)ZY

このコマンドのサポートが追加されました。

次に、ルート ガードをイネーブルにする例を示します。

Router(config-if)# spanning-tree guard root
Router(config-if)#

 
関連コマンド

コマンド
説明

show spanning-tree

スパニングツリー ステートに関する情報を表示します。

spanning-tree loopguard default

所定のブリッジのすべてのポート上でデフォルトとしてループ ガード をイネーブルにします

 

spanning-tree link-type

リンク タイプをポートに設定するには、 spanning-tree link-type コマンドを使用します。デフォルト設定に戻すには、このコマンドの no 形式を使用します。

spanning-tree link-type { point-to-point | shared }

no spanning-tree link-type

 
シンタックスの説明

point-to-point

インターフェイスがポイントツーポイント リンクとなるように指定します。

shared

インターフェイスが共有メディアとなるように指定します。

 
コマンドのデフォルト

リンク タイプは、明示的に設定しなければ、デュプレックス設定から自動的に生成されます。

 
コマンド モード

インターフェイス コンフィギュレーション(config-if)

 
コマンドの履歴

リリース
変更内容

12.2(18)ZY

このコマンドのサポートが追加されました。

 
使用上のガイドライン

RSTP+ 高速トランジションが機能するのは、2 つのブリッジ間のポイントツーポイント リンク上だけです。

デフォルトでは、ポートのリンク タイプはデュプレックス モードから取得されます。つまり、全二重ポートはポイントツーポイント リンクであると見なされ、半二重コンフィギュレーションは共有リンクであると見なされます。

ポートを共有リンクに指定した場合は、デュプレックス設定に関係なく、RSTP+ 高速トランジションを使用できません。

次に、ポートを共有リンクとして設定する例を示します。

Router(config-if)# spanning-tree link-type shared
Router(config-if)#

 
関連コマンド

コマンド
説明

show spanning-tree interface

スパニングツリー ステートに関する情報を表示します。

 

spanning-tree loopguard default

指定されたブリッジのすべてのポート上でループ ガードをデフォルトでイネーブルにするには、 spanning-tree loopguard default コマンドを使用します。 ループ ガードをディセーブルにするには、このコマンドの no 形式を使用します。

spanning-tree loopguard default

no spanning-tree loopguard default

 
シンタックスの説明

このコマンドには、キーワードまたは引数はありません。

 
コマンドのデフォルト

ループ ガードはディセーブルです。

 
コマンド モード

グローバル コンフィギュレーション(config)

 
コマンドの履歴

リリース
変更内容

12.2(18)ZY

このコマンドのサポートが追加されました。

 
使用上のガイドライン

ループ ガードを使用すると、ブリッジ ネットワークのセキュリティが向上します。また、単一方向リンクの原因となる障害によって代替ポートまたはルート ポートが指定ポートとして使用されることがなくなります。

ループ ガードが動作するのは、スパニングツリーがポイントツーポイントと見なすポート上だけです。

ループガード ポートを個別に設定すると、このコマンドが上書きされます。

次に、ループ ガードをイネーブルにする例を示します。

Router(config)# spanning-tree loopguard default
Router(config)#

 
関連コマンド

コマンド
説明

show spanning-tree

スパニングツリー ステートに関する情報を表示します。

spanning-tree guard

ガード モードをイネーブルまたはディセーブルにします。

 

spanning-tree mode

PVST+、高速 PVST+、MST モードを切り替えるには、 spanning-tree mode コマンドを使用します。デフォルト設定に戻すには、このコマンドの no 形式を使用します。

spanning-tree mode [ pvst | mst | rapid-pvst ]

no spanning-tree mode

 
シンタックスの説明

pvst

(任意)PVST+ モード

mst

(任意)MST モード

rapid-pvst

(任意)高速 PVST+ モード

 
コマンドのデフォルト

pvst

 
コマンドのデフォルト

グローバル コンフィギュレーション(config)

 
コマンドの履歴

リリース
変更内容

12.2(18)ZY

このコマンドのサポートが追加されました。

 
使用上のガイドライン


注意 spanning-tree mode コマンドを使用して PVST+、高速 PVST+、および MST モードを切り替える場合は、慎重に行ってください。このコマンドを入力すると、以前のモードのスパニングツリー インスタンスはすべて停止し、新しいモードで再開されます。このコマンドを使用すると、ユーザ トラフィックが中断することがあります。

次に、MST モードに切り替える例を示します。

Router(config)# spanning-tree mode mst
Router(config)#
 

次に、デフォルト モード(PVST+)に戻す例を示します。

Router(config)# no spanning-tree mode
Router(config)#

 
関連コマンド

コマンド
説明

show spanning-tree mst

MST プロトコルに関する情報を表示します。

 

spanning-tree mst

任意の MST インスタンス(インスタンス ID 0 の CIST を含む)のパス コストおよびポート プライオリティ パラメータを設定するには、 spanning-tree mst コマンドを使用します。デフォルト設定に戻すには、このコマンドの no 形式を使用します。

spanning-tree mst instance-id { cost cost } | { port-priority prio }

no spanning-tree mst instance-id { cost | port-priority }

 
シンタックスの説明

instance-id

インスタンス ID 番号を指定します。 有効値は 0 ~ 15 です。

cost cost

(任意)インスタンスのパス コストを指定します。有効値は 1 ~ 200,000,000 です。

port-priority prio

(任意)インスタンスのポート プライオリティを指定します。有効値は 0 ~ 240 で、16 ずつ増分します。

 
コマンドのデフォルト

デフォルト設定は次のとおりです。

cost は、ポート速度に応じて変わります。インターフェイス速度が速いほどコストは小さくなります。MST は常に long のパス コストを使用します。

prio 128 です。

 
コマンドのデフォルト

インターフェイス コンフィギュレーション(config-if)

 
コマンドの履歴

リリース
変更内容

12.2(18)ZY

このコマンドのサポートが追加されました。

 
使用上のガイドライン

cost cost の値が大きいほど、コストは高くなります。 cost 値を入力する場合は、エントリにカンマを含めないでください。たとえば、 1,000 ではなく、 1000 と入力します。

port-priority prio 値が高いほど、プライオリティは小さくなります。

次に、インターフェイスのパス コストを設定する例を示します。

Router(config-if)# spanning-tree mst 0 cost 17031970
Router(config-if)#
 

次に、インターフェイスのプライオリティを設定する例を示します。

Router(config-if)# spanning-tree mst 0 port-priority 64
Router(config-if)#

 
関連コマンド

コマンド
説明

show spanning-tree mst

MST プロトコルに関する情報を表示します。

spanning-tree port-priority

2 つのブリッジがルート ブリッジとなるために競合している場合に、インターフェイスにプライオリティを設定します。

spanning-tree mst configuration

MST コンフィギュレーション サブモードを開始するには、 spanning-tree mst configuration コマンドを使用します。デフォルト設定に戻すには、このコマンドの no 形式を使用します。

spanning-tree mst configuration

no spanning-tree mst configuration

 
シンタックスの説明

このコマンドには、キーワードまたは引数はありません。

 
コマンドのデフォルト

デフォルトでは、MST の設定値がすべてのパラメータのデフォルト値になります。

VLAN はどの MST インスタンスにもマッピングされません(すべての VLAN は CIST インスタンスにマッピングされます)。

リージョン名は空のストリングです。

リビジョン番号は 0 です。

 
コマンド モード

グローバル コンフィギュレーション(config)

 
コマンドの履歴

リリース
変更内容

12.2(18)ZY

このコマンドのサポートが追加されました。

 
使用上のガイドライン

MST の設定には、3 つの主要パラメータが使用されます。

インスタンス VLAN マッピング: instance コマンドを参照してください。

リージョン名: name (MST configuration submode) コマンドを参照してください。

コンフィギュレーション リビジョン番号: revision コマンドを参照してください。

abort および exit コマンドを使用すると、MST コンフィギュレーション サブモードを終了できます。2 つのコマンドの違いは、変更内容を保存するかどうかです。

exit コマンドは、MST コンフィギュレーション サブモードが終了する前に、すべての変更を実行します。セカンダリ VLAN が、対応付けられたプライマリ VLAN と同じインスタンスにマッピングされていない場合に、MST コンフィギュレーション サブモードを終了すると、警告メッセージが表示され、対応付けられたプライマリ VLAN と同じインスタンスにマッピングされていないセカンダリ VLAN が一覧表示されます。警告メッセージは次のとおりです。

These secondary vlans are not mapped to the same instance as their primary:
-> 3
 

abort コマンドは、変更を実行しないで、MST コンフィギュレーション サブモードを終了します。

MST コンフィギュレーション サブモード パラメータを変更すると、接続損失が発生する可能性があります。サービスの中断を減らすには、MST コンフィギュレーション サブモードを開始する場合、現在の MST コンフィギュレーションのコピーを変更します。コンフィギュレーションの編集が終了したら、exit キーワードを使用して、すべての変更を一度に適用するか、または abort キーワードを使用して、コンフィギュレーションへの変更を実行しないで終了できます。

2 名のユーザがまったく同時に新しいコンフィギュレーションを実行することは通常ありませんが、その場合は次の警告メッセージが表示されます。

% MST CFG:Configuration change lost because of concurrent access

次に、MST コンフィギュレーション サブモードを開始する例を示します。

Router(config)# spanning-tree mst configuration
Router(config-mst)#
 

次に、MST コンフィギュレーションをデフォルト設定に戻す例を示します。

Router(config)# no spanning-tree mst configuration
Router(config)#

 
関連コマンド

コマンド
説明

instance

1 つまたは一連の VLAN を MST インスタンスにマッピングします。

name (MST configuration submode)

MST リージョン名を設定します。

revision

MST コンフィギュレーションのリビジョン番号を設定します。

show

MST の設定を確認します。

show spanning-tree mst

MST プロトコルに関する情報を表示します。

 

spanning-tree mst forward-time

転送遅延タイマーを Catalyst 6500 シリーズ スイッチ上のすべてのインスタンスに設定するには、 spanning-tree mst forward-time コマンドを使用します。デフォルト設定に戻すには、このコマンドの no 形式を使用します。

spanning-tree mst forward-time seconds

no spanning-tree mst forward-time

 
シンタックスの説明

seconds

Catalyst 6500 シリーズ スイッチのすべてのインスタンスの転送遅延タイマーの設定秒数。 有効値は、4 ~ 30 秒です。

 
コマンドのデフォルト

seconds 15 です。

 
コマンド モード

グローバル コンフィギュレーション(config)

 
コマンドの履歴

リリース
変更内容

12.2(18)ZY

このコマンドのサポートが追加されました。

次に、転送遅延タイマーを設定する例を示します。

Router(config)# spanning-tree mst forward-time 20

Router(config)#

 
関連コマンド

コマンド
説明

show spanning-tree mst

MST プロトコルに関する情報を表示します。

 

spanning-tree mst hello-time

hello タイム遅延タイマーを Catalyst 6500 シリーズ スイッチ上のすべてのインスタンスに設定するには、 spanning-tree mst hello-time コマンドを使用します。デフォルト設定に戻すには、このコマンドの no 形式を使用します。

spanning-tree mst hello-time seconds

no spanning-tree mst hello-time

 
シンタックスの説明

seconds

Catalyst 6500 シリーズ スイッチのすべてのインスタンスの hello タイム遅延タイマーの設定秒数。有効値は、1 ~ 10 秒です。

 
コマンドのデフォルト

2

 
コマンドのデフォルト

グローバル コンフィギュレーション(config)

 
コマンドの履歴

リリース
変更内容

12.2(18)ZY

このコマンドのサポートが追加されました。

 
使用上のガイドライン

hello-time 値を指定しない場合、この値はネットワークの直径から計算されます。

次に、hello タイム遅延タイマーを設定する例を示します。

Router(config)# spanning-tree mst hello-time 3

Router(config)#

 
関連コマンド

コマンド
説明

show spanning-tree mst

MST プロトコルに関する情報を表示します。

 

spanning-tree mst max-age

有効期限タイマーを Catalyst 6500 シリーズ スイッチ上のすべてのインスタンスに設定するには、 spanning-tree mst max-age コマンドを使用します。デフォルト設定に戻すには、このコマンドの no 形式を使用します。

spanning-tree mst max-age seconds

no spanning-tree mst max-age

 
シンタックスの説明

seconds

Catalyst 6500 シリーズ スイッチのすべてのインスタンスの有効期限タイマーの設定秒数。有効値は、6 ~ 40 秒です。

 
コマンドのデフォルト

20

 
コマンド モード

グローバル コンフィギュレーション(config)

 
コマンドの履歴

リリース
変更内容

12.2(18)ZY

このコマンドのサポートが追加されました。

次に、有効期限タイマーを設定する例を示します。

Router(config)# spanning-tree mst max-age 40

Router(config)#

 
関連コマンド

コマンド
説明

show spanning-tree mst

MST プロトコルに関する情報を表示します。

 

spanning-tree mst max-hops

BPDU が廃棄されるまでのリージョンの最大ホップ数を指定するには、 spanning-tree mst max-hops コマンドを使用します。デフォルト設定に戻すには、このコマンドの no 形式を使用します。

spanning-tree mst max-hops hopnumber

no spanning-tree mst max-hops

 
シンタックスの説明

hopnumber

BPDU が廃棄されるまでのリージョンの最大ホップ数を指定します。 有効値は、1 ~ 255 ホップです。

 
コマンドのデフォルト

20 ホップ

 
コマンドのデフォルト

グローバル コンフィギュレーション(config)

 
コマンドの履歴

リリース
変更内容

12.2(18)ZY

このコマンドのサポートが追加されました。

次に、最大ホップ数を設定する例を示します。

Router(config)# spanning-tree mst max-hops 25

Router(config)#

 
関連コマンド

コマンド
説明

show spanning-tree mst

MST プロトコルに関する情報を表示します。

 

spanning-tree mst pre-standard

先行標準の BPDU だけを送信するようにポートを設定するには、 spanning-tree mst pre-standard コマンドを使用します。デフォルト設定に戻すには、このコマンドの no 形式を使用します。

spanning-tree mst pre-standard

no spanning-tree mst pre-standard

 
シンタックスの説明

このコマンドには、キーワードまたは引数はありません。

 
コマンドのデフォルト

デフォルトでは、先行標準ネイバを自動的に検出します。

 
コマンド モード

インターフェイス コンフィギュレーション(config-if)

 
コマンドの履歴

リリース
変更内容

12.2(18)ZY

このコマンドのサポートが追加されました。

 
使用上のガイドライン

デフォルト設定であっても、ポートは先行標準および標準 BPDU の両方を受信できます。

先行標準 BPDU は、IEEE 標準が完成する前に作成された Cisco IOS MST 実装に基づいています。標準 BPDU は、最終 IEEE 標準に基づいています。

先行標準の BPDU だけを送信するようにポートを設定する場合、先行標準フラグが show spanning-tree コマンドに表示されます。先行標準フラグの種類は次のとおりです。

Pre-STD または prestandard(長形式):ポートが先行標準 BPDU を送信するように設定されている場合、およびこのインターフェイス上で先行標準ネイバ ブリッジが検出された場合に、このフラグが表示されます。

Pre-STD-Cf または prestandard (config)(長形式):先行標準 BPDU を送信するようにポートを設定し、そのポートで先行標準 BPDU が受信されない場合、自動検出メカニズムが失敗した場合、または先行標準ネイバが存在しない場合に設定が間違っている場合、このフラグが表示されます。

Pre-STD-Rx または prestandard (rcvd)(長形式):先行標準 BPDU がポートで受信され、先行標準 BPDU を送信するようにポートを設定していない場合に、このフラグが表示されます。ポートは先行標準 BPDU を送信しますが、先行標準ネイバとのやりとりを自動検出メカニズムだけに依存しないようにポートの設定を変更することを推奨します。

MST の設定が先行標準に適合しない場合(インスタンス ID が 15 より大きい場合)、ポート上の STP の設定に関係なく、標準 MST BPDU だけが送信されます。

次に、先行標準 BPDU だけを送信するようにポートを設定する例を示します。

Router(config-if)# spanning-tree mst pre-standard
Router(config-if)#

 
関連コマンド

コマンド
説明

show spanning-tree mst

MST プロトコルに関する情報を表示します。

 

spanning-tree mst root

インスタンスのプライマリ ルートとセカンダリ ルートを指定したり、ブリッジ プライオリティ、およびタイマー値を設定したりするには、 spanning-tree mst root コマンドを使用します。デフォルト設定に戻すには、このコマンドの no 形式を使用します。

spanning-tree mst instance-id root {{ primary | secondary } | { priority prio }} [ diameter dia [ hello-time hello-time ]]

no spanning-tree mst root

 
シンタックスの説明

instance-id

インスタンス ID 番号を指定します。 有効値は 1 ~ 15 です。

primary

スパニングツリー インスタンスのブリッジ ルートを作成するために必要なプライオリティ(小さな値)を指定します。

secondary

プライマリ ルートに障害が発生した場合に、セカンダリ ルートとして機能させるスイッチを指定します。

priority prio

ブリッジ プライオリティを指定します。有効値および詳細については、「使用上のガイドライン」を参照してください。

diameter dia

(任意)ネットワーク直径に基づくブリッジのタイマー値を指定します。有効値は、 1 ~ 7 です。

hello-time hello-time

(任意)ルート スイッチがコンフィギュレーション メッセージを生成する間隔を指定します。

 
コマンドのデフォルト

デフォルト設定は次のとおりです。

spanning-tree mst root にはデフォルト設定がありません。

prio 32768 です。

 
コマンド モード

グローバル コンフィギュレーション(config)

 
コマンドの履歴

リリース
変更内容

12.2(18)ZY

このコマンドのサポートが追加されました。

 
使用上のガイドライン

ブリッジ プライオリティは、4096 ずつ増分して設定できます。プライオリティを設定する場合、有効値は 0 4096 8192 12288 16384 20480 24576 28672 32768 36864 40960 45056 49152 53248 57344 、および 61440 です。

スイッチをルートにする場合は、 prio 0 に設定します。

instance-id は、単一インスタンスまたはインスタンス範囲(0-3,5,7-9 など)として入力できます。

spanning-tree root secondary のブリッジ プライオリティ値は 16384 です。

diameter dia および hello-time hello-time キーワードおよび引数は、インスタンス 0 だけに使用できます。

hello-time 引数を指定しない場合、この引数はネットワークの直径から計算されます。

次に、ブリッジ プライオリティを設定する例を示します。

Router(config)# spanning-tree mst 0 root priority 4096
Router(config)#
 

次に、ブリッジのプライオリティおよびタイマー値を設定する例を示します。

Router(config)# spanning-tree mst 0 root primary diameter 7 hello-time 2
Router(config)# spanning-tree mst 5 root primary
Router(config)#

 
関連コマンド

コマンド
説明

show spanning-tree mst

MST プロトコルに関する情報を表示します。

 

spanning-tree pathcost method

デフォルトのパス コスト計算方式を設定するには、spanning-tree pathcost method コマンドを使用します。デフォルト設定に戻すには、このコマンドの no 形式を使用します。

s panning-tree pathcost method { long | short }

no s panning-tree pathcost method

 
シンタックスの説明

long

デフォルト ポート パス コスト用の 32 ビット ベース値を指定します。

short

デフォルト ポート パス コスト用の 16 ビット ベース値を指定します。

 
コマンドのデフォルト

short

 
コマンドのデフォルト

グローバル コンフィギュレーション(config)

 
コマンドの履歴

リリース
変更内容

12.2(18)ZY

このコマンドのサポートが追加されました。

 
使用上のガイドライン

このコマンドは、Catalyst 6500 シリーズ スイッチのすべてのスパニングツリー インスタンスに適用されます。

long パス コスト計算方式では、パス コスト計算に 32 ビットをすべて利用して、1 ~ 200,000,000 の値を生成します。

short パス コスト計算方式(16 ビット)では、1 ~ 65,535 の値が生成されます。

次に、デフォルトのパス コスト計算方式を long に設定する例を示します。

Router(config#) spanning-tree pathcost method long
Router(config#)
 

次に、デフォルトのパス コスト計算方式を short に設定する例を示します。

Router(config#) spanning-tree pathcost method short
Router(config#)

 
関連コマンド

コマンド
説明

show spanning-tree

スパニングツリー ステートに関する情報を表示します。

 

spanning-tree portfast (interface configuration mode)

リンクがアップした時点で、インターフェイスがタイマーの経過を待たずにただちにフォワーディング ステートに移行した場合に、PortFast モードをイネーブルにするには、 spanning-tree portfast コマンドを使用します。デフォルト設定に戻すには、このコマンドの no 形式を使用します。

spanning-tree portfast

spanning-tree portfast { disable | trunk }

no spanning-tree portfast

 
シンタックスの説明

disable

インターフェイスの PortFast をディセーブルにします。

trunk

トランク モードの場合でも、インターフェイスの PortFast をイネーブルにします。

 
コマンドのデフォルト

spanning-tree portfast default コマンドによって設定される設定値

 
コマンド モード

インターフェイス コンフィギュレーション(config-if)

 
コマンドの履歴

リリース
変更内容

12.2(18)ZY

このコマンドのサポートが追加されました。

 
使用上のガイドライン

このコマンドは、エンド ステーションに接続されているインターフェイスだけに使用してください。偶発的なトポロジー ループが原因でデータ パケット ループが発生し、Catalyst 6500 シリーズ スイッチおよびネットワークの動作が妨げられることがあります。

リンクがアップすると、PortFast モードがイネーブルに設定されたインターフェイスは標準の転送遅延時間の経過を待たずに、ただちにスパニングツリー フォワーディング ステートに移行します。

no spanning-tree portfast コマンドは、慎重に使用してください。このコマンドは、 spanning-tree portfast default コマンドがイネーブルの場合は、PortFast をディセーブルにしません。

このコマンドには、4 つの状態があります。

spanning-tree portfast :所定のポートで、PortFast を無条件にイネーブルにします。

spanning-tree portfast disable :所定のポートで、PortFast を明示的にディセーブルにします。このコンフィギュレーション行はデフォルトでないため、実行コンフィギュレーションに含まれます。

spanning-tree portfast trunk :トランク ポートに PortFast を設定できます。


spanning-tree portfast trunk コマンドを入力すると、アクセス モードの場合でも、ポートは PortFast に対応するように設定されます。


no spanning-tree portfast spanning-tree portfast default コマンドをグローバル コンフィギュレーション モードで定義する場合、およびポートがトランク ポートでない場合に、PortFast を暗黙的にイネーブルにします。PortFast をグローバルに設定しない場合、 no spanning-tree portfast コマンドは spanning-tree portfast disable コマンドと同様に機能します。

次に、PortFast モードをイネーブルにする例を示します。

Router(config-if)# spanning-tree portfast
Router(config-if)#

 
関連コマンド

コマンド
説明

show spanning-tree

スパニングツリー ステートに関する情報を表示します。

spanning-tree portfast default

すべてのアクセス ポートで、PortFast をデフォルトでイネーブルにします。

 

spanning-tree portfast bpdufilter default

すべての PortFast ポートで、BPDU フィルタリングをデフォルトでイネーブルにするには、 spanning-tree portfast bpdufilter default コマンドを使用します。デフォルト設定に戻すには、このコマンドの no 形式を使用します。

spanning-tree portfast bpdufilter default

no spanning-tree portfast bpdufilter default

 
シンタックスの説明

このコマンドには、キーワードまたは引数はありません。

 
コマンドのデフォルト

ディセーブル

 
コマンド モード

グローバル コンフィギュレーション(config)

 
コマンドの履歴

リリース
変更内容

12.2(18)ZY

このコマンドのサポートが追加されました。

 
使用上のガイドライン

spanning-tree portfast bpdufilter コマンドは、PortFast ポートで BPDU フィルタリングをグローバルにイネーブルにします。BPDU フィルタリングにより、ポートはすべての BPDU を送受信できなくなります。

portfast bpdufilter default コマンドを無効にするには、インターフェイスごとに BPDU フィルタリングを設定します。


) BPDU フィルタリングをイネーブルにする場合は、慎重に行ってください。ポート単位でイネーブルにする場合とグローバルにイネーブルする場合では、機能が異なります。グローバルにイネーブル化された BPDU フィルタリングは、PortFast 動作ステートのポートだけに適用されます。リンクがアップすると、ポートは BPDU をいくつか送信してから、発信 BPDU を効率的にフィルタリングします。エッジ ポートに着信した BPDU は、ただちに PortFast 動作ステータスを失い、BPDU フィルタリングがディセーブルになります。

BPDU フィルタリングがポート上でローカルにイネーブル化されている場合、Catalyst 6500 シリーズ スイッチはこのポート上で BPDU を送受信できません。



注意 このコマンドは、慎重に使用してください。このコマンドを誤って使用すると、ブリッジング ループを発生させる可能性があります。

次に、BPDU フィルタリングをデフォルトでイネーブルにする例を示します。

Router(config)# spanning-tree portfast bpdufilter default
Router(config)#

 
関連コマンド

コマンド
説明

show spanning-tree mst

MST プロトコルに関する情報を表示します。

spanning-tree bpdufilter

インターフェイス上で BPDU フィルタリングをイネーブルにします。

 

spanning-tree portfast bpduguard default

すべての PortFast ポートで、BPDU ガードをデフォルトでイネーブルにするには、 spanning-tree portfast bpduguard default コマンドを使用します。デフォルト設定に戻すには、このコマンドの no 形式を使用します。

spanning-tree portfast bpduguard default

no spanning-tree portfast bpduguard default

 
シンタックスの説明

このコマンドには、キーワードまたは引数はありません。

 
コマンドのデフォルト

ディセーブル

 
コマンド モード

グローバル コンフィギュレーション(config)

 
コマンドの履歴

リリース
変更内容

12.2(18)ZY

このコマンドのサポートが追加されました。

 
使用上のガイドライン


注意 このコマンドは、慎重に使用してください。このコマンドは、エンド ステーションに接続されているインターフェイスだけに使用してください。偶発的なトポロジー ループが原因でデータ パケット ループが発生し、Catalyst 6500 シリーズ スイッチおよびネットワークの動作が妨げられることがあります。

BPDU ガードは、BPDU を受信したポートをディセーブルにします。BPDU ガードが適用されるのは、PortFast がイネーブルに設定されていて、PortFast 動作ステートになっているポートだけです。

次に、BPDU ガードをデフォルトでイネーブルにする例を示します。

Router(config)# spanning-tree portfast bpduguard default
Router(config)#

 
関連コマンド

コマンド
説明

show spanning-tree mst

MST プロトコルに関する情報を表示します。

spanning-tree portfast bpduguard default

インターフェイス上で BPDU ガードをイネーブルにします。

 

spanning-tree portfast default

すべてのアクセス ポートで、PortFast をデフォルトでイネーブルにするには、 spanning-tree portfast default コマンドを使用します。すべてのアクセス ポートで、PortFast をデフォルトでディセーブルにするには、このコマンドの no 形式を使用します。

spanning-tree portfast default

no spanning-tree portfast default

 
シンタックスの説明

このコマンドには、キーワードまたは引数はありません。

 
コマンドのデフォルト

ディセーブル

 
コマンド モード

グローバル コンフィギュレーション(config)

 
コマンドの履歴

リリース
変更内容

12.2(18)ZY

このコマンドのサポートが追加されました。

 
使用上のガイドライン


注意 このコマンドは、慎重に使用してください。このコマンドは、エンド ステーションに接続されているインターフェイスだけに使用してください。偶発的なトポロジー ループが原因でデータ パケット ループが発生し、Catalyst 6500 シリーズ スイッチおよびネットワークの動作が妨げられることがあります。

リンクがアップすると、PortFast モードがイネーブルに設定されたインターフェイスは標準の転送遅延時間の経過を待たずに、ただちにスパニングツリー フォワーディング ステートに移行します。

インターフェイスごとに個別に PortFast モードをイネーブルにするには、 spanning-tree portfast (interface configuration mode) コマンドを使用します。

次に、すべてのアクセス ポートで、PortFast をデフォルトでイネーブルにする例を示します。

Router(config)# spanning-tree portfast default
Router(config)#

 
関連コマンド

コマンド
説明

show spanning-tree

スパニングツリー ステートに関する情報を表示します。

spanning-tree portfast (interface configuration mode)

PortFast モードをイネーブルにします。

spanning-tree port-priority

2 つのブリッジがルート ブリッジとなるために競合している場合に、インターフェイスにプライオリティを設定するには、 spanning-tree port-priority コマンドを使用します。設定されたプライオリティによって、差が生じます。デフォルト設定に戻すには、このコマンドの no 形式を使用します。

spanning-tree port-priority port-priority

no spanning-tree port-priority

 
シンタックスの説明

port-priority

ポートのプライオリティ。 有効値は 2 ~ 255 です。

 
コマンドのデフォルト

port-priority 128 です。

 
コマンド モード

インターフェイス コンフィギュレーション(config-if)

 
コマンドの履歴

リリース
変更内容

12.2(18)ZY

このコマンドのサポートが追加されました。

次に、イーサネット インターフェイス 2/0 のルート ブリッジとしてスパニングツリー インスタンス 20 が選択される可能性を高める例を示します。

Router(config-if)# spanning-tree port-priority 0
Router(config-if)#

 
関連コマンド

コマンド
説明

show spanning-tree

スパニングツリー ステートに関する情報を表示します。

spanning-tree mst

任意の MST インスタンス(インスタンス ID 0 の CIST を含む)のパス コストおよびポート プライオリティ パラメータを設定します。

spanning-tree vlan

VLAN 単位で STP を設定します。

 

spanning-tree transmit hold-count

送信ホールド カウントを指定するには、 spanning-tree transmit hold-count コマンドを使用します。デフォルト設定に戻すには、このコマンドの no 形式を使用します。

spanning-tree transmit hold-count value

no spanning-tree transmit hold-count

 
シンタックスの説明

value

一時停止するまで 1 秒間に送信される BPDU の数。 有効値は、1 ~ 20 です。

 
コマンドのデフォルト

value 6 です。

 
コマンド モード

グローバル コンフィギュレーション(config)

 
コマンドの履歴

リリース
変更内容

12.2(18)ZY

このコマンドのサポートが追加されました。

 
使用上のガイドライン

このコマンドは、すべてのスパニングツリー モードでサポートされています。

送信ホールド カウントは、一時停止するまで 1 秒間に送信される BPDU の数を決定します。


) このパラメータをより高い値に変更すると、特に高速 PVST モードで、CPU 利用率に重大な影響を与える可能性があります。このパラメータを低い値に設定すると、一部のシナリオでコンバージェンスが低速になる可能性があります。デフォルト設定から値を変更しないことを推奨します。


value 設定を変更する場合は、 show running-config コマンドを入力して、変更内容を確認します。

コマンドを削除する場合は、 show spanning-tree mst コマンドを使用して、削除内容を確認します。

次に、送信ホールド カウントを指定する例を示します。

Router(config)# spanning-tree transmit hold-count 8
Router(config)#

 
関連コマンド

コマンド
説明

show running-config

モジュールまたはレイヤ 2 VLAN のステータスおよび設定を表示します。

show spanning-tree mst

MST プロトコルに関する情報を表示します。

 

spanning-tree uplinkfast

UplinkFast をイネーブルにするには、 spanning-tree uplinkfast コマンドを使用します。UplinkFast をディセーブルにするには、このコマンドの no 形式を使用します。

spanning-tree uplinkfast [ max-update-rate packets-per-second ]

no spanning-tree uplinkfast [ max-update-rate ]

 
シンタックスの説明

max-update-rate packets-per-second

(任意)更新パケットの最大送信速度(パケット/秒)を指定します。 有効値は 0 ~ 65,535 です。

 
コマンドのデフォルト

デフォルト設定は次のとおりです。

UplinkFast はディセーブルです。

packets-per-second は 150 パケット/秒です。

 
コマンドのデフォルト

グローバル コンフィギュレーション(config)

 
コマンドの履歴

リリース
変更内容

12.2(18)ZY

このコマンドのサポートが追加されました。

 
使用上のガイドライン

このコマンドはアクセス スイッチだけで使用します。

UplinkFast が設定されている場合、このスイッチがルートとして選択されないように、ブリッジ プライオリティは 49,152 に変更されます。指定されたスパニングツリー インスタンスに属するすべてのスパニングツリー インターフェイスのインターフェイス パス コストも、すべて 3000 ずつ増分します。

ルート インターフェイスの障害がスパニングツリーで検出されると、UplinkFast 機能はただちに代替ルート インターフェイスに切り替えて、新しいルート インターフェイスを直接フォワーディング ステートに移行させます。この間、トポロジー変更通知が送信されます。トポロジーの変更による中断を最小限にするため、元のルート インターフェイスに対応付けられたアドレスを除き、転送元ブリッジのステーション アドレスごとに、マルチキャスト パケットが 01-00-0C-CD-CD-CD に送信されます。

spanning-tree uplinkfast max-update-rate コマンドを使用すると、UplinkFast がイネーブルになり(まだイネーブルでない場合)、更新パケットの送信速度が変更されます。デフォルトの速度に戻すには、このコマンドの no 形式を使用します。

次に、UplinkFast をイネーブルにして、最大速度を 200 パケット/秒に設定する例を示します。

Router(config)# spanning-tree uplinkfast max-update-rate 200
Router(config)#

 
関連コマンド

コマンド
説明

show spanning-tree

スパニングツリー ステートに関する情報を表示します。

 

spanning-tree vlan

VLAN 単位で STP を設定するには、 spanning-tree vlan コマンドを使用します。デフォルト設定に戻すには、このコマンドの no 形式を使用します。

spanning-tree vlan vlan-id [ forward-time seconds | hello-time hello-time | max-age seconds | priority priority | protocol protocol | { root { primary | secondary } [ diameter net-diameter [ hello-time hello-time ]]}]

no spanning-tree vlan vlan-id [ forward-time | hello-time | max-age | priority | protocol | root ]

 
シンタックスの説明

vlan-id

VLAN ID 番号。有効値は 1 ~ 4094 です。

forward-time seconds

(任意)STP 転送遅延時間を指定します。有効値は 4 ~ 30 秒です。

hello-time hello-time

(任意)ルート スイッチで生成されるコンフィギュレーション メッセージの間隔(秒数)を指定します。有効値は 1 ~ 10 秒です。

max-age seconds

(任意)BPDU 内の情報が有効である最大期間(秒数)を指定します。有効値は 6 ~ 40 秒です。

priority priority

(任意)STP ブリッジ プライオリティを指定します。有効値は 0 ~ 65,535 です。

protocol protocol

(任意)STP を指定します。有効値については、「使用上のガイドライン」を参照してください。

root primary

(任意)このスイッチを強制的にルート ブリッジに設定します。

root secondary

(任意)プライマリ ルートに障害が発生した場合に、このスイッチをルート スイッチとして機能させます。

diameter net-diameter

(任意)エンド ステーション間の 2 つの接続ポイント間に存在するブリッジの最大数を指定します。有効値は 2 ~ 7 です。

 
コマンドのデフォルト

デフォルト設定は次のとおりです。

forward-time :15 秒

hello-time :2 秒

max-age :20 秒

priority :IEEE STP がイネーブルの場合のデフォルトは 32768、STP がイネーブルの場合のデフォルトは 128

protocol :IEEE

root :STP ルートなし

 
コマンド モード

グローバル コンフィギュレーション(config)

 
コマンドの履歴

リリース
変更内容

12.2(18)ZY

このコマンドのサポートが追加されました。

 
使用上のガイドライン


注意 no spanning-tree vlan vlan-id コマンドを使用して、VLAN 上でスパニングツリーをディセーブルにする場合は、VLAN 内のすべてのスイッチおよびブリッジでスパニングツリーがディセーブルであることを確認してください。スパニングツリーがイネーブルとなっているスイッチおよびブリッジは、ネットワークの物理トポロジーに関して不完全な情報しか持たないため、同一 VLAN 内の一部のスイッチおよびブリッジでスパニングツリーをディセーブルにし、他のスイッチおよびブリッジでイネーブルにしておくことはできません。


注意 物理的なループがないトポロジー内であっても、スパニングツリーをディセーブルにしないことを推奨します。スパニングツリーは設定ミスやケーブル障害を防ぎます。VLAN 内に物理的なループがないことが確認されるまで、VLAN 内のスパニングツリーをディセーブルにしないでください。

max-age seconds が設定されている場合に、ブリッジが指定インターバル内にルート ブリッジから BPDU を受信しない場合は、ネットワークが変更されていると見なされ、スパニングツリー トポロジーが再計算されます。

protocol の有効値は dec (Digital STP)、 ibm (IBM STP)、 ieee (IEEE Ethernet STP)、および vlan-bridge (VLAN Bridge STP)です。

spanning-tree root primary コマンドを入力すると、スイッチのブリッジ プライオリティが 8192 に変更されます。spanning-tree root primary コマンドを入力したにもかかわらず、スイッチがルートにならなかった場合は、このスイッチのブリッジ プライオリティが現在のブリッジのブリッジ プライオリティよりも 100 だけ小さな値に変更されます。スイッチがルートにならない場合は、エラーが発生します。

spanning-tree root secondary コマンドを入力すると、スイッチのブリッジ プライオリティが 16384 に変更されます。ルート スイッチに障害が発生した場合は、このスイッチが次のルート スイッチになります。

spanning-tree root コマンドは、バックボーン スイッチだけで使用してください。

次に、VLAN 200 でスパニングツリーをイネーブルにする例を示します。

Router(config)# spanning-tree vlan 200
Router(config)#
 

次に、スイッチを VLAN 10 のルート スイッチとして設定し、ネットワーク直径を 4 に設定する例を示します。

Router(config)# spanning-tree vlan 10 root primary diameter 4
Router(config)#
 

次に、スイッチを VLAN 10 のセカンダリ ルート スイッチとして設定し、ネットワーク直径を 4 に設定する例を示します。

Router(config)# spanning-tree vlan 10 root secondary diameter 4
Router(config)#

 
関連コマンド

コマンド
説明

show spanning-tree

スパニングツリー ステートに関する情報を表示します。

 

speed

イーサネット インターフェイスのポート速度を設定するには、 speed コマンドを使用します。速度設定をディセーブルにするには、このコマンドの no 形式を使用します。

speed { 10 | 100 | 1000 }

speed auto [ speed-list ]

speed [ 10 00 | nonegotiate ]

no speed

 
シンタックスの説明

10

インターフェイスの伝送を 10 Mbps に指定します。

100

インターフェイスの伝送を 100 Mbps に指定します。

1000

(任意)インターフェイスの伝送を 1000 Mbps に指定します。

auto

自動ネゴシエーション機能をイネーブルにします。

speed-list

(任意)特定の速度に対する速度の自動ネゴシエーション機能。有効値については、「使用上のガイドライン」を参照してください。

nonegotiate

(任意)ギガビット イーサネット ポート上でリンク ネゴシエーション プロトコルをイネーブルまたはディセーブルにします。

 
コマンドのデフォルト

デフォルト設定のリストについては、 表 2-93 を参照してください。

 
コマンド モード

インターフェイス コンフィギュレーション(config-if)

 
コマンドの履歴

リリース
変更内容

12.2(18)ZY

このコマンドのサポートが追加されました。

 
使用上のガイドライン

10/100 ポートには speed [ 10 | 100 ] コマンド、10/100/1000 ポートには speed auto [ 10 100 [ 1000 ]] コマンド、ギガビット イーサネット ポートには speed [ 10 00 | nonegotiate ] コマンドを使用します。

speed-list の入力値はスペースで区切ります。

次の speed-list 設定がサポートされています。

speed auto :すべての速度をネゴシエーションします。

speed auto 10 100 :10 および 100 の速度だけをネゴシエーションします。

speed auto 10 100 1000 :すべての速度をネゴシエーションします。

リンク ネゴシエーションがイネーブルの場合は、2 つのギガビット イーサネット ポート間の速度、デュプレックス、フロー制御、およびクロッキングのネゴシエーションが自動的にイネーブルになります。

表 2-93 に、サポートされているコマンド オプションをインターフェイス別に示します。

 

表 2-93 サポートされている speed コマンド オプション

インターフェイス タイプ
サポートされている構文
デフォルト設定
使用上のガイドライン

10/100 Mbps モジュール

speed [ 10 | 100 ]

speed auto [ 10 | 100 ]

auto

速度が auto に設定されている場合は、 duplex を設定できません。

速度が 10 または 100 に設定されている場合に、デュプレックスを設定しないと、デュプレックスは half に設定されます。

10/100/1000 Mbps インターフェイス

speed auto [{ 10 100 } [ 1000 ]]

auto

速度が auto に設定されている場合は、 duplex を設定できません。

速度が 10 または 100 に設定されている場合に、デュプレックスを設定しないと、デュプレックスはデフォルトで half に設定されます。

速度が 10 または 100 に設定されている場合に、インターフェイスはデフォルトで強制的に半二重に設定されません。

100 Mbps ファイバ モジュール

出荷時の設定

該当なし

 

ギガビット イーサネット モジュール

speed [ 1000 | nonegotiate ]

速度が 1000 であるか、またはネゴシエーションがイネーブルです。

速度、デュプレックス、フロー制御、およびクロッキングのネゴシエーションがイネーブルです。

10 Mbps ポート

出荷時の設定

該当なし

 

インターフェイスの speed および duplex コマンドを手動で設定し、 speed auto 以外の値(10 または 100 Mbps など)を入力する場合は、接続先インターフェイスの speed コマンドを適合する速度に設定してください。ただし、 auto キーワードは使用しないでください。

10/100 Mbps または 10/100/1000 Mbps イーサネット インターフェイスでイーサネット インターフェイス速度を auto に設定すると、速度およびデュプレックスが両方とも自動ネゴシエーションされます。

ギガビット イーサネット インターフェイスは全二重通信専用です。ギガビット イーサネット インターフェイス、またはギガビット イーサネット用に設定された 10/100/1000 Mps インターフェイス上では、デュプレックス モードを変更できません。

インターフェイス速度を手動で 10 または 100 Mbps に設定すると、インターフェイスのデュプレックス モードを設定するように指示するプロンプトが表示されます。


) Catalyst 6500 シリーズ スイッチは、いずれかの接続先インターフェイスが auto 以外の値に設定されている場合、インターフェイスの速度およびデュプレックス モードを自動ネゴシエーションできません。



注意 インターフェイス速度およびデュプレックス モードを変更すると、インターフェイスがシャットダウンされてから再設定時に再びイネーブルになる場合があります。

ポート速度が 1000 に設定されている場合は、デュプレックス モードを half に設定できません。同様に、モードが半二重に設定されている場合は、ポート速度を 1000 に設定できません。また、ポート速度が auto に設定されている場合は、 duplex コマンドは拒否されます。

表 2-94 で、 duplex コマンドおよび speed コマンド間の関係を説明します。

 

表 2-94 duplex コマンドと speed コマンドの関係

duplex コマンド
speed コマンド
システム アクション

duplex half または duplex full

speed auto

速度とデュプレックス モードの両方を自動ネゴシエーションします。

duplex half

speed 10

強制的に 10 Mbps および半二重になります。

duplex full

speed 10

強制的に 10 Mbps および全二重になります。

duplex half

speed 100

強制的に 100 Mbps および半二重になります。

duplex full

speed 100

強制的に 100 Mbps および全二重になります。

duplex full

speed 1000

強制的に 1000 Mbps および全二重になります。

次に、100 Mbps で伝送するようにインターフェイスを設定する例を示します。

Router(config-if)# speed 100
Router(config-if)#

 
関連コマンド

コマンド
説明

duplex

インターフェイス上でデュプレックス操作を設定します。

interface

設定するインターフェイスを選択し、インターフェイス コンフィギュレーション モードを開始します。

show interfaces

特定のインターフェイスで認識されるトラフィックを表示します。

 

squeeze

フラッシュ ファイル システムをスクイーズしてフラッシュ ファイルを永続的に削除するには、 squeeze コマンドを使用します。

squeeze filesystem :

 
シンタックスの説明

filesystem :

フラッシュ ファイル システムを指定します。有効値は bootflash: および flash: です

 
コマンドのデフォルト

このコマンドにはデフォルト設定がありません。

 
コマンド モード

特権 EXEC

 
コマンドの履歴

リリース
変更内容

12.2(18)ZY

このコマンドのサポートが追加されました。

 
使用上のガイドライン

フラッシュ メモリが満杯の場合は、[deleted] とマークされたファイルによって使用されているスペースを再利用できるように、ファイルを再配置する必要があります。

squeeze コマンドを入力すると、すべての有効なファイルはフラッシュ メモリの先頭にコピーされ、[deleted] とマークされたファイルは全部消去されます。削除されたファイルの回復はできませんが、再利用されるフラッシュ メモリ スペースに書き込むことはできます。

squeeze コマンドを使用すると、削除されたファイルを消去するだけでなく、[error] とマークされたすべてのファイルを消去することもできます。エラー ファイルは、ファイル書き込みに失敗した場合(装置がいっぱいの場合など)に作成されます。エラー ファイルを消去するには、 squeeze コマンドを使用する必要があります。スクイーズ動作は、フラッシュ メモリ スペースのほぼ全体で消去および書き込みが行われるため、数分間かかることがあります。

filesystem を入力するときは、コロンが必要です。

次に、[deleted] とマークされたファイルをフラッシュ メモリから永続的に消去する例を示します。

Router # squeeze flash:
Router #

 
関連コマンド

コマンド
説明

delete

フラッシュ メモリ デバイスまたは NVRAM からファイルを削除します。

dir

ファイル システムのファイル リストを表示します。

undelete

フラッシュ ファイル システムで [delete] マークが付いたファイルを回復します。

 

stack-mib portname

ポートに名前文字列を指定するには、 stack-mib portname コマンドを使用します。

stack-mib portname portname

 
シンタックスの説明

portname

ポートの名前

 
コマンドのデフォルト

このコマンドにはデフォルト設定がありません。

 
コマンド モード

インターフェイス コンフィギュレーション(config-if)

 
コマンドの履歴

リリース
変更内容

12.2(18)ZY

このコマンドのサポートが追加されました。

 
使用上のガイドライン

stack-mib コマンドを使用してポートに名前文字列を設定する処理は、CISCO-STACK-MIB の portTable 内の portName MIB オブジェクトに対応します。portName は CISCO-STACK-MIB の portTable 内の MIB オブジェクトです。このオブジェクトは、インターフェイスの機能を示す説明文として設定できます。

次に、ポートに名前を設定する例を示します。

Router(config-if)# stack-mib portname portal_to_paradise
Router(config-if)#

standby delay minimum reload

HSRP グループを初期化するまでの遅延期間を設定するには、 standby delay minimum reload コマンドを使用します。遅延期間をディセーブルにするには、このコマンドの no 形式を使用します。

standby delay minimum [ min-delay ] reload [ reload-delay ]

no standby delay minimum [ min-delay ] reload [ reload-delay ]

 
シンタックスの説明

min-delay

(任意)インターフェイスの起動後に HSRP グループの初期化を遅らせる最小時間(秒数)。この最小遅延期間は、以降のすべてのインターフェイス イベントに適用されます。

reload-delay

(任意)ルータのリロード後の遅延時間(秒数)。この遅延時間は、ルータのリロード後の最初のインターフェイス起動イベントだけに適用されます。

 
コマンドのデフォルト

デフォルト設定は次のとおりです。

min-delay 1 秒です。

reload-delay 5 秒です。

 
コマンド モード

インターフェイス コンフィギュレーション(config-if)

 
コマンドの履歴

リリース
変更内容

12.2(18)ZY

このコマンドのサポートが追加されました。

 
使用上のガイドライン

アクティブ ルータに障害が発生するか、またはネットワークから取り除かれた場合は、スタンバイ ルータが自動的に新規のアクティブ ルータになります。元のアクティブ ルータがオンライン状態に戻った場合は、 standby preempt コマンドを使用して、このルータにアクティブ ルータとしての機能を引き継がせるかどうかを制御できます。

ただし、 standby preempt コマンドが設定されていない場合でも、元のアクティブ ルータをリロードしてオンライン状態に戻すと、このルータはアクティブ ルータとしての機能を再開します。HSRP グループの初期化の遅延期間を設定するには、 standby delay minimum reload コマンドを使用します。このコマンドを使用すると、ルータがアクティブな機能を再開するまで、パケットの通過を許可する時間を設定できます。

standby timers コマンドがミリ秒単位で設定されている場合、またはスイッチの特定の VLAN インターフェイスに HSRP が設定されている場合は、 standby delay minimum reload コマンドを使用することを推奨します。

ほとんどの設定では、デフォルト値により、パケットが通過する十分な期間が設定されます。これより長い遅延期間を設定する必要はありません。

HSRP パケットがインターフェイスに着信すると、遅延はキャンセルされます。

次に、最小遅延期間を 30 秒に、最初のリロード後の遅延期間を 120 秒に設定する例を示します。

Router(config-if) # standby delay minimum 30 reload 120
Router(config-if) #

 
関連コマンド

コマンド
説明

show standby delay

遅延期間に関する HSRP 情報を表示します。

standby preempt

HSRP プリエンプションおよびプリエンプション遅延を設定します。

standby timers

hello パケットの間隔と、他のルータがアクティブ ホット スタンバイまたはスタンバイ ルータの終了を宣言するまでの時間を設定します。

 

standby track

他のインターフェイスの利用状況に基づいてホット スタンバイ プライオリティが変更されるようにインターフェイスを設定するには、 standby track コマンドを使用します。グループのすべてのトラッキング設定を削除するには、このコマンドの no 形式を使用します。

standby [ group-number ] track { interface-type interface-number | designated-router } [ priority-decrement ]

no standby group-number track

 
シンタックスの説明

group-number

(任意)トラッキングが適用されるインターフェイス上のグループ番号。有効値は、0 ~ 255 です。

interface-type interface-number

トラッキングするインターフェイス タイプおよび番号

designated-router

指定ルータの指定が解除された場合に、アクティブ HSRP ルータが指定ルータになるように指定します。

priority-decrement

(任意)インターフェイスがダウン(または回復)した場合に、ルータのホット スタンバイ プライオリティを減分(または増分)する値

 
コマンドのデフォルト

デフォルト設定は次のとおりです。

group 0 です。

priority-decrement 10 です。

designated-router キーワードはディセーブルです。

 
コマンド モード

インターフェイス コンフィギュレーション(config-if)

 
コマンドの履歴

リリース
変更内容

12.2(18)ZY

このコマンドのサポートが追加されました。

 
使用上のガイドライン

designated-router キーワードを入力する前に、新規の指定ルータが引き継ぐ現行の指定ルータより高い HSRP プライオリティを保有していることを確認する必要があります。

トラッキングされたインターフェイスがダウンすると、ホット スタンバイ プライオリティが priority-decrement 引数によって指定された数だけ減分します。インターフェイスがトラッキングされていなければ、ステートが変化した場合でもホット スタンバイ プライオリティに影響することはありません。ホット スタンバイに設定された各インターフェイスには、トラッキングするインターフェイスのリストを別々に設定できます。

トラッキングされたインターフェイスが複数ダウンした場合、 priority-decrement 値が設定されているかどうかに関係なく、減分値が下がっていきます。

インターフェイスで IP アドレスがディセーブルに設定されていると、トラッキングされたインターフェイスはダウンしていると見なされます。

このコマンドの no 形式を使用する場合は、 group-number を入力する必要があります。

インターフェイスをトラッキングするのに HSRP を設定し、そのインターフェイスが OIR 動作に備えて物理的に削除されている場合、HSRP はインターフェイスが常にダウンしていると見なします。HSRP インターフェイス トラッキング設定は削除できません。この状態を防ぐには、インターフェイスを物理的に削除する前に no standby track interface-type interface-number コマンドを使用します。

group-number 0 を入力する場合、NVRAM にはグループ番号が書き込まれず、下位互換性が提供されます。

次に、特定のインターフェイス上でグループ 1 をトラッキングする HSRP をイネーブルにする例を示します。

Router(config-if)# standby 1 track Ethernet0/2
Router(config-if)#
 

次に、指定ルータの指定が解除された場合に、アクティブ HSRP ルータが指定ルータになるように指定する例を示します。

Router(config-if)# standby 1 track designated-router 15
Router(config-if)#

 
関連コマンド

コマンド
説明

show standby

HSRP 情報を表示します。

 

standby use-bia

割り当て済みの MAC アドレス(イーサネットおよび FDDI 上)または機能アドレス(トークンリング上)の代わりに、インターフェイスの Burned-In Address を仮想 MAC アドレスとして使用するように HSRP を設定するには、 standby use-bia コマンドを使用します。デフォルトの仮想 MAC アドレスに戻すには、このコマンドの no 形式を使用します。

standby use-bia [ scope interface ]

no standby use-bia

 
シンタックスの説明

scope interface

(任意)主要インターフェイスの代わりに入力されたサブインターフェイスに対して、このコマンドを設定します。

 
コマンドのデフォルト

HSRP は、イーサネットおよび FDDI では割り当て済みの MAC アドレスを、トークンリングでは機能アドレスを使用します。

 
コマンド モード

インターフェイス コンフィギュレーション(config-if)

 
コマンドの履歴

リリース
変更内容

12.2(18)ZY

このコマンドのサポートが追加されました。

 
使用上のガイドライン

このコマンドは、PFC 2 が搭載された Catalyst 6500 シリーズ スイッチではサポートされていません。

PFC2 は、最大 16 の一意の HSRP グループ番号をサポートします。異なる VLAN 上で同じ HSRP グループ番号を使用できます。17 個以上の HSRP グループを設定する場合、この制約により、VLAN 番号を HSRP グループ番号としては使用できません。


) 同じ番号の HSRP グループは、同じ仮想 MAC アドレスを使用するため、ブリッジ グループを設定する場合にエラーが発生することがあります。


ハードウェア レイヤ 3 スイッチングは、次の入力および出力カプセル化をサポートします。

イーサネット V2.0(ARPA)

1 バイト コントロールを使用する 802.2 対応の 802.3(SAP1)

802.2 対応の 802.3 および SNAP

ハードウェア レイヤ 3 スイッチングは永続的にイネーブルです。したがって設定作業は不要です。

次に、仮想 IP アドレスにマッピングされる仮想 MAC アドレスとして、インターフェイスの Burned-In Address を使用するように HSRP を設定する例を示します。

Router(config-if) # standby use-bia
Router(config-if) #

storm-control level

抑制レベルを設定するには、 storm-control level コマンドを使用します。抑制モードをオフにするには、このコマンドの no 形式を使用します。

storm-control { broadcast | multicast | unicast } level level [ . level ]

no storm-control { broadcast | multicast | unicast } level

 
シンタックスの説明

broadcast

ブロードキャスト トラフィックを指定します。

multicast

マルチキャスト トラフィック を指定します。

unicast

ユニキャスト トラフィックを指定します。

level

整数の抑制レベル。 有効値は 0 ~ 100% です。

. level

(任意)フラクショナル抑制レベル。有効値は 0 ~ 99 です。

 
コマンドのデフォルト

すべてのパケットが通過します。

 
コマンド モード

インターフェイス コンフィギュレーション(config-if)

 
コマンドの履歴

リリース
変更内容

12.2(18)ZY

このコマンドのサポートが追加されました。

 
使用上のガイドライン

このコマンドは、スイッチ ポートおよびルータ ポートに入力できます。

インターフェイス上でトラフィック ストーム制御をイネーブルにし、トラフィック ストーム制御レベルを設定し、インターフェイス上でイネーブル化されたすべてのトラフィック ストーム制御モードにトラフィック ストーム制御レベルを適用するには、 storm-control level コマンドを入力します。

3 つの抑制モードすべてで共有される抑制レベルは、1 つだけです。たとえば、ブロードキャスト レベルを 30 に設定し、マルチキャスト レベルを 40 に設定した場合は、両方のレベルがイネーブルになり、それぞれ 40 に設定されます。

Catalyst 6500 シリーズ スイッチは、ギガビットおよび 10 ギガビット イーサネット LAN ポート上だけでマルチキャストおよびユニキャスト トラフィックのストーム制御をサポートします。ブロードキャスト トラフィックのストーム制御はすべての LAN ポート上でサポートされます。

multicast および unicast キーワードは、ギガビットおよび 10 ギガビット イーサネット LAN ポートだけでサポートされます。ユニキャストおよびマルチキャスト抑制は、WS-X6148A-RJ-45 および WS-X6148-SFP モジュールでもサポートされています。

フラクショナル抑制レベルを入力するときは、ピリオドが必要です。

抑制レベルは、合計帯域幅に対するパーセントとして入力します。しきい値が 100% であれば、トラフィックに対して制限が課せられていないことになります。しきい値が 0 または 0.0(フラクショナル)% であれば、指定されたすべてのトラフィックは、ポート上でブロックされることになります。次の注意事項を参照してください。

フラクショナル レベルの値が 0.33 以下の場合、次のモジュール上では 0.0 の場合と同様になります。

WS-X6704-10GE

WS-X6748-SFP

WS-X6724-SFP

WS-X6748-GE-TX

ポート上の指定されたすべてのトラフィックをブロックするには、その他すべてのモジュールで 0 を入力します。

廃棄数を表示するには、 show interfaces counters broadcast コマンドを入力します。

イネーブル化された抑制モードおよびレベル設定を表示するには、 show running-config コマンドを入力します。

指定されたトラフィック タイプの抑制をオフにするには、次のいずれかを実行します。

指定されたトラフィック タイプの level を 100% に設定します。

このコマンドの no 形式を使用します。

次に、抑制モードをイネーブルにして、抑制レベルを設定する例を示します。

Router(config-if)# storm-control broadcast level 30
Router(config-if)#
 

次に、抑制モードをディセーブルにする例を示します。

Router(config-if)# no storm-control multicast level
Router(config-if)#

 
関連コマンド

コマンド
説明

show interfaces counters

物理インターフェイスで認識されるトラフィックを表示します。

show running-config

モジュールまたはレイヤ 2 VLAN のステータスおよび設定を表示します。

 

switchport

レイヤ 2 スイッチド インターフェイスのスイッチング特性を変更するには、 switchport コマンドを使用します(パラメータを指定しません)。インターフェイスをルーテッドインターフェイス ステータスに戻して、すべてのレイヤ 2 コンフィギュレーションを消去するには、このコマンドの no 形式を使用します(パラメータを指定しません)。スイッチング特性を設定するには、 switchport コマンドを使用します(パラメータを指定します)。

switchport

switchport { host | nonegotiate }

no switchport

no switchport nonegotiate

 
シンタックスの説明

host

ホスト接続用にポート設定を最適化します。

nonegotiate

装置がこのインターフェイスのネゴシエーション プロトコルに関係しないように指定します。

 
コマンドのデフォルト

プラットフォームまたはインターフェイス ハードウェアに対応するデフォルト VLAN は、デフォルトのアクセス VLAN およびトランク インターフェイス ネイティブ VLAN です。

 
コマンド モード

インターフェイス コンフィギュレーション(config-if)

 
コマンドの履歴

リリース
変更内容

12.2(18)ZY

このコマンドのサポートが追加されました。

 
使用上のガイドライン

LAN インターフェイスをレイヤ 2 インターフェイスとして設定するには、キーワードを指定しないで switchport コマンドを入力してから、キーワードを指定してさらに switchport コマンドを入力する必要があります。この処理は、インターフェイスに対して switchport コマンドをまだ入力していない場合だけ必要となります。

no switchport コマンドを入力すると、ポートはシャットダウンされてから再びイネーブルになります。この処理により、ポートに接続された装置上でメッセージが生成されることがあります。

ポート設定を最適化するには、 switchport host コマンドを入力して、スイッチ ポート モードを access に設定し、スパニングツリーの PortFast をイネーブルにし、チャネルのグループ化をディセーブルにします。この設定を実行できるのは、エンド ステーション上だけです。

スパニングツリー PortFast がイネーブルであるため、単一ホストに接続されたポートだけに、 switchport host コマンドを入力する必要があります。他の Catalyst 6500 シリーズ スイッチ、ハブ、コンセントレータ、スイッチ、およびブリッジを高速起動ポートに接続すると、一時的にスパニングツリー ループが発生することがあります。

パケット転送を開始するまでの期間を短縮するには、 switchport host コマンドをイネーブルにします。

switchport nonegotiate コマンドの no 形式を使用すると、nonegotiate ステータスが削除されます。

nonegotiate キーワードを使用した場合は、インターフェイス上で DISL/DTP ネゴシエーション パケットが送信されません。装置は、指定された access または trunk の mode パラメータによって、トランキングされるかどうかが決まります。dynamic(auto または desirable)モードでこのコマンドを実行しようとすると、エラーが戻されます。

ポートを SPAN 宛先ポートとして設定するには、ポートを強制的にトランキングさせる必要があります。ポートを強制的にトランキングさせるには、 switchport nonegotiate コマンドを使用します。

次に、ポート インターフェイスがシスコ ルーテッド ポートとしての動作を停止して、レイヤ2スイッチド インターフェイスに変換されるように設定する例を示します。

Router(config-if)# switchport
Router(config-if)#

) シスコ ルーテッド ポートをサポートしないプラットフォームでは、switchport コマンドを使用できません。このようなプラットフォームのすべての物理ポートは、レイヤ 2 スイッチド インターフェイスと見なされます。


次に、ホスト接続用にポート設定を最適化する例を示します。

Router(config-if)# switchport host
switchport mode will be set to access
spanning-tree portfast will be enabled
channel group will be disabled
Router(config-if)#
 

次に、スイッチド インターフェイスとして設定されたポート インターフェイスが、トランキング モードをネゴシエーションしないように制限し、(mode の設定に応じて)トランクまたはアクセス ポートとして動作するように設定する例を示します。

Router(config-if)# switchport nonegotiate
Router(config-if)#

 
関連コマンド

コマンド
説明

show interfaces switchport

スイッチング(非ルーティング)ポートの管理ステータスおよび動作ステータスを表示します。

 

switchport access vlan

インターフェイスがアクセス モードのときに VLAN を設定するには、 switchport access vlan コマンドを使用します。アクセス モード VLAN をデバイスの適切なデフォルト VLAN にリセットするには、このコマンドの no 形式を使用します。

switchport access vlan vlan-id

no switchport access vlan

 
シンタックスの説明

vlan-id

インターフェイスがアクセス モードの場合の VLAN を指定します。有効値は 1 ~ 4094 です。

 
コマンドのデフォルト

デフォルト設定は次のとおりです。

アクセス VLAN およびトランク インターフェイス ネイティブ VLAN が、プラットフォームまたはインターフェイス ハードウェアに対応するデフォルト VLAN です。

すべての VLAN リストは VLAN をすべて含みます。

 
コマンド モード

インターフェイス コンフィギュレーション(config-if)

 
コマンドの履歴

リリース
変更内容

12.2(18)ZY

このコマンドのサポートが追加されました。

 
使用上のガイドライン

LAN インターフェイスをレイヤ 2 インターフェイスとして設定するには、キーワードを指定しないで switchport コマンドを入力してから、 switchport access vlan コマンドを入力する必要があります。この処理は、インターフェイスに対して switchport コマンドをまだ入力していない場合だけ必要となります。

no switchport コマンドを入力すると、ポートはシャットダウンされてから再びイネーブルになります。この処理により、ポートに接続された装置上でメッセージが生成されることがあります。

アクセス モード VLAN をデバイスに適したデフォルト VLAN にリセットするには、 switchport access vlan コマンドの no 形式を使用します。

次に、ポート インターフェイスがシスコ ルーテッド ポートとしての動作を停止して、レイヤ2スイッチド インターフェイスに変換されるように設定する例を示します。

Router(config-if)# switchport
Router(config-if)#

) シスコ ルーテッド ポートをサポートしないプラットフォームでは、switchport コマンドを使用できません。このようなプラットフォームのすべての物理ポートは、レイヤ 2 スイッチド インターフェイスと見なされます。


次に、すでにスイッチド インターフェイスとして設定されたポート インターフェイスが、インターフェイス コンフィギュレーション モードで、プラットフォームのデフォルト VLAN ではなく VLAN 2 で動作するように設定する例を示します。

Router(config-if)# switchport access vlan 2
Router(config-if)#

 
関連コマンド

コマンド
説明

show interfaces switchport

スイッチング(非ルーティング)ポートの管理ステータスおよび動作ステータスを表示します。

 

switchport autostate exclude

VLAN インターフェイスのリンクアップ計算からポートを除くには、 switchport autostate exclude コマンドを使用します。デフォルト設定に戻すには、このコマンドの no 形式を使用します。

switchport autostate exclude

no switchport autostate exclude

 
シンタックスの説明

このコマンドには、キーワードまたは引数はありません。

 
コマンドのデフォルト

すべてのポートが VLAN インターフェイスのリンクアップ計算に含まれます。

 
コマンド モード

インターフェイス コンフィギュレーション(config-if)

 
コマンドの履歴

リリース
変更内容

12.2(18)ZY

このコマンドのサポートが追加されました。

 
使用上のガイドライン

LAN インターフェイスをレイヤ 2 インターフェイスとして設定するには、キーワードを指定しないで switchport コマンドを入力してから、さらに switchport autostate exclude コマンドを入力する必要があります。この処理は、インターフェイスに対して switchport コマンドをまだ入力していない場合だけ必要となります。


) シスコ ルーテッド ポートをサポートしないプラットフォームでは、switchport コマンドを使用できません。このようなプラットフォームのすべての物理ポートは、レイヤ 2 スイッチド インターフェイスと見なされます。


PISA 上に設定された VLAN インターフェイスは、関連付けられた VLAN で転送しているポートがある場合に、アップの状態と見なされます。VLAN 上のすべてのポートがダウンまたはブロックしている場合は、PISA 上の VLAN インターフェイスはダウンしていると見なされます。アップの状態と考えられる VLAN インターフェイスについては、VLAN 内のすべてのポートがアップ状態で、転送している必要があります。switchport autostate exclude コマンドを入力すれば、VLAN インターフェイスのリンクアップ計算からポートを除くことができます。

switchport autostate exclude コマンドは、複数のポートが VLAN にある場合に、VLAN インターフェイスのリンクアップ計算から除く ポート をマークします。

show interface interface switchport コマンドは、モードが設定されている場合に、自動ステート モードを表示します。モードが設定されていないと、自動ステート モードが表示されません。

次に、VLAN インターフェイスのリンクアップ計算からポートを除く例を示します。

Router(config-if)# switchport autostate exclude
Router(config-if)#
 

次に、VLAN インターフェイスのリンクアップ計算にポートを加える例を示します。

Router(config-if)# no switchport autostate exclude
Router(config-if)#

 
関連コマンド

コマンド
説明

show interfaces switchport

スイッチング(非ルーティング)ポートの管理ステータスおよび動作ステータスを表示します。

 

switchport backup

Flexlink バックアップ インターフェイスとしてインターフェイスを設定するには、 switchport backup コマンドを使用します。Flexlink をディセーブルにするには、このコマンドの no 形式を使用します。

switchport backup interface interface-type interface-number

no switchport backup interface interface-type interface-number

 
シンタックスの説明

interface interface-type interface-number

Flexlink バックアップ インターフェイスとして設定するインターフェイス タイプ、およびモジュールとポート番号を指定します。

 
コマンドのデフォルト

ディセーブル

 
コマンド モード

インターフェイス コンフィギュレーション(config-if)

 
コマンドの履歴

リリース
変更内容

12.2(18)ZY

このコマンドのサポートが追加されました。

 
使用上のガイドライン

Flexlink をイネーブルにする場合、アクティブ リンクおよびスタンバイ リンクの両方が物理的にアップの状態になり、相互のバックアップが提供されます。

Flexlink はレイヤ 2 インターフェイスだけでサポートされ、ルーテッド ポートをサポートしません。

Flexlink は、復旧後に元のアクティブ インターフェイスに切り替わりません。

interface-number はモジュールおよびポート番号を指定します。有効値は、使用するシャーシおよびモジュールによって異なります。たとえば、13 スロット シャーシに 48 ポート 10/100BASE-T イーサネット モジュールが搭載されている場合、スロット番号の有効値は 1 ~ 13、ポート番号の有効値は 1 ~ 48 です。

Flexlink は、簡易アクセス トポロジー(リーフ ノードからの 2 つのアップリンク)用に設計されています。配線クローゼットとディストリビューション/コア ネットワーク間にループが存在しないようにし、Flexlink が正常に動作するようにする必要があります。

Flexlink は、直接接続されたリンク障害に対してだけ高速コンバージェンスを提供します。他のネットワーク障害は、Flexlink 高速コンバージェンスで改善されません。

LAN インターフェイスをレイヤ 2 インターフェイスとして設定するには、キーワードを指定しないで switchport コマンドを入力してから、さらに switchport autostate exclude コマンドを入力する必要があります。この処理は、インターフェイスに対して switchport コマンドをまだ入力していない場合だけ必要となります。


) シスコ ルーテッド ポートをサポートしないプラットフォームでは、switchport コマンドを使用できません。このようなプラットフォームのすべての物理ポートは、レイヤ 2 スイッチド インターフェイスと見なされます。


次に、インターフェイス上で Flexlink をイネーブルにする例を示します。

Router(config-if)# switchport backup interface fastethernet 4/1
Router(config-if)#
 

次に、インターフェイス上で Flexlink をディセーブルにする例を示します。

Router(config-if)# switchport backup interface fastethernet 4/1
Router(config-if)#

 
関連コマンド

コマンド
説明

show interfaces switchport backup

Flexlink ペアを表示します。

 

switchport block unicast

未知のユニキャスト パケットの転送を禁止するには、 switchport block unicast コマンドを使用します。未知のユニキャスト パケットの転送を許可するには、このコマンドの no 形式を使用します。

switchport block unicast

no switchport block unicast

 
シンタックスの説明

このコマンドには、キーワードまたは引数はありません。

 
コマンドのデフォルト

デフォルト設定は次のとおりです。

未知のユニキャスト トラフィックはブロックされません。

未知のMAC アドレスを持つすべてのトラフィックがすべてのポートに送信されます。

 
コマンドのデフォルト

インターフェイス コンフィギュレーション(config-if)

 
コマンドの履歴

リリース
変更内容

12.2(18)ZY

このコマンドのサポートが追加されました。

 
使用上のガイドライン

スイッチ ポート上で未知のユニキャスト トラフィックをブロックできます。

未知のユニキャスト トラフィックのブロッキングは、スイッチ ポート上で自動的にイネーブルにはなりません。明示的に設定する必要があります。


) パケットのブロッキングの詳細については、『Catalyst Supervisor Engine 32 PISA Cisco IOS Software Configuration GuideムRelease 12.2ZY』を参照してください。


設定を確認するには、 show interfaces interface-id switchport コマンドを入力します。

次に、インターフェイス上で未知のユニキャスト トラフィックをブロックする例を示します。

Router(config-if)# switchport block unicast
Router(config-if)#

 
関連コマンド

コマンド
説明

show interfaces switchport

スイッチング(非ルーティング)ポートの管理ステータスおよび動作ステータスを表示します。

 

switchport capture

VACL でフィルタリングされたトラフィックをキャプチャするようにポートを設定するには、 switchport capture コマンドを使用します。ポート上でキャプチャ モードをディセーブルにするには、このコマンドの no 形式を使用します。

switchport capture

no switchport capture

 
シンタックスの説明

このコマンドには、キーワードまたは引数はありません。

 
コマンドのデフォルト

ディセーブル

 
コマンド モード

インターフェイス コンフィギュレーション(config-if)

 
コマンドの履歴

リリース
変更内容

12.2(18)ZY

このコマンドのサポートが追加されました。

 
使用上のガイドライン

LAN インターフェイスをレイヤ 2 スイッチド インターフェイスとして設定するには、キーワードを指定しないで switchport コマンドを入力してから、キーワードを指定してさらに switchport コマンドを入力する必要があります。この処理は、インターフェイスに対して switchport コマンドをまだ入力していない場合だけ必要となります。

NAM の VACL キャプチャ機能は Supervisor Engine720 上でサポートされますが、IDSM-2 ではサポートされません。

switchport capture コマンドはレイヤ 2 スイッチド インターフェイスだけに適用されます。

WAN インターフェイスは、VACL のキャプチャ機能だけをサポートします。

no switchport コマンドを入力すると、ポートはシャットダウンされてから再びイネーブルになります。この処理により、ポートに接続された装置上でメッセージが生成されることがあります。

switchport capture コマンドを入力するとインターフェイスにキャプチャ機能が設定され、キャプチャ ビットが設定されたパケットがインターフェイスで受信されるようになります。

switchport capture および switchport capture allowed vlan コマンドの入力順に制約はありません。ポートをキャプチャ ポートに設定するには、 switchport capture コマンドを(引数の指定をせずに)入力する必要があります。

キャプチャ ポートでは、キャプチャされたパケットの宛先 VLAN を許可する必要があります。キャプチャ ポートをイネーブルにすると、デフォルトですべての VLAN からのパケットが許可されます。キャプチャ ポートに本来設定されていたモードが解除され、キャプチャ モードからモニタ モードに変わります。モニタ モードでは、キャプチャ ポートは以下のようになります。

以前に属していた VLAN に属しません。

着信トラフィックを許可しません。

トランキング カプセル化が ISL または 802.1Q であった場合に、トランク ポートからキャプチャ ポートをイネーブルにすると、キャプチャ ポートのカプセル化が保護されます。キャプチャされたパケットは、対応するカプセル化タイプによってカプセル化されます。アクセス ポートからキャプチャ ポートをイネーブルにした場合は、キャプチャされたパケットはカプセル化されません。

no switchport capture コマンドを入力してキャプチャ機能をディセーブルにすると、ポートは以前に設定されていたモード(アクセスまたはトランク)に戻ります。

パケットがキャプチャされるのは、宛先 VLAN がキャプチャ ポート上で許可されている場合だけです。

次に、VACL でフィルタリングされたトラフィックをキャプチャするようにインターフェイスを設定する例を示します。

Router(config-if)# switchport capture
Router(config-if)#

 
関連コマンド

コマンド
説明

show interfaces switchport

スイッチング(非ルーティング)ポートの管理ステータスおよび動作ステータスを表示します。

switchport capture allowed vlan

VACL でフィルタリングされたトラフィックの宛先 VLAN を指定します。

 

switchport capture allowed vlan

VACL でフィルタリングされたトラフィックの宛先 VLAN を指定するには、 switchport capture allowed vlan コマンドを使用します。設定された宛先 VLAN リストを消去して、デフォルト設定に戻すには、このコマンドの no 形式を使用します。

switchport capture allowed vlan { add | all | except | remove } vlan-id [ , vlan-id [ , vlan-id [ , ...]]

no switchport capture allowed vlan

 
シンタックスの説明

add

現在のリストに指定された VLAN を追加します。

all

現在のリストにすべての VLAN を追加します。

except

指定された VLAN を除くすべての VLAN を追加します。

remove

現在のリストから指定された VLAN を削除します。

vlan-id

ポートがキャプチャ モードの場合の許可 VLAN の VLAN ID。有効値は 1 ~ 4094 です。

 
コマンドのデフォルト

all

 
コマンド モード

インターフェイス コンフィギュレーション(config-if)

 
コマンドの履歴

リリース
変更内容

12.2(18)ZY

このコマンドのサポートが追加されました。

 
使用上のガイドライン

LAN インターフェイスをレイヤ 2 スイッチド インターフェイスとして設定するには、キーワードを指定しないで switchport コマンドを入力してから、キーワードを指定してさらに switchport コマンドを入力する必要があります。この処理は、インターフェイスに対して switchport コマンドをまだ入力していない場合だけ必要となります。

switchport capture allowed vlan コマンドはレイヤ 2 スイッチド インターフェイスだけに適用されます。

no switchport コマンドを入力すると、ポートはシャットダウンされてから再びイネーブルになります。この処理により、ポートに接続された装置上でメッセージが生成されることがあります。

vlan-id は、単一の VLAN、VLAN グループ、またはその両方として入力できます。たとえば、 switchport capture allowed vlan 1-1000, 2000, 3000-3100 のようになります

switchport capture および switchport capture allowed vlan コマンドの入力順に制約はありません。ポートをキャプチャ ポートに設定するには、 switchport capture コマンドを(引数の指定をせずに)入力する必要があります。

WAN インターフェイスは、VACL のキャプチャ機能だけをサポートします。

次に、指定された VLAN を追加して、VACL でフィルタリングされたトラフィックをキャプチャする例を示します。

Router(config-if)# switchport capture allowed vlan add 100
Router(config-if)#

 
関連コマンド

コマンド
説明

show interfaces switchport

スイッチング(非ルーティング)ポートの管理ステータスおよび動作ステータスを表示します。

 

switchport dot1q ethertype

インターフェイスにプログラミングする EtherType 値を指定するには、 switchport dot1q ethertype コマンドを使用します。デフォルト設定に戻すには、このコマンドの no 形式を使用します。

switchport dot1q ethertype value

 
シンタックスの説明

value

802.1Q カプセル化の EtherType 値。有効値は 0x600 ~ 0xFFFF です。

 
コマンドのデフォルト

value は 0x8100 です。

 
コマンド モード

インターフェイス コンフィギュレーション(config-if)

 
コマンドの履歴

リリース
変更内容

12.2(18)ZY

このコマンドのサポートが追加されました。

 
使用上のガイドライン

カスタム EtherType フィールド値をトランク ポートおよびアクセス ポートで設定できます。

各ポートがサポートする EtherType フィールド値は 1 つだけです。カスタム EtherType フィールド値で設定されたポートは、他の EtherType フィールド値を持つフレームをタグ付きフレームとして認識しません。


注意 カスタム EtherType フィールド値で設定されたポートは、他の EtherType フィールド値を持つフレームをタグなしフレームとして認識します。カスタム EtherType フィールド値で設定されたトランク ポートは、他の EtherType フィールド値でタグ付けされたフレームをネイティブ VLAN 内に入れます。カスタム EtherType フィールド値で設定されたアクセス ポートまたはトンネル ポートは、他の EtherType フィールド値でタグ付けされたフレームをアクセス VLAN 内に入れます。

カスタム EtherType フィールド値は、次のモジュールで設定できます。

スーパーバイザ エンジン

WS-X6516A-GBIC

WS-X6516-GBIC


) WS-X6516A-GBIC および WS-X6516-GBIC モジュールは、設定されたカスタム EtherType フィールド値を、各ポート ASIC によりサポートされるすべてのポートに適用します(1 ~ 8 および 9 ~ 16)。


WS-X6516-GE-TX

カスタム EtherType フィールド値は、EtherChannel 内のポートでは設定できません。

EtherChannel は、カスタム EtherType フィールド値で設定されたポートから構成することはできません。

次に、インターフェイスでプログラミングされる EtherType 値を設定する例を示します。

Router (config-if)# switchport dot1q ethertype 1234
Router (config-if)#

 
関連コマンド

コマンド
説明

show interfaces switchport

スイッチング(非ルーティング)ポートの管理ステータスおよび動作ステータスを表示します。

 

switchport mode

インターフェイス タイプを設定するには、 switchport mode コマンドを使用します。モードを、デバイスに適したデフォルト モードにリセットするには、このコマンドの no 形式を使用します。

switchport mode { access | trunk | { dynamic { auto | desirable }} | dot1q-tunnel }

switchport mode private-vlan { host | promiscuous }

no switchport mode

no switchport mode private-vlan

 
シンタックスの説明

access

単一の非トランキング、タグなし VLAN レイヤ 2 インターフェイスを指定します。

trunk

レイヤ 2 のトランキング VLAN インターフェイスを指定します。

dynamic auto

リンクからトランク リンクに変換されるインターフェイスを指定します。

dynamic desirable

リンクからトランク リンクへの変換を積極的に試行するインターフェイスを指定します。

dot1q-tunnel

802.1Q トンネリング インターフェイスを指定します。

private-vlan host

アクティブ ホストの PVLAN ポートになる PVLAN とのアソシエーションが有効であるポートを指定します。

private-vlan promiscuous

アクティブ混合モード ポートになる PVLAN とのマッピングが有効であるポートを指定します。

 
コマンドのデフォルト

デフォルト設定は次のとおりです。

モードはプラットフォームごとに異なります。配線クローゼット用のプラットフォームでは dynamic auto に、バックボーン スイッチ用のプラットフォームでは dynamic desirable になります。

PVLAN ポートに設定されたモードはありません。

 
コマンド モード

インターフェイス コンフィギュレーション(config-if)

 
コマンドの履歴

リリース
変更内容

12.2(18)ZY

このコマンドのサポートが追加されました。

 
使用上のガイドライン

access モードを開始した場合、インターフェイスは永続的な非トランキング モードになり、近接インターフェイスがリンクから非トランク リンクへの変換に合意しない場合でも、この変換を行うようにネゴシエートします。

trunk モードを開始した場合、インターフェイスは永続的なトランキング モードになり、近接インターフェイスがリンクからトランク リンクへの変換に合意しない場合でも、この変換を行うようにネゴシエートします。

dynamic auto モードを開始した場合に、近接インターフェイスが trunk または desirable モードに設定されると、インターフェイスはリンクをトランク リンクに変換します。

dynamic desirable モードを開始した場合に、近接インターフェイスが trunk desirable 、または auto モードに設定されると、インターフェイスはトランク インターフェイスになります。

ポートが混合モード ポートまたはホスト PVLAN ポートとして設定されていて、次のいずれかの条件が適用される場合、ポートは非アクティブになります。

ポートに PVLAN との有効なアソシエーションがない、またはマッピングが設定されていない。

ポートが SPAN 宛先である。

プライベート ポートの PVLAN とのアソシエーションまたはマッピングを削除するか、またはプライベート ポートを SPAN 宛先として設定した場合、削除されたプライベート ポートの PVLAN とのアソシエーションやマッピング、または SPAN 宛先として設定されたプライベート ポートは非アクティブになります。

dot1q-tunnel モードを開始した場合、プロトコル トンネリング インターフェイス上で BPDU フィルタリングがイネーブルになり、CDP がディセーブルになります。

次に、インターフェイスを dynamic desirable モードに設定する例を示します。

Router(config-if)# switchport mode dynamic desirable
Router(config-if)#
 

次に、ポートを PVLAN ホスト モードに設定する例を示します。

Router(config-if)# switchport mode private-vlan host
Router(config-if)#
 

次に、ポートを PVLAN 混合 モードに設定する例を示します。

Router(config-if)# switchport mode private-vlan promiscuous
Router(config-if)#

 
関連コマンド

コマンド
説明

show dot1q-tunnel

802.1Q トンネル対応ポートのリストを表示します。

show interfaces switchport

スイッチング(非ルーティング)ポートの管理ステータスおよび動作ステータスを表示します。

switchport

レイヤ 2 スイッチド インターフェイスのスイッチング特性を変更します。

switchport private-vlan host-association

レイヤ 2 スイッチド インターフェイスのスイッチング特性を変更します。

switchport private-vlan mapping

混合モード ポートの PVLAN マッピングを定義します。

 

switchport port-security

ポート セキュリティをインターフェイスでイネーブルにするには、 switchport port-security コマンドを使用します。 ポート セキュリティをディセーブルにするには、このコマンドの no 形式を使用します。

switchport port-security

no switchport port-security

 
シンタックスの説明

このコマンドには、キーワードまたは引数はありません。

 
コマンドのデフォルト

ディセーブル

 
コマンド モード

インターフェイス コンフィギュレーション(config-if)

 
コマンドの履歴

リリース
変更内容

12.2(18)ZY

このコマンドのサポートが追加されました。

 
使用上のガイドライン

ポート セキュリティを設定する場合は、次の注意事項に従ってください。

ポート セキュリティはトランク上でサポートされています。

ポート セキュリティは 802.1Q トンネル ポート上でサポートされています。

セキュア ポートは、Switched Port Analyzer(SPAN; スイッチド ポート アナライザ)の宛先ポートにできません。

セキュア ポートは、EtherChannel に所属できません。

セキュア ポートはトランク ポートにできません。

セキュア ポートは、802.1X ポートにできません。セキュア ポートで 802.1X をイネーブルにしようとすると、エラー メッセージが表示され、802.1X はイネーブルになりません。802.1X 対応ポートをセキュア ポートに変更しようとすると、エラー メッセージが表示され、セキュリティ設定は変更されません。

次に、ポート セキュリティをイネーブルにする例を示します。

Router(config-if)# switchport port-security
Router(config-if)#
 

次に、ポート セキュリティをディセーブルにする例を示します。

Router(config-if)# no switchport port-security
Router(config-if)#

 
関連コマンド

コマンド
説明

show port-security

ポート セキュリティ設定に関する情報を表示します。

 

switchport port-security aging

ポート セキュリティ エージングを設定するには、 switchport port-security aging コマンドを使用します。エージングをディセーブルにする には、このコマンドの no 形式を使用します

switchport port-security aging {{ time time } | { type { absolute | inactivity }}}

 
シンタックスの説明

time time

すべてのアドレスが保護される期間を 設定します。 有効値は 1 ~ 1440 分です。

type

エージングのタイプを指定します。

absolute

絶対エージングを指定します。詳細については、「使用上のガイドライン」を参照してください。

inactivity

トラフィックがないときだけタイマーの実行を開始することを指定します。詳細については、「使用上のガイドライン」を参照してください。

 
コマンドのデフォルト

デフォルト設定は次のとおりです。

ディセーブル

イネーブルの場合、 デフォルトは次のとおりです。

time は 0 です。

type absolute です

 
コマンドのデフォルト

インターフェイス コンフィギュレーション(config-if)

 
コマンドの履歴

リリース
変更内容

12.2(18)ZY

このコマンドのサポートが追加されました。

 
使用上のガイドライン

ポート セキュリティを設定する場合は、次の注意事項に従ってください。

ポート セキュリティはトランク上でサポートされています。

ポート セキュリティは 802.1Q トンネル ポート上でサポートされています。

セキュア ポート上で自動的に学習されたアドレスについては、2 つのタイプのエージングのいずれかを適用できます。

絶対エージングでは、トラフィック パターンに関係なく、エージング タイムを超えると MAC アドレスがタイムアウトになります。このデフォルトはすべてのセキュア ポートに適用され、エージング タイムは 0 に設定されます。

非アクティビティ エージングでは、対応するホストからの非アクティビティがエージング タイムを超えると、MAC アドレスがタイムアウトになります。

次に、エージング タイムを 2 時間に設定する例を示します。

Router(config-if)# switchport port-security aging time 120
Router(config-if)#
 

次に、エージング タイムを 2 分に設定する例を示します。

Router(config-if)# switchport port-security aging time 2
Router(config-if)#
 

次に、ポートのエージング タイプを絶対エージングに設定する例を示します。

Router(config-if) switchport port-security aging type absolute
Router(config-if)#
 

次に、ポートのエージング タイプを非アクティビティに設定する例を示します。

Router(config-if) switchport port-security aging type inactivity
Router(config-if)#

 
関連コマンド

コマンド
説明

show port-security

ポート セキュリティ設定に関する情報を表示します。

 

switchport port-security mac-address

セキュア MAC アドレスのリストに MAC アドレスを追加するには、 switchport port-security mac-address コマンドを使用します。セキュア MAC アドレス リストから MAC アドレスを削除するには、このコマンドの no 形式を使用します。

switchport port-security mac- address { mac-addr | { sticky [ mac-addr ]} [ vlan vlan | vlan-list | { voice | access }]}

no switchport port-security mac- address { mac-addr | { sticky [ mac-addr ]} [ vlan vlan | vlan-list | { voice | access }]}

 
シンタックスの説明

mac-addr

インターフェイスの MAC アドレス。有効値は 1 ~ 1024 です。

sticky

インターフェイス上でダイナミック MAC アドレスをスティッキとして設定します。

vlan vlan | vlan-list

(任意)VLAN または VLAN の範囲を指定します。詳細については、「使用上のガイドライン」を参照してください。

access

(任意)アクセス VLAN の MAC アドレスを構成します。

voice

(任意)音声 VLAN の MAC アドレスを構成します。

 
デフォルト

このコマンドにはデフォルト設定がありません

 
コマンド モード

インターフェイス コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

12.2(18)ZY

このコマンドのサポートが追加されました。

12.2(18)ZYA1

access キーワードおよび voice キーワードが追加されました。

 
使用上のガイドライン

すべてのインターフェイスのセキュア MAC アドレスの最大数より少ないセキュア MAC アドレスを設定した場合、残りの MAC アドレスはダイナミックに学習されます。

複数の MAC アドレスを削除するには、削除する MAC アドレスごとに、このコマンドの no 形式を 1 回ずつ入力する必要があります。

vlan-list 引数は、ポートが設定され、トランクとして動作可能な場合だけ使用できます。 switchport mode trunk コマンドを入力してから、 switchport nonegotiate コマンドを入力してください。

sticky キーワードは、インターフェイス上でダイナミック MAC アドレスをスティッキとして設定します。スティッキ MAC アドレスは、スタティック レイヤ 2 エントリを特定のインターフェイスに固定されるように設定します。この機能により、MAC の移動を防止したり、エントリが別のインターフェイスで学習されるのを防いだりすることができます。

インターフェイス上でポート セキュリティ機能がイネーブルになっていないときでも、スティッキ機能を設定することができます。インターフェイス上でポート セキュリティがイネーブルになると動作可能になります。


switchport port-security mac-address sticky コマンドは、インターフェイス上でスティッキ機能がイネーブルになっている場合だけ入力することができます。


ポート セキュリティがイネーブルのとき、スティッキ機能をディセーブルにすると、設定済みの学習されたスティッキ アドレスのすべてが設定から削除されて、ダイナミック セキュア アドレスに変換されます。

ポート セキュリティがディセーブルのとき、スティッキ機能をディセーブルにすると、設定済みの学習されたスティッキ アドレスのすべてが設定から削除されます。

Cisco IOS Release 12.2(18)ZYA1 では、 access キーワードおよび voice キーワード導入されており、ポートが構成されている場合で、アクセス ポートとして動作可能な場合だけに、使用可能です。

次に、セキュア MAC アドレスを設定する例を示します。

Router(config-if)# switchport port-security mac-address 1000.2000.3000
 

次に、アドレス テーブルからセキュア MAC アドレスを削除する例を示します。

Router(config-if)# no switchport port-security mac-address 1000.2000.3000
 

次に、Cisco IOS Release 12.2(18)ZYA1 において、音声 VLAN でセキュア MAC アドレスを設定する例を示します。

Router(config-if)# switchport port-security mac-address 1000.2000.3000 vlan voice
 

次に、インターフェイスでスティッキ機能をイネーブルにする例を示します。

Router(config-if)# switchport port-security mac-address sticky
 

次に、インターフェイスでスティッキ機能をディセーブルにする例を示します。

Router(config-if)# no switchport port-security mac-address sticky
 

次に、特定の MAC アドレスをスティッキ アドレスにする例を示します。

Router(config-if)# switchport port-security mac-address sticky 0000.0000.0001
 

次に、特定のスティッキ アドレスを削除する例を示します。

Router(config-if)# no switchport port-security mac-address sticky 0000.0000.0001
 

次に、インターフェイスに設定されているすべてのスティッキ アドレスとスタティック アドレスを削除する例を示します。

Router(config-if)# no switchport port-security mac-address

 
関連コマンド

コマンド
説明

clear port-security

MAC アドレス テーブルからセキュア MAC アドレスおよびスティッキ MAC アドレスを削除します。

show port-security

ポート セキュリティ設定に関する情報を表示します。

switchport mode trunk

ポートをトランク メンバー として設定します。

switchport nonegotiate

LAN ポートを永続的なトランキング モード として設定します。

switchport port-security maximum

ポート上のセキュア MAC アドレスの最大数を設定するには、 switchport port-security maximum コマンドを使用します。デフォルト設定に戻すには、このコマンドの no 形式を使用します。

switchport port-security maximum maximum [ vlan vlan | vlan-list ]

no switchport port-security maximum

 
シンタックスの説明

maximum

インターフェイスのセキュア MAC アドレスの最大数を指定します。有効値は 1 ~ 4097 です。

vlan vlan | vlan-list

(任意)VLAN または VLAN の範囲を指定します。詳細については、「使用上のガイドライン」を参照してください。

 
コマンドのデフォルト

vlan 1 です

 
コマンド モード

インターフェイス コンフィギュレーション(config-if)

 
コマンドの履歴

リリース
変更内容

12.2(18)ZY

このコマンドのサポートが追加されました。

 
使用上のガイドライン

このコマンドを複数回入力した場合は、2 回め以降の入力によって以前の maximum の値が上書きされます。新しい maximum 引数がこのポートの現在のセキュア アドレス数よりも大きい場合、 maximum 値が単に増加するだけです。

新しい maximum が元の maximum よりも小さく、元の maximum 上により多くのセキュア アドレスが存在する場合、コマンドは拒否されます。

ポートのセキュア MAC アドレスの最大数より少ないセキュア MAC アドレスを設定した場合、残りの MAC アドレスはダイナミックに学習されます。

ポートのセキュア MAC アドレスが最大数に達すると、VLAN ポート単位の最大数が集約最大数と違う場合でも、そのポートではそれ以上のアドレスは学習されません。

特定の VLAN について、ポートのセキュア MAC アドレスの最大数を上書きするには、 switchport port-security maximum maximum vlan vlan | vlan-list コマンドを入力します。

vlan-list 引数には、1,7,9-15,17 など、範囲、カンマ、および区切られたエントリを入力できます。

vlan-list 引数は、ポートが設定され、トランクとして動作可能な場合だけ使用できます。 switchport mode trunk コマンドを入力してから、 switchport nonegotiate コマンドを入力してください。

次に、このポートで許可されているセキュア MAC アドレスの最大数を設定する例を示します。

Router(config-if)# switchport port-security maximum 5
Router(config-if)#
 

次に、特定の VLAN について設定されている最大数を上書きするコマンドの例を示します。

Router(config-if)# switchport port-security maximum 3 vlan 102
Router(config-if)#

 
関連コマンド

コマンド
説明

show port-security

ポート セキュリティ設定に関する情報を表示します。

 

switchport port-security violation

セキュリティ違反が検出された場合に行うアクションを設定するには、 switchport port-security violation コマンドを使用します。デフォルト設定に戻すには、このコマンドの no 形式を使用します。

switchport port-security violation { shutdown | restrict | protect }

 
シンタックスの説明

shutdown

セキュリティ違反がある場合、ポートをシャットダウンします。

restrict

ポート セキュリティ プロセス レベルの非セキュア ホストからのすべてのパケットを廃棄して、セキュリティ違反数を増加させます。

protect

ポート セキュリティ プロセス レベルの非セキュア ホストからのすべてのパケットを廃棄しますが、セキュリティ違反数は増加させません。

 
コマンドのデフォルト

shutdown

 
コマンド モード

インターフェイス コンフィギュレーション(config-if)

 
コマンドの履歴

リリース
変更内容

12.2(18)ZY

このコマンドのサポートが追加されました。

 
使用上のガイドライン

ポート セキュリティ違反は、次のいずれかの理由で発生します。

インターフェイスが認識している送信元 MAC アドレスの数がポート セキュリティの制限を超えている場合

1 つのポートの送信元 MAC セキュア アドレスが別のセキュア ポートに表示される場合。この状況では、restrict/protect モードでソフトウェアが違反トラフィックにヒットするため、違反が発生します。 mls rate-limit layer2 port-security コマンドを使用して、この状態からソフトウェアを保護できます。

セキュリティ違反が検出されると、次のアクションのいずれかが発生します。

protect:ポートのセキュア MAC アドレスの数がポートで許可されている最大限度に達すると、十分な数のセキュア MAC アドレスを削除しない限り、送信元が不明なアドレスを持つパケットは廃棄されます。

restrict:ポートのセキュリティ違反が発生すると、データが制限され、SecurityViolation カウンタの値が増加します。

shutdown:セキュリティ違反が発生すると、インターフェイスが errdisable になります。


) セキュア ポートが errdisable ステートの場合、errdisable recovery cause psecure-violation グローバル コンフィギュレーション コマンドを入力してこのステートを解除したり、shutdown および no shutdown コマンドをインターフェイス コンフィギュレーション モードで入力して手動で再イネーブル化したりすることができます。


次に、セキュリティ違反が検出された場合に実行するアクションを設定する例を示します。

Router(config-if)# switchport port-security violation restrict
Router(config-if)#

 
関連コマンド

コマンド
説明

show port-security

ポート セキュリティ設定に関する情報を表示します。

 

switchport private-vlan host-association

隔離ポートまたはコミュニティ ポートの PVLAN アソシエーションを定義するには、 switchport private-vlan host-association コマンドを使用します。ポートから PVLAN マッピングを削除するには、このコマンドの no 形式を使用します。

switchport private-vlan host-association { primary-vlan-id } { secondary-vlan-id }

no switchport private-vlan host-association

 
シンタックスの説明

primary-vlan-id

PVLAN 関係におけるプライマリ VLAN の番号を指定します。有効値は 1 ~ 4094 です。

secondary-vlan-id

PVLAN 関係におけるセカンダリ VLAN の番号を指定します。有効値は 1 ~ 4094 です。

 
コマンドのデフォルト

PVLAN は設定されていません。

 
コマンド モード

インターフェイス コンフィギュレーション(config-if)

 
コマンドの履歴

リリース
変更内容

12.2(18)ZY

このコマンドのサポートが追加されました。

 
使用上のガイドライン

PVLAN ホスト モードでないポート上では、実行しても効果がありません。ポートが PVLAN ホスト モードであっても VLAN が存在しない場合は、コマンドを使用できますが、このポートは非アクティブになります。

セカンダリ VLAN は隔離またはコミュニティ VLAN になる場合があります。

次に、プライマリ VLAN(VLAN 18)およびセカンダリ VLAN(VLAN 20)をポートに設定する例を示します。

Router(config-if)# switchport private-vlan host-association 18 20
Router(config-if)#
 

次に、ポートから PVLAN アソシエーションを削除する例を示します。

Router(config-if)# no switchport private-vlan host-association
Router(config-if)#

 
関連コマンド

コマンド
説明

show interfaces switchport

スイッチング(非ルーティング)ポートの管理ステータスおよび動作ステータスを表示します。

switchport mode

このコマンドのインターフェイス タイプを設定します。

 

switchport private-vlan mapping

混合モード ポートの PVLAN マッピングを定義するには、 switchport private-vlan mapping コマンドを使用します。プライマリ VLAN からすべてのマッピングを削除するには、このコマンドの no 形式を使用します。

switchport private-vlan mapping { primary-vlan-id } { secondary-vlan-list } | { add secondary-vlan-list } | { remove secondary-vlan-list }

no switchport private-vlan mapping

 
シンタックスの説明

primary-vlan-id

PVLAN 関係におけるプライマリ VLAN の番号を指定します。有効値は 1 ~ 4094 です。

secondary-vlan-id

PVLAN 関係におけるセカンダリ VLAN の番号を指定します。有効値は 1 ~ 4094 です。

add

セカンダリ VLAN をプライマリ VLAN にマッピングします。

remove

セカンダリ VLAN とプライマリ VLAN のマッピングを消去します。

 
コマンドのデフォルト

PVLAN マッピングは設定されていません。

 
コマンド モード

インターフェイス コンフィギュレーション(config-if)

 
コマンドの履歴

リリース
変更内容

12.2(18)ZY

このコマンドのサポートが追加されました。

 
使用上のガイドライン

PVLAN 混合 モードでないポート上では、実行しても効果がありません。ポートが PVLAN 混合 モードであっても VLAN が存在しない場合は、コマンドを使用できますが、このポートは非アクティブになります。

セカンダリ VLAN は隔離またはコミュニティ VLAN になる場合があります。

次に、プライマリ VLAN 18 とセカンダリ隔離 VLAN 20 のマッピングをポートに設定する例を示します。

Router(config-if)# switchport private-vlan mapping 18 20
Router(config-if)#
 

次に、マッピングに VLAN を追加する例を示します。

Router(config-if)# switchport private-vlan mapping 18 add 21
Router(config-if)#
 

次に、ポートから PVLAN マッピングを削除する例を示します。

Router(config-if)# no switchport private-vlan mapping

Router(config-if)#

 
関連コマンド

コマンド
説明

show interfaces private-vlan mapping

VLAN SVI の PVLAN マッピングに関する情報を表示します。

 

switchport trunk

インターフェイスがトランキング モードの場合にトランクの特性を設定するには、 switchport trunk コマンドを使用します。すべてのトランキング特性をデフォルトに戻すには、このコマンドの no 形式を使用します。

switchport trunk encapsulation { isl | { dot1q [ ethertype value ]} | negotiate }

switchport trunk native vlan vlan-id

switchport trunk allowed vlan vlan-list

switchport trunk pruning vlan vlan-list

no switchport trunk { encapsulation { isl | dot1q | negotiate }} | { native vlan } | { allowed vlan } | { pruning vlan }

 
シンタックスの説明

encapsulation isl

トランクのカプセル化形式を ISL に設定します。

encapsulation dot1q

スイッチ ポートのカプセル化形式を 802.1Q に設定します。

ethertype value

EtherType 値を設定します。有効値は 0x0~0x5EF-0xFFFF です。

encapsulation negotiate

DISL および DTP ネゴシエーションでカプセル化形式が解決されない場合に、ISL がカプセル化形式として選択されるように指定します。

native vlan vlan-id

ネイティブ VLAN を 802.1Q トランキング モードでトランク用に設定します。有効値は 1 ~ 4094 です。

allowed vlan vlan-list

トランキング モードにおいて、このインターフェイスをタグ付きフォーマットで伝送する許可 VLAN です。有効値は 1 ~ 4094 です。

pruning vlan vlan-list

トランキング モードにおいて、VTP プルーニング用にイネーブル化される VLAN のリストです。有効値は 1~ 4094 です。

 
コマンドのデフォルト

デフォルト設定は次のとおりです。

カプセル化タイプは、プラットフォームまたはインターフェイス ハードウェアによって決まります。

アクセス VLAN およびトランク インターフェイス ネイティブ VLAN が、プラットフォームまたはインターフェイス ハードウェアに対応するデフォルト VLAN です。

すべての VLAN リストは VLAN をすべて含みます。

802.1Q カプセル化用の ethertype value は 0x8100 です。

 
コマンドのデフォルト

インターフェイス コンフィギュレーション(config-if)

 
コマンドの履歴

リリース
変更内容

12.2(18)ZY

このコマンドのサポートが追加されました。

 
使用上のガイドライン

このコマンドは、GE レイヤ 2 WAN ポートではサポートされていません。

switchport trunk encapsulation コマンドがサポートされるのは、ISL と 802.1Q の両方の形式をサポートするプラットフォームおよびインターフェイス ハードウェアに対してだけです。

switchport trunk encapsulation isl コマンドを、ISL トランク カプセル化をサポートしないインターフェイスを含むポート チャネルで入力した場合、コマンドは拒否されます。

SPAN 宛先ポートがトランクまたはアクセス ポートであるインターフェイスで switchport trunk allowed vlan コマンドを入力できます。


switchport trunk pruning vlan vlan-list コマンドは拡張範囲 VLAN をサポートしません。vlan-list の有効値は 1 ~ 1005 です。


dot1q ethertype value キーワードおよび引数は、ポート チャネル インターフェイスではサポートされていません。このコマンドは、個々のポート インターフェイスだけで実行できます。また、チャネル グループ内のポートは、異なる EtherType 設定を持つように設定できます。


注意 カスタム EtherType 値をポートで設定する場合は注意が必要です。negotiate キーワードを入力した場合、DISL および DTP ネゴシエーションでカプセル化形式が解決されなければ、ISL がカプセル化形式として選択され、セキュリティ リスクが生じることがあります。トランクのカプセル化形式をデフォルトにリセットするには、このコマンドの no 形式を使用します。

ネイティブ モード VLAN を装置に適したデフォルト VLAN にリセットするには、 native vlan コマンドの no 形式を使用します。

リストをデフォルト リスト(すべての VLAN を許可)にリセットするには、 allowed vlan コマンドの no 形式を使用します。

リストをデフォルト リスト(すべての VLAN に VTP プルーニングを許可)にリセットするには、 pruning vlan コマンドの no 形式を使用します。

dot1q ethertype value コマンドの no 形式は、リストをデフォルト値にリセットします。

vlan- list の形式は、 all | none | add | remove | except vlan- list [ , vlan- list... ] です(以下を参照)。

all:適切な VLAN をすべて指定します。このキーワードは、 switchport trunk pruning vlan コマンドではサポートされません。

none:空のリストを意味します。このキーワードは、 switchport trunk allowed vlan コマンドではサポートされません。

add:現在設定されている VLAN リストを置き換えないで、定義済み VLAN リストを追加します。

remove:現在設定されている VLAN リストを置き換えないで、リストから定義済み VLAN リストを削除します。VLAN 1 は削除できます。トランクから VLAN 1 を削除した場合も、トランク インターフェイスは VLAN 1 の管理トラフィック(CDP3、VTP、PAgP4、DTP など)の送受信を継続します。


) トランクから任意のデフォルト VLAN(1002 ~ 1005)を削除できます。この処理は以前のリリースでは実行できません。


except:定義済み VLAN リストを反転して、計算する必要がある VLAN を一覧表示します。

vlan- list は、 1 ~ 4094 の単一の VLAN 番号、または 2 つの VLAN 番号で表される連続した VLAN 範囲です。小さい番号をハイフンで区切って最初に置きます。これは、このポートがトランキング モードにある場合の許可 VLAN の VLAN ID を表します。

スーパーバイザ エンジンと PISA の両方で Cisco IOS ソフトウェアが実行されている Catalyst 6500 シリーズ スイッチを、Catalyst オペレーティング システムが実行されている Catalyst 6500 シリーズ スイッチに接続する場合は、トランク上で予約されている VLAN 範囲(1006 ~ 1024)をイネーブルにしないでください。これらの VLAN は、Catalyst オペレーティング システムを実行する Catalyst 6500 シリーズ スイッチ専用です。これらをイネーブルにすると、Catalyst オペレーティング システムを実行する Catalyst 6500 シリーズ スイッチ間にトランキング チャネルが存在する場合に、ポートが errdisable ステートになる場合があります。

次に、スイッチド インターフェイスとして設定されたポート インターフェイスが、トランキング モードのデフォルトのトランキング形式に関係なく、802.1Q トランキング形式でカプセル化されるように設定する例を示します。

Router(config-if)# switchport trunk encapsulation dot1q
Router(config-if)#

 
関連コマンド

コマンド
説明

show interfaces switchport

スイッチング(非ルーティング)ポートの管理ステータスおよび動作ステータスを表示します。

 

switchport vlan mapping

VLAN original-vlan-id に着信するトラフィックを VLAN translated-vlan-id にマッピングし、内部的に VLAN translated-vlan-id でタグ付けされたトラフィックに、ポートから出力される前に VLAN original-vlan-id でタグ付けするには、 switchport vlan mapping コマンドを使用します。VLAN ペアのマッピングをクリアしたり、スイッチ ポートに設定されているすべてのマッピングをクリアしたりするには、このコマンドの no 形式を使用します。

switchport vlan mapping original-vlan-id translated-vlan-id

no switchport vlan mapping {{ original-vlan-id translated-vlan-id } | all }

 
シンタックスの説明

original-vlan-id

変換前の VLAN 番号。有効値は 1~4094 です。

translated-vlan-id

変換後の VLAN 番号。有効値は 1~4094 です。

all

スイッチ ポートに設定されているすべてのマッピングをクリアします。

 
コマンドのデフォルト

スイッチ ポートにはマッピングが設定されていません。

 
コマンド モード

インターフェイス コンフィギュレーション(config-if)

 
コマンドの履歴

リリース
変更内容

12.2(18)ZY

このコマンドのサポートが追加されました。

 
使用上のガイドライン

このコマンドは、GE レイヤ 2 WAN ポートではサポートされていません。

VLAN 変換を機能させたい場合は、ポートの VLAN 変換をイネーブルにする必要があります。VLAN 変換をイネーブルにするには、 switchport vlan mapping enable コマンドを使用します。

トランクから変換される VLAN を削除しないでください。VLAN をマッピングする場合、両方の VLAN がトラフィックを伝送するトランクで許可されていることを確認します。

表 2-95 に、VLAN 変換、サポートする VLAN 変換のタイプ、ポート グループ単位で設定可能なポート数、VLAN 変換をサポートする各モジュールでのトランク タイプを一覧表示します。

 

表 2-95 VLAN 変換をサポートするモジュール

製品番号
VLAN 変換サポート タイプ
ポート グループ数
ポート グループ単位のポート範囲
ポート グループ単位の変換数
サポートする VLAN 変換トランク タイプ

WS-SUP720

ポート グループ単位

1

1-2

32

802.1Q

WS-X6501-10GEX4

ポート単位

1

1 グループ内に 1 ポート

32

802.1Q

WS-X6502-10GE

ポート単位

1

1 グループ内に 1 ポート

32

802.1Q

WS-X6516A-GBIC

ポート グループ単位

2

1-8, 9-16

32

802.1Q

WS-X6516-GBIC

ポート グループ単位

2

1-8, 9-16

32

802.1Q

WS-X6516-GE-TX

ポート グループ単位

2

1-8, 9-16

32

802.1Q

WS-X6524-100FX-MM

ポート グループ単位

1

1-24

32

ISL および 802.1Q

WS-X6548-RJ-45

ポート グループ単位

1

1-48

32

ISL および 802.1Q

WS-X6548-RJ-21

ポート グループ単位

1

1-48

32

ISL および 802.1Q

switchport vlan mapping コマンドを使用して設定されたマッピングは、スイッチ ポートが動作トランク ポートになるまで有効になりません。

ポートに設定された VLAN マッピングは、同一 ASIC にある他のすべてのポートに適用されます。場合によっては、ASIC のあるポートに設定されたマッピングが同一 ASIC 内にある別のポートに設定済みのマッピングを上書きする場合があります。

ポート VLAN マッピングは、ASIC がポート単位の VLAN マッピングをサポートしない場合、ポート ASIC のすべてのポートに適用されます。

ルータ ポートであるポート ASIC の VLAN マッピングを設定した場合、ポートがスイッチ ポートになるまでポート VLAN マッピングは有効になりません。

VLAN を伝送するトランク タイプにかかわらず、2 つの VLAN をマッピングできます。

次に、変換前の VLAN に変換後の VLAN をマッピングする例を示します。

Router(config-if)# switchport vlan mapping 100 201
Router(config-if)#
 

次に、VLAN ペア間のマッピングをクリアする例を示します。

Router(config-if)# no switchport vlan mapping 100 201
Router(config-if)#
 

次に、スイッチ ポートに設定されているすべてのマッピングをクリアする例を示します。

Router(config-if)# no switchport vlan mapping 100 201
Router(config-if)#

 
関連コマンド

コマンド
説明

show interfaces vlan mapping

ポート上の VLAN マッピングのステータスを表示します。

show vlan mapping

802.1Q VLAN と ISL VLAN のマッピングを登録します。

switchport vlan mapping enable

スイッチ ポート単位で VLAN マッピングをイネーブルにします。

 

switchport vlan mapping enable

スイッチ ポート単位で VLAN マッピングをイネーブルにするには、 switchport vlan mapping enable コマンドを使用します。スイッチ ポート単位の VLAN マッピングをディセーブルにするには、このコマンドの no 形式を使用します。

switchport vlan mapping enable

no switchport vlan mapping enable

 
コマンドのデフォルト

VLAN マッピングはすべてのスイッチ ポートでディセーブルです。

 
コマンドのデフォルト

インターフェイス コンフィギュレーション(config-if)

 
コマンドの履歴

リリース
変更内容

12.2(18)ZY

このコマンドのサポートが追加されました。

 
使用上のガイドライン


) マッピングを実行させるポートに、switchport vlan mapping enable コマンドを入力する必要があります。


このコマンドをサポートするモジュールのリストについては、 表 2-95 を参照してください。

マッピングがグローバル VLAN マッピング コマンドで設定されているか、スイッチポート VLAN マッピング コマンドで設定されているかにかかわらず、switchport vlan mapping enable コマンドは、ハードウェアの VLAN マッピング ルックアップをイネーブルまたはディセーブルにします。

同じポート ASIC に接続されているポート上で選択的に VLAN 変換をオンまたはオフにできるため、このコマンドは、ASIC 単位で VLAN マッピングをサポートしているハードウェアだけで役に立ちます。

次に、スイッチ ポート単位で VLAN マッピングをイネーブルにする例を示します。

Router(config-if)# switchport vlan mapping enable
Router(config-if)#
 

次に、スイッチ ポート単位で VLAN マッピングをディセーブルにする例を示します。

Router(config-if)# no switchport vlan mapping enable
Router(config-if)#

 
関連コマンド

コマンド
説明

show interfaces vlan mapping

ポート上の VLAN マッピングのステータスを表示します。

show vlan mapping

802.1Q VLAN と ISL VLAN のマッピングを登録します。

switchport vlan mapping

VLAN original-vlan-id に着信するトラフィックを VLAN translated-vlan-id にマッピングし、内部的に VLAN translated-vlan-id でタグ付けされたトラフィックに、ポートから出力される前に VLAN original-vlan-id でタグ付けします。

 

switchport voice vlan

複数の VLAN アクセス ポートに音声 VLAN を設定するには、 switchport voice vlan コマンドを使用します。スイッチ ポートから音声 VLAN を削除するには、このコマンドの no 形式を使用します。

switchport voice vlan { dot1p | none | untagged | vvid }

no switchport voice vlan

 
シンタックスの説明

dot1p

レイヤ 2 CoS 値がタグ付けされた 802.1p フレームに音声トラフィックを格納して、デフォルト VLAN 内で伝送するように IP 電話を設定する CDP パケットを送信します。

none

IP 電話がデフォルト VLAN 内で独自の設定を使用し、タグなし音声トラフィックを伝送できるようにします。

untagged

デフォルト VLAN 内でタグなし音声トラフィックを伝送するように IP 電話を設定する CDP パケットを送信します。

vvid

音声 VLAN ID。有効値は 1 ~ 4094 です。レイヤ 2 CoS 値がタグ付けされた 802.1Q フレームに音声トラフィックを格納して、音声 VLAN 内で伝送するように IP 電話を設定する CDP パケットを送信します

 
コマンド モード

none

 
コマンド モード

インターフェイス コンフィギュレーション(config-if)

 
コマンドの履歴

リリース
変更内容

12.2(18)ZY

このコマンドのサポートが追加されました。

 
使用上のガイドライン

デフォルトの レイヤ 2 CoS は 5 です。デフォルトのレイヤ 3 IP precedence は 5 です。

このコマンドは、音声VLANを作成しません。VLAN コンフィギュレーション モードで音声 VLAN を作成するには、 vlan (global configuration mode) コマンドを入力します。VLAN データベースにネイティブ VLAN と音声 VLAN を両方とも設定して、スイッチ ポートを複数の VLAN アクセス モードに設定すると、このコマンドはスイッチ ポートを動作上の起動状態にします。

dot1p を 入力した場合 、スイッチ ポートは 802.1p パケットだけを受信できます。

none を 入力した場合 、スイッチ ポートは VVID TLV を含む CDP パケットを送信しません。

untagged 入力した場合 、スイッチ ポートはタグなしパケットだけを受信できます。

vvid 入力すると 、スイッチ ポートは指定された vvid がタグ付けされたパケットを受信します。

次に、動作する複数の VLAN アクセス ポートを作成する例を示します。

Router(config-if)# switchport
Router(config-if)# switchport mode access
Router(config-if)# switchport access vlan 100
Router(config-if)# switchport voice vlan 101
Router(config-if)
 

次に、複数の VLAN アクセス モードを標準アクセス ポートに変更する例を示します。

Router(config-if)# interface fastethernet5/1
Router(config-if)# no switchport voice vlan
Router(config-if)

 
関連コマンド

コマンド
説明

switchport access vlan

インターフェイスがアクセス モードのときに VLAN を設定します。

switchport mode

インターフェイス タイプを設定します。

 

sync-restart-delay

正確なステータス報告が行われるように同期再起動遅延タイマーを設定するには、 sync-restart-delay コマンドを使用します。

sync-restart-delay timer

 
シンタックスの説明

timer

ステータス レジスタのリセット間隔を指定します。 有効値は 200 ~ 60,000 ミリ秒です。

 
コマンドのデフォルト

timer 210 ミリ秒です。

 
コマンド モード

インターフェイス コンフィギュレーション(config-if)

 
コマンドの履歴

リリース
変更内容

12.2(18)ZY

このコマンドのサポートが追加されました。

 
使用上のガイドライン

このコマンドは、ギガビット イーサネット ファイバ ポートだけでサポートされます。

ステータス レジスタには、リンク パートナーの現在のステータスが記録されます。

次に、ギガビット イーサネットの同期再起動遅延タイマーを設定する例を示します。

Router(config-if)# sync-restart-delay 2000
Router(config-if)#

 
関連コマンド

コマンド
説明

show running-config

モジュールまたはレイヤ 2 VLAN のステータスおよび設定を表示します。

 

system flowcontrol bus

First-in first-out(FIFO; 先入れ先出し)オーバーフロー エラー カウントを設定するには、 system flowcontrol bus コマンドを使用します。元の FIFO しきい値設定に戻すには、このコマンドの no 形式を使用します。

[ default ] system flowcontrol bus { auto | on }

no system flowcontrol bus

 
シンタックスの説明

default

(任意)デフォルト設定を指定します。

auto

FIFO オーバーフロー エラー カウントが 5 秒間隔で設定されたエラーしきい値を超過した場合に、FIFO オーバーフロー エラー カウントをモニタし、警告メッセージを送信します。

on

(任意)元の FIFO しきい値設定を指定します。

 
コマンドのデフォルト

auto

 
コマンドのデフォルト

グローバル コンフィギュレーション(config)

 
コマンドの履歴

リリース
変更内容

12.2(18)ZY

このコマンドのサポートが追加されました。

 
使用上のガイドライン


) システムのフロー制御を auto モードのままにし、Cisco TAC からの指示があった場合にだけ他のモードを使用することを推奨します。


次に、FIFO オーバーフロー エラー カウントが 5 秒間隔で設定されたエラーしきい値を超過した場合に、FIFO オーバーフロー エラー カウントをモニタし、警告メッセージを送信する例を示します。

Router(config)# system flowcontrol bus auto
Router(config)#
 

次に、元の FIFO しきい値設定を指定する例を示します。

Router(config)# system flowcontrol bus on
Router(config)#

 

system jumbomtu

レイヤ 2 およびレイヤ 3 パケットの最大サイズを設定するには、system jumbo mtu コマンドを使用します。デフォルトの MTU 設定に戻すには、このコマンドの no 形式を使用します。

system jumbo mtu mtu-size

no system jumbo mtu

 
シンタックスの説明

mtu-size

レイヤ 2 およびレイヤ 3 パケット の最大サイズ。有効値は 1500 ~ 9216 バイトです。

 
コマンドのデフォルト

mtu-size 9216 バイトです。

 
コマンド モード

グローバル コンフィギュレーション(config)

 
コマンドの履歴

リリース
変更内容

12.2(18)ZY

このコマンドのサポートが追加されました。

 
使用上のガイドライン

mtu-size パラメータが指定するのはイーサネット パケットのサイズであり、イーサネット フレーム全体のサイズではありません。レイヤ 3 MTU は、 system jumbo mtu コマンドを入力すると変化します。

system jumbo mtu コマンドは、ポート ASIC のグローバル MTU をイネーブルにします。ポート ASIC 上でジャンボ フレームをイネーブルにすると、入力側では任意のサイズのパケットが許可され、出力側では発信パケットがチェックされます。グローバル MTU を超える出力側のパケットは、ポート ASIC で廃棄されます。

たとえば、VLAN 1 のポート A および VLAN 2 のポート B が存在する場合に、VLAN 1 および VLAN 2 を mtu 9216 に設定し、 system jumbomtu 4000 コマンドを入力すると、4000 バイトを超えるパケットは発信されなくなります。ポート B および A では、4000 バイトを超えるパケットが廃棄されるためです。

次に、グローバル MTU サイズを 1550 バイトに設定する例を示します。

Router(config)# system jumbomtu 1550
Router(config)# end
Router#
 

次に、MTU のデフォルト設定に戻す例を示します。

Router(config)# no system jumbomtu
Router(config)#

 
関連コマンド

コマンド
説明

mtu

最大パケット サイズまたは MTU サイズを調整します。

show interfaces

特定のインターフェイスで認識されるトラフィックを表示します。

show system jumbomtu

グローバル MTU 設定を表示します。

 

tcam priority

TCAM の入力時、またはラベルが枯渇した場合に、ソフトウェア転送用のインターフェイスのプライオリティを設定するには、 tcam priority コマンドを使用します。

tcam priority { high | normal | low }

 
シンタックスの説明

high

プライオリティを高に設定します。

normal

プライオリティを標準に設定します。

low

プライオリティを低に設定します。

 
コマンドのデフォルト

normal

 
コマンド モード

インターフェイス コンフィギュレーション(config-if)

 
コマンドの履歴

リリース
変更内容

12.2(18)ZY

このコマンドのサポートが追加されました。

 
使用上のガイドライン

インターフェイスは次の順序で選択されます。

1. VACL およびマルチキャストが設定されていないロー プライオリティ インターフェイス

2. VACL が設定されていない、マルチキャストによる承認済みのロー プライオリティ インターフェイス

3. VACL が設定されている、マルチキャストによる承認済みのロー プライオリティ インターフェイス

4. ロー プライオリティ インターフェイス(マルチキャストによって承認されていない)

5. VACL およびマルチキャストが設定されていない標準プライオリティ インターフェイス

6. VACL が設定されていない、マルチキャストによる承認済みの標準プライオリティ インターフェイス

7. VACL が設定されている、マルチキャストによる承認済みの標準プライオリティ インターフェイス

8. 標準プライオリティ インターフェイス(マルチキャストによって承認されていない)

9. VACL およびマルチキャストが設定されていないハイ プライオリティ インターフェイス

10. VACL が設定されていない、マルチキャストによる承認済みのハイ プライオリティ インターフェイス

11. VACL が設定されている、マルチキャストによる承認済みのハイ プライオリティ インターフェイス

12. ハイ プライオリティ インターフェイス(マルチキャストによって承認されていない)

次に、プライオリティを設定する例を示します。

Router(config-if)# tcam priority low
Router(config-if)#

 
関連コマンド

コマンド
説明

show tcam interface

インターフェイスベースの TCAM に関する情報を表示します。

 

test cable-diagnostics

10 ギガビット イーサネット リンク、または 48 ポート 10/100/1000 BASE-T モジュール上の銅ケーブルの状態をテストするには、 test cable-diagnostics コマンドを使用します。

test cable-diagnostics tdr interface { interface interface-number }

 
シンタックスの説明

tdr

48 ポート 10/100/1000 BASE-T モジュール上の銅ケーブルの TDR テストをアクティブ化します。

interface interface

インターフェイス タイプを指定します。有効値については、「使用上のガイドライン」を参照してください。

interface-number

モジュールおよびポート番号

 
コマンドのデフォルト

このコマンドにはデフォルト設定がありません。

 
コマンド モード

特権 EXEC (#)

 
コマンドの履歴

リリース
変更内容

12.2(18)ZY

このコマンドのサポートが追加されました。

 
使用上のガイドライン

ケーブル診断を実行すれば、使用中のケーブルに接続上の問題があるかどうかを検出できます。

TDR テストの注意事項は次のとおりです。

TDR は、最大 115 m の長さのケーブルをテストできます。

TDR をサポートするモジュールの一覧については、『Release Notes for Cisco IOS Release 12.2 ZY』を参照してください。

interface interface の有効値は fastethernet および gigabitethernet です。

テストはケーブルの両端で同時に開始しないでください。テストをケーブルの両端で同時に開始すると、誤ったテスト結果が得られることがあります。

ケーブル診断テスト中は、ポートの設定を変更しないでください。変更すると、誤ったテスト結果が得られることがあります。

インターフェイスは、TDR テスト実行前にアップになっている必要があります。ポートがダウンの場合、 test cable-diagnostics tdr コマンドは拒否され、次のメッセージが表示されます。

Router# test cable-diagnostics tdr interface gigabitethernet2/12
% Interface Gi2/12 is administratively down
% Use 'no shutdown' to enable interface before TDR test start.
 

ポート速度が 1000 でリンクがアップの場合、自動 MDIX 機能をディセーブルにしないでください。

固定 10/100 ポートでは、TDR テスト実行前に、自動 MDIX をケーブルの両端でディセーブルにしてください。そうしないと、誤った結果が得られることがあります。

他のすべての条件では、自動 MDIX 機能はケーブルの両端でディセーブルにする必要があります( no mdix auto コマンドを使用します)。自動 MDIX をディセーブルにしない場合、TDR テストが妨害され、誤った結果が得られます。

リンクの相手側で自動 MDIX がイネーブルの場合は、この処理は TDR ケーブル診断テストを妨害し、テスト結果に誤りが生じます。ワークアラウンドはリンクの相手側で自動 MDIX をディセーブルにします。

ポート速度を 1000 から 10/100 に変更した場合、 no mdix auto コマンドを入力してから TDR テストを実行してください。 speed 1000 コマンドを入力すると、 no mdix auto コマンドを実行済みかどうかに関係なく、自動 MDIX がイネーブルとなります。

次に、TDR ケーブル診断を実行する例を示します。

Router # test cable-diagnostics tdr interface gigabitethernet2/1
TDR test started on interface Gi2/1
A TDR test can take a few seconds to run on an interface
Use 'show cable-diagnostics tdr' to read the TDR results.
Router #

 
関連コマンド

コマンド
説明

clear cable-diagnostics tdr

TDR をサポートする特定のインターフェイスまたはすべてのインターフェイスをクリアします。

show cable-diagnostics tdr

TDR ケーブル診断のテスト結果を表示します。

 

time-range

時間範囲コンフィギュレーション モードをイネーブルにし、機能(拡張アクセス リストなど)に対する時間範囲を定義するには、time-range コマンドを使用します。時間制限を削除するには、このコマンドの no 形式を使用します。

time-range time-range-name

no time-range time-range-name

 
シンタックスの説明

time-range-name

時間範囲の名前

 
コマンドのデフォルト

このコマンドにはデフォルト設定がありません。

 
コマンド モード

グローバル コンフィギュレーション(config)

 
コマンドの履歴

リリース
変更内容

12.2(18)ZY

このコマンドのサポートが追加されました。

 
使用上のガイドライン

time-range エントリは名前で識別され、1 つまたは複数のその他のコンフィギュレーション コマンドによって参照されます。1 つのアクセス リスト、または他の機能で複数の時間範囲が発生します。

time-range-name には、スペースまたは引用符を含めることができず、アルファベットの文字で開始する必要があります。


IP および IPX 拡張アクセス リストは、時間範囲を使用できる唯一のタイプのアクセス リストです。


time-range コマンドを使用したあとに、 periodic 時間範囲コンフィギュレーション コマンド、 absolute 時間範囲コンフィギュレーション コマンド、またはこれらのコマンドの一部の組み合わせを使用して、機能が作用する時間を定義します。時間範囲には、複数の periodic コマンドを使用できますが、 absolute コマンドに関しては 1 つだけ使用できます。


ヒント 混乱しないように、時間範囲および名前付きアクセス リストにそれぞれ別の名前を使用してください。


次に、月曜日から金曜日の午前 8 時から午後 6 時の間に HTTP トラフィックを拒否し、土曜日と日曜日の正午から午前 0 時の間だけ UDP トラフィックを許可する例を示します。

Router(config)# time-range no-http
Router(config)# periodic weekdays 8:00 to 18:00
!
Router(config)# time-range udp-yes
Router(config)# periodic weekend 12:00 to 24:00
!
Router(config)# ip access-list extended strict
Router(config)# deny tcp any any eq http time-range no-http
Router(config)# permit udp any any time-range udp-yes
!
Router(config)# interface ethernet 0
Router(config)# ip access-group strict in

 
関連コマンド

コマンド
説明

absolute

時間範囲が有効なときの絶対時間を指定します。

ip access-list

名前別に IP アクセス リストを定義します。

periodic

時間範囲機能をサポートする機能に繰り返し(週単位)の時間範囲を指定します。

permit (IP)

名前付き IP アクセス リストの条件を設定します。