Catalyst 6500 シリーズ スイッチソフトウェア コン フィギュレーション ガイド リリース8.7
冗長機能の設定
冗長機能の設定
発行日;2012/01/31 | 英語版ドキュメント(2010/04/01 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 19MB) | フィードバック

目次

冗長機能の設定

スーパーバイザ エンジンの冗長機能

スイッチ上での冗長スーパーバイザ エンジンの設定

同期化プロセスの開始

スーパーバイザ エンジンの冗長構成に関する注意事項および制限事項

スタンバイ スーパーバイザ エンジン ステータスの確認

スタンバイ スーパーバイザ エンジンへの強制切り替え

ハイ アベイラビリティ

ハイ アベイラビリティの概要

ハイ アベイラビリティでサポートされる機能

ハイ アベイラビリティ設定時の注意事項

バージョニングの概要

CLI コマンド

スタンバイ スーパーバイザ エンジンへの異なる(ただし互換性のある)イメージのロード

NSF および SSO を使用したスーパーバイザ エンジンの冗長構成

スーパーバイザ エンジンの同期化の例

ランタイム イメージとブートストリングの同期化

アクティブおよびスタンバイ スーパーバイザ エンジンのブート イメージの同期化

MSFC 冗長機能

デュアル MSFC 冗長機能

ハードウェアおよびソフトウェアの要件

単一シャーシによるレイヤ 3 冗長設定

ルーティング プロトコルのピア設定

アクセス コントロール リストの設定

デュアル MSFC 運用モデルの冗長機能および負荷分散

障害の例

HSRP を使用した冗長機能の設定

設定例

MSFC 設定同期化の概要

設定同期化のイネーブル化およびディセーブル化

ハイ アベイラビリティ冗長機能の設定例

単一ルータ モードの冗長機能

ハードウェアおよびソフトウェアの要件

SRM 冗長性設定時の注意事項

Supervisor Engine 720 における単一ルータ モードの冗長機能の設定

Supervisor Engine 1 または Supervisor Engine 2 における単一ルータ モードの冗長機能の設定

新しいアクティブ指定ルータに対する移行時間の指定

単一ルータ モードをイネーブルに設定したイメージのアップグレード

単一ルータ モードの終了

手動モード MSFC 冗長機能

ハードウェアおよびソフトウェアの要件

手動モード MSFC 冗長機能設定時の注意事項

スタンバイ MSFC のアクセス

手動による MSFC の起動

MSFC コンフィギュレーション レジスタの設定

MSFC 回復手順

冗長機能の設定

この章では、Catalyst 6500 シリーズ スイッチ上で冗長スーパーバイザ エンジンを設定する手順、および Multilayer Switch Feature Card(MSFC; マルチレイヤ スイッチ フィーチャ カード)の冗長機能を設定する手順について説明します。

この章で説明する内容は、次のとおりです。

「スーパーバイザ エンジンの冗長機能」

「スイッチ上での冗長スーパーバイザ エンジンの設定」

「MSFC 冗長機能」


) Cisco Nonstop Forwarding(NSF; ノンストップ フォワーディング)または Stateful Switchover(SSO; ステートフル スイッチオーバー)を使用した MSFC 冗長機能の設定については、第 24 章「NSF/SSO MSFC 冗長機能の設定」を参照してください。



注意 単一シャーシに搭載のデュアル MSFC は、冗長モードでの使用だけを目的に設計されており、同一の設定でなければなりません。詳細については、「MSFC 冗長機能」を参照してください。

MSFC の設定が異なる構成はサポートしていません。


) 特に明記されていない限り、この章で説明する情報および手順は、Policy Feature Card 3B/3BXL(PFC3B/PFC3BXL; ポリシー フィーチャ カード 3B/3BXL)を搭載した Supervisor Engine 32、PFC3A/PFC3B/PFC3BXL を搭載した Supervisor Engine 720、PFC2 を搭載した Supervisor Engine 2、および PFC を搭載した Supervisor Engine 1 に適用されます。



MSFC という用語は、このマニュアルを通じて特に明記されていない限り、MSFC、MSFC2、MSFC2A、および MSFC3 を指します。


Catalyst 6500 シリーズ冗長スーパーバイザ エンジンのインストレーションの詳細については、『 Catalyst 6500 Series Switch Module Installation Guide 』を参照してください。この章で使用しているコマンドの構文および使用方法の詳細については、『 Catalyst 6500 Series Switch Command Reference 』を参照してください。

スーパーバイザ エンジンの冗長機能


) 冗長スーパーバイザ エンジンには、同じモデルのフィーチャ カードと同タイプのものを使用する必要があります。WS-X6K-SUP1-2GE および WS-X6K-SUP1A-2GE(両方とも PFC を非搭載)は互換性があり、冗長構成が可能です。PFC が搭載されたスーパーバイザ エンジンの場合、冗長構成にするには PFC が同一でなければなりません(2 つの PFC、2 つの PFC2、2 つの PFC3A、2 つの PFC3B、または 2 つの PFC3BXL)。


2 つのスーパーバイザ エンジンを搭載している場合、先に起動したスーパーバイザ エンジンがアクティブ モジュールになり、2 番めのスーパーバイザ エンジンはスタンバイ モードになります。Simple Network Management Protocol(SNMP; 簡易ネットワーク管理プロトコル)、Command-Line Interface(CLI; コマンドライン インターフェイス)コンソール、Telnet、Spanning Tree Protocol(STP; スパニング ツリー プロトコル)、Cisco Discovery Protocol(CDP; シスコ検出プロトコル)、VLAN Trunking Protocol(VTP; VLAN トランキング プロトコル)などの管理機能およびネットワーク管理機能はすべて、アクティブ スーパーバイザ エンジン上で処理されます。

スタンバイ スーパーバイザ エンジンのコンソール ポートは非アクティブで、モジュール ステータスは「standby」で示されます。ただし、アップリンク ポートのステータス表示は通常どおりです。

Supervisor Engine 1 および Supervisor Engine 2 の場合、冗長スーパーバイザ エンジンはシャーシのスロット 1 および 2 に搭載する必要があります。Supervisor Engine 720 および Supervisor Engine 32 のスロット要件は、次のとおりです。3 スロット シャーシの場合は、Supervisor Engine 720 および Supervisor Engine 32 をスロット 1 または 2 に搭載します。6 スロットまたは 9 スロット シャーシの場合は、Supervisor Engine 720 および Supervisor Engine 32 をスロット 5 または 6 に搭載します。13 スロット シャーシの場合は、Supervisor Engine 720 および Supervisor Engine 32 をスロット 7 または 8 に搭載します。冗長スーパーバイザ エンジンは両方のスロットに搭載する必要があります。

冗長スーパーバイザ エンジンはホットスワップ対応です。システムは冗長スーパーバイザ エンジンに切り替えた後も、同じ設定で稼動を続けます。


) 各スーパーバイザ エンジンを個別に起動できるようにするため、コンフィギュレーション レジスタは、スーパーバイザ エンジン間で同期化されていません。



) アクティブ スーパーバイザ エンジンからスタンバイ スーパーバイザ エンジンへの切り替えに要する時間に、スパニング ツリーのコンバージェンス タイムは含まれていません。


スイッチの起動時には、両方のスーパーバイザ エンジンで初期モジュール レベルの診断が実行されます。両方のスーパーバイザ エンジンがこのレベルの診断をパスした場合、2 つのスーパーバイザ エンジンはバックプレーンを介して通信し、スイッチングバス診断時に協調するようになります。スロット 1 に搭載されたスーパーバイザ エンジンがアクティブになり、スロット 2 のスーパーバイザ エンジンがスタンバイ モードになります。2 つのスーパーバイザ エンジンのソフトウェア バージョンが異なる場合、または Nonvolatile RAM(NVRAM; 不揮発性 RAM)設定が異なっている場合には、アクティブ スーパーバイザ エンジンのソフトウェア イメージおよび設定がスタンバイ スーパーバイザ エンジンに自動的にダウンロードされます。


スロット 1 およびスロット 2 は、冗長スーパーバイザ エンジンを指します。上記のように、Supervisor Engine 720 および Supervisor Engine 32 ではスロット要件が異なります。


アクティブ スーパーバイザ エンジンのバックグラウンド診断によって重大な問題が検出された場合、または例外が発生した場合には、アクティブ スーパーバイザ エンジンがリセットされます。スタンバイ スーパーバイザ エンジンは、アクティブ スーパーバイザ エンジンが稼動しなくなったことを検出し、アクティブになります。スタンバイ スーパーバイザ エンジンは、アクティブ スーパーバイザ エンジンが正常に機能していない場合にそれを検出し、必要に応じてアクティブ スーパーバイザを強制的にリセットすることもできます。リセットされたスーパーバイザ エンジンは、復旧するとスタンバイ モードになります。

2 番めのスーパーバイザ エンジンをオンラインの状態で挿入すると、初期モジュール レベルの診断が完了した時点で、2 番めのモジュールはアクティブ スーパーバイザ エンジンと通信します。アクティブ スーパーバイザ エンジンがすでにバックプレーン上のトラフィックをスイッチングしているため、2 番めのスーパーバイザ エンジンについてはスイッチングバス診断が実行されません。診断を実行すると通常のトラフィックが中断される可能性があるためです。2 番めのスーパーバイザエンジンは、ただちにスタンバイ モードになります。この時点で、アクティブ スーパーバイザ エンジンのソフトウェア イメージおよび設定が、必要に応じてスタンバイ スーパーバイザ エンジンにダウンロードされます。

スーパーバイザ エンジンは、 ブート イメージ ランタイム イメージ という 2 つのフラッシュ イメージを使用します。ブート イメージのファイル名は、BOOT 環境変数で指定し、NVRAM に保存します。ランタイム イメージは、ROM モニタがスーパーバイザ エンジンを起動するために使用するブート イメージです。システム起動後は、ランタイム イメージは DRAM に常駐します。

冗長スーパーバイザ エンジンを搭載したスイッチの電源を入れるか、リセットすると、スタンバイ スーパーバイザ エンジン上のランタイム イメージとブート イメージがアクティブ スーパーバイザ エンジン上のイメージと同じになるように 同期化が行われます。

スーパーバイザ エンジンのランタイム イメージとブート イメージは、異なる場合があります。ブート イメージとランタイム イメージが同じであるときに、BOOT 環境変数を変更したり、システム起動に使用されたフラッシュ デバイス上の現在のブート イメージを上書きしたり破棄したりすると、ランタイム イメージとブート イメージは異なったものになります。ブートイメージを再設定すると、アクティブ スーパーバイザ エンジンは、現在のブート イメージをスタンバイ スーパーバイザ エンジンと同期化させます。

ブート イメージは、フラッシュ ファイル システムに直接読み込まれます。フラッシュ メモリ装置に保存されたファイルに対しては、( copy delete undelete などの)操作を実行できます。また、アクティブ スーパーバイザ エンジンのブート イメージを、スタンバイ スーパーバイザ エンジンのブートフラッシュに保存できます。フラッシュ ファイル システムの詳しい使用手順は、 第 26 章「フラッシュ ファイル システムの使用」 を参照してください。

Supervisor Engine 1 および Supervisor Engine 2 には、オンボード フラッシュ メモリの他にフラッシュ PC カード(PCMCIA [パーソナル コンピュータ メモリ カード国際協会])スロット(slot0)があります。このスロットにフラッシュ PC カードを挿入し、そこに追加のブート イメージを保存することができます。スロットのキーワードは、 slot0: (リニア フラッシュ デバイスの場合)、および disk0: (ATA フラッシュ デバイスの場合)です。


) このマニュアルでは、「PCMCIA カード」という用語の代わりに「フラッシュ PC カード」を使用しています。


Supervisor Engine 720 には、コンパクトフラッシュ Type II スロットが 2 つあります。コンパクトフラッシュ Type II スロットは、コンパクトフラッシュ Type II フラッシュ PC カードをサポートしています。アクティブな Supervisor Engine 720 上のスロットのキーワードは、 disk0: および disk1: です。冗長 Supervisor Engine 720 上のスロットのキーワードは、 slavedisk0: および slavedisk1: です。Supervisor Engine 32 には、コンパクトフラッシュ Type II スロットが 1 つあります。コンパクトフラッシュ Type II スロットは、コンパクトフラッシュ Type II フラッシュ PC カードをサポートしています。アクティブな Supervisor Engine 32 上のスロットのキーワードは、 disk0: です。冗長 Supervisor Engine 32 上のスロットのキーワードは、 slavedisk0: です。

複数のブート イメージを保存できるという理由から、起動および同期化が正しく行われるようにするため、ブート ファイル イメージの名前およびイメージ ファイルのフラッシュ ファイル システムでの保存場所を指定する必要があります。ブート イメージの名前および場所の指定方法については、 第 25 章「スイッチのブート設定の変更」 を参照してください。

同期化プロセス中、アクティブ スーパーバイザ エンジンはスタンバイ スーパーバイザ エンジンのランタイム イメージをチェックし、自身のランタイム イメージと一致していることを確認します。アクティブ スーパーバイザ エンジンがチェックする条件は、次の 3 つです。

アクティブ スーパーバイザ エンジンのブート イメージを、スタンバイ スーパーバイザ エンジンにコピーする必要があるかどうか。

スタンバイ スーパーバイザ エンジンのブートストリングを変更する必要があるかどうか。

スタンバイ スーパーバイザ エンジンをリセットする必要があるかどうか。

ここでは、フラッシュの同期化が開始される条件について説明します。さまざまな設定でスーパーバイザ エンジンのフラッシュ イメージを同期化する例は、「スーパーバイザ エンジンの同期化の例」を参照してください。

スイッチ上での冗長スーパーバイザ エンジンの設定

ここでは冗長スーパーバイザ エンジンの設定方法について説明します。

「同期化プロセスの開始」

「スーパーバイザ エンジンの冗長構成に関する注意事項および制限事項」

「スタンバイ スーパーバイザ エンジン ステータスの確認」

「スタンバイ スーパーバイザ エンジンへの強制切り替え」

「ハイ アベイラビリティ」

「NSF および SSO を使用したスーパーバイザ エンジンの冗長構成」

同期化プロセスの開始

アクティブおよびスタンバイ スーパーバイザ エンジン上のランタイム イメージおよびブート イメージの同期化が開始される条件は、次のとおりです。

アクティブおよびスタンバイ スーパーバイザ エンジン間でのランタイム イメージのタイムスタンプの不一致:システムの起動時またはリセット時に、それぞれのランタイム イメージのタイムスタンプが異なっている場合、アクティブ スーパーバイザ エンジンが自分のランタイム イメージに合わせて、スタンバイ スーパーバイザ エンジンを同期化させます。

アクティブおよびスタンバイ スーパーバイザ エンジン間でのブート イメージのタイムスタンプの不一致:システムの起動時またはリセット時に、それぞれのブート イメージのタイムスタンプが異なっている場合、または BOOT 環境変数が変更された場合には、アクティブ スーパーバイザ エンジンが自分のブート イメージに合わせて、スタンバイ スーパーバイザ エンジンを同期化させます。

現在のブート イメージの上書き:いずれかのフラッシュ デバイス上で保存されている現在のブート イメージが上書きされた場合、ファイル システム管理モジュールがそのイベントを検出し、同期化を開始します。アクティブ スーパーバイザ エンジンが自分の新しいブート イメージに合わせて、スタンバイ スーパーバイザ エンジンを同期化させます。

BOOT 環境変数の変更:BOOT 環境変数を変更して、異なるデフォルトブート イメージを指定した場合、アクティブ スーパーバイザ エンジンによってブート イメージの同期化が開始されます。NVRAM 設定モジュールがそのイベントを検出し、ブート設定パラメータを調べることにより、次に可能性の高いブート ファイル名を指定して、フラッシュ同期機能を呼び出します。

同じブート イメージ ファイル名が使用されているフラッシュ PC カード:アクティブまたはスタンバイのいずれかのスーパーバイザ エンジンのフラッシュ デバイスを交換し、新しいフラッシュ デバイスに以前のフラッシュ デバイスのブート イメージと同じ名前の(タイムスタンプの異なる)ブート イメージが格納されている場合、フラッシュ ファイル管理モジュールが同期機能を開始します。

現在のランタイム イメージの削除:フラッシュ デバイスから現在のランタイム イメージを削除する場合、フラッシュ ファイル管理モジュールから削除の確認を求められます。確認すると、フラッシュ ファイル管理モジュールがフラッシュの同期化を開始し、NVRAM 設定モジュールに変更を通知します。NVRAM 設定モジュールは、BOOT 環境変数を調べ、次に起動できるイメージを特定し、新しいイメージ名を使用してフラッシュ同期機能を呼び出します。

スーパーバイザ エンジンの冗長構成に関する注意事項および制限事項

次に挙げる条件またはイベントは、冗長構成のスーパーバイザ エンジン間でイメージが正しく同期化されず、予想外の結果が生じる原因になります。

アクティブ スーパーバイザ エンジンへの新しいイメージのダウンロード

アクティブ スーパーバイザ エンジンに新しいイメージをダウンロードすると、新しいイメージが(ブートフラッシュまたはフラッシュ PC カードの)ファイル システムにコピーされます。このイメージはブート イメージとして設定されていない場合もあるため、新しくダウンロードしたイメージは、スタンバイ スーパーバイザ エンジンに自動的にはコピーされません。

アクティブおよびスタンバイのスーパーバイザ エンジン間で同期機能を開始するには、新しくダウンロードしたイメージを、アクティブ スーパーバイザ エンジン上でブート イメージとして設定する必要があります。同期化は、ブート変数を変更したときに行われます。新しいイメージを実行するには、システムのリセットが必要です。

現在のランタイム イメージが見つからない場合

アクティブ スーパーバイザ エンジンがフラッシュ デバイス上で現在のランタイム イメージを見つけることができない場合には、エラー状態が伝えられます。スタンバイ スーパーバイザ エンジンが搭載またはリセットされても、フラッシュの同期化は実行されません。さらに、スタンバイ スーパーバイザ エンジン上の STATUS LED がレッドに点灯し、Syslog エラー メッセージが生成されます。

スロット 2 にアクティブ スーパーバイザ エンジンが搭載されている場合

アクティブ スーパーバイザ エンジンがスロット 2 に搭載されている場合、スタンバイ スーパーバイザ エンジンはスロット 1 にあります。設定を変更して新しいブート イメージを指定し、システムをリセットすると、スロット 1 のスーパーバイザ エンジンがアクティブ スーパーバイザ エンジンになり、対応するデフォルトのブート イメージがロードされて、変更した設定内容が取り消されます。この問題を回避するために、ブート ファイル設定を変更すると、スイッチはただちに、フラッシュの同期化を要求するプロンプトを表示します。

スタンバイ スーパーバイザ エンジン ステータスの確認

ここで説明される CLI コマンドを使用して、スタンバイ スーパーバイザ エンジンのステータスを確認することができます。


show module コマンドは、搭載されたドーター カードについての情報を出力します。show test コマンドは、オンボードの Application-Specific Integrated Circuit(ASIC; 特定用途向け集積回路)についての情報を出力します。


スタンバイ スーパーバイザ エンジンのステータスを調べるには、次の作業のうち 1 つ以上を行います。

 

作業
コマンド

スタンバイ スーパーバイザ エンジンのステータスを表示します。

show module [ mod ]

スタンバイ スーパーバイザ エンジンのアップリンク ポート ステートを表示します。

show port [ mod [ /port ]]

スタンバイ スーパーバイザ エンジンについて、診断テスト結果を表示します。

show test [ mod ]

次に、 show module および show test コマンドを入力して、スタンバイ スーパーバイザ エンジンのステータスを調べる例を示します。

Console> (enable) show module 2
Mod Slot Ports Module-Type Model Status
--- ---- ----- ------------------------- ------------------- --------
2 2 2 1000BaseX Supervisor WS-X6K-SUP1-2GE ok
 
Mod Module-Name Serial-Num
--- ------------------- -----------
2 SAD02330231
 
Mod MAC-Address(es) Hw Fw Sw
--- -------------------------------------- ------ ---------- -----------------
2 00-e0-14-0e-f5-6c to 00-e0-14-0e-f5-6d 0.404 4.2(2038) 4.2(0.24)VAI50
00-e0-14-0e-f5-6e to 00-e0-14-0e-f5-6f
00-10-7b-bb-2b-00 to 00-10-7b-bb-2e-ff
 
Mod Sub-Type Sub-Model Sub-Serial Sub-Hw
--- ------------------- ------------------- ----------- ------
2 L2 Switching Engine WS-F6020 SAD02350211 0.101
Console> (enable)
 
Console> (enable) show test 2
Module 2 : 2-port 1000BaseX Supervisor
Network Management Processor (NMP) Status: (. = Pass, F = Fail, U = Unknown)
ROM: . Flash-EEPROM: . Ser-EEPROM: . NVRAM: . EOBC Comm: .
 
Line Card Status for Module 1 : PASS
 
Port Status :
Ports 1 2
-----------
. .
Line Card Diag Status for Module 2 (. = Pass, F = Fail, N = N/A)
 
Module 2
Cafe II Status :
NewLearnTest: .
IndexLearnTest: .
DontForwardTest: .
DontLearnTest: .
ConditionalLearnTest: .
BadBpduTest: .
TrapTest: .
Loopback Status [Reported by Module 2] :
Ports 1 2
-----------
. .
Console> (enable)

スタンバイ スーパーバイザ エンジンへの強制切り替え

アクティブ スーパーバイザ エンジンをリセットすることによって、スタンバイ スーパーバイザ エンジンに強制的に切り替えることができます。


) アクティブ スーパーバイザ エンジンをリセットすると、オープンしている Telnet セッションが切断されます。


スタンバイ スーパーバイザ エンジンに強制的に切り替えるには、特権モードで次の作業を行います。

 

作業
コマンド

アクティブ スーパーバイザ エンジンをリセットします( mod はアクティブ スーパーバイザ エンジンの番号を示します)。

reset mod

また、アクティブ スーパーバイザ エンジン上で CISCO-STACK-MIB moduleAction 変数を reset(2)に設定することによって、スタンバイ スーパーバイザ エンジンに強制的に切り替えることもできます。切り替えが行われると、システムから標準の SNMP ウォームスタート トラップが、設定されているトラップ レシーバーに送信されます。

次に、アクティブ スーパーバイザ エンジンからスタンバイ スーパーバイザ エンジンに強制的に切り替えたときの、アクティブ スーパーバイザ エンジンのコンソール出力例を示します。

Console> (enable) reset 1
This command will force a switch-over to the standby Supervisor module.
Do you want to continue (y/n) [n]? y
Console> (enable) 12/07/1998,17:04:39:SYS-5:Module 1 reset from Console//
 
System Bootstrap, Version 3.1(2)
Copyright (c) 1994-1997 by cisco Systems, Inc.
 
System Bootstrap, Version 3.1(2)
Copyright (c) 1994-1997 by cisco Systems, Inc.
Presto processor with 32768 Kbytes of main memory
 
Autoboot executing command: "boot bootflash:cat6000-sup.5-4-1a.bin"
CCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCC
Uncompressing file: ###########################################################
 
System Power On Diagnostics
NVRAM Size .. .................512KB
ID Prom Test ..................Passed
DPRAM Size ....................16KB
DPRAM Data 0x55 Test ..........Passed
DPRAM Data 0xaa Test ..........Passed
DPRAM Address Test ............Passed
Clearing DPRAM ................Done
System DRAM Memory Size .......32MB
DRAM Data 0x55 Test ...........Passed
DRAM Data 0xaa Test ...........Passed
DRAM Address Test ............Passed
Clearing DRAM .................Done
EARLII ........................Present
EARLII RAM Test ...............Passed
EARL Serial Prom Test .........Passed
Level2 Cache ..................Present
Level2 Cache test..............Passed
 
Boot image: bootflash:cat6000-sup.5-4-1a.bin
Downloading epld sram device please wait ...
Programming successful for Altera 10K50 SRAM EPLD
This module is now in standby mode.
Console is disabled for standby supervisor
 

次に、アクティブ スーパーバイザ エンジンからスタンバイ スーパーバイザ エンジンに強制的に切り替えたときの、スタンバイ スーパーバイザ エンジンのコンソール出力例を示します。

Cisco Systems Console
 
Enter password:
12/07/1998,17:04:43:MLS-5:Multilayer switching is enabled
12/07/1998,17:04:43:MLS-5:Netflow Data Export disabled
12/07/1998,17:04:44:SYS-5:Module 2 is online
12/07/1998,17:04:45:SYS-5:Module 5 is online
12/07/1998,17:04:45:SYS-5:Module 7 is online
12/07/1998,17:04:45:SYS-5:Module 3 is online
12/07/1998,17:04:52:MLS-5:Route Processor 172.20.52.6 added
12/07/1998,17:05:10:SYS-5:Module 8 is online
12/07/1998,17:05:14:SYS-5:Module 9 is online
12/07/1998,17:05:22:SYS-5:Module 4 is online
12/07/1998,17:06:13:SYS-5:Module 1 is in standby mode
Supervisor image synchronization process will start in 10 seconds
12/07/1998,17:06:37:SYS-5:Ports on standby supervisor(Module 1) are UP
12/07/1998,17:06:41:SYS-5:Active supervisor is synchronizing the NMP image.
12/07/1998,17:06:44:SYS-5:The active supervisor has synchronized the NMP image.
 
Console>

ハイ アベイラビリティ

ハイ アベイラビリティ機能により、アクティブ スーパーバイザ エンジンの故障時にアクティブ スーパーバイザ エンジンからスタンバイ スーパーバイザ エンジンへの切り替え時間を最小限に抑えることができます。

ハイ アベイラビリティ機能がリリースされる以前は、高速スイッチオーバーによってスタンバイ スーパーバイザ エンジンへの切り替えがすみやかに行われていました。ただし、高速スイッチオーバーでは、スイッチオーバー以前のスイッチ機能のステートが不明なため、スタンバイ スーパーバイザエンジンをアクティブにする際にすべてのスイッチ機能を再度初期化し、スイッチを再起動する必要がありました。

ハイ アベイラビリティ機能では、このような制約がなくなっています。アクティブ スーパーバイザ エンジンがスタンバイ スーパーバイザ エンジンと通信し、機能のプロトコル ステートの同期化を保つためです。スーパーバイザ エンジン間の同期化により、障害時にスタンバイ スーパーバイザ エンジンがすみやかに機能を引き継ぎます。

さらに、ハイ アベイラビリティ機能では、アクティブおよびスタンバイ スーパーバイザ エンジン上で異なるソフトウェア イメージを実行できる バージョニング オプションも提供されています。

次に、これらの機能について説明します。

「ハイ アベイラビリティの概要」

「ハイ アベイラビリティでサポートされる機能」

「ハイ アベイラビリティ設定時の注意事項」

「バージョニングの概要」

「CLI コマンド」

「スタンバイ スーパーバイザ エンジンへの異なる(ただし互換性のある)イメージのロード」

ハイ アベイラビリティの概要

ハイ アベイラビリティを可能にするために、アクティブ スーパーバイザ エンジン上でシステム データベースが保守され、そのデータベース内のデータに変更があると、スタンバイ スーパーバイザ エンジンに最新情報が送られます。アクティブ スーパーバイザ エンジンは、何らかのステートの変更が発生すると、スタンバイ スーパーバイザ エンジンと通信して情報を更新し、サポートされる機能の現在のプロトコル ステートをスタンバイ スーパーバイザ エンジンが認識できるようにします。スタンバイ スーパーバイザ エンジンは、すべてのモジュール、ポート、および VLAN(仮想 LAN)について現在のプロトコル ステートを認識しています。このステート情報を使用して各プロトコルが初期化され、ただちに動作を開始できます。

アクティブ スーパーバイザ エンジンは、システム バス(バックプレーン)を制御し、ネットワークとの間でパケットを送受信し、すべてのモジュールを制御します。プロトコルはアクティブ スーパーバイザ エンジン上だけで動作します。

スタンバイ スーパーバイザ エンジンはシステム バスから切り離されていて、パケットのスイッチングは行いません。ただし、スイッチング バスからパケットを受信 して 、レイヤ 2 スイッチド フローのために学習し、レイヤ 2 転送テーブルに入力します。さらにスタンバイ スーパーバイザ エンジンは、スイッチング バスからパケットを受信して、レイヤ 3 スイッチド フローのために学習し、テーブルに入力します。スタンバイ スーパーバイザ エンジンは、パケットの転送にはまったく参加せず、どのモジュールとも通信しません。

スタンバイ スーパーバイザ エンジンの稼動時にハイ アベイラビリティをイネーブルに設定すると、イメージのバージョン互換性がチェックされます。互換性がある場合、データベースの同期化が開始されます。ハイ アベイラビリティ互換の各機能は、切り替え後、スタンバイ スーパーバイザ エンジンに保存されていたステートから処理を続行します。

ハイ アベイラビリティをディセーブルにすると、データベースの同期化は実行されず、切り替え後はスタンバイ スーパーバイザ エンジン上ですべての機能を再起動しなければなりません。

ハイ アベイラビリティをイネーブルからディセーブルに変更すると、アクティブ スーパーバイザ エンジンからの同期化は停止され、スタンバイ スーパーバイザ エンジンはその時点での同期データをすべて廃棄します。

ハイ アベイラビリティをディセーブルからイネーブルに変更すると、(スタンバイ スーパーバイザ エンジンが存在し、しかもそのイメージ バージョンが互換である場合)アクティブからスタンバイ スーパーバイザ エンジンへの同期化が開始されます。

NVRAM の同期化は、(2 つのスーパーバイザ エンジンの NVRAM バージョンが互換である場合)ハイ アベイラビリティがイネーブルとディセーブルのどちらであっても行われます。

スタンバイ スーパーバイザ エンジンがシステム ブート時に搭載されていなかった場合、アクティブ スーパーバイザ エンジンはこの状況を検知し、同期化のためのデータベースの最新情報をキューに入れません。同様に、スタンバイ スーパーバイザ エンジンをリセットまたは取り外した場合、同期化のための最新情報はキューに入れられず、同期化キュー内の未処理の更新データは廃棄されます。スタンバイ スーパーバイザ エンジンになる 2 番めのスーパーバイザ エンジンをオンラインの状態で挿入するか再起動すると、アクティブ スーパーバイザ エンジンはシステム データベース全体をスタンバイ スーパーバイザ エンジンにダウンロードします。これで初めてグローバルな同期化が成立し、アクティブ スーパーバイザ エンジンは個々の最新情報をキューに入れ、スタンバイ スーパーバイザ エンジンとの同期化を図るようになります。


) 2 番めのスーパーバイザ エンジンをオンラインの状態で挿入するか再起動した場合、グローバルな同期が成立するまでに数分かかることがあります。


ハイ アベイラビリティでサポートされる機能

Catalyst 6500 シリーズ スイッチのハイ アベイラビリティ機能は、次の 3 つのカテゴリに分類されます( 表 23-1 を参照)。

サポートされる機能:ハイ アベイラビリティが完全にサポートされています。この機能のデータベースは、アクティブ スーパーバイザ エンジンからスタンバイ スーパーバイザ エンジンに同期化されます。

互換機能:ハイ アベイラビリティがサポートされていません。この機能のデータベースは、アクティブ スーパーバイザ エンジンからスタンバイ スーパーバイザ エンジンに同期化されません。ただし、ハイ アベイラビリティをイネーブルにすると、互換機能をイネーブルにできます。

非互換機能:ハイ アベイラビリティがサポートされていません。この機能のデータベースは、アクティブ スーパーバイザ エンジンからスタンバイ スーパーバイザ エンジンに同期化されません。ハイ アベイラビリティをイネーブルにしても、非互換機能をイネーブルにできません。また、この非互換機能をイネーブルにすると、ハイ アベイラビリティをイネーブルにできません。

 

表 23-1 ハイ アベイラビリティ機能のサポート

サポートされる機能
互換機能
非互換機能

CEF

ASLB

ダイナミック VLAN

COPS-DS

CDP

GVRP

COPS-PR

GMRP

プロトコル フィルタリング

DTP

IGMP スヌーピング

EtherChannel

RMON

Cisco IOS ACL

RSVP

MLS

SNMP

PAgP

Telnet セッション

QoS

UplinkFast

スイッチド ポート アナライザ(SPAN)

VTP プルーニング

STP

トランキング

UDLD

VACL

VTP

ポート セキュリティ

 

802.1x

ハイ アベイラビリティ設定時の注意事項

ここでは、ハイ アベイラビリティ設定時の注意事項について説明します。

Cisco IOS ソフトウェアではハイ アベイラビリティは実行されないため、アクティブ MSFC のルーティング テーブル エントリは維持されません。ただし、アクティブおよびスタンバイの両方のスーパーバイザ エンジン上で MSFC を同じコンフィギュレーションに設定し、アクティブ MSFC とスタンバイ MSFC の間でルーティング テーブル エントリを維持することはできます。MSFC 上に Hot Standby Router Protocol(HSRP)を設定すると、ルーティングが自動的にバックアップされます。詳細については、「MSFC 冗長機能」を参照してください。

タイマーおよび統計情報は、アクティブ スーパーバイザ エンジンからスタンバイ スーパーバイザ エンジンに同期化されません。

Multilayer Switching(MLS; マルチレイヤ スイッチング)フローは、アクティブ スーパーバイザ エンジンからスタンバイ スーパーバイザ エンジンへ維持されます。

802.1X ポートでは、許可および未許可のステートだけがアクティブ スーパーバイザ エンジンからスタンバイ スーパーバイザ エンジンに同期化されます。その他のステートにあるポートは、スイッチオーバー発生後初期化されるか、再起動されます。

802.1X レコードの更新は、同様なタイプの更新を 1 つのレコードにまとめることによって最小化されています。
レコードの変数が変更されると、アクティブ スーパーバイザ エンジンは、スタンバイ スーパーバイザ エンジンにレコードを送ります。

許可済みポートの 802.1X 再認証タイマーは、スイッチオーバー発生後に再始動します。

ポート セキュリティ統計情報は、アクティブ スーパーバイザ エンジンからスタンバイ スーパーバイザ エンジンに同期化されません。

ハイ アベイラビリティをイネーブルにするか、セキュア ポートを備えたスイッチ上でスタンバイ スーパーバイザ エンジンをオンラインの状態で取り付けると、ポート単位および MAC 関連情報はすべてアクティブ スーパーバイザ エンジンからスタンバイ スーパーバイザ エンジンに同期化されます。

バージョニングの概要

ハイ アベイラビリティのバージョニング機能をイネーブルに設定した場合、アクティブ スーパーバイザ エンジンおよびスタンバイ スーパーバイザ エンジン上に、異なるが互換性のある 2 つのイメージを保持することができます。アクティブ スーパーバイザ エンジンはスタンバイ スーパーバイザ エンジンとイメージのバージョン情報を交換し、イメージの互換性によってハイ アベイラビリティ機能がイネーブルになるかを判別します。アクティブおよびスタンバイ スーパーバイザ エンジンの実行するイメージ バージョンに互換性がない場合、ハイ アベイラビリティをイネーブルにできません。

イメージ バージョニングは、Release 5.4(1) 以降のスーパーバイザ エンジン ソフトウェア リリースでサポートされています。バージョニングをイネーブルに設定した場合、アクティブ スーパーバイザ エンジンとスタンバイ スーパーバイザ エンジンが異なるイメージを実行していても、それらのイメージに互換性があれば、ハイ アベイラビリティは完全にサポートされます。完全に互換性のあるイメージは、次に示すものだけです。


) 8.x ソフトウェア リリース トレインでは、ソフトウェア イメージ バージョンの互換性がありません。これには、8.1(x)、8.2(x) 間、8.3(x) 間などのメジャー リリースが含まれます。また、8.1(1) と 8.1(2) 間、8.2(1) と 8.2(2) 間などのサブリリースも含まれます。


Supervisor Engine 1

5.5(3) と 5.5(4)

6.1(3) と 6.1(4)

6.2(2) と 6.2(3)

6.3(2) と 6.3(3)

6.3(4) と 6.3(5)

6.3(6) と 6.3(7)

Supervisor Engine 2

6.1(3) と 6.1(4)

6.2(2) と 6.2(3)

6.3(2) と 6.3(3)

ギガビット イーサネット スイッチング モジュールを除くすべてのモジュールと互換性のあるイメージは、次のとおりです。

Supervisor Engine 1

5.4(3) と 5.4(4)

5.5(3) と 5.5(5)

5.5(4) と 5.5(5)

ギガビット イーサネット スイッチング モジュールとは互換性があるが、10/100BASE-T モジュールとは互換性のないイメージは、次のとおりです。

Supervisor Engine 1

5.5(6a) と 5.5(7)

SFM または SFM2 およびファブリック対応モジュールを除くすべてのモジュールと互換性のあるイメージは、次のとおりです。

Supervisor Engine 2

6.3(4) と 6.3(5)

6.3(6) と 6.3(7)


) 互換性のないバージョンのイメージを実行すると設定情報が失われます。



) 2 つのスーパーバイザ エンジンを搭載している場合、先に起動したスーパーバイザ エンジンがアクティブ モジュールになり、2 番めのスーパーバイザ エンジンはスタンバイ モードになります。2 つのスーパーバイザ エンジンがシステムに搭載されている場合は、起動時にスロット 1 のスーパーバイザ エンジンがアクティブになり、スロット 2 のスーパーバイザ エンジンがスタンバイ モードになります。このとき、2 つのスーパーバイザ エンジンのソフトウェア バージョンが異なっているか、2 つのスーパーバイザ エンジンの NVRAM 設定が異なっており、しかもバージョニングがイネーブルに設定されていない場合には、アクティブ スーパーバイザ エンジンのソフトウェア イメージおよび設定がスタンバイ スーパーバイザ エンジンに自動的にダウンロードされます。


CLI コマンド

ここでは、ハイ アベイラビリティおよびバージョニングに関連する CLI コマンドについて説明します。

ハイ アベイラビリティのイネーブル化またはディセーブル化

デフォルトでは、ハイ アベイラビリティはディセーブルに設定されています。ハイ アベイラビリティをイネーブルまたはディセーブルにするには、特権モードで次の作業を行います。

 

作業
コマンド

ハイ アベイラビリティをイネーブルまたはディセーブルにします。

set system highavailability { enable | disable }

次に、ハイ アベイラビリティをイネーブルにする例を示します。

Console> (enable) set system highavailability enable
System high availability enabled.
Console> (enable)
 

次に、ハイ アベイラビリティをディセーブルにする例を示します。

Console> (enable) set system highavailability disable
System high availability disabled.
Console> (enable)

ハイ アベイラビリティ バージョニングのイネーブル化またはディセーブル化

デフォルトでは、ハイ アベイラビリティ バージョニングはディセーブルに設定されています。ハイ アベイラビリティ バージョニングをイネーブルまたはディセーブルにするには、特権モードで次の作業を行います。

 

作業
コマンド

ハイ アベイラビリティ バージョニングをイネーブルまたはディセーブルにします。

set system highavailability versioning { enable | disable }

次に、ハイ アベイラビリティ バージョニングをイネーブルにする例を示します。

Console> (enable) set system highavailability versioning enable
Image versioning enabled.
Console> (enable)
 

次に、ハイ アベイラビリティ バージョニングをディセーブルにする例を示します。

Console> (enable) set system highavailability versioning disable
Image versioning disabled.
Console> (enable)

ハイ アベイラビリティの設定および稼動ステータスの表示

show system highavailability コマンドを実行すると、次の情報が表示されます。

ハイ アベイラビリティの設定(イネーブルまたはディセーブル)

バージョニングの設定(イネーブルまたはディセーブル)

ハイ アベイラビリティの稼動ステータス(スタンバイ スーパーバイザ エンジンが搭載されて稼動しているかどうかに基づく)。稼動ステータス フィールドには、次のいずれかが表示されます。

OFF(high-availability-not-enabled):NVRAM のハイ アベイラビリティ オプションがディセーブルに設定されています。

OFF(standby-supervisor-not-present):スタンバイ スーパーバイザ エンジンが搭載されていません。

OFF(standby-supervisor-image-incompatible):スタンバイ スーパーバイザ エンジンがアクティブ スーパーバイザ エンジンとは異なるイメージを実行しており、しかもイメージがバージョン互換ではありません(NVRAM のバージョニング オプションはイネーブルに設定されています)。同期化はいっさい行われません(アクティブ スーパーバイザ エンジン上の NVRAM で設定が変更されても、バージョン間に互換性がないため、スタンバイ スーパーバイザ エンジン には伝播されません)。

OFF(standby-supervisor-image-nvram-only-compat):スタンバイ スーパーバイザ エンジンがアクティブ スーパーバイザ エンジンとは異なるイメージを実行しており(NVRAM のバージョニング オプションはイネーブルに設定されています)、そのイメージは NVRAM 互換性があるだけです(したがって、アクティブ スーパーバイザ エンジン上の NVRAM で設定が変更されると、スタンバイ スーパーバイザ エンジンに伝播されます)。ただし、ハイ アベイラビリティはサポートできません。

OFF(standby-supervisor-not-operational-yet):スタンバイ スーパーバイザ エンジンが検出されましたが稼動していません(まだオンラインではありません)。

OFF(high-availability-not-operational-yet):スタンバイ スーパーバイザ エンジンは稼動しています(オンラインです)が、ハイ アベイラビリティはまだ稼動していません(システムがリセット後に起動したとき、ハイ アベイラビリティが稼動するまでに数分かかります)。

ON:ハイ アベイラビリティが稼動しています。アクティブ スーパーバイザ エンジンの各機能は、スタンバイ スーパーバイザ エンジンとの同期をとるため、ステータス変更のキューイングを開始しました。

ハイ アベイラビリティの設定および稼動ステートを表示するには、次の作業を行います。

 

作業
コマンド

ハイ アベイラビリティの設定および稼動ステートを表示します。

show system highavailability

次に、ハイ アベイラビリティの設定および稼動ステートを表示する例を示します。

Console> (enable) show system highavailability
Highavailability: disabled
Highavailability versioning: disabled
Highavailability Operational-status: OFF (high-availability-not-enabled)
Console> (enable)
 

次に、ハイ アベイラビリティをイネーブルにする例を示します。

Console> (enable) set system highavailability enable
System high availability enabled.
Console> (enable)
 
Console> (enable) show system highavailability
Highavailability: enabled
Highavailability versioning: disabled
Highavailability Operational-status: ON
Console> (enable)

スタンバイ スーパーバイザ エンジンへの異なる(ただし互換性のある)イメージのロード

スタンバイ スーパーバイザ エンジンに、アクティブ スーパーバイザ エンジン上のイメージとは異なる新しいイメージをロードする手順は、次のとおりです。アクティブ スーパーバイザ エンジンのコンソール ポートから、次の作業を実行します(アクティブ スーパーバイザ エンジンはスロット 1 に搭載されています)。


ステップ 1 ハイ アベイラビリティをイネーブルにします。

Console> (enable) set system highavailability versioning enable
System high availability enabled.
Console> (enable)
 

ステップ 2 アクティブ スーパーバイザ エンジンのブートフラッシュに、新しいイメージをダウンロードします。

Console> (enable) copy tftp:image2.bin bootflash
IP address or name of remote host []? 172.20.52.3
 
8763532 bytes available on device bootflash, proceed (y/n) [n]? y
.
.
.
Console> (enable)
 

ステップ 3 スタンバイ スーパーバイザ エンジンのブートフラッシュに、新しいイメージをコピーします。

Console> (enable) copy bootflash:image2.bin 2/bootflash:
 
5786532 bytes available on device bootflash, proceed (y/n) [n]? y
.
.
.
Console> (enable)
 

ステップ 4 スタンバイ スーパーバイザ エンジンが新しいイメージを起動するように、BOOT 環境変数を変更します。

Console> (enable) set boot system flash bootflash:image2.bin prepend 2
BOOT variable = bootflash:image2.bin,1;slot0:image1.bin,1
Console> (enable)
 

ステップ 5 スタンバイ スーパーバイザ エンジンをリセットして、新しいイメージを起動します。

Console> (enable) reset 2
This command will reset the system.
Do you want to continue (y/n) [n]? y
.
.
.
Console> (enable)
 


 

NSF および SSO を使用したスーパーバイザ エンジンの冗長構成

Cisco NSF は SSO と連携することにより、スイッチオーバー後にユーザがネットワークを使用できなくなる期間を最小にしながら、IP パケットの転送を継続します。

NSF に SSO を設定する手順については、次の URL にある『Catalyst 6500 Series Cisco IOS Software Configuration Guide, 12.2SX』の「Configuring Supervisor Engine Redundancy using NSF with SSO」を参照してください。

http://www.cisco.com/en/US/docs/switches/lan/Catalyst6500/ios/12.2SXF/native/configuration/guide/nsfsso.html

スーパーバイザ エンジンの同期化の例

ここでは、同期機能が特定の条件を検出した場合の現象について説明します。

「ランタイム イメージとブートストリングの同期化」

「アクティブおよびスタンバイ スーパーバイザ エンジンのブート イメージの同期化」


) ここで示す一連の例で、ブートストリングの中のファイル名の後ろの 1 という数字(たとえば bootflash:f1,1)は、Trivial File Transfer Protocol(TFTP; 簡易ファイル転送プロトコル)起動の試行回数を表します。ただし、スーパーバイザ エンジンでは TFTP による起動はサポートされていません。Cisco IOS の表記との一貫性のため、この数字を含めています。



) ここで紹介する例は、考えられるすべての事例を含んでいるわけではありません。


ランタイム イメージとブートストリングの同期化

ここでは、アクティブ スーパーバイザ エンジンのランタイム イメージとスタンバイ スーパーバイザ エンジンとの同期化について、4 つの例を紹介します。

例 1:ランタイム イメージの同期化が行われない場合

例 1 の設定は、次のとおりです。

アクティブ スーパーバイザ エンジンの設定は、次のとおりです(スタンバイ スーパーバイザ エンジンのイメージがアクティブ スーパーバイザ エンジンのイメージと同じである場合、出力は同じになります)。

ランタイム イメージ: bootflash:f1

ブートストリング: bootflash:f1,1

ブートフラッシュ: f1

アクティブ スーパーバイザ エンジン上の f1 のタイムスタンプは、スタンバイ スーパーバイザ エンジン上の f1 と同じです。

予測される結果は、次のとおりです。

アクティブ スーパーバイザ エンジンの f1 イメージは、スタンバイ スーパーバイザ エンジンにコピーされません。

スタンバイ スーパーバイザ エンジンのブートストリングは変更されません。

スタンバイ スーパーバイザ エンジンはリセットされません。

例 2:ファイルのコピー、ブートストリングの変更、スタンバイ スーパーバイザ エンジンのリセットが行われる場合

例 2 の設定は、次のとおりです。

アクティブ スーパーバイザ エンジンの設定は、次のとおりです。

ランタイム イメージ: bootflash:f1

ブートストリング: bootflash:f1,1

ブートフラッシュ: f1

スタンバイ スーパーバイザ エンジンの設定は、次のとおりです。

ランタイム イメージ: bootflash:f2

ブートストリング: bootflash:f2,1

ブートフラッシュ: f2

アクティブ スーパーバイザ エンジン上の f1 のタイムスタンプは、スタンバイ スーパーバイザ エンジン上の f2 と同じではありません。

予測される結果は、次のとおりです。

アクティブ スーパーバイザ エンジンが f1 イメージをスタンバイ スーパーバイザ エンジンにコピーし、ファイル名を RTSYNC_f1 に変更します。

スタンバイ スーパーバイザ エンジンのブートフラッシュが次のように変更されます。 f2, RTSYNC_f1

スタンバイ スーパーバイザ エンジンのブートストリングが次のように変更されます。 bootflash:RTSYNC_f1,1;f2,1;

スタンバイ スーパーバイザ エンジンがリセットされます。

例 3:ファイルがコピーされず、ブートストリングが変更され、スタンバイ スーパーバイザ エンジンがリセットされる場合

例 3 の設定は、次のとおりです。

アクティブ スーパーバイザ エンジンの設定は、次のとおりです。

ランタイム イメージ: bootflash:f1

ブートストリング: bootflash:f1,1

ブートフラッシュ: f1

スタンバイ スーパーバイザ エンジンの設定は、次のとおりです。

ランタイム イメージ: bootflash:f2

ブートストリング: bootflash:f2,1

ブートフラッシュ: f1,f2

アクティブ スーパーバイザ エンジン上の f1 のタイムスタンプは、スタンバイ スーパーバイザ エンジン上の f1 と同じですが、スタンバイ スーパーバイザ エンジン上の f2 とは同じではありません。

予測される結果は、次のとおりです。

アクティブ スーパーバイザ エンジンのランタイム イメージとスタンバイ スーパーバイザ エンジンが同期化されます。

アクティブ スーパーバイザ エンジンの f1 イメージは、スタンバイ スーパーバイザ エンジンにコピーされません。

スタンバイ スーパーバイザ エンジンのブートストリングが次のように変更されます。 f1,1;f2,1;

スタンバイ スーパーバイザ エンジンがリセットされます。

例 4:最も古いブートフラッシュ ファイルが削除され、ブートフラッシュのスクイーズが実行される場合

例 4 の設定は、次のとおりです。

アクティブ スーパーバイザ エンジンの設定は、次のとおりです。

ランタイム イメージ: bootflash:f1

ブートストリング: bootflash:f1,1

ブートフラッシュ: f1

スタンバイ スーパーバイザ エンジンの設定は、次のとおりです。

ランタイム イメージ: bootflash:f2

ブートストリング: bootflash:f2,1;

ブートフラッシュ: f2, f3, f4 (メモリの空きスペースは 1 MB 未満)

アクティブ スーパーバイザ エンジン上の f1 のタイムスタンプは、スタンバイ スーパーバイザ エンジン上の f2 と同じではありません。 f2 のタイムスタンプは f3 より古く、 f3 のタイムスタンプは f4 より古くなっています。

予測される結果は、次のとおりです。

アクティブ スーパーバイザ エンジンのランタイム イメージとスタンバイ スーパーバイザ エンジンが同期化されます。

アクティブ スーパーバイザ エンジンは、スタンバイ スーパーバイザ エンジンへ f1 イメージのコピーを試みます。

スタンバイ スーパーバイザ エンジンのブートフラッシュがスペース不足であるため、冗長同期化機能が最も古いファイルを見つけて削除し、ブートフラッシュのスクイーズを実行します。

アクティブ スーパーバイザ エンジンが f1 イメージをスタンバイ スーパーバイザ エンジンにコピーし、ファイル名を RTSYNC_f1 に変更します。

スタンバイ スーパーバイザ エンジンのブートフラッシュが次のように変更されます。 f3, f4, RTSYNC_f1

スタンバイ スーパーバイザ エンジンのブートストリングが次のように変更されます。 RTSYNC_f1,1;f2,1;

スタンバイ スーパーバイザ エンジンがリセットされます。

アクティブおよびスタンバイ スーパーバイザ エンジンのブート イメージの同期化

ここでは、アクティブおよびスタンバイ スーパーバイザ エンジン上のブートストリングの同期化について、4 つの例を紹介します。

例 1:ブート イメージを割り当てられない場合

この例の設定は、次のとおりです。

アクティブ スーパーバイザ エンジンの設定は、次のとおりです。

ランタイム イメージ: bootflash:f1

ブートストリング: bootflash:f1,1;

ブートフラッシュ: f1

スタンバイ スーパーバイザ エンジンの設定は、次のとおりです。

ランタイム イメージ: bootflash:f1

ブートストリング: bootflash:f1,1;

ブートフラッシュ: f1

アクティブ スーパーバイザ エンジン上の f1 のタイムスタンプは、スタンバイ スーパーバイザ エンジン上の f1 と同じです。

システムはアクティブ スーパーバイザ エンジンのブートストリングを次のように変更しようと試みます。 f2,1;

予測される結果は、次のとおりです。

アクティブ スーパーバイザ エンジンは f2 を割り当てることができず、同期化が失敗します。

Syslog にエラーが記録されます。

アクティブ スーパーバイザ エンジンの f1 イメージは、スタンバイ スーパーバイザ エンジンにコピーされません。

スタンバイ スーパーバイザ エンジンのブートストリングは変更されません。

スタンバイ スーパーバイザ エンジンはリセットされません。

例 2:ファイルがコピーされ、ブートフラッシュが変更され、スタンバイ スーパーバイザ エンジンがリセットされない場合

この例の設定は、次のとおりです。

アクティブ スーパーバイザ エンジンの設定は、次のとおりです。

ランタイム イメージ: bootflash:f1

ブートストリング: bootflash:f1,1;

ブートフラッシュ: f1,f2

スタンバイ スーパーバイザ エンジンの設定は、次のとおりです。

ランタイム イメージ: bootflash:f1

ブートストリング: bootflash:f1,1;

ブートフラッシュ: f1

アクティブ スーパーバイザ エンジン上の f1 のタイムスタンプは、スタンバイ スーパーバイザ エンジン上の f1 と同じです。

アクティブ スーパーバイザ エンジンのブートストリングを次のように変更します。 f2,1;

予測される結果は、次のとおりです。

アクティブ スーパーバイザ エンジンが f2 イメージをスタンバイ スーパーバイザ エンジンにコピーし、ファイル名を BTSYNC_f2 に変更します。

スタンバイ スーパーバイザ エンジンのブートフラッシュが次のように変更されます。 f1, BTSYNC_f2

スタンバイ スーパーバイザ エンジンのブートストリングが次のように変更されます。 bootflash:BTSYNC_f2,1;f1,1;

スタンバイ スーパーバイザ エンジンはリセットされません。

例 3:ファイルがコピーされず、ブートストリングが変更され、スタンバイ スーパーバイザ エンジンがリセットされない場合

この例の設定は、次のとおりです。

アクティブ スーパーバイザ エンジンの設定は、次のとおりです。

ランタイム イメージ: bootflash:f1

ブートストリング: bootflash:f1,1;

ブートフラッシュ: f1,f2

スタンバイ スーパーバイザ エンジンの設定は、次のとおりです。

ランタイム イメージ: bootflash:f1

ブートストリング: bootflash:f1,1;

ブートフラッシュ: f1,f2

アクティブ スーパーバイザ エンジン上の f1 のタイムスタンプは、スタンバイ スーパーバイザ エンジン上の f1 と同じです。アクティブ スーパーバイザ エンジン上の f2 のタイムスタンプは、スタンバイ スーパーバイザ エンジン上の f2 と同じです。

アクティブ スーパーバイザ エンジンのブートストリングが次のように変更されます。 f2,1; f1,1;

予測される結果は、次のとおりです。

アクティブ スーパーバイザ エンジンの f1 イメージは、スタンバイ スーパーバイザ エンジンにコピーされません。

スタンバイ スーパーバイザ エンジンのブートストリングが次のように変更されます。 bootflash:f2,1;bootflash:f1,1;

スタンバイ スーパーバイザ エンジンはリセットされません。

例 4:ファイルのコピー、最も古いファイルの削除、ブートフラッシュのスクイーズ、ブートストリングの変更が行われ、スタンバイ スーパーバイザ エンジンがリセットされない場合

この例の設定は、次のとおりです。

アクティブ スーパーバイザ エンジンの設定は、次のとおりです。

ランタイム イメージ: bootflash:f1

ブートストリング: bootflash:f1,1;

ブートフラッシュ: f1,f2

スタンバイ スーパーバイザ エンジンの設定は、次のとおりです。

ランタイム イメージ: bootflash:f1

ブートストリング: bootflash:f1,1;

ブートフラッシュ: f0,f1,f3 (メモリの空きスペースは 1 MB 未満)

アクティブ スーパーバイザ エンジン上の f1 のタイムスタンプは、スタンバイ スーパーバイザ エンジン上の f1 と同じです。 f0 のタイムスタンプは f1 より古く、 f1 のタイムスタンプは f3 より古くなっています。

アクティブ スーパーバイザ エンジンのブートストリングが次のように変更されます。 bootflash:f2,1;bootflash:f1,1;

予測される結果は、次のとおりです。

アクティブ スーパーバイザ エンジンは、スタンバイ スーパーバイザ エンジンへ f2 イメージのコピーを試みます。

スタンバイ スーパーバイザ エンジンのブートフラッシュがスペース不足であるため、冗長同期化機能が最も古いファイル( f0 )を見つけて削除し、ブートフラッシュのスクイーズを実行します。

アクティブ スーパーバイザ エンジンが f2 イメージをスタンバイ スーパーバイザ エンジンにコピーし、ファイル名を BTSYNC_f2 に変更します。

スタンバイ スーパーバイザ エンジンのブートフラッシュが次のように変更されます。 f1, f3, BTSYNC_f2

スタンバイ スーパーバイザ エンジンのブートストリングが次のように変更されます。 bootflash:BTSYNC_f2,1;bootflash:f1,1;

MSFC 冗長機能

ここでは、次の内容で MSFC 冗長機能について説明します。

「デュアル MSFC 冗長機能」

「単一ルータ モードの冗長機能」

「手動モード MSFC 冗長機能」


) Cisco ノンストップ フォワーディング(NSF)またはステートフル スイッチオーバー(SSO)を使用した MSFC 冗長機能の設定については、第 24 章「NSF/SSO MSFC 冗長機能の設定」を参照してください。



) Single Router Mode(SRM; 単一ルータ モード)の冗長機能は、Supervisor Engine 720 および Supervisor Engine 32 でサポートされる唯一の MSFC 冗長機能オプションです。


デュアル MSFC 冗長機能


注意 両方の MSFC は同一設定にしておく必要があります。表 23-2 に、同一設定の要件、および単一スイッチ シャーシでのレイヤ 3 冗長機能の例外を示します。

MSFC が同一設定でない構成は、サポートされていません。

ここでは、MSFC 冗長機能の設定手順について説明します。

「ハードウェアおよびソフトウェアの要件」

「単一シャーシによるレイヤ 3 冗長設定」

「ルーティング プロトコルのピア設定」

「アクセス コントロール リストの設定」

「デュアル MSFC 運用モデルの冗長機能および負荷分散」

「障害の例」

ハードウェアおよびソフトウェアの要件

レイヤ 3 の冗長機能を設定するには、少なくとも次のいずれかの構成が必要です。

2 つの同一スーパーバイザ エンジン ドーター カードから構成される 1 つのシャーシ。

Policy Feature Card(PFC; ポリシー フィーチャ カード)および MSFC または MSFC2 搭載の Supervisor Engine 1(両方のスーパーバイザ エンジンに同一タイプの MSFC を搭載することが必要)

PFC2 および MSFC2 搭載の Supervisor Engine 2

それぞれスーパーバイザ エンジンを搭載した 2 つのシャーシ。各シャーシに少なくとも 1 つはスーパーバイザ エンジンを搭載しておく必要があります。各スーパーバイザ エンジンに、PFC および MSFC を取り付けておく必要があります。


) 各 MSFC は、同じ Cisco IOS ソフトウェア リリースを実行している必要があります。


単一シャーシによるレイヤ 3 冗長設定

単一の Catalyst 6500 シリーズ シャーシに、それぞれ MSFC を搭載した冗長スーパーバイザ エンジンを取り付けることができます。MSFC 上に Hot Standby Router Protocol(HSRP; ホットスタンバイ ルータ プロトコル)を設定すると、ネットワークで IP ホストに対するトランスペアレントなデフォルト ゲートウェイ冗長機能が実現します。HSRP コンフィギュレーションは、同じインターフェイス上で IPX および AppleTalk コンフィギュレーションと共存できます。

1 つの MSFC で障害が起きると、HSRP により、他方の MSFC(ルータ)が自動的に障害のある MSFC の機能を受け継ぎます。Release 5.4(1) のスーパーバイザ エンジン ソフトウェア リリースのハイ アベイラビリティ機能を併用すると、ネットワークの冗長レベルがさらに向上します。


注意 両方の MSFC は同一設定にしておく必要があります表 23-2 に、同一設定の要件、および単一スイッチ シャーシでのレイヤ 3 冗長機能の例外を示します。

 

表 23-2 単一シャーシのレイヤ 3 冗長機能の要件

同一設定の要件:グローバルおよびインターフェイス レベル
例外:インターフェイス レベル
例外:グローバル レベル

両方の MSFC に次の設定が 必要 です。

同じルーティング プロトコル

同じスタティック ルート

同じデフォルト ルート

同じポリシー ルート

同じ VLAN インターフェイス

同じ Cisco IOS ACL12

すべてのインターフェイスが同じ管理ステータスでなければ なりません

HSRP スタンバイ コマンド

IP アドレス コマンド3

IPX ネットワーク3

IP デフォルト ゲートウェイ

IPX インターナル ネットワーク

IPX デフォルト ルート

1.実データ フローに基づくダイナミック ACL および再帰 ACL は、各 MSFC で設定することができます。

2.両方の MSFC に同一の ACL を定義するだけではなく、ACL を両方の MSFC 上の同じ VLAN インターフェイスの同じ方向に適用する必要があります。

3.IP または IPX アドレスを両方の MSFC 上で同じにする必要はありませんが、両方の MSFC 上で IP または IPX アドレスを設定することが必要です

表 23-2 に示したインターフェイスおよびグローバル レベルの例外に関して、代替コンフィギュレーションを指定する方法については、「alt キーワードの使用方法」を参照してください。

冗長スーパーバイザ エンジンには、同一のハードウェア(MSFC および PFC)が搭載されている 必要 があります。詳細については、「ハードウェアおよびソフトウェアの要件」を参照してください。


) MSFC および MSFC2 のメモリ要件については、次の URL の『Release Notes for MSFC』を参照してください。http://www.cisco.com/en/US/products/hw/switches/ps708/prod_release_notes_list.html


ルーティング プロトコルのピア設定

冗長スーパーバイザ エンジンおよびデュアル MSFC 設定では、1 つのスーパーバイザ エンジンが完全に稼動している状態(アクティブ)で、もう 1 つのスーパーバイザ エンジンがスタンバイ モードになります。ただし、(アクティブ スーパーバイザ エンジン上の PFC をプログラミングするため)MSFC は両方とも稼動し、独立ルータとして運用されます。


PFC:PFC を使用すると、MLS エントリをいずれかの MSFC に対応付けられます(最初のパケットをどちらの MSFC がルーティングするかに基づきます)。アクティブ スーパーバイザ エンジン上の PFC だけが、パケットをスイッチングします。



PFC2:PFC2 では、メイン MSFC だけが、アクティブ スーパーバイザ エンジン上で Forwarding Information Base(FIB; 転送情報ベース)、隣接テーブル、Cisco IOS ソフトウェア、およびポリシー ルーティング ACL をプログラミングします。スタティック ルートまたはポリシー ルーティングを設定した場合は、両方の MSFC で同一の設定にする必要があります。メイン MSFC 上にない非メイン MSFC にスタティック ルートがある場合は、そのルートは PFC2 ではプログラミングされません


両方の MSFC は、ルーティング プロトコルのピア設定の観点から運用可能です。たとえば、単一の Catalyst 6500 シリーズ スイッチ シャーシに 2 つの MSFC を搭載し、両方に VLAN 10 および VLAN 21 のインターフェイスを設定した場合、2 つの MSFC はこれらの VLAN 上で相互にピアを形成します。デュアル シャーシおよびデュアル MSFC の構成で同じ VLAN を設定した場合には、各 MSFC に 6 つのピアが形成されます(VLAN 10 に 3 つ、VLAN 21 に 3 つ)。これは、同じシャーシ内のピアの他、2 つめのシャーシ内の 2 つの MSFC に対応するピアが形成されるためです。図 23-1 を参照してください。

図 23-1 デュアル シャーシおよびデュアル MSFC のピア設定

 

各 MSFC は(ピア設定という観点では)独立ルータとして動作しますが、シャーシ上の 2 つの MSFC は同時に稼動し、同じインターフェイスを運用し、同じルーティング プロトコルを実行します。

スーパーバイザ エンジンのハイ アベイラビリティ機能と MSFC 上の HSRP を併用すると、次のレイヤ 2 およびレイヤ 3 の冗長機能が提供されます。

スーパーバイザ エンジンのレイヤ 2 冗長機能(アクティブおよびスタンバイ):アクティブ スーパーバイザ エンジン(および搭載されている MSFC)に障害が発生すると、レイヤ 2 およびレイヤ 3 の両方の機能がスタンバイ スーパーバイザ エンジンと搭載 MSFC に切り替わります。

2 つの MSFC のレイヤ 3 冗長機能および負荷分散:1 つの MSFC に障害が発生すると、他方の MSFC が(HSRP により)ただちに機能を受け継ぎます。レイヤ 2 の運用は妨げられません(アクティブ スーパーバイザ エンジンはレイヤ 2 トラフィックの転送を続けます)。

アクティブ スーパーバイザ エンジン上の障害のある MSFC によってプログラミングされたレイヤ 3 エントリは、エージング アウトし、新しいアクティブ MSFC により移植されたレイヤ 3 エントリに置き換えられるまで、そのまま使用されます。エージングには 4 分かかるため、新しいアクティブ MSFC は、ハードウェアのスイッチング フローを妨げずに、XTAG 値を使用して MLS エントリを移植することができます。また、このプロセスは、新しいアクティブ MSFC に初期トラフィック フローが大量に送り込まれるのを防ぎます。


) 各 MSFC には、MLS ルート プロセッサであることを示す独自の XTAG 値が設定されています。MSFC #1(アクティブ スーパーバイザ エンジン上)の XTAG は 1、MSFC #2(スタンバイ スーパーバイザ エンジン上)の XTAG は 2 です。

XTAG 値を使用するのは、Supervisor Engine 1 だけです。Supervisor Engine 2 では XTAG 値が使用されません。



注意 同一シャーシ上のレイヤ 3 冗長機能を正常に動作させるには、両方の MSFC の設定が同じでなければなりません表 23-2を参照)。


表 23-2 に、設定の例外が示されています。たとえば、図 23-1では、VLAN10 上に 4 つの MSFC が関与しています。各 MSFC に異なる IP アドレスおよび HSRP プライオリティが設定されています。


アクセス コントロール リストの設定

MSFC 上で Cisco IOS Access Control List(ACL; アクセス コントロール リスト)を使用する場合には、グローバル レベルおよびインターフェイス レベルで、両方の MSFC 上に同じ ACL を設定する 必要 があります。メイン MSFC(最初にオンラインになる MSFC、またはオンライン時間が長い MSFC)だけが、ACL 情報を備えた PFC をプログラミングします。

アクティブ スーパーバイザ エンジン上の PFC のマルチレイヤ機能(CEF [Cisco Express Forwarding] for PFC2)は、ACL ASIC を照会し、設定されている Cisco IOS ACL に応じてパケットを転送するかどうか判別してから、パケットをスイッチングします。メイン MSFC に障害が発生した場合、新たにメインとなった MSFC は、スタティック ACL 用の PFC を再プログラミングする必要があります。一貫した結果を得るには、両方の MSFC に、スタティック ACL など、同一の ACL を設定する 必要があります


) 両方の MSFC 上に同一の ACL を定義するだけではなく、ACL を両方の MSFC 上の同じ VLAN インターフェイスに適用する必要があります。



実データ フローに基づくダイナミック ACL および再帰 ACL は、各 MSFC で設定することができます。



PFC:PFC でのハードウェアおよびソフトウェアによる Cisco IOS ACL の処理の詳細については、「PFC でのハードウェアおよびソフトウェアによる Cisco IOS ACL の処理」を参照してください。



PFC2:PFC2 でのハードウェアおよびソフトウェアによる Cisco IOS ACL の処理の詳細については、「PFC2 および PFC3A/PFC3B/PFC3BXL でのハードウェアおよびソフトウェアによる Cisco IOS ACL の処理」を参照してください。


メイン MSFC のステータスを判別するには、 show fm features コマンドまたは show redundancy コマンドを使用します。

Router-15# show redundancy
Designated Router: 1 Non-designated Router:2
Redundancy Status: non-designated
Config Sync AdminStatus : enabled
Config Sync RuntimeStatus: enabled
 
Router-16# show redundancy
Designated Router: 1 Non-designated Router:2
Redundancy Status: designated
Config Sync AdminStatus : enabled
Config sync RuntimeStatus: enabled

デュアル MSFC 運用モデルの冗長機能および負荷分散

図 23-2 に、アクセス レイヤ スイッチの複数の VLAN による一般的なアクセスおよび分散レイヤ構築ブロックを示します。レイヤ 2 ループは設定されていないため、コンバージェンスおよび負荷分散には HSRP が使用されます。スイッチ S1 およびスイッチ S2 には、スロット 1(Sup #1/MSFC #1)およびスロット 2(Sup #2/MSFC #2)に MSFC 搭載スーパーバイザ エンジンが取り付けられています。両スイッチとも、Sup #1 がアクティブで、Sup #2 はスタンバイ モードです。スーパーバイザ エンジンのハイ アベイラビリティはイネーブルに設定されています。スーパーバイザ エンジンのイメージおよび設定は自動的に同期化されますが、MSFC 上のイメージおよび設定は手動で同期化する必要があります。

図 23-2 デュアル MSFC 運用モデルの冗長機能および負荷分散:VLAN10 および VLAN21

 

図 23-2では、冗長機能および負荷分散を次のように設定します。

VLAN 10(偶数番号の VLAN):スイッチ S1 の MSFC #1 をプライマリ HSRP ルータ(プライオリティ 110)として設定し、MSFC #2 をスタンバイ ルータ(プライオリティ 109)として設定します。

VLAN 21(奇数番号の VLAN):スイッチ S2 の MSFC #1 をプライマリ HSRP ルータ(プライオリティ 110)として設定し、MSFC #2 をスタンバイ ルータ(プライオリティ 109)として設定します。

スイッチ S1 が偶数番号の VLAN をルーティングし、スイッチ S2 が奇数番号の VLAN をルーティングすることによって、負荷分散がサポートされます。一方のスイッチに障害が発生すると、他方のスイッチが奇数 VLAN と偶数 VLAN の両方のサービスを実行します。

スイッチ S1 の MSFC #2 を VLAN 12 のプライマリ HSRP ルータに、スイッチ S2 の MSFC #2 を VLAN 23 のプライマリ HSRP ルータに設定すれば、より高度な負荷分散を達成できます(図 23-3を参照)。

図 23-3 デュアル MSFC 運用モデルの冗長機能および負荷分散:
VLAN 10、12、21 および 23

 

VLAN のアクティブ HSRP ルータだけが、HSRP IP アドレスの Address Resolution Protocol(ARP; アドレス解決プロトコル)要求に対して、HSRP MAC アドレスを戻します。アクティブ HSRP ルータは、エンド ステーションの MAC アドレスに順番に ARP を適用し、ARP キャッシュを伝播します。単一シャーシ上の両方の MSFC を使用して偶数 VLAN の HSRP 処理を分散することによって、制御プレーンの ARP トラフィックを分散できます。いずれかの MSFC に障害が発生した場合、再学習が必要になるのは、影響を受けた VLAN の ARP エントリだけです。

このレベルの冗長機能および負荷分散では、Catalyst 6500 シリーズ スイッチ シャーシ上の MSFC の偶数および奇数 VLAN の追跡が複雑になるという欠点があります。

HSRP MAC アドレスに到達したパケット、およびルータの実 MAC アドレスを持つパケットには、MLS エントリが作成されます。ユニキャスト トラフィックの最初のホップの冗長機能には、HSRP が使用されます。たとえば、VLAN 10 に接続している他のルータ経由で受信したトラフィックには、Sup #1/MSFC #1 の実 MAC アドレスが使用されます。

障害の例

ここでは、デュアル MSFC 搭載の 2 つのスーパーバイザ エンジンを備えた単一シャーシ上で(図 23-4を参照)ハイ アベイラビリティをイネーブルに設定した場合、発生する可能性のある 5 つの障害の例を示します。メイン MSFC が、スタティック ACL の ACL ASIC をプログラミングしています。


) この例は PFC 特有のものですが、PFC2 または MSFC2 のフェールオーバーの例は、ACL および CEF テーブル エントリの処理に対するものと同じです。Supervisor Engine 2 では、メイン MSFC2 は、CEF テーブルの作成など PFC2 上で多数の ASIC をプログラミングします。非メイン MSFC2 に対するメイン MSFC2 HSRP フェールオーバーでは、PFC2 はこれまでのメイン MSFC2 によってプログラミングされた CEF テーブルで機能し続けます。Supervisor Engine 1 または MSFC コンフィギュレーションでの MLS キャッシュによるプロセスと同様に、新しいメイン MSFC2 は固有のエントリで CEF テーブルを再度プログラミングし、古いエントリはエージング アウトします。


図 23-4 デュアル MSFC 搭載の 2 つのスーパーバイザ エンジンを備えた単一シャーシ

 

障害ケース 1:メイン MSFC #1 の障害

メイン MSFC #1 に障害が起きると、次のシーケンスが実行されます。

1. MSFC #1 の MLS エントリが Sup #1 レイヤ 3 キャッシュでエージング アウトし、MSFC #2 は独自の XTAG 値を使用して、これらの MLS エントリを一時的に所有します。

2. MSFC #2 の MLS エントリは影響を受けません。

3. MSFC #2 は、MSFC #1 によってプログラミングされたハードウェア上のすべてのダイナミックおよび再帰 ACL を削除します。

4. MSFC #2 が新しいメイン MSFC となり、Sup #1 ACL ASIC のスタティック ACL を再プログラミングします。

障害ケース 2:非メイン MSFC #2 の障害

非メイン MSFC #2 に障害が起きると、次のシーケンスが実行されます。

1. MSFC #2 の MLS エントリが Sup #1 レイヤ 3 キャッシュでエージング アウトし、MSFC #1 が独自の XTAG 値を使用して、これらの MLS エントリを一時的に所有します。

2. MSFC #1 の MLS エントリは影響を受けません。

3. MSFC #1 は、MSFC #2 によってプログラミングされたハードウェア上のすべてのダイナミックおよび再帰 ACL を削除します。

4. MSFC #1 は、そのままメイン MSFC として動作します。

障害ケース 3:アクティブ Sup #1 の障害

アクティブ スーパーバイザ エンジン(Sup #1)に障害が起きると、次のシーケンスが実行されます。

1. レイヤ 3 のステートは保持されているため、MSFC #1 の MLS エントリは Sup #2 のレイヤ 3 キャッシュでエージング アウトし、MSFC #2 が独自の XTAG 値を使用して、これらの MLS エントリを一時的に所有します。

2. スタンバイ スーパーバイザ エンジンはレイヤ 2 ステートを保持するため、レイヤ 2 のコンバージェンスは発生しません。

3. MSFC #2 は、MSFC #1 によってプログラミングされたハードウェア上のすべてのダイナミックおよび再帰 ACL を削除します。

4. MSFC #2 が、Sup #2 ACL ASIC のスタティック ACL を再プログラミングします。MSFC #2 が新しいメイン MSFC になります。

障害ケース 4:スタンバイ Sup #2 の障害

スタンバイ スーパーバイザ エンジン(Sup #2)に障害が起きると、次のシーケンスが実行されます。

1. MSFC #2 の MLS エントリが Sup #1 レイヤ 3 キャッシュでエージング アウトし、MSFC #1 が独自の XTAG 値を使用して、これらの MLS エントリを一時的に所有します。

2. MSFC #1 の MLS エントリは影響を受けません。

3. MSFC #1 は、MSFC #2 によってプログラミングされたハードウェア上のすべてのダイナミックおよび再帰 ACL を削除します。MSFC #1 は、そのままメイン MSFC として動作します。

障害ケース 5:新しいスーパーバイザまたは障害のあったスーパーバイザをオンラインに戻したとき

障害のあったスーパーバイザ エンジン(Sup #2)をオンラインに戻すと、次のシーケンスが実行されます。

1. Sup #1 は、引き続きアクティブ スーパーバイザ エンジンとして動作します。

2. Sup #2 は、イメージおよびコンフィギュレーションを Sup #1 と同期化します(ハイ アベイラビリティ バージョニングがイネーブルに設定されていない場合)。

3. (Sup #2 上の)MSFC #2 がアップになります。VLAN21 の HSRP preempt が設定されている場合は、MSFC #2 の HSRP がアクティブになります。MSFC #1 の MLS エントリが削除され、MSFC #2 経由で再学習されます。

4. MSFC #1 は、引き続きスタティック ACL のメイン MSFC として動作します。

HSRP を使用した冗長機能の設定

スーパーバイザ エンジン ソフトウェア ハイ アベイラビリティ機能は、冗長スーパーバイザ エンジンの間でプロトコル ステートを維持しますが、冗長 MSFC の間でフェールオーバー用に HSRP を設定する必要があります。HSRP を使用して、ユニキャスト トラフィックの最初のホップの冗長機能を実現します。MSFC の VLAN インターフェイスについて、1 つ以上の HSRP グループを設定することにより、ネットワークのルーティングを自動的にバックアップすることができます。HSRP グループの各 VLAN インターフェイスは、仮想 IP アドレスおよび MAC アドレスを共有します。HSRP アドレスをデフォルト ゲートウェイとして使用するようにエンド ステーションおよび他のデバイスを設定しておくと、1 つのルータ インターフェイスに障害が起きても、これらの装置のサービスは中断されません。

HSRP プライオリティが最も高いインターフェイスが、その HSRP グループのアクティブ インターフェイスになります。


PFC2:PFC2 は、一意の番号を持つ HSRP グループを 16 個までサポートしています。異なる VLAN 上で同じ HSRP グループ番号を使用できます。16 を超える HSRP グループを設定すると、この制限により HSRP グループ番号として VLAN 番号を使用できなくなります。



PFC2:同じ番号の HSRP グループは、同じ仮想 MAC アドレスを使用しますが、このことにより、MSFC でブリッジを設定する場合にエラーが発生する可能性があります。

HSRP 設定では、standby use-bia オプションを入力しないでください。standby use-bia オプションを入力すると、MLS エントリは作成されません。standby use-bia オプションを設定すると、HSRP アクティブ インターフェイスがアップまたはダウンになった場合、スタンバイ VLAN インターフェイスのルータ CAM(連想メモリ)アドレスはありません。ルータ CAM エントリがなければショートカットは作成されません。この問題は、MSFC Cisco IOS のリリースとは無関係です(この問題については警告 CSCdz17169 を参照してください)。


MSFC の VLAN インターフェイス上に HSRP を設定するには、インターフェイス コンフィギュレーション モードで次の作業を行います。

 

作業
コマンド

ステップ 1

HSRP をイネーブルにし、HSRP IP アドレスを指定します。 group_number を指定しない場合、group 0 が使用されます。トラブルシューティングを容易にするため、グループ番号は VLAN 番号と一致するように設定してください。

Router(config-if)# standby [ group_number ] ip [ ip_address ]

ステップ 2

HSRP インターフェイスのプライオリティを指定します。HSRP グループ内の少なくとも 1 つのインターフェイスに、高いプライオリティを設定します(デフォルトは 100 です)。プライオリティの最も高いインターフェイスが、その HSRP グループのアクティブ インターフェイスになります。

Router(config-if)# standby [ group_number ] priority priority

ステップ 3

インターフェイスが現在のアクティブ HSRP インターフェイスを先取(preempt)し、現在のアクティブ インターフェイスよりもプライオリティが高い場合、そのインターフェイスがアクティブになるように設定します。

Router(config-if)# standby [ group_number ] preempt [ delay delay ]

ステップ 4

(任意)インターフェイスの HSRP hello タイマーおよび holdtime タイマーを設定します。デフォルト値は、3(hello)および 10(holdtime)です。HSRP グループのすべてのインターフェイスで、同じタイマー値を使用する必要があります。

Router(config-if)# standby [ group_number ] timers hellotime holdtime

ステップ 5

(任意)インターフェイスのクリア テキスト HSRP 認証ストリングを指定します。HSRP グループのすべてのインターフェイスで、同じ認証ストリングを使用する必要があります。

Router(config-if)# standby [ group_number ] authentication string

次に HSRP グループ 100 に属するインターフェイスを設定する例を示します。

Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# interface vlan100
Router(config-if)# standby 100 ip 172.20.100.10
Router(config-if)# standby 100 priority 110
Router(config-if)# standby 100 preempt
Router(config-if)# standby 100 timers 5 15
Router(config-if)# standby 100 authentication Secret
Router(config-if)# ^Z
Router#

設定例

ここでは、冗長機能を実行する 3 つの設定例を紹介します。

「例 1:1 つのスーパーバイザ エンジンと 1 つの MSFC が搭載された 2 つのシャーシ」

「例 2:スーパーバイザ エンジンおよび MSFC を 2 つずつ装備した単一シャーシ」

「例 3:スーパーバイザ エンジンおよび MSFC を 2 つずつ装備したデュアル シャーシ」

これらの例では、メイン MSFC はアクティブ スーパーバイザ エンジンに搭載されています。メイン MSFC のステータスを判別するには、 show fm features コマンドまたは show redundancy コマンドを使用します。次の例では、Router-16 がメイン MSFC です。

Router-15# show redundancy
Designated Router: 1 Non-designated Router:2
 
Redundancy Status: non-designated
Config Sync AdminStatus : enabled
Config Sync RuntimeStatus: enabled
 
Router-16# show redundancy
Designated Router: 1 Non-designated Router:2
 
Redundancy Status: designated
Config Sync AdminStatus : enabled
Config sync RuntimeStatus: enabled

例 1:1 つのスーパーバイザ エンジンと 1 つの MSFC が搭載された 2 つのシャーシ

図 23-5では、スーパーバイザ エンジン上にハイ アベイラビリティを設定できませんが、MSFC 上に HSRP を設定することができます。

図 23-5 1 つのスーパーバイザ エンジンと 1 つの MSFC が搭載された 2 つのシャーシ

 

次に、スイッチ S1 の MSFC 上に HSRP を設定する例を示します。

Console> (enable) switch console 15
Trying Router-15...
Connected to Router-15.
Type ^C^C^C to switch back...
Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# interface vlan10
Router(config-if)# standby 10 ip 172.20.100.10
Router(config-if)# standby 10 priority 110
Router(config-if)# standby 10 preempt
Router(config-if)# standby 10 timers 5 15
Router(config-if)# standby 10 authentication Secret
Router(config-if)# interface vlan21
Router(config-if)# standby 21 ip 192.20.100.21
Router(config-if)# standby 21 priority 109
Router(config-if)# standby 21 preempt
Router(config-if)# standby 21 timers 5 15
Router(config-if)# standby 21 authentication Secret
Router(config-if)# ^Z
Router# ^C^C^C
 

次に、スイッチ S2 の MSFC 上に HSRP を設定する例を示します。

Console> (enable) switch console 15
Trying Router-15...
Connected to Router-15.
Type ^C^C^C to switch back...
Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# interface vlan10
Router(config-if)# standby 10 ip 172.20.100.10
Router(config-if)# standby 10 priority 109
Router(config-if)# standby 10 preempt
Router(config-if)# standby 10 timers 5 15
Router(config-if)# standby 10 authentication Secret
Router(config-if)# interface vlan21
Router(config-if)# standby 21 ip 192.20.100.21
Router(config-if)# standby 21 priority 110
Router(config-if)# standby 21 preempt
Router(config-if)# standby 21 timers 5 15
Router(config-if)# standby 21 authentication Secret
Router(config-if)# ^Z
Router# ^C^C^C

例 2:スーパーバイザ エンジンおよび MSFC を 2 つずつ装備した単一シャーシ

図 23-6では、スーパーバイザ エンジン上にハイ アベイラビリティを設定し、MSFC 上に HSRP を設定しています。

図 23-6 冗長スーパーバイザ エンジンおよび MSFC が搭載された単一シャーシ

 

次に、スイッチ S1 の MSFC 上に HSRP を設定する例を示します。

Console> (enable) switch console 15
Trying Router-15...
Connected to Router-15.
Type ^C^C^C to switch back...
Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# interface vlan10
Router(config-if)# standby 10 ip 172.20.100.10
Router(config-if)# standby 10 priority 110
Router(config-if)# standby 10 preempt
Router(config-if)# standby 10 timers 5 15
Router(config-if)# standby 10 authentication Secret
Router(config-if)# interface vlan21
Router(config-if)# standby 21 ip 192.20.100.21
Router(config-if)# standby 21 priority 109
Router(config-if)# standby 21 preempt
Router(config-if)# standby 21 timers 5 15
Router(config-if)# standby 21 authentication Secret
Router(config-if)# ^Z
Router# ^C^C^C
 
Console> (enable) switch console 16
Trying Router-16...
Connected to Router-16.
Type ^C^C^C to switch back...
Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# interface vlan10
Router(config-if)# standby 10 ip 172.20.100.10
Router(config-if)# standby 10 priority 109
Router(config-if)# standby 10 preempt
Router(config-if)# standby 10 timers 5 15
Router(config-if)# standby 10 authentication Secret
Router(config-if)# interface vlan21
Router(config-if)# standby 21 ip 192.20.100.21
Router(config-if)# standby 21 priority 110
Router(config-if)# standby 21 preempt
Router(config-if)# standby 21 timers 5 15
Router(config-if)# standby 21 authentication Secret
Router(config-if)# ^Z
Router# ^C^C^C

例 3:スーパーバイザ エンジンおよび MSFC を 2 つずつ装備したデュアル シャーシ

図 23-7 の 2 つの Catalyst 6500 シリーズ スイッチ(S1 および S2)は、それぞれスロット 1(Sup #1/MSFC #1)とスロット 2(Sup #2/MSFC #2)に MSFC およびスーパーバイザ エンジンが搭載されています。レイヤ 2 ループは設定されていないため、コンバージェンスおよび負荷分散には HSRP が使用されます。両スイッチとも、Sup #1 がアクティブ スーパーバイザ エンジンで、Sup #2 はスタンバイ スーパーバイザ エンジンです。

図 23-7 デュアル MSFC 運用モデルの冗長機能および負荷分散

 

次に、スイッチ S1 の MSFC 上に HSRP を設定する例を示します。

Console> (enable) switch console 15
Trying Router-15...
Connected to Router-15.
Type ^C^C^C to switch back...
Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# interface vlan10
Router(config-if)# standby 10 ip 172.20.100.10
Router(config-if)# standby 10 priority 110
Router(config-if)# standby 10 preempt
Router(config-if)# standby 10 timers 5 15
Router(config-if)# standby 10 authentication Secret
Router(config-if)# interface vlan21
Router(config-if)# standby 21 ip 192.20.100.21
Router(config-if)# standby 21 priority 108
Router(config-if)# standby 21 preempt
Router(config-if)# standby 21 timers 5 15
Router(config-if)# standby 21 authentication Secret
Router(config-if)# ^Z
Router# ^C^C^C
 
Console> (enable) switch console 16
Trying Router-16...
Connected to Router-16.
Type ^C^C^C to switch back...
Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# interface vlan10
Router(config-if)# standby 10 ip 172.20.100.10
Router(config-if)# standby 10 priority 109
Router(config-if)# standby 10 preempt
Router(config-if)# standby 10 timers 5 15
Router(config-if)# standby 10 authentication Secret
Router(config-if)# interface vlan21
Router(config-if)# standby 21 ip 192.20.100.21
Router(config-if)# standby 21 priority 107
Router(config-if)# standby 21 preempt
Router(config-if)# standby 21 timers 5 15
Router(config-if)# standby 21 authentication Secret
Router(config-if)# ^Z
Router# ^C^C^C
 

次に、スイッチ S2 の MSFC 上に HSRP を設定する例を示します。

Console> (enable) switch console 15
Trying Router-15...
Connected to Router-15.
Type ^C^C^C to switch back...
Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# interface vlan10
Router(config-if)# standby 10 ip 172.20.100.10
Router(config-if)# standby 10 priority 108
Router(config-if)# standby 10 preempt
Router(config-if)# standby 10 timers 5 15
Router(config-if)# standby 10 authentication Secret
Router(config-if)# interface vlan21
Router(config-if)# standby 21 ip 192.20.100.21
Router(config-if)# standby 21 priority 110
Router(config-if)# standby 21 preempt
Router(config-if)# standby 21 timers 5 15
Router(config-if)# standby 21 authentication Secret
Router(config-if)# ^Z
Router# ^C^C^C
 
Console> (enable) switch console 16
Trying Router-16...
Connected to Router-16.
Type ^C^C^C to switch back...
Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# interface vlan10
Router(config-if)# standby 10 ip 172.20.100.10
Router(config-if)# standby 10 priority 107
Router(config-if)# standby 10 preempt
Router(config-if)# standby 10 timers 5 15
Router(config-if)# standby 10 authentication Secret
Router(config-if)# interface vlan21
Router(config-if)# standby 21 ip 192.20.100.21
Router(config-if)# standby 21 priority 109
Router(config-if)# standby 21 preempt
Router(config-if)# standby 21 timers 5 15
Router(config-if)# standby 21 authentication Secret
Router(config-if)# ^Z
Router# ^C^C^C

MSFC 設定同期化の概要

MSFC ハイ アベイラビリティにより、メイン MSFC(最初にオンラインになる MSFC、またはオンライン時間が最も長い MSFC)と、非メイン MSFC との間で、スタートアップ コンフィギュレーションおよび実行コンフィギュレーションを自動的に同期化することができます。ハイ アベイラビリティ冗長機能は、デフォルトではディセーブルです。


注意 設定同期化がサポートされているのは、IP および IPX コンフィギュレーションに対してだけです。同期化をイネーブルにする前に、両方の MSFC がすべてのプロトコルについて同じ設定を持つようにする必要があります。AppleTalk、DECnet、VINES、またはその他のルーティングを使用している場合は、両方の MSFC ですべてのプロトコルについて同じ設定を持つように手動で設定する必要があります。

メイン MSFC のステータスを判別するには、 show fm features コマンドまたは show redundancy コマンドを使用します。

Router-15# show redundancy
Designated Router: 1 Non-designated Router:2
 
Redundancy Status: non-designated
Config Sync AdminStatus : enabled
Config Sync RuntimeStatus: enabled
 
Router-16# show redundancy
Designated Router: 1 Non-designated Router:2
 
Redundancy Status: designated
Config Sync AdminStatus : enabled
Config sync RuntimeStatus: enabled
 

ハイ アベイラビリティ冗長機能は、スタートアップ コンフィギュレーションおよび実行コンフィギュレーションを同期化します。

ハイ アベイラビリティ冗長機能をイネーブルにすると、メイン MSFC 上で次のいずれかのコマンドを入力した場合、両方の MSFC のスタートアップ コンフィギュレーションが更新されます。

write mem

copy source startup-config

ハイ アベイラビリティ冗長機能をイネーブルにすると、メイン MSFC 上で実行したすべてのコンフィギュレーション コマンドが、非メイン MSFC に送信されます。また、メイン MSFC 上で copy source running-config コマンドを入力すると、実行コンフィギュレーションの同期化が更新されます。

ここでは、MSFC 設定同期化について説明します。

「設定同期化のステート」

「alt キーワードの使用方法」

設定同期化のステート

設定同期化には、次の 2 つのステートがあります。

Config Sync AdminStatus:ユーザが設定した機能が、ただちに反映されます。

Config Sync RuntimeStatus:次の場合に限り、イネーブルになります。

メインおよび非メイン MSFC の両方で、Config Sync AdminStatus がイネーブルになっている場合

メインおよび非メイン MSFC が互換イメージを実行している場合

Config Sync RuntimeStatus がイネーブルの場合には、次の状態になります。

非メイン MSFC の CLI では、コンフィギュレーション モードを使用できません。EXEC モードは使用できます。

alt キーワードが使用でき、必要になります( alt キーワードの詳細については、「alt キーワードの使用方法」を参照してください)。

実行コンフィギュレーションとスタートアップ コンフィギュレーションが同期化されます。

Config Sync RuntimeStatus がディセーブルの場合には、次の状態になります。

両方の MSFC の CLI 上で、コンフィギュレーション モードを使用できます。

alt キーワードを使用できますが、使用は任意です。

実行コンフィギュレーションとスタートアップ コンフィギュレーションは同期化されません。

各種のコンフィギュレーションおよび運用例は、「ハイ アベイラビリティ冗長機能の設定例」を参照してください。

alt キーワードの使用方法

Config Sync RuntimeStatus がイネーブルの場合、非メイン MSFC 上では、EXEC モードだけは使用できますが、コンフィギュレーション モードは使用できません。両方の MSFC のコンフィギュレーションは、メイン MSFC のコンソールまたは Telnet セッション経由で行います。

単一コンソールから両方の MSFC を設定するには、 alt キーワードを使用して、代替コンフィギュレーションを行うことを指定します。代替コンフィギュレーションを指定した場合、 alt キーワードの前に入力したコンフィギュレーションはスイッチのスロット 1 のスーパーバイザ エンジン上の MSFC に適用され、 alt キーワードの後に入力したコンフィギュレーションはスロット 2 のスーパーバイザ エンジン上の MSFC に適用されます。


) Config Sync AdminStatus をイネーブルにするときは、alt キーワードを入力する必要があります。


表 23-3 に、 alt キーワードの含まれるインターフェイスおよびグローバル コンフィギュレーション コマンドを示します。

 

表 23-3 alt キーワードの含まれるインターフェイスおよびグローバル コンフィギュレーション コマンド

インターフェイス コンフィギュレーション コマンド
グローバル コンフィギュレーション コマンド

[ no ] standby [ group_number ] ip [ ip_address [ secondary ]] alt [ no ] standby [ group_number ] ip [ ip_address [ secondary ]]

[ no ] standby [ group_number ] priority priority [ preempt [ delay delay ]] alt [ no ] standby [ group_number ] priority priority [ preempt [ delay delay ]]

[ no ] ip address ip_address mask [ secondary ] alt [ no ] ip address ip_address mask [ secondary ]

[ no ] ipx network network [ encapsulation encapsulation_type [ secondary ]] [ alt [ no ] ipx network network [ encapsulation encapsulation_type [ secondary ]]]

[ no ] hostname hostname alt hostname hostname

[ no ] ip default-gateway ip_address alt [ no ] ip default-gateway ip_address

router bgp autonomous_system
bgp router-id ip_address [ alt ip_address ]

router ospf process_id
router-id ip_address [ alt ip_address ]

次に、 ip address コマンドでの alt キーワードの使用例を示します。

Router-1(config-if)# ip address 1.2.3.4 255.255.255.0 alt ip address 1.2.3.5 255.255.255.0

設定同期化のイネーブル化およびディセーブル化

ハイ アベイラビリティ冗長機能をイネーブルにするには、特権モードで次の作業を行います。

 

作業
コマンド

ステップ 1

冗長機能をイネーブルにします。

redundancy

ステップ 2

ハイ アベイラビリティをイネーブルにします。

high-availability

ステップ 3

設定同期化をイネーブルまたはディセーブルにします。

[ no ] config-sync

次に、ハイ アベイラビリティ冗長機能および設定同期化をイネーブルにする例を示します(Router-15 がメイン MSFC です)。

Console>(enable) session 15
Trying Router-15...
Connected to Router-15.
Escape character is ’^]’.
 
Router-15> enable
Router-15# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router-15(config)# redundancy
Router-15(config-r)# high-availability
Router-15(config-r-ha)# config-sync
Router-15(config-r-ha)# end
 

) ハイ アベイラビリティ冗長機能をイネーブルにすると、非メイン MSFC 上のコンフィギュレーション モードはディセーブルになり、使用できるのは EXEC モードだけになります。


次の例では、Router-16 は非メイン MSFC です。ハイ アベイラビリティ冗長機能および設定同期化がイネーブルに設定されています。

Console>(enable) session 16
Trying Router-16...
Connected to Router-16.
Escape character is ’^]’.
 
Router-16> enable
Router-16# configure terminal
Config mode is disabled on non-designated Router, please configure from designated Router

ハイ アベイラビリティ冗長機能の設定例

ここでは、ハイ アベイラビリティおよび設定同期化をイネーブルにする例を、いくつか紹介します。

「例 1:両方の MSFC 上で設定同期化をイネーブル化」

「例 2:メイン MSFC 上で設定同期化をディセーブル化」

「例 3:メイン MSFC をアップにする場合」

「例 4:非メイン MSFC をアップにする場合」

「例 5:メイン MSFC がダウンした場合」

例 1:両方の MSFC 上で設定同期化をイネーブル化

両方の MSFC がアップになっていることが前提です。

両方の MSFC の設定同期化をイネーブルにすると、最初にすべてのインターフェイス上の IP アドレスがチェックされます。メイン MSFC に IP アドレスが設定され、非メイン MSFC に指定されていないと、代替 IP アドレスが指定されていない最初のインターフェイスを示すメッセージが表示されます。

IP アドレスのチェックが終了すると、HSRP のアドレスがチェックされます。メイン MSFC に HSRP アドレスが設定され、非メイン MSFC に指定されていないと、代替 HSRP(スタンバイ)アドレスが指定されていない最初のインターフェイスを示すメッセージが表示されます。

HSRP アドレスのチェックが終了すると、IPX ネットワーク アドレスがチェックされます。

メイン MSFC を最初に設定します。次の例は、VLAN 1 インターフェイスの代替コンフィギュレーションが設定されていないことを示しています。

Router-16# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router-16(config)# redundancy
Router-16(config-r)# high-availability
Router-16(config-r-ha)# config-sync
 
Alternate IP address missing for Vlan1
The alternate configuration is missing. The auto-config sync can not be enabled
 

) 代替 IP コンフィギュレーションを指定した場合、alt キーワードの前に入力したコンフィギュレーションはスイッチのスロット 1 のスーパーバイザ エンジン上の MSFC に適用され、alt キーワードの後に入力したコンフィギュレーションはスロット 2 のスーパーバイザ エンジン上の MSFC に適用されます。詳細については、「alt キーワードの使用方法」を参照してください。


次に、VLAN 1 の代替コンフィギュレーションを指定する例を示します。

Router-16(config)# interface vlan 1
Router-16(config-if)# ip address 70.0.70.4 255.255.0.0 alt ip address 70.0.70.5 255.255.0.0
Router-16(config-if)# exit
 

次に、ハイ アベイラビリティ冗長機能を設定する例を示します。

Router-16(config)# redundancy
Router-16(config-r)# high-availability
Router-16(config-r-ha)# config-sync
Router-16(config-r-ha)# end
Router-16#
00:03:31: %SYS-5-CONFIG_I: Configured from console by console
 

非メイン MSFC の Config Sync AdminStatus がディセーブルになっているため、メイン MSFC の Config Sync RuntimeStatus はディセーブル モードのままです。メイン MSFC に、次のメッセージが表示されます。

00:17:05: %RUNCFGSYNC-6-SYNCEVENT:
Non-Designated Router is now online
High-Availability Redundancy Feature is not enabled on the Non-Designated Router
 

次に、非メイン MSFC 上で設定同期化をイネーブルにする例を示します。

Router-151(config)# redundancy
Router-15(config-r)# high-availability
Router-15(config-r-ha)# config-sync
Router-15(config-r-ha)# end
Router-15#
00:03:31: %SYS-5-CONFIG_I: Configured from console by console
 

) ハイ アベイラビリティ冗長機能をイネーブルにすると、非メイン MSFC のコンソールのコンフィギュレーション モードはディセーブルになり、使用できるのは EXEC モードだけになります。


非メイン MSFC 上に、ハイ アベイラビリティ機能がイネーブルになり、コンフィギュレーション モードが自動的に終了することを示す、次のメッセージが表示されます。

00:18:57: %RUNCFGSYNC-6-SYNCEVENT:
The High-Availability Redundancy Feature is enabled
The config mode is no longer accessible
 
Router-15#
 
00:19:41: %RUNCFGSYNC-6-SYNCEVENT:
Non-Designated Router is now online
Running Configuration Synchronization will begin in 1 minute
 

非メイン MSFC を安定させるため、1 分間のタイマーがスタートします。タイマーが切れると、現在の実行コンフィギュレーションのスナップショットが非メイン MSFC に送信されます。実行コンフィギュレーションが同期化される前に、次のメッセージが表示されます。

00:20:41: %RUNCFGSYNC-6-SYNCEVENT:
Syncing Running Configuration to the Non-Designated Router
 
00:20:41: %RUNCFGSYNC-6-SYNCEVENT:
Syncing Startup Configuration to the Non-Designated Router
 

次の例は、メイン MSFC と非メイン MSFC が同期化され、同じ実行コンフィギュレーションが設定されていることを示しています。

<designated MSFC>
Router-16# show running-config
Building configuration...
 
Current configuration:
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router-15 alt hostname Router-16
!
boot bootldr bootflash:c6msfc-boot-mz.120-7.XE1
!
ip subnet-zero
!
ip cef
redundancy
high-availability
config-sync
cns event-service server
!
!
!
interface Vlan1
ip address 70.0.70.4 255.255.0.0 alt ip address 70.0.70.5 255.255.0.0
!
interface Vlan10
ip address 192.10.10.1 255.255.255.0 alt ip address 192.10.10.2 255.255.255.0
no ip redirects
shutdown
standby ip 192.20.20.1 alt standby ip 192.20.20.1
!
ip classless
ip route 223.255.254.0 255.255.255.0 70.0.100.0
no ip http server
!
!
!
line con 0
transport input none
line vty 0 4
login
transport input lat pad mop telnet rlogin udptn nasi
!
end
 
 
<nondesignated MSFC>
Router-15# show running-config
Building configuration...
 
Current configuration:
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router1 alt hostname Router2
!
boot bootldr bootflash:c6msfc-boot-mz.120-7.XE1
!
ip subnet-zero
!
ip cef
redundancy
high-availability
config-sync
cns event-service server
!
!
!
interface Vlan1
ip address 70.0.70.4 255.255.0.0 alt ip address 70.0.70.5 255.255.0.0
!
interface Vlan10
ip address 192.10.10.1 255.255.255.0 alt ip address 192.10.10.2 255.255.255.0
no ip redirects
shutdown
standby ip 192.20.20.1 alt standby ip 192.20.20.1
!
ip classless
ip route 223.255.254.0 255.255.255.0 70.0.100.0
no ip http server
!
!
!
line con 0
transport input none
line vty 0 4
login
transport input lat pad mop telnet rlogin udptn nasi
!
end

例 2:メイン MSFC 上で設定同期化をディセーブル化

この例では、設定同期化がすでにイネーブルに設定されています。設定同期化をディセーブルにする例を示します。

Router-16# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router2(config)# redundancy
Router2(config-r)# high-availability
Router2(config-r-ha)# no config-sync
 

設定同期化をディセーブルにすると、非メイン MSFC 上に次のメッセージが表示されます。

00:13:00: %RUNCFGSYNC-6-SYNCEVENT:
The High-Availability Redundancy Feature is now disabled
The config mode is now accessible
 

メインおよび非メイン MSFC の両方で、CLI のコンフィギュレーション モードを使用することができます。

例 3:メイン MSFC をアップにする場合

この例では、Config Sync AdminStatus がすでにイネーブルに設定されています。メイン MSFC は代替コンフィギュレーションを検証し、非メイン MSFC がアップになった時点で、コンフィギュレーションを同期化します。

非メイン MSFC はまだアップになっていないため、Config Sync RuntimeStatus はディセーブルです。したがって、設定同期化は実行されません。非メイン MSFC の情報については、「例 4:非メイン MSFC をアップにする場合」を参照してください。

次の例では、Router-16 がメイン MSFC です。Config Sync AdminStatus はイネーブル、Config Sync RuntimeStatus はディセーブルに設定されています。

Router-16# show redundancy
Designated Router: 1 Non-designated Router:0
 
Redundancy Status: designated
Config Sync AdminStatus : enabled
Config Sync RuntimeStatus: disabled

例 4:非メイン MSFC をアップにする場合

Config Sync AdminStatus がイネーブルの場合

この例では、非メイン MSFC がメイン MSFC に対して、非メイン MSFC がアップになり、Config Sync AdminStatus がイネーブルになったことを通知しています。メイン MSFC は非メイン MSFC に、Config Sync RuntimeStatus をイネーブルにするように要求しています。非メイン MSFC の Config Sync RuntimeStatus がイネーブルになります。

非メイン MSFC には、次のメッセージが表示されます。

00:00:07: %RUNCFGSYNC-6-SYNCEVENT:
The High-Availability Redundancy Feature is enabled
The config mode is no longer accessible
 
00:00:51: %RUNCFGSYNC-6-SYNCEVENT:
Non-Designated Router is now online
Running Configuration Synchronization will begin in 1 minute
 

非メイン MSFC を安定させるため、1 分間のタイマーがスタートします。タイマーが切れると、現在の実行コンフィギュレーションのスナップショットが非メイン MSFC に送信されます。実行コンフィギュレーションが同期化される前に、次のメッセージが表示されます。

00:01:51: %RUNCFGSYNC-6-SYNCEVENT:
Syncing Running Configuration to the Non-Designated Router

Config Sync AdminStatus がディセーブルの場合

この例では、非メイン MSFC がメイン MSFC に対し、アップになったことを通知しています。非メイン MSFC の Config Sync AdminStatus はディセーブルであるため、メイン MSFC に、非メイン MSFC のハイ アベイラビリティ冗長機能をイネーブルにする必要があることを示す次のメッセージが表示されます。

Router-16#
Non-Designated Router came up.
High-Availability Redundancy Feature is not enabled on the Non-Designated Router
 

次に、非メイン MSFC 上で、ハイ アベイラビリティ冗長機能をイネーブルにする例を示します。

Router-15# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router-15(config)# redundancy
Router-15(config-r)# high-availability
Router-15(config-r-ha)# config-sync
Router-15(config-r-ha)#
00:03:47: %SYS-5-CONFIG_I: Configured from console by console
00:03:47: %RUNCFGSYNC-6-SYNCEVENT:
The High-Availability Redundancy Feature is enabled
The config mode is no longer accessible
 
00:00:51: %RUNCFGSYNC-6-SYNCEVENT:
Non-Designated Router is now online
Running Configuration Synchronization will begin in 1 minute
 

非メイン MSFC を安定させるため、1 分間のタイマーがスタートします。タイマーが切れると、現在の実行コンフィギュレーションのスナップショットが非メイン MSFC に送信されます。実行コンフィギュレーションが同期化される前に、次のメッセージが表示されます。

00:01:51: %RUNCFGSYNC-6-SYNCEVENT:
Syncing Running Configuration to the Non-Designated Router
 

次の例は、メイン MSFC および非メイン MSFC 上の Config Sync AdminStatus および Config Sync RuntimeStatus がイネーブルに設定されていることを示しています。

Router-15# show redundancy
Designated Router: 1 Non-designated Router:2
 
Redundancy Status: non-designated
Config Sync AdminStatus : enabled
Config Sync RuntimeStatus: enabled
 
 
Router-16# show redundancy
Designated Router: 1 Non-designated Router:2
 
Redundancy Status: designated
Config Sync AdminStatus : enabled
Config sync RuntimeStatus: enabled

例 5:メイン MSFC がダウンした場合

この例では、非メイン MSFC がメイン MSFC に切り替わります。設定の同期化がディセーブルになり、CLI でのコンフィギュレーション モードが利用できるようになります。

元のメイン MSFC を再びアップにすると、この MSFC は非メイン MSFC になります。「例 4:非メイン MSFC をアップにする場合」を参照してください。

単一ルータ モードの冗長機能

ここでは、単一ルータ モード(SRM)の冗長機能の設定手順について説明します。

「ハードウェアおよびソフトウェアの要件」

「SRM 冗長性設定時の注意事項」

「Supervisor Engine 720 における単一ルータ モードの冗長機能の設定」

「Supervisor Engine 1 または Supervisor Engine 2 における単一ルータ モードの冗長機能の設定」

「単一ルータ モードをイネーブルに設定したイメージのアップグレード」

「単一ルータ モードの終了」

SRM 冗長機能は、両方の MSFC2 が同時にアクティブな内部冗長(デュアル)MSFC2 コンフィギュレーションに代わるものです。SRM 冗長機能では、ネットワークから見えるのは常に指定ルータだけです。非指定ルータは完全に起動され、SRM 開始時にイネーブルに自動設定される設定同期化に参加します。SRM では、「alt」キーワード以後のコンフィギュレーションはすべて無視されます。したがって、非指定ルータの設定は指定ルータのものとまったく同じですが、そのインターフェイスは回線ダウン ステートのままでネットワークからは見えません。ルーティング プロトコルなどのプロセスは、非指定および指定ルータ上で作成されますが、非指定ルータのインターフェイスはすべて回線ダウン ステートにあります。このためネットワークからのアップデートの送受信は行いません。

指定ルータに障害が発生すると、非指定ルータは、非指定ルータから指定ルータにステートを変更し、そのインターフェイスのステートがリンク アップに変わります。新しい指定ルータは、既存のスーパーバイザ エンジン スイッチ プロセッサ エントリを使用してレイヤ 3 トラフィックを転送しながら、ルーティング テーブルを構築します。スイッチ プロセッサは引き続き古いエントリを使用して、レイヤ 3 パケットを転送します。事前に定義された時間が経過した後、新規の指定ルータは新しいレイヤ 3 スイッチング情報をスイッチ プロセッサにダウンロードします。


) Cisco IOS Release 12.1(11b)E 以降のリリースでは、新しい指定ルータがスーパーバイザ エンジンのスイッチ プロセッサに新しいレイヤ 3 スイッチング情報をダウンロードする前に待機する移行時間を指定できます。設定の詳細については、「新しいアクティブ指定ルータに対する移行時間の指定」を参照してください。


ハードウェアおよびソフトウェアの要件

SRM 冗長機能を設定するには、次のハードウェアおよびソフトウェアが必要です。

2 つの同一スーパーバイザ エンジン ドーター カードから構成される 1 つのシャーシ

PFC3B/PFC3BXL および MSFC2A 搭載の Supervisor Engine 32

PFC3A/PFC3B/PFC3BXL および MSFC3 搭載の Supervisor Engine 720

PFC2 および MSFC2 搭載の Supervisor Engine 2

PFC および MSFC または MSFC2 搭載の Supervisor Engine 1


) Cisco IOS Release 12.1(8a)E4 は、Supervisor Engine 1 および MSFC を使用する SRM 冗長構成の初期サポートを提供します。



マルチキャスト サポート:Release 7.1(1) よりも前のソフトウェア リリースでは、MSFC または MSFC2 搭載の Supervisor Engine 1 を SRM 冗長構成で使用する場合、2 番めの MSFC へのフェールオーバーがマルチキャスト MLS に関してステートフルにならない点に注意してください。プライマリ MSFC でエラーが発生すると、すべてのマルチキャスト MLS エントリが削除され、新しくアクティブになった MSFC によって再作成されて再インストールされます。



マルチキャスト サポート:Release 7.1(1) 以降のソフトウェア リリースでは、PFC および MSFC2 搭載の Supervisor Engine 1 および PFC2 および MSFC2 搭載の Supervisor Engine 2 に関して、マルチキャスト トラフィックの SRM 冗長性サポートが改善されています。マルチキャストに関する改善は、MSFC 搭載の Supervisor Engine 1 には当てはまりません。

SRM 冗長機能をイネーブルにすると、コンバージェンス タイムが向上し、切り替え時のマルチキャスト トラフィックの停止が短縮されます。MSFC2 は、切り替え時にマルチキャスト トラフィックで過負荷にならないように保護されます。スイッチは停止した MSFC2 からのフローをキャッシュし、新しくアクティブになった MSFC2 がルータを認識するまで、キャッシュのフローを使用してトラフィックを転送します。一度に少数のフローだけが MSFC2 に与えられるため、あふれることはありません。


Release 6.3(1) 以降のスーパーバイザ エンジン ソフトウェア リリース(Supervisor Engine 720 では Release 8.1(1) 以降のスーパーバイザ エンジン ソフトウェア リリース、Supervisor Engine 32 では Release 8.4(1) 以降のスーパーバイザ エンジン ソフトウェア リリースが必要)

Cisco IOS Release12.1(8a)E2 以降(Supervisor Engine 720 MSFC3 では、Cisco IOS Release12.2(14)SX2 以降が必要)

SRM 冗長性設定時の注意事項

ここでは、SRM 冗長性設定時の注意事項について説明します。

指定ルータおよび非指定ルータが同じ Cisco IOS イメージを実行している必要があります。

指定ルータおよび非指定ルータの両方のブートフラッシュに、Cisco IOS イメージが必要です。

非指定ルータは外部ネットワークに接続できません。

外部ネットワークから指定ルータで起動しないでください。外部ネットワークから起動すると、SRM の機能が大幅に低下します。

SRM 冗長機能を使用すると、指定ルータは外部ネットワークにアクセスし、 copy tftp: などのコピー コマンドを制約なしで使用できます。

スーパーバイザ エンジン上でハイ アベイラビリティをイネーブルに設定する必要があります。

RADIUS や TACACS+ などの認証方式を使用してスイッチへのアクセスを制御する場合、 switch console または session コマンドで非指定ルータにアクセスできるようにするときは、フォールバック オプションを設定してローカルのユーザ名とパスワードでログインする必要があります。

フォールバック オプションの設定手順については、 第 39 章「AAA によるスイッチ アクセスの設定」 を参照してください。

Supervisor Engine 720 における単一ルータ モードの冗長機能の設定


) 単一ルータ モード(SRM)の冗長機能は、Supervisor Engine 720 および Supervisor Engine 32 でサポートされる唯一の MSFC 冗長機能オプションです。


Supervisor Engine 720 および Supervisor Engine 32 では、MSFC で SRM を明示的にイネーブルにする必要はありません。SRM はデフォルトでイネーブルです。SRM が正常に動作しているか判断するため、次の 2 つの方法のうちいずれかで、両方の MSFC が同一のスタートアップ コンフィギュレーションを保有していることを確認する必要があります。

1. システムをリセットしてリロードした後、 write erase コマンドを非メイン MSFC 上で実行し、非メイン MSFC をリロードします。

2. システムをリセットしてリロードした後、 show redundancy コマンドを入力して、SRM ランタイム ステータスがイネーブルであることを確認します。SRM ランタイム ステータスがイネーブルであることを確認した後、 write memory コマンドをメイン MSFC 上で実行し、非メイン MSFC をリロードします(非メイン MSFC の設定をリロード プロンプトで保存しないでください)。


ヒント 非メイン MSFC がメイン MSFC と同じ設定で起動する場合は、第 2 の方法を推奨します。その方が、予期しない問題が発生する可能性が小さくなります。



) システム起動時に、非メイン MSFC のスタートアップ コンフィギュレーションにメイン MSFC 設定にはない設定項目があった場合、MSFC は実行コンフィギュレーションで一貫性がなくなります。上記の 2 つの手順により、非メイン MSFC が常に MSFC と同じ実行コンフィギュレーションを持つことができます。


Supervisor Engine 1 または Supervisor Engine 2 における単一ルータ モードの冗長機能の設定

SRM 冗長機能を設定するには、次の手順を実行します。


注意 デュアル ルータ モードから SRM 冗長機能に移行する前に、MSFC の copy running-config コマンドを使用し、非 SRM コンフィギュレーションをブートフラッシュに保存するようにしてください。SRM 冗長機能に移行すると、代替コンフィギュレーション(alt キーワードの後のコンフィギュレーション)は失われます。SRM 冗長機能をイネーブルにする前に、両方の MSFC に copy running-config bootflash:nosrm_dual_router_config コマンドを入力し、デュアル ルータ モード コンフィギュレーションをブートフラッシュに保存してください。

詳細については、「単一ルータ モードの終了」を参照してください。


) この手順は、指定ルータがスロット 1 に搭載の MSFC2 で、非指定ルータがスロット 2 に搭載の MSFC2 であり、さらにアクティブ スーパーバイザ エンジンはスロット 1 にあり、スタンバイ スーパーバイザ エンジンはスロット 2 にあると仮定しています。



ステップ 1 show version コマンドを使用して、両方のスーパーバイザ エンジンが、スーパーバイザ エンジン Release 6.3(1) 以降のソフトウェア リリースを実行していることを確認します。

ステップ 2 set system highavailability enable コマンドを使用して、アクティブ スーパーバイザ エンジン上でハイ アベイラビリティ機能をイネーブルにします。 show system highavailability コマンドを使用して、ハイ アベイラビリティ機能がイネーブルになっていることを確認します。

ステップ 3 コンソール接続を行っている場合は、 switch console コマンドを使用して指定ルータにアクセスします。Telnet セッションを使用して接続している場合は、 session mod コマンドを使用して指定ルータにアクセスします。

ステップ 4 Cisco IOS Release 12.1(8a)E2 以降のイメージを指定ルータおよび非指定ルータのブートフラッシュにコピーします。

ステップ 5 指定ルータおよび非指定ルータに対してブート イメージとコンフィギュレーション レジスタを設定して、リロード時に新しいイメージを起動します。

指定ルータの場合は、 boot system flash bootflash: image_name コマンドを使用してこのイメージがブート リストの最初にあることを確認します。 boot system コマンドの no 形式を使用して、実行コンフィギュレーションに表示されている( show running-config )すべての既存の boot system コマンドを削除します。

非指定ルータの場合は、
config-register 0x102 コマンドを入力して、自動起動するようにコンフィギュレーション レジスタを設定します。


) SRM 対応 Cisco IOS イメージがロード済みの場合、
ステップ 6の手順は不要です。


ステップ 6 reload コマンドを実行して、指定ルータおよび非指定ルータをリロードします。

ステップ 7 コマンドの no 形式を入力して、指定ルータ上で設定の同期化( config-sync )をディセーブルにします。 write memory コマンドを入力します。これにより、指定ルータと非指定ルータの両方でコンフィギュレーション モードにアクセスできるようになります。

ステップ 8 最初に指定ルータ上で SRM をイネーブルにしてから、次のように非指定ルータ上で SRM をイネーブルにします。

Router(config)# redundancy
Router(config-r)# high-availability
Router(config-r-ha)# single-router-mode
 

) Cisco IOS Release 12.1(11b)E 以降のリリースでは、新しい指定ルータがスーパーバイザ エンジンのスイッチ プロセッサに新しいレイヤ 3 スイッチング情報をダウンロードする前に待機する移行時間を指定できます。設定の詳細については、「新しいアクティブ指定ルータに対する移行時間の指定」を参照してください。


ステップ 9 指定ルータ上で write memory コマンドを実行し、非指定ルータのスタートアップ コンフィギュレーションが SRM をイネーブルに設定していることを確認します。

ステップ 10 非指定ルータ上で show startup-config コマンドを実行し、非指定ルータが次のコンフィギュレーション ステートメントを持っていることを確認します。

redundancy
high-availability
single-router-mode
 

ステップ 11 指定ルータおよび非指定ルータ上で show redundancy コマンドを実行し、いずれのルータにも次のコンフィギュレーション ステートメントがあることを確認します。

Single Router Mode RuntimeStatus: enabled
 

ない場合は、ステップ 9 および 10 をステップ間で十分な時間を取りながら繰り返します。

ステップ 12 reload コマンドを使用して、非指定ルータをリロードします。設定を保存するかどうかの問い合せには、 no を入力します。

次の出力は、SRM 冗長機能をイネーブルにするために指定ルータおよび非指定ルータに対して使用したコンフィギュレーション コマンドの要約です。

Time Designated Router Nondesignated Router
---- --- ----
t0: conf t->red->hi->no config-sync
t1: conf t->red->hi->no config-sync
t2: conf t->red->hi->single-router-mode
t3: conf t->red->hi->single-router-m
t4: write mem
t5: reload
 


 

新しいアクティブ指定ルータに対する移行時間の指定

Release 12.1(11b)E よりも前の Cisco IOS リリースでは、移行時間は 120 秒に定められ、ユーザは設定できませんでした。ルーティング コンバージェンス時間が異なるため、120 秒では足りないことがあります。古いレイヤ 3 スイッチング エントリは消去され、新たにダウンロードしたレイヤ 3 スイッチング情報が不完全なことがあります。

Cisco IOS Release 12.1(11b)E 以降のリリースでは、新しい指定ルータがスイッチ プロセッサに新しいレイヤ 3 スイッチング情報をダウンロードする前に待機する移行時間を指定できます。切り替え時には、スイッチ プロセッサに新しいレイヤ 3 スイッチング情報がダウンロードされる前に、設定した秒数の間、古いレイヤ 3 スイッチング情報が使用されます。

ノンストップの転送が必要な場合、移行時間をデフォルト値(120 秒)より小さい値に設定することは推奨できません。ルートのコンバージェンスには最低限 30 ~ 60 秒かかります。

移行時間を指定するには、次のコマンドを入力します(この例では移行時間は 240 秒に設定されています)。

Router(config)# redundancy
Router(config-r)# high-availability
Router(config-r-ha)# single-router-mode
Router(config-r-ha)# single-router-mode failover ?
table-update-delay Adjust for routing convergence time
Router(config-r-ha)# single-router-mode failover table-update-delay ?
<0-4294967295> Delay in seconds between switch over detection and h/w FIB reload
Router(config-r-ha)# single-router-mode failover table-update-delay 240
Router(config-r-ha)#
 

移行時間をデフォルトの 2 分に設定する場合は、次のように、このコマンドの no 形式を使用します。

Router(config-r-ha)# no single-router-mode failover table-update-delay
 

移行時間を表示するには、次のようにします。

Router-16# show redundancy
Designated Router: 2 Non-designated Router: 1
 
Redundancy Status: designated
 
Config Sync AdminStatus : enabled
 
Config Sync RuntimeStatus: enabled
 
Single Router Mode AdminStatus : enabled
 
Single Router Mode RuntimeStatus: enabled
 
Single Router Mode transition timer : 240 seconds <---- transition time
 
Router-16#

単一ルータ モードをイネーブルに設定したイメージのアップグレード

ここでは、単一ルータ モードの稼動時にアクティブおよびスタンバイ MSFC 上で Cisco IOS イメージをアップグレードする方法について説明します。新しいイメージの名前は c6msfc2-jsv-mz.9E です。スタンバイ MSFC では TFTP でイメージをロードきませんが、スーパーバイザ エンジン フラッシュ PC カード(sup-slot0:)からイメージをロードすることができます。


) この手順はデータ トラフィックに影響します。スケジュールされているメンテナンス ウィンドウで実行することを推奨します。


イメージをアップグレードする手順は、次のとおりです。


ステップ 1 アクティブ スーパーバイザ エンジン上で、 copy tftp sup-slot0: コマンドを実行し、表示されるプロンプトに従って新しい(c6msfc2-jsv-mz.9E)イメージをスーパーバイザ エンジン フラッシュ PC カードにロードします。

ステップ 2 コンソール接続を行っている場合は、 switch console コマンドを使用してアクティブ MSFC にアクセスします。Telnet セッションを使用して接続している場合は、 session mod コマンドを使用してアクティブ MSFC にアクセスします。

ステップ 3 アクティブ MSFC 上で、スーパーバイザ エンジン フラッシュ PC カードから新しいイメージを MSFC ブートフラッシュにコピーします。

copy sup-slot0:c6msfc2-jsv-mz.9E bootflash:c6msfc2-jsv-mz.9E
 

ステップ 4 スタンバイ MSFC にアクセスするには、 switch supervisor コマンドを入力し、その後にアクティブ スーパーバイザ エンジンに switch console コマンドを入力します。


) スタンバイ MSFC は、アクティブ スーパーバイザ エンジンから発行された show module コマンドの出力には表示されません。


ステップ 5 スタンバイ MSFC 上で、スーパーバイザ エンジン フラッシュ PC カードから新しいイメージを MSFC ブートフラッシュにコピーします。

copy sup-slot0:c6msfc2-jsv-mz.9E bootflash:c6msfc2-jsv-mz.9E
 

ステップ 6 アクティブ MSFC 上で、MSFC のリロード時に新しいイメージを起動するように指定します。

boot system flash bootflash:c6msfc2-jsv-mz.9E
 

ステップ 7 アクティブ MSFC 上で、 write memory コマンドを実行して、スタンバイ MSFC スタートアップ コンフィギュレーションが起動情報を取得していることを確認します。

ステップ 8 reload コマンドを実行して、スタンバイ MSFC をリロードします。

ステップ 9 アクティブおよびスタンバイ MSFC 上で show redundancy コマンドを実行し、ともに次のコンフィギュレーション ステートメントを持っていることを確認します。

Single Router Mode RuntimeStatus: enabled
 

ステップ 10 reload コマンドを実行して、アクティブ MSFC をリロードします。

これで、どちらの MSFC も c6msfc2-jsv-mz.9E イメージを実行している状態になります。


 

単一ルータ モードの終了


) 単一ルータ モードの冗長機能を設定する前に、デュアル ルータ モードで使用される実行コンフィギュレーションのコピーを保存した場合は、次に記載する手順を実行する必要はありません。SRM 冗長機能を終了してデュアル ルータ モードに戻るには、両方の MSFC 上で copy bootflash:nosrm_dual_router_config startup-config コマンドを入力します。コンフィギュレーションのコピー後、reload コマンドで MSFC をリロードします。


SRM を終了する手順は、次のとおりです。


ステップ 1 指定ルータ上で、コマンドの no 形式を入力して SRM をディセーブルにします。

Router(config)# redundancy
Router(config-r)# high-availability
Router(config-r-ha)# no single-router-mode
 

ステップ 2 指定ルータおよび非指定ルータ上で write memory コマンドを実行します。

ステップ 3 指定ルータおよび非指定ルータ上で show startup-config コマンドを実行し、スタートアップ コンフィギュレーションに「single-router mode」がないことを確認します。

ステップ 4 reload コマンドを実行して、指定ルータおよび非指定ルータをリロードします。

これで、指定ルータおよび非指定ルータ上で SRM がディセーブルの状態になります。


 

手動モード MSFC 冗長機能


) SRM 機能を含む Release 6.3(1) スーパーバイザ エンジン ソフトウェア リリースの投入により、手動モード MSFC 冗長機能のサポートは 2002 年 12 月までとなります。手動モード MSFC 冗長機能ではなく SRM を使用することを推奨します。この場合、機能のサポートに期限はなく、また、自動レイヤ 3 フェールオーバー機能も得られます。


ここでは、一方の MSFC をアクティブに、もう一方の MSFC を ROM モニタ モードにした状態で冗長 MSFC を設定する方法について説明します。

「ハードウェアおよびソフトウェアの要件」

「手動モード MSFC 冗長機能設定時の注意事項」

「スタンバイ MSFC のアクセス」

「手動による MSFC の起動」

「MSFC コンフィギュレーション レジスタの設定」

「MSFC 回復手順」

ハードウェアおよびソフトウェアの要件

レイヤ 3 の冗長機能を設定するには、少なくとも次のいずれかの構成が必要です。

2 つの同一スーパーバイザ エンジン ドーター カードから構成される 1 つのシャーシ。

ポリシー フィーチャ カード(PFC)および MSFC または MSFC2 搭載の Supervisor Engine 1(両方のスーパーバイザ エンジンに同一タイプの MSFC を搭載することが必要)

PFC2 および MSFC2 搭載の Supervisor Engine 2

それぞれスーパーバイザ エンジンを搭載した 2 つのシャーシ。各シャーシに少なくとも 1 つはスーパーバイザ エンジンを搭載しておく必要があります。各スーパーバイザ エンジンに、PFC および MSFC を取り付けておく必要があります。

手動モード MSFC 冗長機能では、次のソフトウェアが必要です。

Release 6.1(3) 以降のスーパーバイザ エンジン ソフトウェア リリースおよび Cisco IOS Release 12.1(7)E 以降のリリース

Release 5.5.8 以降のスーパーバイザ エンジン ソフトウェア リリースおよび Cisco IOS Release 12.1(7a)E1 以降のリリース


) 各 MSFC は、同じ Cisco IOS ソフトウェア リリースを実行している必要があります。


手動モード MSFC 冗長機能設定時の注意事項

ここでは、手動モード MSFC 冗長機能設定時の注意事項について説明します。

MSFC の切り替えは手動であるため、外部冗長ルータが存在する環境、および HSRP が使用されているか、何らかの形式のゲートウェイ検出がホスト上に実装されている環境だけで手動モード MSFC 冗長機能を使用することを推奨します。

アクティブ MSFC(MSFC-15)上のコンフィギュレーション レジスタが 0x2102 に、ROM モニタ モードの MSFC(MSFC-16)上のコンフィギュレーション レジスタが 0x0 に設定されていることを確認します。この設定により、両方の MSFC が同時にアクティブになるのを防止し、アクティブ MSFC をリセット後にオンラインにすることができます。コンフィギュレーション レジスタの設定の詳細については、「MSFC コンフィギュレーション レジスタの設定」を参照してください。


) 両方の MSFC を 0x0 に設定することはオプションとしてサポートされていますが、スイッチをリセットする場合はユーザによる設定が必要です。


IP アドレスの領域を保護し、レイヤ 3 の全体的な複雑性を緩和するには、両方の MSFC 上で設定同期化をディセーブルにし、すべての「alt」アドレスを削除するようにします。alt アドレスが使用されていると、IP アドレス領域が保護されず、(BGP などの)リンクレベルのピアリングが存在する場合にレイヤ 3 の複雑性が増します。

メンテナンス ウィンドウで ROM モニタ モードの MSFC を起動した場合、アクティブ MSFC と完全に同じ設定かどうかを確認してください。表 23-2 に記載されている設定時の注意事項を参照してください。

手動モード MSFC 冗長機能の間、スーパーバイザ エンジン上でハイ アベイラビリティをイネーブルにして、MSFC 切り替え実行時のレイヤ 2 ダウンタイムを最小限に抑えます。ハイ アベイラビリティはプロトコル フィルタリング、ポート セキュリティ、Dynamic VLAN(DVLAN)、Generic Attribute Registration Protocol(GARP)VLAN Registration Protocol(GVRP)には対応していないため、手動モード MSFC 冗長機能使用時は、これらの機能をディセーブルに設定することを推奨します。

両方のスーパーバイザ エンジン上のコンソール ポートに運用担当者がアクセスできるようにします(端末サーバまたはモデムによる帯域外アクセス)。


) ここでの手順は、switch console コマンドを使用してスーパーバイザ エンジンから MSFC にアクセスします。Telnet セッションでは、switch console コマンドはサポートされていません。


スタンバイ MSFC のアクセス

スタンバイ MSFC にアクセスするには、 switch supervisor コマンドを入力し、その後に switch console コマンドを入力します。


) スタンバイ MSFC は、アクティブ スーパーバイザ エンジンから発行された show module コマンドの出力には表示されません。


手動による MSFC の起動

両方の MSFC のコンフィギュレーション レジスタが 0x0 に設定されている場合、MSFC 手動モードでは、スイッチをリセットするたびに MSFC を手動で起動する必要があります。MSFC を手動で起動するには、次の作業を行います。


ステップ 1 switch console コマンドを使用して MSFC ROMMON プロンプトにアクセスします。

ステップ 2 boot bootflash: image コマンドを入力します。

ステップ 3 MSFC の起動後、Router>プロンプトに Ctrl-C を 3 回入力すると、スーパーバイザ エンジン プロンプトに戻ります。 session コマンドを実行して、MSFC にアクセスします。


 

MSFC コンフィギュレーション レジスタの設定

手動モード MSFC 冗長機能では、次のようにコンフィギュレーション レジスタを設定します。


ステップ 1 アクティブ MSFC(MSFC-15)上で Cisco IOS コンフィギュレーション モードから、 config-register 0x2102 コマンドを入力します。

ステップ 2 ROM モニタ モードの MSFC(MSFC-16)上で、 config-register 0x0 コマンドを入力します。


) 両方の MSFC コンフィギュレーションの boot システム コマンドがブートフラッシュの有効なイメージをポイントするようにし、かつ、これらの boot コマンドを無視するようにはコンフィギュレーション レジスタを設定しないことを推奨します。



 

MSFC 回復手順

ここでは、一時的または永続的な MSFC 障害から回復する手順について説明します。

アクティブ MSFC の一時的な障害が発生した場合、コンフィギュレーション レジスタが 0x2102 に設定されているため、MSFC が再起動します。

永続的な障害の疑いがあるアクティブな MSFC は確認する必要があります。それには、アクティブ スーパーバイザ エンジンのコンソール ポートから reset 15 コマンドを実行し、アクティブ MSFC が正常に再起動するかどうかを確認します。再起動しない場合は、次の 2 つの方法でスタンバイ MSFC に切り替えることができます。

方法 1:スイッチに物理的にアクセスする場合

スイッチに物理的にアクセスする場合は、この方法を使用 します。問題のある MSFC を装備しているアクティブ スーパーバイザ エンジンを取りはずすことにより、冗長スーパーバイザ エンジンが動作を引き継ぎます。冗長スーパーバイザ エンジンの物理コンソール ポートで、次の手順を実行します。


ステップ 1 switch console コマンドを実行します。

ステップ 2 ROMMON プロンプトで、 boot bootflash: image コマンドを実行します。

ステップ 3 スタンバイ MSFC の起動後、Cisco IOS コンフィギュレーション モードで config-register 0x2102 コマンドを実行して、スイッチのリセット時に MSFC が起動するようにします。


 

方法 2:スイッチにリモート アクセスだけが可能な場合

スイッチにリモート アクセスしかできない場合は、この方法を使用します。問題のある MSFC を装備しているアクティブ スーパーバイザ エンジンで、次の手順を実行します。


) 問題のある MSFC がスタンバイ スーパーバイザ エンジン上にある場合は、switch supervisor コマンドを実行します。



ステップ 1 switch console コマンドを実行します。

ステップ 2 ブレーク信号を送信して問題のある MSFC の ROMMON に入ります(ブレークが有効なのは MSFC が引き続き再起動している場合に限ります)。システムのブートストラップ メッセージが出力されてから、メイン Cisco IOS イメージが解凍されるまでの間に発行されるように、ブレークのタイミングを決める必要があります(次の出力の 2 つの矢印を参照)。

System Bootstrap, Version 12.0(3)XE, RELEASE SOFTWARE
Copyright (c) 1998 by cisco Systems, Inc.
Cat6k-MSFC platform with 131072 Kbytes of main memory <======= ISSUE BREAK AFTER THIS POINT
 
 
Self decompressing the image : ###################################################################################### [OK]
 
<==========BUT BEFORE THIS POINT
 
Self decompressing the image : ################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################### [OK]
 

ステップ 3 ROMMON プロンプトで、 confreg コマンドを入力します。

a. 「do you wish to change the configuration? y/n [n]:」のプロンプトに、 y と入力します。

b. Enter を押してすべての質問に対してデフォルトの設定を受け入れると、次のプロンプトが表示されます。「change the boot characteristics?y/n [n]:」

c. y と入力します。

d. 0 と入力して、次のプロンプトで 0 = ROM Monitor オプションを選択します。

e. Configuration Summary を調べて、boot: the ROM Monitor の値を確認します。

f. 再度、「do you wish to change the configuration? y/n [n]:」というプロンプトが表示されます。

g. n と入力します。

h. ROMMON プロンプトに戻ります。

ステップ 4 reset コマンドを実行して、MSFC が ROMMON で起動していることを確認します。このステップにより、この MSFC とアクティブ MSFC が同時に起動しないようになります。

ステップ 5 Ctrl-C を 3 回入力して、スーパーバイザ エンジン プロンプトに戻ります。

ステップ 6 ハイ アベイラビリティがスーパーバイザ エンジンのステートを同期化していることを確認します。そのためには、 show system highavailability コマンドを実行して、ハイ アベイラビリティの「Operational-status」が ON であることを確認します。

ステップ 7 switch supervisor コマンドを実行します。

ステップ 8 switch console コマンドを実行します。

ステップ 9 スタンバイ MSFC の ROMMON プロンプトで、ステップ 3 を繰り返しますが、ステップ 3d ではオプション 2 の [boot system] を選択します。

change the boot characteristics? y/n [n]: y
enter to boot:
0 = ROM Monitor
1 = the boot helper image
2-15 = boot system
[2]: 2 <========================
 
 
Configuration Summary
enabled are:
load rom after netboot fails
console baud: 9600
boot: the ROM Monitor
 
do you wish to change the configuration? y/n [n]: n
 
 
You must reset or power cycle for new config to take effect
rommon 2 >
 

ステップ 10 ROMMON プロンプトで reset コマンドを入力してシステムを起動します。

ステップ 11 MSFC が起動したら、新しいアクティブ MSFC のコンソール ポート上の Cisco IOS コンフィギュレーション モードで config-register 0x2102 コマンドを実行します。

ステップ 12 Ctrl-C を 3 回入力して、スーパーバイザ エンジン プロンプトに戻ります。