Catalyst 6500 シリーズ スイッチ ソフトウェア コンフィギュレーション ガイド Software Release 8.5
ASLB の設定
ASLB の設定
発行日;2012/06/27 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 10MB) | フィードバック

目次

ASLB の設定

ハードウェアおよびソフトウェアの要件

ASLB の機能

ASLB のレイヤ 3 動作

ASLB のレイヤ 2 動作

クライアントからサーバへのデータ転送

パス 1

パス 2

パス 3 ― N

パス N + 1、N + 2...

サーバからクライアントへのデータ転送

ケーブル接続の注意事項

スイッチ上での ASLB の設定

LocalDirector インターフェイスの設定

ASLB 設定時の注意事項

ルータ

サーバ

IP アドレス

スーパバイザ エンジン

バックアップ LocalDirector の設定(任意)

MSFC および MLS

NDE

VLAN

スイッチ ポートの設定

CLI による ASLB の設定

LocalDirector に接続されたスイッチ ポートの設定

ASLB のイネーブル化およびディセーブル化

高速化するサーバ仮想 IP アドレスおよび TCP ポートの指定

構成ルータの MAC アドレスの指定

LocalDirector の MAC アドレスの指定

ルータ VLAN および VLAN 上の LocalDirector ポートの指定

サーバ VLAN および VLAN 上の LocalDirector ポートの指定

UDP エージングの設定

ASLB 設定のコミット

ASLB 設定の表示

ASLB MLS エントリの表示

ASLB MLS 統計情報の表示

ASLB 設定の消去

ASLB の設定例

ASLB 冗長構成の例

IP アドレス

MAC アドレス

Catalyst 6500 シリーズ スイッチ 1 の設定

Catalyst 6500 シリーズ スイッチ 2 の設定

ルータ 1 の設定

ルータ 2 の設定

LocalDirector の設定

ASLB 設定のトラブルシューティング

ASLB の設定

この章では、Catalyst 6500 シリーズ スイッチ上で Accelerated Server Load Balancing(ASLB)を設定する方法について説明します。


) この章で使用しているコマンドの完全な構文および使用方法の詳細については、『Catalyst 6500 Series Switch Command Reference』を参照してください。



) この章で説明する情報および手順は、Policy Feature Card(PFC; ポリシー フィーチャ カード)を搭載した Supervisor Engine 1 にのみ当てはまります。ASLB は、PFC2 搭載の Supervisor Engine 2、PFC3A/PFC3B/PFC3BXL 搭載の Supervisor Engine 720、または PFC3B/PFC3BXL 搭載の Supervisor Engine 32 ではサポートされていません。


この章で説明する内容は、次のとおりです。

「ハードウェアおよびソフトウェアの要件」

「ASLB の機能」

「ケーブル接続の注意事項」

「スイッチ上での ASLB の設定」

「ASLB の設定例」

「ASLB 冗長構成の例」

「ASLB 設定のトラブルシューティング」

ハードウェアおよびソフトウェアの要件

ASLB 設定のハードウェアおよびソフトウェアの要件は、次のとおりです。

LocalDirector の要件は、次のとおりです。

ハードウェア プラットフォーム ― LocalDirector モデル 410、415、416、420、または 430

インターフェイス モジュール ― ASLB を設定するには、10/100BASE-X イーサネット インターフェイスが 2 つ、または 1000BASE-X ギガビット イーサネット インターフェイスが 2 つ必要です。


) 1000BASE-X インターフェイスは、LocalDirector 420 および 430 上でのみサポートされています(LocalDirector 410、415、または 416 ではサポートされていません)。


ソフトウェア ― シスコ コンフィギュレーション バージョン 3.2.x

Catalyst 6500 シリーズ スイッチの要件は、次のとおりです。

PFC を搭載した Supervisor Engine 1(または 1A)

Release 5.3(1)CSX 以降のスーパバイザ エンジン ソフトウェア リリース

構成ルータは、次のとおりです。

Multilayer Switch Feature Card(MSFC; マルチレイヤ スイッチ フィーチャ カード) ― Release 5.4(1)CSX 以降のスーパバイザ エンジン ソフトウェア リリースでは、ASLB を構成するルータとして Catalyst 6500 シリーズ スイッチ内の MSFC を使用できます。これより古いスーパバイザ エンジン ソフトウェア リリースでは、内部 MSFC は構成ルータとして 使用できません

外部 MSFC ― Catalyst 6500 シリーズ スイッチの外付け MSFC は、構成ルータとして使用できます。

Multilayer Switch Module(MSM) ― ASLB に使用する Catalyst 6500 シリーズ スイッチに MSM が搭載されている場合、その MSM は ASLB の構成ルータとして使用できます。Catalyst 6500 シリーズ スイッチの外付け MSM も、構成ルータとして使用できます。

その他のシスコ製ルータも、ASLB の構成ルータとして使用できます。

ASLB の機能


) TCP/IP トラフィックのロードバランシングの概要については、『Cisco LocalDirector Installation and Configuration Guide』 Version 3.2 を参照してください。


ここでは、ASLB について説明します。

「ASLB のレイヤ 3 動作」

「ASLB のレイヤ 2 動作」

「クライアントからサーバへのデータ転送」

「サーバからクライアントへのデータ転送」

LocalDirector は、機密性に優れたリアルタイムの内蔵 OS(オペレーティング システム)で、複数のサーバ間で TCP/IP トラフィック負荷をインテリジェントに分散します。ASLB によって、Catalyst 6500 シリーズ スイッチは Cisco LocalDirector のロードバランシング フローをキャッシュし、LocalDirector のパフォーマンスを高速化できます。


) LocalDirector のパフォーマンス高速化は、Catalyst 6500 シリーズのレイヤ 3 スイッチング テクノロジーによって達成されます。


図51-1 に、ASLB 機能を使用した場合のネットワークを示します。スイッチと LocalDirector は、2 つのリンクで接続する必要があります。一方のリンクはルータが存在する VLAN に接続し、もう一方はサーバが存在する VLAN に接続します。図51-1 では、1 つの LocalDirector リンクが VLAN 10(ルータ VLAN)、もう 1 つのリンクは VLAN 20(サーバ VLAN)に接続されています。

LocalDirector は、directed モードおよび dispatched モードをサポートしています。Catalyst 6500 シリーズ スイッチの ASLB 機能でサポートされているのは、dispatched モードだけです。

図51-1 ASLB の機能

 

ASLB のレイヤ 3 動作

サーバの仮想 IP アドレスと TCP ポートのペアを 1024 個まで指定して、スイッチによるトラフィック高速化を行うことができます。SYN、FIN、RST、およびゼロ以外のオフセットを持つフラグメント パケットを除いて、指定した仮想 IP/ポート間のすべてのトラフィックが高速化されます。このパケットは、(バックアップ LocalDirector が設定されている場合)アクティブ LocalDirector およびスタンバイ LocalDirector の両方にリダイレクトされます。

ASLB のレイヤ 2 動作

Catalyst 6500 シリーズ スイッチの CAM(連想メモリ)テーブルには、ルータ VLAN およびサーバ VLAN のエントリが含まれています。CAM テーブルでは、ルータ VLAN にはポート インデックスに対応付けられた LocalDirector の MAC アドレスのエントリが入っており、サーバ VLAN にはポート インデックスに対応付けられたルータの MAC アドレスのエントリが入っています。このようなポート インデックスでは、ポートは 0/0 として表示されています。 show cam system コマンドを入力すれば、システムの CAM エントリを表示できます。

表51-1 に、CAM テーブルのエントリを示します(ASLB 設定は、図51-1 に示されています)。最初のエントリは、VLAN 10 における LocalDirector の MAC アドレスを表しています。CAM テーブルでは、この MAC アドレスの Xtag 値が 14 であることが示されています。この値は、レイヤ 3 検索が必要であることを示します。2 番めのエントリは、ルータの MAC アドレスであり、これもレイヤ 3 検索が必要です。

 

表51-1 レイヤ 2 テーブル エントリ

VLAN
MAC アドレス
インデックス
Xtag1

10

LocalDirector MAC

0/0

14

20

ルータ MAC2

0/0

14

1.Xtag = レイヤ 2 テーブルで、MAC アドレスが属するルータを表す identifier フィールド

2.ルータの MAC アドレスは、ルータ VLAN(VLAN 10)ではなくサーバ VLAN(VLAN 20)に追加される点に注意してください。

クライアントからサーバへのデータ転送

図51-2 に、ルータからサーバへのデータ転送を示します。 表51-2 で一連のイベントについて説明し、 表51-3 にレイヤ 3 テーブル エントリを示します。

ここでは、クライアントからサーバへのデータ転送パスについて説明します。

「パス 1」

「パス 2」

「パス 3 ― N」

「パス N + 1、N + 2...」

パス 1

ルータからの最初のパケットは、LocalDirector の宛先 MAC アドレスが指定され、VLAN 10 に存在します。この MAC アドレスは、レイヤ 2 テーブルで Xtag 値が 14 になっています。この値はレイヤ 3 検索が必要であることを表し、SYN フラグが設定されているため、フレームはポート P A に転送されます。

スイッチ ハードウェアはフレームをポート P A に転送するほか、レイヤ 3 転送テーブルに「候補」エントリを作成します。このエントリはあとの段階で「イネーブラ」フレームによって更新され、完全な ASLB Multilayer Switching(MLS; マルチレイヤ スイッチング)エントリになります。

パス 2

LocalDirector はポート P A からフレームを受信したあと、標準的なロードバランシング決定を行い、フレームをポート P B に転送します。LocalDirector は宛先 MAC アドレスを適切なサーバのアドレスに変更します。このフレームはスイッチに入った時点で、「イネーブラ」フレームとみなされます。スイッチ ハードウェアはレイヤ 3 テーブルで検索を行い、前の候補パケット(LocalDirector を通じて転送されたパケット)によって作成されたエントリを検索します。この検索が成功すると、レイヤ 3 テーブルで「ヒット」が成立します。

パス 3 ― N

ASLB MLS エントリが作成済みになっています。パケットに SYN、FIN、RST フラグが設定されている場合、またはパケットがフラグメント化されている場合を除き、ルータからの後続のフレーム(LocalDirector MAC の宛先 MAC アドレスを指定)がレイヤ 3 スイッチングされます。

パス N + 1、N + 2...

接続の最後のフレームで、TCP ヘッダーに FIN または RST フラグのどちらかが設定され、それによってパケットが LocalDirector に転送されます。LocalDirector は、宛先 MAC アドレスを適切なサーバのアドレスに変更したあと、フレームをスイッチに戻さなければなりません。このリダイレクトされたフレームは、フローの最初のフレームと同じパスをたどります。LocalDirector はサーバとの接続終了を示すのに FIN パケットを使用し、ASLB は該当する ASLB MLS エントリを削除します。

図51-2 ASLB パケット フロー:クライアントからサーバへ

 

 

表51-2 ASLB パケット フロー:クライアントからサーバへ

パス番号
VLAN
MAC 宛先アドレス
MAC 送信元
アドレス
IP 宛先
アドレス
IP 送信元アドレス
フラグ
アクション

1

10

LocalDirector MAC3

ルータ MAC

VIP4

CIP5

SYN

レイヤ 3 テーブル内の候補エントリ

2

20

サーバ MAC6

ルータ MAC1

VIP

CIP

-

イネーブラ フレーム

3 ― N

10

LocalDirector MAC1

ルータ MAC

VIP

CIP

-

完全な ASLB MLS エントリの作成

N + 1

10

LocalDirector MAC1

ルータ MAC

VIP

CIP

FIN/RST

パス 1 リダイレクト

N + 2...

20

サーバ MAC

ルータ MAC1

VIP

CIP

FIN/RST

パス 2

3.この MAC アドレスでは、このパケットの VLAN に対応するレイヤ 2 テーブル内の Xtag 値が 14 です。

4.VIP = Virtual IP Address(仮想 IP アドレス)

5.CIP = Client’s IP address(クライアントの IP アドレス)

6.LocalDirector が選択したサーバの MAC アドレス

 

表51-3 ASLB レイヤ 3 テーブル エントリ : クライアントからサーバへ

IP 宛先
アドレス
IP 送信元アドレス
プロトコル
ポート
VLAN
MAC 宛先
アドレス
MAC 送信元
アドレス

VIP7

CIP8

TCP

80/YZ

20

サーバ MAC9

ルータ MAC

7.VIP = Virtual IP Address(仮想 IP アドレス)

8.CIP = Client’s IP address(クライアントの IP アドレス)

9.LocalDirector が選択したサーバの MAC アドレス

サーバからクライアントへのデータ転送

図51-3 に、サーバからクライアントへのデータ転送を示します。 表51-4 で一連のイベントについて説明し、 表51-5 にレイヤ 3 テーブル エントリを示します。

サーバからルータまたはクライアント装置へのトラフィックは同様に動作しますが、方向は逆となります( クライアントからサーバへのデータ転送 の説明を参照)。ただし、LocalDirector は、ルータに向かうすべてのパケットに対して固有の MAC アドレスをパケットの送信元として表します。クライアントからサーバへのトラフィックでは、パケットの送信元 MAC アドレスは書き換えられません。

図51-3 ASLB パケット フロー:サーバからクライアントへ

 

 

表51-4 ASLB パケット フロー:サーバからクライアントへ

パス番号
VLAN
MAC 宛先
アドレス
MAC 送信元アドレス
IP 宛先
アドレス
IP 送信元アドレス
フラグ
アクション

1

20

ルータ MAC10

サーバ MAC11

CIP12

VIP13

SYN

レイヤ 3 テーブル内の候補エントリ

2

10

ルータ MAC

LocalDirector MAC1

CIP

VIP

-

イネーブラ パケット

3 ― N

20

ルータ MAC1

サーバ MAC

CIP

VIP

-

完全な ASLB MLS エントリの作成

N + 1

20

ルータ MAC1

サーバ MAC

CIP

VIP

FIN/RST

パス 1 リダイレクト

N +2...

10

ルータ MAC

LocalDirector MAC1

CIP

VIP

FIN/RST

パス 2

10.この MAC アドレスでは、このパケットの VLAN に対応するレイヤ 2 テーブル内の Xtag 値が 14 です。

11.LocalDirector が選択したサーバの MAC アドレス

12.CIP = Client’s IP address(クライアントの IP アドレス)

13.VIP = Virtual IP Address(仮想 IP アドレス)

 

表51-5 ASLB レイヤ 3 テーブル エントリ : サーバからクライアントへ

IP 宛先
アドレス
IP 送信元アドレス
プロトコル
ポート
VLAN
MAC 宛先
アドレス
MAC 送信元
アドレス

VIP14

CIP15

TCP

80/YZ

20

サーバ MAC16

ルータ MAC

CIP

VIP

TCP

YZ/80

10

ルータ MAC

LocalDirector MAC

14.VIP = Virtual IP Address(仮想 IP アドレス)

15.CIP = Client’s IP address(クライアントの IP アドレス)

16.LocalDirector が選択したサーバの MAC アドレス

ケーブル接続の注意事項

ここでは、ASLB 設定のケーブル接続を行う際の注意事項について説明します。

スイッチへのサーバ接続を確認してください。各サーバはスイッチに直接接続されているか、またはサーバ VLAN の LocalDirector ポートと同じブリッジング ドメイン内に存在している必要があります。

カテゴリ 5 Unshielded Twisted-Pair(UTP; シールドなしツイストペア)ケーブル 2 本を使用して、2 つの 10/100 スイッチ ポート、または 2 つの 1000BASE-X スイッチ ポートを、対応する 2 つの LocalDirector インターフェイスに接続します。


注意 Catalyst 6500 シリーズ スイッチに LocalDirector を直接接続します。

LocalDirector インターフェイスの設定手順については、「LocalDirector インターフェイスの設定」を参照してください。スイッチの設定手順については、「CLI による ASLB の設定」を参照してください。

スイッチ上での ASLB の設定

ここでは、ASLB の設定作業について紹介します。

「LocalDirector インターフェイスの設定」

「ASLB 設定時の注意事項」

「CLI による ASLB の設定」

LocalDirector インターフェイスの設定

LocalDirector インターフェイスを ASLB 用に設定するための詳しい手順については、『 Cisco LocalDirector Installation and Configuration Guide 』 Version 3.2 を参照してください。

ASLB 設定時の注意事項

ここでは、ASLB を設定する際の使用上の注意事項と制限事項を示します。

「ルータ」

「サーバ」

「IP アドレス」

「スーパバイザ エンジン」

「バックアップ LocalDirector の設定(任意)」

「MSFC および MLS」

「NDE」

「VLAN」

「スイッチ ポートの設定」

設定例については、「ASLB の設定例」を参照してください。設定作業中に問題が生じた場合は、「ASLB 設定のトラブルシューティング」を参照してください。

ルータ

ルータ設定時の注意事項は次のとおりです。

ルータはロードバランシングの対象になるサーバのデフォルト ゲートウェイでなければならず、ルータの MAC アドレスを明確にしておく必要があります。

同一のルータ VLAN 上に、複数のルータが存在する必要があります。 set lda mac router コマンドを入力して、すべての構成ルータの MAC アドレスを指定します。

ASLB を設定すると、LocalDirector が接続されている 2 つの VLAN 上の TCP トラフィックをリダイレクトするための VACL が作成されます。これらの VLAN には、セキュリティ Cisco IOS Access Control List(ACL; アクセス制御リスト)または VACL は設定できません。

サーバ

サーバ設定時の注意事項は次のとおりです。

各サーバはスイッチに直接接続されているか、またはサーバ VLAN の LocalDirector ポートと同じブリッジング ドメイン内に存在している必要があります。

サーバのデフォルト ルートを、サーバの実際の IP アドレスと同じサブネットに存在するルータのエイリアス アドレスとして設定します。

サーバが仮想 IP アドレスに関する Address Resolution Protocol(ARP; アドレス解決プロトコル)要求を無視するように設定します。サーバの OS によっては、エイリアス(セカンダリ)IP アドレスに関する ARP 要求への応答をディセーブルに設定できない場合があります。仮想 IP アドレスに関する ARP 要求に応答するサーバの場合、対応策として、ルータ側でスタティック ARP エントリを使用してください。


注意 クライアント/サーバ間トラフィックを高速化するには、サーバが仮想 IP アドレスに関する ARP 要求を無視するように設定する必要があります。この設定をしなかった場合は、トラフィックの高速化が開始されず、LocalDirector に障害があった場合にネットワークでの完全冗長トポロジーの復旧に時間がかかります。

IP アドレス

IP アドレス設定時の注意事項は次のとおりです。


) 仮想 IP アドレスには、サーバの IP ネットワーク アドレス以外の IP アドレスを指定できます。


LocalDirector が各サーバの実際の IP アドレスを ARP 要求できるように、LocalDirector とサーバが同じサブネット上に存在するようにしてください。

各ルータが仮想 IP アドレスと同じサブネット上に存在するようにしてください。ルータが仮想 IP アドレスを ARP 要求できるようにするためです。

次のように、ネットワークに ASLB を設定します(この例では、仮想 IP アドレスは 171.1.1.200 です)。

 

ルータ
LocalDirector
サーバ17

171.1.1.1

171.1.1.2

171.1.1.x

17.各サーバのデフォルト ルータは 171.1.1.1 です。

ASLB 設定で使用するサーバがプライバシのために RFC 1918 に準拠しなければならない場合には、次の例を参考にしてください(この例では、仮想 IP アドレスは 171.1.1.200 です)。

 

ルータ
LocalDirector
サーバ18

171.1.1.1

171.1.1.2

10.1.1.x(実際の IP アドレス)

エイリアス 10.1.1.1

エイリアス 10.1.1.2

エイリアスを 171.1.1.200 にループバック

18.各サーバのデフォルト ルータは 10.1.1.1 です。

スーパバイザ エンジン

スーパバイザ エンジン設定時の注意事項は次のとおりです。

最大 32 のルータ MAC アドレスがサポートされています。

最大 1024 の仮想 IP/TCP ポートのペアがサポートされています。

バックアップ LocalDirector の設定(任意)

バックアップ LocalDirector のポートをスイッチに接続し、 set lda server および set lda router コマンドを入力してサーバおよびルータの設定を指定します。アクティブ LocalDirector およびバックアップ LocalDirector を所定のポートに接続しないと、 ASLB 機能は作動しません。

MSFC および MLS

MSFC および MLS 設定時の注意事項は次のとおりです。

Release 5.4(1)CSX 以降のスーパバイザ エンジン ソフトウェア リリースでは、MSFC は ASLB の構成ルータになることができます。


) MSFC がクライアントからのトラフィックをルーティングするとき、トラフィックはレイヤ 3 スイッチングされます。このプロセスによって MLS エントリが作成されます。このエントリは同じトラフィックの ASLB MLS エントリとは別個に存在します。


終了した ASLB フローを削除するためのエージングにより、MLS の終了したフローも削除されます。ASLB MLS エントリは、MLS ショートカット エントリとレイヤ 3 MLS キャッシュを共用します。

MLS コマンド( set mls clear mls 、および show mls )は、ASLB( set lda clear lda show lda および commit lda )コマンドと相互作用しません。ASLB では、個別のコマンドを使用して LocalDirector MLS エントリを表示します。

ASLB をイネーブルにすると、full-flow モードのフロー マスク(ip-flow)を 1 つ使用して ASLB MLS エントリが作成されます。

NDE

ASLB をイネーブルにしている場合は、NetFlow Data Export(NDE;NetFlow データ エクスポート)を使用できません。逆に NDE をイネーブルにしている場合は ASLB を使用できません。

VLAN

VLAN 設定時の注意事項は次のとおりです。

ASLB を設定すると、LocalDirector が接続されている 2 つの VLAN(ルータ VLAN およびサーバ VLAN)上で TCP トラフィックをリダイレクトするための VACL が作成されます。これらの VLAN にセキュリティ Cisco IOS ACL または VACL を設定することはできません。

ルータ VLAN およびサーバ VLAN は ASLB 専用にしてください。これら 2 つの VLAN には、他のネットワーク装置(エンド ステーション、クライアントなど)を接続しないでください。

VLAN Trunking Protocol(VTP; VLAN トランキング プロトコル)がサーバ モードのとき、ASLB 用に作成した VLAN は VTP によって他のスイッチに伝播されます。ネットワークのすべての VTP スイッチ上で、Spanning-Tree Protocol(STP; スパニングツリー プロトコル)がこれらの ASLB VLAN に作用する結果、ネットワーク全体でオーバーヘッドが増加します。スパニングツリーの伝播遅延を防ぐには、次の方法を使用してください。

スイッチを VTP トランスペアレントとして設定し、VLAN を伝播させないようにします。

すべてのスイッチ上のすべてのトランクから、ASLB VLAN を削除します( clear trunk コマンドを使用します)。

スイッチ ポートの設定

スイッチ ポート設定時の注意事項は次のとおりです。

LocalDirector(バックアップが設定されている場合は、アクティブ LocalDirector およびスタンバイ LocalDirector の両方)に接続するポート上で、Cisco Discovery Protocol(CDP)をディセーブルにします。

EtherChannel の一部分であるポートを指定すると、EtherChannel に含まれるすべてのポート間でトラフィックが自動的にリダイレクトされます。

CLI による ASLB の設定

ここでは、Catalyst 6500 シリーズ スイッチの lda コマンド セットを使用して ASLB を設定する方法について説明します。

「LocalDirector に接続されたスイッチ ポートの設定」

「ASLB のイネーブル化およびディセーブル化」

「高速化するサーバ仮想 IP アドレスおよび TCP ポートの指定」

「構成ルータの MAC アドレスの指定」

「LocalDirector の MAC アドレスの指定」

「ルータ VLAN および VLAN 上の LocalDirector ポートの指定」

「サーバ VLAN および VLAN 上の LocalDirector ポートの指定」

「UDP エージングの設定」

「ASLB 設定のコミット」

「ASLB 設定の表示」

「ASLB MLS エントリの表示」

「ASLB MLS 統計情報の表示」

「ASLB 設定の消去」

LocalDirector に接続されたスイッチ ポートの設定

LocalDirector に接続された 10/100 イーサネット スイッチ ポートを設定するには、次の作業を行います。


ステップ 1 set vlan vlan_num mod_ports コマンドを入力して、スイッチ ポートを適正な VLAN(ルータ VLAN およびサーバ VLAN)に追加します。

ステップ 2 すべての 10/100 スイッチ ポートはデフォルトで自動ネゴシエーションを行うように設定されているので、スイッチ ポートの速度およびデュプレックス タイプの設定は不要です。自動ネゴシエーションに問題がある場合には、ポート速度およびデュプレックス タイプを次の方法で設定してください。

set port speed mod / port { 10 | 100 | auto }コマンドを入力して、ポート速度を設定します。

set port duplex mod / port { full | half | auto }コマンドを入力して、デュプレックス タイプを設定します。


 

ASLB のイネーブル化およびディセーブル化


) ASLB は、デフォルトでディセーブルに設定されています。ASLB がディセーブルになっている状態では、set lda コマンドを入力して設定作業を行うことはできません。set lda コマンドを入力するには、ASLB をイネーブルにする必要があります。


ASLB をイネーブルまたはディセーブルにするには、イネーブル モードで次の作業を行います。

 

作業
コマンド

ASLB をイネーブルまたはディセーブルにします。

set lda enable | disable

次に、スイッチ上で ASLB をイネーブルにする例を示します。

Console> (enable) set lda enable
Successfully enabled Local Director Accelerator.
Console> (enable)
 

次に、スイッチ上で ASLB をディセーブルにする例を示します。

Console> (enable) set lda disable
Successfully disabled Local Director Accelerator.
Console> (enable)

高速化するサーバ仮想 IP アドレスおよび TCP ポートの指定


) Catalyst 6500 シリーズ スイッチによる高速化の対象として、仮想 IP アドレスと TCP ポートのペアを 1024 個まで指定できます。新しいペアを指定しても、以前に指定したペアは置き換えられません。以前に入力したペアをキャンセルするには、clear lda vip コマンドを使用します。



destination_tcp_port には、ワイルドカードの数値としてゼロ(0)を使用できます。


高速化するサーバ仮想 IP アドレスおよび TCP ポートを指定するには、イネーブル モードで次の作業を行います。

 

作業
コマンド

高速化するサーバ仮想 IP アドレスおよび TCP ポートを指定します。

set lda vip { server _ virtual_ip } { destination _ tcp_port } [{ server _ virtual_ip } { destination _ tcp_port }...]

次に、高速化するサーバ仮想 IP アドレスおよび TCP ポートを指定する例を示します。

Console> (enable) set lda vip 10.0.0.8 8
Successfully set server virtual ip and port information.
Use commit lda command to save settings to hardware.
Console> (enable)

構成ルータの MAC アドレスの指定


) 最大 32 個のルータ MAC アドレスを指定できます。


構成ルータの MAC アドレスを指定するには、イネーブル モードで次の作業を行います。

 

作業
コマンド

構成ルータの MAC アドレスを指定します。

set lda mac router { mac-address }...

次に、構成ルータの MAC アドレスを指定する例を示します。

Console> (enable) set lda mac router 00-23-45-67-ee-7f
Successfully set mac address.
Use commit lda command to save settings to hardware.
Console> (enable)

LocalDirector の MAC アドレスの指定

LocalDirector の MAC アドレスを指定するには、イネーブル モードで次の作業を行います。

:

作業
コマンド

LocalDirector の MAC アドレスを指定します。

set lda mac ld { ld_mac-address }

次に、LocalDirector の MAC アドレスを指定する例を示します。

Console> (enable) set lda mac ld 00-11-22-33-55-66
Successfully set mac address.
Use commit lda command to save settings to hardware.
Console> (enable)

ルータ VLAN および VLAN 上の LocalDirector ポートの指定


set lda router コマンドを入力したあとで、LocalDirector の接続先スイッチ ポートを変更した場合には、もう一度 set lda router コマンドを入力して新しい設定を指定する必要があります。



) LocalDirector のフェールオーバー コンフィギュレーションを設定する場合を除き、バックアップ LocalDirector ポートの指定は省略可能です。フェールオーバー コンフィギュレーションを設定する場合は、バックアップ LocalDirector のポートを指定する必要があります。この作業を行わないと、スーパバイザ エンジンはバックアップ LocalDirector にトラフィックを送信しないため、フェールオーバーは機能しません。


ルータ VLAN、およびその VLAN 上の LocalDirector ポートを指定するには、イネーブル モードで次の作業を行います。

 

作業
コマンド

ルータ VLAN およびその VLAN 上の LocalDirector ポートを指定します。

set lda router { router _ vlan } { ld_mod/port } [ backup_ld_mod/port ]

次に、ルータ VLAN およびその VLAN 上の LocalDirector ポートを指定する例を示します。

Console> (enable) set lda router 110 4/26
Successfully set router vlan and LD port.
Use commit lda command to save settings to hardware.
Console> (enable)

サーバ VLAN および VLAN 上の LocalDirector ポートの指定


set lda server コマンドを入力したあとで、LocalDirector の接続先スイッチ ポートを変更した場合には、もう一度 set lda server コマンドを入力して新しい設定を指定する必要があります。



) LocalDirector のフェールオーバー コンフィギュレーションを設定する場合を除き、バックアップ LocalDirector ポートの指定は省略可能です。フェールオーバー コンフィギュレーションを設定する場合は、バックアップ LocalDirector のポートを指定する必要があります。この作業を行わないと、スーパバイザ エンジンはバックアップ LocalDirector にトラフィックを送信しないため、フェールオーバーは機能しません。


サーバ VLAN、およびその VLAN 上の LocalDirector ポートを指定するには、イネーブル モードで次の作業を行います。

 

作業
コマンド

サーバ VLAN およびその VLAN 上の LocalDirector ポートを指定します。

set lda server { server _ vlan } { ld_mod/port } [ backup_ld_mod/port ]

次に、サーバ VLAN およびその VLAN 上の LocalDirector ポートを指定する例を示します。

Console> (enable) set lda server 105 4/40
Successfully set server vlan and LD port.
Use commit lda command to save settings to hardware.
Console> (enable)

UDP エージングの設定

UDP エージングを設定するには、イネーブル モードで次の作業を行います。

 

作業
コマンド

UDP エージングを設定します。

set lda udpage time_in_ms

エージングは、1 ~ 2024000 ミリ秒(ms)の範囲で設定できます。UDP エージングをディセーブルにするには、0 を入力します。

次に、UDP エージングを 500 ミリ秒に設定する例を示します。

Console> (enable) set lda udpage 500
Successfully set LDA UDP aging time to 500ms.
Console> (enable)

ASLB 設定のコミット


) ASLB の設定値は、一時的に編集バッファに格納されます。これらの設定値は NVRAM に保存されますが、設定値を有効にするには、commit lda コマンドを入力する必要があります。このコマンドによって設定値が確認されます。情報が正しく入力されており、かつ整合性検査にパスすれば、設定値がハードウェアにプログラミングされます。ASLB 設定が正常にコミットされると、NVRAM にマッピングが保存され、システムの起動時に復元されます。


ASLB 設定値をコミットするには、イネーブル モードで次の作業を行います。

 

作業
コマンド

ASLB 設定値をコミットします。

commit lda

次に、ASLB 設定値をコミットする例を示します。

Console> (enable) commit lda
Commit operation in progress...
Successfully committed Local Director Accelerator.
Console> (enable)

ASLB 設定の表示


show lda コマンドにキーワード(committed | uncommitted)を指定しないで入力すると、コミットされた設定値が表示されます。


コミットされた ASLB 設定値、またはまだコミットされていない ASLB 設定値を表示するには、イネーブル モードで次の作業を行います。

 

作業
コマンド

コミットされた ASLB 設定値、またはまだコミットされていない ASLB 設定値を表示します。

show lda [ committed | uncommitted ]

次に、コミットされた ASLB 設定値を表示する例を示します。

Console> (enable) show lda committed
Status:Committed
 
Virtual IP addresses:
Local Director Flow:10.0.0.8/ (TCP port 8)
 
Router MAC:
00-23-45-67-ee-7f
 
 
LD MAC:00-11-22-33-55-66
 
LD Router Side:
---------------
Router and LD are on VLAN 110
LD is connected to switch port 4/26 on VLAN 110
 
LD Server Side:
---------------
Server(s) and LD are on VLAN 105
LD is connected to switch port 4/40 on VLAN 105
Console> (enable)
 

設定を変更し、その変更をコミットせずに、もう一度 show lda コマンドを入力すると、メッセージが表示され、前回のコミット以降に設定が変更されているが、新しい変更については表示せず、コミット済みの変更だけを表示する旨が示されます。新しい変更を表示するには、 show lda uncommitted コマンドを入力します。

ASLB MLS エントリの表示


short | long オプションの使用により、出力を通常のフォーマット(1 行が 80 文字)または幅の広いフォーマットで表示できます。


ASLB MLS エントリを表示するには、イネーブル モードで次の作業を行います。

 

作業
コマンド

ASLB MLS エントリを表示します。

show lda mls entry

show lda mls entry [ destination ip_addr_spec ] [ source ip_addr_spec ] [ protocol protocol ] [ src-port port ] [ dst-port port ] [ short | long ]

次に、すべての ASLB MLS エントリを short フォーマットで表示する例を示します。

Console> (enable) show lda mls entry short
Destination-IP Source-IP Prot DstPrt SrcPrt Destination-Mac Vlan
--------------- --------------- ----- ------ ------ ----------------- ----
EDst ESrc DPort SPort Stat-Pkts Stat-Bytes Uptime Age
---- ---- ------ ------ ---------- ----------- -------- --------
10.0.0.8 172.20.20.10 TCP 8 64 00-33-66-99-22-44 105
ARPA ARPA - 4/25 0 0 00:00:02 00:00:05
 
10.0.0.8 172.20.20.11 TCP 8 64 00-33-66-99-22-44 105
ARPA ARPA - 4/25 0 0 00:00:05 00:00:08
Console> (enable)
 

次に、特定の送信元 IP アドレスについて、ASLB 情報を short フォーマットで表示する例を示します。

Console> (enable) show lda mls entry source 172.20.20.11 short
Destination-IP Source-IP Prot DstPrt SrcPrt Destination-Mac Vlan
--------------- --------------- ----- ------ ------ ----------------- ----
EDst ESrc DPort SPort Stat-Pkts Stat-Bytes Uptime Age
---- ---- ------ ------ ---------- ----------- -------- --------
10.0.0.8 172.20.20.11 TCP 8 64 00-33-66-99-22-44 105
ARPA ARPA - 4/25 0 0 00:00:05 00:00:08
Console> (enable)

ASLB MLS 統計情報の表示

ASLB MLS 統計情報を表示するには、イネーブル モードで次の作業を行います。

 

作業
コマンド

ASLB MLS エントリの統計情報を表示します。

show lda mls statistics entry

show lda mls statistics count

show lda mls statistics entry [ destination ip_addr_spec ]
[
source ip_addr_spec ] [ protocol protocol ]
[
src-port port ] [ dst-port port ]

次に、すべての ASLB MLS エントリについて統計情報を表示する例を示します。

Console> (enable) show lda mls statistics entry
Last Used
Destination IP Source IP Prot DstPrt SrcPrt Stat-Pkts Stat-Bytes
--------------- --------------- ---- ------ ------ ---------- ---------------
10.0.0.8 172.20.20.10 TCP WWW 64 636 29256
10.0.0.8 172.20.22.10 TCP WWW 64 0 0
Console> (enable)
 

次に、ASLB のアクティブ MLS エントリ数を表示する例を示します。

Console> (enable) show lda mls statistics count
LDA active shortcuts: 20
Console> (enable)
 

次に、特定の宛先 IP アドレスについて統計情報を表示する例を示します。

Console> (enable) show lda mls statistics entry destination 172.20.22.14
Last Used Last Used
Destination IP Source IP Prot DstPrt SrcPrt Stat-Pkts Stat-Bytes
--------------- --------------- ---- ------ ------ ---------- ---------------
172.20.22.14 172.20.25.10 6 50648 80 3152 347854
Console> (enable)

ASLB 設定の消去


注意 clear lda コマンドにキーワードを指定しないで入力すると、ハードウェアと NVRAM から ASLB 設定全体(MLS エントリを含む)が削除されます。clear lda mls コマンドにキーワードを指定しないで入力すると、すべての MLS エントリが消去されます。

ASLB エントリまたはルータの MAC アドレスを消去するには、イネーブル モードで次の作業を行います。

 

作業
コマンド

ASLB 設定値を消去します。

clear lda mls

clear lda mls [ destination ip_addr_spec ] [ source ip_addr_spec ] [ protocol protocol src-port src_port dst-port dst_port ]

clear lda vip { all | vip | vip tcp_port }

clear lda mac { all | router_mac_address }

次に、特定の宛先アドレスについて MLS エントリを消去する例を示します。

Console> (enable) clear lda mls destination 172.20.26.22
MLS IP entry cleared.
Console> (enable)
 

次に、仮想 IP アドレスおよびポートのペア(10.0.0.8、ポート 8)を削除する例を示します。

Console> (enable) clear lda vip 10.0.0.8 8
Successfully deleted vip/port pairs.
Console> (enable)
 

次に、すべての ASLB ルータ MAC アドレスを消去する例を示します。

Console> (enable) clear lda mac all
Successfully cleared Router MAC address.
Console> (enable)
 

次に、特定の ASLB ルータ MAC アドレスを消去する例を示します。

Console> (enable) clear lda mac 1-2-3-4-5-6
Successfully cleared Router MAC address.
Console> (enable)

ASLB の設定例

ここでは、一般的な ASLB ネットワークの設定例を示します。図51-4 はネットワーク例です。設定の仕様は次のとおりです。

仮想 IP アドレスは 192.255.201.55 です。

ルータ インターフェイスの MAC アドレスは 00-d0-bc-e9-fb-47、IP アドレスは 192.255.201.1 です。

LocalDirector の IP アドレスは 192.255.201.2 です。

LocalDirector の MAC アドレスは 00-e0-b6-00-4b-04 です。

サーバ ファームの IP アドレスは、192.255.201.3 ~ 192.255.201.11 です。

一連のサーバは、仮想 IP アドレス 192.255.201.55 に関する ARP 要求を無視するように設定されています。

図51-4 の例では、次の処理が行われています。

サーバ 192.255.201.3 ~ 192.255.201.10 で、ラウンドロビン シーケンスにより HTTP 接続の負荷を分散

ポート 8001 への接続をサーバ 192.255.201.11 に転送

サーバ 192.255.201.3 ~ 192.255.201.8 で、LocalDirector のデフォルトである [leastconns] シーケンスにより、FTP 接続の負荷を分散

図51-4 ASLB の設定例

 

ルータの設定は、次のとおりです(この例では MSM を使用しています)。

!
interface Port-channel1.7
encapsulation isl 7
ip address 192.255.201.1 255.255.255.0
no ip redirects
no ip directed-broadcast
!
 

Catalyst 6500 シリーズ スイッチの設定は、次のとおりです。

Console (enable) show lda
Status:Committed
 
Virtual IP addresses:
Local Director Flow:192.255.201.55/www (TCP port 80)
Local Director Flow:192.255.201.55/ (TCP port 8001)
Local Director Flow:192.255.201.55/ftp (TCP port 21)
 
Router MAC:
00-d0-bc-e9-fb-47
 
LD MAC: 00-e0-b6-00-4b-04
 
LD Router Side:
---------------
Router and LD are on VLAN 7
LD is connected to switch port 5/7 on VLAN 7
 
LD Server Side:
---------------
Server(s) and LD are on VLAN 5
LD is connected to switch port 5/5 on VLAN 5
Console (enable)
 

LocalDirector の設定は、次のとおりです。

LD430# show configuration
:Saved
:LocalDirector 430 Version 3.1.3.105
syslog output 20.3
no syslog console
hostname LD430
no shutdown ethernet 0
no shutdown ethernet 1
shutdown ethernet 2
shutdown ethernet 3
interface ethernet 0 100full
interface ethernet 1 100full
interface ethernet 2 auto
interface ethernet 3 auto
mtu 0 1500
mtu 1 1500
mtu 2 1500
mtu 3 1500
no multiring all
no secure 0
no secure 1
no secure 2
no secure 3
ping-allow 0
ping-allow 1
no ping-allow 2
no ping-allow 3
 
ip address 192.255.201.2 255.255.255.0
route 0.0.0.0 0.0.0.0 192.255.201.1 1
no rip passive
rip version 1
failover ip address 0.0.0.0
no failover
snmp-server enable traps
no snmp-server contact
no snmp-server location
virtual 192.255.201.55:80:0:tcp is
virtual 192.255.201.55:8001:0:tcp is
virtual 192.255.201.55:21:0:tcp is
predictor 192.255.201.55:80:0:tcp roundrobin
redirection 192.255.201.55:80:0:tcp dispatched assisted wildcard-ttl 60
fixed-ttl 60 igmp 224.0.1.2 port 1637
redirection 192.255.201.55:8001:0:tcp dispatched assisted wildcard-ttl 60
fixed-ttl 60 igmp 224.0.1.2 port 1637
redirection 192.255.201.55:21:0:tcp dispatched assisted wildcard-ttl 60
fixed-ttl 60 igmp 224.0.1.2 port 1637
real 192.255.201.5:80:0:tcp is
real 192.255.201.3:80:0:tcp is
real 192.255.201.4:80:0:tcp is
real 192.255.201.6:80:0:tcp is
real 192.255.201.7:80:0:tcp is
real 192.255.201.8:80:0:tcp is
real 192.255.201.9:80:0:tcp oos
real 192.255.201.10:80:0:tcp oos
real 192.255.201.11:8001:0:tcp oos
real 192.255.201.3:21:0:tcp is
real 192.255.201.4:21:0:tcp is
real 192.255.201.5:21:0:tcp is
real 192.255.201.6:21:0:tcp is
real 192.255.201.7:21:0:tcp is
real 192.255.201.8:21:0:tcp is
bind 192.255.201.55:80:0:tcp 192.255.201.3:80:0:tcp
bind 192.255.201.55:80:0:tcp 192.255.201.4:80:0:tcp
bind 192.255.201.55:80:0:tcp 192.255.201.5:80:0:tcp
bind 192.255.201.55:80:0:tcp 192.255.201.6:80:0:tcp
bind 192.255.201.55:80:0:tcp 192.255.201.7:80:0:tcp
bind 192.255.201.55:80:0:tcp 192.255.201.8:80:0:tcp
bind 192.255.201.55:80:0:tcp 192.255.201.9:80:0:tcp
bind 192.255.201.55:80:0:tcp 192.255.201.10:80:0:tcp
bind 192.255.201.55:8001:0:tcp 192.255.201.11:8001:0:tcp
bind 192.255.201.55:21:0:tcp 192.255.201.3:21:0:tcp
bind 192.255.201.55:21:0:tcp 192.255.201.4:21:0:tcp
bind 192.255.201.55:21:0:tcp 192.255.201.5:21:0:tcp
bind 192.255.201.55:21:0:tcp 192.255.201.6:21:0:tcp
bind 192.255.201.55:21:0:tcp 192.255.201.7:21:0:tcp
bind 192.255.201.55:21:0:tcp 192.255.201.8:21:0:tcp

ASLB 冗長構成の例

ここでは、一般的な冗長 ASLB ネットワーク構成例を示します。図51-5 は冗長ネットワーク例です。サーバ VIP アドレス 13.13.13.13 に対する HTTP および Telnet を高速化するように、LocalDirectors および Catalyst 6500 シリーズ スイッチを設定します。


注意 図51-5 では、ルータ 1 およびルータ 2 のインターフェイス(f1 および f2)上で Hot Standby Router Protocol(HSRP)が稼働しています。インターフェイス f2 がアクティブになっているルータ上で f1 がアクティブになっている必要があります。アクティブになっていない場合、一方のルータ上のインターフェイス f1 にトラフィックが到達しても、もう一方のルータ上でアクティブになっているインターフェイス f2 に転送されません。HSRP の track コマンドを使用して、各ルータの反対側のインターフェイスの状況を追跡します。

図51-5 ASLB 冗長構成の例

 

IP アドレス

IP アドレスは、次のとおりです。

ルータ 1、f1 IP アドレス:7.0.0.100(ネットワーク 7)

ルータ 2、f1 IP アドレス:7.0.0.101(ネットワーク 7)

HSRP IP アドレス:ネットワーク 7 で 7.0.0.1

ルータ 1、f2 IP アドレス:5.0.0.100(ネットワーク 5)

ルータ 2、f2 IP アドレス:5.0.0.101(ネットワーク 5)

HSRP IP アドレス:ネットワーク 5 で 5.0.0.2

LocalDirector IP アドレス: 5.0.0.1

サーバ IP アドレス: 5.100.100.100

サーバの VIP アドレス: 13.13.13.13

MAC アドレス

MAC アドレスは、次のとおりです。

ネットワーク 7 の HSRP MAC アドレス:00-00-0c-07-ac-00

ネットワーク 5 の HSRP MAC アドレス:00-00-0c-07-ac-01

ルータ 1、f2 MAC アドレス:00-d0-79-7b-20-88

ルータ 2、f2 MAC アドレス:00-d0-79-7b-18-88

LocalDirector MAC アドレス:00-e0-b6-00-47-ec

Catalyst 6500 シリーズ スイッチ 1 の設定

スイッチ 1 の設定は、次のとおりです。

set trunk 3/23 on isl 1,5,9
set lda enable
clear lda vip all
set lda vip 13.13.13.13 80 13.13.13.13 23
clear lda mac all
set lda mac router 00-00-0c-07-ac-01
set lda mac router 00-d0-79-7b-20-88
set lda mac router 00-d0-79-7b-18-88
set lda mac ld 00-e0-b6-00-47-ec
set lda router 9 3/7 3/23
set lda server 5 3/8 3/23
commit lda
 

Catalyst 6500 シリーズ スイッチ 2 の設定

スイッチ 2 の設定は、次のとおりです。

set trunk 3/23 on isl 1,5,9
set lda enable
clear lda vip all
set lda vip 13.13.13.13 80 13.13.13.13 23
clear lda mac all
set lda mac router 00-00-0c-07-ac-01
set lda mac router 00-d0-79-7b-20-88
set lda mac router 00-d0-79-7b-18-88
set lda mac ld 00-e0-b6-00-47-ec
set lda router 9 3/27 3/23
set lda server 5 3/28 3/23
commit lda
 

ルータ 1 の設定

ルータ 1 の設定は、次のとおりです。

interface FastEthernet1
ip address 7.0.0.100 255.0.0.0
no ip redirects
no ip directed-broadcast
no ip route-cache distributed
load-interval 30
no keepalive
full-duplex
standby 1 ip 7.0.0.1
standby 1 track FastEthernet2
!
interface FastEthernet2
ip address 5.0.0.100 255.0.0.0
no ip redirects
no ip directed-broadcast
no ip route-cache distributed
no keepalive
full-duplex
standby priority 250
standby 2 ip 5.0.0.2
standby 2 track FastEthernet1
!
ip route 13.13.13.13 255.255.255.255 5.0.0.1
 

ルータ 2 の設定

ルータ 2 の設定は、次のとおりです。

interface FastEthernet1
ip address 7.0.0.101 255.0.0.0
no ip redirects
no ip directed-broadcast
no ip route-cache distributed
load-interval 30
no keepalive
full-duplex
standby 1 ip 7.0.0.1
standby 1 track FastEthernet2
!
interface FastEthernet2
ip address 5.0.0.101 255.0.0.0
no ip redirects
no ip directed-broadcast
no ip route-cache distributed
no keepalive
full-duplex
standby priority 250
standby 2 ip 5.0.0.2
standby 2 track FastEthernet1
!
ip route 13.13.13.13 255.255.255.255 5.0.0.1
 

LocalDirector の設定

LocalDirector 1 および LocalDirector 2 の設定は、次のとおりです(設定は両方の LocalDirector で共通です)。

no shutdown ethernet 0
no shutdown ethernet 4
interface ethernet 0 100full
interface ethernet 4 100full
ip address 5.0.0.1 255.0.0.0
failover ip address 5.0.0.5
virtual 13.13.13.13:80:0:tcp is
virtual 13.13.13.13:23:0:tcp is
predictor 13.13.13.13:80:0:tcp roundrobin
predictor 13.13.13.13:23:0:tcp roundrobin
redirection 13.13.13.13:80:0:tcp dispatched assisted
redirection 13.13.13.13:23:0:tcp dispatched assisted
real 5.100.100.100:80:0:tcp is
real 5.100.100.100:23:0:tcp is
bind 13.13.13.13:80:0:tcp 5.100.100.100:80:0:tcp
bind 13.13.13.13:23:0:tcp 5.100.100.100:23:0:tcp
 

ASLB 設定のトラブルシューティング

表51-6 に、発生する可能性のある問題と、ASLB 設定のトラブルシューティングのために推奨する対処方法を示します。

 

表51-6 ASLB 設定のトラブルシューティング

現象
対処方法

LocalDirector がトラフィックを受信しない。

set lda server および set lda router コマンドを使用して指定したポートに、LocalDirector が接続していることを確認します。

LocalDirector 接続エントリが削除されない。

set lda vip コマンドを使用して、すべての仮想 IP/ポートのペアを設定していることを確認します。

ASLB MLS エントリが単一方向にしか作成されない。

スーパバイザ エンジン( set lda vip コマンド)および LocalDirector の両方で、仮想 IP/ポートのペアをすべて設定していることを確認します。

LocalDirector が [dispatched assisted] モードになっていることを確認します。

「IP アドレス」に記載されている注意事項に従って、ルータ、
LocalDirector、およびサーバの IP アドレスを設定していることを確認します。トラフィックが仮想 IP アドレスに転送されたときに、LocalDirector に到達する方法をルータが認識していることを確認します(仮想 IP アドレスがルータ インターフェイスとは別のサブネットに存在する場合)。

ルータの MAC アドレスが、 set lda mac router コマンドで指定したアドレスと同じであることを確認します。

LocalDirector の MAC アドレスが、 set lda mac ld コマンドで指定したアドレスと同じであることを確認します。

バックアップ LocalDirector がトラフィックを受信しない。

set lda router および set lda server コマンドを使用してバックアップ LocalDirector ポートを設定していることを確認します。たとえば、 set lda router { router _ vlan } 3/7 3/9 および set lda server { server _ vlan } 3/8 3/10 コマンドを入力します。

ルータからサーバへの ping は成功するが、データ トラフィックを送信しても ASLB MLS エントリが作成されない。

サーバが仮想 IP アドレスに関する ARP 要求を無視するように設定されていることを確認します。

次のメッセージが表示される。

%CDP-4-NVLANMISMATCH:Native vlan mismatch detected on port ...

LocalDirector に接続されたポート上で CDP19 をディセーブルにします( set cdp disable コマンドを入力します)。

LocalDirector の set コマンドが有効にならない。

set lda コマンドは、 commit lda コマンドを入力しないかぎり有効になりません。

どの set lda コマンドが有効になっているかを確認するには、 show lda commit コマンドを使用します。

どの設定済み set lda コマンドがコミットされていないか、または現在の set lda コマンドをコミットするとどのような変化が起きるかを判別するには、 show lda uncommitted コマンドを使用します。

Catalyst 6500 シリーズ スイッチ ポートに[collisions]、または[port disabled]と表示される。

LocalDirector とスイッチ間のリンクの両端で、ポート速度およびデュプレックスの設定が一致していることを確認します。たとえば、スイッチ上のポート 3/7 が LocalDirector の interface ethernet 0 に接続されている場合、ポート 3/7 が 100full に設定され、LocalDirector の interface ethernet 0 も 100full に設定されていることを確認します。

19.CDP = Cisco Discovery Protocol