Catalyst 6500 シリーズ スイッチ ソフトウェア コンフィギュレーション ガイド Software Release 8.4
ASLBの設定
ASLBの設定
発行日;2012/01/09 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 9MB) | フィードバック

目次

ASLBの設定

ハードウェアおよびソフトウェアの要件

ASLBの機能

ASLBのレイヤ3動作

ASLBのレイヤ2動作

クライアントからサーバへのデータ転送

パス1

パス2

パス3 ― N

パスN + 1、N + 2...

サーバからクライアントへのデータ転送

ケーブル接続の注意事項

スイッチ上でのASLBの設定

LocalDirectorインターフェイスの設定

ASLB設定時の注意事項

ルータ

サーバ

IPアドレス

スーパバイザ エンジン

バックアップLocalDirectorの設定(任意)

MSFCおよびMLS

NDE

VLAN

スイッチ ポートの設定

CLIによるASLBの設定

LocalDirectorに接続されたスイッチ ポートの設定

ASLBのイネーブル化およびディセーブル化

高速化するサーバ仮想IPアドレスおよびTCPポートの指定

構成ルータのMACアドレスの指定

LocalDirectorのMACアドレスの指定

ルータVLANおよびVLAN上のLocalDirectorポートの指定

サーバVLANおよびVLAN上のLocalDirectorポートの指定

UDPエージングの設定

ASLB設定のコミット

ASLB設定の表示

ASLB MLSエントリの表示

ASLB MLS統計情報の表示

ASLB設定の消去

ASLBの設定例

ASLB冗長構成の例

IPアドレス

MACアドレス

Catalyst 6500シリーズ スイッチ1の設定

Catalyst 6500シリーズ スイッチ2の設定

ルータ1の設定

ルータ2の設定

LocalDirectorの設定

ASLB設定のトラブルシューティング

ASLBの設定

この章では、Catalyst 6500シリーズ スイッチ上でAccelerated Server Load Balancing(ASLB;Accelerated Serverロードバランシング)を設定する方法について説明します。


) この章で使用しているコマンドの完全な構文および使用方法の詳細については、『Catalyst 6500 Series Switch Command Reference』を参照してください。



) この章で説明する情報および手順は、Policy Feature Card(PFC;ポリシー フィーチャ カード)を搭載したSupervisor Engine 1にのみ当てはまります。ASLBは、PFC2搭載のSupervisor Engine 2、PFC3A/PFC3B/PFC3BXL搭載のSupervisor Engine 720、またはPFC3B/PFC3BXL搭載のSupervisor Engine 32ではサポートされていません。


この章で説明する内容は、次のとおりです。

「ハードウェアおよびソフトウェアの要件」

「ASLBの機能」

「ケーブル接続の注意事項」

「スイッチ上でのASLBの設定」

「ASLBの設定例」

「ASLB冗長構成の例」

「ASLB設定のトラブルシューティング」

ハードウェアおよびソフトウェアの要件

ASLB設定のハードウェアおよびソフトウェアの要件は、次のとおりです。

LocalDirectorの要件は、次のとおりです。

ハードウェア プラットフォーム ― LocalDirectorモデル410、415、416、420、または430

インターフェイス モジュール ― ASLBを設定するには、10/100BASE-Xイーサネット インターフェイスが2つ、または1000BASE-Xギガビット イーサネット インターフェイスが2つ必要です。


) 1000BASE-Xインターフェイスは、LocalDirector 420および430上でのみサポートされています(LocalDirector 410、415、または416ではサポートされていません)。


ソフトウェア ― シスコ コンフィギュレーション バージョン3.2.x

Catalyst 6500シリーズ スイッチの要件は、次のとおりです。

PFCを搭載したSupervisor Engine 1(または1A)

Release 5.3(1)CSX以降のスーパバイザ エンジン ソフトウェア リリース

構成ルータは、次のとおりです。

Multilayer Switch Feature Card(MSFC;マルチレイヤ スイッチ フィーチャ カード) ― Release 5.4(1)CSX以降のスーパバイザ エンジン ソフトウェア リリースでは、ASLBを構成するルータとしてCatalyst 6500シリーズ スイッチ内のMSFCを使用できます。これより古いスーパバイザ エンジン ソフトウェア リリースでは、内部MSFCは構成ルータとして 使用できません

外部MSFC ― Catalyst 6500シリーズ スイッチの外付けMSFCは、構成ルータとして使用できます。

Multilayer Switch Module(MSM) ― ASLBに使用するCatalyst 6500シリーズ スイッチにMSMが搭載されている場合、そのMSMはASLBの構成ルータとして使用できます。Catalyst 6500シリーズ スイッチの外付けMSMも、構成ルータとして使用できます。

その他のシスコ製ルータも、ASLBの構成ルータとして使用できます。

ASLBの機能


) TCP/IPトラフィックのロードバランシングの概要については、『Cisco LocalDirector Installation and Configuration Guide』Version 3.2を参照してください。


ここでは、ASLBについて説明します。

「ASLBのレイヤ3動作」

「ASLBのレイヤ2動作」

「クライアントからサーバへのデータ転送」

「サーバからクライアントへのデータ転送」

LocalDirectorは、機密性に優れたリアルタイムの内蔵OS(オペレーティング システム)で、複数のサーバ間でTCP/IPトラフィック負荷をインテリジェントに分散します。ASLBによって、Catalyst 6500シリーズ スイッチはCisco LocalDirectorのロードバランシング フローをキャッシュし、LocalDirectorのパフォーマンスを高速化できます。


) LocalDirectorのパフォーマンス高速化は、Catalyst 6500シリーズのレイヤ3スイッチング テクノロジーによって達成されます。


図46-1に、ASLB機能を使用した場合のネットワークを示します。スイッチとLocalDirectorは、2つのリンクで接続する必要があります。一方のリンクはルータが存在するVLANに接続し、もう一方はサーバが存在するVLANに接続します。図46-1では、1つのLocalDirectorリンクがVLAN 10(ルータVLAN)、もう1つのリンクはVLAN 20(サーバVLAN)に接続されています。

LocalDirectorは、directedモードおよびdispatchedモードをサポートしています。Catalyst 6500シリーズ スイッチのASLB機能でサポートされているのは、dispatchedモードだけです。

図46-1 ASLBの機能

 

ASLBのレイヤ3動作

サーバの仮想IPアドレスとTCPポートのペアを1024個まで指定して、スイッチによるトラフィック高速化を行うことができます。SYN、FIN、RST、およびゼロ以外のオフセットを持つフラグメント パケットを除いて、指定した仮想IP/ポート間のすべてのトラフィックが高速化されます。このパケットは、(バックアップLocalDirectorが設定されている場合)アクティブLocalDirectorおよびスタンバイLocalDirectorの両方にリダイレクトされます。

ASLBのレイヤ2動作

Catalyst 6500シリーズ スイッチのCAM(連想メモリ)テーブルには、ルータVLANおよびサーバVLANのエントリが含まれています。CAMテーブルでは、ルータVLANにはポート インデックスに対応付けられたLocalDirectorのMACアドレスのエントリが入っており、サーバVLANにはポート インデックスに対応付けられたルータのMACアドレスのエントリが入っています。このようなポート インデックスでは、ポートは0/0として表示されています。 show cam system コマンドを入力すれば、システムのCAMエントリを表示できます。

表46-1 に、CAMテーブルのエントリを示します(ASLB設定は、図46-1に示されています)。最初のエントリは、VLAN 10におけるLocalDirectorのMACアドレスを表しています。CAMテーブルでは、このMACアドレスのXtag値が14であることが示されています。この値は、レイヤ3検索が必要であることを示します。2番めのエントリは、ルータのMACアドレスであり、これもレイヤ3検索が必要です。

 

表46-1 レイヤ2テーブル エントリ

VLAN
MACアドレス
インデックス
Xtag1

10

LocalDirector MAC

0/0

14

20

ルータMAC2

0/0

14

1.Xtag = レイヤ2テーブルで、MACアドレスが属するルータを表すidentifierフィールド。

2.ルータのMACアドレスは、ルータVLAN(VLAN 10)ではなくサーバVLAN(VLAN 20)に追加される点に注意してください。

クライアントからサーバへのデータ転送

図46-2に、ルータからサーバへのデータ転送を示します。 表46-2 で一連のイベントについて説明し、 表46-3 にレイヤ3テーブル エントリを示します。

ここでは、クライアントからサーバへのデータ転送パスについて説明します。

「パス1」

「パス2」

「パス3 ― N」

「パスN + 1、N + 2...」

パス1

ルータからの最初のパケットは、LocalDirectorの宛先MACアドレスが指定され、VLAN 10に存在します。このMACアドレスは、レイヤ2テーブルでXtag値が14になっています。この値はレイヤ3検索が必要であることを表し、SYNフラグが設定されているため、フレームはポートP A に転送されます。

スイッチ ハードウェアはフレームをポートP A に転送するほか、レイヤ3転送テーブルに「候補」エントリを作成します。このエントリはあとの段階で「イネーブラ」フレームによって更新され、完全なASLB Multilayer Switching(MLS;マルチレイヤ スイッチング)エントリになります。

パス2

LocalDirectorはポートP A からフレームを受信したあと、標準的なロードバランシング決定を行い、フレームをポートP B に転送します。LocalDirectorは宛先MACアドレスを適切なサーバのアドレスに変更します。このフレームはスイッチに入った時点で、「イネーブラ」フレームとみなされます。スイッチ ハードウェアはレイヤ3テーブルで検索を行い、前の候補パケット(LocalDirectorを通じて転送されたパケット)によって作成されたエントリを検索します。この検索が成功すると、レイヤ3テーブルで「ヒット」が成立します。

パス3 ― N

ASLB MLSエントリが作成済みになっています。パケットにSYN、FIN、RSTフラグが設定されている場合、またはパケットがフラグメント化されている場合を除き、ルータからの後続のフレーム(LocalDirector MACの宛先MACアドレスを指定)がレイヤ3スイッチングされます。

パスN + 1、N + 2...

接続の最後のフレームで、TCPヘッダーにFINまたはRSTフラグのどちらかが設定され、それによってパケットがLocalDirectorに転送されます。LocalDirectorは、宛先MACアドレスを適切なサーバのアドレスに変更したあと、フレームをスイッチに戻さなければなりません。このリダイレクトされたフレームは、フローの最初のフレームと同じパスをたどります。LocalDirectorはサーバとの接続終了を示すのにFINパケットを使用し、ASLBは該当するASLB MLSエントリを削除します。

図46-2 ASLBパケット フロー:クライアントからサーバへ

 

 

表46-2 ASLBパケット フロー:クライアントからサーバへ

パス番号
VLAN
MAC宛先
アドレス
MAC送信元アドレス
IP宛先
アドレス
IP送信元
アドレス
フラグ
アクション

1

10

LocalDirector MAC3

ルータMAC

VIP4

CIP5

SYN

レイヤ3テーブル内の候補エントリ

2

20

サーバMAC6

ルータMAC1

VIP

CIP

-

イネーブラ フレーム

3 ― N

10

LocalDirector MAC1

ルータMAC

VIP

CIP

-

完全なASLB MLSエントリが作成される

N + 1

10

LocalDirector MAC1

ルータMAC

VIP

CIP

FIN/RST

パス1リダイレクト

N + 2...

20

サーバMAC

ルータMAC1

VIP

CIP

FIN/RST

パス2

3.このMACアドレスでは、このパケットのVLANに対応するレイヤ2テーブル内のXtag値が14です。

4.VIP = Virtual IP Address(仮想IPアドレス)

5.CIP = Client’s IP address(クライアントのIPアドレス)

6.LocalDirectorが選択したサーバのMACアドレス

 

表46-3 ASLBレイヤ3テーブル エントリ: クライアントからサーバへ

IP宛先
アドレス
IP送信元
アドレス
プロトコル
ポート
VLAN
MAC宛先
アドレス
MAC送信元
アドレス

VIP7

CIP8

TCP

80/YZ

20

サーバMAC9

ルータMAC

7.VIP = Virtual IP Address(仮想IPアドレス)

8.CIP = Client’s IP address(クライアントのIPアドレス)

9.LocalDirectorが選択したサーバのMACアドレス

サーバからクライアントへのデータ転送

図46-3に、サーバからクライアントへのデータ転送を示します。 表46-4 で一連のイベントについて説明し、 表46-5 にレイヤ3テーブル エントリを示します。

サーバからルータまたはクライアント装置へのトラフィックは同様に動作しますが、方向は逆となります(クライアントからサーバへのデータ転送の説明を参照)。ただし、LocalDirectorは、ルータに向かうすべてのパケットに対して固有のMACアドレスをパケットの送信元として表します。クライアントからサーバへのトラフィックでは、パケットの送信元MACアドレスは書き換えられません。

図46-3 ASLBパケット フロー:サーバからクライアントへ

 

 

表46-4 ASLBパケット フロー:サーバからクライアントへ

パス番号
VLAN
MAC宛先アドレス
MAC送信元アドレス
IP宛先
アドレス
IP送信元アドレス
フラグ
アクション

1

20

ルータMAC10

サーバMAC11

CIP12

VIP13

SYN

レイヤ3テーブル内の候補エントリ

2

10

ルータMAC

LocalDirector MAC1

CIP

VIP

-

イネーブラ パケット

3 ― N

20

ルータMAC1

サーバMAC

CIP

VIP

-

完全なASLB MLSエントリが作成される

N + 1

20

ルータMAC1

サーバMAC

CIP

VIP

FIN/RST

パス1リダイレクト

N +2...

10

ルータMAC

LocalDirector MAC1

CIP

VIP

FIN/RST

パス2

10.このMACアドレスでは、このパケットのVLANに対応するレイヤ2テーブル内のXtag値が14です。

11.LocalDirectorが選択したサーバのMACアドレス

12.CIP = Client’s IP address(クライアントのIPアドレス)

13.VIP = Virtual IP Address(仮想IPアドレス)

 

表46-5 ASLBレイヤ3テーブル エントリ: サーバからクライアントへ

IP宛先
アドレス
IP送信元
アドレス
プロトコル
ポート
VLAN
MAC宛先
アドレス
MAC送信元
アドレス

VIP14

CIP15

TCP

80/YZ

20

サーバMAC16

ルータMAC

CIP

VIP

TCP

YZ/80

10

ルータMAC

LocalDirector MAC

14.VIP = Virtual IP Address(仮想IPアドレス)

15.CIP = Client’s IP address(クライアントのIPアドレス)

16.LocalDirectorが選択したサーバのMACアドレス

ケーブル接続の注意事項

ここでは、ASLB設定のケーブル接続を行う際の注意事項について説明します。

スイッチへのサーバ接続を確認してください。各サーバはスイッチに直接接続されているか、またはサーバVLANのLocalDirectorポートと同じブリッジング ドメイン内に存在している必要があります。

カテゴリ5 Unshielded Twisted-Pair(UTP;シールドなしツイストペア)ケーブル2本を使用して、2つの10/100スイッチ ポート、または2つの1000BASE-Xスイッチ ポートを、対応する2つのLocalDirectorインターフェイスに接続します。


注意 Catalyst 6500シリーズ スイッチにLocalDirectorを直接接続します。

LocalDirectorインターフェイスの設定手順については、「LocalDirectorインターフェイスの設定」を参照してください。スイッチの設定手順については、「CLIによるASLBの設定」を参照してください。

スイッチ上でのASLBの設定

ここでは、ASLBの設定作業について紹介します。

「LocalDirectorインターフェイスの設定」

「ASLB設定時の注意事項」

「CLIによるASLBの設定」

LocalDirectorインターフェイスの設定

LocalDirectorインターフェイスをASLB用に設定するための詳しい手順については、『 Cisco LocalDirector Installation and Configuration Guide 』Version 3.2を参照してください。

ASLB設定時の注意事項

ここでは、ASLBを設定する際の使用上の注意事項と制限事項を示します。

「ルータ」

「サーバ」

「IPアドレス」

「スーパバイザ エンジン」

「バックアップLocalDirectorの設定(任意)」

「MSFCおよびMLS」

「NDE」

「VLAN」

「スイッチ ポートの設定」

設定例については、「ASLBの設定例」を参照してください。設定作業中に問題が生じた場合は、「ASLB設定のトラブルシューティング」を参照してください。

ルータ

ルータ設定時の注意事項は次のとおりです。

ルータはロードバランシングの対象になるサーバのデフォルト ゲートウェイでなければならず、ルータのMACアドレスを明確にしておく必要があります。

同一のルータVLAN上に、複数のルータが存在する必要があります。 set lda mac router コマンドを入力して、すべての構成ルータのMACアドレスを指定します。

ASLBを設定すると、LocalDirectorが接続されている2つのVLAN上のTCPトラフィックをリダイレクトするためのVACLが作成されます。これらのVLANには、セキュリティCisco IOS ACLまたはVACLは設定できません。

サーバ

サーバ設定時の注意事項は次のとおりです。

各サーバはスイッチに直接接続されているか、またはサーバVLANのLocalDirectorポートと同じブリッジング ドメイン内に存在している必要があります。

サーバのデフォルト ルートを、サーバの実際のIPアドレスと同じサブネットに存在するルータのエイリアス アドレスとして設定します。

サーバが仮想IPアドレスに関するAddress Resolution Protocol(ARP)要求を無視するように設定します。サーバのOS(オペレーティング システム)によっては、エイリアス(セカンダリ)IPアドレスに関するARP要求への応答をディセーブルに設定できない場合があります。仮想IPアドレスに関するARP要求に応答するサーバの場合、対応策として、ルータ側でスタティックARPエントリを使用してください。


注意 クライアント/サーバ間トラフィックを高速化するには、サーバが仮想IPアドレスに関するARP要求を無視するように設定する必要があります。この設定をしなかった場合は、トラフィックの高速化が開始されず、LocalDirectorに障害があった場合にネットワークでの完全冗長トポロジーの復旧に時間がかかります。

IPアドレス

IPアドレス設定時の注意事項は次のとおりです。


) 仮想IPアドレスには、サーバのIPネットワーク アドレス以外のIPアドレスを指定できます。


LocalDirectorが各サーバの実際のIPアドレスをARP要求できるように、LocalDirectorとサーバが同じサブネット上に存在するようにしてください。

各ルータが仮想IPアドレスと同じサブネット上に存在するようにしてください。ルータが仮想IPアドレスをARP要求できるようにするためです。

次のように、ネットワークにASLBを設定します(この例では、仮想IPアドレスは171.1.1.200です)。

 

ルータ
LocalDirector
サーバ17

171.1.1.1

171.1.1.2

171.1.1.x

17.各サーバのデフォルト ルータは171.1.1.1です。

ASLB設定で使用するサーバがプライバシのためにRFC 1918に準拠しなければならない場合には、次の例を参考にしてください(この例では、仮想IPアドレスは171.1.1.200です)。

 

ルータ
LocalDirector
サーバ18

171.1.1.1

171.1.1.2

10.1.1.x(実際のIPアドレス)

エイリアス10.1.1.1

エイリアス10.1.1.2

エイリアスを171.1.1.200にループバック

18.各サーバのデフォルト ルータは10.1.1.1です。

スーパバイザ エンジン

スーパバイザ エンジン設定時の注意事項は次のとおりです。

最大32のルータMACアドレスがサポートされています。

最大1024の仮想IP/TCPポートのペアがサポートされています。

バックアップLocalDirectorの設定(任意)

バックアップLocalDirectorのポートをスイッチに接続し、 set lda server および set lda router コマンドを入力してサーバおよびルータの設定を指定します。アクティブLocalDirectorおよびバックアップLocalDirectorを所定のポートに接続しないと、 ASLB機能は作動しません。

MSFCおよびMLS

MSFCおよびMLS設定時の注意事項は次のとおりです。

Release 5.4(1)CSX以降のスーパバイザ エンジン ソフトウェア リリースでは、MSFCはASLBの構成ルータになることができます。


) MSFCがクライアントからのトラフィックをルーティングするとき、トラフィックはレイヤ3スイッチングされます。このプロセスによってMLSエントリが作成されます。このエントリは同じトラフィックのASLB MLSエントリとは別個に存在します。


終了したASLBフローを削除するためのエージングにより、MLSの終了したフローも削除されます。ASLB MLSエントリは、MLSショートカット エントリとレイヤ3 MLSキャッシュを共用します。

MLSコマンド( set mls clear mls 、および show mls )は、ASLB( set lda clear lda show lda および commit lda )コマンドと相互作用しません。ASLBでは、個別のコマンドを使用してLocalDirector MLSエントリを表示します。

ASLBをイネーブルにすると、full-flowモードのフロー マスク(ip-flow)を1つ使用してASLB MLSエントリが作成されます。

NDE

ASLBをイネーブルにしている場合は、NetFlow Data Export(NDE;NetFlowデータ エクスポート)を使用できません。逆にNDEをイネーブルにしている場合はASLBを使用できません。

VLAN

VLAN設定時の注意事項は次のとおりです。

ASLBを設定すると、LocalDirectorが接続されている2つのVLAN(ルータVLANおよびサーバVLAN)上でTCPトラフィックをリダイレクトするためのVACLが作成されます。これらのVLANにセキュリティCisco IOS ACLまたはVACLを設定することはできません。

ルータVLANおよびサーバVLANはASLB専用にしてください。これら2つのVLANには、他のネットワーク装置(エンド ステーション、クライアントなど)を接続しないでください。

VLAN Trunking Protocol(VTP;VLANトランキング プロトコル)がサーバ モードのとき、ASLB用に作成したVLANはVTPによって他のスイッチに伝播されます。ネットワークのすべてのVTPスイッチ上で、Spanning-Tree Protocol(STP;スパニングツリー プロトコル)がこれらのASLB VLANに作用する結果、ネットワーク全体でオーバーヘッドが増加します。スパニングツリーの伝播遅延を防ぐには、次の方法を使用してください。

スイッチをVTPトランスペアレントとして設定し、VLANを伝播させないようにします。

すべてのスイッチ上のすべてのトランクから、ASLB VLANを削除します( clear trunk コマンドを使用します)。

スイッチ ポートの設定

スイッチ ポート設定時の注意事項は次のとおりです。

LocalDirector(バックアップが設定されている場合は、アクティブLocalDirectorおよびスタンバイLocalDirectorの両方)に接続するポート上で、Cisco Discovery Protocol(CDP)をディセーブルにします。

EtherChannelの一部分であるポートを指定すると、EtherChannelに含まれるすべてのポート間でトラフィックが自動的にリダイレクトされます。

CLIによるASLBの設定

ここでは、Catalyst 6500シリーズ スイッチの lda コマンド セットを使用してASLBを設定する方法について説明します。

「LocalDirectorに接続されたスイッチ ポートの設定」

「ASLBのイネーブル化およびディセーブル化」

「高速化するサーバ仮想IPアドレスおよびTCPポートの指定」

「構成ルータのMACアドレスの指定」

「LocalDirectorのMACアドレスの指定」

「ルータVLANおよびVLAN上のLocalDirectorポートの指定」

「サーバVLANおよびVLAN上のLocalDirectorポートの指定」

「UDPエージングの設定」

「ASLB設定のコミット」

「ASLB設定の表示」

「ASLB MLSエントリの表示」

「ASLB MLS統計情報の表示」

「ASLB設定の消去」

LocalDirectorに接続されたスイッチ ポートの設定

LocalDirectorに接続された10/100イーサネット スイッチ ポートを設定するには、次の作業を行います。


ステップ 1 set vlan vlan_num mod_ports コマンドを入力して、スイッチ ポートを適正なVLAN(ルータVLANおよびサーバVLAN)に追加します。

ステップ 2 すべての10/100スイッチ ポートはデフォルトで自動ネゴシエーションを行うように設定されているので、スイッチ ポートの速度およびデュプレックス タイプの設定は不要です。自動ネゴシエーションに問題がある場合には、ポート速度およびデュプレックス タイプを次の方法で設定してください。

set port speed mod / port { 10 | 100 | auto }コマンドを入力して、ポート速度を設定します。

set port duplex mod / port { full | half | auto }コマンドを入力して、デュプレックス タイプを設定します。


 

ASLBのイネーブル化およびディセーブル化


) ASLBは、デフォルトでディセーブルに設定されています。ASLBがディセーブルになっている状態では、set ldaコマンドを入力して設定作業を行うことはできません。set ldaコマンドを入力するには、ASLBをイネーブルにする必要があります。


ASLBをイネーブルまたはディセーブルにするには、イネーブル モードで次の作業を行います。

 

作業
コマンド

ASLBをイネーブルまたはディセーブルにします。

set lda enable | disable

次に、スイッチ上でASLBをイネーブルにする例を示します。

Console> (enable) set lda enable
Successfully enabled Local Director Accelerator.
Console> (enable)
 

次に、スイッチ上でASLBをディセーブルにする例を示します。

Console> (enable) set lda disable
Successfully disabled Local Director Accelerator.
Console> (enable)

高速化するサーバ仮想IPアドレスおよびTCPポートの指定


) Catalyst 6500シリーズ スイッチによる高速化の対象として、仮想IPアドレスとTCPポートのペアを1024個まで指定できます。新しいペアを指定しても、以前に指定したペアは置き換えられません。以前に入力したペアをキャンセルするには、clear lda vipコマンドを使用します。



destination_tcp_portには、ワイルドカードの数値としてゼロ(0)を使用できます。


高速化するサーバ仮想IPアドレスおよびTCPポートを指定するには、イネーブル モードで次の作業を行います。

 

作業
コマンド

高速化するサーバ仮想IPアドレスおよびTCPポートを指定します。

set lda vip { server _ virtual_ip } { destination _ tcp_port } [{ server _ virtual_ip } { destination _ tcp_port }...]

次に、高速化するサーバ仮想IPアドレスおよびTCPポートを指定する例を示します。

Console> (enable) set lda vip 10.0.0.8 8
Successfully set server virtual ip and port information.
Use commit lda command to save settings to hardware.
Console> (enable)

構成ルータのMACアドレスの指定


) 最大32個のルータMACアドレスを指定できます。


構成ルータのMACアドレスを指定するには、イネーブル モードで次の作業を行います。

 

作業
コマンド

構成ルータのMACアドレスを指定します。

set lda mac router { mac-address }...

次に、構成ルータのMACアドレスを指定する例を示します。

Console> (enable) set lda mac router 00-23-45-67-ee-7f
Successfully set mac address.
Use commit lda command to save settings to hardware.
Console> (enable)

LocalDirectorのMACアドレスの指定

LocalDirectorのMACアドレスを指定するには、イネーブル モードで次の作業を行います。

:

作業
コマンド

LocalDirectorのMACアドレスを指定します。

set lda mac ld { ld_mac-address }

次に、LocalDirectorのMACアドレスを指定する例を示します。

Console> (enable) set lda mac ld 00-11-22-33-55-66
Successfully set mac address.
Use commit lda command to save settings to hardware.
Console> (enable)

ルータVLANおよびVLAN上のLocalDirectorポートの指定


set lda routerコマンドを入力したあとで、LocalDirectorの接続先スイッチ ポートを変更した場合には、もう一度set lda routerコマンドを入力して新しい設定を指定する必要があります。



) LocalDirectorのフェールオーバー コンフィギュレーションを設定する場合を除き、バックアップLocalDirectorポートの指定は省略可能です。フェールオーバー コンフィギュレーションを設定する場合は、バックアップLocalDirectorのポートを指定する必要があります。この作業を行わないと、スーパバイザ エンジンはバックアップLocalDirectorにトラフィックを送信しないため、フェールオーバーは機能しません。


ルータVLAN、およびそのVLAN上のLocalDirectorポートを指定するには、イネーブル モードで次の作業を行います。

 

作業
コマンド

ルータVLANおよびそのVLAN上のLocalDirectorポートを指定します。

set lda router { router _ vlan } { ld_mod/port } [ backup_ld_mod/port ]

次に、ルータVLANおよびそのVLAN上のLocalDirectorポートを指定する例を示します。

Console> (enable) set lda router 110 4/26
Successfully set router vlan and LD port.
Use commit lda command to save settings to hardware.
Console> (enable)

サーバVLANおよびVLAN上のLocalDirectorポートの指定


set lda serverコマンドを入力したあとで、LocalDirectorの接続先スイッチ ポートを変更した場合には、もう一度set lda server コマンドを入力して新しい設定を指定する必要があります。



) LocalDirectorのフェールオーバー コンフィギュレーションを設定する場合を除き、バックアップLocalDirectorポートの指定は省略可能です。フェールオーバー コンフィギュレーションを設定する場合は、バックアップLocalDirectorのポートを指定する必要があります。この作業を行わないと、スーパバイザ エンジンはバックアップLocalDirectorにトラフィックを送信しないため、フェールオーバーは機能しません。


サーバVLAN、およびそのVLAN上のLocalDirectorポートを指定するには、イネーブル モードで次の作業を行います。

 

作業
コマンド

サーバVLANおよびそのVLAN上のLocalDirectorポートを指定します。

set lda server { server _ vlan } { ld_mod/port } [ backup_ld_mod/port ]

次に、サーバVLANおよびそのVLAN上のLocalDirectorポートを指定する例を示します。

Console> (enable) set lda server 105 4/40
Successfully set server vlan and LD port.
Use commit lda command to save settings to hardware.
Console> (enable)

UDPエージングの設定

UDPエージングを設定するには、イネーブル モードで次の作業を行います。

 

作業
コマンド

UDPエージングを設定します。

set lda udpage time_in_ms

エージングは、1~2024000ミリ秒(ms)の範囲で設定できます。UDPエージングをディセーブルにするには、0を入力します。

次に、UDPエージングを500ミリ秒に設定する例を示します。

Console> (enable) set lda udpage 500
Successfully set LDA UDP aging time to 500ms.
Console> (enable)

ASLB設定のコミット


) ASLBの設定値は、一時的に編集バッファに格納されます。これらの設定値はNVRAMに保存されますが、設定値を有効にするには、commit ldaコマンドを入力する必要があります。このコマンドによって設定値が確認されます。情報が正しく入力されており、かつ整合性検査にパスすれば、設定値がハードウェアにプログラミングされます。ASLB設定が正常にコミットされると、NVRAMにマッピングが保存され、システムの起動時に復元されます。


ASLB設定値をコミットするには、イネーブル モードで次の作業を行います。

 

作業
コマンド

ASLB設定値をコミットします。

commit lda

次に、ASLB設定値をコミットする例を示します。

Console> (enable) commit lda
Commit operation in progress...
Successfully committed Local Director Accelerator.
Console> (enable)

ASLB設定の表示


show ldaコマンドにキーワード(committed | uncommitted)を指定しないで入力すると、コミットされた設定値が表示されます。


コミットされたASLB設定値、またはまだコミットされていないASLB設定値を表示するには、イネーブル モードで次の作業を行います。

 

作業
コマンド

コミットされたASLB設定値、またはまだコミットされていないASLB設定値を表示します。

show lda [ committed | uncommitted ]

次に、コミットされたASLB設定値を表示する例を示します。

Console> (enable) show lda committed
Status:Committed
 
Virtual IP addresses:
Local Director Flow:10.0.0.8/ (TCP port 8)
 
Router MAC:
00-23-45-67-ee-7f
 
 
LD MAC:00-11-22-33-55-66
 
LD Router Side:
---------------
Router and LD are on VLAN 110
LD is connected to switch port 4/26 on VLAN 110
 
LD Server Side:
---------------
Server(s) and LD are on VLAN 105
LD is connected to switch port 4/40 on VLAN 105
Console> (enable)
 

設定を変更し、その変更をコミットせずに、もう一度 show lda コマンドを入力すると、メッセージが表示され、前回のコミット以降に設定が変更されているが、新しい変更については表示せず、コミット済みの変更だけを表示する旨が示されます。新しい変更を表示するには、 show lda uncommitted コマンドを入力します。

ASLB MLSエントリの表示


short | longオプションの使用により、出力を通常のフォーマット(1行が80文字)または幅の広いフォーマットで表示できます。


ASLB MLSエントリを表示するには、イネーブル モードで次の作業を行います。

 

作業
コマンド

ASLB MLSエントリを表示します。

show lda mls entry

show lda mls entry [ destination ip_addr_spec ] [ source ip_addr_spec ] [ protocol protocol ] [ src-port port ] [ dst-port port ] [ short | long ]

次に、すべてのASLB MLSエントリをshortフォーマットで表示する例を示します。

Console> (enable) show lda mls entry short
Destination-IP Source-IP Prot DstPrt SrcPrt Destination-Mac Vlan
--------------- --------------- ----- ------ ------ ----------------- ----
EDst ESrc DPort SPort Stat-Pkts Stat-Bytes Uptime Age
---- ---- ------ ------ ---------- ----------- -------- --------
10.0.0.8 172.20.20.10 TCP 8 64 00-33-66-99-22-44 105
ARPA ARPA - 4/25 0 0 00:00:02 00:00:05
 
10.0.0.8 172.20.20.11 TCP 8 64 00-33-66-99-22-44 105
ARPA ARPA - 4/25 0 0 00:00:05 00:00:08
Console> (enable)
 

次に、特定の送信元IPアドレスについて、ASLB情報をshortフォーマットで表示する例を示します。

Console> (enable) show lda mls entry source 172.20.20.11 short
Destination-IP Source-IP Prot DstPrt SrcPrt Destination-Mac Vlan
--------------- --------------- ----- ------ ------ ----------------- ----
EDst ESrc DPort SPort Stat-Pkts Stat-Bytes Uptime Age
---- ---- ------ ------ ---------- ----------- -------- --------
10.0.0.8 172.20.20.11 TCP 8 64 00-33-66-99-22-44 105
ARPA ARPA - 4/25 0 0 00:00:05 00:00:08
Console> (enable)

ASLB MLS統計情報の表示

ASLB MLS統計情報を表示するには、イネーブル モードで次の作業を行います。

 

作業
コマンド

ASLB MLSエントリの統計情報を表示します。

show lda mls statistics entry

show lda mls statistics count

show lda mls statistics entry [ destination ip_addr_spec ]
[
source ip_addr_spec ] [ protocol protocol ]
[
src-port port ] [ dst-port port ]

次に、すべてのASLB MLSエントリについて統計情報を表示する例を示します。

Console> (enable) show lda mls statistics entry
Last Used
Destination IP Source IP Prot DstPrt SrcPrt Stat-Pkts Stat-Bytes
--------------- --------------- ---- ------ ------ ---------- ---------------
10.0.0.8 172.20.20.10 TCP WWW 64 636 29256
10.0.0.8 172.20.22.10 TCP WWW 64 0 0
Console> (enable)
 

次に、ASLBのアクティブMLSエントリ数を表示する例を示します。

Console> (enable) show lda mls statistics count
LDA active shortcuts: 20
Console> (enable)

次に、特定の宛先IPアドレスについて統計情報を表示する例を示します。

Console> (enable) show lda mls statistics entry destination 172.20.22.14
Last Used Last Used
Destination IP Source IP Prot DstPrt SrcPrt Stat-Pkts Stat-Bytes
--------------- --------------- ---- ------ ------ ---------- ---------------
172.20.22.14 172.20.25.10 6 50648 80 3152 347854
Console> (enable)

ASLB設定の消去


注意 clear ldaコマンドにキーワードを指定しないで入力すると、ハードウェアとNVRAMからASLB設定全体(MLSエントリを含む)が削除されます。clear lda mlsコマンドにキーワードを指定しないで入力すると、すべてのMLSエントリが消去されます。

ASLBエントリまたはルータのMACアドレスを消去するには、イネーブル モードで次の作業を行います。

 

作業
コマンド

ASLB設定値を消去します。

clear lda mls

clear lda mls [ destination ip_addr_spec ] [ source ip_addr_spec ] [ protocol protocol src-port src_port dst-port dst_port ]

clear lda vip { all | vip | vip tcp_port }

clear lda mac { all | router_mac_address }

次に、特定の宛先アドレスについてMLSエントリを消去する例を示します。

Console> (enable) clear lda mls destination 172.20.26.22
MLS IP entry cleared.
Console> (enable)
 

次に、仮想IPアドレスおよびポートのペア(10.0.0.8、ポート8)を削除する例を示します。

Console> (enable) clear lda vip 10.0.0.8 8
Successfully deleted vip/port pairs.
Console> (enable)
 

次に、すべてのASLBルータMACアドレスを消去する例を示します。

Console> (enable) clear lda mac all
Successfully cleared Router MAC address.
Console> (enable)
 

次に、特定のASLBルータMACアドレスを消去する例を示します。

Console> (enable) clear lda mac 1-2-3-4-5-6
Successfully cleared Router MAC address.
Console> (enable)

ASLBの設定例

ここでは、一般的なASLBネットワーク構成例を示します。図46-4はネットワーク例です。設定の仕様は次のとおりです。

仮想IPアドレスは192.255.201.55です。

ルータ インターフェイスのMACアドレスは00-d0-bc-e9-fb-47、IPアドレスは192.255.201.1です。

LocalDirectorのIPアドレスは192.255.201.2です。

LocalDirectorのMACアドレスは00-e0-b6-00-4b-04です。

サーバ ファームのIPアドレスは、192.255.201.3~192.255.201.11です。

一連のサーバは、仮想IPアドレス192.255.201.55に関するARP要求を無視するように設定されています。

図46-4の例では、次の処理が行われています。

サーバ192.255.201.3~192.255.201.10で、ラウンドロビン シーケンスによりHTTP接続の負荷を分散

ポート8001への接続をサーバ192.255.201.11に転送

サーバ192.255.201.3~192.255.201.8で、LocalDirectorのデフォルトである[leastconns]シーケンスにより、FTP接続の負荷を分散

図46-4 ASLBの設定例

 

ルータの設定は、次のとおりです(この例ではMSMを使用しています)。

!
interface Port-channel1.7
encapsulation isl 7
ip address 192.255.201.1 255.255.255.0
no ip redirects
no ip directed-broadcast
!
 

Catalyst 6500シリーズ スイッチの設定は、次のとおりです。

Console (enable) show lda
Status:Committed
 
Virtual IP addresses:
Local Director Flow:192.255.201.55/www (TCP port 80)
Local Director Flow:192.255.201.55/ (TCP port 8001)
Local Director Flow:192.255.201.55/ftp (TCP port 21)
 
Router MAC:
00-d0-bc-e9-fb-47
 
LD MAC: 00-e0-b6-00-4b-04
 
LD Router Side:
---------------
Router and LD are on VLAN 7
LD is connected to switch port 5/7 on VLAN 7
 
LD Server Side:
---------------
Server(s) and LD are on VLAN 5
LD is connected to switch port 5/5 on VLAN 5
Console (enable)
 

LocalDirectorの設定は、次のとおりです。

LD430# show configuration
:Saved
:LocalDirector 430 Version 3.1.3.105
syslog output 20.3
no syslog console
hostname LD430
no shutdown ethernet 0
no shutdown ethernet 1
shutdown ethernet 2
shutdown ethernet 3
interface ethernet 0 100full
interface ethernet 1 100full
interface ethernet 2 auto
interface ethernet 3 auto
mtu 0 1500
mtu 1 1500
mtu 2 1500
mtu 3 1500
no multiring all
no secure 0
no secure 1
no secure 2
no secure 3
ping-allow 0
ping-allow 1
no ping-allow 2
no ping-allow 3
 
ip address 192.255.201.2 255.255.255.0
route 0.0.0.0 0.0.0.0 192.255.201.1 1
no rip passive
rip version 1
failover ip address 0.0.0.0
no failover
snmp-server enable traps
no snmp-server contact
no snmp-server location
virtual 192.255.201.55:80:0:tcp is
virtual 192.255.201.55:8001:0:tcp is
virtual 192.255.201.55:21:0:tcp is
predictor 192.255.201.55:80:0:tcp roundrobin
redirection 192.255.201.55:80:0:tcp dispatched assisted wildcard-ttl 60
fixed-ttl 60 igmp 224.0.1.2 port 1637
redirection 192.255.201.55:8001:0:tcp dispatched assisted wildcard-ttl 60
fixed-ttl 60 igmp 224.0.1.2 port 1637
redirection 192.255.201.55:21:0:tcp dispatched assisted wildcard-ttl 60
fixed-ttl 60 igmp 224.0.1.2 port 1637
real 192.255.201.5:80:0:tcp is
real 192.255.201.3:80:0:tcp is
real 192.255.201.4:80:0:tcp is
real 192.255.201.6:80:0:tcp is
real 192.255.201.7:80:0:tcp is
real 192.255.201.8:80:0:tcp is
real 192.255.201.9:80:0:tcp oos
real 192.255.201.10:80:0:tcp oos
real 192.255.201.11:8001:0:tcp oos
real 192.255.201.3:21:0:tcp is
real 192.255.201.4:21:0:tcp is
real 192.255.201.5:21:0:tcp is
real 192.255.201.6:21:0:tcp is
real 192.255.201.7:21:0:tcp is
real 192.255.201.8:21:0:tcp is
bind 192.255.201.55:80:0:tcp 192.255.201.3:80:0:tcp
bind 192.255.201.55:80:0:tcp 192.255.201.4:80:0:tcp
bind 192.255.201.55:80:0:tcp 192.255.201.5:80:0:tcp
bind 192.255.201.55:80:0:tcp 192.255.201.6:80:0:tcp
bind 192.255.201.55:80:0:tcp 192.255.201.7:80:0:tcp
bind 192.255.201.55:80:0:tcp 192.255.201.8:80:0:tcp
bind 192.255.201.55:80:0:tcp 192.255.201.9:80:0:tcp
bind 192.255.201.55:80:0:tcp 192.255.201.10:80:0:tcp
bind 192.255.201.55:8001:0:tcp 192.255.201.11:8001:0:tcp
bind 192.255.201.55:21:0:tcp 192.255.201.3:21:0:tcp
bind 192.255.201.55:21:0:tcp 192.255.201.4:21:0:tcp
bind 192.255.201.55:21:0:tcp 192.255.201.5:21:0:tcp
bind 192.255.201.55:21:0:tcp 192.255.201.6:21:0:tcp
bind 192.255.201.55:21:0:tcp 192.255.201.7:21:0:tcp
bind 192.255.201.55:21:0:tcp 192.255.201.8:21:0:tcp

ASLB冗長構成の例

ここでは、一般的な冗長ASLBネットワーク構成例を示します。図46-5は冗長ネットワーク例です。サーバVIPアドレス13.13.13.13に対するHTTPおよびTelnetを高速化するように、LocalDirectorsおよびCatalyst 6500シリーズ スイッチを設定します。


注意 図46-5では、ルータ1およびルータ2のインターフェイス(f1およびf2)上でHot Standby Router Protocol(HSRP)が稼働しています。インターフェイスf2がアクティブになっているルータ上でf1がアクティブになっている必要があります。アクティブになっていない場合、一方のルータ上のインターフェイスf1にトラフィックが到達しても、もう一方のルータ上でアクティブになっているインターフェイスf2に転送されません。HSRPのtrackコマンドを使用して、各ルータの反対側のインターフェイスの状況を追跡します。

図46-5 ASLB冗長構成の例

 

IPアドレス

IPアドレスは、次のとおりです。

ルータ1、f1 IPアドレス:7.0.0.100(ネットワーク7)

ルータ2、f1 IPアドレス:7.0.0.101(ネットワーク7)

HSRP IPアドレス:ネットワーク7で7.0.0.1

ルータ1、f2 IPアドレス:5.0.0.100(ネットワーク5)

ルータ2、f2 IPアドレス:5.0.0.101(ネットワーク5)

HSRP IPアドレス:ネットワーク5で5.0.0.2

LocalDirector IPアドレス: 5.0.0.1

サーバIPアドレス: 5.100.100.100

サーバのVIPアドレス: 13.13.13.13

MACアドレス

MACアドレスは、次のとおりです。

ネットワーク7のHSRP MACアドレス:00-00-0c-07-ac-00

ネットワーク5のHSRP MACアドレス:00-00-0c-07-ac-01

ルータ1、f2 MACアドレス:00-d0-79-7b-20-88

ルータ2、f2 MACアドレス:00-d0-79-7b-18-88

LocalDirector MACアドレス:00-e0-b6-00-47-ec

Catalyst 6500シリーズ スイッチ1の設定

スイッチ1の設定は、次のとおりです。

set trunk 3/23 on isl 1,5,9
set lda enable
clear lda vip all
set lda vip 13.13.13.13 80 13.13.13.13 23
clear lda mac all
set lda mac router 00-00-0c-07-ac-01
set lda mac router 00-d0-79-7b-20-88
set lda mac router 00-d0-79-7b-18-88
set lda mac ld 00-e0-b6-00-47-ec
set lda router 9 3/7 3/23
set lda server 5 3/8 3/23
commit lda
 

Catalyst 6500シリーズ スイッチ2の設定

スイッチ2の設定は、次のとおりです。

set trunk 3/23 on isl 1,5,9
set lda enable
clear lda vip all
set lda vip 13.13.13.13 80 13.13.13.13 23
clear lda mac all
set lda mac router 00-00-0c-07-ac-01
set lda mac router 00-d0-79-7b-20-88
set lda mac router 00-d0-79-7b-18-88
set lda mac ld 00-e0-b6-00-47-ec
set lda router 9 3/27 3/23
set lda server 5 3/28 3/23
commit lda
 

ルータ1の設定

ルータ1の設定は、次のとおりです。

interface FastEthernet1
ip address 7.0.0.100 255.0.0.0
no ip redirects
no ip directed-broadcast
no ip route-cache distributed
load-interval 30
no keepalive
full-duplex
standby 1 ip 7.0.0.1
standby 1 track FastEthernet2
!
interface FastEthernet2
ip address 5.0.0.100 255.0.0.0
no ip redirects
no ip directed-broadcast
no ip route-cache distributed
no keepalive
full-duplex
standby priority 250
standby 2 ip 5.0.0.2
standby 2 track FastEthernet1
!
ip route 13.13.13.13 255.255.255.255 5.0.0.1
 

ルータ2の設定

ルータ2の設定は、次のとおりです。

interface FastEthernet1
ip address 7.0.0.101 255.0.0.0
no ip redirects
no ip directed-broadcast
no ip route-cache distributed
load-interval 30
no keepalive
full-duplex
standby 1 ip 7.0.0.1
standby 1 track FastEthernet2
!
interface FastEthernet2
ip address 5.0.0.101 255.0.0.0
no ip redirects
no ip directed-broadcast
no ip route-cache distributed
no keepalive
full-duplex
standby priority 250
standby 2 ip 5.0.0.2
standby 2 track FastEthernet1
!
ip route 13.13.13.13 255.255.255.255 5.0.0.1
 

LocalDirectorの設定

LocalDirector 1およびLocalDirector 2の設定は、次のとおりです(設定は両方のLocalDirectorで共通です)。

no shutdown ethernet 0
no shutdown ethernet 4
interface ethernet 0 100full
interface ethernet 4 100full
ip address 5.0.0.1 255.0.0.0
failover ip address 5.0.0.5
virtual 13.13.13.13:80:0:tcp is
virtual 13.13.13.13:23:0:tcp is
predictor 13.13.13.13:80:0:tcp roundrobin
predictor 13.13.13.13:23:0:tcp roundrobin
redirection 13.13.13.13:80:0:tcp dispatched assisted
redirection 13.13.13.13:23:0:tcp dispatched assisted
real 5.100.100.100:80:0:tcp is
real 5.100.100.100:23:0:tcp is
bind 13.13.13.13:80:0:tcp 5.100.100.100:80:0:tcp
bind 13.13.13.13:23:0:tcp 5.100.100.100:23:0:tcp
 

ASLB設定のトラブルシューティング

表46-6 に、発生する可能性のある問題と、ASLB設定のトラブルシューティングのために推奨する対処方法を示します。

 

表46-6 ASLB設定のトラブルシューティング

現象
対処方法

LocalDirectorがトラフィックを受信しない。

set lda server および set lda router コマンドを使用して指定したポートに、LocalDirectorが接続していることを確認します。

LocalDirector接続エントリが削除されない。

set lda vip コマンドを使用して、すべての仮想IP/ポートのペアを設定していることを確認します。

ASLB MLSエントリが単一方向にしか作成されない。

スーパバイザ エンジン( set lda vip コマンド)およびLocalDirectorの両方で、仮想IP/ポートのペアをすべて設定していることを確認します。

LocalDirectorが[dispatched assisted]モードになっていることを確認します。

「IPアドレス」に記載されている注意事項に従って、ルータ、LocalDirector、およびサーバのIPアドレスを設定していることを確認します。(仮想IPアドレスがルータ インターフェイスとは別のサブネットに存在する場合)トラフィックが仮想IPアドレスに転送されたときに、LocalDirectorに到達する方法をルータが認識していることを確認します。

ルータのMACアドレスが、 set lda mac router コマンドで指定したアドレスと同じであることを確認します。

LocalDirectorのMACアドレスが、 set lda mac ld コマンドで指定したアドレスと同じであることを確認します。

バックアップLocalDirectorがトラフィックを受信しない。

set lda router および set lda server コマンドを使用してバックアップLocalDirectorポートを設定していることを確認します。たとえば、 set lda router { router _ vlan } 3/7 3/9 および set lda server { server _ vlan } 3/8 3/10 コマンドを入力します。

ルータからサーバへのpingは成功するが、データ トラフィックを送信してもASLB MLSエントリが作成されない。

サーバが仮想IPアドレスに関するARP要求を無視するように設定されていることを確認します。

次のメッセージが表示される。

%CDP-4-NVLANMISMATCH:Native vlan mismatch detected on port ...

LocalDirectorに接続するポート上でCDP19をディセーブルにします( set cdp disable コマンドを入力します)。

LocalDirectorの set コマンドが有効にならない。

set lda コマンドは、 commit lda コマンドを入力しないかぎり有効になりません。

どの set lda コマンドが有効になっているかを確認するには、 show lda commit コマンドを使用します。

どの設定済み set lda コマンドがコミットされていないか、または現在の set lda コマンドをコミットするとどのような変化が起きるかを判別するには、 show lda uncommitted コマンドを使用します。

Catalyst 6500シリーズ スイッチ ポートに[collisions]、または[port disabled]と表示される。

LocalDirectorとスイッチ間のリンクの両端で、ポート速度およびデュプレックスの設定が一致していることを確認します。たとえば、スイッチ上のポート3/7がLocalDirectorのinterface ethernet 0に接続している場合、ポート3/7が100fullに設定され、LocalDirectorのinterface ethernet 0も100fullに設定されていることを確認します。

19.CDP = Cisco Discovery Protocol