Catalyst 6500 シリーズ スイッチ ソフトウェア コンフィギュレーション ガイド Software Release 8.4
冗長機能の設定
冗長機能の設定
発行日;2012/01/09 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 9MB) | フィードバック

目次

冗長機能の設定

スーパバイザ エンジンの冗長機能

スイッチ上での冗長スーパバイザ エンジンの設定

同期化プロセスの開始

スーパバイザ エンジンの冗長構成に関する注意事項および制限事項

スタンバイ スーパバイザ エンジン ステータスの確認

スタンバイ スーパバイザ エンジンへの強制切り替え

ハイ アベイラビリティ機能

ハイ アベイラビリティの概要

ハイ アベイラビリティでサポートされる機能

ハイ アベイラビリティ設定時の注意事項

バージョニングの概要

CLIコマンド

スタンバイ スーパバイザ エンジンへの異なる(ただし互換性のある)イメージのロード

NSFおよびSSOを使用したスーパバイザ エンジンの冗長構成

スーパバイザ エンジンの同期化の例

ランタイム イメージとブートストリングの同期化

アクティブおよびスタンバイ スーパバイザ エンジンのブート イメージの同期化

MSFC冗長機能

デュアルMSFC冗長機能

ハードウェアおよびソフトウェアの要件

単一シャーシによるレイヤ3冗長設定

ルーティング プロトコルのピア設定

ACLの設定

デュアルMSFC運用モデルの冗長機能および負荷分散

障害の例

HSRPを使用した冗長機能の設定

設定例

MSFC設定同期化の概要

設定同期化のイネーブル化およびディセーブル化

ハイ アベイラビリティ冗長機能の設定例

SRMの冗長機能

ハードウェアおよびソフトウェアの要件

SRM冗長性設定時の注意事項

Supervisor Engine 720におけるSRM冗長機能の設定

Supervisor Engine 1またはSupervisor Engine 2におけるSRM冗長機能の設定

新しいアクティブ指定ルータに対する移行時間の指定

SRMをイネーブルに設定したイメージのアップグレード

SRMの終了

手動モードMSFC冗長機能

ハードウェアおよびソフトウェアの要件

手動モードMSFC冗長機能設定時の注意事項

スタンバイMSFCのアクセス

手動によるMSFCの起動

MSFCコンフィギュレーション レジスタの設定

MSFC回復手順

冗長機能の設定

この章では、Catalyst 6500シリーズ スイッチ上で冗長スーパバイザ エンジンを設定する手順、およびMultilayer Switch Feature Card(MSFC;マルチレイヤ スイッチ フィーチャ カード)の冗長機能を設定する手順について説明します。

この章で説明する内容は、次のとおりです。

「スーパバイザ エンジンの冗長機能」

「スイッチ上での冗長スーパバイザ エンジンの設定」

「MSFC冗長機能」


注意 単一シャーシに搭載のデュアルMSFCは、冗長モードのみでの使用を目的に設計されており、同一の設定でなければなりません。詳細については、「MSFC冗長機能」を参照してください。

MSFCの設定が異なる構成はサポートしていません。


) 特に明記されていないかぎり、この章で説明する情報および手順は、Policy Feature Card 3B/3BXL(PFC3B/PFC3BXL;ポリシー フィーチャ カード3B/3BXL)を搭載したSupervisor Engine 32、PFC3A/PFC3B/PFC3BXLを搭載したSupervisor Engine 720、PFC2を搭載したSupervisor Engine 2 、およびPFCを搭載したSupervisor Engine 1に適用されます。



MSFCという用語は、このマニュアルを通じて特に明記されていないかぎり、MSFC、MSFC2、MSFC2A、およびMSFC3を指します。


Catalyst 6500シリーズ冗長スーパバイザ エンジンのインストレーションの詳細については、『 Catalyst 6500 Series Switch Module Installation Guide 』を参照してください。この章で使用しているコマンドの構文および使用方法の詳細については、『 Catalyst 6500 Series Switch Command Reference 』を参照してください。

スーパバイザ エンジンの冗長機能


) 冗長スーパバイザ エンジンには、同じモデルのフィーチャ カードと同タイプのものを使用する必要があります。WS-X6K-SUP1-2GEおよびWS-X6K-SUP1A-2GE(両方ともPFCを非搭載)は互換性があり、冗長構成が可能です。PFCが搭載されたスーパバイザ エンジンの場合、冗長構成にするにはPFCが同一でなければなりません(2つのPFC、2つのPFC2、2つのPFC3A、または2つのPFC3BXL)。


2つのスーパバイザ エンジンを搭載している場合、先に起動したスーパバイザ エンジンがアクティブ モジュールになり、2番めのスーパバイザ エンジンはスタンバイ モードになります。SNMP(簡易ネットワーク管理プロトコル)、CLI(コマンドライン インターフェイス)コンソール、Telnet、Spanning-Tree Protocol(STP;スパニングツリー プロトコル)、Cisco Discovery Protocol(CDP)、VLAN Trunking Protocol(VTP;VLANトランキング プロトコル)などの管理機能およびネットワーク管理機能はすべて、アクティブ スーパバイザ エンジン上で処理されます。

スタンバイ スーパバイザ エンジンのコンソール ポートは非アクティブで、モジュール ステータスは[standby]で示されます。ただし、アップリンク ポートのステータス表示は通常どおりです。

Supervisor Engine 1およびSupervisor Engine 2の場合、冗長スーパバイザ エンジンはシャーシのスロット1および2に搭載する必要があります。Supervisor Engine 720およびSupervisor Engine 32のスロット要件は、次のとおりです。3スロット シャーシの場合は、Supervisor Engine 720およびSupervisor Engine 32をスロット1または2に搭載します。6スロットまたは9スロット シャーシの場合は、Supervisor Engine 720およびSupervisor Engine 32をスロット5または6に搭載します。13スロット シャーシの場合は、Supervisor Engine 720およびSupervisor Engine 32をスロット7または8に搭載します。冗長スーパバイザ エンジンは両方のスロットに搭載する必要があります。

冗長スーパバイザ エンジンはホットスワップ対応です。システムは冗長スーパバイザ エンジンに切り替えたあとも、同じ設定で稼働を続けます。


) 各スーパバイザ エンジンを個別に起動できるようにするため、コンフィギュレーション レジスタは、スーパバイザ エンジン間で同期化されていません。



) アクティブ スーパバイザ エンジンからスタンバイ スーパバイザ エンジンへの切り替えに要する時間に、スパニングツリーのコンバージェンス タイムは含まれていません。


スイッチの起動時には、両方のスーパバイザ エンジンで初期モジュール レベルの診断が実行されます。両方のスーパバイザ エンジンがこのレベルの診断をパスした場合、2つのスーパバイザ エンジンはバックプレーンを介して通信し、スイッチングバス診断時に協調するようになります。スロット1に搭載されたスーパバイザ エンジンがアクティブになり、スロット2のスーパバイザ エンジンがスタンバイ モードになります。2つのスーパバイザ エンジンのソフトウェア バージョンが異なる場合、またはNVRAM(不揮発性RAM)設定が異なっている場合には、アクティブ スーパバイザ エンジンのソフトウェア イメージおよび設定がスタンバイ スーパバイザ エンジンに自動的にダウンロードされます。


スロット1およびスロット2は、冗長スーパバイザ エンジンを指します。上記のように、Supervisor Engine 720およびSupervisor Engine 32ではスロット要件が異なります。


アクティブ スーパバイザ エンジンのバックグラウンド診断によって重大な問題が検出された場合、または例外が発生した場合には、アクティブ スーパバイザ エンジンがリセットされます。スタンバイ スーパバイザ エンジンは、アクティブ スーパバイザ エンジンが稼働しなくなったことを検出し、アクティブになります。スタンバイ スーパバイザ エンジンは、アクティブ スーパバイザ エンジンが正常に機能していない場合にそれを検出し、必要に応じてアクティブ スーパバイザを強制的にリセットすることもできます。リセットされたスーパバイザ エンジンは、復旧するとスタンバイ モードになります。

2番めのスーパバイザ エンジンをオンラインの状態で挿入すると、初期モジュール レベルの診断が完了した時点で、2番めのモジュールはアクティブ スーパバイザ エンジンと通信します。アクティブ スーパバイザ エンジンがすでにバックプレーン上のトラフィックをスイッチングしているので、2番めのスーパバイザ エンジンについてはスイッチングバス診断は実行されません。診断を実行すると通常のトラフィックが中断される可能性があるためです。2番めのスーパバイザエンジンは、ただちにスタンバイ モードになります。この時点で、アクティブ スーパバイザ エンジンのソフトウェア イメージおよび設定が、必要に応じてスタンバイ スーパバイザ エンジンにダウンロードされます。

スーパバイザ エンジンは、 ブート イメージ ランタイム イメージ という2つのフラッシュ イメージを使用します。ブート イメージのファイル名は、BOOT環境変数で指定し、NVRAMに保存します。ランタイム イメージは、ROMモニタがスーパバイザ エンジンを起動するために使用するブート イメージです。システム起動後は、ランタイム イメージはDRAMに常駐します。

冗長スーパバイザ エンジンを搭載したスイッチの電源を入れるか、リセットすると、スタンバイ スーパバイザ エンジン上のランタイム イメージとブート イメージがアクティブ スーパバイザ エンジン上のイメージと同じになるように 同期化が行われます。

スーパバイザ エンジンのランタイム イメージとブート イメージは、異なる場合があります。ブート イメージとランタイム イメージが同じであるときに、BOOT環境変数を変更したり、システム起動に使用されたフラッシュ デバイス上の現在のブート イメージを上書きしたり破棄したりすると、ランタイム イメージとブート イメージは異なったものになります。ブートイメージを再設定すると、アクティブ スーパバイザ エンジンは、現在のブート イメージをスタンバイ スーパバイザ エンジンと同期化させます。

ブート イメージは、フラッシュ ファイル システムに直接読み込まれます。フラッシュ メモリ装置に保存されたファイルに対しては、( copy delete undelete などの)操作を実行できます。また、アクティブ スーパバイザ エンジンのブート イメージを、スタンバイ スーパバイザ エンジンのブートフラッシュに保存できます。フラッシュ ファイル システムの詳しい使用手順は、 第24章「フラッシュ ファイル システムの使用」 を参照してください。

Supervisor Engine 1およびSupervisor Engine 2には、オンボード フラッシュ メモリのほかにフラッシュPCカード(PCMCIA[パーソナル コンピュータ メモリ カード国際協会])スロット(slot0)があります。このスロットにフラッシュPCカードを挿入し、そこに追加のブート イメージを保存することができます。スロットのキーワードは、 slot0: (リニア フラッシュ デバイスの場合)、および disk0: (ATAフラッシュ デバイスの場合)です。


) このマニュアルでは、「PCMCIAカード」という用語の代わりに「フラッシュPCカード」を使用しています。


Supervisor Engine 720には、コンパクトフラッシュType IIスロットが2つあります。コンパクトフラッシュType IIスロットは、コンパクトフラッシュType IIフラッシュPCカードをサポートしています。アクティブなSupervisor Engine 720上のスロットのキーワードは、 disk0: および disk1: です。冗長Supervisor Engine 720上のスロットのキーワードは、 slavedisk0: および slavedisk1: です。Supervisor Engine 32には、コンパクトフラッシュType IIスロットが1つあります。コンパクトフラッシュType IIスロットは、コンパクトフラッシュType IIフラッシュPCカードをサポートしています。アクティブなSupervisor Engine 32上のスロットのキーワードは、 disk0: 冗長Supervisor Engine 32上のスロットのキーワードは、 slavedisk0:

複数のブート イメージを保存できるという理由から、起動および同期化が正しく行われるようにするため、ブート ファイル イメージの名前およびイメージ ファイルのフラッシュ ファイル システムでの保存場所を指定する必要があります。ブート イメージの名前および場所の指定方法については、 第23章「スイッチの起動設定の変更」 を参照してください。

同期化プロセス中、アクティブ スーパバイザ エンジンはスタンバイ スーパバイザ エンジンのランタイム イメージをチェックし、自身のランタイム イメージと一致していることを確認します。アクティブ スーパバイザ エンジンがチェックする条件は、次の3つです。

アクティブ スーパバイザ エンジンのブート イメージを、スタンバイ スーパバイザ エンジンにコピーする必要があるかどうか。

スタンバイ スーパバイザ エンジンのブートストリングを変更する必要があるかどうか。

スタンバイ スーパバイザ エンジンをリセットする必要があるかどうか。

ここでは、フラッシュの同期化が開始される条件について説明します。さまざまな設定でスーパバイザ エンジンのフラッシュ イメージを同期化する例は、「スーパバイザ エンジンの同期化の例」を参照してください。

スイッチ上での冗長スーパバイザ エンジンの設定

ここでは冗長スーパバイザ エンジンの設定方法について説明します。

「同期化プロセスの開始」

「スーパバイザ エンジンの冗長構成に関する注意事項および制限事項」

「スタンバイ スーパバイザ エンジン ステータスの確認」

「スタンバイ スーパバイザ エンジンへの強制切り替え」

「ハイ アベイラビリティ機能」

「NSFおよびSSOを使用したスーパバイザ エンジンの冗長構成」

同期化プロセスの開始

アクティブおよびスタンバイ スーパバイザ エンジン上のランタイム イメージおよびブート イメージの同期化が開始される条件は、次のとおりです。

アクティブおよびスタンバイ スーパバイザ エンジン間でのランタイム イメージのタイムスタンプの不一致 ― システムの起動時またはリセット時に、それぞれのランタイム イメージのタイムスタンプが異なっている場合、アクティブ スーパバイザ エンジンが自分のランタイム イメージに合わせて、スタンバイ スーパバイザ エンジンを同期化させます。

アクティブおよびスタンバイ スーパバイザ エンジン間でのブート イメージのタイムスタンプの不一致 ― システムの起動時またはリセット時に、それぞれのブート イメージのタイムスタンプが異なっている場合、またはBOOT環境変数が変更された場合には、アクティブ スーパバイザ エンジンが自分のブート イメージに合わせて、スタンバイ スーパバイザ エンジンを同期化させます。

現在のブート イメージの上書き ― いずれかのフラッシュ デバイス上で保存されている現在のブート イメージが上書きされた場合、ファイル システム管理モジュールがそのイベントを検出し、同期化を開始します。アクティブ スーパバイザ エンジンが自分の新しいブート イメージに合わせて、スタンバイ スーパバイザ エンジンを同期化させます。

BOOT環境変数の変更 ― BOOT環境変数を変更して、異なるデフォルトブート イメージを指定した場合、アクティブ スーパバイザ エンジンによってブート イメージの同期化が開始されます。NVRAM設定モジュールがそのイベントを検出し、起動設定パラメータを調べることにより、次に可能性の高いブート ファイル名を指定して、フラッシュ同期機能を呼び出します。

同じブート イメージ ファイル名が使用されているフラッシュPCカード ― アクティブまたはスタンバイのどちらかのスーパバイザ エンジンのフラッシュ デバイスを交換し、新しいフラッシュ デバイスに以前のフラッシュ デバイスのブート イメージと同じ名前の(タイムスタンプの異なる)ブート イメージが格納されている場合、フラッシュ ファイル管理モジュールが同期機能を開始します。

現在のランタイム イメージの削除 ― フラッシュ デバイスから現在のランタイム イメージを削除する場合、フラッシュ ファイル管理モジュールから削除の確認を求められます。確認すると、フラッシュ ファイル管理モジュールがフラッシュの同期化を開始し、NVRAM設定モジュールに変更を通知します。NVRAM設定モジュールは、BOOT環境変数を調べ、次に起動できるイメージを特定し、新しいイメージ名を使用してフラッシュ同期機能を呼び出します。

スーパバイザ エンジンの冗長構成に関する注意事項および制限事項

次に挙げる条件またはイベントは、冗長構成のスーパバイザ エンジン間でイメージが正しく同期化されず、予想外の結果が生じる原因になります。

アクティブ スーパバイザ エンジンへの新しいイメージのダウンロード

アクティブ スーパバイザ エンジンに新しいイメージをダウンロードすると、新しいイメージが(ブートフラッシュまたはフラッシュPCカードの)ファイル システムにコピーされます。このイメージはブート イメージとして設定されていない場合もあるので、新しくダウンロードしたイメージは、スタンバイ スーパバイザ エンジンに自動的にはコピーされません。

アクティブおよびスタンバイのスーパバイザ エンジン間で同期機能を開始するには、新しくダウンロードしたイメージを、アクティブ スーパバイザ エンジン上でブート イメージとして設定する必要があります。同期化は、ブート変数を変更したときに行われます。新しいイメージを実行するには、システムのリセットが必要です。

現在のランタイム イメージが見つからない場合

アクティブ スーパバイザ エンジンがフラッシュ デバイス上で現在のランタイム イメージを見つけることができない場合には、エラー状態が伝えられます。スタンバイ スーパバイザ エンジンが搭載またはリセットされても、フラッシュの同期化は実行されません。さらに、スタンバイ スーパバイザ エンジン上のSTATUS LEDがレッドに点灯し、Syslogエラー メッセージが生成されます。

スロット2にアクティブ スーパバイザ エンジンが搭載されている場合

アクティブ スーパバイザ エンジンがスロット2に搭載されている場合、スタンバイ スーパバイザ エンジンはスロット1にあります。設定を変更して新しいブート イメージを指定し、システムをリセットすると、スロット1のスーパバイザ エンジンがアクティブ スーパバイザ エンジンになり、対応するデフォルトのブート イメージがロードされて、変更した設定内容が取り消されます。この問題を回避するために、ブート ファイル設定を変更すると、スイッチはただちに、フラッシュの同期化を要求するプロンプトを表示します。

スタンバイ スーパバイザ エンジン ステータスの確認

ここで説明されるCLIコマンドを使用して、スタンバイ スーパバイザ エンジンのステータスを確認することができます。


show moduleコマンドは、搭載されたドータカードについての情報を出力します。show testコマンドは、オンボードのApplication-Specific Integrated Circuit(ASIC;特定用途向けIC)についての情報を出力します。


スタンバイ スーパバイザ エンジンのステータスを調べるには、次の作業のうち1つまたは複数を行います。

 

作業
コマンド

スタンバイ スーパバイザ エンジンのステータスを表示します。

show module [ mod ]

スタンバイ スーパバイザ エンジンのアップリンク ポート ステートを表示します。

show port [ mod [ /port ]]

スタンバイ スーパバイザ エンジンについて、診断テスト結果を表示します。

show test [ mod ]

次に、 show module および show test コマンドを入力して、スタンバイ スーパバイザ エンジンのステータスを調べる例を示します。

Console> (enable) show module 2
Mod Slot Ports Module-Type Model Status
--- ---- ----- ------------------------- ------------------- --------
2 2 2 1000BaseX Supervisor WS-X6K-SUP1-2GE ok
 
Mod Module-Name Serial-Num
--- ------------------- -----------
2 SAD02330231
 
Mod MAC-Address(es) Hw Fw Sw
--- -------------------------------------- ------ ---------- -----------------
2 00-e0-14-0e-f5-6c to 00-e0-14-0e-f5-6d 0.404 4.2(2038) 4.2(0.24)VAI50
00-e0-14-0e-f5-6e to 00-e0-14-0e-f5-6f
00-10-7b-bb-2b-00 to 00-10-7b-bb-2e-ff
 
Mod Sub-Type Sub-Model Sub-Serial Sub-Hw
--- ------------------- ------------------- ----------- ------
2 L2 Switching Engine WS-F6020 SAD02350211 0.101
Console> (enable)
 
Console> (enable) show test 2
Module 2 : 2-port 1000BaseX Supervisor
Network Management Processor (NMP) Status: (. = Pass, F = Fail, U = Unknown)
ROM: . Flash-EEPROM: . Ser-EEPROM: . NVRAM: . EOBC Comm: .
 
Line Card Status for Module 1 : PASS
 
Port Status :
Ports 1 2
-----------
. .
Line Card Diag Status for Module 2 (. = Pass, F = Fail, N = N/A)
 
Module 2
Cafe II Status :
NewLearnTest: .
IndexLearnTest: .
DontForwardTest: .
DontLearnTest: .
ConditionalLearnTest: .
BadBpduTest: .
TrapTest: .
Loopback Status [Reported by Module 2] :
Ports 1 2
-----------
. .
Console> (enable)

スタンバイ スーパバイザ エンジンへの強制切り替え

アクティブ スーパバイザ エンジンをリセットすることによって、スタンバイ スーパバイザ エンジンに強制的に切り替えることができます。


) アクティブ スーパバイザ エンジンをリセットすると、オープンしているTelnetセッションが切断されます。


スタンバイ スーパバイザ エンジンに強制的に切り替えるには、イネーブル モードで次の作業を行います。

 

作業
コマンド

アクティブ スーパバイザ エンジンをリセットします( mod はアクティブ スーパバイザ エンジンの番号を示します)。

reset mod

また、アクティブ スーパバイザ エンジン上でCISCO-STACK-MIB moduleAction変数をreset(2)に設定することによって、スタンバイ スーパバイザ エンジンに強制的に切り替えることもできます。切り替えが行われると、システムから標準のSNMPウォームスタート トラップが、設定されているトラップ レシーバーに送信されます。

次に、アクティブ スーパバイザ エンジンからスタンバイ スーパバイザ エンジンに強制的に切り替えたときの、アクティブ スーパバイザ エンジンのコンソール出力例を示します。

Console> (enable) reset 1
This command will force a switch-over to the standby Supervisor module.
Do you want to continue (y/n) [n]? y
Console> (enable) 12/07/1998,17:04:39:SYS-5:Module 1 reset from Console//
 
System Bootstrap, Version 3.1(2)
Copyright (c) 1994-1997 by cisco Systems, Inc.
 
System Bootstrap, Version 3.1(2)
Copyright (c) 1994-1997 by cisco Systems, Inc.
Presto processor with 32768 Kbytes of main memory
 
Autoboot executing command: "boot bootflash:cat6000-sup.5-4-1a.bin"
CCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCC
Uncompressing file: ###########################################################
 
System Power On Diagnostics
NVRAM Size .. .................512KB
ID Prom Test ..................Passed
DPRAM Size ....................16KB
DPRAM Data 0x55 Test ..........Passed
DPRAM Data 0xaa Test ..........Passed
DPRAM Address Test ............Passed
Clearing DPRAM ................Done
System DRAM Memory Size .......32MB
DRAM Data 0x55 Test ...........Passed
DRAM Data 0xaa Test ...........Passed
DRAM Address Test ............Passed
Clearing DRAM .................Done
EARLII ........................Present
EARLII RAM Test ...............Passed
EARL Serial Prom Test .........Passed
Level2 Cache ..................Present
Level2 Cache test..............Passed
 
Boot image: bootflash:cat6000-sup.5-4-1a.bin
Downloading epld sram device please wait ...
Programming successful for Altera 10K50 SRAM EPLD
This module is now in standby mode.
Console is disabled for standby supervisor
 

次に、アクティブ スーパバイザ エンジンからスタンバイ スーパバイザ エンジンに強制的に切り替えたときの、スタンバイ スーパバイザ エンジンのコンソール出力例を示します。

Cisco Systems Console
 
Enter password:
12/07/1998,17:04:43:MLS-5:Multilayer switching is enabled
12/07/1998,17:04:43:MLS-5:Netflow Data Export disabled
12/07/1998,17:04:44:SYS-5:Module 2 is online
12/07/1998,17:04:45:SYS-5:Module 5 is online
12/07/1998,17:04:45:SYS-5:Module 7 is online
12/07/1998,17:04:45:SYS-5:Module 3 is online
12/07/1998,17:04:52:MLS-5:Route Processor 172.20.52.6 added
12/07/1998,17:05:10:SYS-5:Module 8 is online
12/07/1998,17:05:14:SYS-5:Module 9 is online
12/07/1998,17:05:22:SYS-5:Module 4 is online
12/07/1998,17:06:13:SYS-5:Module 1 is in standby mode
Supervisor image synchronization process will start in 10 seconds
12/07/1998,17:06:37:SYS-5:Ports on standby supervisor(Module 1) are UP
12/07/1998,17:06:41:SYS-5:Active supervisor is synchronizing the NMP image.
12/07/1998,17:06:44:SYS-5:The active supervisor has synchronized the NMP image.
 
Console>

ハイ アベイラビリティ機能

ハイ アベイラビリティ機能により、アクティブ スーパバイザ エンジンの故障時にアクティブ スーパバイザ エンジンからスタンバイ スーパバイザ エンジンへの切り替え時間を最小限に抑えることができます。

ハイ アベイラビリティ機能がリリースされる以前は、高速スイッチオーバーによってスタンバイ スーパバイザ エンジンへの切り替えが速やかに行われていました。ただし、高速スイッチオーバーでは、スイッチオーバー以前のスイッチ機能のステートが不明なため、スタンバイ スーパバイザエンジンをアクティブにする際にすべてのスイッチ機能を再度初期化し、スイッチを再起動する必要がありました。

ハイ アベイラビリティ機能では、このような制約がなくなっています。アクティブ スーパバイザ エンジンがスタンバイ スーパバイザ エンジンと通信し、機能のプロトコル ステートの同期化を保つためです。スーパバイザ エンジン間の同期化により、障害時にスタンバイ スーパバイザ エンジンが速やかに機能を引き継ぎます。

さらに、ハイ アベイラビリティ機能では、アクティブおよびスタンバイ スーパバイザ エンジン上で異なるソフトウェア イメージを実行できる バージョニング オプションも提供されています。

次に、これらの機能について説明します。

「ハイ アベイラビリティの概要」

「ハイ アベイラビリティでサポートされる機能」

「ハイ アベイラビリティ設定時の注意事項」

「バージョニングの概要」

「CLIコマンド」

「スタンバイ スーパバイザ エンジンへの異なる(ただし互換性のある)イメージのロード」

ハイ アベイラビリティの概要

ハイ アベイラビリティを可能にするために、アクティブ スーパバイザ エンジン上でシステム データベースが保守され、そのデータベース内のデータに変更があると、スタンバイ スーパバイザ エンジンに最新情報が送られます。アクティブ スーパバイザ エンジンは、何らかのステートの変更が発生すると、スタンバイ スーパバイザ エンジンと通信して情報を更新し、サポートされる機能の現在のプロトコル ステートをスタンバイ スーパバイザ エンジンが認識できるようにします。スタンバイ スーパバイザ エンジンは、すべてのモジュール、ポート、およびVLAN(仮想LAN)について現在のプロトコル ステートを認識しています。このステート情報を使用して各プロトコルが初期化され、ただちに動作を開始できます。

アクティブ スーパバイザ エンジンは、システム バス(バックプレーン)を制御し、ネットワークとの間でパケットを送受信し、すべてのモジュールを制御します。プロトコルはアクティブ スーパバイザ エンジン上でだけ動作します。

スタンバイ スーパバイザ エンジンはシステム バスから切り離されていて、パケットのスイッチングは行いません。ただし、スイッチング バスからパケットを受信して、レイヤ2スイッチド フローのために学習し、レイヤ2転送テーブルに入力します。さらにスタンバイ スーパバイザ エンジンは、スイッチング バスからパケットを受信して、レイヤ3スイッチド フローのために学習し、テーブルに入力します。スタンバイ スーパバイザ エンジンは、パケットの転送にはまったく参加せず、どのモジュールとも通信しません。

スタンバイ スーパバイザ エンジンの稼働時にハイ アベイラビリティをイネーブルに設定すると、イメージのバージョン互換性がチェックされます。互換性がある場合、データベースの同期化が開始されます。ハイ アベイラビリティ互換の各機能は、切り替え後、スタンバイ スーパバイザ エンジンに保存されていたステートから処理を続行します。

ハイ アベイラビリティをディセーブルにすると、データベースの同期化は実行されず、切り替え後はスタンバイ スーパバイザ エンジン上ですべての機能を再起動しなければなりません。

ハイ アベイラビリティをイネーブルからディセーブルに変更すると、アクティブ スーパバイザ エンジンからの同期化は停止され、スタンバイ スーパバイザ エンジンはその時点での同期データをすべて廃棄します。

ハイ アベイラビリティをディセーブルからイネーブルに変更すると、(スタンバイ スーパバイザ エンジンが存在し、しかもそのイメージ バージョンが互換である場合)アクティブからスタンバイ スーパバイザ エンジンへの同期化が開始されます。

NVRAMの同期化は、(2つのスーパバイザ エンジンのNVRAMバージョンが互換である場合)ハイ アベイラビリティがイネーブルとディセーブルのどちらであっても行われます。

スタンバイ スーパバイザ エンジンがシステム ブート時に搭載されていなかった場合、アクティブ スーパバイザ エンジンはこの状況を検知し、同期化のためのデータベースの最新情報をキューに入れません。同様に、スタンバイ スーパバイザ エンジンをリセットまたは取り外した場合、同期化のための最新情報はキューに入れられず、同期化キュー内の未処理の更新データは廃棄されます。スタンバイ スーパバイザ エンジンになる2番めのスーパバイザ エンジンをオンラインの状態で挿入するか再起動すると、アクティブ スーパバイザ エンジンはシステム データベース全体をスタンバイ スーパバイザ エンジンにダウンロードします。これで初めてグローバルな同期化が成立し、アクティブ スーパバイザ エンジンは個々の最新情報をキューに入れ、スタンバイ スーパバイザ エンジンとの同期化を図るようになります。


) 2番めのスーパバイザ エンジンをオンラインの状態で挿入するか再起動した場合、グローバルな同期が成立するまでに数分かかることがあります。


ハイ アベイラビリティでサポートされる機能

Catalyst 6500シリーズ スイッチのハイ アベイラビリティ機能は、次の3つのカテゴリに分類されます( 表22-1 を参照)。

サポートされる機能 ― ハイ アベイラビリティが完全にサポートされています。この機能のデータベースは、アクティブ スーパバイザ エンジンからスタンバイ スーパバイザ エンジンに同期化されます。

互換機能 ― ハイ アベイラビリティがサポートされていません。この機能のデータベースは、アクティブ スーパバイザ エンジンからスタンバイ スーパバイザ エンジンに同期化されません。ただし、ハイ アベイラビリティをイネーブルにすると、互換機能をイネーブルにできます。

非互換機能 ― ハイ アベイラビリティがサポートされていません。この機能のデータベースは、アクティブ スーパバイザ エンジンからスタンバイ スーパバイザ エンジンに同期化されません。ハイ アベイラビリティをイネーブルにしても、非互換機能をイネーブルにできません。また、この非互換機能をイネーブルにすると、ハイ アベイラビリティをイネーブルにできません。

 

表22-1 ハイ アベイラビリティ機能のサポート

サポートされる機能
互換機能
非互換機能

CEF

ASLB

ダイナミックVLAN

COPS-DS

CDP

GVRP

COPS-PR

GMRP

プロトコル フィルタリング

DTP

IGMPスヌーピング

EtherChannel

RMON

Cisco IOS ACL

RSVP

MLS

SNMP

PAgP

Telnetセッション

QoS

UplinkFast

SPAN

VTPプルーニング

STP

トランキング

UDLD

VACL

VTP

ポート セキュリティ

 

802.1x

ハイ アベイラビリティ設定時の注意事項

ここでは、ハイ アベイラビリティ設定時の注意事項について説明します。

Cisco IOSソフトウェアではハイ アベイラビリティは実行されないので、アクティブMSFCのルーティング テーブル エントリは維持されません。ただし、アクティブおよびスタンバイの両方のスーパバイザ エンジン上でMSFCを同じコンフィギュレーションに設定し、アクティブMSFCとスタンバイMSFCの間でルーティング テーブル エントリを維持することはできます。MSFC上にHot Standby Router Protocol(HSRP)を設定すると、ルーティングが自動的にバックアップされます。詳細については、「MSFC冗長機能」を参照してください。

タイマーおよび統計情報は、アクティブ スーパバイザ エンジンからスタンバイ スーパバイザ エンジンに同期化されません。

MLS(マルチレイヤ スイッチング)フローは、アクティブ スーパバイザ エンジンからスタンバイ スーパバイザ エンジンへ維持されます。

802.1xポートでは、許可および未許可のステートだけがアクティブ スーパバイザ エンジンからスタンバイ スーパバイザ エンジンに同期化されます。その他のステートにあるポートは、スイッチオーバー発生後初期化されるか、再起動されます。

802.1xレコードの更新は、同様なタイプの更新を1つのレコードにまとめることによって最小化されています。レコードの変数が変更されると、アクティブ スーパバイザ エンジンは、スタンバイ スーパバイザ エンジンにレコードを送ります。

許可済みポートの802.1x再認証タイマーは、スイッチオーバー発生後に再始動します。

ポート セキュリティ統計情報は、アクティブ スーパバイザ エンジンからスタンバイ スーパバイザ エンジンに同期化されません。

ハイ アベイラビリティをイネーブルにするか、セキュア ポートを備えたスイッチ上でスタンバイ スーパバイザ エンジンをオンラインの状態で取り付けると、ポート単位およびMAC(メディア アクセス制御)関連情報はすべてアクティブ スーパバイザ エンジンからスタンバイ スーパバイザ エンジンに同期化されます。

バージョニングの概要

ハイ アベイラビリティのバージョニング機能をイネーブルに設定した場合、アクティブ スーパバイザ エンジンおよびスタンバイ スーパバイザ エンジン上に、異なるが互換性のある2つのイメージを保持することができます。アクティブ スーパバイザ エンジンはスタンバイ スーパバイザ エンジンとイメージのバージョン情報を交換し、イメージの互換性によってハイ アベイラビリティ機能がイネーブルになるかを判別します。アクティブおよびスタンバイ スーパバイザ エンジンの実行するイメージ バージョンに互換性がない場合、ハイ アベイラビリティをイネーブルにすることはできません。

イメージ バージョニングは、Release 5.4(1)以降のスーパバイザ エンジン ソフトウェア リリースでサポートされています。バージョニングをイネーブルに設定した場合、アクティブ スーパバイザ エンジンとスタンバイ スーパバイザ エンジンが異なるイメージを実行していても、それらのイメージに互換性があれば、ハイ アベイラビリティは完全にサポートされます。完全に互換性のあるイメージは、次に示すものだけです。

Supervisor Engine 1

5.5(3)と5.5(4)

6.1(3)と6.1(4)

6.2(2)と6.2(3)

6.3(2)と6.3(3)

6.3(4)と6.3(5)

6.3(6)と6.3(7)

Supervisor Engine 2

6.1(3)と6.1(4)

6.2(2)と6.2(3)

6.3(2)と6.3(3)

Supervisor Engine 720では、アクティブおよびスタンバイ スーパバイザ エンジン上で、Release 8.1(1)以降のソフトウェア リリースが稼働していなければなりません。

ギガビット イーサネット スイッチング モジュールを除くすべてのモジュールと互換性のあるイメージは、次のとおりです。

Supervisor Engine 1

5.4(3)と5.4(4)

5.5(3)と5.5(5)

5.5(4)と5.5(5)

ギガビット イーサネット スイッチング モジュールとは互換性があるが、10/100BASE-Tモジュールとは互換性のないイメージは、次のとおりです。

Supervisor Engine 1

5.5(6a)と5.5(7)

SFM/SFM2およびファブリック対応モジュールを除くすべてのモジュールと互換性のあるイメージは、次のとおりです。

Supervisor Engine 2

6.3(4)と6.3(5)

6.3(6)と6.3(7)

8.1(2)と8.1(3)


) 互換性のないバージョンのイメージを実行すると設定情報が失われます。



) 2つのスーパバイザ エンジンを搭載している場合、先に起動したスーパバイザ エンジンがアクティブ モジュールになり、2番めのスーパバイザ エンジンはスタンバイ モードになります。2つのスーパバイザ エンジンがシステムに搭載されている場合は、起動時にスロット1のスーパバイザ エンジンがアクティブになり、スロット2のスーパバイザ エンジンがスタンバイ モードになります。このとき、2つのスーパバイザ エンジンのソフトウェア バージョンが異なっているか、2つのスーパバイザ エンジンのNVRAM設定が異なっており、しかもバージョニングがイネーブルに設定されていない場合には、アクティブ スーパバイザ エンジンのソフトウェア イメージおよび設定がスタンバイ スーパバイザ エンジンに自動的にダウンロードされます。


CLIコマンド

ここでは、ハイ アベイラビリティおよびバージョニングに関連するCLIコマンドについて説明します。

ハイ アベイラビリティのイネーブル化またはディセーブル化

デフォルトでは、ハイ アベイラビリティはディセーブルに設定されています。ハイ アベイラビリティをイネーブルまたはディセーブルにするには、イネーブル モードで次の作業を行います。

 

作業
コマンド

ハイ アベイラビリティをイネーブルまたはディセーブルにします。

set system highavailability { enable | disable }

次に、ハイ アベイラビリティをイネーブルにする例を示します。

Console> (enable) set system highavailability enable
System high availability enabled.
Console> (enable)
 

次に、ハイ アベイラビリティをディセーブルにする例を示します。

Console> (enable) set system highavailability disable
System high availability disabled.
Console> (enable)
 

ハイ アベイラビリティ バージョニングのイネーブル化またはディセーブル化

デフォルトでは、ハイ アベイラビリティ バージョニングはディセーブルに設定されています。ハイ アベイラビリティ バージョニングをイネーブルまたはディセーブルにするには、イネーブル モードで次の作業を行います。

 

作業
コマンド

ハイ アベイラビリティ バージョニングをイネーブルまたはディセーブルにします。

set system highavailability versioning { enable | disable }

次に、ハイ アベイラビリティ バージョニングをイネーブルにする例を示します。

Console> (enable) set system highavailability versioning enable
Image versioning enabled.
Console> (enable)
 

次に、ハイ アベイラビリティ バージョニングをディセーブルにする例を示します。

Console> (enable) set system highavailability versioning disable
Image versioning disabled.
Console> (enable)
 

ハイ アベイラビリティの設定および稼働ステータスの表示

show system highavailability コマンドを実行すると、次の情報が表示されます。

ハイ アベイラビリティの設定(イネーブルまたはディセーブル)

バージョニングの設定(イネーブルまたはディセーブル)

ハイ アベイラビリティの稼働ステータス(スタンバイ スーパバイザ エンジンが搭載されて稼働しているかどうかに基づく)。稼働ステータス フィールドには、次のいずれかが表示されます。

OFF(high-availability-not-enabled):NVRAMのハイ アベイラビリティ オプションがディセーブルに設定されています。

OFF(standby-supervisor-not-present):スタンバイ スーパバイザ エンジンが搭載されていません。

OFF(standby-supervisor-image-incompatible):スタンバイ スーパバイザ エンジンがアクティブ スーパバイザ エンジンとは異なるイメージを実行しており、しかもイメージがバージョン互換ではありません(NVRAMのバージョニング オプションはイネーブルに設定されています)。同期化は一切行われません(アクティブ スーパバイザ エンジン上のNVRAMで設定が変更されても、バージョン間に互換性がないので、スタンバイ スーパバイザ エンジン には伝播されません)。

OFF(standby-supervisor-image-nvram-only-compat):スタンバイ スーパバイザ エンジンがアクティブ スーパバイザ エンジンとは異なるイメージを実行しており(NVRAMのバージョニング オプションはイネーブルに設定されています)、そのイメージはNVRAM互換性があるだけです(したがって、アクティブ スーパバイザ エンジン上のNVRAMで設定が変更されると、スタンバイ スーパバイザ エンジン に伝播されます)。ただし、ハイ アベイラビリティはサポートできません。

OFF(standby-supervisor-not-operational-yet):スタンバイ スーパバイザ エンジンが検出されましたが稼働していません(まだオンラインではありません)。

OFF(high-availability-not-operational-yet):スタンバイ スーパバイザ エンジンは稼働しています(オンラインです)が、ハイ アベイラビリティはまだ稼働していません(システムがリセット後に起動したとき、ハイ アベイラビリティが稼働するまでに数分かかります)。

ON:ハイ アベイラビリティが稼働しています。アクティブ スーパバイザ エンジンの各機能は、スタンバイ スーパバイザ エンジンとの同期をとるため、ステータス変更のキューイングを開始しました。

ハイ アベイラビリティの設定および稼働ステートを表示するには、次の作業を行います。

 

作業
コマンド

ハイ アベイラビリティの設定および稼働ステートを表示します。

show system highavailability

次に、ハイ アベイラビリティの設定および稼働ステートを表示する例を示します。

Console> (enable) show system highavailability
Highavailability: disabled
Highavailability versioning: disabled
Highavailability Operational-status: OFF (high-availability-not-enabled)
Console> (enable)
 

次に、ハイ アベイラビリティをイネーブルにする例を示します。

Console> (enable) set system highavailability enable
System high availability enabled.
Console> (enable)
 
Console> (enable) show system highavailability
Highavailability: enabled
Highavailability versioning: disabled
Highavailability Operational-status: ON
Console> (enable)

スタンバイ スーパバイザ エンジンへの異なる(ただし互換性のある)イメージのロード

スタンバイ スーパバイザ エンジンに、アクティブ スーパバイザ エンジン上のイメージとは異なる新しいイメージをロードする手順は、次のとおりです。アクティブ スーパバイザ エンジンのコンソール ポートから、次の作業を実行します(アクティブ スーパバイザ エンジンはスロット1に搭載されています)。


ステップ 1 ハイ アベイラビリティをイネーブルにします。

Console> (enable) set system highavailability enable
System high availability enabled.
Console> (enable)
 

ステップ 2 アクティブ スーパバイザ エンジンのブートフラッシュに、新しいイメージをダウンロードします。

Console> (enable) copy tftp:image2.bin bootflash
IP address or name of remote host []? 172.20.52.3
 
8763532 bytes available on device bootflash, proceed (y/n) [n]? y
.
.
.
Console> (enable)
 

ステップ 3 スタンバイ スーパバイザ エンジンのブートフラッシュに、新しいイメージをコピーします。

Console> (enable) copy bootflash:image2.bin 2/bootflash:
 
5786532 bytes available on device bootflash, proceed (y/n) [n]? y
.
.
.
Console> (enable)
 

ステップ 4 スタンバイ スーパバイザ エンジンが新しいイメージを起動するように、BOOT環境変数を変更します。

Console> (enable) set boot system flash bootflash:image2.bin prepend 2
BOOT variable = bootflash:image2.bin,1;slot0:image1.bin,1
Console> (enable)
 

ステップ 5 スタンバイ スーパバイザ エンジンをリセットして、新しいイメージを起動します。

Console> (enable) reset 2
This command will reset the system.
Do you want to continue (y/n) [n]? y
.
.
.
Console> (enable)
 


 

NSFおよびSSOを使用したスーパバイザ エンジンの冗長構成

Cisco NSFはSSOと連携することにより、スイッチオーバー後にユーザがネットワークを使用できなくなる期間を最小にしながら、IPパケットの転送を継続します。

NSFにSSOを設定する手順については、次のURLにある『Catalyst 6500 Series Cisco IOS Software Configuration Guide, 12.2SX』の「Configuring Supervisor Engine Redundancy using NSF with SSO」を参照してください。
http://www.cisco.com/univercd/cc/td/doc/product/lan/cat6000/122sx/swcg/nsfsso.htm

スーパバイザ エンジンの同期化の例

ここでは、同期機能が特定の条件を検出した場合の現象について説明します。

「ランタイム イメージとブートストリングの同期化」

「アクティブおよびスタンバイ スーパバイザ エンジンのブート イメージの同期化」


) ここで示す一連の例で、ブートストリングの中のファイル名の後ろの1という数字(たとえばbootflash:f1,1)は、Trivial File Transfer Protocol(TFTP;簡易ファイル転送プロトコル)起動の試行回数を表します。ただし、スーパバイザ エンジンではTFTPによる起動はサポートされていません。Cisco IOSの表記との一貫性のため、この数字を含めています。



) ここで紹介する例は、考えられるすべての事例を含んでいるわけではありません。


ランタイム イメージとブートストリングの同期化

ここでは、アクティブ スーパバイザ エンジンのランタイム イメージとスタンバイ スーパバイザ エンジンとの同期化について、4つの例を紹介します。

例1:ランタイム イメージの同期化が行われない場合

例1の設定は、次のとおりです。

アクティブ スーパバイザ エンジンの設定は、次のとおりです(スタンバイ スーパバイザ エンジンのイメージがアクティブ スーパバイザ エンジンのイメージと同じである場合、出力は同じになります)。

ランタイム イメージ: bootflash:f1

ブートストリング: bootflash:f1,1

ブートフラッシュ: f1

アクティブ スーパバイザ エンジン上の f1 のタイムスタンプは、スタンバイ スーパバイザ エンジン上の f1 と同じです。

予測される結果は、次のとおりです。

アクティブ スーパバイザ エンジンの f1 イメージは、スタンバイ スーパバイザ エンジンにコピーされません。

スタンバイ スーパバイザ エンジンのブートストリングは変更されません。

スタンバイ スーパバイザ エンジンはリセットされません。

例2:ファイルのコピー、ブートストリングの変更、スタンバイ スーパバイザ エンジンのリセットが行われる場合

例2の設定は、次のとおりです。

アクティブ スーパバイザ エンジンの設定は、次のとおりです。

ランタイム イメージ: bootflash:f1

ブートストリング: bootflash:f1,1

ブートフラッシュ: f1

スタンバイ スーパバイザ エンジンの設定は、次のとおりです。

ランタイム イメージ: bootflash:f2

ブートストリング: bootflash:f2,1

ブートフラッシュ: f2

アクティブ スーパバイザ エンジン上の f1 のタイムスタンプは、スタンバイ スーパバイザ エンジン上の f2 と同じではありません。

予測される結果は、次のとおりです。

アクティブ スーパバイザ エンジンが f1 イメージをスタンバイ スーパバイザ エンジンにコピーし、ファイル名を RTSYNC_f1 に変更します。

スタンバイ スーパバイザ エンジンのブートフラッシュが次のように変更されます。
f2, RTSYNC_f1

スタンバイ スーパバイザ エンジンのブートストリングが次のように変更されます。 bootflash:RTSYNC_f1,1;f2,1;

スタンバイ スーパバイザ エンジンがリセットされます。

例3:ファイルがコピーされず、ブートストリングが変更され、スタンバイ スーパバイザ エンジンがリセットされる場合

例3の設定は、次のとおりです。

アクティブ スーパバイザ エンジンの設定は、次のとおりです。

ランタイム イメージ: bootflash:f1

ブートストリング: bootflash:f1,1

ブートフラッシュ: f1

スタンバイ スーパバイザ エンジンの設定は、次のとおりです。

ランタイム イメージ: bootflash:f2

ブートストリング: bootflash:f2,1

ブートフラッシュ: f1,f2

アクティブ スーパバイザ エンジン上の f1 のタイムスタンプは、スタンバイ スーパバイザ エンジン上の f1 と同じですが、スタンバイ スーパバイザ エンジン上の f2 とは同じではありません。

予測される結果は、次のとおりです。

アクティブ スーパバイザ エンジンのランタイム イメージとスタンバイ スーパバイザ エンジンが同期化されます。

アクティブ スーパバイザ エンジンの f1 イメージは、スタンバイ スーパバイザ エンジンにコピーされません。

スタンバイ スーパバイザ エンジンのブートストリングが次のように変更されます。 f1,1;f2,1;

スタンバイ スーパバイザ エンジンがリセットされます。

例4:最も古いブートフラッシュ ファイルが削除され、ブートフラッシュのスクイーズが実行される場合

例4の設定は、次のとおりです。

アクティブ スーパバイザ エンジンの設定は、次のとおりです。

ランタイム イメージ: bootflash:f1

ブートストリング: bootflash:f1,1

ブートフラッシュ: f1

スタンバイ スーパバイザ エンジンの設定は、次のとおりです。

ランタイム イメージ: bootflash:f2

ブートストリング: bootflash:f2,1;

ブートフラッシュ: f2, f3, f4 (メモリの空きスペースは1 MB未満)

アクティブ スーパバイザ エンジン上の f1 のタイムスタンプは、スタンバイ スーパバイザ エンジン上の f2 と同じではありません。 f2 のタイムスタンプは f3 より古く、 f3 のタイムスタンプは f4 より古くなっています。

予測される結果は、次のとおりです。

アクティブ スーパバイザ エンジンのランタイム イメージとスタンバイ スーパバイザ エンジンが同期化されます。

アクティブ スーパバイザ エンジンは、スタンバイ スーパバイザ エンジンへ f1 イメージのコピーを試みます。

スタンバイ スーパバイザ エンジンのブートフラッシュがスペース不足なので、冗長同期化機能が最も古いファイルを見つけて削除し、ブートフラッシュのスクイーズを実行します。

アクティブ スーパバイザ エンジンが f1 イメージをスタンバイ スーパバイザ エンジンにコピーし、ファイル名を RTSYNC_f1 に変更します。

スタンバイ スーパバイザ エンジンのブートフラッシュが次のように変更されます。
f3, f4, RTSYNC_f1

スタンバイ スーパバイザ エンジンのブートストリングが次のように変更されます。 RTSYNC_f1,1;f2,1;

スタンバイ スーパバイザ エンジンがリセットされます。

アクティブおよびスタンバイ スーパバイザ エンジンのブート イメージの同期化

ここでは、アクティブおよびスタンバイ スーパバイザ エンジン上のブートストリングの同期化について、4つの例を紹介します。

例1:ブート イメージを割り当てられない場合

この例の設定は、次のとおりです。

アクティブ スーパバイザ エンジンの設定は、次のとおりです。

ランタイム イメージ: bootflash:f1

ブートストリング: bootflash:f1,1;

ブートフラッシュ: f1

スタンバイ スーパバイザ エンジンの設定は、次のとおりです。

ランタイム イメージ: bootflash:f1

ブートストリング: bootflash:f1,1;

ブートフラッシュ: f1

アクティブ スーパバイザ エンジン上の f1 のタイムスタンプは、スタンバイ スーパバイザ エンジン上の f1 と同じです。

システムはアクティブ スーパバイザ エンジンのブートストリングを次のように変更しようと試みます。 f2,1;

予測される結果は、次のとおりです。

アクティブ スーパバイザ エンジンは f2 を割り当てることができず、同期化が失敗します。

Syslogにエラーが記録されます。

アクティブ スーパバイザ エンジンの f1 イメージは、スタンバイ スーパバイザ エンジンにコピーされません。

スタンバイ スーパバイザ エンジンのブートストリングは変更されません。

スタンバイ スーパバイザ エンジンはリセットされません。

例2:ファイルがコピーされ、ブートフラッシュが変更され、スタンバイ スーパバイザ エンジンがリセットされない場合

この例の設定は、次のとおりです。

アクティブ スーパバイザ エンジンの設定は、次のとおりです。

ランタイム イメージ: bootflash:f1

ブートストリング: bootflash:f1,1;

ブートフラッシュ: f1,f2

スタンバイ スーパバイザ エンジンの設定は、次のとおりです。

ランタイム イメージ: bootflash:f1

ブートストリング: bootflash:f1,1;

ブートフラッシュ: f1

アクティブ スーパバイザ エンジン上の f1 のタイムスタンプは、スタンバイ スーパバイザ エンジン上の f1 と同じです。

アクティブ スーパバイザ エンジンのブートストリングを次のように変更します。 f2,1;

予測される結果は、次のとおりです。

アクティブ スーパバイザ エンジンが f2 イメージをスタンバイ スーパバイザ エンジンにコピーし、ファイル名を BTSYNC_f2 に変更します。

スタンバイ スーパバイザ エンジンのブートフラッシュが次のように変更されます。
f1, BTSYNC_f2

スタンバイ スーパバイザ エンジンのブートストリングが次のように変更されます。 bootflash:BTSYNC_f2,1;f1,1;

スタンバイ スーパバイザ エンジンはリセットされません。

例3:ファイルがコピーされず、ブートストリングが変更され、スタンバイ スーパバイザ エンジンがリセットされない場合

この例の設定は、次のとおりです。

アクティブ スーパバイザ エンジンの設定は、次のとおりです。

ランタイム イメージ: bootflash:f1

ブートストリング: bootflash:f1,1;

ブートフラッシュ: f1,f2

スタンバイ スーパバイザ エンジンの設定は、次のとおりです。

ランタイム イメージ: bootflash:f1

ブートストリング: bootflash:f1,1;

ブートフラッシュ: f1,f2

アクティブ スーパバイザ エンジン上の f1 のタイムスタンプは、スタンバイ スーパバイザ エンジン上の f1 と同じです。アクティブ スーパバイザ エンジン上の f2 のタイムスタンプは、スタンバイ スーパバイザ エンジン上の f2 と同じです。

アクティブ スーパバイザ エンジンのブートストリングが次のように変更されます。 f2,1; f1,1;

予測される結果は、次のとおりです。

アクティブ スーパバイザ エンジンの f1 イメージは、スタンバイ スーパバイザ エンジンにコピーされません。

スタンバイ スーパバイザ エンジンのブートストリングが次のように変更されます。 bootflash:f2,1;bootflash:f1,1;

スタンバイ スーパバイザ エンジンはリセットされません。

例4:ファイルのコピー、最も古いファイルの削除、ブートフラッシュのスクイーズ、ブートストリングの変更が行われ、スタンバイ スーパバイザ エンジンがリセットされない場合

この例の設定は、次のとおりです。

アクティブ スーパバイザ エンジンの設定は、次のとおりです。

ランタイム イメージ: bootflash:f1

ブートストリング: bootflash:f1,1;

ブートフラッシュ: f1,f2

スタンバイ スーパバイザ エンジンの設定は、次のとおりです。

ランタイム イメージ: bootflash:f1

ブートストリング: bootflash:f1,1;

ブートフラッシュ: f0,f1,f3 (メモリの空きスペースは1 MB未満)

アクティブ スーパバイザ エンジン上の f1 のタイムスタンプは、スタンバイ スーパバイザ エンジン上の f1 と同じです。 f0 のタイムスタンプは f1 より古く、 f1 のタイムスタンプは f3 より古くなっています。

アクティブ スーパバイザ エンジンのブートストリングが次のように変更されます。 bootflash:f2,1;bootflash:f1,1;

予測される結果は、次のとおりです。

アクティブ スーパバイザ エンジンは、スタンバイ スーパバイザ エンジンへ f2 イメージのコピーを試みます。

スタンバイ スーパバイザ エンジンのブートフラッシュがスペース不足なので、冗長同期化機能が最も古いファイル( f0 )を見つけて削除し、ブートフラッシュのスクイーズを実行します。

アクティブ スーパバイザ エンジンが f2 イメージをスタンバイ スーパバイザ エンジンにコピーし、ファイル名を BTSYNC_f2 に変更します。

スタンバイ スーパバイザ エンジンのブートフラッシュが次のように変更されます。
f1, f3, BTSYNC_f2

スタンバイ スーパバイザ エンジンのブートストリングが次のように変更されます。 bootflash:BTSYNC_f2,1;bootflash:f1,1;

MSFC冗長機能

ここでは、次の内容でMSFC冗長機能について説明します。

「デュアルMSFC冗長機能」

「SRMの冗長機能」

「手動モードMSFC冗長機能」


) Single Router Mode(SRM)の冗長機能は、Supervisor Engine 720およびSupervisor Engine 32でサポートされる唯一のMSFC冗長機能オプションです。


デュアルMSFC冗長機能


注意 両方のMSFCは同一設定にしておく必要があります。表22-2に、同一設定の要件、および単一スイッチ シャーシでのレイヤ3冗長機能の例外を示します。

MSFCが同一設定でない構成は、サポートされていません。

ここでは、MSFC冗長機能の設定手順について説明します。

「ハードウェアおよびソフトウェアの要件」

「単一シャーシによるレイヤ3冗長設定」

「ルーティング プロトコルのピア設定」

「ACLの設定」

「デュアルMSFC運用モデルの冗長機能および負荷分散」

「障害の例」

ハードウェアおよびソフトウェアの要件

レイヤ3の冗長機能を設定するには、少なくとも次のいずれかの構成が必要です。

2つの同一スーパバイザ エンジン ドータカードから構成される1つのシャーシ

PFCおよびMSFCまたはMSFC2搭載のSupervisor Engine 1(両方のスーパバイザ エンジンに同一タイプのMSFCを搭載することが必要)

PFC2およびMSFC2搭載のSupervisor Engine 2

それぞれスーパバイザ エンジンを搭載したシャーシ ― 各シャーシに少なくとも1つはスーパバイザ エンジンを搭載しておく必要があります。各スーパバイザ エンジンに、PFCおよびMSFCを取り付けておく必要があります。


) 各MSFCは、同じCisco IOSソフトウェア リリースを実行している必要があります。


単一シャーシによるレイヤ3冗長設定

単一のCatalyst 6500シリーズ シャーシに、それぞれMSFCを搭載した冗長スーパバイザ エンジンを取り付けることができます。MSFC上にHSRPを設定すると、ネットワークでIPホストに対するトランスペアレントなデフォルト ゲートウェイ冗長機能が実現します。HSRPコンフィギュレーションは、同じインターフェイス上でIPXおよびAppleTalkコンフィギュレーションと共存できます。

1つのMSFCで障害が起きると、HSRPにより、他方のMSFC(ルータ)が自動的に障害のあるMSFCの機能を受け継ぎます。Release 5.4(1)のスーパバイザ エンジン ソフトウェア リリースのハイ アベイラビリティ機能を併用すると、ネットワークの冗長レベルがさらに向上します。


注意 両方のMSFCは同一設定にしておく必要があります。表22-2に、同一設定の要件、および単一スイッチ シャーシでのレイヤ3冗長機能の例外を示します。

 

表22-2 単一シャーシのレイヤ3冗長機能の要件

同一設定の要件 ― グローバルおよびインターフェイス レベル
例外 ― インターフェイス レベル
例外 ― グローバル レベル

両方のMSFCに次の設定が 必要 です。

同じルーティング プロトコル

同じスタティック ルート

同じデフォルト ルート

同じポリシー ルート

同じVLANインターフェイス

同じCisco IOS ACL12

すべてのインターフェイスが同じ管理ステータスでなければ なりません

HSRPスタンバイ コマンド

IPアドレス コマンド3

IPXネットワーク3

IPデフォルト ゲートウェイ

IPXインターナル ネットワーク

IPXデフォルト ルート

1.実データ フローに基づくダイナミックACLおよび再帰ACLは、各MSFCで設定することができます。

2.両方のMSFCに同一のACLを定義するだけではなく、ACLを両方のMSFC上の同じVLANインターフェイスの同じ方向に適用する必要があります。

3.IPまたはIPXアドレスを両方のMSFC上で同じにする必要はありませんが、両方のMSFC上でIPまたはIPXアドレスを設定することが必要です。

表22-2 に示したインターフェイスおよびグローバル レベルの例外に関して、代替コンフィギュレーションを指定する方法については、「altキーワードの使用方法」を参照してください。

冗長スーパバイザ エンジンには、同一のハードウェア(MSFCおよびPFC)が搭載されている 必要 があります。詳細については、「ハードウェアおよびソフトウェアの要件」を参照してください。


) MSFCおよびMSFC2のメモリ要件については、次のURLの『Release Notes for MSFC』を参照してください。
http://www.cisco.com/univercd/cc/td/doc/product/lan/cat6000/relnotes/index.htm


ルーティング プロトコルのピア設定

冗長スーパバイザ エンジンおよびデュアルMSFC設定では、1つのスーパバイザ エンジンが完全に稼働している状態(アクティブ)で、もう1つのスーパバイザ エンジンがスタンバイ モードになります。ただし、(アクティブ スーパバイザ エンジン上のPFCをプログラミングするため)MSFCは両方とも稼働し、独立ルータとして運用されます。


PFC:PFCを使用すると、MLSエントリをどちらかのMSFCに対応付けられます(最初のパケットをどちらのMSFCがルーティングするかに基づきます)。アクティブ スーパバイザ エンジン上のPFCだけが、パケットをスイッチングします。



PFC2:PFC2では、メインMSFCのみが、アクティブ スーパバイザ エンジン上でForwarding Information Base(FIB;転送情報ベース)、隣接テーブル、Cisco IOSソフトウェア、およびポリシー ルーティングACLをプログラミングします。スタティック ルートまたはポリシー ルーティングを設定した場合は、両方のMSFCで同一の設定にする必要があります。メインMSFC上にない非メインMSFCにスタティック ルートがある場合は、そのルートはPFC2ではプログラミングされません


両方のMSFCは、ルーティング プロトコルのピア設定の観点から運用可能です。たとえば、単一のCatalyst 6500シリーズ スイッチ シャーシに2つのMSFCを搭載し、両方にVLAN 10およびVLAN 21のインターフェイスを設定した場合、2つのMSFCはこれらのVLAN上で相互にピアを形成します。デュアル シャーシおよびデュアルMSFCの構成で同じVLANを設定した場合には、各MSFCに6つのピア(VLAN10に3つ、VLAN21に3つ)が形成されます。同じシャーシ内のピアのほか、2つめのシャーシ内の2つのMSFCに対応するピアが形成されるためです(VLAN 10の3、VLAN 21の3)。図22-1を参照してください。

図22-1 デュアル シャーシおよびデュアルMSFCのピア設定

 

各MSFCは(ピア設定という観点では)独立ルータとして動作しますが、シャーシ上の2つのMSFCは同時に稼働し、同じインターフェイスを運用し、同じルーティング プロトコルを実行します。

スーパバイザ エンジンのハイ アベイラビリティ機能とMSFC上のHSRPを併用すると、次のレイヤ2およびレイヤ3の冗長機能が提供されます。

スーパバイザ エンジンのレイヤ2冗長機能(アクティブおよびスタンバイ) ― アクティブ スーパバイザ エンジン(および搭載されているMSFC)に障害が発生すると、レイヤ2およびレイヤ3の両方の機能がスタンバイ スーパバイザ エンジンと搭載MSFCに切り替わります。

2つのMSFCのレイヤ3冗長機能および負荷分散 ― 1つのMSFCに障害が発生すると、他方のMSFCが(HSRPにより)ただちに機能を受け継ぎます。レイヤ2の運用は妨げられません(アクティブ スーパバイザ エンジンはレイヤ2トラフィックの転送を続けます)。

アクティブ スーパバイザ エンジン上の障害のあるMSFCによってプログラミングされたレイヤ3エントリは、エージング アウトし、新しいアクティブMSFCにより移植されたレイヤ3エントリに置き換えられるまで、そのまま使用されます。エージングには4分かかるので、新しいアクティブMSFCは、ハードウェアのスイッチング フローを妨げずに、XTAG値を使用してMLSエントリを移植することができます。また、このプロセスは、新しいアクティブMSFCに初期トラフィック フローが大量に送り込まれるのを防ぎます。


) 各MSFCには、MLSルート プロセッサであることを示す独自のXTAG値が設定されています。MSFC #1(アクティブ スーパバイザ エンジン上)のXTAGは1、MSFC #2(スタンバイ スーパバイザ エンジン上)のXTAGは2です。

XTAG値を使用するのは、Supervisor Engine 1のみです。Supervisor Engine 2ではXTAG値が使用されません。



注意 同一シャーシ上のレイヤ3冗長機能を正常に動作させるには、両方のMSFCの設定が同じでなければなりません単一シャーシのレイヤ3冗長機能の要件を参照)。


表22-2に、設定の例外が示されています。たとえば、図22-1では、VLAN10上に4つのMSFCが関与しています。各MSFCに異なるIPアドレスおよびHSRPプライオリティが設定されています。


ACLの設定

MSFC上でCisco IOS Access Control List(ACL;アクセス制御リスト)を使用する場合には、グローバル レベルおよびインターフェイス レベルで、両方のMSFC上に同じACLを設定する 必要 があります。メインMSFC(最初にオンラインになるMSFC、またはオンライン時間が長いMSFC)だけが、ACL情報を備えたPFCをプログラミングします。

アクティブ スーパバイザ エンジン上のPFCのマルチレイヤ機能(CEF[Cisco Express Forwarding]for PFC2)は、ACL ASICを照会し、設定されているCisco IOS ACLに応じてパケットを転送するかどうか判別してから、パケットをスイッチングします。メインMSFCに障害が発生した場合、新たにメインとなったMSFCは、スタティックACL用のPFCを再プログラミングする必要があります。一貫した結果を得るには、両方のMSFCに、スタティックACLなど、同一のACLを設定する 必要があります


) 両方のMSFC上に同一のACLを定義するだけではなく、ACLを両方のMSFC上の同じVLANインターフェイスに適用する必要があります。



) 実データ フローに基づくダイナミックACLおよび再帰ACLは、各MSFCで設定することができます。



PFC:PFCでのハードウェアおよびソフトウェアによるCisco IOS ACLの処理の詳細については、「PFCでのハードウェアおよびソフトウェアによるCisco IOS ACLの処理」を参照してください。



PFC2:PFC2でのハードウェアおよびソフトウェアによるCisco IOS ACLの処理の詳細については、「PFC2およびPFC3A/PFC3B/PFC3BXLでのハードウェアおよびソフトウェアによるCisco IOS ACLの処理」を参照してください。


メインMSFCのステータスを判別するには、 show fm features コマンドまたは show redundancy コマンドを使用します。

Router-15# show redundancy
Designated Router: 1 Non-designated Router:2
Redundancy Status: non-designated
Config Sync AdminStatus : enabled
Config Sync RuntimeStatus: enabled
 
Router-16# show redundancy
Designated Router: 1 Non-designated Router:2
Redundancy Status: designated
Config Sync AdminStatus : enabled
Config sync RuntimeStatus: enabled

デュアルMSFC運用モデルの冗長機能および負荷分散

図22-2に、アクセス レイヤ スイッチの複数のVLANによる一般的なアクセスおよび分散レイヤ構築ブロックを示します。レイヤ2ループは設定されていないので、コンバージェンスおよび負荷分散にはHSRPが使用されます。スイッチS1およびスイッチS2には、スロット1(Sup #1/MSFC #1)およびスロット2(Sup #2/MSFC #2)にMSFC搭載スーパバイザ エンジンが取り付けられています。両スイッチとも、Sup #1がアクティブで、Sup #2はスタンバイ モードです。スーパバイザ エンジンのハイ アベイラビリティはイネーブルに設定されています。スーパバイザ エンジンのイメージおよび設定は自動的に同期化されますが、MSFC上のイメージおよび設定は手動で同期化する必要があります。

図22-2 デュアルMSFC運用モデルの冗長機能および負荷分散 ― VLAN10およびVLAN21

 

図22-2では、冗長機能および負荷分散を次のように設定します。

VLAN10(偶数番号のVLAN) ― スイッチS1のMSFC #1をプライマリHSRPルータ(プライオリティ110)として設定し、MSFC #2をスタンバイ ルータ(プライオリティ109)として設定します。

VLAN21(奇数番号のVLAN) ― スイッチS2のMSFC #1をプライマリHSRPルータ(プライオリティ110)として設定し、MSFC #2をスタンバイ ルータ(プライオリティ109)として設定します。

スイッチS1が偶数番号のVLANをルーティングし、スイッチS2が奇数番号のVLANをルーティングすることによって、負荷分散がサポートされます。一方のスイッチに障害が発生すると、他方のスイッチが奇数VLANと偶数VLANの両方のサービスを実行します。

スイッチS1のMSFC #2をVLAN 12のプライマリHSRPルータに、スイッチS2のMSFC #2をVLAN23のプライマリHSRPルータに設定すれば、より高度な負荷分散を達成できます(図22-3を参照)。

図22-3 デュアルMSFC運用モデルの冗長機能および負荷分散 ― VLAN10、12、21および23

 

VLANのアクティブHSRPルータだけが、HSRP IPアドレスのAddress Resolution Protocol(ARP)要求に対して、HSRP MACアドレスを戻します。アクティブHSRPルータは、エンド ステーションのMACアドレスに順番にARPを適用し、ARPキャッシュを伝播します。単一シャーシ上の両方のMSFCを使用して偶数VLANのHSRP処理を分散することによって、制御プレーンのARPトラフィックを分散できます。いずれかのMSFCに障害が発生した場合、再学習が必要になるのは、影響を受けたVLANのARPエントリだけです。

このレベルの冗長機能および負荷分散では、Catalyst 6500シリーズ スイッチ シャーシ上のMSFCの偶数および奇数VLANの追跡が複雑になるという欠点があります。

HSRP MACアドレスに到達したパケット、およびルータの実MACアドレスを持つパケットには、MLSエントリが作成されます。ユニキャスト トラフィックの最初のホップの冗長機能には、HSRPが使用されます。たとえば、VLAN10に接続している他のルータ経由で受信したトラフィックには、Sup #1/MSFC #1の実MACアドレスが使用されます。

障害の例

ここでは、デュアルMSFC搭載の2つのスーパバイザ エンジンを備えた単一シャーシ上で(図22-4を参照)ハイ アベイラビリティをイネーブルに設定した場合、発生する可能性のある5つの障害の例を示します。メインMSFCが、スタティックACLのACL ASICをプログラミングしています。


) この例はPFC特有のものですが、PFC2/MSFC2のフェールオーバーの例は、ACLおよびCEFテーブル エントリの処理に対するものと同じです。Supervisor Engine 2では、メインMSFC2は、CEFテーブルの作成などPFC2上で多数のASICをプログラミングします。非メインMSFC2に対するメインMSFC2 HSRPフェールオーバーでは、PFC2はこれまでのメインMSFC2によってプログラミングされたCEFテーブルで機能し続けます。Supervisor Engine 1/MSFCコンフィギュレーションでのMLSキャッシュによるプロセスと同様に、新しいメインMSFC2は固有のエントリでCEFテーブルを再度プログラミングし、古いエントリはエージング アウトします。


図22-4 デュアルMSFC搭載の2つのスーパバイザ エンジンを備えた単一シャーシ

 

障害ケース 1:メインMSFC #1の障害

メインMSFC #1に障害が起きると、次のシーケンスが実行されます。

1. MSFC #1のMLSエントリがSup #1レイヤ-3キャッシュでエージング アウトし、MSFC #2は独自のXTAG値を使用して、これらのMLSエントリを一時的に所有します。

2. MSFC #2のMLSエントリは影響を受けません。

3. MSFC #2は、MSFC #1によってプログラミングされたハードウェア上のすべてのダイナミックおよび再帰ACLを削除します。

4. MSFC #2が新しいメインMSFCとなり、Sup #1 ACL ASICのスタティックACLを再プログラミングします。

障害ケース 2:非メインMSFC #2の障害

非メインMSFC #2に障害が起きると、次のシーケンスが実行されます。

1. MSFC #2のMLSエントリがSup #1レイヤ3キャッシュでエージング アウトし、MSFC #1は独自のXTAG値を使用して、これらのMLSエントリを一時的に所有します。

2. MSFC #1のMLSエントリは影響を受けません。

3. MSFC #1は、MSFC #2によってプログラミングされたハードウェア上のすべてのダイナミックおよび再帰ACLを削除します。

4. MSFC #1は、そのままメインMSFCとして動作します。

障害ケース 3:アクティブSup #1の障害

アクティブ スーパバイザ エンジン(Sup #1)に障害が起きると、次のシーケンスが実行されます。

1. レイヤ3のステートは保持されているので、MSFC #1のMLSエントリはSup #2のレイヤ3キャッシュでエージング アウトし、MSFC #2 が独自のXTAG値を使用して、これらのMLSエントリを一時的に所有します。

2. スタンバイ スーパバイザ エンジンはレイヤ2ステートを保持するので、レイヤ2のコンバージェンスは発生しません。

3. MSFC #2は、MSFC #1によってプログラミングされたハードウェア上のすべてのダイナミックおよび再帰ACLを削除します。

4. MSFC #2が、Sup #2 ACL ASICのスタティックACLを再プログラミングします。MSFC #2が新しいメインMSFCになります。

障害ケース 4:スタンバイSup #2の障害

スタンバイ スーパバイザ エンジン(Sup #2)に障害が起きると、次のシーケンスが実行されます。

1. MSFC #2のMLSエントリがSup #1レイヤ3キャッシュでエージング アウトし、MSFC #1が独自のXTAG値を使用して、これらのMLSエントリを一時的に所有します。

2. MSFC #1のMLSエントリは影響を受けません。

3. MSFC #1は、MSFC #2によってプログラミングされたハードウェア上のすべてのダイナミックおよび再帰ACLを削除します。MSFC #1は、そのままメインMSFCとして動作します。

障害ケース 5:新しいスーパ バイザまたは障害のあったスーパバイザをオンラインに戻したとき

障害のあったスーパバイザ エンジン(Sup #2)をオンラインに戻すと、次のシーケンスが実行されます。

1. Sup #1は、引き続きアクティブ スーパバイザ エンジンとして動作します。

2. Sup #2は、イメージおよびコンフィギュレーションをSup #1と同期化します(ハイ アベイラビリティ バージョニングがイネーブルに設定されていない場合)。

3. (Sup #2上の)MSFC #2がアップになります。VLAN21のHSRP preemptが設定されている場合は、MSFC #2のHSRPがアクティブになります。MSFC #1のMLSエントリが削除され、MSFC #2経由で再学習されます。

4. MSFC #1は、引き続きスタティックACLのメインMSFCとして動作します。

HSRPを使用した冗長機能の設定

スーパバイザ エンジン ハイ アベイラビリティ機能は、冗長スーパバイザ エンジンの間でプロトコル ステートを維持しますが、冗長MSFCの間でフェールオーバー用にHSRPを設定する必要があります。HSRPを使用して、ユニキャスト トラフィックの最初のホップの冗長機能を実現します。MSFCのVLANインターフェイスについて、1つまたは複数のHSRPグループを設定することにより、ネットワークのルーティングを自動的にバックアップすることができます。HSRPグループの各VLANインターフェイスは、仮想IPアドレスおよびMACアドレスを共有します。HSRPアドレスをデフォルト ゲートウェイとして使用するようにエンド ステーションおよび他のデバイスを設定しておくと、1つのルータ インターフェイスに障害が起きても、これらの装置のサービスは中断されません。

HSRPプライオリティが最も高いインターフェイスが、そのHSRPグループのアクティブ インターフェイスになります。


PFC2:PFC2は、一意の番号を持つHSRPグループを16個までサポートしています。異なるVLAN上で同じHSRPグループ番号を使用できます。16を超えるHSRPグループを設定すると、この制限によりHSRPグループ番号としてVLAN番号を使用できなくなります。



PFC2:同じ番号のHSRPグループは、同じ仮想MACアドレスを使用しますが、このことにより、MSFCでブリッジを設定する場合にエラーが発生する可能性があります。

HSRP設定では、standby use-biaオプションを入力しないでください。standby use-biaオプションを入力すると、MLSエントリは作成されません。standby use-biaオプションを設定すると、HSRPアクティブ インターフェイスがアップまたはダウンになった場合、スタンバイVLANインターフェイスのルータCAM(連想メモリ)アドレスはありません。ルータCAMアドレスがなければショートカットは作成されません。この問題は、MSFC Cisco IOSのリリースとは無関係です(この問題については警告CSCdz17169を参照してください)。


MSFCのVLANインターフェイス上にHSRPを設定するには、インターフェイス コンフィギュレーション モードで次の作業を行います。

 

作業
コマンド

ステップ 1

HSRPをイネーブルにし、HSRP IPアドレスを指定します。 group_number を指定しない場合、group 0が使用されます。トラブルシューティングを容易にするため、グループ番号はVLAN番号と一致するように設定してください。

Router(config-if)# standby [ group_number ] ip [ ip_address ]

ステップ 2

HSRPインターフェイスのプライオリティを指定します。HSRPグループ内の少なくとも1つのインターフェイスに、高いプライオリティを設定します(デフォルトは100です)。プライオリティの最も高いインターフェイスが、そのHSRPグループのアクティブ インターフェイスになります。

Router(config-if)# standby [ group_number ] priority priority

ステップ 3

インターフェイスが現在のアクティブHSRPインターフェイスを先取(preempt)し、現在のアクティブ インターフェイスよりもプライオリティが高い場合、そのインターフェイスがアクティブになるように設定します。

Router(config-if)# standby [ group_number ] preempt [ delay delay ]

ステップ 4

(任意)インターフェイスのHSRP helloタイマーおよびholdtimeタイマーを設定します。デフォルト値は、3(hello)および10(holdtime)です。HSRPグループのすべてのインターフェイスで、同じタイマー値を使用する必要があります。

Router(config-if)# standby [ group_number ] timers hellotime holdtime

ステップ 5

(任意)インターフェイスのクリア テキストHSRP認証ストリングを指定します。HSRPグループのすべてのインターフェイスで、同じ認証ストリングを使用する必要があります。

Router(config-if)# standby [ group_number ] authentication string

次にHSRPグループ100に属するインターフェイスを設定する例を示します。

Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# interface vlan100
Router(config-if)# standby 100 ip 172.20.100.10
Router(config-if)# standby 100 priority 110
Router(config-if)# standby 100 preempt
Router(config-if)# standby 100 timers 5 15
Router(config-if)# standby 100 authentication Secret
Router(config-if)# ^Z
Router#

設定例

ここでは、冗長機能を実行する3つの設定例を紹介します。

「例1:スーパバイザ エンジンおよびMSFCを1つずつ搭載した2つのシャーシ」

「例2:スーパバイザ エンジンおよびMSFCを2つずつ装備した単一シャーシ」

「例3:スーパバイザ エンジンおよびMSFCを2つずつ装備したデュアル シャーシ」

これらの例では、メインMSFCはアクティブ スーパバイザ エンジンに搭載されています。メインMSFCのステータスを判別するには、 show fm features コマンドまたは show redundancy コマンドを使用します。次の例では、Router-16がメインMSFCです。

Router-15# show redundancy
Designated Router: 1 Non-designated Router:2
 
Redundancy Status: non-designated
Config Sync AdminStatus : enabled
Config Sync RuntimeStatus: enabled
 
Router-16# show redundancy
Designated Router: 1 Non-designated Router:2
 
Redundancy Status: designated
Config Sync AdminStatus : enabled
Config sync RuntimeStatus: enabled
 

例1:スーパバイザ エンジンおよびMSFCを1つずつ搭載した2つのシャーシ

図22-5では、スーパバイザ エンジン上にハイ アベイラビリティを設定することはできませんが、MSFC上にHSRPを設定することができます。

図22-5 1つのスーパバイザ エンジンと1つのMSFCが搭載された2つのシャーシ

 

次に、スイッチS1のMSFC上にHSRPを設定する例を示します。

Console> (enable) switch console 15
Trying Router-15...
Connected to Router-15.
Type ^C^C^C to switch back...
Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# interface vlan10
Router(config-if)# standby 10 ip 172.20.100.10
Router(config-if)# standby 10 priority 110
Router(config-if)# standby 10 preempt
Router(config-if)# standby 10 timers 5 15
Router(config-if)# standby 10 authentication Secret
Router(config-if)# interface vlan21
Router(config-if)# standby 21 ip 192.20.100.21
Router(config-if)# standby 21 priority 109
Router(config-if)# standby 21 preempt
Router(config-if)# standby 21 timers 5 15
Router(config-if)# standby 21 authentication Secret
Router(config-if)# ^Z
Router# ^C^C^C
 

次に、スイッチS2のMSFC上にHSRPを設定する例を示します。

Console> (enable) switch console 15
Trying Router-15...
Connected to Router-15.
Type ^C^C^C to switch back...
Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# interface vlan10
Router(config-if)# standby 10 ip 172.20.100.10
Router(config-if)# standby 10 priority 109
Router(config-if)# standby 10 preempt
Router(config-if)# standby 10 timers 5 15
Router(config-if)# standby 10 authentication Secret
Router(config-if)# interface vlan21
Router(config-if)# standby 21 ip 192.20.100.21
Router(config-if)# standby 21 priority 110
Router(config-if)# standby 21 preempt
Router(config-if)# standby 21 timers 5 15
Router(config-if)# standby 21 authentication Secret
Router(config-if)# ^Z
Router# ^C^C^C
 

例2:スーパバイザ エンジンおよびMSFCを2つずつ装備した単一シャーシ

図22-6では、スーパバイザ エンジン上にハイ アベイラビリティを設定し、MSFC上にHSRPを設定しています。

図22-6 冗長スーパバイザ エンジンおよびMSFCが搭載された単一シャーシ

 

次に、スイッチS1のMSFC上にHSRPを設定する例を示します。

Console> (enable) switch console 15
Trying Router-15...
Connected to Router-15.
Type ^C^C^C to switch back...
Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# interface vlan10
Router(config-if)# standby 10 ip 172.20.100.10
Router(config-if)# standby 10 priority 110
Router(config-if)# standby 10 preempt
Router(config-if)# standby 10 timers 5 15
Router(config-if)# standby 10 authentication Secret
Router(config-if)# interface vlan21
Router(config-if)# standby 21 ip 192.20.100.21
Router(config-if)# standby 21 priority 109
Router(config-if)# standby 21 preempt
Router(config-if)# standby 21 timers 5 15
Router(config-if)# standby 21 authentication Secret
Router(config-if)# ^Z
Router# ^C^C^C
 
Console> (enable) switch console 16
Trying Router-16...
Connected to Router-16.
Type ^C^C^C to switch back...
Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# interface vlan10
Router(config-if)# standby 10 ip 172.20.100.10
Router(config-if)# standby 10 priority 109
Router(config-if)# standby 10 preempt
Router(config-if)# standby 10 timers 5 15
Router(config-if)# standby 10 authentication Secret
Router(config-if)# interface vlan21
Router(config-if)# standby 21 ip 192.20.100.21
Router(config-if)# standby 21 priority 110
Router(config-if)# standby 21 preempt
Router(config-if)# standby 21 timers 5 15
Router(config-if)# standby 21 authentication Secret
Router(config-if)# ^Z
Router# ^C^C^C

例3:スーパバイザ エンジンおよびMSFCを2つずつ装備したデュアル シャーシ

図22-7の2つのCatalyst 6500シリーズ スイッチ(S1およびS2)は、それぞれスロット1(Sup #1/MSFC #1)とスロット2(Sup #2/MSFC #2)にMSFCおよびスーパバイザ エンジンが搭載されています。レイヤ-2ループは設定されていないので、コンバージェンスおよび負荷分散にはHSRPが使用されます。両スイッチとも、Sup #1がアクティブ スーパバイザ エンジンで、Sup #2はスタンバイ スーパバイザ エンジンです。

図22-7 デュアルMSFC運用モデルの冗長機能および負荷分散

 

次に、スイッチS1のMSFC上にHSRPを設定する例を示します。

Console> (enable) switch console 15
Trying Router-15...
Connected to Router-15.
Type ^C^C^C to switch back...
Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# interface vlan10
Router(config-if)# standby 10 ip 172.20.100.10
Router(config-if)# standby 10 priority 110
Router(config-if)# standby 10 preempt
Router(config-if)# standby 10 timers 5 15
Router(config-if)# standby 10 authentication Secret
Router(config-if)# interface vlan21
Router(config-if)# standby 21 ip 192.20.100.21
Router(config-if)# standby 21 priority 108
Router(config-if)# standby 21 preempt
Router(config-if)# standby 21 timers 5 15
Router(config-if)# standby 21 authentication Secret
Router(config-if)# ^Z
Router# ^C^C^C
 
Console> (enable) switch console 16
Trying Router-16...
Connected to Router-16.
Type ^C^C^C to switch back...
Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# interface vlan10
Router(config-if)# standby 10 ip 172.20.100.10
Router(config-if)# standby 10 priority 109
Router(config-if)# standby 10 preempt
Router(config-if)# standby 10 timers 5 15
Router(config-if)# standby 10 authentication Secret
Router(config-if)# interface vlan21
Router(config-if)# standby 21 ip 192.20.100.21
Router(config-if)# standby 21 priority 107
Router(config-if)# standby 21 preempt
Router(config-if)# standby 21 timers 5 15
Router(config-if)# standby 21 authentication Secret
Router(config-if)# ^Z
Router# ^C^C^C
 

次に、スイッチS2のMSFC上にHSRPを設定する例を示します。

Console> (enable) switch console 15
Trying Router-15...
Connected to Router-15.
Type ^C^C^C to switch back...
Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# interface vlan10
Router(config-if)# standby 10 ip 172.20.100.10
Router(config-if)# standby 10 priority 108
Router(config-if)# standby 10 preempt
Router(config-if)# standby 10 timers 5 15
Router(config-if)# standby 10 authentication Secret
Router(config-if)# interface vlan21
Router(config-if)# standby 21 ip 192.20.100.21
Router(config-if)# standby 21 priority 110
Router(config-if)# standby 21 preempt
Router(config-if)# standby 21 timers 5 15
Router(config-if)# standby 21 authentication Secret
Router(config-if)# ^Z
Router# ^C^C^C
 
Console> (enable) switch console 16
Trying Router-16...
Connected to Router-16.
Type ^C^C^C to switch back...
Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# interface vlan10
Router(config-if)# standby 10 ip 172.20.100.10
Router(config-if)# standby 10 priority 107
Router(config-if)# standby 10 preempt
Router(config-if)# standby 10 timers 5 15
Router(config-if)# standby 10 authentication Secret
Router(config-if)# interface vlan21
Router(config-if)# standby 21 ip 192.20.100.21
Router(config-if)# standby 21 priority 109
Router(config-if)# standby 21 preempt
Router(config-if)# standby 21 timers 5 15
Router(config-if)# standby 21 authentication Secret
Router(config-if)# ^Z
Router# ^C^C^C

MSFC設定同期化の概要

MSFCハイ アベイラビリティにより、メインMSFC(最初にオンラインになるMSFC、またはオンライン時間が最も長いMSFC)と、非メインMSFCとの間で、スタートアップ コンフィギュレーションおよび実行コンフィギュレーションを自動的に同期化することができます。ハイ アベイラビリティ冗長機能は、デフォルトではディセーブルです。


注意 設定同期化がサポートされているのは、IPおよびIPXコンフィギュレーションに対してだけです。同期化をイネーブルにする前に、両方のMSFCがすべてのプロトコルについて同じ設定を持つようにする必要があります。AppleTalk、DECnet、VINES、またはその他のルーティングを使用している場合は、両方のMSFCですべてのプロトコルについて同じ設定を持つように手動で設定する必要があります。

メインMSFCのステータスを判別するには、 show fm features コマンドまたは show redundancy コマンドを使用します。

Router-15# show redundancy
Designated Router: 1 Non-designated Router:2
 
Redundancy Status: non-designated
Config Sync AdminStatus : enabled
Config Sync RuntimeStatus: enabled
 
Router-16# show redundancy
Designated Router: 1 Non-designated Router:2
 
Redundancy Status: designated
Config Sync AdminStatus : enabled
Config sync RuntimeStatus: enabled
 

ハイ アベイラビリティ冗長機能は、スタートアップ コンフィギュレーションおよび実行コンフィギュレーションを同期化します。

ハイ アベイラビリティ冗長機能をイネーブルにすると、メインMSFC上で次のいずれかのコマンドを入力した場合、両方のMSFCのスタートアップ コンフィギュレーションが更新されます。

write mem

copy source startup-config

ハイ アベイラビリティ冗長機能をイネーブルにすると、メインMSFC上で実行したすべてのコンフィギュレーション コマンドが、非メインMSFCに送信されます。また、メインMSFC上で copy source running-config コマンドを入力すると、実行コンフィギュレーションの同期化が更新されます。

ここでは、MSFC設定同期化について説明します。

「設定同期化のステート」

「altキーワードの使用方法」

設定同期化のステート

設定同期化には、次の2つのステートがあります。

Config Sync AdminStatus ― ユーザが設定した機能が、ただちに反映されます。

Config Sync RuntimeStatus ― 次の場合に限り、イネーブルになります。

メインおよび非メインMSFCの両方で、Config Sync AdminStatusがイネーブルになっている場合

メインおよび非メインMSFCが互換イメージを実行している場合

Config Sync RuntimeStatusがイネーブルの場合には、次の状態になります。

非メインMSFCのCLIでは、コンフィギュレーション モードを使用できません。EXECモードは使用できます。

alt キーワードが使用でき、必要になります( alt キーワードの詳細については、altキーワードの使用方法を参照)。

実行コンフィギュレーションとスタートアップ コンフィギュレーションが同期化されます。

Config Sync RuntimeStatusがディセーブルの場合には、次の状態になります。

両方のMSFCのCLI上で、コンフィギュレーション モードを使用できます。

alt キーワードを使用できますが、使用は任意です。

実行コンフィギュレーションとスタートアップ コンフィギュレーションは同期化されません。

各種のコンフィギュレーションおよび運用例は、「ハイ アベイラビリティ冗長機能の設定例」を参照してください。

altキーワードの使用方法

Config Sync RuntimeStatusがイネーブルの場合、非メインMSFC上では、EXECモードだけは使用できますが、コンフィギュレーション モードは使用できません。両方のMSFCのコンフィギュレーションは、メインMSFCのコンソールまたはTelnetセッション経由で行います。

単一コンソールから両方のMSFCを設定するには、 alt キーワードを使用して、代替コンフィギュレーションを行うことを指定します。代替コンフィギュレーションを指定した場合、 alt キーワードの前に入力したコンフィギュレーションはスイッチのスロット1のスーパバイザ エンジン上のMSFCに適用され、 alt キーワードのあとに入力したコンフィギュレーションはスロット2のスーパバイザ エンジン上のMSFCに適用されます。


) Config Sync AdminStatusをイネーブルにするときは、altキーワードを入力する必要があります。


表22-3 に、 alt キーワードの含まれるインターフェイスおよびグローバル コンフィギュレーション コマンドを示します。

 

表22-3 altキーワードの含まれるインターフェイスおよびグローバル コンフィギュレーション コマンド

インターフェイス コンフィギュレーション コマンド
グローバル コンフィギュレーション コマンド

[ no ] standby [ group_number ] ip [ ip_address [ secondary ]] alt [ no ] standby [ group_number ] ip [ ip_address [ secondary ]]

[ no ] standby [ group_number ] priority priority [ preempt [ delay delay ]] alt [ no ] standby [ group_number ] priority priority [ preempt [ delay delay ]]

[ no ] ip address ip_address mask [ secondary ] alt [ no ] ip address ip_address mask [ secondary ]

[ no ] ipx network network [ encapsulation encapsulation_type [ secondary ]] [ alt [ no ] ipx network network [ encapsulation encapsulation_type [ secondary ]]]

[ no ] hostname hostname alt hostname hostname

[ no ] ip default-gateway ip_address alt [ no ] ip default-gateway ip_address

router bgp autonomous_system
bgp router-id ip_address [ alt ip_address ]

router ospf process_id
router-id ip_address [ alt ip_address ]

次に、 ip address コマンドでの alt キーワードの使用例を示します。

Router-1(config-if)# ip address 1.2.3.4 255.255.255.0 alt ip address 1.2.3.5 255.255.255.0

設定同期化のイネーブル化およびディセーブル化

ハイ アベイラビリティ冗長機能をイネーブルにするには、イネーブル モードで次の作業を行います。

 

作業
コマンド

ステップ 1

冗長機能をイネーブルにします。

redundancy

ステップ 2

ハイ アベイラビリティをイネーブルにします。

high-availability

ステップ 3

設定同期化をイネーブルまたはディセーブルにします。

[ no ] config-sync

次に、ハイ アベイラビリティ冗長機能および設定同期化をイネーブルにする例を示します(Router-15がメインMSFCです)。

Console>(enable) session 15
Trying Router-15...
Connected to Router-15.
Escape character is ’^]’.
 
Router-15> enable
Router-15# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router-15(config)# redundancy
Router-15(config-r)# high-availability
Router-15(config-r-ha)# config-sync
Router-15(config-r-ha)# end
 

) ハイ アベイラビリティ冗長機能をイネーブルにすると、非メインMSFC上のコンフィギュレーション モードはディセーブルになり、使用できるのはEXECモードだけになります。


次の例では、Router-16は非メインMSFCです。ハイ アベイラビリティ冗長機能および設定同期化がイネーブルに設定されています。

Console>(enable) session 16
Trying Router-16...
Connected to Router-16.
Escape character is ’^]’.
 
Router-16> enable
Router-16# configure terminal
Config mode is disabled on non-designated Router, please configure from designated Router

ハイ アベイラビリティ冗長機能の設定例

ここでは、ハイ アベイラビリティおよび設定同期化をイネーブルにする例を、いくつか紹介します。

「例1:両方のMSFC上で設定同期化をイネーブル化」

「例2:メインMSFC上で設定同期化をディセーブル化」

「例3:メインMSFCをアップにする場合」

「例4:非メインMSFCをアップにする場合」

「例5:メインMSFCがダウンした場合」

例1:両方のMSFC上で設定同期化をイネーブル化

両方のMSFCがアップになっていることが前提です。

両方のMSFCの設定同期化をイネーブルにすると、最初にすべてのインターフェイス上のIPアドレスがチェックされます。メインMSFCにIPアドレスが設定され、非メインMSFCに指定されていないと、代替IPアドレスが指定されていない最初のインターフェイスを示すメッセージが表示されます。

IPアドレスのチェックが終了すると、HSRPのアドレスがチェックされます。メインMSFCにHSRPアドレスが設定され、非メインMSFCに指定されていないと、代替HSRP(スタンバイ)アドレスが指定されていない最初のインターフェイスを示すメッセージが表示されます。

HSRPアドレスのチェックが終了すると、IPXネットワーク アドレスがチェックされます。

メインMSFCを最初に設定します。次の例は、VLAN1インターフェイスの代替コンフィギュレーションが設定されていないことを示しています。

Router-16# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router-16(config)# redundancy
Router-16(config-r)# high-availability
Router-16(config-r-ha)# config-sync
 
Alternate IP address missing for Vlan1
The alternate configuration is missing. The auto-config sync can not be enabled
 

) 代替IPコンフィギュレーションを指定する場合、altキーワードの前に入力したコンフィギュレーションはスイッチのスロット1のスーパバイザ エンジン上のMSFCに適用され、altキーワードのあとに入力したコンフィギュレーションはスロット2のスーパバイザ エンジン上のMSFCに適用されます。詳細については、「altキーワードの使用方法」を参照してください。


次に、VLAN1の代替コンフィギュレーションを指定する例を示します。

Router-16(config)# interface vlan 1
Router-16(config-if)# ip address 70.0.70.4 255.255.0.0 alt ip address 70.0.70.5 255.255.0.0
Router-16(config-if)# exit
 

次に、ハイ アベイラビリティ冗長機能を設定する例を示します。

Router-16(config)# redundancy
Router-16(config-r)# high-availability
Router-16(config-r-ha)# config-sync
Router-16(config-r-ha)# end
Router-16#
00:03:31: %SYS-5-CONFIG_I: Configured from console by console
 

非メインMSFCのConfig Sync AdminStatusがディセーブルになっているので、メインMSFCのConfig Sync RuntimeStatusはディセーブル モードのままです。メインMSFCに、次のメッセージが表示されます。

00:17:05: %RUNCFGSYNC-6-SYNCEVENT:
Non-Designated Router is now online
High-Availability Redundancy Feature is not enabled on the Non-Designated Router
 

次に、非メインMSFC上で設定同期化をイネーブルにする例を示します。

Router-151(config)# redundancy
Router-15(config-r)# high-availability
Router-15(config-r-ha)# config-sync
Router-15(config-r-ha)# end
Router-15#
00:03:31: %SYS-5-CONFIG_I: Configured from console by console
 

) ハイ アベイラビリティ冗長機能をイネーブルにすると、非メインMSFCのコンソールのコンフィギュレーション モードはディセーブルになり、使用できるのはEXECモードだけになります。


非メインMSFC上に、ハイ アベイラビリティ機能がイネーブルになり、コンフィギュレーション モードが自動的に終了することを示す、次のメッセージが表示されます。

00:18:57: %RUNCFGSYNC-6-SYNCEVENT:
The High-Availability Redundancy Feature is enabled
The config mode is no longer accessible
 
Router-15#
 
00:19:41: %RUNCFGSYNC-6-SYNCEVENT:
Non-Designated Router is now online
Running Configuration Synchronization will begin in 1 minute
 

非メインMSFCを安定させるため、1分間のタイマーがスタートします。タイマーが切れると、現在の実行コンフィギュレーションのスナップショットが非メインMSFCに送信されます。実行コンフィギュレーションが同期化される前に、次のメッセージが表示されます。

00:20:41: %RUNCFGSYNC-6-SYNCEVENT:
Syncing Running Configuration to the Non-Designated Router
 
00:20:41: %RUNCFGSYNC-6-SYNCEVENT:
Syncing Startup Configuration to the Non-Designated Router
 

以下の例は、メインMSFCと非メインMSFCが同期化され、同じ実行コンフィギュレーションが設定されていることを示しています。

<designated MSFC>
Router-16# show running-config
Building configuration...
 
Current configuration:
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router-15 alt hostname Router-16
!
boot bootldr bootflash:c6msfc-boot-mz.120-7.XE1
!
ip subnet-zero
!
ip cef
redundancy
high-availability
config-sync
cns event-service server
!
!
!
interface Vlan1
ip address 70.0.70.4 255.255.0.0 alt ip address 70.0.70.5 255.255.0.0
!
interface Vlan10
ip address 192.10.10.1 255.255.255.0 alt ip address 192.10.10.2 255.255.255.0
no ip redirects
shutdown
standby ip 192.20.20.1 alt standby ip 192.20.20.1
!
ip classless
ip route 223.255.254.0 255.255.255.0 70.0.100.0
no ip http server
!
!
!
line con 0
transport input none
line vty 0 4
login
transport input lat pad mop telnet rlogin udptn nasi
!
end
 
 
<nondesignated MSFC>
Router-15# show running-config
Building configuration...
 
Current configuration:
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router1 alt hostname Router2
!
boot bootldr bootflash:c6msfc-boot-mz.120-7.XE1
!
ip subnet-zero
!
ip cef
redundancy
high-availability
config-sync
cns event-service server
!
!
!
interface Vlan1
ip address 70.0.70.4 255.255.0.0 alt ip address 70.0.70.5 255.255.0.0
!
interface Vlan10
ip address 192.10.10.1 255.255.255.0 alt ip address 192.10.10.2 255.255.255.0
no ip redirects
shutdown
standby ip 192.20.20.1 alt standby ip 192.20.20.1
!
ip classless
ip route 223.255.254.0 255.255.255.0 70.0.100.0
no ip http server
!
!
!
line con 0
transport input none
line vty 0 4
login
transport input lat pad mop telnet rlogin udptn nasi
!
end
 

例2:メインMSFC上で設定同期化をディセーブル化

この例では、設定同期化がすでにイネーブルに設定されています。設定同期化をディセーブルにする例を示します。

Router-16# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router2(config)# redundancy
Router2(config-r)# high-availability
Router2(config-r-ha)# no config-sync
 

設定同期化をディセーブルにすると、非メインMSFC上に次のメッセージが表示されます。

00:13:00: %RUNCFGSYNC-6-SYNCEVENT:
The High-Availability Redundancy Feature is now disabled
The config mode is now accessible
 

メインおよび非メインMSFCの両方で、CLIのコンフィギュレーション モードを使用することができます。

例3:メインMSFCをアップにする場合

この例では、Config Sync AdminStatusがすでにイネーブルに設定されています。メインMSFCは代替コンフィギュレーションを検証し、非メインMSFCがアップになった時点で、コンフィギュレーションを同期化します。

非メインMSFCはまだアップになっていないので、Config Sync RuntimeStatusはディセーブルです。したがって、設定同期化は実行されません。非メインMSFCの情報については、「例4:非メインMSFCをアップにする場合」を参照してください。

次の例では、Router-16がメインMSFCです。Config Sync AdminStatusはイネーブル、Config Sync RuntimeStatusはディセーブルに設定されています。

Router-16# show redundancy
Designated Router: 1 Non-designated Router:0
 
Redundancy Status: designated
Config Sync AdminStatus : enabled
Config Sync RuntimeStatus: disabled
 

例4:非メインMSFCをアップにする場合

Config Sync AdminStatusがイネーブルの場合

この例では、非メインMSFCがメインMSFCに対して、非メインMSFCがアップになり、Config Sync AdminStatusがイネーブルになったことを通知しています。メインMSFCは非メインMSFCに、Config Sync RuntimeStatusをイネーブルにするように要求しています。非メインMSFCのConfig Sync RuntimeStatusがイネーブルになります。

非メインMSFCには、次のメッセージが表示されます。

00:00:07: %RUNCFGSYNC-6-SYNCEVENT:
The High-Availability Redundancy Feature is enabled
The config mode is no longer accessible
 
00:00:51: %RUNCFGSYNC-6-SYNCEVENT:
Non-Designated Router is now online
Running Configuration Synchronization will begin in 1 minute
 

非メインMSFCを安定させるため、1分間のタイマーがスタートします。タイマーが切れると、現在の実行コンフィギュレーションのスナップショットが非メインMSFCに送信されます。実行コンフィギュレーションが同期化される前に、次のメッセージが表示されます。

00:01:51: %RUNCFGSYNC-6-SYNCEVENT:
Syncing Running Configuration to the Non-Designated Router
 

Config Sync AdminStatusがディセーブルの場合

この例では、非メインMSFCがメインMSFCに対し、アップになったことを通知しています。非メインMSFCのConfig Sync AdminStatusはディセーブルなので、メインMSFCに、非メインMSFCのハイ アベイラビリティ冗長機能をイネーブルにする必要があることを示す次のメッセージが表示されます。

Router-16#
Non-Designated Router came up.
High-Availability Redundancy Feature is not enabled on the Non-Designated Router
 

次に、非メインMSFC上で、ハイ アベイラビリティ冗長機能をイネーブルにする例を示します。

Router-15# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router-15(config)# redundancy
Router-15(config-r)# high-availability
Router-15(config-r-ha)# config-sync
Router-15(config-r-ha)#
00:03:47: %SYS-5-CONFIG_I: Configured from console by console
00:03:47: %RUNCFGSYNC-6-SYNCEVENT:
The High-Availability Redundancy Feature is enabled
The config mode is no longer accessible
 
00:00:51: %RUNCFGSYNC-6-SYNCEVENT:
Non-Designated Router is now online
Running Configuration Synchronization will begin in 1 minute
 

非メインMSFCを安定させるため、1分間のタイマーがスタートします。タイマーが切れると、現在の実行コンフィギュレーションのスナップショットが非メインMSFCに送信されます。実行コンフィギュレーションが同期化される前に、次のメッセージが表示されます。

00:01:51: %RUNCFGSYNC-6-SYNCEVENT:
Syncing Running Configuration to the Non-Designated Router
 

次の例は、メインMSFCおよび非メインMSFC上のConfig Sync AdminStatusおよびConfig Sync RuntimeStatusがイネーブルに設定されていることを示しています。

Router-15# show redundancy
Designated Router: 1 Non-designated Router:2
 
Redundancy Status: non-designated
Config Sync AdminStatus : enabled
Config Sync RuntimeStatus: enabled
 
 
Router-16# show redundancy
Designated Router: 1 Non-designated Router:2
 
Redundancy Status: designated
Config Sync AdminStatus : enabled
Config sync RuntimeStatus: enabled
 

例5:メインMSFCがダウンした場合

この例では、非メインMSFCがメインMSFCに切り替わります。設定の同期化がディセーブルになり、CLIでのコンフィギュレーション モードが利用できるようになります。

元のメインMSFCを再びアップにすると、このMSFCは非メインMSFCになります。「例4:非メインMSFCをアップにする場合」を参照してください。

SRMの冗長機能

ここでは、SRM冗長機能の設定手順について説明します。

「ハードウェアおよびソフトウェアの要件」

「SRM冗長性設定時の注意事項」

「Supervisor Engine 720におけるSRM冗長機能の設定」

「Supervisor Engine 1またはSupervisor Engine 2におけるSRM冗長機能の設定」

「SRMをイネーブルに設定したイメージのアップグレード」

「SRMの終了」

SRM冗長機能は、両方のMSFC2が同時にアクティブな内部冗長(デュアル)MSFC2コンフィギュレーションに代わるものです。SRM冗長機能では、ネットワークから見えるのは常に指定ルータのみです。非指定ルータは完全に起動され、SRM開始時にイネーブルに自動設定される設定同期化に参加します。SRMでは、[alt]キーワード以後のコンフィギュレーションはすべて無視されます。したがって、非指定ルータの設定は指定ルータのものとまったく同じですが、そのインターフェイスは回線ダウン ステートのままでネットワークからは見えません。ルーティング プロトコルなどのプロセスは、非指定および指定ルータ上で作成されますが、非指定ルータのインターフェイスはすべて回線ダウン ステートにあります。このためネットワークからのアップデートの送受信は行いません。

指定ルータに障害が発生すると、非指定ルータは、非指定ルータから指定ルータにステートを変更し、そのインターフェイスのステートがリンク アップに変わります。新しい指定ルータは、既存のスーパバイザ エンジン スイッチ プロセッサ エントリを使用してレイヤ3トラフィックを転送しながら、ルーティング テーブルを構築します。スイッチ プロセッサは引き続き古いエントリを使用して、レイヤ3パケットを転送します。事前に定義された時間が経過したあと、新規の指定ルータは新しいレイヤ3スイッチング情報をスイッチ プロセッサにダウンロードします。


) Cisco IOS Release 12.1(11b)E以降のリリースでは、新しい指定ルータがスーパバイザ エンジンのスイッチ プロセッサに新しいレイヤ3スイッチング情報をダウンロードする前に待機する移行時間を指定できます。設定の詳細については、「新しいアクティブ指定ルータに対する移行時間の指定」を参照してください。


ハードウェアおよびソフトウェアの要件

SRM冗長機能を設定するには、次のハードウェアおよびソフトウェアが必要です。

2つの同一スーパバイザ エンジン ドータカードから構成される1つのシャーシ

PFC3B/PFC3BXLおよびMSFC2A搭載のSupervisor Engine 32

PFC3A/PFC3B/PFC3BXLおよびMSFC3搭載のSupervisor Engine 720

PFC2およびMSFC2搭載のSupervisor Engine 2

PFCおよびMSFCまたはMSFC2搭載のSupervisor Engine 1


) Cisco IOS Release 12.1(8a)E4は、Supervisor Engine 1およびMSFCを使用するSRM冗長構成の初期サポートを提供します。



マルチキャスト サポート:Release 7.1(1)より前のソフトウェア リリースでは、MSFCまたはMSFC2搭載のSupervisor Engine 1をSRM冗長構成で使用する場合、2番めのMSFCへのフェールオーバーがマルチキャストMLSに関してステートフルにならない点に注意してください。プライマリMSFCでエラーが発生すると、すべてのマルチキャストMLSエントリが削除され、新しくアクティブになったMSFCによって再作成されて再インストールされます。



マルチキャスト サポート:Release 7.1(1)以降のソフトウェア リリースでは、PFCおよびMSFC2搭載のSupervisor Engine 1およびPFC2およびMSFC2搭載のSupervisor Engine 2に関して、マルチキャスト トラフィックのSRM冗長性サポートが改善されています。マルチキャストに関する改善は、MSFC搭載のSupervisor Engine 1には当てはまりません。

SRM冗長機能をイネーブルにすると、コンバージェンス タイムが向上し、切り替え時のマルチキャスト トラフィックの停止が短縮されます。MSFC2は、切り替え時にマルチキャスト トラフィックで過負荷にならないように保護されます。スイッチは停止したMSFC2からのフローをキャッシュし、新しくアクティブになったMSFC2がルータを認識するまで、キャッシュのフローを使用してトラフィックを転送します。一度に少数のフローだけがMSFC2に与えられるので、あふれることはありません。


Release 6.3(1)以降のスーパバイザ エンジン ソフトウェア リリース(Supervisor Engine 720ではRelease 8.1(1)以降のスーパバイザ エンジン ソフトウェア リリース、Supervisor Engine 32ではRelease 8.4(1)以降のスーパバイザ エンジン ソフトウェア リリースが必要)

Cisco IOS Release12.1(8a)E2以降(Supervisor Engine 720 MSFC3では、Cisco IOS Release12.2(14)SX2以降が必要)

SRM冗長性設定時の注意事項

ここでは、SRM冗長性設定時の注意事項について説明します。

指定ルータおよび非指定ルータが同じCisco IOSイメージを実行している必要があります。

指定ルータおよび非指定ルータの両方のブートフラッシュに、Cisco IOSイメージが必要です。

非指定ルータは外部ネットワークに接続できません。

外部ネットワークから指定ルータで起動しないでください。外部ネットワークから起動すると、SRMの機能が大幅に低下します。

SRM冗長機能を使用すると、指定ルータは外部ネットワークにアクセスし、 copy tftp: などのコピー コマンドを制約なしで使用できます。

スーパバイザ エンジン上でハイ アベイラビリティをイネーブルに設定する必要があります。

RADIUSやTACACS+などの認証方式を使用してスイッチへのアクセスを制御する場合、 switch console または session コマンドで非指定ルータにアクセスできるようにするときは、フォールバック オプションを設定してローカルのユーザ名とパスワードでログインする必要があります。

フォールバック オプションの設定手順については、 第21章「AAAによるスイッチ アクセスの設定」 を参照してください。

Supervisor Engine 720におけるSRM冗長機能の設定


) SRMの冗長機能は、Supervisor Engine 720およびSupervisor Engine 32でサポートされる唯一のMSFC冗長機能オプションです。


Supervisor Engine 720およびSupervisor Engine 32では、MSFCでSRMを明示的にイネーブルにする必要はありません。SRMはデフォルトでイネーブルです。SRMが正常に動作しているか判断するため、両方のMSFCが同一のスタートアップ コンフィギュレーションを保有していることを確認する必要があります。

1. システムをリセットしてリロードしたあと、 write erase コマンドを非メインMSFC上で実行し、非メインMSFCをリロードします。

2. システムをリセットしてリロードしたあと、 show redundancy コマンドを入力して、SRMランタイム ステータスがイネーブルであることを確認します。SRMランタイム ステータスがイネーブルであることを確認したあと、 write memory コマンドをメインMSFC上で実行し、非メインMSFCをリロードします(非メインMSFCの設定をリロード プロンプトで保存しないでください)。


ヒント 非メインMSFCがメインMSFCと同じ設定で起動する場合は、第2の方法を推奨します。その方が、予期しない問題が発生する可能性が小さくなります。



) システム起動時に、非メインMSFCのスタートアップ コンフィギュレーションにメインMSFC設定にはない設定項目があった場合、MSFCは実行コンフィギュレーションで一貫性がなくなります。上記の2つの手順により、非メインMSFCが常にMSFCと同じ実行コンフィギュレーションを持つことができます。


Supervisor Engine 1またはSupervisor Engine 2におけるSRM冗長機能の設定

SRM冗長機能を設定するには、次の手順を実行します。


注意 デュアル ルータ モードからSRM冗長機能に移行する前に、MSFCのcopy running-configコマンドを使用し、非SRMコンフィギュレーションをブートフラッシュに保存するようにしてください。SRM冗長機能に移行すると、代替コンフィギュレーション(altキーワードのあとのコンフィギュレーション)は失われます。SRM冗長機能をイネーブルにする前に、両方のMSFCにcopy running-config bootflash:nosrm_dual_router_configコマンドを入力し、デュアル ルータ モード コンフィギュレーションをブートフラッシュに保存してください。

詳細については、「SRMの終了」を参照してください。


) この手順は、指定ルータがスロット1に搭載のMSFC2で、非指定ルータがスロット2に搭載のMSFC2であり、さらにアクティブ スーパバイザ エンジンはスロット1にあり、スタンバイ スーパバイザ エンジンはスロット2にあると仮定しています。



ステップ 1 show version コマンドを使用して、両方のスーパバイザ エンジンが、スーパバイザ エンジンRelease 6.3(1)以降のソフトウェア リリースを実行していることを確認します。

ステップ 2 set system highavailability enable コマンドを使用して、アクティブ スーパバイザ エンジン上でハイ アベイラビリティ機能をイネーブルにします。 show system highavailability コマンドを使用して、ハイ アベイラビリティ機能がイネーブルになっていることを確認します。

ステップ 3 コンソール接続を行っている場合は、 switch console コマンドを使用して指定ルータにアクセスします。Telnetセッションを使用して接続している場合は、 session mod コマンドを使用して指定ルータにアクセスします。

ステップ 4 Cisco IOS Release 12.1(8a)E2以降のイメージを指定ルータおよび非指定ルータのブートフラッシュにコピーします。

ステップ 5 指定ルータおよび非指定ルータに対してブート イメージとコンフィギュレーション レジスタを設定して、リロード時に新しいイメージを起動します。

指定ルータの場合は、 boot system flash bootflash: image_name コマンドを使用してこのイメージがブート リストの最初にあることを確認します。 boot system コマンドの no 形式を使用して、実行コンフィギュレーションに表示されている( show running-config )すべての既存の boot system コマンドを削除します。

非指定ルータの場合は、 config-register 0x102 コマンドを入力して、自動起動するようにコンフィギュレーション レジスタを設定します。


) SRM対応Cisco IOSイメージがロード済みの場合、ステップ6の手順は不要です。


ステップ 6 reload コマンドを使用して、指定ルータおよび非指定ルータをリロードします。

ステップ 7 コマンドの no 形式を入力して、指定ルータ上で設定の同期化( config-sync )をディセーブルにします。 write memory コマンドを入力します。これにより、指定ルータと非指定ルータの両方でコンフィギュレーション モードにアクセスできるようになります。

ステップ 8 最初に指定ルータ上でSRMをイネーブルにしてから、次のように非指定ルータ上でSRMをイネーブルにします。

Router(config)#redundancy
Router(config-r)#high-availability
Router(config-r-ha)#single-router-mode
 

) Cisco IOS Release 12.1(11b)E以降のリリースでは、新しい指定ルータがスーパバイザ エンジンのスイッチ プロセッサに新しいレイヤ3スイッチング情報をダウンロードする前に待機する移行時間を指定できます。設定の詳細については、「新しいアクティブ指定ルータに対する移行時間の指定」を参照してください。


ステップ 9 指定ルータ上で write memory コマンドを実行し、非指定ルータのスタートアップ コンフィギュレーションがSRMをイネーブルに設定していることを確認します。

ステップ 10 非指定ルータ上で show startup-config コマンドを実行し、非指定ルータが次のコンフィギュレーション ステートメントを持っていることを確認します。

redundancy
high-availability
single-router-mode
 

ステップ 11 指定ルータおよび非指定ルータ上で show redundancy コマンドを実行し、いずれのルータにも次のコンフィギュレーション ステートメントがあることを確認します。

Single Router Mode RuntimeStatus: enabled
 

持っていない場合は、ステップ9および10をステップ間で十分な時間を取りながら繰り返します。

ステップ 12 reload コマンドを使用して、非指定ルータをリロードします。設定を保存するかどうかの問い合せには、 no を入力します。

次の出力は、SRM冗長機能をイネーブルにするために指定ルータおよび非指定ルータに対して使用したコンフィギュレーション コマンドの要約です。

Time Designated Router Nondesignated Router
---- --- ----
t0: conf t->red->hi->no config-sync
t1: conf t->red->hi->no config-sync
t2: conf t->red->hi->single-router-mode
t3: conf t->red->hi->single-router-m
t4: write mem
t5: reload
 


 

新しいアクティブ指定ルータに対する移行時間の指定

Release 12.1(11b)Eより前のCisco IOSリリースでは、移行時間は120秒に定められ、ユーザは設定できませんでした。ルーティング コンバージェンス時間が異なるので、120秒では足りないことがあります。古いレイヤ3スイッチング エントリは消去され、新たにダウンロードしたレイヤ3スイッチング情報が不完全なことがあります。

Cisco IOS Release 12.1(11b)E以降のリリースでは、新しい指定ルータがスイッチ プロセッサに新しいレイヤ3スイッチング情報をダウンロードする前に待機する移行時間を指定できます。切り替え時には、スイッチ プロセッサに新しいレイヤ3スイッチング情報がダウンロードされる前に、設定した秒数の間、古いレイヤ3スイッチング情報が使用されます。

ノンストップの転送が必要な場合、移行時間をデフォルト値(120秒)より小さい値に設定することは推奨できません。ルートのコンバージェンスには最低限30~60秒かかります。

移行時間を指定するには、以下のコマンドを入力します(この例では移行時間は240秒に設定されています)。

Router(config)#redundancy
Router(config-r)#high-availability
Router(config-r-ha)#single-router-mode
Router(config-r-ha)#single-router-mode failover ?
table-update-delay Adjust for routing convergence time
Router(config-r-ha)#single-router-mode failover table-update-delay ?
<0-4294967295> Delay in seconds between switch over detection and h/w FIB reload
Router(config-r-ha)#single-router-mode failover table-update-delay 240
Router(config-r-ha)#
 

移行時間をデフォルトの2分に設定する場合は、次のように、このコマンドの no 形式を使用します。

Router(config-r-ha)#no single-router-mode failover table-update-delay
 

移行時間を表示するには、次のようにします。

Router-16#show redundancy
Designated Router: 2 Non-designated Router: 1
 
Redundancy Status: designated
 
Config Sync AdminStatus : enabled
 
Config Sync RuntimeStatus: enabled
 
Single Router Mode AdminStatus : enabled
 
Single Router Mode RuntimeStatus: enabled
 
Single Router Mode transition timer : 240 seconds <---- transition time
 
Router-16#
 

SRMをイネーブルに設定したイメージのアップグレード

ここでは、SRMの稼働時にアクティブおよびスタンバイMSFC上でCisco IOSイメージをアップグレードする方法について説明します。新しいイメージの名前はc6msfc2-jsv-mz.9Eです。スタンバイMSFCはTFTPでイメージをロードすることはできませんが、スーパバイザ エンジン フラッシュPCカード(sup-slot0:)からイメージをロードすることができます。


) この手順はデータ トラフィックに影響します。スケジュールされているメンテナンス ウィンドウで実行することを推奨します。


イメージをアップグレードする手順は、次のとおりです。


ステップ 1 アクティブ スーパバイザ エンジン上で、 copy tftp sup-slot0: コマンドを実行し、表示されるプロンプトに従って新しい(c6msfc2-jsv-mz.9E)イメージをスーパバイザ エンジン フラッシュPCカードにロードします。

ステップ 2 コンソール接続を行っている場合は、 switch console コマンドを使用してアクティブMSFCにアクセスします。Telnetセッションを使用して接続している場合は、 session mod コマンドを使用してアクティブMSFCにアクセスします。

ステップ 3 アクティブMSFC上で、スーパバイザ エンジン フラッシュPCカードから新しいイメージをMSFCブートフラッシュにコピーします。

copy sup-slot0:c6msfc2-jsv-mz.9E bootflash:c6msfc2-jsv-mz.9E
 

ステップ 4 スタンバイMSFCにアクセスするには、 switch supervisor コマンドを入力し、そのあとにアクティブ スーパバイザ エンジンに switch console コマンドを入力します。


) スタンバイMSFCは、アクティブ スーパバイザ エンジンから発行されたshow moduleコマンドの出力には表示されません。


ステップ 5 スタンバイMSFC上で、スーパバイザ エンジン フラッシュPCカードから新しいイメージをMSFCブートフラッシュにコピーします。

copy sup-slot0:c6msfc2-jsv-mz.9E bootflash:c6msfc2-jsv-mz.9E
 

ステップ 6 アクティブMSFC上で、MSFCのリロード時に新しいイメージを起動するように指定します。

boot system flash bootflash:c6msfc2-jsv-mz.9E
 

ステップ 7 アクティブMSFC上で、 write memory コマンドを実行して、スタンバイMSFCスタートアップ コンフィギュレーションが起動情報を取得していることを確認します。

ステップ 8 reload コマンドを実行して、スタンバイMSFCをリロードします。

ステップ 9 アクティブおよびスタンバイMSFC上で show redundancy コマンドを実行し、ともに次のコンフィギュレーション ステートメントを持っていることを確認します。

Single Router Mode RuntimeStatus: enabled
 

ステップ 10 reload コマンドを実行して、アクティブMSFCをリロードします。

これで、どちらのMSFCもc6msfc2-jsv-mz.9Eイメージを実行している状態になります。


 

SRMの終了


) SRM冗長機能を設定する前に、デュアル ルータ モードで使用される実行コンフィギュレーションのコピーを保存した場合は、以下に記載する手順を実行する必要はありません。SRM冗長機能を終了してデュアル ルータ モードに戻るには、両方のMSFC上で
copy bootflash:nosrm_dual_router_config startup-configコマンドを入力します。コンフィギュレーションのコピー後、reloadコマンドでMSFCをリロードします。


SRMを終了する手順は、次のとおりです。


ステップ 1 指定ルータ上で、コマンドの no 形式を入力してSRMをディセーブルにします。

Router(config)#redundancy
Router(config-r)#high-availability
Router(config-r-ha)#no single-router-mode
 

ステップ 2 指定ルータおよび非指定ルータ上で write memory コマンドを実行します。

ステップ 3 指定ルータおよび非指定ルータ上で show startup-config コマンドを実行し、スタートアップ コンフィギュレーションに[single-router mode]がないことを確認します。

ステップ 4 reload コマンドを実行して、指定ルータおよび非指定ルータをリロードします。

これで、指定ルータおよび非指定ルータ上でSRMがディセーブルの状態になります。


 

手動モードMSFC冗長機能


) SRM機能を含むRelease 6.3(1)スーパバイザ エンジン ソフトウェア リリースの投入により、手動モードMSFC冗長機能のサポートは2002年12月までとなります。手動モードMSFC冗長機能ではなくSRMを使用することを推奨します。この場合、機能のサポートに期限はなく、また、自動レイヤ3フェールオーバー機能も得られます。


ここでは、一方のMSFCをアクティブに、もう一方のMSFCをROMモニタ モードにした状態で冗長MSFCを設定する方法について説明します。

「ハードウェアおよびソフトウェアの要件」

「手動モードMSFC冗長機能設定時の注意事項」

「スタンバイMSFCのアクセス」

「手動によるMSFCの起動」

「MSFCコンフィギュレーション レジスタの設定」

「MSFC回復手順」

ハードウェアおよびソフトウェアの要件

レイヤ3の冗長機能を設定するには、少なくとも次のいずれかの構成が必要です。

2つの同一スーパバイザ エンジン ドータカードから構成される1つのシャーシ

PFCおよびMSFCまたはMSFC2搭載のSupervisor Engine 1(両方のスーパバイザ エンジンに同一タイプのMSFCを搭載することが必要)

PFC2およびMSFC2搭載のSupervisor Engine 2

それぞれスーパバイザ エンジンを搭載したシャーシ ― 各シャーシに少なくとも1つはスーパバイザ エンジンを搭載しておく必要があります。各スーパバイザ エンジンに、PFCおよびMSFCを取り付けておく必要があります。

手動モードMSFC冗長機能では、次のソフトウェアが必要です。

Release 6.1(3)以降のスーパバイザ エンジン ソフトウェア リリースおよびCisco IOS Release 12.1(7)E以降のリリース

Release 5.5.8以降のスーパバイザ エンジン ソフトウェア リリースおよびCisco IOS Release 12.1(7a)E1以降のリリース


) 各MSFCは、同じCisco IOSソフトウェア リリースを実行している必要があります。


手動モードMSFC冗長機能設定時の注意事項

ここでは、手動モードMSFC冗長機能設定時の注意事項について説明します。

MSFCの切り替えは手動なので、外部冗長ルータが存在する環境、およびHSRPが使用されているか、何らかの形式のゲートウェイ検出がホスト上に実装されている環境でのみ手動モードMSFC冗長機能を使用することを推奨します。

アクティブMSFC(MSFC-15)上のコンフィギュレーション レジスタが0x2102に、ROMモニタ モードのMSFC(MSFC-16)上のコンフィギュレーション レジスタが0x0に設定されていることを確認します。この設定により、両方のMSFCが同時にアクティブになるのを防止し、アクティブMSFCをリセット後にオンラインにすることができます。コンフィギュレーション レジスタの設定の詳細については、「MSFCコンフィギュレーション レジスタの設定」を参照してください。


) 両方のMSFCを0x0に設定することはオプションとしてサポートされていますが、スイッチをリセットする場合はユーザによる設定が必要です。


IPアドレスの領域を保護し、レイヤ3の全体的な複雑性を緩和するには、両方のMSFC上で設定同期化をディセーブルにし、すべての[alt]アドレスを削除するようにします。altアドレスが使用されていると、IPアドレス領域が保護されず、(BGPなどの)リンクレベルのピアリングが存在する場合にレイヤ3の複雑性が増します。

メンテナンス ウィンドウでROMモニタ モードのMSFCを起動した場合、アクティブMSFCと完全に同じ設定かどうかを確認してください。表22-2に記載されている設定時の注意事項を参照してください。

手動モードMSFC冗長機能の間、スーパバイザ エンジン上でハイ アベイラビリティをイネーブルにして、MSFC切り替え実行時のレイヤ2ダウンタイムを最小限に抑えます。ハイ アベイラビリティはプロトコル フィルタリング、ポート セキュリティ、Dynamic VLAN(DVLAN)、Generic Attribute Registration Protocol(GARP)VLAN Registration Protocol(GVRP)には対応していないので、手動モードMSFC冗長機能使用時は、これらの機能をディセーブルに設定することを推奨します。

両方のスーパバイザ エンジン上のコンソール ポートに運用担当者がアクセスできるようにします(端末サーバまたはモデムによる帯域外アクセス)。


) ここでの手順は、switch consoleコマンドを使用してスーパバイザ エンジンからMSFCにアクセスします。Telnetセッションでは、switch consoleコマンドはサポートされていません。


スタンバイMSFCのアクセス

スタンバイMSFCにアクセスするには、 switch supervisor コマンドを入力し、そのあとに switch console コマンドを入力します。


) スタンバイMSFCは、アクティブ スーパバイザ エンジンから発行されたshow moduleコマンドの出力には表示されません。


手動によるMSFCの起動

両方のMSFCのコンフィギュレーション レジスタが0x0に設定されている場合、MSFC手動モードでは、スイッチをリセットするたびにMSFCを手動で起動する必要があります。MSFCを手動で起動するには、次の作業を行います。


ステップ 1 switch console コマンドを使用してMSFC ROMMONプロンプトにアクセスします。

ステップ 2 boot bootflash: image コマンドを入力します。

ステップ 3 MSFCの起動後、Router>プロンプトに Ctrl-C を3回入力すると、スーパバイザ エンジン プロンプトに戻ります。 session コマンドを実行して、MSFCにアクセスします。


 

MSFCコンフィギュレーション レジスタの設定

手動モードMSFC冗長機能では、次のようにコンフィギュレーション レジスタを設定します。


ステップ 1 アクティブMSFC(MSFC-15)上でCisco IOSコンフィギュレーション モードから、 config-register 0x2102 コマンドを入力します。

ステップ 2 ROMモニタ モードのMSFC(MSFC-16)上で、 config-register 0x0 コマンドを入力します。


) 両方のMSFCコンフィギュレーションのbootシステム コマンドがブートフラッシュの有効なイメージをポイントするようにし、かつ、これらのbootコマンドを無視するようにはコンフィギュレーション レジスタを設定しないことを推奨します。



 

MSFC回復手順

ここでは、一時的または永続的なMSFC障害から回復する手順について説明します。

アクティブMSFCの一時的な障害が発生した場合、コンフィギュレーション レジスタが0x2102に設定されているため、MSFCが再起動します。

永続的な障害の疑いがあるアクティブなMSFCは確認する必要があります。それには、アクティブ スーパバイザ エンジンのコンソール ポートから reset 15 コマンドを実行し、アクティブMSFCが正常に再起動するかどうかを確認します。再起動しない場合は、次の2つの方法でスタンバイMSFCに切り替えることができます。

方法1:スイッチに物理的にアクセスする場合

スイッチに物理的にアクセスする場合は、この方法を使用 します。問題のあるMSFCを装備しているアクティブ スーパバイザ エンジンを取り外すことにより、冗長スーパバイザ エンジンが動作を引き継ぎます。冗長スーパバイザ エンジンの物理コンソール ポートで、次の手順を実行します。


ステップ 1 switch console コマンドを実行します。

ステップ 2 ROMMONプロンプトで、 boot bootflash: image コマンドを実行します。

ステップ 3 スタンバイMSFCの起動後、Cisco IOSコンフィギュレーション モードで config-register 0x2102 コマンドを実行して、スイッチのリセット時にMSFCが起動するようにします。


 

方法2:スイッチにリモート アクセスだけが可能な場合

スイッチにリモート アクセスしかできない場合は、この方法を使用します。問題のあるMSFCを装備しているアクティブ スーパバイザ エンジンで、次の手順を実行します。


) 問題のあるMSFCがスタンバイ スーパバイザ エンジン上にある場合は、switch supervisorコマンドを実行します。



ステップ 1 switch console コマンドを実行します。

ステップ 2 ブレーク信号を送信して問題のあるMSFCのROMMONに入ります(ブレークが有効なのはMSFCが引き続き再起動している場合に限ります)。システムのブートストラップ メッセージが出力されてから、メインCisco IOSイメージが解凍されるまでの間に発行されるように、ブレークのタイミングを決める必要があります(次の出力の2つの矢印を参照)。

System Bootstrap, Version 12.0(3)XE, RELEASE SOFTWARE
Copyright (c) 1998 by cisco Systems, Inc.
Cat6k-MSFC platform with 131072 Kbytes of main memory <======= ISSUE BREAK AFTER THIS POINT
 
 
Self decompressing the image : ###################################################################################### [OK]
 
<==========BUT BEFORE THIS POINT
 
Self decompressing the image : ################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################### [OK]
 

ステップ 3 ROMMONプロンプトで、 confreg コマンドを入力します。

a. [do you wish to change the configuration? y/n [n]:]のプロンプトに、 y と入力します。

b. Enter を押してすべての質問に対してデフォルトの設定を受け入れると、次のプロンプトが表示されます。[change the boot characteristics? y/n [n]:]

c. y と入力します。

d. 0 と入力して、次のプロンプトで0 = ROM Monitorオプションを選択します。

e. Configuration Summaryを調べて、boot:the ROM Monitorの値を確認します。

f. 再度、[do you wish to change the configuration? y/n [n]:]というプロンプトが表示されます。

g. n と入力します。

h. ROMMONプロンプトに戻ります。

ステップ 4 reset コマンドを実行して、MSFCがROMMONで起動していることを確認します。このステップにより、このMSFCとアクティブMSFCが同時に起動しないようになります。

ステップ 5 Ctrl-C を3回入力して、スーパバイザ エンジン プロンプトに戻ります。

ステップ 6 ハイ アベイラビリティがスーパバイザ エンジンのステートを同期化していることを確認します。そのためには、 show system highavailability コマンドを実行して、ハイ アベイラビリティの[Operational-status]がONであることを確認します。

ステップ 7 switch supervisor コマンドを実行します。

ステップ 8 switch console コマンドを実行します。

ステップ 9 スタンバイMSFCのROMMONプロンプトで、ステップ3を繰り返しますが、ステップ3dではオプション2の[boot system]を選択します。

change the boot characteristics? y/n [n]: y
enter to boot:
0 = ROM Monitor
1 = the boot helper image
2-15 = boot system
[2]: 2 <========================
 
 
Configuration Summary
enabled are:
load rom after netboot fails
console baud: 9600
boot: the ROM Monitor
 
do you wish to change the configuration? y/n [n]: n
 
 
You must reset or power cycle for new config to take effect
rommon 2 >
 

ステップ 10 ROMMONプロンプトで reset コマンドを入力してシステムを起動します。

ステップ 11 MSFCが起動したら、新しいアクティブMSFCのコンソール ポート上のCisco IOSコンフィギュレーション モードで config-register 0x2102 コマンドを実行します。

ステップ 12 Ctrl-C を3回入力して、スーパバイザ エンジン プロンプトに戻ります。