Catalyst 6500 シリーズ スイッチ Cisco IOS ソフトウェア コンフィギュレーション ガイド Release 12.2SX
ローカル SPAN、RSPAN、および ERSPAN の設定
ローカル SPAN、RSPAN、および ERSPAN の設定
発行日;2012/01/12 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 11MB) | フィードバック

目次

ローカル SPAN、RSPAN、および ERSPAN の設定

ローカル SPAN、RSPAN、および ERSPAN の機能概要

ローカル SPAN、RSPAN、および ERSPAN の概要

ローカル SPAN の概要

RSPAN の概要

ERSPAN の概要

モニタ対象トラフィック

ローカル SPAN、RSPAN、および ERSPAN の送信元

送信元ポート

送信元 VLAN

ローカル SPAN、RSPAN、および ERSPAN の宛先ポート

ローカル SPAN、RSPAN、および ERSPAN 設定時の注意事項および制約事項

機能の非互換性

ローカル SPAN、RSPAN、および ERSPAN セッションの制限

PFC3

PFC2

ローカル SPAN、RSPAN、および ERSPAN の注意事項および制約事項

VSPAN に関する注意事項および制約事項

RSPAN に関する注意事項および制約事項

ERSPAN に関する注意事項および制約事項

ローカル SPAN、RSPAN、および ERSPAN の設定

宛先ポートの許可リストの設定(任意)

ローカル SPAN の設定

RSPAN の設定

RSPAN VLAN の設定

RSPAN 送信元セッションの設定

RSPAN 宛先セッションの設定

ERSPAN の設定

ERSPAN 送信元セッションの設定

ERSPAN 宛先セッションの設定

ローカル SPAN および RSPAN の送信元 VLAN フィルタリングの設定

無条件トランクとしての宛先ポートの設定

宛先トランク ポートの VLAN フィルタリングの設定

設定の確認

設定例

ローカル SPAN、RSPAN、および ERSPAN の設定

この章では、Catalyst 6500 シリーズ スイッチ上でローカル Switched Port Analyzer(SPAN; スイッチド ポート アナライザ)、Remote SPAN(RSPAN)、および Encapsulated RSPAN(ERSPAN)を設定する手順について説明します。PFC3 を使用する場合は、ERSPAN は Release12.2(18)SXE 以降のリリースでサポートされます(ERSPAN に関する注意事項および制約事項を参照)。


) • この章で使用しているコマンドの構文および使用方法の詳細については、次の URL の『Catalyst 6500 Series Switch Cisco IOS Command Reference』Release 12.2SX を参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/lan/cat6000/122sx/cmdref/index.htm

OSM(オプティカル サービス モジュール)WAN ポートおよび FlexWAN ポートは、SPAN、RSPAN、または ERSPAN をサポートしません。

PFC2 は ERSPAN をサポートしません。


 

この章で説明する内容は、次のとおりです。

「ローカル SPAN、RSPAN、および ERSPAN の機能概要」

「ローカル SPAN、RSPAN、および ERSPAN 設定時の注意事項および制約事項」

「ローカル SPAN、RSPAN、および ERSPAN の設定」

ローカル SPAN、RSPAN、および ERSPAN の機能概要

ここでは、ローカル SPAN、RSPAN、および ERSPAN の機能について説明します。

「ローカル SPAN、RSPAN、および ERSPAN の概要」

「ローカル SPAN、RSPAN、および ERSPAN の送信元」

「ローカル SPAN、RSPAN、および ERSPAN の宛先ポート」

ローカル SPAN、RSPAN、および ERSPAN の概要

ローカル SPAN、RSPAN、および ERSPAN セッションを使用すると、1 つまたは複数のポート、あるいは 1 つまたは複数の VLAN を対象にトラフィックをモニタし、モニタしたトラフィックを、1 つまたは複数の宛先ポートに送信することができます。Release 12.2(18)SXD 以降のリリースでは、宛先トランク ポートに VLAN 単位のフィルタリングを設定できます。

ローカル SPAN、RSPAN、および ERSPAN は、SwitchProbe 装置、その他の Remote Monitoring(RMON)プローブなどのネットワーク アナライザにトラフィックを送信します。SPAN は、送信元ポートまたは VLAN(仮想 LAN)上のトラフィックのスイッチングには影響しません。SPAN は、送信元ポートと VLAN によって送受信されるパケットのコピーを宛先ポートに送信します。その宛先ポートは、SPAN 専用に設定しなければなりません。

ここでは、ローカル SPAN、RSPAN、および ERSPAN の概要を説明します。

「ローカル SPAN の概要」

「RSPAN の概要」

「ERSPAN の概要」

「モニタ対象トラフィック」

ローカル SPAN の概要

ローカル SPAN セッションは、送信元ポートおよび送信元 VLAN と、1 つまたは複数の宛先ポートを対応付けます。ローカル SPAN セッションを単一のスイッチに設定します。ローカル SPAN には、個別の送信元および宛先のセッションはありません。

ローカル SPAN セッションは、RSPAN VLAN を伝送する送信元トランク ポートからローカルに送信された RSPAN トラフィックをコピーしません。ローカル SPAN セッションは、送信元ポートからローカルに送信された RSPAN VLAN GRE(総称ルーティング カプセル化) カプセル化トラフィックをコピーしません。

各ローカル SPAN セッションは、ポートまたは VLAN のいずれかを送信元とすることができますが、両方を送信元にすることはできません。

ローカル SPAN は、任意の VLAN 上の 1 つまたは複数の送信元ポートからのトラフィック、あるいは 1 つまたは複数の VLAN からのトラフィックを分析するために宛先ポートへコピーします(図52-1 を参照)。たとえば、図52-1 に示すように、イーサネット ポート 5(送信元ポート)上の全トラフィックが、イーサネット ポート 10 にコピーされます。イーサネット ポート 10 のネットワーク アナライザは、イーサネット ポート 5 に物理的に接続していなくても、このポートからのあらゆるトラフィックを受信することができます。

図52-1 SPAN の設定例

 

RSPAN の概要

RSPAN は、様々なスイッチ上の送信元ポート、送信元 VLAN、および宛先ポートをサポートし、ネットワーク全体に存在する複数のスイッチをリモート モニタします(図52-2 を参照)。

RSPAN は、RSPAN 送信元セッション、RSPAN VLAN、および RSPAN 宛先セッションで構成されています。RSPAN の送信元セッションと宛先セッションを、様々なスイッチ上で個別に設定します。RSPAN 送信元セッションを 1 つのスイッチ上で設定するには、送信元ポートまたは VLAN のセットを RSPAN VLAN に対応付けます。RSPAN 宛先セッションを別のスイッチ上で設定するには、宛先ポートを RSPAN VLAN に対応付けます。

各 RSPAN セッション用のトラフィックは、ユーザ固有の RSPAN VLAN(すべての参加スイッチでその RSPAN セッション専用となっている)経由で、レイヤ 2 の非ルーティング トラフィックとして伝送されます。すべての参加スイッチはレイヤ 2 にトランク接続される必要があります。

RSPAN 送信元セッションは、RSPAN VLAN を伝送する送信元トランク ポートからローカルに送信される RSPAN VLAN トラフィックをコピーしません。RSPAN 送信元セッションは、送信元ポートからローカルに送信された RSPAN GRE カプセル化トラフィックをコピーしません。

各 RSPAN 送信元セッションは、ポートまたは VLAN のいずれかを送信元とすることができますが、両方を送信元にすることはできません。

RSPAN 送信元セッションは、送信元ポートまたは送信元 VLAN からのトラフィックをコピーして、RSPAN VLAN のトラフィックを RSPAN 宛先セッションにスイッチングします。RSPAN 宛先セッションでは、トラフィックを宛先ポートにスイッチングします。

図52-2 RSPAN の設定

 

ERSPAN の概要

ERSPAN は、様々なスイッチ上の送信元ポート、送信元 VLAN、および宛先ポートをサポートし、ネットワーク全体に存在する複数のスイッチをリモート モニタします(図52-3 を参照)。

ERSPAN は、ERSPAN 送信元セッション、ルーティング可能な ERSPAN GRE カプセル化トラフィック、および ERSPAN 宛先セッションで構成されています。ERSPAN の送信元セッションと宛先セッションを、様々なスイッチ上で個別に設定します。

ERSPAN 送信元セッションを 1 つのスイッチ上で設定するには、送信元ポートまたは VLAN のセットを、宛先 IP アドレス、ERSPAN ID 番号、およびオプションとして VRF(VPN ルーティング/転送)名に対応付けます。ERSPAN 宛先セッションを別のスイッチ上で設定するには、宛先ポートを、送信元 IP アドレス、ERSPAN ID 番号、およびオプションとして VRF 名に対応付けます。

ERSPAN 送信元セッションは、RSPAN VLAN を伝送する送信元トランク ポートからローカルに送信される RSPAN VLAN トラフィックをコピーしません。ERSPAN 送信元セッションは、送信元ポートからローカルに送信された ERSPAN GRE カプセル化トラフィックをコピーしません。

各 ERSPAN 送信元セッションは、ポートまたは VLAN のいずれかを送信元とすることができますが、両方を送信元にすることはできません。

ERSPAN 送信元セッションは、送信元ポートまたは送信元 VLAN からのトラフィックをコピーして、このトラフィックを、ルーティング可能な GRE カプセル化パケットを使用して ERSPAN 宛先セッションに転送します。ERSPAN 宛先セッションでは、トラフィックを宛先ポートにスイッチングします。

図52-3 ERSPAN のデフォルト設定

 

モニタ対象トラフィック

ここでは、ローカル SPAN、RSPAN、および ERSPAN によってモニタが可能なトラフィックについて説明します。

「モニタ対象トラフィックの方向」

「モニタ対象トラフィック」

「重複トラフィック」

モニタ対象トラフィックの方向

ローカル SPAN セッション、RSPAN 送信元セッション、および ERSPAN 送信元セッションを、入力トラフィックのモニタ(入力 SPAN と呼ばれます)、出力トラフィックのモニタ(出力 SPAN と呼ばれます)、または両方向でのトラフィック フローをモニタするように設定できます。

入力 SPAN は、送信元ポートおよび VLAN が受信したトラフィックを、宛先ポートで分析できるようにコピーします。出力 SPAN は、送信元ポートおよび VLAN が送信したトラフィックをコピーします。 both キーワードを入力すると、SPAN は送信元ポートおよび VLAN によって送受信されたトラフィックを宛先ポートにコピーします。

モニタ対象トラフィック

デフォルトでは、ローカル SPAN および ERSPAN は、マルチキャストおよび Bridge Protocol Data Unit(BPDU; ブリッジ プロトコル データ ユニット)フレームを含めて、すべてのトラフィックをモニタします。RSPAN は BPDU モニタをサポートしません。

重複トラフィック

設定によっては、SPAN が、同じ送信元のトラフィックの複数のコピーを、宛先ポートに送信します。たとえば、s1 と s2 という 2 つの SPAN 送信元から、d1 という SPAN 宛先ポートに対して両方向の SPAN セッション(入力および出力の両方)が設定されていて、パケットが、s1 経由でスイッチに入り、そのスイッチから s2 へ出力されるように送信される場合、s1 における入力 SPAN はパケットのコピーを SPAN 宛先ポートの d1 に送信し、s2 における出力 SPAN も、パケットのコピーを SPAN 宛先ポートの d1 に送信します。パケットが s1 から s2 へスイッチングされたレイヤ 2 だった場合、両方の SPAN パケットは同一になります。パケットが s1 から s2 へスイッチングされたレイヤ 3 だった場合、レイヤ 3 の書き換えは送信元と宛先のレイヤ 2 アドレスを変更し、この場合、SPAN パケットは異なるものになります。

ローカル SPAN、RSPAN、および ERSPAN の送信元

ここでは、ローカル SPAN、RSPAN、および ERSPAN の送信元について説明します。

「送信元ポート」

「送信元 VLAN」

送信元ポート

送信元ポートは、トラフィック分析のためにモニタ対象になるポートです。スイッチングおよびルーティングされているポートの両方を、SPAN 送信元ポートとして設定できます。SPAN は、1 つまたは複数の送信元ポートを、単一の SPAN セッションでモニタできます。任意の VLAN に送信元ポートを設定できます。トランク ポートを、送信元ポートとして設定したり、非トランク送信元ポートと混在させることができます。SPAN は、送信元トランク ポートからのカプセル化をコピーしません。

送信元 VLAN

送信元 VLAN は、トラフィック分析のためにモニタ対象になる VLAN です。VLAN ベースの SPAN(VSPAN)は、VLAN を SPAN 送信元として使用します。送信元 VLAN にあるすべてのポートが、送信元ポートになります。

ローカル SPAN、RSPAN、および ERSPAN の宛先ポート

宛先ポートは、ローカル SPAN、RSPAN、または ERSPAN が分析用のトラフィックを送信するレイヤ 2 LAN ポートまたはレイヤ 3 LAN ポートです。

ポートを宛先ポートとして設定すると、そのポートはトラフィックを受信することができなくなります。ポートを宛先ポートとして設定すると、そのポートは SPAN 機能によってのみ使用される専用のポートになるからです。SPAN 宛先ポートでは、SPAN セッションに必要なトラフィック以外の転送は行われません。

トランク ポートを宛先ポートとして設定することができます。これによって、宛先トランク ポートがカプセル化したトラフィックを転送することができます。Release 12.2(18)SXD 以降のリリースでは、ローカル SPAN の場合、許可される VLAN のリストを使用して宛先トランク ポートに VLAN 単位のフィルタリングを設定できます(宛先トランク ポートの VLAN フィルタリングの設定参照)。

ローカル SPAN、RSPAN、および ERSPAN 設定時の注意事項および制約事項

ここでは、ローカル SPAN、RSPAN、および ERSPAN の設定に関する注意事項および制約事項について説明します。

「機能の非互換性」

「ローカル SPAN、RSPAN、および ERSPAN セッションの制限」

「ローカル SPAN、RSPAN、および ERSPAN の注意事項および制約事項」

「VSPAN に関する注意事項および制約事項」

「RSPAN に関する注意事項および制約事項」

「ERSPAN に関する注意事項および制約事項」


) ERSPAN は Release12.2(18)SXE 以降のリリースでサポートされます。


機能の非互換性

ローカル SPAN、RSPAN、および ERSPAN には、次のような機能の非互換性問題が存在します。

PFC3 では、EoMPLS ポートを SPAN 送信元として使用することはできません。(CSCed51245)

ポートチャネル インターフェイス(EtherChannel)は SPAN 送信元として使用できますが、EtherChannel のアクティブなメンバー ポートを SPAN 送信元ポートとして設定することはできません。EtherChannel の非アクティブ メンバー ポートは SPAN 送信元として設定できますが、これらのポートは中断ステートになり、トラフィックを伝送しません。

ポートチャネル インターフェイス(EtherChannel)は SPAN 宛先として設定できません。

SPAN 宛先ポートとして、EtherChannel のアクティブなメンバー ポートを設定することはできません。EtherChannel の非アクティブ メンバー ポートは SPAN 宛先として設定できますが、これらのポートは中断ステートになり、トラフィックを伝送しません。

SPAN 宛先ポートは入力トラフィックを廃棄するので、次の機能は SPAN 宛先ポートでは互換性がありません。

プライベート VLAN

IEEE 802.1X ポートベースの認証

ポート セキュリティ

Spanning-Tree Protocol(STP; スパニングツリー プロトコル)および関連機能(PortFast、PortFast BPDU フィルタリング、BPDU ガード、UplinkFast、BackboneFast、EtherChannel ガード、ルート ガード、ループ ガード)

VLAN Trunking Protocol(VTP; VLAN トランキング プロトコル)

Dynamic Trunking Protocol(DTP; ダイナミック トランキング プロトコル)

IEEE 802.1Q トンネリング


) SPAN 宛先ポートは、IEEE 802.3Z フロー制御に関与できます。


ローカル SPAN、RSPAN、および ERSPAN セッションの制限

ここでは、ローカル SPAN、RSPAN、および ERSPAN セッションの制限について説明します。

「PFC3」

「PFC2」

PFC3

PFC3 ローカル SPAN、RSPAN、および ERSPAN セッションの制限は、次のとおりです。

 

総セッション数
ローカル SPAN、RSPAN、または ERSPAN 送信元セッション
RSPAN 宛先セッション
ERSPAN 宛先セッション

66

2(入力か出力、または両方)

64

23

PFC3 でのローカル SPAN、RSPAN、および ERSPAN 送信元および宛先の制限は、次のとおりです。

 

各ローカル
SPAN セッション
各 RSPAN
送信元セッション
各 ERSPAN
送信元セッション
各 RSPAN
宛先セッション
各 ERSPAN
宛先セッション

出力または「両方」の送信元

--

--

Release 12.2(18)SXE より前のリリース

1

1

1

Release12.2(18)SXE 以降のリリース

128

128

128

入力送信元

--

--

Release 12.2(18)SXD
より前のリリース

64

64

64

Release12.2(18)SXD 以降のリリース

128

128

128

RSPAN および ERSPAN 宛先セッションの送信元

--

--

--

1 RSPAN VLAN

1 IP アドレス

セッションごとの宛先

64

1 RSPAN VLAN

1 IP アドレス

64

64

PFC2


) • ローカル SPAN セッションの出力 SPAN 送信元を設定する場合、PFC2 は RSPAN をサポートしません。

RSPAN を設定する場合、PFC2 はローカル SPAN の出力 SPAN 送信元をサポートしません。


 

PFC2 でのローカル SPAN および RSPAN セッションの制限は、次のとおりです。

 

総セッション数
ローカル SPAN セッション
RSPAN 送信元セッション
RSPAN 宛先セッション

66

2(入力か出力、または両方)

0

64

1(入力)

1(入力か出力、または両方)

64

1 または 2(出力)

0

64

PFC2 でのローカル SPAN および RSPAN 送信元および宛先の制限は、次のとおりです。

 

各ローカル SPAN セッション
各 RSPAN 送信元セッション
各 RSPAN 宛先セッション

出力または「両方」の送信元

1(リモート SPAN 送信元セッションが設定されている場合 0)

1(ローカル SPAN 出力送信元セッションが設定されている場合 0)

--

入力送信元

--

Release 12.2(18)SXD
より前のリリース

64

64

Release12.2(18)SXD 以降のリリース

128

128

RSPAN 宛先セッションの送信元

--

--

1 RSPAN VLAN

セッションごとの宛先

64

1 RSPAN VLAN

64

ローカル SPAN、RSPAN、および ERSPAN の注意事項および制約事項

ローカル SPAN、RSPAN、および ERSPAN には、次の注意事項および制約事項が適用されます。

1 つの出力 SPAN 送信元ポートからトラフィックをコピーした SPAN 宛先ポートは、出力トラフィックのみをネットワーク アナライザに送信します。ただし、Release 12.2(18)SXE 以降のリリースでは、複数の出力 SPAN 送信元ポートを設定している場合は、ネットワーク アナライザに送信されるトラフィックに、出力 SPAN 送信元ポートから受信した特定タイプの入力トラフィックも含まれます。この入力トラフィックのタイプは次のとおりです。

VLAN 上でフラッディングしたすべてのユニキャスト トラフィック

ブロードキャストおよびマルチキャスト トラフィック

この状況が発生するのは、出力 SPAN 送信元ポートはこれらのトラフィック タイプを VLAN から受信したあと、自身がトラフィックの送信元であることを認識し、受信したトラフィックの送信元にこのトラフィックを返送せず、廃棄してしまうためです。SPAN は廃棄する前にこのトラフィックをコピーし、SPAN 宛先ポートに送信します。(CSCds22021)

monitor session コマンドを追加して入力しても、前に設定した SPAN パラメータは消去されません。設定済みの SPAN パラメータを削除するには、 no monitor session コマンドを使用する必要があります。

ネットワーク アナライザを SPAN 宛先ポートに接続します。

すべての SPAN 宛先ポートは、すべてのトラフィックをすべての SPAN 送信元から受信します。


) Release 12.2(18)SXD 以降のリリースでは、許可される VLAN のリストを使用して、宛先トランク ポート VLAN フィルタリングを設定できます(宛先トランク ポートの VLAN フィルタリングの設定参照)。

Release 12.2(18)SXE 以降のリリースでは、ローカル SPAN および RSPAN の場合は、送信元 VLAN フィルタリングを設定できます(ローカル SPAN および RSPAN の送信元 VLAN フィルタリングの設定を参照)。


レイヤ 2 LAN ポート( switchport コマンドを使用して設定された LAN ポート)とレイヤ 3 LAN ポート( switchport コマンドで設定されていないポート)の両方を送信元または宛先として設定できます。

1 つのセッションに、個別の送信元ポートおよび送信元 VLAN を混在させることはできません。

複数の入力送信元ポートを指定する場合、各ポートはそれぞれ異なる VLAN に属するものであってもかまいません。

1 つのセッション内では、送信元 VLAN とフィルタ VLAN を混在させることはできません。送信元 VLAN またはフィルタ VLAN を使用することはできますが、両方を同時に使用することはできません。

ローカル SPAN、RSPAN、および ERSPAN をイネーブルにすると、すでに入力された設定があれば、その設定が使用されます。

送信元を指定し、トラフィックの方向(入力、出力、または両方)を指定しない場合、「両方」がデフォルトで使用されます。

SPAN は、レイヤ 2 イーサネット フレームをコピーしますが、SPAN は送信元トランク ポート ISL(スイッチ間リンク)や 802.1Q タグをコピーしません。宛先ポートをトランクとして設定して、ローカルにタグ付けされたトラフィックをトラフィック アナライザに送信できます。


) トランクとして設定した宛先ポートは、レイヤ 3 LAN 送信元ポートからのトラフィックを、レイヤ 3 LAN ポートによって使用される内部 VLAN としてタグを付けます。


ローカル SPAN セッション、RSPAN 送信元セッション、および ERSPAN 送信元セッションは、RSPAN VLAN を伝送する送信元トランク ポートからローカルに送信された RSPAN VLAN トラフィックをコピーしません。

ローカル SPAN セッション、RSPAN 送信元セッション、および ERSPAN 送信元セッションは、送信元ポートからローカルに送信された ERSPAN GRE カプセル化トラフィックをコピーしません。

1 つの SPAN セッションで宛先ポートとして指定されたポートは、別の SPAN セッションの宛先ポートにすることはできません。

宛先ポートとして設定されたポートは、送信元ポートとして設定できません。

宛先ポートは、スパニングツリー インスタンスには関与しません。ローカル SPAN はモニタ対象トラフィックに BPDU を含めます。したがって、宛先ポートで確認される BPDU は、送信元ポートから送られたものです。RSPAN は BPDU モニタをサポートしません。

出力送信元として設定されているポートからの伝送用にスイッチを経由して送信されるすべてのパケットは、宛先ポートにコピーされます。このパケットには、STP がポートをブロッキング ステートにするためポート経由でスイッチから送出されないパケットや、STP が VLAN をトランク ポートでブロッキング ステートに移行するので、トランク ポートにあるパケットが含まれます。

VSPAN に関する注意事項および制約事項


) ローカル SPAN、RSPAN、および ERSPAN は、すべて VSPAN をサポートします。


ここでは、VSPAN に関する注意事項および制約事項について説明します。

入力および出力の両方が設定されている VSPAN セッションについては、2 つのパケットが同じ VLAN でスイッチングされている場合、それらは宛先ポートから(1 つは入力ポートからの入力トラフィックとして、もう 1 つは出力ポートからの出力トラフィックとして)転送されます。

VSPAN は、VLAN 中のレイヤ 2 ポートから出入りするトラフィックのみをモニタします。

VLAN を入力送信元として設定し、トラフィックが、モニタされている VLAN へとルーティングされると、そのルーティングされたトラフィックは、VLAN 中のレイヤ 2 ポートで受信する入力トラフィックとしてみなされないためモニタされません。

VLAN を出力送信元として設定し、トラフィックが、モニタされている VLAN からルーティングされると、そのルーティングされたトラフィックは、VLAN 中のレイヤ 2 ポートから送信される出力トラフィックとしてみなされないためモニタされません。

RSPAN に関する注意事項および制約事項

ここでは、RSPAN に関する注意事項および制約事項について説明します。

ローカル SPAN セッションの出力 SPAN 送信元を設定する場合、Supervisor Engine 2 は RSPAN をサポートしません。

RSPAN を設定する場合、Supervisor Engine 2 はローカル SPAN の出力 SPAN をサポートしません。

すべての参加スイッチはレイヤ 2 にトランク接続される必要があります。

RSPAN VLAN をサポートするネットワーク装置は、RSPAN 中間装置とすることができます。

ネットワークが伝送する RSPAN VLAN の数に制限はありません。

中間ネットワーク装置は、サポートすることができる RSPAN VLAN の数を制限することがあります。

すべての送信元、中間、宛先ネットワーク装置において、RSPAN VLAN を設定しなければなりません。VTP がイネーブルの場合、1 ~ 1024 の番号がついた VLAN の設定を RSPAN VLAN として伝播できます。1024 より大きい番号の VLAN は、すべての送信元、中間、および宛先ネットワーク装置で、RSPAN VLAN として手動で設定する必要があります。

VTP および VTP プルーニングをイネーブルにすると、RSPAN トラフィックはトランクでプルーニングされて、RSPAN トラフィックがネットワーク全体に不必要にフラッディングするのを防ぎます。

RSPAN VLAN は、RSPAN トラフィックに対してのみ使用できます。

管理トラフィックを伝送するのに使用する VLAN を、RSPAN VLAN として設定しないでください。

アクセス ポートを RSPAN VLAN に割り当てないでください。RSPAN は、RSPAN VLAN 中のアクセス ポートを中断ステートにします。

RSPAN トラフィックを伝送するために選択されたトランク ポートを除き、RSPAN VLAN にはポートを設定しないでください。

MAC(メディア アクセス制御)アドレス学習は、RSPAN VLAN でディセーブルにされます。

RSPAN 送信元スイッチにある RSPAN VLAN で、出力 Access Control List(ACL; アクセス制御リスト)を使用して、RSPAN 宛先へ送信されるトラフィックをフィルタリングできます。

RSPAN は BPDU モニタをサポートしません。

RSPAN VLAN を VSPAN セッション中の送信元として設定しないでください。

参加ネットワーク装置のすべてが RSPAN VLAN の設定をサポートし、参加ネットワーク装置のすべてで各 RSPAN セッションに対して同じ RSPAN VLAN を使用するかぎり、VLAN を RSPAN VLAN として設定できます。

ERSPAN に関する注意事項および制約事項

ここでは、ERSPAN に関する注意事項および制約事項について説明します。

ERSPAN は Release12.2(18)SXE 以降のリリースでサポートされます。

Release 12.2(18)SXE 以降のリリースでは、スイッチがどのスイッチング モードで動作している場合でも、ERSPAN がサポートされます。(CSCec70695)。

Release 12.2(18)SXE およびリビルドでは、スイッチが compact スイッチング モードで動作している場合に限り、ERSPAN がサポートされます。すべてのモジュールはファブリック対応である必要があります。

PFC3B および PFC3BXL は ERSPAN をサポートします。

WS-SUP720(PFC3A 搭載の Supervisor Engine 720)のハードウェア バージョン 3.2 以降は ERSPAN をサポートします。ハードウェア バージョンを確認するには、 show module version | include WS-SUP720-BASE コマンドを入力してください。次に、例を示します。

Router# show module version | include WS-SUP720-BASE
7 2 WS-SUP720-BASE SAD075301SZ Hw :3.2
 

PFC2 は ERSPAN をサポートしません。

ERSPAN パケットでは、GRE ヘッダー内の [protocol type] フィールドの値は 0x88BE です。

レイヤ 3 ERSPAN パケットのペイロードは、コピーされたレイヤ 2 イーサネット フレームからすべての ISL または 802.1Q タグを取り除いたものです。

ERSPAN は、コピーされた個々のレイヤ 2 イーサネット フレームに 50 バイトのヘッダーを追加し、4 バイトの Cyclic Redundancy Check(CRC; 巡回冗長検査)トレーラーと置き換えます。

ERSPAN は、最大 9,202 バイトのレイヤ 3 パケットを保持するジャンボ フレームをサポートします。コピーされたレイヤ 2 イーサネット フレームの長さが 9,170(9,152 バイトのレイヤ 3 パケット)を超える場合は、ERSPAN はコピーされたレイヤ 2 イーサネット フレームを切り捨て、9,202 バイトの ERSPAN レイヤ 3 パケットを作成します。

設定された MTU サイズとは関係なく、ERSPAN は最長 9,202 バイトのレイヤ 3 パケットを作成します。ERSPAN トラフィックは、MTU サイズを 9,202 バイト未満に規定しているネットワーク内のインターフェイスによって廃棄される可能性があります。

デフォルトの MTU サイズ(1,500 バイト)の場合、コピーされたレイヤ 2 イーサネット フレームの長さが 1,468 バイト(1,450 バイトのレイヤ 3 パケット)を超えると、MTU サイズを 1,500 バイトに規定しているネットワーク内のインターフェイスによって ERSPAN トラフィックは廃棄されます。


mtu インターフェイス コマンド、および system jumbomtu コマンド( ジャンボ フレームのサポートの設定を参照)は、レイヤ 3 パケットの最大サイズを設定します(デフォルト値は 1,500 バイト、最大値は 9,216 バイト)。


すべての参加スイッチはレイヤ 3 に接続されている必要があり、ネットワーク パスが ERSPAN トラフィックのサイズをサポートしている必要があります。

ERSPAN はパケット分割をサポートしません。[do not fragment] ビットは、ERSPAN パケットの IP ヘッダー内で設定されます。ERSPAN 宛先セッションでは、分割された ERSPAN パケットを再構成できません。

ERSPAN トラフィックは、ネットワークのトラフィック負荷条件の影響を受けます。ERSPAN パケットの IP precedence または DSCP 値を設定することで、QoS において ERSPAN トラフィックを優先できます。

ERSPAN トラフィックでサポートされる唯一の宛先は、PFC3 上の ERSPAN 宛先セッションです。

スイッチ上のすべての ERSPAN 送信元セッションには、同一の起点 IP アドレスを使用する必要があります。これは、 origin ip address コマンドによって設定します(ERSPAN 送信元セッションの設定を参照)。

スイッチ上のすべての ERSPAN 宛先セッションは、同じ宛先インターフェイス上の同一の IP アドレスを使用する必要があります。宛先インターフェイスの IP アドレスは、 ip address コマンドを使用して入力します(ERSPAN 宛先セッションの設定を参照)。

ERSPAN 送信元セッションの宛先 IP アドレス(宛先スイッチのインターフェイス上で設定する必要がある)は、ERSPAN 宛先セッションが宛先ポートまで送信するトラフィックの送信元です。 ip address コマンドを使用して、送信元セッションおよび宛先セッションの両方に同一のアドレスを設定します。

ERSPAN ID は、様々な ERSPAN 送信元セッションから送られ、同一の宛先 IP アドレスに到着した ERSPAN トラフィックを区別します。

ローカル SPAN、RSPAN、および ERSPAN の設定

ここでは、ローカル SPAN、RSPAN、および ERSPAN の設定手順について説明します。

「宛先ポートの許可リストの設定(任意)」

「ローカル SPAN の設定」

「RSPAN の設定」

「ERSPAN の設定」

「ローカル SPAN および RSPAN の送信元 VLAN フィルタリングの設定」

「無条件トランクとしての宛先ポートの設定」

「宛先トランク ポートの VLAN フィルタリングの設定」

「設定の確認」

「設定例」

宛先ポートの許可リストの設定(任意)

ポートを誤って宛先として設定してしまうことがないように、宛先として有効なポートの一覧を示す許可リストを作成できます。宛先ポートの許可リストを設定すると、許可リスト内のポートだけが宛先として設定できるようになります。

宛先ポートの許可リストを設定するには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

Router(config)# monitor permit-list

宛先ポートの許可リストの使用をイネーブルにします。

ステップ 3

Router(config)# no monitor permit-list

宛先ポートの許可リストの使用をディセーブルにします。

ステップ 4

Router(config)# monitor permit-list destination interface type 1 slot/port [ - port ] [ , type 1 slot/port - port ]

宛先ポートの許可リストを設定するか、または既存の宛先ポート許可リストに追加します。

ステップ 5

Router(config)# no monitor permit-list destination interface type 1 slot/port [ - port ] [ , type 1 slot/port - port ]

既存の宛先ポート許可リストを削除または消去します。

ステップ 6

Router(config)# do show monitor permit-list

設定を確認します。

1.type = ethernetfastethernetgigabitethernet、または tengigabitethernet

次の例では、ポート GigabitEthernet 5/1 ~ 5/4、および 6/1 を含む宛先ポート許可リストを設定します。

Router# configure terminal
Router(config)# monitor permit-list
Router(config)# monitor permit-list destination interface gigabitethernet 5/1-4, gigabitethernet 6/1
 

次に、設定を確認する例を示します。

Router(config)# do show monitor permit-list
SPAN Permit-list :Admin Enabled
Permit-list ports :Gi5/1-4,Gi6/1
 

ローカル SPAN の設定

ローカル SPAN は、個別の送信元および宛先のセッションを使用しません。ローカル SPAN セッションを設定するには、同じセッション番号のローカル SPAN 送信元および宛先を設定します。ローカル SPAN セッションを設定するには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

Router(config)# monitor session local_span_session_number source {{ single_interface | interface_list | interface_range | mixed_interface_list | single_vlan | vlan_list | vlan_range | mixed_vlan_list } [ rx | tx | both ]}}

ローカル SPAN 送信元セッション番号と送信元ポートまたは VLAN を対応付けて、モニタするトラフィックの方向を選択します。

ステップ 3

Router(config)# monitor session local_span_session_number destination { single_interface | interface_list | interface_range | mixed_interface_list }

ローカル SPAN セッション番号と宛先ポートを対応付けます。

Router(config)# no monitor session { session_number | all | local | range session_range [[, session_range ],...]}

モニタ設定を消去します。

ローカル SPAN セッションを設定する際は、次の点に注意してください。

local_span_session_number は 1 ~ 66 の範囲で指定できます。

single_interface interface type slot / port の形式で、 type は、 ethernet fastethernet gigabitethernet 、または tengigabitethernet になります。

interface_list single_interface , single_interface , single_interface ...です。


) 各リストでは、カンマの前後にスペースを入れる必要があります。各範囲では、ダッシュの前後にスペースを入れる必要があります。


interface_range interface type slot / first_port - last_port です。

mixed_interface_list は、順不同で single_interface , interface_range , ...です。

single_vlan は、単一の VLAN の ID 番号です。

vlan_list single_vlan , single_vlan , single_vlan ...です。

vlan_range は、 first_vlan_ID - last_vlan_ID です。

mixed_vlan_list は、順不同で single_vlan , vlan_range , ...です。

モニタ対象トラフィックが宛先ポートを出る際、タグ付けを行うには、宛先ポートを無条件にトランクに設定してから、そのポートを宛先として設定します(無条件トランクとしての宛先ポートの設定を参照)。

モニタ セッションを消去する際は、次の点に注意してください。

他のパラメータを指定しないで入力された no monitor session number コマンドは、セッションの session_number を消去します。

session_range first_session_number - last_session_number です。


) no monitor session range コマンドでは、ダッシュの前後にスペースを入れません。複数の範囲を入力する場合、カンマの前後にスペースを入れないでください。


次に、セッション 1 の双方向送信元として、ポート FastEthernet 5/1 を設定する例を示します。

Router(config)# monitor session 1 source interface fastethernet 5/1
 

次に、SPAN セッション 1 の宛先として、ポート FastEthernet 5/48 を設定する例を示します。

Router(config)# monitor session 1 destination interface fastethernet 5/48
 

追加の例については、「設定例」を参照してください。

RSPAN の設定

RSPAN では、1 つのスイッチで送信元セッションを使用し、別のスイッチで宛先セッションを使用します。ここでは、RSPAN セッションの設定手順について説明します。

「RSPAN VLAN の設定」

「RSPAN 送信元セッションの設定」

「RSPAN 宛先セッションの設定」

RSPAN VLAN の設定

VLAN を RSPAN VLAN として設定するには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

Router(config)# vlan vlan_ID {[- vlan_ID ]|[, vlan_ID ])

単独のイーサネット VLAN、イーサネット VLAN の範囲、またはカンマ区切りをした複数のイーサネット VLAN のリストを作成または変更します(スペースは挿入しないでください)。

ステップ 3

Router(config-vlan)# remote-span

VLAN を RSPAN VLAN として設定します。

Router(config-vlan)# no remote-span

RSPAN VLAN の設定を消去します。

ステップ 4

Router(config-vlan)# end

VLAN データベースを更新して、イネーブル EXEC モードに戻ります。

RSPAN 送信元セッションの設定

RSPAN 送信元セッションを設定するには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

Router(config)# monitor session RSPAN_source_session_number source {{ single_interface | interface_list | interface_range | mixed_interface_list | single_vlan | vlan_list | vlan_range | mixed_vlan_list } [ rx | tx | both ]}}

RSPAN 送信元セッションの番号と送信元ポートまたは VLAN を対応付けて、モニタするトラフィックの方向を選択します。

ステップ 3

Router(config)# monitor session RSPAN_source_session_number destination remote vlan rspan_vlan_ID

RSPAN 送信元セッションの番号と RSPAN VLAN を対応付けます。

ステップ 4

Router(config)# no monitor session { session_number | all | range session_range [[, session_range ],...] | remote }

モニタ設定を消去します。

モニタ セッションを設定する際は、次の点に注意してください。

RSPAN VLAN を設定するには、「RSPAN VLAN の設定」を参照してください。

RSPAN_source_span_session_number は 1 ~ 66 の範囲で指定できます。

single_interface interface type slot / port の形式で、 type は、 ethernet fastethernet gigabitethernet 、または tengigabitethernet になります。

interface_list single_interface , single_interface , single_interface ...です。


) 各リストでは、カンマの前後にスペースを入れる必要があります。各範囲では、ダッシュの前後にスペースを入れる必要があります。


interface_range interface type slot / first_port - last_port です。

mixed_interface_list は、順不同で single_interface , interface_range , ...です。

single_vlan は、単一の VLAN の ID 番号です。

vlan_list single_vlan , single_vlan , single_vlan ...です。

vlan_range は、 first_vlan_ID - last_vlan_ID です。

mixed_vlan_list は、順不同で single_vlan , vlan_range , ...です。

モニタ セッションを消去する際は、次の点に注意してください。

他のパラメータを指定しないで入力された no monitor session number コマンドは、セッションの session_number を消去します。

session_range first_session_number - last_session_number です。


) no monitor session range コマンドでは、ダッシュの前後にスペースを入れません。複数の範囲を入力する場合、カンマの前後にスペースを入れないでください。


次に、セッション 2 の送信元として、ポート FastEthernet 5/2 を設定する例を示します。

Router(config)# monitor session 2 source interface fastethernet 5/2
 

次に、RSPAN VLAN 200 をセッション 2 の宛先として設定する例を示します。

Router(config)# monitor session 2 destination remote vlan 200
 

追加の例については、「設定例」を参照してください。

RSPAN 宛先セッションの設定


) RSPAN 送信元セッション スイッチ上に RSPAN 宛先セッションを設定して、RSPAN トラフィックをローカルにモニタすることができます。


RSPAN 宛先セッションを設定するには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

Router(config)# monitor session RSPAN_destination_session_number source remote vlan rspan_vlan_ID

RSPAN 宛先セッション番号と RSPAN VLAN を対応付けます。

ステップ 3

Router(config)# monitor session RSPAN_destination_session_number destination { single_interface | interface_list | interface_range | mixed_interface_list }}

RSPAN 宛先セッション番号と宛先ポートを対応付けます。

ステップ 4

Router(config)# no monitor session { session_number | all | range session_range [[, session_range ],...] | remote }

モニタ設定を消去します。

モニタ セッションを設定する際は、次の点に注意してください。

モニタ対象トラフィックにタグ付けをするには、ポートを無条件にトランクに設定してから、そのポートを宛先として設定する必要があります(無条件トランクとしての宛先ポートの設定を参照)。

RSPAN_destination_span_session_number は 1 ~ 66 の範囲で指定できます。

single_interface interface type slot / port の形式で、 type は、 ethernet fastethernet gigabitethernet 、または tengigabitethernet になります。

interface_list single_interface , single_interface , single_interface ...です。


) 各リストでは、カンマの前後にスペースを入れる必要があります。各範囲では、ダッシュの前後にスペースを入れる必要があります。


interface_range interface type slot / first_port - last_port です。

mixed_interface_list は、順不同で single_interface , interface_range , ...です。

モニタ セッションを消去する際は、次の点に注意してください。

他のパラメータを指定しないで入力された、no monitor session number コマンドは、セッションの session_number を消去します。

session_range first_session_number - last_session_number です。


) no monitor session range コマンドでは、ダッシュの前後にスペースを入れません。複数の範囲を入力する場合、カンマの前後にスペースを入れないでください。


次に、RSPAN VLAN 200 をセッション 3 の送信元として設定する例を示します。

Router(config)# monitor session 3 source remote vlan 200
 

次に、セッション 3 の宛先として、ポート FastEthernet 5/47 を設定する例を示します。

Router(config)# monitor session 3 destination interface fastethernet 5/47
 

追加の例については、「設定例」を参照してください。

ERSPAN の設定

ERSPAN では、個別の送信元セッションおよび宛先セッションを使用します。送信元セッションと宛先セッションは、異なるスイッチ上に設定します。ここでは、ERSPAN セッションの設定手順について説明します。

「ERSPAN 送信元セッションの設定」

「ERSPAN 宛先セッションの設定」


) PFC3 を使用する場合は、ERSPAN は Release12.2(18)SXE 以降のリリースでサポートされます(ERSPAN に関する注意事項および制約事項を参照)。


ERSPAN 送信元セッションの設定

ERSPAN 送信元セッションを設定するには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

Router(config)# monitor session ERSPAN_source_session_number type erspan-source

ERSPAN 送信元セッション番号を設定し、このセッションに対する ERSPAN 送信元セッション コンフィギュレーション モードを開始します。

Router(config)# no monitor session { session_number | all | range session_range [[, session_range ],...]}

モニタ設定を消去します。

ステップ 3

Router(config-mon-erspan-src)# description session_description

(任意)ERSPAN 送信元セッションの説明を入力します。

ステップ 4

Router(config-mon-erspan-src)# shutdown

(デフォルト)ERSPAN 送信元セッションを非アクティブにします。

Router(config-mon-erspan-src)# no shutdown

ERSPAN 送信元セッションをアクティブにします。

ステップ 5

Router(config-mon-erspan-src)# source {{ single_interface | interface_list | interface_range | mixed_interface_list | single_vlan | vlan_list | vlan_range | mixed_vlan_list } [ rx | tx | both ]}

ERSPAN 送信元セッションの番号と送信元ポートまたは VLAN を対応付けて、モニタするトラフィックの方向を選択します。

ステップ 6

Router(config-mon-erspan-src)# filter single_vlan | vlan_list | vlan_range | mixed_vlan_list

(任意)ERSPAN 送信元がトランク ポートである場合、送信元 VLAN フィルタリングを設定します。

ステップ 7

Router(config-mon-erspan-src)# destination

ERSPAN 送信元セッションの宛先コンフィギュレーション モードを開始します。

ステップ 8

Router(config-mon-erspan-src-dst)# ip address ip_address

ERSPAN フローの宛先 IP アドレスを設定します。これは、宛先スイッチのインターフェイス上でも設定する必要があるほか、ERSPAN 宛先セッションの設定でも入力する必要があります(ERSPAN 宛先セッションの設定ステップ 7 を参照)。

ステップ 9

Router(config-mon-erspan-src-dst)# erspan-id ERSPAN_flow_id

ERSPAN トラフィックを識別するため、送信元および宛先セッションで使用される ID 番号を設定します。これは、ERSPAN 宛先セッションの設定でも入力する必要があります(ERSPAN 宛先セッションの設定ステップ 8 を参照)。

ステップ 10

Router(config-mon-erspan-src-dst)# origin ip address ip_address [ force ]

ERSPAN トラフィックの送信元として使用される IP アドレスを設定します。

ステップ 11

Router(config-mon-erspan-src-dst)# ip ttl ttl_value

(任意)ERSPAN トラフィック内のパケットの IP Time to Live(TTL)値を設定します。

ステップ 12

Router(config-mon-erspan-src-dst)# ip prec ipp_value

(任意)ERSPAN トラフィック内のパケットの IP precedence 値を設定します。

ステップ 13

Router(config-mon-erspan-src-dst)# ip dscp dscp_value

(任意)ERSPAN トラフィック内のパケットの IP DSCP 値を設定します。

ステップ 14

Router(config-mon-erspan-src-dst)# vrf vrf_name

(任意)グローバル ルーティング テーブルの代わりに使用する VRF 名を設定します。

ステップ 15

Router(config-mon-erspan-src-dst)# end

コンフィギュレーション モードを終了します。

モニタ セッションを設定する際は、次の点に注意してください。

session_description には最大 240 文字を使用できます。ただし、特殊文字またはスペースは使用できません。


description コマンドに続けて、240 文字を入力できます。


ERSPAN_source_span_session_number は 1 ~ 66 の範囲で指定できます。

single_interface interface type slot / port の形式で、 type は、 ethernet fastethernet gigabitethernet 、または tengigabitethernet になります。

interface_list single_interface , single_interface , single_interface ...です。


) 各リストでは、カンマの前後にスペースを入れる必要があります。各範囲では、ダッシュの前後にスペースを入れる必要があります。


interface_range interface type slot / first_port - last_port です。

mixed_interface_list は、順不同で single_interface , interface_range , ...です。

single_vlan は、単一の VLAN の ID 番号です。

vlan_list single_vlan , single_vlan , single_vlan ...です。

vlan_range は、 first_vlan_ID - last_vlan_ID です。

mixed_vlan_list は、順不同で single_vlan , vlan_range , ...です。

ERSPAN_flow_id は 1 ~ 1023 の範囲で指定できます。

1 つのスイッチのすべての ERSPAN 送信元セッションは、同一の送信元 IP アドレスを使用する必要があります。スイッチ上ですべての ERSPAN 送信元セッションに設定された起点 IP アドレスを変更するには、 origin ip address ip_address force コマンドを入力します。

ttl_value は 1 ~ 255 の範囲で指定できます。

ipp_value は 0 ~ 7 の範囲で指定できます。

dscp_value は 0 ~ 63 の範囲で指定できます。

モニタ セッションを消去する際は、次の点に注意してください。

他のパラメータを指定しないで入力された no monitor session number コマンドは、セッションの session_number を消去します。

session_range first_session_number - last_session_number です。


) no monitor session range コマンドでは、ダッシュの前後にスペースを入れません。複数の範囲を入力する場合、カンマの前後にスペースを入れないでください。


次の例は、ポート GigabitEthernet 4/1 からの双方向トラフィックをモニタするようにセッション 3 を設定する方法を示します。

Router(config)# monitor session 3 type erspan-source
Router(config-mon-erspan-src)# source interface gigabitethernet 4/1
Router(config-mon-erspan-src)# destination
Router(config-mon-erspan-src-dst)# ip address 10.1.1.1
Router(config-mon-erspan-src-dst)# origin ip address 20.1.1.1
Router(config-mon-erspan-src-dst)# erspan-id 101
 

追加の例については、「設定例」を参照してください。

ERSPAN 宛先セッションの設定


) ERSPAN トラフィックをローカルにモニタすることはできません。


ERSPAN 宛先セッションを設定するには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

Router(config)# monitor session ERSPAN_destination_session_number type erspan-destination

ERSPAN 宛先セッション番号を設定し、このセッションに対する ERSPAN 宛先セッション コンフィギュレーション モードを開始します。

Router(config)# no monitor session { session_number | all | range session_range [[, session_range ],...]}

モニタ設定を消去します。

ステップ 3

Router(config-mon-erspan-dst)# description session_description

(任意)ERSPAN 宛先セッションの説明を入力します。

ステップ 4

Router(config-mon-erspan-dst)# shutdown

(デフォルト)ERSPAN 宛先セッションを非アクティブにします。

Router(config-mon-erspan-dst)# no shutdown

ERSPAN 宛先セッションをアクティブにします。

ステップ 5

Router(config-mon-erspan-dst)# destination { single_interface | interface_list | interface_range | mixed_interface_list }}

ERSPAN 宛先セッション番号と宛先ポートを対応付けます。

ステップ 6

Router(config-mon-erspan-dst)# source

ERSPAN 宛先セッションの送信元コンフィギュレーション モードを開始します。

ステップ 7

Router(config-mon-erspan-dst-src)# ip address ip_address [ force ]

ERSPAN フローの宛先 IP アドレスを設定します。これは、ローカル インターフェイス上のアドレスであり、「ERSPAN 送信元セッションの設定」ステップ 8 で入力したアドレスと一致する必要があります。

ステップ 8

Router(config-mon-erspan-dst-src)# erspan-id ERSPAN_flow_id

ERSPAN トラフィックを識別するため、宛先および宛先セッションで使用される ID 番号を設定します。これは、「ERSPAN 送信元セッションの設定」ステップ 9 で入力した ID と一致する必要があります。

ステップ 9

Router(config-mon-erspan-dst-src)# vrf vrf_name

(任意)グローバル ルーティング テーブルの代わりに使用する VRF 名を設定します。

ステップ 10

Router(config-mon-erspan-dst-src)# end

コンフィギュレーション モードを終了します。

モニタ セッションを設定する際は、次の点に注意してください。

ERSPAN_destination_span_session_number は 1 ~ 66 の範囲で指定できます。

single_interface interface type slot / port の形式で、 type は、 ethernet fastethernet gigabitethernet 、または tengigabitethernet になります。

interface_list single_interface , single_interface , single_interface ...です。


) 各リストでは、カンマの前後にスペースを入れる必要があります。各範囲では、ダッシュの前後にスペースを入れる必要があります。


interface_range interface type slot / first_port - last_port です。

mixed_interface_list は、順不同で single_interface , interface_range , ...です。

スイッチ上のすべての ERSPAN 宛先セッションは、同じ宛先インターフェイス上の同一の IP アドレスを使用する必要があります。スイッチ上ですべての ERSPAN 宛先セッションに設定された IP アドレスを変更するには、 ip address ip_address force コマンドを入力します。


) また、すべての ERSPAN 送信元セッションの宛先 IP アドレスを変更する必要があります(ERSPAN 送信元セッションの設定ステップ 8 を参照)。


ERSPAN_flow_id は 1 ~ 1023 の範囲で指定できます。

モニタ セッションを消去する際は、次の点に注意してください。

他のパラメータを指定しないで入力された no monitor session number コマンドは、セッションの session_number を消去します。

session_range first_session_number - last_session_number です。


) no monitor session range コマンドでは、ダッシュの前後にスペースを入れません。複数の範囲を入力する場合、カンマの前後にスペースを入れないでください。


次の例は、IP アドレス 10.1.1.1 に着信した ERSPAN ID 101 トラフィックを、ポート GigabitEthernet 2/1 に送信するように ERSPAN 宛先セッションを設定する方法を示します。

Router(config)# monitor session 3 type erspan-destination
Router(config-erspan-dst)# destination interface gigabitethernet 2/1
Router(config-erspan-dst)# source
Router(config-erspan-dst-src)# ip address 10.1.1.1
Router(config-erspan-dst-src)# erspan-id 101
 

追加の例については、「設定例」を参照してください。

ローカル SPAN および RSPAN の送信元 VLAN フィルタリングの設定

送信元 VLAN フィルタリングは、送信元がトランク ポートの場合に特定の VLAN をモニタします。


) ERSPAN の送信元 VLAN フィルタリングを設定する方法については、「ERSPAN の設定」を参照してください。


ローカル SPAN または RSPAN 送信元がトランク ポートである場合、送信元 VLAN フィルタリングを設定するには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

Router(config)# monitor session session_number filter single_vlan | vlan_list | vlan_range | mixed_vlan_list

ローカル SPAN または RSPAN 送信元がトランク ポートである場合、送信元 VLAN フィルタリングを設定します。

Router(config)# no monitor session session_number filter single_vlan | vlan_list | vlan_range | mixed_vlan_list

送信元 VLAN フィルタリングを消去します。

送信元 VLAN フィルタリングを設定する場合は、次の点に注意してください。

single_vlan は、単一の VLAN の ID 番号です。

vlan_list single_vlan , single_vlan , single_vlan ...です。

vlan_range は、 first_vlan_ID - last_vlan_ID です。

mixed_vlan_list は、順不同で single_vlan , vlan_range , ...です。

次に、送信元がトランク ポートである場合に、VLAN 1 ~ 5 および VLAN 9 をモニタする例を示します。

Router(config)# monitor session 2 filter vlan 1 - 5 , 9
 

無条件トランクとしての宛先ポートの設定

モニタ対象トラフィックが宛先ポートを出る際、タグ付けを行うには、宛先ポートをトランクとして設定します。

宛先ポートをトランクとして設定するには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

Router(config)# interface type 2 slot/port

設定する LAN ポートを選択します。

ステップ 3

Router(config-if)# switchport

LAN ポートをレイヤ 2 スイッチング用に設定します(この操作は LAN ポートがレイヤ 2 スイッチング用に設定されていない場合にのみ必要です)。

ステップ 4

Router(config-if)# switchport trunk encapsulation { isl | dot1q }

カプセル化を設定して、レイヤ 2 スイッチング ポートを ISL または 802.1Q トランクとして設定します。

ステップ 5

Router(config-if)# switchport mode trunk

無条件にポートをトランクに設定します。

ステップ 6

Router(config-if)# switchport nonegotiate

DTP を使用しないようにトランクを設定します。

2.type = ethernetfastethernetgigabitethernet、または tengigabitethernet

次に、ポートを無条件 IEEE 802.1Q トランクとして設定する例を示します。

Router(config)# interface fastethernet 5/12
Router(config-if)# switchport
Router(config-if)# switchport trunk encapsulation dot1q
Router(config-if)# switchport mode trunk
Router(config-if)# switchport nonegotiate

宛先トランク ポートの VLAN フィルタリングの設定


) トランクで VLAN をフィルタリングするだけでなく、許可される VLAN リストをアクセス ポートに適用することもできます。


Release 12.2(18)SXD 以降のリリースでは、宛先ポートがトランクの場合、トランクで許可される VLAN のリストを使用して宛先ポートから送信されるトラフィックをフィルタリングできます。(CSCeb01318)

宛先トランク ポート VLAN フィルタリングを使用すると、すべての宛先ポートがすべての送信元からのすべてのトラフィックを受信するという制約がなくなります。宛先トランク ポート VLAN フィルタリングでは、各宛先トランク ポートからネットワーク アナライザに送信されたトラフィックを、VLAN 単位で選択できます。

宛先トランク ポートに宛先トランク ポート VLAN フィルタリングを設定するには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

Router(config)# interface type 3 slot/port

設定する宛先トランク ポートを選択します。

ステップ 3

Router(config-if)# switchport trunk allowed vlan { add | except | none | remove } vlan [, vlan [, vlan [,...]]

トランク上で許可される VLAN のリストを設定します。

3.type = ethernetfastethernetgigabitethernet、または tengigabitethernet

宛先トランク ポートで許可される VLAN のリストを設定する際は、次の点に注意してください。

vlan パラメータは、1 ~ 4094 の範囲の単一の VLAN 番号、または 2 つの VLAN 番号(小さい番号が先、ダッシュで区切る)で指定する VLAN 範囲です。カンマで区切った vlan パラメータの間、またはダッシュで指定した範囲の間には、スペースを入れないでください。

デフォルトでは、すべての VLAN が許可されます。

すべての VLAN を許可されたリストから削除するには、 switchport trunk allowed vlan none コマンドを入力します。

VLAN を許可されたリストに追加するには、 switchport trunk allowed vlan add コマンドを入力します。

SPAN 設定を削除せずに許可された VLAN リストを変更できます。

次に、複数の VLAN が送信元で複数のトランク ポートが宛先であるローカル SPAN セッションを設定する例を示します。宛先トランク ポート VLAN フィルタリングは SPAN トラフィックをフィルタリングし、各宛先トランク ポートが、1 つの VLAN からトラフィックを伝送します。

interface GigabitEthernet1/1
description SPAN destination interface for VLAN 10
no ip address
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 10
switchport mode trunk
switchport nonegotiate
!
interface GigabitEthernet1/2
description SPAN destination interface for VLAN 11
no ip address
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 11
switchport mode trunk
switchport nonegotiate
!
interface GigabitEthernet1/3
description SPAN destination interface for VLAN 12
no ip address
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 12
switchport mode trunk
switchport nonegotiate
!
interface GigabitEthernet1/4
description SPAN destination interface for VLAN 13
no ip address
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 13
switchport mode trunk
switchport nonegotiate
!
monitor session 1 source vlan 10 - 13
monitor session 1 destination interface Gi1/1 ñ 4

設定の確認

設定を確認するには、 show monitor session コマンドを入力します。

次に、セッション 2 の設定を確認する例を示します。

Router# show monitor session 2
Session 2
------------
Type : Remote Source Session
 
Source Ports:
RX Only: Fa3/1
Dest RSPAN VLAN: 901
Router#
 

次に、セッション 2 の詳細を完全に表示する例を示します。

Router# show monitor session 2 detail
Session 2
------------
Type : Remote Source Session
 
Source Ports:
RX Only: Fa1/1-3
TX Only: None
Both: None
Source VLANs:
RX Only: None
TX Only: None
Both: None
Source RSPAN VLAN: None
Destination Ports: None
Filter VLANs: None
Dest RSPAN VLAN: 901

設定例

次に、RSPAN 送信元セッション 2 を設定する例を示します。

Router(config)# monitor session 2 source interface fastethernet1/1 - 3 rx
Router(config)# monitor session 2 destination remote vlan 901
 

次に、セッション 1 とセッション 2 の設定を消去する例を示します。

Router(config)# no monitor session range 1-2
 

次に、複数の送信元で RSPAN 送信元セッションを設定する例を示します。

Router(config)# monitor session 2 source interface fastethernet 5/15 , 7/3 rx
Router(config)# monitor session 2 source interface gigabitethernet 1/2 tx
Router(config)# monitor session 2 source interface port-channel 102
Router(config)# monitor session 2 source filter vlan 2 - 3
Router(config)# monitor session 2 destination remote vlan 901
 

次に、セッションの送信元を削除する例を示します。

Router(config)# no monitor session 2 source interface fastethernet 5/15 , 7/3
 

次に、セッションの送信元に対するオプションを削除する例を示します。

Router(config)# no monitor session 2 source interface gigabitethernet 1/2
Router(config)# no monitor session 2 source interface port-channel 102 tx
 

次に、セッションの VLAN フィルタリングを削除する例を示します。

Router(config)# no monitor session 2 filter vlan 3
 

次に、RSPAN 宛先セッション 8 の設定例を示します。

Router(config)# monitor session 8 source remote vlan 901
Router(config)# monitor session 8 destination interface fastethernet 1/2 , 2/3
 

次に、ERSPAN 送信元セッション 12 の設定例を示します。

monitor session 12 type erspan-source
description SOURCE_SESSION_FOR_VRF_GRAY
source interface Gi8/48 rx
destination
erspan-id 120
ip address 10.8.1.2
origin ip address 32.1.1.1
vrf gray
 

次に、ERSPAN 宛先セッション 12 の設定例を示します。

monitor session 12 type erspan-destination
description DEST_SESSION_FOR_VRF_GRAY
destination interface Gi4/48
source
erspan-id 120
ip address 10.8.1.2
vrf gray
 

次に、ERSPAN 送信元セッション 13 の設定例を示します。

monitor session 13 type erspan-source
source interface Gi6/1 tx
destination
erspan-id 130
ip address 10.11.1.1
origin ip address 32.1.1.1
 

次に、ERSPAN 宛先セッション 13 の設定例を示します。

monitor session 13 type erspan-destination
destination interface Gi6/1
source
erspan-id 130
ip address 10.11.1.1