Catalyst 6500 シリーズ スイッチ Cisco IOS ソフトウェア コンフィギュレーション ガイド Release 12.2SX
IPv4 MVPN サポートの設定
IPv4 MVPN サポートの設定
発行日;2012/01/12 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 11MB) | フィードバック

目次

IPv4 MVPN サポートの設定

MVPN の機能概要

MVPN の概要

マルチキャスト ルーティング/転送とマルチキャスト ドメイン

マルチキャスト分散ツリー

マルチキャスト トンネル インターフェイス

MVPN 用のPE ルータ ルーティング テーブルのサポート

マルチキャスト分散スイッチングのサポート

ハードウェア処理の IPv4 マルチキャスト

MVPN 設定時の注意事項および制約事項

MVPN の設定

入力マルチキャスト レプリケーション モードへの強制的な変更(任意)

MVRF インスタンスの設定

VRF エントリの設定

ルート識別子の設定

ルートターゲット拡張コミュニティの設定

デフォルト MDT の設定

データ MDT の設定(任意)

データ MDT ログ機能のイネーブル化

コンフィギュレーション例

VRF 情報の表示

マルチキャスト VRF ルーティングの設定

IPv4 マルチキャスト ルーティングのグローバルなイネーブル化

IPv4 マルチキャスト VRF ルーティングのイネーブル化

PIM VRF レジスタ メッセージの送信元アドレスの設定

PIM VRF RP アドレスの指定

MSDP ピアの設定

IPv4 マルチキャスト ヘッダー ストレージのイネーブル化

マルチキャスト ルートの最大数の設定

IPv4 マルチキャスト ルート フィルタリングの設定

コンフィギュレーション例

IPv4 マルチキャスト VRF ルーティング情報の表示

MVPN をサポートするためのマルチキャスト ルーティング用インターフェイスの設定

マルチキャスト ルーティングの設定の概要

インターフェイスでの PIM の設定

IPv4 VRF 転送用インターフェイスの設定

コンフィギュレーション例

MVPN のコンフィギュレーション例

デフォルト MDT のみを使用した MVPN コンフィギュレーション

デフォルト MDT とデータ MDT を使用した MVPN コンフィギュレーション

IPv4 MVPN サポートの設定

この章では、Catalyst 6500 シリーズ スイッチに IPv4 Multicast Virtual Private Network(MVPN; マルチキャスト仮想私設網)サポートを設定する手順について説明します。Release 12.2(18)SXE 以降のリリースでは、スイッチが PFC3B モードまたは PFC3BXL モードで動作している場合に MVPN がサポートされます。


) この章で使用しているコマンドの構文および使用方法の詳細については、次の URL で『Catalyst 6500 Series Switch Cisco IOS Command Reference』Release 12.2SX を参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/lan/cat6000/122sx/cmdref/index.htm


 

この章で説明する内容は、次のとおりです。

「MVPN の機能概要」

「MVPN 設定時の注意事項および制約事項」

「MVPN の設定」

MVPN の機能概要

ここでは MVPN について説明します。

「MVPN の概要」

「マルチキャスト ルーティング/転送とマルチキャスト ドメイン」

「マルチキャスト分散ツリー」

「マルチキャスト トンネル インターフェイス」

「MVPN 用のPE ルータ ルーティング テーブルのサポート」

「マルチキャスト分散スイッチングのサポート」

「ハードウェア処理の IPv4 マルチキャスト」

MVPN の概要

MVPN は、標準ベースの機能で、MPLS VPN クラウド全体に IPv4 マルチキャスト トラフィックを伝送します。Catalyst 6500 シリーズ スイッチの MVPN は、VPN を介してワイヤ速度でマルチキャスト トラフィックを転送するのに、IPv4 マルチキャスト トラフィックに対する既存の PFC ハードウェア サポートを使用します。MVPN は、レイヤ 3 IPv4 VPN を介した IPv4 マルチキャスト トラフィックのサポートを既存の IPv4 ユニキャスト サポートに追加します。

MVPN は、個別の VPN Routing and Forwarding(VRF; VPN ルーティング/転送)インスタンスのマルチキャスト パケットをルーティングし転送するだけでなく、サービス プロバイダー バックボーン全体に VPN トンネルを介してマルチキャスト パケットを伝送します。

MVPNは、IP-in-IP Generic Routing Encapsulation(GRE; 総称ルーティング カプセル化)トンネルに置き換わるものです。GRE トンネルは、簡単に拡張できるソリューションではなく、提供する粒度にも制限があります。

マルチキャスト ルーティング/転送とマルチキャスト ドメイン

MVPN は、マルチキャスト ルーティング情報を VRF テーブルに追加します。Provider Edge(PE; プロバイダー エッジ)ルータがマルチキャスト データまたは制御パケットを Customer Edge(CE; カスタマー エッジ)ルータから受信すると、Multicast VRF(MVRF; マルチキャスト VRF)内の情報に応じて転送が実行されます。


) MVRF は、Multicast over VRF-Lite とも呼ばれます。


各 MVRF では、特定の VRF インスタンスに必要なルーティング/転送情報を保持しています。MVRF は、マルチキャスト ルーティングがイネーブルになる以外は、既存の VRF と同じ方法で作成、設定されます。

マルチキャスト ドメインは、MPLS ネットワーク内で互いにマルチキャスト トラフィックを送信できるホストのセットを構成します。たとえば、特定のタイプのマルチキャスト トラフィックを全社の従業員に送信したい企業向けのマルチキャスト ドメインは、その企業に関連しているすべての CE ルータで構成されます。

マルチキャスト分散ツリー

MVPN 機能は、各マルチキャスト ドメインに対して少なくとも 1 つのMulticast Distribution Tree(MDT; マルチキャスト分散ツリー)を作成します。MDT は、異なる PE ルータにある同じ MVRF を相互接続するために必要な情報を提供します。

MVPN は、次の 2 種類の MDT をサポートします。

デフォルト MDT ― デフォルト MDT は、Protocol Independent Multicast(PIM)制御メッセージの持続的なチャネルで、特定のマルチキャスト ドメイン内にあるすべての PE ルータ間の低帯域幅ストリームです。デフォルト MDT にあるすべてのマルチキャスト トラフィックは、ドメイン内にあるすべての他の PE ルータに複製されます。各 PE ルータは、ドメイン内にある他のすべての PE ルータから論理的に PIM ネイバ(1 ホップ先)として認識されます。

データ MDT ― データ MDT はオプションです。これをイネーブルにすると、フルモーション動画など、すべての PE ルータに送信する必要のない高帯域幅伝送用の最適パスを提供するように、動的に作成されます。これにより、PE ルータ間で高帯域幅トラフィックのオンデマンド転送が可能になり、作成されるすべての高帯域幅ストリームによってすべての PE ルータがフラッディングしないようにできます。

データ MDT を作成するには、マルチキャスト ストリームを定期的にバックボーンに転送する各 PE ルータが、各デフォルト MDT で送信されるトラフィックを次のように検査します。

1. 各 PE ルータが定期的(ソフトウェア スイッチングで約 10 秒ごと、ハードウェア スイッチングで 90 秒ごと)にマルチキャスト トラフィックをサンプリングして、マルチキャスト ストリームが設定されたスレッシュホールドを超過しているかどうかを判別します(ストリームをサンプリングする時間によっては、最悪の場合、高帯域幅ストリームが検出されるまでに 180 秒かかる可能性があります)。


) データ MDT は、VRF マルチキャスト ルーティング テーブル内の(S, G)マルチキャスト ルート エントリに対してのみ作成されます。これらは、(*, G)エントリに対して作成されません。


2. 特定のマルチキャスト ストリームが定義されたスレッシュホールドを超過した場合、この特定のマルチキャスト トラフィックに対して送信側 PE ルータは動的にデータ MDT を作成します。

3. 次に送信側 PE ルータは DATA-MDT JOIN 要求(ポート 3232 への UDP メッセージ)を他の PE ルータに送信し、新しいデータ MDT について通知します。

4. 受信側 PE ルータは、VRF ルーティング テーブルを検査して、このデータ ストリームの受信対象がいるかどうかを判断します。いる場合、受信側 PE ルータは、ストリームを受け入れるために、PIM プロトコルを使用して(グローバル テーブル PIM インスタンス内にある)この特定のデータ MDT グループの PIM JOIN メッセージを伝送します。現在このストリームの対象がいないルータも、後でこのストリームを要求することがある場合に備えて情報をキャッシュし続けます。

5. DATA-MDT JOIN メッセージを送信してから 3 秒後に、送信側 PE ルータは高帯域幅マルチキャスト ストリームをデフォルト MDT から削除して、新しいデータ MDT の伝送を開始します。

6. 送信側 PE ルータは、マルチキャスト ストリームが定義したスレッシュホールドを超過し続ける間、DATA-MDT JOIN メッセージを 60 秒ごとに送信し続けます。ストリームがスレッシュホールドを 60 秒以上下回った場合、送信側 PE ルータは DATA-MDT JOIN メッセージの送信を停止して、ストリームをデフォルトの MDT に戻します。

7. 受信側ルータは、DATA-MDT JOIN メッセージを 3 分以上受信しなくなると、デフォルト MDT のキャッシュ情報を期限切れにします。

データ MDT は、MPLS VPN コア内で、最適なトラフィック転送を保証しながら VPN 内の高帯域ソースを許可します。


) DATA-MDT JOIN メッセージとその他のデータ MDT 作成および使用法に関する技術情報については、Eric C. Rosental のインターネット ドラフト『Multicast in MPLS/BGP IP VPNs』を参照してください。


以下の例では、サービス プロバイダーに San Jose、New York、および Dallas にオフィスを持つマルチキャスト カスタマーがいます。San Jose サイトでは、一方向のマルチキャスト プレゼンテーションを伝送します。サービス プロバイダー ネットワークは、このカスタマーに関連した 3 つのサイトすべてをサポートし、さらに他の企業の Houston サイトもサポートしています。

この企業のデフォルト MDT は、プロバイダー ルータ P1、P2、および P3 と、関連する PE ルータで構成されています。PE4 は MPLS コア内にあるこれらの他のルータと相互接続しています。ただし、PE4 は別のカスタマーに関連し、したがってデフォルト MDT の一部ではありません。

図26-1は、San Jose の外側にマルチキャスト ブロードキャストに加わるものがいない場合、つまりデフォルト MDT に沿って流れるデータがない場合の、このネットワークの状況を示します。各 PE ルータは、デフォルト MDT を介して他の PE ルータとの PIM 関係を維持するだけでなく、直接接続された PE ルータと PIM 関係も維持します。

図26-1 デフォルトのマルチキャスト分散ツリーの概要

 

New York の従業員がマルチキャスト セッションに加わる場合、New York サイトに関連づけられた PE ルータが Join メッセージを送信し、そのメッセージはマルチキャスト ドメインのデフォルト MDT に流れます。マルチキャスト セッション送信元(PE1)に関連付けられた PE ルータが要求を受信します。図26-2 に、PE ルータがマルチキャスト送信元(CE1a)に関連付けられた CE ルータに要求を転送する方法を示します。

図26-2 データ MDT の初期化

 

CE ルータ(CE1a)が関連づけられている PE ルータ(PE1)へマルチキャスト データの送信を開始し、データ MDT の作成される帯域幅スレッシュホールドを、マルチキャスト データが超過したことを認識します。そこで PE1 はデータ MDT を作成して、すべてのルータにデータ MDT に関する情報が含まれるデフォルト MDT を使用してメッセージを送信します。

約 3 秒後に PE1 は、特定のストリームに対して、データ MDT を使用してマルチキャスト データの送信を開始します。PE2 のみがこの送信元に関係するレシーバーがあるので、PE2 がデータ MDT に参加して、そのトラフィックを受信します。

マルチキャスト トンネル インターフェイス

PE ルータは、マルチキャスト ドメイン内の各 MVRF に対して Multicast Tunnel Interface(MTI; マルチキャスト トンネル インターフェイス)を作成します。MVRF は、MVRF とグローバル MVRF を接続するコンジットを提供するために、トンネル インターフェイスを使用してマルチキャスト ドメインにアクセスします。

ルータでは、MTI がクラス D マルチキャスト アドレスを持つトンネル インターフェイスです( interface tunnel コマンドを使用して作成されます)。この MVRF のデフォルト MDT で設定されているすべての PE ルータは、マルチキャスト ドメイン内にある他のすべての PE ルータに対して、各 PE ルータが PIM ネイバ(1 ホップ先)として認識されるような、論理ネットワークを作成します。この場合、各ルータ間の実際の物理的な距離は関係ありません。

MVRF が設定されると MTI は自動的に作成されます。BGP ピアリング アドレスは、MTI インターフェイス送信元アドレスとして割り当てられ、PIM プロトコルは自動的に各 MTI でイネーブルになります。

ルータがネットワークのカスタマー側からマルチキャスト パケットを受信すると、着信インターフェイスの VRF を使用してどの MVRF が受信すべきかを判断します。次に、ルータは GRE カプセル化を使用してパケットをカプセル化します。ルータがパケットをカプセル化すると、送信元アドレスをその BGP ピアリング インターフェイスに設定し、宛先アドレスをデフォルト MDT のマルチキャスト アドレス、または設定されている場合にはデータ MDT の送信元アドレスに設定します。次にルータは、適切な数の MTI インターフェイスに転送するために、必要に応じてパケットを複製します。

ルータが MTI インターフェースでパケットを受信すると、宛先アドレスを使用して適切なデフォルト MDT またはデータ MDT を識別し、その結果適切な MVRF を識別します。ここで、パケットのカプセルを開放してこれを該当するインターフェイスに転送して、必要な分だけ複製します。


) • MVPN MTI は、シスコ製ルータで一般的に使用されている他のトンネル インターフェイスとは違い、ポイントツーポイント インターフェイスではなく LAN インターフェイスとして分類されます。MTI インターフェイスは設定できませんが、show interface tunnel コマンドを使用してそのステータスを表示することはできます。

MTI インターフェイスは、もっぱら VPN トンネルを介したマルチキャスト トラフィックで使用されます。

トンネルはユニキャスト ルーテッド トラフィックは伝送しません。


 

MVPN 用のPE ルータ ルーティング テーブルのサポート

MVPN 機能をサポートする各 PE ルータは、VPN および MVPN トラフィックが正常にルーティングされるようにするために、以下のルーティング テーブルを使用します。

デフォルトのルーティング テーブル ― すべてのシスコ製ルータで使用される標準ルーティング テーブル。このテーブルには、バックボーン トラフィックや非 MPLS VPN ユニキャストおよびマルチキャスト トラフィック(GRE マルチキャスト トラフィックなど)で必要なルートが含まれています。

VRF テーブル ― 各 VRF インスタンスで作成されるルーティング テーブル。MPLS ネットワークにある VPN 間のユニキャスト トラフィックのルーティングに使用されます。

MVRF テーブル ― 各 VRF インスタンス用に作成されたマルチキャスト ルーティング テーブルおよびマルチキャスト ルーティング プロトコル インスタンス。ネットワークのマルチキャスト ドメインにある マルチキャスト トラフィックのルーティングに使用されます。またこのテーブルには、マルチキャスト ドメイン全体で使用されるマルチキャスト トンネル インターフェイスも含まれています。

マルチキャスト分散スイッチングのサポート

MVPN は、インターフェイス単位または VRF 単位でのマルチキャストをサポートする Multicast Distributed Switching(MDS; マルチキャスト分散スイッチング)をサポートしています。MDS を設定する際に、インターフェイス(ループバック インターフェイスを含む)に no ip mroute-cache コマンドが設定されていないことを確認する必要があります。

ハードウェア処理の IPv4 マルチキャスト

PFC3BXL または PFC3B モードは、VPN トラフィックを介した IPv4 マルチキャストのハードウェア アクセラレーションをサポートしています。これにより、マルチキャスト トラフィックを MSFC3 CPU の利用率を増やすことなくワイヤ速度で該当する VPN に転送します。

カスタマー VRF では、PFC3BXL または PFC3B モードのハードウェア アクセラレーションは、PIM dence(密)、PIM sparse(疎)、PIM 双方向、PIM Source-Specific Multicast(SSM)モードのマルチキャスト トラフィックをサポートします。

サービス プロバイダー コアでは、PFC3BXL または PFC3B モードのハードウェア アクセラレーションは、PIM sparse(疎)、PIM 双方向、PIM SSM モードのマルチキャスト トラフィックをサポートします。サービス プロバイダー コアでは、PFC3BXL または PFC3B モードのハードウェア アクセラレーションは、PIM dense(密)モードのマルチキャスト トラフィックをサポートしません。

MVPN 設定時の注意事項および制約事項

MVPN を設定する際に、以下の注意事項と制約事項に従ってください。

Release 12.2(18)SXE 以降のリリースでは、スイッチが PFC3B モードまたは PFC3BXL モードで動作している場合に MVPN がサポートされます。Supervisor Engine 2 は、MVPN をサポートしていません。

マルチキャスト ドメイン内にあるすべての PE ルータは、MVPN 機能をサポートする Cisco IOS ソフトウェア イメージを実行している必要があります。PE ルータおよび CE ルータについては、MVPN サポートの要件はありません。

IPv4 マルチキャスト トラフィックのサポートは、すべてのバックボーン ルータでイネーブルでなければなりません。

Border Gateway Protocol(BGP)ルーティング プロトコルは、マルチキャスト トラフィックをサポートするすべてのルータに設定され、動作可能でなければなりません。さらに、ネットワークで MDT を使用できるようにするためには、( neighbor send-community both または neighbor send-community extended コマンドを使用して)BGP 拡張コミュニティがイネーブルでなければなりません。

MVPN が設定される場合、入力レプリケーションのみがサポートされます。スイッチが現在出力レプリケーション用に設定されている場合、最初に MVRF が設定されるときに強制的に入力レプリケーションになります。

スイッチが PE として動作していて、Time to Live(TTL)値が 2 のカスタマー ルータからのマルチキャスト パケットを受信した場合、パケットは廃棄され、カプセル化して MVPN リンクに転送されることはありません。そのようなパケットは通常 MVPN リンクのもう一方の端にある PE で廃棄されるため、トラフィック フローには影響しません。

コア マルチキャスト ルーティングで SSM を使用している場合、データとデフォルトの MDT グループが IPv4 アドレスの SSM 範囲に設定されていなければなりません。

BGP ピアリングのアップデート送信元インターフェイスは、デフォルト MDT を適切に設定するために、ルータ上にあるすべての BGP ピアリングと同じでなければなりません。BGP ピアリングのループバック アドレスを使用する場合、PIM sparse(疎)モードがループバック アドレスでイネーブルでなければなりません。

分散マルチキャスト スイッチングがこれをサポートするプラットフォーム上で機能するために、 ip mroute-cache コマンドが、BGP ピアリング インターフェイスとして使用されるループバック インターフェイスでイネーブルになっていなければなりません。これらのインターフェイスには、 no ip mroute-cache コマンドが存在しては いけません

dense(密)モード マルチキャスト トラフィックのフラッディングおよびプルーニング特性により、データ MDT は定期的にアクティブになり、ティアダウンされるため、VRF PIM dense(密)モード マルチキャスト ストリームに対してデータ MDT は作成されません。

送信元情報が利用できないため、VRF PIM 双方向モードに対してデータ MDT は作成されません。

MVPN は複数の BGP ピアリング アップデート送信元をサポートせず、これを設定すると MVPN RPF チェック機能が中断する可能性があります。MVPN トンネルの送信元 IPv4 アドレスは、BGP ピアリング アップデート送信元に使用されているもっとも高い IPv4 アドレスによって決定されます。この IPv4 アドレスが、リモート PE ルータを持つ BGP ピアリング アドレスとして使用されている IPv4 アドレスではない場合、MVPN は適切に機能しません。

MDT トンネルはユニキャスト トラフィックは伝送しません。

MVPN が MPLS VPN ネットワークのインフラストラクチャを使用していても、VPN を介したマルチキャスト トラフィックに MPLS タグやラベルは適用できません。

デフォルト MDT で設定されている各 MVRF は、3 種類の隠し VLAN(カプセル化、カプセル開放、インターフェイス用にそれぞれ 1 つ)に加えて、外部の、ユーザから見える VLAN を使用しています。つまり、最大 1,000 の MVRF が各ルータでサポートされるということです(MDT が設定されていない MVRF が 1 つの内部 VLAN を使用しているので、未使用 MVRF は VLAN 割り当てを節約するために削除されます)。

MVPN が MPLS を使用しているので、MVPN は RPR と RPR+ 冗長モードのみをサポートします。Release 12.2(18)SXD およびリビルドでは、MPLS は NSF/SSO 冗長モードと共存できますが、ステートフル MPLS スイッチオーバーのサポートはありません。

すでに MPLS VPN ネットワークに VRF のネットワークが含まれている場合、MVRF トラフィックをサポートできるようにこれを削除したり再作成したりする必要はありません。代わりに、以下の手順で示しているように、 mdt default および mdt data コマンドを設定して VRF を介したマルチキャスト トラフィックをイネーブルにします。

BGP は、マルチキャスト トラフィックを送受信するすべてのルータに設定済みで、動作可能である必要があります。さらに、ネットワークで MDT を使用できるようにするためには、( neighbor send-community both または neighbor send-community extended コマンドを使用して)BGP 拡張コミュニティがイネーブルでなければなりません。

特定の VPN 接続をサポートする各 PE ルータに、同じ MVRF が設定されていなければなりません。

特定の MVRF をサポートする各 PE ルータは、同じ mdt default コマンドで設定されていなければなりません。

MVPN が設定される場合、スイッチでは入力レプリケーションのみがサポートされます。スイッチが現在出力レプリケーション用に設定されている場合、最初に MVRF が設定されるときに強制的に入力レプリケーションになります。スイッチが現在出力レプリケーション用に設定されている場合、トラフィックの中断が最小限になるように、スケジュールされたメンテナンス期間にのみこのタスクを実行することを推奨します。

MVPN の設定

ここでは、MVPN の設定手順について説明します。

「入力マルチキャスト レプリケーション モードへの強制的な変更(任意)」

「MVRF インスタンスの設定」

「マルチキャスト VRF ルーティングの設定」

「MVPN をサポートするためのマルチキャスト ルーティング用インターフェイスの設定」


) これらの設定タスクでは、BGP がマルチキャスト トラフィックを送受信するすべてのルータに設定済みで、動作可能であることを想定しています。さらに、ネットワークで MDT を使用できるようにするためには、(neighbor send-community both または neighbor send-community extendedコマンドを使用して)BGP 拡張コミュニティがイネーブルでなければなりません。


入力マルチキャスト レプリケーション モードへの強制的な変更(任意)

MVPN 機能は入力マルチキャスト レプリケーション モードのみをサポートします。スイッチが現在出力レプリケーション用に設定されている場合、最初に MVRF が設定されるときに強制的に入力レプリケーションになります。このレプリケーション モードの変更によって、ハードウェア内の転送エントリがすべて自動的に削除され、テーブル エントリが再構築されるまでスイッチが一時的にソフトウェア スイッチングに強制的に変更されます。

カスタマー トラフィックが停止しないようにするために、MVRFの設定前には、スイッチがすでに入力マルチキャスト レプリケーション モードになっていることを確認することを推奨します。

次に、現在のマルチキャスト レプリケーション モードを確認する例を示します。

Router# show mls ip multicast capability
 
Current mode of replication is Ingress
auto replication mode detection is ON
 
Slot Multicast replication capability
2 Egress
5 Egress
6 Egress
8 Ingress
9 Ingress
 
Router#
 

現在のレプリケーション モードが出力であるか、いずれかのスイッチング モジュールが出力レプリケーション モードに対応している場合、カスタマー トラフィックの停止を最小限にするために、スケジュールされたメンテナンス期間に入力レプリケーション モードを設定します。

入力マルチキャスト レプリケーション モードを設定するには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

Router(config)# mls ip multicast replication-mode ingress

入力マルチキャスト レプリケーション モードを設定して、(デフォルトでイネーブルの)レプリケーション モードの自動検出をディセーブルにします。

Router(config)# no mls ip multicast replication-mode ingress

レプリケーション モードの自動検出をイネーブルにします。

ステップ 3

Router(config)# do show mls ip multicast capability | include Current

設定を確認します。

次に、入力マルチキャスト レプリケーション モードを設定して、その設定を確認する例を示します。

Router(config)# mls ip multicast replication-mode ingress
Router(config)# do show mls ip multicast capability | include Current
Current mode of replication is Ingress

MVRF インスタンスの設定

ここでは、PE ルータの各 VPN 接続に、MVRF インスタンスを設定する方法を示します。各 PE ルータでは、マルチキャスト トラフィックを送受信するための特定の VPN 接続のトラフィックを処理します。

「VRF エントリの設定」

「ルート識別子の設定」

「ルートターゲット拡張コミュニティの設定」

「デフォルト MDT の設定」

「データ MDT の設定(任意)」

「データ MDT ログ機能のイネーブル化」

「コンフィギュレーション例」

「VRF 情報の表示」

VRF エントリの設定

VRF エントリを設定するには、次の作業を行います。

 

コマンドまたはアクション
目的

ステップ 1

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

Router(config)# ip vrf vrf_name

VRF ルーティング テーブル エントリと Cisco Express Forwarding(CEF)テーブル エントリを設定して、VRF コンフィギュレーション モードを開始します。

Router(config)# no ip vrf vrf_name

VRF エントリを削除します。

ステップ 3

Router(config-vrf)# do show ip vrf vrf_name

設定を確認します。

次に、blue という名前の VRF を設定して、その設定を確認する例を示します。

Router# configure terminal
Router(config)# ip vrf blue
Router(config-vrf)# do show ip vrf blue
Name Default RD Interfaces
blue <not set>

ルート識別子の設定

ルート識別子を設定するには、次の作業を行います。

 

コマンドまたはアクション
目的

ステップ 1

Router(config-vrf)# rd route_distinguisher

VPN IPv4 プレフィクスのルート識別子を指定します。

Router(config-vrf)# no rd route_distinguisher

ルート識別子を削除します。

ステップ 2

Router(config-vrf)# do show ip vrf vrf_name

設定を確認します。

ルート識別子を設定する際に、以下のいずれかの形式でルート識別子を入力します。

16 ビット AS 番号 : ユーザの 32 ビットの番号(101:3)

32 ビット IPv4 アドレス : ユーザの 16 ビットの番号(192.168.122.15:1)

次に、ルート識別子として 55:1111 を設定して、その設定を確認する例を示します。

Router(config-vrf)# rd 55:1111
Router(config-vrf)# do show ip vrf blue
Name Default RD Interfaces
blue 55:1111
 

ルートターゲット拡張コミュニティの設定

ルートターゲット拡張コミュニティを設定するには、次の作業を行います。

 

コマンドまたはアクション
目的

ステップ 1

Router(config-vrf)# route-target [ import | export | both ] route_target_ext_community

VRF のルートターゲット拡張コミュニティを設定します。

Router(config-vrf)# no route-target [[ import | export | both ] route_target_ext_community ]

ルートターゲット拡張コミュニティを削除します。

ステップ 2

Router(config-vrf)# do show ip vrf detail

設定を確認します。

ルートターゲット拡張コミュニティを設定する際、次の情報に注意してください。

import ― ルーティング情報をターゲット VPN 拡張コミュニティからインポートします。

export ― ルーティング情報をターゲット VPN 拡張コミュニティにエクスポートします。

both ― インポートとエクスポートの両方を行います。

route_target_ext_community ― 48 ビットのルートターゲット拡張コミュニティを VRF に追加します。以下のいずれかの形式で番号を入力します。

16 ビット AS 番号 : ユーザの 32 ビットの番号(101:3)

32 ビット IPv4 アドレス : ユーザの 16 ビットの番号(192.168.122.15:1)

次に、インポートおよびエクスポート ルートターゲット拡張コミュニティとして 55:1111 を設定して、その設定を確認する例を示します。

Router(config-vrf)# route-target both 55:1111

Router(config-vrf)# do show ip vrf detail

VRF blue; default RD 55:1111; default VPNID <not set>

VRF Table ID = 1

No interfaces

Connected addresses are not in global routing table

Export VPN route-target communities

RT:55:1111

Import VPN route-target communities

RT:55:1111

No import route-map

No export route-map

CSC is not configured.

デフォルト MDT の設定

デフォルト MDT を設定するには、次の作業を行います。

 

コマンドまたはアクション
目的

Router(config-vrf)# mdt default group_address

デフォルト MDT を設定します。

Router(config-vrf)# no mdt default

デフォルト MDT を削除します。

デフォルト MDT を設定する際、次の情報に注意してください。

group_address は、デフォルト MDT グループのマルチキャスト IPv4 アドレスです。すべての PE ルータが同じグループ アドレスに設定されている場合、それらのルータは同じグループのメンバーとなるため、このアドレスは、MVRF コミュニティの識別子としての役割を果たします。これにより、グループ内の他のメンバーが送信した PIM 制御メッセージとマルチキャスト トラフィックを受信できます。

PE ルータをイネーブルにしてこの特定の MVRF のマルチキャスト トラフィックを受信するために、各 PE ルータにはこの同じデフォルト MDT が設定されていなければなりません。

次に、デフォルト MDT として 239.1.1.1 を設定する設定する例を示します。

Router(config-vrf)# mdt default 239.1.1.1

 

データ MDT の設定(任意)

任意のデータ MDT を設定するには、次の作業を行います。

 

コマンドまたはアクション
目的

Router(config-vrf)# mdt data group_address wildcard_bits [ threshold threshold_value ] [ list access_list ]

(任意)指定された範囲のマルチキャスト アドレスに対してデータ MDT を設定します。

Router(config-vrf)# no mdt data

データ MDT を削除します。

オプションのデータ MDT を設定する際、次の情報に注意してください。

group_address1 ― マルチキャスト グループ アドレス。アドレスは 224.0.0.1 ~ 239.255.255.255 の範囲で設定可能ですが、デフォルト MDT に割り当てられたアドレスと重複できません。

wildcard_bits ― 可能なアドレス範囲を作成するために、マルチキャスト グループ アドレスに適用されるワイルドカード ビットマスク。これにより、各 MVRF がサポートできるデータ MDT の最大数を制限できます。

threshold threshold_value ― (任意)マルチキャスト トラフィックがデフォルト MDT からデータ MDT に切り替えられるスレッシュホールド値をキロビット単位で定義します。
threshold_value
パラメータは、1 ~ 4294967 キロビットに設定可能です。

list access_list ― (任意)このトラフィックに適用されるアクセス リスト名または番号を指定します。

次に、データ MDT を設定する例を示します。

Router(config-vrf)# mdt data 239.1.2.0 0.0.0.3 threshold 10

データ MDT ログ機能のイネーブル化

データ MDT ログ機能をイネーブルにするには、次の作業を行います。

 

コマンドまたはアクション
目的

Router(config-vrf)# mdt log-reuse

(任意)データ MDT が再利用されるたびにSyslog メッセージを生成することで、データ MDT 再利用情報の記録をイネーブルにします。データ MDT を頻繁に再利用する場合、 mdt data コマンドで使用されるワイルドカード ビットマスクのサイズを増やして、使用可能な MDT の数を増やす必要があります。

Router(config-vrf)# no log-reuse

MDT ログ機能をディセーブルにします。

次に、データ MDT ログ機能をイネーブルにする例を示します。

Router(config-vrf)# mdt log-reuse

コンフィギュレーション例

以下のコンフィギュレーション ファイルからの抜粋は、VRF 範囲の一般的な VRF コンフィギュレーションを示しています。表示を簡略化するために、最初と最後の VRF のみ示しています。

!
ip vrf mvpn-cus1
rd 200:1
route-target export 200:1
route-target import 200:1
mdt default 239.1.1.1
!
ip vrf mvpn-cus2
rd 200:2
route-target export 200:2
route-target import 200:2
mdt default 239.1.1.2
!
ip vrf mvpn-cus3
rd 200:3
route-target export 200:3
route-target import 200:3
mdt default 239.1.1.3
!
...
 
ip vrf mvpn-cus249
rd 200:249
route-target export 200:249
route-target import 200:249
mdt default 239.1.1.249
mdt data 239.1.1.128 0.0.0.7

VRF 情報の表示

スイッチで設定されるすべての VRF を表示するには、 show ip vrf コマンドを使用します。

Router# show ip vrf
 
Name Default RD Interfaces
green 1:52 GigabitEthernet6/1
red 200:1 GigabitEthernet1/1
GigabitEthernet3/16
Loopback2
 
Router#
 

すべての MVRF に現在設定されている MDT に関する情報を表示するには、 show ip pim mdt コマンドを使用します。次に、このコマンドの一般的な出力例を示します。

Router# show ip pim mdt
 
MDT Group Interface Source VRF
* 227.1.0.1 Tunnel1 Loopback0 BIDIR01
* 227.2.0.1 Tunnel2 Loopback0 BIDIR02
* 228.1.0.1 Tunnel3 Loopback0 SPARSE01
* 228.2.0.1 Tunnel4 Loopback0 SPARSE02
 

) 特定のトンネル インターフェイスに関する情報を表示するには、show interface tunnel コマンドを使用します。トンネル インターフェイス用の IPv4 アドレスは、MVRF の デフォルト MDT に対するマルチキャスト グループ アドレスです。


MDT の追加情報を表示するには、 show mls ip multicast mdt コマンドを使用します。次に、このコマンドの一般的な出力例を示します。

Router# show mls ip multicast mdt
 
State: H - Hardware Installed, I - Install Pending, D - Delete Pending,
Z - Zombie
 
MMLS
VRF VPN-ID MDT INFO MDT Type State
BIDIR01HWRP 1 (10.10.10.9, 227.1.0.1) default H
BIDIR01SWRP 2 (10.10.10.9, 227.2.0.1) default H
SPARSE01HWRP 3 (10.10.10.9, 228.1.0.1) default H
SPARSE01SWRP 4 (10.10.10.9, 228.2.0.1) default H
red 5 (6.6.6.6, 234.1.1.1) default H
red 5 (131.2.1.2, 228.1.1.75) data (send) H
red 5 (131.2.1.2, 228.1.1.76) data (send) H
red 5 (131.2.1.2, 228.1.1.77) data (send) H
red 5 (131.2.1.2, 228.1.1.78) data (send) H
 
Router#
 

特定の VRF のルーティング情報を表示するには、 show ip route vrf コマンドを使用します。

Router# show ip route vrf red
 
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
 
Gateway of last resort is not set
 
2.0.0.0/32 is subnetted, 1 subnets
C 2.2.2.2 is directly connected, Loopback2
3.0.0.0/32 is subnetted, 1 subnets
B 3.3.3.3 [200/0] via 3.1.1.3, 00:20:09
C 21.0.0.0/8 is directly connected, GigabitEthernet3/16
B 22.0.0.0/8 [200/0] via 3.1.1.3, 00:20:09
 
Router#
 

特定の MVRF のマルチキャスト ルーティング テーブルとトンネル インターフェイスに関する情報を表示するには、 show ip mroute vrf コマンドを使用します。次に、BIDIR01 という名前の MVRF の一般的な出力例を示します。

Router# show ip mroute vrf BIDIR01
 
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report, Z - Multicast Tunnel
Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
(*, 228.1.0.1), 00:16:25/stopped, RP 10.10.10.12, flags: SJCF
Incoming interface: Tunnel1, RPF nbr 10.10.10.12, Partial-SC
Outgoing interface list:
GigabitEthernet3/1.3001, Forward/Sparse-Dense, 00:16:25/00:02:49, H
(6.9.0.100, 228.1.0.1), 00:14:13/00:03:29, flags: FT
Incoming interface: GigabitEthernet3/1.3001, RPF nbr 0.0.0.0, RPF-MFD
Outgoing interface list:
Tunnel1, Forward/Sparse-Dense, 00:14:13/00:02:46, H
 
Router#

) この例では、show ip mroute vrf コマンドは、この VRF で使用されている Tunnel1 が MDT トンネル インターフェイス(MTI)であることを示しています。


マルチキャスト VRF ルーティングの設定

ここでは、MVPN をサポートするためのマルチキャスト ルーティングの設定手順について説明します。

「IPv4 マルチキャスト ルーティングのグローバルなイネーブル化」

「IPv4 マルチキャスト VRF ルーティングのイネーブル化」

「PIM VRF レジスタ メッセージの送信元アドレスの設定」

「PIM VRF RP アドレスの指定」

「MSDP ピアの設定」

「IPv4 マルチキャスト ヘッダー ストレージのイネーブル化」

「マルチキャスト ルートの最大数の設定」

「コンフィギュレーション例」

「IPv4 マルチキャスト VRF ルーティング情報の表示」


) BGP は、マルチキャスト トラフィックを送受信するすべてのルータに設定済みで、動作可能である必要があります。さらに、ネットワークで MDT を使用できるようにするためには、(neighbor send-community both または neighbor send-community extendedコマンドを使用して)BGP 拡張コミュニティがイネーブルでなければなりません。


IPv4 マルチキャスト ルーティングのグローバルなイネーブル化

IPv4 マルチキャスト ルーティングをグローバルにイネーブルにするには、次の作業を行います。

 

コマンドまたはアクション
目的

ステップ 1

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

Router(config)# ip multicast-routing

IPv4 マルチキャスト ルーティングをグローバルにイネーブルにします。

Router(config)# no ip multicast-routing

IPv4 マルチキャスト ルーティングをグローバルにディセーブルにします。

次に、IPv4 マルチキャスト ルーティングをグローバルにイネーブルにする例を示します。

Router# configure terminal

Router(config)# ip multicast-routing

 

IPv4 マルチキャスト VRF ルーティングのイネーブル化

IPv4 マルチキャスト VRF ルーティングをイネーブルにするには、次の作業を行います。

 

コマンドまたはアクション
目的

Router(config)# ip multicast-routing vrf vrf_name [ distributed ]

IPv4 マルチキャスト VRF ルーティングをイネーブルにします。

Router(config)# no ip multicast-routing

IPv4 マルチキャスト VRF ルーティングをディセーブルにします。

IPv4 マルチキャスト VRF ルーティングをイネーブルにする際、次の情報に注意してください。

vrf_name ― マルチキャスト ルーティング用に 特定の VRF を指定します。 vrf_name は、「MVRF インスタンスの設定」で示しているように、前に作成された VRF を参照するようにします。

distributed ― (任意)MDS をイネーブルにします。

次に、IPv4 マルチキャスト VRF ルーティングをイネーブルにする例を示します。

Router# configure terminal

Router(config)# ip multicast-routing vrf blue

PIM VRF レジスタ メッセージの送信元アドレスの設定

PIM VRF レジスタメッセージの送信元アドレスを設定するには、次の作業を行います。

 

コマンドまたはアクション
目的
Router(config)# ip pim vrf vrf_name register-source interface_type interface_number

(任意)PIM VRF レジスタ メッセージの送信元アドレスを設定します。ループバック インターフェイスをレジスタ メッセージの送信元として設定できます。

Router(config)# no ip pim vrf vrf_name register-source

IPv4 マルチキャスト VRF ルーティングをディセーブルにします。

次に、PIM VRF レジスタ メッセージの送信元アドレスを設定する例を示します。

Router(config)# ip pim vrf blue register-source loopback 3

PIM VRF RP アドレスの指定

PIM VRF Rendezvous Point(RP; ランデブー ポイント)を指定するには、次の作業を行います。

 

コマンドまたはアクション
目的
Router(config)# ip pim vrf vrf_name rp-address rp_address [ access_list ] [ override ] [ bidir ]

sparse(疎)PIM ネットワークに必要な PIM RP IPv4 アドレスを指定します。

Router(config)# no ip pim vrf vrf_name rp-address rp_address

PIM RP IPv4 アドレスをクリアします。

PIM VRF RP アドレスを指定する際、次の情報に注意してください。

vrf vrf_name ― (任意)使用する特定の VRF インスタンスを指定します。

rp_address ― PIM RP ルータのユニキャスト IP アドレス

access_list ― (任意)RP のマルチキャスト グループを定義するアクセス リストの番号または名前

override ― (任意)RP アドレスが矛盾している場合、この特定の RP を Auto-RP を通じて学習した RP に上書きします。

bidir ― (任意) access_list 引数で指定されたマルチキャスト グループが双方向モードで動作するように指定します。このオプションが指定されていない場合、グループは PIM sparse(疎)モードで動作します。

スケーラビリティ向上のため、可能なかぎり双方向モードを使用してください。

次に、PIM VRF RP アドレスを指定する例を示します。

Router(config)# ip pim vrf blue rp-address 198.196.100.33

MSDP ピアの設定

Multicast Source Discovery Protocol(MSDP)ピアを設定するには、次の作業を行います。

 

コマンドまたはアクション
目的

Router(config)# ip msdp vrf vrf_name peer { peer_name | peer_address } [ connect-source interface_type interface_number ] [ remote-as ASN ]

(任意)MSDPピアを設定します。

Router(config)# no ip msdp vrf vrf_name peer { peer_name | peer_address } [ connect-source interface_type interface_number ] [ remote-as ASN ]

PIM RP IPv4 アドレスをクリアします。

MSDP ピアを設定する際、次の情報に注意してください。

vrf vrf_name ― 使用する特定の VRF インスタンスを指定します。

{ peer_name | peer_address } ― MSDP ピア ルータの Domain Name System(DNS; ドメイン ネーム システム)名または IP アドレス

connect-source interface_type interface_number ― プライマリ アドレスが TCP 接続の送信元 IP アドレスとして使用されいているインターフェイスのインターフェイス名と番号

remote-as ASN ― (任意)MSDP ピアの自律システム番号。これは、表示するためだけのものです。

次に、MSDP ピアの設定例を示します。

Router(config)# ip msdp peer router.cisco.com connect-source fastethernet 1/1 remote-as 109

IPv4 マルチキャスト ヘッダー ストレージのイネーブル化

IPv4 マルチキャスト ヘッダー ストレージをイネーブルにするには、次の作業を行います。

 

コマンドまたはアクション
目的

Router(config)# ip multicast vrf vrf_name cache-headers [ rtp ]

(任意)IPv4 マルチキャスト パケット ヘッダーを保存する循環バッファをイネーブルにします。

Router(config)# no ip multicast vrf vrf_name cache-headers [ rtp ]

IPv4 マルチキャスト ヘッダー ストレージをディセーブルにします。

IPv4 マルチキャスト ヘッダー ストレージをイネーブルにする際、次の情報に注意してください。

vrf vrf_name ― 指定 VRF のバッファを割り当てます。

rtp ― (任意)Real-Time Transport Protocol(RTP; リアルタイム トランスポート プロトコル)ヘッダーもキャッシュします。

バッファは show ip mpacket コマンドとともに表示できます。

次に、IPv4 マルチキャスト ヘッダー ストレージをイネーブルにする例を示します。

Router(config)# ip multicast vrf blue cache-headers

マルチキャスト ルートの最大数の設定

マルチキャスト ルートの最大数を設定するには、次の作業を行います。

 

コマンドまたはアクション
目的

Router(config)# ip multicast vrf vrf_name route-limit limit [ threshold ]

(任意)マルチキャスト トラフィックに追加できるマルチキャスト ルートの最大数を設定します。

Router(config)# no ip multicast vrf vrf_name route-limit limit [ threshold ]

設定されているマルチキャスト ルートの最大数をクリアします。

最大ルート数を設定する際、次の情報に注意してください。

vrf vrf_name ― 指定 VRF のルート制限をイネーブルにします。

limit ― 追加できるマルチキャスト数。指定できる範囲は 1 ~ 2147483647 です。デフォルトは 2147483647 です。

threshold ― (任意)警告メッセージが発生するまで追加できるマルチキャスト ルート数。有効な範囲は 1 から limit パラメータの値までです。

次に、マルチキャスト ルートの最大数を設定する例を示します。

Router(config)# ip multicast vrf blue route-limit 200000 20000

IPv4 マルチキャスト ルート フィルタリングの設定

IPv4 マルチキャスト ルート フィルタリングを設定にするには、次の作業を行います。

 

コマンドまたはアクション
目的

Router(config)# ip multicast mrinfo-filter access_list

(任意)アクセス リストを使用して IPv4 マルチキャスト ルートを設定します。 access_list パラメータにはアクセス リストの名前または番号を指定できます。

Router(config)# no ip multicast mrinfo-filter

設定されているマルチキャスト ルートの最大数をクリアします。

次に、IPv4 マルチキャスト ルート フィルタリングをイネーブルにする例を示します。

Router(config)# ip multicast mrinfo-filter 101

コンフィギュレーション例

以下のコンフィギュレーション ファイルからの抜粋は、VRF 範囲のマルチキャスト ルーティングをサポートするのに必要な最小コンフィギュレーションを示しています。表示を簡略化するために、最初と最後の VRF のみ示しています。

!
ip multicast-routing
ip multicast-routing vrf lite
ip multicast-routing vrf vpn201
ip multicast-routing vrf vpn202
 
...
 
ip multicast-routing vrf vpn249
ip multicast-routing vrf vpn250
ip multicast cache-headers
 
 
...
 
ip pim rp-address 192.0.1.1
ip pim vrf lite rp-address 104.1.1.2
ip pim vrf vpn201 rp-address 192.200.1.1
ip pim vrf vpn202 rp-address 192.200.2.1
 
...
 
ip pim vrf vpn249 rp-address 192.200.49.6
ip pim vrf vpn250 rp-address 192.200.50.6
...
 

IPv4 マルチキャスト VRF ルーティング情報の表示

特定の MVRF に対する既知の PIM ネイバを表示するには、 show ip pim vrf neighbor コマンドを使用します。

Router# show ip pim vrf 98 neighbor
 
PIM Neighbor Table
Neighbor Interface Uptime/Expires Ver DR
Address Prio/Mode
40.60.0.11 Tunnel96 00:00:31/00:01:13 v2 1 / S
40.50.0.11 Tunnel96 00:00:54/00:00:50 v2 1 / S
 
Router#

MVPN をサポートするためのマルチキャスト ルーティング用インターフェイスの設定

ここでは、MVPN をサポートするためのマルチキャスト ルーティング用インターフェイスの設定手順について説明します。

「マルチキャスト ルーティングの設定の概要」

「インターフェイスでの PIM の設定」

「IPv4 VRF 転送用インターフェイスの設定」

「コンフィギュレーション例」

マルチキャスト ルーティングの設定の概要

PIM は、IPv4 マルチキャスト トラフィックに使用されるすべてのインターフェイスで設定されていなければなりません。VPN マルチキャスト環境では、少なくとも以下のすべてのインターフェイスで PIM をイネーブルにする必要があります。

バックボーンに接続されている PE ルータの物理インターフェイス

BGP ピアリングで使用されるループバック インターフェイス

sparse(疎)PIM RP ルータ アドレスの送信元として使用されるループバック インターフェイス

さらに、マルチキャスト トラフィックを転送しようとしているこれらのインターフェイスと MVRF を関連づける必要があります。

BGP は、マルチキャスト トラフィックを送受信するすべてのルータに設定済みで、動作可能である必要があります。さらに、ネットワークで MDT を使用できるようにするためには、( neighbor send-community both または neighbor send-community extended コマンドを使用して)BGP 拡張コミュニティがイネーブルでなければなりません。

インターフェイスでの PIM の設定

インターフェイスで PIM を設定するには、次の作業を行います。

 

コマンドまたはアクション
目的

ステップ 1

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

Router(config)# interface type { slot/port | number }

特定のインターフェイスのインターフェイス コンフィギュレーション モードを開始します。

ステップ 3

Router(config-if)# ip pim { dense-mode | sparse-mode | sparse-dense-mode }

インターフェイスで PIM をイネーブルにします。

Router(config)# no ip pim [ dense-mode | sparse-mode | sparse-dense-mode ]

PIM をディセーブルにします。

インターフェイスで PIM を設定する際、次の情報に注意してください。

次のインターフェイス タイプのいずれかを使用できます。

バックボーンに接続されている PE ルータの物理インターフェイス

BGP ピアリングで使用されるループバック インターフェイス

sparse(疎)PIM ネットワーク RP アドレスの送信元として使用されるループバック インターフェイス

PIM モードには以下のものがあります。

dense-mode ― 動作の dense(密)モードをイネーブルにします。

sparse-mode ― 動作の sparse(疎)モードをイネーブルにします。

sparse-dense-mode ― マルチキャスト グループに RP ルータが定義されている場合は sparse(疎)モードをイネーブルにし、RP ルータが定義されていない場合は dense(密)モードをイネーブルにします。

バックボーンに接続されたすべての PE ルータの物理インターフェイスに対して、または BGP ピアリングまたは RP アドレッシングの送信元として使用されるすべてのループバック インターフェイスで、 sparse-mode を使用します。

次に、物理インターフェイスに PIM sparse(疎)モードを設定にする例を示します。

Router# configure terminal

interface gigabitethernet 10/1

Router(config-if)# ip pim sparse-mode

 

次に、ループバック インターフェイスに PIM sparse(疎)モードを設定する例を示します。

Router# configure terminal

Router(config)# interface loopback 2

Router(config-if)# ip pim sparse-mode

IPv4 VRF 転送用インターフェイスの設定

IPv4 VRF 転送用インターフェイスを設定にするには、次の作業を行います。

 

コマンドまたはアクション
目的
Router(config-if)# ip vrf forwarding vrf_name

(任意)指定した VRF ルーティング/転送テーブルをインターフェイスと関連づけます。これが指定されていない場合、インターフェイスはデフォルトでグローバル ルーティング テーブルを使用します。


) インターフェイスでこのコマンドを入力すると IP アドレスが削除されるので、IP アドレスを再設定します。


Router(config-if)# no ip vrf forwarding [ vrf_name ]

IPv4 VRF 転送をディセーブルにします。

次に、インターフェイスに VRF bule 転送を設定する例を示します。

Router(config-if)# ip vrf forwarding blue

コンフィギュレーション例

以下のコンフィギュレーション ファイルからの抜粋は、単一の MVRF を介したマルチキャスト トラフィックをイネーブルにするためのインターフェイス コンフィギュレーションを、関連する MVRF コンフィギュレーションと共に示しています。

ip multicast-routing vrf blue
ip multicast-routing
 
ip vrf blue
rd 100:27
route-target export 100:27
route-target import 100:27
mdt default 239.192.10.2
interface GigabitEthernet1/1
description blue connection
ip vrf forwarding blue
ip address 192.168.2.26 255.255.255.0
ip pim sparse-mode
 
interface GigabitEthernet1/15
description Backbone connection
ip address 10.8.4.2 255.255.255.0
ip pim sparse-mode
 
ip pim vrf blue rp-address 192.7.25.1
ip pim rp-address 10.1.1.1

MVPN のコンフィギュレーション例

ここでは、MVPN 機能のコンフィギュレーション例を示します。

「デフォルト MDT のみを使用した MVPN コンフィギュレーション」

「デフォルト MDT とデータ MDT を使用した MVPN コンフィギュレーション」

デフォルト MDT のみを使用した MVPN コンフィギュレーション

以下のコンフィギュレーション ファイルからの抜粋は、3 つの MVRF の MVPN コンフィギュレーションに関連した行を示しています(必要な BGP コンフィギュレーションは省略しています)。

!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
service compress-config
!
hostname MVPN Router
!
boot system flash slot0:
logging snmp-authfail
!
ip subnet-zero
!
!
no ip domain-lookup
ip host tftp 223.255.254.238
!
ip vrf mvpn-cus1
rd 200:1
route-target export 200:1
route-target import 200:1
mdt default 239.1.1.1
!
ip vrf mvpn-cus2
rd 200:2
route-target export 200:2
route-target import 200:2
mdt default 239.1.1.2
!
ip vrf mvpn-cus3
rd 200:3
route-target export 200:3
route-target import 200:3
mdt default 239.1.1.3
!
ip multicast-routing
ip multicast-routing vrf mvpn-cus1
ip multicast-routing vrf mvpn-cus2
ip multicast-routing vrf mvpn-cus3
ip multicast multipath
frame-relay switching
mpls label range 4112 262143
mpls label protocol ldp
mpls ldp logging neighbor-changes
mpls ldp explicit-null
mpls traffic-eng tunnels
tag-switching tdp discovery directed-hello accept from 1
tag-switching tdp router-id Loopback0 force
mls ip multicast replication-mode ingress
mls ip multicast flow-stat-timer 9
mls ip multicast bidir gm-scan-interval 10
mls flow ip destination
no mls flow ipv6
mls rate-limit unicast cef glean 10 10
mls qos
mls cef error action freeze
 
...
 
vlan internal allocation policy ascending
vlan access-log ratelimit 2000
!
vlan 2001-2101,3501-3700,4001,4051-4080,4093
!
!
!
interface Loopback0
ip address 201.252.1.14 255.255.255.255
ip pim sparse-dense-mode
!
interface Loopback1
ip address 209.255.255.14 255.255.255.255
!
interface Loopback10
ip vrf forwarding mvpn-cus1
ip address 210.101.255.14 255.255.255.255
!
interface Loopback11
ip vrf forwarding mvpn-cus1
ip address 210.111.255.14 255.255.255.255
ip pim sparse-dense-mode
!
interface Loopback12
ip vrf forwarding mvpn-cus1
ip address 210.112.255.14 255.255.255.255
 
...
 
!
interface GigabitEthernet3/3
mtu 9216
ip vrf forwarding mvpn-cus3
ip address 172.10.14.1 255.255.255.0
ip pim sparse-dense-mode
!
 
...
 
!
interface GigabitEthernet3/19
ip vrf forwarding mvpn-cus2
ip address 192.16.4.1 255.255.255.0
ip pim sparse-dense-mode
ip igmp static-group 229.1.1.1
ip igmp static-group 229.1.1.2
ip igmp static-group 229.1.1.4
!
interface GigabitEthernet3/20
ip vrf forwarding mvpn-cus1
ip address 192.16.1.1 255.255.255.0
ip pim sparse-dense-mode
!
...

デフォルト MDT とデータ MDT を使用した MVPN コンフィギュレーション

次のコンフィギュレーション例には、デフォルト MDT とデータ MDT の両方が設定された 3 つの MVRF が含まれています。MVPN コンフィギュレーションに関連したコンフィギュレーションのみを示しています。

...
!
ip vrf v1
rd 1:1
route-target export 1:1
route-target import 1:1
mdt default 226.1.1.1
mdt data 226.1.1.128 0.0.0.7 threshold 1
!
ip vrf v2
rd 2:2
route-target export 2:2
route-target import 2:2
mdt default 226.2.2.1
mdt data 226.2.2.128 0.0.0.7
!
ip vrf v3
rd 3:3
route-target export 3:3
route-target import 3:3
mdt default 226.3.3.1
mdt data 226.3.3.128 0.0.0.7
!
ip vrf v4
rd 155.255.255.1:4
route-target export 155.255.255.1:4
route-target import 155.255.255.1:4
mdt default 226.4.4.1
mdt data 226.4.4.128 0.0.0.7
!
ip multicast-routing
ip multicast-routing vrf v1
ip multicast-routing vrf v2
ip multicast-routing vrf v3
ip multicast-routing vrf v4
mpls label protocol ldp
mpls ldp logging neighbor-changes
tag-switching tdp router-id Loopback1
mls ip multicast replication-mode ingress
mls ip multicast bidir gm-scan-interval 10
no mls flow ip
no mls flow ipv6
mls cef error action freeze
!
!
!
!
!
 
...
 
vlan internal allocation policy ascending
vlan access-log ratelimit 2000
!
!
interface Loopback1
ip address 155.255.255.1 255.255.255.255
ip pim sparse-mode
!
interface Loopback4
ip vrf forwarding v4
ip address 155.255.4.4 255.255.255.255
ip pim sparse-mode
!
interface Loopback11
ip vrf forwarding v1
ip address 155.255.255.11 255.255.255.255
ip pim sparse-dense-mode
!
interface Loopback22
ip vrf forwarding v2
ip address 155.255.255.22 255.255.255.255
ip pim sparse-mode
!
interface Loopback33
ip vrf forwarding v3
ip address 155.255.255.33 255.255.255.255
ip pim sparse-mode
!
interface Loopback44
no ip address
!
interface Loopback111
ip vrf forwarding v1
ip address 1.1.1.1 255.255.255.252
ip pim sparse-dense-mode
ip ospf network point-to-point
!
interface GigabitEthernet1/1
description Gi1/1 - 155.50.1.155 255.255.255.0 - peer dut50 - mpls
mtu 9216
ip address 155.50.1.155 255.255.255.0
ip pim sparse-mode
tag-switching ip
!
interface GigabitEthernet1/2
ip vrf forwarding v1
ip address 155.1.2.254 255.255.255.0
ip pim sparse-mode
!
interface GigabitEthernet1/3
description Gi1/3 - 185.155.1.155/24 - vrf v1 stub peer 185.Gi1/3
ip vrf forwarding v1
ip address 185.155.1.155 255.255.255.0
ip pim sparse-mode
!
 
...
 
!
interface GigabitEthernet1/48
ip vrf forwarding v1
ip address 157.155.1.155 255.255.255.0
ip pim bsr-border
ip pim sparse-dense-mode
!
interface GigabitEthernet6/1
no ip address
shutdown
!
interface GigabitEthernet6/2
ip address 9.1.10.155 255.255.255.0
media-type rj45
!
interface Vlan1
no ip address
shutdown
!
router ospf 11 vrf v1
router-id 155.255.255.11
log-adjacency-changes
redistribute connected subnets tag 155
redistribute bgp 1 subnets tag 155
network 1.1.1.0 0.0.0.3 area 155
network 155.255.255.11 0.0.0.0 area 155
network 155.0.0.0 0.255.255.255 area 155
network 157.155.1.0 0.0.0.255 area 0
!
router ospf 22 vrf v2
router-id 155.255.255.22
log-adjacency-changes
network 155.255.255.22 0.0.0.0 area 155
network 155.0.0.0 0.255.255.255 area 155
network 157.155.1.0 0.0.0.255 area 0
!
router ospf 33 vrf v3
router-id 155.255.255.33
log-adjacency-changes
network 155.255.255.33 0.0.0.0 area 155
!
router ospf 1
log-adjacency-changes
network 155.50.1.0 0.0.0.255 area 0
network 155.255.255.1 0.0.0.0 area 155
!
router bgp 1
bgp router-id 155.255.255.1
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 175.255.255.1 remote-as 1
neighbor 175.255.255.1 update-source Loopback1
neighbor 185.255.255.1 remote-as 1
neighbor 185.255.255.1 update-source Loopback1
!
address-family vpnv4
neighbor 175.255.255.1 activate
neighbor 175.255.255.1 send-community extended
neighbor 185.255.255.1 activate
neighbor 185.255.255.1 send-community extended
exit-address-family
!
address-family ipv4 vrf v4
no auto-summary
no synchronization
exit-address-family
!
address-family ipv4 vrf v3
redistribute ospf 33
no auto-summary
no synchronization
exit-address-family
!
address-family ipv4 vrf v2
redistribute ospf 22
no auto-summary
no synchronization
exit-address-family
!
address-family ipv4 vrf v1
redistribute ospf 11
no auto-summary
no synchronization
exit-address-family
!
ip classless
ip route 9.255.254.1 255.255.255.255 9.1.10.254
no ip http server
ip pim bidir-enable
ip pim rp-address 50.255.2.2 MCAST.MVPN.MDT.v2 override bidir
ip pim rp-address 50.255.3.3 MCAST.MVPN.MDT.v3 override bidir
ip pim rp-address 50.255.1.1 MCAST.MVPN.MDT.v1 override bidir
ip pim vrf v1 spt-threshold infinity
ip pim vrf v1 send-rp-announce Loopback11 scope 16 group-list MCAST.GROUP.BIDIR bidir
ip pim vrf v1 send-rp-discovery Loopback11 scope 16
ip pim vrf v1 bsr-candidate Loopback111 0
ip msdp vrf v1 peer 185.255.255.11 connect-source Loopback11
ip msdp vrf v1 cache-sa-state
!
!
ip access-list standard MCAST.ANYCAST.CE
permit 2.2.2.2
ip access-list standard MCAST.ANYCAST.PE
permit 1.1.1.1
ip access-list standard MCAST.BOUNDARY.VRF.v1
deny 226.192.1.1
permit any
ip access-list standard MCAST.GROUP.BIDIR
permit 226.192.0.0 0.0.255.255
ip access-list standard MCAST.GROUP.SPARSE
permit 226.193.0.0 0.0.255.255
ip access-list standard MCAST.MVPN.BOUNDARY.DATA.MDT
deny 226.1.1.128
permit any
ip access-list standard MCAST.MVPN.MDT.v1
permit 226.1.0.0 0.0.255.255
ip access-list standard MCAST.MVPN.MDT.v2
permit 226.2.0.0 0.0.255.255
ip access-list standard MCAST.MVPN.MDT.v3
permit 226.3.0.0 0.0.255.255
ip access-list standard MCAST.MVPN.RP.v4
permit 227.0.0.0 0.255.255.255
!
access-list 1 permit 226.1.1.1
access-list 2 deny 226.1.1.1
access-list 2 permit any
...