Catalyst 6500 シリーズ スイッチ Cisco IOS ソフトウェア コンフィギュレーション ガイド Release 12.2SX
PFC3BXL および PFC3B モード MPLS の設定
PFC3BXL および PFC3B モード MPLS の設定
発行日;2012/01/12 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 11MB) | フィードバック

目次

PFC3BXL および PFC3B モード MPLS の設定

PFC3BXL および PFC3B モード MPLS ラベル スイッチングの設定

MPLS の概要

PFC3BXL および PFC3B モード MPLS ラベル スイッチングの概要

IP/MPLS

MPLS/MPLS

MPLS/IP

MPLS VPN 転送

再循環

サポートされるハードウェア機能

サポートされる Cisco IOS 機能

MPLS の注意事項および制約事項

PFC3BXL および PFC3B モード MPLS でサポートされるコマンド

MPLS の設定

MPLS のラベル単位ロードバランス

基本的な MPLS ロードバランス

MPLS レイヤ 2 VPN ロードバランス

MPLS レイヤ 3 VPN ロードバランス

MPLS の設定例

PFC3BXL または PFC3B モード VPN スイッチング

PFC3BXL または PFC3B モード VPN スイッチング処理

MPLS VPN の注意事項および制約事項

PFC3BXL または PFC3B モード MPLS VPN でサポートされるコマンド

MPLS VPN の設定

MPLS VPN の設定例

AToM

AToM ロードバランス

EoMPLS の概要

EoMPLS の注意事項および制約事項

EoMPLS の設定

前提条件

PFC3BXL および PFC3B モード VLAN ベース EoMPLS の設定

PFC3BXL および PFC3B モード ポートベース EoMPLS の設定

PFC3BXL および PFC3B モード MPLS の設定

この章では、Catalyst 6500 シリーズ スイッチに PFC3BXL および PFC3B モード Multiprotocol Label Switching(MPLS; マルチプロトコル ラベル スイッチング)を設定する方法について説明します。


) この章で使用しているコマンドの構文および使用方法の詳細については、以下のマニュアルを参照してください。

次の URL の『 Catalyst 6500 Series Switch Cisco IOS Command Reference 』Release 12.2SX

http://www.cisco.com/univercd/cc/td/doc/product/lan/cat6000/122sx/cmdref/index.htm

次の URL の Release 12.2 のマニュアル

http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122cgcr/index.htm


 

この章で説明する内容は、次のとおりです。

「PFC3BXL および PFC3B モード MPLS ラベル スイッチングの設定」

「PFC3BXL または PFC3B モード VPN スイッチング」

「AToM」

PFC3BXL および PFC3B モード MPLS ラベル スイッチングの設定

ここでは、PFC3BXL および PFC3B モード MPLS ラベル スイッチングについて説明します。

「MPLS の概要」

「PFC3BXL および PFC3B モード MPLS ラベル スイッチングの概要」

「サポートされるハードウェア機能」

「サポートされる Cisco IOS 機能」

「MPLS の注意事項および制約事項」

「MPLS の設定」

「MPLS のラベル単位ロードバランス」

「MPLS の設定例」

MPLS の概要

MPLS はラベル スイッチングを使用して、Packet-over-SONET(POS)、フレーム リレー、Asynchronous Transfer Mode(ATM; 非同期転送モード)、イーサネットなどのさまざまなリンクレベル テクノロジーを介してパケットを転送します。ラベルはグループ化または Forwarding Equivalence Class(FEC)に基づいて、パケットに割り当てられます。ラベルはレイヤ 2 ヘッダーとレイヤ 3 ヘッダーの間に追加されます。

MPLS ネットワークでは、Label Edge Router(LER; ラベル エッジ ルータ)が着信ラベルのラベル検索を実行し、着信ラベルを発信ラベルに切り替えて、パケットを Label Switch Router(LSR; ラベル スイッチ ルータ)のネクストホップに送信します。パケットに対してラベルがインポーズ(プッシュ)されるのは、MPLS ネットワークの入力エッジ上に限ります。出力エッジでは、ラベルが削除(ポップ)されます。コア ネットワーク LSR(プロバイダーまたは P ルータ)はラベルを読み取り、適切なサービスを適用し、ラベルに基づいてパケットを転送します。

着信ラベルには集約または非集約の 2 つのタイプがあります。集約ラベルの場合、ネクストホップおよび発信インターフェイスを検出するときに、IP 検索によって着信 MPLS パケットをスイッチングする必要があります。非集約ラベルの場合、パケットに IP ネクストホップ情報が格納されます。

図25-1 に、カスタマー ネットワークの 2 つのサイトを接続する、サービス プロバイダーの MPLS ネットワークを示します。

図25-1 MPLS ネットワーク

 

MPLS の詳細については、以下のマニュアルを参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122cgcr/fswtch_c/swprt3/xcftagov.htm

PFC3BXL および PFC3B モード MPLS ラベル スイッチングの概要

PFC3BXL または PFC3B モードは、レイヤ 3 MPLS Virtual Private Network(VPN; 仮想私設網)やレイヤ 2 Ethernet over MPLS(EoMPLS)をサポートし、Quality of Service(QoS; サービス品質)やセキュリティに対応しています。

スーパーバイザ エンジン上の MSFC は、アドレス解決やルーティング プロトコルなどのレイヤ 3 制御プレーン機能を実行します。MSFC はルーティング プロトコルおよび Label Distribution Protocol(LDP)からの情報を処理し、IP 転送(Forwarding Information Base[FIB; 転送情報ベース])テーブルおよびラベル転送(Label Forwarding Information Base [LFIB])テーブルを構築します。MSFC は両方のテーブルの情報を PFC3BXL または PFC3B に配布します。

PFC3BXL または PFC3B は情報を取得し、FIB および LFIB テーブルのコピーを独自に作成します。また、これらのテーブルを組み合わせて FIB Ternary CAM(TCAM) を作成します。DFC は FIB TCAM テーブル内で、着信 IP パケットおよびラベル付きパケットを検索します。検索結果は、特定の隣接エントリへのポインタとして示されます。この隣接エントリには、ラベルのプッシュ(IP/MPLS パスの場合)、ラベルのスワップ(MPLS/MPLS パスの場合)、ラベルのポップ(MPLS/IP パスの場合)、カプセル化に関する適切な情報が含まれます。

図25-2 に、PFC3BXL および PFC3B モード MPLS ラベル スイッチングをサポートする各機能ブロックを示します。ルーティング プロトコルは、IP および MPLS データ パケットの転送に使用する Routing Information Base(RIB)を生成します。Cisco Express Forwarding(CEF)の場合、必要なルーティング情報が RIB から抽出されて、FIB に構築されます。LDP は RIB からルートを取得して、ラベル スイッチ パスを介してラベルを配布し、各 LSR および LER 内に LFIB を構築します。

図25-2 MPLS 転送、制御、データ プレーン

 

IP/MPLS

PFC3BXL または PFC3B は MPLS ネットワークへの入口で IP パケットを調べて、FIB TCAM 内でルートを検索します。検索結果は、特定の隣接エントリへのポインタとして示されます。隣接エントリには、ラベルのプッシュ(IP/MPLS パスの場合)およびカプセル化に関する適切な情報が含まれます。PFC3BXL または PFC3B は、MPLS パケットのスイッチングに必要なインポジション ラベルを含めた結果を生成します。


) MPLS 負荷分散が設定されている場合、隣接は負荷分散パスを指すことがあります。「基本的な MPLS ロードバランス」を参照してください。


MPLS/MPLS

PFC3BXL または PFC3B は MPLS ネットワークのコアで最上位ラベルを使用して、FIB TCAM 内で検索を実行します。正常な検索結果が指す隣接は、パケット内の最上位ラベルを、ダウンストリーム LSR によってアドバタイズされた新しいラベルで置き換えます。ルータが直前ホップ LSR ルータ(出力 LER の次のアップストリーム LSR)である場合、隣接は PFCBXL に最上位ラベルをポップするように指示します。これにより、VPN または Any Transport over MPLS(AToM)で使用するラベルが残っている MPLS パケット、またはネイティブ IP パケットが作成されます。

MPLS/IP

MPLS ネットワークの出口での処理には複数の方法があります。

ネイティブ IP パケットの場合(直前ルータがラベルをポップした場合)、PFC3BXL または PFC3B は FIB TCAM 内でルートを検索します。

MPLS VPN パケットの場合、Interior Gateway Protocol(IGP) ラベルが直前ルータでポップされたあとに、VPN ラベルが残ります。PFC3BXL または PFC3B が実行する処理は、VPN ラベル タイプによって異なります。集約ラベルを伝送するパケットでは、集約ラベルをポップしたあとに、IP ヘッダーに基づいてさらに検索する必要があります。非集約ラベルの場合、PFC3BXL または PFC3B は FIB TCAM 内でルートを検索し、IP ネクストホップ情報を取得します。

IGP ラベルおよび VPN ラベルが添付されたパケットの場合、Penultimate Hop Popping(PHP)が発生しなければ、パケットは VPN ラベルの上部で明示的 Null ラベルを伝送します。PFC3BXL または PFC3B は FIB TCAM 内で最上位ラベルを検索し、パケットを再循環させます。それから、PFC3BXL または PFC3B は上記段落の説明に従い、集約ラベルであるか非集約ラベルであるかに応じて残りのラベルを処理します。

EoMPLS、MPLS、MPLS VPN の場合、明示的 Null ラベルが添付されたパケットについて、MPLS は同様に処理されます。

MPLS VPN 転送

VPN ラベルには、直接接続されたネットワークまたは集約ルート用の集約ラベルと、非集約ラベルの 2 種類があります。集約ラベルを伝送するパケットでは、集約ラベルをポップしたあとに、IP ヘッダーに基づいてさらに検索する必要があります。VPN 情報(VPN-IPv4 アドレス、拡張コミュニティ、ラベル)は Multiprotocol Border Gateway Protocol(MBGP)によって配布されます。

再循環

場合によって、PFC3BXL または PFC3B はパケットの再循環機能を提供します。再循環を使用すると、Access Control List(ACL; アクセス制御リスト)または QoS TCAM、Netflow テーブル、または FIB TCAM テーブル内で追加検索を実行できます。再循環は次の場合に必須です。

4 つ以上のラベルをインポジションにプッシュする場合

3 つ以上のラベルをディスポジションにポップする場合

最上位の明示的 Null ラベルをポップする場合

VPN Routing and Forwarding(VRF; VPNルーティング/転送)番号が 511 を超える場合

出力インターフェイスの IP ACL の場合(非集約[プレフィクス単位]ラベル専用)

パケット再循環が発生するのは、特定のパケット フローに対してのみです。その他のパケット フローには影響しません。パケットの書き替えはモジュールで行われます。書き替えられたパケットは PFC3BXL または PFC3B に転送されて、さらに処理されます。

サポートされるハードウェア機能

次のハードウェア機能がサポートされています。

ラベル処理 ― 任意の個数のラベルをプッシュまたはポップできます。ただし、最適な結果を得るために、同じ処理内でプッシュするラベル数を最大 3 つ、ポップするラベル数を最大 2 つにしてください。

IP/MPLS パス ― IP パケットを受信して、MPLS パスに送信できます。

MPLS/IP パス ― ラベル付きパケットを受信して、IP パスに送信できます。

MPLS/MPLS パス ― ラベル付きパケットを受信して、そのラベル パスに送信できます。

MPLS Traffic Engineering(MPLS TE) ― MPLS バックボーンは、レイヤ 2 ATM およびフレーム リレー ネットワークのトラフィック エンジニアリング機能を反復および拡張できます。

Time to Live(TTL)処理 ― MPLS ネットワークの入口では、MPLS フレーム ヘッダーの TTL 値を、IP パケット ヘッダーの TTL フィールド、または隣接エントリのユーザ設定値から取得できます。MPLS ネットワークの出口では、最終 TTL はラベル TTL と IP TTL のいずれか小さい方の値から 1 を引いた値になります。


) 均一モードでは、TTL は IP TTL から取得されます。パイプ モードでは、ハードウェア レジスタから取得した値 255 が発信ラベルに使用されます。


QoS ― IP パケットから取得した Differentiated Services(DiffServ)および Type of Service(ToS; サービス タイプ)に関する情報を、MPLS EXP フィールドにマッピングできます。

MPLS/VPN サポート ― 最大 1024 個の VRF をサポートできます(VRF が 511 個を超える場合、再循環する必要があります)。

EoMPLS ― MPLS ドメインの入口でイーサネット フレームをカプセル化し、出口でカプセル開放できます。

パケット再循環 ― PFC3BXL または PFC3B にはパケット再循環機能があります。「再循環」を参照してください。

MPLS スイッチング設定は、mpls ip コマンドを使用した VLAN(仮想 LAN)インターフェイスでサポートされます。

サポートされる Cisco IOS 機能

PFC3BXL または PFC3B モードでは、次の Cisco IOS ソフトウェア機能がサポートされています。


) CE ルータ(VRF Lite)の Multi-VPN Routing and Forwarding(VRF)は、VRF インターフェイス間の IPv4 転送、IPv4 ACL、および IPv4 HSRP 機能とともにサポートされています。IPv4 マルチキャストはサポートされていません。


CE ルータ(VRF Lite)の multi-VRF ― VRF Lite は、サービス プロバイダーが複数の VPN をサポートして(VRF ベース IPv4 のみを使用)、IP アドレスを重複使用できるようにするための機能です。次のマニュアルを参照してください。

http://www.cisco.com/en/US/products/hw/routers/ps259/prod_bulletin09186a00800921d7.html

シスコ製ルータ上の MPLS ― この機能は、LER で IP パケットのラベルをインポーズしたり削除したり、LSR でラベルをスイッチングするための、基本的な MPLS サポートを提供します。次のマニュアルを参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/software/ios120/120newft/120limit/120st/120st21/fs_rtr.htm

MPLS TE ― MPLS トラフィック エンジニアリング ソフトウェアにより、MPLS バックボーンはレイヤ 2 ATM およびフレーム リレー ネットワークのトラフィック エンジニアリング機能を反復および拡張できます。したがって、MPLS トラフィック処理により従来のレイヤ 2 機能をレイヤ 3 トラフィック フローでも利用できます。詳細については、以下のマニュアルを参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122cgcr/fswtch_c/swprt3/xcftagc.htm

http://www.cisco.com/warp/public/105/mplsteisis.html

http://www.cisco.com/warp/public/105/mpls_te_ospf.html

MPLS TE DiffServ 認識(DS-TE) ― この機能は、MPLS TE に対する拡張を提供し、これを DiffServ 認識にして、保証されたトラフィックの制約に基づくルーティングを可能にします。次のマニュアルを参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/software/ios122s/122snwft/release/122s18/fsdserv3.htm

MPLS TE 転送隣接 ― この機能により、ネットワーク管理者はトラフィック エンジニアリングである Label-Switched Path(LSP)トンネルを、Shortest Path First(SPF)アルゴリズムに基づいた IGP ネットワーク内のリンクとして処理できます。Intermediate System-to-Intermediate System(IS-IS)を用いた転送隣接の詳細については、次のマニュアルを参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/software/ios122s/122snwft/release/122s18/fstefa_3.htm

MPLS TE Interarea トンネル ― この機能により、ルータは複数の IGP 領域およびレベルにまたがる MPLS TE トンネルを確立して、トンネルの最初と最後のルータを同じ領域におく必要がある制約事項を削除できます。次のマニュアルを参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/software/ios122s/122snwft/release/122s18/fsiarea3.htm

MPLS VPN ― この機能を使用すると、Cisco IOS ネットワーク上に容易に拡張できる IPv4 レイヤ 3 VPN バックボーン サービスを導入することが可能です。次のマニュアルを参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/software/ios120/120newft/120limit/120st/120st21/fs_vpn.htm

MPLS VPN Carrier Supporting Carrier(CSC) ― この機能を使用すると、MPLS VPN ベース サービス プロバイダーは、バックボーン ネットワークのセグメントの使用を他のサービス プロバイダーに許可できます。次のマニュアルを参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122newft/122t/122t8/ftcsc8.htm

MPLS VPN CSC IPv4 BGP ラベル配布 ― この機能を使用すると、Border Gateway Protocol(BGP)がバックボーン キャリア Provider Edge(PE; プロバイダー エッジ)ルータとカスタマー キャリア Customer Edge(CE; カスタマー エッジ)ルータ間でルートおよび MPLS ラベルを送信できるように、ご使用の CSC ネットワークを設定できます。次のマニュアルを参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122newft/122t/122t13/ftcscl13.htm

MPLS VPN Interautonomous System(InterAS)のサポート ― この機能を使用すると、MPLS VPN をサービス プロバイダーおよび Autonomous System(AS; 自律システム)に拡張できます。次のマニュアルを参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/software/ios120/120newft/120limit/120s/120s24/fsias24.htm

MPLS VPN InterAS IPv4 BGP ラベル配布 ― この機能を使用すると、Autonomous System Boundary Router(ASBR; 自律システム境界ルータ)が IPv4 ルートを PE ルータの MPLS ラベルと交換できるように、VPN サービス プロバイダー ネットワークを設定できます。次のマニュアルを参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122newft/122t/122t13/ftiasl13.htm

MPLS VPN Hot Standby Router Protocol(HSRP)のサポート ― この機能を使用すると、グローバル ルーティング テーブルではなく、正しい IP ルーティング テーブルに、HSRP 仮想 IP アドレスが追加されます。次のマニュアルを参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121newft/121t/121t3/dt_hsmp.htm

MPLS VPNの OSPF 模造リンク サポート ― この機能を使用すると、模造リンクを使用して、Open Shortest Path First(OSPF)プロトコルが稼働する VPN クライアント サイトに接続し、MPLS VPN コンフィギュレーション内で OSPF リンクを共有できます。次のマニュアルを参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122newft/122t/122t8/ospfshmk.htm

AtoM ― MPLS バックボーン上でレイヤ 2 パケットを送信します。「AToM」を参照してください。

MPLS の注意事項および制約事項

PFC3BXL または PFC3B MPLS を設定する場合、次の注意事項および制約事項に注意してください。

PFC3BXL または PFC3B モードでは、最大 8 個の負荷分散パスをサポートできます。他のプラットフォーム用の Cisco IOS リリースでサポートできる負荷分散パスは、8 個のみです。

PFC3BXL または PFC3B モードは、MTU のチェックおよびフラグメンテーションをサポートします。


) フラグメンテーションは(IP/MPLS パスの)ソフトウェアでサポートされます。
Catalyst 6500 Series Switch Cisco IOS Command Reference』Release 12.2SX の mtu コマンドを参照してください。



) その他の制限および制約事項については、「MPLS VPN の注意事項および制約事項」および「EoMPLS の注意事項および制約事項」を参照してください。


PFC3BXL および PFC3B モード MPLS でサポートされるコマンド

PFC3BXL および PFC3B モード MPLS では、次のコマンドがサポートされます。

mpls ip default route

mpls ip propagate-ttl

mpls ip ttl-expiration pop

mpls label protocol

mpls label range

mpls ip

mpls label protocol

mpls mtu

詳細については、以下のマニュアルを参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122cgcr/fswtch_r/index.htm

MPLS の設定

MPLS の設定手順については、次の URL にある『Multiprotocol Label Switching on Cisco Routers』のマニュアルを参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122cgcr/fswtch_c/swprt3/xcftagc.htm

MPLS のラベル単位ロードバランス

ここでは、基本的な MPLS、MLPS レイヤ 2 VPN、MPLS レイヤ 3 VPN ロードバランスの情報について説明します。

基本的な MPLS ロードバランス

ロードバランス パスの最大数は 8 です。PFC3BXL または PFC3B は、明示的に設定されていない場合でも MPLS ラベルの付けられたパケットを転送します。パケットに添付されたラベルが 3 つ以下で、基礎となるパケットが IPv4 の場合、PFC3BXL または PFC3B は送信元および宛先 IPv4 アドレスを使用します。基礎となるパケットが IPv4 でなく、4 つ以上のラベルが存在する場合、PFC3BXL または PFC3B は 5 番めまたは最下位ラベルまでを解析して、ハッシュに使用します。

MPLS レイヤ 2 VPN ロードバランス

カスタマー イーサネット フレームの MAC(メディア アクセス制御)アドレスの最初のニブルが 4 以外の場合、ロードバランスは MPLS コアの VC ラベルに基づきます。


) レイヤ 2 VPN の場合、入力 PE ではロードバランスはサポートされません。


MPLS レイヤ 3 VPN ロードバランス

MPLS レイヤ 3 VPN ロードバランスは、基本的な MPLS ロードバランスと類似しています。詳細については、「基本的な MPLS ロードバランス」を参照してください。

MPLS の設定例

次に、MPLS の基本設定の例を示します。

*****
Basic MPLS
*****
 
 
IP ingress interface:
 
Router# mpls label protocol ldp
 
interface GigabitEthernet6/2
ip address 75.0.77.1 255.255.255.0
media-type rj45
speed 1000
end
 
Label egress interface:
 
interface GigabitEthernet7/15
mtu 9216
ip address 75.0.67.2 255.255.255.0
logging event link-status
mpls ip
 
 
Router# show ip route 188.0.0.0
Routing entry for 188.0.0.0/24, 1 known subnets
 
O IA 188.0.0.0 [110/1] via 75.0.77.2, 00:00:10, GigabitEthernet6/2
 
 
Router#sh ip ro 88.0.0.0
Routing entry for 88.0.0.0/24, 1 known subnets
 
O E2 88.0.0.0 [110/0] via 75.0.67.1, 00:00:24, GigabitEthernet7/15
[110/0] via 75.0.21.2, 00:00:24, GigabitEthernet7/16
Router#
 
 
Router# show mpls forwarding-table 88.0.0.0
Local Outgoing Prefix Bytes tag Outgoing Next Hop
tag tag or VC or Tunnel Id switched interface
30 50 88.0.0.0/24 0 Gi7/15 75.0.67.1
50 88.0.0.0/24 0 Gi7/16 75.0.21.2
 
 
Router# show mls cef 88.0.0.0 detail
 
Codes: M - mask entry, V - value entry, A - adjacency index, P - priority bit
D - full don't switch, m - load balancing modnumber, B - BGP Bucket sel
V0 - Vlan 0,C0 - don't comp bit 0,V1 - Vlan 1,C1 - don't comp bit 1
RVTEN - RPF Vlan table enable, RVTSEL - RPF Vlan table select
Format: IPV4_DA - (8 | xtag vpn pi cr recirc tos prefix)
Format: IPV4_SA - (9 | xtag vpn pi cr recirc prefix)
M(3223 ): E | 1 FFF 0 0 0 0 255.255.255.0
V(3223 ): 8 | 1 0 0 0 0 0 88.0.0.0 (A:344105 ,P:1,D:0,m:1 ,B:0 )
M(3223 ): E | 1 FFF 0 0 0 255.255.255.0
V(3223 ): 9 | 1 0 0 0 0 88.0.0.0 (V0:0 ,C0:0 ,V1:0 ,C1:0 ,RVTEN:0 ,RVTSEL:0 )
Router# show mls cef adj ent 344105
 
Index: 344105 smac: 0005.9a39.a480, dmac: 000a.8ad8.2340
mtu: 9234, vlan: 1031, dindex: 0x0, l3rw_vld: 1
packets: 109478260, bytes: 7006608640
 
Router# show mls cef adj ent 344105 de
 
Index: 344105 smac: 0005.9a39.a480, dmac: 000a.8ad8.2340
mtu: 9234, vlan: 1031, dindex: 0x0, l3rw_vld: 1
format: MPLS, flags: 0x1000008418
label0: 0, exp: 0, ovr: 0
label1: 0, exp: 0, ovr: 0
label2: 50, exp: 0, ovr: 0
op: PUSH_LABEL2
packets: 112344419, bytes: 7190042816
 

PFC3BXL または PFC3B モード VPN スイッチング

ここでは、PFC3BXL または PFC3B モード VPN スイッチングについて説明します。

「PFC3BXL または PFC3B モード VPN スイッチング処理」

「MPLS VPN の注意事項および制約事項」

「PFC3BXL または PFC3B モード MPLS VPN でサポートされるコマンド」

「MPLS VPN の設定例」

PFC3BXL または PFC3B モード VPN スイッチング処理

MPLS の IP VPN 機能により Cisco IOS ネットワークは、拡張が容易な IP レイヤ 3 VPN バックボーン サービスを共有インフラストラクチャに配置された複数のサイトに展開し、同時にプライベート ネットワークと同じアクセスまたはセキュリティを提供できます。MPLS テクノロジーに基づいた VPN には、ルーティングの隔離、セキュリティの向上、ルーティングの簡素化、スケーラビリティの向上という利点があります。

MPLS VPN の概要および詳細な設定については、次の URL にある Cisco IOS ソフトウェア マニュアルを参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122cgcr/fswtch_c/swprt3/index.htm

図25-3 に、一般的な MPLS VPN ネットワーク トポロジーを示します。

図25-3 VPN およびサービス プロバイダー バックボーン

 

PFC3BXL または PFC3B は、入力 PE でパケット ヘッダーに基づいて転送を判断します。PFC3BXL または PFC3B には、VLAN を VPN にマッピングするテーブルが含まれます。Catalyst 6500 シリーズ スイッチ アーキテクチャでは、システム内のすべての物理入力インターフェイスが特定の VPN に対応付けられます。PFC3BXL または PFC3B は CEF テーブル内で IP 宛先アドレスを検索しますが、対象となるのは特定の VPN 内のプレフィクスのみです(テーブル エントリは特定の隣接セットを指します。複数のパラレル パスが存在する場合は、ロードバランス判断によって特定の隣接が選択されます)。

テーブル エントリには、パケットに必要なレイヤ 2 ヘッダー情報、およびフレームにプッシュされる特定の MPLS ラベルが含まれます。パケット書き替え用のこの情報は、入力ライン カードに送信されて書き替えが行われ、出力ライン インターフェイスに転送されます。

VPN トラフィックはプレフィクス単位のラベルまたは集約ラベルに基づいて、PE からの出口で処理されます。プレフィクス単位のラベルが使用される場合、各 VPN プレフィクスには一意のラベルが対応付けられます。これにより、PE は FIB 内のラベル検索に基づいて、パケットを最終宛先に転送できます。


) PFC3BXL または PFC3B が割り当てるのは、VRF ごとに 1 つの集約ラベルのみです。


出力 PE のディスポジションに集約ラベルが使用される場合、複数のインターフェイスの多数のプレフィクスをこのラベルに対応付けることができます。この場合、PFC3BXL または PFC3B は IP 検索を実行して最終宛先を判別する必要があります。IP 検索では再循環を必要とする場合があります。

MPLS VPN の注意事項および制約事項

MPLS VPN を設定する際に、以下の注意事項と制約事項に従ってください。

PFC3BXL または PFC3B モードでは、拡張 OSM を使用してシャーシごとに合計 1024 個の VRF をサポートします。非拡張 OSM を使用すると、システムはデフォルトの VRF 数 511 になります。

PFC3BXL または PFC3B モードでは、VPN 数が 511 を超えると VPN が再循環されます。

PFC3BXL または PFC3B モード MPLS VPN でサポートされるコマンド

PFC3BXL および PFC3B モード MPLS VPN では、次のコマンドがサポートされます。

address-family

exit-address-family

import map

ip route vrf

ip route forwarding

ip vrf

neighbor activate

rd

route-target

詳細については、以下のマニュアルを参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122cgcr/fswtch_r/index.htm

MPLS VPN の設定

MPLS VPN の設定手順については、次の URL にある『MPLS Virtual Private Networks』フィーチャ モジュールを参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122cgcr/fswtch_c/swprt3/xcftagc.htm#63744


) 別の MPLS装置とのレイヤ 2 ポート ピアリングを使用する MPLS アップリンクとしてレイヤ 3 VLAN インターフェイスを使用した場合、VRF インターフェイスとして別のレイヤ 3 VLAN を使用できます。


MPLS VPN の設定例

次に、LAN、OSM、および FlexWAN CE 方向のインターフェイスのコンフィギュレーション例を示します。PFC3BXL または PFC3B モード MPLS スイッチング コンフィギュレーションは、他のプラットフォームのコンフィギュレーションと同様です。

!ip vrf blues
rd 100:10
route-target export 100:1
route-target import 100:1
!
mpls label protocol ldp
mpls ldp logging neighbor-changes
mls mpls tunnel-recir
!
interface Loopback0
ip address 10.4.4.4 255.255.255.255
!
interface GigabitEthernet4/2
description Catalyst link to P2
no ip address
mls qos trust dscp
!
interface GigabitEthernet4/2.42
encapsulation dot1Q 42
ip address 10.0.3.2 255.255.255.0
tag-switching ip
!
interface GigabitEthernet7/3
description Catalyst link to CE2
no ip address
mls qos trust dscp
!
interface GigabitEthernet7/3.73
encapsulation dot1Q 73
ip vrf forwarding blues
ip address 10.19.7.1 255.255.255.0
!
interface POS8/1
description OSM link to CE3
ip vrf forwarding blues
ip address 10.19.8.1 255.255.255.252
encapsulation ppp
mls qos trust dscp
pos scramble-atm
pos flag c2 22
!
interface POS9/0/0
description FlexWAN link to CE1
ip vrf forwarding blues
ip address 10.19.9.1 255.255.255.252
encapsulation ppp
pos scramble-atm
pos flag c2 22
!
router ospf 100
log-adjacency-changes
network 10.4.4.4 0.0.0.0 area 0
network 10.0.0.0 0.0.255.255 area 0
!
router ospf 65000 vrf blues
log-adjacency-changes
redistribute bgp 100 subnets
network 10.19.0.0 0.0.255.255 area 0
!
router bgp 100
no synchronization
bgp log-neighbor-changes
neighbor 10.3.3.3 remote-as 100
neighbor 10.3.3.3 description MP-BGP to PE1
neighbor 10.3.3.3 update-source Loopback0
no auto-summary
!
address-family vpnv4
neighbor 10.3.3.3 activate
neighbor 10.3.3.3 send-community extended
exit-address-family
!
address-family ipv4 vrf blues
redistribute connected
redistribute ospf 65000 match internal external 1 external 2
no auto-summary
no synchronization
exit-address-family
!

AToM

AtoM は、MPLS バックボーン上でレイヤ 2 パケットを送信します。AToM はエッジ ルータの間で転送された LDP セッションを使用して、接続の設定およびメンテナンスを行います。2 つのレベルのラベルを使用して、エッジ ルータ間でスイッチングを行うと、転送が発生します。外部ラベル(トンネル ラベル)は、MPLS バックボーンを介して入力 PE から出力 PE にパケットをルーティングします。VC ラベルは、トンネル エンドポイント(出力 PE の特定の出力インターフェイスおよびイーサネット フレームのVLAN ID)で接続を判別する Demux ラベルです。

AToM は、PFC3BXL または PFC3B モードに関して次の類似したトランスポート タイプをサポートします。

EoMPLS(VLAN モードおよびポート モード)

DLCI 間接続による Frame Relay over MPLS(FRoMPLS)

ATM AAL5 over MPLS

ATM Cell Relay over MPLS


) その他の AToM タイプが今後のリリースに組み込まれる予定です。


PFC3BXL または PFC3B モードは、ハードウェアベースの EoMPLS および OSM ベース、FlexWAN ベースまたは FlexWAN2 ベースの EoMPLS をサポートします。詳細については、以下のマニュアルを参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/core/cis7600/cfgnotes/optical/122sx/mpls.htm#wp1128955

Supervisor Engine 2 ベースの EoMPLS の要件の詳細については、以下のマニュアルを参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/core/cis7600/cfgnotes/optical/122sx/mpls.htm#wp1270404

その他の AToM 実装(ATM AAL5 over MPLS、ATM Cell Relay over MPLS、Frame Relay over MPLS)については、以下のマニュアルを参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/core/cis7600/cfgnotes/optical/122sx/mpls.htm#wp1279824

ここでは AToM について説明します。

「AToM ロードバランス」

「EoMPLS の概要」

「EoMPLS の注意事項および制約事項」

「EoMPLS の設定」

AToM ロードバランス

PFC3BXL または PFC3B モード EoMPLS の場合、トンネル入口ではロードバランスは行われません。複数の IGP パスを使用できる場合でも、IGP パスは1つのみ選択されますが、MPLS コアではロードバランスを使用できます。

EoMPLS の概要

EoMPLS は AToM トランスポート タイプの 1 つです。AToM はエッジ ルータの間で転送された LDP セッションを使用して、MPLS バックボーンを介してレイヤ 2 パケットを転送し、接続を設定およびメンテナンスします。2 つのレベルのラベルを使用して、エッジ ルータ間でスイッチングを行うと、転送が発生します。外部ラベル(トンネル ラベル)は、MPLS バックボーンを介して入力 PE から出力 PE にパケットをルーティングします。VC ラベルは、トンネル エンドポイント(出力 PE の特定の出力インターフェイスおよびイーサネット フレームのVLAN ID)で接続を判別する Demux ラベルです。

EoMPLS は MPLS パケットに Ethernet PDU をカプセル化し、MPLS ネットワーク上で転送することにより機能します。各 PDU は単一パケットとして送信されます。


) 同じ VLAN 上でローカルなレイヤ 2 スイッチングおよび EoMPLS を実行する場合は、OSM ベースのEoMPLS を使用してください。SVI に EoMPLS を設定する必要があります。コア方向のカードは OSM でなければなりません。ローカルなレイヤ 2 スイッチングが不要な場合、サブインターフェイスまたは物理インターフェイスに設定された PFC ベースの EoMPLS を使用してください。


EoMPLS の注意事項および制約事項

EoMPLS を設定する際に、以下の注意事項と制約事項に従ってください。

受信された最大のレイヤ 2 VLAN を伝送できるように、エンドポイント間のすべての中間リンクの MTU を設定する必要があります。

EoMPLS は、IEEE 802.1Q 標準に準拠する VLAN パケットをサポートします。802.1Q 仕様は、イーサネット フレームに VLAN メンバーシップ情報を挿入する標準方式を確立します。

QoS がグローバルにディセーブルになっている場合、802.1p および IP precedence ビットは両方とも保護されます。QoS がレイヤ 2 ポートでイネーブルになっている場合、802.1Q P ビットまたは IP precedence ビットのいずれかを、信頼できる設定を使用して保護できます。ただし、デフォルトでは、保護されていないビットは保護されたビットの値によって上書きされます。たとえば、P ビットが保護されている場合、IP precedence ビットは P ビットの値で上書きされます。PFC3BXL または PFC3B モードには、IP precedence ビットを保護しながら、P ビットを信頼できるようにする新しいコマンドが装備されています。IP precedence ビットを保護するには、no mls qos rewrite ip dscp コマンドを使用します。


) no mls qos rewrite ip dscp コマンドは、MPLS および MPLS VPN 機能と互換性がありません。第42章「PFC QoS の設定」を参照してください。



) 同じシステム内で PFC ベースの EoMPLS サービスおよび PXF ベースの EoMPLS サービスを使用する場合は、no mls qos rewrite ip dscp コマンドを使用しないでください。


プライベート VLAN では、EoMPLS はサポートされません。

EoMPLS でトランクを使用する場合は、次の制約事項が適用されます。

EoMPLS クラウドでイーサネット スパニングツリー Bridge Protocol Data Unit(BPDU; ブリッジ プロトコル データ ユニット)をサポートするには、MPLS VLAN 上のイーサネットのスーパーバイザ エンジン スパニングツリーをディセーブルにする必要があります。これにより、EoMPLS VLAN のカスタマー スイッチへの伝送経路がトランクに限定されます。このようにしないと、BPDU はスーパーバイザ エンジンに転送され、EoMPLS クラウドに転送されません。

トランクのネイティブ VLAN を EoMPLS VLAN として設定しないでください。

PFC3BXL または PFC3B モードでは、すべてのプロトコル(CDP、VTP、BPDU など)は無条件に MPLS クラウドでトンネリングされます。

EoMPLS パケットを受信するインターフェイスでは、ISL(スイッチ間リンク)カプセル化はサポートされません。

インターフェイス間では一意の VLAN が必要です。異なるインターフェイスで同じ VLAN を使用することはできません。

PE 間の LSP を確保するには、ルーティング テーブルおよび CEF テーブル内の EoMPLS トンネル宛先ルートが/32 アドレス(マスクが 255.255.255.255 であるホスト アドレス)でなければなりません。

特定の EoMPLS 接続では、入力 PE の入力 EoMPLS インターフェイスおよび出力 PE の出力 EoMPLS インターフェイスを、dot1Q カプセル化が設定されたサブインターフェイスにする必要があります。このようにしないと、どちらもサブインターフェイスになりません。

MPLS ネットワークに接続された発信インターフェイスがレイヤ 2 カードのポートである場合、802.1Q-in-802 over EoMPLS がサポートされます。

MPLS ネットワークに接続された出力インターフェイスがレイヤ 2 LAN ポート(PFC ベース EoMPLS と呼ばれるモード)である場合、EoMPLS トラフィックのシェーピングはサポートされません。

PFC3BXL または PFC3B に基づいた EoMPLS では、宛先 MAC アドレスがローカルまたはリモート セグメント上にあるかどうかを判別するためのレイヤ 2 検索を実行しません。また、レイヤ 2 アドレス学習も実行しません(従来の LAN ブリッジングが実行します)。この機能(ローカル スイッチング)を使用できるのは、OSM および FlexWAN モジュールをアップリンクとして使用している場合のみです。

AToM の旧リリースでは、AToM 回路を設定するのに使用するコマンドは mpls l2 transport route でした。このコマンドは、xconnect コマンドで置き換えられています。xconnect コマンドを使用して EoMPLS 回路を設定できます。

AToM 制御ワードはサポートされていません。

EoMPLS は、レイヤ 3 VLAN インターフェイスではサポートされません。

ポイントツーポイント EoMPLS は、物理インターフェイスおよびサブインターフェイスと連動します。

前提条件

EoMPLS を設定する前に、ネットワークが次のように設定されていることを確認してください。

PE ルータが IP 経由で相互に到達できるように、コアに IP ルーティングを設定します。

PE ルータ間で LSP が存在するように、コアに MPLS を設定します。

EoMPLS は MPLS パケットに Ethernet PDU をカプセル化し、MPLS ネットワーク上で転送することにより機能します。各 PDU は単一パケットとして送信されます。PFC3BXL または PFC3B モードで EoMPLS を設定する場合、次の 2 つの方法を使用できます。

VLANモード ― MPLS ネットワーク上の単一 VC を介して、送信元 802.1Q VLAN から宛先 802.1Q VLAN にイーサネット トラフィックをトランスポートします。VLAN モードは、デフォルトとして VC タイプ 5(dot1q タグなし)を使用します。リモート PE サブインターフェイス(VLAN)ベースの EoMPLS に対して VC タイプ 5 をサポートしない場合は、VC タイプ 4(トランスポート dot1 タグ)を使用します。

ポート モード ― ポートのすべてのトラフィックが MPLS ネットワーク上の単一 VC を共有できるようにします。ポート モードは VC タイプ 5 を使用します。


) • VLAN モードおよびポート モードのどちらの場合も、ループバック ポートを使用しないかぎり、PFC3BXL および PFC3B モード EoMPLS はインターフェイス間におけるパケットのローカル スイッチングを許可しません。

システムでは、OSM または FlexWAN 設定、および PFC3BXL または PFC3B モード設定を同時にイネーブルにできます。シスコはこの設定をサポートしますが、推奨しません。MPLS コアへのアップリンクが OSM または FlexWAN 対応インターフェイスを経由しない場合、OSM またはFlexWAN ベースの EoMPLS 接続はアクティブになりません。このため、非 WAN インターフェイスに着信する OSM または FlexWAN ベースの EoMPLS に対応するパケットは廃棄されます。WAN(FlexWAN および OSM)EoMPLS の詳細については、以下のマニュアルを参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/core/cis7600/cfgnotes/optical/122sx/mpls.htm#wp1128955


 

PFC3BXL または PFC3B モード は MPLS をサポートします。PFC3BXL または PFC3B モードでは、LAN ポートは OSM または FlexWAN モジュールを使用しなくても、レイヤ 2 トラフィックを受信し、ラベルをインポーズし、フレームを MPLS コアにスイッチングできます。

PFC3BXL または PFC3B モードでは、MPLS ネットワークのコア方向の OSM または FlexWAN モジュールを装備することができます。この場合、OSM 設定または FlexWAN 設定、あるいは PFC3BXL または PFC3B モード設定のいずれかを使用できます。詳細については、以下のマニュアルを参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/core/cis7600/cfgnotes/optical/122sx/mpls.htm#wp1128955

PFC3BXL および PFC3B モード VLAN ベース EoMPLS の設定

PFC3BXL または PFC3B モード VLAN ベース EoMPLS を設定する場合、次の注意事項および制約事項 に注意してください。

AToM 制御ワードはサポートされていません。

ハードウェアレベルの CRC エラー、フレーミング エラー、ラント パケットを含むイーサネット パケットは、入力時に廃棄されます。

サブインターフェイスに VLAN ベース EoMPLS を設定する必要があります。

PFC3BXL または PFC3B モード VLAN ベース EoMPLS を設定する場合、PE ルータで次の作業を行ってください。

 

コマンド
目的

ステップ 1

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

Router(config)# interface gigabitethernetslot/interface.subinterface

ギガビット イーサネット サブインターフェイスを指定します。隣接 CE ルータのサブインターフェイスがこの PE ルータと同じ VLAN 上にあることを確認します。

ステップ 3

Router(config-if)# encapsulation dot1q vlan_id

サブインターフェイスでの 802.1Q VLAN パケットの受信をイネーブルにします。

EoMPLS が稼働している CE ルータと PE ルータ間のサブインターフェイスは、同じサブネット内に存在する必要があります。その他のすべてのサブインターフェイスおよびバックボーン ルータは、同じサブネット内に存在する必要はありません。

ステップ 4

Router(config-if)# xconnect peer_router_id vcid encapsulation mpls

接続回路を疑似接続 VC にバインドします。このコマンドの構文は、その他のレイヤ 2 トランスポートの場合と同じです。

次に、PFC3BXL または PFC3B モード VLAN ベース EoMPLS 設定の例を示します。

!
interface GigabitEthernet6/4
xconnect 13.13.13.13 4 encapsulation mpls
no shut
!
interface GigabitEthernet7/4.2
encapsulation dot1Q 3
xconnect 13.13.13.13 3 encapsulation mpls
no shut
 

) IP アドレスは CE 装置のサブインターフェイス上で設定されます。


設定の確認

MPLS トンネルを介したレイヤ 2 VLAN トランスポートの設定を確認および表示するには、次の作業を行います。

VLAN ごとの VLAN 名、ステータス、ポートを 1 行で表示するには、show vlan brief コマンドを使用します。

Router# show vlan brief
 
VLAN Name Status Ports
---- -------------------------------- --------- -------------------------
1 default active
2 VLAN0002 active
3 VLAN0003 active
1002 fddi-default act/unsup
1003 token-ring-default act/unsup
1004 fddinet-default act/unsup
1005 trnet-default act/unsup
 

PE ルータ エンドポイントが相互に検出されたことを確認するには、show mpls ldp discovery コマンドを使用します。PE ルータが別の PE ルータから LDP Hello メッセージを受信した場合、そのルータおよび指定されたラベル スペースは「検出された」とみなされます。

Router# show mpls ldp discovery
Local LDP Identifier:
13.13.13.13:0
Discovery Sources:
Interfaces:
GE-WAN3/3 (ldp): xmit/recv
LDP Id: 12.12.12.12:0
Targeted Hellos:
13.13.13.13 -> 11.11.11.11 (ldp): active/passive, xmit/recv
LDP Id: 11.11.11.11:0
 

ラベル配布セッションが確立されたことを確認するには、show mpls ldp neighbor コマンドを使用します。出力の 3 行めは、LDP セッションのステートが動作可能であり、メッセージが送受信中であることを示します。

Router# show mpls ldp neighbor
Peer LDP Ident: 12.12.12.12:0; Local LDP Ident 13.13.13.13:0
TCP connection: 12.12.12.12.646 - 13.13.13.13.11010
State: Oper; Msgs sent/rcvd: 1649/1640; Downstream
Up time: 23:42:45
LDP discovery sources:
GE-WAN3/3, Src IP addr: 34.0.0.2
Addresses bound to peer LDP Ident:
23.2.1.14 37.0.0.2 12.12.12.12 34.0.0.2
99.0.0.1
Peer LDP Ident: 11.11.11.11:0; Local LDP Ident 13.13.13.13:0
TCP connection: 11.11.11.11.646 - 13.13.13.13.11013
State: Oper; Msgs sent/rcvd: 1650/1653; Downstream
Up time: 23:42:29
LDP discovery sources:
Targeted Hello 13.13.13.13 -> 11.11.11.11, active, passive
Addresses bound to peer LDP Ident:
11.11.11.11 37.0.0.1 23.2.1.13
 

ラベル転送テーブルが正しく構築されたことを確認するには、show mpls forwarding-table コマンドを入力して、リモート PE のラベルが学習されたこと、およびこのラベルが正しいインターフェイスから正しいネクストホップに送信されていることを確認します。

Router# show mpls forwarding-table
Local Outgoing Prefix Bytes tag Outgoing Next Hop
tag tag or VC or Tunnel Id switched interface
16 Untagged 223.255.254.254/32 \
0 Gi2/1 23.2.0.1
20 Untagged l2ckt(2) 133093 Vl2 point2point
21 Untagged l2ckt(3) 185497 Vl3 point2point
24 Pop tag 37.0.0.0/8 0 GE3/3 34.0.0.2
25 17 11.11.11.11/32 0 GE3/3 34.0.0.2
26 Pop tag 12.12.12.12/32 0 GE3/3 34.0.0.2
Router#
 

出力では次のデータが表示されます。

Local tag ― このルータによって割り当てられたラベル

Outgoing tag or VC ― ネクストホップによって割り当てられたラベル

Prefix or Tunnel ID ― このラベルが添付されたパケットの送信先アドレスまたはトンネル

Bytes tag switched ― この着信ラベルによってスイッチングされるバイト数

Outgoing interface ― このラベルが添付されたパケットが送信されるインターフェイス

Next Hop ― 発信ラベルに割り当てられたネイバの IP アドレス

現在ルーティングされている VC のステートを表示するには、show mpls l2transport vc コマンドを入力します。

Router# show mpls l2transport vc
 
Local intf Local circuit Dest address VC ID Status
------------- -------------------- --------------- ---------- ----------
Vl2 Eth VLAN 2 11.11.11.11 2 UP
Vl3 Eth VLAN 3 11.11.11.11 3 UP
 

各 VC の詳細情報を表示するには、detail キーワードを追加します。

Router# show mpls l2transport vc detail
Local interface: Vl2 up, line protocol up, Eth VLAN 2 up
Destination address: 11.11.11.11, VC ID: 2, VC status: up
Tunnel label: 17, next hop 34.0.0.2
Output interface: GE3/3, imposed label stack {17 18}
Create time: 01:24:44, last status change time: 00:10:55
Signaling protocol: LDP, peer 11.11.11.11:0 up
MPLS VC labels: local 20, remote 18
Group ID: local 71, remote 89
MTU: local 1500, remote 1500
Remote interface description:
Sequencing: receive disabled, send disabled
VC statistics:
packet totals: receive 1009, send 1019
byte totals: receive 133093, send 138089
packet drops: receive 0, send 0
 
Local interface: Vl3 up, line protocol up, Eth VLAN 3 up
Destination address: 11.11.11.11, VC ID: 3, VC status: up
Tunnel label: 17, next hop 34.0.0.2
Output interface: GE3/3, imposed label stack {17 19}
Create time: 01:24:38, last status change time: 00:10:55
Signaling protocol: LDP, peer 11.11.11.11:0 up
MPLS VC labels: local 21, remote 19
Group ID: local 72, remote 90
MTU: local 1500, remote 1500
Remote interface description:
Sequencing: receive disabled, send disabled
VC statistics:
packet totals: receive 1406, send 1414
byte totals: receive 185497, send 191917
packet drops: receive 0, send 0

PFC3BXL および PFC3B モード ポートベース EoMPLS の設定

PFC3BXL または PFC3B モード ポートベース EoMPLS を設定する場合、次の注意事項および制約事項 に注意してください。

AToM 制御ワードはサポートされていません。

ハードウェアレベルの CRC エラー、フレーミング エラー、ラント パケットを含むイーサネット パケットは、入力時に廃棄されます。

ポートベース EoMPLS および VLAN ベース EoMPLS は相互に排他的な関係です。メイン インターフェイスでポートツーポート トランスポートをイネーブルにした場合、サブインターフェイスでのコマンドも入力できません。

PFC3BXL または PFC3B モードで EoMPLS による 802.1Q-in-802.1Q トラフィックおよびイーサネット トラフィックをサポートするには、次の作業を行って、ポートベースの EoMPLS を設定します。

 

コマンド
目的

ステップ 1

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

Router(config)# interface gigabitethernetslot/interface

ギガビット イーサネット インターフェイスを指定します。隣接 CE ルータのインターフェイスがこの PE ルータと同じ VLAN 上にあることを確認します。

ステップ 3

Router(config-if)# xconnect peer_router_id vcid encapsulation mpls

接続回路を疑似接続 VC にバインドします。このコマンドの構文は、その他のレイヤ 2 トランスポートの場合と同じです。

次に、ポートベースの基本設定の例を示します。

!
EoMPLS:
 
router# show mpls l2transport vc
 
Local intf Local circuit Dest address VC ID Status
------------- -------------------- --------------- ---------- ----------
Fa8/48 Ethernet 75.0.78.1 1 UP
Gi7/11.2000 Eth VLAN 2000 75.0.78.1 2000 UP
 
 
Port-Based EoMPLS Config:
 
router# show run interface f8/48
Building configuration...
 
Current configuration : 86 bytes
!
interface FastEthernet8/48
no ip address
xconnect 75.0.78.1 1 encapsulation mpls
end
 
Sub-Interface Based Mode:
router# show run interface g7/11
Building configuration...
 
Current configuration : 118 bytes
!
interface GigabitEthernet7/11
description Traffic-Generator
no ip address
logging event link-status
speed nonegotiate
end
 
router# show run int g7/11.2000
Building configuration...
 
Current configuration : 112 bytes
!
interface GigabitEthernet7/11.2000
encapsulation dot1Q 2000
xconnect 75.0.78.1 2000 encapsulation mpls
end
 
kb7606# show mpls l2transport vc 1 detail
Local interface: Gi7/47 up, line protocol up, Ethernet up
Destination address: 75.0.80.1, VC ID: 1, VC status: up
Tunnel label: 5704, next hop 75.0.83.1
Output interface: Te8/3, imposed label stack {5704 10038}
Create time: 00:30:33, last status change time: 00:00:43
Signaling protocol: LDP, peer 75.0.80.1:0 up
MPLS VC labels: local 10579, remote 10038
Group ID: local 155, remote 116
MTU: local 1500, remote 1500
Remote interface description:
Sequencing: receive disabled, send disabled
VC statistics:
packet totals: receive 26, send 0
byte totals: receive 13546, send 0
packet drops: receive 0, send 0
 

VC タイプを取得するには、次のコマンドを使用します。

kb7606# remote command switch show mpls l2transport vc 1 de
 
Local interface: GigabitEthernet7/47, Ethernet
Destination address: 75.0.80.1, VC ID: 1
VC status: receive UP, send DOWN
VC type: receive 5, send 5
Tunnel label: not ready, destination not in LFIB
Output interface: unknown, imposed label stack {}
MPLS VC label: local 10579, remote 10038
Linecard VC statistics:
packet totals: receive: 0 send: 0
byte totals: receive: 0 send: 0
packet drops: receive: 0 send: 0
Control flags:
receive 1, send: 31
!

設定の確認

MPLS トンネルを介したレイヤ 2 VLAN トランスポートの設定を確認および表示するには、次の作業を行います。

VLAN ごとの VLAN 名、ステータス、ポートを 1 行で表示するには、show vlan brief コマンドを使用します。

Router# show vlan brief
 
VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
1 default active
2 VLAN0002 active Gi1/4
1002 fddi-default act/unsup
1003 token-ring-default act/unsup
1004 fddinet-default act/unsup
1005 trnet-default act/unsup
 

PE ルータ エンドポイントが相互に検出されたことを確認するには、show mpls ldp discovery コマンドを使用します。PE ルータが別の PE ルータから LDP Hello メッセージを受信した場合、そのルータおよび指定されたラベル スペースは「検出された」とみなされます。

Router# show mpls ldp discovery
Local LDP Identifier:
13.13.13.13:0
Discovery Sources:
Interfaces:
GE-WAN3/3 (ldp): xmit/recv
LDP Id: 12.12.12.12:0
Targeted Hellos:
13.13.13.13 -> 11.11.11.11 (ldp): active/passive, xmit/recv
LDP Id: 11.11.11.11:0
 

ラベル配布セッションが確立されたことを確認するには、show mpls ldp neighbor コマンドを使用します。出力の 3 行めは、LDP セッションのステートが動作可能であり、メッセージが送受信中であることを示します。

Router# show mpls ldp neighbor
Peer LDP Ident: 12.12.12.12:0; Local LDP Ident 13.13.13.13:0
TCP connection: 12.12.12.12.646 - 13.13.13.13.11010
State: Oper; Msgs sent/rcvd: 1715/1706; Downstream
Up time: 1d00h
LDP discovery sources:
GE-WAN3/3, Src IP addr: 34.0.0.2
Addresses bound to peer LDP Ident:
23.2.1.14 37.0.0.2 12.12.12.12 34.0.0.2
99.0.0.1
Peer LDP Ident: 11.11.11.11:0; Local LDP Ident 13.13.13.13:0
TCP connection: 11.11.11.11.646 - 13.13.13.13.11013
State: Oper; Msgs sent/rcvd: 1724/1730; Downstream
Up time: 1d00h
LDP discovery sources:
Targeted Hello 13.13.13.13 -> 11.11.11.11, active, passive
Addresses bound to peer LDP Ident:
11.11.11.11 37.0.0.1 23.2.1.13
 

ラベル転送テーブルが正しく構築されたかを確認するには、show mpls forwarding-table コマンドを入力します。

Router# show mpls forwarding-table
Local Outgoing Prefix Bytes tag Outgoing Next Hop
tag tag or VC or Tunnel Id switched interface
16 Untagged 223.255.254.254/32 \
0 Gi2/1 23.2.0.1
20 Untagged l2ckt(2) 55146580 Vl2 point2point
24 Pop tag 37.0.0.0/8 0 GE3/3 34.0.0.2
25 17 11.11.11.11/32 0 GE3/3 34.0.0.2
26 Pop tag 12.12.12.12/32 0 GE3/3 34.0.0.2
 

出力では次のデータが表示されます。

Local tag ― このルータによって割り当てられたラベル

Outgoing tag or VC ― ネクストホップによって割り当てられたラベル

Prefix or Tunnel ID ― このラベルが添付されたパケットの送信先アドレスまたはトンネル

Bytes tag switched ― この着信ラベルによってスイッチングされるバイト数

Outgoing interface ― このラベルが添付されたパケットが送信されるインターフェイス

Next Hop ― 発信ラベルに割り当てられたネイバの IP アドレス

現在ルーティングされている VC のステートを表示するには、show mpls l2transport vc コマンドを入力します。

Router# show mpls l2transport vc
 
Local intf Local circuit Dest address VC ID Status
------------- -------------------- --------------- ---------- ----------
Vl2 Eth VLAN 2 11.11.11.11 2 UP