Cisco IOS ソフトウェア コンフィギュレーション ガイド リリース12.2(33)SXH以降
UDE および UDLR の設定
UDE および UDLR の設定
発行日;2012/02/01 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 18MB) | フィードバック

目次

UDE および UDLR の設定

UDE および UDLR の概要

UDE と UDLR の概要

サポートされるハードウェア

UDE の概要

UDE の概要

ハードウェア ベース UDE の概要

ソフトウェア ベース UDE の概要

UDLR の概要

UDE および UDLR の設定

UDE の設定

UDE 設定時の注意事項

ハードウェア ベース UDE の設定

ソフトウェア ベース UDE の設定

UDLR の設定

UDLR バック チャネル トンネル設定時の注意事項

UDE 送信専用ポートでの受信専用トンネル インターフェイスの設定

UDE 受信専用ポートでの送信専用トンネル インターフェイスの設定

UDE および UDLR の設定

この章では、Catalyst 6500 シリーズ スイッチの Unidirectional Ethernet(UDE; 単一方向イーサネット)および Unidirectional Link Routing(UDLR; 単一方向リンク ルーティング)を設定する手順について説明します。


) • Cisco ME 6500 シリーズ イーサネット スイッチは UDE および UDLR をサポートしません。

この章で使用しているコマンドの構文および使用方法の詳細については、次の URL の『Cisco IOS Master Command List, Release 12.2SX』を参照してください。

http://www.cisco.com/en/US/docs/ios/mcl/122sxmcl/12_2sx_mcl_book.html


 

ここでは、UDE および UDLR の概要について説明します。

「UDE および UDLR の概要」

「UDE および UDLR の設定」

UDE および UDLR の概要

ここでは、UDE および UDLR の概要について説明します。

「UDE と UDLR の概要」

「サポートされるハードウェア」

「UDE の概要」

「UDLR の概要」

UDE と UDLR の概要

ルーティング プロトコルが単一方向リンクをサポートするのは、単一方向リンクが双方向リンクをエミュレートしている場合だけです。これは、同じインターフェイス上でルーティング プロトコルがトラフィックの送受信をするためです。

単一方向リンクが便利なのは、大容量の全二重双方向リンクで確認応答を受けずに大量の単一方向トラフィックを送信する場合(ビデオ ブロードキャスト ストリームなど)、送信元から宛先までのリンクと、宛先から送信元へほとんど確認応答を送らない「バック チャネル」と呼ばれる大容量の逆方向リンクの両方を同じように使用するためです。

UDE および UDLR を使用すると、バック チャネルに同程度の大容量リンクを消費せずに、大量のトラフィックに対して大容量単一方向リンクをサポートできます。UDE は大容量の単一方向リンクを提供します。UDLR は、標準的な容量のリンクにバック チャネルとしてトンネルを提供します。また、UDLR は、バック チャネルが大容量単一方向リンクと同じインターフェイスにあるかのように透過的に見せることによって、双方向リンクのエミュレーションも行います。

サポートされるハードウェア

Catalyst 6500 シリーズ スイッチでは、次のスイッチング モジュールのインターフェイスで UDE と UDLR がサポートされています。

WS-X6704-10GE 4 ポート 10 ギガビット イーサネット

WS-X6816-GBIC 16 ポート ギガビット イーサネット

WS-X6516A-GBIC 16 ポート ギガビット イーサネット

WS-X6516-GBIC 16 ポート ギガビット イーサネット

UDE の概要

ここでは UDE について説明します。

「UDE の概要」

「ハードウェア ベース UDE の概要」

「ソフトウェア ベース UDE の概要」

UDE の概要

Catalyst 6500 シリーズ スイッチでは、ハードウェアまたはソフトウェアを使用して UDE を実装できます。ハードウェア ベース UDE およびソフトウェア ベース UDE では、双方向トラフィックで必要とされる 2 本のファイバケーブルの代わりに 1 本だけを使用します。

ハードウェア ベース UDE が受信専用と送信専用のどちらであるかは、双方向トランシーバが判断します。ソフトウェア ベース UDE は、送信専用または受信専用のどちらにも設定できます。

ハードウェア ベース UDE を実装するポートに、ソフトウェア ベース UDE を設定する必要はありません。


) ハードウェア ベース UDE およびソフトウェア ベース UDE をサポートするインターフェイスを搭載したモジュールの一覧については、「サポートされるハードウェア」を参照してください。


ハードウェア ベース UDE の概要

単一方向トランシーバを使用すると、単一方向リンクを構築できます。単一方向トランシーバは、双方向トランシーバより安価です。サポートされる単一方向トランシーバは次のとおりです。

受信専用 WDM GBIC(WDM-GBIC-REC=)

受信専用 XENPAK(WDM-XENPAK-REC=)

ソフトウェア ベース UDE の概要

双方向トランシーバを搭載したポートでトラフィックの単一方向の送受信を設定すると、単一方向リンクを構築できます。適切な単一方向トランシーバが入手できない場合は、ソフトウェア ベース UDE を使用できます。たとえば、送信専用トランシーバがサポートされていない場合、ソフトウェア ベース UDE を使用して送信専用リンクを設定する必要があります。

UDLR の概要

UDLR は、大容量の単一方向リンクのバック チャネルとして単一方向トンネルを提供し、ユニキャストおよびマルチキャストのトラフィック用に 1 つの双方向リンクを透過的にエミュレートします。

UDLR は、送信の必要のあるパケットを受信専用インターフェイスで代行受信し、UDLR バック チャネル トンネルで送信します。ルータが UDLR バック チャネル トンネルからパケットを受信すると、UDLR によってパケットは送信専用インターフェイスで受信されたかのように扱われます。

UDLR バック チャネル トンネルは、次の IPv4 機能をサポートしています。

Address Resolution Protocol(ARP; アドレス解決プロトコル)

NHRP

すべての IPv4 トラフィック用の双方向リンクのエミュレーション(ブロードキャストおよびマルチキャスト専用制御トラフィックとは逆)

受信専用トンネルでの IPv4 GRE マルチポイント


) UDLR バック チャネル トンネルは、IPv6 または MPLS をサポートしていません。


UDE および UDLR の設定

ここでは、UDE および UDLR の設定手順について説明します。

「UDE の設定」

「UDLR の設定」


) この注意事項は、UDLR をサポートしているリリースに対応しています。隣接 ISIS ルータは、UDLR トポロジを介して認識されません (CSCee56596)。


UDE の設定

ここでは、UDE の設定手順について説明します。

「UDE 設定時の注意事項」

「ハードウェア ベース UDE の設定」

「ソフトウェア ベース UDE の設定」

UDE 設定時の注意事項

UDE を設定する際に、次の注意事項に従ってください。

UDE は Supervisor Engine 720 でサポートされます。

Spanning Tree Protocol(STP; スパニング ツリー プロトコル)では、単一リンクを備えたトポロジでレイヤ 2 ループの発生を防止できません。

送信専用ポートでは、Bridge Protocol Data Unit(BPDU; ブリッジ プロトコル データ ユニット)を受信できないため、必ず STP フォワーディング ステートに移行します。

受信専用ポートは BPDU を送信できません。

単一方向ポートは、リンクの反対側のポートとの間でネゴシエーションを必要とする次の機能またはプロトコルをサポートしていません。

速度およびデュプレックス モードの自動ネゴシエーション

リンク ネゴシエーション

IEEE 802.3Z フロー制御

Dynamic Trunking Protocol(DTP; ダイナミック トランキング プロトコル)

通常はレイヤ 2 プロトコルで制御されるパラメータは、手動で設定する必要があります。

VLAN Trunking Protocol(VTP; VLAN トランキング プロトコル)サーバが VTP フレームを VTP ドメインにある全スイッチに送信できる場合に、単一方向リンクを含むトポロジは VTP だけをサポートします。

VTP プルーニングは情報の双方向交換によって異なるため、送信専用ポートを備えたスイッチで VTP プルーニングをディセーブルにします。

単一方向 EtherChannel は、Port Aggregation Protocol(PAgP)または Link Aggregation Control Protocol(LACP)をサポートできません。単一方向 EtherChannel を作成するには、「on」モードで EtherChannel を作成する必要があります。

ソフトウェア ベース UDE は、EtherChannel の物理ポートに設定できます。ソフトウェア ベース UDE は、非物理インターフェイス(ポート チャネル インターフェイスなど)には設定できません。

ポートにハードウェア ベース UDE またはソフトウェア ベース UDE を実装すると、Unidirectional Link Detection(UDLD; 単一方向リンク検出)は自動的にディセーブルになります。

CDP は、送信専用ポートから CDP フレームを送信し、受信専用ポートで CDP フレームを受信します。つまり、単一方向リンクの送信専用側のスイッチは CDP 情報を受信しません。

Switched Port Analyzer(SPAN; スイッチド ポート アナライザ)では、単一方向ポートの設定が送信先または宛先として制限されることはありません。

SPAN の宛先を送信専用ポートにすることができます。

SPAN の送信元を受信専用ポートにすることができます。

単一方向ポートは、IEEE 802.1X ポートベースの認証をサポートしていません。

Internet Group Management Protocol(IGMP)スヌーピングは、スイッチとホストとの間にマルチキャスト トラフィックを受信する単一方向リンクがあるトポロジをサポートしていません。

スイッチ上の IGMP スヌーピングとマルチキャスト ルータ間の単一方向リンクでの通信をサポートするように、UDLR を UDE で設定します。

単一方向リンクは ARP をサポートしていません。

ハードウェア ベース UDE の設定

ハードウェア ベース UDE をサポートするために必要なソフトウェアの設定手順はありません。単一方向トランシーバを取り付けて、ハードウェア ベース UDE を実装します。

ポート上でハードウェア ベース UDE を確認するには、次の作業を行います。

 

コマンド
目的

Router# show interfaces [{ gigabitethernet | tengigabitethernet } slot/interface }] status

設定を確認します。

次に、ポート GigabitEthernet 1/1 の設定を確認する例を示します。

Router# show interfaces gigabitethernet 1/1 status
 
Port Name Status Vlan Duplex Speed Type
Gi1/1 notconnect 1 full 1000 WDM-RXONLY

ソフトウェア ベース UDE の設定

ポート上でソフトウェア ベース UDE を確認するには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# interface {{ gigabitethernet | tengigabitethernet } slot/interface }

設定するインターフェイスを選択します。

ステップ 2

Router(config-if)# unidirectional { send-only | receive-only }

ソフトウェア ベース UDE を設定します。

Router(config-if)# no unidirectional

ソフトウェア ベース UDE の設定を削除します。

ステップ 3

Router(config-if)# end

コンフィギュレーション モードを終了します。

ステップ 4

Router# show interface {{ gigabitethernet | tengigabitethernet } slot/interface } unidirectional

設定を確認します。

次に、10 ギガビット イーサネット ポート 1/1 を UDE 送信専用ポートとして設定する例を示します。

Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# interface tengigabitethernet 1/1
Router(config-if)# unidirectional send-only
Router(config-if)# end
 
Warning!
 
Enable port unidirectional mode will automatically disable port udld. You must manually ensure that the unidirectional link does not create a spanning tree loop in the network.
 
Enable l3 port unidirectional mode will automatically disable ip routing on the port. You must manually configure static ip route and arp entry in order to route ip traffic.
 

次に、10 ギガビット イーサネット ポート 1/2 を UDE 受信専用ポートとして設定する例を示します。

Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# interface tengigabitethernet 1/2
Router(config-if)# unidirectional receive-only
Router(config-if)# end
 
Warning!
 
Enable port unidirectional mode will automatically disable port udld. You must manually ensure that the unidirectional link does not create a spanning tree loop in the network.
 
Enable l3 port unidirectional mode will automatically disable ip routing on the port. You must manually configure static ip route and arp entry in order to route ip traffic.
 

次に、設定を確認する例を示します。

Router> show interface tengigabitethernet 1/1 unidirectional
Unidirectional configuration mode: send only
CDP neighbour unidirectional configuration mode: receive only
 

次に、10 ギガビット イーサネット インターフェイス 1/1 で UDE をディセーブルにする例を示します。

Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# interface tengigabitethernet 1/1
Router(config-if)# no unidirectional
Router(config-if)# end
 

次に、UDE をサポートしていないポートに対する show interface コマンドの実行結果を示します。

Router# show interface fastethernet 6/1 unidirectional
Unidirectional Ethernet is not supported on FastEthernet6/1

UDLR バック チャネル トンネル設定時の注意事項

UDE バック チャネル トンネルを設定する際に、次の注意事項に従ってください。

Policy Feature Card(PFC; ポリシー フィーチャ カード)3 は、ハードウェアでは UDLR バック チャネル トンネルをサポートしていません。Route Processor(RP; ルート プロセッサ)は、UDLR バック チャネル トンネルをソフトウェアでサポートしています。

単一方向リンクに UDLR バック チャネル トンネルを設定します。

UDE 送信専用インターフェイスで、受信ができるように UDLR バック チャネル トンネル インターフェイスを設定します。

UDE 受信専用インターフェイスで、送信ができるように UDLR バック チャネル トンネル インターフェイスを設定します。

UDLR バック チャネル トンネル インターフェイスでは IPv4 アドレスを設定する必要があります。

UDLR バック チャネル トンネル インターフェイスで、送信元および宛先の IPv4 アドレスを設定する必要があります。

UDLR バック チャネル トンネルのデフォルト モードは GRE です。

UDLR バック チャネル トンネルは、IPv6 または MPLS をサポートしていません。

UDE 送信専用ポートでの受信専用トンネル インターフェイスの設定

UDE 送信専用ポートに受信専用トンネル インターフェイスを設定するには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# interface tunnel number

トンネル インターフェイスを選択します。

ステップ 2

Router(config-if)# tunnel udlr receive-only ude_send_only_port

トンネルの受信専用インターフェイスを UDE 送信専用ポートと関連付けます。

ステップ 3

Router(config-if)# ip address ipv4_address

トンネル IPv4 アドレスを設定します。

ステップ 4

Router(config-if)# tunnel source { ipv4_address | type number }

トンネルの送信元を設定します。

ステップ 5

Router(config-if)# tunnel destination { hostname | ipv4_address }

トンネルの宛先を設定します。

UDE 受信専用ポートでの送信専用トンネル インターフェイスの設定

UDE 受信専用ポートに送信専用トンネル インターフェイスを設定するには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# interface tunnel number

トンネル インターフェイスを選択します。

ステップ 2

Router(config-if)# tunnel udlr send-only ude_receive_only_port

トンネルの送信専用インターフェイスを UDE 受信専用ポートと関連付けます。

ステップ 3

Router(config-if)# ip address ipv4_address

トンネル IPv4 アドレスを設定します。

ステップ 4

Router(config-if)# tunnel source { ipv4_address | type number }

トンネルの送信元を設定します。

ステップ 5

Router(config-if)# tunnel destination { hostname | ipv4_address }

トンネルの宛先を設定します。

ステップ 6

Router(config-if)# tunnel udlr address-resolution

ARP および NHRP をイネーブルにします。

次に、UDE および UDLR の設定例を示します。

ルータ A の場合

OSPF および PIM が設定されています。

10 ギガビット イーサネット ポート 1/1 が送信専用 UDE ポートになります。

UDLR バック チャネル トンネルが受信専用として設定され、10 ギガビット イーサネット ポート 1/1 に関連付けられます。

ルータ B の場合

OSPF および PIM が設定されます。

10 ギガビット イーサネット ポート 1/2 が受信専用 UDE ポートになります。

UDLR バック チャネル トンネルが送信専用として設定され、10 ギガビット イーサネット ポート 1/2 に関連付けられます。

ARP および NHRP がイネーブルになります。

ルータ A の設定

ip multicast-routing
!
! tengigabitethernet 1/1 is send-only
!
interface tengigabitethernet 1/1
unidirectional send-only
ip address 10.1.0.1 255.255.0.0
ip pim sparse-dense-mode
!
! Configure tunnel as receive-only UDLR tunnel.
!
interface tunnel 0
tunnel source 11.0.0.1
tunnel destination 11.0.0.2
tunnel udlr receive-only tengigabitethernet 1/1
!
! Configure OSPF.
!
router ospf <pid>
network 10.0.0.0 0.255.255.255 area 0

ルータ B の設定

ip multicast-routing
!
! tengigabitethernet 1/2 is receive-only
!
interface tengigabitethernet 1/2
unidirectional receive-only
ip address 10.1.0.2 255.255.0.0
ip pim sparse-dense-mode
!
! Configure tunnel as send-only UDLR tunnel.
!
interface tunnel 0
tunnel source 11.0.0.2
tunnel destination 11.0.0.1
tunnel udlr send-only tengigabitethernet 1/2
tunnel udlr address-resolution
!
! Configure OSPF.
!
router ospf <pid>
network 10.0.0.0 0.255.255.255 area 0