Cisco IOS ソフトウェア コンフィギュレーション ガイド リリース12.2(33)SXH以降
オプションの STP 機能の設定
オプションの STP 機能の設定
発行日;2012/02/01 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 18MB) | フィードバック

目次

オプションの STP 機能の設定

オプションの STP 機能の概要

STP ポート タイプの概要

PortFast の概要

ブリッジ保証の概要

BPDU ガードの概要

PortFast BPDU フィルタリングの概要

UplinkFast の概要

BackboneFast の概要

EtherChannel ガードの概要

ルート ガードの概要

ループ ガードの概要

PVST シミュレーションの概要

オプションの STP 機能の設定

PortFast のイネーブル化

ブリッジ保証のイネーブル化

PortFast BPDU フィルタリングのイネーブル化

BPDU ガードのイネーブル化

UplinkFast のイネーブル化

BackboneFast のイネーブル化

EtherChannel ガードのイネーブル化

ルート ガードのイネーブル化

ループ ガードのイネーブル化

PVST シミュレーションの設定

オプションの STP 機能の確認

show spanning-tree コマンドの使用方法

Release 12.2(33)SXI 以降の例

Release 12.2(33)SXI よりも前のリリースの例

オプションの STP 機能の設定

この章では、オプションの Spanning-Tree Protocol(STP; スパニング ツリー プロトコル)機能を設定する手順について説明します。


) この章で使用しているコマンドの構文および使用方法の詳細については、次の URL の『Cisco IOS Master Command List, Release 12.2SX』を参照してください。

http://www.cisco.com/en/US/docs/ios/mcl/122sxmcl/12_2sx_mcl_book.html


 

この章で説明する内容は、次のとおりです。

「オプションの STP 機能の概要」

「オプションの STP 機能の設定」

「オプションの STP 機能の確認」


) Spanning-Tree Protocol(STP)の設定手順については、「STP および MST の設定」を参照してください。


オプションの STP 機能の概要

スパニング ツリー プロトコル(STP)のオプション機能は、ループの防止を強化し、ユーザの設定ミスをなくし、プロトコル パラメータに関する制御力を高めます。同様の機能は IEEE 802.1w Rapid Spanning Tree Protocol(RSTP; 高速スパニング ツリー プロトコル)標準に組み込まれる場合もありますが、ここで説明する拡張機能を使用することを推奨します。PVST シミュレーションの拡張機能を除き、これらすべての拡張機能は Rapid PVST+ と MST の両方で使用できます。PVST シミュレーションは、MST だけで動作します。

次のセクションでは、オプション機能について説明します。

「STP ポート タイプの概要」

「PortFast の概要」

「ブリッジ保証の概要」

「BPDU ガードの概要」

「PortFast BPDU フィルタリングの概要」

「UplinkFast の概要」

「BackboneFast の概要」

「EtherChannel ガードの概要」

「ルート ガードの概要」

「ループ ガードの概要」

「PVST シミュレーションの概要」

STP ポート タイプの概要

Cisco IOS Release 12.2(33)SXI 以降では、スパニング ツリー ポートをエッジ ポート、ネットワーク ポート、または標準ポートとして個別に設定できます。ポート タイプによって、STP 拡張機能に関するポートの動作が決まります。

レイヤ 2 ホストに接続されるエッジ ポートは、アクセス ポートまたはトランク ポートとして動作できます。


) レイヤ 2 スイッチまたはブリッジに接続されたポートをエッジ ポートとして設定すると、ブリッジング ループが発生するおそれがあります。


ネットワーク ポートは、レイヤ 2 スイッチまたはブリッジだけに接続されます。


) レイヤ 2 にホスト接続されたポートを、間違ってスパニング ツリー ネットワーク ポートとして設定すると、そのポートは自動的にブロッキング ステートになります。


デフォルトのスパニング ツリー ポート タイプは、標準タイプです。これは単に、そのトポロジが指定されていないことを意味します。

Cisco IOS Release 12.2(33)SXI よりも前のリリースでは、PortFast を使用してポートを設定した場合は、そのポートがエッジ ポートであることを意味します。それ以外の場合、ポートは標準ポートであると見なされます。

PortFast の概要

STP PortFast を使用すると、アクセス ポートとして設定されたレイヤ 2 LAN ポートが、リスニング ステートおよびラーニング ステートを経由せずに、ただちにフォワーディング ステートを開始します。1 台のワークステーションまたはサーバに接続されたレイヤ 2 アクセス ポート上で PortFast を使用すると、STP のコンバージェンスを待たずに、デバイスがただちにネットワークに接続されます。1 台のワークステーションまたはサーバに接続されたインターフェイスが Bridge Protocol Data Unit(BPDU; ブリッジ プロトコル データ ユニット)を受信しないようにする必要があります。PortFast 用に設定されているポートでも、STP は稼動しています。PortFast 対応ポートは、必要に応じて、ブロッキング ステートにただちに移行できます(これは、上位 BPDU を受信したときに発生することがあります)。トランク ポート上で PortFast をイネーブルにできます。PortFast には、設定値と異なる動作値を設定できます。


) Cisco IOS Release 12.2(33)SXI 以降では、PortFast オプションはエッジと標準です。エッジ ポートと PortFast ポートに違いはありません。



注意 PortFast の目的は、アクセス ポートが STP のコンバージェンスを待つ時間を最小限に抑えることです。したがって、PortFast はアクセス(エッジ)ポート上だけで使用する必要があります。スイッチ(ネットワーク ポート)に接続されたポート上で PortFast をイネーブルにすると、一時的なブリッジング ループが発生するおそれがあります。

ブリッジ保証の概要

With Cisco IOS Release 12.2(33)SXI 以降では、ブリッジ保証を使用して、ネットワーク内でブリッジング ループを発生させるおそれがある特定の問題を防止できます。具体的には、ブリッジ保証を使用して、単一方向リンク障害やその他のソフトウェア障害、スパニング ツリー アルゴリズムが機能しなくなってもデータ トラフィックを転送し続けるデバイスの問題などを防止します。


) ブリッジ保証は、Rapid PVST+ および MST だけでサポートされます。


ブリッジ保証はデフォルトでイネーブルになっており、ディセーブル化はグローバルに限り可能です。さらにブリッジ保証は、ポイントツーポイントのスパニング ツリー ネットワーク ポートでだけイネーブルになります。また、ブリッジ保証はリンクの両端でイネーブルにする必要があります。リンクの片側のデバイスではブリッジ保証がイネーブルであり、もう一方の側のデバイスはブリッジ保証をサポートしていないか、この機能をイネーブルにしていない場合、接続先ポートはブロックされます。

ブリッジ保証をイネーブルにすると、各 hello タイム期間中に、代替ポートやバックアップ ポートを含む動作中のすべてのネットワーク ポートで BPDU が送信されます。所定の期間に BPDU を受信しなかったポートは、一貫性のない(ブロッキング)ステートになります。このポートは、ルート ポートの計算には使用されません。BPDU を受信すると、このポートは通常のスパニング ツリー移行を再開します。

図 24-1 は、標準の STP トポロジを示しています。図 24-2 は、デバイスが故障しており、ブリッジ保証が実行されていない場合に想定されるネットワークの問題点を示しています。

図 24-1 標準 STP トポロジを使用したネットワーク

図 24-2 ブリッジ保証が実行されていないネットワークの問題点

 

図 24-3 に、ブリッジ保証がイネーブルで、各 STP ネットワーク ポートから送出される双方向 BPDU によって STP トポロジが正常に進行するネットワークを示します。図 24-4 に、ネットワークでブリッジ保証をイネーブルにすると、図 24-2 で示したネットワークの問題がどのように回避されるかを示します。

図 24-3 ブリッジ保証が実行されているネットワーク STP トポロジ

 

図 24-4 ブリッジ保証をイネーブルにして回避されるネットワーク問題

 

 

ブリッジ保証を使用する場合は、次の注意事項に従ってください。

ブリッジ保証は、ポイントツーポイントのスパニング ツリー ネットワーク ポートでだけ動作します。ブリッジ保証機能の設定は、リンクの両端でそれぞれ行う必要があります。

ネットワーク全体でブリッジ保証をイネーブルにしておくことを推奨します。

BPDU ガードの概要

BPDU ガードがポート上でイネーブルになっている場合、BPDU ガードは BPDU を受信するポートをシャットダウンします。BPDU ガードがグローバルに設定されている場合、BPDU ガードは PortFast(エッジ)ステートのポート上だけで有効です。有効な設定では、PortFast レイヤ 2 LAN インターフェイス(エッジ ポート)は BPDU を受信しません。PortFast レイヤ 2 LAN インターフェイスが BPDU を受信した場合、認証されていないデバイスが接続された場合と同じように、無効な設定として通知されます。このように BPDU ガード機能では、管理者が手動でレイヤ 2 LAN インターフェイスを再び作動させなければならないので、無効な設定に対する安全な対処が可能になります。BPDU ガードはインターフェイス レベルで設定可能です。インターフェイス レベルで設定された BPDU ガードは、PortFast 設定に関係なく、ポートが BPDU を受信するとすぐにポートをシャットダウンします。


) グローバルにイネーブル化された BPDU ガードは、PortFast(エッジ)動作ステートのすべてのインターフェイスに適用されます。


PortFast BPDU フィルタリングの概要

PortFast BPDU フィルタリングを使うことで、管理者は特定ポート上での BPDU 送信や BPDU 受信をシステムで禁止できます。


) Cisco IOS Release 12.2(33)SXI 以降では、PortFast BPDU フィルタリングは PortFast エッジ BPDU フィルタリングと呼ばれます。


グローバルに設定された PortFast BPDU フィルタリングは、動作中のすべての PortFast(エッジ)ポートに適用されます。PortFast 動作ステートのポートは、ホストに接続されていると見なされ、通常は BPDU をドロップします。動作中の PortFast ポートが BPDU を受信すると、そのポートはただちに PortFast 動作ステータスが消失して標準ポートになります。その場合、このポートでの PortFast BPDU フィルタリングはディセーブルになり、STP はこのポート上で BPDU の送信を再開します。

PortFast BPDU フィルタリングはポート単位で設定することもできます。PortFast BPDU フィルタリングがポート上で明示的に設定されている場合、BPDU は送信されず、受信したすべての BPDU はドロップされます。


注意 ホストに接続されていないポートで PortFast BPDU フィルタリングを明示的に設定すると、そのポートは受信したすべての BPDU を無視し、フォワーディング ステートに移行するため、ブリッジング ループが発生することがあります。

PortFast BPDU フィルタリングをグローバルにイネーブルにし、ポート設定を PortFast BPDU フィルタリングのデフォルトに設定すると(「PortFast BPDU フィルタリングのイネーブル化」を参照)、PortFast は PortFast BPDU フィルタリングをイネーブルまたはディセーブルにします。

ポート設定がデフォルトに設定されていない場合、PortFast の設定が PortFast BPDU フィルタリングに影響することはありません。 表 24-1 に、設定可能な PortFast BPDU フィルタリングの組み合わせを示します。PortFast BPDU フィルタリングを使用すると、エンド ホストの接続直後に、アクセス ポートがフォワーディング ステートに直接移行できます。

 

表 24-1 PortFast BPDU フィルタリングのポート設定

ポート単位の設定
グローバル
コンフィギュレーション
PortFast の
ステート
PortFast BPDU フィルタリングのステート

デフォルト

イネーブル

イネーブル

イネーブル1

デフォルト

イネーブル

ディセーブル

ディセーブル

デフォルト

ディセーブル

適用不可

ディセーブル

ディセーブル

適用不可

適用不可

ディセーブル

イネーブル

適用不可

適用不可

イネーブル

1.ポートは 10 以上の BPDU を送信します。このポートがいずれかの BPDU を受信した場合、PortFast および PortFast BPDU フィルタリングはディセーブルになります。

UplinkFast の概要

UplinkFast は、直接接続されたリンクの障害発生後に高速コンバージェンスを行い、アップリンク グループを使用して、冗長レイヤ 2 リンク間でロード バランシングを実行します。アップリンク グループは、(VLAN ごとの)レイヤ 2 LAN インターフェイスの集合であり、どの時点でも、その中の 1 つのインターフェイスだけが転送を行います。つまり、アップリンク グループは、(転送を行う)ルート ポートと、(セルフループを行うポートを除く)ブロックされたポートの集合で構成されます。アップリンク グループは、転送中のリンクで障害が起きた場合に代替パスを提供します。


) UplinkFast は、配線クローゼット スイッチに使用すると最も効果的です。それ以外の用途には、この機能は有用でない場合もあります。


図 24-5 は、リンク障害が発生していないときのトポロジ例です。スイッチ A(ルート ブリッジ)は、リンク L1 を通じてスイッチ B に、リンク L2 を通じてスイッチ C に直接接続されています。スイッチ B に直接接続されているスイッチ C のレイヤ 2 LAN インターフェイスは、ブロッキング ステートです。

図 24-5 直接リンク障害が発生する前の UplinkFast の例

 

スイッチ C が、現在アクティブ リンクであるルート ポート上の L2 でリンク障害( 直接 リンク障害)を検出すると、UplinkFast はスイッチ C でブロックされていたポートのブロックを解除し、リスニング ステートおよびラーニング ステートを経由せずに、ただちにフォワーディング ステートに移行させます(図 24-6 を参照)。このスイッチオーバーに要する時間は 1 ~ 5 秒です。

図 24-6 直接リンク障害が発生したあとの UplinkFast の例

 

BackboneFast の概要

ネットワーク デバイス上のルート ポートまたはブロックされたポートが、そのポートの指定ブリッジから下位 BPDU を受信すると、BackboneFast が開始されます。下位 BPDU は、1 台のネットワーク デバイスをルート ブリッジおよび指定ブリッジの両方として識別します。ネットワーク デバイスが下位 BPDU を受信すると、ネットワーク デバイスはそのネットワーク デバイスが直接接続されていないリンク( 間接 リンク)で障害が発生した(つまり、指定ブリッジからルート ブリッジへの接続が切断された)ものと見なします。標準的な STP ルールに従う場合、ネットワーク デバイスは設定されている最大エージング タイム(STP の max-age コマンドで指定)の間下位 BPDU を無視します。

ネットワーク デバイスは、ルート ブリッジへの代替パスの有無を判別します。下位 BPDU がブロックされたポートに到達した場合には、ネットワーク デバイスのルート ポートおよびその他のブロックされたポートがルート ブリッジへの代替パスになります (セルフループ ポートはルート ブリッジへの代替パスとは見なされません)。下位 BPDU がルート ポートに到達した場合には、すべてのブロック ポートがルート ブリッジへの代替パスになります。下位 BPDU がルート ポートに到達し、かつブロックされたポートがない場合には、ネットワーク デバイスはルート ブリッジへの接続が切断されたものと見なし、ルートの最大エージング タイムを満了させ、通常の STP ルールに従ってルート ブリッジになります。

ネットワーク デバイスにルート ブリッジへの代替パスがある場合、ネットワーク デバイスはそれらの代替パスを使用して、ルート リンク クエリー Protocol Data Unit(PDU; プロトコル データ ユニット)と呼ばれる新しい種類の PDU を送信します。ネットワーク デバイスはルート ブリッジへのすべての代替パスに対して、ルート リンク クエリー PDU を送信します。ルートへの代替パスがまだ存在していることが判明すると、ネットワーク デバイスは、下位 BPDU を受信したポートの最大エージング タイムを満了させます。ルート ブリッジへのすべての代替パスが、ネットワーク デバイスとルート ブリッジ間の接続が切断されていることを示している場合には、ネットワーク デバイスは、下位 BPDU を受信したポートの最大エージング タイムを満了させます。1 つまたは複数の代替パスからルート ブリッジに引き続き接続できる場合には、ネットワーク デバイスは、下位 BPDU を受信したすべてのポートを Designated Port(DP; 指定ポート)にして、(ブロッキング ステートになっていた場合)ブロッキング ステートから、リスニング ステートおよびラーニング ステートを経て、フォワーディング ステートに移行させます。

図 24-7 は、リンク障害が発生していないときのトポロジ例です。スイッチ A(ルート ブリッジ)は、リンク L1 を通じてスイッチ B に、リンク L2 を通じてスイッチ C に直接接続されています。スイッチ B に直接接続されているスイッチ C のレイヤ 2 LAN インターフェイスは、ブロッキング ステートです。

図 24-7 間接リンク障害が発生する前の BackboneFast の例

 

リンク L1 で障害が発生した場合、スイッチ C はリンク L1 に直接接続されていないので、この障害を検出できません。一方、スイッチ B は L1 を通じてルート ブリッジに直接接続されているので、この障害を検出し、自身をルートに選定し、スイッチ C に対して自身がルートであることを表す BPDU の送信を開始します。スイッチ C がスイッチ B から下位 BPDU を受信すると、スイッチ C は間接障害が発生したことを推測します。この時点で、BackboneFast により、スイッチ C のブロック ポートは、そのポートに設定されている最大エージング タイムの満了を待たずに、ただちにリスニング ステートに移行します。BackboneFast はさらに、スイッチ C のレイヤ 2 LAN インターフェイスをフォワーディング ステートに移行させ、スイッチ B からスイッチ A までのパスを提供します。転送遅延時間にデフォルト値の 15 秒が設定されている場合、このスイッチオーバーに要する時間は、転送遅延時間の 2 倍にあたる約 30 秒です。図 24-8 に、BackboneFast がリンク L1 の障害に対応するために、どのようにトポロジを再設定するかを示します。

図 24-8 間接リンク障害が発生したあとの BackboneFast の例

 

図 24-9 に示すメディア共有型トポロジに新しいネットワーク デバイスが組み込まれた場合、BackboneFast は起動されません。これは、認識している指定ブリッジ(スイッチ B)から下位 BPDU が着信していないためです。新しいネットワーク デバイスは、自らがルート ブリッジであることを伝える下位 BPDU の送信を開始します。しかし、他のネットワーク デバイスはこれらの下位 BPDU を無視します。その結果、新しいネットワーク デバイスは、スイッチ B がルート ブリッジであるスイッチ A への指定ブリッジであることを学習します。

図 24-9 メディア共有型トポロジにおけるネットワーク デバイスの追加

 

EtherChannel ガードの概要

EtherChannel ガードは、正しく設定されていない EtherChannel を検出します(スイッチのインターフェイスが EtherChannel として設定されているが、他のデバイスのインターフェイスが EtherChannel として設定されていない場合、または他のデバイスのインターフェイスの一部が同じ EtherChannel に設定されていない場合など)。

他のデバイスの設定に誤りがあることが検出されると、EtherChannel ガードはスイッチのインターフェイスを errdisable ステートにします。

ルート ガードの概要

STP ルート ガード機能を使用すると、ポートがルート ポートやブロックされたポートにならなくなります。ルート ガードに設定されたポートが上位 BPDU を受信すると、このポートはただちにルートとして一貫性のない(ブロックされた)ステートになります。

ループ ガードの概要

ループ ガードを使用すると、ポイントツーポイント リンクで単一方向リンクの障害によって発生することがあるブリッジング ループを防止できます。グローバルにイネーブル化されたループ ガードは、システム上のすべてのポイントツーポイント ポートに適用されます。ループ ガードはルート ポートおよびブロックされたポートを検出し、これらのポートがセグメント上の DP から BPDU を受信し続けるようにします。ループ ガードがイネーブルになっているルート ポートまたはブロックされたポートが DP からの BPDU の受信を停止した場合、このポートはポート上に物理リンク エラーがあると想定して、ループに一貫性のないブロッキング ステートに移行します。BPDU を受信したポートは、ループに一貫性のないステートからただちに回復します。

ループ ガードはポート単位でイネーブルにできます。ループ ガードをイネーブルにすると、すべてのアクティブ インスタンスまたはポートが属する VLAN にループ ガードが自動的に適用されます。ループ ガードをディセーブルにした場合は、指定したポートに対してディセーブルになります。ループ ガードをディセーブルにすると、ループに一貫性のないすべてのポートがリスニング ステートに移行します。

チャネル上でループ ガードをイネーブルにしたあとに、最初のリンクが単一方向リンクになると、ループ ガードは影響を受けたポートがチャネルから削除されるまで、チャネル全体をブロックします。図 24-10 に、三角型のスイッチ設定におけるループ ガードを示します。

図 24-10 ループ ガードが設定された三角型のスイッチ設定

 

図 24-10 に、次の設定を示します。

スイッチ A およびスイッチ B はディストリビューション スイッチです。

スイッチ C はアクセス スイッチです。

ループ ガードは、スイッチ A、B、C のポート 3/1 および 3/2 でイネーブルです。

ルート スイッチ上でループ ガードをイネーブルにしても影響はありませんが、ルート スイッチが非ルート スイッチになると、保護機能が有効になります。

ループ ガードを使用するときは、次の注意事項に従ってください。

PortFast 対応ポートでは、ループ ガードをイネーブルにできません。

ルート ガードがイネーブルの場合は、ループ ガードをイネーブルにできません。

ループ ガードは、次のように他の機能と相互作用します。

ループ ガードは UplinkFast または BackboneFast の機能には影響しません。

ポイントツーポイント リンクに接続されていないポート上でループ ガードをイネーブルにしても、機能しません。

ルート ガードは、強制的に、ポートを常にルート ポートとして指定された状態にします。ポートがルート ポートまたは代替ポートの場合だけ、ループ ガードは有効です。特定のポート上ではループ ガードとルート ガードの両方を同時にイネーブルにできません。

ループ ガードはスパニング ツリーで認識されているポートを使用します。ループ ガードは、Port Aggregation Protocol(PAgP)が提供する論理ポートを利用できます。ただし、チャネルを形成するには、そのチャネルにグループ化するすべての物理ポートの設定に互換性がなければなリません。チャネルを形成するために、PAgP はすべての物理ポート上でルート ガードまたはループ ガードの設定を均一にします。

ループ ガードに適用される注意事項は、次のとおりです。

スパニング ツリーは、BPDU を送信するチャネル内で最初に動作するポートを常に選択します。このリンクが単一方向になった場合、チャネル内の他のリンクが適切に機能している場合でも、ループ ガードはチャネルをブロックします。

ループ ガードによってブロックされている一連のポートをグループ化して、チャネルを形成した場合、スパニング ツリーはこれらのポートのステート情報をすべて失い、新しいチャネル ポートは指定された役割を使用してフォワーディング ステートに移行できます。

チャネルがループ ガードによってブロックされている場合に、チャネルが切断されると、スパニング ツリーはすべてのステート情報を失います。チャネルを形成する 1 つまたは複数のリンクが単一方向リンクである場合も、各物理ポートは指定された役割を使用して、フォワーディング ステートに移行できます。


) UniDirectional Link Detection(UDLD; 単一方向リンク検出)をイネーブルにして、リンク障害を隔離します。UDLD が障害を検出するまでループが発生することがありますが、ループ ガードはこのループを検出できません。


ディセーブル化されたスパニング ツリー インスタンスまたは VLAN 上では、ループ ガードは無効です。

PVST シミュレーションの概要

MST は、Rapid PVST+ と相互運用し、ユーザ設定は不要です。このシームレスな相互運用性は、PVST シミュレーション機能によって実現されます。


) MST をイネーブルにすると、PVST シミュレーションがデフォルトでイネーブルになります。つまり、デフォルトでは、デバイス上のすべてのインターフェイスが MST および Rapid PVST+ 間で相互運用します。PVST シミュレーションをディセーブル化する機能は、Cisco IOS Release 12.2(33)SXI で導入されます。


MST と Rapid PVST+ 間の接続を制御して、Rapid PVST+ の実行がイネーブルに設定されたポートに MST 対応ポートを誤って接続するのを防止できます。Rapid PVST+ はデフォルトの STP モードであるので、多数の Rapid PVST+ 接続が行われる場合があります。

Rapid PVST+ シミュレーションのディセーブル化は、ポートごと、またはデバイス全体でグローバルに実行できます。Rapid PVST+ シミュレーションをディセーブルにした場合、MST 対応ポートは自身が Rapid PVST+ 対応ポートに接続されていることを検出すると、PVST ピアの一貫性がない(ブロッキング)ステートに移行します。このポートは、Shared Spanning Tree Protocol(SSTP)BPDU の受信を停止するまでは一貫性のないステートを維持し、受信停止後は通常の STP 移行プロセスを再開します。

すべての STP インスタンス用のすべてのルート ブリッジは、MST 領域または Rapid PVST+ 側のいずれかに配置されている必要があります。すべての STP インスタンス用ルート ブリッジがどちらの側にもない場合、ソフトウェアはポートを PVST シミュレーションに一貫性がないステートに移行させます。


) すべての STP インスタンス用ルート ブリッジは、MST 領域に配置することを推奨します。


オプションの STP 機能の設定

ここでは、次の内容について説明します。

「PortFast のイネーブル化」

「ブリッジ保証のイネーブル化」

「PortFast BPDU フィルタリングのイネーブル化」

「BPDU ガードのイネーブル化」

「UplinkFast のイネーブル化」

「BackboneFast のイネーブル化」

「EtherChannel ガードのイネーブル化」

「ルート ガードのイネーブル化」

「ループ ガードのイネーブル化」

「PVST シミュレーションの設定」

PortFast のイネーブル化


注意 PortFast は、単一のエンド ステーションをレイヤ 2 アクセス ポートに接続する場合に限って使用してください。そうしない場合、ネットワーク ループが発生する可能性があります。

レイヤ 2 アクセス ポート上で PortFast をイネーブルにするには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# interface { type2 slot/port } | { port-channel port_channel_number }

設定するポートを選択します。

ステップ 2

Router(config-if)# no spanning-tree portfast

ポートを標準ポートとして設定します。

Cisco IOS Release 12.2(33)SXI and later releases:
Router(config-if)# spanning-tree portfast edge [ trunk ]

単一のワークステーションまたはサーバに接続されたレイヤ 2 アクセス ポート上でエッジの動作をイネーブルにします。 trunk キーワードにより、トランク ポート上のエッジの動作はイネーブルになります。

Router(config-if)# spanning-tree portfast edge disable

ポート上でエッジの動作をディセーブルにします。

Earlier releases:
Router(config-if)# spanning-tree portfast [ trunk ]

単一のワークステーションまたはサーバに接続されたレイヤ 2 アクセス ポート上で PortFast をイネーブルにします。

Router(config-if)# spanning-tree portfast disable

ポート上でエッジの動作をディセーブルにします。

ステップ 3

Router(config-if)# end

コンフィギュレーション モードを終了します。

ステップ 4

Router# show running interface { type1 slot/port } | { port-channel port_channel_number }

設定を確認します。

2.type = fastethernetgigabitethernet、または tengigabitethernet

次に、インターフェイス FastEthernet 5/8 上で PortFast をイネーブルにする例を示します。

Router# configure terminal
Router(config)# interface fastethernet 5/8
Router(config-if)# spanning-tree portfast
Router(config-if)# end
Router#
 

次に、設定を確認する例を示します。

Router# show running-config interface fastethernet 5/8
Building configuration...
 
Current configuration:
!
interface FastEthernet5/8
no ip address
switchport
switchport access vlan 200
switchport mode access
spanning-tree portfast
end
Router#
 

PortFast のデフォルト設定を設定および確認するには、次の作業を行います。

 

コマンド
目的

ステップ 1

Cisco IOS Release 12.2(33)SXI 以降

Router(config)# spanning-tree portfast [ edge | network | normal ] default

すべてのスイッチアクセス ポートのデフォルト ステートを、エッジ、ネットワーク、または標準に設定します。ブリッジ保証は、デフォルトによりすべてのネットワーク アクセス ポート上でイネーブルになります。

旧リリース

Router(config)# [no] spanning-tree portfast default

すべてのスイッチアクセス ポートのデフォルト ステートをエッジに設定します。デフォルト ステートを標準に設定するには、 no プレフィクスを使用します。

ステップ 2

Router(config-if)# end

コンフィギュレーション モードを終了します。

ステップ 3

Router# show spanning-tree summary totals

グローバル コンフィギュレーションを確認します。

ステップ 4

Router# show spanning-tree interface { type3 slot/port } detail

特定のポートに対する効果を確認します。

3.type = fastethernetgigabitethernet、または tengigabitethernet

次に、Cisco IOS Release 12.2(33)SXI 以降のリリースで、デフォルトのスイッチアクセス ポート ステートをエッジに設定する例を示します。

Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# spanning-tree portfast edge default
Router(config-if)# exit
 

次に、Cisco IOS Release 12.2(33)SXI よりも前のリリースで、デフォルトのスイッチアクセス ポート ステートをエッジに設定する例を示します。

Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# spanning-tree portfast default
Router(config-if)# ^Z

ブリッジ保証のイネーブル化

Release 12.2(33)SXI 以降では、ブリッジ保証がサポートされます。デフォルトでは、ブリッジ保証はスイッチのすべてのネットワーク ポートでイネーブルになっています。ブリッジ保証をディセーブルにすると、すべての設定済みネットワーク ポートが標準のスパニング ツリー ポートとして動作します。ブリッジ保証をグローバルにイネーブル化またはディセーブル化するには、次の作業を行います。

 

コマンド
目的

Router(config)# spanning-tree bridge assurance

スイッチのすべてのネットワーク ポートでブリッジ保証をイネーブルにします。

次に、スイッチのすべてのネットワーク ポートで PortFast ブリッジ保証をディセーブルにする例を示します。

Router(config)# no spanning-tree bridge assurance

PortFast BPDU フィルタリングのイネーブル化

ここでは、PortFast BPDU フィルタリングの設定手順について説明します。PortFast BPDU フィルタリングをグローバルにイネーブルにするには、次の作業を行います。

 

コマンド
目的

ステップ 1

Cisco IOS Release 12.2(33)SXI 以降

Router(config)# spanning-tree portfast edge bpdufilter default

スイッチのすべてのエッジ ポートで、BPDU フィルタリングをデフォルトでグローバルにイネーブル化します。スイッチのすべてのエッジ ポートで、BPDU フィルタリングをデフォルトでグローバルにディセーブル化するには、 no プレフィクスを使用します。

旧リリース

Router(config)# spanning-tree portfast bpdufilter default

ステップ 2

Router(config)# end

コンフィギュレーション モードを終了します。

ステップ 3

Router# show spanning-tree summary totals

設定を確認します。

各エッジ ポート上で、BPDU フィルタリングはデフォルトに設定されています。次に、ポート上で PortFast BPDU フィルタリングをイネーブルにして、 PVST + モードで設定を確認する例を示します。

Router(config)# spanning-tree portfast edge bpdufilter default
Router(config)# ^Z
 
Router# show spanning-tree summary totals
Root bridge for: Bridge VLAN0025
EtherChannel misconfiguration guard is enabled
Extended system ID is enabled
PortFast Edge BPDU Guard Default is disabled
Portfast Edge BPDU Filter Default is enabled
Portfast Default is edge
Bridge Assurance is enabled
Loopguard is disabled
UplinkFast is disabled
BackboneFast is disabled
Pathcost method used is long
 
Name Blocking Listening Learning Forwarding STP Active
---------------------- -------- --------- -------- ---------- ----------
2 vlans 0 0 0 3 3
Router#
 

非トランキング ポート上で PortFast BPDU フィルタリングをイネーブルまたはディセーブルにするには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# interface { type4 slot/port }

設定するインターフェイスを選択します。

ステップ 2

Router(config-if)# spanning-tree bpdufilter [ enable | disable ]

ポート上で BPDU フィルタリングをイネーブルまたはディセーブルにします。

ステップ 3

Router(config-if)# end

コンフィギュレーション モードを終了します。

ステップ 4

Router# show spanning-tree interface { type slot/port }

設定を確認します。

4.type = fastethernetgigabitethernet、または tengigabitethernet

次に、非トランキング ポート上で PortFast BPDU フィルタリングをイネーブルにする例を示します。

Router(config)# interface fastEthernet 4/4
Router(config-if)# spanning-tree bpdufilter enable
Router(config-if)# ^Z
 
Router# show spanning-tree interface fastEthernet 4/4
 
Vlan Role Sts Cost Prio.Nbr Status
---------------- ---- --- --------- -------- --------------------------------
VLAN0010 Desg FWD 1000 160.196 Edge P2p
 
Router# show spanning-tree interface fastEthernet 4/4 detail
Port 196 (FastEthernet4/4) of VLAN0010 is forwarding
Port path cost 1000, Port priority 160, Port Identifier 160.196.
Designated root has priority 32768, address 00d0.00b8.140a
Designated bridge has priority 32768, address 00d0.00b8.140a
Designated port id is 160.196, designated path cost 0
Timers:message age 0, forward delay 0, hold 0
Number of transitions to forwarding state:1
The port is in the portfast mode by portfast trunk configuration
Link type is point-to-point by default
Bpdu filter is enabled
BPDU:sent 0, received 0
Router#

BPDU ガードのイネーブル化

BPDU ガードをグローバルにイネーブルにするには、次の作業を行います。

 

コマンド
目的

ステップ 1

Cisco IOS Release 12.2(33)SXI 以降

Router(config)# spanning-tree portfast edge bpduguard default

スイッチのすべてのエッジ ポートで、BPDU ガードをデフォルトでグローバルにイネーブル化します。スイッチのすべてのエッジ ポートで BPDU ガードをデフォルトでグローバルにディセーブル化するには、このコマンドの no 形式を使用します。

旧リリース

Router(config)# spanning-tree portfast bpduguard default

ステップ 2

Router(config)# end

コンフィギュレーション モードを終了します。

ステップ 3

Router# show spanning-tree summary totals

設定を確認します。

次に、BPDU ガードをイネーブルにする例を示します。

Router# configure terminal
Router(config)# spanning-tree portfast edge bpduguard default
Router(config)# end
Router#
 

次に、設定を確認する例を示します。

Router# show spanning-tree summary totals
Root bridge for: Bridge VLAN0025
EtherChannel misconfiguration guard is enabled
Extended system ID is enabled
PortFast Edge BPDU Guard Default is enabled
Portfast Edge BPDU Filter Default is disabled
Portfast Default is edge
Bridge Assurance is enabled
Loopguard is disabled
UplinkFast is disabled
BackboneFast is disabled
Pathcost method used is long
 
Name Blocking Listening Learning Forwarding STP Active
---------------------- -------- --------- -------- ---------- ----------
2 vlans 0 0 0 3 3
Router#

UplinkFast のイネーブル化

UplinkFast を使用すると、ブリッジ プライオリティが 49152 に増えるとともに、スイッチ上のすべてのレイヤ 2 LAN ポートの STP ポート コストに 3000 が加算されます。その結果、スイッチがルート ブリッジになる確率が低くなります。ブリッジ プライオリティを設定している VLAN 上では、UplinkFast をイネーブルにできません。ブリッジ プライオリティを設定している VLAN 上で UplinkFast をイネーブルにするには、グローバル コンフィギュレーション モードで no spanning-tree vlan vlan_ID priority コマンドを入力して、VLAN のブリッジ プライオリティをデフォルトに戻します。


) UplinkFast をイネーブルにすると、スイッチ上のすべての VLAN に影響します。個々の VLAN では UplinkFast を設定できません。


UplinkFast をイネーブルにするには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# spanning-tree uplinkfast

Router(config)# spanning-tree uplinkfast [ max-update-rate max_update_rate ]

UplinkFast をイネーブルにします。

UplinkFast をイネーブルにし、アップデート速度を秒単位で指定します。

ステップ 2

Router(config)# end

コンフィギュレーション モードを終了します。

ステップ 3

Router# show spanning-tree vlan vlan_ID

UplinkFast がイネーブルになっていることを確認します。

次に、UplinkFast をイネーブルにする例を示します。

Router# configure terminal
Router(config)# spanning-tree uplinkfast
Router(config)# exit
Router#

 

次に、UplinkFast をイネーブルにして、アップデート速度を 400 パケット/秒に設定する例を示します。

Router# configure terminal
Router(config)# spanning-tree uplinkfast
Router(config)# spanning-tree uplinkfast max-update-rate 400
Router(config)# exit
Router#
 

次に、UplinkFast がイネーブルになっていることを確認する例を示します。

Router# show spanning-tree uplinkfast
UplinkFast is enabled
Router#

BackboneFast のイネーブル化


) BackboneFast が適切に動作するのは、ネットワーク内のすべてのネットワーク デバイス上でイネーブルになっている場合だけです。BackboneFast は、トークンリング VLAN ではサポートされません。この機能は、サードパーティ製のネットワーク デバイスと組み合わせて使用できます。


BackboneFast をイネーブルにするには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# spanning-tree backbonefast

BackboneFast をイネーブルにします。

ステップ 2

Router(config)# end

コンフィギュレーション モードを終了します。

ステップ 3

Router# show spanning-tree vlan vlan_ID

BackboneFast がイネーブルになっていることを確認します。

次に、BackboneFast をイネーブルにする例を示します。

Router# configure terminal
Router(config)# spanning-tree backbonefast
Router(config)# end
Router#
 

次に、BackboneFast がイネーブルになっていることを確認する例を示します。

Router# show spanning-tree backbonefast
BackboneFast is enabled
 
BackboneFast statistics
-----------------------
Number of transition via backboneFast (all VLANs) : 0
Number of inferior BPDUs received (all VLANs) : 0
Number of RLQ request PDUs received (all VLANs) : 0
Number of RLQ response PDUs received (all VLANs) : 0
Number of RLQ request PDUs sent (all VLANs) : 0
Number of RLQ response PDUs sent (all VLANs) : 0
Router#

EtherChannel ガードのイネーブル化

EtherChannel ガードをイネーブルにするには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# spanning-tree etherchannel guard misconfig

EtherChannel ガードをイネーブルにします。

ステップ 2

Router(config)# end

コンフィギュレーション モードを終了します。

ステップ 3

Router# show spanning-tree summary | include EtherChannel

EtherChannel ガードがイネーブルになっていることを確認します。

次に、EtherChannel ガードをイネーブルにする例を示します。

Router# configure terminal
Router(config)# spanning-tree etherchannel guard misconfig
Router(config)# end
Router#
 

次に、設定を確認する例を示します。

Router# show spanning-tree summary | include EtherChannel
EtherChannel misconfiguration guard is enabled
 

errdisable ステートのインターフェイスを表示するには、 show interface status err-disable コマンドを入力します。

誤っている設定が解消されると、errdisable ステートのインターフェイスは自動的に回復します。ポートを手動で動作状態に戻すには、 shutdown コマンドを入力してから、該当するインターフェイスに対して no shutdown コマンドを入力します。

ルート ガードのイネーブル化

ルート ガードをイネーブルにするには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# interface { type5 slot/port } | { port-channel port_channel_number }

設定するポートを選択します。

ステップ 2

Router(config-if)# spanning-tree guard root

ルート ガードをイネーブルにします。

ステップ 3

Router(config-if)# end

コンフィギュレーション モードを終了します。

ステップ 4

Router# show spanning-tree

Router# show running interface { type1 slot/port } | { port-channel port_channel_number }

設定を確認します。

5.type = fastethernetgigabitethernet、または tengigabitethernet

ルートとして一貫性のないステートになっているポートを表示するには、 show spanning-tree inconsistentports コマンドを入力します。

ループ ガードのイネーブル化

スイッチ上でループ ガードをグローバルにイネーブル化するには、次の作業を実行します。

 

コマンド
目的

ステップ 1

Router(config)# spanning-tree loopguard default

スイッチ上でループ ガードをグローバルにイネーブル化します。

ステップ 2

Router(config)# end

コンフィギュレーション モードを終了します。

ステップ 3

Router# show spanning-tree interface { type6 slot/port } detail

この設定がポートに作用していることを確認します。

6.type = fastethernetgigabitethernet、または tengigabitethernet

次に、ループ ガードをグローバルにイネーブルにする例を示します。

Router# configure terminal
 
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# spanning-tree loopguard default
Router(config)# ^Z
 
Router# show spanning-tree interface fastEthernet 4/4 detail
Port 196 (FastEthernet4/4) of VLAN0010 is forwarding
Port path cost 1000, Port priority 160, Port Identifier 160.196.
Designated root has priority 32768, address 00d0.00b8.140a
Designated bridge has priority 32768, address 00d0.00b8.140a
Designated port id is 160.196, designated path cost 0
Timers:message age 0, forward delay 0, hold 0
Number of transitions to forwarding state:1
The port is in the portfast mode by portfast trunk configuration
Link type is point-to-point by default
Bpdu filter is enabled
Loop guard is enabled by default on the port
BPDU:sent 0, received 0
 

特定のポート上でループ ガードをイネーブルにするには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# interface { type7 slot/port } | { port-channel port_channel_number }

設定するポートを選択します。

ステップ 2

Router(config-if)# spanning-tree guard loop

ループ ガードを設定します。

ステップ 3

Router(config)# end

コンフィギュレーション モードを終了します。

ステップ 4

Router# show spanning-tree interface { type slot/port } detail

この設定がポートに作用していることを確認します。

7.type = fastethernetgigabitethernet、または tengigabitethernet

次に、ループ ガードをイネーブルにする例を示します。

Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# interface fastEthernet 4/4
Router(config-if)# spanning-tree guard loop
Router(config-if)# ^Z
 

次に、設定を確認する例を示します。

Router# show spanning-tree interface fastEthernet 4/4 detail
Port 196 (FastEthernet4/4) of VLAN0010 is forwarding
Port path cost 1000, Port priority 160, Port Identifier 160.196.
Designated root has priority 32768, address 00d0.00b8.140a
Designated bridge has priority 32768, address 00d0.00b8.140a
Designated port id is 160.196, designated path cost 0
Timers:message age 0, forward delay 0, hold 0
Number of transitions to forwarding state:1
The port is in the portfast mode by portfast trunk configuration
Link type is point-to-point by default
Bpdu filter is enabled
Loop guard is enabled on the port
BPDU:sent 0, received 0
Router#
 

PVST シミュレーションの設定


) PVST シミュレーションはデフォルトでイネーブルになっているので、デバイス上のすべてのインターフェイスは MST および Rapid PVST+ 間で相互運用します。PVST シミュレーションをディセーブル化する機能は、Cisco IOS Release 12.2(33)SXI で導入されます。


MST をデフォルトの STP モードとして実行していないデバイスに誤って接続するのを避けるには、PVST シミュレーションをディセーブルにします。PVST シミュレーションをディセーブルにした場合、MST 対応ポートは自身が Rapid PVST+ 対応ポートに接続されていることを検出すると、ブロッキング ステートに移行します。このポートは、BPDU の受信を停止するまでは一貫性のないステートを維持し、受信停止後は通常の STP 移行プロセスを再開します。

PVST シミュレーションをグローバルにイネーブル化またはディセーブル化するには、次に示すように、 global キーワードを使用してコマンドを入力します。

 

コマンド
目的

Router(config)# spanning-tree mst simulate pvst global

すべてのポートをイネーブルにして、Rapid PVST+ モードで動作している接続先デバイスと自動的に相互運用するようにします。デフォルトはイネーブルです。したがって、すべてのインターフェイスは、Rapid PVST+ および MST 間でシームレスに動作します。

ポートのグローバルな PVST シミュレーション設定を上書きするには、インターフェイス コマンド モードで次のようにコマンドを入力します。

 

コマンド
目的

ステップ 1

Router(config)# interface { type8 slot/port }

設定するポートを選択します。

ステップ 2

Router(config-if)# spanning-tree mst simulate pvst

このインターフェイスをイネーブルにして、Rapid PVST+ モードで動作している接続先デバイスと自動的に相互運用するようにします。

8.type = fastethernetgigabitethernet、または tengigabitethernet

次に、Rapid PVST+ を実行している接続先デバイスとスイッチが自動的に相互運用しないようにする例を示します。

Router(config)# no spanning-tree mst simulate pvst global
 

次に、Rapid PVST+ を実行している接続先デバイスとポートが自動的に相互運用しないようにする例を示します。

Router(config)# interface gi3/13
Router(config-if)# spanning-tree mst simulate pvst disable
 

オプションの STP 機能の確認

ここでは、次の内容について説明します。

「show spanning-tree コマンドの使用方法」

「Release 12.2(33)SXI 以降の例」

「Release 12.2(33)SXI よりも前のリリースの例」

show spanning-tree コマンドの使用方法

ここで説明する show spanning-tree コマンドを使用して、グローバル レベルとポート レベルの両方で、スパニング ツリー ステータスと設定情報を表示できます。

スパニング ツリー ステータスと設定情報を表示するには、次の作業のいずれかを行います。

 

コマンド
目的

Router# show spanning-tree

プロトコル タイプやポート タイプを含む、スパニング ツリーに関する情報を表示します。

Router# show spanning-tree summary

スパニング ツリー機能の設定および VLAN のスパニング ツリー ステートのサマリを表示します。

Router# show spanning-tree summary totals

スパニング ツリー機能の設定のサマリと VLAN ステート全体を表示します。

Router# show spanning-tree interface { type9 slot/port } detail

インターフェイスのスパニング ツリー ステータスの詳細を表示します。

Router# show spanning-tree interface { type1 slot/port } portfast edge

すべてのインスタンスに対するスパニング ツリー portfast エッジ インターフェイスの動作ステートを表示します。

Cisco IOS Release 12.2(33)SXI よりも前のリリースでは、 edge キーワードは使用されません。

9.type = fastethernetgigabitethernet、または tengigabitethernet

Release 12.2(33)SXI 以降の例


) Release 12.2(33)SXI よりも前のリリースにおける show spanning-tree コマンドの出力は、Release 12.2(33)SXI 以降での出力と異なります。このセクションの例では、両者の違いを太字で示しています。


次に、ブリッジ保証はイネーブルだが一貫性のないステートのスパニング ツリー ステータスの例を示します。

Router# show spanning-tree
VLAN0010
Spanning tree enabled protocol rstp
Root ID Priority 32778
Address 0002.172c.f400
This bridge is the root
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
 
Bridge ID Priority 32778 (priority 32768 sys-id-ext 10)
Address 0002.172c.f400
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 300
 
Interface Role Sts Cost Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Gi3/14 Desg BKN*4 128.270 Network, P2p *BA_Inc
Router#
 

次の一貫性の欠如に関するメッセージを [Type] フィールドに追加できます。

*BA_Inc:ブリッジ保証が一貫性のないステートであることを示します。

*PVST_Peer_Inc:ポートがピア タイプに一貫性のないステートであることを示します。

Dispute:競合する状態が検出されたことを示します。

次に、スパニング ツリー設定サマリの例を示します。

Router# show spanning-tree summary
 
Switch is in rapid-pvst mode
Root bridge for: Bridge VLAN0025
EtherChannel misconfiguration guard is enabled
Extended system ID is enabled
PortFast Edge BPDU Guard Default is disabled
Portfast Edge BPDU Filter Default is disabled
Portfast Default is edge
Bridge Assurance is enabled
Loopguard is disabled
UplinkFast is disabled
BackboneFast is disabled
Pathcost method used is short
PVST Simulation Default is enabled
 
Name Blocking Listening Learning Forwarding STP Active
---------------------- -------- --------- -------- ---------- ----------
VLAN0025 0 0 0 1 1
VLAN0030 0 0 0 2 2
---------------------- -------- --------- -------- ---------- ----------
2 vlans 0 0 0 3 3
Router#
 

Bridge Assurance フィールドで使用できるステートは次のとおりです。

is enabled

is disabled

is enabled but not active in the PVST mode

次に、STP モードで PVST シミュレーションがディセーブルな場合のスパニング ツリー サマリの例を示します。

 
Router# show spanning-tree summary
 
Switch is in mst mode (IEEE Standard)
Root bridge for: MST0
EtherChannel misconfig guard is enabled
Extended system ID is enabled
Portfast Default is disabled
PortFast BPDU Guard Default is disabled
Portfast BPDU Filter Default is disabled
Loopguard Default is disabled
UplinkFast is disabled
BackboneFast is disabled
Pathcost method used is long
PVST Simulation Default is disabled
 
Name Blocking Listening Learning Forwarding STP Active
---------------------- -------- --------- -------- ---------- ----------
MST0 2 0 0 0 2
---------------------- -------- --------- -------- ---------- ----------
1 mst 2 0 0 0 2
 

PVST Simulation Default フィールドで使用できるステートは次のとおりです。

is enabled

is disabled

is enabled but not active in rapid-PVST mode

次に、スパニング ツリー サマリ全体の例を示します。

Router# show spanning-tree summary totals
Root bridge for: Bridge VLAN0025
EtherChannel misconfiguration guard is enabled
Extended system ID is enabled
PortFast Edge BPDU Guard Default is enabled
Portfast Edge BPDU Filter Default is disabled
Portfast Default is edge
Bridge Assurance is enabled
Loopguard is disabled
UplinkFast is disabled
BackboneFast is disabled
Pathcost method used is long
 
Name Blocking Listening Learning Forwarding STP Active
---------------------- -------- --------- -------- ---------- ----------
2 vlans 0 0 0 3 3
Router#
 

次に、エッジ ポートのスパニング ツリー設定詳細の例を示します。

Router# show spanning-tree interface gi3/13 detail
Port 269 (GigabitEthernet3/13) of VLAN0002 is forwarding
Port path cost 4, Port priority 128, Port Identifier 128.269.
Designated root has priority 32770, address 0002.172c.f400
Designated bridge has priority 32770, address 0002.172c.f400
Designated port id is 128.269, designated path cost 0
Timers: message age 0, forward delay 0, hold 0
Number of transitions to forwarding state: 1
Link type is point-to-point by default
Loop guard is enabled by default on the port
The port is in the portfast edge mode by default
BPDU: sent 2183, received 0
 

次に、トランク ポートのスパニング ツリー設定詳細の例を示します。

Router(config-if)# spanning-tree portfast edge trunk
%Warning:portfast should only be enabled on ports connected to a single
host. Connecting hubs, concentrators, switches, bridges, etc... to this
interface when portfast is enabled, can cause temporary bridging loops.
Use with CAUTION
 
Router(config-if)# ^Z
 
Router# show spanning-tree interface gi3/13 detail
Port 269 (GigabitEthernet3/13) of VLAN0002 is forwarding
Port path cost 4, Port priority 128, Port Identifier 128.269.
Designated root has priority 32770, address 0002.172c.f400
Designated bridge has priority 32770, address 0002.172c.f400
Designated port id is 128.269, designated path cost 0
Timers: message age 0, forward delay 0, hold 0
Number of transitions to forwarding state: 1
Link type is point-to-point by default
Loop guard is enabled by default on the port
The port is in the portfast edge trunk mode
BPDU: sent 2183, received 0
Router#
 

次に、競合する状態が検出された場合のエッジ ポートのスパニング ツリー設定詳細の例を示します。

Router# show spanning-tree interface gi3/13 detail
Port 269 (GigabitEthernet3/13) of VLAN0002 is designated blocking (dispute)
Port path cost 4, Port priority 128, Port Identifier 128.297.
Designated root has priority 32769, address 0013.5f20.01c0
Designated bridge has priority 32769, address 0013.5f20.01c0
Designated port id is 128.297, designated path cost 0
Timers: message age 0, forward delay 0, hold 0
Number of transitions to forwarding state: 1
Link type is point-to-point by default
BPDU: sent 132, received 1
Router#
 

次に、すべてのインスタンスに対するスパニング ツリー portfast エッジ インターフェイスの動作ステートの例を示します。

Router# show spanning-tree interface gi3/1 portfast edge
MST0 disabled
MST1 disabled
 

Release 12.2(33)SXI よりも前のリリースの例


) Release 12.2(33)SXI よりも前のリリースにおける show spanning-tree コマンドの出力は、Release 12.2(33)SXI 以降での出力と異なります。このセクションの例では、両者の違いを太字で示しています。


次に、スパニング ツリー ステータスの例を示します。

Router# show spanning-tree
VLAN0010
Spanning tree enabled protocol rstp
Root ID Priority 32778
Address 0002.172c.f400
This bridge is the root
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
 
Bridge ID Priority 32778 (priority 32768 sys-id-ext 10)
Address 0002.172c.f400
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 300
 
Interface Role Sts Cost Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Gi3/14 Desg FWD 4 128.270 Edge, P2p
Router#
 

次に、スパニング ツリー設定サマリの例を示します。

Router# show spanning-tree summary
 
Switch is in rapid-pvst mode
Root bridge for:VLAN0010
EtherChannel misconfiguration guard is enabled
Extended system ID is disabled
Portfast is enabled by default
PortFast BPDU Guard is disabled by default
Portfast BPDU Filter is disabled by default
Loopguard is disabled by default
UplinkFast is disabled
BackboneFast is disabled
Pathcost method used is long
 
Name Blocking Listening Learning Forwarding STP Active
---------------------- -------- --------- -------- ---------- ----------
VLAN0001 0 0 0 1 1
VLAN0010 0 0 0 2 2
---------------------- -------- --------- -------- ---------- ----------
2 vlans 0 0 0 3 3
Router#
 

次に、スパニング ツリー設定サマリ全体の例を示します。

Router# show spanning-tree summary totals
 
Switch is in rapid-pvst mode
Root bridge for:VLAN0010
EtherChannel misconfiguration guard is enabled
Extended system ID is disabled
Portfast is enabled by default
PortFast BPDU Guard is disabled by default
Portfast BPDU Filter is disabled by default
Loopguard is disabled by default
UplinkFast is disabled
BackboneFast is disabled
Pathcost method used is long
 
Name Blocking Listening Learning Forwarding STP Active
---------------------- -------- --------- -------- ---------- ----------
2 vlans 0 0 0 3 3
Router#
 

次に、エッジ ポートのスパニング ツリー設定詳細の例を示します。

Router# show spanning-tree interface fastEthernet 4/4 detail
Port 196 (FastEthernet4/4) of VLAN0010 is forwarding
Port path cost 1000, Port priority 160, Port Identifier 160.196.
Designated root has priority 32768, address 00d0.00b8.140a
Designated bridge has priority 32768, address 00d0.00b8.140a
Designated port id is 160.196, designated path cost 0
Timers:message age 0, forward delay 0, hold 0
Number of transitions to forwarding state:1
The port is in the portfast mode by default
Link type is point-to-point by default
BPDU:sent 10, received 0
 

次に、トランク ポートのスパニング ツリー設定詳細の例を示します。

Router(config-if)# spanning-tree portfast trunk
%Warning:portfast should only be enabled on ports connected to a single
host. Connecting hubs, concentrators, switches, bridges, etc... to this
interface when portfast is enabled, can cause temporary bridging loops.
Use with CAUTION
 
Router(config-if)# ^Z
 
Router# show spanning-tree interface fastEthernet 4/4 detail
Port 196 (FastEthernet4/4) of VLAN0010 is forwarding
Port path cost 1000, Port priority 160, Port Identifier 160.196.
Designated root has priority 32768, address 00d0.00b8.140a
Designated bridge has priority 32768, address 00d0.00b8.140a
Designated port id is 160.196, designated path cost 0
Timers:message age 0, forward delay 0, hold 0
Number of transitions to forwarding state:1
The port is in the portfast mode by portfast trunk configuration
Link type is point-to-point by default
BPDU:sent 30, received 0
Router#
 

次に、すべてのインスタンスに対するスパニング ツリー portfast インターフェイスの動作ステートの例を示します。

Router# show spanning-tree interface gi3/1 portfast
MST0 disabled
MST1 disabled