Catalyst 6500 Release 12.2SXH and Later Software コンフィギュレーション ガイド
ローカル SPAN、RSPAN、および ERSPAN の設定
ローカル SPAN、RSPAN、および ERSPAN の設定
発行日;2012/02/01 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 12MB) | フィードバック

目次

ローカル SPAN、RSPAN、および ERSPAN の設定

ローカル SPAN、RSPAN、および ERSPAN の概要

ローカル SPAN、RSPAN、および ERSPAN の概要

ローカル SPAN の概要

RSPAN の概要

ERSPAN の概要

SPAN 送信元でモニタされるトラフィックの概要

ローカル SPAN、RSPAN、および ERSPAN の送信元

送信元 CPU

送信元ポートおよび EtherChannel

送信元 VLAN

ローカル SPAN、RSPAN、および ERSPAN の宛先

ローカル SPAN、RSPAN、および ERSPAN 設定時の注意事項および制約事項

機能の非互換性

ローカル SPAN、RSPAN、および ERSPAN セッションの制限

ローカル SPAN、RSPAN、および ERSPAN インターフェイスの制限

ローカル SPAN、RSPAN、および ERSPAN の注意事項および制約事項

VSPAN に関する注意事項および制約事項

RSPAN に関する注意事項および制約事項

ERSPAN に関する注意事項および制約事項

分散型出力 SPAN モードの注意事項および制約事項

ローカル SPAN、RSPAN、および ERSPAN の設定

ローカル SPAN、RSPAN、および ERSPAN のデフォルト設定

無条件トランクとしての宛先の設定(任意)

宛先トランク VLAN フィルタリングの設定(任意)

宛先ポートの許可リストの設定(任意)

出力 SPAN モードの設定(任意)

ローカル SPAN の設定

ローカル SPAN の設定(SPAN コンフィギュレーション モード)

ローカル SPAN の設定(グローバル コンフィギュレーション モード)

RSPAN の設定

RSPAN VLAN の設定

RSPAN セッションの設定(SPAN コンフィギュレーション モード)

RSPAN セッションの設定(グローバル コンフィギュレーション モード)

ERSPAN の設定

ERSPAN 送信元セッションの設定

ERSPAN 宛先セッションの設定

グローバル コンフィギュレーション モードでの送信元 VLAN フィルタリングの設定

設定の確認

設定例

ローカル SPAN、RSPAN、および ERSPAN の設定

この章では、Cisco IOS Software Release 12.2SX でローカル Switched Port Analyzer(SPAN; スイッチド ポート アナライザ)、Remote SPAN(RSPAN)、および Encapsulated RSPAN(ERSPAN)を設定する手順について説明します。


) • この章で使用しているコマンドの構文および使用方法の詳細については、次の URL の『Cisco IOS Software Releases 12.2SX Command References』を参照してください。

http://www.cisco.com/en/US/docs/ios/mcl/122sxmcl/12_2sx_mcl_book.html

SPA ポートおよび FlexWAN ポートは、SPAN、RSPAN、または ERSPAN をサポートしません。


 

この章で説明する内容は、次のとおりです。

「ローカル SPAN、RSPAN、および ERSPAN の概要」

「ローカル SPAN、RSPAN、および ERSPAN 設定時の注意事項および制約事項」

「ローカル SPAN、RSPAN、および ERSPAN の設定」

ローカル SPAN、RSPAN、および ERSPAN の概要

ここでは、ローカル SPAN、RSPAN、および ERSPAN の機能について説明します。

「ローカル SPAN、RSPAN、および ERSPAN の概要」

「ローカル SPAN、RSPAN、および ERSPAN の送信元」

「ローカル SPAN、RSPAN、および ERSPAN の宛先」

ローカル SPAN、RSPAN、および ERSPAN の概要

SPAN は、1 つ以上の CPU、1 つ以上のポート、1 つ以上の EtherChannel、または 1 つ以上の VLAN からトラフィックをコピーし、SwitchProbe デバイスまたは他の Remoter Monitoring(RMON)プローブなどのネットワーク アナライザが分析できるように、1 つ以上の宛先にコピーしたトラフィックを送信します。

SPAN は、送信元上のトラフィックのスイッチングには影響しません。その宛先は、SPAN 専用に設定する必要があります。SPAN により生成されたトラフィックのコピーは、スイッチ リソースのユーザ トラフィックと競合します。

ここでは、ローカル SPAN、RSPAN、および ERSPAN の概要を説明します。

「ローカル SPAN の概要」

「RSPAN の概要」

「ERSPAN の概要」

「SPAN 送信元でモニタされるトラフィックの概要」

ローカル SPAN の概要

ローカル SPAN セッションは、送信元ポートおよび送信元 VLAN と、1 つまたは複数の宛先を対応付けます。ローカル SPAN セッションを単一のスイッチに設定します。ローカル SPAN には、個別の送信元および宛先のセッションはありません。

ローカル SPAN セッションは、RSPAN VLAN を伝送する送信元トランク ポートからローカルに送信された RSPAN トラフィックをコピーしません。ローカル SPAN セッションは、送信元ポートからローカルに送信された RSPAN VLAN GRE(総称ルーティング カプセル化)カプセル化トラフィックをコピーしません。

各ローカル SPAN セッションは、ポートまたは VLAN のいずれかを送信元とすることができますが、両方を送信元にすることはできません。

ローカル SPAN は、任意の VLAN 上の 1 つまたは複数の送信元ポートからのトラフィック、あるいは 1 つまたは複数の VLAN からのトラフィックを分析するために宛先へコピーします(図57-1 を参照)。たとえば、図57-1 に示すように、イーサネット ポート 5(送信元ポート)上の全トラフィックが、イーサネット ポート 10 にコピーされます。イーサネット ポート 10 のネットワーク アナライザは、イーサネット ポート 5 に物理的に接続していなくても、このポートからのあらゆるトラフィックを受信することができます。

図57-1 SPAN の設定例

 

RSPAN の概要

RSPAN は、様々なスイッチ上の送信元ポート、送信元 VLAN、および宛先をサポートし、ネットワーク全体に存在する複数のスイッチをリモート モニタします(図57-2 を参照)。RSPAN はレイヤ 2 VLAN を使用して、スイッチ間で SPAN トラフィックを伝送します。

RSPAN は、RSPAN 送信元セッション、RSPAN VLAN、および RSPAN 宛先セッションで構成されています。RSPAN の送信元セッションと宛先セッションを、様々なスイッチ上で個別に設定します。RSPAN 送信元セッションを 1 つのスイッチ上で設定するには、送信元ポートまたは VLAN のセットを RSPAN VLAN に対応付けます。RSPAN 宛先セッションを別のスイッチ上で設定するには、宛先を RSPAN VLAN に対応付けます。

各 RSPAN セッション用のトラフィックは、ユーザ固有の RSPAN VLAN(すべての参加スイッチでその RSPAN セッション専用となっている)経由で、レイヤ 2 の非ルーティング トラフィックとして伝送されます。すべての参加スイッチはレイヤ 2 にトランク接続される必要があります。

RSPAN 送信元セッションは、RSPAN VLAN を伝送する送信元トランク ポートからローカルに送信される RSPAN VLAN トラフィックをコピーしません。RSPAN 送信元セッションは、送信元ポートからローカルに送信された RSPAN GRE カプセル化トラフィックをコピーしません。

各 RSPAN 送信元セッションは、ポートまたは VLAN のいずれかを送信元とすることができますが、両方を送信元にすることはできません。

RSPAN 送信元セッションは、送信元ポートまたは送信元 VLAN からのトラフィックをコピーして、RSPAN VLAN のトラフィックを RSPAN 宛先セッションにスイッチングします。RSPAN 宛先セッションでは、トラフィックを宛先にスイッチングします。

図57-2 RSPAN の設定

 

ERSPAN の概要

ERSPAN は、様々なスイッチ上の送信元ポート、送信元 VLAN、および宛先をサポートし、ネットワーク全体に存在する複数のスイッチをリモート モニタします(図57-3 を参照)。ERSPAN は GRE トンネルを使用し、スイッチ間でトラフィックを伝送します。

ERSPAN は、ERSPAN 送信元セッション、ルーティング可能な ERSPAN GRE カプセル化トラフィック、および ERSPAN 宛先セッションで構成されています。ERSPAN の送信元セッションと宛先セッションを、様々なスイッチ上で個別に設定します。

ERSPAN 送信元セッションを 1 つのスイッチ上で設定するには、送信元ポートまたは VLAN のセットを宛先 IP アドレス、ERSPAN ID 番号、およびオプションとして VRF(VPN ルーティング/転送)名に対応付けます。ERSPAN 宛先セッションを別のスイッチ上で設定するには、宛先を送信元 IP アドレス、ERSPAN ID 番号、およびオプションとして VRF 名に対応付けます。

ERSPAN 送信元セッションは、RSPAN VLAN を伝送する送信元トランク ポートからローカルに送信される RSPAN VLAN トラフィックをコピーしません。ERSPAN 送信元セッションは、送信元ポートからローカルに送信された ERSPAN GRE カプセル化トラフィックをコピーしません。

各 ERSPAN 送信元セッションは、ポートまたは VLAN のいずれかを送信元とすることができますが、両方を送信元にすることはできません。

ERSPAN 送信元セッションは、送信元ポートまたは送信元 VLAN からのトラフィックをコピーして、ルーティング可能な GRE カプセル化パケットを使用することでこのトラフィックを ERSPAN 宛先セッションに転送します。ERSPAN 宛先セッションでは、トラフィックを宛先にスイッチングします。

図57-3 ERSPAN のデフォルト設定

 

SPAN 送信元でモニタされるトラフィックの概要

ここでは、ローカル SPAN、RSPAN、および ERSPAN 送信元によってモニタが可能なトラフィックについて説明します。

「モニタ対象トラフィックの方向」

「モニタ対象トラフィック タイプ」

「重複トラフィック」

モニタ対象トラフィックの方向

ローカル SPAN セッション、RSPAN 送信元セッション、および ERSPAN 送信元セッションを設定して、次のトラフィックをモニタできます。

入力トラフィック

呼び出された入力 SPAN

送信元が受信するトラフィックをコピーします(入力トラフィック)。

入力トラフィックは、コピーされるスーパーバイザ エンジン SPAN ASIC に送信されます。

出力トラフィック

呼び出された出力 SPAN

送信元から送信するトラフィックをコピーします(出力トラフィック)。

分散型出力 SPAN モード -- Release 12.2(33)SXH 以降のリリースでは、一部のファブリック対応スイッチング モジュールで、スイッチング モジュール SPAN ASIC によって出力トラフィックをローカルにコピーし、SPAN 宛先に送信できます。分散型出力 SPAN モードをサポートするスイッチング モジュールについては、「分散型出力 SPAN モードの注意事項および制約事項」を参照してください。

集中型出力 SPAN モード -- 他のすべてのスイッチング モジュールでは、出力トラフィックがコピーされるスーパーバイザ エンジン SPAN ASIC に送信され、さらに SPAN 宛先に送信されます。

設定手順については、「出力 SPAN モードの設定(任意)」を参照してください。

両方

受信トラフィックと送信トラフィックの両方をコピーします(入力および出力トラフィック)。

入力トラフィックと出力トラフィックのいずれも、コピーされるスーパーバイザ エンジン SPAN ASIC に送信されます。

モニタ対象トラフィック タイプ

デフォルトでは、ローカル SPAN および ERSPAN は、マルチキャストおよび Bridge Protocol Data Unit(BPDU; ブリッジ プロトコル データ ユニット)フレームを含めて、すべてのトラフィックをモニタします。RSPAN は BPDU モニタをサポートしません。

重複トラフィック

設定によっては、SPAN が同じ送信元のトラフィックの複数のコピーを、宛先に送信します。たとえば、s1 と s2 という 2 つの SPAN 送信元から、d1 という SPAN 宛先ポートに対して両方向の SPAN セッション(入力および出力の両方)が設定されていて、パケットが s1 経由でスイッチに入り、そのスイッチから s2 へ出力されるように送信される場合、s1 における入力 SPAN はパケットのコピーを SPAN 宛先ポートの d1 に送信し、s2 における出力 SPAN も、パケットのコピーを SPAN 宛先ポートの d1 に送信します。パケットが s1 から s2 へスイッチングされたレイヤ 2 だった場合、両方の SPAN パケットは同一になります。パケットが s1 から s2 へスイッチングされたレイヤ 3 だった場合、レイヤ 3 の書き換えは送信元と宛先のレイヤ 2 アドレスを変更し、この場合、SPAN パケットは異なるものになります。

ローカル SPAN、RSPAN、および ERSPAN の送信元

ここでは、ローカル SPAN、RSPAN、および ERSPAN の送信元について説明します。

「送信元 CPU」

「送信元ポートおよび EtherChannel」

「送信元 VLAN」

送信元 CPU

送信元 CPU は、トラフィック分析のためにモニタ対象になる CPU です。Release 12.2(33)SXH 以降のリリースでは、SP CPU と RP CPU の両方を SPAN 送信元として設定できます。次に、CPU モニタリングで生成されるデータでできることの例を示します。

CPU トラフィックに関するベースライン情報の開発

CoPP ポリシーの作成時に使用する情報の開発

CPU 関連の問題(たとえば、CPU の高利用率)のトラブルシューティング


) • CPU SPAN は、CPU 自身のボードからではなく、CPU トラフィックを送受信する ASIC の観点から CPU トラフィックをモニタします。

CPU とやりとりするトラフィックには、VLAN ID のタグが付けられます。CPU トラフィックの送信元 VLAN フィルタリングが設定可能です。


 

送信元ポートおよび EtherChannel

送信元ポートまたは EtherChannel は、トラフィック分析のためにモニタ対象になるポートまたは EtherChannel です。レイヤ 2 およびレイヤ 3 のポートと EtherChannel はいずれも、SPAN 送信元として設定できます。SPAN は、1 つまたは複数の送信元ポートまたは EtherChannel を、単一の SPAN セッションでモニタできます。任意の VLAN のポートまたは EtherChannel を SPAN 送信元として設定できます。トランク ポートまたは EtherChannel は、送信元および非トランク送信元との混在として設定できます。


) SPAN は、トランク送信元からのカプセル化をコピーしません。SPAN 宛先をトランクとして設定し、分析用に送信される前に、監視対象トラフィックにタグを付けることができます。


送信元 VLAN

送信元 VLAN は、トラフィック分析のためにモニタ対象になる VLAN です。VLAN ベースの SPAN(VSPAN)は、VLAN を SPAN 送信元として使用します。送信元 VLAN のすべてのポートおよび EthernetChannel は、SPAN トラフィックの送信元になります。


) 送信元 VLAN 上のレイヤ 3 VLAN インターフェイスは、SPAN トラフィックの送信元ではありません。レイヤ 3 VLAN インターフェイスを介して VLAN に入ってくるトラフィックは、送信元 VLAN にある出力ポートまたは EtherChannel を介してスイッチから送信されるときにモニタされます。


ローカル SPAN、RSPAN、および ERSPAN の宛先

SPAN 宛先は、レイヤ 2 やレイヤ 3 ポート、またはRelease 12.2(33)SXH 以降のリリースでは EtherChannel で、これらに対してローカル SPAN、RSPAN、または ERSPAN が分析用のトラフィックを送信します。ポートまたは EtherChannel を SPAN の宛先として設定すると、その宛先は SPAN 機能によってのみ使用される専用の宛先になります。

宛先 EtherChannel は、PAgP または LACP EtherChannel プロトコルをサポートしません。すべての EtherChannel プロトコルのサポートがディセーブルになっているときだけ、オン モードがサポートされます。

宛先 EtherChannel のメンバ リンクが EtherChannel をサポートするデバイスの接続される場合、要件はありません。たとえば、メンバ リンクを別個のネットワーク アナライザに接続できます。EtherChannel についての詳細は、「EtherChannel の設定」を参照してください。

デフォルトでは、宛先はトラフィックを受信できません。Release 12.2(33)SXH 以降のリリースでは、任意の接続デバイスからトラフィックを受信するようにレイヤ 2 宛先を設定できます。

デフォルトでは、宛先は SPAN 以外のトラフィックを送信しません。トラフィックを受信するように設定してあるレイヤ 2 宛先は、宛先に接続されているデバイスのレイヤ 2 アドレスを学習し、そのデバイスに宛てたトラフィックを送信するように設定できます。

トランクは宛先として設定でき、これによってトランク宛先がカプセル化トラフィックを送信できるようになります。許可された VLAN リストを使用して、宛先トランク VLAN フィルタリングを設定できます。

ローカル SPAN、RSPAN、および ERSPAN 設定時の注意事項および制約事項

ここでは、ローカル SPAN、RSPAN、および ERSPAN の設定に関する注意事項および制約事項について説明します。

「機能の非互換性」

「ローカル SPAN、RSPAN、および ERSPAN セッションの制限」

「ローカル SPAN、RSPAN、および ERSPAN インターフェイスの制限」

「ローカル SPAN、RSPAN、および ERSPAN の注意事項および制約事項」

「VSPAN に関する注意事項および制約事項」

「RSPAN に関する注意事項および制約事項」

「ERSPAN に関する注意事項および制約事項」

「分散型出力 SPAN モードの注意事項および制約事項」

機能の非互換性

ローカル SPAN、RSPAN、および ERSPAN には、次のような機能の非互換性問題が存在します。

出力 SPAN は出力マルチキャスト モードではサポートされていません(CSCsa95965)。

UUFB ポートは、RSPAN またはローカル SPAN 出力専用宛先として使用することはできません(CSCsj27695)。

PFC3 モードと PEC3CXL モード以外では、EoMPLS ポートを SPAN 送信元として使用することはできません(CSCed51245)。

ポートチャネル インターフェイス(EtherChannel)は SPAN 送信元として使用できますが、EtherChannel のアクティブなメンバー ポートを SPAN 送信元ポートとして設定することはできません。EtherChannel の非アクティブ メンバー ポートは SPAN 送信元として設定できますが、これらのポートは中断ステートになり、トラフィックを伝送しません。

次の機能は、SPAN 宛先との互換性がありません。

プライベート VLAN

IEEE 802.1X ポートベースの認証

ポート セキュリティ

Spanning-Tree Protocol(STP; スパニング ツリー プロトコル)および関連機能(PortFast、PortFast BPDU フィルタリング、BPDU ガード、UplinkFast、BackboneFast、EtherChannel ガード、ルート ガード、ループ ガード)

VLAN Trunking Protocol(VTP; VLAN トランキング プロトコル)

Dynamic Trunking Protocol(DTP; ダイナミック トランキング プロトコル)

IEEE 802.1Q トンネリング


) SPAN 宛先は、IEEE 802.3Z フロー制御に関与できます。



) 出力パケット レプリケーションを使用している IP マルチキャスト スイッチングは、SPAN との互換性がありません。一部の場合、出力レプリケーションでは、SPAN 宛先ポートにマルチキャスト パケットが送信されない結果となることがあります。SPAN を使用していて、スイッチング モジュールが出力レプリケーションに対応している場合、出力レプリケーションを強制するには、mls ip multicast replication-mode ingress コマンドを入力します。


ローカル SPAN、RSPAN、および ERSPAN セッションの制限

Release 12.2(33)SXH 以降のリリースでは、次の項目が PFC3 ローカル SPAN、RSPAN、および ERSPAN セッションの制限となります。

 

総セッション数
ローカルおよび送信元セッション
宛先セッション
ローカル SPAN、RSPAN 送信元、ERSPAN 送信元入力または出力またはその両方
ローカル SPAN 出力専用
RSPAN
ERSPAN

80

2

14

64

23

ローカル SPAN、RSPAN、および ERSPAN インターフェイスの制限

Release 12.2(33)SXH 以降のリリースでは、次の項目が PFC3 ローカル SPAN、RSPAN、および ERSPAN 送信元および宛先インターフェイスの制限となります。

 

 
各ローカル
SPAN
セッション
各 RSPAN
送信元
セッション
各 ERSPAN
送信元
セッション
各 RSPAN
宛先セッション
各 ERSPAN
宛先セッション

出力または「両方」の送信元

128

128

128

--

--

入力送信元

128

128

128

--

--

RSPAN および ERSPAN 宛先セッションの送信元

--

--

--

1 RSPAN VLAN

1 IP アドレス

セッションごとの宛先

64

1 RSPAN VLAN

1 IP アドレス

64

64

ローカル SPAN、RSPAN、および ERSPAN の注意事項および制約事項

ローカル SPAN、RSPAN、および ERSPAN には、次の注意事項および制約事項が適用されます。

1 つの出力 SPAN 送信元ポートからトラフィックをコピーした SPAN 宛先は、出力トラフィックのみをネットワーク アナライザに送信します。複数の出力 SPAN 送信元ポートを設定している場合、ネットワーク アナライザに送信されるトラフィックに、出力 SPAN 送信元ポートから受信した特定タイプの入力トラフィックも含まれます。この入力トラフィックのタイプは次のとおりです。

VLAN 上でフラッディングしたすべてのユニキャスト トラフィック

ブロードキャストおよびマルチキャスト トラフィック

この状況が発生するのは、出力 SPAN 送信元ポートはこれらのトラフィック タイプを VLAN から受信したあと、自身がトラフィックの送信元であることを認識し、受信したトラフィックの送信元にこのトラフィックを返送せず、ドロップしてしまうためです。SPAN はドロップする前にこのトラフィックをコピーし、SPAN 宛先に送信します。(CSCds22021)

monitor session コマンドを追加して入力しても、前に設定した SPAN パラメータは消去されません。設定済みの SPAN パラメータを削除するには、 no monitor session コマンドを使用する必要があります。

ネットワーク アナライザを SPAN 宛先に接続します。

SPAN セッション内では、送信元 VLAN フィルタリングが SPAN 送信元で設定されている場合を除き、すべての SPAN 送信元からの全トラフィックを、すべての SPAN 宛先が受信します。

宛先 トランク VLAN フィルタリングが SAPN 宛先から送信されたトラフィックを選択するように設定できます。

レイヤ 2 LAN ポート( switchport コマンドを使用して設定された LAN ポート)とレイヤ 3 LAN ポート( switchport コマンドで設定されていないポート)の両方を送信元または宛先として設定できます。

1 つのセッションに、個別の送信元ポートおよび送信元 VLAN を混在させることはできません。

複数の入力送信元ポートを指定する場合、各ポートはそれぞれ異なる VLAN に属するものであってもかまいません。

セッション内では、SPAN 送信元として VLAN を設定することと、送信元 VLAN フィルタリングを実行することは、両方一度にはできません。SPAN 送信元として VLAN を設定すること、または送信元ポートおよび EtherChannel からのトラフィックの送信元 VLAN フィルタリングを実行することは可能ですが、同一セッション内で両方を行うことはできません。

内部 VLAN に対して送信元 VLAN フィルタリングを設定することはできません。

ローカル SPAN、RSPAN、および ERSPAN をイネーブルにすると、すでに入力された設定があれば、その設定が使用されます。

送信元を指定し、トラフィックの方向(入力、出力、または両方)を指定しない場合、「両方」がデフォルトで使用されます。

SPAN は、レイヤ 2 イーサネット フレームをコピーしますが、SPAN は送信元トランク ポート ISL(スイッチ間リンク)や 802.1Q タグをコピーしません。宛先をトランクとして設定して、ローカルにタグ付けされたトラフィックをトラフィック アナライザに送信できます。


) トランクとして設定した宛先は、レイヤ 3 LAN 送信元からのトラフィックを、レイヤ 3 LAN 送信元によって使用される内部 VLAN としてタグを付けます。


ローカル SPAN セッション、RSPAN 送信元セッション、および ERSPAN 送信元セッションは、RSPAN VLAN を伝送する送信元トランク ポートからローカルに送信された RSPAN VLAN トラフィックをコピーしません。

ローカル SPAN セッション、RSPAN 送信元セッション、および ERSPAN 送信元セッションは、送信元ポートからローカルに送信された ERSPAN GRE カプセル化トラフィックをコピーしません。

1 つのポートまたは EtherChannel は、1 つだけの SPAN セッションに対して SPAN 宛先となることができます。SPAN セッションは、宛先を共有できません。

SPAN 宛先は、SPAN 送信元になれません。

宛先は、スパニング ツリー インスタンスには関与しません。ローカル SPAN はモニタ対象トラフィックに BPDU を含めます。したがって、宛先で確認される BPDU は、送信元から送られたものです。RSPAN は BPDU モニタをサポートしません。

出力 SPAN 送信元として設定されているポートからの伝送用にスイッチを経由して転送されるすべてのパケットは、SPAN 宛先にコピーされます。このパケットには、STP が出力ポートをブロッキング ステートにするため出力ポート経由でスイッチから送出されないパケットや、STP が VLAN をトランク ポートでブロッキング ステートに移行するので、出力トランク ポートにあるパケットが含まれます。

VSPAN に関する注意事項および制約事項


) ローカル SPAN、RSPAN、および ERSPAN は、すべて VSPAN をサポートします。


ここでは、VSPAN に関する注意事項および制約事項について説明します。

VSPAN セッションは、送信元 VLAN フィルタリングをサポートしません。

入力および出力の両方が設定されている VSPAN セッションについては、2 つのパケットが同じ VLAN でスイッチングされている場合、それらは宛先から(1 つは入力ポートからの入力トラフィックとして、もう 1 つは出力ポートからの出力トラフィックとして)アナライザに転送されます。

VSPAN は、VLAN 中のレイヤ 2 ポートから出入りするトラフィックのみをモニタします。

VLAN を入力送信元として設定し、トラフィックが、モニタされている VLAN へとルーティングされると、そのルーティングされたトラフィックは、VLAN 中のレイヤ 2 ポートで受信する入力トラフィックとしてみなされないためモニタされません。

VLAN を出力送信元として設定し、トラフィックが、モニタされている VLAN からルーティングされると、そのルーティングされたトラフィックは、VLAN 中のレイヤ 2 ポートから送信される出力トラフィックとしてみなされないためモニタされません。

RSPAN に関する注意事項および制約事項

ここでは、RSPAN に関する注意事項および制約事項について説明します。

すべての参加スイッチはレイヤ 2 トランクによって接続される必要があります。

RSPAN VLAN をサポートするネットワーク装置は、RSPAN 中間装置とすることができます。

ネットワークが伝送する RSPAN VLAN の数に制限はありません。

中間ネットワーク装置は、サポートすることができる RSPAN VLAN の数を制限することがあります。

すべての送信元、中間、宛先ネットワーク装置において、RSPAN VLAN を設定しなければなりません。VTP がイネーブルの場合、1 ~ 1024 の番号が付いた VLAN の設定を RSPAN VLAN として伝播できます。1024 より大きい番号の VLAN は、すべての送信元、中間、および宛先ネットワーク装置で、RSPAN VLAN として手動で設定する必要があります。

VTP および VTP プルーニングをイネーブルにすると、RSPAN トラフィックはトランクでプルーニングされて、RSPAN トラフィックがネットワーク全体に不必要にフラッディングするのを防ぎます。

RSPAN VLAN は、RSPAN トラフィックに対してのみ使用できます。

管理トラフィックを伝送するのに使用する VLAN を、RSPAN VLAN として設定しないでください。

アクセス ポートを RSPAN VLAN に割り当てないでください。RSPAN は、RSPAN VLAN 中のアクセス ポートを中断ステートにします。

RSPAN トラフィックを伝送するために選択されたトランク ポートを除き、RSPAN VLAN にはポートを設定しないでください。

MAC(メディア アクセス制御)アドレス学習は、RSPAN VLAN でディセーブルにされます。

RSPAN 送信元スイッチにある RSPAN VLAN で、出力 Access Control List(ACL; アクセス制御リスト)を使用して、RSPAN 宛先へ送信されるトラフィックをフィルタリングできます。

RSPAN は BPDU モニタをサポートしません。

RSPAN VLAN を VSPAN セッション中の送信元として設定しないでください。

参加ネットワーク装置のすべてが RSPAN VLAN の設定をサポートし、参加ネットワーク装置のすべてで各 RSPAN セッションに対して同じ RSPAN VLAN を使用するかぎり、VLAN を RSPAN VLAN として設定できます。

ERSPAN に関する注意事項および制約事項

ここでは、ERSPAN に関する注意事項および制約事項について説明します。

WS-SUP720(PFC3A を使用して製造された Supervisor Engine 720)は、ハードウェア バージョン 3.2 以上である場合、ERSPAN のみをサポートします。ハードウェア バージョンを確認するには、 show module version | include WS-SUP720-BASE コマンドを入力してください。次に例を示します。

Router# show module version | include WS-SUP720-BASE
7 2 WS-SUP720-BASE SAD075301SZ Hw :3.2
 

ERSPAN パケットでは、GRE ヘッダー内の [protocol type] フィールドの値は 0x88BE です。

レイヤ 3 ERSPAN パケットのペイロードは、コピーされたレイヤ 2 イーサネット フレームからすべての ISL または 802.1Q タグを取り除いたものです。

ERSPAN は、コピーされた個々のレイヤ 2 イーサネット フレームに 50 バイトのヘッダーを追加し、4 バイトの Cyclic Redundancy Check(CRC; 巡回冗長検査)トレーラーと置き換えます。

ERSPAN は、最大 9,202 バイトのレイヤ 3 パケットを保持するジャンボ フレームをサポートします。コピーされたレイヤ 2 イーサネット フレームの長さが 9,170(9,152 バイトのレイヤ 3 パケット)を超える場合は、ERSPAN はコピーされたレイヤ 2 イーサネット フレームを切り捨て、9,202 バイトの ERSPAN レイヤ 3 パケットを作成します。

設定された MTU サイズとは関係なく、ERSPAN は最長 9,202 バイトのレイヤ 3 パケットを作成します。ERSPAN トラフィックは、MTU サイズを 9,202 バイト未満に規定しているネットワーク内のインターフェイスによってドロップされる可能性があります。

デフォルトの MTU サイズ(1,500 バイト)の場合、コピーされたレイヤ 2 イーサネット フレームの長さが 1,468 バイト(1,450 バイトのレイヤ 3 パケット)を超えると、MTU サイズを 1,500 バイトに規定しているネットワーク内のインターフェイスによって ERSPAN トラフィックはドロップされます。


mtu インターフェイス コマンドおよび system jumbomtu コマンド( ジャンボ フレームのサポートの設定を参照)は、レイヤ 3 パケットの最大サイズを設定します(デフォルト値は 1,500 バイト、最大値は 9,216 バイト)。


すべての参加スイッチはレイヤ 3 に接続されている必要があり、ネットワーク パスが ERSPAN トラフィックのサイズをサポートしている必要があります。

ERSPAN はパケット分割をサポートしません。[do not fragment]ビットは、ERSPAN パケットの IP ヘッダー内で設定されます。ERSPAN 宛先セッションでは、分割された ERSPAN パケットを再構成できません。

ERSPAN トラフィックは、ネットワークのトラフィック負荷条件の影響を受けます。ERSPAN パケットの IP precedence または DSCP 値を設定することで、QoS において ERSPAN トラフィックを優先できます。

ERSPAN トラフィックでサポートされる唯一の宛先は、PFC3 上の ERSPAN 宛先セッションです。

スイッチ上のすべての ERSPAN 送信元セッションには、同一の起点 IP アドレスを使用する必要があります。これは、 origin ip address コマンドによって設定します(ERSPAN 送信元セッションの設定を参照)。

スイッチ上のすべての ERSPAN 宛先セッションは、同じ宛先インターフェイス上の同一の IP アドレスを使用する必要があります。宛先インターフェイスの IP アドレスは、 ip address コマンドを使用して入力します(ERSPAN 宛先セッションの設定を参照)。

ERSPAN 送信元セッションの宛先 IP アドレス(宛先スイッチのインターフェイス上で設定する必要がある)は、ERSPAN 宛先セッションが宛先ポートまで送信するトラフィックの送信元です。 ip address コマンドを使用して、送信元セッションおよび宛先セッションの両方に同一のアドレスを設定します。

ERSPAN ID は、様々な ERSPAN 送信元セッションから送られ、同一の宛先 IP アドレスに到着した ERSPAN トラフィックを区別します。

分散型出力 SPAN モードの注意事項および制約事項

ここでは、分散型出力 SPAN モードに関する注意事項および制約事項について説明します。

次のスイッチング モジュールでは、 分散型出力 SPAN モード がディセーブルになっています。

WS-X6502-10GE

WS-X6816-GBIC

WS-X6516-GBIC

WS-X6516-GE-TX

WS-X6524-100FX-MM

WS-X6548-RJ-45

WS-X6548-RJ-21

次のいずれかスイッチング モジュールが搭載されている場合、出力 SPAN モードが集中管理されます。

分散型出力 SPAN モードがディセーブルになっているスイッチング モジュールを表示するには、 show monitor session egress replication-mode | include Operational|slot コマンドを入力します。分散型出力 SPAN モードがディセーブルになっているモジュールが搭載されていない場合、コマンドでは出力 SPAN 動作モードだけが表示されます。

一部のスイッチング モジュールには、ERSPAN に対する分散型出力 SPAN モードをサポートしない ASIC があります。

ERSPAN 送信元に対して分散型出力 SPAN モードをサポートしないスイッチング モジュールのスロット番号を表示するには、 show monitor session egress replication-mode | include Distributed.*Distributed.*Centralized コマンドを入力します。

ERSPAN 送信元に対して分散型出力 SPAN モードがサポートされないスロットにあるスイッチング モジュールの ASIC のバージョンを表示するには、 show asic-version slot slot_number コマンドを入力します。

Hyperion ASIC バージョン レベル 5.0 以上および Metropolis ASIC のすべてのバージョンは、ERSPAN 送信元に対する分散型出力 SPAN モードをサポートします。Hyperion ASIC バージョン レベル 5.0 未満のスイッチング モジュールは、ERSPAN 送信元に対する分散型出力 SPAN モードをサポートしません。

ローカル SPAN、RSPAN、および ERSPAN の設定

ここでは、ローカル SPAN、RSPAN、および ERSPAN の設定手順について説明します。

「ローカル SPAN、RSPAN、および ERSPAN のデフォルト設定」

「無条件トランクとしての宛先の設定(任意)」

「宛先トランク VLAN フィルタリングの設定(任意)」

「宛先ポートの許可リストの設定(任意)」

「出力 SPAN モードの設定(任意)」

「ローカル SPAN の設定」

「RSPAN の設定」

「ERSPAN の設定」

「グローバル コンフィギュレーション モードでの送信元 VLAN フィルタリングの設定」

「設定の確認」

「設定例」

ローカル SPAN、RSPAN、および ERSPAN のデフォルト設定

 

機能
デフォルト値

ローカル SPAN

ディセーブル

RSPAN

ディセーブル

ERSPAN

ディセーブル

出力 SPAN セッションのデフォルト操作モード

 

Release 12.2(33)SXH より前のリリース

集中型

Release 12.2(33)SXH

分散型

Release 12.2(33)SXH1

分散型

Release 12.2(33)SXH2

分散型

Release 12.2(33)SXH2a

集中型

無条件トランクとしての宛先の設定(任意)

監視対象トラフィックが宛先から伝送されるときにタグを付けるには、宛先を宛先として設定する前に、トランクとして設定します。

宛先をトランクとして設定するには、次の作業を行います。

 

 
コマンド
目的

ステップ 1

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

Router(config)# interface { type 1 slot/port | port-channel number }

設定するインターフェイスを選択します。

ステップ 3

Router(config-if)# switchport

インターフェイスをレイヤ 2 スイッチング用に設定します(この操作は インターフェイスがレイヤ 2 スイッチング用に設定されていない場合にのみ必要です)。

ステップ 4

Router(config-if)# switchport trunk encapsulation { isl | dot1q }

カプセル化を設定して、インターフェイスを ISL または 802.1Q トランクとして設定します。

ステップ 5

Router(config-if)# switchport mode trunk

無条件にインターフェイスをトランクに設定します。

1.type = fastethernetgigabitethernet、または tengigabitethernet

次に、ポートを無条件 IEEE 802.1Q トランクとして設定する例を示します。

Router(config)# interface fastethernet 5/12
Router(config-if)# switchport
Router(config-if)# switchport trunk encapsulation dot1q
Router(config-if)# switchport mode trunk

) Release 12.2(33)SXH 以前のリリースでは、宛先ポートを無条件とランクとして設定する場合、switchport nonegotiate コマンドを入力する必要があります。Release 12.2(33)SXH 以降のリリースでは、この要件は削除されています。


宛先トランク VLAN フィルタリングの設定(任意)


) • トランクで VLAN をフィルタリングするだけでなく、許可される VLAN リストをアクセス ポートに適用することもできます。

宛先トランク VLAN フィルタリングは、宛先で適用されます。宛先トランク VLAN フィルタリングにより、SPAN 送信元から SPAN 宛先に送信されるトラフィックの量が減ることはありません。


 

宛先がトランクになっている場合、トランクで許可される VLAN のリストを使用して、宛先から送信されるトラフィックをフィルタできます。(CSCeb01318)

宛先トランク VLAN フィルタリングを使用すると、SPAN セッション内で、すべての宛先がすべての送信元からのすべてのトラフィックを受信するという制約がなくなります。宛先トランク VLAN フィルタリングでは、各宛先トランクからネットワーク アナライザに送信されたトラフィックを、VLAN 単位で選択できます。

宛先トランクに宛先トランク VLAN フィルタリングを設定するには、次の作業を行います。

 

 
コマンド
目的

ステップ 1

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

Router(config)# interface type 2 slot/port

設定する宛先トランク ポートを選択します。

ステップ 3

Router(config-if)# switchport trunk allowed vlan { add | except | none | remove } vlan [, vlan [, vlan [,...]]

トランク上で許可される VLAN のリストを設定します。

2.type = fastethernetgigabitethernet、または tengigabitethernet

宛先トランク ポートで許可される VLAN のリストを設定する際は、次の点に注意してください。

vlan パラメータは、1 ~ 4094 の範囲の単一の VLAN 番号、または 2 つの VLAN 番号(小さい番号が先、ダッシュで区切る)で指定する VLAN 範囲です。カンマで区切った vlan パラメータの間、またはダッシュで指定した範囲の間には、スペースを入れないでください。

デフォルトでは、すべての VLAN が許可されます。

すべての VLAN を許可されたリストから削除するには、 switchport trunk allowed vlan none コマンドを入力します。

VLAN を許可されたリストに追加するには、 switchport trunk allowed vlan add コマンドを入力します。

SPAN 設定を削除せずに許可された VLAN リストを変更できます。

次に、複数の VLAN が送信元で複数のトランク ポートが宛先であるローカル SPAN セッションを設定する例を示します。宛先トランク VLAN フィルタリングは SPAN トラフィックをフィルタリングし、各宛先トランク ポートが、1 つの VLAN からトラフィックを伝送します。

interface GigabitEthernet1/1
description SPAN destination interface for VLAN 10
no ip address
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 10
switchport mode trunk
switchport nonegotiate
!
interface GigabitEthernet1/2
description SPAN destination interface for VLAN 11
no ip address
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 11
switchport mode trunk
switchport nonegotiate
!
interface GigabitEthernet1/3
description SPAN destination interface for VLAN 12
no ip address
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 12
switchport mode trunk
switchport nonegotiate
!
interface GigabitEthernet1/4
description SPAN destination interface for VLAN 13
no ip address
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 13
switchport mode trunk
switchport nonegotiate
!
monitor session 1 source vlan 10 - 13
monitor session 1 destination interface Gi1/1 ñ 4

宛先ポートの許可リストの設定(任意)

ポートを誤って宛先として設定してしまうことがないように、宛先として有効なポートの一覧を示す許可リストを作成できます。宛先ポートの許可リストを設定すると、許可リスト内のポートだけが宛先として設定できるようになります。

宛先ポートの許可リストを設定するには、次の作業を行います。

 

 
コマンド
目的

ステップ 1

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

Router(config)# monitor permit-list

宛先ポートの許可リストの使用をイネーブルにします。

Router(config)# no monitor permit-list

宛先ポートの許可リストの使用をディセーブルにします。

ステップ 3

Router(config)# monitor permit-list destination interface type 3 slot/port [ - port ] [ , type 1 slot/port - port ]

宛先ポートの許可リストを設定するか、または既存の宛先ポート許可リストに追加します。

Router(config)# no monitor permit-list destination interface type 1 slot/port [ - port ] [ , type 1 slot/port - port ]

既存の宛先ポート許可リストを削除または消去します。

ステップ 4

Router(config)# do show monitor permit-list

設定を確認します。

3.type = fastethernetgigabitethernet、または tengigabitethernet

次の例では、ポート GigabitEthernet 5/1 ~ 5/4、および 6/1 を含む宛先ポート許可リストを設定します。

Router# configure terminal
Router(config)# monitor permit-list
Router(config)# monitor permit-list destination interface gigabitethernet 5/1-4, gigabitethernet 6/1
 

次に、設定を確認する例を示します。

Router(config)# do show monitor permit-list
SPAN Permit-list :Admin Enabled
Permit-list ports :Gi5/1-4,Gi6/1

出力 SPAN モードの設定(任意)

Release 12.2(33)SXH、Release 12.2(33)SXH1、Release 12.2(33)SXH2 では、ディセーブルにするスイッチング モジュールが設定されていない場合、 分散型出力 SPAN モード がデフォルトとなります。

Release 12.2(33)SXH2a 以降では、 集中型出力 SPNA モード がデフォルトとなります。

分散型出力 SPAN モードをサポートするスイッチング モジュールについては、「分散型出力 SPAN モードの注意事項および制約事項」を参照してください。

Release 12.2(33)SXH2a 以降のリリースで出力 SPAN モードを設定するには、次の手順を実行します。

 

 
コマンド
目的

ステップ 1

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

Router(config)# monitor session egress replication-mode distributed

分散型出力 SPAN モードをイネーブルにします。


) 集中型出力 SPAN モードをイネーブルにするには、no monitor session egress replication-mode distributed コマンドを入力します。


ステップ 3

Router(config)# end

コンフィギュレーション モードを終了します。

次に、分散型出力 SPAN モードをイネーブルにする例を示します。

Router# configure terminal
Router(config)# monitor session egress replication-mode distributed
Router(config)# end
 

Release 12.2(33)SXH、Release 12.2(33)SXH1、および Release 12.2(33)SXH2 で出力 SPAN モードを設定するには、次の手順を実行します。

 

 
コマンド
目的

ステップ 1

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

Router(config)# monitor session egress replication-mode centralized

集中型出力 SPAN モードをイネーブルにします。


) 分散型出力 SPAN モードをイネーブルにするには、no monitor session egress replication-mode centralized コマンドを入力します。


ステップ 3

Router(config)# end

コンフィギュレーション モードを終了します。

次に、分散型出力 SPAN モードをディセーブルにする例を示します。

Router# configure terminal
Router(config)# monitor session egress replication-mode centralized
Router(config)# end
 

次に、設定された出力 SPAN モードを表示する例を示します。

Router# show monitor session egress replication-mode | include Configured
Configured mode : Centralized
 

ローカル SPAN の設定

ここでは、ローカル SPAN セッションの設定手順について説明します。

「ローカル SPAN の設定(SPAN コンフィギュレーション モード)」

「ローカル SPAN の設定(グローバル コンフィギュレーション モード)」

ローカル SPAN の設定(SPAN コンフィギュレーション モード)


) モニタ対象トラフィックが宛先ポートを出る際、タグ付けを行うには、宛先ポートを無条件にトランクに設定してから、そのポートを宛先として設定します(無条件トランクとしての宛先の設定(任意)を参照)。


SPAN コンフィギュレーション モードでローカル SPAN セッションを設定するには、次の作業を行います。

 

 
コマンド
目的

ステップ 1

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

Router(config)# monitor session local_SPAN_session_number type [ local | local-tx ]

ローカル SPAN セッション番号を設定し、ローカル SPAN コンフィギュレーション モードを開始します。


) • 入力または出力、またはその両方の SPAN セッションを設定するには、local キーワードを入力します。

出力のみ の SPAN セッションを設定するには、 local-tx キーワードを入力します。

ステップ 3

Router(config-mon-local)# description session_description

(任意)ローカル SPAN セッションの説明を入力します。

ステップ 4

Router(config-mon-local)# source { cpu { rp | sp }} | single_interface | interface_list | interface_range | mixed_interface_list | single_vlan | vlan_list | vlan_range | mixed_vlan_list } [ rx | tx | both ]

ローカル SPAN セッション番号と CPU、送信元ポート、または VLAN を対応付けて、モニタするトラフィックの方向を選択します。


) • local-tx キーワードを入力するとき、rx および both キーワードは使用できなくなり、tx キーワードが必要になります。

使用可能 SPAN セッションを最大限に利用するには、 ローカル セッションに tx キーワードを付けて使用するよりも、 local-tx セッションを使用してください。

ステップ 5

Router(config-mon-local)# filter single_vlan | vlan_list | vlan_range | mixed_vlan_list

(任意)ローカル SPAN 送信元がトランク ポートである場合、送信元 VLAN フィルタリングを設定します。

ステップ 6

Router(config-mon-local)# destination { single_interface | interface_list | interface_range | mixed_interface_list } [ ingress [ learning ]]

ローカル SPAN セッション番号と宛先を対応付けます。

ステップ 7

Router(config-mon-local)# no shutdown

ローカル SPAN セッションをアクティブにします。


no shutdown コマンドおよび shutdown コマンドは、local-tx 出力専用 SPAN セッションではサポートされていません。


ステップ 8

Router(config-mon-local)# end

コンフィギュレーション モードを終了します。

モニタ セッションを設定する際は、次の点に注意してください。

session_description には、最大 240 文字まで入力できますが、特殊文字は入力できません。Release 12.2(33)SXH 以降のリリースでは、説明にスペースを含めることができます。


description コマンドに続けて、240 文字を入力できます。


local_span_session_number は 1 ~ 80 の範囲で指定できます。

cpu rp は、ルート プロセッサ(RP)です。

cpu sp は、スイッチ プロセッサ(SP)です。

single_interface の内容は次のとおりです。

interface type slot / port で、 type fastethernet gigabitethernet 、または tengigabitethernet です。

interface port-channel number


) 宛先ポート チャネル インターフェイスは、channel-group group_num mode on コマンドおよび no channel-protocol コマンドで設定する必要があります。「EtherChannel の設定」を参照してください。


interface_list single_interface , single_interface , single_interface ...です。


) 各リストでは、カンマの前後にスペースを入れる必要があります。各範囲では、ダッシュの前後にスペースを入れる必要があります。


interface_range は、 interface type slot / first_port - last_port です。

mixed_interface_list は、順不同で single_interface , interface_range , ...です。

single_vlan は、単一の VLAN の ID 番号です。

vlan_list single_vlan , single_vlan , single_vlan ...です。

vlan_range は、 first_vlan_ID - last_vlan_ID です。

mixed_vlan_list は、順不同で single_vlan , vlan_range , ...です。

接続されたデバイスからトラフィックを受信するように宛先を設定するには、 ingress キーワードを入力します。

宛先からの MAC アドレスの学習をイネーブルにするには、 learning キーワードを入力します。この設定により、スイッチは宛先に接続されているデバイスに宛てたトラフィックを送信できるようになります。

ingress キーワードおよび learning キーワードで宛先を設定するとき、次の点に注意してください。

レイヤ 2 スイッチング用に宛先を設定します。「レイヤ 2 スイッチング用の LAN インターフェイスの設定」を参照してください。

宛先がトランクで、接続されたデバイスがタグ付きトラフィックをスイッチに戻す場合、ISL または 802.1q トランキングのいずれかを使用できます。

宛先がトランクで、接続されたデバイスがタグの付いていないトラフィックをスイッチに戻す場合、接続デバイスからのトラフィックを受け入れるように設定されたネイティブ VLAN とともに 802.1q トランキングを使用します。

宛先をレイヤ 3 アドレスで設定しないでください。宛先に接続されたデバイスへのトラフィックおよびそのデバイスからのトラフィックをルーティングするには、VLAN インターフェイスを使用します。

宛先は、ダウン ステートに保持されます。接続されたデバイスへのトラフィックおよび接続されたデバイスからのトラフィックをルーティングするには、VLAN の追加のアクティブなレイヤ 2 ポートを設定し、VLAN インターフェイスをアップ ステートに保持します。

次に、セッション 1 がギガビット イーサネット ポート 1/1 からの入力トラフィックをモニタするように設定し、さらにギガビット イーサネット ポート 1/2 を宛先として設定する例を示します。

Router(config)# monitor session 1 type local
Router(config-mon-local)# source interface gigabitethernet 1/1 rx
Router(config-mon-local)# destination interface gigabitethernet 1/2
 

追加の例については、「設定例」を参照してください。

ローカル SPAN の設定(グローバル コンフィギュレーション モード)


) • モニタ対象トラフィックが宛先ポートを出る際、タグ付けを行うには、宛先ポートを無条件にトランクに設定してから、そのポートを宛先として設定します(無条件トランクとしての宛先の設定(任意)を参照)。

グローバル コンフィギュレーション モードでは、2 つまでのローカル SPAN セッションを設定できます。

SPAN コンフィギュレーション モードは、すべての SPAN 設定作業に使用できます。

サポートされる最大数の SPAN セッションを設定するには、SPAN コンフィギュレーション モードを使用する必要があります。


 

ローカル SPAN は、個別の送信元および宛先のセッションを使用しません。ローカル SPAN セッションを設定するには、同じセッション番号のローカル SPAN 送信元および宛先を設定します。ローカル SPAN セッションを設定するには、次の作業を行います。

 

 
コマンド
目的

ステップ 1

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

Router(config)# monitor session local_span_session_number source { single_interface | interface_list | interface_range | mixed_interface_list | single_vlan | vlan_list | vlan_range | mixed_vlan_list } [ rx | tx | both ]

ローカル SPAN 送信元セッション番号と送信元ポートまたは VLAN を対応付けて、モニタするトラフィックの方向を選択します。

ステップ 3

Router(config)# monitor session local_span_session_number destination { single_interface | interface_list | interface_range | mixed_interface_list } [ ingress [ learning ]]

ローカル SPAN セッション番号と宛先ポートを対応付けます。

ローカル SPAN セッションを設定する際は、次の点に注意してください。

local_span_session_number は 1 ~ 66 の範囲で指定できます。

single_interface の内容は次のとおりです。

interface type slot / port で、 type fastethernet gigabitethernet 、または tengigabitethernet です。

interface port-channel number


) 宛先ポート チャネル インターフェイスは、channel-group group_num mode on コマンドおよび no channel-protocol コマンドで設定する必要があります。「EtherChannel の設定」を参照してください。


interface_list single_interface , single_interface , single_interface ...です。


) 各リストでは、カンマの前後にスペースを入れる必要があります。各範囲では、ダッシュの前後にスペースを入れる必要があります。


interface_range は、 interface type slot / first_port - last_port です。

mixed_interface_list は、順不同で single_interface , interface_range , ...です。

single_vlan は、単一の VLAN の ID 番号です。

vlan_list single_vlan , single_vlan , single_vlan ...です。

vlan_range は、 first_vlan_ID - last_vlan_ID です。

mixed_vlan_list は、順不同で single_vlan , vlan_range , ...です。

接続されたデバイスからトラフィックを受信するように宛先を設定するには、 ingress キーワードを入力します。

宛先からの MAC アドレスの学習をイネーブルにするには、 learning キーワードを入力します。この設定により、スイッチは宛先に接続されているデバイスに宛てたトラフィックを送信できるようになります。

ingress キーワードおよび learning キーワードで宛先を設定するとき、次の点に注意してください。

レイヤ 2 スイッチング用に宛先を設定します。「レイヤ 2 スイッチング用の LAN インターフェイスの設定」を参照してください。

宛先がトランクで、接続されたデバイスがタグ付きトラフィックをスイッチに戻す場合、ISL または 802.1q トランキングのいずれかを使用できます。

宛先がトランクで、接続されたデバイスがタグの付いていないトラフィックをスイッチに戻す場合、接続デバイスからのトラフィックを受け入れるように設定されたネイティブ VLAN とともに 802.1q トランキングを使用します。

宛先をレイヤ 3 アドレスで設定しないでください。宛先に接続されたデバイスへのトラフィックおよびそのデバイスからのトラフィックをルーティングするには、VLAN インターフェイスを使用します。

宛先は、ダウン ステートに保持されます。接続されたデバイスへのトラフィックおよび接続されたデバイスからのトラフィックをルーティングするには、VLAN の追加のアクティブなレイヤ 2 ポートを設定し、VLAN インターフェイスをアップ ステートに保持します。

次に、セッション 1 の双方向送信元として、ポート FastEthernet 5/1 を設定する例を示します。

Router(config)# monitor session 1 source interface fastethernet 5/1
 

次に、SPAN セッション 1 の宛先として、ポート FastEthernet 5/48 を設定する例を示します。

Router(config)# monitor session 1 destination interface fastethernet 5/48
 

追加の例については、「設定例」を参照してください。

RSPAN の設定

RSPAN では、1 つのスイッチで送信元セッションを使用し、別のスイッチで宛先セッションを使用します。ここでは、RSPAN セッションの設定手順について説明します。

「RSPAN VLAN の設定」

「RSPAN セッションの設定(SPAN コンフィギュレーション モード)」

「RSPAN セッションの設定(グローバル コンフィギュレーション モード)」

RSPAN VLAN の設定

VLAN を RSPAN VLAN として設定するには、次の作業を行います。

 

 
コマンド
目的

ステップ 1

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

Router(config)# vlan vlan_ID [{-|,} vlan_ID ]

単独のイーサネット VLAN、イーサネット VLAN の範囲、またはカンマで区切った複数のイーサネット VLAN のリストを作成または変更します(スペースは挿入しないでください)。

ステップ 3

Router(config-vlan)# remote-span

VLAN を RSPAN VLAN として設定します。

ステップ 4

Router(config-vlan)# end

VLAN データベースを更新して、特権 EXEC モードに戻ります。

RSPAN セッションの設定(SPAN コンフィギュレーション モード)

ここでは、SPAN コンフィギュレーション モードでの RSPAN セッションの設定手順について説明します。

「SPAN コンフィギュレーション モードでの RSPAN 送信元セッションの設定」

「SPAN コンフィギュレーション モードでの RSPAN 宛先セッションの設定」

SPAN コンフィギュレーション モードでの RSPAN 送信元セッションの設定

SPAN コンフィギュレーション モードで RSPAN 送信元セッションを設定するには、次の作業を行います。

 

 
コマンド
目的

ステップ 1

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

Router(config)# monitor session RSPAN_source_session_number type rspan-source

RSPAN 送信元セッション番号を設定し、このセッションに対する RSPAN 送信元セッション コンフィギュレーション モードを開始します。

ステップ 3

Router(config-mon-rspan-src)# description session_description

(任意)RSPAN 送信元セッションの説明を入力します。

ステップ 4

Router(config-mon-rspan-src)# source {{ cpu { rp | sp }} | single_interface | interface_list | interface_range | mixed_interface_list | single_vlan | vlan_list | vlan_range | mixed_vlan_list } [ rx | tx | both ]

RSPAN 送信元セッションの番号と CPU、送信元ポート、または VLAN を対応付けて、モニタするトラフィックの方向を選択します。

ステップ 5

Router(config-mon-rspan-src)# filter single_vlan | vlan_list | vlan_range | mixed_vlan_list

(任意)RSPAN 送信元がトランク ポートである場合、送信元 VLAN フィルタリングを設定します。

ステップ 6

Router(config-mon-rspan-src)# destination remote vlan rspan_vlan_ID

RSPAN 送信元セッションの番号と RSPAN VLAN を対応付けます。

ステップ 7

Router(config-mon-rspan-src)# no shutdown

RSPAN 送信元セッションをアクティブにします。

ステップ 8

Router(config-mon-rspan-src)# end

コンフィギュレーション モードを終了します。

RSPAN 送信元セッションを設定するとき、次の点に注意してください。

session_description には、最大 240 文字まで入力できますが、特殊文字は入力できません。Release 12.2(33)SXH 以降のリリースでは、説明にスペースを含めることができます。


description コマンドに続けて、240 文字を入力できます。


RSPAN_source_span_session_number は 1 ~ 80 の範囲で指定できます。

cpu rp は、ルート プロセッサ(RP)です。

cpu sp は、スイッチ プロセッサ(SP)です。

single_interface の内容は次のとおりです。

interface type slot / port で、 type fastethernet gigabitethernet 、または tengigabitethernet です。

interface port-channel number

interface_list single_interface , single_interface , single_interface ...です。


) 各リストでは、カンマの前後にスペースを入れる必要があります。各範囲では、ダッシュの前後にスペースを入れる必要があります。


interface_range は、 interface type slot / first_port - last_port です。

mixed_interface_list は、順不同で single_interface , interface_range , ...です。

single_vlan は、単一の VLAN の ID 番号です。

vlan_list single_vlan , single_vlan , single_vlan ...です。

vlan_range は、 first_vlan_ID - last_vlan_ID です。

mixed_vlan_list は、順不同で single_vlan , vlan_range , ...です。

RSPAN VLAN ID については、「RSPAN VLAN の設定」を参照してください。

次の例は、ポート GigabitEthernet 1/1 からの双方向トラフィックをモニタするようにセッション 1 を設定する方法を示します。

Router(config)# monitor session 1 type rspan-source
Router(config-mon-rspan-src)# source interface gigabitethernet 1/1
Router(config-mon-rspan-src)# destination remote vlan 2
 

追加の例については、「設定例」を参照してください。

SPAN コンフィギュレーション モードでの RSPAN 宛先セッションの設定


) • モニタ対象トラフィックにタグ付けをするには、ポートを無条件にトランクに設定してから、そのポートを宛先として設定する必要があります(無条件トランクとしての宛先の設定(任意)を参照)。

RSPAN 送信元セッション スイッチ上に RSPAN 宛先セッションを設定して、RSPAN トラフィックをローカルにモニタすることができます。


 

RSPAN 宛先セッションを設定するには、次の作業を行います。

 

 
コマンド
目的

ステップ 1

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

Router(config)# monitor session RSPAN_destination_session_number type rspan-destination

RSPAN 宛先セッション番号を設定し、このセッションに対する RSPAN 宛先セッション コンフィギュレーション モードを開始します。

ステップ 3

Router(config-mon-rspan-dst)# description session_description

(任意)RSPAN 宛先セッションの説明を入力します。

ステップ 4

Router(config-mon-rspan-dst)# source remote vlan rspan_vlan_ID

RSPAN 宛先セッション番号と RSPAN VLAN を対応付けます。

ステップ 5

Router(config-mon-rspan-dst)# destination { single_interface | interface_list | interface_range | mixed_interface_list }} [ ingress [ learning ]]

RSPAN 宛先セッション番号と宛先を対応付けます。

ステップ 6

Router(config-mon-rspan-dst)# end

コンフィギュレーション モードを終了します。

RSPAN 宛先セッションを設定するとき、次の点に注意してください。

RSPAN_destination_span_session_number は 1 ~ 80 の範囲で指定できます。

single_interface の内容は次のとおりです。

interface type slot / port で、 type fastethernet gigabitethernet 、または tengigabitethernet です。

interface port-channel number


) 宛先ポート チャネル インターフェイスは、channel-group group_num mode on コマンドおよび no channel-protocol コマンドで設定する必要があります。「EtherChannel の設定」を参照してください。


interface_list single_interface , single_interface , single_interface ...です。


) 各リストでは、カンマの前後にスペースを入れる必要があります。各範囲では、ダッシュの前後にスペースを入れる必要があります。


interface_range は、 interface type slot / first_port - last_port です。

mixed_interface_list は、順不同で single_interface , interface_range , ...です。

接続されたデバイスからトラフィックを受信するように宛先を設定するには、 ingress キーワードを入力します。

宛先からの MAC アドレスの学習をイネーブルにするには、 learning キーワードを入力します。この設定により、スイッチは宛先に接続されているデバイスに宛てたトラフィックを送信できるようになります。

ingress キーワードおよび learning キーワードで宛先を設定するとき、次の点に注意してください。

レイヤ 2 スイッチング用に宛先を設定します。「レイヤ 2 スイッチング用の LAN インターフェイスの設定」を参照してください。

宛先がトランクで、接続されたデバイスがタグ付きトラフィックをスイッチに戻す場合、ISL または 802.1q トランキングのいずれかを使用できます。

宛先がトランクで、接続されたデバイスがタグの付いていないトラフィックをスイッチに戻す場合、接続デバイスからのトラフィックを受け入れるように設定されたネイティブ VLAN とともに 802.1q トランキングを使用します。

宛先をレイヤ 3 アドレスで設定しないでください。宛先に接続されたデバイスへのトラフィックおよびそのデバイスからのトラフィックをルーティングするには、VLAN インターフェイスを使用します。

宛先は、ダウン ステートに保持されます。接続されたデバイスへのトラフィックおよび接続されたデバイスからのトラフィックをルーティングするには、VLAN の追加のアクティブなレイヤ 2 ポートを設定し、VLAN インターフェイスをアップ ステートに保持します。

no shutdown コマンドおよび shutdown コマンドは、RSPAN 宛先セッションではサポートされていません。

次に、セッション 1 の送信元として RSPAN VLAN 2 を、宛先としてギガビット イーサネット ポート 1/2 を、それぞれ設定する例を示します。

Router(config)# monitor session 1 type rspan-destination
Router(config-rspan-dst)# source remote vlan 2
Router(config-rspan-dst)# destination interface gigabitethernet 1/2
 

追加の例については、「設定例」を参照してください。

RSPAN セッションの設定(グローバル コンフィギュレーション モード)

ここでは、グローバル コンフィギュレーション モードでの RSPAN セッションの設定手順について説明します。

「グローバル コンフィギュレーション モードでの RSPAN 送信元セッションの設定」

「グローバル コンフィギュレーション モードでの RSPAN 宛先セッションの設定」

グローバル コンフィギュレーション モードでの RSPAN 送信元セッションの設定

グローバル コンフィギュレーション モードで RSPAN 送信元セッションを設定するには、次の作業を行います。

 

 
コマンド
目的

ステップ 1

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

Router(config)# monitor session RSPAN_source_session_number source { single_interface | interface_list | interface_range | mixed_interface_list | single_vlan | vlan_list | vlan_range | mixed_vlan_list } [ rx | tx | both ]

RSPAN 送信元セッションの番号と送信元ポートまたは VLAN を対応付けて、モニタするトラフィックの方向を選択します。

ステップ 3

Router(config)# monitor session RSPAN_source_session_number destination remote vlan rspan_vlan_ID

RSPAN 送信元セッションの番号と RSPAN VLAN を対応付けます。

RSPAN 送信元セッションを設定するとき、次の点に注意してください。

RSPAN VLAN を設定するには、「RSPAN VLAN の設定」を参照してください。

RSPAN_source_span_session_number は 1 ~ 66 の範囲で指定できます。

single_interface の内容は次のとおりです。

interface type slot / port で、 type fastethernet gigabitethernet 、または tengigabitethernet です。

interface port-channel number

interface_list single_interface , single_interface , single_interface ...です。


) 各リストでは、カンマの前後にスペースを入れる必要があります。各範囲では、ダッシュの前後にスペースを入れる必要があります。


interface_range は、 interface type slot / first_port - last_port です。

mixed_interface_list は、順不同で single_interface , interface_range , ...です。

single_vlan は、単一の VLAN の ID 番号です。

vlan_list single_vlan , single_vlan , single_vlan ...です。

vlan_range は、 first_vlan_ID - last_vlan_ID です。

mixed_vlan_list は、順不同で single_vlan , vlan_range , ...です。

RSPAN VLAN ID については、「RSPAN VLAN の設定」を参照してください。

次に、セッション 2 の送信元として、ポート FastEthernet 5/2 を設定する例を示します。

Router(config)# monitor session 2 source interface fastethernet 5/2
 

次に、RSPAN VLAN 200 をセッション 2 の宛先として設定する例を示します。

Router(config)# monitor session 2 destination remote vlan 200
 

追加の例については、「設定例」を参照してください。

グローバル コンフィギュレーション モードでの RSPAN 宛先セッションの設定


) • モニタ対象トラフィックにタグ付けをするには、ポートを無条件にトランクに設定してから、そのポートを宛先として設定する必要があります(無条件トランクとしての宛先の設定(任意)を参照)。

RSPAN 送信元セッション スイッチ上に RSPAN 宛先セッションを設定して、RSPAN トラフィックをローカルにモニタすることができます。


 

グローバル コンフィギュレーション モードで RSPAN 宛先セッションを設定するには、次の作業を行います。

 

 
コマンド
目的

ステップ 1

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

Router(config)# monitor session RSPAN_destination_session_number source remote vlan rspan_vlan_ID

RSPAN 宛先セッション番号と RSPAN VLAN を対応付けます。

ステップ 3

Router(config)# monitor session RSPAN_destination_session_number destination { single_interface | interface_list | interface_range | mixed_interface_list } [ ingress [ learning ]]

RSPAN 宛先セッション番号と宛先を対応付けます。

モニタ セッションを設定する際は、次の点に注意してください。

RSPAN_destination_span_session_number は 1 ~ 66 の範囲で指定できます。

RSPAN VLAN ID については、「RSPAN VLAN の設定」を参照してください。

single_interface の内容は次のとおりです。

interface type slot / port で、 type fastethernet gigabitethernet 、または tengigabitethernet です。

interface port-channel number


) 宛先ポート チャネル インターフェイスは、channel-group group_num mode on コマンドおよび no channel-protocol コマンドで設定する必要があります。「EtherChannel の設定」を参照してください。


interface_list single_interface , single_interface , single_interface ...です。


) 各リストでは、カンマの前後にスペースを入れる必要があります。各範囲では、ダッシュの前後にスペースを入れる必要があります。


interface_range は、 interface type slot / first_port - last_port です。

mixed_interface_list は、順不同で single_interface , interface_range , ...です。

接続されたデバイスからトラフィックを受信するように宛先を設定するには、 ingress キーワードを入力します。

宛先からの MAC アドレスの学習をイネーブルにするには、 learning キーワードを入力します。この設定により、スイッチは宛先に接続されているデバイスに宛てたトラフィックを送信できるようになります。

ingress キーワードおよび learning キーワードで宛先を設定するとき、次の点に注意してください。

レイヤ 2 スイッチング用に宛先を設定します。「レイヤ 2 スイッチング用の LAN インターフェイスの設定」を参照してください。

宛先がトランクで、接続されたデバイスがタグ付きトラフィックをスイッチに戻す場合、ISL または 802.1q トランキングのいずれかを使用できます。

宛先がトランクで、接続されたデバイスがタグの付いていないトラフィックをスイッチに戻す場合、接続デバイスからのトラフィックを受け入れるように設定されたネイティブ VLAN とともに 802.1q トランキングを使用します。

宛先をレイヤ 3 アドレスで設定しないでください。宛先に接続されたデバイスへのトラフィックおよびそのデバイスからのトラフィックをルーティングするには、VLAN インターフェイスを使用します。

宛先は、ダウン ステートに保持されます。接続されたデバイスへのトラフィックおよび接続されたデバイスからのトラフィックをルーティングするには、VLAN の追加のアクティブなレイヤ 2 ポートを設定し、VLAN インターフェイスをアップ ステートに保持します。

次に、RSPAN VLAN 200 をセッション 3 の送信元として設定する例を示します。

Router(config)# monitor session 3 source remote vlan 200
 

次に、セッション 3 の宛先として、ポート FastEthernet 5/47 を設定する例を示します。

Router(config)# monitor session 3 destination interface fastethernet 5/47
 

追加の例については、「設定例」を参照してください。

ERSPAN の設定

ERSPAN では、個別の送信元セッションおよび宛先セッションを使用します。送信元セッションと宛先セッションは、異なるスイッチ上に設定します。ここでは、ERSPAN セッションの設定手順について説明します。

「ERSPAN 送信元セッションの設定」

「ERSPAN 宛先セッションの設定」

ERSPAN 送信元セッションの設定

ERSPAN 送信元セッションを設定するには、次の作業を行います。

 

 
コマンド
目的

ステップ 1

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

Router(config)# monitor session ERSPAN_source_session_number type erspan-source

ERSPAN 送信元セッション番号を設定し、このセッションに対する ERSPAN 送信元セッション コンフィギュレーション モードを開始します。

ステップ 3

Router(config-mon-erspan-src)# description session_description

(任意)ERSPAN 送信元セッションの説明を入力します。

ステップ 4

Router(config-mon-erspan-src)# source {{{ cpu { rp | sp }} | single_interface | interface_list | interface_range | mixed_interface_list | single_vlan | vlan_list | vlan_range | mixed_vlan_list } [ rx | tx | both ]}

ERSPAN 送信元セッションの番号と CPU、送信元ポート、または VLAN を対応付けて、モニタするトラフィックの方向を選択します。

ステップ 5

Router(config-mon-erspan-src)# filter single_vlan | vlan_list | vlan_range | mixed_vlan_list

(任意)ERSPAN 送信元がトランク ポートである場合、送信元 VLAN フィルタリングを設定します。

ステップ 6

Router(config-mon-erspan-src)# destination

ERSPAN 送信元セッションの宛先コンフィギュレーション モードを開始します。

ステップ 7

Router(config-mon-erspan-src-dst)# ip address ip_address

ERSPAN フローの宛先 IP アドレスを設定します。これは、宛先スイッチのインターフェイス上でも設定する必要があるほか、ERSPAN 宛先セッションの設定でも入力する必要があります(ERSPAN 宛先セッションの設定ステップ 6 を参照)。

ステップ 8

Router(config-mon-erspan-src-dst)# erspan-id ERSPAN_flow_id

ERSPAN トラフィックを識別するため、送信元および宛先セッションで使用される ID 番号を設定します。これは、ERSPAN 宛先セッションの設定でも入力する必要があります(ERSPAN 宛先セッションの設定ステップ 7 を参照)。

ステップ 9

Router(config-mon-erspan-src-dst)# origin ip address ip_address [ force ]

ERSPAN トラフィックの送信元として使用される IP アドレスを設定します。

ステップ 10

Router(config-mon-erspan-src-dst)# ip ttl ttl_value

(任意)ERSPAN トラフィック内のパケットの IP Time to Live(TTL)値を設定します。

ステップ 11

Router(config-mon-erspan-src-dst)# ip prec ipp_value

(任意)ERSPAN トラフィック内のパケットの IP precedence 値を設定します。

ステップ 12

Router(config-mon-erspan-src-dst)# ip dscp dscp_value

(任意)ERSPAN トラフィック内のパケットの IP DSCP 値を設定します。

ステップ 13

Router(config-mon-erspan-src-dst)# vrf vrf_name

(任意)グローバル ルーティング テーブルの代わりに使用する VRF 名を設定します。

ステップ 14

Router(config-mon-erspan-src)# no shutdown

ERSPAN 送信元セッションをアクティブにします。

ステップ 15

Router(config-mon-erspan-src-dst)# end

コンフィギュレーション モードを終了します。

モニタ セッションを設定する際は、次の点に注意してください。

session_description には、最大 240 文字まで入力できますが、特殊文字は入力できません。Release 12.2(33)SXH 以降のリリースでは、説明にスペースを含めることができます。


description コマンドに続けて、240 文字を入力できます。


ERSPAN_source_span_session_number は 1 ~ 66 の範囲で指定できます。

cpu rp は、ルート プロセッサ(RP)です。

cpu sp は、スイッチ プロセッサ(SP)です。

single_interface の内容は次のとおりです。

interface type slot / port で、 type fastethernet gigabitethernet 、または tengigabitethernet です。

interface port-channel number


) ポート チャネル インターフェイスは、channel-group group_num mode on コマンドおよび no channel-protocol コマンドで設定する必要があります。「EtherChannel の設定」を参照してください。


interface_list single_interface , single_interface , single_interface ...です。


) 各リストでは、カンマの前後にスペースを入れる必要があります。各範囲では、ダッシュの前後にスペースを入れる必要があります。


interface_range は、 interface type slot / first_port - last_port です。

mixed_interface_list は、順不同で single_interface , interface_range , ...です。

single_vlan は、単一の VLAN の ID 番号です。

vlan_list single_vlan , single_vlan , single_vlan ...です。

vlan_range は、 first_vlan_ID - last_vlan_ID です。

mixed_vlan_list は、順不同で single_vlan , vlan_range , ...です。

ERSPAN_flow_id は 1 ~ 1023 の範囲で指定できます。

1 つのスイッチのすべての ERSPAN 送信元セッションは、同一の送信元 IP アドレスを使用する必要があります。スイッチ上ですべての ERSPAN 送信元セッションに設定された起点 IP アドレスを変更するには、 origin ip address ip_address force コマンドを入力します。

ttl_value は 1 ~ 255 の範囲で指定できます。

ipp_value は 0 ~ 7 の範囲で指定できます。

dscp_value は 0 ~ 63 の範囲で指定できます。

次の例は、ポート GigabitEthernet 4/1 からの双方向トラフィックをモニタするようにセッション 3 を設定する方法を示します。

Router(config)# monitor session 3 type erspan-source
Router(config-mon-erspan-src)# source interface gigabitethernet 4/1
Router(config-mon-erspan-src)# destination
Router(config-mon-erspan-src-dst)# ip address 10.1.1.1
Router(config-mon-erspan-src-dst)# origin ip address 20.1.1.1
Router(config-mon-erspan-src-dst)# erspan-id 101
 

追加の例については、「設定例」を参照してください。

ERSPAN 宛先セッションの設定


) ERSPAN トラフィックをローカルにモニタすることはできません。


ERSPAN 宛先セッションを設定するには、次の作業を行います。

 

 
コマンド
目的

ステップ 1

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

Router(config)# monitor session ERSPAN_destination_session_number type erspan-destination

ERSPAN 宛先セッション番号を設定し、このセッションに対する ERSPAN 宛先セッション コンフィギュレーション モードを開始します。

ステップ 3

Router(config-mon-erspan-dst)# description session_description

(任意)ERSPAN 宛先セッションの説明を入力します。

ステップ 4

Router(config-mon-erspan-dst)# destination { single_interface | interface_list | interface_range | mixed_interface_list }} [ ingress [ learning ]]

ERSPAN 宛先セッション番号と宛先を対応付けます。

ステップ 5

Router(config-mon-erspan-dst)# source

ERSPAN 宛先セッションの送信元コンフィギュレーション モードを開始します。

ステップ 6

Router(config-mon-erspan-dst-src)# ip address ip_address [ force ]

ERSPAN フローの宛先 IP アドレスを設定します。これは、ローカル インターフェイス上のアドレスであり、「ERSPAN 送信元セッションの設定」ステップ 7 で入力したアドレスと一致する必要があります。

ステップ 7

Router(config-mon-erspan-dst-src)# erspan-id ERSPAN_flow_id

ERSPAN トラフィックを識別するため、宛先および宛先セッションで使用される ID 番号を設定します。これは、「ERSPAN 送信元セッションの設定」ステップ 8 で入力した ID と一致する必要があります。

ステップ 8

Router(config-mon-erspan-dst-src)# vrf vrf_name

(任意)グローバル ルーティング テーブルの代わりに使用する VRF 名を設定します。

ステップ 9

Router(config-mon-erspan-dst)# no shutdown

ERSPAN 宛先セッションをアクティブにします。

ステップ 10

Router(config-mon-erspan-dst-src)# end

コンフィギュレーション モードを終了します。

モニタ セッションを設定する際は、次の点に注意してください。

ERSPAN_destination_span_session_number は 1 ~ 66 の範囲で指定できます。

single_interface の内容は次のとおりです。

interface type slot / port で、 type fastethernet gigabitethernet 、または tengigabitethernet です。

interface port-channel number


) 宛先ポート チャネル インターフェイスは、channel-group group_num mode on コマンドおよび no channel-protocol コマンドで設定する必要があります。「EtherChannel の設定」を参照してください。


interface_list single_interface , single_interface , single_interface ...です。


) 各リストでは、カンマの前後にスペースを入れる必要があります。各範囲では、ダッシュの前後にスペースを入れる必要があります。


interface_range は、 interface type slot / first_port - last_port です。

mixed_interface_list は、順不同で single_interface , interface_range , ...です。

スイッチ上のすべての ERSPAN 宛先セッションは、同じ宛先インターフェイス上の同一の IP アドレスを使用する必要があります。スイッチ上ですべての ERSPAN 送信元セッションに設定された IP アドレスを変更するには、 ip address ip_address force コマンドを入力します。


) また、すべての ERSPAN 送信元セッションの宛先 IP アドレスを変更する必要があります(ERSPAN 送信元セッションの設定ステップ 7 を参照)。


ERSPAN_flow_id は 1 ~ 1023 の範囲で指定できます。

接続されたデバイスからトラフィックを受信するように宛先を設定するには、 ingress キーワードを入力します。

宛先からの MAC アドレスの学習をイネーブルにするには、 learning キーワードを入力します。この設定により、スイッチは宛先に接続されているデバイスに宛てたトラフィックを送信できるようになります。

ingress キーワードおよび learning キーワードで宛先を設定するとき、次の点に注意してください。

レイヤ 2 スイッチング用に宛先を設定します。「レイヤ 2 スイッチング用の LAN インターフェイスの設定」を参照してください。

宛先がトランクで、接続されたデバイスがタグ付きトラフィックをスイッチに戻す場合、ISL または 802.1q トランキングのいずれかを使用できます。

宛先がトランクで、接続されたデバイスがタグの付いていないトラフィックをスイッチに戻す場合、接続デバイスからのトラフィックを受け入れるように設定されたネイティブ VLAN とともに 802.1q トランキングを使用します。

宛先をレイヤ 3 アドレスで設定しないでください。宛先に接続されたデバイスへのトラフィックおよびそのデバイスからのトラフィックをルーティングするには、VLAN インターフェイスを使用します。

宛先は、ダウン ステートに保持されます。接続されたデバイスへのトラフィックおよび接続されたデバイスからのトラフィックをルーティングするには、VLAN の追加のアクティブなレイヤ 2 ポートを設定し、VLAN インターフェイスをアップ ステートに保持します。

次の例は、IP アドレス 10.1.1.1 に着信した ERSPAN ID 101 トラフィックを、ポート GigabitEthernet 2/1 に送信するように ERSPAN 宛先セッションを設定する方法を示します。

Router(config)# monitor session 3 type erspan-destination
Router(config-erspan-dst)# destination interface gigabitethernet 2/1
Router(config-erspan-dst)# source
Router(config-erspan-dst-src)# ip address 10.1.1.1
Router(config-erspan-dst-src)# erspan-id 101
 

追加の例については、「設定例」を参照してください。

グローバル コンフィギュレーション モードでの送信元 VLAN フィルタリングの設定


) • SPAN コンフィギュレーション モードで送信元 VLAN フィルタリングを設定するには、次を参照してください。

「ローカル SPAN の設定(SPAN コンフィギュレーション モード)」

「SPAN コンフィギュレーション モードでの RSPAN 送信元セッションの設定」

「ERSPAN の設定」

送信元 VLAN フィルタリングにより、SPAN 送信元から SPAN 宛先に送信されるトラフィックの量が減ります。


 

送信元 VLAN フィルタリングは、送信元がトランク ポートの場合に特定の VLAN をモニタします。

ローカル SPAN または RSPAN 送信元がトランク ポートである場合、送信元 VLAN フィルタリングを設定するには、次の作業を行います。

 

 
コマンド
目的

ステップ 1

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

Router(config)# monitor session session_number filter single_vlan | vlan_list | vlan_range | mixed_vlan_list

ローカル SPAN または RSPAN 送信元がトランク ポートである場合、送信元 VLAN フィルタリングを設定します。

送信元 VLAN フィルタリングを設定する場合は、次の点に注意してください。

single_vlan は、単一の VLAN の ID 番号です。

vlan_list single_vlan , single_vlan , single_vlan ...です。

vlan_range は、 first_vlan_ID - last_vlan_ID です。

mixed_vlan_list は、順不同で single_vlan , vlan_range , ...です。

次に、送信元がトランク ポートである場合に、VLAN 1 ~ 5 および VLAN 9 をモニタする例を示します。

Router(config)# monitor session 2 filter vlan 1 - 5 , 9

設定の確認

設定を確認するには、 show monitor session コマンドを入力します。

次に、セッション 2 の設定を確認する例を示します。

Router# show monitor session 2
Session 2
------------
Type : Remote Source Session
 
Source Ports:
RX Only: Fa3/1
Dest RSPAN VLAN: 901
Router#
 

次に、セッション 2 の詳細を完全に表示する例を示します。

Router# show monitor session 2 detail
Session 2
------------
Type : Remote Source Session
 
Source Ports:
RX Only: Fa1/1-3
TX Only: None
Both: None
Source VLANs:
RX Only: None
TX Only: None
Both: None
Source RSPAN VLAN: None
Destination Ports: None
Filter VLANs: None
Dest RSPAN VLAN: 901

設定例

次に、RSPAN 送信元セッション 2 を設定する例を示します。

Router(config)# monitor session 2 source interface fastethernet1/1 - 3 rx
Router(config)# monitor session 2 destination remote vlan 901
 

次に、セッション 1 とセッション 2 の設定を消去する例を示します。

Router(config)# no monitor session range 1-2
 

次に、複数の送信元で RSPAN 送信元セッションを設定する例を示します。

Router(config)# monitor session 2 source interface fastethernet 5/15 , 7/3 rx
Router(config)# monitor session 2 source interface gigabitethernet 1/2 tx
Router(config)# monitor session 2 source interface port-channel 102
Router(config)# monitor session 2 source filter vlan 2 - 3
Router(config)# monitor session 2 destination remote vlan 901
 

次に、セッションの送信元を削除する例を示します。

Router(config)# no monitor session 2 source interface fastethernet 5/15 , 7/3
 

次に、セッションの送信元に対するオプションを削除する例を示します。

Router(config)# no monitor session 2 source interface gigabitethernet 1/2
Router(config)# no monitor session 2 source interface port-channel 102 tx
 

次に、セッションの送信元 VLAN フィルタリングを削除する例を示します。

Router(config)# no monitor session 2 filter vlan 3
 

次に、RSPAN 宛先セッション 8 の設定例を示します。

Router(config)# monitor session 8 source remote vlan 901
Router(config)# monitor session 8 destination interface fastethernet 1/2 , 2/3
 

次に、ERSPAN 送信元セッション 12 の設定例を示します。

monitor session 12 type erspan-source
description SOURCE_SESSION_FOR_VRF_GRAY
source interface Gi8/48 rx
destination
erspan-id 120
ip address 10.8.1.2
origin ip address 32.1.1.1
vrf gray
 

次に、ERSPAN 宛先セッション 12 の設定例を示します。

monitor session 12 type erspan-destination
description DEST_SESSION_FOR_VRF_GRAY
destination interface Gi4/48
source
erspan-id 120
ip address 10.8.1.2
vrf gray
 

次に、ERSPAN 送信元セッション 13 の設定例を示します。

monitor session 13 type erspan-source
source interface Gi6/1 tx
destination
erspan-id 130
ip address 10.11.1.1
origin ip address 32.1.1.1
 

次に、ERSPAN 宛先セッション 13 の設定例を示します。

monitor session 13 type erspan-destination
destination interface Gi6/1
source
erspan-id 130
ip address 10.11.1.1