Catalyst 6500 Release 12.2SXH and Later Software コンフィギュレーション ガイド
MPLS QoS の設定
MPLS QoS の設定
発行日;2012/02/06 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 12MB) | フィードバック

目次

MPLS QoS の設定

用語

MPLS QoS の機能

MPLS EXP フィールド

信頼性

分類

ポリシングおよびマーキング

IP ToS の保持

EXP 変換

MPLS DiffServ トンネリング モード

MPLS QoS の概要

IP precedence フィールドでの QoS の指定

MPLS QoS

MPLS ネットワークの入力エッジでの LER

MPLS ネットワーク コアの LSR

MPLS ネットワークの出力エッジでの LER

MPLS QoSの概要

EoMPLS エッジの LER

Ethernet/MPLS

MPLS/Ethernet

IP エッジでの LER(MPLS、MPLS VPN)

IP/MPLS

MPLS/IP

MPLS VPN

MPLS コアでの LSR

MPLS/MPLS

MPLS QoS のデフォルト設定

MPLS QoS コマンド

MPLS QoS の注意事項および制約事項

MPLS QoS の設定

QoS をグローバルにイネーブルにする方法

queueing-only モードのイネーブル化

制約事項および使用上の注意事項

MPLS パケット分類のためのクラス マップの設定

制約事項および使用上の注意事項

入力ポートでの MPLS パケットの信頼状態の設定

制約事項および使用上の注意事項

ポリシー マップの設定

インポーズした全ラベルで EXP 値を設定するためのポリシー マップの設定

police コマンドを使用したポリシー マップの設定

ポリシー マップの表示

MPLS QoS ポリシー マップのクラス サマリーの表示

すべてのクラスの設定の表示

MPLS QoS の出力 EXP 変換の設定

名前付き EXP 変換マップの設定

インターフェイスへの出力 EXP 変換マップの付加

EXP 値マッピングの設定

入力 EXP/内部 DSCP マップの設定

名前付き出力 DSCP/出力 EXP マップの設定

MPLS DiffServ トンネリング モード

Short Pipe モード

Short Pipe モードの制約事項および注意事項

Uniform モード

Uniform モードの制約事項および注意事項

MPLS DiffServ トンネリングの制限事項および使用上の注意事項

Short Pipe モードの設定

入力 PE ルータ—カスタマー方向インターフェイス

入力 PE ルータの設定— P 方向インターフェイス

設定例

P ルータの設定—出力インターフェイス

設定例

出力 PE ルータの設定—カスタマー方向インターフェイス

設定例

Uniform モードの設定

入力 PE ルータの設定—カスタマー方向インターフェイス

設定例

入力 PE ルータの設定— P 方向インターフェイス

出力 PE ルータの設定—カスタマー方向インターフェイス

MPLS QoS の設定

この章では、Cisco IOS Software Release 12.2SX で Multiprotocol Label Switching(MPLS; マルチプロトコル ラベル スイッチング)QoS(Quality of Service)を設定する方法について説明します。


) • この章で使用しているコマンドの構文および使用方法の詳細については、次の URL の『Cisco IOS Software Releases 12.2SX Command References』を参照してください。

http://www.cisco.com/en/US/docs/ios/mcl/122sxmcl/12_2sx_mcl_book.html

MPLS QoS は、「PFC QoS の設定」で説明する PFC QoS 機能を MPLS トラフィックに拡張します。

ここでは、MPLS QoS の各機能についての補足情報を説明します。この章では、PFC QoS 機能を理解していることが前提となります。

MPLS QoS で使用可能なポリシングおよびマーキングは、Modular QoS Command-Line Interface(MQC; モジュラ QoS コマンドライン インターフェイス)から管理します。MQC は、トラフィック クラスを定義し、トラフィック ポリシー(ポリシー マップ)を作成および設定し、トラフィック ポリシーをインターフェイスに付加できるコマンドライン インターフェイスです。MQC の詳細については、次の URL で『 Cisco IOS Quality of Service Solutions Configuration Guide 』Release 12.2 を参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122cgcr/fqos_c/qcfbook.pdf


 

この章で説明する内容は、次のとおりです。

「用語」

「MPLS QoS の機能」

「MPLS QoS の概要」

「MPLS QoS」

「MPLS QoSの概要」

「MPLS QoS のデフォルト設定」

「MPLS QoS コマンド」

「MPLS QoS の注意事項および制約事項」

「MPLS QoS の設定」

「MPLS DiffServ トンネリング モード」

「Short Pipe モードの設定」

「Uniform モードの設定」

用語

ここでは、MPLS QoS 用語の一部を定義します。

Class of Service (CoS; サービス クラス)は、Inter-Switch Link(ISL; スイッチ間リンク)ヘッダーまたは 802.1Q ヘッダー内の 3 ビットを指します。CoS は、交換回線ネットワークを通過するイーサネット フレームのプライオリティを示すために使用されます。802.1Q ヘッダーの CoS ビットは、一般的に 802.1p ビットと呼びます。レイヤ 2 およびレイヤ 3 ドメインの両方を通過するパケットの QoS を維持するには、Type of Service(ToS; タイプ オブ サービス)値と CoS 値を相互にマッピングします。

分類 は、QoS のマーキングを行うトラフィックを選択する処理です。

Differentiated Services Code Point (DSCP; DiffServ コード ポイント)は、IP ヘッダーの ToS バイトの最初の 6 ビットです。DSCP は IP パケット内にのみ存在します。

E-LSP は、ノードが MPLS ヘッダーの experimental(EXP)ビットのみに基づき、MPLS パケットに対する QoS 処理を予測する Label Switched Path(LSP; ラベル スイッチド パス)です。QoS 処理は EXP(クラス優先度およびドロップ優先度の両方)から予測されるので、複数のトラフィック クラスを 1 つの LSP に多重化できます(同じラベルを使用)。EXP フィールドは 3 ビット フィールドなので、単一 LSP では最大 8 つのトラフィック クラスをサポートできます。最大クラス数は、コントロール プレーン トラフィックのいくつかの値を予約したあと、または一部のクラス値に対応付けられたドロップ優先度がある場合は、これより少なくなります。

EXP ビット は、ノードがパケットに行う必要がある QoS 処理(Per-Hop Behavior [PHB])を定義します。これは、IP ネットワークの Differentiated Service(DiffServ; ディファレンシエーテッド サービス)Code Point(DSCP; DiffServ コード ポイント)に相当します。DSCP はクラスおよびドロップ優先度を定義します。EXP ビットは通常、IP DSCP で符号化されたすべての情報の伝送に使用されます。ただし、ドロップ優先度を符号化するためだけに EXP ビットを使用する場合もあります。

フレーム は、レイヤ 2 のトラフィックを伝送します。レイヤ 2 フレームはレイヤ 3 パケットを伝送します。

IP precedence は、IP ヘッダーの ToS バイト内の最上位 3 ビットです。

QoS タグ は、レイヤ 3 パケットおよびレイヤ 2 フレームで伝送されるプライオリティ値です。レイヤ 2 CoS ラベルの値の範囲は 0 ~ 7 であり、数値が高いほどプライオリティは高くなります。レイヤ 3 IP precedence ラベルの値の範囲も 0 ~ 7 であり、数値が高いほどプライオリティは高くなります。IP precedence 値は、1 バイトの ToS バイト内の最上位 3 ビットによって定義されます。レイヤ 3 の DSCP ラベルの値は 0 ~ 63 です。DSCP 値は、1 バイトの IP ToS フィールド内の最上位 6 ビットによって定義されます。

Label Edge Router (LER; ラベル エッジ ルータ)は、パケットにラベルをインポーズまたはディスポーズする装置です。Provider Edge(PE; プロバイダー エッジ)ルータともいいます。

Label Switching Router (LSR; ラベル スイッチング ルータ)は、パケットのラベルに基づきトラフィックを転送する装置です。Provider(P)ルータともいいます。

マーキング は、パケットのレイヤ 3 DSCP 値を設定する処理です。また、輻輳の発生中に必要なプライオリティを各パケットに設定するため、各パケットに対して MPLS EXP フィールドの様々な値を選択する処理でもあります。

パケット は、レイヤ 3 でトラフィックを伝送します。

ポリシング -- トラフィック フローが使用する帯域幅を制限する処理です。ポリシングによって、トラフィックのマーキングまたはドロップが可能になります。

MPLS QoS の機能

ネットワークに QoS を導入することで、選択したネットワーク トラフィックに提供するサービスを向上させることができます。ここでは、次の MPLS QoS 機能について説明します。これらは MPLS ネットワークでサポートされます。

「MPLS EXP フィールド」

「信頼性」

「分類」

「ポリシングおよびマーキング」

「IP ToS の保持」

「EXP 変換」

「MPLS DiffServ トンネリング モード」

MPLS EXP フィールド

MPLS EXP フィールド値の設定により、自身のネットワーク上で送信される IP パケット内の IP precedence フィールド値を変更させたくないという、サービス プロバイダーの要件を満たすことができます。

MPLS EXP フィールドに対して異なる値を選択することで、輻輳期間に必要とするプライオリティを各パケットに設定できるように、パケットをマーキングできます。

デフォルトでは、インポジション中に、IP precedence 値が MPLS EXP フィールドにコピーされます。MPLS EXP ビットは、MPLS QoS ポリシーによってマーキングできます。

信頼性

受信したレイヤ 3 MPLS パケットに対し、PFC は通常、受信した最上位ラベルの EXP 値を信頼します。MPLS パケットは、次のいずれの影響も受けません。

インターフェイスの信頼状態

ポートの CoS 値

policy-map trust コマンド

PFC は受信したレイヤ 2 MPLS パケットに対し、受信した最上位ラベルの EXP 値を信頼するか、または CoS および出力キューイングの目的で、MPLS パケットにポートの信頼状態またはポリシーの信頼状態を適用します。

分類

分類とは、マーキングするトラフィックを選択する処理です。分類では、トラフィックは複数のプライオリティ レベルまたは CoS に分割されます。トラフィック分類は、クラスベースの QoS プロビジョニングの主要コンポーネントです。PFC は、受信した MPLS パケット(ポリシーのインストール後)の最上位ラベルの EXP ビットに基づき、分類を行います。詳細については、「MPLS パケット分類のためのクラス マップの設定」を参照してください。

ポリシングおよびマーキング

ポリシングでは、設定されたレートを超えたトラフィックは廃棄されるか、またはより高いドロップ優先度にマークダウンされます。マーキングは、差別化すべきパケット フローを識別する手段です。パケット マーキングにより、使用するネットワークを複数のプライオリティ レベル、またはサービス クラスに分割できます。

実装可能な MPLS QoS ポリシングおよびマーキング機能は、受信したトラフィック タイプ、およびトラフィックに適用される転送処理によって決まります。詳細については、「ポリシー マップの設定」 を参照してください。

IP ToS の保持

PFC では、インポジション、スワップ、ディスポジションを含むすべての MPLS 操作中に、IP ToS が自動的に保持されます。IP ToS を保存するためのコマンドを入力する必要はありません。

EXP 変換

最大 8 個の 出力 EXP 変換マップを設定して、内部 EXP 値が出力 EXP 値として書き込まれる前に、内部 EXP 値を変換できます。出力 EXP 変換マップは、次のインターフェイス タイプに付加できます。

LAN ポート サブインターフェイス

レイヤ 3 VLAN インターフェイス

レイヤ 3 LAN ポート

EXP 変換 マップは、次のインターフェイス タイプには付加できません。

レイヤ 2 LAN ポート( switchport コマンドにより設定されるポート)

FlexWAN ポートまたはサブインターフェイス

設定の詳細については、「MPLS QoS の出力 EXP 変換の設定」を参照してください。

MPLS DiffServ トンネリング モード

PFC は、MPLS DiffServ トンネリング モードを使用します。トンネリングにより、ネットワークの端から端まで、QoS の透過性を提供できます。詳細については、「MPLS DiffServ トンネリング モード」を参照してください。

MPLS QoS の概要

ネットワーク管理者は MPLS QoS を使用することで、差別化したサービス タイプを MPLS ネットワーク上で提供できます。DiffServ では、送信するパケットごとに、QoS によって各パケットに指定されたサービスを提供することで、幅広い要件を満たします。サービスは様々な方法で指定できます。たとえば、IP パケットでは IP precedence ビットの設定を使用します。

IP precedence フィールドでの QoS の指定

あるサイトから別のサイトへ IP パケットを送信する際、IP precedence フィールド(IP パケット ヘッダーに含まれる DSCP フィールドの先頭 3 ビット)は QoS を指定します。IP precedence マーキングに基づき、この QoS に対して設定された処理がパケットに適用されます。サービス プロバイダー ネットワークが MPLS ネットワークである場合、IP precedence ビットはネットワーク エッジで MPLS EXP フィールドにコピーされます。ただし、サービス プロバイダーが MPLS パケットの QoS を、提供するサービスに基づき別の値に設定したい場合もあります。

この場合、サービス プロバイダーは MPLS EXP フィールドを設定できます。IP ヘッダーは、常にカスタマーが利用できます。IP パケットが MPLS ネットワークを通じて送信されても、IP パケットの QoS は変更されません。

詳細については、「MPLS DiffServ トンネリング モード」を参照してください。

MPLS QoS

ここでは、MPLS QoS の動作方法について説明します。

図38-1 に、カスタマー ネットワークの 2 つのサイトを接続する、サービス プロバイダーの MPLS ネットワークを示します。

図38-1 カスタマー IP ネットワークの 2 つのサイトを接続する MPLS ネットワーク

 

ネットワークは双方向ですが、このマニュアルではパケットは左から右へ移動するものとします。

図38-1 の記号には、次の意味があります。

CE1 -- カスタマー装置 1

PE1 -- サービス プロバイダーの入力 LER

P1 -- サービス プロバイダーのネットワーク コア内の Label Switch Router(LSR; ラベル スイッチ ルータ)

P2 -- サービス プロバイダーのネットワーク コア内の LSR

PE2 -- サービス プロバイダーの出力 LER

CE2 -- カスタマー装置 2


) PE1 および PE2 は、MPLS ネットワークと IP ネットワークの境界に存在します。


次に、MPLS ネットワークでの LER および LSR の動作について説明します。

「MPLS ネットワークの入力エッジでの LER」

「MPLS ネットワーク コアの LSR」

「MPLS ネットワークの出力エッジでの LER」


) 入力インターフェイスでの QoS 機能は、入力インターフェイスが LAN ポート、FlexWAN、または拡張 FlexWAN モジュールのポート アダプタのいずれかによって異なります。ここでは、LAN ポートについて説明します。FlexWAN または拡張 FlexWAN モジュールの詳細については『FlexWAN and Enhanced FlexWAN Installation and Configuration Note』を参照してください。


MPLS ネットワークの入力エッジでの LER


) 着信ラベルには集約または非集約の 2 つのタイプがあります。集約ラベルの場合は、到着した MPLS または MPLS Virtual Private Network(VPN; バーチャル プライベート ネットワーク)パケットは、IP 検索によって次のホップおよび発信インターフェイスを見つけ出すことでスイッチングされる必要があることを示します。非集約ラベルの場合、パケットに IP ネクストホップ情報が格納されます。


ここでは、MPLS ネットワークの入力側または出力側で、エッジ LER がどのように動作するかを説明します。

MPLS ネットワークの入力側では、LER は次のようにパケットを処理します。

1. レイヤ 2 またはレイヤ 3 トラフィックは、MPLS ネットワークのエッジであるエッジ LER(PE1)に入ります。

2. PFC は入力インターフェイスからトラフィックを受信し、802.1p ビットまたは IP ToS ビットを使用して EXP ビットを決定して、分類、マーキング、ポリシングを実行します。着信 IP パケットを分類するため、入力サービス ポリシーでは Access Control List(ACL; アクセス コントロール リスト)も使用されます。

3. PFC は着信 IP パケットごとに IP アドレスの検索を行い、ネクストホップ ルータを決定します。

4. 適切なラベルがパケットにプッシュ(インポジション)され、QoS の決定に基づく EXP 値がラベル ヘッダーの MPLS EXP フィールドにコピーされます。

5. PFC は、ラベルの付けられたパケットを、適切な発信インターフェイスに転送して処理します。

6. PFC は、802.1p ビットまたは IP ToS ビットも発信インターフェイスに転送します。

7. 発信インターフェイスでは、ラベル付きパケットはマーキングまたはポリシングのため、クラスによって区別されます。LAN インターフェイスの場合、出力分類は MPLS ではなく、IP に基づいて行われます。

8. ラベル付きパケット(EXP によってマーキング)は、コア MPLS ネットワークに送信されます。

MPLS ネットワーク コアの LSR

ここでは、MPLS ネットワーク コアで使用される LSR がパケットを処理する仕組みについて説明します。

1. エッジ LER(または他のコア装置)から送られた MPLS ラベル付きパケット(および 802.1p ビットまたは IP ToS ビット)は、コア LSR に着信します。

2. PFC は、入力インターフェイスからトラフィックを受信し、EXP ビットを使用して分類、マーキング、ポリシングを実行します。

3. PFC は、テーブルを検索してネクストホップ LSR を決定します。

4. 適切なラベルがパケットに添付(スワップ)され、MPLS EXP ビットがラベル ヘッダーにコピーされます。

5. PFC は、ラベルの付けられたパケットを、適切な発信インターフェイスに転送して処理します。

6. PFC は、802.1p ビットまたは IP ToS ビットも発信インターフェイスに転送します。

7. 発信パケットはマーキングまたはポリシングのため、MPLS EXP フィールドによって区別されます。

8. ラベルが添付された(EXP マークの付いた)パケットは、コア MPLS ネットワーク内の別の LSR、または出力エッジの LER に送信されます。


) これらは MPLS パケットなので、サービス プロバイダーのネットワーク内には、使用するキューイング アルゴリズム用の IP precedence フィールドが存在しません。パケットは、プロバイダー エッジ ルータである PE2 に着信するまでは MPLS パケットのままです。


MPLS ネットワークの出力エッジでの LER

MPLS ネットワークの出力側では、LER は次のようにパケットを処理します。

1. コア LSR からの MPLS ラベル付きパケット(および 802.1p ビットまたは IP ToS ビット)は、MPLS ネットワーク バックボーンからの出力 LER(PE2)に着信します。

2. PFC は、MPLS ラベルをパケットからポップ(ディスポジション)します。集約ラベルは、元の 802.1p ビットまたは IP ToS ビットを使用して分類されます。非集約ラベルは、デフォルトでは EXP 値で分類されます。

3. 集約ラベルの場合、PFC は IP アドレスの検索を行い、パケットの宛先を決定します。次に、PFC はパケット処理のため、パケットを適切な発信インターフェイスに転送します。非集約ラベルの場合、転送はラベルに基づいて行われます。デフォルトでは、非集約ラベルは出力 PE ルータではなく、直前のホップ LSR ルータ(最後の前)でポップされます。

4. PFC は、802.1p ビットまたは IP ToS ビットも発信インターフェイスに転送します。

5. パケットは 802.1p ビットまたは IP ToS ビットに従って区別され、適宜処理されます。


) MPLS EXP ビットを使用すると、MPLS パケットに QoS を指定できます。IP precedence ビットおよび DSCP ビットを使用すると、IP パケットに QoS を指定できます。


MPLS QoSの概要

MPLS QoS は、IP QoS をサポートしています。MPLS パケットでは、PFC が非 MPLS の QoS マーキングおよび ポリシングを適用できるように、EXP 値が内部 DSCP にマッピングされます。

入力および出力ポリシーでは、PFC モード MPLS QoS マーキングおよびポリシングの決定が、入力 PFC でインターフェイス単位で行われます。入力インターフェイスは物理ポート、サブインターフェイス、または VLAN です。

QoS ポリシー ACL は、入力および出力検索ごとに個別に QoS Ternary CAM(TCAM)でプログラムされます。TCAM 出力検索は、IP 転送テーブル(Forwarding Information Base [FIB; 転送情報ベース])の検索と NetFlow 検索が完了したあとに実行されます。

各 QoS TCAM 検索の結果、ポリサー設定およびポリシング カウンタを保持する RAM にインデックスが作成されます。その他の RAM 領域には、microflow ポリサー設定が含まれます。microflow ポリシング カウンタは、QoS ACL と一致する各 NetFlow エントリで維持されます。

入力および出力集約の結果と microflow ポリシングの組み合わせにより、最終的なポリシングが決定されます。プロファイル外パケットは、ドロップするか、または DSCP でマークダウンできます。

ここでは、次の場合の MPLS QoS について説明します。

「EoMPLS エッジの LER」

「IP エッジでの LER(MPLS、MPLS VPN)」

「MPLS コアでの LSR」


) ここでは、LAN ポートおよび FlexWAN ポートの QoS 機能について扱います。各機能の動作の詳細については、適切なマニュアルを参照してください。


EoMPLS エッジの LER

ここでは、LER 上で機能する Ethernet over MPLS(EoMPLS)QoS 機能の概要について説明します。EoMPLS QoS のサポートは、IP/MPLS-QoS に類似しています。

EoMPLS では、ポートが信頼できない場合、CoS の信頼状態は VC タイプ 5(ポート モード)ではなく、VC タイプ 4(VLAN モード)に自動的に設定されます。これは、トンネル上での 802.1q CoS 保存機能に似ています。

トンネルの入口で受信されたパケットは、VC タイプ 4 以外の EoMPLS インターフェイスでは信頼不可として処理されます。VC タイプ 4 インターフェイスでは、入力ポートには trust CoS が自動設定され、ポリシー マーキングは適用されません。

入力ポートが信頼可能として設定されている場合は、EoMPLS インターフェイス上で受信されるパケットは、元の IP パケット ヘッダーの QoS ポリシーによってマーキングされません。IP ポリシーによるマーキングは、信頼できないポートに対して行われます。

802.1q ヘッダーを介して 802.1p CoS を利用できる場合、これは入力時から出力時まで保存されます。

1p タグが EoMPLS ヘッダー(VC タイプ 4)によってトンネリングされた場合、トンネルの出口から出力されたあと、キューイングは保存された 802.1p CoS に基づいて行われます。それ以外の場合、キューイングは QoS の決定から得られた CoS に基づいて行われます。

Ethernet/MPLS

Ethernet/MPLS では、入力インターフェイス、MPLS QoS、出力インターフェイスの各機能は、IP/MPLS における該当機能と類似しています。詳細については、次のセクションを参照してください。

「IP/MPLS の分類」

「IP/MPLS モード MPLS QoS の分類」

「IP/MPLS 入力ポートでの分類」

「IP/MPLS 出力ポートでの分類」

MPLS/Ethernet

MPLS/Ethernet の場合、入力インターフェイス、MPLS QoS、出力インターフェイスの各機能は、MPLS/IP における該当機能と類似しています。ただし、EoMPLS カプセル開放では、出力 IP ポリシーを適用できません(パケットは MPLS としてのみ分類できます)。

詳細については、次のセクションを参照してください。

「MPLS/IP の分類」

「MPLS/IP MPLS QoS の分類」

「MPLS/IP 入力ポートでの分類」

「MPLS/IP 出力ポートでの分類」

IP エッジでの LER(MPLS、MPLS VPN)

ここでは、MPLS および MPLS VPN ネットワークの入力(CE/PE)エッジおよび出力(PE/CE)エッジでの、LER の QoS 機能について説明します。MPLS および MPLS VPN は、いずれも一般的な MPLS QoS 機能をサポートします。追加された MPLS VPN 固有の QoS 情報については、「MPLS VPN」を参照してください。

IP/MPLS

PFC は、IP/MPLS エッジで次の MPLS QoS 機能を提供します。

mls qos trust コマンドまたは policy-map コマンドに基づいた EXP 値の割り当て

ポリシーを使用した EXP 値のマーキング

ポリシーを使用したトラフィックのポリシング

ここでは、IP/MPLS エッジで PFC がサポートする MPLS QoS 分類に関する情報を提供します。さらに、入力および出力インターフェイス モジュールによる機能についても説明します。

IP/MPLS の分類

IP トラフィックに対し、PFC の入力ポリシーと出力ポリシーは、IP precedence、IP DSCP、IP ACL の match コマンドを使用して、受信した元の IP 上のトラフィックを分類します。出力ポリシーでは、インポーズした EXP 値、または入力ポリシーによるマーキングに基づくトラフィックの分類は行われません。

PFC は、ポート信頼ポリシーと QoS ポリシーを適用したあと、内部 DSCP を割り当てます。次に、PFC はインポーズしたラベルの内部 DSCP/EXP グローバル マップに基づき、EXP 値を割り当てます。複数のラベルがインポーズされている場合でも、各ラベルの EXP 値は同じ値です。MPLS ラベルがインポーズされている場合、PFC は元の IP ToS を保持します。

PFC は、内部 DSCP/CoS グローバル マップに基づき、出力 CoS を割り当てます。デフォルトの内部 DSCP/EXP と内部 DSCP/CoS マップに整合性がある場合は、出力 CoS はインポーズされた EXP と同じ値になります。

入力ポートが IP/IP トラフィックと IP/MPLS トラフィックの両方を受信する場合、分類を使用して 2 つのトラフィック タイプを分ける必要があります。たとえば、IP/IP トラフィックと IP/MPLS トラフィックの宛先アドレス範囲が異なる場合は、宛先アドレスに基づきトラフィックを分類します。次に、IP ToS ポリシーを IP/IP トラフィックに適用し、(インポーズされた MPLS ヘッダーに EXP 値をマーキングまたは設定する)適切なポリシーを IP/MPLS トラフィックに適用します。次の 2 つの例を参照してください。

IP ToS をマーキングする PFC ポリシーによって内部 DSCP を設定 -- このポリシーがトラフィックすべてに適用された場合は、IP/IP トラフィックでは出力ポートによって、出力パケット内の CoS(内部 DSCP から作成)が IP ToS バイトに書き換えられます。IP/MPLS トラフィックでは、PFC は、内部 DSCP をインポーズされた EXP 値にマッピングします。

MPLS EXP をマーキングする PFC ポリシーによって内部 DSCP を設定 -- このポリシーがトラフィックすべてに適用された場合は、IP/IP トラフィックでは出力ポートによって、入力 IP ポリシー(または trust)に従って IP ToS が書き換えられます。CoS は ToS からマッピングされます。IP/MPLS トラフィックでは、PFC は、内部 DSCP をインポーズされた EXP 値にマッピングします。

IP/MPLS モード MPLS QoS の分類

MPLS QoS は、PE1 への入力時に以下をサポートします。

IP precedence 値または DSCP 値に基づく照合、またはアクセス グループによるフィルタリング

set mpls experimental imposition コマンドおよび police コマンド

MPLS QoS は、PE1 からの出力時に mpls experimental topmost コマンドをサポートします。

IP/MPLS 入力ポートでの分類

IP/MPLS の分類は、IP/IP と同じです。LAN ポート分類は、受信したレイヤ 2 802.1Q CoS 値に基づいて行われます。FlexWAN インターフェイスは、受信したレイヤ 3 IP ヘッダーの情報に基づきトラフィックを分類します。

IP/MPLS 出力ポートでの分類

LAN ポートでの分類は、受信した EXP 値に基づいて行われ、この値から出力 CoS 値がマッピングされます。

FlexWAN インターフェイスによるトラフィックの分類は、 match mpls experimental コマンドを使用して、出力 CoS を EXP 値のプロキシとして一致させた場合に行われます。
match mpls experimental コマンドは、最上位ラベルの EXP 値では一致しません。

出力ポートがトランクの場合は、LAN ポートは、出力 CoS を出力 802.1Q フィールドにコピーします。

MPLS/IP

MPLS QoS は、MPLS/IP エッジで次の機能をサポートします。

MPLS ドメインからの出力時に、出力インターフェイスごとに EXP 値を IP DSCP に伝播するオプション

MPLS/IP 出力インターフェイスで IP サービス ポリシーを使用するオプション

ここでは、MPLS/IP MPLS QoS 分類に関する情報を提供します。さらに、入力および出力モジュールによる機能についても説明します。

MPLS/IP の分類

PFC は QoS の結果に基づき、内部 DSCP(PFC が各フレームに割り当てる内部プライオリティ)を割り当てます。QoS の結果は次の影響を受けます。

trust EXP のデフォルト値

ラベル タイプ(プレフィクス単位または集約)

VPN 数

明示的な NULL の使用

QoS ポリシー

分類モードには次の 3 つがあります。

通常の MPLS 分類 -- 非集約ラベルでは、MPLS の再循環が存在しない場合、PFC は MPLS EXP 入力または出力ポリシーに基づいてパケットを分類します。PFC は EXP/DSCP/CoS マッピングから作成した CoS に基づき、パケットをキューイングします。基本 IP DSCP は、出力時のカプセル開放後に保存されるか、または(EXP/DSCP マップに基づき)EXP によって上書きされます。

VPN CAM 内の集約レベルの一致による IP 分類 -- PFC は、次のいずれかを行います。

基本の IP ToS を保存

EXP/DSCP グローバル マップから得られた値によって IP ToS を書き換え

IP ToS を、出力 IP ポリシーから得られた任意の値に変更

すべての場合、出力キューイングは DSCP/CoS マップからの最終 IP ToS に基づいています。

VPN CAM に集約ラベルが存在しない場合の IP 分類 -- 再循環後、PFC は、MPLS カプセル開放隣接で指定された入力予約済み VLAN に基づき、MPLS/IP パケットを通常の IP/IP パケットから区別します。予約済み VLAN は、VPN および非 VPN において VPN Routing/Forwarding instance(VRF; VPN ルーティング/転送インスタンス)単位で割り当てられます。再循環後の入力 ToS は元の IP ToS 値となるか、または元の EXP 値から作成できます。出力 IP ポリシーは、入力 ToS を任意の値に上書きできます。


) 再循環の詳細については、「再循環」を参照してください。


PE/CE 入力時の着信 MPLS パケットの場合は、PFC は MPLS 分類のみをサポートします。入力 IP ポリシーはサポートされません。MPLS コアからの PE/CE トラフィックは、出力時に IP として分類またはポリシングされます。

MPLS/IP MPLS QoS の分類

MPLS QoS は、PE2 への入力時に、EXP 値の照合および police コマンドをサポートします。

MPLS QoS は、PE2 からの出力時に、IP precedence または DSCP 値の照合、またはアクセス グループと police コマンドによるフィルタリングをサポートします。

MPLS/IP 入力ポートでの分類

LAN ポートでの分類は、EXP 値に基づいて行われます。FlexWAN インターフェイスは、 match mpls experimental コマンドを使用してトラフィックを分類します。 match mpls experimental コマンドは、受信した最上位ラベルの EXP 値で一致します。

MPLS/IP 出力ポートでの分類


) 出力分類キューイングは、LAN ポートと WAN ポートでは異なります。


MPLS/IP の分類は、IP/IP の分類と同じです。

LAN インターフェイスの分類は、出力 CoS に基づいて行われます。FlexWAN インターフェイスは、送信した IP ヘッダーの情報に基づいてトラフィックを分類します。

出力ポートがトランクの場合は、LAN ポートは出力 CoS を出力 802.1Q フィールドにコピーします。


) MPLS/IP では、出力インターフェイスで MPLS IP(またはタグ IP)がイネーブルにされている場合、出力 IP ACL または QoS は出力インターフェイスで無効となります。例外は、VPN CAM 内で一致した場合です。この場合、パケットは出口で IP として分類されます。


MPLS VPN

ここで説明する情報は、MPLS VPN ネットワークにも該当します。

MPLS VPN では、次の PE MPLS QoS 機能がサポートされます。

VPN サブインターフェイスを通る CE/PE IP トラフィックの分類、ポリシング、またはマーキング

VPN 単位の QoS(ポート単位、VLAN 単位、またはサブインターフェイス単位)

Customer Edge(CE; カスタマー エッジ)/PE トラフィックの場合、または CE/PE/CE トラフィックの場合は、サブインターフェイスのサポートにより、IP QoS 入力ポリシーまたは出力ポリシーをサブインターフェイスおよび物理インターフェイスに適用できます。VPN 単位ポリシングは、CE 側で指定された VPN に対応付けられた特定のインターフェイスまたはサブインターフェイスにも提供されます。

複数のインターフェイスが同じ VPN に属する状況では、同じ PFC に関連付けられた類似インターフェイスすべてに対し、入力または出力サービス ポリシー内で同一の共有ポリサーを使用することで、VPN 単位のポリシング集約を実行できます。

集約 VPN ラベルでは、再循環の場合の EXP 伝播機能はサポートされないことがあります。最終パケットが使用する出力インターフェイスが、MPLS 隣接に通知されないためです。


) 再循環の詳細については、「再循環」を参照してください。


VPN のインターフェイスすべてで EXP 伝播機能がイネーブルの場合、PFC は EXP 値を伝播します。

次の PE MPLS QoS 機能がサポートされます。

IP パケットに対する一般的な MPLS QoS 機能

VPN サブインターフェイスを通る CE/PE IP トラフィックの分類、ポリシング、またはマーキング

VPN 単位の QoS(ポート単位、VLAN 単位、またはサブインターフェイス単位)

MPLS コアでの LSR

ここでは、MPLS および MPLS VPN ネットワーク コアにおける LSR(MPLS/MPLS)の MPLS QoS 機能について説明します。Carrier Supporting Carrier(CSC)QoS 機能における入力機能、出力インターフェイス、PFC 機能は、次に説明する MPLS/MPLS で使用される各機能と類似しています。CSC と MPLS/MPLS との違いは、CSC ではラベルを MPLS ドメイン内にインポーズできることです。

MPLS/MPLS

MPLS コアでの MPLS QoS は、次の機能をサポートします。

サービス ポリシーに基づく EXP 単位のポリシング

最上位 EXP 入力値を、新たにインポーズされた EXP 値にコピー

MPLS ドメイン間の出力境界上での、任意の EXP 変換(2 つの近接 MPLS ドメイン間で、インターフェイス エッジ上での EXP 値の変更)

特定の EXP 値に対する個別のラベル フローに基づく microflow ポリシング

マルチラベル スタックから最上位ラベルをポップする際の、最上位 EXP 値の基本 EXP 値への任意伝播

ここでは、MPLS/MPLS QoS 分類に関する情報を提供します。さらに、入力および出力モジュールの機能についての情報も提供します。

MPLS/MPLS の分類

受信 MPLS パケットの場合、PFC はポートの信頼状態、入力 CoS、およびすべての policy-map trust コマンドを無視します。代わりに、PFC は最上位ラベルの EXP 値を信頼します。


match mpls experimental コマンドを入力すると、MPLS トラフィックに対する PFC モード MPLS QoS 入力ポリシーおよび出力ポリシーは、受信した最上位ラベルの EXP 値に基づきトラフィックを分類します。


MPLS QoS は、EXP/DSCP グローバル マップを使用して、EXP 値を内部 DSCP にマッピングします。PFC の次の動作は、ラベルのスワップ、新規ラベルのインポーズ、またはラベルのポップのどれを行うかによって異なります。

ラベルのスワップ -- ラベルをスワップする場合、PFC は受信した最上位ラベルの EXP 値を保持し、発信する最上位ラベルの EXP 値にこの値をコピーします。PFC は、内部 DSCP/CoS グローバル マップを使用して、出力 CoS を割り当てます。DSCP グローバル マップに整合性がある場合、出力 CoS は発信する最上位ラベルの EXP に基づきます。

PFC は、 police コマンドの exceed および violate アクションを使用して、プロファイル外トラフィックをマークダウンできます。適合するトラフィックはマーキングされないので、 conform アクションを送信する必要があります。 set コマンドは使用できません。PFC はマークダウンを行う際、内部 DSCP マークダウン マップのインデックスとして内部 DSCP を使用します。PFC は、内部 DSCP/EXP グローバル マップを使用して、内部 DSCP マークダウンの結果を EXP 値にマッピングします。PFC は新しい EXP 値を発信最上位ラベルに書き換え、新しい EXP 値をスタック内の他のラベルにコピーしません。PFC は、内部 DSCP/CoS グローバル マップを使用して、出力 CoS を割り当てます。DSCP マップに整合性がある場合、出力 CoS は発信最上位ラベルの EXP 値に基づきます。

追加ラベルのインポーズ -- 新規ラベルを既存のラベル スタックにインポーズする場合、PFC は内部 DSCP/EXP マップを使用して、インポーズされたラベルの EXP 値に内部 DSCP をマッピングします。次に、インポーズしたラベルの EXP 値を基本スワップ ラベルにコピーします。PFC は、内部 DSCP/CoS グローバル マップを使用して、出力 CoS を割り当てます。DSCP マップに整合性がある場合、出力 CoS はインポーズしたラベルの EXP 値に基づきます。

PFC はプロファイル内トラフィックをマーキングし、プロファイル外トラフィックをマークダウンします。内部 DSCP をマーキングしたあと、PFC は内部 DSCP/EXP グローバル マップを使用して、新規にインポーズされたラベルの EXP 値に内部 DSCP をマッピングします。次に、PFC は、インポーズしたラベルの EXP 値を基本スワップ ラベルにコピーします。PFC は、内部 DSCP/CoS グローバル マップを使用して、出力 CoS を割り当てます。したがって、出力 CoS はインポーズしたラベルの EXP に基づきます。

ラベルのポップ -- ラベルをマルチラベル スタックからポップする場合、PFC はエクスポーズしたラベルの EXP 値を保持します。PFC は、内部 DSCP/CoS グローバル マップを使用して、出力 CoS を割り当てます。DSCP マップに整合性がある場合、出力 CoS はポップしたラベルの EXP 値に基づきます。

出力インターフェイスに EXP 伝播が設定されている場合は、PFC は DSCP/EXP グローバル マップを使用して、内部 DSCP をエクスポーズしたラベルの EXP 値にマッピングします。PFC は、内部 DSCP/CoS グローバル マップを使用して、出力 CoS を割り当てます。DSCP マップに整合性がある場合、出力 CoS はエクスポーズしたラベルの EXP 値に基づきます。

MPLS/MPLS QoS の分類

P1 または P2 への入力時に、MPLS QoS は次の機能をサポートします。

mpls experimental topmost コマンドによる照合

set mpls experimental imposition police set imposition を併用する police コマンド

MPLS QoS は、P1 または P2 からの出力時に mpls experimental topmost コマンドによる照合をサポートします。

MPLS/MPLS 入力ポートでの分類

LAN ポートでの分類は、PFC からの出力 CoS に基づいて行われます。FlexWAN インターフェイスは、 match mpls experimental コマンドを使用してトラフィックを分類します。
match mpls experimental コマンドは、受信した最上位ラベルの EXP 値で一致します。

MPLS/MPLS 出力ポートでの分類

LAN ポートでの分類は、PFC からの出力 CoS 値に基づいて行われます。FlexWAN インターフェイスは、 match mpls experimental コマンドを使用してトラフィックを分類します。 match mpls experimental コマンドは、出力 CoS で一致しますが、最上位ラベルの EXP 値では一致しません。

出力ポートがトランクの場合は、LAN ポートは出力 CoS を出力 802.1Q フィールドにコピーします。

MPLS QoS のデフォルト設定

ここでは、MPLS QoS のデフォルト設定について説明します。次のグローバル MPLS QoS 設定が適用されます。

 

機能
デフォルト値

PFC QoS のグローバル イネーブル ステート


) PFC QoS がディセーブルで、他のすべての PFC QoS パラメータがデフォルト値の場合、デフォルトの EXP は IP precedence からマッピングされます。



) PFC QoS がイネーブルで、他のすべての PFC QoS パラメータがデフォルト値の場合、PFC QoS は LAN ポート(デフォルトは untrusted)から送信されたすべてのトラフィックで、レイヤ 3 DSCP を 0(untrusted ポートのみ)に、レイヤ 2 CoS を 0 に、インポーズされた EXP を 0 に設定します。trust CoS の場合、EXP のデフォルト値は CoS からマッピングされます。trust DSCP の場合、EXP のデフォルト値は IP precedence からマッピングされます。


PFC QoS のポート イネーブル ステート

PFC QoS がグローバルにイネーブルの場合、イネーブル

ポートの CoS 値

0

マイクロフロー ポリシング

イネーブル

VLAN 内マイクロフロー ポリシング

ディセーブル

ポート ベースまたは VLAN ベースの PFC QoS

ポートベース

EXP/DSCP マップ
(EXP 値に基づき設定された DSCP)

EXP 0 = DSCP 0
EXP 1 = DSCP 8
EXP 2 = DSCP 16
EXP 3 = DSCP 24
EXP 4 = DSCP 32
EXP 5 = DSCP 40
EXP 6 = DSCP 48
EXP 7 = DSCP 56

IP precedence/DSCP マップ
(IP precedence 値に基づき設定された DSCP)

IP precedence 0 = DSCP 0
IP precedence 1 = DSCP 8
IP precedence 2 = DSCP 16
IP precedence 3 = DSCP 24
IP precedence 4 = DSCP 32
IP precedence 5 = DSCP 40
IP precedence 6 = DSCP 48
IP precedence 7 = DSCP 56

DSCP/EXP マップ
(DSCP 値に基づき設定された EXP)

DSCP 0 ~ 7 = EXP 0
DSCP 8 ~ 15 = EXP 1
DSCP 16 ~ 23 = EXP 2
DSCP 24 ~ 31 = EXP 3
DSCP 32 ~ 39 = EXP 4
DSCP 40 ~ 47 = EXP 5
DSCP 48 ~ 55 = EXP 6
DSCP 56 ~ 63 = EXP 7

DSCP マップからの DSCP のマークダウン

マークダウンされた DSCP 値は元の DSCP 値と等しい(マークダウンなし)

EXP 変換マップ

デフォルトでは変換マップなし

ポリサー

なし

ポリシー マップ

なし

NetFlow テーブルの MPLS フロー マスク

Label + EXP 値

MPLS コア QoS

MPLS コア QoS は、次の 4 つのいずれかとなります。

スワップ -- 着信 EXP フィールドは発信 EXP フィールドにコピーされます。

スワップ+インポジション -- 着信 EXP フィールドは、スワップされた EXP フィールドとインポーズされた EXP フィールドの両方にコピーされます。


) EXP フィールド用にサービスポリシーが設定されている場合は、この EXP フィールドはインポーズされたラベル、およびスワップされたラベルに挿入されます。


最上位ラベルのディスポジション -- エクスポーズした EXP フィールドを保持します。

ラベルのみのディスポジション -- エクスポーズした IP DSCP を保持します。

MPLS/IP エッジ QoS

エクスポーズした IP DSCP を保持します。

MPLS QoS コマンド

MPLS QoS は、次の MPLS QoS コマンドをサポートします。

match mpls experimental topmost

set mpls experimental imposition

police

mls qos map exp-dscp

mls qos map dscp-exp

mls qos map exp-mutation

mls qos exp-mutation

show mls qos mpls

no mls qos mpls trust exp


) サポートされる非 MPLS QoS コマンドの詳細については、「PFC QoS の設定」を参照してください。


次のコマンドはサポートされません。

set qos-group

set discard-class

MPLS QoS の注意事項および制約事項

MPLS QoS を設定する際に、以下の注意事項と制約事項に従ってください。

受信パケットが IP パケットの場合の IP/MPLS または EoMPLS インポジション

QoS がディセーブルの場合は、EXP 値は受信した IP ToS に基づきます。

QoS が queuing-only モードの場合、EXP 値は受信した IP ToS に基づきます。

受信パケットが IP パケット以外の場合の EoMPLS インポジション

QoS がディセーブルの場合、EXP 値は入力 CoS に基づきます。

QoS が queuing-only モードの場合、EXP 値は受信した IP ToS に基づきます。

MPLS/MPLS 操作

QoS がディセーブルの場合にスワップすると、EXP 値は元の EXP値に基づきます(EXP 変換が存在しない場合)。

QoS がキューイングする場合にのみスワップすると、EXP 値は元の EXP 値に基づきます(EXP 変換が存在しない場合)。

QoS がディセーブルの場合に追加ラベルをインポーズすると、EXP 値は元の EXP 値に基づきます(EXP 変換が存在しない場合)。

QoS がキューイングする場合にのみ追加ラベルをインポーズすると、EXP 値は元の EXP 値に基づきます(EXP 変換が存在しない場合)。

QoS がディセーブルの場合にラベルを 1 つポップすると、EXP 値は基本 EXP 値に基づきます。

QoS が キューイングする場合にのみラベルを 1 つポップすると、EXP 値は基本 EXP 値に基づきます。

EXP 値は MPLS/IP ディスポジションとは関係ありません。

no mls qos rewrite ip dscp コマンドと MPLS には互換性がありません。PFC がインポーズするラベルに正しい EXP 値を割り当てられるように、デフォルトの mls qos rewrite ip dscp コマンドはイネーブルである必要があります。

no mls qos mpls trust exp コマンドを使用すると、CoS および出力キューイングの目的で、MPLS パケットをレイヤ 2 パケットと同様に扱うことができます。この場合、デフォルトの EXP 値ではなく、ポートの信頼状態またはポリシーの信頼状態が適用されます。

MPLS QoS の設定

ここでは、MPLS QoS の設定手順について説明します。

「QoS をグローバルにイネーブルにする方法」

「queueing-only モードのイネーブル化」

「MPLS パケット分類のためのクラス マップの設定」

「入力ポートでの MPLS パケットの信頼状態の設定」

「ポリシー マップの設定」

「ポリシー マップの表示」

「MPLS QoS の出力 EXP 変換の設定」

「EXP 値マッピングの設定」

QoS をグローバルにイネーブルにする方法

PFC に QoS を設定する前に、 mls qos コマンドを使用して、QoS 機能をグローバルにイネーブルにする必要があります。このコマンドを使用すると、トラフィックのデフォルトの QoS 処理がイネーブルになります。

mls qos コマンドがイネーブルになると、PFC はプライオリティ値を各フレームに割り当てます。この値は内部 DSCP です。内部 DSCP は、受信したフレームと QoS 設定の内容に基づいて割り当てられます。この値は、出力フレームの CoS および ToS フィールドに書き換えられます。

QoS をグローバルにイネーブルにするには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# mls qos

スイッチで PFC QoS をグローバルにイネーブルにします。

Router(config)# no mls qos

スイッチで PFC QoS をグローバルにディセーブルにします。

ステップ 2

Router(config)# end

コンフィギュレーション モードを終了します。

ステップ 3

Router# show mls qos

設定を確認します。

次に、QoS をグローバルにイネーブルにする例を示します。

Router(config)# mls qos
Router(config)# end
Router#
 

次に、設定を確認する例を示します。

Router# show mls qos
QoS is enabled globally
Microflow policing is enabled globally
QoS ip packet dscp rewrite enabled globally
 
Qos trust state is DSCP on the following interfaces:
Gi4/1 Gi4/1.12
 
Qos trust state is IP Precedence on the following interfaces:
Gi4/2 Gi4/2.42
Vlan or Portchannel(Multi-Earl) policies supported: Yes
Egress policies supported: Yes
 
 
----- Module [5] -----
QoS global counters:
Total packets: 5957870
IP shortcut packets: 0
Packets dropped by policing: 0
IP packets with TOS changed by policing: 6
IP packets with COS changed by policing: 0
Non-IP packets with COS changed by policing: 3
MPLS packets with EXP changed by policing: 0

queueing-only モードのイネーブル化

queueing-only モードをイネーブルにするには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# mls qos queueing-only

queueing-only モードをイネーブルにします。

Router(config)# no mls qos queueing-only

PFC QoS をグローバルにディセーブルにします。


) queueing-only モードを個別にディセーブルにすることはできません。


ステップ 2

Router(config)# end

コンフィギュレーション モードを終了します。

ステップ 3

Router# show mls qos

設定を確認します。

queueing-only モードをイネーブルにすると、ルータは次の処理を行います。

マーキングおよびポリシングをグローバルにディセーブルにします。

すべてのポートがレイヤ 2 CoS を信頼するように設定します。


) スイッチでは、タグなし入力トラフィックと、trust CoS に設定できないポートを介して受信されるトラフィックにポート CoS 値が適用されます。


次に、queueing-only モードをイネーブルにする例を示します。

Router# configure terminal
Router(config)# mls qos queueing-only
Router(config)# end
Router#

制約事項および使用上の注意事項

QoS が PFC でディセーブル( no mls qos )の場合、EXP 値は次のように決定されます。

受信パケットが IP パケットの場合の IP/MPLS または EoMPLS インポジション

QoS がディセーブル( no mls qos )の場合、EXP 値は受信した IP ToS に基づきます。

QoS が queuing-only モードの場合( mls qos queueing-only )、EXP 値は受信した IP ToS に基づきます。

受信パケットが IP パケット以外の場合の EoMPLS インポジション

QoS がディセーブルの場合、EXP 値は入力 CoS に基づきます。

QoS が queuing-only モードの場合、EXP 値は受信した IP ToS に基づきます。

MPLS/MPLS 操作

QoS がディセーブルの場合にスワップすると、EXP 値は元の EXP値に基づきます(EXP 変換が存在しない場合)。

QoS がキューイングする場合にのみスワップすると、EXP 値は元の EXP 値に基づきます(EXP 変換が存在しない場合)。

QoS がディセーブルの場合に追加ラベルをインポーズすると、EXP 値は元の EXP 値に基づきます(EXP 変換が存在しない場合)。

QoS が queuing-only モードの場合に追加ラベルをインポーズすると、EXP 値は元の EXP 値に基づきます(EXP 変換が存在しない場合)。

QoS がディセーブルの場合にラベルを 1 つポップすると、EXP 値は基本 EXP 値に基づきます。

QoS が キューイングする場合にのみラベルを 1 つポップすると、EXP 値は基本 EXP 値に基づきます。

EXP 値は MPLS/IP ディスポジションとは関係ありません。

MPLS パケット分類のためのクラス マップの設定

パケットの EXP 値によって MPLS ドメイン内のトラフィック クラスを定義するには、 match mpls experimental topmost コマンドを使用できます。これにより、 police コマンドを使用して、インターフェイス単位で EXP トラフィックをポリシングするようサービス ポリシーを定義できます。

クラス マップを設定するには、グローバル コンフィギュレーション モードで次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# class-map class_name

パケットと一致するクラス マップを指定します。

ステップ 2

Router(config-cmap)# match mpls experimental topmost value

クラスと一致するパケット特性を指定します。

ステップ 3

Router(config-cmap)# exit

クラスマップ コンフィギュレーション モードを終了します。

次に、MPLS EXP 値 3 を含むパケットすべてがトラフィック クラス exp3 と一致する例を示します。

Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# class-map exp3
Router(config-cmap)# match mpls experimental topmost 3
Router(config-cmap)# exit
Router(config)# policy-map exp3
Router(config-pmap)# class exp3
Router(config-pmap-c)# police 1000000 8000000 conform-action transmit exceed-action drop
Router(config-pmap-c)# exit
Router(config-pmap)# end
Router# show class exp3
Class Map match-all exp3 (id 61)
Match mpls experimental topmost 3
Router# show policy-map exp3
Policy Map exp3
Class exp3
police cir 1000000 bc 8000000 be 8000000 conform-action transmit exceed-action drop
Router# show running-config interface fastethernet 3/27
Building configuration...
 
Current configuration : 173 bytes
!
interface FastEthernet3/27
ip address 47.0.0.1 255.0.0.0
tag-switching ip
end
 
Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# interface fastethernet 3/27
Router(config-if)# service-policy input exp3
Router(config-if)#
Router#
Enter configuration commands, one per line. End with CNTL/Z.
Router# show running-config interface fastethernet 3/27
Building configuration...
 
Current configuration : 173 bytes
!
interface FastEthernet3/27
ip address 47.0.0.1 255.0.0.0
tag-switching ip
service-policy input exp3
end
 
Router#
1w4d: %SYS-5-CONFIG_I: Configured from console by console
Router# show mls qos mpls
QoS Summary [MPLS]: (* - shared aggregates, Mod - switch module)
 
Int Mod Dir Class-map DSCP Agg Trust Fl AgForward-By AgPoliced-By
Id Id
-------------------------------------------------------------------------------
Fa3/27 5 In exp3 0 2 dscp 0 0 0
 
All 5 - Default 0 0* No 0 3466140423 0
Router# show policy-map interface fastethernet 3/27
FastEthernet3/27
 
Service-policy input: exp3
 
class-map: exp3 (match-all)
Match: mpls experimental topmost 3
police :
1000000 bps 8000000 limit 8000000 extended limit
Earl in slot 5 :
0 bytes
5 minute offered rate 0 bps
aggregate-forwarded 0 bytes action: transmit
exceeded 0 bytes action: drop
aggregate-forward 0 bps exceed 0 bps
 
Class-map: class-default (match-any)
0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: any
 
Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# interface fastethernet 3/27
Router(config-if)# service-policy output ip2tag
Router(config-if)# end
Router# show mls qos ip
QoS Summary [IPv4]: (* - shared aggregates, Mod - switch module)
 
Int Mod Dir Class-map DSCP Agg Trust Fl AgForward-By AgPoliced-By
Id Id
-------------------------------------------------------------------------------
Vl300 5 In x 44 1 No 0 0 0
Fa3/27 5 Out iptcp 24 2 -- 0 0 0
 
All 5 - Default 0 0* No 0 3466610741 0

制約事項および使用上の注意事項

MPLS パケットを分類する場合は、次の制約事項および注意事項が適用されます。

match mpls experimental コマンドでは、一致基準として使用する EXP フィールド値の名前を指定します。各パケットはこの基準に基づき、クラス マップによって指定されたクラスに属するかどうかをチェックされます。

match mpls experimental コマンドを使用するには、確立したい基準と一致するクラス名を指定するため、まず class-map コマンドを入力する必要があります。クラスを特定してから、 match mpls experimental コマンドを使用して一致基準を設定できます。

1 つのクラス マップで複数のコマンドを指定すると、最後に入力したコマンドだけが適用されます。最後のコマンドは、それ以前に入力したコマンドを上書きします。

入力ポートでの MPLS パケットの信頼状態の設定

no mls qos mpls trust exp コマンドを使用すると、レイヤ 2 パケットに適用する場合と同様に、MPLS パケットにポートまたはポリシーの信頼状態を適用できます。

入力ポートの MPLS パケット信頼状態を設定するには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# interface {{type slot/port} | {port-channel number}}

設定するインターフェイスを選択します。

ステップ 2

Router(config-if)# no mls qos mpls trust exp

信頼できるすべてのトラフィック(trust cos、trust dscp、trust ip-precedence)が trust-cos として扱われるように、MPLS パケットの信頼状態を設定します。

Router(config-if)# mls qos mpls trust exp

着信パケット内の EXP 値だけが信頼されるように、デフォルトの信頼状態に戻します。

ステップ 3

Router(config-if)# end

インターフェイス コンフィギュレーション モードを終了します。

ステップ 4

Router# show mls qos

設定を確認します。

次に、着信 MPLS パケットが着信レイヤ 2 パケットと同様に動作するように、MPLS パケットの信頼状態を untrusted に設定する例を示します。

Router(config)# interface fastethernet 3/27
Router(config-if)# no mls qos mpls trust exp
Router(config-if)#

制約事項および使用上の注意事項

no mls qos mpls trust exp コマンドを使用して、入力ポートでの MPLS パケットの信頼状態を設定する場合は、以下の制約事項および注意事項に従ってください。

このコマンドは、レイヤ 2 パケットにもレイヤ 3 パケットにも影響を与えます。したがって、このコマンドはレイヤ 2 パケットがスイッチングされるインターフェイスのみで使用してください。

no mls qos mpls trust exp コマンドは入力マーキングに影響を与えますが、分類には影響はありません。

ポリシー マップの設定

1 つのインターフェイスに付加できるポリシー マップは、1 つに限られます。ポリシー マップには、ポリシー マップ コマンドがそれぞれ異なる 1 つまたは複数のポリシー マップ クラスを含めることができます。

インターフェイスで受信するトラフィック タイプごとに、個別のポリシー マップ クラスをポリシー マップ内に設定します。各トラフィック タイプ用の全コマンドを、同一のポリシー マップ クラスに入れます。MPLS QoS は、一致したトラフィックに複数のポリシー マップ クラスのコマンドを適用することはありません。

インポーズした全ラベルで EXP 値を設定するためのポリシー マップの設定

インポーズした全ラベル エントリで MPLS EXP フィールドの値を設定するには、QoS ポリシーマップ クラス コンフィギュレーション モードで set mpls experimental imposition コマンドを使用します。設定をディセーブルにするには、このコマンドの no 形式を使用します。


set mpls experimental コマンドが set mpls experimental imposition コマンドに置き換えられます。


 

コマンド
目的

ステップ 1

Router(config)# policy-map policy_name

ポリシー マップを作成します。

ステップ 2

Router(config-pmap)# class-map name [match-all | match-any]

QoS クラス マップを設定するため、QoS クラス マップ コンフィギュレーション モードにアクセスします。

ステップ 3

Router(config-pmap-c)# set mpls experimental imposition {mpls-exp-value | from-field [table table-map-name]}

インポーズしたラベル エントリすべてで MPLS EXP フィールドの値を設定します。

ステップ 4

Router(config-pmap-c)# exit

クラスマップ コンフィギュレーション モードを終了します。

次に、MPLS EXP 値 3 で定義された DSCP 値に従って、MPLS EXP インポジション値を設定する例を示します。

Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# access-l 101 p tcp any any
Router(config)# class-map iptcp
Router(config-cmap)# match acc 101
Router(config-cmap)# exit
Router(config)#
Router(config-cmap)# policy-map ip2tag
Router(config-pmap)# class iptcp
Router(config-pmap-c)# set mpls exp imposition 3
Router(config-pmap-c)# exit
Router(config-pmap)# exit
Router(config)#
Router#
1w4d: %SYS-5-CONFIG_I: Configured from console by console
Router#
Router# show policy-map ip2tag
Policy Map ip2tag
Class iptcp
set mpls experimental imposition 3
Router# show class iptcp
Class Map match-all iptcp (id 62)
Match access-group101
 
Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# interface fastethernet 3/27
Router(config-if)# ser in ip2tag
Router(config-if)#
Routers
1w4d: %SYS-5-CONFIG_I: Configured from console by console
Router# show pol ip2tag
Policy Map ip2tag
Class iptcp
set mpls experimental imposition 3
Router# show class-map iptcp
Class Map match-all iptcp (id 62)
Match access-group 101
 
Router# show access-l 101
Extended IP access list 101
10 permit tcp any any
Router# show mls qos ip
QoS Summary [IPv4]: (* - shared aggregates, Mod - switch module)
 
Int Mod Dir Class-map DSCP Agg Trust Fl AgForward-By AgPoliced-By
Id Id
-------------------------------------------------------------------------------
Fa3/27 5 In iptcp 24 2 No 0 0 0
Vl300 5 In x 44 1 No 0 0 0
 
All 5 - Default 0 0* No 0 3466448105 0
Router#
Router# show policy-map interface fastethernet 3/27
FastEthernet3/27
 
Service-policy input: ip2tag
 
class-map: iptcp (match-all)
Match: access-group 101
set mpls experimental 3:
Earl in slot 5 :
0 bytes
5 minute offered rate 0 bps
aggregate-forwarded 0 bytes
 
class-map: class-default (match-any)
Match: any
 
Class-map: class-default (match-any)
0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: any
 

次に、設定を確認する例を示します。

Router# show policy map ip2tag
Policy Map ip2tag
Class iptcp
set mpls experimental imposition 3

EXP 値のインポジションに関する注意事項および制約事項

インポーズしたすべてのラベルに EXP 値を設定する場合は、次の注意事項および制約事項に従います。

ラベルのインポジション中は set mpls experimental imposition コマンドを使用します。このコマンドは、インポーズされたすべてのラベル エントリの MPLS EXP フィールドを設定します。

set mpls experimental imposition コマンドは、入力インターフェイス(インポジション)でのみサポートされます。

set mpls experimental imposition コマンドは EXP 値を直接マーキングしません。代わりに、内部 DSCP/EXP グローバル マップを通じて EXP にマッピングされる内部 DSCP をマーキングします。

分類(元の受信 IP ヘッダーに基づく)とマーキング(内部 DSCP に対して行われる)においては、IP/IP トラフィックと IP/MPLS トラフィックとが区別されないことに注意してください。IP ToS および EXP のマーキングに使用するコマンドの実行結果は、内部 DSCP をマーキングした場合と同じです。

プッシュされたラベル エントリ値をデフォルト値とは異なる値に設定するには、 set mpls experimental imposition コマンドを使用します。

IP precedence、DSCP フィールド、または QoS IP ACL で set mpls experimental imposition コマンドを任意で使用すると、インポーズされたラベル エントリすべてで MPLS EXP フィールドを設定できます。

PFC で受信 IP トラフィックにラベルをインポーズする場合、 set mpls experimental imposition コマンドを使用して、EXP フィールドをマーキングできます。

このコマンドの詳細については、次の URL で『 Cisco IOS Switching Services Command Reference 』Release 12.3 を参照してください。

http://www.cisco.com/en/US/products/sw/iosswrel/ps5187/products_command_reference_chapter09186a008017cf44.html#wp1092877

police コマンドを使用したポリシー マップの設定

ポリシングは、特定のトラフィック クラスを固有のレートに制限する、PFC ハードウェアの機能です。PFC は、集約ポリシングおよびマイクロフロー ポリシングをサポートします。

集約ポリシングは、異なる送信元、宛先、プロトコル、送信元ポート、または宛先ポートに関係なく、ポートに入るトラフィックをすべて測定します。マイクロフロー ポリシングは、ポートに入るトラフィックすべてをフロー単位で(送信元、宛先、プロトコル、送信元ポート、または宛先ポート単位で)測定します。集約ポリシングおよびマイクロフロー ポリシングの詳細については、「ポリサー」を参照してください。

トラフィック ポリシングを設定するには、 police コマンドを使用します。このコマンドの詳細については、『 Cisco IOS Software Releases 12.2SX Command References 』を参照してください。

 

コマンド
目的

ステップ 1

Router(config)# policy-map policy_name

ポリシー マップを作成します。

ステップ 2

Router(config-pmap)# class-map name [match-all | match-any]

QoS クラス マップを設定するため、QoS クラス マップ コンフィギュレーション モードにアクセスします。

ステップ 3

Router(config-pmap-c)# police {aggregate name}

共有集約ポリサーにクラスを追加します。

ステップ 4

Router(config-pmap-c)# police bps burst_normal burst_max conform-action action exceed-action action violate-action action

クラス別インターフェイス別のポリサーを作成します。

ステップ 5

Router(config-pmap-c)# police flow { bps [ burst_normal ] | [conform-action action ] [exceed-action action ]

入力フロー ポリサーを作成します(出力ポリシーではサポートされません)。

ステップ 6

Router(config-pmap-c)# exit

クラスマップ コンフィギュレーション モードを終了します。

次に、ポリサーでポリシー マップを作成する例を示します。

Router(config)# policy-map ip2tag
Router(config-pmap)# class iptcp
Router(config-pmap-c)# no set mpls exp topmost 3
Router(config-pmap-c)# police 1000000 1000000 c set-mpls-exp?
set-mpls-exp-imposition-transmit
 
Router(config-pmap-c)# police 1000000 1000000 c set-mpls-exp-imposit 3 e d
Router(config-pmap-c)# exit
Router(config-pmap)# exit
Router(config)# interface fastethernet 3/27
Router(config-if)# ser in ip2tag
Router(config-if)#
 

次に、設定を確認する例を示します。

Router# show pol ip2tag
Policy Map ip2tag
Class iptcp
police cir 1000000 bc 1000000 be 1000000 conform-action set-mpls-exp-imposition-transmit 3 exceed-action drop
Router# show running-config interface fastethernet 3/27
Building configuration...
 
Current configuration : 202 bytes
!
interface FastEthernet3/27
logging event link-status
service-policy input ip2tag
end
 
Router# show mls qos ip
QoS Summary [IPv4]: (* - shared aggregates, Mod - switch module)
 
Int Mod Dir Class-map DSCP Agg Trust Fl AgForward-By AgPoliced-By
Id Id
-------------------------------------------------------------------------------
Fa3/27 5 In iptcp 24 2 No 0 0 0
Vl300 5 In x 44 1 No 0 0 0
 
All 5 - Default 0 0* No 0 3468105262 0
Router# show policy interface fastethernet 3/27
FastEthernet3/27
 
Service-policy input: ip2tag
 
class-map: iptcp (match-all)
Match: access-group 101
police :
1000000 bps 1000000 limit 1000000 extended limit
Earl in slot 5 :
0 bytes
5 minute offered rate 0 bps
aggregate-forwarded 0 bytes action: set-mpls-exp-imposition-transmit
exceeded 0 bytes action: drop
aggregate-forward 0 bps exceed 0 bps
 
class-map: class-default (match-any)
Match: any
 
Class-map: class-default (match-any)
0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: any
R7# show mls qos ip
QoS Summary [IPv4]: (* - shared aggregates, Mod - switch module)
 
Int Mod Dir Class-map DSCP Agg Trust Fl AgForward-By AgPoliced-By
Id Id
-------------------------------------------------------------------------------
Fa3/27 5 In iptcp 24 2 No 0 0 0
Vl300 5 In x 44 1 No 0 0 0
 
All 5 - Default 0 0* No 0 3468161522 0

制約事項および使用上の注意事項

police コマンドを使用してポリシー マップを設定する場合は、次の制約事項および注意事項が適用されます。

MPLS では、 exceed-action action コマンドと violate-action action コマンドは、IP を使用する場合と同様に動作します。パケットがドロップされるか、または EXP 値がマークダウンされます。これらのアクションが IP/IP トラフィックに与える影響については、「ポリシー マップの設定」を参照してください。

MPLS では、 set-dscp transmit action コマンドと set-prec-transmit action コマンドは、CoS ビットにマッピングされる内部 DSCP を設定します。内部 DSCP はキューイングに影響します。ただし、インポジション以外の EXP 値は変更されません。

PFC で受信 MPLS トラフィックのラベルをスワップする場合、 police コマンドの exceed-action policed-dscp-transmit および violate-action policed-dscp-transmit キーワードを使用して、プロファイル外トラフィックをマークダウンできます。PFC は、プロファイル内トラフィックをマーキングしません。プロファイル外トラフィックをマークダウンする場合、PFC3BXL または PFC3B は発信最上位ラベルをマーキングします。PFC は、ラベル スタック内でマークダウンを伝播しません。

MPLS では、フロー キーはラベルおよび EXP 値に基づきます。フローマスク オプションはありません。それ以外の場合、フロー キー操作は IP/IP と同様です。「ポリシー マップの設定」を参照してください。

police コマンドを使用すると、プッシュしたラベル エントリ値を、ラベル インポジション中のデフォルト値とは異なる値に設定できます。

PFC で受信 IP トラフィックにラベルをインポーズする場合、
conform-action set-mpls-exp-imposition-transmit キーワードを使用して、EXP フィールドをマーキングできます。

IP/MPLS インポジション中、IP ToS マーキングはサポートされません。IP ToS をマーキングするようにポリシーを設定すると、PFC は EXP 値をマーキングします。

ポリシー マップの表示

ポリシー マップの表示では、MPLS QoS クラスのインターフェイス サマリーを表示するか、または指定したインターフェイス上のサービス ポリシーすべてに対して設定された全クラスの設定を表示できます。

MPLS QoS ポリシー マップのクラス サマリーの表示

MPLS QoS ポリシー マップのクラス サマリーを表示するには、次の作業を行います。

 

コマンド
目的

Router# show mls qos mpls [{ interface interface_type interface_number } | {module slot }

MPLS QoS ポリシー マップのクラス サマリーを表示します。

次に、MPLS QoS ポリシー マップのクラス サマリーを表示する例を示します。

Router# show mls qos mpls
QoS Summary [MPLS]: (* - shared aggregates, Mod - switch module)
Int Mod Dir Class-map DSCP Agg Trust Fl AgForward-By AgPoliced-By
Id Id
-------------------------------------------------------------------------------
Fa3/27 5 In exp3 0 2 dscp 0 0 0
All 5 - Default 0 0* No 0 3466140423 0

すべてのクラスの設定の表示

指定したインターフェイス上のすべてのサービス ポリシーに対して設定された、すべてのクラスの設定を表示するには、次の作業を行います。

 

コマンド
目的

Router# show policy interface interface_type interface_number

指定したインターフェイス上のすべてのポリシー マップに設定された、すべてのクラスの設定を表示します。

次に、インターフェイス FastEthernet 3/27 の全クラスの設定を表示する例を示します。

Router# show policy interface fastethernet 3/27
FastEthernet3/27
 
Service-policy input: ip2tag
 
class-map: iptcp (match-all)
Match: access-group 101
police :
1000000 bps 1000000 limit 1000000 extended limit
Earl in slot 5 :
0 bytes
5 minute offered rate 0 bps
aggregate-forwarded 0 bytes action: set-mpls-exp-imposition-transmit
exceeded 0 bytes action: drop
aggregate-forward 0 bps exceed 0 bps
 
class-map: class-default (match-any)
Match: any
 
Class-map: class-default (match-any)
0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: any

MPLS QoS の出力 EXP 変換の設定

ここでは、MPLS QoS の出力 EXP 変換を設定する手順について説明します。

「名前付き EXP 変換マップの設定」

「インターフェイスへの出力 EXP 変換マップの付加」

名前付き EXP 変換マップの設定

名前付き EXP 変換マップを設定するには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# mls qos map exp-mutation name mutated_exp1 mutated_exp2 mutated_exp3 mutated_exp4 mutated_exp5 mutated_exp6 mutated_exp7 mutated_exp8

名前付き EXP 変換マップを設定します。

Router(config)# no mls qos map exp-mutation name

デフォルトのマッピングに戻します。

ステップ 2

Router(config)# end

コンフィギュレーション モードを終了します。

ステップ 3

Router# show mls qos maps

設定を確認します。

名前付き EXP 変換マップを設定する場合は、次の点に注意してください。

変換された EXP 値にマッピングする、最大 8 つの入力 EXP 値を入力できます。

複数のコマンドを入力して、変換された EXP 値に追加の EXP 値をマッピングできます。

変換された EXP 値ごとに個別のコマンドを入力できます。

内部 EXP 値が入力 EXP 値として書き込まれる前に、内部 EXP 値を変換する入力 EXP 変換マップを最大 15 個設定できます。入力 EXP 変換 マップは、PFC QoS がサポートする任意のインターフェイスに付加できます。

PFC QoS は、内部 DSCP 値に基づいて出力 EXP 値を作成します。入力 EXP 変換を設定する場合は、PFC QoS は変換した EXP 値から入力 EXP 値を作成しません。

インターフェイスへの出力 EXP 変換マップの付加

出力 EXP 変換マップをインターフェイスに付加するには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# interface {{ vlan vlan_ID } | { type 1 slot/port [. subinterface ]} | { port-channel number [. subinterface ]}}

設定するインターフェイスを選択します。

ステップ 2

Router(config-if)# mls qos exp-mutation exp-mutation-table-name

出力 EXP 変換マップをインターフェイスに付加します。

Router(config-if)# no mls qos exp-mutation

インターフェイスから出力 DSCP 変換マップを削除します。

ステップ 3

Router(config-if)# end

コンフィギュレーション モードを終了します。

ステップ 4

Router# show running-config interface {{ vlan vlan_ID } | { type slot/port } | { port-channel number }}

設定を確認します。

1.type = fastethernetgigabitethernet、または tengigabitethernet

次に、mutemap2 という名前の出力 EXP 変換マップを付加する例を示します。

Router(config)# interface fastethernet 3/26
Router(config-if)# mls qos exp-mutation mutemap2
Router(config-if)# end

EXP 値マッピングの設定

ここでは、EXP 値を他の値にマッピングする方法について説明します。

「入力 EXP/内部 DSCP マップの設定」

「名前付き出力 DSCP/出力 EXP マップの設定」

入力 EXP/内部 DSCP マップの設定

入力 EXP/内部 DSCP マップを設定するには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# mls qos map exp-dscp values

入力 EXP 値から内部 DSCP 値へのマッピングを設定します。EXP 値に対応する DSCP 値を 8 個入力する必要があります。有効値は 0 ~ 63 です。

Router(config)# no mls qos map exp-dscp

デフォルトのマッピングに戻します。

ステップ 2

Router(config)# end

コンフィギュレーション モードを終了します。

ステップ 3

Router# show mls qos maps

設定を確認します。

次に、入力 EXP/内部 DSCP マップを設定する例を示します。

Router(config)# mls qos map exp-dscp 43 43 43 43 43 43 43 43
Router(config)#
 

次に、設定を確認する例を示します。

Router(config)# show mls qos map exp-dscp
Exp-dscp map:
exp: 0 1 2 3 4 5 6 7
------------------------------------
dscp: 43 43 43 43 43 43 43 43

名前付き出力 DSCP/出力 EXP マップの設定

名前付き出力 DSCP/出力 EXP マップを設定するには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# mls qos map dscp-exp dscp_values to exp_values

名前付き出力 DSCP/出力 EXP マップを設定します。1 つの EXP 値には、一度に最大 8 個の DSCP 値を入力できます。有効値は 0 ~ 7 です。

Router(config)# no mls qos map dscp-exp

デフォルトのマッピングに戻します。

ステップ 2

Router(config)# end

コンフィギュレーション モードを終了します。

ステップ 3

Router# show mls qos maps

設定を確認します。

次に、名前付き出力 DSCP/出力 EXP マップを設定する例を示します。

Router(config)# mls qos map dscp-exp 20 25 to 3
Router(config)#

MPLS DiffServ トンネリング モード

トンネリングでは、ネットワークの一方のエッジから他方のエッジまで、QoS を透過的にすることができます。トンネルは、ラベルがインポーズされたところから開始します。トンネルは、ラベルがディスポーズされたところで終了します。つまり、ここではラベルがスタックから取り外され、パケットは下位に位置する別の PHB レイヤでの MPLS パケットとして、または IP PHB レイヤでの IP パケットとして出力されます。

PFC の場合、ネットワーク上でのパケットの転送方法は 2 つあります。

Short Pipe モード -- Short Pipe モードでは、出力 PE ルータは中間プロバイダー(P)ルータによるマーキングではなく、元のパケット マーキングを使用します。EXP マーキングは、パケット ToS バイトに伝播しません。

このモードの詳細については、「Short Pipe モード」を参照してください。

設定の詳細については、「Short Pipe モードの設定」を参照してください。

Uniform モード -- Uniform モードでは、IP パケットのマーキングを操作して、サービス プロバイダーの QoS マーキングをコアに反映できます。このモードでは、CE ルータやコア ルータを含め、ネットワーク全体で一貫した QoS 分類およびマーキングを実行できます。EXP マーキングは基本 ToS バイトに伝播されます。

詳細については、「Uniform モード」を参照してください。

設定手順の詳細については、「Uniform モードの設定」を参照してください。

いずれのトンネリング モードも、エッジ LSR および直前 LSR の動作に影響します。ここではラベルのパケットへの付加、およびパケットからの削除が行われます。これらのモードは、中間ルータでのラベル スワップには影響しません。サービス プロバイダーは、カスタマーごとに異なるタイプのトンネリング モードを選択できます。

詳細については、次の URL で「MPLS DiffServ Tunneling Modes」を参照してください。
http://www.cisco.com/en/US/products/sw/iosswrel/ps1839/products_feature_guide09186a0080110bd5.html

Short Pipe モード

Short Pipe モードは、カスタマーとサービス プロバイダーの DiffServ ドメインが異なる場合に使用します。これにより、サービス プロバイダーは独自の DiffServ ポリシーを実行しつつ、カスタマーの DiffServ 情報を保存できます。この結果、サービス プロバイダー ネットワーク全体において、DiffServ の透過性を維持できます。

コアで実装された QoS ポリシーは、パケットの ToS バイトに伝播しません。MPLS EXP 値に基づいた分類は、カスタマー方向の出力 PE インターフェイスで終了します。カスタマー方向の出力 PE インターフェイスでの分類は、MPLS ヘッダーではなく、元の IP パケット ヘッダーに基づきます。


) 出力 IP ポリシー(プロバイダーの PHB マーキングではなく、カスタマーの PHB マーキングに基づく)が存在する場合は、自動的に Short Pipe モードであることを意味します。


図38-2 VPN での Short Pipe モードの動作

 

Short Pipe モードは次のように機能します。

1. CE1 は IP パケットを、IP DSCP 値 1 の PE1 に送信します。

2. PE1 は MPLS EXP フィールドをインポーズ ラベル エントリの 5 に設定します。

3. PE1 はパケットを P1 に送信します。

4. P1 は MPLS EXP フィールド値をスワップ ラベル エントリの 5 に設定します。

5. P1 はパケットを P2 に送信します。

6. P2 は IGP ラベル エントリをポップします。

7. P2 はパケットを PE2 に送信します。

8. PE2 は BGP ラベルをポップします。

9. PE2 はパケットを CE2 に送信しますが、IP DSCP 値に基づいて QoS を送信しません。

詳細については、次の URL で「MPLS DiffServ Tunneling Modes」を参照してください。

http://www.cisco.com/en/US/products/sw/iosswrel/ps1839/products_feature_guide09186a0080110bd5.html

Short Pipe モードの制約事項および注意事項

次の制約事項が Short Pipe モードに適用されます。

MPLS/IP 出力インターフェイスが EoMPLS である(隣接に End Of Marker [EoM] ビットが設定されている)場合、Short Pipe モードはサポートされません。

Uniform モード

Uniform モードでは、パケットは IP および MPLS ネットワークで均一に処理されます。つまり、IP precedence 値および MPLS EXP ビットは、常に同じ PHB に対応します。ルータがパケットの PHB を変更またはリカラーするつど、その変更は、カプセル化のマーキングすべてに伝播される必要があります。ルータによる伝播が行われるのは、パケットのパス上にあるいずれかのルータでラベルのインポジションまたはディスポジションが行われたため、PHB が追加またはエクスポーズされた場合のみです。カラーは、全レベルのあらゆる場所に反映する必要があります。たとえば、パケットの QoS マーキングが MPLS ネットワークで変更された場合、IP QoS マーキングはその変更を反映します。

図38-3 Uniform モードでの操作

 

このアクションは、IP precedence ビット マーキングまたは DSCP マーキングのどちらが存在するかによって異なります。

IP precedence ビット マーキングが存在する場合は、次のアクションが行われます。

1. IP パケットが、MPLS ネットワーク内の PE1(サービス プロバイダーのエッジ ルータ)に着信します。

2. ラベルがパケットにコピーされます。

3. MPLS EXP フィールド値がリカラーされる場合は(送信されるパケット数が多すぎたためにパケットがレート超過になる場合など)、その値が IGP ラベルにコピーされます。BGP ラベル値は変更されません。

4. 直前ホップでは、IGP ラベルは削除されます。この値は、次に低いレベルのラベルにコピーされます。

5. すべての MPLS ラベルが IP パケットとして送信されるパケットから削除されると、IP precedence 値または DSCP 値は、コアで最後に変更された EXP 値に設定されます。

次に、IP precedence ビット マーキングが存在する場合の例を示します。

1. CE1(カスタマー装置 1)では、IP パケットの IP precedence 値が 3 となっています。

2. パケットが MPLS ネットワーク内の PE1(サービス プロバイダーのエッジ ルータ)に着信すると、パケットにインポーズされたラベル エントリに IP precedence 値 3 がコピーされます。

3. IGP ラベル ヘッダーの MPLS EXP フィールドは、マークダウンすることで MPLS コア内(P1 など)で変更できます。


) IP precedence ビットが 3 であり、Uniform モードではラベルが常に同じなので、BGP ラベルおよび IGP ラベルの値も 3 となります。パケットは IP および MPLS ネットワークで均一に処理されます。


Uniform モードの制約事項および注意事項

次の制約事項は Uniform モードに適用されます。

出力 IP ACL またはサービス ポリシーが MPLS/IP 終了ポイントで設定されている場合、Uniform モードは再循環されるので常に実行されます。

MPLS DiffServ トンネリングの制限事項および使用上の注意事項

MPLS DiffServ トンネリングの 制限事項および使用上の注意事項は次のとおりです。

MPLS EXP フィールドは 3 ビット フィールドなので、1 個の LSP では、最大 8 個のトラフィック クラス(つまり 8 個の PHB)をサポートできます。

MPLS DiffServ トンネリング モードは E-LSP をサポートします。E-LSP は、ノードが MPLS ヘッダーの EXP ビットからのみ、MPLS パケットに対する QoS 処理を決定する LSP です。

次の機能は、MPLS DiffServ トンネリング モードでサポートされます。

MPLS PHB レイヤ管理(レイヤ管理は、パケットにマーキングする PHB のレイヤを追加する機能です)

管理 CE ルータ上での制御による、MPLS レイヤ管理の向上したスケーラビリティ

MPLS がパケットの QoS をトンネリング可能(すなわち、QoS がエッジからエッジまで透過的)。QoS の透過性では、IP パケットの IP マーキングは MPLS ネットワーク上で保持されます。

MPLS EXP フィールドは、IP precedence フィールドまたは DSCP フィールドでマーキングされた PHB とは別々にマーキングされます。

Short Pipe モードの設定

ここでは、Short Pipe モードの設定方法について説明します。

「入力 PE ルータ--カスタマー方向インターフェイス」

「入力 PE ルータの設定-- P 方向インターフェイス」

「P ルータの設定--出力インターフェイス」

「出力 PE ルータの設定--カスタマー方向インターフェイス」


) • 次のステップは、Short Pipe モードを設定する方法を示しますが、これが唯一の方法ではありません。

IP クラスを含んだ出力サービス ポリシーをインターフェイスに付加する場合、出力 PE(または PHP)の Short Pipe モードは自動設定されます。


 

入力 PE ルータ--カスタマー方向インターフェイス

この手順では、MPLS EXP フィールドをインポーズ ラベル エントリに設定するようポリシー マップを設定します。

EXP 値を設定するには、入力 LAN が信頼不可(untrusted)である必要があります。FlexWAN ポートには信頼性の概念がありませんが、従来の Cisco IOS ルータと同様、入力 ToS は変更されません(マーキング ポリシーが設定されていないかぎり)。

MPLS および VPN では、入力 PE はすべての入力 PFC IP ポリシーをサポートします。
IP ACL/DSCP/precedence に基づいた PFC IP ポリシーの分類の詳細については、次の URL を参照してください。 http://www.cisco.com/univercd/cc/td/doc/product/core/cis7600/software/122sx/swcg/qos.htm

MPLS EXP フィールドをインポーズ ラベル エントリに設定するようにポリシー マップを設定するには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# mls qos

PFC QoS をグローバルにイネーブルにします。

ステップ 2

Router(config)# access-list ipv4_acl_number_or_name permit any

IPv4 アクセス リストを作成します。

ステップ 3

Router(config)# class-map class_name

クラス マップを作成します。

ステップ 4

Router(config-cmap)# match access-group ipv4_acl_number_or_name

ステップ 2 で作成した ACL に基づくフィルタリングを行うように、クラス マップを設定します。

ステップ 5

Router(config)# policy-map policy_map_name

名前付き QoS ポリシーを作成します。

ステップ 6

Router(config-pmap)# class class_name

ステップ 3 で作成したクラス マップを使用するように、ポリシーを設定します。

ステップ 7

Router(config-pmap-c)# police bits_per_second [ normal_burst_bytes ] conform-action set-mpls-exp-transmit exp_value exceed-action drop

ポリシングを設定します。ここでは、次を設定します。

Service Level Agreement(SLA; サービス レベル契約)で指定されたレート制限に準拠するパケットに対して実行するアクション。

SLA で指定されたレート制限を超えるパケットに対して実行するアクション。

exp_value は、MPLS EXP フィールドを設定します。

ステップ 8

Router(config)# interface type slot/port

設定するインターフェイスを選択します。

ステップ 9

Router(config-if)# no mls qos trust

インターフェイスを untrusted として設定します。

ステップ 10

Router(config-if)# service-policy input policy_map_name

ステップ 5 で作成したポリシー マップを、入力サービス ポリシーとしてインターフェイスに付加します。

設定例

次に、MPLS EXP フィールドをインポーズ ラベル エントリに設定するようポリシー マップを設定する例を示します。

Router(config)# mls qos
Router(config)# access-list 1 permit any
Router(config)# class-map CUSTOMER-A
Router(config-cmap)# match access-group 1
Router(config)# policy-map set-MPLS-PHB
Router(config-pmap)# class CUSTOMER-A
Router(config-pmap-c)# police 50000000 conform-action set-mpls-exp-transmit 4 exceed-action drop
Router(config)# interface GE-WAN 3/1
Router(config-if)# no mls qos trust
Router(config)# interface GE-WAN 3/1.31
Router(config-if)# service-policy input set-MPLS-PHB

入力 PE ルータの設定-- P 方向インターフェイス

この手順では、MPLS EXP フィールドに基づいてパケットを分類し、適切な廃棄処理およびスケジューリング処理を行います。


) ここで示す QoS 機能は、FlexWAN、拡張 FlexWAN モジュールでのみ利用できます。


MPLS EXP フィールドに基づいてパケットを分類し、適切な廃棄処理およびスケジューリング処理を行うには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# mls qos

PFC QoS をグローバルにイネーブルにします。

ステップ 2

Router(config)# class-map class_name

パケットがマッピングされる(パケットと一致する)クラス マップを指定します。トラフィック クラスを作成します。

ステップ 3

Router(config-c-map)# match mpls experimental exp_list

パケットがクラスに属するかを判別するための照合で一致基準として使用される、MPLS EXP フィールド値を指定します。

ステップ 4

Router(config)# policy-map name

クラスと一致するパケットに QoS ポリシーを設定します。

ステップ 5

Router(config-p-map)# class class_name

トラフィック クラスとサービス ポリシーを関連付けます。

ステップ 6

Router(config-p-map-c)# bandwidth { bandwidth_kbps | percent percent }

トラフィック クラスに対する最小帯域幅保証を指定します。最小帯域幅保証は、kbps 単位または帯域幅全体の割合で指定できます。

ステップ 7

Router(config-p-map)# class class-default

ポリシーを設定または変更できるようにデフォルト クラスを指定します。

ステップ 8

Router(config-p-map-c)# random-detect

帯域幅保証のあるトラフィック クラスに対し、WRED ドロップ ポリシーをイネーブルにします。

ステップ 9

Router(config)# interface type slot/port

設定するインターフェイスを選択します。

ステップ 10

Router(config-if)# service-policy output name

QoS ポリシーをインターフェイスに付加し、インターフェイスから送信されるパケット上に適用するポリシーを指定します。


bandwidth コマンドおよび random-detect コマンドは、LAN ポートではサポートされません。


設定例

次に、MPLS EXP フィールドに基づいてパケットを分類し、適切な廃棄処理およびスケジューリング処理を行う例を示します。

Router(config)# mls qos
Router(config)# class-map MPLS-EXP-4
Router(config-c-map)# match mpls experimental 4
Router(config)# policy-map output-qos
Router(config-p-map)# class MPLS-EXP-4
Router(config-p-map-c)# bandwidth percent 40
Router(config-p-map)# class class-default
Router(config-p-map-c)# random-detect
Router(config)# interface pos 4/1
Router(config-if)# service-policy output output-qos

P ルータの設定--出力インターフェイス


) ここで示す QoS 機能は、FlexWAN、拡張 FlexWAN モジュールでのみ利用できます。


MPLS EXP フィールドに基づいてパケットを分類し、適切な廃棄処理およびスケジューリング処理を行うには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# mls qos

PFC QoS をグローバルにイネーブルにします。

ステップ 2

Router(config)# class-map class_name

パケットがマッピングされる(パケットと一致する)クラス マップを指定します。トラフィック クラスを作成します。

ステップ 3

Router(config-c-map)# match mpls experimental exp_list

パケットがクラスに属するかを判別するための照合で一致基準として使用される、MPLS EXP フィールド値を指定します。

ステップ 4

Router(config)# policy-map name

クラスと一致するパケットに QoS ポリシーを設定します。

ステップ 5

Router(config-p-map)# class class_name

トラフィック クラスとサービス ポリシーを関連付けます。

ステップ 6

Router(config-p-map-c)# bandwidth { bandwidth_kbps | percent percent }

トラフィック クラスに対する最小帯域幅保証を指定します。最小帯域幅保証は、kbps 単位または帯域幅全体の割合で指定できます。

ステップ 7

Router(config-p-map)# class class-default

ポリシーを設定または変更できるようにデフォルト クラスを指定します。

ステップ 8

Router(config-p-map-c)# random-detect

IP precedence または MPLS EXP フィールド値に基づいて、WRED をポリシーに適用します。

ステップ 9

Router(config)# interface type slot/port

設定するインターフェイスを選択します。

ステップ 10

Router(config-if)# service-policy output name

QoS ポリシーをインターフェイスに付加し、インターフェイスから送信されるパケット上に適用するポリシーを指定します。


bandwidth コマンドおよび random-detect コマンドは、LAN ポートではサポートされません。


設定例

次に、MPLS EXP フィールドに基づいてパケットを分類し、適切な廃棄処理およびスケジューリング処理を行う例を示します。

Router(config)# mls qos
Router(config)# class-map MPLS-EXP-4
Router(config-c-map)# match mpls experimental 4
Router(config)# policy-map output-qos
Router(config-p-map)# class MPLS-EXP-4
Router(config-p-map-c)# bandwidth percent 40
Router(config-p-map)# class class-default
Router(config-p-map-c)# random-detect
Router(config)# interface pos 2/1
Router(config-if)# service-policy output output-qos

出力 PE ルータの設定--カスタマー方向インターフェイス


) ここで示す QoS 機能は、FlexWAN、拡張 FlexWAN モジュールでのみ利用できます。


IP DSCP 値に基づいてパケットを分類し、適切な廃棄処理およびスケジューリング処理を行うには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# mls qos

PFC QoS をグローバルにイネーブルにします。

ステップ 2

Router(config)# class-map class_name

パケットがマッピングされる(パケットと一致する)クラス マップを指定します。トラフィック クラスを作成します。

ステップ 3

Router(config-c-map)# match ip dscp dscp_values

DSCP 値を一致基準として使用します。

ステップ 4

Router(config)# policy-map name

クラスと一致するパケットに QoS ポリシーを設定します。

ステップ 5

Router(config-p-map)# class class_name

トラフィック クラスとサービス ポリシーを関連付けます。

ステップ 6

Router(config-p-map-c)# bandwidth { bandwidth_kbps | percent percent }

トラフィック クラスに対する最小帯域幅保証を指定します。最小帯域幅保証は、kbps 単位または帯域幅全体の割合で指定できます。

ステップ 7

Router(config-p-map)# class class-default

ポリシーを設定または変更できるようにデフォルト クラスを指定します。

ステップ 8

Router(config-p-map-c)# random-detect dscp-based

帯域幅保証のあるトラフィック クラスに対し、WRED ドロップ ポリシーをイネーブルにします。

ステップ 9

Router(config)# interface type slot/port

設定するインターフェイスを選択します。

ステップ 10

Router(config-if)# service-policy output name

QoS ポリシーをインターフェイスに付加し、インターフェイスから送信されるパケット上に適用するポリシーを指定します。


bandwidth コマンドおよび random-detect コマンドは、LAN ポートではサポートされません。


設定例

次に、IP DSCP 値に基づいてパケットを分類し、適切な廃棄処理およびスケジューリング処理を行う例を示します。

Router(config)# mls qos
Router(config)# class-map IP-PREC-4
Router(config-c-map)# match ip precedence 4
Router(config)# policy-map output-qos
Router(config-p-map)# class IP-PREC-4
Router(config-p-map-c)# bandwidth percent 40
Router(config-p-map)# class class-default
Router(config-p-map-c)# random-detect
Router(config)# interface GE-WAN 3/2.32
Router(config-if)# service-policy output output-qos

Uniform モードの設定

ここでは、次を設定する手順について説明します。

「入力 PE ルータの設定--カスタマー方向インターフェイス」

「入力 PE ルータの設定-- P 方向インターフェイス」

「出力 PE ルータの設定--カスタマー方向インターフェイス」


) 次のステップは、Uniform モードを設定する方法を示しますが、これが唯一の方法ではありません。


入力 PE ルータの設定--カスタマー方向インターフェイス

Uniform モードで、IP precedence または IP DSCP に信頼状態を設定すると、PFC は IP PHB を MPLS PHB にコピーできます。


) この説明は、LAN ポートの PFC に適用されます。FlexWAN および拡張 FlexWAN QoS の詳細については、次の URL で『FlexWAN and Enhanced FlexWAN Modules Installation and Configuration Guide』を参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/core/cis7600/cfgnotes/flexport/combo/index.htm


 

MPLS EXP フィールドをインポーズ ラベル エントリに設定するようポリシー マップを設定するには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# mls qos

PFC QoS をグローバルにイネーブルにします。

ステップ 2

Router(config)# access-list ipv4_acl_number_or_name permit any

IPv4 アクセス リストを作成します。

ステップ 3

Router(config)# class-map class_name

クラス マップを作成します。

ステップ 4

Router(config-cmap)# match access-group ipv4_acl_number_or_name

ステップ 2 で作成した ACL に基づくフィルタリングを行うように、クラス マップを設定します。

ステップ 5

Router(config)# policy-map policy_map_name

名前付き QoS ポリシーを作成します。

ステップ 6

Router(config-pmap)# class class_name

ステップ 3 で作成したクラス マップを使用するように、ポリシーを設定します。

ステップ 7

Router(config-pmap-c)# police bits_per_second [normal_burst_bytes] conform-action transmit exceed-action drop

ポリシングを設定します。ここでは、次を設定します。

SLA で指定されたレート制限に準拠するパケットに対して実行するアクション。

SLA で指定されたレート制限を超えるパケットに対して実行するアクション。

ステップ 8

Router(config)# interface type slot/port

設定するインターフェイスを選択します。

ステップ 9

Router(config-if)# mls qos trust dscp

受信した DSCP を、全ポートの入力トラフィックに対する内部 DSCP 基準値として設定します。

ステップ 10

Router(config-if)# service-policy input policy_map_name

ステップ 5 で作成したポリシー マップを、入力サービス ポリシーとしてインターフェイスに付加します。

設定例

次に、MPLS EXP フィールドをインポーズ ラベル エントリに設定するようポリシー マップを設定する例を示します。

Router(config)# mls qos
Router(config)# access-list 1 permit any
Router(config)# class-map CUSTOMER-A
Router(config-cmap)# match access-group 1
Router(config)# policy-map SLA-A
Router(config-pmap)# class CUSTOMER-A
Router(config-pmap-c)# police 50000000 conform-action transmit exceed-action drop
Router(config)# interface GE-WAN 3/1
Router(config-if)# mls qos trust dscp
Router(config)# interface GE-WAN 3/1.31
Router(config-if)# service-policy input SLA-A

入力 PE ルータの設定-- P 方向インターフェイス

MPLS EXP フィールドに基づいてパケットを分類し、適切な廃棄処理およびスケジューリング処理を行うには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# mls qos

PFC QoS をグローバルにイネーブルにします。

ステップ 2

Router(config)# class-map class_name

パケットがマッピングされる(パケットと一致する)クラス マップを指定します。トラフィック クラスを作成します。

ステップ 3

Router(config-c-map)# match mpls experimental exp_list

パケットがクラスに属するかを判別するための照合で一致基準として使用される、MPLS EXP フィールド値を指定します。

ステップ 4

Router(config)# policy-map name

クラスと一致するパケットに QoS ポリシーを設定します。

ステップ 5

Router(config-p-map)# class class_name

トラフィック クラスとサービス ポリシーを関連付けます。

ステップ 6

Router(config-p-map-c)# bandwidth { bandwidth_kbps | percent percent }

トラフィック クラスに対する最小帯域幅保証を指定します。最小帯域幅保証は、kbps 単位または帯域幅全体の割合で指定できます。

ステップ 7

Router(config-p-map)# class class-default

ポリシーを設定または変更できるようにデフォルト クラスを指定します。

ステップ 8

Router(config-p-map-c)# random-detect

帯域幅保証のあるトラフィック クラスに対し、WRED ドロップ ポリシーをイネーブルにします。

ステップ 9

Router(config)# interface type slot/port

設定するインターフェイスを選択します。

ステップ 10

Router(config-if)# service-policy output name

QoS ポリシーをインターフェイスに付加し、インターフェイスから送信されるパケット上に適用するポリシーを指定します。


bandwidth コマンドおよび random-detect コマンドは、LAN ポートではサポートされません。


設定例

次に、MPLS EXP フィールドに基づいてパケットを分類し、適切な廃棄処理およびスケジューリング処理を行う例を示します。

Router(config)# mls qos
Router(config)# class-map MPLS-EXP-3
Router(config-c-map)# match mpls experimental 3
Router(config)# policy-map output-qos
Router(config-p-map)# class MPLS-EXP-3
Router(config-p-map-c)# bandwidth percent 40
Router(config-p-map)# class class-default
Router(config-p-map-c)# random-detect
Router(config)# interface pos 4/1
Router(config-if)# service-policy output output-qos

出力 PE ルータの設定--カスタマー方向インターフェイス

カスタマー方向インターフェイスで出力 PE ルータを設定するには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# mls qos

PFC QoS をグローバルにイネーブルにします。

ステップ 2

Router(config)# class-map class_name

パケットがマッピングされる(パケットと一致する)クラス マップを指定します。トラフィック クラスを作成します。

ステップ 3

Router(config-c-map)# match ip precedence precedence-value

IP precedence 値を一致基準として確認します。

ステップ 4

Router(config)# policy-map name

クラスと一致するパケットに QoS ポリシーを設定します。

ステップ 5

Router(config-p-map)# class class_name

トラフィック クラスとサービス ポリシーを関連付けます。

ステップ 6

Router(config-p-map-c)# bandwidth { bandwidth_kbps | percent percent }

トラフィック クラスに対する最小帯域幅保証を指定します。最小帯域幅保証は、kbps 単位または帯域幅全体の割合で指定できます。

ステップ 7

Router(config-p-map)# class class-default

ポリシーを設定または変更できるようにデフォルト クラスを指定します。

ステップ 8

Router(config-p-map-c)# random-detect

IP precedence または MPLS EXP フィールド値に基づいて、WRED をポリシーに適用します。

ステップ 9

Router(config)# interface type slot / port

設定するインターフェイスを選択します。

ステップ 10

Router(config-if) mpls propagate-cos

MPLS ドメイン終了 LER 出力ポートで、基本 IP DSCP への EXP 値の伝播機能をイネーブルにします。

ステップ 11

Router(config-if)# service-policy output name

QoS ポリシーをインターフェイスに付加し、インターフェイスに着信するパケットに適用するポリシーを指定します。


bandwidth コマンドおよび random-detect コマンドは、LAN ポートではサポートされません。


設定例

次に、カスタマー方向インターフェイスで出力 PE ルータを設定する例を示します。

Router(config)# mls qos
Router(config)# class-map IP-PREC-4
Router(config-c-map)# match ip precedence 4
Router(config)# policy-map output-qos
Router(config-p-map)# class IP-PREC-4
Router(config-p-map-c)# bandwidth percent 40
Router(config-p-map)# class class-default
Router(config-p-map-c)# random-detect
Router(config)# interface GE-WAN 3/2.32
Router(config-if) mpls propagate-cos
Router(config-if)# service-policy output output-qos