Catalyst 6500 Release 12.2SXH and Later Software コンフィギュレーション ガイド
WCCP による Web キャッシュ サービ スの設定
WCCP による Web キャッシュ サービスの設定
発行日;2012/02/05 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 12MB) | フィードバック

目次

WCCP による Web キャッシュ サービスの設定

WCCP の概要

WCCP の概要

ハードウェアの加速化

WCCPv1 設定の概要

WCCPv2 設定の概要

WCCPv2 の機能

非 HTTP サービスのサポート

複数ルータのサポート

MD5 セキュリティ

Web キャッシュ パケットのリターン

負荷分散

WCCPv2 の制約事項

WCCP の設定

WCCP のバージョンの指定

WCCPv2 によるサービス グループの設定

Web キャッシュ サービスの指定

特定インターフェイスにおけるリダイレクションからのトラフィックの除外

マルチキャスト アドレスへのルータの登録

WCCP サービス グループのアクセス リストの使用

ルータおよびキャッシュ エンジンのパスワードの設定

WCCP 設定の確認およびモニタリング

WCCP の設定例

ルータでの WCCP バージョンの変更例

一般的な WCCPv2 設定の実行例

Web キャッシュ サービスの実行例

リバース プロキシ サービスの実行例

マルチキャスト アドレスへのルータの登録例

アクセス リストの使用例

ルータおよびキャッシュ エンジンのパスワード設定例

WCCP 設定の確認例

WCCP による Web キャッシュ サービスの設定

この章では、Web Cache Communication Protocol(WCCP)を使用して、キャッシュ エンジン(Web キャッシュ)へトラフィックをリダイレクトするように スイッチを設定する方法、およびキャッシュ エンジン クラスタ(キャッシュ ファーム)を管理する方法について説明します。


) • この章で使用しているコマンドの構文および使用方法の詳細については、次の URL の『Cisco IOS Software Releases 12.2SX Command References』を参照してください。

http://www.cisco.com/en/US/docs/ios/mcl/122sxmcl/12_2sx_mcl_book.html

WCCP レイヤ 2 PFC リダイレクション機能を使用するには、この章の説明に従って スイッチ で WCCP を設定し、次のマニュアルに従ってキャッシュ エンジンに加速 WCCP を設定します。

http://www.cisco.com/univercd/cc/td/doc/product/webscale/uce/acns42/cnfg42/transprt.htm#xtocid34

Release 4.2.2 以降の Cisco Application and Content Networking System(ACNS)ソフトウェア リリースでは、PFC で ip wccp service accelerated コマンドをサポートします。

マスク割り当て用に設定したキャッシュ エンジンがファームへの加入を試みる場合、このファームで選択された割り当て方式がハッシュであると、キャッシュ エンジンの割り当て方式が既存ファームの方式と一致しないかぎり、ファームには加入できません。

サービス グループの転送方式が WCCP レイヤ 2 PFC リダイレクションの場合は、 show ip wccp service_name コマンドによって出力されるパケット カウンタ値は、パケット数ではなくフロー数となります。


 

この章で説明する内容は、次のとおりです。

「WCCP の概要」

「WCCPv2 の制約事項」

「WCCP の設定」

「WCCP 設定の確認およびモニタリング」

「WCCP の設定例」


) この章の作業では、ネットワークですでにキャッシュ エンジンを設定していることを前提とします。Cisco Cache Engine および WCCP に関するハードウェアおよびネットワーク プランニングの詳細については、次の URL の Cisco.com Web Scaling サイトにある「Product Literature and
Documentation」リンクを参照してください。
http://www.cisco.com/warp/public/cc/pd/cxsr/ces/index.shtml


WCCP の概要

ここでは WCCP について説明します。

「WCCP の概要」

「ハードウェアの加速化」

「WCCPv1 設定の概要」

「WCCPv2 設定の概要」

「WCCPv2 の機能」

WCCP の概要

WCCP はシスコが開発したコンテンツ ルーティング技術で、キャッシュ エンジン(Cisco Cache Engine 550 など)をネットワーク インフラストラクチャに統合できます。


) シスコシステムズは 2001 年 7 月、Cache Engine 500 シリーズ プラットフォームを Content Engine プラットフォームに置き換えました。Cache Engine 製品は、Cache Engine 505、550、570、および 550-DS3 です。Content Engine 製品には、Content Engine 507、560、590、および 7320 があります。


Cisco IOS WCCP 機能では、Cisco Cache Engine(または WCCP で動作する他のキャッシュ エンジン)を使用してネットワークの Web トラフィック パターンをローカライズし、コンテンツ要求にローカルで対応できるようにします。トラフィックのローカライズによって伝送コストを引き下げ、ダウンロード時間を短縮できます。

WCCP によって、Cisco IOS ルーティング プラットフォームはコンテンツ要求を透過的にリダイレクトできます。透過的なリダイレクションの大きな利点は、Web プロキシを使用するためのブラウザの設定が不要ということです。代わりに、ターゲット URL を使用してコンテンツを要求すると、要求が自動的にキャッシュ エンジンにリダイレクトされます。この場合の「透過的」という用語は、要求対象のファイル(Web ページなど)が初めに指定したサーバからではなく、キャッシュ エンジンから送られてきたことがエンド ユーザにはわからないことを指します。

キャッシュ エンジンは要求を受け取ると、専用のローカル キャッシュから対応しようとします。要求された情報が存在しない場合、キャッシュ エンジンは自身の要求を元のターゲット サーバに送信して要求された情報を取得します。要求された情報をキャッシュ エンジンが取得すると、要求元のクライアントに転送し、またキャッシュして今後の要求に備えます。これにより、ダウンロード パフォーマンスが最大になり、伝送コストを大幅に削減できます。

WCCP では、キャッシュ エンジン クラスタと呼ばれる一連のキャッシュ エンジンがイネーブルになり、1 つまたは複数のルータにコンテンツを提供します。ネットワーク管理者は、キャッシュ エンジンを簡単に拡張し、クラスタの機能を利用して大量のトラフィック ロードを処理できます。シスコ クラスタリング テクノロジーではキャッシュ メンバーがパラレルに稼働でき、リニア スケーラビリティが得られます。キャッシュ エンジンをクラスタリングすると、キャッシング ソリューションのスケーラビリティ、冗長性、およびアベイラビリティが大幅に向上します。目的の容量に応じて、最大 32 のキャッシュ エンジンをクラスタリングできます。

ハードウェアの加速化

Cisco IOS Software Release 12.2SX でサポートされるスイッチは、Cisco Cache Engine に直接接続されている場合、WCCP レイヤ 2 PFC リダイレクションによってハードウェアを加速化します。これは、Generic Routing Encapsulation(GRE; 総称ルーティング カプセル化)を備えた Route Processor(RP; ルート プロセッサ)での、ソフトウェアによるレイヤ 3 リダイレクションより効率的です。

WCCP レイヤ 2 PFC リダイレクションでは、Cisco Cache Engine はハードウェアでサポートされているレイヤ 2 リダイレクションを使用できます。直接接続された Cache Engine を設定すると、WCCP レイヤ 2 PFC リダイレクション機能の使用をネゴシエートできます。WCCP レイヤ 2 PFC リダイレクション機能は RP 上で設定する必要がありません。 show ip wccp web-cache detail コマンドを実行すると、使用されているリダイレクション方法がキャッシュ別に表示されます。

WCCP レイヤ 2 PFC リダイレクションについては、次の注意事項があります。

WCCP レイヤ 2 PFC リダイレクション機能では、IP フロー マスクが full-flow モードに設定されます。

Cisco Cache Engine ソフトウェア リリース 2.2 以降を設定すると、WCCP レイヤ 2 PFC リダイレクション機能を使用できます。

レイヤ 2 リダイレクションは PFC で実行され、RP には認識されません。RP で show ip wccp web-cache detail コマンドを実行すると、レイヤ 2 リダイレクションが行われたフローの 1 番めのパケットのみの統計情報が表示されます。これにより、パケットではなく、いくつのフローがレイヤ 2 リダイレクションを使用しているかがわかります。 show mls entries コマンドを入力すると、レイヤ 2 リダイレクションの他のパケットも表示されます。


) • PFC3 は、GRE 用にハードウェアを加速します。GRE で WCCP レイヤ 3 リダイレクションを使用すると、カプセル化がハードウェアによってサポートされますが、WCCP GRE トラフィックのカプセル開放では PFC3 によるハードウェア サポートは行われません。

Release 4.2.1 以降の ACNS ソフトウェア リリースでは、 accelerated キーワードがサポートされます。


 

WCCPv1 設定の概要

WCCP-Version 1 の場合、1 つのルータのみがクラスタに対応します。このシナリオの場合、このルータがすべての IP パケットのリダイレクションを行う装置です。図28-1 は、この構成図を示します。

図28-1 WCCP-Version 1 による Cisco Cache Engine ネットワークの設定

 

コンテンツは、キャッシュ エンジンでは複製されません。複数のキャッシュを使用する利点は、複数の物理キャッシュを 1 つの論理キャッシュとしてクラスタリングすることによってキャッシング ソリューションを拡張できることです。

WCCPv1 設定の機能の詳細を次の一連のイベントで示します。

1. 各キャッシュ エンジンは、システム管理者が制御ルータの IP アドレスを使用して設定します。1 つの制御ルータには最大 32 のキャッシュ エンジンを接続できます。

2. キャッシュ エンジンは、WCCP で自身の存在を示して IP アドレスを制御ルータに送信します。ルータおよびキャッシュ エンジンは、UDP ポート 2048 に基づいた制御チャネルを通して相互に通信します。

3. 制御ルータではこの情報が使用されて、クラスタ ビュー(クラスタ内のキャッシュの一覧)が作成されます。このビューはクラスタ内の各キャッシュに送信され、基本的にすべてのキャッシュ エンジンが相互の存在を認識できるようになります。クラスタのメンバシップが一定時間変わらないと、安定したビューが確立されます。

4. 安定したビューが確立されると、1 つのキャッシュ エンジンがリード キャッシュ エンジンに選択されます(このリード キャッシュ エンジンはクラスタ内のすべてのキャッシュ エンジンから IP アドレスが一番小さいとみなされます)。このリード キャッシュ エンジンは WCCP を使用して、IP パケット リダイレクションの実行の仕組みを制御ルータに示します。特にリード キャッシュ エンジンは、リダイレクトされたトラフィックをクラスタ内のキャッシュ エンジンに分配する方法を指定します。

WCCPv2 設定の概要

複数のルータは、キャッシュ クラスタに対応するために WCCPv2 を使用します。これは、1 つのルータのみがコンテンツ要求をクラスタにリダイレクトできる WCCPv1 とは対照的です。 図28-2 は、複数のルータを使用した構成例を示します。

図28-2 WCCPv2 による Cisco Cache Engine ネットワークの設定

 

同じサービスを実行するクラスタに接続されているクラスタ内のキャッシュ エンジンのサブセットおよびルータをサービス グループと呼びます。利用可能なサービスには、TCP および UDP リダイレクションがあります。

WCCPv1 を使用して、1 つのルータのアドレスでキャッシュ エンジンが設定されます。WCCPv2 では、各キャッシュ エンジンがサービス グループ内のすべてのルータを認識する必要があります。サービス グループ内のすべてのルータのアドレスを指定するには、次のいずれかの方法を選択する必要があります。

ユニキャスト -- グループ内の各ルータのルータ アドレスの一覧が各キャッシュ エンジンに設定されます。この場合、グループ内の各ルータのアドレスは、設定中に各キャッシュ エンジンに明示的に指定する必要があります。

マルチキャスト -- 1 つのマルチキャスト アドレスを各キャッシュ エンジンに設定します。このマルチキャスト アドレス方式では、キャッシュ エンジンが、サービス グループ内のすべてのルータをカバーするシングル アドレス通知を送信します。たとえば、キャッシュ エンジンは、224.0.0.100 というマルチキャスト アドレスにパケットを送信するように指示できます。この場合、マルチキャスト パケットは、サービス グループ内で WCCP を使用してグループで待ち受けるように設定されたすべてのルータに送信されます(詳細については、 ip wccp group-listen インターフェイス コンフィギュレーション コマンドを参照)。

マルチキャスト オプションは、各キャッシュ エンジンに指定するアドレスが 1 つのみであるため、設定しやすくなっています。この方式では、サービス グループとの間でのルータの追加および削除がダイナミックにでき、毎回別のアドレス一覧を使用してキャッシュ エンジンを再設定する必要がありません。

WCCPv2 設定の機能の詳細を、次の一連のイベントで示します。

1. 各キャッシュ エンジンは、ルータの一覧を使用して設定します。

2. 各キャッシュ エンジンは自身の存在およびすべてのルータの一覧をアナウンスして、通信を確立します。ルータは、グループ内のキャッシュ エンジンのビュー(一覧)を使用して応答します。

3. クラスタ内のすべてのキャッシュ エンジンについてビューに整合性があると、1 つのキャッシュ エンジンがリードとして指定され、パケットをリダイレクトする場合にルータが使用する必要のあるポリシーが設定されます。

次に、ルータをサービス グループに参加させるためにルータに WCCPv2 を設定する方法について説明します。

非 HTTP サービスのサポート

WCCPv2 では、様々な UDP および TCP トラフィックを含め、HTTP(TCP ポート 80 トラフィック)以外のトラフィックのリダイレクションが可能です。WCCPv1 では、HTTP(TCP ポート 80)トラフィックのみのリダイレクションをサポートしています。WCCPv2 は、他のポート宛てのパケットのリダイレクションをサポートしています。これらのパケットには、プロキシ/Web キャッシュ処理用、File Transfer Protocol(FTP; ファイル転送プロトコル)キャッシング用、FTP プロキシ処理用、80 以外のポートの Web キャッシング用、オーディオ、ビデオ、テレフォニー アプリケーション用があります。

各種の利用可能なサービスに対応するために、WCCPv2 は複数の サービス グループ という概念を導入しています。ダイナミック サービス ID 番号(「98」など)または定義済みサービス キーワード([web-cache] など)を使用して、WCCP 設定コマンドでサービス情報を指定します。この情報は、サービス グループ メンバーが同じサービスを使用または提供していることを確認するために使用されます。

サービス グループ中のキャッシュ エンジンは、プロトコル(TCP または UDP)のリダイレクト対象にするトラフィックおよびポート(送信元または宛先)を指定します。各サービス グループにはプライオリティ ステータスが割り当てられます。パケットはプライオリティ順にサービス グループに対して照合が行われます。

複数ルータのサポート

WCCPv2 では、複数のルータをキャッシュ エンジンのクラスタに追加できます。サービス グループの複数のルータを使用すると、冗長構成、インターフェイスのアグリゲーション、およびリダイレクションの負荷分散が可能になります。

MD5 セキュリティ

WCCPv2 では、Hash-based Message Authentication Code(HMAC)MD5 標準およびパスワードを使用して、どのルータおよびキャッシュ エンジンをサービス グループに参加させるかを決めることができる認証をオプションで提供します。共有秘密鍵 MD5 ワンタイム認証( ip wccp [ password [ 0-7 ] password ] グローバル コンフィギュレーション コマンドを使用して設定)では、メッセージの傍受、検査、およびリプレイから保護します。

Web キャッシュ パケットのリターン

キャッシュ エンジンはキャッシュしたオブジェクトのうちで要求されたものをエラーまたは過負荷のために提供できない場合、要求をルータに返して、最初に指定された宛先サーバに伝送されるようにします。WCCPv2 は、どの要求が対応されずにキャッシュ エンジンから返されたかをパケットごとにチェックします。ルータはこの情報を使用して、要求を元のターゲット サーバに転送できます(キャッシュ クラスタへの再送はしません)。これにより、エラー処理はクライアントには透過的になります。

キャッシュ エンジンがパケットを拒否してパケット リターン機能を実行する一般的な理由は、次のとおりです。

キャッシュ エンジンが過負荷状態で、パケットに対応する余裕がない場合。

キャッシュ エンジンが、パケットのキャッシングによって逆効果となる特定の状況(IP 認証をオンにしたときなど)でフィルタリングをする場合。

負荷分散

WCCPv2 を各キャッシュ エンジンに分散する負荷の調整に使用すると、利用可能なリソースを効率的に使用しながら高い QoS(Quality of Service)をクライアントに提供できます。WCCPv2 では指定キャッシュは、特定のキャッシュの負荷を調整し、クラスタ内のキャッシュ全体に負荷を分散できます。WCCPv2 では負荷分散を実行するために、次の 3 つの方法を使用します。

ホット スポット処理 -- 個々のハッシュ バケットをすべてのキャッシュ エンジンに分散できます。WCCPv2 以前は、1 つのハッシュ バケットの情報は 1 つのキャッシュ エンジンにのみ送ることができました。

ロード バランシング -- ハッシュ バケット セットをキャッシュ エンジンに割り当てて調整することにより、処理能力に余裕がないキャッシュ エンジンから余裕のある他のキャッシュ エンジンに負荷を分散させることができます。

負荷制限 -- ルータは負荷を選択的にリダイレクトして、キャッシュ エンジンの処理能力を超えないようにします。

こうしたハッシュ パラメータを使用すると、1 つのキャッシュが過負荷になることを防止し、輻輳の可能性を減らすことができます。

WCCPv2 の制約事項

WCCPv2 には次の制約事項があります。

WCCP は IP ネットワークでのみ動作します。

ルータをマルチキャスト クラスタに対応させるには、Time to Live(TTL; 存続可能時間)値を 15 以下に設定する必要があります。

メッセージは IP マルチキャストされることがあるため、メンバーは目的以外のメッセージまたは重複したメッセージを受け取ることがあります。適切なフィルタリングを実行する必要があります。

サービス グループを構成できるのは、32 以下のキャッシュ エンジンおよび 32 以下のルータです。

クラスタ内のすべてのキャッシュ エンジンは、クラスタに対応するすべてのルータと通信できるように設定する必要があります。

マルチキャスト アドレスは、224.0.0.0 ~ 239.255.255.255 の範囲にする必要があります。

WCCP の設定

次の設定作業では、ネットワークに導入するキャッシュ エンジンがすでにインストールおよび設定されていることを前提としています。ルータに WCCP 機能を設定する前に、クラスタ内のキャッシュ エンジンを設定する必要があります。キャッシュ エンジンの設定およびセットアップ作業の詳細については、『 Cisco Cache Engine User Guide 』を参照してください。

キャッシュ エンジンに接続されているルータ インターフェイス、およびインターネットに接続されているルータ インターフェイスで IP を設定してください。Cisco Cache Engine で直接接続するには、ファスト イーサネット インターフェイスを必要とします。ルータの設定例は、あとで説明します。コマンド構文の詳細については、『 Cisco IOS Configuration Fundamentals Command Reference 』Release 12.2 を参照してください。

ここでは、WCCP の設定手順について説明します。

「WCCP のバージョンの指定」(任意)

「WCCPv2 によるサービス グループの設定」(必須)

「特定インターフェイスにおけるリダイレクションからのトラフィックの除外」(任意)

「マルチキャスト アドレスへのルータの登録」(任意)

「WCCP サービス グループのアクセス リストの使用」(任意)

「ルータおよびキャッシュ エンジンのパスワードの設定」(任意)

WCCP のバージョンの指定

ip wccp { web-cache | service-number } グローバル コンフィギュレーション コマンドを使用して WCCP を設定するまで、ルータでは WCCP はディセーブルです。 ip wccp 形式のコマンドを最初に使用することによって、WCCP はイネーブルになります。デフォルトでは WCCPv2 はサービス用に使用されますが、代わりに WCCPv1 機能を使用することもできます。現在実行中の WCCP のバージョンを Version 2 から Version 1 に変更する、または最初の変更後に WCCPv2 に戻すには、EXEC モードで次の作業を行います。

 

コマンド
目的

Router# ip wccp version { 1 | 2 }

ルータに設定する WCCP のバージョンを指定します。WCCPv2 がデフォルトのバージョンです。

WCCPv1 では、以前の Cisco IOS バージョンの WCCP コマンドを使用できません。代わりに、この章で説明する WCCP コマンドを使用してください。WCCPv1 で許可されていない機能の場合は、エラー プロンプトが画面に表示されます。たとえば、ルータで WCCPv1 を実行している場合にダイナミック サービスを設定しようとすると、[WCCP V1 only supports the web-cache service] というメッセージが表示されます。 show ip wccp EXEC コマンドを使用すると、ルータ上で現在実行されている WCCP プロトコルのバージョン番号を表示できます。

WCCPv2 によるサービス グループの設定

WCCPv2 では、トラフィックの代行受信およびリダイレクションを行うために使用されている論理リダイレクション サービスを基にサービス グループを使用します。標準サービスは、TCP ポート 80(HTTP)トラフィックを代行受信し、キャッシュ エンジンにリダイレクトする Web キャッシュです。このサービスを well-known と呼びます。ルータおよびキャッシュ エンジンの両方により、Web キャッシュ サービスの特性がよく知られているためです。サービス ID 以外の well-known サービスの記述は不要です(この場合は CLI がコマンド構文に web-cache キーワードを提供します)。

Web キャッシュ サービス以外にも、サービス グループでは最大 7 つのダイナミック サービスを同時に実行できます。


) 1 つのルータで複数のサービスを同時に実行することも、ルータおよびキャッシュ装置を複数のサービス グループに同時に参加させることもできます。


ダイナミック サービスはキャッシュ エンジンで定義され、キャッシュは代行受信するプロトコルまたはポートと、トラフィックの分散方法をルータに指示します。ルータ自体はダイナミック サービス グループのトラフィックの特性に関する情報を持っていません。この情報は、グループに最初に参加した Web キャッシュが提供するためです。ダイナミック サービスでは、1 つのプロトコルに最大 8 ポートを指定できます。

たとえば、Cisco Cache Engine はダイナミック サービス 99 を使用して、リバース プロキシ サービスを指定します。ただし、他のキャッシュ装置は、他のサービスのサービス番号を使用できます。次の設定情報は、シスコ ルータで汎用サービスをイネーブルにするためのものです。キャッシュ装置にサービスを設定する方法については、キャッシュ サーバの資料を参照してください。

サービスをイネーブルにするには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# ip wccp { web-cache | service-number } [ accelerated ] [ group-address groupaddress ] [ redirect-list access-list ] [ group-list access-list ] [ password password ]

ルータでイネーブルにする Web キャッシュまたはダイナミック サービスを指定します。サービス グループで使用する IP マルチキャスト アドレスを指定します。使用するアクセス リストを指定します。MD5 認証を使用するかどうかを指定します。WCCP サービスをイネーブルにします。

ステップ 2

Router(config)# interface type number

設定するインターフェイスを指定します。インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

Router(config-if)# ip wccp { web-cache | service-number } redirect { out | in }

特定のインターフェイスで WCCP リダイレクションをイネーブルにします。


) ACNS ソフトウェアの今後のリリース(Release 4.2.2 以降)では、ip wccp service accelerated コマンドをサポートします。


ip wccp service redirect コマンド中の out および in キーワード オプションで示されるように、リダイレクションはアウトバウンド インターフェイスまたはインバウンド インターフェイスに指定できます。

インバウンド トラフィックは Cisco Express Forwarding(CEF; シスコ エクスプレス フォワーディング)、distributed Cisco Express Forwarding(dCEF)、Fast Forwarding、または Process Forwarding を使用するように設定できます。

インターフェイスでインバウンド トラフィックに WCCP を設定すると、アウトバウンド トラフィックの CEF 転送に伴うオーバーヘッドを避けることができます。インターフェイスに出力機能を設定すると、すべてのインターフェイスに到着するすべてのパケットが通過する機能のスイッチング パスが低速になります。インターフェイスに入力機能を設定すると、このインターフェイスに到着したパケットのみが設定済み機能パスを通り、他のインターフェイスに到着するパケットは高速なデフォルト パスを使用します。インバウンド トラフィックに WCCP を設定すると、パケットが分類されてからルーティング テーブルが検索され、パケットのリダイレクションが高速になります。

Web キャッシュ サービスの指定

Web キャッシュ サービスを設定するには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# ip wccp web-cache

ルータで Web キャッシュ サービスをイネーブルにします。

ステップ 2

Router(config)# interface type number

Web キャッシュ サービスを実行するインターフェイス番号を指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

Router(config-if)# ip wccp web-cache redirect { out | in }

ステップ 2 で指定したインターフェイスを使用して、Web キャッシュにリダイレクトする資格があるかどうかを判別するためにパケットのチェックをイネーブルにします。

特定インターフェイスにおけるリダイレクションからのトラフィックの除外

インバウンド トラフィックのリダイレクションをインターフェイスで実行しないようにするには、グローバル コンフィギュレーション モードで次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# interface type number

設定するインターフェイスを指定します。インターフェイス コンフィギュレーション モードを開始します。

ステップ 2

Router(config-if)# ip wccp redirect exclude in

インターフェイス上でリダイレクションから除外するインバウンド パケットを許可します。

マルチキャスト アドレスへのルータの登録

サービス グループにマルチキャスト アドレス オプションを使用する場合、ルータがインターフェイスでマルチキャスト ブロードキャストを待ち受けるように設定する必要があります。ルータを設定するには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# ip wccp { web-cache | service-number } group-address groupaddress

サービス グループのマルチキャスト アドレスを指定します。

ステップ 2

Router(config)# interface type number

マルチキャスト受信用に設定するインターフェイスを指定します。

ステップ 3

Router(config-if)# ip wccp { web-cache | service-number } group-listen

ステップ 2 で指定したインターフェイスで IP マルチキャスト パケット(キャッシュ エンジンから送られるコンテンツ)の受信をイネーブルにします。

リダイレクトされたトラフィックが仲介ルータを経由する必要のあるネットワーク設定の場合、経由対象のルータは、IP マルチキャスト ルーティングを実行するように設定する必要があります。仲介ルータの経由をイネーブルにするには、次の 2 つのコンポーネントを設定してください。

ip multicast routing インターフェイス コンフィギュレーション コマンドを使用して、IP マルチキャスト ルーティングをイネーブルにします。

ip wccp group-listen インターフェイス コンフィギュレーション コマンドを使用して、キャッシュ エンジンがマルチキャスト伝送を受信するために接続するインターフェイスをイネーブルにします(以前のバージョンの Cisco IOS では ip pim インターフェイス コンフィギュレーション コマンドの使用が必要でした)。

WCCP サービス グループのアクセス リストの使用

どのトラフィックをどのキャッシュ エンジンにリダイレクトするかを決めるためにアクセス リストを使用するようにルータを設定するには、グローバル コンフィギュレーション モードで次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# access-list access-list permit ip host host-address [ destination-address | destination-host | any ]

キャッシュ エンジンへのトラフィックのリダイレクションをイネーブルまたはディセーブルにするアクセス リストを作成します。

ステップ 2

Router(config)# ip wccp web-cache group-list access-list

パケットを受け取るキャッシュ エンジンの IP アドレスをルータに指定します。

特定のクライアントのキャッシングをディセーブルにするには、グローバル コンフィギュレーション モードで次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# access-list access-list permit ip host host-address [ destination-address | destination-host | any ]

キャッシュ エンジンへのトラフィックのリダイレクションをイネーブルまたはディセーブルにするアクセス リストを作成します。

ステップ 2

Router(config)# ip wccp web-cache redirect-list access-list

リダイレクションのイネーブル化に使用するアクセス リストを設定します。

ルータおよびキャッシュ エンジンのパスワードの設定

MD5 パスワード セキュリティでは、サービス グループ パスワードを使用して、サービス グループに参加させる各ルータおよびキャッシュ エンジンを設定する必要があります。パスワードは最大 7 文字にできます。サービス グループ内の各キャッシュ エンジンまたは各ルータは、WCCP メッセージ ヘッダーの確認後すぐに受信した WCCP パケット内のセキュリティ コンポーネントを認証します。認証に失敗したパケットは廃棄されます。

WCCP 通信においてルータが MD5 パスワードを使用するように設定するには、グローバル コンフィギュレーション モードで次の作業を行います。

 

コマンド
目的

Router(config)# ip wccp web-cache password password

ルータで MD5 パスワードを設定します。

WCCP 設定の確認およびモニタリング

WCCP の設定を確認および監視するには、特権 EXEC モードで次の作業を行います。

 

コマンド
目的

Router# show ip wccp [web-cache | service-number ]

WCCP に関連したグローバル情報を表示します。この情報には、現在使用中のプロトコル バージョン、ルータ サービス グループ内のキャッシュ エンジン数、ルータへの接続が許可されているキャッシュ エンジン グループ、使用されているアクセス リストなどがあります。

Router# show ip wccp { web-cache | service-number } detail

特定サービス グループのどのキャッシュ エンジンに関する情報を検出したかをルータに問い合わせます。Web キャッシュ サービスまたは指定のダイナミック サービスのいずれかの情報が表示されます。

Router# show ip interface

ip wccp リダイレクション コマンドがインターフェイスに設定されているかどうかについてのステータスを表示します。たとえば、[Web Cache Redirect is enabled / disabled] のように表示されます。

Router# show ip wccp { web-cache | service-number } view

特定のサービス グループのどの装置が検出され、どのキャッシュ エンジンが他のルータから認識可能か、また現在のルータの接続先がどこかを表示します。 view キーワードは、サービス グループのサービス一覧を示します。Web キャッシュ サービスまたは指定のダイナミック サービスのいずれかの情報が表示されます。トラブルシューティングの詳細については、 show ip wccp { web-cache | service number } service コマンドを使用します。

WCCP の設定例

ここでは、次の設定例について説明します。

「ルータでの WCCP バージョンの変更例」

「一般的な WCCPv2 設定の実行例」

「Web キャッシュ サービスの実行例」

「リバース プロキシ サービスの実行例」

「マルチキャスト アドレスへのルータの登録例」

「アクセス リストの使用例」

「ルータおよびキャッシュ エンジンのパスワード設定例」

「WCCP 設定の確認例」

ルータでの WCCP バージョンの変更例

次に、WCCP バージョンをデフォルトの WCCPv2 から WCCPv1 に変更し、WCCPv1 で Web キャッシュ サービスをイネーブルにする処理例を示します。

Router# show ip wccp
% WCCP version 2 is not enabled
Router# configure terminal
Router(config)# ip wccp version 1
Router(config)# end
Router# show ip wccp
% WCCP version 1 is not enabled
 
Router# config terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# ip wccp web-cache
Router(config)# end
Router# show ip wccp
Global WCCP information:
Router information:
Router Identifier: 10.4.9.8
Protocol Version: 1.0
. . .

一般的な WCCPv2 設定の実行例

次に、一般的な WCCPv2 設定セッション例を示します。

Router# configure terminal
Router(config)# ip wccp web-cache group-address 224.1.1.100 password alaska1
Router(config)# interface vlan 20
Router(config-if)# ip wccp web-cache redirect out

Web キャッシュ サービスの実行例

次に、Web キャッシュ サービス設定セッション例を示します。

router# configure terminal
router(config)# ip wccp web-cache
router(config)# interface vlan 20
router(config-if)# ip wccp web-cache redirect out
Router(config-if)# ^Z
Router# copy running-config startup-config
 

次に、VLAN インターフェイス 30 に到着する HTTP トラフィックのリダイレクションをイネーブルにする設定セッション例を示します。

Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# interface vlan 30
Router(config-if)# ip wccp web-cache redirect in
Router(config-if)# ^Z
Router# show ip interface vlan 30 | include WCCP Redirect
WCCP Redirect inbound is enabled
WCCP Redirect exclude is disabled

リバース プロキシ サービスの実行例

次の例では、リバース プロキシ サービスの実行にダイナミック サービス 99 を使用する Cisco Cache Engine を使用してサービス グループを設定することを前提としています。

router# configure terminal
router(config)# ip wccp 99
router(config)# interface vlan 40
router(config-if)# ip wccp 99 redirect out

マルチキャスト アドレスへのルータの登録例

次に、ルータをマルチキャスト アドレス 224.1.1.100 に登録する例を示します。

Router(config)# ip wccp web-cache group-address 224.1.1.100
Router(config)# interface vlan 50
Router(config-if)# ip wccp web cache group-listen
 

次に、マルチキャスト アドレス 224.1.1.1 を使用してリバース プロキシ サービスを実行するようにルータを設定する例を示します。リダイレクションは、VLAN インターフェイス 60 から送信されるパケットに適用されます。

 
Router(config)# ip wccp 99 group-address 224.1.1.1
Router(config)# interface vlan 60
Router(config-if)# ip wccp 99 redirect out

アクセス リストの使用例

セキュリティを向上させるには、標準的なアクセス リストを使用して、現在のルータに登録しようとするキャッシュ エンジンにとってどの IP アドレスが有効なアドレスであるかをルータに通知します。次に、サンプル ホストのアクセス リスト番号が 10 である標準的なアクセス リストの設定セッション例を示します。

router(config)# access-list 10 permit host 11.1.1.1
router(config)# access-list 10 permit host 11.1.1.2
router(config)# access-list 10 permit host 11.1.1.3
router(config)# ip wccp web-cache group-list 10
 

特定のクライアント、サーバ、またはクライアント/サーバ ペアに対してキャッシングをディセーブルにするには、WCCP アクセス リストを使用します。次に、10.1.1.1 ~ 12.1.1.1 から送信される要求がキャッシュをバイパスするようにし、他のすべての要求には正常に対応させる例を示します。

Router(config)# ip wccp web-cache redirect-list 120
Router(config)# access-list 120 deny tcp host 10.1.1.1 any
Router(config)# access-list 120 deny tcp any host 12.1.1.1
Router(config)# access-list 120 permit ip any any
 

次に、VLAN インターフェイス 70 で受信した Web 関連パケットを、209.165.196.51 以外のホスト宛てにリダイレクトするようにルータを設定する例を示します。

 
Router(config)# access-list 100 deny ip any host 209.165.196.51
Router(config)# access-list 100 permit ip any any
Router(config)# ip wccp web-cache redirect-list 100
Router(config)# interface vlan 70
Router(config-if)# ip wccp web-cache redirect in

ルータおよびキャッシュ エンジンのパスワード設定例

次に、パスワードを alaska1 とした場合の、WCCPv2 パスワード設定のセッション例を示します。

router# configure terminal
router(config)# ip wccp web-cache password alaska1

WCCP 設定の確認例

設定の変更を確認するには、 more system:running-config EXEC コマンドを使用します。次は、Web キャッシュ サービスおよびダイナミック サービス 99 の両方がルータでイネーブルであることを示す例です。

router# more system:running-config
 
Building configuration...
Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
service udp-small-servers
service tcp-small-servers
!
hostname router4
!
enable secret 5 $1$nSVy$faliJsVQXVPW.KuCxZNTh1
enable password alabama1
!
ip subnet-zero
ip wccp web-cache
ip wccp 99
ip domain-name cisco.com
ip name-server 10.1.1.1
ip name-server 10.1.1.2
ip name-server 10.1.1.3
!
!
!
interface Vlan200
ip address 10.3.1.2 255.255.255.0
no ip directed-broadcast
ip wccp web-cache redirect out
ip wccp 99 redirect out
no ip route-cache
no ip mroute-cache
!
 
interface Vlan300
ip address 10.4.1.1 255.255.255.0
no ip directed-broadcast
ip wccp 99 redirect out
no ip route-cache
no ip mroute-cache
!
interface Serial0
no ip address
no ip directed-broadcast
no ip route-cache
no ip mroute-cache
shutdown
!
interface Serial1
no ip address
no ip directed-broadcast
no ip route-cache
no ip mroute-cache
shutdown
!
ip default-gateway 10.3.1.1
ip classless
ip route 0.0.0.0 0.0.0.0 10.3.1.1
no ip http server
!
!
!
line con 0
transport input none
line aux 0
transport input all
line vty 0 4
password alaska1
login
!
end