Catalyst 6500 Release 12.2SXH and Later Software コンフィギュレーション ガイド
MPLS の設定
MPLS の設定
発行日;2012/02/05 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 12MB) | フィードバック

目次

MPLS の設定

MPLS

MPLS の概要

MPLS の概要

IP/MPLS

MPLS/MPLS

MPLS/IP

MPLS VPN 転送

再循環

サポートされるハードウェア機能

サポートされる Cisco IOS 機能

MPLS の注意事項および制約事項

MPLS サポート コマンド

MPLS の設定

MPLS のラベル単位ロード バランシング

基本的な MPLS ロード バランシング

MPLS レイヤ 2 VPN ロード バランシング

MPLS レイヤ 3 VPN ロード バランシング

MPLS の設定例

VPN スイッチング

VPN スイッチングの動作

MPLS VPN の注意事項および制約事項

MPLS VPN サポート コマンド

MPLS VPN の設定

MPLS VPN の設定例

AToM

AToM ロード バランシング

EoMPLS の概要

EoMPLS の注意事項および制約事項

EoMPLS の設定

前提条件

VLAN ベース EoMPLS の設定

ポートベース EoMPLS の設定

LAN カードでの MUX-UNI サポートの設定

MPLS の設定

この章では、Cisco IOS Release 12.2SX で Multiprotocol Label Switching(MPLS; マルチプロトコル ラベル スイッチング)を設定する手順について説明します。


) • MPLS は PFC3A モードではサポートされません。

この章で使用しているコマンドの構文および使用方法の詳細については、以下のマニュアルを参照してください。

次の URL にある『 Cisco IOS Software Releases 12.2SX Command References

http://www.cisco.com/en/US/docs/ios/mcl/122sxmcl/12_2sx_mcl_book.html

次の URL にある Release 12.2 のマニュアル

http://www.cisco.com/en/US/products/sw/iosswrel/ps1835/products_installation_and_configuration_guides_list.html


 

この章で説明する内容は、次のとおりです。

「MPLS」

「VPN スイッチング」

「AToM」

MPLS

ここでは MPLS について説明します。

「MPLS の概要」

「MPLS の概要」

「サポートされるハードウェア機能」

「サポートされる Cisco IOS 機能」

「MPLS の注意事項および制約事項」

「MPLS の設定」

「MPLS のラベル単位ロード バランシング」

「MPLS の設定例」

MPLS の概要

MPLS はラベル スイッチングを使用して、Packet-over-SONET(POS)、フレーム リレー、Asynchronous Transfer Mode(ATM; 非同期転送モード)、イーサネットなどのさまざまなリンクレベル テクノロジーを介してパケットを転送します。ラベルはグループ化または Forwarding Equivalence Class(FEC)に基づいて、パケットに割り当てられます。ラベルはレイヤ 2 ヘッダーとレイヤ 3 ヘッダーの間に追加されます。

MPLS ネットワークでは、Label Edge Router(LER; ラベル エッジ ルータ)が着信ラベルのラベル検索を実行し、着信ラベルを発信ラベルに切り替えて、パケットを Label Switch Router(LSR; ラベル スイッチ ルータ)のネクストホップに送信します。パケットに対してラベルがインポーズ(プッシュ)されるのは、MPLS ネットワークの入力エッジ上に限ります。出力エッジでは、ラベルが削除(ポップ)されます。コア ネットワーク LSR(プロバイダーまたは P ルータ)はラベルを読み取り、適切なサービスを適用し、ラベルに基づいてパケットを転送します。

着信ラベルには集約または非集約の 2 つのタイプがあります。集約ラベルの場合、ネクストホップおよび発信インターフェイスを検出するときに、IP 検索によって着信 MPLS パケットをスイッチングする必要があります。非集約ラベルの場合、パケットに IP ネクストホップ情報が格納されます。

図26-1 に、カスタマー ネットワークの 2 つのサイトを接続する、サービス プロバイダーの MPLS ネットワークを示します。

図26-1 MPLS ネットワーク

 

MPLS の詳細については、以下のマニュアルを参照してください。

http://www.cisco.com/en/US/docs/ios/12_2/switch/configuration/guide/xcftagov.html

MPLS の概要

Cisco IOS Release 12.2SX は、レイヤ 3 MPLS Virtual Private Network(VPN; バーチャル プライベート ネットワーク)およびレイヤ 2 Ethernet over MPLS(EoMPLS)をサポートし、QoS(Quality of Service)やセキュリティに対応しています。

Route Processor(RP; ルート プロセッサ)は、アドレス解決やルーティング プロトコルなどのレイヤ 3 コントロール プレーン機能を実行します。RP はルーティング プロトコルおよびラベル配布プロトコル(Label Distribution Protocol; LDP)からの情報を処理し、IP 転送(Forwarding Information Base[FIB; 転送情報ベース])テーブルおよびラベル転送(Label Forwarding Information Base [LFIB])テーブルを構築します。RP は両方のテーブルの情報を PFC3 に配布します。

PFC3 は情報を取得し、FIB および LFIB テーブルのコピーを独自に作成します。また、これらのテーブルを組み合わせて FIB TCAM を作成します。DFC は FIB Ternary CAM(TCAM)テーブル内で、着信 IP パケットおよびラベル付きパケットを検索します。検索結果は、特定の隣接エントリへのポインタとして示されます。この隣接エントリには、ラベルのプッシュ(IP/MPLS パスの場合)、ラベルのスワップ(MPLS/MPLS パスの場合)、ラベルのポップ(MPLS/IP パスの場合)、カプセル化に関する適切な情報が含まれます。

図26-2 に MPLS をサポートする各機能ブロックを示します。ルーティング プロトコルは、IP および MPLS データ パケットの転送に使用する Routing Information Base(RIB)を生成します。Cisco Express Forwarding(CEF; シスコ エクスプレス フォワーディング)の場合、必要なルーティング情報が RIB から抽出されて、FIB に構築されます。LDP は RIB からルートを取得して、ラベル スイッチ パスを介してラベルを配布し、各 LSR および LER 内に LFIB を構築します。

図26-2 MPLS 転送、制御、データ プレーン

 

IP/MPLS

PFC は MPLS ネットワークの入口で IP パケットを検証し、FIB TCAM 内でルートを検索します。検索結果は、特定の隣接エントリへのポインタとして示されます。隣接エントリには、ラベルのプッシュ(IP/MPLS パスの場合)およびカプセル化に関する適切な情報が含まれます。PFC は、MPLS パケットのスイッチングに必要なインポジション ラベルを含めた結果を生成します。


) MPLS 負荷分散が設定されている場合、隣接は負荷分散パスを指すことがあります。「基本的な MPLS ロード バランシング」を参照してください。


MPLS/MPLS

PFC は MPLS ネットワークのコアで最上位ラベルを使用して、FIB TCAM 内で検索を実行します。正常な検索結果が指す隣接は、パケット内の最上位ラベルを、ダウンストリーム LSR によってアドバタイズされた新しいラベルで置き換えます。ルータが直前ホップ LSR ルータ(出力 LER の次のアップストリーム LSR)である場合、隣接は PFCBXL に最上位ラベルをポップするように指示します。これにより、VPN または Any Transport over MPLS(AToM)で使用するラベルが残っている MPLS パケット、またはネイティブ IP パケットが作成されます。

MPLS/IP

MPLS ネットワークの出口での処理には複数の方法があります。

ネイティブ IP パケットの場合(直前ルータがラベルをポップした場合)、PFC は FIB TCAM 内でルートを検索します。

MPLS VPN パケットの場合、 IGP ラベルが直前ルータでポップされたあとに、VPN ラベルが残ります。PFC が実行する処理は、VPN ラベル タイプによって異なります。集約ラベルを伝送するパケットでは、集約ラベルをポップしたあとに、IP ヘッダーに基づいてさらに検索する必要があります。非集約ラベルの場合、PFC は FIB TCAM 内でルートを検索し、IP ネクストホップ情報を取得します。

IGP ラベルおよび VPN ラベルが添付されたパケットの場合、Penultimate Hop Popping(PHP)が発生しなければ、パケットは VPN ラベルの上部で明示的 Null ラベルを伝送します。PFC は FIB TCAM 内で最上位ラベルを検索し、パケットを再循環させます。次に、PFC は上記段落の説明に従い、集約ラベルであるか非集約ラベルであるかに応じて残りのラベルを処理します。

EoMPLS、MPLS、MPLS VPN の場合、明示的 Null ラベルが添付されたパケットについて、MPLS は同様に処理されます。

MPLS VPN 転送

VPN ラベルには、直接接続されたネットワークまたは集約ルート用の集約ラベルと、非集約ラベルの 2 種類があります。集約ラベルを伝送するパケットでは、集約ラベルをポップしたあとに、IP ヘッダーに基づいてさらに検索する必要があります。VPN 情報(VPN-IPv4 アドレス、拡張コミュニティ、ラベル)は Multiprotocol Border Gateway Protocol(MBGP)によって配布されます。

再循環

PFC はパケットの再循環機能を提供する場合があります。再循環を使用すると、Access Control List(ACL; アクセス コントロール リスト)または QoS TCAM、NetFlow テーブル、または FIB TCAM テーブル内で追加検索を実行できます。再循環は次の場合に使用する必要があります。

4 つ以上のラベルをインポジションにプッシュする場合

3 つ以上のラベルをディスポジションにポップする場合

最上位の明示的 Null ラベルをポップする場合

VPN Routing and Forwarding(VRF; VPNルーティング/転送)番号が 511 を超える場合

出力インターフェイスの IP ACL の場合(非集約[プレフィクス単位]ラベル専用)

パケット再循環が発生するのは、特定のパケット フローに対してのみです。その他のパケット フローには影響しません。パケットの書き替えはモジュールで行われます。書き替えられたパケットは PFC に転送されて、さらに処理されます。

サポートされるハードウェア機能

次のハードウェア機能がサポートされています。

ラベル処理 -- 任意の個数のラベルをプッシュまたはポップできます。ただし、最適な結果を得るために、同じ処理内でプッシュするラベル数を最大 3 つ、ポップするラベル数を最大 2 つにしてください。

IP/MPLS パス -- IP パケットを受信して、MPLS パスに送信できます。

MPLS/IP パス -- ラベル付きパケットを受信して、IP パスに送信できます。

MPLS/MPLS パス -- ラベル付きパケットを受信して、そのラベル パスに送信できます。

MPLS Traffic Engineering(MPLS TE) -- MPLS バックボーンは、レイヤ 2 ATM およびフレーム リレー ネットワークのトラフィック エンジニアリング機能を反復および拡張できます。

Time to Live(TTL; 存続可能時間)処理 -- MPLS ネットワークの入口では、MPLS フレーム ヘッダーの TTL 値を、IP パケット ヘッダーの TTL フィールド、または隣接エントリのユーザ設定値から取得できます。MPLS ネットワークの出口では、最終 TTL はラベル TTL と IP TTL のいずれか小さい方の値から 1 を引いた値になります。


) 均一モードでは、TTL は IP TTL から取得されます。パイプ モードでは、ハードウェア レジスタから取得した値 255 が発信ラベルに使用されます。


QoS -- IP パケットから取得した Differentiated Services(DiffServ; 差別化サービス)および Type of Service(ToS; サービス タイプ)に関する情報を、MPLS EXP フィールドにマッピングできます。

MPLS/VPN サポート -- 最大 1024 の VRF をサポートできます(VRF が 511 を超える場合、再循環する必要があります)。

EoMPLS -- MPLS ドメインの入口でイーサネット フレームをカプセル化し、出口でカプセル開放できます。

パケット再循環 -- PFC にはパケット再循環機能があります。「再循環」を参照してください。

MPLS スイッチング設定は、mpls ip コマンドを使用した VLAN(仮想 LAN)インターフェイスでサポートされます。

サポートされる Cisco IOS 機能

次の Cisco IOS ソフトウェア機能がサポートされています。


) CE ルータ(VRF Lite)の Multi-VRF は、VRF インターフェイス間の IPv4 転送、IPv4 ACL、および IPv4 HSRP 機能とともにサポートされています。IPv4 マルチキャストはサポートされていません。


CE ルータ(VRF Lite)の multi-VRF -- VRF Lite は、サービス プロバイダーが複数の VPN をサポートして(VRF ベース IPv4 のみを使用)、IP アドレスを重複使用できるようにするための機能です。次のマニュアルを参照してください。

http://www.cisco.com/en/US/products/hw/routers/ps259/prod_bulletin09186a00800921d7.html

シスコ製ルータ上の MPLS -- この機能は、LER で IP パケットのラベルをインポーズしたり削除したり、LSR でラベルをスイッチングするための、基本的な MPLS サポートを提供します。次のマニュアルを参照してください。

http://www.cisco.com/en/US/docs/ios/12_0st/12_0st21/feature/guide/fs_rtr.html

MPLS TE -- MPLS トラフィック エンジニアリング ソフトウェアにより、MPLS バックボーンはレイヤ 2 ATM およびフレーム リレー ネットワークのトラフィック エンジニアリング機能を反復および拡張できます。したがって、MPLS トラフィック処理により従来のレイヤ 2 機能をレイヤ 3 トラフィック フローでも利用できます。詳細については、以下のマニュアルを参照してください。

http://www.cisco.com/en/US/docs/ios/12_2/switch/configuration/guide/xcftagc.html

http://www.cisco.com/warp/public/105/mplsteisis.html

http://www.cisco.com/warp/public/105/mpls_te_ospf.html

MPLS TE DiffServ 認識(DS-TE) -- この機能は、MPLS TE に対する拡張を提供し、これを DiffServ 認識にして、保証されたトラフィックの制約に基づくルーティングを可能にします。次のマニュアルを参照してください。

http://www.cisco.com/en/US/docs/ios/12_2s/feature/guide/fsdserv3.html

MPLS TE 転送隣接 -- この機能により、ネットワーク管理者はトラフィック エンジニアリングである Label-Switched Path(LSP)トンネルを、Shortest Path First(SPF)アルゴリズムに基づいた IGP ネットワーク内のリンクとして処理できます。Intermediate System-to-Intermediate System(IS-IS)を用いた転送隣接の詳細については、次のマニュアルを参照してください。

http://www.cisco.com/en/US/docs/ios/12_2s/feature/guide/fstefa_3.html

MPLS TE Interarea トンネル -- この機能により、ルータは複数の IGP 領域およびレベルにまたがる MPLS TE トンネルを確立して、トンネルの最初と最後のルータを同じ領域におく必要がある制約事項を削除できます。次のマニュアルを参照してください。

http://www.cisco.com/en/US/docs/ios/12_2s/feature/guide/fsiarea3.html

MPLS VPN -- この機能を使用すると、Cisco IOS ネットワーク上に容易に拡張できる IPv4 レイヤ 3 VPN バックボーン サービスを導入することが可能です。次のマニュアルを参照してください。

http://www.cisco.com/en/US/docs/ios/12_0st/12_0st21/feature/guide/fs_vpn.html

MPLS VPN Carrier Supporting Carrier(CSC) -- この機能を使用すると、MPLS VPN ベース サービス プロバイダーは、バックボーン ネットワークのセグメントの使用を他のサービス プロバイダーに許可できます。次のマニュアルを参照してください。

http://www.cisco.com/en/US/docs/ios/12_2t/12_2t8/feature/guide/ftcsc8.html

MPLS VPN CSC IPv4 BGP ラベル配布 -- この機能を使用すると、Border Gateway Protocol(BGP; ボーダー ゲートウェイ プロトコル)がバックボーン キャリア Provider Edge(PE; プロバイダー エッジ)ルータとカスタマー キャリア Customer Edge(CE; カスタマー エッジ)ルータ間でルートおよび MPLS ラベルを送信できるように、ご使用の CSC ネットワークを設定できます。次のマニュアルを参照してください。

http://www.cisco.com/en/US/docs/ios/12_2t/12_2t13/feature/guide/ftcscl13.html

MPLS VPN Interautonomous System(InterAS)のサポート -- この機能を使用すると、MPLS VPN をサービス プロバイダーおよび Autonomous System(AS; 自律システム)に拡張できます。次のマニュアルを参照してください。

http://www.cisco.com/en/US/docs/ios/12_0s/feature/guide/fsias24.html

MPLS VPN InterAS IPv4 BGP ラベル配布 -- この機能を使用すると、Autonomous System Boundary Router(ASBR; 自律システム境界ルータ)が IPv4 ルートを PE ルータの MPLS ラベルと交換できるように、VPN サービス プロバイダー ネットワークを設定できます。次のマニュアルを参照してください。

http://www.cisco.com/en/US/docs/ios/12_2t/12_2t13/feature/guide/ftiasl13.html

MPLS VPN Hot Standby Router Protocol(HSRP; ホットスタンバイ ルータ プロトコル)のサポート -- この機能を使用すると、グローバル ルーティング テーブルではなく、正しい IP ルーティング テーブルに、HSRP 仮想 IP アドレスが追加されます。次のマニュアルを参照してください。

http://www.cisco.com/en/US/docs/ios/12_1t/12_1t3/feature/guide/dt_hsmp.html

MPLS VPNの OSPF 模造リンク サポート -- この機能を使用すると、模造リンクを使用して、OSPF プロトコルが稼働する VPN クライアント サイトに接続し、MPLS VPN コンフィギュレーション内で OSPF リンクを共有できます。次のマニュアルを参照してください。

http://www.cisco.com/en/US/docs/ios/12_2t/12_2t8/feature/guide/ospfshmk.html

AtoM -- MPLS バックボーン上でレイヤ 2 パケットを送信します。「AToM」を参照してください。

MPLS の注意事項および制約事項

MPLS を設定する際に、以下の注意事項と制約事項に従ってください。

PFC3 は、最大 8 つの負荷分散パスをサポートできます。他のプラットフォーム用の Cisco IOS リリースでサポートできる負荷分散パスは、8 つのみです。

MTU の確認とフラグメンテーションがサポートされています。


) フラグメンテーションは(IP/MPLS パスの)ソフトウェアでサポートされます。『Cisco IOS Software Releases 12.2SX Command References』の mtu コマンドを参照してください。



) その他の制限および制約事項については、「MPLS VPN の注意事項および制約事項」および「EoMPLS の注意事項および制約事項」を参照してください。


MPLS サポート コマンド

MPLS では以下のコマンドがサポートされます。

mpls ip default route

mpls ip propagate-ttl

mpls ip ttl-expiration pop

mpls label protocol

mpls label range

mpls ip

mpls label protocol

mpls mtu

詳細については、以下のマニュアルを参照してください。

http://www.cisco.com/en/US/docs/ios/mcl/122sxmcl/12_2sx_mcl_book.html

MPLS の設定

MPLS の設定手順については、次の URL にある『Multiprotocol Label Switching on Cisco Routers』のマニュアルを参照してください。

http://www.cisco.com/en/US/docs/ios/12_2/switch/configuration/guide/xcftagc.html

MPLS のラベル単位ロード バランシング

ここでは、基本的な MPLS、MLPS レイヤ 2 VPN、MPLS レイヤ 3 VPN ロード バランシングの情報について説明します。

基本的な MPLS ロード バランシング

ロード バランシング パスの最大数は 8 です。PFC は、明示的に設定されていない場合でも MPLS ラベルの付けられたパケットを転送します。パケットに添付されたラベルが 3 つ以下で、基礎となるパケットが IPv4 の場合、PFC は送信元および宛先 IPv4 アドレスを使用します。基礎となるパケットが IPv4 でなかったり、4 つ以上のラベルが存在する場合、PFC は 5 番めまたは最下位ラベルまでを解析して、ハッシュに使用します。

MPLS レイヤ 2 VPN ロード バランシング

カスタマー イーサネット フレームの Media Access Control(MAC; メディア アクセス制御)アドレスの最初のニブルが 4 以外の場合、ロード バランシングは MPLS コアの VC ラベルに基づきます。


) レイヤ 2 VPN の場合、入力 PE ではロード バランシングはサポートされません。


MPLS レイヤ 3 VPN ロード バランシング

MPLS レイヤ 3 VPN ロード バランシングは、基本的な MPLS ロード バランシングと類似しています。詳細については、「基本的な MPLS ロード バランシング」を参照してください。

MPLS の設定例

次に、MPLS の基本設定の例を示します。

*****
Basic MPLS
*****
 
 
IP ingress interface:
 
Router# mpls label protocol ldp
 
interface GigabitEthernet6/2
ip address 75.0.77.1 255.255.255.0
media-type rj45
speed 1000
end
 
Label egress interface:
 
interface GigabitEthernet7/15
mtu 9216
ip address 75.0.67.2 255.255.255.0
logging event link-status
mpls ip
 
 
Router# show ip route 188.0.0.0
Routing entry for 188.0.0.0/24, 1 known subnets
 
O IA 188.0.0.0 [110/1] via 75.0.77.2, 00:00:10, GigabitEthernet6/2
 
 
Router# show ip routing 88.0.0.0
Routing entry for 88.0.0.0/24, 1 known subnets
 
O E2 88.0.0.0 [110/0] via 75.0.67.1, 00:00:24, GigabitEthernet7/15
[110/0] via 75.0.21.2, 00:00:24, GigabitEthernet7/16
Router# show mpls forwarding-table 88.0.0.0
Local Outgoing Prefix Bytes tag Outgoing Next Hop
tag tag or VC or Tunnel Id switched interface
30 50 88.0.0.0/24 0 Gi7/15 75.0.67.1
50 88.0.0.0/24 0 Gi7/16 75.0.21.2
 
 
Router# show mls cef 88.0.0.0 detail
 
Codes: M - mask entry, V - value entry, A - adjacency index, P - priority bit
D - full don't switch, m - load balancing modnumber, B - BGP Bucket sel
V0 - Vlan 0,C0 - don't comp bit 0,V1 - Vlan 1,C1 - don't comp bit 1
RVTEN - RPF Vlan table enable, RVTSEL - RPF Vlan table select
Format: IPV4_DA - (8 | xtag vpn pi cr recirc tos prefix)
Format: IPV4_SA - (9 | xtag vpn pi cr recirc prefix)
M(3223 ): E | 1 FFF 0 0 0 0 255.255.255.0
V(3223 ): 8 | 1 0 0 0 0 0 88.0.0.0 (A:344105 ,P:1,D:0,m:1 ,B:0 )
M(3223 ): E | 1 FFF 0 0 0 255.255.255.0
V(3223 ): 9 | 1 0 0 0 0 88.0.0.0 (V0:0 ,C0:0 ,V1:0 ,C1:0 ,RVTEN:0 ,RVTSEL:0 )
Router# show mls cef adj ent 344105
 
Index: 344105 smac: 0005.9a39.a480, dmac: 000a.8ad8.2340
mtu: 9234, vlan: 1031, dindex: 0x0, l3rw_vld: 1
packets: 109478260, bytes: 7006608640
 
Router# show mls cef adj ent 344105 de
 
Index: 344105 smac: 0005.9a39.a480, dmac: 000a.8ad8.2340
mtu: 9234, vlan: 1031, dindex: 0x0, l3rw_vld: 1
format: MPLS, flags: 0x1000008418
label0: 0, exp: 0, ovr: 0
label1: 0, exp: 0, ovr: 0
label2: 50, exp: 0, ovr: 0
op: PUSH_LABEL2
packets: 112344419, bytes: 7190042816
 

VPN スイッチング

ここでは、VPN スイッチングについて説明します。

「VPN スイッチングの動作」

「MPLS VPN の注意事項および制約事項」

「MPLS VPN サポート コマンド」

「MPLS VPN の設定例」

VPN スイッチングの動作

MPLS の IP VPN 機能により Cisco IOS ネットワークは、拡張が容易な IP レイヤ 3 VPN バックボーン サービスを共有インフラストラクチャに配置された複数のサイトに展開し、同時にプライベート ネットワークと同じアクセスまたはセキュリティを提供できます。MPLS テクノロジーに基づいた VPN には、ルーティングの隔離、セキュリティの向上、ルーティングの簡素化、スケーラビリティの向上という利点があります。

MPLS VPN の概要および詳細な設定については、次の URL にある Cisco IOS ソフトウェア マニュアルを参照してください。

http://www.cisco.com/en/US/docs/ios/12_2/switch/configuration/guide/xcftagov_ps1835_TSD_Products_Configuration_Guide_Chapter.html

図26-3 に、一般的な MPLS VPN ネットワーク トポロジを示します。

図26-3 VPN およびサービス プロバイダー バックボーン

 

PFC は、入力 PE でパケット ヘッダーに基づいて転送を判断します。PFC には、VLAN を VPN にマッピングするテーブルが含まれます。スイッチ アーキテクチャでは、システム内のすべての物理入力インターフェイスが特定の VPN に対応付けられます。PFC は CEF テーブル内で IP 宛先アドレスを検索しますが、対象となるのは特定の VPN 内のプレフィクスのみです(テーブル エントリは特定の隣接セットを指します。複数のパラレル パスが存在する場合は、ロード バランシング判断によって特定の隣接が選択されます)。

テーブル エントリには、パケットに必要なレイヤ 2 ヘッダー情報、およびフレームにプッシュされる特定の MPLS ラベルが含まれます。パケット書き替え用のこの情報は、入力ライン カードに送信されて書き替えが行われ、出力ライン インターフェイスに転送されます。

VPN トラフィックはプレフィクス単位のラベルまたは集約ラベルに基づいて、PE からの出口で処理されます。プレフィクス単位のラベルが使用される場合、各 VPN プレフィクスには一意のラベルが対応付けられます。これにより、PE は FIB 内のラベル検索に基づいて、パケットを最終宛先に転送できます。


) PFC が割り当てるのは、VRF ごとに 1 つの集約ラベルのみです。


出力 PE のディスポジションに集約ラベルが使用される場合、複数のインターフェイスの多数のプレフィクスをこのラベルに対応付けることができます。この場合、PFC は IP 検索を実行して最終的な宛先を判別する必要があります。IP 検索では再循環を必要とする場合があります。

MPLS VPN の注意事項および制約事項

MPLS VPN を設定する場合、VPN 数が 511 を超えると VPN が再循環されることに注意してください。

MPLS VPN サポート コマンド

MPLS VPN では以下のコマンドがサポートされます。

address-family

exit-address-family

import map

ip route vrf

ip route forwarding

ip vrf

neighbor activate

rd

route-target

詳細については、以下のマニュアルを参照してください。

http://www.cisco.com/en/US/docs/ios/mcl/122sxmcl/12_2sx_mcl_book.html

MPLS VPN の設定

MPLS VPN の設定手順については、次の URL にある『MPLS Virtual Private Networks』フィーチャ モジュールを参照してください。

http://www.cisco.com/en/US/docs/ios/12_2/switch/configuration/guide/xcftagc_ps1835_TSD_Products_Configuration_Guide_Chapter.html#Configuring_MPLS_Virtual_Private_Networks


) 別の MPLS 装置とのレイヤ 2 ポート ピアリングを使用する MPLS アップリンクとしてレイヤ 3 VLAN インターフェイスを使用した場合、VRF インターフェイスとして別のレイヤ 3 VLAN を使用できます。


MPLS VPN の設定例

次に、LAN および FlexWAN CE 方向のインターフェイスの設定例を示します。Cisco IOS Release 12.2SX での MPLS スイッチングの設定は、他のリリースの設定とまったく同じです。

!ip vrf blues
rd 100:10
route-target export 100:1
route-target import 100:1
!
mpls label protocol ldp
mpls ldp logging neighbor-changes
mls mpls tunnel-recir
!
interface Loopback0
ip address 10.4.4.4 255.255.255.255
!
interface GigabitEthernet4/2
description Catalyst link to P2
no ip address
mls qos trust dscp
!
interface GigabitEthernet4/2.42
encapsulation dot1Q 42
ip address 10.0.3.2 255.255.255.0
tag-switching ip
!
interface GigabitEthernet7/3
description Catalyst link to CE2
no ip address
mls qos trust dscp
!
interface GigabitEthernet7/3.73
encapsulation dot1Q 73
ip vrf forwarding blues
ip address 10.19.7.1 255.255.255.0
!
interface POS8/1
description OSM link to CE3
ip vrf forwarding blues
ip address 10.19.8.1 255.255.255.252
encapsulation ppp
mls qos trust dscp
pos scramble-atm
pos flag c2 22
!
interface POS9/0/0
description FlexWAN link to CE1
ip vrf forwarding blues
ip address 10.19.9.1 255.255.255.252
encapsulation ppp
pos scramble-atm
pos flag c2 22
!
router ospf 100
log-adjacency-changes
network 10.4.4.4 0.0.0.0 area 0
network 10.0.0.0 0.0.255.255 area 0
!
router ospf 65000 vrf blues
log-adjacency-changes
redistribute bgp 100 subnets
network 10.19.0.0 0.0.255.255 area 0
!
router bgp 100
no synchronization
bgp log-neighbor-changes
neighbor 10.3.3.3 remote-as 100
neighbor 10.3.3.3 description MP-BGP to PE1
neighbor 10.3.3.3 update-source Loopback0
no auto-summary
!
address-family vpnv4
neighbor 10.3.3.3 activate
neighbor 10.3.3.3 send-community extended
exit-address-family
!
address-family ipv4 vrf blues
redistribute connected
redistribute ospf 65000 match internal external 1 external 2
no auto-summary
no synchronization
exit-address-family
!

AToM

AtoM は、MPLS バックボーン上でレイヤ 2 パケットを送信します。AToM はエッジ ルータの間で転送された LDP セッションを使用して、接続の設定およびメンテナンスを行います。2 つのレベルのラベルを使用して、エッジ ルータ間でスイッチングを行うと、転送が発生します。外部ラベル(トンネル ラベル)は、MPLS バックボーンを介して入力 PE から出力 PE にパケットをルーティングします。VC ラベルは、トンネル エンドポイント(出力 PE の特定の出力インターフェイスおよびイーサネット フレームのVLAN ID)で接続を判別する Demux ラベルです。

AToM は、Cisco IOS Release 12.2SX で次の類似したトランスポート タイプをサポートします。

EoMPLS(VLAN モードおよびポート モード)

DLCI 間接続による Frame Relay over MPLS(FRoMPLS)

ATM AAL5 over MPLS

ATM Cell Relay over MPLS


) その他の AToM タイプが今後のリリースに組み込まれる予定です。


Cisco IOS Release 12.2SX では、PFC で高速化される EoMPLS だけでなく FlexWAN2 ベースの EoMPLS もサポートされます。詳細については、以下のマニュアルを参照してください。

http://www.cisco.com/en/US/docs/routers/7600/install_config/12.2SX_OSM_config/mpls.html#Ethernet_over_MPLS

その他の AToM 実装(ATM AAL5 over MPLS、ATM Cell Relay over MPLS、Frame Relay over MPLS)については、以下のマニュアルを参照してください。

http://www.cisco.com/en/US/docs/routers/7600/install_config/12.2SX_OSM_config/mpls.html#Any_Transport_over_MPLS

ここでは AToM について説明します。

「AToM ロード バランシング」

「EoMPLS の概要」

「EoMPLS の注意事項および制約事項」

「EoMPLS の設定」

「LAN カードでの MUX-UNI サポートの設定」

AToM ロード バランシング

Cisco IOS Release 12.2SX の EoMPLS の場合、トンネル入口ではロード バランシングは行われません。複数の IGP パスを使用できる場合でも、IGP パスは 1 つのみ選択されますが、MPLS コアではロード バランシングを使用できます。

EoMPLS の概要

EoMPLS は AToM トランスポート タイプの 1 つです。AToM はエッジ ルータの間で転送された LDP セッションを使用して、MPLS バックボーンを介してレイヤ 2 パケットを転送し、接続を設定およびメンテナンスします。2 つのレベルのラベルを使用して、エッジ ルータ間でスイッチングを行うと、転送が発生します。外部ラベル(トンネル ラベル)は、MPLS バックボーンを介して入力 PE から出力 PE にパケットをルーティングします。VC ラベルは、トンネル エンドポイント(出力 PE の特定の出力インターフェイスおよびイーサネット フレームのVLAN ID)で接続を判別する Demux ラベルです。

EoMPLS は MPLS パケットに Ethernet PDU をカプセル化し、MPLS ネットワーク上で転送することにより機能します。各 PDU は単一パケットとして送信されます。


) 同じ VLAN 上でローカルなレイヤ 2 スイッチングおよび EoMPLS を実行する場合は、FlexWAN ベースのEoMPLS を使用してください。SVI に EoMPLS を設定する必要があります。コア方向のカードは FlexWAN モジュールを使用する必要があります。ローカルなレイヤ 2 スイッチングが不要な場合、サブインターフェイスまたは物理インターフェイスに設定された PFC ベースの EoMPLS を使用してください。


EoMPLS の注意事項および制約事項

EoMPLS を設定する際に、以下の注意事項と制約事項に従ってください。

受信された最大のレイヤ 2 VLAN を伝送できるように、エンドポイント間のすべての中間リンクの maximum transmission unit(MTU; 最大伝送ユニット)を設定する必要があります。

EoMPLS は、IEEE 802.1Q 標準に準拠する VLAN パケットをサポートします。802.1Q 仕様は、イーサネット フレームに VLAN メンバシップ情報を挿入する標準方式を確立します。

QoS がグローバルにディセーブルになっている場合、802.1p および IP precedence ビットは両方とも保護されます。QoS がレイヤ 2 ポートでイネーブルになっている場合、802.1Q P ビットまたは IP precedence ビットのいずれかを、信頼できる設定を使用して保護できます。ただし、デフォルトでは、保護されていないビットは保護されたビットの値によって上書きされます。たとえば、P ビットが保護されている場合、IP precedence ビットは P ビットの値で上書きされます。Cisco IOS Release 12.2SX では、IP precedence ビットを保護しながら、P ビットを信頼できるようにする新しいコマンドが提供されています。IP precedence ビットを保護するには、no mls qos rewrite ip dscp コマンドを使用します。


) no mls qos rewrite ip dscp コマンドは、MPLS および MPLS VPN 機能と互換性がありません。「PFC QoS の設定」 を参照してください。



) 同じシステム内で PFC ベースの EoMPLS サービスおよび PXF ベースの EoMPLS サービスを使用する場合は、no mls qos rewrite ip dscp コマンドを使用しないでください。


プライベート VLAN では、EoMPLS はサポートされません。

EoMPLS でトランクを使用する場合は、次の制約事項が適用されます。

EoMPLS クラウドでイーサネット スパニング ツリー Bridge Protocol Data Unit(BPDU; ブリッジ プロトコル データ ユニット)をサポートするには、MPLS VLAN 上のイーサネットのスパニング ツリーをディセーブルにする必要があります。これにより、EoMPLS VLAN のカスタマー スイッチへの伝送経路がトランクに限定されます。このようにしないと、BPDU は EoMPLS クラウドに転送されません。

トランクのネイティブ VLAN を EoMPLS VLAN として設定しないでください。

Cisco IOS Release 12.2SX では、すべてのプロトコル(CDP、VTP、BPDU など)は無条件に MPLS クラウドでトンネリングされます。

EoMPLS パケットを受信するインターフェイスでは、Inter Switch Link(ISL; スイッチ間リンク)カプセル化はサポートされません。

インターフェイス間では一意の VLAN が必要です。異なるインターフェイスで同じ VLAN を使用することはできません。

PE 間の LSP を確保するには、ルーティング テーブルおよび CEF テーブル内の EoMPLS トンネル宛先ルートが/32 アドレス(マスクが 255.255.255.255 であるホスト アドレス)でなければなりません。

特定の EoMPLS 接続では、入力 PE の入力 EoMPLS インターフェイスおよび出力 PE の出力 EoMPLS インターフェイスを、dot1Q カプセル化が設定されたサブインターフェイスにする必要があります。このようにしないと、どちらもサブインターフェイスになりません。

MPLS ネットワークに接続された発信インターフェイスがレイヤ 2 カードのポートである場合、802.1Q-in-802 over EoMPLS がサポートされます。

MPLS ネットワークに接続された出力インターフェイスがレイヤ 2 LAN ポート(PFC ベース EoMPLS と呼ばれるモード)である場合、EoMPLS トラフィックのシェーピングはサポートされません。

PFC に基づいた EoMPLS では、宛先 MAC アドレスがローカルまたはリモート セグメント上にあるかどうかを判別するためのレイヤ 2 検索を実行しません。また、レイヤ 2 アドレス学習も実行しません(従来の LAN ブリッジングが実行します)。この機能(ローカル スイッチング)を使用できるのは、FlexWAN モジュールをアップリンクとして使用している場合のみです。

AToM の旧リリースでは、AToM 回路を設定するのに使用するコマンドは mpls l2 transport route でした。このコマンドは、xconnect コマンドで置き換えられています。xconnect コマンドを使用して EoMPLS 回路を設定できます。

AToM 制御ワードはサポートされていません。

EoMPLS は、レイヤ 3 VLAN インターフェイスではサポートされません。

ポイントツーポイント EoMPLS は、物理インターフェイスおよびサブインターフェイスと連動します。

EoMPLS の設定

ここでは、EoMPLS の設定手順について説明します。

「前提条件」

「VLAN ベース EoMPLS の設定」

「ポートベース EoMPLS の設定」

前提条件

EoMPLS を設定する前に、ネットワークが次のように設定されていることを確認してください。

PE ルータが IP 経由で相互に到達できるように、コアに IP ルーティングを設定します。

PE ルータ間で LSP が存在するように、コアに MPLS を設定します。

EoMPLS は MPLS パケットに Ethernet PDU をカプセル化し、MPLS ネットワーク上で転送することにより機能します。各 PDU は単一パケットとして送信されます。Cisco IOS Release 12.2SX で EoMPLS を設定する場合、次の 2 つの方法を使用できます。

VLANモード -- MPLS ネットワーク上の単一 VC を介して、送信元 802.1Q VLAN から宛先 802.1Q VLAN にイーサネット トラフィックをトランスポートします。VLAN モードは、デフォルトとして VC タイプ 5(dot1q タグなし)を使用します。リモート PE サブインターフェイス(VLAN)ベースの EoMPLS に対して VC タイプ 5 をサポートしない場合は、VC タイプ 4(トランスポート dot1 タグ)を使用します。

ポート モード -- ポートのすべてのトラフィックが MPLS ネットワーク上の単一 VC を共有できるようにします。ポート モードは VC タイプ 5 を使用します。


) • VLAN モードおよびポート モードのどちらの場合も、ループバック ポートを使用しないかぎり、Cisco IOS Release 12.2SX での EoMPLS はインターフェイス間におけるパケットのローカル スイッチングを許可しません。

システムでは、FlexWAN 設定および PFC 設定を同時にイネーブルにできます。シスコはこの設定をサポートしますが、推奨しません。MPLS コアへのアップリンクが FlexWAN インターフェイスを経由しない場合、FlexWAN ベースの EoMPLS 接続はアクティブになりません。このため、非 WAN インターフェイスに着信する FlexWAN ベースの EoMPLS に対応するパケットはドロップされます。FlexWAN EoMPLS の詳細については、以下のマニュアルを参照してください。

http://www.cisco.com/en/US/docs/routers/7600/install_config/12.2SX_OSM_config/mpls.html#Ethernet_over_MPLS


 

Cisco IOS Release 12.2SX では、LAN ポートは FlexWAN モジュールを使用しなくても、レイヤ 2 トラフィックを受信し、ラベルをインポーズし、フレームを MPLS コアにスイッチングできます。

Cisco IOS Release 12.2SX では、FlexWAN モジュールを MPLS ネットワークのコア方向に設定でき、FlexWAN 設定または PFC 設定のいずれかを使用できます。詳細については、以下のマニュアルを参照してください。

http://www.cisco.com/en/US/docs/routers/7600/install_config/12.2SX_OSM_config/mpls.html#Ethernet_over_MPLS

VLAN ベース EoMPLS の設定

VLAN ベース EoMPLS を設定する際に、以下の注意事項と制約事項に従ってください。

AToM 制御ワードはサポートされていません。

ハードウェアレベルの CRC エラー、フレーミング エラー、ラント パケットを含むイーサネット パケットは、入力時に廃棄されます。

サブインターフェイスに VLAN ベース EoMPLS を設定する必要があります。

VLAN ベース EoMPLS を設定する場合、PE ルータで次の作業を行ってください。

 

コマンド
目的

ステップ 1

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

Router(config)# interface gigabitethernetslot/interface.subinterface

ギガビット イーサネット サブインターフェイスを指定します。隣接 CE ルータのサブインターフェイスがこの PE ルータと同じ VLAN 上にあることを確認します。

ステップ 3

Router(config-if)# encapsulation dot1q vlan_id

サブインターフェイスでの 802.1Q VLAN パケットの受信をイネーブルにします。

EoMPLS が稼働している CE ルータと PE ルータ間のサブインターフェイスは、同じサブネット内に存在する必要があります。その他のすべてのサブインターフェイスおよびバックボーン ルータは、同じサブネット内に存在する必要はありません。

ステップ 4

Router(config-if)# xconnect peer_router_id vcid encapsulation mpls

接続回路を疑似接続 VC にバインドします。このコマンドの構文は、その他のレイヤ 2 トランスポートの場合と同じです。

次に、VLAN ベース EoMPLS の設定例を示します。

!
interface GigabitEthernet6/4
xconnect 13.13.13.13 4 encapsulation mpls
no shut
!
interface GigabitEthernet7/4.2
encapsulation dot1Q 3
xconnect 13.13.13.13 3 encapsulation mpls
no shut

) IP アドレスは CE 装置のサブインターフェイス上で設定されます。


設定の確認

MPLS トンネルを介したレイヤ 2 VLAN トランスポートの設定を確認および表示するには、次の作業を行います。

VLAN ごとの VLAN 名、ステータス、ポートを 1 行で表示するには、show vlan brief コマンドを使用します。

Router# show vlan brief
 
VLAN Name Status Ports
---- -------------------------------- --------- -------------------------
1 default active
2 VLAN0002 active
3 VLAN0003 active
1002 fddi-default act/unsup
1003 token-ring-default act/unsup
1004 fddinet-default act/unsup
1005 trnet-default act/unsup
 

PE ルータ エンドポイントが相互に検出されたことを確認するには、show mpls ldp discovery コマンドを使用します。PE ルータが別の PE ルータから LDP Hello メッセージを受信した場合、そのルータおよび指定されたラベル スペースは「検出された」とみなされます。

Router# show mpls ldp discovery
Local LDP Identifier:
13.13.13.13:0
Discovery Sources:
Interfaces:
GE-WAN3/3 (ldp):xmit/recv
LDP Id: 12.12.12.12:0
Targeted Hellos:
13.13.13.13 -> 11.11.11.11 (ldp):active/passive, xmit/recv
LDP Id: 11.11.11.11:0
 

ラベル配布セッションが確立されたことを確認するには、show mpls ldp neighbor コマンドを使用します。出力の 3 行めは、LDP セッションのステートが動作可能であり、メッセージが送受信中であることを示します。

Router# show mpls ldp neighbor
Peer LDP Ident:12.12.12.12:0; Local LDP Ident 13.13.13.13:0
TCP connection: 12.12.12.12.646 - 13.13.13.13.11010
State:Oper; Msgs sent/rcvd:1649/1640; Downstream
Up time: 23:42:45
LDP discovery sources:
GE-WAN3/3, Src IP addr: 34.0.0.2
Addresses bound to peer LDP Ident:
23.2.1.14 37.0.0.2 12.12.12.12 34.0.0.2
99.0.0.1
Peer LDP Ident:11.11.11.11:0; Local LDP Ident 13.13.13.13:0
TCP connection: 11.11.11.11.646 - 13.13.13.13.11013
State:Oper; Msgs sent/rcvd:1650/1653; Downstream
Up time: 23:42:29
LDP discovery sources:
Targeted Hello 13.13.13.13 -> 11.11.11.11, active, passive
Addresses bound to peer LDP Ident:
11.11.11.11 37.0.0.1 23.2.1.13
 

ラベル転送テーブルが正しく構築されたことを確認するには、show mpls forwarding-table コマンドを入力して、リモート PE のラベルが学習されたこと、およびこのラベルが正しいインターフェイスから正しいネクストホップに送信されていることを確認します。

Router# show mpls forwarding-table
Local Outgoing Prefix Bytes tag Outgoing Next Hop
tag tag or VC or Tunnel Id switched interface
16 Untagged 223.255.254.254/32 \
0 Gi2/1 23.2.0.1
20 Untagged l2ckt(2) 133093 Vl2 point2point
21 Untagged l2ckt(3) 185497 Vl3 point2point
24 Pop tag 37.0.0.0/8 0 GE3/3 34.0.0.2
25 17 11.11.11.11/32 0 GE3/3 34.0.0.2
26 Pop tag 12.12.12.12/32 0 GE3/3 34.0.0.2
Router#
 

出力では次のデータが表示されます。

Local tag -- このルータによって割り当てられたラベル

Outgoing tag or VC -- ネクストホップによって割り当てられたラベル

Prefix or Tunnel ID -- このラベルが添付されたパケットの送信先アドレスまたはトンネル

Bytes tag switched -- この着信ラベルによってスイッチングされるバイト数

Outgoing interface -- このラベルが添付されたパケットが送信されるインターフェイス

Next Hop -- 発信ラベルに割り当てられたネイバーの IP アドレス

現在ルーティングされている VC のステートを表示するには、show mpls l2transport vc コマンドを入力します。

Router# show mpls l2transport vc
 
Local intf Local circuit Dest address VC ID Status
------------- -------------------- --------------- ---------- ----------
Vl2 Eth VLAN 2 11.11.11.11 2 UP
Vl3 Eth VLAN 3 11.11.11.11 3 UP
 

各 VC の詳細情報を表示するには、detail キーワードを追加します。

Router# show mpls l2transport vc detail
Local interface:Vl2 up, line protocol up, Eth VLAN 2 up
Destination address:11.11.11.11, VC ID:2, VC status:up
Tunnel label:17, next hop 34.0.0.2
Output interface:GE3/3, imposed label stack {17 18}
Create time:01:24:44, last status change time: 00:10:55
Signaling protocol:LDP, peer 11.11.11.11:0 up
MPLS VC labels:local 20, remote 18
Group ID:local 71, remote 89
MTU:local 1500, remote 1500
Remote interface description:
Sequencing:receive disabled, send disabled
VC statistics:
packet totals:receive 1009, send 1019
byte totals:receive 133093, send 138089
packet drops:receive 0, send 0
 
Local interface:Vl3 up, line protocol up, Eth VLAN 3 up
Destination address:11.11.11.11, VC ID:3, VC status:up
Tunnel label:17, next hop 34.0.0.2
Output interface:GE3/3, imposed label stack {17 19}
Create time:01:24:38, last status change time: 00:10:55
Signaling protocol:LDP, peer 11.11.11.11:0 up
MPLS VC labels:local 21, remote 19
Group ID:local 72, remote 90
MTU:local 1500, remote 1500
Remote interface description:
Sequencing:receive disabled, send disabled
VC statistics:
packet totals:receive 1406, send 1414
byte totals:receive 185497, send 191917
packet drops:receive 0, send 0

ポートベース EoMPLS の設定

Cisco IOS Release 12.2SX でポートベース EoMPLS を設定する際に、以下の注意事項と制約事項に従ってください。

AToM 制御ワードはサポートされていません。

ハードウェアレベルの CRC エラー、フレーミング エラー、ラント パケットを含むイーサネット パケットは、入力時に廃棄されます。

ポートベース EoMPLS および VLAN ベース EoMPLS は相互に排他的な関係です。メイン インターフェイスでポートツーポート トランスポートをイネーブルにした場合、サブインターフェイスでのコマンドも入力できません。

Cisco IOS Release 12.2SX で EoMPLS による 802.1Q-in-802.1Q トラフィックおよびイーサネット トラフィックをサポートするには、次の作業を行って、ポートベースの EoMPLS を設定します。

 

コマンド
目的

ステップ 1

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

Router(config)# interface gigabitethernetslot/interface

ギガビット イーサネット インターフェイスを指定します。隣接 CE ルータのインターフェイスがこの PE ルータと同じ VLAN 上にあることを確認します。

ステップ 3

Router(config-if)# xconnect peer_router_id vcid encapsulation mpls

接続回路を疑似接続 VC にバインドします。このコマンドの構文は、その他のレイヤ 2 トランスポートの場合と同じです。

次に、ポートベースの基本設定の例を示します。

!
EoMPLS:
 
router# show mpls l2transport vc
 
Local intf Local circuit Dest address VC ID Status
------------- -------------------- --------------- ---------- ----------
Fa8/48 Ethernet 75.0.78.1 1 UP
Gi7/11.2000 Eth VLAN 2000 75.0.78.1 2000 UP
 
 
Port-Based EoMPLS Config:
 
router# show run interface f8/48
Building configuration...
 
Current configuration : 86 bytes
!
interface FastEthernet8/48
no ip address
xconnect 75.0.78.1 1 encapsulation mpls
end
 
Sub-Interface Based Mode:
router# show run interface g7/11
Building configuration...
 
Current configuration : 118 bytes
!
interface GigabitEthernet7/11
description Traffic-Generator
no ip address
logging event link-status
speed nonegotiate
end
 
router# show run int g7/11.2000
Building configuration...
 
Current configuration : 112 bytes
!
interface GigabitEthernet7/11.2000
encapsulation dot1Q 2000
xconnect 75.0.78.1 2000 encapsulation mpls
end
 
kb7606# show mpls l2transport vc 1 detail
Local interface: Gi7/47 up, line protocol up, Ethernet up
Destination address: 75.0.80.1, VC ID: 1, VC status: up
Tunnel label: 5704, next hop 75.0.83.1
Output interface: Te8/3, imposed label stack {5704 10038}
Create time: 00:30:33, last status change time: 00:00:43
Signaling protocol: LDP, peer 75.0.80.1:0 up
MPLS VC labels: local 10579, remote 10038
Group ID: local 155, remote 116
MTU: local 1500, remote 1500
Remote interface description:
Sequencing: receive disabled, send disabled
VC statistics:
packet totals: receive 26, send 0
byte totals: receive 13546, send 0
packet drops: receive 0, send 0
 

VC タイプを取得するには、次のコマンドを使用します。

kb7606# remote command switch show mpls l2transport vc 1 de
 
Local interface: GigabitEthernet7/47, Ethernet
Destination address: 75.0.80.1, VC ID: 1
VC status: receive UP, send DOWN
VC type: receive 5, send 5
Tunnel label: not ready, destination not in LFIB
Output interface: unknown, imposed label stack {}
MPLS VC label: local 10579, remote 10038
Linecard VC statistics:
packet totals: receive: 0 send: 0
byte totals: receive: 0 send: 0
packet drops: receive: 0 send: 0
Control flags:
receive 1, send: 31
!

設定の確認

MPLS トンネルを介したレイヤ 2 VLAN トランスポートの設定を確認および表示するには、次の作業を行います。

VLAN ごとの VLAN 名、ステータス、ポートを 1 行で表示するには、show vlan brief コマンドを使用します。

Router# show vlan brief
 
VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
1 default active
2 VLAN0002 active Gi1/4
1002 fddi-default act/unsup
1003 token-ring-default act/unsup
1004 fddinet-default act/unsup
1005 trnet-default act/unsup
 

PE ルータ エンドポイントが相互に検出されたことを確認するには、show mpls ldp discovery コマンドを使用します。PE ルータが別の PE ルータから LDP Hello メッセージを受信した場合、そのルータおよび指定されたラベル スペースは「検出された」とみなされます。

Router# show mpls ldp discovery
Local LDP Identifier:
13.13.13.13:0
Discovery Sources:
Interfaces:
GE-WAN3/3 (ldp):xmit/recv
LDP Id: 12.12.12.12:0
Targeted Hellos:
13.13.13.13 -> 11.11.11.11 (ldp):active/passive, xmit/recv
LDP Id: 11.11.11.11:0
 

ラベル配布セッションが確立されたことを確認するには、show mpls ldp neighbor コマンドを使用します。出力の 3 行めは、LDP セッションのステートが動作可能であり、メッセージが送受信中であることを示します。

Router# show mpls ldp neighbor
Peer LDP Ident:12.12.12.12:0; Local LDP Ident 13.13.13.13:0
TCP connection: 12.12.12.12.646 - 13.13.13.13.11010
State:Oper; Msgs sent/rcvd:1715/1706; Downstream
Up time:1d00h
LDP discovery sources:
GE-WAN3/3, Src IP addr: 34.0.0.2
Addresses bound to peer LDP Ident:
23.2.1.14 37.0.0.2 12.12.12.12 34.0.0.2
99.0.0.1
Peer LDP Ident:11.11.11.11:0; Local LDP Ident 13.13.13.13:0
TCP connection: 11.11.11.11.646 - 13.13.13.13.11013
State:Oper; Msgs sent/rcvd:1724/1730; Downstream
Up time:1d00h
LDP discovery sources:
Targeted Hello 13.13.13.13 -> 11.11.11.11, active, passive
Addresses bound to peer LDP Ident:
11.11.11.11 37.0.0.1 23.2.1.13
 

ラベル転送テーブルが正しく構築されたかを確認するには、show mpls forwarding-table コマンドを入力します。

Router# show mpls forwarding-table
Local Outgoing Prefix Bytes tag Outgoing Next Hop
tag tag or VC or Tunnel Id switched interface
16 Untagged 223.255.254.254/32 \
0 Gi2/1 23.2.0.1
20 Untagged l2ckt(2) 55146580 Vl2 point2point
24 Pop tag 37.0.0.0/8 0 GE3/3 34.0.0.2
25 17 11.11.11.11/32 0 GE3/3 34.0.0.2
26 Pop tag 12.12.12.12/32 0 GE3/3 34.0.0.2
 

出力では次のデータが表示されます。

Local tag -- このルータによって割り当てられたラベル

Outgoing tag or VC -- ネクストホップによって割り当てられたラベル

Prefix or Tunnel ID -- このラベルが添付されたパケットの送信先アドレスまたはトンネル

Bytes tag switched -- この着信ラベルによってスイッチングされるバイト数

Outgoing interface -- このラベルが添付されたパケットが送信されるインターフェイス

Next Hop -- 発信ラベルに割り当てられたネイバーの IP アドレス

現在ルーティングされている VC のステートを表示するには、show mpls l2transport vc コマンドを入力します。

Router# show mpls l2transport vc
 
Local intf Local circuit Dest address VC ID Status
------------- -------------------- --------------- ---------- ----------
Vl2 Eth VLAN 2 11.11.11.11 2 UP
 

LAN カードでの MUX-UNI サポートの設定

User Network Interface(UNI; ユーザ ネットワーク インターフェイス)は、CE 機器と入力 PE の接続ポイントで、接続 VLAN は UNI ポートの VLAN です。

LAN カードの MUX-UNI サポート機能では、接続 VLAN の物理ポートを分割して、単一の UNI で複数のレイヤ 2 およびレイヤ 3 サービスを提供できます。

LAN カードの MUX-UNI サポートを設定する際に、以下の注意事項と制約事項に従ってください。

メイン インターフェイスでのカプセル化は、ISL ではなく dot1Q にする必要があります。

メイン インターフェイスで dot1q カプセル化を使用すると、サブインターフェイスで ISL を設定することはできません。レイヤ 3 インターフェイスに影響はありません。

LAN カードで MUX-UNI サポートを設定する場合、PE ルータで次の作業を行ってください。

 

コマンド
目的

ステップ 1

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

Router(config)# interface type number

設定するインターフェイスを指定して、インターフェイス コンフィギュレーション モードを開始します(イーサネット ポートのみで有効)。

ステップ 3

Router(config-if)# switchport

レイヤ 3 モードのインターフェイスを、レイヤ 2 設定用にレイヤ 2 モードにします。

ステップ 4

Router(config-if)# switchport trunk encapsulation {isl | dot1q}

802.1Q カプセル化をサポートするようポートを設定します。

リンクの両端で同一のカプセル化タイプを設定する必要があります。


) MUX-UNI サポートの有効な選択肢は dot1Q です。


ステップ 5

Router(config-if)# switchport mode trunk

ポートを VLAN トランクとして設定します。

ステップ 6

Router(config-if)# switchport trunk allowed vlan vlan-list

デフォルトでは、すべての VLAN が許可されます。VLAN を明示的に許可するには、このコマンドを使用します。 vlan-list の有効な値は、1 ~ 4094 です。


) メイン インターフェイスとサブインターフェイス間で VLAN 割り当てが重複しないようにしてください。メイン インターフェイスとサブインターフェイス間の VLAN 割り当ては、相互に排他的にする必要があります。


ステップ 7

Router(config-if)# exit

インターフェイス コンフィギュレーション モードを終了します。

ステップ 8

Router(config)# interface type slot/port.subinterface-number

設定するサブインターフェイスを指定して、インターフェイス コンフィギュレーション モードを開始します(イーサネット ポートのみで有効)。

ステップ 9

Router(config-if)# encapsulation dot1q vlan_id

サブインターフェイスでの 802.1Q VLAN パケットの受信をイネーブルにします。

EoMPLS が稼働している CE ルータと PE ルータ間のサブインターフェイスは、同じサブネット内に存在する必要があります。その他のすべてのサブインターフェイスおよびバックボーン ルータは、同じサブネット内に存在する必要はありません。

ステップ 10

Router(config-if)# xconnect peer_router_id vcid encapsulation mpls

接続回路を疑似接続 VC にバインドします。このコマンドの構文は、その他のレイヤ 2 トランスポートの場合と同じです。

次に、UNI として使用される物理トランク ポートの例を示します。

Router(config)# interface Fastethernet3/1
Router(config-if)# switchport
Router(config-if)# switchport encapsulation dot1q
Router(config-if)# switchport mode trunk
Router(config-if)# switchport trunk allowed VLAN 200-250

Router(config-if)# exit

 
Router(config)# interface Fastethernet3/1.10
Router(config-if)# encap dot1q 3000
Router(config-if)# xconnect 10.0.0.1 3000 encapsulation mpls

Router(config-if)# exit

 
 

次に、UNI として使用されるレイヤ 2 ポート チャネルの例を示します。

Router(config)# interface Port-channel100
Router(config-if)# switchport
Router(config-if)# switchport trunk encapsulation dot1q
Router(config-if)# switchport trunk allowed VLAN 100-200
Router(config-if)# switchport mode trunk
Router(config-if)# no ip address

Router(config-if)# exit

 
Router(config)# interface Port-channel100.1
Router(config-if)# encapsulation dot1Q 3100
Router(config-if)# xconnect 10.0.0.30 100 encapsulation mpls

Router(config-if)# exit

 
 

次に、多重化 UNI ポートのレイヤ 3 終端および VRF の例を示します。

 
Router(config)# vlan 200, 300, 400
Router(config)# interface Fastethernet3/1
Router(config-if)# switchport
Router(config-if)# switchport encapsulation dot1q
Router(config-if)# switchport mode trunk
Router(config-if)# switchport trunk allowed VLAN 200-500

Router(config-if)# exit

 
Router(config)# interface Fastethernet3/1.10
Router(config-if)# encap dot1q 3000
Router(config-if)# xconnect 10.0.0.1 3000 encapsulation mpls

Router(config-if)# exit

 
Router(config)# interface Vlan 200
Router(config-if)# ip address 1.1.1.3

Router(config-if)# exit

 
Router(config)# interface Vlan 300
Router(config-if)# ip vpn VRF A
Router(config-if)# ip address 3.3.3.1

Router(config-if)# exit

 
Router(config)# interface Vlan 400
Router(config-if)# ip address 4.4.4.1
Router(config-if)# ip ospf network broadcast
Router(config-if)# mpls label protocol ldp
Router(config-if)# mpls ip

Router(config-if)# exit