Catalyst Supervisor Engine 32 PISA Cisco IOS ソフトウェア コンフィギュレーション ガイド, 12.2ZY
レイヤ 2 スイッチング用 LAN ポートの設定
レイヤ 2 スイッチング用 LAN ポートの設定
発行日;2012/02/01 | 英語版ドキュメント(2011/03/28 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 21MB) | フィードバック

目次

レイヤ 2 スイッチング用 LAN ポートの設定

レイヤ 2 スイッチングの機能概要

レイヤ 2 イーサネット スイッチングの概要

レイヤ 2 イーサネット スイッチングの概要

セグメント間のフレーム スイッチング

アドレス テーブルの作成

VLAN トランクの概要

トランキングの概要

カプセル化タイプ

レイヤ 2 LAN ポート モード

レイヤ 2 LAN インターフェイスのデフォルト設定

レイヤ 2 LAN インターフェイス設定時の注意事項および制約事項

レイヤ 2 スイッチング用の LAN インターフェイスの設定

レイヤ 2 スイッチング用の LAN ポートの設定

トランクとしてのレイヤ 2 スイッチング ポートの設定

ISL または 802.1Q トランクとしてのレイヤ 2 スイッチング ポートの設定

DTP を使用するためのレイヤ 2 トランクの設定

DTP を使用しないようにするためのレイヤ 2 トランクの設定

アクセス VLAN の設定

802.1Q ネイティブ VLAN の設定

トランク上で許容される VLAN のリストの設定

プルーニング適格 VLAN のリストの設定

トランクの設定の完了

レイヤ 2 トランクの設定の確認

設定および確認の例

レイヤ 2 アクセス ポートとしての LAN インターフェイスの設定

カスタム IEEE 802.1Q EtherType フィールド値の設定

レイヤ 2 スイッチング用 LAN ポートの設定

この章では、コマンドライン インターフェイス(CLI)を使用して、Catalyst 6500 シリーズ スイッチ上でレイヤ 2 スイッチング用のイーサネット、ファスト イーサネット、ギガビット イーサネット、および 10 ギガビット イーサネット LAN ポートを設定する手順について説明します。この章の設定作業は、LAN スイッチング モジュール上の LAN ポート、およびスーパーバイザ エンジン上の LAN ポートに適用されます。


) • この章で使用しているコマンドの構文および使用方法の詳細については、次の URL で『Catalyst Supervisor Engine 32 PISA Cisco IOS Command Reference, Release 12.2ZY』を参照してください。

http://www.cisco.com/en/US/docs/switches/lan/catalyst6500/ios/12.2ZY/command/reference/cmdref.html

レイヤ 3 インターフェイスの設定手順については、 第 19 章「レイヤ 3 インターフェイスの設定」 を参照してください。


 

この章で説明する内容は、次のとおりです。

「レイヤ 2 スイッチングの機能概要」

「レイヤ 2 LAN インターフェイスのデフォルト設定」

「レイヤ 2 LAN インターフェイス設定時の注意事項および制約事項」

「レイヤ 2 スイッチング用の LAN インターフェイスの設定」

レイヤ 2 スイッチングの機能概要

ここでは、Catalyst 6500 シリーズ スイッチにおけるレイヤ 2 スイッチングの機能について説明します。

「レイヤ 2 イーサネット スイッチングの概要」

「VLAN トランクの概要」

「レイヤ 2 LAN ポート モード」

レイヤ 2 イーサネット スイッチングの概要

ここではレイヤ 2 イーサネット スイッチングについて説明します。

「レイヤ 2 イーサネット スイッチングの概要」

「セグメント間のフレーム スイッチング」

「アドレス テーブルの作成」

レイヤ 2 イーサネット スイッチングの概要

Catalyst 6500 シリーズ スイッチは、レイヤ 2 イーサネット セグメント間の同時パラレル接続をサポートしています。イーサネット セグメント間のスイッチド コネクションが維持されるのは、パケットの伝送時間の長さだけです。次のパケットには、別のセグメント間に新しい接続が確立されます。

Catalyst 6500 シリーズ スイッチは、広帯域の装置および大量のユーザに起因する輻輳問題を解決するために、装置(サーバなど)ごとに専用の 10 Mbps、100 Mbps、または 1000 Mbps 衝突ドメインを割り当てます。各 LAN ポートは、それぞれ別のイーサネット衝突ドメインに接続されているので、スイッチング環境が適切に設定されていれば、サーバは全帯域幅にアクセスできます。

衝突はイーサネット ネットワークにおける重大な障害になっていますが、有効な解決策の 1 つは全二重通信です。通常、イーサネットは半二重モードで動作します。つまり、各ステーションは送信または受信のどちらか一方しか実行できません。全二重モードでは、2 つのステーション間で同時に送受信を行うことができます。パケットは両方向で同時に流れることができる場合、有効なイーサネット帯域幅が 2 倍になります。

セグメント間のフレーム スイッチング

Catalyst 6500 シリーズ スイッチ上の各 LAN ポートは、1 台のワークステーションまたはサーバに接続することも、ハブを介して複数のワークステーションまたはサーバをネットワークに接続することもできます。

標準的なイーサネット ハブでは、すべてのポートがハブ内の共通のバックプレーンに接続され、ハブに接続されたすべての装置が、ネットワークの帯域幅を共用します。2 つのステーション間で、相当量の帯域幅を使用するセッションを確立した場合には、そのハブに接続された他のすべてのステーションで、ネットワークのパフォーマンスが低下します。

このようなパフォーマンス低下を軽減するために、スイッチは各 LAN ポートをそれぞれ独立したセグメントとして扱います。異なる LAN ポートに接続されているステーションが相互に通信する必要がある場合、スイッチは、一方の LAN ポートから他方の LAN ポートにワイヤ速度でフレームを転送して、各セッションが全帯域幅を利用できるようにします。

LAN ポート間のフレーム スイッチングを効率的に行うために、スイッチはアドレス テーブルを維持します。フレームがスイッチに着信すると、スイッチは送信元ネットワーク装置の MAC アドレスと、フレームを受信した LAN ポートを対応付けます。

アドレス テーブルの作成

Catalyst 6500 シリーズ スイッチは、受信したフレームの送信元アドレスを使用して、アドレス テーブルを作成します。アドレス テーブルに宛先アドレスが登録されていないフレームをスイッチが受信すると、そのフレームを受信したポート以外の、同一 VLAN のすべての LAN ポートに、フレームをフラッディングします。宛先ステーションから応答があると、スイッチは関連する送信元アドレスおよびポート ID をアドレス テーブルに追加します。スイッチは以後、LAN ポートすべてに後続フレームをフラッディングせずに、1 つの LAN ポートだけに転送します。

アドレス テーブルには、エントリのフラッディングを伴わずに 32,000 以上のアドレス エントリを保管できます。スイッチは設定変更可能なエージング タイマーによって定められたエージング メカニズムを使用するので、アドレスが所定の秒数だけ非アクティブ状態になると、アドレス テーブルから削除されます。

VLAN トランクの概要

ここでは、Catalyst 6500 シリーズ スイッチ上での VLAN トランクについて説明します。

「トランキングの概要」

「カプセル化タイプ」

トランキングの概要


) VLAN の詳細については、第 12 章「VLAN の設定」を参照してください。


トランクとはスイッチとその他のネットワーキング装置間のポイントツーポイント リンクです。トランクは 1 つのリンクを介して複数の VLAN トラフィックを伝送するので、VLAN をネットワーク全体に拡張することができます。

次の 2 種類のトランキング カプセル化方式が、すべてのイーサネット ポートで使用可能です。

Inter-Switch Link(ISL; スイッチ間リンク):ISL はシスコ独自のトランキング カプセル化方式です。


) 次のスイッチング モジュールは ISL カプセル化をサポートしていません。

• WS-X6502-10GE
• WS-X6548-GE-TX、WS-X6548V-GE-TX、WS-X6548-GE-45AF
• WS-X6148-GE-TX、WS-X6148V-GE-TX、WS-X6148-GE-45AF


802.1Q:802.1Q は、業界標準のトランキング カプセル化方式です。

1 つのイーサネット ポートまたは EtherChannel に対してトランクを設定できます。EtherChannel の詳細については、 第 10 章「EtherChannel の設定」 を参照してください。

イーサネット トランク ポートは、数種類のトランキング モードをサポートしています(表 8-2を参照)。さらに、トランクでの ISL または 802.1Q カプセル化の使用、またはカプセル化タイプの自動ネゴシエーションを指定することもできます。


) カプセル化タイプをネゴシエーションするように LAN ポートを設定できます。カプセル化タイプをネゴシエーションするように WAN インターフェイスを設定することはできません。


Dynamic Trunking Protocol(DTP; ダイナミック トランキング プロトコル)は LAN ポート上のトランク自動ネゴシエーションを管理します。DTP は、ISL トランクおよび 802.1Q トランクの両方で自動ネゴシエーションをサポートします。

トランキングを自動ネゴシエーションするには、LAN ポートが同じ VLAN Trunking Protocol(VTP; VLAN トランキング プロトコル)ドメインに存在する必要があります。異なるドメイン内の LAN ポートを強制的にトランクするには、 trunk キーワードまたは nonegotiate キーワードを使用します。VTP ドメインの詳細については、 第 11 章「VLAN トランキング プロトコル(VTP)の設定」 を参照してください。

カプセル化タイプ

表 8-1 に、イーサネット トランクのカプセル化タイプを示します。

 

表 8-1 イーサネット トランクのカプセル化タイプ

カプセル化
機能

switchport trunk encapsulation isl

トランク リンクに ISL カプセル化を指定します。

(注) ISL カプセル化をサポートしていないモジュールもあります(「トランキングの概要」を参照)。

switchport trunk encapsulation dot1q

トランク リンクに 802.1Q カプセル化を指定します。

switchport trunk encapsulation negotiate

LAN ポートが近接 LAN ポートとネゴシエーションを行い、近接 LAN ポートの設定および機能に応じて、ISL トランク(優先)または 802.1Q トランクになるように指定します。

リンクが ISL トランクまたは 802.1Q トランクのどちらになるかは、接続された 2 つの LAN ポートのトランキング モード、トランク カプセル化タイプ、およびハードウェア機能によって決まります。

レイヤ 2 LAN ポート モード

表 8-2 に、レイヤ 2 LAN ポート モードを示し、LAN ポートにおける各モードの機能について説明します。

 

表 8-2 レイヤ 2 LAN ポート モード

モード
機能

switchport mode access

LAN ポートは永続的な非トランキング モードになり、リンクを非トランク リンクに変換するようにネゴシエーションを行います。近接 LAN ポートが変更に同意しなくても、LAN ポートは非トランク ポートになります。

switchport mode dynamic desirable

リンクからトランク リンクへの変換を LAN ポートにアクティブに試行させます。近接 LAN ポートが trunk desirable 、または auto モードに設定されていれば、LAN ポートはトランク ポートになります。このモードは、すべての LAN ポートのデフォルト モードです。

switchport mode dynamic auto

LAN ポートにリンクからトランク リンクへの変換を試行させます。近接 LAN ポートが trunk または desirable モードに設定されていれば、LAN ポートはトランク ポートになります。

switchport mode trunk

LAN ポートは永続的なトランキング モードになり、リンクをトランク リンクに変換するようにネゴシエーションを行います。近接ポートが変更に同意しなくても、LAN ポートはトランク ポートになります。

switchport nonegotiate

LAN ポートを永続的なトランキング モードにしますが、LAN ポートが DTP フレームを生成するのを防ぎます。トランク リンクを確立するには、近接ポートを手動でトランク ポートとして設定する必要があります。


DTP は PPP(ポイントツーポイント プロトコル)です。ただし、インターネットワーキング装置によっては、DTP フレームが正しく転送されないことがあります。この問題を避けるために、これらのリンク上でトランキングを行わない場合は、DTP をサポートしない装置に接続されている LAN ポートが、access キーワードを使用して設定されていることを確認してください。DTP をサポートしない装置へのトランキングをイネーブルにするには、nonegotiate キーワードを使用して、LAN ポートをトランクにし、DTP フレームが生成されないようにします。


レイヤ 2 LAN インターフェイスのデフォルト設定

表 8-3 に、レイヤ 2 LAN ポートのデフォルト設定を示します。

 

表 8-3 レイヤ 2 LAN インターフェイスのデフォルト設定

機能
デフォルト

インターフェイス モード:

switchport コマンドの入力前

レイヤ 3(未設定)

switchport コマンドの入力後

switchport mode dynamic desirable

トランク カプセル化

switchport trunk encapsulation negotiate

VLAN 許容範囲

VLAN 1 ~ 4094(予約済み VLAN を除く)(表 12-1 を参照)

プルーニングに適格な VLAN 範囲

VLAN 2 ~ 1001

デフォルト アクセス VLAN

VLAN 1

ネイティブ VLAN(802.1Q トランク用)

VLAN 1

Spanning Tree Protocol(STP; スパンニングツリー プロトコル)

すべての VLAN でイネーブル

STP ポート プライオリティ

128

STP ポート コスト

10 Mbps イーサネット LAN ポートでは 100

10/100 Mbps ファスト イーサネット LAN ポートでは 19

100 Mbps ファスト イーサネット LAN ポートでは 19

1,000 Mbps ギガビット イーサネット LAN ポートでは 4

10,000 Mbps 10 ギガビット イーサネット LAN ポートでは 2

レイヤ 2 LAN インターフェイス設定時の注意事項および制約事項

レイヤ 2 LAN ポートを設定する際に、以下の注意事項と制約事項に従ってください。

次のスイッチング モジュールは、ISL カプセル化をサポートしません。

WS-X6502-10GE

WS-X6548-GE-TX、WS-X6548V-GE-TX、WS-X6548-GE-45AF

WS-X6148-GE-TX、WS-X6148V-GE-TX、WS-X6148-GE-45AF

次に示す設定時の注意事項および制約事項は、802.1Q トランクを使用するときに適用され、ネットワークのトランキングの構築方法が多少制限されます。802.1Q トランクを使用するときは、これらの制約事項に注意してください。

802.1Q トランクを介してシスコ製スイッチを接続するときは、802.1Q トランクのネイティブ VLAN がトランク リンクの両端で同じであることを確認してください。トランクの一端のネイティブ VLAN と他端のネイティブ VLAN が異なると、スパニングツリー ループの原因になります。

ネットワーク上のすべてのネイティブ VLAN についてスパニングツリーをディセーブルにせずに、802.1Q トランクの VLAN 上のスパニングツリーをディセーブルにすると、スパニングツリー ループが発生することがあります。802.1Q トランクのネイティブ VLAN 上で、スパニング ツリーをイネーブルのままにしておくことを推奨します。この設定ができない場合は、ネットワークのすべての VLAN 上でスパニング ツリーをディセーブルにしてください。スパニングツリーをディセーブルにする場合には、事前にネットワークに物理的なループが存在しないことを確認してください。

802.1Q トランクを介して 2 台のシスコ製スイッチを接続すると、トランク上で許容される VLAN ごとにスパニングツリー Bridge Protocol Data Unit(BPDU; ブリッジ プロトコル データ ユニット)が交換されます。トランクのネイティブ VLAN 上の BPDU は、タグなしの状態で、予約済み IEEE 802.1d スパニングツリー マルチキャスト Media Access Control(MAC; メディア アクセス制御)アドレス(01-80-C2-00-00-00)に送信されます。トランクの他のすべての VLAN 上の BPDU は、タグ付きの状態で、予約済み Cisco Shared Spanning Tree(SSTP)マルチキャスト MAC アドレス(01-00-0c-cc-cc-cd)に送信されます。

他社製の 802.1Q スイッチでは、すべての VLAN に対してスパニングツリー トポロジを定義するスパニングツリーのインスタンス(Mono Spanning Tree(MST))が 1 つしか維持されません。802.1Q トランクを介してシスコ製スイッチを他社製のスイッチに接続すると、他社製のスイッチの MST とシスコのスイッチのネイティブ VLAN スパニングツリーが組み合わされて、Common Spanning Tree(CST)と呼ばれる単一のスパニングツリー トポロジが形成されます。

シスコ製スイッチは、トランクのネイティブ VLAN 以外の VLAN にある SSTP マルチキャスト MAC アドレスに BPDU を送信します。したがって、他社製のスイッチではこれらのフレームが BPDU として認識されず、対応する VLAN のすべてのポート上でフラッディングされます。他社製の 802.1Q クラウドに接続された他のシスコのスイッチは、フラッディングされたこれらの BPDU を受信します。このようにして、シスコのスイッチは、他社製の 802.1Q スイッチ クラウドにわたって、VLAN 別のスパニングツリー トポロジを維持できます。シスコのスイッチを隔てている他社製の 802.1Q クラウドは、802.1Q トランクを介して他社製の 802.1Q クラウドに接続されたすべてのスイッチ間の単一のブロードキャスト セグメントとして処理されます。

シスコのスイッチを他社製の 802.1Q クラウドに接続するすべての 802.1Q トランク上で、ネイティブ VLAN が同じであることを確認します。

他社製の特定の 802.1Q クラウドに複数のシスコのスイッチを接続する場合は、すべての接続に 802.1Q トランクを使用する必要があります。ISL トランクまたはアクセス ポートを介して、シスコのスイッチを他社製の 802.1Q クラウドに接続することはできません。このように接続すると、スイッチで ISL トランク ポートまたアクセス ポートはスパニングツリーのポート ステートが「一貫しない」状態になり、ポートを介してトラフィックが送信されなくなります。

レイヤ 2 スイッチング用の LAN インターフェイスの設定

ここでは、Catalyst 6500 シリーズ スイッチにおけるレイヤ 2 スイッチングの設定手順について説明します。

「レイヤ 2 スイッチング用の LAN ポートの設定」

「トランクとしてのレイヤ 2 スイッチング ポートの設定」

「レイヤ 2 アクセス ポートとしての LAN インターフェイスの設定」

「カスタム IEEE 802.1Q EtherType フィールド値の設定」


) インターフェイスをデフォルト設定に戻すには、default interface {ethernet | fastethernet | gigabitethernet | tengigabitethernet} slot/port コマンドを使用します。


レイヤ 2 スイッチング用の LAN ポートの設定

レイヤ 2 スイッチング用の LAN ポートを設定するには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# interface type 1 slot/port

設定する LAN ポートを選択します。

ステップ 2

Router(config-if)# shutdown

(任意)設定が完了するまでトラフィック フローを防止するために、インターフェイスをシャットダウンします。

ステップ 3

Router(config-if)# switchport

LAN ポートをレイヤ 2 スイッチング用に設定します。

コマンドを入力してください。

Router(config-if)# no switchport

レイヤ 2 LAN ポートの設定を消去します。

ステップ 4

Router(config-if)# no shutdown

インターフェイスをアクティブにします (インターフェイスをシャットダウンしている場合に限り必要)。

ステップ 5

Router(config-if)# end

コンフィギュレーション モードを終了します。

ステップ 6

Router# show running-config interface [ type 1 slot/port ]

インターフェイスの実行コンフィギュレーションを表示します。

ステップ 7

Router# show interfaces [ type 1 slot/port ] switchport

インターフェイスのスイッチ ポートの設定を表示します。

ステップ 8

Router# show interfaces [ type 1 slot/port ] trunk

インターフェイスのトランクの設定を表示します。

1.type = ethernetfastethernetgigabitethernet、または tengigabitethernet

switchport コマンドを入力したあとのデフォルト モードは、 switchport mode dynamic desirable です。近接ポートがトランキングをサポートし、かつトランキングを許可するように設定されている場合、 switchport コマンドを入力すると、リンクはレイヤ 2 トランクになります。LAN トランク ポートは、デフォルトでカプセル化についてネゴシエーションします。近接ポートが ISL および 802.1Q カプセル化をサポートし、かつ両方のポートがカプセル化タイプについてネゴシエーションするように設定されていれば、トランクは ISL カプセル化を使用します(10 ギガビット イーサネット ポートは ISL カプセル化をサポートしません)。


) レイヤ 3 用に設定されていたポートを switchport コマンドを使用してレイヤ 2 用に設定すると、レイヤ 3 用のコンフィギュレーションは、実行コンフィギュレーション内からはなくなるものの、メモリ内には残され、ポートがレイヤ 3 に戻された場合にポートに適用されます。同様に、レイヤ 2 用に設定されていたポートをレイヤ 3 用に設定すると、レイヤ 2 用のコンフィギュレーションは、実行コンフィギュレーション内からはなくなるものの、メモリ内には残され、ポートがレイヤ 2 に戻された場合にポートに適用されます。メモリ内および実行コンフィギュレーション内のコンフィギュレーションをポートをデフォルトに戻すには、default interface コマンドを使用します。ポート ロールを switchport コマンドで変更している間に発生する可能性がある問題を回避するために、switchport コマンドの適用はインターフェイスをシャットダウンしてから行ってください。


トランクとしてのレイヤ 2 スイッチング ポートの設定

ここでは、レイヤ 2 スイッチング ポートをトランクとして設定する手順について説明します。

「ISL または 802.1Q トランクとしてのレイヤ 2 スイッチング ポートの設定」

「DTP を使用するためのレイヤ 2 トランクの設定」

「DTP を使用しないようにするためのレイヤ 2 トランクの設定」

「アクセス VLAN の設定」

「802.1Q ネイティブ VLAN の設定」

「トランク上で許容される VLAN のリストの設定」

「プルーニング適格 VLAN のリストの設定」

「トランクの設定の完了」

「レイヤ 2 トランクの設定の確認」

「設定および確認の例」

ISL または 802.1Q トランクとしてのレイヤ 2 スイッチング ポートの設定


) • ここに記載された作業を実行する前に、「レイヤ 2 スイッチング用の LAN ポートの設定」の手順を実行します。

キーワードを指定せずに switchport コマンドを入力した場合(前のセクションの ステップ 3)、デフォルト モードは switchport mode dynamic desirable switchport trunk encapsulation negotiate です。


 

レイヤ 2 スイッチング ポートを ISL または 802.1Q トランクとして設定するには、次の作業を行います。

 

コマンド
目的

Router(config-if)# switchport trunk encapsulation { isl | dot1q | negotiate }

(任意)カプセル化を設定して、レイヤ 2 スイッチング ポートを ISL または 802.1Q トランクとして設定します。

Router(config-if)# no switchport trunk encapsulation

デフォルトのトランク カプセル化モード( negotiate )に戻します。

レイヤ 2 スイッチング ポートを ISL または 802.1Q トランクとして設定する際、次の作業情報に注意してください。

switchport mode trunk コマンド(「DTP を使用しないようにするためのレイヤ 2 トランクの設定」を参照)は、 switchport trunk encapsulation negotiate コマンドとは互換性がありません。

switchport mode trunk コマンドを使用できるようにするには、ISL または 802.1Q としてカプセル化を設定する必要があります。

次のスイッチング モジュールは、ISL カプセル化をサポートしません。

WS-X6502-10GE

WS-X6548-GE-TX、WS-X6548V-GE-TX、WS-X6548-GE-45AF

WS-X6148-GE-TX、WS-X6148V-GE-TX、WS-X6148-GE-45AF


) ここに記載された作業を実行したあとで、「トランクの設定の完了」の手順を実行します。


DTP を使用するためのレイヤ 2 トランクの設定


) ここに記載された作業を実行する前に、「レイヤ 2 スイッチング用の LAN ポートの設定」の手順を実行します。


DTP を使用するようにレイヤ 2 トランクを設定するには、次の作業を行います。

 

コマンド
目的

Router(config-if)# switchport mode dynamic { auto | desirable }

(任意)DTP を使用するようにトランクを設定します。

Router(config-if)# no switchport mode

デフォルトのトランク トランキング モード( switchport mode dynamic desirable )に戻します。

DTP を使用するようにレイヤ 2 トランクを設定する際、次の情報に注意してください。

インターフェイスがレイヤ 2 アクセス ポートの場合、またはトランキング モードを指定する場合に限り必須です。

トランキング モードの詳細については、表 8-2を参照してください。


) ここに記載された作業を実行したあとで、「トランクの設定の完了」の手順を実行します。


DTP を使用しないようにするためのレイヤ 2 トランクの設定


) ここに記載された作業を実行する前に、「レイヤ 2 スイッチング用の LAN ポートの設定」の手順を実行します。


DTP を使用しないようにレイヤ 2 トランクを設定するには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config-if)# switchport mode trunk

(任意)無条件にポートをトランクに設定します。

Router(config-if)# no switchport mode

デフォルトのトランク トランキング モード( switchport mode dynamic desirable )に戻します。

ステップ 2

Router(config-if)# switchport nonegotiate

(任意)DTP を使用しないようにトランクを設定します。

Router(config-if)# no switchport nonegotiate

ポート上で DTP をイネーブルにします。

DTP を使用しないようにレイヤ 2 トランクを設定する際、次の情報に注意してください。

switchport mode trunk コマンドを入力する前に、カプセル化を設定する必要があります(「ISL または 802.1Q トランクとしてのレイヤ 2 スイッチング ポートの設定」を参照)。

switchport nonegotiate コマンドを使用できるようにするには、 switchport mode trunk コマンドを入力する必要があります。

switchport mode dynamic trunk コマンドを入力します。トランキング モードの詳細については、表 8-2を参照してください。

switchport nonegotiate コマンドを入力する前にカプセル化を設定し(「ISL または 802.1Q トランクとしてのレイヤ 2 スイッチング ポートの設定」を参照)、 switchport mode trunk コマンドを使用して無条件にポートをトランクに設定する必要があります(「DTP を使用するためのレイヤ 2 トランクの設定」を参照)。


) ここに記載された作業を実行したあとで、「トランクの設定の完了」の手順を実行します。


アクセス VLAN の設定


) ここに記載された作業を実行する前に、「レイヤ 2 スイッチング用の LAN ポートの設定」の手順を実行します。


アクセス VLAN を設定するには、次の作業を行います。

 

コマンド
目的

Router(config-if)# switchport access vlan vlan_ID

(任意)インターフェイスがトランキングを停止した場合に使用するアクセス VLAN を設定します。 vlan_ID の値は 1 ~ 4094 です(予約済み VLAN は除く。表 12-1を参照)。

Router(config-if)# no switchport access vlan

デフォルト値に戻します(VLAN 1)。


) ここに記載された作業を実行したあとで、「トランクの設定の完了」の手順を実行します。


802.1Q ネイティブ VLAN の設定


) ここに記載された作業を実行する前に、「レイヤ 2 スイッチング用の LAN ポートの設定」の手順を実行します。


802.1Q ネイティブ VLAN を設定するには、次の作業を行います。

 

コマンド
目的

Router(config-if)# switchport trunk native vlan vlan_ID

(任意)802.1Q ネイティブ VLAN を設定します。

Router(config-if)# no switchport trunk native vlan

デフォルト値に戻します(VLAN 1)。

ネイティブ VLAN を設定する際、次の情報に注意してください。

vlan_ID の値は 1 ~ 4094 です(予約済み VLAN は除く。表 12-1を参照)。

アクセス VLAN がネイティブ VLAN として自動的に使用されることはありません。


) ここに記載された作業を実行したあとで、「トランクの設定の完了」の手順を実行します。


トランク上で許容される VLAN のリストの設定


) ここに記載された作業を実行する前に、「レイヤ 2 スイッチング用の LAN ポートの設定」の手順を実行します。


トランク上で許容される VLAN のリストを設定するには、次の作業を行います。

 

コマンド
目的

Router(config-if)# switchport trunk allowed vlan { add | except | none | remove } vlan [, vlan [, vlan [,...]]

(任意)トランク上で許容される VLAN のリストを設定します。

Router(config-if)# no switchport trunk allowed vlan

デフォルト値に戻します(すべての VLAN を許容)。

トランク上で許容される VLAN のリストを設定する際、次の情報に注意してください。

vlan パラメータは、1 ~ 4094 の範囲の単一の VLAN 番号、または 2 つの VLAN 番号(小さい番号が先、ダッシュで区切る)で指定する VLAN 範囲です。カンマで区切った vlan パラメータの間、またはダッシュで指定した範囲の間には、スペースを入れないでください。

デフォルトでは、すべての VLAN が許可されます。

VLAN 1 は削除できます。トランクから VLAN 1 を削除した場合も、トランク インターフェイスは VLAN 1 の Cisco Discovery Protocol(CDP)、VTP、Port Aggregation Protocol(PAgP)、DTP などの管理トラフィックを引き続き送受信します。


) ここに記載された作業を実行したあとで、「トランクの設定の完了」の手順を実行します。


プルーニング適格 VLAN のリストの設定


) ここに記載された作業を実行する前に、「レイヤ 2 スイッチング用の LAN ポートの設定」の手順を実行します。


レイヤ 2 トランクでプルーニング適格 VLAN のリストを設定するには、次の作業を行います。

 

コマンド
目的

Router(config-if)# switchport trunk pruning vlan { none |{{ add | except | remove } vlan [, vlan [, vlan [,...]]}}

(任意)トランクでプルーニング適格 VLAN のリストを設定します(「VTP プルーニングの概要」を参照)。

Router(config-if)# no switchport trunk pruning vlan

デフォルト値に戻します(すべての VLAN がプルーニング適格)。

トランク上で許容されるプルーニング適格 VLAN のリストを設定する際、次の情報に注意してください。

vlan パラメータは、1 ~ 4094 の範囲の単一の VLAN 番号(予約済み VLAN を除く。表 12-1 を参照)、または 2 つの VLAN 番号(小さい番号が先、ダッシュで区切る)で指定する VLAN 範囲です。カンマで区切った vlan パラメータの間、またはダッシュで指定した範囲の間には、スペースを入れないでください。

デフォルトでは、プルーニングが許容される VLAN のリストには、すべての VLAN が含まれます。

VTP トランスペアレント モードのネットワーク装置は、VTP Join メッセージを送信しません。VTP トランスペアレント モードのネットワーク装置にトランク接続されている Catalyst 6500 シリーズ スイッチでは、トランスペアレント モード ネットワーク装置によって使用される VLAN、またはプルーニング不適格としてトランスペアレント モード ネットワーク装置全体に伝送する必要がある VLAN を設定します。


) ここに記載された作業を実行したあとで、「トランクの設定の完了」の手順を実行します。


トランクの設定の完了

レイヤ 2 トランクの設定を完了するには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config-if)# no shutdown

インターフェイスをアクティブにします (インターフェイスをシャットダウンしている場合に限り必要)。

ステップ 2

Router(config-if)# end

コンフィギュレーション モードを終了します。

レイヤ 2 トランクの設定の確認

レイヤ 2 トランクの設定を確認するには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router# show running-config interface type 2 slot/port

インターフェイスの実行コンフィギュレーションを表示します。

ステップ 2

Router# show interfaces [ type 1 slot/port] switchport

インターフェイスのスイッチ ポートの設定を表示します。

ステップ 3

Router# show interfaces [ type 1 slot/port] trunk

インターフェイスのトランクの設定を表示します。

2.type = ethernetfastethernetgigabitethernet、または tengigabitethernet

設定および確認の例

次に、ポート FastEthernet 5/8 を 802.1Q トランクとして設定する例を示します。この例では、近接ポートが 802.1Q トランキングをサポートするように設定されていることを前提としています。

Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# interface fastethernet 5/8
Router(config-if)# shutdown
Router(config-if)# switchport
Router(config-if)# switchport mode dynamic desirable
Router(config-if)# switchport trunk encapsulation dot1q
Router(config-if)# no shutdown
Router(config-if)# end
Router# exit
 

次に、設定を確認する例を示します。

Router# show running-config interface fastethernet 5/8
Building configuration...
Current configuration:
!
interface FastEthernet5/8
no ip address
switchport
switchport trunk encapsulation dot1q
end
 
Router# show interfaces fastethernet 5/8 switchport
Name: Fa5/8
Switchport: Enabled
Administrative Mode: dynamic desirable
Operational Mode: trunk
Administrative Trunking Encapsulation: negotiate
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: Enabled
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: ALL
 
Router# show interfaces fastethernet 5/8 trunk
 
Port Mode Encapsulation Status Native vlan
Fa5/8 desirable n-802.1q trunking 1
 
Port Vlans allowed on trunk
Fa5/8 1-1005
 
Port Vlans allowed and active in management domain
Fa5/8 1-6,10,20,50,100,152,200,300,303-305,349-351,400,500,521,524,570,801-8
02,850,917,999,1002-1005
 
Port Vlans in spanning tree forwarding state and not pruned
Fa5/8 1-6,10,20,50,100,152,200,300,303-305,349-351,400,500,521,524,570,801-8
02,850,917,999,1002-1005
 
Router#

レイヤ 2 アクセス ポートとしての LAN インターフェイスの設定


) 存在しない VLAN に LAN ポートを割り当てると、VLAN データベースにその VLAN を作成するまで、LAN ポートはシャットダウンされます(「イーサネット VLAN の作成または変更」を参照)。


LAN ポートをレイヤ 2 アクセス ポートとして設定するには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# interface type 3 slot/port

設定する LAN ポートを選択します。

ステップ 2

Router(config-if)# shutdown

(任意)設定が完了するまでトラフィック フローを防止するために、インターフェイスをシャットダウンします。

ステップ 3

Router(config-if)# switchport

LAN ポートをレイヤ 2 スイッチング用に設定します。

コマンドを入力してください。

ステップ 4

Router(config-if)# no switchport

レイヤ 2 LAN ポートの設定を消去します。

ステップ 5

Router(config-if)# switchport mode access

LAN ポートをレイヤ 2 アクセス ポートとして設定します。

Router(config-if)# no switchport mode

デフォルトのスイッチポート モード( switchport mode dynamic desirable )に戻します。

ステップ 6

Router(config-if)# switchport access vlan vlan_ID

LAN ポートを VLAN に入れます。 vlan_ID の値は 1 ~ 4094 です(予約済み VLAN は除く。表 12-1を参照)。

Router(config-if)# no switchport access vlan

デフォルトのアクセス VLAN に戻します(VLAN 1)。

ステップ 7

Router(config-if)# no shutdown

インターフェイスをアクティブにします (インターフェイスをシャットダウンしている場合に限り必要)。

ステップ 8

Router(config-if)# end

コンフィギュレーション モードを終了します。

ステップ 9

Router# show running-config interface [ type 1 slot/port ]

インターフェイスの実行コンフィギュレーションを表示します。

ステップ 10

Router# show interfaces [ type 1 slot/port ] switchport

インターフェイスのスイッチ ポートの設定を表示します。

3.type = ethernetfastethernetgigabitethernet、または tengigabitethernet

次に、ポート FastEthernet 5/6 を VLAN 200 のアクセス ポートとして設定する例を示します。

Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# interface fastethernet 5/6
Router(config-if)# shutdown
Router(config-if)# switchport
Router(config-if)# switchport mode access
Router(config-if)# switchport access vlan 200
Router(config-if)# no shutdown
Router(config-if)# end
Router# exit
 

次に、設定を確認する例を示します。

Router# show running-config interface fastethernet 5/6
Building configuration...
!
Current configuration:
interface FastEthernet5/6
no ip address
switchport access vlan 200
switchport mode access
end
 
Router# show interfaces fastethernet 5/6 switchport
Name: Fa5/6
Switchport: Enabled
Administrative Mode: static access
Operational Mode: static access
Administrative Trunking Encapsulation: negotiate
Operational Trunking Encapsulation: native
Negotiation of Trunking: Enabled
Access Mode VLAN: 200 (VLAN0200)
Trunking Native Mode VLAN: 1 (default)
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: ALL
 
Router#

カスタム IEEE 802.1Q EtherType フィールド値の設定

802.1Q タグ付きまたは 802.1p タグ付きフレームの標準 0x8100 EtherType フィールド値を使用しないネットワーク装置をサポートするように、ポートでカスタム EtherType フィールド値を設定できます。

EtherType フィールドのカスタム値を設定するには、次の作業を行います。

 

コマンド
目的

Router(config-if)# switchport dot1q ethertype value

ポートの 802.1Q EtherType フィールド値を設定します。

Router(config-if)# no switchport dot1q ethertype

デフォルトの 802.1Q EtherType フィールド値(0x8100)に戻します。

カスタム EtherType フィールド値を設定する場合、次の情報に注意してください。

カスタム EtherType フィールド値を使用するには、ネットワーク上のトラフィック パス内のネットワーク装置すべてがカスタム EtherType フィールド値をサポートする必要があります。

トランク ポート、アクセス ポート、トンネル ポート上のカスタム EtherType フィールド値を設定できます。

EtherChannel のメンバー ポート上のカスタム EtherType フィールド値を設定できます。

ポート チャネル インターフェイス上のカスタム EtherType フィールド値は設定できません。

ポートごとに、EtherType フィールド値 1 つだけをサポートします。カスタム EtherType フィールド値で設定されたポートでは、他の EtherType フィールド値を持つフレームはタグ付きフレームとして認識されません。たとえば、カスタム EtherType フィールド値で設定されたトランク ポートでは、802.1Q タグ付きフレームの標準 0x8100 EtherType フィールド値は認識されず、このフレームが属する VLAN にフレームを配置することができません。


注意 カスタム EtherType フィールド値で設定されたポートは、他の EtherType フィールド値を持つフレームをタグなしのフレームと見なします。カスタム EtherType フィールド値を持つトランク ポートは、他の EtherType フィールド値を持つフレームをネイティブ VLAN に配置します。カスタム EtherType フィールド値を持つアクセス ポートまたはトンネル ポートは、他の EtherType フィールド値を持つフレームをアクセス VLAN に配置します。カスタム EtherType フィールド値を正しく設定しないと、フレームは間違った VLAN に配置される場合があります。

カスタム IEEE 802.1Q EtherType フィールド値をサポートするモジュールのリストについては、『 Release Notes for Cisco IOS Release 12.2ZY on the Supervisor Engine 32 PISA 』を参照してください。

次に、EtherType フィールド値を 0x1234 に設定する例を示します。

Router (config-if)# switchport dot1q ethertype 1234
Router (config-if)#