Catalyst 6500 シリーズ スイッチ Cisco IOS ソフトウェア コンフィギュレーション ガイド - リリース 12.1 E
オプションのスパニング ツリー プロトコル (STP)機能の設定
オプションのスパニング ツリー プロトコル(STP)機能の設定
発行日;2012/02/02 | 英語版ドキュメント(2011/06/13 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 10MB) | フィードバック

目次

オプションのスパニング ツリー プロトコル(STP)機能の設定

PortFast の機能概要

BPDU ガードの機能概要

PortFast BPDU フィルタリングの機能概要

UplinkFast の機能概要

BackboneFast の機能概要

EtherChannel ガードの機能概要

ルート ガードの機能概要

ループ ガードの機能概要

PortFast のイネーブル化

PortFast BPDU フィルタリングのイネーブル化

BPDU ガードのイネーブル化

UplinkFast のイネーブル化

BackboneFast のイネーブル化

EtherChannel ガードのイネーブル化

ルート ガードのイネーブル化

ループ ガードのイネーブル化

オプションのスパニング ツリー プロトコル(STP)機能の設定

この章では、オプションの Spanning Tree Protocol(STP; スパニング ツリー プロトコル)機能を設定する手順について説明します。


) この章で使用しているコマンドの構文および使用方法の詳細については、『Catalyst 6500 Series Switch Cisco IOS Command Reference』を参照してください。


この章で説明する内容は、次のとおりです。

「PortFast の機能概要」

「BPDU ガードの機能概要」

「PortFast BPDU フィルタリングの機能概要」

「UplinkFast の機能概要」

「BackboneFast の機能概要」

「EtherChannel ガードの機能概要」

「ルート ガードの機能概要」

「ループ ガードの機能概要」

「PortFast のイネーブル化」

「PortFast BPDU フィルタリングのイネーブル化」

「BPDU ガードのイネーブル化」

「UplinkFast のイネーブル化」

「BackboneFast のイネーブル化」

「EtherChannel ガードのイネーブル化」

「ルート ガードのイネーブル化」

「ループ ガードのイネーブル化」


) • スパニング ツリー プロトコル(STP)の設定手順については、「スパニング ツリー プロトコル(STP)および先行標準 IEEE 802.1s 多重スパニング ツリー(MST)の設定」を参照してください。

Release 12.1(11b)E 以降では、コンフィギュレーション モードで、EXEC モード レベル コマンドの前に do キーワードを入力することによって、EXEC モード レベル コマンドを入力できます。


 

PortFast の機能概要

STP PortFast を使用すると、アクセス ポートとして設定されたレイヤ 2 LAN インターフェイスが、リスニング ステートおよびラーニング ステートを経由せずに、ただちにフォワーディング ステートを開始します。1 台のワークステーションまたはサーバに接続されたレイヤ 2 アクセス ポート上で PortFast を使用すると、STP のコンバージェンスを待たずに、装置がただちにネットワークに接続されます。1 台のワークステーションまたはサーバに接続されたインターフェイスが Bridge Protocol Data Unit(BPDU; ブリッジ プロトコル データ ユニット)を受信しないようにする必要があります。PortFast 用に設定されているポートでも、スパニング ツリー プロトコルは稼動しています。PortFast がイネーブルのポートは、必要に応じて、ブロッキング ステートにただちに移行できます(これは、上位 BPDU を受信したときに発生することがあります)。

Release 12.1(11b)E では、次の機能が導入されています。

トランク ポート上で PortFast をイネーブルにできます。

PortFast には、設定値と異なる動作値を設定できます。


注意 PortFast の目的は、アクセス ポートが STP のコンバージェンスを待つ時間を最小限に抑えることです。したがって、PortFast はアクセス ポート上だけで使用する必要があります。スイッチに接続されたポート上で PortFast をイネーブルにすると、一時的なブリッジング ループが発生するおそれがあります。

BPDU ガードの機能概要

BPDU ガードがポート上でイネーブルになっている場合、BPDU ガードは BPDU を受信するポートをシャットダウンします。BPDU ガードがグローバルに設定されている場合は、BPDU ガードは PortFast 動作ステートのポート上だけで有効です。有効な設定では、PortFast レイヤ 2 LAN インターフェイスは BPDU を受信しません。PortFast レイヤ 2 LAN インターフェイスが BPDU を受信した場合、認証されていない装置が接続された場合と同じように、無効な設定として通知されます。このように BPDU ガード機能では、管理者が手動でレイヤ 2 LAN インターフェイスを再び作動させなければならないため、無効な設定に対する安全な対処が可能になります。Release 12.1(11b)E では、インターフェイス レベルでも BPDU ガード機能を設定することができます。インターフェイス レベルで設定された BPDU ガードは、PortFast 設定に関係なく、ポートが BPDU を受信するとすぐにポートをシャットダウンします。


) グローバルに設定されている BPDU ガードは、PortFast 動作ステートのすべてのインターフェイスに適用されます。


PortFast BPDU フィルタリングの機能概要

PortFast BPDU フィルタリングは、Release 12.1(13)E 以降のリリースでサポートされます。PortFast BPDU フィルタリングを使うことで、管理者は特定ポート上での BPDU 送信や BPDU 受信をシステムで禁止することができます。

グローバルに設定された PortFast BPDU フィルタリングは、動作中のすべての PortFast ポートに適用されます。PortFast 動作ステートのポートは、ホストに接続されていると見なされ、通常 BPDU を廃棄します。動作中の PortFast ポートが BPDU を受信すると、ポートはすぐに PortFast 動作ステータスを失います。この場合、PortFast BPDU フィルタリングはこのポート上でディセーブルになり、STP はポート上で BPDU の送信を再開します。

PortFast BPDU フィルタリングはポート単位で設定することもできます。PortFast BPDU フィルタリングがポート上で明示的に設定されている場合、BPDU は送信されず、受信したすべての BPDU は廃棄されます。


注意 ホストに接続されていないポートに PortFast BPDU フィルタリングを明示的に設定すると、このポートは受信したすべての BPDU を無視し、フォワーディングに移行するため、ブリッジング ループが発生することがあります。

PortFast BPDU フィルタリングをグローバルにイネーブルにし、ポート設定を PortFast BPDU フィルタリングのデフォルトに設定すると(「PortFast BPDU フィルタリングのイネーブル化」を参照)、PortFast は PortFast BPDU フィルタリングをイネーブルまたはディセーブルにします。

ポート設定がデフォルトに設定されていない場合、PortFast 設定は PortFast BPDU フィルタリングに影響しません。 表 16-1 に、使用可能な PortFast BPDU フィルタリングのすべての組み合わせを示します。PortFast BPDU フィルタリングを使用すると、エンド ホストの接続直後に、アクセス ポートがフォワーディング ステートに直接移行できます。

 

表 16-1 PortFast BPDU フィルタリングのポート設定

ポート単位の設定
グローバル コンフィギュレーション
PortFast のステート
PortFast BPDU フィルタリングのステート

デフォルト

イネーブル

イネーブル

イネーブル1

デフォルト

イネーブル

ディセーブル

ディセーブル

デフォルト

ディセーブル

適用不可

ディセーブル

ディセーブル

適用不可

適用不可

ディセーブル

イネーブル

適用不可

適用不可

イネーブル

1.ポートは最低 10 個の BPDU を送信します。このポートがいずれかの BPDU を受信した場合、PortFast および PortFast BPDU フィルタリングはディセーブルになります。

UplinkFast の機能概要

UplinkFast は、直接接続されたリンクの障害発生後、高速コンバージェンスを行い、アップリンク グループを使用して、冗長レイヤ 2 リンク間でロードバランスを実行します。アップリンク グループは、(Virtual LAN [VLAN; 仮想 LAN] ごとの)レイヤ 2 LAN インターフェイスの集合であり、どの時点でも、その中の 1 つのインターフェイスだけがフォワーディングを行います。つまり、アップリンク グループは、(フォワーディングを行う)ルート ポートと、(セルフループを行うポートを除く)ブロックされたポートの集合で構成されます。アップリンク グループは、フォワーディング中のリンクで障害が起きた場合に代替パスを提供します。


) UplinkFast は、配線クローゼット スイッチに使用すると最も効果的です。それ以外の用途には、この機能は有用でない場合もあります。


図 16-1 は、リンク障害が発生していないときのトポロジ例です。スイッチ A(ルート ブリッジ)は、リンク L1 を通じてスイッチ B に、リンク L2 を通じてスイッチ C に直接接続されています。スイッチ B に直接接続されているスイッチ C のレイヤ 2 LAN インターフェイスは、ブロッキング ステートです。

図 16-1 直接リンク障害が発生する前の UplinkFast の例

 

スイッチ C が、現在アクティブ リンクであるルート ポート上の L2 でリンク障害( 直接 リンク障害)を検出すると、UplinkFast はスイッチ C でブロックされていたポートのブロックを解除し、リスニング ステートおよびラーニング ステートを経由せずに、ただちにフォワーディング ステートに移行させます(図 16-2 を参照)。このスイッチ オーバーに要する時間は 1 ~ 5 秒です。

図 16-2 直接リンク障害が発生した後の UplinkFast の例

 

BackboneFast の機能概要

ネットワーク装置上のルート ポートまたはブロックされたポートが、そのポートの指定ブリッジから下位 BPDU を受信すると、BackboneFast が開始されます。下位 BPDU により、1 台のネットワーク装置をルート ブリッジおよび指定ブリッジの両方として識別します。ネットワーク装置が下位 BPDU を受信すると、ネットワーク装置はそのネットワーク装置が直接接続されていないリンク( 間接 リンク)で障害が発生した(つまり、指定ブリッジからルート ブリッジへの接続が切断された)ものと見なします。標準的な STP ルールに従う場合、ネットワーク装置は設定されている最大エージング タイム(STP の max-age コマンドで指定)の間、下位 BPDU を無視します。

ネットワーク装置は、ルート ブリッジへの代替パスの有無を判別します。下位 BPDU がブロックされたポートに到達した場合には、ネットワーク装置のルート ポートおよびその他のブロックされたポートがルート ブリッジへの代替パスになります (セルフループ ポートはルート ブリッジの代替パスとは見なされません)。下位 BPDU がルート ポートに到達した場合には、すべてのブロック ポートがルート ブリッジへの代替パスになります。下位 BPDU がルート ポートに到達し、かつブロックされたポートがない場合には、ネットワーク装置はルート ブリッジへの接続が切断されたものと見なし、ルートの最大エージング タイムを満了させ、通常の STP ルールに従ってルート ブリッジになります。

ネットワーク装置にルート ブリッジへの代替パスがある場合、ネットワーク装置はそれらの代替パスを使用して、Root Link Query PDU と呼ばれる新しい種類の Protocol Data Unit(PDU; プロトコル データ ユニット)を送信します。ネットワーク装置はルート ブリッジへのすべての代替パスに対して、Root Link Query PDU を送信します。ルートへの代替パスがまだ存在していることが判明すると、ネットワーク装置は、下位 BPDU を受信したポートの最大エージング タイムを満了させます。ルート ブリッジへのすべての代替パスが、ネットワーク装置とルート ブリッジ間の接続が切断されていることを示している場合には、ネットワーク装置は、下位 BPDU を受信したポートの最大エージング タイムを満了させます。1 つ以上の代替パスからルート ブリッジに引き続き接続できる場合には、ネットワーク装置は、下位 BPDU を受信したすべてのポートを指定ポートにして、(ブロッキング ステートになっていた場合)ブロッキング ステートから、リスニング ステートおよびラーニング ステートを経て、フォワーディング ステートに移行させます。

図 16-3 は、リンク障害が発生していないときのトポロジ例です。スイッチ A(ルート ブリッジ)は、リンク L1 を通じてスイッチ B に、リンク L2 を通じてスイッチ C に直接接続されています。スイッチ B に直接接続されているスイッチ C のレイヤ 2 LAN インターフェイスは、ブロッキング ステートです。

図 16-3 間接リンク障害が発生する前の BackboneFast の例

 

リンク L1 で障害が発生した場合、スイッチ C はリンク L1 に直接接続されていないため、この障害を検出できません。一方、スイッチ B は L1 を通じてルート ブリッジに直接接続されているため、この障害を検出し、自身をルートに選定し、スイッチ C に対して自身がルートであることを表す BPDU の送信を開始します。スイッチ C がスイッチ B から下位 BPDU を受信すると、スイッチ C は間接障害が発生したことを推測します。この時点で、BackboneFast により、スイッチ C のブロック ポートは、そのポートに設定されている最大エージング タイムの満了を待たずに、ただちにリスニング ステートに移行します。BackboneFast はさらに、スイッチ C のレイヤ 2 LAN インターフェイスをフォワーディング ステートに移行させ、スイッチ B からスイッチ A までのパスを提供します。このスイッチオーバーに要する時間は、約 30 秒(デフォルトの転送遅延時間である 15 秒が設定されている場合、その 2 倍)です。図 16-4 に、BackboneFast がリンク L1 で発生した障害に応じてどのようにトポロジを再設定するかを示します。

図 16-4 間接リンク障害が発生した後の BackboneFast の例

 

図 16-5 に示すメディア共有型トポロジに新しいネットワーク装置が組み込まれた場合、BackboneFast は起動されません。これは、認識している指定ブリッジ(スイッチ B)から下位 BPDU が着信していないためです。新しいネットワーク装置は、自らがルート ブリッジであることを伝える下位 BPDU の送信を開始します。しかし、他のネットワーク装置はこれらの下位 BPDU を無視します。その結果、新しいネットワーク装置はスイッチ B がルート ブリッジであるスイッチ A への代表ブリッジであることを学習します。

図 16-5 メディア共有型トポロジにおけるネットワーク装置の追加

 

EtherChannel ガードの機能概要

EtherChannel ガードは正しく設定されていない EtherChannel を検出します(Catalyst 6500 シリーズ スイッチのインターフェイスが EtherChannel として設定されているが、他の装置のインターフェイスまたはその一部が同じ EtherChannel に設定されていない場合など)。

他の装置の設定に誤りがあることが検出されると、EtherChannel ガードは Catalyst 6500 シリーズ スイッチのインターフェイスを errdisable ステートにします。

ルート ガードの機能概要

STP ルート ガード機能を使用すると、ポートがルート ポートやブロックされたポートにならなくなります。ルート ガードに設定されたポートが上位 BPDU を受信すると、このポートはただちにルートとして一貫性のない(ブロックされた)ステートになります。

ループ ガードの機能概要

ループ ガードを使用すると、ポイントツーポイント リンク上の単一方向リンクの障害によって発生することがあるブリッジング ループを防止することができます。グローバルにイネーブル化されたループ ガードは、システム上のすべてのポイントツーポイント ポートに適用されます。ループ ガードはルート ポートおよびブロックされたポートを検出し、これらのポートがセグメント上の指定ポートから BPDU を受信し続けるようにします。ループ ガードがイネーブルになっているルート ポートまたはブロックされたポートが指定ポートからの BPDU の受信を停止した場合、このポートはポート上に物理リンク エラーがあると想定して、ループに一貫性のないブロッキング ステートに移行します。ポートが BPDU を受信すると、ただちにこのループに一貫性のないステートから回復します。

ループ ガードはポート単位でイネーブルにすることができます。ループ ガードをイネーブルにすると、すべてのアクティブ インスタンスまたはポートが属する VLAN にループ ガードが自動的に適用されます。ループ ガードをディセーブルにした場合は、指定したポートに対してディセーブルになります。ループ ガードをディセーブルにすると、ループに一貫性のないすべてのポートがリスニング ステートに移行します。

チャネル上でループ ガードをイネーブルにした後に、最初のリンクが単一方向リンクになると、ループ ガードは影響を受けたポートがチャネルから削除されるまで、チャネル全体をブロックします。図 16-6 に、三角型のスイッチ設定におけるループ ガードを示します。

図 16-6 ループ ガードが設定された三角型のスイッチ設定

 

図 16-6 に、次の設定を示します。

スイッチ A およびスイッチ B はディストリビューション スイッチです。

スイッチ C はアクセス スイッチです。

ループ ガードは、スイッチ A、B、C のポート 3/1 および 3/2 でイネーブルです。

ルート スイッチ上でループ ガードをイネーブルにしても影響はありませんが、ルート スイッチが非ルート スイッチになると、保護機能が有効になります。

ループ ガードを使用するときは、次の注意事項に従ってください。

PortFast がイネーブルのポートまたはダイナミック VLAN ポートでは、ループ ガードをイネーブルにできません。

ルート ガードがイネーブルの場合は、ループ ガードをイネーブルにできません。

ループ ガードは、次のように他の機能と相互作用します。

ループ ガードは UplinkFast または BackboneFast の機能には影響しません。

ポイントツーポイント リンクに接続されていないポート上でループ ガードをイネーブルにしても、機能しません。

ルート ガードは、強制的に、ポートを常にルート ポートとして指定された状態にします。ポートがルート ポートまたは代替ポートの場合に限り、ループ ガードは有効です。特定のポート上でループ ガードとルート ガードの両方を同時にイネーブルにできません。

ループ ガードはスパニング ツリーで認識されているポートを使用します。ループ ガードは、Port Aggregation Protocol(PAgP; ポート集約プロトコル)が提供する論理ポートを利用できます。ただし、チャネルを形成するには、そのチャネルにグループ化するすべての物理ポートの設定に互換性がなければなリません。チャネルを形成するために、PAgP はすべての物理ポート上でルート ガードまたはループ ガードの設定を均一にします。

ループ ガードに適用される注意事項は、次のとおりです。

スパニング ツリーは、BPDU を送信するチャネル内で最初に動作するポートを常に選択します。このリンクが単一方向になった場合、チャネル内の他のリンクが適切に機能している場合でも、ループ ガードはチャネルをブロックします。

ループ ガードによってブロックされている一連のポートをグループ化して、チャネルを形成した場合、スパニング ツリーはこれらのポートのステート情報をすべて失い、新しいチャネル ポートは指定された役割を使用してフォワーディング ステートに移行できます。

チャネルがループ ガードによってブロックされている場合に、チャネルが切断されると、スパニング ツリーはすべてのステート情報を失います。チャネルを形成する 1 つ以上のリンクが単一方向リンクである場合も、各物理ポートは指定された役割を使用して、フォワーディング ステートに移行できます。


) UniDirectional Link Detection(UDLD; 単一方向リンク検出)をイネーブルにして、リンク障害を特定することができます。UDLD が障害を検出するまでループが発生することがありますが、ループ ガードはこのループを検出できません。


ディセーブル化されたスパニング ツリー インスタンスまたは VLAN 上では、ループ ガードは無効です。

PortFast のイネーブル化


注意 PortFast は、単一のエンド ステーションをレイヤ 2 アクセス ポートに接続する場合に限って使用してください。そうしない場合、ネットワーク ループが発生する可能性があります。

レイヤ 2 アクセス ポート上で PortFast をイネーブルにするには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# interface { type 2 slot/port } | { port-channel port_channel_number }

設定するインターフェイスを選択します。

ステップ 2

Router(config-if)# spanning-tree portfast

単一のワークステーションまたはサーバに接続されたレイヤ 2 アクセス ポート上で PortFast をイネーブルにします。

ステップ 3

Router(config-if)# spanning-tree portfast default

PortFast をイネーブルにします。

ステップ 4

Router(config-if)# end

コンフィギュレーション モードを終了します。

ステップ 5

Router# show running interface { type 1 slot/port } | { port-channel port_channel_number }

設定を確認します。

2.type = ethernetfastethernetgigabitethernet、または tengigabitethernet

次に、インターフェイス FastEthernet 5/8 上で PortFast をイネーブルにする例を示します。

Router# configure terminal
Router(config)# interface fastethernet 5/8
Router(config-if)# spanning-tree portfast
Router(config-if)# end
Router#
 

次に、設定を確認する例を示します。

Router# show running-config interface fastethernet 5/8
Building configuration...
 
Current configuration:
!
interface FastEthernet5/8
no ip address
switchport
switchport access vlan 200
switchport mode access
spanning-tree portfast
end
 
Router#

PortFast のデフォルト設定をイネーブルにするには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# spanning-tree portfast default

PortFast をデフォルトに設定します。

ステップ 2

Router(config)# show spanning-tree summary totals

グローバル コンフィギュレーションを確認します。

ステップ 3

Router(config)# show spanning-tree interface x detail

特定のポートに対する効果を確認します。

ステップ 4

Router(config-if)# spanning-tree portfast trunk

ポート上で PortFast トランクをイネーブルにします。

ステップ 5

Router# show spanning-tree interface fastEthernet x detail

設定を確認します。

次に、PortFast のデフォルト設定をイネーブルにする例を示します。

Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# spanning-tree portfast default
Router(config)# ^Z
 
Root bridge for:VLAN0010
EtherChannel misconfiguration guard is enabled
Extended system ID is disabled
Portfast is enabled by default
PortFast BPDU Guard is disabled by default
Portfast BPDU Filter is disabled by default
Loopguard is disabled by default
UplinkFast is disabled
BackboneFast is disabled
Pathcost method used is long
 
Name Blocking Listening Learning Forwarding STP Active
---------------------- -------- --------- -------- ---------- ----------
VLAN0001 0 0 0 1 1
VLAN0010 0 0 0 2 2
---------------------- -------- --------- -------- ---------- ----------
2 vlans 0 0 0 3 3
Router#
 
Router# show spanning-tree interface fastEthernet 4/4 detail
Port 196 (FastEthernet4/4) of VLAN0010 is forwarding
Port path cost 1000, Port priority 160, Port Identifier 160.196.
Designated root has priority 32768, address 00d0.00b8.140a
Designated bridge has priority 32768, address 00d0.00b8.140a
Designated port id is 160.196, designated path cost 0
Timers:message age 0, forward delay 0, hold 0
Number of transitions to forwarding state:1
The port is in the portfast mode by default
Link type is point-to-point by default
BPDU:sent 10, received 0
 
Router(config-if)# spanning-tree portfast trunk
%Warning:portfast should only be enabled on ports connected to a single
host. Connecting hubs, concentrators, switches, bridges, etc... to this
interface when portfast is enabled, can cause temporary bridging loops.
Use with CAUTION
 
Router(config-if)# ^Z
 
Router# show spanning-tree interface fastEthernet 4/4 detail
Port 196 (FastEthernet4/4) of VLAN0010 is forwarding
Port path cost 1000, Port priority 160, Port Identifier 160.196.
Designated root has priority 32768, address 00d0.00b8.140a
Designated bridge has priority 32768, address 00d0.00b8.140a
Designated port id is 160.196, designated path cost 0
Timers:message age 0, forward delay 0, hold 0
Number of transitions to forwarding state:1
The port is in the portfast mode by portfast trunk configuration
Link type is point-to-point by default
BPDU:sent 30, received 0
Router#

PortFast BPDU フィルタリングのイネーブル化

ここでは、スイッチ上で PortFast BPDU フィルタリングを設定する手順について説明します。

PortFast BPDU フィルタリングをグローバルにイネーブルにするには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# spanning-tree portfast bpdufilter default

スイッチ上で BPDU フィルタリングをグローバルにイネーブルにします。

ステップ 2

Router# show spanning-tree summary totals

設定を確認します。

各ポート上で、BPDU フィルタリングはデフォルトに設定されています。次に、ポート上で PortFast BPDU フィルタリングをイネーブルにして、PVST+ モードで設定を確認する例を示します。


) PVST+ の詳細については、「スパニング ツリー プロトコル(STP)および先行標準 IEEE 802.1s 多重スパニング ツリー(MST)の設定」 を参照してください。


Router(config)# spanning-tree portfast bpdufilter default
Router(config)# ^Z
 
Router# show spanning-tree summary totals
Root bridge for:VLAN0010
EtherChannel misconfiguration guard is enabled
Extended system ID is disabled
Portfast is enabled by default
PortFast BPDU Guard is disabled by default
Portfast BPDU Filter is enabled by default
Loopguard is disabled by default
UplinkFast is disabled
BackboneFast is disabled
Pathcost method used is long
 
Name Blocking Listening Learning Forwarding STP Active
---------------------- -------- --------- -------- ---------- ----------
2 vlans 0 0 0 3 3
Router#
 

非トランキング ポート上で PortFast BPDU フィルタリングをイネーブルにするには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# interface fastEthernet 4/4

設定するインターフェイスを選択します。

ステップ 2

Router(config-if)# spanning-tree bpdufilter enable

BPDU フィルタリングをイネーブルにします。

ステップ 3

Router# show spanning-tree interface fastEthernet 4/4

設定を確認します。

次に、非トランキング ポート上で PortFast BPDU フィルタリングをイネーブルにする例を示します。

Router(config)# interface fastEthernet 4/4
Router(config-if)# spanning-tree bpdufilter enable
Router(config-if)# ^Z
 
Router# show spanning-tree interface fastEthernet 4/4
 
Vlan Role Sts Cost Prio.Nbr Status
---------------- ---- --- --------- -------- --------------------------------
VLAN0010 Desg FWD 1000 160.196 Edge P2p
Router# show spanning-tree interface fastEthernet 4/4 detail
Router# show spanning-tree interface fastEthernet 4/4 detail
Port 196 (FastEthernet4/4) of VLAN0010 is forwarding
Port path cost 1000, Port priority 160, Port Identifier 160.196.
Designated root has priority 32768, address 00d0.00b8.140a
Designated bridge has priority 32768, address 00d0.00b8.140a
Designated port id is 160.196, designated path cost 0
Timers:message age 0, forward delay 0, hold 0
Number of transitions to forwarding state:1
The port is in the portfast mode by portfast trunk configuration
Link type is point-to-point by default
Bpdu filter is enabled
BPDU:sent 0, received 0
Router#

BPDU ガードのイネーブル化

BPDU ガードをグローバルにイネーブルにするには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# spanning-tree portfast bpduguard default

Router(config)# no spanning-tree portfast bpduguard default

BPDU ガードをグローバルにイネーブルにします。

BPDU ガードをグローバルにディセーブルにします。

ステップ 2

Router(config)# end

コンフィギュレーション モードを終了します。

ステップ 3

Router# show spanning-tree summary totals

設定を確認します。

次に、BPDU ガードをイネーブルにする例を示します。

Router# configure terminal
Router(config)# spanning-tree portfast bpduguard
Router(config)# end
Router#

次に、設定を確認する例を示します。

Router# show spanning-tree summary totals default
Root bridge for:VLAN0010
EtherChannel misconfiguration guard is enabled
Extended system ID is disabled
Portfast is enabled by default
PortFast BPDU Guard is disabled by default
Portfast BPDU Filter is enabled by default
Loopguard is disabled by default
UplinkFast is disabled
BackboneFast is disabled
Pathcost method used is long
 
Name Blocking Listening Learning Forwarding STP Active
---------------------- -------- --------- -------- ---------- ----------
2 vlans 0 0 0 3 3
Router#
 

UplinkFast のイネーブル化

UplinkFast を使用すると、ブリッジ プライオリティが 49152 に増えるとともに、Catalyst 6500 シリーズ スイッチ上のすべてのレイヤ 2 LAN インターフェイスの STP ポート コストに 3000 が加算されます。その結果、スイッチがルート ブリッジになる確率が低くなります。ブリッジ プライオリティを設定している VLAN 上では、UplinkFast をイネーブルにできません。ブリッジ プライオリティを設定している VLAN 上で UplinkFast をイネーブルにするには、グローバル コンフィギュレーション モードで no spanning-tree vlan vlan_ID priority コマンドを入力して、VLAN のブリッジ プライオリティをデフォルト値に戻します。


) UplinkFast をイネーブルにすると、Catalyst 6500 シリーズ スイッチ上のすべての VLAN に影響します。個々の VLAN について UplinkFast を設定できません。


UplinkFast をイネーブルにするには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# spanning-tree uplinkfast

Router(config)# spanning-tree uplinkfast [ max-update-rate max_update_rate ]

UplinkFast をイネーブルにします。

UplinkFast をイネーブルにして、アップデート速度を秒単位にします。

Router(config)# no spanning-tree uplinkfast max-update-rate

デフォルトのレートに戻します。

Router(config)# no spanning-tree uplinkfast

UplinkFast をディセーブルにします。

ステップ 2

Router(config)# end

コンフィギュレーション モードを終了します。

ステップ 3

Router# show spanning-tree vlan vlan_ID

UplinkFast がイネーブルになっていることを確認します。

次の例では、UplinkFast をイネーブルにする方法を示します。

Router# configure terminal
Router(config)# spanning-tree uplinkfast
Router(config)# exit
Router#

 

次に、UplinkFast をイネーブルにして、アップデート速度を 400 パケット/秒に設定する例を示します。

Router# configure terminal
Router(config)# spanning-tree uplinkfast
Router(config)# spanning-tree uplinkfast max-update-rate 400
Router(config)# exit
Router#
 

次に、UplinkFast がイネーブルになっていることを確認する例を示します。

Router# show spanning-tree uplinkfast
UplinkFast is enabled
Router#

BackboneFast のイネーブル化


) BackboneFast が適切に動作するのは、ネットワーク内のすべてのネットワーク装置上でイネーブルになっている場合だけです。BackboneFast は、トークンリング VLAN ではサポートされません。この機能は、サードパーティ製のネットワーク装置と組み合わせて使用することができます。


BackboneFast をイネーブルにするには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# spanning-tree backbonefast

BackboneFast をイネーブルにします。

Router(config)# no spanning-tree backbonefast

BackboneFast をディセーブルにします。

ステップ 2

Router(config)# end

コンフィギュレーション モードを終了します。

ステップ 3

Router# show spanning-tree vlan vlan_ID

BackboneFast がイネーブルになっていることを確認します。

次に、BackboneFast をイネーブルにする例を示します。

Router# configure terminal
Router(config)# spanning-tree backbonefast
Router(config)# end
Router#
 

次に、BackboneFast がイネーブルになっていることを確認する例を示します。

Router# show spanning-tree backbonefast
BackboneFast is enabled
 
BackboneFast statistics
-----------------------
Number of transition via backboneFast (all VLANs) : 0
Number of inferior BPDUs received (all VLANs) : 0
Number of RLQ request PDUs received (all VLANs) : 0
Number of RLQ response PDUs received (all VLANs) : 0
Number of RLQ request PDUs sent (all VLANs) : 0
Number of RLQ response PDUs sent (all VLANs) : 0
Router#

EtherChannel ガードのイネーブル化

EtherChannel ガードをイネーブルにするには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# spanning-tree etherchannel guard misconfig

EtherChannel ガードをイネーブルにします。

Router(config)# no spanning-tree etherchannel guard misconfig

EtherChannel ガードをディセーブルにします。

ステップ 2

Router(config)# end

コンフィギュレーション モードを終了します。

ステップ 3

Router# show spanning-tree summary | include EtherChannel

EtherChannel ガードがイネーブルになっていることを確認します。

次に、EtherChannel ガードをイネーブルにする例を示します。

Router# configure terminal
Router(config)# spanning-tree etherchannel guard misconfig
Router(config)# end
Router#
 

次に、設定を確認する例を示します。

Router# show spanning-tree summary | include EtherChannel
EtherChannel misconfiguration guard is enabled
 

show interface status err-disable コマンドを入力して、errdisable ステートになっているインターフェイスを表示します。

誤っている設定が解消されると、errdisable ステートのインターフェイスは自動的に回復します。インターフェイスを手動で動作状態に戻すには、 shutdown コマンドを入力してから、該当するインターフェイスに対して no shutdown コマンドを入力します。

ルート ガードのイネーブル化

ルート ガードをイネーブルにするには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# interface { type 3 slot/port } | { port-channel port_channel_number }

設定するインターフェイスを選択します。

ステップ 2

Router(config-if)# spanning-tree guard root

ルート ガードをイネーブルにします。

Router(config-if)# no spanning-tree guard root

ルート ガードをディセーブルにします。

ステップ 3

Router(config-if)# end

コンフィギュレーション モードを終了します。

ステップ 4

Router# show spanning-tree

Router# show running interface { type 1 slot/port } | { port-channel port_channel_number }

設定を確認します。

3.type = ethernetfastethernetgigabitethernet、または tengigabitethernet

show spanning-tree inconsistentports コマンドを入力して、ルートとして一貫性のないステートになっているポートを表示します。

ループ ガードのイネーブル化

set spanning-tree guard コマンドを使用して、スパニング ツリーのループ ガード機能をポート単位でイネーブルまたはディセーブルにします。

スイッチ上でループ ガードをグローバルにイネーブルにするには、次の作業を実行します。

 

コマンド
目的

ステップ 1

Router(config)# spanning-tree loopguard default

スイッチ上でループ ガードをグローバルにイネーブルにします。

ステップ 2

Router(config)# end

コンフィギュレーション モードを終了します。

ステップ 3

Router# show spanning tree interface 4/4detail

この設定がポートに作用していることを確認します。

次に、ループ ガードをグローバルにイネーブルにする例を示します。

Router# configure terminal
 
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# spanning-tree loopguard default
Router(config)# ^Z
 
Router# show spanning-tree interface fastEthernet 4/4 detail
Port 196 (FastEthernet4/4) of VLAN0010 is forwarding
Port path cost 1000, Port priority 160, Port Identifier 160.196.
Designated root has priority 32768, address 00d0.00b8.140a
Designated bridge has priority 32768, address 00d0.00b8.140a
Designated port id is 160.196, designated path cost 0
Timers:message age 0, forward delay 0, hold 0
Number of transitions to forwarding state:1
The port is in the portfast mode by portfast trunk configuration
Link type is point-to-point by default
Bpdu filter is enabled
Loop guard is enabled by default on the port
BPDU:sent 0, received 0
 

ループ ガードをインターフェイスでイネーブルにするには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# interface { type 4 slot/port } | { port-channel port_channel_number }

設定するインターフェイスを選択します。

ステップ 2

Router(config-if)# spanning-tree guard loop

ループ ガードを設定します。

ステップ 3

Router(config)# end

コンフィギュレーション モードを終了します。

ステップ 4

Router# show spanning tree interface 4/4detail

この設定がポートに作用していることを確認します。

4.type = ethernetfastethernetgigabitethernet、または tengigabitethernet

次に、ループ ガードをイネーブルにする例を示します。

Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# interface fastEthernet 4/4
Router(config-if)# spanning-tree guard loop
Router(config-if)# ^Z
 

次に、設定を確認する例を示します。

Router# show spanning-tree interface fastEthernet 4/4 detail
Port 196 (FastEthernet4/4) of VLAN0010 is forwarding
Port path cost 1000, Port priority 160, Port Identifier 160.196.
Designated root has priority 32768, address 00d0.00b8.140a
Designated bridge has priority 32768, address 00d0.00b8.140a
Designated port id is 160.196, designated path cost 0
Timers:message age 0, forward delay 0, hold 0
Number of transitions to forwarding state:1
The port is in the portfast mode by portfast trunk configuration
Link type is point-to-point by default
Bpdu filter is enabled
Loop guard is enabled on the port
BPDU:sent 0, received 0
Router#